Namespaces

Namespaces
Namespace | Description
CodeSmith.BaseTemplates | This assembly includes various base template classes that templates can inherit from to gain functionality.
CodeSmith.CustomProperties | This assembly contains custom property types that templates can make use of.
CodeSmith.Engine | The CodeSmith engine can be used to programmatically generate code from templates.
CodeSmith.Engine.Compiler |
CodeSmith.Engine.Schema |
SchemaExplorer | Allows programmatic discovery of database schema information.
SchemaExplorer.Design |
SchemaExplorer.Extensions |
SchemaExplorer.Serialization |
SchemaExplorer.TypeConverters |

Copyright ©2002-2022 CodeSmith Tools, LLC. All rights reserved.

Send comments on this topic to support@codesmithtools.com


CodeSmith.BaseTemplates Namespace

This assembly includes various base template classes that templates can inherit from to gain functionality.
Classes
 | Class | Description
Public class | Batch |
Public class | OutputFileCodeTemplate | Templates can be derived from this class to allow their output to be saved to file during generation.
Public class | ScriptError | An error that occurred during a script execution.
Public class | ScriptErrorCollection |
Public class | ScriptResult | The result of a script execution including any errors that may have occurred.
Public class | ScriptUtility | This class can be used to execute SQL scripts on a database. It takes a SQL script, parsers out the GO's and executes each batch remembering the correct line numbers.
Public class | SqlCodeTemplate | Templates can be derived from this class to gain various helper methods that are useful when generating code from a SQL metadata source.
Public class | StringUtility | Obsolete. Various string utility methods.
Public class | VBSqlCodeTemplate |


Batch Class

Inheritance Hierarchy
SystemObject
CodeSmith.BaseTemplatesBatch

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class Batch
Public Class Batch

The Batch type exposes the following members.

Constructors
 | Name | Description
Public method | Batch | Initializes a new instance of the Batch class
Top
Properties
 | Name | Description
Public property | Content |
Public property | LineCount |
Public property | StartLineNumber |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSmith.BaseTemplates Namespace


Batch Constructor

Initializes a new instance of the Batch class

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public Batch(
    int startLineNumber,
    int lineCount,
    string content
)
Public Sub New (
    startLineNumber As Integer,
    lineCount As Integer,
    content As String
)

Parameters

startLineNumber
Type: SystemInt32
lineCount
Type: SystemInt32
content
Type: SystemString
See Also

Reference

Batch Class
CodeSmith.BaseTemplates Namespace


Batch Properties

The Batch type exposes the following members.

Properties
 | Name | Description
Public property | Content |
Public property | LineCount |
Public property | StartLineNumber |
Top
See Also

Reference

Batch Class
CodeSmith.BaseTemplates Namespace


Batch.Content Property

CodeSmith Generator API

BatchContent Property

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string Content { get; }
Public ReadOnly Property Content As String
    Get

Property Value

Type: String
See Also

Reference

Batch Class
CodeSmith.BaseTemplates Namespace


Batch.LineCount Property

BatchLineCount Property

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public int LineCount { get; }
Public ReadOnly Property LineCount As Integer
    Get

Property Value

Type: Int32
See Also

Reference

Batch Class
CodeSmith.BaseTemplates Namespace


Batch.StartLineNumber Property

BatchStartLineNumber Property

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public int StartLineNumber { get; }
Public ReadOnly Property StartLineNumber As Integer
    Get

Property Value

Type: Int32
See Also

Reference

Batch Class
CodeSmith.BaseTemplates Namespace


Batch Methods

The Batch type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Batch Class
CodeSmith.BaseTemplates Namespace


OutputFileCodeTemplate Class

Templates can be derived from this class to allow their output to be saved to file during generation.
Inheritance Hierarchy
SystemObject
CodeSmith.EngineControl
CodeSmith.EngineCodeTemplate
CodeSmith.BaseTemplatesOutputFileCodeTemplate
CodeSmith.BaseTemplatesSqlCodeTemplate

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class OutputFileCodeTemplate : CodeTemplate
Public Class OutputFileCodeTemplate
    Inherits CodeTemplate

The OutputFileCodeTemplate type exposes the following members.

Constructors
 | Name | Description
Public method | OutputFileCodeTemplate | Initializes a new instance of the OutputFileCodeTemplate class
Top
Properties
 | Name | Description
Protected property | ChildControlsCreated | (Inherited from Control.)
Protected property | CodeTemplate | (Inherited from Control.)
Public property | CodeTemplateInfo | Gets the information for the current template. (Inherited from CodeTemplate.)
Public property | ContextData | Contextual data items can be stored in this object and shared with sub-templates. This data will not be persisted with the template property set. (Inherited from CodeTemplate.)
Protected property | Controls | (Inherited from Control.)
Public property | OutputFile | This property is used to specify an output file name that the template output will be saved to.
Protected property | Parent | (Inherited from Control.)
Public property | Progress | Provides a way to report execution progress for the template. (Inherited from CodeTemplate.)
Public property | RegisteredOutputs | (Inherited from CodeTemplate.)
Public property | RegisteredReferences | (Inherited from CodeTemplate.)
Public property | Response | Response stream for the template output. You can write to the stream programmatically using this property. (Inherited from CodeTemplate.)
Public property | State | State of this template instance. (Inherited from CodeTemplate.)
Public property | ValidationErrors | Gets the validation errors for this template. (Inherited from CodeTemplate.)
Protected property | Visible | (Inherited from CodeTemplate.)
Top
Methods
 | Name | Description
Protected method | ControlAdded | (Inherited from Control.)
Protected method | ControlRemoved | (Inherited from Control.)
Public method | CopyPropertiesTo(CodeTemplate) | Copies any matching properties to another CodeTemplate instance. (Inherited from CodeTemplate.)
Public method | CopyPropertiesTo(CodeTemplate, Boolean) | Copies any matching properties to another CodeTemplate instance. (Inherited from CodeTemplate.)
Public method | CopyPropertiesTo(CodeTemplate, ICollectionString) | Copies any matching properties to another CodeTemplate instance. (Inherited from CodeTemplate.)
Public method | CopyPropertiesTo(CodeTemplate, Boolean, ICollectionString) | Copies any matching properties to another CodeTemplate instance. (Inherited from CodeTemplate.)
Public method | CreateT | Gets an instance of the specified template type. Should be used with the Register directive. (Inherited from CodeTemplate.)
Public method | CreateT(Boolean) | Gets an instance of the specified template type. Should be used with the Register directive. (Inherited from CodeTemplate.)
Protected method | CreateChildControls | (Inherited from Control.)
Protected method | CreateControlCollection | (Inherited from Control.)
Public method | Dispose | (Inherited from CodeTemplate.)
Protected method | Dispose(Boolean) | (Inherited from CodeTemplate.)
Protected method | EnsureChildControls | (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | (Inherited from CodeTemplate.)
Public method | GetCodeTemplateInstance(String) | Gets an instance of the specified template. (Inherited from CodeTemplate.)
Public method | GetCodeTemplateInstance(String, Boolean) | Gets an instance of the specified template. (Inherited from CodeTemplate.)
Public method | GetCodeTemplateInstance(String, Boolean, Boolean) | Gets an instance of the specified template. (Inherited from CodeTemplate.)
Public method | GetCustomValidationErrors | Allows the developer to add custom ValidationErrors to the validation collection. (Inherited from CodeTemplate.)
Public method | GetFileName | Gets a default name for the template output. This can be overridden in your template to provide a suitable name for the output of the template based on the property values. (Inherited from CodeTemplate.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetProperties | Gets information on all of the properties on this template. (Inherited from CodeTemplate.)
Public method | GetProperties(Boolean) | Gets information on all of the properties on this template. (Inherited from CodeTemplate.)
Public method | GetProperty | Gets the value for the specified property. (Inherited from CodeTemplate.)
Public method | GetPropertyAttribute | Gets the property attribute. Property attributes can be used to store various information at the property level. (Inherited from CodeTemplate.)
Public method | GetPropertyDescription | (Inherited from CodeTemplate.)
Public method | GetPropertyInfo | (Inherited from CodeTemplate.)
Public method | GetRequiredProperties | Gets information on all of the required properties for this template. (Inherited from CodeTemplate.)
Public method | GetTemplateAttribute | Gets the template attribute. Template attributes can be used to store various information at the template level. (Inherited from CodeTemplate.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControls | (Inherited from Control.)
Public method | IsPropertyRequired | (Inherited from CodeTemplate.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnError | This method can be overridden to perform logic when a template exception occurs. (Inherited from CodeTemplate.)
Protected method | OnInit | This method can be overridden to perform logic when the template instance is created. (Inherited from CodeTemplate.)
Protected method | OnOutputRegistered | This is the method that is responsible for notifying receivers that the event occurred (Inherited from CodeTemplate.)
Protected method | OnPostRender | Override the OnPostRender method so that we can take the result and save it to a file if an output file was specified. (Overrides CodeTemplateOnPostRender(String).)
Protected method | OnPreOutputWritten(OutputCancelEventArgs) | This is the method that is responsible for notifying receivers that the event occurred (Inherited from CodeTemplate.)
Protected method | OnPreOutputWritten(String) | This is the method that is responsible for notifying receivers that the event occurred (Inherited from CodeTemplate.)
Protected method | OnPreRender | This method can be overridden to perform logic before the template is rendered. (Inherited from CodeTemplate.)
Protected method | OnPropertiesLoaded | This method can be overridden to perform logic when properties are loaded. (Inherited from CodeTemplate.)
Protected method | OnPropertiesSaved | This method can be overridden to perform logic when properties are saved. (Inherited from CodeTemplate.)
Protected method | OnPropertyChanged | This method can be overridden to perform logic when a property changes. (Inherited from CodeTemplate.)
Protected method | OnReferenceRegistered | Raises the ItemRegisteredEventArgs event. (Inherited from CodeTemplate.)
Public method | ParseDefaultValue | Parses the default value for properties. This can be overridden to provide custom default parsing logic. (Inherited from CodeTemplate.)
Public method | RefreshProperties | (Inherited from CodeTemplate.)
Public method | RefreshProperties(Boolean) | (Inherited from CodeTemplate.)
Public method | RegisterOutput(OutputFile) | (Inherited from CodeTemplate.)
Public method | RegisterOutput(String) | (Inherited from CodeTemplate.)
Public method | RegisterReference | Registers the reference. When generating from within Visual Studio, these references will be added to the project. (Inherited from CodeTemplate.)
Public method | Render | Renders to the template output to the specified writer. (Inherited from CodeTemplate.)
Protected method | RenderChildren | (Inherited from Control.)
Public method | RenderToFile(OutputFile, Boolean) | Renders the template output to a file. (Inherited from CodeTemplate.)
Public method | RenderToFile(String, IMergeStrategy) | Renders the template output to a file using a merge strategy. (Inherited from CodeTemplate.)
Public method | RenderToFile(String, Boolean) | Renders the template output to a file. (Inherited from CodeTemplate.)
Public method | RenderToFile(OutputFile, String, IMergeStrategy) | Renders the template output to a file using a merge strategy. (Inherited from CodeTemplate.)
Public method | RenderToFile(String, String, IMergeStrategy) | Renders the template output to a file using a merge strategy. (Inherited from CodeTemplate.)
Public method | RenderToFile(String, String, Boolean) | Renders the template output to a file. (Inherited from CodeTemplate.)
Public method | RenderToString | Renders the template output to a String. (Inherited from CodeTemplate.)
Public method | RenderToString(String, IMergeStrategy) | Renders the template output to a String. (Inherited from CodeTemplate.)
Public method | RestorePropertiesFromHashtable | Restores the properties from a Hashtable. (Inherited from CodeTemplate.)
Public method | RestorePropertiesFromPropertySet(PropertySet, String) | (Inherited from CodeTemplate.)
Public method | RestorePropertiesFromPropertySet(PropertySet, String, Hashtable) | (Inherited from CodeTemplate.)
Public method | RestorePropertiesFromSchema | (Inherited from CodeTemplate.)
Public method | RestorePropertiesFromXml | Restores the properties from XML. (Inherited from CodeTemplate.)
Public method | RestorePropertiesFromXmlFile | Restores the properties from XML file. (Inherited from CodeTemplate.)
Public method | SavePropertiesToHashtable | Saves the properties to a Hashtable. (Inherited from CodeTemplate.)
Public method | SavePropertiesToHashtable(Boolean) | Saves the properties to a Hashtable. (Inherited from CodeTemplate.)
Public method | SavePropertiesToPropertySet | (Inherited from CodeTemplate.)
Public method | SavePropertiesToXml | Saves the properties to XML. (Inherited from CodeTemplate.)
Public method | SavePropertiesToXml(XmlWriter) | Saves the properties to XML. (Inherited from CodeTemplate.)
Public method | SavePropertiesToXmlFile | Saves the properties to an XML file. (Inherited from CodeTemplate.)
Protected method | SetContextData | Set the context data object for the template. Any items in the current ContextData object will be added to the new one. This method should only be called while a template is initializing. (Inherited from CodeTemplate.)
Public method | SetProperty(PropertyInfo, Object) | Sets the value for the specified property. (Inherited from CodeTemplate.)
Public method | SetProperty(String, Object) | Sets the value for the specified property. (Inherited from CodeTemplate.)
Public method | SetProperty(XmlNode, String) | (Inherited from CodeTemplate.)
Public method | SetPropertyAttribute | Sets the property attribute. Property attributes can be used to store various information at the property level. (Inherited from CodeTemplate.)
Protected method | SetPropertyDefaults | This method is overridden in templates to set default values in a template instance. (Inherited from CodeTemplate.)
Public method | SetTemplateAttribute | Sets the template attribute. Template attributes can be used to store various information at the template level. (Inherited from CodeTemplate.)
Protected method | SetUnknownDirectiveAttributes | This method is overridden in templates to set unknown directive attributes in the ContextData. (Inherited from CodeTemplate.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates this template instance. (Inherited from CodeTemplate.)
Top
Events
 | Name | Description
Public event | OutputRegistered | Raised when an output file is registered (Inherited from CodeTemplate.)
Public event | PreOutputWritten | Raised prior to an output being written to disk (Inherited from CodeTemplate.)
Public event | PropertiesLoaded | (Inherited from CodeTemplate.)
Public event | PropertiesSaved | (Inherited from CodeTemplate.)
Public event | PropertyChanged | (Inherited from CodeTemplate.)
Public event | ReferenceRegistered | Occurs when a reference is registered. (Inherited from CodeTemplate.)
Top
Fields
 | Name | Description
Protected field | _childControlsCreated | (Inherited from Control.)
Protected field | _codeTemplate | (Inherited from Control.)
Protected field | _controls | (Inherited from Control.)
Protected field | _outputFile |
Protected field | _parent | (Inherited from Control.)
Protected field | _visible | (Inherited from Control.)
Top
See Also

Reference

CodeSmith.BaseTemplates Namespace


OutputFileCodeTemplate Constructor

Initializes a new instance of the OutputFileCodeTemplate class

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public OutputFileCodeTemplate()
Public Sub New
See Also

Reference

OutputFileCodeTemplate Class
CodeSmith.BaseTemplates Namespace


OutputFileCodeTemplate Properties

The OutputFileCodeTemplate type exposes the following members.

Properties
 | Name | Description
Protected property | ChildControlsCreated | (Inherited from Control.)
Protected property | CodeTemplate | (Inherited from Control.)
Public property | CodeTemplateInfo | Gets the information for the current template. (Inherited from CodeTemplate.)
Public property | ContextData | Contextual data items can be stored in this object and shared with sub-templates. This data will not be persisted with the template property set. (Inherited from CodeTemplate.)
Protected property | Controls | (Inherited from Control.)
Public property | OutputFile | This property is used to specify an output file name that the template output will be saved to.
Protected property | Parent | (Inherited from Control.)
Public property | Progress | Provides a way to report execution progress for the template. (Inherited from CodeTemplate.)
Public property | RegisteredOutputs | (Inherited from CodeTemplate.)
Public property | RegisteredReferences | (Inherited from CodeTemplate.)
Public property | Response | Response stream for the template output. You can write to the stream programmatically using this property. (Inherited from CodeTemplate.)
Public property | State | State of this template instance. (Inherited from CodeTemplate.)
Public property | ValidationErrors | Gets the validation errors for this template. (Inherited from CodeTemplate.)
Protected property | Visible | (Inherited from CodeTemplate.)
Top
See Also

Reference

OutputFileCodeTemplate Class
CodeSmith.BaseTemplates Namespace


OutputFileCodeTemplate.OutputFile Property

OutputFileCodeTemplateOutputFile Property

This property is used to specify an output file name that the template output will be saved to.

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual string OutputFile { get; set; }
Public Overridable Property OutputFile As String
    Get
    Set

Property Value

Type: String
See Also

Reference

OutputFileCodeTemplate Class
CodeSmith.BaseTemplates Namespace


OutputFileCodeTemplate Methods

The OutputFileCodeTemplate type exposes the following members.

Methods
 | Name | Description
Protected method | ControlAdded | (Inherited from Control.)
Protected method | ControlRemoved | (Inherited from Control.)
Public method | CopyPropertiesTo(CodeTemplate) | Copies any matching properties to another CodeTemplate instance. (Inherited from CodeTemplate.)
Public method | CopyPropertiesTo(CodeTemplate, Boolean) | Copies any matching properties to another CodeTemplate instance. (Inherited from CodeTemplate.)
Public method | CopyPropertiesTo(CodeTemplate, ICollectionString) | Copies any matching properties to another CodeTemplate instance. (Inherited from CodeTemplate.)
Public method | CopyPropertiesTo(CodeTemplate, Boolean, ICollectionString) | Copies any matching properties to another CodeTemplate instance. (Inherited from CodeTemplate.)
Public method | CreateT | Gets an instance of the specified template type. Should be used with the Register directive. (Inherited from CodeTemplate.)
Public method | CreateT(Boolean) | Gets an instance of the specified template type. Should be used with the Register directive. (Inherited from CodeTemplate.)
Protected method | CreateChildControls | (Inherited from Control.)
Protected method | CreateControlCollection | (Inherited from Control.)
Public method | Dispose | (Inherited from CodeTemplate.)
Protected method | Dispose(Boolean) | (Inherited from CodeTemplate.)
Protected method | EnsureChildControls | (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | (Inherited from CodeTemplate.)
Public method | GetCodeTemplateInstance(String) | Gets an instance of the specified template. (Inherited from CodeTemplate.)
Public method | GetCodeTemplateInstance(String, Boolean) | Gets an instance of the specified template. (Inherited from CodeTemplate.)
Public method | GetCodeTemplateInstance(String, Boolean, Boolean) | Gets an instance of the specified template. (Inherited from CodeTemplate.)
Public method | GetCustomValidationErrors | Allows the developer to add custom ValidationErrors to the validation collection. (Inherited from CodeTemplate.)
Public method | GetFileName | Gets a default name for the template output. This can be overridden in your template to provide a suitable name for the output of the template based on the property values. (Inherited from CodeTemplate.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetProperties | Gets information on all of the properties on this template. (Inherited from CodeTemplate.)
Public method | GetProperties(Boolean) | Gets information on all of the properties on this template. (Inherited from CodeTemplate.)
Public method | GetProperty | Gets the value for the specified property. (Inherited from CodeTemplate.)
Public method | GetPropertyAttribute | Gets the property attribute. Property attributes can be used to store various information at the property level. (Inherited from CodeTemplate.)
Public method | GetPropertyDescription | (Inherited from CodeTemplate.)
Public method | GetPropertyInfo | (Inherited from CodeTemplate.)
Public method | GetRequiredProperties | Gets information on all of the required properties for this template. (Inherited from CodeTemplate.)
Public method | GetTemplateAttribute | Gets the template attribute. Template attributes can be used to store various information at the template level. (Inherited from CodeTemplate.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControls | (Inherited from Control.)
Public method | IsPropertyRequired | (Inherited from CodeTemplate.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnError | This method can be overridden to perform logic when a template exception occurs. (Inherited from CodeTemplate.)
Protected method | OnInit | This method can be overridden to perform logic when the template instance is created. (Inherited from CodeTemplate.)
Protected method | OnOutputRegistered | This is the method that is responsible for notifying receivers that the event occurred (Inherited from CodeTemplate.)
Protected method | OnPostRender | Override the OnPostRender method so that we can take the result and save it to a file if an output file was specified. (Overrides CodeTemplateOnPostRender(String).)
Protected method | OnPreOutputWritten(OutputCancelEventArgs) | This is the method that is responsible for notifying receivers that the event occurred (Inherited from CodeTemplate.)
Protected method | OnPreOutputWritten(String) | This is the method that is responsible for notifying receivers that the event occurred (Inherited from CodeTemplate.)
Protected method | OnPreRender | This method can be overridden to perform logic before the template is rendered. (Inherited from CodeTemplate.)
Protected method | OnPropertiesLoaded | This method can be overridden to perform logic when properties are loaded. (Inherited from CodeTemplate.)
Protected method | OnPropertiesSaved | This method can be overridden to perform logic when properties are saved. (Inherited from CodeTemplate.)
Protected method | OnPropertyChanged | This method can be overridden to perform logic when a property changes. (Inherited from CodeTemplate.)
Protected method | OnReferenceRegistered | Raises the ItemRegisteredEventArgs event. (Inherited from CodeTemplate.)
Public method | ParseDefaultValue | Parses the default value for properties. This can be overridden to provide custom default parsing logic. (Inherited from CodeTemplate.)
Public method | RefreshProperties | (Inherited from CodeTemplate.)
Public method | RefreshProperties(Boolean) | (Inherited from CodeTemplate.)
Public method | RegisterOutput(OutputFile) | (Inherited from CodeTemplate.)
Public method | RegisterOutput(String) | (Inherited from CodeTemplate.)
Public method | RegisterReference | Registers the reference. When generating from within Visual Studio, these references will be added to the project. (Inherited from CodeTemplate.)
Public method | Render | Renders to the template output to the specified writer. (Inherited from CodeTemplate.)
Protected method | RenderChildren | (Inherited from Control.)
Public method | RenderToFile(OutputFile, Boolean) | Renders the template output to a file. (Inherited from CodeTemplate.)
Public method | RenderToFile(String, IMergeStrategy) | Renders the template output to a file using a merge strategy. (Inherited from CodeTemplate.)
Public method | RenderToFile(String, Boolean) | Renders the template output to a file. (Inherited from CodeTemplate.)
Public method | RenderToFile(OutputFile, String, IMergeStrategy) | Renders the template output to a file using a merge strategy. (Inherited from CodeTemplate.)
Public method | RenderToFile(String, String, IMergeStrategy) | Renders the template output to a file using a merge strategy. (Inherited from CodeTemplate.)
Public method | RenderToFile(String, String, Boolean) | Renders the template output to a file. (Inherited from CodeTemplate.)
Public method | RenderToString | Renders the template output to a String. (Inherited from CodeTemplate.)
Public method | RenderToString(String, IMergeStrategy) | Renders the template output to a String. (Inherited from CodeTemplate.)
Public method | RestorePropertiesFromHashtable | Restores the properties from a Hashtable. (Inherited from CodeTemplate.)
Public method | RestorePropertiesFromPropertySet(PropertySet, String) | (Inherited from CodeTemplate.)
Public method | RestorePropertiesFromPropertySet(PropertySet, String, Hashtable) | (Inherited from CodeTemplate.)
Public method | RestorePropertiesFromSchema | (Inherited from CodeTemplate.)
Public method | RestorePropertiesFromXml | Restores the properties from XML. (Inherited from CodeTemplate.)
Public method | RestorePropertiesFromXmlFile | Restores the properties from XML file. (Inherited from CodeTemplate.)
Public method | SavePropertiesToHashtable | Saves the properties to a Hashtable. (Inherited from CodeTemplate.)
Public method | SavePropertiesToHashtable(Boolean) | Saves the properties to a Hashtable. (Inherited from CodeTemplate.)
Public method | SavePropertiesToPropertySet | (Inherited from CodeTemplate.)
Public method | SavePropertiesToXml | Saves the properties to XML. (Inherited from CodeTemplate.)
Public method | SavePropertiesToXml(XmlWriter) | Saves the properties to XML. (Inherited from CodeTemplate.)
Public method | SavePropertiesToXmlFile | Saves the properties to an XML file. (Inherited from CodeTemplate.)
Protected method | SetContextData | Set the context data object for the template. Any items in the current ContextData object will be added to the new one. This method should only be called while a template is initializing. (Inherited from CodeTemplate.)
Public method | SetProperty(PropertyInfo, Object) | Sets the value for the specified property. (Inherited from CodeTemplate.)
Public method | SetProperty(String, Object) | Sets the value for the specified property. (Inherited from CodeTemplate.)
Public method | SetProperty(XmlNode, String) | (Inherited from CodeTemplate.)
Public method | SetPropertyAttribute | Sets the property attribute. Property attributes can be used to store various information at the property level. (Inherited from CodeTemplate.)
Protected method | SetPropertyDefaults | This method is overridden in templates to set default values in a template instance. (Inherited from CodeTemplate.)
Public method | SetTemplateAttribute | Sets the template attribute. Template attributes can be used to store various information at the template level. (Inherited from CodeTemplate.)
Protected method | SetUnknownDirectiveAttributes | This method is overridden in templates to set unknown directive attributes in the ContextData. (Inherited from CodeTemplate.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates this template instance. (Inherited from CodeTemplate.)
Top
See Also

Reference

OutputFileCodeTemplate Class
CodeSmith.BaseTemplates Namespace


OutputFileCodeTemplate.OnPostRender Method

OutputFileCodeTemplateOnPostRender Method

Override the OnPostRender method so that we can take the result and save it to a file if an output file was specified.

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected override void OnPostRender(
    string result
)
Protected Overrides Sub OnPostRender (
    result As String
)

Parameters

result
Type: SystemString
See Also

Reference

OutputFileCodeTemplate Class
CodeSmith.BaseTemplates Namespace


OutputFileCodeTemplate Events

The OutputFileCodeTemplate type exposes the following members.

Events
 | Name | Description
Public event | OutputRegistered | Raised when an output file is registered (Inherited from CodeTemplate.)
Public event | PreOutputWritten | Raised prior to an output being written to disk (Inherited from CodeTemplate.)
Public event | PropertiesLoaded | (Inherited from CodeTemplate.)
Public event | PropertiesSaved | (Inherited from CodeTemplate.)
Public event | PropertyChanged | (Inherited from CodeTemplate.)
Public event | ReferenceRegistered | Occurs when a reference is registered. (Inherited from CodeTemplate.)
Top
See Also

Reference

OutputFileCodeTemplate Class
CodeSmith.BaseTemplates Namespace


OutputFileCodeTemplate Fields

The OutputFileCodeTemplate type exposes the following members.

Fields
 | Name | Description
Protected field | _childControlsCreated | (Inherited from Control.)
Protected field | _codeTemplate | (Inherited from Control.)
Protected field | _controls | (Inherited from Control.)
Protected field | _outputFile |
Protected field | _parent | (Inherited from Control.)
Protected field | _visible | (Inherited from Control.)
Top
See Also

Reference

OutputFileCodeTemplate Class
CodeSmith.BaseTemplates Namespace


OutputFileCodeTemplate._outputFile Field

OutputFileCodeTemplate_outputFile Field

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected string _outputFile
Protected _outputFile As String

Field Value

Type: String
See Also

Reference

OutputFileCodeTemplate Class
CodeSmith.BaseTemplates Namespace


ScriptError Class

An error that occurred during a script execution.
Inheritance Hierarchy
SystemObject
CodeSmith.BaseTemplatesScriptError

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class ScriptError
Public Class ScriptError

The ScriptError type exposes the following members.

Constructors
 | Name | Description
Public method | ScriptError | Initializes a new instance of the ScriptError class
Top
Properties
 | Name | Description
Public property | Class |
Public property | LineNumber |
Public property | Message |
Public property | Number |
Public property | Procedure |
Public property | State |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides ObjectToString.)
Top
See Also

Reference

CodeSmith.BaseTemplates Namespace


ScriptError Constructor

Initializes a new instance of the ScriptError class

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ScriptError(
    int infoNumber,
    byte errorState,
    byte errorClass,
    string errorMessage,
    string procedure,
    int lineNumber
)
Public Sub New (
    infoNumber As Integer,
    errorState As Byte,
    errorClass As Byte,
    errorMessage As String,
    procedure As String,
    lineNumber As Integer
)

Parameters

infoNumber
Type: SystemInt32
errorState
Type: SystemByte
errorClass
Type: SystemByte
errorMessage
Type: SystemString
procedure
Type: SystemString
lineNumber
Type: SystemInt32
See Also

Reference

ScriptError Class
CodeSmith.BaseTemplates Namespace


ScriptError Properties

The ScriptError type exposes the following members.

Properties
 | Name | Description
Public property | Class |
Public property | LineNumber |
Public property | Message |
Public property | Number |
Public property | Procedure |
Public property | State |
Top
See Also

Reference

ScriptError Class
CodeSmith.BaseTemplates Namespace


ScriptError.Class Property

ScriptErrorClass Property

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public byte Class { get; }
Public ReadOnly Property Class As Byte
    Get

Property Value

Type: Byte
See Also

Reference

ScriptError Class
CodeSmith.BaseTemplates Namespace


ScriptError.LineNumber Property

ScriptErrorLineNumber Property

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public int LineNumber { get; }
Public ReadOnly Property LineNumber As Integer
    Get

Property Value

Type: Int32
See Also

Reference

ScriptError Class
CodeSmith.BaseTemplates Namespace


ScriptError.Message Property

ScriptErrorMessage Property

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string Message { get; }
Public ReadOnly Property Message As String
    Get

Property Value

Type: String
See Also

Reference

ScriptError Class
CodeSmith.BaseTemplates Namespace


ScriptError.Number Property

ScriptErrorNumber Property

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public int Number { get; }
Public ReadOnly Property Number As Integer
    Get

Property Value

Type: Int32
See Also

Reference

ScriptError Class
CodeSmith.BaseTemplates Namespace


ScriptError.Procedure Property

ScriptErrorProcedure Property

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string Procedure { get; }
Public ReadOnly Property Procedure As String
    Get

Property Value

Type: String
See Also

Reference

ScriptError Class
CodeSmith.BaseTemplates Namespace


ScriptError.State Property

ScriptErrorState Property

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public byte State { get; }
Public ReadOnly Property State As Byte
    Get

Property Value

Type: Byte
See Also

Reference

ScriptError Class
CodeSmith.BaseTemplates Namespace


ScriptError Methods

The ScriptError type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides ObjectToString.)
Top
See Also

Reference

ScriptError Class
CodeSmith.BaseTemplates Namespace


ScriptError.ToString Method

ScriptErrorToString Method

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
See Also

Reference

ScriptError Class
CodeSmith.BaseTemplates Namespace


ScriptErrorCollection Class

Inheritance Hierarchy
SystemObject
CodeSmith.BaseTemplatesScriptErrorCollection

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class ScriptErrorCollection : ICollection,
    IEnumerable
Public Class ScriptErrorCollection
    Implements ICollection, IEnumerable

The ScriptErrorCollection type exposes the following members.

Constructors
 | Name | Description
Public method | ScriptErrorCollection | Initializes a new instance of the ScriptErrorCollection class
Top
Properties
 | Name | Description
Public property | Count |
Public property | Item |
Top
Methods
 | Name | Description
Public method | CopyTo |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSmith.BaseTemplates Namespace


ScriptErrorCollection Constructor

Initializes a new instance of the ScriptErrorCollection class

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ScriptErrorCollection()
Public Sub New
See Also

Reference

ScriptErrorCollection Class
CodeSmith.BaseTemplates Namespace


ScriptErrorCollection Properties

The ScriptErrorCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count |
Public property | Item |
Top
See Also

Reference

ScriptErrorCollection Class
CodeSmith.BaseTemplates Namespace


ScriptErrorCollection.Count Property

ScriptErrorCollectionCount Property

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Implements

ICollectionCount
See Also

Reference

ScriptErrorCollection Class
CodeSmith.BaseTemplates Namespace


ScriptErrorCollection.Item Property

ScriptErrorCollectionItem Property

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ScriptError this[
    int index
] { get; }
Public ReadOnly Default Property Item (
    index As Integer
) As ScriptError
    Get

Parameters

index
Type: SystemInt32

Property Value

Type: ScriptError
See Also

Reference

ScriptErrorCollection Class
CodeSmith.BaseTemplates Namespace


ScriptErrorCollection Methods

The ScriptErrorCollection type exposes the following members.

Methods
 | Name | Description
Public method | CopyTo |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ScriptErrorCollection Class
CodeSmith.BaseTemplates Namespace


ScriptErrorCollection.CopyTo Method

ScriptErrorCollectionCopyTo Method

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void CopyTo(
    Array array,
    int index
)
Public Sub CopyTo (
    array As Array,
    index As Integer
)

Parameters

array
Type: SystemArray
index
Type: SystemInt32

Implements

ICollectionCopyTo(Array, Int32)
See Also

Reference

ScriptErrorCollection Class
CodeSmith.BaseTemplates Namespace


ScriptErrorCollection.GetEnumerator Method

ScriptErrorCollectionGetEnumerator Method

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator

Implements

IEnumerableGetEnumerator
See Also

Reference

ScriptErrorCollection Class
CodeSmith.BaseTemplates Namespace


ScriptResult Class

The result of a script execution including any errors that may have occurred.
Inheritance Hierarchy
SystemObject
CodeSmith.BaseTemplatesScriptResult

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class ScriptResult
Public Class ScriptResult

The ScriptResult type exposes the following members.

Constructors
 | Name | Description
Public method | ScriptResult | Initializes a new instance of the ScriptResult class
Top
Properties
 | Name | Description
Public property | Errors | Any errors that occurred as the result of executing the script.
Public property | Success | Whether the script was executed successfully or not.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string containing the script execution results including errors. (Overrides ObjectToString.)
Top
See Also

Reference

CodeSmith.BaseTemplates Namespace


ScriptResult Constructor

Initializes a new instance of the ScriptResult class

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ScriptResult(
    bool success,
    ScriptErrorCollection errors
)
Public Sub New (
    success As Boolean,
    errors As ScriptErrorCollection
)

Parameters

success
Type: SystemBoolean
errors
Type: CodeSmith.BaseTemplatesScriptErrorCollection
See Also

Reference

ScriptResult Class
CodeSmith.BaseTemplates Namespace


ScriptResult Properties

The ScriptResult type exposes the following members.

Properties
 | Name | Description
Public property | Errors | Any errors that occurred as the result of executing the script.
Public property | Success | Whether the script was executed successfully or not.
Top
See Also

Reference

ScriptResult Class
CodeSmith.BaseTemplates Namespace


ScriptResult.Errors Property

ScriptResultErrors Property

Any errors that occurred as the result of executing the script.

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ScriptErrorCollection Errors { get; }
Public ReadOnly Property Errors As ScriptErrorCollection
    Get

Property Value

Type: ScriptErrorCollection
See Also

Reference

ScriptResult Class
CodeSmith.BaseTemplates Namespace


ScriptResult.Success Property

ScriptResultSuccess Property

Whether the script was executed successfully or not.

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool Success { get; }
Public ReadOnly Property Success As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

ScriptResult Class
CodeSmith.BaseTemplates Namespace


ScriptResult Methods

The ScriptResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string containing the script execution results including errors. (Overrides ObjectToString.)
Top
See Also

Reference

ScriptResult Class
CodeSmith.BaseTemplates Namespace


ScriptResult.ToString Method

ScriptResultToString Method

Returns a string containing the script execution results including errors.

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
See Also

Reference

ScriptResult Class
CodeSmith.BaseTemplates Namespace


ScriptUtility Class

This class can be used to execute SQL scripts on a database. It takes a SQL script, parsers out the GO's and executes each batch remembering the correct line numbers.
Inheritance Hierarchy
SystemObject
CodeSmith.BaseTemplatesScriptUtility

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class ScriptUtility
Public Class ScriptUtility

The ScriptUtility type exposes the following members.

Constructors
 | Name | Description
Public method | ScriptUtility | Initializes a new instance of the ScriptUtility class
Public method | ScriptUtility(String, String) | Initializes a new instance of the ScriptUtility class
Top
Properties
 | Name | Description
Public property | ConnectionString | The connection string to use when executing the script.
Public property | Script | The script to execute.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | ExecuteScript | Executes the script.
 | ExecuteScript(String, String) | Executes a SQL script using the given connection string.
 | ExecuteScript(String, String, SqlInfoMessageEventHandler) | Executes a SQL script using the given connection string.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | ScriptInfoMessage |
Top
See Also

Reference

CodeSmith.BaseTemplates Namespace


ScriptUtility Constructor

Overload List
 | Name | Description
Public method | ScriptUtility | Initializes a new instance of the ScriptUtility class
Public method | ScriptUtility(String, String) | Initializes a new instance of the ScriptUtility class
Top
See Also

Reference

ScriptUtility Class
CodeSmith.BaseTemplates Namespace


ScriptUtility Constructor

Initializes a new instance of the ScriptUtility class

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ScriptUtility()
Public Sub New
See Also

Reference

ScriptUtility Class
ScriptUtility Overload
CodeSmith.BaseTemplates Namespace


ScriptUtility Constructor (String, String)

Initializes a new instance of the ScriptUtility class

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ScriptUtility(
    string connectionString,
    string script
)
Public Sub New (
    connectionString As String,
    script As String
)

Parameters

connectionString
Type: SystemString
script
Type: SystemString
See Also

Reference

ScriptUtility Class
ScriptUtility Overload
CodeSmith.BaseTemplates Namespace


ScriptUtility Properties

The ScriptUtility type exposes the following members.

Properties
 | Name | Description
Public property | ConnectionString | The connection string to use when executing the script.
Public property | Script | The script to execute.
Top
See Also

Reference

ScriptUtility Class
CodeSmith.BaseTemplates Namespace


ScriptUtility.ConnectionString Property

ScriptUtilityConnectionString Property

The connection string to use when executing the script.

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string ConnectionString { get; set; }
Public Property ConnectionString As String
    Get
    Set

Property Value

Type: String
See Also

Reference

ScriptUtility Class
CodeSmith.BaseTemplates Namespace


ScriptUtility.Script Property

ScriptUtilityScript Property

The script to execute.

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string Script { get; set; }
Public Property Script As String
    Get
    Set

Property Value

Type: String
See Also

Reference

ScriptUtility Class
CodeSmith.BaseTemplates Namespace


ScriptUtility Methods

The ScriptUtility type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | ExecuteScript | Executes the script.
 | ExecuteScript(String, String) | Executes a SQL script using the given connection string.
 | ExecuteScript(String, String, SqlInfoMessageEventHandler) | Executes a SQL script using the given connection string.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ScriptUtility Class
CodeSmith.BaseTemplates Namespace


ScriptUtility.ExecuteScript Method

ScriptUtilityExecuteScript Method

Overload List
 | Name | Description
Public method | ExecuteScript | Executes the script.
 | ExecuteScript(String, String) | Executes a SQL script using the given connection string.
 | ExecuteScript(String, String, SqlInfoMessageEventHandler) | Executes a SQL script using the given connection string.
Top
See Also

Reference

ScriptUtility Class
CodeSmith.BaseTemplates Namespace


ScriptUtility.ExecuteScript Method

ScriptUtilityExecuteScript Method

Executes the script.

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ScriptResult ExecuteScript()
Public Function ExecuteScript As ScriptResult

Return Value

Type: ScriptResult
See Also

Reference

ScriptUtility Class
ExecuteScript Overload
CodeSmith.BaseTemplates Namespace


ScriptUtility.ExecuteScript Method (String, String)

ScriptUtilityExecuteScript Method (String, String)

Executes a SQL script using the given connection string.

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static ScriptResult ExecuteScript(
    string connectionString,
    string script
)
Public Shared Function ExecuteScript (
    connectionString As String,
    script As String
) As ScriptResult

Parameters

connectionString
Type: SystemString
script
Type: SystemString

Return Value

Type: ScriptResult
See Also

Reference

ScriptUtility Class
ExecuteScript Overload
CodeSmith.BaseTemplates Namespace


ScriptUtility.ExecuteScript Method (String, String, SqlInfoMessageEventHandler)

ScriptUtilityExecuteScript Method (String, String, SqlInfoMessageEventHandler)

Executes a SQL script using the given connection string.

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static ScriptResult ExecuteScript(
    string connectionString,
    string script,
    SqlInfoMessageEventHandler infoMessageHandler
)
Public Shared Function ExecuteScript (
    connectionString As String,
    script As String,
    infoMessageHandler As SqlInfoMessageEventHandler
) As ScriptResult

Parameters

connectionString
Type: SystemString
script
Type: SystemString
infoMessageHandler
Type: System.Data.SqlClientSqlInfoMessageEventHandler

Return Value

Type: ScriptResult
See Also

Reference

ScriptUtility Class
ExecuteScript Overload
CodeSmith.BaseTemplates Namespace


ScriptUtility Events

The ScriptUtility type exposes the following members.

Events
 | Name | Description
Public event | ScriptInfoMessage |
Top
See Also

Reference

ScriptUtility Class
CodeSmith.BaseTemplates Namespace


ScriptUtility.ScriptInfoMessage Event

ScriptUtilityScriptInfoMessage Event

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public event SqlInfoMessageEventHandler ScriptInfoMessage
Public Event ScriptInfoMessage As SqlInfoMessageEventHandler

Value

Type: System.Data.SqlClientSqlInfoMessageEventHandler
See Also

Reference

ScriptUtility Class
CodeSmith.BaseTemplates Namespace


SqlCodeTemplate Class

Templates can be derived from this class to gain various helper methods that are useful when generating code from a SQL metadata source.
Inheritance Hierarchy
SystemObject
CodeSmith.EngineControl
CodeSmith.EngineCodeTemplate
CodeSmith.BaseTemplatesOutputFileCodeTemplate
CodeSmith.BaseTemplatesSqlCodeTemplate
CodeSmith.BaseTemplatesVBSqlCodeTemplate

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class SqlCodeTemplate : OutputFileCodeTemplate
Public Class SqlCodeTemplate
    Inherits OutputFileCodeTemplate

The SqlCodeTemplate type exposes the following members.

Constructors
 | Name | Description
Public method | SqlCodeTemplate | Initializes a new instance of the SqlCodeTemplate class
Top
Properties
 | Name | Description
Protected property | ChildControlsCreated | (Inherited from Control.)
Protected property | CodeTemplate | (Inherited from Control.)
Public property | CodeTemplateInfo | Gets the information for the current template. (Inherited from CodeTemplate.)
Public property | ContextData | Contextual data items can be stored in this object and shared with sub-templates. This data will not be persisted with the template property set. (Inherited from CodeTemplate.)
Protected property | Controls | (Inherited from Control.)
Public property | DbTypeToCSharp |
Public property | DbTypeToDataReaderMethod |
Public property | OutputFile | This property is used to specify an output file name that the template output will be saved to. (Inherited from OutputFileCodeTemplate.)
Protected property | Parent | (Inherited from Control.)
Public property | Progress | Provides a way to report execution progress for the template. (Inherited from CodeTemplate.)
Public property | RegisteredOutputs | (Inherited from CodeTemplate.)
Public property | RegisteredReferences | (Inherited from CodeTemplate.)
Public property | Response | Response stream for the template output. You can write to the stream programmatically using this property. (Inherited from CodeTemplate.)
Public property | State | State of this template instance. (Inherited from CodeTemplate.)
Public property | ValidationErrors | Gets the validation errors for this template. (Inherited from CodeTemplate.)
Protected property | Visible | (Inherited from CodeTemplate.)
Top
Methods
 | Name | Description
Protected method | ControlAdded | (Inherited from Control.)
Protected method | ControlRemoved | (Inherited from Control.)
Public method | CopyPropertiesTo(CodeTemplate) | Copies any matching properties to another CodeTemplate instance. (Inherited from CodeTemplate.)
Public method | CopyPropertiesTo(CodeTemplate, Boolean) | Copies any matching properties to another CodeTemplate instance. (Inherited from CodeTemplate.)
Public method | CopyPropertiesTo(CodeTemplate, ICollectionString) | Copies any matching properties to another CodeTemplate instance. (Inherited from CodeTemplate.)
Public method | CopyPropertiesTo(CodeTemplate, Boolean, ICollectionString) | Copies any matching properties to another CodeTemplate instance. (Inherited from CodeTemplate.)
Public method | CreateT | Gets an instance of the specified template type. Should be used with the Register directive. (Inherited from CodeTemplate.)
Public method | CreateT(Boolean) | Gets an instance of the specified template type. Should be used with the Register directive. (Inherited from CodeTemplate.)
Protected method | CreateChildControls | (Inherited from Control.)
Protected method | CreateControlCollection | (Inherited from Control.)
Public method | Dispose | (Inherited from CodeTemplate.)
Protected method | Dispose(Boolean) | (Inherited from CodeTemplate.)
Protected method | EnsureChildControls | (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | (Inherited from CodeTemplate.)
Public method | GetCamelCaseName | Returns a camel cased name from the given identifier.
Public method | GetCodeTemplateInstance(String) | Gets an instance of the specified template. (Inherited from CodeTemplate.)
Public method | GetCodeTemplateInstance(String, Boolean) | Gets an instance of the specified template. (Inherited from CodeTemplate.)
Public method | GetCodeTemplateInstance(String, Boolean, Boolean) | Gets an instance of the specified template. (Inherited from CodeTemplate.)
Public method | GetCSharpVariableType(ColumnSchema) | Returns the C# variable type based on the given column.
Public method | GetCSharpVariableType(CommandResultColumnSchema) | Returns the C# variable type based on the given column.
Public method | GetCSharpVariableType(DbType) | Returns the C# variable type based on the given dataType.
Public method | GetCSharpVariableType(ParameterSchema) | Returns the C# variable type based on the given parameter.
Public method | GetCSharpVariableType(ViewColumnSchema) | Returns the C# variable type based on the given column.
Public method | GetCustomValidationErrors | Allows the developer to add custom ValidationErrors to the validation collection. (Inherited from CodeTemplate.)
 | GetDelimitedIdentifier(DataObjectBase) | This will look up and see if a column name should be escaped with delimited identifiers '[]'. http://msdn.microsoft.com/en-us/library/aa224033(SQL.80).aspx
 | GetDelimitedIdentifier(String, Boolean) | This will look up and see if a column name should be escaped with delimited identifiers '[]'. http://msdn.microsoft.com/en-us/library/aa224033(SQL.80).aspx
Public method | GetFileName | Gets a default name for the template output. This can be overridden in your template to provide a suitable name for the output of the template based on the property values. (Inherited from CodeTemplate.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetMemberVariableDeclarationStatement(ColumnSchema) | Returns a C# member variable declaration statement.
Public method | GetMemberVariableDeclarationStatement(ViewColumnSchema) | Returns a C# member variable declaration statement.
Public method | GetMemberVariableDeclarationStatement(String, ColumnSchema) | Returns a C# member variable declaration statement.
Protected method | GetMemberVariableDeclarationStatement(String, DataObjectBase) | Returns a C# member variable declaration statement.
Public method | GetMemberVariableDeclarationStatement(String, ViewColumnSchema) | Returns a C# member variable declaration statement.
Public method | GetMemberVariableDefaultValue(ColumnSchema) |
 | GetMemberVariableDefaultValue(DataObjectBase) | Returns a default value based on a column's data type.
Public method | GetMemberVariableDefaultValue(ViewColumnSchema) |
Public method | GetMemberVariableName | Returns the C# member variable name for a given identifier.
Public method | GetProperties | Gets information on all of the properties on this template. (Inherited from CodeTemplate.)
Public method | GetProperties(Boolean) | Gets information on all of the properties on this template. (Inherited from CodeTemplate.)
Public method | GetProperty | Gets the value for the specified property. (Inherited from CodeTemplate.)
Public method | GetPropertyAttribute | Gets the property attribute. Property attributes can be used to store various information at the property level. (Inherited from CodeTemplate.)
Public method | GetPropertyDescription | (Inherited from CodeTemplate.)
Public method | GetPropertyInfo | (Inherited from CodeTemplate.)
Public method | GetPropertyName | Returns the name of the public property for a given column.
Public method | GetReaderMethod(ColumnSchema) | Returns the name of the typed reader method for a given column.
Public method | GetReaderMethod(DbType) | Returns the name of the typed reader method for a given column.
Public method | GetReaderMethod(ViewColumnSchema) | Returns the name of the typed reader method for a given column.
Public method | GetRequiredProperties | Gets information on all of the required properties for this template. (Inherited from CodeTemplate.)
Public method | GetSpacedName | Returns a spaced out version of the identifier.
Public method | GetSqlDbType(ColumnSchema) |
Public method | GetSqlDbType(String) | Returns the SqlDbType based on a string.
Public method | GetSqlDbType(ViewColumnSchema) |
Public method | GetSqlParameterExtraParams(String, ColumnSchema) | Generates any extra parameters that are needed for the ADO parameter statement.
Protected method | GetSqlParameterExtraParams(String, DataObjectBase) | Generates any extra parameters that are needed for the ADO parameter statement.
Public method | GetSqlParameterExtraParams(String, ViewColumnSchema) | Generates any extra parameters that are needed for the ADO parameter statement.
Public method | GetSqlParameterStatement(ColumnSchema) | Returns a T-SQL parameter statement based on the given column.
Public method | GetSqlParameterStatement(ViewColumnSchema) | Returns a T-SQL parameter statement based on the given column.
Public method | GetSqlParameterStatement(ColumnSchema, Boolean) | Returns a T-SQL parameter statement based on the given column.
 | GetSqlParameterStatement(DataObjectBase, Boolean) | Returns a T-SQL parameter statement based on the given column.
Public method | GetSqlParameterStatement(ViewColumnSchema, Boolean) | Returns a T-SQL parameter statement based on the given column.
Public method | GetSqlParameterStatements(String, ColumnSchema) | Generates an assignment statement that adds a parameter to a ADO object for the given column.
Public method | GetSqlParameterStatements(String, ColumnSchema, String) | Generates an assignment statement that adds a parameter to a ADO object for the given column.
Public method | GetSqlReaderAssignmentStatement | Returns a typed C# reader.ReadXXX() statement.
Public method | GetTemplateAttribute | Gets the template attribute. Template attributes can be used to store various information at the template level. (Inherited from CodeTemplate.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidateStatements | Generates a batch of C# validation statements based on the column.
Protected method | HasControls | (Inherited from Control.)
Public method | IncludeEmptyCheck | Determines if a given column should use a check for an Empty value.
Public method | IncludeMaxLengthCheck(ColumnSchema) | Determines if the given column's data type requires a max length to be defined.
Public method | IncludeMaxLengthCheck(ViewColumnSchema) | Determines if the given column's data type requires a max length to be defined.
Public method | IsPropertyRequired | (Inherited from CodeTemplate.)
Public method | IsUserDefinedType(ColumnSchema) | Determine if the given column is using a UDT.
 | IsUserDefinedType(DataObjectBase) | Determine if the given column is using a UDT.
Public method | IsUserDefinedType(ViewColumnSchema) | Determine if the given column is using a UDT.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnError | This method can be overridden to perform logic when a template exception occurs. (Inherited from CodeTemplate.)
Protected method | OnInit | This method can be overridden to perform logic when the template instance is created. (Inherited from CodeTemplate.)
Protected method | OnOutputRegistered | This is the method that is responsible for notifying receivers that the event occurred (Inherited from CodeTemplate.)
Protected method | OnPostRender | Override the OnPostRender method so that we can take the result and save it to a file if an output file was specified. (Inherited from OutputFileCodeTemplate.)
Protected method | OnPreOutputWritten(OutputCancelEventArgs) | This is the method that is responsible for notifying receivers that the event occurred (Inherited from CodeTemplate.)
Protected method | OnPreOutputWritten(String) | This is the method that is responsible for notifying receivers that the event occurred (Inherited from CodeTemplate.)
Protected method | OnPreRender | This method can be overridden to perform logic before the template is rendered. (Inherited from CodeTemplate.)
Protected method | OnPropertiesLoaded | This method can be overridden to perform logic when properties are loaded. (Inherited from CodeTemplate.)
Protected method | OnPropertiesSaved | This method can be overridden to perform logic when properties are saved. (Inherited from CodeTemplate.)
Protected method | OnPropertyChanged | This method can be overridden to perform logic when a property changes. (Inherited from CodeTemplate.)
Protected method | OnReferenceRegistered | Raises the ItemRegisteredEventArgs event. (Inherited from CodeTemplate.)
Public method | ParseDefaultValue | Parses the default value for properties. This can be overridden to provide custom default parsing logic. (Inherited from CodeTemplate.)
Public method | RefreshProperties | (Inherited from CodeTemplate.)
Public method | RefreshProperties(Boolean) | (Inherited from CodeTemplate.)
Public method | RegisterOutput(OutputFile) | (Inherited from CodeTemplate.)
Public method | RegisterOutput(String) | (Inherited from CodeTemplate.)
Public method | RegisterReference | Registers the reference. When generating from within Visual Studio, these references will be added to the project. (Inherited from CodeTemplate.)
Public method | Render | Renders to the template output to the specified writer. (Inherited from CodeTemplate.)
Protected method | RenderChildren | (Inherited from Control.)
Public method | RenderToFile(OutputFile, Boolean) | Renders the template output to a file. (Inherited from CodeTemplate.)
Public method | RenderToFile(String, IMergeStrategy) | Renders the template output to a file using a merge strategy. (Inherited from CodeTemplate.)
Public method | RenderToFile(String, Boolean) | Renders the template output to a file. (Inherited from CodeTemplate.)
Public method | RenderToFile(OutputFile, String, IMergeStrategy) | Renders the template output to a file using a merge strategy. (Inherited from CodeTemplate.)
Public method | RenderToFile(String, String, IMergeStrategy) | Renders the template output to a file using a merge strategy. (Inherited from CodeTemplate.)
Public method | RenderToFile(String, String, Boolean) | Renders the template output to a file. (Inherited from CodeTemplate.)
Public method | RenderToString | Renders the template output to a String. (Inherited from CodeTemplate.)
Public method | RenderToString(String, IMergeStrategy) | Renders the template output to a String. (Inherited from CodeTemplate.)
Public method | RestorePropertiesFromHashtable | Restores the properties from a Hashtable. (Inherited from CodeTemplate.)
Public method | RestorePropertiesFromPropertySet(PropertySet, String) | (Inherited from CodeTemplate.)
Public method | RestorePropertiesFromPropertySet(PropertySet, String, Hashtable) | (Inherited from CodeTemplate.)
Public method | RestorePropertiesFromSchema | (Inherited from CodeTemplate.)
Public method | RestorePropertiesFromXml | Restores the properties from XML. (Inherited from CodeTemplate.)
Public method | RestorePropertiesFromXmlFile | Restores the properties from XML file. (Inherited from CodeTemplate.)
Public method | SavePropertiesToHashtable | Saves the properties to a Hashtable. (Inherited from CodeTemplate.)
Public method | SavePropertiesToHashtable(Boolean) | Saves the properties to a Hashtable. (Inherited from CodeTemplate.)
Public method | SavePropertiesToPropertySet | (Inherited from CodeTemplate.)
Public method | SavePropertiesToXml | Saves the properties to XML. (Inherited from CodeTemplate.)
Public method | SavePropertiesToXml(XmlWriter) | Saves the properties to XML. (Inherited from CodeTemplate.)
Public method | SavePropertiesToXmlFile | Saves the properties to an XML file. (Inherited from CodeTemplate.)
Protected method | SetContextData | Set the context data object for the template. Any items in the current ContextData object will be added to the new one. This method should only be called while a template is initializing. (Inherited from CodeTemplate.)
Public method | SetProperty(PropertyInfo, Object) | Sets the value for the specified property. (Inherited from CodeTemplate.)
Public method | SetProperty(String, Object) | Sets the value for the specified property. (Inherited from CodeTemplate.)
Public method | SetProperty(XmlNode, String) | (Inherited from CodeTemplate.)
Public method | SetPropertyAttribute | Sets the property attribute. Property attributes can be used to store various information at the property level. (Inherited from CodeTemplate.)
Protected method | SetPropertyDefaults | This method is overridden in templates to set default values in a template instance. (Inherited from CodeTemplate.)
Public method | SetTemplateAttribute | Sets the template attribute. Template attributes can be used to store various information at the template level. (Inherited from CodeTemplate.)
Protected method | SetUnknownDirectiveAttributes | This method is overridden in templates to set unknown directive attributes in the ContextData. (Inherited from CodeTemplate.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates this template instance. (Inherited from CodeTemplate.)
Top
Events
 | Name | Description
Public event | OutputRegistered | Raised when an output file is registered (Inherited from CodeTemplate.)
Public event | PreOutputWritten | Raised prior to an output being written to disk (Inherited from CodeTemplate.)
Public event | PropertiesLoaded | (Inherited from CodeTemplate.)
Public event | PropertiesSaved | (Inherited from CodeTemplate.)
Public event | PropertyChanged | (Inherited from CodeTemplate.)
Public event | ReferenceRegistered | Occurs when a reference is registered. (Inherited from CodeTemplate.)
Top
Fields
 | Name | Description
Protected field | _childControlsCreated | (Inherited from Control.)
Protected field | _codeTemplate | (Inherited from Control.)
Protected field | _controls | (Inherited from Control.)
Protected field | _outputFile | (Inherited from OutputFileCodeTemplate.)
Protected field | _parent | (Inherited from Control.)
Protected field | _visible | (Inherited from Control.)
Top
See Also

Reference

CodeSmith.BaseTemplates Namespace


SqlCodeTemplate Constructor

Initializes a new instance of the SqlCodeTemplate class

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public SqlCodeTemplate()
Public Sub New
See Also

Reference

SqlCodeTemplate Class
CodeSmith.BaseTemplates Namespace


SqlCodeTemplate Properties

The SqlCodeTemplate type exposes the following members.

Properties
 | Name | Description
Protected property | ChildControlsCreated | (Inherited from Control.)
Protected property | CodeTemplate | (Inherited from Control.)
Public property | CodeTemplateInfo | Gets the information for the current template. (Inherited from CodeTemplate.)
Public property | ContextData | Contextual data items can be stored in this object and shared with sub-templates. This data will not be persisted with the template property set. (Inherited from CodeTemplate.)
Protected property | Controls | (Inherited from Control.)
Public property | DbTypeToCSharp |
Public property | DbTypeToDataReaderMethod |
Public property | OutputFile | This property is used to specify an output file name that the template output will be saved to. (Inherited from OutputFileCodeTemplate.)
Protected property | Parent | (Inherited from Control.)
Public property | Progress | Provides a way to report execution progress for the template. (Inherited from CodeTemplate.)
Public property | RegisteredOutputs | (Inherited from CodeTemplate.)
Public property | RegisteredReferences | (Inherited from CodeTemplate.)
Public property | Response | Response stream for the template output. You can write to the stream programmatically using this property. (Inherited from CodeTemplate.)
Public property | State | State of this template instance. (Inherited from CodeTemplate.)
Public property | ValidationErrors | Gets the validation errors for this template. (Inherited from CodeTemplate.)
Protected property | Visible | (Inherited from CodeTemplate.)
Top
See Also

Reference

SqlCodeTemplate Class
CodeSmith.BaseTemplates Namespace


SqlCodeTemplate.DbTypeToCSharp Property

SqlCodeTemplateDbTypeToCSharp Property

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public MapCollection DbTypeToCSharp { get; }
Public ReadOnly Property DbTypeToCSharp As MapCollection
    Get

Property Value

Type: MapCollection
See Also

Reference

SqlCodeTemplate Class
CodeSmith.BaseTemplates Namespace


SqlCodeTemplate.DbTypeToDataReaderMethod Property

SqlCodeTemplateDbTypeToDataReaderMethod Property

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public MapCollection DbTypeToDataReaderMethod { get; }
Public ReadOnly Property DbTypeToDataReaderMethod As MapCollection
    Get

Property Value

Type: MapCollection
See Also

Reference

SqlCodeTemplate Class
CodeSmith.BaseTemplates Namespace


SqlCodeTemplate Methods

The SqlCodeTemplate type exposes the following members.

Methods
 | Name | Description
Protected method | ControlAdded | (Inherited from Control.)
Protected method | ControlRemoved | (Inherited from Control.)
Public method | CopyPropertiesTo(CodeTemplate) | Copies any matching properties to another CodeTemplate instance. (Inherited from CodeTemplate.)
Public method | CopyPropertiesTo(CodeTemplate, Boolean) | Copies any matching properties to another CodeTemplate instance. (Inherited from CodeTemplate.)
Public method | CopyPropertiesTo(CodeTemplate, ICollectionString) | Copies any matching properties to another CodeTemplate instance. (Inherited from CodeTemplate.)
Public method | CopyPropertiesTo(CodeTemplate, Boolean, ICollectionString) | Copies any matching properties to another CodeTemplate instance. (Inherited from CodeTemplate.)
Public method | CreateT | Gets an instance of the specified template type. Should be used with the Register directive. (Inherited from CodeTemplate.)
Public method | CreateT(Boolean) | Gets an instance of the specified template type. Should be used with the Register directive. (Inherited from CodeTemplate.)
Protected method | CreateChildControls | (Inherited from Control.)
Protected method | CreateControlCollection | (Inherited from Control.)
Public method | Dispose | (Inherited from CodeTemplate.)
Protected method | Dispose(Boolean) | (Inherited from CodeTemplate.)
Protected method | EnsureChildControls | (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | (Inherited from CodeTemplate.)
Public method | GetCamelCaseName | Returns a camel cased name from the given identifier.
Public method | GetCodeTemplateInstance(String) | Gets an instance of the specified template. (Inherited from CodeTemplate.)
Public method | GetCodeTemplateInstance(String, Boolean) | Gets an instance of the specified template. (Inherited from CodeTemplate.)
Public method | GetCodeTemplateInstance(String, Boolean, Boolean) | Gets an instance of the specified template. (Inherited from CodeTemplate.)
Public method | GetCSharpVariableType(ColumnSchema) | Returns the C# variable type based on the given column.
Public method | GetCSharpVariableType(CommandResultColumnSchema) | Returns the C# variable type based on the given column.
Public method | GetCSharpVariableType(DbType) | Returns the C# variable type based on the given dataType.
Public method | GetCSharpVariableType(ParameterSchema) | Returns the C# variable type based on the given parameter.
Public method | GetCSharpVariableType(ViewColumnSchema) | Returns the C# variable type based on the given column.
Public method | GetCustomValidationErrors | Allows the developer to add custom ValidationErrors to the validation collection. (Inherited from CodeTemplate.)
 | GetDelimitedIdentifier(DataObjectBase) | This will look up and see if a column name should be escaped with delimited identifiers '[]'. http://msdn.microsoft.com/en-us/library/aa224033(SQL.80).aspx
 | GetDelimitedIdentifier(String, Boolean) | This will look up and see if a column name should be escaped with delimited identifiers '[]'. http://msdn.microsoft.com/en-us/library/aa224033(SQL.80).aspx
Public method | GetFileName | Gets a default name for the template output. This can be overridden in your template to provide a suitable name for the output of the template based on the property values. (Inherited from CodeTemplate.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetMemberVariableDeclarationStatement(ColumnSchema) | Returns a C# member variable declaration statement.
Public method | GetMemberVariableDeclarationStatement(ViewColumnSchema) | Returns a C# member variable declaration statement.
Public method | GetMemberVariableDeclarationStatement(String, ColumnSchema) | Returns a C# member variable declaration statement.
Protected method | GetMemberVariableDeclarationStatement(String, DataObjectBase) | Returns a C# member variable declaration statement.
Public method | GetMemberVariableDeclarationStatement(String, ViewColumnSchema) | Returns a C# member variable declaration statement.
Public method | GetMemberVariableDefaultValue(ColumnSchema) |
 | GetMemberVariableDefaultValue(DataObjectBase) | Returns a default value based on a column's data type.
Public method | GetMemberVariableDefaultValue(ViewColumnSchema) |
Public method | GetMemberVariableName | Returns the C# member variable name for a given identifier.
Public method | GetProperties | Gets information on all of the properties on this template. (Inherited from CodeTemplate.)
Public method | GetProperties(Boolean) | Gets information on all of the properties on this template. (Inherited from CodeTemplate.)
Public method | GetProperty | Gets the value for the specified property. (Inherited from CodeTemplate.)
Public method | GetPropertyAttribute | Gets the property attribute. Property attributes can be used to store various information at the property level. (Inherited from CodeTemplate.)
Public method | GetPropertyDescription | (Inherited from CodeTemplate.)
Public method | GetPropertyInfo | (Inherited from CodeTemplate.)
Public method | GetPropertyName | Returns the name of the public property for a given column.
Public method | GetReaderMethod(ColumnSchema) | Returns the name of the typed reader method for a given column.
Public method | GetReaderMethod(DbType) | Returns the name of the typed reader method for a given column.
Public method | GetReaderMethod(ViewColumnSchema) | Returns the name of the typed reader method for a given column.
Public method | GetRequiredProperties | Gets information on all of the required properties for this template. (Inherited from CodeTemplate.)
Public method | GetSpacedName | Returns a spaced out version of the identifier.
Public method | GetSqlDbType(ColumnSchema) |
Public method | GetSqlDbType(String) | Returns the SqlDbType based on a string.
Public method | GetSqlDbType(ViewColumnSchema) |
Public method | GetSqlParameterExtraParams(String, ColumnSchema) | Generates any extra parameters that are needed for the ADO parameter statement.
Protected method | GetSqlParameterExtraParams(String, DataObjectBase) | Generates any extra parameters that are needed for the ADO parameter statement.
Public method | GetSqlParameterExtraParams(String, ViewColumnSchema) | Generates any extra parameters that are needed for the ADO parameter statement.
Public method | GetSqlParameterStatement(ColumnSchema) | Returns a T-SQL parameter statement based on the given column.
Public method | GetSqlParameterStatement(ViewColumnSchema) | Returns a T-SQL parameter statement based on the given column.
Public method | GetSqlParameterStatement(ColumnSchema, Boolean) | Returns a T-SQL parameter statement based on the given column.
 | GetSqlParameterStatement(DataObjectBase, Boolean) | Returns a T-SQL parameter statement based on the given column.
Public method | GetSqlParameterStatement(ViewColumnSchema, Boolean) | Returns a T-SQL parameter statement based on the given column.
Public method | GetSqlParameterStatements(String, ColumnSchema) | Generates an assignment statement that adds a parameter to a ADO object for the given column.
Public method | GetSqlParameterStatements(String, ColumnSchema, String) | Generates an assignment statement that adds a parameter to a ADO object for the given column.
Public method | GetSqlReaderAssignmentStatement | Returns a typed C# reader.ReadXXX() statement.
Public method | GetTemplateAttribute | Gets the template attribute. Template attributes can be used to store various information at the template level. (Inherited from CodeTemplate.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidateStatements | Generates a batch of C# validation statements based on the column.
Protected method | HasControls | (Inherited from Control.)
Public method | IncludeEmptyCheck | Determines if a given column should use a check for an Empty value.
Public method | IncludeMaxLengthCheck(ColumnSchema) | Determines if the given column's data type requires a max length to be defined.
Public method | IncludeMaxLengthCheck(ViewColumnSchema) | Determines if the given column's data type requires a max length to be defined.
Public method | IsPropertyRequired | (Inherited from CodeTemplate.)
Public method | IsUserDefinedType(ColumnSchema) | Determine if the given column is using a UDT.
 | IsUserDefinedType(DataObjectBase) | Determine if the given column is using a UDT.
Public method | IsUserDefinedType(ViewColumnSchema) | Determine if the given column is using a UDT.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnError | This method can be overridden to perform logic when a template exception occurs. (Inherited from CodeTemplate.)
Protected method | OnInit | This method can be overridden to perform logic when the template instance is created. (Inherited from CodeTemplate.)
Protected method | OnOutputRegistered | This is the method that is responsible for notifying receivers that the event occurred (Inherited from CodeTemplate.)
Protected method | OnPostRender | Override the OnPostRender method so that we can take the result and save it to a file if an output file was specified. (Inherited from OutputFileCodeTemplate.)
Protected method | OnPreOutputWritten(OutputCancelEventArgs) | This is the method that is responsible for notifying receivers that the event occurred (Inherited from CodeTemplate.)
Protected method | OnPreOutputWritten(String) | This is the method that is responsible for notifying receivers that the event occurred (Inherited from CodeTemplate.)
Protected method | OnPreRender | This method can be overridden to perform logic before the template is rendered. (Inherited from CodeTemplate.)
Protected method | OnPropertiesLoaded | This method can be overridden to perform logic when properties are loaded. (Inherited from CodeTemplate.)
Protected method | OnPropertiesSaved | This method can be overridden to perform logic when properties are saved. (Inherited from CodeTemplate.)
Protected method | OnPropertyChanged | This method can be overridden to perform logic when a property changes. (Inherited from CodeTemplate.)
Protected method | OnReferenceRegistered | Raises the ItemRegisteredEventArgs event. (Inherited from CodeTemplate.)
Public method | ParseDefaultValue | Parses the default value for properties. This can be overridden to provide custom default parsing logic. (Inherited from CodeTemplate.)
Public method | RefreshProperties | (Inherited from CodeTemplate.)
Public method | RefreshProperties(Boolean) | (Inherited from CodeTemplate.)
Public method | RegisterOutput(OutputFile) | (Inherited from CodeTemplate.)
Public method | RegisterOutput(String) | (Inherited from CodeTemplate.)
Public method | RegisterReference | Registers the reference. When generating from within Visual Studio, these references will be added to the project. (Inherited from CodeTemplate.)
Public method | Render | Renders to the template output to the specified writer. (Inherited from CodeTemplate.)
Protected method | RenderChildren | (Inherited from Control.)
Public method | RenderToFile(OutputFile, Boolean) | Renders the template output to a file. (Inherited from CodeTemplate.)
Public method | RenderToFile(String, IMergeStrategy) | Renders the template output to a file using a merge strategy. (Inherited from CodeTemplate.)
Public method | RenderToFile(String, Boolean) | Renders the template output to a file. (Inherited from CodeTemplate.)
Public method | RenderToFile(OutputFile, String, IMergeStrategy) | Renders the template output to a file using a merge strategy. (Inherited from CodeTemplate.)
Public method | RenderToFile(String, String, IMergeStrategy) | Renders the template output to a file using a merge strategy. (Inherited from CodeTemplate.)
Public method | RenderToFile(String, String, Boolean) | Renders the template output to a file. (Inherited from CodeTemplate.)
Public method | RenderToString | Renders the template output to a String. (Inherited from CodeTemplate.)
Public method | RenderToString(String, IMergeStrategy) | Renders the template output to a String. (Inherited from CodeTemplate.)
Public method | RestorePropertiesFromHashtable | Restores the properties from a Hashtable. (Inherited from CodeTemplate.)
Public method | RestorePropertiesFromPropertySet(PropertySet, String) | (Inherited from CodeTemplate.)
Public method | RestorePropertiesFromPropertySet(PropertySet, String, Hashtable) | (Inherited from CodeTemplate.)
Public method | RestorePropertiesFromSchema | (Inherited from CodeTemplate.)
Public method | RestorePropertiesFromXml | Restores the properties from XML. (Inherited from CodeTemplate.)
Public method | RestorePropertiesFromXmlFile | Restores the properties from XML file. (Inherited from CodeTemplate.)
Public method | SavePropertiesToHashtable | Saves the properties to a Hashtable. (Inherited from CodeTemplate.)
Public method | SavePropertiesToHashtable(Boolean) | Saves the properties to a Hashtable. (Inherited from CodeTemplate.)
Public method | SavePropertiesToPropertySet | (Inherited from CodeTemplate.)
Public method | SavePropertiesToXml | Saves the properties to XML. (Inherited from CodeTemplate.)
Public method | SavePropertiesToXml(XmlWriter) | Saves the properties to XML. (Inherited from CodeTemplate.)
Public method | SavePropertiesToXmlFile | Saves the properties to an XML file. (Inherited from CodeTemplate.)
Protected method | SetContextData | Set the context data object for the template. Any items in the current ContextData object will be added to the new one. This method should only be called while a template is initializing. (Inherited from CodeTemplate.)
Public method | SetProperty(PropertyInfo, Object) | Sets the value for the specified property. (Inherited from CodeTemplate.)
Public method | SetProperty(String, Object) | Sets the value for the specified property. (Inherited from CodeTemplate.)
Public method | SetProperty(XmlNode, String) | (Inherited from CodeTemplate.)
Public method | SetPropertyAttribute | Sets the property attribute. Property attributes can be used to store various information at the property level. (Inherited from CodeTemplate.)
Protected method | SetPropertyDefaults | This method is overridden in templates to set default values in a template instance. (Inherited from CodeTemplate.)
Public method | SetTemplateAttribute | Sets the template attribute. Template attributes can be used to store various information at the template level. (Inherited from CodeTemplate.)
Protected method | SetUnknownDirectiveAttributes | This method is overridden in templates to set unknown directive attributes in the ContextData. (Inherited from CodeTemplate.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates this template instance. (Inherited from CodeTemplate.)
Top
See Also

Reference

SqlCodeTemplate Class
CodeSmith.BaseTemplates Namespace


SqlCodeTemplate.GetCamelCaseName Method

SqlCodeTemplateGetCamelCaseName Method

Returns a camel cased name from the given identifier.

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string GetCamelCaseName(
    string value
)
Public Function GetCamelCaseName (
    value As String
) As String

Parameters

value
Type: SystemString

Return Value

Type: String
See Also

Reference

SqlCodeTemplate Class
CodeSmith.BaseTemplates Namespace


SqlCodeTemplate.GetCSharpVariableType Method

SqlCodeTemplateGetCSharpVariableType Method

Overload List
 | Name | Description
Public method | GetCSharpVariableType(ColumnSchema) | Returns the C# variable type based on the given column.
Public method | GetCSharpVariableType(CommandResultColumnSchema) | Returns the C# variable type based on the given column.
Public method | GetCSharpVariableType(DbType) | Returns the C# variable type based on the given dataType.
Public method | GetCSharpVariableType(ParameterSchema) | Returns the C# variable type based on the given parameter.
Public method | GetCSharpVariableType(ViewColumnSchema) | Returns the C# variable type based on the given column.
Top
See Also

Reference

SqlCodeTemplate Class
CodeSmith.BaseTemplates Namespace


SqlCodeTemplate.GetCSharpVariableType Method (ColumnSchema)

SqlCodeTemplateGetCSharpVariableType Method (ColumnSchema)

Returns the C# variable type based on the given column.

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string GetCSharpVariableType(
    ColumnSchema column
)
Public Function GetCSharpVariableType (
    column As ColumnSchema
) As String

Parameters

column
Type: SchemaExplorerColumnSchema

Return Value

Type: String
See Also

Reference

SqlCodeTemplate Class
GetCSharpVariableType Overload
CodeSmith.BaseTemplates Namespace


SqlCodeTemplate.GetCSharpVariableType Method (CommandResultColumnSchema)

SqlCodeTemplateGetCSharpVariableType Method (CommandResultColumnSchema)

Returns the C# variable type based on the given column.

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string GetCSharpVariableType(
    CommandResultColumnSchema column
)
Public Function GetCSharpVariableType (
    column As CommandResultColumnSchema
) As String

Parameters

column
Type: SchemaExplorerCommandResultColumnSchema

Return Value

Type: String
See Also

Reference

SqlCodeTemplate Class
GetCSharpVariableType Overload
CodeSmith.BaseTemplates Namespace


SqlCodeTemplate.GetCSharpVariableType Method (DbType)

SqlCodeTemplateGetCSharpVariableType Method (DbType)

Returns the C# variable type based on the given dataType.

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string GetCSharpVariableType(
    DbType dataType
)
Public Function GetCSharpVariableType (
    dataType As DbType
) As String

Parameters

dataType
Type: System.DataDbType

Return Value

Type: String
See Also

Reference

SqlCodeTemplate Class
GetCSharpVariableType Overload
CodeSmith.BaseTemplates Namespace


SqlCodeTemplate.GetCSharpVariableType Method (ParameterSchema)

SqlCodeTemplateGetCSharpVariableType Method (ParameterSchema)

Returns the C# variable type based on the given parameter.

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string GetCSharpVariableType(
    ParameterSchema column
)
Public Function GetCSharpVariableType (
    column As ParameterSchema
) As String

Parameters

column
Type: SchemaExplorerParameterSchema

Return Value

Type: String
See Also

Reference

SqlCodeTemplate Class
GetCSharpVariableType Overload
CodeSmith.BaseTemplates Namespace


SqlCodeTemplate.GetCSharpVariableType Method (ViewColumnSchema)

SqlCodeTemplateGetCSharpVariableType Method (ViewColumnSchema)

Returns the C# variable type based on the given column.

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string GetCSharpVariableType(
    ViewColumnSchema column
)
Public Function GetCSharpVariableType (
    column As ViewColumnSchema
) As String

Parameters

column
Type: SchemaExplorerViewColumnSchema

Return Value

Type: String
See Also

Reference

SqlCodeTemplate Class
GetCSharpVariableType Overload
CodeSmith.BaseTemplates Namespace


SqlCodeTemplate.GetDelimitedIdentifier Method

SqlCodeTemplateGetDelimitedIdentifier Method

Overload List
Name | Description
GetDelimitedIdentifier(DataObjectBase) | This will look up and see if a column name should be escaped with delimited identifiers '[]'. http://msdn.microsoft.com/en-us/library/aa224033(SQL.80).aspx
GetDelimitedIdentifier(String, Boolean) | This will look up and see if a column name should be escaped with delimited identifiers '[]'. http://msdn.microsoft.com/en-us/library/aa224033(SQL.80).aspx
Top
See Also

Reference

SqlCodeTemplate Class
CodeSmith.BaseTemplates Namespace


SqlCodeTemplate.GetDelimitedIdentifier Method (DataObjectBase)

SqlCodeTemplateGetDelimitedIdentifier Method (DataObjectBase)

This will look up and see if a column name should be escaped with delimited identifiers '[]'. http://msdn.microsoft.com/en-us/library/aa224033(SQL.80).aspx

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected static string GetDelimitedIdentifier(
    DataObjectBase column
)
Protected Shared Function GetDelimitedIdentifier (
    column As DataObjectBase
) As String

Parameters

column
Type: SchemaExplorerDataObjectBase
The source.

Return Value

Type: String
See Also

Reference

SqlCodeTemplate Class
GetDelimitedIdentifier Overload
CodeSmith.BaseTemplates Namespace


SqlCodeTemplate.GetDelimitedIdentifier Method (String, Boolean)

SqlCodeTemplateGetDelimitedIdentifier Method (String, Boolean)

This will look up and see if a column name should be escaped with delimited identifiers '[]'. http://msdn.microsoft.com/en-us/library/aa224033(SQL.80).aspx

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected static string GetDelimitedIdentifier(
    string source,
    bool includeDelimitedIdentifier
)
Protected Shared Function GetDelimitedIdentifier (
    source As String,
    includeDelimitedIdentifier As Boolean
) As String

Parameters

source
Type: SystemString
The source.
includeDelimitedIdentifier
Type: SystemBoolean
Enforces that a delimited identifiers are added.

Return Value

Type: String
See Also

Reference

SqlCodeTemplate Class
GetDelimitedIdentifier Overload
CodeSmith.BaseTemplates Namespace


SqlCodeTemplate.GetMemberVariableDeclarationStatement Method

SqlCodeTemplateGetMemberVariableDeclarationStatement Method

Overload List
 | Name | Description
Public method | GetMemberVariableDeclarationStatement(ColumnSchema) | Returns a C# member variable declaration statement.
Public method | GetMemberVariableDeclarationStatement(ViewColumnSchema) | Returns a C# member variable declaration statement.
Public method | GetMemberVariableDeclarationStatement(String, ColumnSchema) | Returns a C# member variable declaration statement.
Protected method | GetMemberVariableDeclarationStatement(String, DataObjectBase) | Returns a C# member variable declaration statement.
Public method | GetMemberVariableDeclarationStatement(String, ViewColumnSchema) | Returns a C# member variable declaration statement.
Top
See Also

Reference

SqlCodeTemplate Class
CodeSmith.BaseTemplates Namespace


SqlCodeTemplate.GetMemberVariableDeclarationStatement Method (ColumnSchema)

SqlCodeTemplateGetMemberVariableDeclarationStatement Method (ColumnSchema)

Returns a C# member variable declaration statement.

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual string GetMemberVariableDeclarationStatement(
    ColumnSchema column
)
Public Overridable Function GetMemberVariableDeclarationStatement (
    column As ColumnSchema
) As String

Parameters

column
Type: SchemaExplorerColumnSchema

Return Value

Type: String
See Also

Reference

SqlCodeTemplate Class
GetMemberVariableDeclarationStatement Overload
CodeSmith.BaseTemplates Namespace


SqlCodeTemplate.GetMemberVariableDeclarationStatement Method (ViewColumnSchema)

SqlCodeTemplateGetMemberVariableDeclarationStatement Method (ViewColumnSchema)

Returns a C# member variable declaration statement.

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual string GetMemberVariableDeclarationStatement(
    ViewColumnSchema column
)
Public Overridable Function GetMemberVariableDeclarationStatement (
    column As ViewColumnSchema
) As String

Parameters

column
Type: SchemaExplorerViewColumnSchema

Return Value

Type: String
See Also

Reference

SqlCodeTemplate Class
GetMemberVariableDeclarationStatement Overload
CodeSmith.BaseTemplates Namespace


SqlCodeTemplate.GetMemberVariableDeclarationStatement Method (String, ColumnSchema)

SqlCodeTemplateGetMemberVariableDeclarationStatement Method (String, ColumnSchema)

Returns a C# member variable declaration statement.

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string GetMemberVariableDeclarationStatement(
    string protectionLevel,
    ColumnSchema column
)
Public Function GetMemberVariableDeclarationStatement (
    protectionLevel As String,
    column As ColumnSchema
) As String

Parameters

protectionLevel
Type: SystemString
column
Type: SchemaExplorerColumnSchema

Return Value

Type: String
See Also

Reference

SqlCodeTemplate Class
GetMemberVariableDeclarationStatement Overload
CodeSmith.BaseTemplates Namespace


SqlCodeTemplate.GetMemberVariableDeclarationStatement Method (String, DataObjectBase)

SqlCodeTemplateGetMemberVariableDeclarationStatement Method (String, DataObjectBase)

Returns a C# member variable declaration statement.

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual string GetMemberVariableDeclarationStatement(
    string protectionLevel,
    DataObjectBase column
)
Protected Overridable Function GetMemberVariableDeclarationStatement (
    protectionLevel As String,
    column As DataObjectBase
) As String

Parameters

protectionLevel
Type: SystemString
column
Type: SchemaExplorerDataObjectBase

Return Value

Type: String
See Also

Reference

SqlCodeTemplate Class
GetMemberVariableDeclarationStatement Overload
CodeSmith.BaseTemplates Namespace


SqlCodeTemplate.GetMemberVariableDeclarationStatement Method (String, ViewColumnSchema)

SqlCodeTemplateGetMemberVariableDeclarationStatement Method (String, ViewColumnSchema)

Returns a C# member variable declaration statement.

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string GetMemberVariableDeclarationStatement(
    string protectionLevel,
    ViewColumnSchema column
)
Public Function GetMemberVariableDeclarationStatement (
    protectionLevel As String,
    column As ViewColumnSchema
) As String

Parameters

protectionLevel
Type: SystemString
column
Type: SchemaExplorerViewColumnSchema

Return Value

Type: String
See Also

Reference

SqlCodeTemplate Class
GetMemberVariableDeclarationStatement Overload
CodeSmith.BaseTemplates Namespace


SqlCodeTemplate.GetMemberVariableDefaultValue Method

SqlCodeTemplateGetMemberVariableDefaultValue Method

Overload List
 | Name | Description
Public method | GetMemberVariableDefaultValue(ColumnSchema) |
 | GetMemberVariableDefaultValue(DataObjectBase) | Returns a default value based on a column's data type.
Public method | GetMemberVariableDefaultValue(ViewColumnSchema) |
Top
See Also

Reference

SqlCodeTemplate Class
CodeSmith.BaseTemplates Namespace


SqlCodeTemplate.GetMemberVariableDefaultValue Method (ColumnSchema)

SqlCodeTemplateGetMemberVariableDefaultValue Method (ColumnSchema)

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string GetMemberVariableDefaultValue(
    ColumnSchema column
)
Public Function GetMemberVariableDefaultValue (
    column As ColumnSchema
) As String

Parameters

column
Type: SchemaExplorerColumnSchema

Return Value

Type: String
See Also

Reference

SqlCodeTemplate Class
GetMemberVariableDefaultValue Overload
CodeSmith.BaseTemplates Namespace


SqlCodeTemplate.GetMemberVariableDefaultValue Method (DataObjectBase)

SqlCodeTemplateGetMemberVariableDefaultValue Method (DataObjectBase)

Returns a default value based on a column's data type.

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected static string GetMemberVariableDefaultValue(
    DataObjectBase column
)
Protected Shared Function GetMemberVariableDefaultValue (
    column As DataObjectBase
) As String

Parameters

column
Type: SchemaExplorerDataObjectBase

Return Value

Type: String
See Also

Reference

SqlCodeTemplate Class
GetMemberVariableDefaultValue Overload
CodeSmith.BaseTemplates Namespace


SqlCodeTemplate.GetMemberVariableDefaultValue Method (ViewColumnSchema)

SqlCodeTemplateGetMemberVariableDefaultValue Method (ViewColumnSchema)

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string GetMemberVariableDefaultValue(
    ViewColumnSchema column
)
Public Function GetMemberVariableDefaultValue (
    column As ViewColumnSchema
) As String

Parameters

column
Type: SchemaExplorerViewColumnSchema

Return Value

Type: String
See Also

Reference

SqlCodeTemplate Class
GetMemberVariableDefaultValue Overload
CodeSmith.BaseTemplates Namespace


SqlCodeTemplate.GetMemberVariableName Method

SqlCodeTemplateGetMemberVariableName Method

Returns the C# member variable name for a given identifier.

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string GetMemberVariableName(
    string value
)
Public Function GetMemberVariableName (
    value As String
) As String

Parameters

value
Type: SystemString

Return Value

Type: String
See Also

Reference

SqlCodeTemplate Class
CodeSmith.BaseTemplates Namespace


SqlCodeTemplate.GetPropertyName Method

SqlCodeTemplateGetPropertyName Method

Returns the name of the public property for a given column.

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string GetPropertyName(
    ColumnSchema column
)
Public Function GetPropertyName (
    column As ColumnSchema
) As String

Parameters

column
Type: SchemaExplorerColumnSchema

Return Value

Type: String
See Also

Reference

SqlCodeTemplate Class
CodeSmith.BaseTemplates Namespace


SqlCodeTemplate.GetReaderMethod Method

SqlCodeTemplateGetReaderMethod Method

Overload List
 | Name | Description
Public method | GetReaderMethod(ColumnSchema) | Returns the name of the typed reader method for a given column.
Public method | GetReaderMethod(DbType) | Returns the name of the typed reader method for a given column.
Public method | GetReaderMethod(ViewColumnSchema) | Returns the name of the typed reader method for a given column.
Top
See Also

Reference

SqlCodeTemplate Class
CodeSmith.BaseTemplates Namespace


SqlCodeTemplate.GetReaderMethod Method (ColumnSchema)

SqlCodeTemplateGetReaderMethod Method (ColumnSchema)

Returns the name of the typed reader method for a given column.

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string GetReaderMethod(
    ColumnSchema column
)
Public Function GetReaderMethod (
    column As ColumnSchema
) As String

Parameters

column
Type: SchemaExplorerColumnSchema

Return Value

Type: String
See Also

Reference

SqlCodeTemplate Class
GetReaderMethod Overload
CodeSmith.BaseTemplates Namespace


SqlCodeTemplate.GetReaderMethod Method (DbType)

SqlCodeTemplateGetReaderMethod Method (DbType)

Returns the name of the typed reader method for a given column.

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string GetReaderMethod(
    DbType dataType
)
Public Function GetReaderMethod (
    dataType As DbType
) As String

Parameters

dataType
Type: System.DataDbType

Return Value

Type: String
See Also

Reference

SqlCodeTemplate Class
GetReaderMethod Overload
CodeSmith.BaseTemplates Namespace


SqlCodeTemplate.GetReaderMethod Method (ViewColumnSchema)

SqlCodeTemplateGetReaderMethod Method (ViewColumnSchema)

Returns the name of the typed reader method for a given column.

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string GetReaderMethod(
    ViewColumnSchema column
)
Public Function GetReaderMethod (
    column As ViewColumnSchema
) As String

Parameters

column
Type: SchemaExplorerViewColumnSchema

Return Value

Type: String
See Also

Reference

SqlCodeTemplate Class
GetReaderMethod Overload
CodeSmith.BaseTemplates Namespace


SqlCodeTemplate.GetSpacedName Method

SqlCodeTemplateGetSpacedName Method

Returns a spaced out version of the identifier.

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string GetSpacedName(
    string value
)
Public Function GetSpacedName (
    value As String
) As String

Parameters

value
Type: SystemString

Return Value

Type: String
See Also

Reference

SqlCodeTemplate Class
CodeSmith.BaseTemplates Namespace


SqlCodeTemplate.GetSqlDbType Method

SqlCodeTemplateGetSqlDbType Method

Overload List
 | Name | Description
Public method | GetSqlDbType(ColumnSchema) |
Public method | GetSqlDbType(String) | Returns the SqlDbType based on a string.
Public method | GetSqlDbType(ViewColumnSchema) |
Top
See Also

Reference

SqlCodeTemplate Class
CodeSmith.BaseTemplates Namespace


SqlCodeTemplate.GetSqlDbType Method (ColumnSchema)

SqlCodeTemplateGetSqlDbType Method (ColumnSchema)

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string GetSqlDbType(
    ColumnSchema column
)
Public Function GetSqlDbType (
    column As ColumnSchema
) As String

Parameters

column
Type: SchemaExplorerColumnSchema

Return Value

Type: String
See Also

Reference

SqlCodeTemplate Class
GetSqlDbType Overload
CodeSmith.BaseTemplates Namespace


SqlCodeTemplate.GetSqlDbType Method (String)

SqlCodeTemplateGetSqlDbType Method (String)

Returns the SqlDbType based on a string.

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string GetSqlDbType(
    string nativeType
)
Public Function GetSqlDbType (
    nativeType As String
) As String

Parameters

nativeType
Type: SystemString

Return Value

Type: String
See Also

Reference

SqlCodeTemplate Class
GetSqlDbType Overload
CodeSmith.BaseTemplates Namespace


SqlCodeTemplate.GetSqlDbType Method (ViewColumnSchema)

SqlCodeTemplateGetSqlDbType Method (ViewColumnSchema)

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string GetSqlDbType(
    ViewColumnSchema column
)
Public Function GetSqlDbType (
    column As ViewColumnSchema
) As String

Parameters

column
Type: SchemaExplorerViewColumnSchema

Return Value

Type: String
See Also

Reference

SqlCodeTemplate Class
GetSqlDbType Overload
CodeSmith.BaseTemplates Namespace


SqlCodeTemplate.GetSqlParameterExtraParams Method

SqlCodeTemplateGetSqlParameterExtraParams Method

Overload List
 | Name | Description
Public method | GetSqlParameterExtraParams(String, ColumnSchema) | Generates any extra parameters that are needed for the ADO parameter statement.
Protected method | GetSqlParameterExtraParams(String, DataObjectBase) | Generates any extra parameters that are needed for the ADO parameter statement.
Public method | GetSqlParameterExtraParams(String, ViewColumnSchema) | Generates any extra parameters that are needed for the ADO parameter statement.
Top
See Also

Reference

SqlCodeTemplate Class
CodeSmith.BaseTemplates Namespace


SqlCodeTemplate.GetSqlParameterExtraParams Method (String, ColumnSchema)

SqlCodeTemplateGetSqlParameterExtraParams Method (String, ColumnSchema)

Generates any extra parameters that are needed for the ADO parameter statement.

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string GetSqlParameterExtraParams(
    string statementPrefix,
    ColumnSchema column
)
Public Function GetSqlParameterExtraParams (
    statementPrefix As String,
    column As ColumnSchema
) As String

Parameters

statementPrefix
Type: SystemString
column
Type: SchemaExplorerColumnSchema

Return Value

Type: String
See Also

Reference

SqlCodeTemplate Class
GetSqlParameterExtraParams Overload
CodeSmith.BaseTemplates Namespace


SqlCodeTemplate.GetSqlParameterExtraParams Method (String, DataObjectBase)

SqlCodeTemplateGetSqlParameterExtraParams Method (String, DataObjectBase)

Generates any extra parameters that are needed for the ADO parameter statement.

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual string GetSqlParameterExtraParams(
    string statementPrefix,
    DataObjectBase column
)
Protected Overridable Function GetSqlParameterExtraParams (
    statementPrefix As String,
    column As DataObjectBase
) As String

Parameters

statementPrefix
Type: SystemString
column
Type: SchemaExplorerDataObjectBase

Return Value

Type: String
See Also

Reference

SqlCodeTemplate Class
GetSqlParameterExtraParams Overload
CodeSmith.BaseTemplates Namespace


SqlCodeTemplate.GetSqlParameterExtraParams Method (String, ViewColumnSchema)

SqlCodeTemplateGetSqlParameterExtraParams Method (String, ViewColumnSchema)

Generates any extra parameters that are needed for the ADO parameter statement.

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string GetSqlParameterExtraParams(
    string statementPrefix,
    ViewColumnSchema column
)
Public Function GetSqlParameterExtraParams (
    statementPrefix As String,
    column As ViewColumnSchema
) As String

Parameters

statementPrefix
Type: SystemString
column
Type: SchemaExplorerViewColumnSchema

Return Value

Type: String
See Also

Reference

SqlCodeTemplate Class
GetSqlParameterExtraParams Overload
CodeSmith.BaseTemplates Namespace


SqlCodeTemplate.GetSqlParameterStatement Method

SqlCodeTemplateGetSqlParameterStatement Method

Overload List
 | Name | Description
Public method | GetSqlParameterStatement(ColumnSchema) | Returns a T-SQL parameter statement based on the given column.
Public method | GetSqlParameterStatement(ViewColumnSchema) | Returns a T-SQL parameter statement based on the given column.
Public method | GetSqlParameterStatement(ColumnSchema, Boolean) | Returns a T-SQL parameter statement based on the given column.
 | GetSqlParameterStatement(DataObjectBase, Boolean) | Returns a T-SQL parameter statement based on the given column.
Public method | GetSqlParameterStatement(ViewColumnSchema, Boolean) | Returns a T-SQL parameter statement based on the given column.
Top
See Also

Reference

SqlCodeTemplate Class
CodeSmith.BaseTemplates Namespace


SqlCodeTemplate.GetSqlParameterStatement Method (ColumnSchema)

SqlCodeTemplateGetSqlParameterStatement Method (ColumnSchema)

Returns a T-SQL parameter statement based on the given column.

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string GetSqlParameterStatement(
    ColumnSchema column
)
Public Function GetSqlParameterStatement (
    column As ColumnSchema
) As String

Parameters

column
Type: SchemaExplorerColumnSchema

Return Value

Type: String
See Also

Reference

SqlCodeTemplate Class
GetSqlParameterStatement Overload
CodeSmith.BaseTemplates Namespace


SqlCodeTemplate.GetSqlParameterStatement Method (ViewColumnSchema)

SqlCodeTemplateGetSqlParameterStatement Method (ViewColumnSchema)

Returns a T-SQL parameter statement based on the given column.

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string GetSqlParameterStatement(
    ViewColumnSchema column
)
Public Function GetSqlParameterStatement (
    column As ViewColumnSchema
) As String

Parameters

column
Type: SchemaExplorerViewColumnSchema

Return Value

Type: String
See Also

Reference

SqlCodeTemplate Class
GetSqlParameterStatement Overload
CodeSmith.BaseTemplates Namespace


SqlCodeTemplate.GetSqlParameterStatement Method (ColumnSchema, Boolean)

SqlCodeTemplateGetSqlParameterStatement Method (ColumnSchema, Boolean)

Returns a T-SQL parameter statement based on the given column.

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string GetSqlParameterStatement(
    ColumnSchema column,
    bool isOutput
)
Public Function GetSqlParameterStatement (
    column As ColumnSchema,
    isOutput As Boolean
) As String

Parameters

column
Type: SchemaExplorerColumnSchema
isOutput
Type: SystemBoolean

Return Value

Type: String
See Also

Reference

SqlCodeTemplate Class
GetSqlParameterStatement Overload
CodeSmith.BaseTemplates Namespace


SqlCodeTemplate.GetSqlParameterStatement Method (DataObjectBase, Boolean)

SqlCodeTemplateGetSqlParameterStatement Method (DataObjectBase, Boolean)

Returns a T-SQL parameter statement based on the given column.

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected static string GetSqlParameterStatement(
    DataObjectBase column,
    bool isOutput
)
Protected Shared Function GetSqlParameterStatement (
    column As DataObjectBase,
    isOutput As Boolean
) As String

Parameters

column
Type: SchemaExplorerDataObjectBase
isOutput
Type: SystemBoolean

Return Value

Type: String
See Also

Reference

SqlCodeTemplate Class
GetSqlParameterStatement Overload
CodeSmith.BaseTemplates Namespace


SqlCodeTemplate.GetSqlParameterStatement Method (ViewColumnSchema, Boolean)

SqlCodeTemplateGetSqlParameterStatement Method (ViewColumnSchema, Boolean)

Returns a T-SQL parameter statement based on the given column.

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string GetSqlParameterStatement(
    ViewColumnSchema column,
    bool isOutput
)
Public Function GetSqlParameterStatement (
    column As ViewColumnSchema,
    isOutput As Boolean
) As String

Parameters

column
Type: SchemaExplorerViewColumnSchema
isOutput
Type: SystemBoolean

Return Value

Type: String
See Also

Reference

SqlCodeTemplate Class
GetSqlParameterStatement Overload
CodeSmith.BaseTemplates Namespace


SqlCodeTemplate.GetSqlParameterStatements Method

SqlCodeTemplateGetSqlParameterStatements Method

Overload List
 | Name | Description
Public method | GetSqlParameterStatements(String, ColumnSchema) | Generates an assignment statement that adds a parameter to a ADO object for the given column.
Public method | GetSqlParameterStatements(String, ColumnSchema, String) | Generates an assignment statement that adds a parameter to a ADO object for the given column.
Top
See Also

Reference

SqlCodeTemplate Class
CodeSmith.BaseTemplates Namespace


SqlCodeTemplate.GetSqlParameterStatements Method (String, ColumnSchema)

SqlCodeTemplateGetSqlParameterStatements Method (String, ColumnSchema)

Generates an assignment statement that adds a parameter to a ADO object for the given column.

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string GetSqlParameterStatements(
    string statementPrefix,
    ColumnSchema column
)
Public Function GetSqlParameterStatements (
    statementPrefix As String,
    column As ColumnSchema
) As String

Parameters

statementPrefix
Type: SystemString
column
Type: SchemaExplorerColumnSchema

Return Value

Type: String
See Also

Reference

SqlCodeTemplate Class
GetSqlParameterStatements Overload
CodeSmith.BaseTemplates Namespace


SqlCodeTemplate.GetSqlParameterStatements Method (String, ColumnSchema, String)

SqlCodeTemplateGetSqlParameterStatements Method (String, ColumnSchema, String)

Generates an assignment statement that adds a parameter to a ADO object for the given column.

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual string GetSqlParameterStatements(
    string statementPrefix,
    ColumnSchema column,
    string sqlObjectName
)
Public Overridable Function GetSqlParameterStatements (
    statementPrefix As String,
    column As ColumnSchema,
    sqlObjectName As String
) As String

Parameters

statementPrefix
Type: SystemString
column
Type: SchemaExplorerColumnSchema
sqlObjectName
Type: SystemString

Return Value

Type: String
See Also

Reference

SqlCodeTemplate Class
GetSqlParameterStatements Overload
CodeSmith.BaseTemplates Namespace


SqlCodeTemplate.GetSqlReaderAssignmentStatement Method

SqlCodeTemplateGetSqlReaderAssignmentStatement Method

Returns a typed C# reader.ReadXXX() statement.

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual string GetSqlReaderAssignmentStatement(
    ColumnSchema column,
    int index
)
Public Overridable Function GetSqlReaderAssignmentStatement (
    column As ColumnSchema,
    index As Integer
) As String

Parameters

column
Type: SchemaExplorerColumnSchema
index
Type: SystemInt32

Return Value

Type: String
See Also

Reference

SqlCodeTemplate Class
CodeSmith.BaseTemplates Namespace


SqlCodeTemplate.GetValidateStatements Method

SqlCodeTemplateGetValidateStatements Method

Generates a batch of C# validation statements based on the column.

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual string GetValidateStatements(
    TableSchema table,
    string statementPrefix
)
Public Overridable Function GetValidateStatements (
    table As TableSchema,
    statementPrefix As String
) As String

Parameters

table
Type: SchemaExplorerTableSchema
statementPrefix
Type: SystemString

Return Value

Type: String
See Also

Reference

SqlCodeTemplate Class
CodeSmith.BaseTemplates Namespace


SqlCodeTemplate.IncludeEmptyCheck Method

SqlCodeTemplateIncludeEmptyCheck Method

Determines if a given column should use a check for an Empty value.

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool IncludeEmptyCheck(
    ColumnSchema column
)
Public Function IncludeEmptyCheck (
    column As ColumnSchema
) As Boolean

Parameters

column
Type: SchemaExplorerColumnSchema

Return Value

Type: Boolean
See Also

Reference

SqlCodeTemplate Class
CodeSmith.BaseTemplates Namespace


SqlCodeTemplate.IncludeMaxLengthCheck Method

SqlCodeTemplateIncludeMaxLengthCheck Method

Overload List
 | Name | Description
Public method | IncludeMaxLengthCheck(ColumnSchema) | Determines if the given column's data type requires a max length to be defined.
Public method | IncludeMaxLengthCheck(ViewColumnSchema) | Determines if the given column's data type requires a max length to be defined.
Top
See Also

Reference

SqlCodeTemplate Class
CodeSmith.BaseTemplates Namespace


SqlCodeTemplate.IncludeMaxLengthCheck Method (ColumnSchema)

SqlCodeTemplateIncludeMaxLengthCheck Method (ColumnSchema)

Determines if the given column's data type requires a max length to be defined.

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool IncludeMaxLengthCheck(
    ColumnSchema column
)
Public Function IncludeMaxLengthCheck (
    column As ColumnSchema
) As Boolean

Parameters

column
Type: SchemaExplorerColumnSchema

Return Value

Type: Boolean
See Also

Reference

SqlCodeTemplate Class
IncludeMaxLengthCheck Overload
CodeSmith.BaseTemplates Namespace


SqlCodeTemplate.IncludeMaxLengthCheck Method (ViewColumnSchema)

SqlCodeTemplateIncludeMaxLengthCheck Method (ViewColumnSchema)

Determines if the given column's data type requires a max length to be defined.

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool IncludeMaxLengthCheck(
    ViewColumnSchema column
)
Public Function IncludeMaxLengthCheck (
    column As ViewColumnSchema
) As Boolean

Parameters

column
Type: SchemaExplorerViewColumnSchema

Return Value

Type: Boolean
See Also

Reference

SqlCodeTemplate Class
IncludeMaxLengthCheck Overload
CodeSmith.BaseTemplates Namespace


SqlCodeTemplate.IsUserDefinedType Method

SqlCodeTemplateIsUserDefinedType Method

Overload List
 | Name | Description
Public method | IsUserDefinedType(ColumnSchema) | Determine if the given column is using a UDT.
 | IsUserDefinedType(DataObjectBase) | Determine if the given column is using a UDT.
Public method | IsUserDefinedType(ViewColumnSchema) | Determine if the given column is using a UDT.
Top
See Also

Reference

SqlCodeTemplate Class
CodeSmith.BaseTemplates Namespace


SqlCodeTemplate.IsUserDefinedType Method (ColumnSchema)

SqlCodeTemplateIsUserDefinedType Method (ColumnSchema)

Determine if the given column is using a UDT.

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool IsUserDefinedType(
    ColumnSchema column
)
Public Function IsUserDefinedType (
    column As ColumnSchema
) As Boolean

Parameters

column
Type: SchemaExplorerColumnSchema

Return Value

Type: Boolean
See Also

Reference

SqlCodeTemplate Class
IsUserDefinedType Overload
CodeSmith.BaseTemplates Namespace


SqlCodeTemplate.IsUserDefinedType Method (DataObjectBase)

SqlCodeTemplateIsUserDefinedType Method (DataObjectBase)

Determine if the given column is using a UDT.

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected static bool IsUserDefinedType(
    DataObjectBase column
)
Protected Shared Function IsUserDefinedType (
    column As DataObjectBase
) As Boolean

Parameters

column
Type: SchemaExplorerDataObjectBase

Return Value

Type: Boolean
See Also

Reference

SqlCodeTemplate Class
IsUserDefinedType Overload
CodeSmith.BaseTemplates Namespace


SqlCodeTemplate.IsUserDefinedType Method (ViewColumnSchema)

SqlCodeTemplateIsUserDefinedType Method (ViewColumnSchema)

Determine if the given column is using a UDT.

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool IsUserDefinedType(
    ViewColumnSchema column
)
Public Function IsUserDefinedType (
    column As ViewColumnSchema
) As Boolean

Parameters

column
Type: SchemaExplorerViewColumnSchema

Return Value

Type: Boolean
See Also

Reference

SqlCodeTemplate Class
IsUserDefinedType Overload
CodeSmith.BaseTemplates Namespace


SqlCodeTemplate Events

The SqlCodeTemplate type exposes the following members.

Events
 | Name | Description
Public event | OutputRegistered | Raised when an output file is registered (Inherited from CodeTemplate.)
Public event | PreOutputWritten | Raised prior to an output being written to disk (Inherited from CodeTemplate.)
Public event | PropertiesLoaded | (Inherited from CodeTemplate.)
Public event | PropertiesSaved | (Inherited from CodeTemplate.)
Public event | PropertyChanged | (Inherited from CodeTemplate.)
Public event | ReferenceRegistered | Occurs when a reference is registered. (Inherited from CodeTemplate.)
Top
See Also

Reference

SqlCodeTemplate Class
CodeSmith.BaseTemplates Namespace


SqlCodeTemplate Fields

The SqlCodeTemplate type exposes the following members.

Fields
 | Name | Description
Protected field | _childControlsCreated | (Inherited from Control.)
Protected field | _codeTemplate | (Inherited from Control.)
Protected field | _controls | (Inherited from Control.)
Protected field | _outputFile | (Inherited from OutputFileCodeTemplate.)
Protected field | _parent | (Inherited from Control.)
Protected field | _visible | (Inherited from Control.)
Top
See Also

Reference

SqlCodeTemplate Class
CodeSmith.BaseTemplates Namespace


StringUtility Class

Note: This API is now obsolete.

Various string utility methods.
Inheritance Hierarchy
SystemObject
CodeSmith.BaseTemplatesStringUtility

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[ObsoleteAttribute("This method has been deprecated. Please use StringUtil instead.")]
public class StringUtility
<ObsoleteAttribute("This method has been deprecated. Please use StringUtil instead.")>
Public Class StringUtility

The StringUtility type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsPlural | Obsolete. Determines if a string is in plural form based on some simple rules.
 | IsSingular | Obsolete. Determines if a string is in singular form based on some simple rules.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToCamelCase | Obsolete. Converts a string to use camelCase.
 | ToPascalCase | Obsolete. Converts a string to use PascalCase.
 | ToPlural | Obsolete. Converts a string to plural based on some simple rules.
 | ToSingular | Obsolete. Converts a string to singular based on some simple rules.
 | ToSpacedWords | Obsolete. Takes a NameIdentifier and spaces it out into words "Name Identifier".
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSmith.BaseTemplates Namespace


StringUtility Methods

The StringUtility type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsPlural | Obsolete. Determines if a string is in plural form based on some simple rules.
 | IsSingular | Obsolete. Determines if a string is in singular form based on some simple rules.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToCamelCase | Obsolete. Converts a string to use camelCase.
 | ToPascalCase | Obsolete. Converts a string to use PascalCase.
 | ToPlural | Obsolete. Converts a string to plural based on some simple rules.
 | ToSingular | Obsolete. Converts a string to singular based on some simple rules.
 | ToSpacedWords | Obsolete. Takes a NameIdentifier and spaces it out into words "Name Identifier".
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

StringUtility Class
CodeSmith.BaseTemplates Namespace


StringUtility.IsPlural Method

StringUtilityIsPlural Method

Note: This API is now obsolete.

Determines if a string is in plural form based on some simple rules.

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[ObsoleteAttribute("This method has been deprecated. Please use StringUtil.IsPlural() instead.")]
public static bool IsPlural(
    string value
)
<ObsoleteAttribute("This method has been deprecated. Please use StringUtil.IsPlural() instead.")>
Public Shared Function IsPlural (
    value As String
) As Boolean

Parameters

value
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

StringUtility Class
CodeSmith.BaseTemplates Namespace


StringUtility.IsSingular Method

StringUtilityIsSingular Method

Note: This API is now obsolete.

Determines if a string is in singular form based on some simple rules.

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[ObsoleteAttribute("This method has been deprecated. Please use StringUtil.IsSingular() instead.")]
public static bool IsSingular(
    string value
)
<ObsoleteAttribute("This method has been deprecated. Please use StringUtil.IsSingular() instead.")>
Public Shared Function IsSingular (
    value As String
) As Boolean

Parameters

value
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

StringUtility Class
CodeSmith.BaseTemplates Namespace


StringUtility.ToCamelCase Method

StringUtilityToCamelCase Method

Note: This API is now obsolete.

Converts a string to use camelCase.

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[ObsoleteAttribute("This method has been deprecated. Please use StringUtil.ToCamelCase() instead.")]
public static string ToCamelCase(
    string value
)
<ObsoleteAttribute("This method has been deprecated. Please use StringUtil.ToCamelCase() instead.")>
Public Shared Function ToCamelCase (
    value As String
) As String

Parameters

value
Type: SystemString

Return Value

Type: String
See Also

Reference

StringUtility Class
CodeSmith.BaseTemplates Namespace


StringUtility.ToPascalCase Method

StringUtilityToPascalCase Method

Note: This API is now obsolete.

Converts a string to use PascalCase.

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[ObsoleteAttribute("This method has been deprecated. Please use StringUtil.ToPascalCase() instead.")]
public static string ToPascalCase(
    string value
)
<ObsoleteAttribute("This method has been deprecated. Please use StringUtil.ToPascalCase() instead.")>
Public Shared Function ToPascalCase (
    value As String
) As String

Parameters

value
Type: SystemString
Text to convert

Return Value

Type: String
See Also

Reference

StringUtility Class
CodeSmith.BaseTemplates Namespace


StringUtility.ToPlural Method

StringUtilityToPlural Method

Note: This API is now obsolete.

Converts a string to plural based on some simple rules.

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[ObsoleteAttribute("This method has been deprecated. Please use StringUtil.ToPlural() instead.")]
public static string ToPlural(
    string value
)
<ObsoleteAttribute("This method has been deprecated. Please use StringUtil.ToPlural() instead.")>
Public Shared Function ToPlural (
    value As String
) As String

Parameters

value
Type: SystemString

Return Value

Type: String
See Also

Reference

StringUtility Class
CodeSmith.BaseTemplates Namespace


StringUtility.ToSingular Method

StringUtilityToSingular Method

Note: This API is now obsolete.

Converts a string to singular based on some simple rules.

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[ObsoleteAttribute("This method has been deprecated. Please use StringUtil.ToSingular() instead.")]
public static string ToSingular(
    string value
)
<ObsoleteAttribute("This method has been deprecated. Please use StringUtil.ToSingular() instead.")>
Public Shared Function ToSingular (
    value As String
) As String

Parameters

value
Type: SystemString

Return Value

Type: String
See Also

Reference

StringUtility Class
CodeSmith.BaseTemplates Namespace


StringUtility.ToSpacedWords Method

StringUtilityToSpacedWords Method

Note: This API is now obsolete.

Takes a NameIdentifier and spaces it out into words "Name Identifier".

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[ObsoleteAttribute("This method has been deprecated. Please use StringUtil.ToSpacedWords() instead.")]
public static string ToSpacedWords(
    string value
)
<ObsoleteAttribute("This method has been deprecated. Please use StringUtil.ToSpacedWords() instead.")>
Public Shared Function ToSpacedWords (
    value As String
) As String

Parameters

value
Type: SystemString

Return Value

Type: String
See Also

Reference

StringUtility Class
CodeSmith.BaseTemplates Namespace


VBSqlCodeTemplate Class

Inheritance Hierarchy
SystemObject
CodeSmith.EngineControl
CodeSmith.EngineCodeTemplate
CodeSmith.BaseTemplatesOutputFileCodeTemplate
CodeSmith.BaseTemplatesSqlCodeTemplate
CodeSmith.BaseTemplatesVBSqlCodeTemplate

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class VBSqlCodeTemplate : SqlCodeTemplate
Public Class VBSqlCodeTemplate
    Inherits SqlCodeTemplate

The VBSqlCodeTemplate type exposes the following members.

Constructors
 | Name | Description
Public method | VBSqlCodeTemplate | Initializes a new instance of the VBSqlCodeTemplate class
Top
Properties
 | Name | Description
Protected property | ChildControlsCreated | (Inherited from Control.)
Protected property | CodeTemplate | (Inherited from Control.)
Public property | CodeTemplateInfo | Gets the information for the current template. (Inherited from CodeTemplate.)
Public property | ContextData | Contextual data items can be stored in this object and shared with sub-templates. This data will not be persisted with the template property set. (Inherited from CodeTemplate.)
Protected property | Controls | (Inherited from Control.)
Public property | DbTypeToCSharp | (Inherited from SqlCodeTemplate.)
Public property | DbTypeToDataReaderMethod | (Inherited from SqlCodeTemplate.)
Public property | DbTypeToVB |
Public property | OutputFile | This property is used to specify an output file name that the template output will be saved to. (Inherited from OutputFileCodeTemplate.)
Protected property | Parent | (Inherited from Control.)
Public property | Progress | Provides a way to report execution progress for the template. (Inherited from CodeTemplate.)
Public property | RegisteredOutputs | (Inherited from CodeTemplate.)
Public property | RegisteredReferences | (Inherited from CodeTemplate.)
Public property | Response | Response stream for the template output. You can write to the stream programmatically using this property. (Inherited from CodeTemplate.)
Public property | State | State of this template instance. (Inherited from CodeTemplate.)
Public property | ValidationErrors | Gets the validation errors for this template. (Inherited from CodeTemplate.)
Protected property | Visible | (Inherited from CodeTemplate.)
Top
Methods
 | Name | Description
Protected method | ControlAdded | (Inherited from Control.)
Protected method | ControlRemoved | (Inherited from Control.)
Public method | CopyPropertiesTo(CodeTemplate) | Copies any matching properties to another CodeTemplate instance. (Inherited from CodeTemplate.)
Public method | CopyPropertiesTo(CodeTemplate, Boolean) | Copies any matching properties to another CodeTemplate instance. (Inherited from CodeTemplate.)
Public method | CopyPropertiesTo(CodeTemplate, ICollectionString) | Copies any matching properties to another CodeTemplate instance. (Inherited from CodeTemplate.)
Public method | CopyPropertiesTo(CodeTemplate, Boolean, ICollectionString) | Copies any matching properties to another CodeTemplate instance. (Inherited from CodeTemplate.)
Public method | CreateT | Gets an instance of the specified template type. Should be used with the Register directive. (Inherited from CodeTemplate.)
Public method | CreateT(Boolean) | Gets an instance of the specified template type. Should be used with the Register directive. (Inherited from CodeTemplate.)
Protected method | CreateChildControls | (Inherited from Control.)
Protected method | CreateControlCollection | (Inherited from Control.)
Public method | Dispose | (Inherited from CodeTemplate.)
Protected method | Dispose(Boolean) | (Inherited from CodeTemplate.)
Protected method | EnsureChildControls | (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | (Inherited from CodeTemplate.)
Public method | GetCamelCaseName | Returns a camel cased name from the given identifier. (Inherited from SqlCodeTemplate.)
Public method | GetCodeTemplateInstance(String) | Gets an instance of the specified template. (Inherited from CodeTemplate.)
Public method | GetCodeTemplateInstance(String, Boolean) | Gets an instance of the specified template. (Inherited from CodeTemplate.)
Public method | GetCodeTemplateInstance(String, Boolean, Boolean) | Gets an instance of the specified template. (Inherited from CodeTemplate.)
Public method | GetCSharpVariableType(ColumnSchema) | Returns the C# variable type based on the given column. (Inherited from SqlCodeTemplate.)
Public method | GetCSharpVariableType(CommandResultColumnSchema) | Returns the C# variable type based on the given column. (Inherited from SqlCodeTemplate.)
Public method | GetCSharpVariableType(DbType) | Returns the C# variable type based on the given dataType. (Inherited from SqlCodeTemplate.)
Public method | GetCSharpVariableType(ParameterSchema) | Returns the C# variable type based on the given parameter. (Inherited from SqlCodeTemplate.)
Public method | GetCSharpVariableType(ViewColumnSchema) | Returns the C# variable type based on the given column. (Inherited from SqlCodeTemplate.)
Public method | GetCustomValidationErrors | Allows the developer to add custom ValidationErrors to the validation collection. (Inherited from CodeTemplate.)
Public method | GetFileName | Gets a default name for the template output. This can be overridden in your template to provide a suitable name for the output of the template based on the property values. (Inherited from CodeTemplate.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetMemberVariableDeclarationStatement(ColumnSchema) | Returns a VB.Net member variable declaration statement. (Overrides SqlCodeTemplateGetMemberVariableDeclarationStatement(ColumnSchema).)
Public method | GetMemberVariableDeclarationStatement(ViewColumnSchema) | Returns a VB.Net member variable declaration statement. (Overrides SqlCodeTemplateGetMemberVariableDeclarationStatement(ViewColumnSchema).)
Public method | GetMemberVariableDeclarationStatement(String, ColumnSchema) | Returns a C# member variable declaration statement. (Inherited from SqlCodeTemplate.)
Public method | GetMemberVariableDeclarationStatement(String, ViewColumnSchema) | Returns a C# member variable declaration statement. (Inherited from SqlCodeTemplate.)
Protected method | GetMemberVariableDeclarationStatement(String, DataObjectBase) | Returns a VB.Net member variable declaration statement. (Overrides SqlCodeTemplateGetMemberVariableDeclarationStatement(String, DataObjectBase).)
Public method | GetMemberVariableDefaultValue(ColumnSchema) | (Inherited from SqlCodeTemplate.)
Public method | GetMemberVariableDefaultValue(ViewColumnSchema) | (Inherited from SqlCodeTemplate.)
Public method | GetMemberVariableName | Returns the C# member variable name for a given identifier. (Inherited from SqlCodeTemplate.)
Public method | GetProperties | Gets information on all of the properties on this template. (Inherited from CodeTemplate.)
Public method | GetProperties(Boolean) | Gets information on all of the properties on this template. (Inherited from CodeTemplate.)
Public method | GetProperty | Gets the value for the specified property. (Inherited from CodeTemplate.)
Public method | GetPropertyAttribute | Gets the property attribute. Property attributes can be used to store various information at the property level. (Inherited from CodeTemplate.)
Public method | GetPropertyDescription | (Inherited from CodeTemplate.)
Public method | GetPropertyInfo | (Inherited from CodeTemplate.)
Public method | GetPropertyName | Returns the name of the public property for a given column. (Inherited from SqlCodeTemplate.)
Public method | GetReaderMethod(ColumnSchema) | Returns the name of the typed reader method for a given column. (Inherited from SqlCodeTemplate.)
Public method | GetReaderMethod(DbType) | Returns the name of the typed reader method for a given column. (Inherited from SqlCodeTemplate.)
Public method | GetReaderMethod(ViewColumnSchema) | Returns the name of the typed reader method for a given column. (Inherited from SqlCodeTemplate.)
Public method | GetRequiredProperties | Gets information on all of the required properties for this template. (Inherited from CodeTemplate.)
Public method | GetSpacedName | Returns a spaced out version of the identifier. (Inherited from SqlCodeTemplate.)
Public method | GetSqlDbType(ColumnSchema) | (Inherited from SqlCodeTemplate.)
Public method | GetSqlDbType(String) | Returns the SqlDbType based on a string. (Inherited from SqlCodeTemplate.)
Public method | GetSqlDbType(ViewColumnSchema) | (Inherited from SqlCodeTemplate.)
Public method | GetSqlParameterExtraParams(String, ColumnSchema) | Generates any extra parameters that are needed for the ADO parameter statement. (Inherited from SqlCodeTemplate.)
Public method | GetSqlParameterExtraParams(String, ViewColumnSchema) | Generates any extra parameters that are needed for the ADO parameter statement. (Inherited from SqlCodeTemplate.)
Protected method | GetSqlParameterExtraParams(String, DataObjectBase) | Generates any extra parameters that are needed for the ADO parameter statement. (Overrides SqlCodeTemplateGetSqlParameterExtraParams(String, DataObjectBase).)
Public method | GetSqlParameterStatement(ColumnSchema) | Returns a T-SQL parameter statement based on the given column. (Inherited from SqlCodeTemplate.)
Public method | GetSqlParameterStatement(ViewColumnSchema) | Returns a T-SQL parameter statement based on the given column. (Inherited from SqlCodeTemplate.)
Public method | GetSqlParameterStatement(ColumnSchema, Boolean) | Returns a T-SQL parameter statement based on the given column. (Inherited from SqlCodeTemplate.)
Public method | GetSqlParameterStatement(ViewColumnSchema, Boolean) | Returns a T-SQL parameter statement based on the given column. (Inherited from SqlCodeTemplate.)
Public method | GetSqlParameterStatements(String, ColumnSchema) | Generates an assignment statement that adds a parameter to a ADO object for the given column. (Inherited from SqlCodeTemplate.)
Public method | GetSqlParameterStatements(String, ColumnSchema, String) | Generates an assignment statement that adds a parameter to a ADO object for the given column. (Overrides SqlCodeTemplateGetSqlParameterStatements(String, ColumnSchema, String).)
Public method | GetSqlReaderAssignmentStatement | Returns a typed VB.Net reader.ReadXXX() statement. (Overrides SqlCodeTemplateGetSqlReaderAssignmentStatement(ColumnSchema, Int32).)
Public method | GetTemplateAttribute | Gets the template attribute. Template attributes can be used to store various information at the template level. (Inherited from CodeTemplate.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidateStatements | Generates a batch of C# validation statements based on the column. (Overrides SqlCodeTemplateGetValidateStatements(TableSchema, String).)
Public method | GetVBVariableType(ColumnSchema) | Returns the C# variable type based on the given column.
Public method | GetVBVariableType(CommandResultColumnSchema) | Returns the C# variable type based on the given column.
Public method | GetVBVariableType(DbType) | Returns the C# variable type based on the given dataType.
Public method | GetVBVariableType(ParameterSchema) | Returns the C# variable type based on the given parameter.
Public method | GetVBVariableType(ViewColumnSchema) | Returns the C# variable type based on the given column.
Protected method | HasControls | (Inherited from Control.)
Public method | IncludeEmptyCheck | Determines if a given column should use a check for an Empty value. (Inherited from SqlCodeTemplate.)
Public method | IncludeMaxLengthCheck(ColumnSchema) | Determines if the given column's data type requires a max length to be defined. (Inherited from SqlCodeTemplate.)
Public method | IncludeMaxLengthCheck(ViewColumnSchema) | Determines if the given column's data type requires a max length to be defined. (Inherited from SqlCodeTemplate.)
Public method | IsPropertyRequired | (Inherited from CodeTemplate.)
Public method | IsUserDefinedType(ColumnSchema) | Determine if the given column is using a UDT. (Inherited from SqlCodeTemplate.)
Public method | IsUserDefinedType(ViewColumnSchema) | Determine if the given column is using a UDT. (Inherited from SqlCodeTemplate.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnError | This method can be overridden to perform logic when a template exception occurs. (Inherited from CodeTemplate.)
Protected method | OnInit | This method can be overridden to perform logic when the template instance is created. (Inherited from CodeTemplate.)
Protected method | OnOutputRegistered | This is the method that is responsible for notifying receivers that the event occurred (Inherited from CodeTemplate.)
Protected method | OnPostRender | Override the OnPostRender method so that we can take the result and save it to a file if an output file was specified. (Inherited from OutputFileCodeTemplate.)
Protected method | OnPreOutputWritten(OutputCancelEventArgs) | This is the method that is responsible for notifying receivers that the event occurred (Inherited from CodeTemplate.)
Protected method | OnPreOutputWritten(String) | This is the method that is responsible for notifying receivers that the event occurred (Inherited from CodeTemplate.)
Protected method | OnPreRender | This method can be overridden to perform logic before the template is rendered. (Inherited from CodeTemplate.)
Protected method | OnPropertiesLoaded | This method can be overridden to perform logic when properties are loaded. (Inherited from CodeTemplate.)
Protected method | OnPropertiesSaved | This method can be overridden to perform logic when properties are saved. (Inherited from CodeTemplate.)
Protected method | OnPropertyChanged | This method can be overridden to perform logic when a property changes. (Inherited from CodeTemplate.)
Protected method | OnReferenceRegistered | Raises the ItemRegisteredEventArgs event. (Inherited from CodeTemplate.)
Public method | ParseDefaultValue | Parses the default value for properties. This can be overridden to provide custom default parsing logic. (Inherited from CodeTemplate.)
Public method | RefreshProperties | (Inherited from CodeTemplate.)
Public method | RefreshProperties(Boolean) | (Inherited from CodeTemplate.)
Public method | RegisterOutput(OutputFile) | (Inherited from CodeTemplate.)
Public method | RegisterOutput(String) | (Inherited from CodeTemplate.)
Public method | RegisterReference | Registers the reference. When generating from within Visual Studio, these references will be added to the project. (Inherited from CodeTemplate.)
Public method | Render | Renders to the template output to the specified writer. (Inherited from CodeTemplate.)
Protected method | RenderChildren | (Inherited from Control.)
Public method | RenderToFile(OutputFile, Boolean) | Renders the template output to a file. (Inherited from CodeTemplate.)
Public method | RenderToFile(String, IMergeStrategy) | Renders the template output to a file using a merge strategy. (Inherited from CodeTemplate.)
Public method | RenderToFile(String, Boolean) | Renders the template output to a file. (Inherited from CodeTemplate.)
Public method | RenderToFile(OutputFile, String, IMergeStrategy) | Renders the template output to a file using a merge strategy. (Inherited from CodeTemplate.)
Public method | RenderToFile(String, String, IMergeStrategy) | Renders the template output to a file using a merge strategy. (Inherited from CodeTemplate.)
Public method | RenderToFile(String, String, Boolean) | Renders the template output to a file. (Inherited from CodeTemplate.)
Public method | RenderToString | Renders the template output to a String. (Inherited from CodeTemplate.)
Public method | RenderToString(String, IMergeStrategy) | Renders the template output to a String. (Inherited from CodeTemplate.)
Public method | RestorePropertiesFromHashtable | Restores the properties from a Hashtable. (Inherited from CodeTemplate.)
Public method | RestorePropertiesFromPropertySet(PropertySet, String) | (Inherited from CodeTemplate.)
Public method | RestorePropertiesFromPropertySet(PropertySet, String, Hashtable) | (Inherited from CodeTemplate.)
Public method | RestorePropertiesFromSchema | (Inherited from CodeTemplate.)
Public method | RestorePropertiesFromXml | Restores the properties from XML. (Inherited from CodeTemplate.)
Public method | RestorePropertiesFromXmlFile | Restores the properties from XML file. (Inherited from CodeTemplate.)
Public method | SavePropertiesToHashtable | Saves the properties to a Hashtable. (Inherited from CodeTemplate.)
Public method | SavePropertiesToHashtable(Boolean) | Saves the properties to a Hashtable. (Inherited from CodeTemplate.)
Public method | SavePropertiesToPropertySet | (Inherited from CodeTemplate.)
Public method | SavePropertiesToXml | Saves the properties to XML. (Inherited from CodeTemplate.)
Public method | SavePropertiesToXml(XmlWriter) | Saves the properties to XML. (Inherited from CodeTemplate.)
Public method | SavePropertiesToXmlFile | Saves the properties to an XML file. (Inherited from CodeTemplate.)
Protected method | SetContextData | Set the context data object for the template. Any items in the current ContextData object will be added to the new one. This method should only be called while a template is initializing. (Inherited from CodeTemplate.)
Public method | SetProperty(PropertyInfo, Object) | Sets the value for the specified property. (Inherited from CodeTemplate.)
Public method | SetProperty(String, Object) | Sets the value for the specified property. (Inherited from CodeTemplate.)
Public method | SetProperty(XmlNode, String) | (Inherited from CodeTemplate.)
Public method | SetPropertyAttribute | Sets the property attribute. Property attributes can be used to store various information at the property level. (Inherited from CodeTemplate.)
Protected method | SetPropertyDefaults | This method is overridden in templates to set default values in a template instance. (Inherited from CodeTemplate.)
Public method | SetTemplateAttribute | Sets the template attribute. Template attributes can be used to store various information at the template level. (Inherited from CodeTemplate.)
Protected method | SetUnknownDirectiveAttributes | This method is overridden in templates to set unknown directive attributes in the ContextData. (Inherited from CodeTemplate.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates this template instance. (Inherited from CodeTemplate.)
Top
Events
 | Name | Description
Public event | OutputRegistered | Raised when an output file is registered (Inherited from CodeTemplate.)
Public event | PreOutputWritten | Raised prior to an output being written to disk (Inherited from CodeTemplate.)
Public event | PropertiesLoaded | (Inherited from CodeTemplate.)
Public event | PropertiesSaved | (Inherited from CodeTemplate.)
Public event | PropertyChanged | (Inherited from CodeTemplate.)
Public event | ReferenceRegistered | Occurs when a reference is registered. (Inherited from CodeTemplate.)
Top
Fields
 | Name | Description
Protected field | _childControlsCreated | (Inherited from Control.)
Protected field | _codeTemplate | (Inherited from Control.)
Protected field | _controls | (Inherited from Control.)
Protected field | _outputFile | (Inherited from OutputFileCodeTemplate.)
Protected field | _parent | (Inherited from Control.)
Protected field | _visible | (Inherited from Control.)
Top
See Also

Reference

CodeSmith.BaseTemplates Namespace


VBSqlCodeTemplate Constructor

Initializes a new instance of the VBSqlCodeTemplate class

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public VBSqlCodeTemplate()
Public Sub New
See Also

Reference

VBSqlCodeTemplate Class
CodeSmith.BaseTemplates Namespace


VBSqlCodeTemplate Properties

The VBSqlCodeTemplate type exposes the following members.

Properties
 | Name | Description
Protected property | ChildControlsCreated | (Inherited from Control.)
Protected property | CodeTemplate | (Inherited from Control.)
Public property | CodeTemplateInfo | Gets the information for the current template. (Inherited from CodeTemplate.)
Public property | ContextData | Contextual data items can be stored in this object and shared with sub-templates. This data will not be persisted with the template property set. (Inherited from CodeTemplate.)
Protected property | Controls | (Inherited from Control.)
Public property | DbTypeToCSharp | (Inherited from SqlCodeTemplate.)
Public property | DbTypeToDataReaderMethod | (Inherited from SqlCodeTemplate.)
Public property | DbTypeToVB |
Public property | OutputFile | This property is used to specify an output file name that the template output will be saved to. (Inherited from OutputFileCodeTemplate.)
Protected property | Parent | (Inherited from Control.)
Public property | Progress | Provides a way to report execution progress for the template. (Inherited from CodeTemplate.)
Public property | RegisteredOutputs | (Inherited from CodeTemplate.)
Public property | RegisteredReferences | (Inherited from CodeTemplate.)
Public property | Response | Response stream for the template output. You can write to the stream programmatically using this property. (Inherited from CodeTemplate.)
Public property | State | State of this template instance. (Inherited from CodeTemplate.)
Public property | ValidationErrors | Gets the validation errors for this template. (Inherited from CodeTemplate.)
Protected property | Visible | (Inherited from CodeTemplate.)
Top
See Also

Reference

VBSqlCodeTemplate Class
CodeSmith.BaseTemplates Namespace


VBSqlCodeTemplate.DbTypeToVB Property

VBSqlCodeTemplateDbTypeToVB Property

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public MapCollection DbTypeToVB { get; }
Public ReadOnly Property DbTypeToVB As MapCollection
    Get

Property Value

Type: MapCollection
See Also

Reference

VBSqlCodeTemplate Class
CodeSmith.BaseTemplates Namespace


VBSqlCodeTemplate Methods

The VBSqlCodeTemplate type exposes the following members.

Methods
 | Name | Description
Protected method | ControlAdded | (Inherited from Control.)
Protected method | ControlRemoved | (Inherited from Control.)
Public method | CopyPropertiesTo(CodeTemplate) | Copies any matching properties to another CodeTemplate instance. (Inherited from CodeTemplate.)
Public method | CopyPropertiesTo(CodeTemplate, Boolean) | Copies any matching properties to another CodeTemplate instance. (Inherited from CodeTemplate.)
Public method | CopyPropertiesTo(CodeTemplate, ICollectionString) | Copies any matching properties to another CodeTemplate instance. (Inherited from CodeTemplate.)
Public method | CopyPropertiesTo(CodeTemplate, Boolean, ICollectionString) | Copies any matching properties to another CodeTemplate instance. (Inherited from CodeTemplate.)
Public method | CreateT | Gets an instance of the specified template type. Should be used with the Register directive. (Inherited from CodeTemplate.)
Public method | CreateT(Boolean) | Gets an instance of the specified template type. Should be used with the Register directive. (Inherited from CodeTemplate.)
Protected method | CreateChildControls | (Inherited from Control.)
Protected method | CreateControlCollection | (Inherited from Control.)
Public method | Dispose | (Inherited from CodeTemplate.)
Protected method | Dispose(Boolean) | (Inherited from CodeTemplate.)
Protected method | EnsureChildControls | (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | (Inherited from CodeTemplate.)
Public method | GetCamelCaseName | Returns a camel cased name from the given identifier. (Inherited from SqlCodeTemplate.)
Public method | GetCodeTemplateInstance(String) | Gets an instance of the specified template. (Inherited from CodeTemplate.)
Public method | GetCodeTemplateInstance(String, Boolean) | Gets an instance of the specified template. (Inherited from CodeTemplate.)
Public method | GetCodeTemplateInstance(String, Boolean, Boolean) | Gets an instance of the specified template. (Inherited from CodeTemplate.)
Public method | GetCSharpVariableType(ColumnSchema) | Returns the C# variable type based on the given column. (Inherited from SqlCodeTemplate.)
Public method | GetCSharpVariableType(CommandResultColumnSchema) | Returns the C# variable type based on the given column. (Inherited from SqlCodeTemplate.)
Public method | GetCSharpVariableType(DbType) | Returns the C# variable type based on the given dataType. (Inherited from SqlCodeTemplate.)
Public method | GetCSharpVariableType(ParameterSchema) | Returns the C# variable type based on the given parameter. (Inherited from SqlCodeTemplate.)
Public method | GetCSharpVariableType(ViewColumnSchema) | Returns the C# variable type based on the given column. (Inherited from SqlCodeTemplate.)
Public method | GetCustomValidationErrors | Allows the developer to add custom ValidationErrors to the validation collection. (Inherited from CodeTemplate.)
Public method | GetFileName | Gets a default name for the template output. This can be overridden in your template to provide a suitable name for the output of the template based on the property values. (Inherited from CodeTemplate.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetMemberVariableDeclarationStatement(ColumnSchema) | Returns a VB.Net member variable declaration statement. (Overrides SqlCodeTemplateGetMemberVariableDeclarationStatement(ColumnSchema).)
Public method | GetMemberVariableDeclarationStatement(ViewColumnSchema) | Returns a VB.Net member variable declaration statement. (Overrides SqlCodeTemplateGetMemberVariableDeclarationStatement(ViewColumnSchema).)
Public method | GetMemberVariableDeclarationStatement(String, ColumnSchema) | Returns a C# member variable declaration statement. (Inherited from SqlCodeTemplate.)
Public method | GetMemberVariableDeclarationStatement(String, ViewColumnSchema) | Returns a C# member variable declaration statement. (Inherited from SqlCodeTemplate.)
Protected method | GetMemberVariableDeclarationStatement(String, DataObjectBase) | Returns a VB.Net member variable declaration statement. (Overrides SqlCodeTemplateGetMemberVariableDeclarationStatement(String, DataObjectBase).)
Public method | GetMemberVariableDefaultValue(ColumnSchema) | (Inherited from SqlCodeTemplate.)
Public method | GetMemberVariableDefaultValue(ViewColumnSchema) | (Inherited from SqlCodeTemplate.)
Public method | GetMemberVariableName | Returns the C# member variable name for a given identifier. (Inherited from SqlCodeTemplate.)
Public method | GetProperties | Gets information on all of the properties on this template. (Inherited from CodeTemplate.)
Public method | GetProperties(Boolean) | Gets information on all of the properties on this template. (Inherited from CodeTemplate.)
Public method | GetProperty | Gets the value for the specified property. (Inherited from CodeTemplate.)
Public method | GetPropertyAttribute | Gets the property attribute. Property attributes can be used to store various information at the property level. (Inherited from CodeTemplate.)
Public method | GetPropertyDescription | (Inherited from CodeTemplate.)
Public method | GetPropertyInfo | (Inherited from CodeTemplate.)
Public method | GetPropertyName | Returns the name of the public property for a given column. (Inherited from SqlCodeTemplate.)
Public method | GetReaderMethod(ColumnSchema) | Returns the name of the typed reader method for a given column. (Inherited from SqlCodeTemplate.)
Public method | GetReaderMethod(DbType) | Returns the name of the typed reader method for a given column. (Inherited from SqlCodeTemplate.)
Public method | GetReaderMethod(ViewColumnSchema) | Returns the name of the typed reader method for a given column. (Inherited from SqlCodeTemplate.)
Public method | GetRequiredProperties | Gets information on all of the required properties for this template. (Inherited from CodeTemplate.)
Public method | GetSpacedName | Returns a spaced out version of the identifier. (Inherited from SqlCodeTemplate.)
Public method | GetSqlDbType(ColumnSchema) | (Inherited from SqlCodeTemplate.)
Public method | GetSqlDbType(String) | Returns the SqlDbType based on a string. (Inherited from SqlCodeTemplate.)
Public method | GetSqlDbType(ViewColumnSchema) | (Inherited from SqlCodeTemplate.)
Public method | GetSqlParameterExtraParams(String, ColumnSchema) | Generates any extra parameters that are needed for the ADO parameter statement. (Inherited from SqlCodeTemplate.)
Public method | GetSqlParameterExtraParams(String, ViewColumnSchema) | Generates any extra parameters that are needed for the ADO parameter statement. (Inherited from SqlCodeTemplate.)
Protected method | GetSqlParameterExtraParams(String, DataObjectBase) | Generates any extra parameters that are needed for the ADO parameter statement. (Overrides SqlCodeTemplateGetSqlParameterExtraParams(String, DataObjectBase).)
Public method | GetSqlParameterStatement(ColumnSchema) | Returns a T-SQL parameter statement based on the given column. (Inherited from SqlCodeTemplate.)
Public method | GetSqlParameterStatement(ViewColumnSchema) | Returns a T-SQL parameter statement based on the given column. (Inherited from SqlCodeTemplate.)
Public method | GetSqlParameterStatement(ColumnSchema, Boolean) | Returns a T-SQL parameter statement based on the given column. (Inherited from SqlCodeTemplate.)
Public method | GetSqlParameterStatement(ViewColumnSchema, Boolean) | Returns a T-SQL parameter statement based on the given column. (Inherited from SqlCodeTemplate.)
Public method | GetSqlParameterStatements(String, ColumnSchema) | Generates an assignment statement that adds a parameter to a ADO object for the given column. (Inherited from SqlCodeTemplate.)
Public method | GetSqlParameterStatements(String, ColumnSchema, String) | Generates an assignment statement that adds a parameter to a ADO object for the given column. (Overrides SqlCodeTemplateGetSqlParameterStatements(String, ColumnSchema, String).)
Public method | GetSqlReaderAssignmentStatement | Returns a typed VB.Net reader.ReadXXX() statement. (Overrides SqlCodeTemplateGetSqlReaderAssignmentStatement(ColumnSchema, Int32).)
Public method | GetTemplateAttribute | Gets the template attribute. Template attributes can be used to store various information at the template level. (Inherited from CodeTemplate.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidateStatements | Generates a batch of C# validation statements based on the column. (Overrides SqlCodeTemplateGetValidateStatements(TableSchema, String).)
Public method | GetVBVariableType(ColumnSchema) | Returns the C# variable type based on the given column.
Public method | GetVBVariableType(CommandResultColumnSchema) | Returns the C# variable type based on the given column.
Public method | GetVBVariableType(DbType) | Returns the C# variable type based on the given dataType.
Public method | GetVBVariableType(ParameterSchema) | Returns the C# variable type based on the given parameter.
Public method | GetVBVariableType(ViewColumnSchema) | Returns the C# variable type based on the given column.
Protected method | HasControls | (Inherited from Control.)
Public method | IncludeEmptyCheck | Determines if a given column should use a check for an Empty value. (Inherited from SqlCodeTemplate.)
Public method | IncludeMaxLengthCheck(ColumnSchema) | Determines if the given column's data type requires a max length to be defined. (Inherited from SqlCodeTemplate.)
Public method | IncludeMaxLengthCheck(ViewColumnSchema) | Determines if the given column's data type requires a max length to be defined. (Inherited from SqlCodeTemplate.)
Public method | IsPropertyRequired | (Inherited from CodeTemplate.)
Public method | IsUserDefinedType(ColumnSchema) | Determine if the given column is using a UDT. (Inherited from SqlCodeTemplate.)
Public method | IsUserDefinedType(ViewColumnSchema) | Determine if the given column is using a UDT. (Inherited from SqlCodeTemplate.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnError | This method can be overridden to perform logic when a template exception occurs. (Inherited from CodeTemplate.)
Protected method | OnInit | This method can be overridden to perform logic when the template instance is created. (Inherited from CodeTemplate.)
Protected method | OnOutputRegistered | This is the method that is responsible for notifying receivers that the event occurred (Inherited from CodeTemplate.)
Protected method | OnPostRender | Override the OnPostRender method so that we can take the result and save it to a file if an output file was specified. (Inherited from OutputFileCodeTemplate.)
Protected method | OnPreOutputWritten(OutputCancelEventArgs) | This is the method that is responsible for notifying receivers that the event occurred (Inherited from CodeTemplate.)
Protected method | OnPreOutputWritten(String) | This is the method that is responsible for notifying receivers that the event occurred (Inherited from CodeTemplate.)
Protected method | OnPreRender | This method can be overridden to perform logic before the template is rendered. (Inherited from CodeTemplate.)
Protected method | OnPropertiesLoaded | This method can be overridden to perform logic when properties are loaded. (Inherited from CodeTemplate.)
Protected method | OnPropertiesSaved | This method can be overridden to perform logic when properties are saved. (Inherited from CodeTemplate.)
Protected method | OnPropertyChanged | This method can be overridden to perform logic when a property changes. (Inherited from CodeTemplate.)
Protected method | OnReferenceRegistered | Raises the ItemRegisteredEventArgs event. (Inherited from CodeTemplate.)
Public method | ParseDefaultValue | Parses the default value for properties. This can be overridden to provide custom default parsing logic. (Inherited from CodeTemplate.)
Public method | RefreshProperties | (Inherited from CodeTemplate.)
Public method | RefreshProperties(Boolean) | (Inherited from CodeTemplate.)
Public method | RegisterOutput(OutputFile) | (Inherited from CodeTemplate.)
Public method | RegisterOutput(String) | (Inherited from CodeTemplate.)
Public method | RegisterReference | Registers the reference. When generating from within Visual Studio, these references will be added to the project. (Inherited from CodeTemplate.)
Public method | Render | Renders to the template output to the specified writer. (Inherited from CodeTemplate.)
Protected method | RenderChildren | (Inherited from Control.)
Public method | RenderToFile(OutputFile, Boolean) | Renders the template output to a file. (Inherited from CodeTemplate.)
Public method | RenderToFile(String, IMergeStrategy) | Renders the template output to a file using a merge strategy. (Inherited from CodeTemplate.)
Public method | RenderToFile(String, Boolean) | Renders the template output to a file. (Inherited from CodeTemplate.)
Public method | RenderToFile(OutputFile, String, IMergeStrategy) | Renders the template output to a file using a merge strategy. (Inherited from CodeTemplate.)
Public method | RenderToFile(String, String, IMergeStrategy) | Renders the template output to a file using a merge strategy. (Inherited from CodeTemplate.)
Public method | RenderToFile(String, String, Boolean) | Renders the template output to a file. (Inherited from CodeTemplate.)
Public method | RenderToString | Renders the template output to a String. (Inherited from CodeTemplate.)
Public method | RenderToString(String, IMergeStrategy) | Renders the template output to a String. (Inherited from CodeTemplate.)
Public method | RestorePropertiesFromHashtable | Restores the properties from a Hashtable. (Inherited from CodeTemplate.)
Public method | RestorePropertiesFromPropertySet(PropertySet, String) | (Inherited from CodeTemplate.)
Public method | RestorePropertiesFromPropertySet(PropertySet, String, Hashtable) | (Inherited from CodeTemplate.)
Public method | RestorePropertiesFromSchema | (Inherited from CodeTemplate.)
Public method | RestorePropertiesFromXml | Restores the properties from XML. (Inherited from CodeTemplate.)
Public method | RestorePropertiesFromXmlFile | Restores the properties from XML file. (Inherited from CodeTemplate.)
Public method | SavePropertiesToHashtable | Saves the properties to a Hashtable. (Inherited from CodeTemplate.)
Public method | SavePropertiesToHashtable(Boolean) | Saves the properties to a Hashtable. (Inherited from CodeTemplate.)
Public method | SavePropertiesToPropertySet | (Inherited from CodeTemplate.)
Public method | SavePropertiesToXml | Saves the properties to XML. (Inherited from CodeTemplate.)
Public method | SavePropertiesToXml(XmlWriter) | Saves the properties to XML. (Inherited from CodeTemplate.)
Public method | SavePropertiesToXmlFile | Saves the properties to an XML file. (Inherited from CodeTemplate.)
Protected method | SetContextData | Set the context data object for the template. Any items in the current ContextData object will be added to the new one. This method should only be called while a template is initializing. (Inherited from CodeTemplate.)
Public method | SetProperty(PropertyInfo, Object) | Sets the value for the specified property. (Inherited from CodeTemplate.)
Public method | SetProperty(String, Object) | Sets the value for the specified property. (Inherited from CodeTemplate.)
Public method | SetProperty(XmlNode, String) | (Inherited from CodeTemplate.)
Public method | SetPropertyAttribute | Sets the property attribute. Property attributes can be used to store various information at the property level. (Inherited from CodeTemplate.)
Protected method | SetPropertyDefaults | This method is overridden in templates to set default values in a template instance. (Inherited from CodeTemplate.)
Public method | SetTemplateAttribute | Sets the template attribute. Template attributes can be used to store various information at the template level. (Inherited from CodeTemplate.)
Protected method | SetUnknownDirectiveAttributes | This method is overridden in templates to set unknown directive attributes in the ContextData. (Inherited from CodeTemplate.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates this template instance. (Inherited from CodeTemplate.)
Top
See Also

Reference

VBSqlCodeTemplate Class
CodeSmith.BaseTemplates Namespace


VBSqlCodeTemplate.GetMemberVariableDeclarationStatement Method

VBSqlCodeTemplateGetMemberVariableDeclarationStatement Method

Overload List
 | Name | Description
Public method | GetMemberVariableDeclarationStatement(ColumnSchema) | Returns a VB.Net member variable declaration statement. (Overrides SqlCodeTemplateGetMemberVariableDeclarationStatement(ColumnSchema).)
Public method | GetMemberVariableDeclarationStatement(ViewColumnSchema) | Returns a VB.Net member variable declaration statement. (Overrides SqlCodeTemplateGetMemberVariableDeclarationStatement(ViewColumnSchema).)
Public method | GetMemberVariableDeclarationStatement(String, ColumnSchema) | Returns a C# member variable declaration statement. (Inherited from SqlCodeTemplate.)
Public method | GetMemberVariableDeclarationStatement(String, ViewColumnSchema) | Returns a C# member variable declaration statement. (Inherited from SqlCodeTemplate.)
Protected method | GetMemberVariableDeclarationStatement(String, DataObjectBase) | Returns a VB.Net member variable declaration statement. (Overrides SqlCodeTemplateGetMemberVariableDeclarationStatement(String, DataObjectBase).)
Top
See Also

Reference

VBSqlCodeTemplate Class
CodeSmith.BaseTemplates Namespace


VBSqlCodeTemplate.GetMemberVariableDeclarationStatement Method (ColumnSchema)

VBSqlCodeTemplateGetMemberVariableDeclarationStatement Method (ColumnSchema)

Returns a VB.Net member variable declaration statement.

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override string GetMemberVariableDeclarationStatement(
    ColumnSchema column
)
Public Overrides Function GetMemberVariableDeclarationStatement (
    column As ColumnSchema
) As String

Parameters

column
Type: SchemaExplorerColumnSchema

Return Value

Type: String
See Also

Reference

VBSqlCodeTemplate Class
GetMemberVariableDeclarationStatement Overload
CodeSmith.BaseTemplates Namespace


VBSqlCodeTemplate.GetMemberVariableDeclarationStatement Method (ViewColumnSchema)

VBSqlCodeTemplateGetMemberVariableDeclarationStatement Method (ViewColumnSchema)

Returns a VB.Net member variable declaration statement.

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override string GetMemberVariableDeclarationStatement(
    ViewColumnSchema column
)
Public Overrides Function GetMemberVariableDeclarationStatement (
    column As ViewColumnSchema
) As String

Parameters

column
Type: SchemaExplorerViewColumnSchema

Return Value

Type: String
See Also

Reference

VBSqlCodeTemplate Class
GetMemberVariableDeclarationStatement Overload
CodeSmith.BaseTemplates Namespace


VBSqlCodeTemplate.GetMemberVariableDeclarationStatement Method (String, DataObjectBase)

VBSqlCodeTemplateGetMemberVariableDeclarationStatement Method (String, DataObjectBase)

Returns a VB.Net member variable declaration statement.

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected override string GetMemberVariableDeclarationStatement(
    string protectionLevel,
    DataObjectBase column
)
Protected Overrides Function GetMemberVariableDeclarationStatement (
    protectionLevel As String,
    column As DataObjectBase
) As String

Parameters

protectionLevel
Type: SystemString
column
Type: SchemaExplorerDataObjectBase

Return Value

Type: String
See Also

Reference

VBSqlCodeTemplate Class
GetMemberVariableDeclarationStatement Overload
CodeSmith.BaseTemplates Namespace


VBSqlCodeTemplate.GetSqlParameterExtraParams Method

VBSqlCodeTemplateGetSqlParameterExtraParams Method

Overload List
 | Name | Description
Public method | GetSqlParameterExtraParams(String, ColumnSchema) | Generates any extra parameters that are needed for the ADO parameter statement. (Inherited from SqlCodeTemplate.)
Public method | GetSqlParameterExtraParams(String, ViewColumnSchema) | Generates any extra parameters that are needed for the ADO parameter statement. (Inherited from SqlCodeTemplate.)
Protected method | GetSqlParameterExtraParams(String, DataObjectBase) | Generates any extra parameters that are needed for the ADO parameter statement. (Overrides SqlCodeTemplateGetSqlParameterExtraParams(String, DataObjectBase).)
Top
See Also

Reference

VBSqlCodeTemplate Class
CodeSmith.BaseTemplates Namespace


VBSqlCodeTemplate.GetSqlParameterExtraParams Method (String, DataObjectBase)

VBSqlCodeTemplateGetSqlParameterExtraParams Method (String, DataObjectBase)

Generates any extra parameters that are needed for the ADO parameter statement.

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected override string GetSqlParameterExtraParams(
    string statementPrefix,
    DataObjectBase column
)
Protected Overrides Function GetSqlParameterExtraParams (
    statementPrefix As String,
    column As DataObjectBase
) As String

Parameters

statementPrefix
Type: SystemString
column
Type: SchemaExplorerDataObjectBase

Return Value

Type: String
See Also

Reference

VBSqlCodeTemplate Class
GetSqlParameterExtraParams Overload
CodeSmith.BaseTemplates Namespace


VBSqlCodeTemplate.GetSqlParameterStatements Method

VBSqlCodeTemplateGetSqlParameterStatements Method

Overload List
 | Name | Description
Public method | GetSqlParameterStatements(String, ColumnSchema) | Generates an assignment statement that adds a parameter to a ADO object for the given column. (Inherited from SqlCodeTemplate.)
Public method | GetSqlParameterStatements(String, ColumnSchema, String) | Generates an assignment statement that adds a parameter to a ADO object for the given column. (Overrides SqlCodeTemplateGetSqlParameterStatements(String, ColumnSchema, String).)
Top
See Also

Reference

VBSqlCodeTemplate Class
CodeSmith.BaseTemplates Namespace


VBSqlCodeTemplate.GetSqlParameterStatements Method (String, ColumnSchema, String)

VBSqlCodeTemplateGetSqlParameterStatements Method (String, ColumnSchema, String)

Generates an assignment statement that adds a parameter to a ADO object for the given column.

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override string GetSqlParameterStatements(
    string statementPrefix,
    ColumnSchema column,
    string sqlObjectName
)
Public Overrides Function GetSqlParameterStatements (
    statementPrefix As String,
    column As ColumnSchema,
    sqlObjectName As String
) As String

Parameters

statementPrefix
Type: SystemString
column
Type: SchemaExplorerColumnSchema
sqlObjectName
Type: SystemString

Return Value

Type: String
See Also

Reference

VBSqlCodeTemplate Class
GetSqlParameterStatements Overload
CodeSmith.BaseTemplates Namespace


VBSqlCodeTemplate.GetSqlReaderAssignmentStatement Method

VBSqlCodeTemplateGetSqlReaderAssignmentStatement Method

Returns a typed VB.Net reader.ReadXXX() statement.

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override string GetSqlReaderAssignmentStatement(
    ColumnSchema column,
    int index
)
Public Overrides Function GetSqlReaderAssignmentStatement (
    column As ColumnSchema,
    index As Integer
) As String

Parameters

column
Type: SchemaExplorerColumnSchema
index
Type: SystemInt32

Return Value

Type: String
See Also

Reference

VBSqlCodeTemplate Class
CodeSmith.BaseTemplates Namespace


VBSqlCodeTemplate.GetValidateStatements Method

VBSqlCodeTemplateGetValidateStatements Method

Generates a batch of C# validation statements based on the column.

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override string GetValidateStatements(
    TableSchema table,
    string statementPrefix
)
Public Overrides Function GetValidateStatements (
    table As TableSchema,
    statementPrefix As String
) As String

Parameters

table
Type: SchemaExplorerTableSchema
statementPrefix
Type: SystemString

Return Value

Type: String
See Also

Reference

VBSqlCodeTemplate Class
CodeSmith.BaseTemplates Namespace


VBSqlCodeTemplate.GetVBVariableType Method

VBSqlCodeTemplateGetVBVariableType Method

Overload List
 | Name | Description
Public method | GetVBVariableType(ColumnSchema) | Returns the C# variable type based on the given column.
Public method | GetVBVariableType(CommandResultColumnSchema) | Returns the C# variable type based on the given column.
Public method | GetVBVariableType(DbType) | Returns the C# variable type based on the given dataType.
Public method | GetVBVariableType(ParameterSchema) | Returns the C# variable type based on the given parameter.
Public method | GetVBVariableType(ViewColumnSchema) | Returns the C# variable type based on the given column.
Top
See Also

Reference

VBSqlCodeTemplate Class
CodeSmith.BaseTemplates Namespace


VBSqlCodeTemplate.GetVBVariableType Method (ColumnSchema)

VBSqlCodeTemplateGetVBVariableType Method (ColumnSchema)

Returns the C# variable type based on the given column.

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string GetVBVariableType(
    ColumnSchema column
)
Public Function GetVBVariableType (
    column As ColumnSchema
) As String

Parameters

column
Type: SchemaExplorerColumnSchema

Return Value

Type: String
See Also

Reference

VBSqlCodeTemplate Class
GetVBVariableType Overload
CodeSmith.BaseTemplates Namespace


VBSqlCodeTemplate.GetVBVariableType Method (CommandResultColumnSchema)

VBSqlCodeTemplateGetVBVariableType Method (CommandResultColumnSchema)

Returns the C# variable type based on the given column.

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string GetVBVariableType(
    CommandResultColumnSchema column
)
Public Function GetVBVariableType (
    column As CommandResultColumnSchema
) As String

Parameters

column
Type: SchemaExplorerCommandResultColumnSchema

Return Value

Type: String
See Also

Reference

VBSqlCodeTemplate Class
GetVBVariableType Overload
CodeSmith.BaseTemplates Namespace


VBSqlCodeTemplate.GetVBVariableType Method (DbType)

VBSqlCodeTemplateGetVBVariableType Method (DbType)

Returns the C# variable type based on the given dataType.

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual string GetVBVariableType(
    DbType dataType
)
Public Overridable Function GetVBVariableType (
    dataType As DbType
) As String

Parameters

dataType
Type: System.DataDbType

Return Value

Type: String
See Also

Reference

VBSqlCodeTemplate Class
GetVBVariableType Overload
CodeSmith.BaseTemplates Namespace


VBSqlCodeTemplate.GetVBVariableType Method (ParameterSchema)

VBSqlCodeTemplateGetVBVariableType Method (ParameterSchema)

Returns the C# variable type based on the given parameter.

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string GetVBVariableType(
    ParameterSchema column
)
Public Function GetVBVariableType (
    column As ParameterSchema
) As String

Parameters

column
Type: SchemaExplorerParameterSchema

Return Value

Type: String
See Also

Reference

VBSqlCodeTemplate Class
GetVBVariableType Overload
CodeSmith.BaseTemplates Namespace


VBSqlCodeTemplate.GetVBVariableType Method (ViewColumnSchema)

VBSqlCodeTemplateGetVBVariableType Method (ViewColumnSchema)

Returns the C# variable type based on the given column.

Namespace: CodeSmith.BaseTemplates
Assembly: CodeSmith.BaseTemplates (in CodeSmith.BaseTemplates.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string GetVBVariableType(
    ViewColumnSchema column
)
Public Function GetVBVariableType (
    column As ViewColumnSchema
) As String

Parameters

column
Type: SchemaExplorerViewColumnSchema

Return Value

Type: String
See Also

Reference

VBSqlCodeTemplate Class
GetVBVariableType Overload
CodeSmith.BaseTemplates Namespace


VBSqlCodeTemplate Events

The VBSqlCodeTemplate type exposes the following members.

Events
 | Name | Description
Public event | OutputRegistered | Raised when an output file is registered (Inherited from CodeTemplate.)
Public event | PreOutputWritten | Raised prior to an output being written to disk (Inherited from CodeTemplate.)
Public event | PropertiesLoaded | (Inherited from CodeTemplate.)
Public event | PropertiesSaved | (Inherited from CodeTemplate.)
Public event | PropertyChanged | (Inherited from CodeTemplate.)
Public event | ReferenceRegistered | Occurs when a reference is registered. (Inherited from CodeTemplate.)
Top
See Also

Reference

VBSqlCodeTemplate Class
CodeSmith.BaseTemplates Namespace


VBSqlCodeTemplate Fields

The VBSqlCodeTemplate type exposes the following members.

Fields
 | Name | Description
Protected field | _childControlsCreated | (Inherited from Control.)
Protected field | _codeTemplate | (Inherited from Control.)
Protected field | _controls | (Inherited from Control.)
Protected field | _outputFile | (Inherited from OutputFileCodeTemplate.)
Protected field | _parent | (Inherited from Control.)
Protected field | _visible | (Inherited from Control.)
Top
See Also

Reference

VBSqlCodeTemplate Class
CodeSmith.BaseTemplates Namespace


CodeSmith.CustomProperties Namespace

This assembly contains custom property types that templates can make use of.
Classes
 | Class | Description
Public class | AssemblyFilePicker | Allows you to browse for an assembly.
Public class | FileDialogAttribute |
Public class | FileNameEditor | Allows you to browse for a file.
Public class | NameValueCollection | Obsolete. Implements a strongly typed collection of NameValueEntry key-and-value pairs that retain their insertion order and are accessible by index and by key.
Public class | NameValueCollectionEditor | Obsolete. Allows you to quickly edit an NameValueCollection.
Public class | NameValueCollectionEditorUI | Obsolete.
Public class | NameValueCollectionSerializer | Obsolete.
Public class | NameValueCollectionTypeConverter | Obsolete.
Public class | StringCollection | Obsolete.
Public class | StringCollectionEditor | Obsolete. Allows you quickly edit a string collection.
Public class | StringCollectionEditorUI | Obsolete.
Public class | StringCollectionSerializer | Obsolete.
Public class | StringCollectionTypeConverter | Obsolete.
Public class | XmlSerializedFilePicker | Allows you to browse for an Xml file.
Public class | XmlSerializedTypeConverter |
Structures
 | Structure | Description
Public structure | NameValueEntry | Implements a strongly typed pair of one String key and one String value.
Interfaces
 | Interface | Description
Public interface | IStringCollection | Defines size, enumerators, and synchronization methods for strongly typed collections of String elements.
Public interface | IStringEnumerator | Supports type-safe iteration over a collection that contains String elements.
Public interface | IStringList | Represents a strongly typed collection of String objects that can be individually accessed by index.
Public interface | IStringStringCollection | Defines size, enumerators, and synchronization methods for strongly typed collections of NameValueEntry elements.
Public interface | IStringStringDictionary | Represents a strongly typed collection of NameValueEntry key-and-value pairs.
Public interface | IStringStringEnumerator | Supports type-safe iteration over a dictionary that contains NameValueEntry elements.
Public interface | IStringStringList | Represents a strongly typed collection of NameValueEntry objects that can be individually accessed by index.
Public interface | StringCollectionIStringCollectionEnumerator | Supports type-safe iteration over a StringCollection.
Enumerations
 | Enumeration | Description
Public enumeration | FileDialogType |
Protected enumeration | StringCollectionTag |


AssemblyFilePicker Class

Allows you to browse for an assembly.
Inheritance Hierarchy
SystemObject
System.Drawing.DesignUITypeEditor
CodeSmith.CustomPropertiesAssemblyFilePicker

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class AssemblyFilePicker : UITypeEditor
Public Class AssemblyFilePicker
    Inherits UITypeEditor

The AssemblyFilePicker type exposes the following members.

Constructors
 | Name | Description
Public method | AssemblyFilePicker | Initializes a new instance of the AssemblyFilePicker class
Top
Properties
 | Name | Description
Public property | IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Inherited from UITypeEditor.)
Top
Methods
 | Name | Description
Public method | EditValue(IServiceProvider, Object) | Edits the value of the specified object using the editor style indicated by the GetEditStyle method. (Inherited from UITypeEditor.)
Public method | EditValue(ITypeDescriptorContext, IServiceProvider, Object) | (Overrides UITypeEditorEditValue(ITypeDescriptorContext, IServiceProvider, Object).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEditStyle | Gets the editor style used by the EditValue(IServiceProvider, Object) method. (Inherited from UITypeEditor.)
Public method | GetEditStyle(ITypeDescriptorContext) | (Overrides UITypeEditorGetEditStyle(ITypeDescriptorContext).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetPaintValueSupported | Indicates whether this editor supports painting a representation of an object's value. (Inherited from UITypeEditor.)
Public method | GetPaintValueSupported(ITypeDescriptorContext) | Indicates whether the specified context supports painting a representation of an object's value within the specified context. (Inherited from UITypeEditor.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PaintValue(PaintValueEventArgs) | Paints a representation of the value of an object using the specified PaintValueEventArgs. (Inherited from UITypeEditor.)
Public method | PaintValue(Object, Graphics, Rectangle) | Paints a representation of the value of the specified object to the specified canvas. (Inherited from UITypeEditor.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSmith.CustomProperties Namespace


AssemblyFilePicker Constructor

Initializes a new instance of the AssemblyFilePicker class

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public AssemblyFilePicker()
Public Sub New
See Also

Reference

AssemblyFilePicker Class
CodeSmith.CustomProperties Namespace


AssemblyFilePicker Properties

The AssemblyFilePicker type exposes the following members.

Properties
 | Name | Description
Public property | IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Inherited from UITypeEditor.)
Top
See Also

Reference

AssemblyFilePicker Class
CodeSmith.CustomProperties Namespace


AssemblyFilePicker Methods

The AssemblyFilePicker type exposes the following members.

Methods
 | Name | Description
Public method | EditValue(IServiceProvider, Object) | Edits the value of the specified object using the editor style indicated by the GetEditStyle method. (Inherited from UITypeEditor.)
Public method | EditValue(ITypeDescriptorContext, IServiceProvider, Object) | (Overrides UITypeEditorEditValue(ITypeDescriptorContext, IServiceProvider, Object).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEditStyle | Gets the editor style used by the EditValue(IServiceProvider, Object) method. (Inherited from UITypeEditor.)
Public method | GetEditStyle(ITypeDescriptorContext) | (Overrides UITypeEditorGetEditStyle(ITypeDescriptorContext).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetPaintValueSupported | Indicates whether this editor supports painting a representation of an object's value. (Inherited from UITypeEditor.)
Public method | GetPaintValueSupported(ITypeDescriptorContext) | Indicates whether the specified context supports painting a representation of an object's value within the specified context. (Inherited from UITypeEditor.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PaintValue(PaintValueEventArgs) | Paints a representation of the value of an object using the specified PaintValueEventArgs. (Inherited from UITypeEditor.)
Public method | PaintValue(Object, Graphics, Rectangle) | Paints a representation of the value of the specified object to the specified canvas. (Inherited from UITypeEditor.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AssemblyFilePicker Class
CodeSmith.CustomProperties Namespace


AssemblyFilePicker.EditValue Method

AssemblyFilePickerEditValue Method

Overload List
 | Name | Description
Public method | EditValue(IServiceProvider, Object) | Edits the value of the specified object using the editor style indicated by the GetEditStyle method. (Inherited from UITypeEditor.)
Public method | EditValue(ITypeDescriptorContext, IServiceProvider, Object) | (Overrides UITypeEditorEditValue(ITypeDescriptorContext, IServiceProvider, Object).)
Top
See Also

Reference

AssemblyFilePicker Class
CodeSmith.CustomProperties Namespace


AssemblyFilePicker.EditValue Method (ITypeDescriptorContext, IServiceProvider, Object)

AssemblyFilePickerEditValue Method (ITypeDescriptorContext, IServiceProvider, Object)

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override Object EditValue(
    ITypeDescriptorContext context,
    IServiceProvider provider,
    Object value
)
Public Overrides Function EditValue (
    context As ITypeDescriptorContext,
    provider As IServiceProvider,
    value As Object
) As Object

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
provider
Type: SystemIServiceProvider
value
Type: SystemObject

Return Value

Type: Object
See Also

Reference

AssemblyFilePicker Class
EditValue Overload
CodeSmith.CustomProperties Namespace


AssemblyFilePicker.GetEditStyle Method

AssemblyFilePickerGetEditStyle Method

Overload List
 | Name | Description
Public method | GetEditStyle | Gets the editor style used by the EditValue(IServiceProvider, Object) method. (Inherited from UITypeEditor.)
Public method | GetEditStyle(ITypeDescriptorContext) | (Overrides UITypeEditorGetEditStyle(ITypeDescriptorContext).)
Top
See Also

Reference

AssemblyFilePicker Class
CodeSmith.CustomProperties Namespace


AssemblyFilePicker.GetEditStyle Method (ITypeDescriptorContext)

AssemblyFilePickerGetEditStyle Method (ITypeDescriptorContext)

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override UITypeEditorEditStyle GetEditStyle(
    ITypeDescriptorContext context
)
Public Overrides Function GetEditStyle (
    context As ITypeDescriptorContext
) As UITypeEditorEditStyle

Parameters

context
Type: System.ComponentModelITypeDescriptorContext

Return Value

Type: UITypeEditorEditStyle
See Also

Reference

AssemblyFilePicker Class
GetEditStyle Overload
CodeSmith.CustomProperties Namespace


FileDialogAttribute Class

Inheritance Hierarchy
SystemObject
SystemAttribute
CodeSmith.CustomPropertiesFileDialogAttribute

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class FileDialogAttribute : Attribute
Public Class FileDialogAttribute
    Inherits Attribute

The FileDialogAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | FileDialogAttribute | Initializes a new instance of the FileDialogAttribute class
Top
Properties
 | Name | Description
Public property | CheckFileExists |
Public property | CheckPathExists |
Public property | DefaultExtension |
Public property | DialogType |
Public property | Filter |
Public property | IsCheckFileExistsSet |
Public property | IsCheckPathExistsSet |
Public property | IsDefaultExtensionSet |
Public property | IsFilterSet |
Public property | IsTitleSet |
Public property | Title |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSmith.CustomProperties Namespace


FileDialogAttribute Constructor

Initializes a new instance of the FileDialogAttribute class

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public FileDialogAttribute(
    FileDialogType dialogType
)
Public Sub New (
    dialogType As FileDialogType
)

Parameters

dialogType
Type: CodeSmith.CustomPropertiesFileDialogType
See Also

Reference

FileDialogAttribute Class
CodeSmith.CustomProperties Namespace


FileDialogAttribute Properties

The FileDialogAttribute type exposes the following members.

Properties
 | Name | Description
Public property | CheckFileExists |
Public property | CheckPathExists |
Public property | DefaultExtension |
Public property | DialogType |
Public property | Filter |
Public property | IsCheckFileExistsSet |
Public property | IsCheckPathExistsSet |
Public property | IsDefaultExtensionSet |
Public property | IsFilterSet |
Public property | IsTitleSet |
Public property | Title |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

FileDialogAttribute Class
CodeSmith.CustomProperties Namespace


FileDialogAttribute.CheckFileExists Property

FileDialogAttributeCheckFileExists Property

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool CheckFileExists { get; set; }
Public Property CheckFileExists As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

FileDialogAttribute Class
CodeSmith.CustomProperties Namespace


FileDialogAttribute.CheckPathExists Property

FileDialogAttributeCheckPathExists Property

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool CheckPathExists { get; set; }
Public Property CheckPathExists As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

FileDialogAttribute Class
CodeSmith.CustomProperties Namespace


FileDialogAttribute.DefaultExtension Property

FileDialogAttributeDefaultExtension Property

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string DefaultExtension { get; set; }
Public Property DefaultExtension As String
    Get
    Set

Property Value

Type: String
See Also

Reference

FileDialogAttribute Class
CodeSmith.CustomProperties Namespace


FileDialogAttribute.DialogType Property

FileDialogAttributeDialogType Property

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public FileDialogType DialogType { get; set; }
Public Property DialogType As FileDialogType
    Get
    Set

Property Value

Type: FileDialogType
See Also

Reference

FileDialogAttribute Class
CodeSmith.CustomProperties Namespace


FileDialogAttribute.Filter Property

FileDialogAttributeFilter Property

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string Filter { get; set; }
Public Property Filter As String
    Get
    Set

Property Value

Type: String
See Also

Reference

FileDialogAttribute Class
CodeSmith.CustomProperties Namespace


FileDialogAttribute.IsCheckFileExistsSet Property

FileDialogAttributeIsCheckFileExistsSet Property

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool IsCheckFileExistsSet { get; }
Public ReadOnly Property IsCheckFileExistsSet As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

FileDialogAttribute Class
CodeSmith.CustomProperties Namespace


FileDialogAttribute.IsCheckPathExistsSet Property

FileDialogAttributeIsCheckPathExistsSet Property

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool IsCheckPathExistsSet { get; }
Public ReadOnly Property IsCheckPathExistsSet As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

FileDialogAttribute Class
CodeSmith.CustomProperties Namespace


FileDialogAttribute.IsDefaultExtensionSet Property

FileDialogAttributeIsDefaultExtensionSet Property

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool IsDefaultExtensionSet { get; }
Public ReadOnly Property IsDefaultExtensionSet As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

FileDialogAttribute Class
CodeSmith.CustomProperties Namespace


FileDialogAttribute.IsFilterSet Property

FileDialogAttributeIsFilterSet Property

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool IsFilterSet { get; }
Public ReadOnly Property IsFilterSet As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

FileDialogAttribute Class
CodeSmith.CustomProperties Namespace


FileDialogAttribute.IsTitleSet Property

FileDialogAttributeIsTitleSet Property

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool IsTitleSet { get; }
Public ReadOnly Property IsTitleSet As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

FileDialogAttribute Class
CodeSmith.CustomProperties Namespace


FileDialogAttribute.Title Property

FileDialogAttributeTitle Property

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string Title { get; set; }
Public Property Title As String
    Get
    Set

Property Value

Type: String
See Also

Reference

FileDialogAttribute Class
CodeSmith.CustomProperties Namespace


FileDialogAttribute Methods

The FileDialogAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FileDialogAttribute Class
CodeSmith.CustomProperties Namespace


FileDialogType Enumeration

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public enum FileDialogType
Public Enumeration FileDialogType
Members
Member name | Value | Description
Save | 0 |
Open | 1 |
See Also

Reference

CodeSmith.CustomProperties Namespace


FileNameEditor Class

Allows you to browse for a file.
Inheritance Hierarchy
SystemObject
System.Drawing.DesignUITypeEditor
CodeSmith.CustomPropertiesFileNameEditor

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class FileNameEditor : UITypeEditor
Public Class FileNameEditor
    Inherits UITypeEditor

The FileNameEditor type exposes the following members.

Constructors
 | Name | Description
Public method | FileNameEditor | Initializes a new instance of the FileNameEditor class
Top
Properties
 | Name | Description
Public property | IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Inherited from UITypeEditor.)
Top
Methods
 | Name | Description
Public method | EditValue(IServiceProvider, Object) | Edits the value of the specified object using the editor style indicated by the GetEditStyle method. (Inherited from UITypeEditor.)
Public method | EditValue(ITypeDescriptorContext, IServiceProvider, Object) | (Overrides UITypeEditorEditValue(ITypeDescriptorContext, IServiceProvider, Object).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEditStyle | Gets the editor style used by the EditValue(IServiceProvider, Object) method. (Inherited from UITypeEditor.)
Public method | GetEditStyle(ITypeDescriptorContext) | (Overrides UITypeEditorGetEditStyle(ITypeDescriptorContext).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetPaintValueSupported | Indicates whether this editor supports painting a representation of an object's value. (Inherited from UITypeEditor.)
Public method | GetPaintValueSupported(ITypeDescriptorContext) | Indicates whether the specified context supports painting a representation of an object's value within the specified context. (Inherited from UITypeEditor.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InitializeDialog |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PaintValue(PaintValueEventArgs) | Paints a representation of the value of an object using the specified PaintValueEventArgs. (Inherited from UITypeEditor.)
Public method | PaintValue(Object, Graphics, Rectangle) | Paints a representation of the value of the specified object to the specified canvas. (Inherited from UITypeEditor.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSmith.CustomProperties Namespace


FileNameEditor Constructor

Initializes a new instance of the FileNameEditor class

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public FileNameEditor()
Public Sub New
See Also

Reference

FileNameEditor Class
CodeSmith.CustomProperties Namespace


FileNameEditor Properties

The FileNameEditor type exposes the following members.

Properties
 | Name | Description
Public property | IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Inherited from UITypeEditor.)
Top
See Also

Reference

FileNameEditor Class
CodeSmith.CustomProperties Namespace


FileNameEditor Methods

The FileNameEditor type exposes the following members.

Methods
 | Name | Description
Public method | EditValue(IServiceProvider, Object) | Edits the value of the specified object using the editor style indicated by the GetEditStyle method. (Inherited from UITypeEditor.)
Public method | EditValue(ITypeDescriptorContext, IServiceProvider, Object) | (Overrides UITypeEditorEditValue(ITypeDescriptorContext, IServiceProvider, Object).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEditStyle | Gets the editor style used by the EditValue(IServiceProvider, Object) method. (Inherited from UITypeEditor.)
Public method | GetEditStyle(ITypeDescriptorContext) | (Overrides UITypeEditorGetEditStyle(ITypeDescriptorContext).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetPaintValueSupported | Indicates whether this editor supports painting a representation of an object's value. (Inherited from UITypeEditor.)
Public method | GetPaintValueSupported(ITypeDescriptorContext) | Indicates whether the specified context supports painting a representation of an object's value within the specified context. (Inherited from UITypeEditor.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InitializeDialog |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PaintValue(PaintValueEventArgs) | Paints a representation of the value of an object using the specified PaintValueEventArgs. (Inherited from UITypeEditor.)
Public method | PaintValue(Object, Graphics, Rectangle) | Paints a representation of the value of the specified object to the specified canvas. (Inherited from UITypeEditor.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FileNameEditor Class
CodeSmith.CustomProperties Namespace


FileNameEditor.EditValue Method

FileNameEditorEditValue Method

Overload List
 | Name | Description
Public method | EditValue(IServiceProvider, Object) | Edits the value of the specified object using the editor style indicated by the GetEditStyle method. (Inherited from UITypeEditor.)
Public method | EditValue(ITypeDescriptorContext, IServiceProvider, Object) | (Overrides UITypeEditorEditValue(ITypeDescriptorContext, IServiceProvider, Object).)
Top
See Also

Reference

FileNameEditor Class
CodeSmith.CustomProperties Namespace


FileNameEditor.EditValue Method (ITypeDescriptorContext, IServiceProvider, Object)

FileNameEditorEditValue Method (ITypeDescriptorContext, IServiceProvider, Object)

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override Object EditValue(
    ITypeDescriptorContext context,
    IServiceProvider provider,
    Object value
)
Public Overrides Function EditValue (
    context As ITypeDescriptorContext,
    provider As IServiceProvider,
    value As Object
) As Object

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
provider
Type: SystemIServiceProvider
value
Type: SystemObject

Return Value

Type: Object
See Also

Reference

FileNameEditor Class
EditValue Overload
CodeSmith.CustomProperties Namespace


FileNameEditor.GetEditStyle Method

FileNameEditorGetEditStyle Method

Overload List
 | Name | Description
Public method | GetEditStyle | Gets the editor style used by the EditValue(IServiceProvider, Object) method. (Inherited from UITypeEditor.)
Public method | GetEditStyle(ITypeDescriptorContext) | (Overrides UITypeEditorGetEditStyle(ITypeDescriptorContext).)
Top
See Also

Reference

FileNameEditor Class
CodeSmith.CustomProperties Namespace


FileNameEditor.GetEditStyle Method (ITypeDescriptorContext)

FileNameEditorGetEditStyle Method (ITypeDescriptorContext)

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override UITypeEditorEditStyle GetEditStyle(
    ITypeDescriptorContext context
)
Public Overrides Function GetEditStyle (
    context As ITypeDescriptorContext
) As UITypeEditorEditStyle

Parameters

context
Type: System.ComponentModelITypeDescriptorContext

Return Value

Type: UITypeEditorEditStyle
See Also

Reference

FileNameEditor Class
GetEditStyle Overload
CodeSmith.CustomProperties Namespace


FileNameEditor.InitializeDialog Method

FileNameEditorInitializeDialog Method

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual void InitializeDialog(
    FileDialog fileDialog,
    ITypeDescriptorContext context
)
Protected Overridable Sub InitializeDialog (
    fileDialog As FileDialog,
    context As ITypeDescriptorContext
)

Parameters

fileDialog
Type: System.Windows.FormsFileDialog
context
Type: System.ComponentModelITypeDescriptorContext
See Also

Reference

FileNameEditor Class
CodeSmith.CustomProperties Namespace


IStringCollection Interface

Defines size, enumerators, and synchronization methods for strongly typed collections of String elements.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public interface IStringCollection
Public Interface IStringCollection

The IStringCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the IStringCollection.
Public property | IsSynchronized | Gets a value indicating whether access to the IStringCollection is synchronized (thread-safe).
Public property | SyncRoot | Gets an object that can be used to synchronize access to the IStringCollection.
Top
Methods
 | Name | Description
Public method | CopyTo | Copies the entire IStringCollection to a one-dimensional Array of String elements, starting at the specified index of the target array.
Public method | GetEnumerator | Returns an IStringEnumerator that can iterate through the IStringCollection.
Top
Remarks
IStringCollection provides an ICollection that is strongly typed for String elements.
See Also

Reference

CodeSmith.CustomProperties Namespace


IStringCollection Properties

The IStringCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the IStringCollection.
Public property | IsSynchronized | Gets a value indicating whether access to the IStringCollection is synchronized (thread-safe).
Public property | SyncRoot | Gets an object that can be used to synchronize access to the IStringCollection.
Top
See Also

Reference

IStringCollection Interface
CodeSmith.CustomProperties Namespace


IStringCollection.Count Property

IStringCollectionCount Property

Gets the number of elements contained in the IStringCollection.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32
The number of elements contained in the IStringCollection.
Remarks
Please refer to Count for details.
See Also

Reference

IStringCollection Interface
CodeSmith.CustomProperties Namespace


IStringCollection.IsSynchronized Property

IStringCollectionIsSynchronized Property

Gets a value indicating whether access to the IStringCollection is synchronized (thread-safe).

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
bool IsSynchronized { get; }
ReadOnly Property IsSynchronized As Boolean
    Get

Property Value

Type: Boolean
true if access to the IStringCollection is synchronized (thread-safe); otherwise, false. The default is false.
Remarks
Please refer to IsSynchronized for details.
See Also

Reference

IStringCollection Interface
CodeSmith.CustomProperties Namespace


IStringCollection.SyncRoot Property

IStringCollectionSyncRoot Property

Gets an object that can be used to synchronize access to the IStringCollection.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
Object SyncRoot { get; }
ReadOnly Property SyncRoot As Object
    Get

Property Value

Type: Object
An object that can be used to synchronize access to the IStringCollection.
Remarks
Please refer to SyncRoot for details.
See Also

Reference

IStringCollection Interface
CodeSmith.CustomProperties Namespace


IStringCollection Methods

The IStringCollection type exposes the following members.

Methods
 | Name | Description
Public method | CopyTo | Copies the entire IStringCollection to a one-dimensional Array of String elements, starting at the specified index of the target array.
Public method | GetEnumerator | Returns an IStringEnumerator that can iterate through the IStringCollection.
Top
See Also

Reference

IStringCollection Interface
CodeSmith.CustomProperties Namespace


IStringCollection.CopyTo Method

IStringCollectionCopyTo Method

Copies the entire IStringCollection to a one-dimensional Array of String elements, starting at the specified index of the target array.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
void CopyTo(
    string[] array,
    int arrayIndex
)
Sub CopyTo (
    array As String(),
    arrayIndex As Integer
)

Parameters

array
Type: SystemString
The one-dimensional Array that is the destination of the String elements copied from the IStringCollection. The Array must have zero-based indexing.
arrayIndex
Type: SystemInt32
The zero-based index in array at which copying begins.
Exceptions
Exception | Condition
ArgumentNullException | array is a null reference.
ArgumentOutOfRangeException | arrayIndex is less than zero.
ArgumentException | arrayIndex is equal to or greater than the length of array. -or- The number of elements in the source IStringCollection is greater than the available space from arrayIndex to the end of the destination array.
Remarks
Please refer to CopyTo(Array, Int32) for details.
See Also

Reference

IStringCollection Interface
CodeSmith.CustomProperties Namespace


IStringCollection.GetEnumerator Method

IStringCollectionGetEnumerator Method

Returns an IStringEnumerator that can iterate through the IStringCollection.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
IStringEnumerator GetEnumerator()
Function GetEnumerator As IStringEnumerator

Return Value

Type: IStringEnumerator
An IStringEnumerator for the entire IStringCollection.
Remarks
Please refer to GetEnumerator for details.
See Also

Reference

IStringCollection Interface
CodeSmith.CustomProperties Namespace


IStringEnumerator Interface

Supports type-safe iteration over a collection that contains String elements.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public interface IStringEnumerator
Public Interface IStringEnumerator

The IStringEnumerator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Gets the current String element in the collection.
Top
Methods
 | Name | Description
Public method | MoveNext | Advances the enumerator to the next element of the collection.
Public method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
Top
Remarks
IStringEnumerator provides an IEnumerator that is strongly typed for String elements.
See Also

Reference

CodeSmith.CustomProperties Namespace


IStringEnumerator Properties

The IStringEnumerator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Gets the current String element in the collection.
Top
See Also

Reference

IStringEnumerator Interface
CodeSmith.CustomProperties Namespace


IStringEnumerator.Current Property

IStringEnumeratorCurrent Property

Gets the current String element in the collection.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
string Current { get; }
ReadOnly Property Current As String
    Get

Property Value

Type: String
The current String element in the collection.
Exceptions
Exception | Condition
InvalidOperationException | The enumerator is positioned before the first element of the collection or after the last element. -or- The collection was modified after the enumerator was created.
Remarks
Please refer to Current for details, but note that Current fails if the collection was modified since the last successful call to MoveNext or Reset.
See Also

Reference

IStringEnumerator Interface
CodeSmith.CustomProperties Namespace


IStringEnumerator Methods

The IStringEnumerator type exposes the following members.

Methods
 | Name | Description
Public method | MoveNext | Advances the enumerator to the next element of the collection.
Public method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
Top
See Also

Reference

IStringEnumerator Interface
CodeSmith.CustomProperties Namespace


IStringEnumerator.MoveNext Method

IStringEnumeratorMoveNext Method

Advances the enumerator to the next element of the collection.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
bool MoveNext()
Function MoveNext As Boolean

Return Value

Type: Boolean
true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.
Exceptions
Exception | Condition
InvalidOperationException | The collection was modified after the enumerator was created.
Remarks
Please refer to MoveNext for details.
See Also

Reference

IStringEnumerator Interface
CodeSmith.CustomProperties Namespace


IStringEnumerator.Reset Method

IStringEnumeratorReset Method

Sets the enumerator to its initial position, which is before the first element in the collection.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
void Reset()
Sub Reset
Exceptions
Exception | Condition
InvalidOperationException | The collection was modified after the enumerator was created.
Remarks
Please refer to Reset for details.
See Also

Reference

IStringEnumerator Interface
CodeSmith.CustomProperties Namespace


IStringList Interface

Represents a strongly typed collection of String objects that can be individually accessed by index.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public interface IStringList : IStringCollection
Public Interface IStringList
    Inherits IStringCollection

The IStringList type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the IStringCollection. (Inherited from IStringCollection.)
Public property | IsFixedSize | Gets a value indicating whether the IStringList has a fixed size.
Public property | IsReadOnly | Gets a value indicating whether the IStringList is read-only.
Public property | IsSynchronized | Gets a value indicating whether access to the IStringCollection is synchronized (thread-safe). (Inherited from IStringCollection.)
Public property | Item | Gets or sets the String element at the specified index.
Public property | SyncRoot | Gets an object that can be used to synchronize access to the IStringCollection. (Inherited from IStringCollection.)
Top
Methods
 | Name | Description
Public method | Add | Adds a String to the end of the IStringList.
Public method | Clear | Removes all elements from the IStringList.
Public method | Contains | Determines whether the IStringList contains the specified String element.
Public method | CopyTo | Copies the entire IStringCollection to a one-dimensional Array of String elements, starting at the specified index of the target array. (Inherited from IStringCollection.)
Public method | GetEnumerator | Returns an IStringEnumerator that can iterate through the IStringCollection. (Inherited from IStringCollection.)
Public method | IndexOf | Returns the zero-based index of the first occurrence of the specified String in the IStringList.
Public method | Insert | Inserts a String element into the IStringList at the specified index.
Public method | Remove | Removes the first occurrence of the specified String from the IStringList.
Public method | RemoveAt | Removes the element at the specified index of the IStringList.
Top
Remarks
IStringList provides an IList that is strongly typed for String elements.
See Also

Reference

CodeSmith.CustomProperties Namespace


IStringList Properties

The IStringList type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the IStringCollection. (Inherited from IStringCollection.)
Public property | IsFixedSize | Gets a value indicating whether the IStringList has a fixed size.
Public property | IsReadOnly | Gets a value indicating whether the IStringList is read-only.
Public property | IsSynchronized | Gets a value indicating whether access to the IStringCollection is synchronized (thread-safe). (Inherited from IStringCollection.)
Public property | Item | Gets or sets the String element at the specified index.
Public property | SyncRoot | Gets an object that can be used to synchronize access to the IStringCollection. (Inherited from IStringCollection.)
Top
See Also

Reference

IStringList Interface
CodeSmith.CustomProperties Namespace


IStringList.IsFixedSize Property

IStringListIsFixedSize Property

Gets a value indicating whether the IStringList has a fixed size.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
bool IsFixedSize { get; }
ReadOnly Property IsFixedSize As Boolean
    Get

Property Value

Type: Boolean
true if the IStringList has a fixed size; otherwise, false. The default is false.
Remarks
Please refer to IsFixedSize for details.
See Also

Reference

IStringList Interface
CodeSmith.CustomProperties Namespace


IStringList.IsReadOnly Property

IStringListIsReadOnly Property

Gets a value indicating whether the IStringList is read-only.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
bool IsReadOnly { get; }
ReadOnly Property IsReadOnly As Boolean
    Get

Property Value

Type: Boolean
true if the IStringList is read-only; otherwise, false. The default is false.
Remarks
Please refer to IsReadOnly for details.
See Also

Reference

IStringList Interface
CodeSmith.CustomProperties Namespace


IStringList.Item Property

IStringListItem Property

Gets or sets the String element at the specified index.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
string this[
    int index
] { get; set; }
Default Property Item (
    index As Integer
) As String
    Get
    Set

Parameters

index
Type: SystemInt32
The zero-based index of the String element to get or set.

Property Value

Type: String
The String element at the specified index.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than Count.
NotSupportedException | The property is set and the IStringList is read-only.
Remarks
Please refer to ItemInt32 for details.
See Also

Reference

IStringList Interface
CodeSmith.CustomProperties Namespace


IStringList Methods

The IStringList type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds a String to the end of the IStringList.
Public method | Clear | Removes all elements from the IStringList.
Public method | Contains | Determines whether the IStringList contains the specified String element.
Public method | CopyTo | Copies the entire IStringCollection to a one-dimensional Array of String elements, starting at the specified index of the target array. (Inherited from IStringCollection.)
Public method | GetEnumerator | Returns an IStringEnumerator that can iterate through the IStringCollection. (Inherited from IStringCollection.)
Public method | IndexOf | Returns the zero-based index of the first occurrence of the specified String in the IStringList.
Public method | Insert | Inserts a String element into the IStringList at the specified index.
Public method | Remove | Removes the first occurrence of the specified String from the IStringList.
Public method | RemoveAt | Removes the element at the specified index of the IStringList.
Top
See Also

Reference

IStringList Interface
CodeSmith.CustomProperties Namespace


IStringList.Add Method

IStringListAdd Method

Adds a String to the end of the IStringList.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
int Add(
    string value
)
Function Add (
    value As String
) As Integer

Parameters

value
Type: SystemString
The String object to be added to the end of the IStringList. This argument can be a null reference.

Return Value

Type: Int32
The IStringList index at which the value has been added.
Exceptions
Exception | Condition
NotSupportedException | The IStringList is read-only. -or- The IStringList has a fixed size.
Remarks
Please refer to Add(Object) for details.
See Also

Reference

IStringList Interface
CodeSmith.CustomProperties Namespace


IStringList.Clear Method

IStringListClear Method

Removes all elements from the IStringList.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
void Clear()
Sub Clear
Exceptions
Exception | Condition
NotSupportedException | The IStringList is read-only. -or- The IStringList has a fixed size.
Remarks
Please refer to Clear for details.
See Also

Reference

IStringList Interface
CodeSmith.CustomProperties Namespace


IStringList.Contains Method

IStringListContains Method

Determines whether the IStringList contains the specified String element.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
bool Contains(
    string value
)
Function Contains (
    value As String
) As Boolean

Parameters

value
Type: SystemString
The String object to locate in the IStringList. This argument can be a null reference.

Return Value

Type: Boolean
true if value is found in the IStringList; otherwise, false.
Remarks
Please refer to Contains(Object) for details.
See Also

Reference

IStringList Interface
CodeSmith.CustomProperties Namespace


IStringList.IndexOf Method

IStringListIndexOf Method

Returns the zero-based index of the first occurrence of the specified String in the IStringList.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
int IndexOf(
    string value
)
Function IndexOf (
    value As String
) As Integer

Parameters

value
Type: SystemString
The String object to locate in the IStringList. This argument can be a null reference.

Return Value

Type: Int32
The zero-based index of the first occurrence of value in the IStringList, if found; otherwise, -1.
Remarks
Please refer to IndexOf(Object) for details.
See Also

Reference

IStringList Interface
CodeSmith.CustomProperties Namespace


IStringList.Insert Method

IStringListInsert Method

Inserts a String element into the IStringList at the specified index.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
void Insert(
    int index,
    string value
)
Sub Insert (
    index As Integer,
    value As String
)

Parameters

index
Type: SystemInt32
The zero-based index at which value should be inserted.
value
Type: SystemString
The String object to insert into the IStringList. This argument can be a null reference.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | index is less than zero. -or- index is greater than Count.
NotSupportedException | The IStringList is read-only. -or- The IStringList has a fixed size.
Remarks
Please refer to Insert(Int32, Object) for details.
See Also

Reference

IStringList Interface
CodeSmith.CustomProperties Namespace


IStringList.Remove Method

IStringListRemove Method

Removes the first occurrence of the specified String from the IStringList.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
void Remove(
    string value
)
Sub Remove (
    value As String
)

Parameters

value
Type: SystemString
The String object to remove from the IStringList. This argument can be a null reference.
Exceptions
Exception | Condition
NotSupportedException | The IStringList is read-only. -or- The IStringList has a fixed size.
Remarks
Please refer to Remove(Object) for details.
See Also

Reference

IStringList Interface
CodeSmith.CustomProperties Namespace


IStringList.RemoveAt Method

IStringListRemoveAt Method

Removes the element at the specified index of the IStringList.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
void RemoveAt(
    int index
)
Sub RemoveAt (
    index As Integer
)

Parameters

index
Type: SystemInt32
The zero-based index of the element to remove.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than Count.
NotSupportedException | The IStringList is read-only. -or- The IStringList has a fixed size.
Remarks
Please refer to RemoveAt(Int32) for details.
See Also

Reference

IStringList Interface
CodeSmith.CustomProperties Namespace


IStringStringCollection Interface

Defines size, enumerators, and synchronization methods for strongly typed collections of NameValueEntry elements.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public interface IStringStringCollection
Public Interface IStringStringCollection

The IStringStringCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the IStringStringCollection.
Public property | IsSynchronized | Gets a value indicating whether access to the IStringStringCollection is synchronized (thread-safe).
Public property | SyncRoot | Gets an object that can be used to synchronize access to the IStringStringCollection.
Top
Methods
 | Name | Description
Public method | CopyTo | Copies the entire IStringStringCollection to a one-dimensional Array of NameValueEntry elements, starting at the specified index of the target array.
Public method | GetEnumerator | Returns an IStringStringEnumerator that can iterate through the IStringStringCollection.
Top
Remarks
IStringStringCollection provides an ICollection that is strongly typed for NameValueEntry elements.
See Also

Reference

CodeSmith.CustomProperties Namespace


IStringStringCollection Properties

The IStringStringCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the IStringStringCollection.
Public property | IsSynchronized | Gets a value indicating whether access to the IStringStringCollection is synchronized (thread-safe).
Public property | SyncRoot | Gets an object that can be used to synchronize access to the IStringStringCollection.
Top
See Also

Reference

IStringStringCollection Interface
CodeSmith.CustomProperties Namespace


IStringStringCollection.Count Property

IStringStringCollectionCount Property

Gets the number of elements contained in the IStringStringCollection.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32
The number of elements contained in the IStringStringCollection.
Remarks
Please refer to Count for details.
See Also

Reference

IStringStringCollection Interface
CodeSmith.CustomProperties Namespace


IStringStringCollection.IsSynchronized Property

IStringStringCollectionIsSynchronized Property

Gets a value indicating whether access to the IStringStringCollection is synchronized (thread-safe).

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
bool IsSynchronized { get; }
ReadOnly Property IsSynchronized As Boolean
    Get

Property Value

Type: Boolean
true if access to the IStringStringCollection is synchronized (thread-safe); otherwise, false. The default is false.
Remarks
Please refer to IsSynchronized for details.
See Also

Reference

IStringStringCollection Interface
CodeSmith.CustomProperties Namespace


IStringStringCollection.SyncRoot Property

IStringStringCollectionSyncRoot Property

Gets an object that can be used to synchronize access to the IStringStringCollection.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
Object SyncRoot { get; }
ReadOnly Property SyncRoot As Object
    Get

Property Value

Type: Object
An object that can be used to synchronize access to the IStringStringCollection.
Remarks
Please refer to SyncRoot for details.
See Also

Reference

IStringStringCollection Interface
CodeSmith.CustomProperties Namespace


IStringStringCollection Methods

The IStringStringCollection type exposes the following members.

Methods
 | Name | Description
Public method | CopyTo | Copies the entire IStringStringCollection to a one-dimensional Array of NameValueEntry elements, starting at the specified index of the target array.
Public method | GetEnumerator | Returns an IStringStringEnumerator that can iterate through the IStringStringCollection.
Top
See Also

Reference

IStringStringCollection Interface
CodeSmith.CustomProperties Namespace


IStringStringCollection.CopyTo Method

IStringStringCollectionCopyTo Method

Copies the entire IStringStringCollection to a one-dimensional Array of NameValueEntry elements, starting at the specified index of the target array.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
void CopyTo(
    NameValueEntry[] array,
    int arrayIndex
)
Sub CopyTo (
    array As NameValueEntry(),
    arrayIndex As Integer
)

Parameters

array
Type: CodeSmith.CustomPropertiesNameValueEntry
The one-dimensional Array that is the destination of the NameValueEntry elements copied from the IStringStringCollection. The Array must have zero-based indexing.
arrayIndex
Type: SystemInt32
The zero-based index in array at which copying begins.
Exceptions
Exception | Condition
ArgumentNullException | array is a null reference.
ArgumentOutOfRangeException | arrayIndex is less than zero.
ArgumentException | arrayIndex is equal to or greater than the length of array. -or- The number of elements in the source IStringStringCollection is greater than the available space from arrayIndex to the end of the destination array.
Remarks
Please refer to CopyTo(Array, Int32) for details.
See Also

Reference

IStringStringCollection Interface
CodeSmith.CustomProperties Namespace


IStringStringCollection.GetEnumerator Method

IStringStringCollectionGetEnumerator Method

Returns an IStringStringEnumerator that can iterate through the IStringStringCollection.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
IStringStringEnumerator GetEnumerator()
Function GetEnumerator As IStringStringEnumerator

Return Value

Type: IStringStringEnumerator
An IStringStringEnumerator for the entire IStringStringCollection.
Remarks
Please refer to GetEnumerator for details.
See Also

Reference

IStringStringCollection Interface
CodeSmith.CustomProperties Namespace


IStringStringDictionary Interface

Represents a strongly typed collection of NameValueEntry key-and-value pairs.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public interface IStringStringDictionary : IStringStringCollection
Public Interface IStringStringDictionary
    Inherits IStringStringCollection

The IStringStringDictionary type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the IStringStringCollection. (Inherited from IStringStringCollection.)
Public property | IsFixedSize | Gets a value indicating whether the IStringStringDictionary has a fixed size.
Public property | IsReadOnly | Gets a value indicating whether the IStringStringDictionary is read-only.
Public property | IsSynchronized | Gets a value indicating whether access to the IStringStringCollection is synchronized (thread-safe). (Inherited from IStringStringCollection.)
Public property | Item | Gets or sets the String value associated with the specified String key.
Public property | Keys | Gets an IStringCollection containing the keys in the IStringStringDictionary.
Public property | SyncRoot | Gets an object that can be used to synchronize access to the IStringStringCollection. (Inherited from IStringStringCollection.)
Public property | Values | Gets an IStringCollection containing the values in the IStringStringDictionary.
Top
Methods
 | Name | Description
Public method | Add | Adds an element with the specified String key and String value to the IStringStringDictionary.
Public method | Clear | Removes all elements from the IStringStringDictionary.
Public method | Contains | Determines whether the IStringStringDictionary contains the specified String key.
Public method | CopyTo | Copies the entire IStringStringCollection to a one-dimensional Array of NameValueEntry elements, starting at the specified index of the target array. (Inherited from IStringStringCollection.)
Public method | GetEnumerator | Returns an IStringStringEnumerator that can iterate through the IStringStringCollection. (Inherited from IStringStringCollection.)
Public method | Remove | Removes the element with the specified String key from the IStringStringDictionary.
Top
Remarks
IStringStringDictionary provides an IDictionary that is strongly typed for String keys and String values.
See Also

Reference

CodeSmith.CustomProperties Namespace


IStringStringDictionary Properties

The IStringStringDictionary type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the IStringStringCollection. (Inherited from IStringStringCollection.)
Public property | IsFixedSize | Gets a value indicating whether the IStringStringDictionary has a fixed size.
Public property | IsReadOnly | Gets a value indicating whether the IStringStringDictionary is read-only.
Public property | IsSynchronized | Gets a value indicating whether access to the IStringStringCollection is synchronized (thread-safe). (Inherited from IStringStringCollection.)
Public property | Item | Gets or sets the String value associated with the specified String key.
Public property | Keys | Gets an IStringCollection containing the keys in the IStringStringDictionary.
Public property | SyncRoot | Gets an object that can be used to synchronize access to the IStringStringCollection. (Inherited from IStringStringCollection.)
Public property | Values | Gets an IStringCollection containing the values in the IStringStringDictionary.
Top
See Also

Reference

IStringStringDictionary Interface
CodeSmith.CustomProperties Namespace


IStringStringDictionary.IsFixedSize Property

IStringStringDictionaryIsFixedSize Property

Gets a value indicating whether the IStringStringDictionary has a fixed size.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
bool IsFixedSize { get; }
ReadOnly Property IsFixedSize As Boolean
    Get

Property Value

Type: Boolean
true if the IStringStringDictionary has a fixed size; otherwise, false. The default is false.
Remarks
Please refer to IsFixedSize for details.
See Also

Reference

IStringStringDictionary Interface
CodeSmith.CustomProperties Namespace


IStringStringDictionary.IsReadOnly Property

IStringStringDictionaryIsReadOnly Property

Gets a value indicating whether the IStringStringDictionary is read-only.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
bool IsReadOnly { get; }
ReadOnly Property IsReadOnly As Boolean
    Get

Property Value

Type: Boolean
true if the IStringStringDictionary is read-only; otherwise, false. The default is false.
Remarks
Please refer to IsReadOnly for details.
See Also

Reference

IStringStringDictionary Interface
CodeSmith.CustomProperties Namespace


IStringStringDictionary.Item Property

IStringStringDictionaryItem Property

Gets or sets the String value associated with the specified String key.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
string this[
    string key
] { get; set; }
Default Property Item (
    key As String
) As String
    Get
    Set

Parameters

key
Type: SystemString
The String key whose value to get or set.

Property Value

Type: String
The String value associated with the specified key. If the specified key is not found, attempting to get it returns a null reference, and attempting to set it creates a new element using the specified key.
Exceptions
Exception | Condition
ArgumentNullException | key is a null reference.
NotSupportedException | The property is set and the IStringStringDictionary is read-only. -or- The property is set, key does not exist in the collection, and the IStringStringDictionary has a fixed size.
Remarks
Please refer to ItemObject for details.
See Also

Reference

IStringStringDictionary Interface
CodeSmith.CustomProperties Namespace


IStringStringDictionary.Keys Property

IStringStringDictionaryKeys Property

Gets an IStringCollection containing the keys in the IStringStringDictionary.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
IStringCollection Keys { get; }
ReadOnly Property Keys As IStringCollection
    Get

Property Value

Type: IStringCollection
An IStringCollection containing the keys in the IStringStringDictionary.
Remarks
Please refer to Keys for details.
See Also

Reference

IStringStringDictionary Interface
CodeSmith.CustomProperties Namespace


IStringStringDictionary.Values Property

IStringStringDictionaryValues Property

Gets an IStringCollection containing the values in the IStringStringDictionary.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
IStringCollection Values { get; }
ReadOnly Property Values As IStringCollection
    Get

Property Value

Type: IStringCollection
An IStringCollection containing the values in the IStringStringDictionary.
Remarks
Please refer to Values for details.
See Also

Reference

IStringStringDictionary Interface
CodeSmith.CustomProperties Namespace


IStringStringDictionary Methods

The IStringStringDictionary type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an element with the specified String key and String value to the IStringStringDictionary.
Public method | Clear | Removes all elements from the IStringStringDictionary.
Public method | Contains | Determines whether the IStringStringDictionary contains the specified String key.
Public method | CopyTo | Copies the entire IStringStringCollection to a one-dimensional Array of NameValueEntry elements, starting at the specified index of the target array. (Inherited from IStringStringCollection.)
Public method | GetEnumerator | Returns an IStringStringEnumerator that can iterate through the IStringStringCollection. (Inherited from IStringStringCollection.)
Public method | Remove | Removes the element with the specified String key from the IStringStringDictionary.
Top
See Also

Reference

IStringStringDictionary Interface
CodeSmith.CustomProperties Namespace


IStringStringDictionary.Add Method

IStringStringDictionaryAdd Method

Adds an element with the specified String key and String value to the IStringStringDictionary.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
void Add(
    string key,
    string value
)
Sub Add (
    key As String,
    value As String
)

Parameters

key
Type: SystemString
The String key of the element to add to the IStringStringDictionary.
value
Type: SystemString
The String value of the element to add to the IStringStringDictionary. This argument can be a null reference.
Exceptions
Exception | Condition
ArgumentException | An element with the specified key already exists in the IStringStringDictionary. -or- The IStringStringDictionary is set to use the IComparable interface, and key does not implement the IComparable interface.
ArgumentNullException | key is a null reference.
InvalidOperationException | The comparer throws an exception.
NotSupportedException | The IStringStringDictionary is read-only. -or- The IStringStringDictionary has a fixed size.
Remarks
Please refer to Add(Object, Object) for details.
See Also

Reference

IStringStringDictionary Interface
CodeSmith.CustomProperties Namespace


IStringStringDictionary.Clear Method

IStringStringDictionaryClear Method

Removes all elements from the IStringStringDictionary.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
void Clear()
Sub Clear
Exceptions
Exception | Condition
NotSupportedException | The IStringStringDictionary is read-only. -or- The IStringStringDictionary has a fixed size.
Remarks
Please refer to Clear for details.
See Also

Reference

IStringStringDictionary Interface
CodeSmith.CustomProperties Namespace


IStringStringDictionary.Contains Method

IStringStringDictionaryContains Method

Determines whether the IStringStringDictionary contains the specified String key.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
bool Contains(
    string key
)
Function Contains (
    key As String
) As Boolean

Parameters

key
Type: SystemString
The String key to locate in the IStringStringDictionary.

Return Value

Type: Boolean
true if the IStringStringDictionary contains an element with the specified key; otherwise, false.
Exceptions
Exception | Condition
ArgumentNullException | key is a null reference.
InvalidOperationException | The comparer throws an exception.
Remarks
Please refer to Contains(Object) for details.
See Also

Reference

IStringStringDictionary Interface
CodeSmith.CustomProperties Namespace


IStringStringDictionary.Remove Method

IStringStringDictionaryRemove Method

Removes the element with the specified String key from the IStringStringDictionary.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
void Remove(
    string key
)
Sub Remove (
    key As String
)

Parameters

key
Type: SystemString
The String key of the element to remove from the IStringStringDictionary.
Exceptions
Exception | Condition
ArgumentNullException | key is a null reference.
InvalidOperationException | The comparer throws an exception.
NotSupportedException | The IStringStringDictionary is read-only. -or- The IStringStringDictionary has a fixed size.
Remarks
Please refer to Remove(Object) for details.
See Also

Reference

IStringStringDictionary Interface
CodeSmith.CustomProperties Namespace


IStringStringEnumerator Interface

Supports type-safe iteration over a dictionary that contains NameValueEntry elements.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public interface IStringStringEnumerator
Public Interface IStringStringEnumerator

The IStringStringEnumerator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Gets the current NameValueEntry element in the collection.
Public property | Entry | Gets a NameValueEntry containing both the key and the value of the current dictionary entry.
Public property | Key | Gets the String key of the current dictionary entry.
Public property | Value | Gets the String value of the current dictionary entry.
Top
Methods
 | Name | Description
Public method | MoveNext | Advances the enumerator to the next element of the collection.
Public method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
Top
Remarks
IStringStringEnumerator provides an IDictionaryEnumerator that is strongly typed for String keys and String values.
See Also

Reference

CodeSmith.CustomProperties Namespace


IStringStringEnumerator Properties

The IStringStringEnumerator type exposes the following members.

Properties
 | Name | Description
Public property | Current | Gets the current NameValueEntry element in the collection.
Public property | Entry | Gets a NameValueEntry containing both the key and the value of the current dictionary entry.
Public property | Key | Gets the String key of the current dictionary entry.
Public property | Value | Gets the String value of the current dictionary entry.
Top
See Also

Reference

IStringStringEnumerator Interface
CodeSmith.CustomProperties Namespace


IStringStringEnumerator.Current Property

IStringStringEnumeratorCurrent Property

Gets the current NameValueEntry element in the collection.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
NameValueEntry Current { get; }
ReadOnly Property Current As NameValueEntry
    Get

Property Value

Type: NameValueEntry
The current NameValueEntry element in the collection.
Exceptions
Exception | Condition
InvalidOperationException | The enumerator is positioned before the first element of the collection or after the last element. -or- The collection was modified after the enumerator was created.
Remarks
Please refer to Current for details, but note that Current fails if the collection was modified since the last successful call to MoveNext or Reset.
See Also

Reference

IStringStringEnumerator Interface
CodeSmith.CustomProperties Namespace


IStringStringEnumerator.Entry Property

IStringStringEnumeratorEntry Property

Gets a NameValueEntry containing both the key and the value of the current dictionary entry.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
NameValueEntry Entry { get; }
ReadOnly Property Entry As NameValueEntry
    Get

Property Value

Type: NameValueEntry
A NameValueEntry containing both the key and the value of the current dictionary entry.
Exceptions
Exception | Condition
InvalidOperationException | The enumerator is positioned before the first element of the dictionary or after the last element. -or- The dictionary was modified after the enumerator was created.
Remarks
Please refer to Entry for details, but note that Entry fails if the collection was modified since the last successful call to MoveNext or Reset.
See Also

Reference

IStringStringEnumerator Interface
CodeSmith.CustomProperties Namespace


IStringStringEnumerator.Key Property

IStringStringEnumeratorKey Property

Gets the String key of the current dictionary entry.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
string Key { get; }
ReadOnly Property Key As String
    Get

Property Value

Type: String
The String key of the current element of the enumeration.
Exceptions
Exception | Condition
InvalidOperationException | The enumerator is positioned before the first element of the dictionary or after the last element. -or- The dictionary was modified after the enumerator was created.
Remarks
Please refer to Key for details, but note that Key fails if the collection was modified since the last successful call to MoveNext or Reset.
See Also

Reference

IStringStringEnumerator Interface
CodeSmith.CustomProperties Namespace


IStringStringEnumerator.Value Property

IStringStringEnumeratorValue Property

Gets the String value of the current dictionary entry.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
string Value { get; }
ReadOnly Property Value As String
    Get

Property Value

Type: String
The String value of the current element of the enumeration.
Exceptions
Exception | Condition
InvalidOperationException | The enumerator is positioned before the first element of the dictionary or after the last element. -or- The dictionary was modified after the enumerator was created.
Remarks
Please refer to Value for details, but note that Value fails if the collection was modified since the last successful call to MoveNext or Reset.
See Also

Reference

IStringStringEnumerator Interface
CodeSmith.CustomProperties Namespace


IStringStringEnumerator Methods

The IStringStringEnumerator type exposes the following members.

Methods
 | Name | Description
Public method | MoveNext | Advances the enumerator to the next element of the collection.
Public method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
Top
See Also

Reference

IStringStringEnumerator Interface
CodeSmith.CustomProperties Namespace


IStringStringEnumerator.MoveNext Method

IStringStringEnumeratorMoveNext Method

Advances the enumerator to the next element of the collection.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
bool MoveNext()
Function MoveNext As Boolean

Return Value

Type: Boolean
true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.
Exceptions
Exception | Condition
InvalidOperationException | The collection was modified after the enumerator was created.
Remarks
Please refer to MoveNext for details.
See Also

Reference

IStringStringEnumerator Interface
CodeSmith.CustomProperties Namespace


IStringStringEnumerator.Reset Method

IStringStringEnumeratorReset Method

Sets the enumerator to its initial position, which is before the first element in the collection.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
void Reset()
Sub Reset
Exceptions
Exception | Condition
InvalidOperationException | The collection was modified after the enumerator was created.
Remarks
Please refer to Reset for details.
See Also

Reference

IStringStringEnumerator Interface
CodeSmith.CustomProperties Namespace


IStringStringList Interface

Represents a strongly typed collection of NameValueEntry objects that can be individually accessed by index.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public interface IStringStringList : IStringStringCollection
Public Interface IStringStringList
    Inherits IStringStringCollection

The IStringStringList type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the IStringStringCollection. (Inherited from IStringStringCollection.)
Public property | IsFixedSize | Gets a value indicating whether the IStringStringList has a fixed size.
Public property | IsReadOnly | Gets a value indicating whether the IStringStringList is read-only.
Public property | IsSynchronized | Gets a value indicating whether access to the IStringStringCollection is synchronized (thread-safe). (Inherited from IStringStringCollection.)
Public property | Item | Gets or sets the NameValueEntry element at the specified index.
Public property | SyncRoot | Gets an object that can be used to synchronize access to the IStringStringCollection. (Inherited from IStringStringCollection.)
Top
Methods
 | Name | Description
Public method | Add | Adds a NameValueEntry to the end of the IStringStringList.
Public method | Clear | Removes all elements from the IStringStringList.
Public method | Contains | Determines whether the IStringStringList contains the specified NameValueEntry element.
Public method | CopyTo | Copies the entire IStringStringCollection to a one-dimensional Array of NameValueEntry elements, starting at the specified index of the target array. (Inherited from IStringStringCollection.)
Public method | GetEnumerator | Returns an IStringStringEnumerator that can iterate through the IStringStringCollection. (Inherited from IStringStringCollection.)
Public method | IndexOf | Returns the zero-based index of the first occurrence of the specified NameValueEntry in the IStringStringList.
Public method | Insert | Inserts a NameValueEntry element into the IStringStringList at the specified index.
Public method | Remove | Removes the first occurrence of the specified NameValueEntry from the IStringStringList.
Public method | RemoveAt | Removes the element at the specified index of the IStringStringList.
Top
Remarks
IStringStringList provides an IList that is strongly typed for NameValueEntry elements.
See Also

Reference

CodeSmith.CustomProperties Namespace


IStringStringList Properties

The IStringStringList type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the IStringStringCollection. (Inherited from IStringStringCollection.)
Public property | IsFixedSize | Gets a value indicating whether the IStringStringList has a fixed size.
Public property | IsReadOnly | Gets a value indicating whether the IStringStringList is read-only.
Public property | IsSynchronized | Gets a value indicating whether access to the IStringStringCollection is synchronized (thread-safe). (Inherited from IStringStringCollection.)
Public property | Item | Gets or sets the NameValueEntry element at the specified index.
Public property | SyncRoot | Gets an object that can be used to synchronize access to the IStringStringCollection. (Inherited from IStringStringCollection.)
Top
See Also

Reference

IStringStringList Interface
CodeSmith.CustomProperties Namespace


IStringStringList.IsFixedSize Property

IStringStringListIsFixedSize Property

Gets a value indicating whether the IStringStringList has a fixed size.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
bool IsFixedSize { get; }
ReadOnly Property IsFixedSize As Boolean
    Get

Property Value

Type: Boolean
true if the IStringStringList has a fixed size; otherwise, false. The default is false.
Remarks
Please refer to IsFixedSize for details.
See Also

Reference

IStringStringList Interface
CodeSmith.CustomProperties Namespace


IStringStringList.IsReadOnly Property

IStringStringListIsReadOnly Property

Gets a value indicating whether the IStringStringList is read-only.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
bool IsReadOnly { get; }
ReadOnly Property IsReadOnly As Boolean
    Get

Property Value

Type: Boolean
true if the IStringStringList is read-only; otherwise, false. The default is false.
Remarks
Please refer to IsReadOnly for details.
See Also

Reference

IStringStringList Interface
CodeSmith.CustomProperties Namespace


IStringStringList.Item Property

IStringStringListItem Property

Gets or sets the NameValueEntry element at the specified index.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
NameValueEntry this[
    int index
] { get; set; }
Default Property Item (
    index As Integer
) As NameValueEntry
    Get
    Set

Parameters

index
Type: SystemInt32
The zero-based index of the NameValueEntry element to get or set.

Property Value

Type: NameValueEntry
The NameValueEntry element at the specified index.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than Count.
NotSupportedException | The property is set and the IStringStringList is read-only.
Remarks
Please refer to ItemInt32 for details.
See Also

Reference

IStringStringList Interface
CodeSmith.CustomProperties Namespace


IStringStringList Methods

The IStringStringList type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds a NameValueEntry to the end of the IStringStringList.
Public method | Clear | Removes all elements from the IStringStringList.
Public method | Contains | Determines whether the IStringStringList contains the specified NameValueEntry element.
Public method | CopyTo | Copies the entire IStringStringCollection to a one-dimensional Array of NameValueEntry elements, starting at the specified index of the target array. (Inherited from IStringStringCollection.)
Public method | GetEnumerator | Returns an IStringStringEnumerator that can iterate through the IStringStringCollection. (Inherited from IStringStringCollection.)
Public method | IndexOf | Returns the zero-based index of the first occurrence of the specified NameValueEntry in the IStringStringList.
Public method | Insert | Inserts a NameValueEntry element into the IStringStringList at the specified index.
Public method | Remove | Removes the first occurrence of the specified NameValueEntry from the IStringStringList.
Public method | RemoveAt | Removes the element at the specified index of the IStringStringList.
Top
See Also

Reference

IStringStringList Interface
CodeSmith.CustomProperties Namespace


IStringStringList.Add Method

IStringStringListAdd Method

Adds a NameValueEntry to the end of the IStringStringList.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
int Add(
    NameValueEntry entry
)
Function Add (
    entry As NameValueEntry
) As Integer

Parameters

entry
Type: CodeSmith.CustomPropertiesNameValueEntry
The NameValueEntry object to be added to the end of the IStringStringList.

Return Value

Type: Int32
The IStringStringList index at which the entry has been added.
Exceptions
Exception | Condition
NotSupportedException | The IStringStringList is read-only. -or- The IStringStringList has a fixed size.
Remarks
Please refer to Add(Object) for details.
See Also

Reference

IStringStringList Interface
CodeSmith.CustomProperties Namespace


IStringStringList.Clear Method

IStringStringListClear Method

Removes all elements from the IStringStringList.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
void Clear()
Sub Clear
Exceptions
Exception | Condition
NotSupportedException | The IStringStringList is read-only. -or- The IStringStringList has a fixed size.
Remarks
Please refer to Clear for details.
See Also

Reference

IStringStringList Interface
CodeSmith.CustomProperties Namespace


IStringStringList.Contains Method

IStringStringListContains Method

Determines whether the IStringStringList contains the specified NameValueEntry element.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
bool Contains(
    NameValueEntry entry
)
Function Contains (
    entry As NameValueEntry
) As Boolean

Parameters

entry
Type: CodeSmith.CustomPropertiesNameValueEntry
The NameValueEntry object to locate in the IStringStringList.

Return Value

Type: Boolean
true if entry is found in the IStringStringList; otherwise, false.
Remarks
Please refer to Contains(Object) for details.
See Also

Reference

IStringStringList Interface
CodeSmith.CustomProperties Namespace


IStringStringList.IndexOf Method

IStringStringListIndexOf Method

Returns the zero-based index of the first occurrence of the specified NameValueEntry in the IStringStringList.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
int IndexOf(
    NameValueEntry entry
)
Function IndexOf (
    entry As NameValueEntry
) As Integer

Parameters

entry
Type: CodeSmith.CustomPropertiesNameValueEntry
The NameValueEntry object to locate in the IStringStringList.

Return Value

Type: Int32
The zero-based index of the first occurrence of entry in the IStringStringList, if found; otherwise, -1.
Remarks
Please refer to IndexOf(Object) for details.
See Also

Reference

IStringStringList Interface
CodeSmith.CustomProperties Namespace


IStringStringList.Insert Method

IStringStringListInsert Method

Inserts a NameValueEntry element into the IStringStringList at the specified index.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
void Insert(
    int index,
    NameValueEntry entry
)
Sub Insert (
    index As Integer,
    entry As NameValueEntry
)

Parameters

index
Type: SystemInt32
The zero-based index at which entry should be inserted.
entry
Type: CodeSmith.CustomPropertiesNameValueEntry
The NameValueEntry object to insert into the IStringStringList.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | index is less than zero. -or- index is greater than Count.
NotSupportedException | The IStringStringList is read-only. -or- The IStringStringList has a fixed size.
Remarks
Please refer to Insert(Int32, Object) for details.
See Also

Reference

IStringStringList Interface
CodeSmith.CustomProperties Namespace


IStringStringList.Remove Method

IStringStringListRemove Method

Removes the first occurrence of the specified NameValueEntry from the IStringStringList.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
void Remove(
    NameValueEntry entry
)
Sub Remove (
    entry As NameValueEntry
)

Parameters

entry
Type: CodeSmith.CustomPropertiesNameValueEntry
The NameValueEntry object to remove from the IStringStringList.
Exceptions
Exception | Condition
NotSupportedException | The IStringStringList is read-only. -or- The IStringStringList has a fixed size.
Remarks
Please refer to Remove(Object) for details.
See Also

Reference

IStringStringList Interface
CodeSmith.CustomProperties Namespace


IStringStringList.RemoveAt Method

IStringStringListRemoveAt Method

Removes the element at the specified index of the IStringStringList.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
void RemoveAt(
    int index
)
Sub RemoveAt (
    index As Integer
)

Parameters

index
Type: SystemInt32
The zero-based index of the element to remove.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than Count.
NotSupportedException | The IStringStringList is read-only. -or- The IStringStringList has a fixed size.
Remarks
Please refer to RemoveAt(Int32) for details.
See Also

Reference

IStringStringList Interface
CodeSmith.CustomProperties Namespace


NameValueCollection Class

Note: This API is now obsolete.

Implements a strongly typed collection of NameValueEntry key-and-value pairs that retain their insertion order and are accessible by index and by key.
Inheritance Hierarchy
SystemObject
CodeSmith.CustomPropertiesNameValueCollection

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
[TypeConverterAttribute(typeof(NameValueCollectionTypeConverter))]
[ObsoleteAttribute("The NameValueCollection has been deprecated, use the System.Collections.Generic.Dictionary<T,K> or System.Collections.Specialized.NameValueCollection instead.",
    false)]
public class NameValueCollection : IStringStringList,
    IStringStringCollection, IList, ICollection, IEnumerable, ICloneable
<SerializableAttribute>
<TypeConverterAttribute(GetType(NameValueCollectionTypeConverter))>
<ObsoleteAttribute("The NameValueCollection has been deprecated, use the System.Collections.Generic.Dictionary<T,K> or System.Collections.Specialized.NameValueCollection instead.",
    false)>
Public Class NameValueCollection
    Implements IStringStringList, IStringStringCollection, IList, ICollection,
    IEnumerable, ICloneable

The NameValueCollection type exposes the following members.

Constructors
 | Name | Description
Public method | NameValueCollection | Initializes a new instance of the NameValueCollection class that is empty and has the default initial capacity.
Public method | NameValueCollection(Int32) | Initializes a new instance of the NameValueCollection class that is empty and has the specified initial capacity.
Public method | NameValueCollection(NameValueCollection) | Initializes a new instance of the NameValueCollection class that contains elements copied from the specified collection and that has the same initial capacity as the number of elements copied.
Public method | NameValueCollection(NameValueEntry) | Initializes a new instance of the NameValueCollection class that contains elements copied from the specified NameValueEntry array and that has the same initial capacity as the number of elements copied.
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the capacity of the NameValueCollection.
Public property | Count | Gets the number of key-and-value pairs contained in the NameValueCollection.
Protected property | InnerKeys | Gets the list of keys contained in the NameValueCollection instance.
Protected property | InnerValues | Gets the list of values contained in the NameValueCollection instance.
Public property | IsFixedSize | Gets a value indicating whether the NameValueCollection has a fixed size.
Public property | IsReadOnly | Gets a value indicating whether the NameValueCollection is read-only.
Public property | IsSynchronized | Gets a value indicating whether access to the NameValueCollection is synchronized (thread-safe).
Public property | Item | Gets or sets the NameValueEntry element at the specified index.
Public property | Keys | Gets an IStringCollection containing the keys in the NameValueCollection.
Public property | SyncRoot | Gets an object that can be used to synchronize access to the NameValueCollection.
Public property | Values | Gets an IStringCollection containing the values in the NameValueCollection.
Top
Methods
 | Name | Description
Public method | Add(NameValueEntry) | Adds a NameValueEntry to the end of the NameValueCollection.
Public method | Add(String, String) | Adds an element with the specified String key and String value to the end of the NameValueCollection.
Public method | AddRange(NameValueCollection) | Adds the elements of another collection to the end of the NameValueCollection.
Public method | AddRange(NameValueEntry) | Adds the elements of a NameValueEntry array to the end of the NameValueCollection.
Public method | Clear | Removes all elements from the NameValueCollection.
Public method | Clone | Creates a shallow copy of the NameValueCollection.
Public method | Contains | Determines whether the NameValueCollection contains the specified NameValueEntry element.
Public method | ContainsKey | Determines whether the NameValueCollection contains the specified String key.
Public method | ContainsValue | Determines whether the NameValueCollection contains the specified String value.
Public method | CopyTo | Copies the entire NameValueCollection to a one-dimensional Array of NameValueEntry elements, starting at the specified index of the target array.
Public method | Equals(NameValueCollection) | Determines whether the specified NameValueCollection is equal to the current NameValueCollection.
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetByIndex | Gets the String value at the specified index of the NameValueCollection.
Public method | GetByKey | Gets the String value associated with the first occurrence of the specified String key.
Public method | GetEnumerator | Returns an IStringStringEnumerator that can iterate through the NameValueCollection.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetKey | Gets the String key at the specified index of the NameValueCollection.
Public method | GetKeyList | Gets the keys in the NameValueCollection.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValueList | Gets the values in the NameValueCollection.
Public method | IndexOf | Returns the zero-based index of the first occurrence of the specified NameValueEntry in the NameValueCollection.
Public method | IndexOfKey | Returns the zero-based index of the first occurrence of the specified String key in the NameValueCollection.
Public method | IndexOfValue | Returns the zero-based index of first occurrence of the specified String value in the NameValueCollection.
Public method | Insert | Inserts a NameValueEntry element into the NameValueCollection at the specified index.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of the specified NameValueEntry from the NameValueCollection.
Public method | RemoveAt | Removes the element at the specified index of the NameValueCollection.
Public method | SetByIndex | Sets the String value at the specified index of the NameValueCollection.
Public method | SetByKey | Sets the String value associated with the first occurrence of the specified String key.
 | Synchronized | Returns a synchronized (thread-safe) wrapper for the specified NameValueCollection.
Public method | ToArray | Copies the elements of the NameValueCollection to a new Array of NameValueEntry elements.
Public method | ToString | (Overrides ObjectToString.)
Public method | TrimToSize | Sets the capacity to the actual number of elements in the NameValueCollection.
Top
Remarks

NameValueCollection provides an ArrayList that is strongly typed for NameValueEntry elements and allows direct access to its String keys and String values.

The collection may contain multiple identical keys. All key access methods return the first occurrence of the specified key, if found. Access by index is an O(1) operation but access by key or value are both O(N) operations, where N is the current value of the Count property.

See Also

Reference

CodeSmith.CustomProperties Namespace


NameValueCollection Constructor

Initializes a new instance of the NameValueCollection class.
Overload List
 | Name | Description
Public method | NameValueCollection | Initializes a new instance of the NameValueCollection class that is empty and has the default initial capacity.
Public method | NameValueCollection(Int32) | Initializes a new instance of the NameValueCollection class that is empty and has the specified initial capacity.
Public method | NameValueCollection(NameValueCollection) | Initializes a new instance of the NameValueCollection class that contains elements copied from the specified collection and that has the same initial capacity as the number of elements copied.
Public method | NameValueCollection(NameValueEntry) | Initializes a new instance of the NameValueCollection class that contains elements copied from the specified NameValueEntry array and that has the same initial capacity as the number of elements copied.
Top
See Also

Reference

NameValueCollection Class
CodeSmith.CustomProperties Namespace


NameValueCollection Constructor

Initializes a new instance of the NameValueCollection class that is empty and has the default initial capacity.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public NameValueCollection()
Public Sub New
Remarks
Please refer to ArrayList for details.
See Also

Reference

NameValueCollection Class
NameValueCollection Overload
CodeSmith.CustomProperties Namespace


NameValueCollection Constructor (Int32)

Initializes a new instance of the NameValueCollection class that is empty and has the specified initial capacity.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public NameValueCollection(
    int capacity
)
Public Sub New (
    capacity As Integer
)

Parameters

capacity
Type: SystemInt32
The number of elements that the new NameValueCollection is initially capable of storing.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | capacity is less than zero.
Remarks
Please refer to ArrayList(Int32) for details.
See Also

Reference

NameValueCollection Class
NameValueCollection Overload
CodeSmith.CustomProperties Namespace


NameValueCollection Constructor (NameValueCollection)

Initializes a new instance of the NameValueCollection class that contains elements copied from the specified collection and that has the same initial capacity as the number of elements copied.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public NameValueCollection(
    NameValueCollection collection
)
Public Sub New (
    collection As NameValueCollection
)

Parameters

collection
Type: CodeSmith.CustomPropertiesNameValueCollection
The NameValueCollection whose elements are copied to the new collection.
Exceptions
Exception | Condition
ArgumentNullException | collection is a null reference.
Remarks
Please refer to ArrayList(ICollection) for details.
See Also

Reference

NameValueCollection Class
NameValueCollection Overload
CodeSmith.CustomProperties Namespace


NameValueCollection Constructor (NameValueEntry[])

NameValueCollection Constructor (NameValueEntry)

Initializes a new instance of the NameValueCollection class that contains elements copied from the specified NameValueEntry array and that has the same initial capacity as the number of elements copied.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public NameValueCollection(
    NameValueEntry[] array
)
Public Sub New (
    array As NameValueEntry()
)

Parameters

array
Type: CodeSmith.CustomPropertiesNameValueEntry
An Array of NameValueEntry elements that are copied to the new collection.
Exceptions
Exception | Condition
ArgumentNullException | array is a null reference.
Remarks
Please refer to ArrayList(ICollection) for details.
See Also

Reference

NameValueCollection Class
NameValueCollection Overload
CodeSmith.CustomProperties Namespace


NameValueCollection Properties

The NameValueCollection type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the capacity of the NameValueCollection.
Public property | Count | Gets the number of key-and-value pairs contained in the NameValueCollection.
Protected property | InnerKeys | Gets the list of keys contained in the NameValueCollection instance.
Protected property | InnerValues | Gets the list of values contained in the NameValueCollection instance.
Public property | IsFixedSize | Gets a value indicating whether the NameValueCollection has a fixed size.
Public property | IsReadOnly | Gets a value indicating whether the NameValueCollection is read-only.
Public property | IsSynchronized | Gets a value indicating whether access to the NameValueCollection is synchronized (thread-safe).
Public property | Item | Gets or sets the NameValueEntry element at the specified index.
Public property | Keys | Gets an IStringCollection containing the keys in the NameValueCollection.
Public property | SyncRoot | Gets an object that can be used to synchronize access to the NameValueCollection.
Public property | Values | Gets an IStringCollection containing the values in the NameValueCollection.
Top
See Also

Reference

NameValueCollection Class
CodeSmith.CustomProperties Namespace


NameValueCollection.Capacity Property

NameValueCollectionCapacity Property

Gets or sets the capacity of the NameValueCollection.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual int Capacity { get; set; }
Public Overridable Property Capacity As Integer
    Get
    Set

Property Value

Type: Int32
The number of elements that the NameValueCollection can contain.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Capacity is set to a value that is less than Count.
Remarks
Please refer to Capacity for details.
See Also

Reference

NameValueCollection Class
CodeSmith.CustomProperties Namespace


NameValueCollection.Count Property

NameValueCollectionCount Property

Gets the number of key-and-value pairs contained in the NameValueCollection.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual int Count { get; }
Public Overridable ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32
The number of key-and-value pairs contained in the NameValueCollection.

Implements

IStringStringCollectionCount
ICollectionCount
Remarks
Please refer to Count for details.
See Also

Reference

NameValueCollection Class
CodeSmith.CustomProperties Namespace


NameValueCollection.InnerKeys Property

NameValueCollectionInnerKeys Property

Gets the list of keys contained in the NameValueCollection instance.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual string[] InnerKeys { get; }
Protected Overridable ReadOnly Property InnerKeys As String()
    Get

Property Value

Type: String
A one-dimensional Array with zero-based indexing that contains all String elements in the NameValueCollection.
Remarks
Use InnerKeys to access the key array of a NameValueCollection instance that might be a read-only or synchronized wrapper. This is necessary because the key and value arrays of wrapper classes are always null references.
See Also

Reference

NameValueCollection Class
CodeSmith.CustomProperties Namespace


NameValueCollection.InnerValues Property

NameValueCollectionInnerValues Property

Gets the list of values contained in the NameValueCollection instance.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual string[] InnerValues { get; }
Protected Overridable ReadOnly Property InnerValues As String()
    Get

Property Value

Type: String
A one-dimensional Array with zero-based indexing that contains all String elements in the NameValueCollection.
Remarks
Use InnerValues to access the value array of a NameValueCollection instance that might be a read-only or synchronized wrapper. This is necessary because the key and value arrays of wrapper classes are always null references.
See Also

Reference

NameValueCollection Class
CodeSmith.CustomProperties Namespace


NameValueCollection.IsFixedSize Property

NameValueCollectionIsFixedSize Property

Gets a value indicating whether the NameValueCollection has a fixed size.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual bool IsFixedSize { get; }
Public Overridable ReadOnly Property IsFixedSize As Boolean
    Get

Property Value

Type: Boolean
true if the NameValueCollection has a fixed size; otherwise, false. The default is false.

Implements

IStringStringListIsFixedSize
IListIsFixedSize
Remarks
Please refer to IsFixedSize for details.
See Also

Reference

NameValueCollection Class
CodeSmith.CustomProperties Namespace


NameValueCollection.IsReadOnly Property

NameValueCollectionIsReadOnly Property

Gets a value indicating whether the NameValueCollection is read-only.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual bool IsReadOnly { get; }
Public Overridable ReadOnly Property IsReadOnly As Boolean
    Get

Property Value

Type: Boolean
true if the NameValueCollection is read-only; otherwise, false. The default is false.

Implements

IStringStringListIsReadOnly
IListIsReadOnly
Remarks
Please refer to IsReadOnly for details.
See Also

Reference

NameValueCollection Class
CodeSmith.CustomProperties Namespace


NameValueCollection.IsSynchronized Property

NameValueCollectionIsSynchronized Property

Gets a value indicating whether access to the NameValueCollection is synchronized (thread-safe).

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual bool IsSynchronized { get; }
Public Overridable ReadOnly Property IsSynchronized As Boolean
    Get

Property Value

Type: Boolean
true if access to the NameValueCollection is synchronized (thread-safe); otherwise, false. The default is false.

Implements

IStringStringCollectionIsSynchronized
ICollectionIsSynchronized
Remarks
Please refer to IsSynchronized for details.
See Also

Reference

NameValueCollection Class
CodeSmith.CustomProperties Namespace


NameValueCollection.Item Property

NameValueCollectionItem Property

Gets or sets the NameValueEntry element at the specified index.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual NameValueEntry this[
    int index
] { get; set; }
Public Overridable Default Property Item (
    index As Integer
) As NameValueEntry
    Get
    Set

Parameters

index
Type: SystemInt32
The zero-based index of the NameValueEntry element to get or set.

Property Value

Type: NameValueEntry
The NameValueEntry element at the specified index.

Implements

IStringStringListItemInt32
Exceptions
Exception | Condition
ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than Count.
NotSupportedException | The property is set and the NameValueCollection is read-only.
Remarks
Please refer to ItemInt32 for details.
See Also

Reference

NameValueCollection Class
CodeSmith.CustomProperties Namespace


NameValueCollection.Keys Property

NameValueCollectionKeys Property

Gets an IStringCollection containing the keys in the NameValueCollection.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual IStringCollection Keys { get; }
Public Overridable ReadOnly Property Keys As IStringCollection
    Get

Property Value

Type: IStringCollection
An IStringCollection containing the keys in the NameValueCollection.
Remarks
Please refer to Keys for details.
See Also

Reference

NameValueCollection Class
CodeSmith.CustomProperties Namespace


NameValueCollection.SyncRoot Property

NameValueCollectionSyncRoot Property

Gets an object that can be used to synchronize access to the NameValueCollection.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual Object SyncRoot { get; }
Public Overridable ReadOnly Property SyncRoot As Object
    Get

Property Value

Type: Object
An object that can be used to synchronize access to the NameValueCollection.

Implements

IStringStringCollectionSyncRoot
ICollectionSyncRoot
Remarks
Please refer to SyncRoot for details.
See Also

Reference

NameValueCollection Class
CodeSmith.CustomProperties Namespace


NameValueCollection.Values Property

NameValueCollectionValues Property

Gets an IStringCollection containing the values in the NameValueCollection.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual IStringCollection Values { get; }
Public Overridable ReadOnly Property Values As IStringCollection
    Get

Property Value

Type: IStringCollection
An IStringCollection containing the values in the NameValueCollection.
Remarks
Please refer to Values for details.
See Also

Reference

NameValueCollection Class
CodeSmith.CustomProperties Namespace


NameValueCollection Methods

The NameValueCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add(NameValueEntry) | Adds a NameValueEntry to the end of the NameValueCollection.
Public method | Add(String, String) | Adds an element with the specified String key and String value to the end of the NameValueCollection.
Public method | AddRange(NameValueCollection) | Adds the elements of another collection to the end of the NameValueCollection.
Public method | AddRange(NameValueEntry) | Adds the elements of a NameValueEntry array to the end of the NameValueCollection.
Public method | Clear | Removes all elements from the NameValueCollection.
Public method | Clone | Creates a shallow copy of the NameValueCollection.
Public method | Contains | Determines whether the NameValueCollection contains the specified NameValueEntry element.
Public method | ContainsKey | Determines whether the NameValueCollection contains the specified String key.
Public method | ContainsValue | Determines whether the NameValueCollection contains the specified String value.
Public method | CopyTo | Copies the entire NameValueCollection to a one-dimensional Array of NameValueEntry elements, starting at the specified index of the target array.
Public method | Equals(NameValueCollection) | Determines whether the specified NameValueCollection is equal to the current NameValueCollection.
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetByIndex | Gets the String value at the specified index of the NameValueCollection.
Public method | GetByKey | Gets the String value associated with the first occurrence of the specified String key.
Public method | GetEnumerator | Returns an IStringStringEnumerator that can iterate through the NameValueCollection.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetKey | Gets the String key at the specified index of the NameValueCollection.
Public method | GetKeyList | Gets the keys in the NameValueCollection.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValueList | Gets the values in the NameValueCollection.
Public method | IndexOf | Returns the zero-based index of the first occurrence of the specified NameValueEntry in the NameValueCollection.
Public method | IndexOfKey | Returns the zero-based index of the first occurrence of the specified String key in the NameValueCollection.
Public method | IndexOfValue | Returns the zero-based index of first occurrence of the specified String value in the NameValueCollection.
Public method | Insert | Inserts a NameValueEntry element into the NameValueCollection at the specified index.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of the specified NameValueEntry from the NameValueCollection.
Public method | RemoveAt | Removes the element at the specified index of the NameValueCollection.
Public method | SetByIndex | Sets the String value at the specified index of the NameValueCollection.
Public method | SetByKey | Sets the String value associated with the first occurrence of the specified String key.
 | Synchronized | Returns a synchronized (thread-safe) wrapper for the specified NameValueCollection.
Public method | ToArray | Copies the elements of the NameValueCollection to a new Array of NameValueEntry elements.
Public method | ToString | (Overrides ObjectToString.)
Public method | TrimToSize | Sets the capacity to the actual number of elements in the NameValueCollection.
Top
See Also

Reference

NameValueCollection Class
CodeSmith.CustomProperties Namespace


NameValueCollection.Add Method

NameValueCollectionAdd Method

Adds an element to the end of the NameValueCollection.
Overload List
 | Name | Description
Public method | Add(NameValueEntry) | Adds a NameValueEntry to the end of the NameValueCollection.
Public method | Add(String, String) | Adds an element with the specified String key and String value to the end of the NameValueCollection.
Top
See Also

Reference

NameValueCollection Class
CodeSmith.CustomProperties Namespace


NameValueCollection.Add Method (NameValueEntry)

NameValueCollectionAdd Method (NameValueEntry)

Adds a NameValueEntry to the end of the NameValueCollection.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual int Add(
    NameValueEntry entry
)
Public Overridable Function Add (
    entry As NameValueEntry
) As Integer

Parameters

entry
Type: CodeSmith.CustomPropertiesNameValueEntry
The NameValueEntry object to be added to the end of the NameValueCollection.

Return Value

Type: Int32
The NameValueCollection index at which the entry has been added.

Implements

IStringStringListAdd(NameValueEntry)
Exceptions
Exception | Condition
NotSupportedException | The NameValueCollection is read-only. -or- The NameValueCollection has a fixed size.
Remarks
Please refer to Add(Object) for details.
See Also

Reference

NameValueCollection Class
Add Overload
CodeSmith.CustomProperties Namespace


NameValueCollection.Add Method (String, String)

NameValueCollectionAdd Method (String, String)

Adds an element with the specified String key and String value to the end of the NameValueCollection.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public int Add(
    string key,
    string value
)
Public Function Add (
    key As String,
    value As String
) As Integer

Parameters

key
Type: SystemString
The String key of the element to add to the end of the NameValueCollection.
value
Type: SystemString
The String value of the element to add to the end of the NameValueCollection. This argument can be a null reference.

Return Value

Type: Int32
The NameValueCollection index at which the new element has been added.
Exceptions
Exception | Condition
ArgumentNullException | key is a null reference.
NotSupportedException | The NameValueCollection is read-only. -or- The NameValueCollection has a fixed size.
Remarks
Please refer to Add(Object, Object) for details but note that the NameValueCollection may contain multiple identical keys.
See Also

Reference

NameValueCollection Class
Add Overload
CodeSmith.CustomProperties Namespace


NameValueCollection.AddRange Method

NameValueCollectionAddRange Method

Adds a range of elements to the end of the NameValueCollection.
Overload List
 | Name | Description
Public method | AddRange(NameValueCollection) | Adds the elements of another collection to the end of the NameValueCollection.
Public method | AddRange(NameValueEntry) | Adds the elements of a NameValueEntry array to the end of the NameValueCollection.
Top
See Also

Reference

NameValueCollection Class
CodeSmith.CustomProperties Namespace


NameValueCollection.AddRange Method (NameValueCollection)

NameValueCollectionAddRange Method (NameValueCollection)

Adds the elements of another collection to the end of the NameValueCollection.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual void AddRange(
    NameValueCollection collection
)
Public Overridable Sub AddRange (
    collection As NameValueCollection
)

Parameters

collection
Type: CodeSmith.CustomPropertiesNameValueCollection
The NameValueCollection whose elements should be added to the end of the current collection.
Exceptions
Exception | Condition
ArgumentNullException | collection is a null reference.
NotSupportedException | The NameValueCollection is read-only. -or- The NameValueCollection has a fixed size.
Remarks
Please refer to AddRange(ICollection) for details.
See Also

Reference

NameValueCollection Class
AddRange Overload
CodeSmith.CustomProperties Namespace


NameValueCollection.AddRange Method (NameValueEntry[])

NameValueCollectionAddRange Method (NameValueEntry)

Adds the elements of a NameValueEntry array to the end of the NameValueCollection.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual void AddRange(
    NameValueEntry[] array
)
Public Overridable Sub AddRange (
    array As NameValueEntry()
)

Parameters

array
Type: CodeSmith.CustomPropertiesNameValueEntry
An Array of NameValueEntry elements that should be added to the end of the NameValueCollection.
Exceptions
Exception | Condition
ArgumentNullException | array is a null reference.
NotSupportedException | The NameValueCollection is read-only. -or- The NameValueCollection has a fixed size.
Remarks
Please refer to AddRange(ICollection) for details.
See Also

Reference

NameValueCollection Class
AddRange Overload
CodeSmith.CustomProperties Namespace


NameValueCollection.Clear Method

NameValueCollectionClear Method

Removes all elements from the NameValueCollection.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual void Clear()
Public Overridable Sub Clear

Implements

IStringStringListClear
IListClear
Exceptions
Exception | Condition
NotSupportedException | The NameValueCollection is read-only. -or- The NameValueCollection has a fixed size.
Remarks
Please refer to Clear for details.
See Also

Reference

NameValueCollection Class
CodeSmith.CustomProperties Namespace


NameValueCollection.Clone Method

NameValueCollectionClone Method

Creates a shallow copy of the NameValueCollection.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual Object Clone()
Public Overridable Function Clone As Object

Return Value

Type: Object
A shallow copy of the NameValueCollection.

Implements

ICloneableClone
Remarks
Please refer to Clone for details.
See Also

Reference

NameValueCollection Class
CodeSmith.CustomProperties Namespace


NameValueCollection.Contains Method

NameValueCollectionContains Method

Determines whether the NameValueCollection contains the specified NameValueEntry element.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool Contains(
    NameValueEntry entry
)
Public Function Contains (
    entry As NameValueEntry
) As Boolean

Parameters

entry
Type: CodeSmith.CustomPropertiesNameValueEntry
The NameValueEntry object to locate in the NameValueCollection.

Return Value

Type: Boolean
true if entry is found in the NameValueCollection; otherwise, false.

Implements

IStringStringListContains(NameValueEntry)
Remarks

Please refer to Contains(Object) for details.

Contains uses the equality operators defined by String and String to locate the specified entry.

See Also

Reference

NameValueCollection Class
CodeSmith.CustomProperties Namespace


NameValueCollection.ContainsKey Method

NameValueCollectionContainsKey Method

Determines whether the NameValueCollection contains the specified String key.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool ContainsKey(
    string key
)
Public Function ContainsKey (
    key As String
) As Boolean

Parameters

key
Type: SystemString
The String key to locate in the NameValueCollection.

Return Value

Type: Boolean
true if the NameValueCollection contains an element with the specified key; otherwise, false.
Exceptions
Exception | Condition
ArgumentNullException | key is a null reference.
Remarks
Please refer to ContainsKey(Object) for details but note that the NameValueCollection requires linear time to locate a key.
See Also

Reference

NameValueCollection Class
CodeSmith.CustomProperties Namespace


NameValueCollection.ContainsValue Method

NameValueCollectionContainsValue Method

Determines whether the NameValueCollection contains the specified String value.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool ContainsValue(
    string value
)
Public Function ContainsValue (
    value As String
) As Boolean

Parameters

value
Type: SystemString
The String value to locate in the NameValueCollection. This argument can be a null reference.

Return Value

Type: Boolean
true if the NameValueCollection contains an element with the specified value; otherwise, false.
Remarks
Please refer to ContainsValue(Object) for details.
See Also

Reference

NameValueCollection Class
CodeSmith.CustomProperties Namespace


NameValueCollection.CopyTo Method

NameValueCollectionCopyTo Method

Copies the entire NameValueCollection to a one-dimensional Array of NameValueEntry elements, starting at the specified index of the target array.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual void CopyTo(
    NameValueEntry[] array,
    int arrayIndex
)
Public Overridable Sub CopyTo (
    array As NameValueEntry(),
    arrayIndex As Integer
)

Parameters

array
Type: CodeSmith.CustomPropertiesNameValueEntry
The one-dimensional Array that is the destination of the NameValueEntry elements copied from the NameValueCollection. The Array must have zero-based indexing.
arrayIndex
Type: SystemInt32
The zero-based index in array at which copying begins.

Implements

IStringStringCollectionCopyTo(NameValueEntry, Int32)
Exceptions
Exception | Condition
ArgumentNullException | array is a null reference.
ArgumentOutOfRangeException | arrayIndex is less than zero.
ArgumentException | arrayIndex is equal to or greater than the length of array. -or- The number of elements in the source NameValueCollection is greater than the available space from arrayIndex to the end of the destination array.
Remarks
Please refer to CopyTo(Array) for details.
See Also

Reference

NameValueCollection Class
CodeSmith.CustomProperties Namespace


NameValueCollection.Equals Method

NameValueCollectionEquals Method

Overload List
 | Name | Description
Public method | Equals(NameValueCollection) | Determines whether the specified NameValueCollection is equal to the current NameValueCollection.
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Top
See Also

Reference

NameValueCollection Class
CodeSmith.CustomProperties Namespace


NameValueCollection.Equals Method (NameValueCollection)

NameValueCollectionEquals Method (NameValueCollection)

Determines whether the specified NameValueCollection is equal to the current NameValueCollection.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual bool Equals(
    NameValueCollection collection
)
Public Overridable Function Equals (
    collection As NameValueCollection
) As Boolean

Parameters

collection
Type: CodeSmith.CustomPropertiesNameValueCollection
The NameValueCollection to compare with the current NameValueCollection.

Return Value

Type: Boolean
true if the specified NameValueCollection is equal to the current NameValueCollection; otherwise, false.
Remarks

This Equals overload tests for value equality of all NameValueEntry elements contained in the two NameValueCollection collections.

Equals returns false if collection is a null reference, holds a different number of elements, or holds at least one NameValueEntry element at a given index position whose key and/or value is different from that of the element at the same index position in this NameValueCollection, as determined by the inequality operators defined by String and String.

See Also

Reference

NameValueCollection Class
Equals Overload
CodeSmith.CustomProperties Namespace


NameValueCollection.GetByIndex Method

NameValueCollectionGetByIndex Method

Gets the String value at the specified index of the NameValueCollection.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual string GetByIndex(
    int index
)
Public Overridable Function GetByIndex (
    index As Integer
) As String

Parameters

index
Type: SystemInt32
The zero-based index of the String value to get.

Return Value

Type: String
The String value at the specified index of the NameValueCollection.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than Count.
Remarks
Please refer to GetByIndex(Int32) for details.
See Also

Reference

NameValueCollection Class
CodeSmith.CustomProperties Namespace


NameValueCollection.GetByKey Method

NameValueCollectionGetByKey Method

Gets the String value associated with the first occurrence of the specified String key.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual string GetByKey(
    string key
)
Public Overridable Function GetByKey (
    key As String
) As String

Parameters

key
Type: SystemString
The String key whose value to get.

Return Value

Type: String
The String value associated with the first occurrence of the specified key, if found; otherwise, a null reference.
Exceptions
Exception | Condition
ArgumentNullException | key is a null reference.
Remarks
GetByKey and SetByKey(String, String) emulate the indexer of the SortedList class but require linear time to locate a key.
See Also

Reference

NameValueCollection Class
CodeSmith.CustomProperties Namespace


NameValueCollection.GetEnumerator Method

NameValueCollectionGetEnumerator Method

Returns an IStringStringEnumerator that can iterate through the NameValueCollection.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual IStringStringEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As IStringStringEnumerator

Return Value

Type: IStringStringEnumerator
An IStringStringEnumerator for the entire NameValueCollection.

Implements

IStringStringCollectionGetEnumerator
Remarks
Please refer to GetEnumerator for details.
See Also

Reference

NameValueCollection Class
CodeSmith.CustomProperties Namespace


NameValueCollection.GetKey Method

NameValueCollectionGetKey Method

Gets the String key at the specified index of the NameValueCollection.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual string GetKey(
    int index
)
Public Overridable Function GetKey (
    index As Integer
) As String

Parameters

index
Type: SystemInt32
The zero-based index of the String key to get.

Return Value

Type: String
The String key at the specified index of the NameValueCollection.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than Count.
Remarks
Please refer to GetKey(Int32) for details.
See Also

Reference

NameValueCollection Class
CodeSmith.CustomProperties Namespace


NameValueCollection.GetKeyList Method

NameValueCollectionGetKeyList Method

Gets the keys in the NameValueCollection.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual IStringList GetKeyList()
Public Overridable Function GetKeyList As IStringList

Return Value

Type: IStringList
An IStringList containing the keys in the NameValueCollection.
Remarks
Please refer to GetKeyList for details.
See Also

Reference

NameValueCollection Class
CodeSmith.CustomProperties Namespace


NameValueCollection.GetValueList Method

NameValueCollectionGetValueList Method

Gets the values in the NameValueCollection.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual IStringList GetValueList()
Public Overridable Function GetValueList As IStringList

Return Value

Type: IStringList
An IStringList containing the values in the NameValueCollection.
Remarks
Please refer to GetValueList for details.
See Also

Reference

NameValueCollection Class
CodeSmith.CustomProperties Namespace


NameValueCollection.IndexOf Method

NameValueCollectionIndexOf Method

Returns the zero-based index of the first occurrence of the specified NameValueEntry in the NameValueCollection.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual int IndexOf(
    NameValueEntry entry
)
Public Overridable Function IndexOf (
    entry As NameValueEntry
) As Integer

Parameters

entry
Type: CodeSmith.CustomPropertiesNameValueEntry
The NameValueEntry object to locate in the NameValueCollection.

Return Value

Type: Int32
The zero-based index of the first occurrence of entry in the NameValueCollection, if found; otherwise, -1.

Implements

IStringStringListIndexOf(NameValueEntry)
Remarks

Please refer to IndexOf(Object) for details.

IndexOf uses the equality operators defined by String and String to locate the specified entry.

See Also

Reference

NameValueCollection Class
CodeSmith.CustomProperties Namespace


NameValueCollection.IndexOfKey Method

NameValueCollectionIndexOfKey Method

Returns the zero-based index of the first occurrence of the specified String key in the NameValueCollection.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual int IndexOfKey(
    string key
)
Public Overridable Function IndexOfKey (
    key As String
) As Integer

Parameters

key
Type: SystemString
The String key to locate in the NameValueCollection.

Return Value

Type: Int32
The zero-based index of the first occurrence of key in the NameValueCollection, if found; otherwise, -1.
Exceptions
Exception | Condition
ArgumentNullException | key is a null reference.
Remarks
Please refer to IndexOfKey(Object) for details but note that the NameValueCollection requires linear time to locate a key.
See Also

Reference

NameValueCollection Class
CodeSmith.CustomProperties Namespace


NameValueCollection.IndexOfValue Method

NameValueCollectionIndexOfValue Method

Returns the zero-based index of first occurrence of the specified String value in the NameValueCollection.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual int IndexOfValue(
    string value
)
Public Overridable Function IndexOfValue (
    value As String
) As Integer

Parameters

value
Type: SystemString
The String value to locate in the NameValueCollection. This argument can be a null reference.

Return Value

Type: Int32
The zero-based index of the first occurrence of value in the NameValueCollection, if found; otherwise, -1.
Remarks
Please refer to IndexOfValue(Object) for details.
See Also

Reference

NameValueCollection Class
CodeSmith.CustomProperties Namespace


NameValueCollection.Insert Method

NameValueCollectionInsert Method

Inserts a NameValueEntry element into the NameValueCollection at the specified index.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual void Insert(
    int index,
    NameValueEntry entry
)
Public Overridable Sub Insert (
    index As Integer,
    entry As NameValueEntry
)

Parameters

index
Type: SystemInt32
The zero-based index at which entry should be inserted.
entry
Type: CodeSmith.CustomPropertiesNameValueEntry
The NameValueEntry object to insert into the NameValueCollection.

Implements

IStringStringListInsert(Int32, NameValueEntry)
Exceptions
Exception | Condition
ArgumentOutOfRangeException | index is less than zero. -or- index is greater than Count.
NotSupportedException | The NameValueCollection is read-only. -or- The NameValueCollection has a fixed size.
Remarks
Please refer to Insert(Int32, Object) for details.
See Also

Reference

NameValueCollection Class
CodeSmith.CustomProperties Namespace


NameValueCollection.Remove Method

NameValueCollectionRemove Method

Removes the first occurrence of the specified NameValueEntry from the NameValueCollection.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual void Remove(
    NameValueEntry entry
)
Public Overridable Sub Remove (
    entry As NameValueEntry
)

Parameters

entry
Type: CodeSmith.CustomPropertiesNameValueEntry
The NameValueEntry object to remove from the NameValueCollection.

Implements

IStringStringListRemove(NameValueEntry)
Exceptions
Exception | Condition
NotSupportedException | The NameValueCollection is read-only. -or- The NameValueCollection has a fixed size.
Remarks
Please refer to Remove(Object) for details.
See Also

Reference

NameValueCollection Class
CodeSmith.CustomProperties Namespace


NameValueCollection.RemoveAt Method

NameValueCollectionRemoveAt Method

Removes the element at the specified index of the NameValueCollection.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual void RemoveAt(
    int index
)
Public Overridable Sub RemoveAt (
    index As Integer
)

Parameters

index
Type: SystemInt32
The zero-based index of the element to remove.

Implements

IStringStringListRemoveAt(Int32)
IListRemoveAt(Int32)
Exceptions
Exception | Condition
ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than Count.
NotSupportedException | The NameValueCollection is read-only. -or- The NameValueCollection has a fixed size.
Remarks
Please refer to RemoveAt(Int32) for details.
See Also

Reference

NameValueCollection Class
CodeSmith.CustomProperties Namespace


NameValueCollection.SetByIndex Method

NameValueCollectionSetByIndex Method

Sets the String value at the specified index of the NameValueCollection.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual void SetByIndex(
    int index,
    string value
)
Public Overridable Sub SetByIndex (
    index As Integer,
    value As String
)

Parameters

index
Type: SystemInt32
The zero-based index of the String value to set.
value
Type: SystemString
The String object to store at the specified index of the NameValueCollection. This argument can be a null reference.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than Count.
Remarks
Please refer to SetByIndex(Int32, Object) for details.
See Also

Reference

NameValueCollection Class
CodeSmith.CustomProperties Namespace


NameValueCollection.SetByKey Method

NameValueCollectionSetByKey Method

Sets the String value associated with the first occurrence of the specified String key.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual int SetByKey(
    string key,
    string value
)
Public Overridable Function SetByKey (
    key As String,
    value As String
) As Integer

Parameters

key
Type: SystemString
The String key whose value to set.
value
Type: SystemString
The String object to associate with the first occurrence of the specified key. This argument can be a null reference. If the specified key is not found, SetByKey adds a new element with the specified key and value to the end of the NameValueCollection.

Return Value

Type: Int32
The NameValueCollection index of the element that was changed or added.
Exceptions
Exception | Condition
ArgumentNullException | key is a null reference.
NotSupportedException | The NameValueCollection is read-only. -or- key does not exist in the collection, and the NameValueCollection has a fixed size.
Remarks
SetByKey and GetByKey(String) emulate the indexer of the SortedList class but require linear time to locate a key.
See Also

Reference

NameValueCollection Class
CodeSmith.CustomProperties Namespace


NameValueCollection.Synchronized Method

NameValueCollectionSynchronized Method

Returns a synchronized (thread-safe) wrapper for the specified NameValueCollection.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static NameValueCollection Synchronized(
    NameValueCollection collection
)
Public Shared Function Synchronized (
    collection As NameValueCollection
) As NameValueCollection

Parameters

collection
Type: CodeSmith.CustomPropertiesNameValueCollection
The NameValueCollection to synchronize.

Return Value

Type: NameValueCollection
A synchronized (thread-safe) wrapper around collection.
Exceptions
Exception | Condition
ArgumentNullException | collection is a null reference.
Remarks
Please refer to Synchronized(IList) for details.
See Also

Reference

NameValueCollection Class
CodeSmith.CustomProperties Namespace


NameValueCollection.ToArray Method

NameValueCollectionToArray Method

Copies the elements of the NameValueCollection to a new Array of NameValueEntry elements.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual NameValueEntry[] ToArray()
Public Overridable Function ToArray As NameValueEntry()

Return Value

Type: NameValueEntry
A one-dimensional Array of NameValueEntry elements containing copies of the elements of the NameValueCollection.
Remarks
Please refer to ToArray for details.
See Also

Reference

NameValueCollection Class
CodeSmith.CustomProperties Namespace


NameValueCollection.ToString Method

NameValueCollectionToString Method

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
See Also

Reference

NameValueCollection Class
CodeSmith.CustomProperties Namespace


NameValueCollection.TrimToSize Method

NameValueCollectionTrimToSize Method

Sets the capacity to the actual number of elements in the NameValueCollection.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual void TrimToSize()
Public Overridable Sub TrimToSize
Exceptions
Exception | Condition
NotSupportedException | The NameValueCollection is read-only. -or- The NameValueCollection has a fixed size.
Remarks
Please refer to TrimToSize for details.
See Also

Reference

NameValueCollection Class
CodeSmith.CustomProperties Namespace


NameValueCollectionEditor Class

Note: This API is now obsolete.

Allows you to quickly edit an NameValueCollection.
Inheritance Hierarchy
SystemObject
System.Drawing.DesignUITypeEditor
CodeSmith.CustomPropertiesNameValueCollectionEditor

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[ObsoleteAttribute("The NameValueCollectionEditor has been deprecated.",
    false)]
public class NameValueCollectionEditor : UITypeEditor
<ObsoleteAttribute("The NameValueCollectionEditor has been deprecated.",
    false)>
Public Class NameValueCollectionEditor
    Inherits UITypeEditor

The NameValueCollectionEditor type exposes the following members.

Constructors
 | Name | Description
Public method | NameValueCollectionEditor | Initializes a new instance of the NameValueCollectionEditor class
Top
Properties
 | Name | Description
Public property | IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Inherited from UITypeEditor.)
Top
Methods
 | Name | Description
Public method | EditValue(IServiceProvider, Object) | Edits the value of the specified object using the editor style indicated by the GetEditStyle method. (Inherited from UITypeEditor.)
Public method | EditValue(ITypeDescriptorContext, IServiceProvider, Object) | (Overrides UITypeEditorEditValue(ITypeDescriptorContext, IServiceProvider, Object).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEditStyle | Gets the editor style used by the EditValue(IServiceProvider, Object) method. (Inherited from UITypeEditor.)
Public method | GetEditStyle(ITypeDescriptorContext) | (Overrides UITypeEditorGetEditStyle(ITypeDescriptorContext).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetPaintValueSupported | Indicates whether this editor supports painting a representation of an object's value. (Inherited from UITypeEditor.)
Public method | GetPaintValueSupported(ITypeDescriptorContext) | Indicates whether the specified context supports painting a representation of an object's value within the specified context. (Inherited from UITypeEditor.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PaintValue(PaintValueEventArgs) | Paints a representation of the value of an object using the specified PaintValueEventArgs. (Inherited from UITypeEditor.)
Public method | PaintValue(Object, Graphics, Rectangle) | Paints a representation of the value of the specified object to the specified canvas. (Inherited from UITypeEditor.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSmith.CustomProperties Namespace


NameValueCollectionEditor Constructor

Initializes a new instance of the NameValueCollectionEditor class

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public NameValueCollectionEditor()
Public Sub New
See Also

Reference

NameValueCollectionEditor Class
CodeSmith.CustomProperties Namespace


NameValueCollectionEditor Properties

The NameValueCollectionEditor type exposes the following members.

Properties
 | Name | Description
Public property | IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Inherited from UITypeEditor.)
Top
See Also

Reference

NameValueCollectionEditor Class
CodeSmith.CustomProperties Namespace


NameValueCollectionEditor Methods

The NameValueCollectionEditor type exposes the following members.

Methods
 | Name | Description
Public method | EditValue(IServiceProvider, Object) | Edits the value of the specified object using the editor style indicated by the GetEditStyle method. (Inherited from UITypeEditor.)
Public method | EditValue(ITypeDescriptorContext, IServiceProvider, Object) | (Overrides UITypeEditorEditValue(ITypeDescriptorContext, IServiceProvider, Object).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEditStyle | Gets the editor style used by the EditValue(IServiceProvider, Object) method. (Inherited from UITypeEditor.)
Public method | GetEditStyle(ITypeDescriptorContext) | (Overrides UITypeEditorGetEditStyle(ITypeDescriptorContext).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetPaintValueSupported | Indicates whether this editor supports painting a representation of an object's value. (Inherited from UITypeEditor.)
Public method | GetPaintValueSupported(ITypeDescriptorContext) | Indicates whether the specified context supports painting a representation of an object's value within the specified context. (Inherited from UITypeEditor.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PaintValue(PaintValueEventArgs) | Paints a representation of the value of an object using the specified PaintValueEventArgs. (Inherited from UITypeEditor.)
Public method | PaintValue(Object, Graphics, Rectangle) | Paints a representation of the value of the specified object to the specified canvas. (Inherited from UITypeEditor.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

NameValueCollectionEditor Class
CodeSmith.CustomProperties Namespace


NameValueCollectionEditor.EditValue Method

NameValueCollectionEditorEditValue Method

Overload List
 | Name | Description
Public method | EditValue(IServiceProvider, Object) | Edits the value of the specified object using the editor style indicated by the GetEditStyle method. (Inherited from UITypeEditor.)
Public method | EditValue(ITypeDescriptorContext, IServiceProvider, Object) | (Overrides UITypeEditorEditValue(ITypeDescriptorContext, IServiceProvider, Object).)
Top
See Also

Reference

NameValueCollectionEditor Class
CodeSmith.CustomProperties Namespace


NameValueCollectionEditor.EditValue Method (ITypeDescriptorContext, IServiceProvider, Object)

NameValueCollectionEditorEditValue Method (ITypeDescriptorContext, IServiceProvider, Object)

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override Object EditValue(
    ITypeDescriptorContext context,
    IServiceProvider provider,
    Object value
)
Public Overrides Function EditValue (
    context As ITypeDescriptorContext,
    provider As IServiceProvider,
    value As Object
) As Object

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
provider
Type: SystemIServiceProvider
value
Type: SystemObject

Return Value

Type: Object
See Also

Reference

NameValueCollectionEditor Class
EditValue Overload
CodeSmith.CustomProperties Namespace


NameValueCollectionEditor.GetEditStyle Method

NameValueCollectionEditorGetEditStyle Method

Overload List
 | Name | Description
Public method | GetEditStyle | Gets the editor style used by the EditValue(IServiceProvider, Object) method. (Inherited from UITypeEditor.)
Public method | GetEditStyle(ITypeDescriptorContext) | (Overrides UITypeEditorGetEditStyle(ITypeDescriptorContext).)
Top
See Also

Reference

NameValueCollectionEditor Class
CodeSmith.CustomProperties Namespace


NameValueCollectionEditor.GetEditStyle Method (ITypeDescriptorContext)

NameValueCollectionEditorGetEditStyle Method (ITypeDescriptorContext)

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override UITypeEditorEditStyle GetEditStyle(
    ITypeDescriptorContext context
)
Public Overrides Function GetEditStyle (
    context As ITypeDescriptorContext
) As UITypeEditorEditStyle

Parameters

context
Type: System.ComponentModelITypeDescriptorContext

Return Value

Type: UITypeEditorEditStyle
See Also

Reference

NameValueCollectionEditor Class
GetEditStyle Overload
CodeSmith.CustomProperties Namespace


NameValueCollectionEditorUI Class

Note: This API is now obsolete.

Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
CodeSmith.CustomPropertiesNameValueCollectionEditorUI

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[ObsoleteAttribute("The NameValueCollectionEditor has been deprecated.",
    false)]
public class NameValueCollectionEditorUI : Form
<ObsoleteAttribute("The NameValueCollectionEditor has been deprecated.",
    false)>
Public Class NameValueCollectionEditorUI
    Inherits Form

The NameValueCollectionEditorUI type exposes the following members.

Constructors
 | Name | Description
Public method | NameValueCollectionEditorUI | Initializes a new instance of the NameValueCollectionEditorUI class
Top
Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | Gets or sets a value that indicates whether controls in this container will be automatically validated when the focus changes. (Inherited from Form.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Form.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DeviceDpi | Gets the DPI value for the display device where the control is currently being displayed. (Inherited from Control.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
Protected property | MaximizedBounds | Gets or sets the size of the form when it is maximized. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | NameValueCollection |
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Protected property | ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Form.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Protected method | ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Protected method | AdjustFormScrollbars | Adjusts the scroll bars on the container based on the current control positions and the control currently selected. (Inherited from Form.)
Protected method | ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
Protected method | CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Form.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Form.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides FormDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | End |
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Form.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Public method | LogicalToDeviceUnits(Int32) | Converts a Logical DPI value to its equivalent DeviceUnit DPI value. (Inherited from Control.)
Public method | LogicalToDeviceUnits(Size) | Transforms a size from logical to device units by scaling it for the current DPI and rounding down to the nearest integer value for width and height. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnActivated | Raises the Activated event. (Inherited from Form.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnClosed | Raises the Closed event. (Inherited from Form.)
Protected method | OnClosing | Raises the Closing event. (Inherited from Form.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDpiChanged | Raises the DpiChanged event. (Inherited from Form.)
Protected method | OnDpiChangedAfterParent | Raises the DpiChangedAfterParent event. (Inherited from Control.)
Protected method | OnDpiChangedBeforeParent | Raises the DpiChangedBeforeParent event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Form.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Form.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Form.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
Protected method | OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
Protected method | OnGetDpiScaledSize | Raises the GetDpiScaledSize event. (Inherited from Form.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Form.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Form.)
Protected method | OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
Protected method | OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Form.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from Form.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
Protected method | OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
Protected method | OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
Protected method | OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
Protected method | OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
Protected method | OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Form.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Form.)
Protected method | OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
Protected method | OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnShown | Raises the Shown event. (Inherited from Form.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Form.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Form.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Form.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Form.)
Protected method | ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Form.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Form.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from Form.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Protected method | RescaleConstantsForDpi | Provides constants for rescaling the control when a DPI change occurs. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value (Empty). (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScaleBitmapLogicalToDevice | Scales a logical bitmap value to it's equivalent device unit value when a DPI change occurs. (Inherited from Control.)
Protected method | ScaleControl | Scales the location, size, padding, and margin of a control. (Inherited from Form.)
Protected method | ScaleCore | Performs scaling of the form. (Inherited from Form.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Form.)
Protected method | SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either or . (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Form.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog | Shows the form as a modal dialog box. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | Start |
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | Causes all of the child controls within a control that support validation to validate their data. (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | Causes all of the child controls within a control that support validation to validate their data. (Inherited from Form.)
Protected method | WndProc | Processes Windows messages. (Inherited from Form.)
Top
Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from Form.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DpiChanged | Occurs when the DPI setting changes on the display device where the form is currently displayed. (Inherited from Form.)
Public event | DpiChangedAfterParent | Occurs when the DPI setting for a control is changed programmatically after the DPI of its parent control or form has changed. (Inherited from Control.)
Public event | DpiChangedBeforeParent | Occurs when the DPI setting for a control is changed programmatically before a DPI change event for its parent control or form has occurred. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the Margin property changes. (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | Occurs when the TabStop property changes. (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

CodeSmith.CustomProperties Namespace


NameValueCollectionEditorUI Constructor

Initializes a new instance of the NameValueCollectionEditorUI class

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public NameValueCollectionEditorUI()
Public Sub New
See Also

Reference

NameValueCollectionEditorUI Class
CodeSmith.CustomProperties Namespace


NameValueCollectionEditorUI Properties

The NameValueCollectionEditorUI type exposes the following members.

Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | Gets or sets a value that indicates whether controls in this container will be automatically validated when the focus changes. (Inherited from Form.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Form.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DeviceDpi | Gets the DPI value for the display device where the control is currently being displayed. (Inherited from Control.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
Protected property | MaximizedBounds | Gets or sets the size of the form when it is maximized. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | NameValueCollection |
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Protected property | ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Form.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

NameValueCollectionEditorUI Class
CodeSmith.CustomProperties Namespace


NameValueCollectionEditorUI.NameValueCollection Property

NameValueCollectionEditorUINameValueCollection Property

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public NameValueCollection NameValueCollection { get; }
Public ReadOnly Property NameValueCollection As NameValueCollection
    Get

Property Value

Type: NameValueCollection
See Also

Reference

NameValueCollectionEditorUI Class
CodeSmith.CustomProperties Namespace


NameValueCollectionEditorUI Methods

The NameValueCollectionEditorUI type exposes the following members.

Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Protected method | ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Protected method | AdjustFormScrollbars | Adjusts the scroll bars on the container based on the current control positions and the control currently selected. (Inherited from Form.)
Protected method | ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
Protected method | CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Form.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Form.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides FormDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | End |
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Form.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Public method | LogicalToDeviceUnits(Int32) | Converts a Logical DPI value to its equivalent DeviceUnit DPI value. (Inherited from Control.)
Public method | LogicalToDeviceUnits(Size) | Transforms a size from logical to device units by scaling it for the current DPI and rounding down to the nearest integer value for width and height. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnActivated | Raises the Activated event. (Inherited from Form.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnClosed | Raises the Closed event. (Inherited from Form.)
Protected method | OnClosing | Raises the Closing event. (Inherited from Form.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDpiChanged | Raises the DpiChanged event. (Inherited from Form.)
Protected method | OnDpiChangedAfterParent | Raises the DpiChangedAfterParent event. (Inherited from Control.)
Protected method | OnDpiChangedBeforeParent | Raises the DpiChangedBeforeParent event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Form.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Form.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Form.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
Protected method | OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
Protected method | OnGetDpiScaledSize | Raises the GetDpiScaledSize event. (Inherited from Form.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Form.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Form.)
Protected method | OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
Protected method | OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Form.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from Form.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
Protected method | OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
Protected method | OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
Protected method | OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
Protected method | OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
Protected method | OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Form.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Form.)
Protected method | OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
Protected method | OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnShown | Raises the Shown event. (Inherited from Form.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Form.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Form.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Form.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Form.)
Protected method | ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Form.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Form.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from Form.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Protected method | RescaleConstantsForDpi | Provides constants for rescaling the control when a DPI change occurs. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value (Empty). (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScaleBitmapLogicalToDevice | Scales a logical bitmap value to it's equivalent device unit value when a DPI change occurs. (Inherited from Control.)
Protected method | ScaleControl | Scales the location, size, padding, and margin of a control. (Inherited from Form.)
Protected method | ScaleCore | Performs scaling of the form. (Inherited from Form.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Form.)
Protected method | SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either or . (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Form.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog | Shows the form as a modal dialog box. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | Start |
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | Causes all of the child controls within a control that support validation to validate their data. (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | Causes all of the child controls within a control that support validation to validate their data. (Inherited from Form.)
Protected method | WndProc | Processes Windows messages. (Inherited from Form.)
Top
See Also

Reference

NameValueCollectionEditorUI Class
CodeSmith.CustomProperties Namespace


NameValueCollectionEditorUI.Dispose Method

NameValueCollectionEditorUIDispose Method

Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides FormDispose(Boolean).)
Top
See Also

Reference

NameValueCollectionEditorUI Class
CodeSmith.CustomProperties Namespace


NameValueCollectionEditorUI.Dispose Method (Boolean)

NameValueCollectionEditorUIDispose Method (Boolean)

Clean up any resources being used.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
true if managed resources should be disposed; otherwise, false.
See Also

Reference

NameValueCollectionEditorUI Class
Dispose Overload
CodeSmith.CustomProperties Namespace


NameValueCollectionEditorUI.End Method

NameValueCollectionEditorUIEnd Method

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void End()
Public Sub End
See Also

Reference

NameValueCollectionEditorUI Class
CodeSmith.CustomProperties Namespace


NameValueCollectionEditorUI.Start Method

NameValueCollectionEditorUIStart Method

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void Start(
    IWindowsFormsEditorService editorService,
    Object value
)
Public Sub Start (
    editorService As IWindowsFormsEditorService,
    value As Object
)

Parameters

editorService
Type: System.Windows.Forms.DesignIWindowsFormsEditorService
value
Type: SystemObject
See Also

Reference

NameValueCollectionEditorUI Class
CodeSmith.CustomProperties Namespace


NameValueCollectionEditorUI Events

The NameValueCollectionEditorUI type exposes the following members.

Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from Form.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DpiChanged | Occurs when the DPI setting changes on the display device where the form is currently displayed. (Inherited from Form.)
Public event | DpiChangedAfterParent | Occurs when the DPI setting for a control is changed programmatically after the DPI of its parent control or form has changed. (Inherited from Control.)
Public event | DpiChangedBeforeParent | Occurs when the DPI setting for a control is changed programmatically before a DPI change event for its parent control or form has occurred. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the Margin property changes. (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | Occurs when the TabStop property changes. (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

NameValueCollectionEditorUI Class
CodeSmith.CustomProperties Namespace


NameValueCollectionSerializer Class

Note: This API is now obsolete.

Inheritance Hierarchy
SystemObject
CodeSmith.CustomPropertiesNameValueCollectionSerializer

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[ObsoleteAttribute("The NameValueCollectionSerializer has been deprecated.",
    false)]
public class NameValueCollectionSerializer : IPropertySerializer
<ObsoleteAttribute("The NameValueCollectionSerializer has been deprecated.",
    false)>
Public Class NameValueCollectionSerializer
    Implements IPropertySerializer

The NameValueCollectionSerializer type exposes the following members.

Constructors
 | Name | Description
Public method | NameValueCollectionSerializer | Initializes a new instance of the NameValueCollectionSerializer class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadProperty |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseDefaultValue |
Public method | ReadPropertyXml |
Public method | SaveProperty |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WritePropertyXml |
Top
See Also

Reference

CodeSmith.CustomProperties Namespace


NameValueCollectionSerializer Constructor

Initializes a new instance of the NameValueCollectionSerializer class

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public NameValueCollectionSerializer()
Public Sub New
See Also

Reference

NameValueCollectionSerializer Class
CodeSmith.CustomProperties Namespace


NameValueCollectionSerializer Methods

The NameValueCollectionSerializer type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadProperty |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseDefaultValue |
Public method | ReadPropertyXml |
Public method | SaveProperty |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WritePropertyXml |
Top
See Also

Reference

NameValueCollectionSerializer Class
CodeSmith.CustomProperties Namespace


NameValueCollectionSerializer.LoadProperty Method

NameValueCollectionSerializerLoadProperty Method

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public Object LoadProperty(
    PropertySerializerContext context,
    Object propertyValue
)
Public Function LoadProperty (
    context As PropertySerializerContext,
    propertyValue As Object
) As Object

Parameters

context
Type: CodeSmith.EnginePropertySerializerContext
propertyValue
Type: SystemObject

Return Value

Type: Object

Implements

IPropertySerializerLoadProperty(PropertySerializerContext, Object)
See Also

Reference

NameValueCollectionSerializer Class
CodeSmith.CustomProperties Namespace


NameValueCollectionSerializer.ParseDefaultValue Method

NameValueCollectionSerializerParseDefaultValue Method

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public Object ParseDefaultValue(
    PropertySerializerContext context,
    string defaultValue
)
Public Function ParseDefaultValue (
    context As PropertySerializerContext,
    defaultValue As String
) As Object

Parameters

context
Type: CodeSmith.EnginePropertySerializerContext
defaultValue
Type: SystemString

Return Value

Type: Object

Implements

IPropertySerializerParseDefaultValue(PropertySerializerContext, String)
See Also

Reference

NameValueCollectionSerializer Class
CodeSmith.CustomProperties Namespace


NameValueCollectionSerializer.ReadPropertyXml Method

NameValueCollectionSerializerReadPropertyXml Method

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public Object ReadPropertyXml(
    PropertySerializerContext context,
    XmlNode propertyValue
)
Public Function ReadPropertyXml (
    context As PropertySerializerContext,
    propertyValue As XmlNode
) As Object

Parameters

context
Type: CodeSmith.EnginePropertySerializerContext
propertyValue
Type: System.XmlXmlNode

Return Value

Type: Object

Implements

IPropertySerializerReadPropertyXml(PropertySerializerContext, XmlNode)
See Also

Reference

NameValueCollectionSerializer Class
CodeSmith.CustomProperties Namespace


NameValueCollectionSerializer.SaveProperty Method

NameValueCollectionSerializerSaveProperty Method

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public Object SaveProperty(
    PropertySerializerContext context,
    Object propertyValue
)
Public Function SaveProperty (
    context As PropertySerializerContext,
    propertyValue As Object
) As Object

Parameters

context
Type: CodeSmith.EnginePropertySerializerContext
propertyValue
Type: SystemObject

Return Value

Type: Object

Implements

IPropertySerializerSaveProperty(PropertySerializerContext, Object)
See Also

Reference

NameValueCollectionSerializer Class
CodeSmith.CustomProperties Namespace


NameValueCollectionSerializer.WritePropertyXml Method

NameValueCollectionSerializerWritePropertyXml Method

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void WritePropertyXml(
    PropertySerializerContext context,
    XmlWriter writer,
    Object propertyValue
)
Public Sub WritePropertyXml (
    context As PropertySerializerContext,
    writer As XmlWriter,
    propertyValue As Object
)

Parameters

context
Type: CodeSmith.EnginePropertySerializerContext
writer
Type: System.XmlXmlWriter
propertyValue
Type: SystemObject

Implements

IPropertySerializerWritePropertyXml(PropertySerializerContext, XmlWriter, Object)
See Also

Reference

NameValueCollectionSerializer Class
CodeSmith.CustomProperties Namespace


NameValueCollectionTypeConverter Class

Note: This API is now obsolete.

Inheritance Hierarchy
SystemObject
System.ComponentModelTypeConverter
CodeSmith.CustomPropertiesNameValueCollectionTypeConverter

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[ObsoleteAttribute("The NameValueCollectionTypeConverter has been deprecated.",
    false)]
public class NameValueCollectionTypeConverter : TypeConverter
<ObsoleteAttribute("The NameValueCollectionTypeConverter has been deprecated.",
    false)>
Public Class NameValueCollectionTypeConverter
    Inherits TypeConverter

The NameValueCollectionTypeConverter type exposes the following members.

Constructors
 | Name | Description
Public method | NameValueCollectionTypeConverter | Initializes a new instance of the NameValueCollectionTypeConverter class
Top
Methods
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | (Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | (Overrides TypeConverterCanConvertTo(ITypeDescriptorContext, Type).)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
Public method | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | (Overrides TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Public method | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
Public method | CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Protected method | GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object, Attribute) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported | Returns whether this object supports properties. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | Returns whether this object supports properties, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValues | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
Public method | GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
Public method | IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSmith.CustomProperties Namespace


NameValueCollectionTypeConverter Constructor

Initializes a new instance of the NameValueCollectionTypeConverter class

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public NameValueCollectionTypeConverter()
Public Sub New
See Also

Reference

NameValueCollectionTypeConverter Class
CodeSmith.CustomProperties Namespace


NameValueCollectionTypeConverter Methods

The NameValueCollectionTypeConverter type exposes the following members.

Methods
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | (Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | (Overrides TypeConverterCanConvertTo(ITypeDescriptorContext, Type).)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
Public method | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | (Overrides TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Public method | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
Public method | CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Protected method | GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object, Attribute) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported | Returns whether this object supports properties. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | Returns whether this object supports properties, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValues | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
Public method | GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
Public method | IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

NameValueCollectionTypeConverter Class
CodeSmith.CustomProperties Namespace


NameValueCollectionTypeConverter.CanConvertFrom Method

NameValueCollectionTypeConverterCanConvertFrom Method

Overload List
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | (Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Top
See Also

Reference

NameValueCollectionTypeConverter Class
CodeSmith.CustomProperties Namespace


NameValueCollectionTypeConverter.CanConvertFrom Method (ITypeDescriptorContext, Type)

NameValueCollectionTypeConverterCanConvertFrom Method (ITypeDescriptorContext, Type)

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override bool CanConvertFrom(
    ITypeDescriptorContext context,
    Type sourceType
)
Public Overrides Function CanConvertFrom (
    context As ITypeDescriptorContext,
    sourceType As Type
) As Boolean

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
sourceType
Type: SystemType

Return Value

Type: Boolean
See Also

Reference

NameValueCollectionTypeConverter Class
CanConvertFrom Overload
CodeSmith.CustomProperties Namespace


NameValueCollectionTypeConverter.CanConvertTo Method

NameValueCollectionTypeConverterCanConvertTo Method

Overload List
 | Name | Description
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | (Overrides TypeConverterCanConvertTo(ITypeDescriptorContext, Type).)
Top
See Also

Reference

NameValueCollectionTypeConverter Class
CodeSmith.CustomProperties Namespace


NameValueCollectionTypeConverter.CanConvertTo Method (ITypeDescriptorContext, Type)

NameValueCollectionTypeConverterCanConvertTo Method (ITypeDescriptorContext, Type)

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override bool CanConvertTo(
    ITypeDescriptorContext context,
    Type destinationType
)
Public Overrides Function CanConvertTo (
    context As ITypeDescriptorContext,
    destinationType As Type
) As Boolean

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
destinationType
Type: SystemType

Return Value

Type: Boolean
See Also

Reference

NameValueCollectionTypeConverter Class
CanConvertTo Overload
CodeSmith.CustomProperties Namespace


NameValueCollectionTypeConverter.ConvertFrom Method

NameValueCollectionTypeConverterConvertFrom Method

Overload List
 | Name | Description
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Top
See Also

Reference

NameValueCollectionTypeConverter Class
CodeSmith.CustomProperties Namespace


NameValueCollectionTypeConverter.ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

NameValueCollectionTypeConverterConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override Object ConvertFrom(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value
)
Public Overrides Function ConvertFrom (
    context As ITypeDescriptorContext,
    culture As CultureInfo,
    value As Object
) As Object

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
culture
Type: System.GlobalizationCultureInfo
value
Type: SystemObject

Return Value

Type: Object
See Also

Reference

NameValueCollectionTypeConverter Class
ConvertFrom Overload
CodeSmith.CustomProperties Namespace


NameValueCollectionTypeConverter.ConvertTo Method

NameValueCollectionTypeConverterConvertTo Method

Overload List
 | Name | Description
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | (Overrides TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Top
See Also

Reference

NameValueCollectionTypeConverter Class
CodeSmith.CustomProperties Namespace


NameValueCollectionTypeConverter.ConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)

NameValueCollectionTypeConverterConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override Object ConvertTo(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value,
    Type destinationType
)
Public Overrides Function ConvertTo (
    context As ITypeDescriptorContext,
    culture As CultureInfo,
    value As Object,
    destinationType As Type
) As Object

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
culture
Type: System.GlobalizationCultureInfo
value
Type: SystemObject
destinationType
Type: SystemType

Return Value

Type: Object
See Also

Reference

NameValueCollectionTypeConverter Class
ConvertTo Overload
CodeSmith.CustomProperties Namespace


NameValueEntry Structure

Implements a strongly typed pair of one String key and one String value.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
public struct NameValueEntry
<SerializableAttribute>
Public Structure NameValueEntry

The NameValueEntry type exposes the following members.

Constructors
 | Name | Description
Public method | NameValueEntry | Initializes a new instance of the NameValueEntry class with the specified key and value.
Top
Properties
 | Name | Description
Public property | Key | Gets or sets the String key in the key-and-value pair.
Public property | Value | Gets or sets the String value in the key-and-value pair.
Top
Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Operators
Name | Description
(DictionaryEntry to NameValueEntry) | Converts a DictionaryEntry to a NameValueEntry.
(NameValueEntry to DictionaryEntry) | Converts a NameValueEntry to a DictionaryEntry.
Top
Remarks
NameValueEntry provides a DictionaryEntry that is strongly typed for String keys and String values.
See Also

Reference

CodeSmith.CustomProperties Namespace


NameValueEntry Constructor

Initializes a new instance of the NameValueEntry class with the specified key and value.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public NameValueEntry(
    string key,
    string value
)
Public Sub New (
    key As String,
    value As String
)

Parameters

key
Type: SystemString
The String key in the key-and-value pair.
value
Type: SystemString
The String value in the key-and-value pair. This argument can be a null reference.
Exceptions
Exception | Condition
ArgumentNullException | key is a null reference.
See Also

Reference

NameValueEntry Structure
CodeSmith.CustomProperties Namespace


NameValueEntry Properties

The NameValueEntry type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets or sets the String key in the key-and-value pair.
Public property | Value | Gets or sets the String value in the key-and-value pair.
Top
See Also

Reference

NameValueEntry Structure
CodeSmith.CustomProperties Namespace


NameValueEntry.Key Property

NameValueEntryKey Property

Gets or sets the String key in the key-and-value pair.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string Key { get; set; }
Public Property Key As String
    Get
    Set

Property Value

Type: String
The String key in the key-and-value pair. The default is a null reference.
Exceptions
Exception | Condition
ArgumentNullException | Key is set to a null reference.
Remarks
NameValueEntry is a value type and therefore has an implicit default constructor that zeroes all data members. This means that the Key property of a default-constructed NameValueEntry contains a null reference by default, even though it is not possible to explicitly set Key to a null reference.
See Also

Reference

NameValueEntry Structure
CodeSmith.CustomProperties Namespace


NameValueEntry.Value Property

NameValueEntryValue Property

Gets or sets the String value in the key-and-value pair.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string Value { get; set; }
Public Property Value As String
    Get
    Set

Property Value

Type: String
The String value in the key-and-value pair. This value can be a null reference, which is also the default.
See Also

Reference

NameValueEntry Structure
CodeSmith.CustomProperties Namespace


NameValueEntry Methods

The NameValueEntry type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

NameValueEntry Structure
CodeSmith.CustomProperties Namespace


NameValueEntry Type Conversions

Operators
Name | Description
(DictionaryEntry to NameValueEntry) | Converts a DictionaryEntry to a NameValueEntry.
(NameValueEntry to DictionaryEntry) | Converts a NameValueEntry to a DictionaryEntry.
Top
See Also

Reference

NameValueEntry Structure
CodeSmith.CustomProperties Namespace


NameValueEntry Implicit Conversion Operators

NameValueEntry Conversion Operators

Overload List
Name | Description
(DictionaryEntry to NameValueEntry) | Converts a DictionaryEntry to a NameValueEntry.
(NameValueEntry to DictionaryEntry) | Converts a NameValueEntry to a DictionaryEntry.
Top
See Also

Reference

NameValueEntry Structure
CodeSmith.CustomProperties Namespace


NameValueEntry Implicit Conversion (DictionaryEntry to NameValueEntry)

NameValueEntry Conversion (DictionaryEntry to NameValueEntry)

Converts a DictionaryEntry to a NameValueEntry.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static implicit operator NameValueEntry (
    DictionaryEntry entry
)
Public Shared Widening Operator CType (
    entry As DictionaryEntry
) As NameValueEntry

Parameters

entry
Type: System.CollectionsDictionaryEntry
A DictionaryEntry object to convert.

Return Value

Type: NameValueEntry
A NameValueEntry object that represents the converted entry.
Exceptions
Exception | Condition
InvalidCastException | entry contains a key that is not compatible with String. -or- entry contains a value that is not compatible with String.
See Also

Reference

NameValueEntry Structure
Overload
CodeSmith.CustomProperties Namespace


NameValueEntry Implicit Conversion (NameValueEntry to DictionaryEntry)

NameValueEntry Conversion (NameValueEntry to DictionaryEntry)

Converts a NameValueEntry to a DictionaryEntry.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static implicit operator DictionaryEntry (
    NameValueEntry pair
)
Public Shared Widening Operator CType (
    pair As NameValueEntry
) As DictionaryEntry

Parameters

pair
Type: CodeSmith.CustomPropertiesNameValueEntry
A NameValueEntry object to convert.

Return Value

Type: DictionaryEntry
A DictionaryEntry object that represents the converted pair.
See Also

Reference

NameValueEntry Structure
Overload
CodeSmith.CustomProperties Namespace


StringCollection Class

Note: This API is now obsolete.

Inheritance Hierarchy
SystemObject
CodeSmith.CustomPropertiesStringCollection

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
[TypeConverterAttribute(typeof(StringCollectionTypeConverter))]
[ObsoleteAttribute("The StringCollection has been deprecated, please use a List<string> instead.",
    false)]
public class StringCollection : ICollection,
    IEnumerable, IList, ICloneable
<SerializableAttribute>
<TypeConverterAttribute(GetType(StringCollectionTypeConverter))>
<ObsoleteAttribute("The StringCollection has been deprecated, please use a List<string> instead.",
    false)>
Public Class StringCollection
    Implements ICollection, IEnumerable, IList, ICloneable

The StringCollection type exposes the following members.

Constructors
 | Name | Description
Public method | StringCollection | Initializes a new instance of the StringCollection class
Public method | StringCollection(Int32) | Initializes a new instance of the StringCollection class
Public method | StringCollection(String) | Initializes a new instance of the StringCollection class
Public method | StringCollection(StringCollection) | Initializes a new instance of the StringCollection class
Protected method | StringCollection(StringCollectionTag) | Initializes a new instance of the StringCollection class
Top
Properties
 | Name | Description
Public property | Capacity |
Public property | Count |
Public property | IsFixedSize |
Public property | IsReadOnly |
Public property | IsSynchronized |
Public property | Item |
Public property | SyncRoot |
Top
Methods
 | Name | Description
Public method | Add |
Public method | AddRange(String) |
Public method | AddRange(StringCollection) |
Public method | Clear |
Public method | Clone |
Public method | Contains |
Public method | CopyTo(String) |
Public method | CopyTo(String, Int32) |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf |
Public method | Insert |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ReadOnly |
Public method | Remove |
Public method | RemoveAt |
 | Synchronized |
Public method | ToArray |
Public method | ToString | (Overrides ObjectToString.)
Public method | TrimToSize |
Top
See Also

Reference

CodeSmith.CustomProperties Namespace


StringCollection Constructor

Overload List
 | Name | Description
Public method | StringCollection | Initializes a new instance of the StringCollection class
Public method | StringCollection(Int32) | Initializes a new instance of the StringCollection class
Public method | StringCollection(String) | Initializes a new instance of the StringCollection class
Public method | StringCollection(StringCollection) | Initializes a new instance of the StringCollection class
Protected method | StringCollection(StringCollectionTag) | Initializes a new instance of the StringCollection class
Top
See Also

Reference

StringCollection Class
CodeSmith.CustomProperties Namespace


StringCollection Constructor

Initializes a new instance of the StringCollection class

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public StringCollection()
Public Sub New
See Also

Reference

StringCollection Class
StringCollection Overload
CodeSmith.CustomProperties Namespace


StringCollection Constructor (Int32)

Initializes a new instance of the StringCollection class

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public StringCollection(
    int capacity
)
Public Sub New (
    capacity As Integer
)

Parameters

capacity
Type: SystemInt32
See Also

Reference

StringCollection Class
StringCollection Overload
CodeSmith.CustomProperties Namespace


StringCollection Constructor (String[])

StringCollection Constructor (String)

Initializes a new instance of the StringCollection class

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public StringCollection(
    string[] a
)
Public Sub New (
    a As String()
)

Parameters

a
Type: SystemString
See Also

Reference

StringCollection Class
StringCollection Overload
CodeSmith.CustomProperties Namespace


StringCollection Constructor (StringCollection)

Initializes a new instance of the StringCollection class

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public StringCollection(
    StringCollection c
)
Public Sub New (
    c As StringCollection
)

Parameters

c
Type: CodeSmith.CustomPropertiesStringCollection
See Also

Reference

StringCollection Class
StringCollection Overload
CodeSmith.CustomProperties Namespace


StringCollection Constructor (StringCollection.Tag)

StringCollection Constructor (StringCollectionTag)

Initializes a new instance of the StringCollection class

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected StringCollection(
    StringCollectionTag t
)
Protected Sub New (
    t As StringCollectionTag
)

Parameters

t
Type: CodeSmith.CustomPropertiesStringCollectionTag
See Also

Reference

StringCollection Class
StringCollection Overload
CodeSmith.CustomProperties Namespace


StringCollection Properties

The StringCollection type exposes the following members.

Properties
 | Name | Description
Public property | Capacity |
Public property | Count |
Public property | IsFixedSize |
Public property | IsReadOnly |
Public property | IsSynchronized |
Public property | Item |
Public property | SyncRoot |
Top
See Also

Reference

StringCollection Class
CodeSmith.CustomProperties Namespace


StringCollection.Capacity Property

StringCollectionCapacity Property

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual int Capacity { get; set; }
Public Overridable Property Capacity As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

StringCollection Class
CodeSmith.CustomProperties Namespace


StringCollection.Count Property

StringCollectionCount Property

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual int Count { get; }
Public Overridable ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Implements

ICollectionCount
See Also

Reference

StringCollection Class
CodeSmith.CustomProperties Namespace


StringCollection.IsFixedSize Property

StringCollectionIsFixedSize Property

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual bool IsFixedSize { get; }
Public Overridable ReadOnly Property IsFixedSize As Boolean
    Get

Property Value

Type: Boolean

Implements

IListIsFixedSize
See Also

Reference

StringCollection Class
CodeSmith.CustomProperties Namespace


StringCollection.IsReadOnly Property

StringCollectionIsReadOnly Property

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual bool IsReadOnly { get; }
Public Overridable ReadOnly Property IsReadOnly As Boolean
    Get

Property Value

Type: Boolean

Implements

IListIsReadOnly
See Also

Reference

StringCollection Class
CodeSmith.CustomProperties Namespace


StringCollection.IsSynchronized Property

StringCollectionIsSynchronized Property

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual bool IsSynchronized { get; }
Public Overridable ReadOnly Property IsSynchronized As Boolean
    Get

Property Value

Type: Boolean

Implements

ICollectionIsSynchronized
See Also

Reference

StringCollection Class
CodeSmith.CustomProperties Namespace


StringCollection.Item Property

StringCollectionItem Property

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual string this[
    int index
] { get; set; }
Public Overridable Default Property Item (
    index As Integer
) As String
    Get
    Set

Parameters

index
Type: SystemInt32

Property Value

Type: String
See Also

Reference

StringCollection Class
CodeSmith.CustomProperties Namespace


StringCollection.SyncRoot Property

StringCollectionSyncRoot Property

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual Object SyncRoot { get; }
Public Overridable ReadOnly Property SyncRoot As Object
    Get

Property Value

Type: Object

Implements

ICollectionSyncRoot
See Also

Reference

StringCollection Class
CodeSmith.CustomProperties Namespace


StringCollection Methods

The StringCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add |
Public method | AddRange(String) |
Public method | AddRange(StringCollection) |
Public method | Clear |
Public method | Clone |
Public method | Contains |
Public method | CopyTo(String) |
Public method | CopyTo(String, Int32) |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf |
Public method | Insert |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ReadOnly |
Public method | Remove |
Public method | RemoveAt |
 | Synchronized |
Public method | ToArray |
Public method | ToString | (Overrides ObjectToString.)
Public method | TrimToSize |
Top
See Also

Reference

StringCollection Class
CodeSmith.CustomProperties Namespace


StringCollection.Add Method

StringCollectionAdd Method

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual int Add(
    string item
)
Public Overridable Function Add (
    item As String
) As Integer

Parameters

item
Type: SystemString

Return Value

Type: Int32
See Also

Reference

StringCollection Class
CodeSmith.CustomProperties Namespace


StringCollection.AddRange Method

StringCollectionAddRange Method

Overload List
 | Name | Description
Public method | AddRange(String) |
Public method | AddRange(StringCollection) |
Top
See Also

Reference

StringCollection Class
CodeSmith.CustomProperties Namespace


StringCollection.AddRange Method (String[])

StringCollectionAddRange Method (String)

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual int AddRange(
    string[] x
)
Public Overridable Function AddRange (
    x As String()
) As Integer

Parameters

x
Type: SystemString

Return Value

Type: Int32
See Also

Reference

StringCollection Class
AddRange Overload
CodeSmith.CustomProperties Namespace


StringCollection.AddRange Method (StringCollection)

StringCollectionAddRange Method (StringCollection)

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual int AddRange(
    StringCollection x
)
Public Overridable Function AddRange (
    x As StringCollection
) As Integer

Parameters

x
Type: CodeSmith.CustomPropertiesStringCollection

Return Value

Type: Int32
See Also

Reference

StringCollection Class
AddRange Overload
CodeSmith.CustomProperties Namespace


StringCollection.Clear Method

StringCollectionClear Method

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual void Clear()
Public Overridable Sub Clear

Implements

IListClear
See Also

Reference

StringCollection Class
CodeSmith.CustomProperties Namespace


StringCollection.Clone Method

StringCollectionClone Method

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual Object Clone()
Public Overridable Function Clone As Object

Return Value

Type: Object

Implements

ICloneableClone
See Also

Reference

StringCollection Class
CodeSmith.CustomProperties Namespace


StringCollection.Contains Method

StringCollectionContains Method

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual bool Contains(
    string item
)
Public Overridable Function Contains (
    item As String
) As Boolean

Parameters

item
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

StringCollection Class
CodeSmith.CustomProperties Namespace


StringCollection.CopyTo Method

StringCollectionCopyTo Method

Overload List
 | Name | Description
Public method | CopyTo(String) |
Public method | CopyTo(String, Int32) |
Top
See Also

Reference

StringCollection Class
CodeSmith.CustomProperties Namespace


StringCollection.CopyTo Method (String[])

StringCollectionCopyTo Method (String)

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual void CopyTo(
    string[] array
)
Public Overridable Sub CopyTo (
    array As String()
)

Parameters

array
Type: SystemString
See Also

Reference

StringCollection Class
CopyTo Overload
CodeSmith.CustomProperties Namespace


StringCollection.CopyTo Method (String[], Int32)

StringCollectionCopyTo Method (String, Int32)

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual void CopyTo(
    string[] array,
    int start
)
Public Overridable Sub CopyTo (
    array As String(),
    start As Integer
)

Parameters

array
Type: SystemString
start
Type: SystemInt32
See Also

Reference

StringCollection Class
CopyTo Overload
CodeSmith.CustomProperties Namespace


StringCollection.GetEnumerator Method

StringCollectionGetEnumerator Method

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual StringCollectionIStringCollectionEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As StringCollectionIStringCollectionEnumerator

Return Value

Type: StringCollectionIStringCollectionEnumerator
See Also

Reference

StringCollection Class
CodeSmith.CustomProperties Namespace


StringCollection.IndexOf Method

StringCollectionIndexOf Method

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual int IndexOf(
    string item
)
Public Overridable Function IndexOf (
    item As String
) As Integer

Parameters

item
Type: SystemString

Return Value

Type: Int32
See Also

Reference

StringCollection Class
CodeSmith.CustomProperties Namespace


StringCollection.Insert Method

StringCollectionInsert Method

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual void Insert(
    int index,
    string item
)
Public Overridable Sub Insert (
    index As Integer,
    item As String
)

Parameters

index
Type: SystemInt32
item
Type: SystemString
See Also

Reference

StringCollection Class
CodeSmith.CustomProperties Namespace


StringCollection.ReadOnly Method

StringCollectionReadOnly Method

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static StringCollection ReadOnly(
    StringCollection list
)
Public Shared Function ReadOnly (
    list As StringCollection
) As StringCollection

Parameters

list
Type: CodeSmith.CustomPropertiesStringCollection

Return Value

Type: StringCollection
See Also

Reference

StringCollection Class
CodeSmith.CustomProperties Namespace


StringCollection.Remove Method

StringCollectionRemove Method

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual void Remove(
    string item
)
Public Overridable Sub Remove (
    item As String
)

Parameters

item
Type: SystemString
See Also

Reference

StringCollection Class
CodeSmith.CustomProperties Namespace


StringCollection.RemoveAt Method

StringCollectionRemoveAt Method

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual void RemoveAt(
    int index
)
Public Overridable Sub RemoveAt (
    index As Integer
)

Parameters

index
Type: SystemInt32
See Also

Reference

StringCollection Class
CodeSmith.CustomProperties Namespace


StringCollection.Synchronized Method

StringCollectionSynchronized Method

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static StringCollection Synchronized(
    StringCollection list
)
Public Shared Function Synchronized (
    list As StringCollection
) As StringCollection

Parameters

list
Type: CodeSmith.CustomPropertiesStringCollection

Return Value

Type: StringCollection
See Also

Reference

StringCollection Class
CodeSmith.CustomProperties Namespace


StringCollection.ToArray Method

StringCollectionToArray Method

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string[] ToArray()
Public Function ToArray As String()

Return Value

Type: String
See Also

Reference

StringCollection Class
CodeSmith.CustomProperties Namespace


StringCollection.ToString Method

StringCollectionToString Method

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
See Also

Reference

StringCollection Class
CodeSmith.CustomProperties Namespace


StringCollection.TrimToSize Method

StringCollectionTrimToSize Method

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual void TrimToSize()
Public Overridable Sub TrimToSize
See Also

Reference

StringCollection Class
CodeSmith.CustomProperties Namespace


StringCollection.IStringCollectionEnumerator Interface

StringCollectionIStringCollectionEnumerator Interface

Supports type-safe iteration over a StringCollection.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public interface IStringCollectionEnumerator
Public Interface IStringCollectionEnumerator

The StringCollectionIStringCollectionEnumerator type exposes the following members.

Properties
 | Name | Description
Public property | Current |
Top
Methods
 | Name | Description
Public method | MoveNext |
Public method | Reset |
Top
See Also

Reference

CodeSmith.CustomProperties Namespace


IStringCollectionEnumerator Properties

The StringCollectionIStringCollectionEnumerator type exposes the following members.

Properties
 | Name | Description
Public property | Current |
Top
See Also

Reference

StringCollectionIStringCollectionEnumerator Interface
CodeSmith.CustomProperties Namespace


StringCollection.IStringCollectionEnumerator.Current Property

StringCollectionIStringCollectionEnumeratorCurrent Property

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
string Current { get; }
ReadOnly Property Current As String
    Get

Property Value

Type: String
See Also

Reference

StringCollectionIStringCollectionEnumerator Interface
CodeSmith.CustomProperties Namespace


IStringCollectionEnumerator Methods

The StringCollectionIStringCollectionEnumerator type exposes the following members.

Methods
 | Name | Description
Public method | MoveNext |
Public method | Reset |
Top
See Also

Reference

StringCollectionIStringCollectionEnumerator Interface
CodeSmith.CustomProperties Namespace


StringCollection.IStringCollectionEnumerator.MoveNext Method

StringCollectionIStringCollectionEnumeratorMoveNext Method

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
bool MoveNext()
Function MoveNext As Boolean

Return Value

Type: Boolean
See Also

Reference

StringCollectionIStringCollectionEnumerator Interface
CodeSmith.CustomProperties Namespace


StringCollection.IStringCollectionEnumerator.Reset Method

StringCollectionIStringCollectionEnumeratorReset Method

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
void Reset()
Sub Reset
See Also

Reference

StringCollectionIStringCollectionEnumerator Interface
CodeSmith.CustomProperties Namespace


StringCollection.Tag Enumeration

StringCollectionTag Enumeration

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected enum Tag
Protected Enumeration Tag
Members
Member name | Value | Description
Default | 0 |
See Also

Reference

CodeSmith.CustomProperties Namespace


StringCollectionEditor Class

Note: This API is now obsolete.

Allows you quickly edit a string collection.
Inheritance Hierarchy
SystemObject
System.Drawing.DesignUITypeEditor
CodeSmith.CustomPropertiesStringCollectionEditor

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[ObsoleteAttribute("The StringCollectionEditor has been deprecated.",
    false)]
public class StringCollectionEditor : UITypeEditor
<ObsoleteAttribute("The StringCollectionEditor has been deprecated.",
    false)>
Public Class StringCollectionEditor
    Inherits UITypeEditor

The StringCollectionEditor type exposes the following members.

Constructors
 | Name | Description
Public method | StringCollectionEditor | Initializes a new instance of the StringCollectionEditor class
Top
Properties
 | Name | Description
Public property | IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Inherited from UITypeEditor.)
Top
Methods
 | Name | Description
Public method | EditValue(IServiceProvider, Object) | Edits the value of the specified object using the editor style indicated by the GetEditStyle method. (Inherited from UITypeEditor.)
Public method | EditValue(ITypeDescriptorContext, IServiceProvider, Object) | (Overrides UITypeEditorEditValue(ITypeDescriptorContext, IServiceProvider, Object).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEditStyle | Gets the editor style used by the EditValue(IServiceProvider, Object) method. (Inherited from UITypeEditor.)
Public method | GetEditStyle(ITypeDescriptorContext) | (Overrides UITypeEditorGetEditStyle(ITypeDescriptorContext).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetPaintValueSupported | Indicates whether this editor supports painting a representation of an object's value. (Inherited from UITypeEditor.)
Public method | GetPaintValueSupported(ITypeDescriptorContext) | Indicates whether the specified context supports painting a representation of an object's value within the specified context. (Inherited from UITypeEditor.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PaintValue(PaintValueEventArgs) | Paints a representation of the value of an object using the specified PaintValueEventArgs. (Inherited from UITypeEditor.)
Public method | PaintValue(Object, Graphics, Rectangle) | Paints a representation of the value of the specified object to the specified canvas. (Inherited from UITypeEditor.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSmith.CustomProperties Namespace


StringCollectionEditor Constructor

Initializes a new instance of the StringCollectionEditor class

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public StringCollectionEditor()
Public Sub New
See Also

Reference

StringCollectionEditor Class
CodeSmith.CustomProperties Namespace


StringCollectionEditor Properties

The StringCollectionEditor type exposes the following members.

Properties
 | Name | Description
Public property | IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Inherited from UITypeEditor.)
Top
See Also

Reference

StringCollectionEditor Class
CodeSmith.CustomProperties Namespace


StringCollectionEditor Methods

The StringCollectionEditor type exposes the following members.

Methods
 | Name | Description
Public method | EditValue(IServiceProvider, Object) | Edits the value of the specified object using the editor style indicated by the GetEditStyle method. (Inherited from UITypeEditor.)
Public method | EditValue(ITypeDescriptorContext, IServiceProvider, Object) | (Overrides UITypeEditorEditValue(ITypeDescriptorContext, IServiceProvider, Object).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEditStyle | Gets the editor style used by the EditValue(IServiceProvider, Object) method. (Inherited from UITypeEditor.)
Public method | GetEditStyle(ITypeDescriptorContext) | (Overrides UITypeEditorGetEditStyle(ITypeDescriptorContext).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetPaintValueSupported | Indicates whether this editor supports painting a representation of an object's value. (Inherited from UITypeEditor.)
Public method | GetPaintValueSupported(ITypeDescriptorContext) | Indicates whether the specified context supports painting a representation of an object's value within the specified context. (Inherited from UITypeEditor.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PaintValue(PaintValueEventArgs) | Paints a representation of the value of an object using the specified PaintValueEventArgs. (Inherited from UITypeEditor.)
Public method | PaintValue(Object, Graphics, Rectangle) | Paints a representation of the value of the specified object to the specified canvas. (Inherited from UITypeEditor.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

StringCollectionEditor Class
CodeSmith.CustomProperties Namespace


StringCollectionEditor.EditValue Method

StringCollectionEditorEditValue Method

Overload List
 | Name | Description
Public method | EditValue(IServiceProvider, Object) | Edits the value of the specified object using the editor style indicated by the GetEditStyle method. (Inherited from UITypeEditor.)
Public method | EditValue(ITypeDescriptorContext, IServiceProvider, Object) | (Overrides UITypeEditorEditValue(ITypeDescriptorContext, IServiceProvider, Object).)
Top
See Also

Reference

StringCollectionEditor Class
CodeSmith.CustomProperties Namespace


StringCollectionEditor.EditValue Method (ITypeDescriptorContext, IServiceProvider, Object)

StringCollectionEditorEditValue Method (ITypeDescriptorContext, IServiceProvider, Object)

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override Object EditValue(
    ITypeDescriptorContext context,
    IServiceProvider provider,
    Object value
)
Public Overrides Function EditValue (
    context As ITypeDescriptorContext,
    provider As IServiceProvider,
    value As Object
) As Object

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
provider
Type: SystemIServiceProvider
value
Type: SystemObject

Return Value

Type: Object
See Also

Reference

StringCollectionEditor Class
EditValue Overload
CodeSmith.CustomProperties Namespace


StringCollectionEditor.GetEditStyle Method

StringCollectionEditorGetEditStyle Method

Overload List
 | Name | Description
Public method | GetEditStyle | Gets the editor style used by the EditValue(IServiceProvider, Object) method. (Inherited from UITypeEditor.)
Public method | GetEditStyle(ITypeDescriptorContext) | (Overrides UITypeEditorGetEditStyle(ITypeDescriptorContext).)
Top
See Also

Reference

StringCollectionEditor Class
CodeSmith.CustomProperties Namespace


StringCollectionEditor.GetEditStyle Method (ITypeDescriptorContext)

StringCollectionEditorGetEditStyle Method (ITypeDescriptorContext)

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override UITypeEditorEditStyle GetEditStyle(
    ITypeDescriptorContext context
)
Public Overrides Function GetEditStyle (
    context As ITypeDescriptorContext
) As UITypeEditorEditStyle

Parameters

context
Type: System.ComponentModelITypeDescriptorContext

Return Value

Type: UITypeEditorEditStyle
See Also

Reference

StringCollectionEditor Class
GetEditStyle Overload
CodeSmith.CustomProperties Namespace


StringCollectionEditorUI Class

Note: This API is now obsolete.

Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
CodeSmith.CustomPropertiesStringCollectionEditorUI

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[ObsoleteAttribute("The StringCollectionEditorUI has been deprecated.",
    false)]
public class StringCollectionEditorUI : Form
<ObsoleteAttribute("The StringCollectionEditorUI has been deprecated.",
    false)>
Public Class StringCollectionEditorUI
    Inherits Form

The StringCollectionEditorUI type exposes the following members.

Constructors
 | Name | Description
Public method | StringCollectionEditorUI | Initializes a new instance of the StringCollectionEditorUI class
Top
Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | Gets or sets a value that indicates whether controls in this container will be automatically validated when the focus changes. (Inherited from Form.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Form.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DeviceDpi | Gets the DPI value for the display device where the control is currently being displayed. (Inherited from Control.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
Protected property | MaximizedBounds | Gets or sets the size of the form when it is maximized. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Protected property | ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | StringCollection |
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Form.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Protected method | ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Protected method | AdjustFormScrollbars | Adjusts the scroll bars on the container based on the current control positions and the control currently selected. (Inherited from Form.)
Protected method | ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
Protected method | CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Form.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Form.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides FormDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | End |
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Form.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Public method | LogicalToDeviceUnits(Int32) | Converts a Logical DPI value to its equivalent DeviceUnit DPI value. (Inherited from Control.)
Public method | LogicalToDeviceUnits(Size) | Transforms a size from logical to device units by scaling it for the current DPI and rounding down to the nearest integer value for width and height. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnActivated | Raises the Activated event. (Inherited from Form.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnClosed | Raises the Closed event. (Inherited from Form.)
Protected method | OnClosing | Raises the Closing event. (Inherited from Form.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDpiChanged | Raises the DpiChanged event. (Inherited from Form.)
Protected method | OnDpiChangedAfterParent | Raises the DpiChangedAfterParent event. (Inherited from Control.)
Protected method | OnDpiChangedBeforeParent | Raises the DpiChangedBeforeParent event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Form.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Form.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Form.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
Protected method | OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
Protected method | OnGetDpiScaledSize | Raises the GetDpiScaledSize event. (Inherited from Form.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Form.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Form.)
Protected method | OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
Protected method | OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Form.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from Form.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
Protected method | OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
Protected method | OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
Protected method | OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
Protected method | OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
Protected method | OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Form.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Form.)
Protected method | OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
Protected method | OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnShown | Raises the Shown event. (Inherited from Form.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Form.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Form.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Form.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Form.)
Protected method | ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Form.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Form.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from Form.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Protected method | RescaleConstantsForDpi | Provides constants for rescaling the control when a DPI change occurs. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value (Empty). (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScaleBitmapLogicalToDevice | Scales a logical bitmap value to it's equivalent device unit value when a DPI change occurs. (Inherited from Control.)
Protected method | ScaleControl | Scales the location, size, padding, and margin of a control. (Inherited from Form.)
Protected method | ScaleCore | Performs scaling of the form. (Inherited from Form.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Form.)
Protected method | SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either or . (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Form.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog | Shows the form as a modal dialog box. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | Start |
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | Causes all of the child controls within a control that support validation to validate their data. (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | Causes all of the child controls within a control that support validation to validate their data. (Inherited from Form.)
Protected method | WndProc | Processes Windows messages. (Inherited from Form.)
Top
Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from Form.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DpiChanged | Occurs when the DPI setting changes on the display device where the form is currently displayed. (Inherited from Form.)
Public event | DpiChangedAfterParent | Occurs when the DPI setting for a control is changed programmatically after the DPI of its parent control or form has changed. (Inherited from Control.)
Public event | DpiChangedBeforeParent | Occurs when the DPI setting for a control is changed programmatically before a DPI change event for its parent control or form has occurred. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the Margin property changes. (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | Occurs when the TabStop property changes. (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

CodeSmith.CustomProperties Namespace


StringCollectionEditorUI Constructor

Initializes a new instance of the StringCollectionEditorUI class

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public StringCollectionEditorUI()
Public Sub New
See Also

Reference

StringCollectionEditorUI Class
CodeSmith.CustomProperties Namespace


StringCollectionEditorUI Properties

The StringCollectionEditorUI type exposes the following members.

Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | Gets or sets a value that indicates whether controls in this container will be automatically validated when the focus changes. (Inherited from Form.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Form.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DeviceDpi | Gets the DPI value for the display device where the control is currently being displayed. (Inherited from Control.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
Protected property | MaximizedBounds | Gets or sets the size of the form when it is maximized. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Protected property | ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | StringCollection |
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Form.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

StringCollectionEditorUI Class
CodeSmith.CustomProperties Namespace


StringCollectionEditorUI.StringCollection Property

StringCollectionEditorUIStringCollection Property

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public StringCollection StringCollection { get; }
Public ReadOnly Property StringCollection As StringCollection
    Get

Property Value

Type: StringCollection
See Also

Reference

StringCollectionEditorUI Class
CodeSmith.CustomProperties Namespace


StringCollectionEditorUI Methods

The StringCollectionEditorUI type exposes the following members.

Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Protected method | ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Protected method | AdjustFormScrollbars | Adjusts the scroll bars on the container based on the current control positions and the control currently selected. (Inherited from Form.)
Protected method | ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
Protected method | CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Form.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Form.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides FormDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | End |
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Form.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Public method | LogicalToDeviceUnits(Int32) | Converts a Logical DPI value to its equivalent DeviceUnit DPI value. (Inherited from Control.)
Public method | LogicalToDeviceUnits(Size) | Transforms a size from logical to device units by scaling it for the current DPI and rounding down to the nearest integer value for width and height. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnActivated | Raises the Activated event. (Inherited from Form.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnClosed | Raises the Closed event. (Inherited from Form.)
Protected method | OnClosing | Raises the Closing event. (Inherited from Form.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDpiChanged | Raises the DpiChanged event. (Inherited from Form.)
Protected method | OnDpiChangedAfterParent | Raises the DpiChangedAfterParent event. (Inherited from Control.)
Protected method | OnDpiChangedBeforeParent | Raises the DpiChangedBeforeParent event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Form.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Form.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Form.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
Protected method | OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
Protected method | OnGetDpiScaledSize | Raises the GetDpiScaledSize event. (Inherited from Form.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Form.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Form.)
Protected method | OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
Protected method | OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Form.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from Form.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
Protected method | OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
Protected method | OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
Protected method | OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
Protected method | OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
Protected method | OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Form.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Form.)
Protected method | OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
Protected method | OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnShown | Raises the Shown event. (Inherited from Form.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Form.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Form.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Form.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Form.)
Protected method | ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Form.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Form.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from Form.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Protected method | RescaleConstantsForDpi | Provides constants for rescaling the control when a DPI change occurs. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value (Empty). (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScaleBitmapLogicalToDevice | Scales a logical bitmap value to it's equivalent device unit value when a DPI change occurs. (Inherited from Control.)
Protected method | ScaleControl | Scales the location, size, padding, and margin of a control. (Inherited from Form.)
Protected method | ScaleCore | Performs scaling of the form. (Inherited from Form.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Form.)
Protected method | SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either or . (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Form.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog | Shows the form as a modal dialog box. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | Start |
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | Causes all of the child controls within a control that support validation to validate their data. (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | Causes all of the child controls within a control that support validation to validate their data. (Inherited from Form.)
Protected method | WndProc | Processes Windows messages. (Inherited from Form.)
Top
See Also

Reference

StringCollectionEditorUI Class
CodeSmith.CustomProperties Namespace


StringCollectionEditorUI.Dispose Method

StringCollectionEditorUIDispose Method

Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides FormDispose(Boolean).)
Top
See Also

Reference

StringCollectionEditorUI Class
CodeSmith.CustomProperties Namespace


StringCollectionEditorUI.Dispose Method (Boolean)

StringCollectionEditorUIDispose Method (Boolean)

Clean up any resources being used.

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
true if managed resources should be disposed; otherwise, false.
See Also

Reference

StringCollectionEditorUI Class
Dispose Overload
CodeSmith.CustomProperties Namespace


StringCollectionEditorUI.End Method

StringCollectionEditorUIEnd Method

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void End()
Public Sub End
See Also

Reference

StringCollectionEditorUI Class
CodeSmith.CustomProperties Namespace


StringCollectionEditorUI.Start Method

StringCollectionEditorUIStart Method

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void Start(
    IWindowsFormsEditorService editorService,
    Object value
)
Public Sub Start (
    editorService As IWindowsFormsEditorService,
    value As Object
)

Parameters

editorService
Type: System.Windows.Forms.DesignIWindowsFormsEditorService
value
Type: SystemObject
See Also

Reference

StringCollectionEditorUI Class
CodeSmith.CustomProperties Namespace


StringCollectionEditorUI Events

The StringCollectionEditorUI type exposes the following members.

Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from Form.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DpiChanged | Occurs when the DPI setting changes on the display device where the form is currently displayed. (Inherited from Form.)
Public event | DpiChangedAfterParent | Occurs when the DPI setting for a control is changed programmatically after the DPI of its parent control or form has changed. (Inherited from Control.)
Public event | DpiChangedBeforeParent | Occurs when the DPI setting for a control is changed programmatically before a DPI change event for its parent control or form has occurred. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the Margin property changes. (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | Occurs when the TabStop property changes. (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

StringCollectionEditorUI Class
CodeSmith.CustomProperties Namespace


StringCollectionSerializer Class

Note: This API is now obsolete.

Inheritance Hierarchy
SystemObject
CodeSmith.CustomPropertiesStringCollectionSerializer

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[ObsoleteAttribute("The StringCollectionSerializer has been deprecated.",
    false)]
public class StringCollectionSerializer : IPropertySerializer
<ObsoleteAttribute("The StringCollectionSerializer has been deprecated.",
    false)>
Public Class StringCollectionSerializer
    Implements IPropertySerializer

The StringCollectionSerializer type exposes the following members.

Constructors
 | Name | Description
Public method | StringCollectionSerializer | Initializes a new instance of the StringCollectionSerializer class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadProperty |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseDefaultValue |
Public method | ReadPropertyXml |
Public method | SaveProperty |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WritePropertyXml |
Top
See Also

Reference

CodeSmith.CustomProperties Namespace


StringCollectionSerializer Constructor

Initializes a new instance of the StringCollectionSerializer class

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public StringCollectionSerializer()
Public Sub New
See Also

Reference

StringCollectionSerializer Class
CodeSmith.CustomProperties Namespace


StringCollectionSerializer Methods

The StringCollectionSerializer type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadProperty |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseDefaultValue |
Public method | ReadPropertyXml |
Public method | SaveProperty |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WritePropertyXml |
Top
See Also

Reference

StringCollectionSerializer Class
CodeSmith.CustomProperties Namespace


StringCollectionSerializer.LoadProperty Method

StringCollectionSerializerLoadProperty Method

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public Object LoadProperty(
    PropertySerializerContext context,
    Object propertyValue
)
Public Function LoadProperty (
    context As PropertySerializerContext,
    propertyValue As Object
) As Object

Parameters

context
Type: CodeSmith.EnginePropertySerializerContext
propertyValue
Type: SystemObject

Return Value

Type: Object

Implements

IPropertySerializerLoadProperty(PropertySerializerContext, Object)
See Also

Reference

StringCollectionSerializer Class
CodeSmith.CustomProperties Namespace


StringCollectionSerializer.ParseDefaultValue Method

StringCollectionSerializerParseDefaultValue Method

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public Object ParseDefaultValue(
    PropertySerializerContext context,
    string defaultValue
)
Public Function ParseDefaultValue (
    context As PropertySerializerContext,
    defaultValue As String
) As Object

Parameters

context
Type: CodeSmith.EnginePropertySerializerContext
defaultValue
Type: SystemString

Return Value

Type: Object

Implements

IPropertySerializerParseDefaultValue(PropertySerializerContext, String)
See Also

Reference

StringCollectionSerializer Class
CodeSmith.CustomProperties Namespace


StringCollectionSerializer.ReadPropertyXml Method

StringCollectionSerializerReadPropertyXml Method

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public Object ReadPropertyXml(
    PropertySerializerContext context,
    XmlNode propertyValue
)
Public Function ReadPropertyXml (
    context As PropertySerializerContext,
    propertyValue As XmlNode
) As Object

Parameters

context
Type: CodeSmith.EnginePropertySerializerContext
propertyValue
Type: System.XmlXmlNode

Return Value

Type: Object

Implements

IPropertySerializerReadPropertyXml(PropertySerializerContext, XmlNode)
See Also

Reference

StringCollectionSerializer Class
CodeSmith.CustomProperties Namespace


StringCollectionSerializer.SaveProperty Method

StringCollectionSerializerSaveProperty Method

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public Object SaveProperty(
    PropertySerializerContext context,
    Object propertyValue
)
Public Function SaveProperty (
    context As PropertySerializerContext,
    propertyValue As Object
) As Object

Parameters

context
Type: CodeSmith.EnginePropertySerializerContext
propertyValue
Type: SystemObject

Return Value

Type: Object

Implements

IPropertySerializerSaveProperty(PropertySerializerContext, Object)
See Also

Reference

StringCollectionSerializer Class
CodeSmith.CustomProperties Namespace


StringCollectionSerializer.WritePropertyXml Method

StringCollectionSerializerWritePropertyXml Method

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void WritePropertyXml(
    PropertySerializerContext context,
    XmlWriter writer,
    Object propertyValue
)
Public Sub WritePropertyXml (
    context As PropertySerializerContext,
    writer As XmlWriter,
    propertyValue As Object
)

Parameters

context
Type: CodeSmith.EnginePropertySerializerContext
writer
Type: System.XmlXmlWriter
propertyValue
Type: SystemObject

Implements

IPropertySerializerWritePropertyXml(PropertySerializerContext, XmlWriter, Object)
See Also

Reference

StringCollectionSerializer Class
CodeSmith.CustomProperties Namespace


StringCollectionTypeConverter Class

Note: This API is now obsolete.

Inheritance Hierarchy
SystemObject
System.ComponentModelTypeConverter
CodeSmith.CustomPropertiesStringCollectionTypeConverter

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[ObsoleteAttribute("The StringCollectionTypeConverter has been deprecated.",
    false)]
public class StringCollectionTypeConverter : TypeConverter
<ObsoleteAttribute("The StringCollectionTypeConverter has been deprecated.",
    false)>
Public Class StringCollectionTypeConverter
    Inherits TypeConverter

The StringCollectionTypeConverter type exposes the following members.

Constructors
 | Name | Description
Public method | StringCollectionTypeConverter | Initializes a new instance of the StringCollectionTypeConverter class
Top
Methods
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | (Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | (Overrides TypeConverterCanConvertTo(ITypeDescriptorContext, Type).)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
Public method | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | (Overrides TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Public method | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
Public method | CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Protected method | GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object, Attribute) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported | Returns whether this object supports properties. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | Returns whether this object supports properties, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValues | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
Public method | GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
Public method | IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSmith.CustomProperties Namespace


StringCollectionTypeConverter Constructor

Initializes a new instance of the StringCollectionTypeConverter class

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public StringCollectionTypeConverter()
Public Sub New
See Also

Reference

StringCollectionTypeConverter Class
CodeSmith.CustomProperties Namespace


StringCollectionTypeConverter Methods

The StringCollectionTypeConverter type exposes the following members.

Methods
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | (Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | (Overrides TypeConverterCanConvertTo(ITypeDescriptorContext, Type).)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
Public method | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | (Overrides TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Public method | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
Public method | CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Protected method | GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object, Attribute) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported | Returns whether this object supports properties. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | Returns whether this object supports properties, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValues | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
Public method | GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
Public method | IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

StringCollectionTypeConverter Class
CodeSmith.CustomProperties Namespace


StringCollectionTypeConverter.CanConvertFrom Method

StringCollectionTypeConverterCanConvertFrom Method

Overload List
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | (Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Top
See Also

Reference

StringCollectionTypeConverter Class
CodeSmith.CustomProperties Namespace


StringCollectionTypeConverter.CanConvertFrom Method (ITypeDescriptorContext, Type)

StringCollectionTypeConverterCanConvertFrom Method (ITypeDescriptorContext, Type)

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override bool CanConvertFrom(
    ITypeDescriptorContext context,
    Type sourceType
)
Public Overrides Function CanConvertFrom (
    context As ITypeDescriptorContext,
    sourceType As Type
) As Boolean

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
sourceType
Type: SystemType

Return Value

Type: Boolean
See Also

Reference

StringCollectionTypeConverter Class
CanConvertFrom Overload
CodeSmith.CustomProperties Namespace


StringCollectionTypeConverter.CanConvertTo Method

StringCollectionTypeConverterCanConvertTo Method

Overload List
 | Name | Description
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | (Overrides TypeConverterCanConvertTo(ITypeDescriptorContext, Type).)
Top
See Also

Reference

StringCollectionTypeConverter Class
CodeSmith.CustomProperties Namespace


StringCollectionTypeConverter.CanConvertTo Method (ITypeDescriptorContext, Type)

StringCollectionTypeConverterCanConvertTo Method (ITypeDescriptorContext, Type)

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override bool CanConvertTo(
    ITypeDescriptorContext context,
    Type destinationType
)
Public Overrides Function CanConvertTo (
    context As ITypeDescriptorContext,
    destinationType As Type
) As Boolean

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
destinationType
Type: SystemType

Return Value

Type: Boolean
See Also

Reference

StringCollectionTypeConverter Class
CanConvertTo Overload
CodeSmith.CustomProperties Namespace


StringCollectionTypeConverter.ConvertFrom Method

StringCollectionTypeConverterConvertFrom Method

Overload List
 | Name | Description
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Top
See Also

Reference

StringCollectionTypeConverter Class
CodeSmith.CustomProperties Namespace


StringCollectionTypeConverter.ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

StringCollectionTypeConverterConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override Object ConvertFrom(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value
)
Public Overrides Function ConvertFrom (
    context As ITypeDescriptorContext,
    culture As CultureInfo,
    value As Object
) As Object

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
culture
Type: System.GlobalizationCultureInfo
value
Type: SystemObject

Return Value

Type: Object
See Also

Reference

StringCollectionTypeConverter Class
ConvertFrom Overload
CodeSmith.CustomProperties Namespace


StringCollectionTypeConverter.ConvertTo Method

StringCollectionTypeConverterConvertTo Method

Overload List
 | Name | Description
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | (Overrides TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Top
See Also

Reference

StringCollectionTypeConverter Class
CodeSmith.CustomProperties Namespace


StringCollectionTypeConverter.ConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)

StringCollectionTypeConverterConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override Object ConvertTo(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value,
    Type destinationType
)
Public Overrides Function ConvertTo (
    context As ITypeDescriptorContext,
    culture As CultureInfo,
    value As Object,
    destinationType As Type
) As Object

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
culture
Type: System.GlobalizationCultureInfo
value
Type: SystemObject
destinationType
Type: SystemType

Return Value

Type: Object
See Also

Reference

StringCollectionTypeConverter Class
ConvertTo Overload
CodeSmith.CustomProperties Namespace


XmlSerializedFilePicker Class

Allows you to browse for an Xml file.
Inheritance Hierarchy
SystemObject
System.Drawing.DesignUITypeEditor
CodeSmith.CustomPropertiesXmlSerializedFilePicker

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class XmlSerializedFilePicker : UITypeEditor
Public Class XmlSerializedFilePicker
    Inherits UITypeEditor

The XmlSerializedFilePicker type exposes the following members.

Constructors
 | Name | Description
Public method | XmlSerializedFilePicker | Initializes a new instance of the XmlSerializedFilePicker class
Top
Properties
 | Name | Description
Public property | IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Inherited from UITypeEditor.)
Top
Methods
 | Name | Description
Public method | EditValue(IServiceProvider, Object) | Edits the value of the specified object using the editor style indicated by the GetEditStyle method. (Inherited from UITypeEditor.)
Public method | EditValue(ITypeDescriptorContext, IServiceProvider, Object) | (Overrides UITypeEditorEditValue(ITypeDescriptorContext, IServiceProvider, Object).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEditStyle | Gets the editor style used by the EditValue(IServiceProvider, Object) method. (Inherited from UITypeEditor.)
Public method | GetEditStyle(ITypeDescriptorContext) | (Overrides UITypeEditorGetEditStyle(ITypeDescriptorContext).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetPaintValueSupported | Indicates whether this editor supports painting a representation of an object's value. (Inherited from UITypeEditor.)
Public method | GetPaintValueSupported(ITypeDescriptorContext) | Indicates whether the specified context supports painting a representation of an object's value within the specified context. (Inherited from UITypeEditor.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PaintValue(PaintValueEventArgs) | Paints a representation of the value of an object using the specified PaintValueEventArgs. (Inherited from UITypeEditor.)
Public method | PaintValue(Object, Graphics, Rectangle) | Paints a representation of the value of the specified object to the specified canvas. (Inherited from UITypeEditor.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSmith.CustomProperties Namespace


XmlSerializedFilePicker Constructor

Initializes a new instance of the XmlSerializedFilePicker class

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public XmlSerializedFilePicker()
Public Sub New
See Also

Reference

XmlSerializedFilePicker Class
CodeSmith.CustomProperties Namespace


XmlSerializedFilePicker Properties

The XmlSerializedFilePicker type exposes the following members.

Properties
 | Name | Description
Public property | IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Inherited from UITypeEditor.)
Top
See Also

Reference

XmlSerializedFilePicker Class
CodeSmith.CustomProperties Namespace


XmlSerializedFilePicker Methods

The XmlSerializedFilePicker type exposes the following members.

Methods
 | Name | Description
Public method | EditValue(IServiceProvider, Object) | Edits the value of the specified object using the editor style indicated by the GetEditStyle method. (Inherited from UITypeEditor.)
Public method | EditValue(ITypeDescriptorContext, IServiceProvider, Object) | (Overrides UITypeEditorEditValue(ITypeDescriptorContext, IServiceProvider, Object).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEditStyle | Gets the editor style used by the EditValue(IServiceProvider, Object) method. (Inherited from UITypeEditor.)
Public method | GetEditStyle(ITypeDescriptorContext) | (Overrides UITypeEditorGetEditStyle(ITypeDescriptorContext).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetPaintValueSupported | Indicates whether this editor supports painting a representation of an object's value. (Inherited from UITypeEditor.)
Public method | GetPaintValueSupported(ITypeDescriptorContext) | Indicates whether the specified context supports painting a representation of an object's value within the specified context. (Inherited from UITypeEditor.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PaintValue(PaintValueEventArgs) | Paints a representation of the value of an object using the specified PaintValueEventArgs. (Inherited from UITypeEditor.)
Public method | PaintValue(Object, Graphics, Rectangle) | Paints a representation of the value of the specified object to the specified canvas. (Inherited from UITypeEditor.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XmlSerializedFilePicker Class
CodeSmith.CustomProperties Namespace


XmlSerializedFilePicker.EditValue Method

XmlSerializedFilePickerEditValue Method

Overload List
 | Name | Description
Public method | EditValue(IServiceProvider, Object) | Edits the value of the specified object using the editor style indicated by the GetEditStyle method. (Inherited from UITypeEditor.)
Public method | EditValue(ITypeDescriptorContext, IServiceProvider, Object) | (Overrides UITypeEditorEditValue(ITypeDescriptorContext, IServiceProvider, Object).)
Top
See Also

Reference

XmlSerializedFilePicker Class
CodeSmith.CustomProperties Namespace


XmlSerializedFilePicker.EditValue Method (ITypeDescriptorContext, IServiceProvider, Object)

XmlSerializedFilePickerEditValue Method (ITypeDescriptorContext, IServiceProvider, Object)

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override Object EditValue(
    ITypeDescriptorContext context,
    IServiceProvider provider,
    Object value
)
Public Overrides Function EditValue (
    context As ITypeDescriptorContext,
    provider As IServiceProvider,
    value As Object
) As Object

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
provider
Type: SystemIServiceProvider
value
Type: SystemObject

Return Value

Type: Object
See Also

Reference

XmlSerializedFilePicker Class
EditValue Overload
CodeSmith.CustomProperties Namespace


XmlSerializedFilePicker.GetEditStyle Method

XmlSerializedFilePickerGetEditStyle Method

Overload List
 | Name | Description
Public method | GetEditStyle | Gets the editor style used by the EditValue(IServiceProvider, Object) method. (Inherited from UITypeEditor.)
Public method | GetEditStyle(ITypeDescriptorContext) | (Overrides UITypeEditorGetEditStyle(ITypeDescriptorContext).)
Top
See Also

Reference

XmlSerializedFilePicker Class
CodeSmith.CustomProperties Namespace


XmlSerializedFilePicker.GetEditStyle Method (ITypeDescriptorContext)

XmlSerializedFilePickerGetEditStyle Method (ITypeDescriptorContext)

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override UITypeEditorEditStyle GetEditStyle(
    ITypeDescriptorContext context
)
Public Overrides Function GetEditStyle (
    context As ITypeDescriptorContext
) As UITypeEditorEditStyle

Parameters

context
Type: System.ComponentModelITypeDescriptorContext

Return Value

Type: UITypeEditorEditStyle
See Also

Reference

XmlSerializedFilePicker Class
GetEditStyle Overload
CodeSmith.CustomProperties Namespace


XmlSerializedTypeConverter Class

Inheritance Hierarchy
SystemObject
System.ComponentModelTypeConverter
CodeSmith.CustomPropertiesXmlSerializedTypeConverter

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class XmlSerializedTypeConverter : TypeConverter
Public Class XmlSerializedTypeConverter
    Inherits TypeConverter

The XmlSerializedTypeConverter type exposes the following members.

Constructors
 | Name | Description
Public method | XmlSerializedTypeConverter | Initializes a new instance of the XmlSerializedTypeConverter class
Top
Methods
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | (Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | (Overrides TypeConverterCanConvertTo(ITypeDescriptorContext, Type).)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
Public method | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | (Overrides TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Public method | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
Public method | CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Protected method | GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object, Attribute) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported | Returns whether this object supports properties. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | Returns whether this object supports properties, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValues | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
Public method | GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
Public method | IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSmith.CustomProperties Namespace


XmlSerializedTypeConverter Constructor

Initializes a new instance of the XmlSerializedTypeConverter class

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public XmlSerializedTypeConverter()
Public Sub New
See Also

Reference

XmlSerializedTypeConverter Class
CodeSmith.CustomProperties Namespace


XmlSerializedTypeConverter Methods

The XmlSerializedTypeConverter type exposes the following members.

Methods
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | (Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | (Overrides TypeConverterCanConvertTo(ITypeDescriptorContext, Type).)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
Public method | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | (Overrides TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Public method | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
Public method | CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Protected method | GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object, Attribute) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported | Returns whether this object supports properties. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | Returns whether this object supports properties, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValues | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
Public method | GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
Public method | IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XmlSerializedTypeConverter Class
CodeSmith.CustomProperties Namespace


XmlSerializedTypeConverter.CanConvertFrom Method

XmlSerializedTypeConverterCanConvertFrom Method

Overload List
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | (Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Top
See Also

Reference

XmlSerializedTypeConverter Class
CodeSmith.CustomProperties Namespace


XmlSerializedTypeConverter.CanConvertFrom Method (ITypeDescriptorContext, Type)

XmlSerializedTypeConverterCanConvertFrom Method (ITypeDescriptorContext, Type)

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override bool CanConvertFrom(
    ITypeDescriptorContext context,
    Type sourceType
)
Public Overrides Function CanConvertFrom (
    context As ITypeDescriptorContext,
    sourceType As Type
) As Boolean

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
sourceType
Type: SystemType

Return Value

Type: Boolean
See Also

Reference

XmlSerializedTypeConverter Class
CanConvertFrom Overload
CodeSmith.CustomProperties Namespace


XmlSerializedTypeConverter.CanConvertTo Method

XmlSerializedTypeConverterCanConvertTo Method

Overload List
 | Name | Description
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | (Overrides TypeConverterCanConvertTo(ITypeDescriptorContext, Type).)
Top
See Also

Reference

XmlSerializedTypeConverter Class
CodeSmith.CustomProperties Namespace


XmlSerializedTypeConverter.CanConvertTo Method (ITypeDescriptorContext, Type)

XmlSerializedTypeConverterCanConvertTo Method (ITypeDescriptorContext, Type)

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override bool CanConvertTo(
    ITypeDescriptorContext context,
    Type destinationType
)
Public Overrides Function CanConvertTo (
    context As ITypeDescriptorContext,
    destinationType As Type
) As Boolean

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
destinationType
Type: SystemType

Return Value

Type: Boolean
See Also

Reference

XmlSerializedTypeConverter Class
CanConvertTo Overload
CodeSmith.CustomProperties Namespace


XmlSerializedTypeConverter.ConvertFrom Method

XmlSerializedTypeConverterConvertFrom Method

Overload List
 | Name | Description
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Top
See Also

Reference

XmlSerializedTypeConverter Class
CodeSmith.CustomProperties Namespace


XmlSerializedTypeConverter.ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

XmlSerializedTypeConverterConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override Object ConvertFrom(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value
)
Public Overrides Function ConvertFrom (
    context As ITypeDescriptorContext,
    culture As CultureInfo,
    value As Object
) As Object

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
culture
Type: System.GlobalizationCultureInfo
value
Type: SystemObject

Return Value

Type: Object
See Also

Reference

XmlSerializedTypeConverter Class
ConvertFrom Overload
CodeSmith.CustomProperties Namespace


XmlSerializedTypeConverter.ConvertTo Method

XmlSerializedTypeConverterConvertTo Method

Overload List
 | Name | Description
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | (Overrides TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Top
See Also

Reference

XmlSerializedTypeConverter Class
CodeSmith.CustomProperties Namespace


XmlSerializedTypeConverter.ConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)

XmlSerializedTypeConverterConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)

Namespace: CodeSmith.CustomProperties
Assembly: CodeSmith.CustomProperties (in CodeSmith.CustomProperties.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override Object ConvertTo(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value,
    Type destinationType
)
Public Overrides Function ConvertTo (
    context As ITypeDescriptorContext,
    culture As CultureInfo,
    value As Object,
    destinationType As Type
) As Object

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
culture
Type: System.GlobalizationCultureInfo
value
Type: SystemObject
destinationType
Type: SystemType

Return Value

Type: Object
See Also

Reference

XmlSerializedTypeConverter Class
ConvertTo Overload
CodeSmith.CustomProperties Namespace


CodeSmith.Engine Namespace

The CodeSmith engine can be used to programmatically generate code from templates.
Classes
 | Class | Description
Public class | ActiveSnippetCompleteEventArgs |
Public class | ActiveSnippetConfiguration |
Public class | ActiveSnippetEventArgs |
Public class | ActiveSnippetGenerator |
Public class | ActiveSnippetMapping |
Public class | ActiveSnippetMappingCollection |
Public class | AdoHelperTFactory | The AdoHelper class is intended to encapsulate high performance, scalable best practices for common data access uses.
Public class | BusinessObjectBase | Obsolete.
Public class | CachedConfiguration |
Public class | CodeGeneratorBase |
Public class | CodeSmithDomainFactory |
Public class | CodeTemplate | All templates must derive from this class.
Public class | CodeTemplateCompiler | This class can be used to compile templates.
Public class | CodeTemplateInfo |
Public class | CodeTemplatePropertyAttribute | Obsolete.
Public class | CodeTemplateValidationException |
Public class | CodeTemplateWriter |
Public class | CompileTemplateResult |
Public class | Configuration |
Public class | ConfigurationBase |
Public class | ConfigurationBaseT | Obsolete.
Public class | ConfigurationCollectionBaseT |
Public class | ConfigurationItemBase |
Public class | ContextItem |
Public class | Control |
Public class | ControlCollection |
Public class | ControlCollectionControlCollectionEnumerator |
Public class | DefaultEngineHost |
Public class | DefaultLogger |
Public class | DelegateControl |
Public class | DelimitedStringCollection | A collection that provides notifications when items get added, removed, or when the whole list is refreshed.
Public class | DelimitedStringCollectionDelimitedStringTypeConverter | A type converter for the DelimitedStringCollection.
Public class | DidNotAcceptTrialException |
Public class | EmptyControlCollection |
Public class | EngineConstants |
Public class | EngineHostBase |
Public class | FeatureNotAllowedException |
Public class | GenerateCodeResult |
Public class | GenerateEndEventArgs |
Public class | GenerateEventArgs |
Public class | GenerateStartEventArgs |
Public class | GenerateTemplateResult |
Public class | GeneratorCompleteEventArgs | EventArgs derived type which holds the custom event fields
Public class | GeneratorErrorEventArgs | EventArgs derived type which holds the custom event fields
Public class | GeneratorEventsCallbackBase |
Public class | GeneratorProgressEventArgs | EventArgs derived type which holds the custom event fields
Public class | HashCodeCombiner |
Public class | IndexedEnumerable | IndexedEnumerable makes enumerating over collections much easier by implementing properties like: IsEven, IsOdd, IsLast.
Public class | IndexedEnumerableT | IndexedEnumerable makes enumerating over collections much easier by implementing properties like: IsEven, IsOdd, IsLast.
Public class | IndexedEnumerableTEntryItem | Represents each entry returned within a collection, containing the _value and whether it is the first and/or the last entry in the collection's. enumeration
Public class | InMemoryCodeTemplateInfo |
Public class | InsertRegionMergeStrategy | This merge strategy can be used to insert the template output into a named region inside an existing file and preserve the rest of the content in the file. The initialization string should be of the format: "RegionName=<RegionName>;Language=<Language>"
Public class | InvalidPublisherException |
Public class | ItemRegisteredEventArgs |
Public class | LanguageRegionDefinition |
Public class | LanguageRegionDefinitionCollection |
Public class | Logger |
Public class | Map |
Public class | MapCollection |
Public class | MergeContext |
Public class | MergeStrategyAlias |
Public class | MergeStrategyAliasCollection |
Public class | MessageEventArgs | EventArgs derived type which holds the custom event fields
Public class | MethodPropertyRefresher |
Public class | NotCheckedAttribute | Excludes a property from being required.
Public class | OptionalAttribute | Marks a property as optional.
Public class | OutputCancelEventArgs |
Public class | OutputFile | A class representing a template output file.
Public class | OutputRegisteredEventArgs | EventArgs derived type which holds the custom event fields
Public class | PreserveRegionsMergeStrategy | This merge strategy can be used to preserve designated custom regions inside an existing file and regenerate the rest of the content in the file. The initialization string should be of the format: "RegionNameRegex=<RegexExpression>;Language=<Language>"
Public class | Progress | Progress information.
Public class | ProgressEventArgs |
Public class | ProjectCodeGenerator |
Public class | PropertyDesignerMap |
Public class | PropertyDesignerMapCollection |
Public class | PropertyRefresherAttribute |
Public class | PropertyRefresherContext | Context information passed into the IPropertyRefresher methods.
Public class | PropertyRequiredValidationError |
Public class | PropertySerializerAttribute |
Public class | PropertySerializerContext | Context information passed into the IPropertySerializer methods.
Public class | PropertySetCache |
Public class | RegisteredContent |
Public class | SafeDataReader | This is a DataReader that 'fixes' any null values before they are returned to our business code.
Public class | SchemaArguments |
Public class | SerializableDictionaryTKey, TValue | Represents a xml serializable collection of keys and values.
Public class | ShowDialogEventArgs |
Public class | StatusChangedEventArgs |
Public class | StringUtil |
Public class | TemplateContext |
Public class | TemplateEngine |
Public class | TemplateError |
Public class | TemplateErrorCollection |
Public class | TemplateParseResult |
Public class | TextWriterCollection |
Public class | Util |
Public class | ValidationError | Provides information about a template validation error.
Public class | ValidationErrorCollection |
Public class | VersionCheck |
Public class | VersionInfo |
Public class | VirtualCollectionBaseT | A base Collection used to load data on depand from database.
Public class | XmlPropertyDirectiveTypeConverter | This class can be used to convert to and from an XmlNode for a class that supports XML serialization.
Public class | XmlPropertyFilePicker | This type editor can be used on a class that supports XML serialization to allow the user to pick an XML file and have that XML file deserialized into the target class.
Public class | XmlPropertyRefresher |
Public class | XmlPropertySerializer |
Public class | XmlPropertyTypeConverter | This class can be used to convert to and from an XmlNode for a class that supports XML serialization.
Public class | XmlSchemaFilePicker | Allows you to browse for an XSD Schema.
Public class | XmlSchemaSerializer |
Public class | XsdHelper |
Interfaces
 | Interface | Description
Public interface | ICodeTemplateInfo |
Public interface | IConfiguration |
Public interface | IEngineHost |
Public interface | IIndexed | Interface defining an indexed object.
Public interface | ILogger |
Public interface | IMergeStrategy | This interface can be implemented to create a merge strategy.
Public interface | IPropertyRefresher | Interface that all property refreshers must implement.
Public interface | IPropertySerializer | Interface that all property serializers must implement.
Delegates
 | Delegate | Description
Public delegate | AdoHelperTFactoryRowUpdatedHandler | Delegate for creating a RowUpdatedEvent handler
Public delegate | AdoHelperTFactoryRowUpdatingHandler | Delegate for creating a RowUpdatingEvent handler
Public delegate | GenerateEndEventHandler |
Public delegate | GenerateStartEventHandler |
Public delegate | GeneratorCompleteEventHandler | This represents the delegate method prototype that event receivers must implement
Public delegate | GeneratorErrorEventHandler | This represents the delegate method prototype that event receivers must implement
Public delegate | GeneratorProgressEventHandler | This represents the delegate method prototype that event receivers must implement
Public delegate | MessageEventHandler | This represents the delegate method prototype that event receivers must implement
Public delegate | OutputCancelEventHandler | This represents the delegate method prototype that event receivers must implement
Public delegate | OutputRegisteredEventHandler | This represents the delegate method prototype that event receivers must implement
Public delegate | ProgressEventHandler |
Public delegate | RenderMethod |
Public delegate | StatusChangedEventHandler |
Enumerations
 | Enumeration | Description
Protected enumeration | AdoHelperTFactoryAdoConnectionOwnership | This enum is used to indicate whether the connection was provided by the caller, or created by AdoHelper, so that we can set the appropriate CommandBehavior when calling ExecuteReader()
Public enumeration | CodeTemplateOutputType |
Public enumeration | CodeTemplatePropertyOption | Obsolete.
Public enumeration | LanguageKind |
Public enumeration | LogLevel |
Public enumeration | OutputLanguage |
Public enumeration | TemplateErrorLevel |
Public enumeration | TemplateErrorType |
Public enumeration | TemplateState |


ActiveSnippetCompleteEventArgs Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
CodeSmith.EngineActiveSnippetEventArgs
CodeSmith.EngineActiveSnippetCompleteEventArgs

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
public class ActiveSnippetCompleteEventArgs : ActiveSnippetEventArgs
<SerializableAttribute>
Public Class ActiveSnippetCompleteEventArgs
    Inherits ActiveSnippetEventArgs

The ActiveSnippetCompleteEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ActiveSnippetCompleteEventArgs | Initializes a new instance of the ActiveSnippetCompleteEventArgs class
Top
Properties
 | Name | Description
Public property | LineLength | (Inherited from ActiveSnippetEventArgs.)
Public property | LineNumber | (Inherited from ActiveSnippetEventArgs.)
Public property | OutputText |
Public property | ShowUsage | (Inherited from ActiveSnippetEventArgs.)
Public property | SourceText | (Inherited from ActiveSnippetEventArgs.)
Public property | Successful |
Public property | TargetExtension | (Inherited from ActiveSnippetEventArgs.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSmith.Engine Namespace


ActiveSnippetCompleteEventArgs Constructor

Initializes a new instance of the ActiveSnippetCompleteEventArgs class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ActiveSnippetCompleteEventArgs()
Public Sub New
See Also

Reference

ActiveSnippetCompleteEventArgs Class
CodeSmith.Engine Namespace


ActiveSnippetCompleteEventArgs Properties

The ActiveSnippetCompleteEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | LineLength | (Inherited from ActiveSnippetEventArgs.)
Public property | LineNumber | (Inherited from ActiveSnippetEventArgs.)
Public property | OutputText |
Public property | ShowUsage | (Inherited from ActiveSnippetEventArgs.)
Public property | SourceText | (Inherited from ActiveSnippetEventArgs.)
Public property | Successful |
Public property | TargetExtension | (Inherited from ActiveSnippetEventArgs.)
Top
See Also

Reference

ActiveSnippetCompleteEventArgs Class
CodeSmith.Engine Namespace


ActiveSnippetCompleteEventArgs.OutputText Property

ActiveSnippetCompleteEventArgsOutputText Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string OutputText { get; set; }
Public Property OutputText As String
    Get
    Set

Property Value

Type: String
See Also

Reference

ActiveSnippetCompleteEventArgs Class
CodeSmith.Engine Namespace


ActiveSnippetCompleteEventArgs.Successful Property

ActiveSnippetCompleteEventArgsSuccessful Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool Successful { get; set; }
Public Property Successful As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

ActiveSnippetCompleteEventArgs Class
CodeSmith.Engine Namespace


ActiveSnippetCompleteEventArgs Methods

The ActiveSnippetCompleteEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ActiveSnippetCompleteEventArgs Class
CodeSmith.Engine Namespace


ActiveSnippetConfiguration Class

Inheritance Hierarchy
SystemObject
CodeSmith.EngineConfigurationBase
CodeSmith.EngineActiveSnippetConfiguration

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class ActiveSnippetConfiguration : ConfigurationBase
Public Class ActiveSnippetConfiguration
    Inherits ConfigurationBase

The ActiveSnippetConfiguration type exposes the following members.

Constructors
 | Name | Description
Public method | ActiveSnippetConfiguration | Initializes a new instance of the ActiveSnippetConfiguration class
Top
Properties
 | Name | Description
Public property | ConfigurationVersion | (Inherited from ConfigurationBase.)
 | Instance | Gets the current singleton instance of Configuration.
Protected property | NamePrefix | (Overrides ConfigurationBaseNamePrefix.)
Public property | SnippetMappings | A collection of Active Snippet maps.
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from ConfigurationBase.)
Public method | EnsureInitialize | This method is here purely to make sure that we don't make a double call to the Initialize method while initializing configuration. (Inherited from ConfigurationBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find | Finds the specified alias.
Public method | FindSimilar | Finds the ActiveSnippetMapping instance that match closest to the alias.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetValueT(String) | (Inherited from ConfigurationBase.)
Protected method | GetValueT(String, T) | (Inherited from ConfigurationBase.)
Protected method | GetValueT(String, Action) | (Inherited from ConfigurationBase.)
Protected method | GetValueT(String, T, FuncT, Boolean) | (Inherited from ConfigurationBase.)
Protected method | GetValueT(String, Action, FuncT, Boolean) | (Inherited from ConfigurationBase.)
Protected method | GetValueT(String, String, T) | (Inherited from ConfigurationBase.)
Protected method | GetValueT(String, String, Action) | (Inherited from ConfigurationBase.)
Protected method | GetValueT(String, String, T, FuncT, Boolean) | (Inherited from ConfigurationBase.)
Protected method | GetValueT(String, String, Action, FuncT, Boolean) | (Inherited from ConfigurationBase.)
Public method | Initialize | (Overrides ConfigurationBaseInitialize.)
Public method | LoadDefaults | (Overrides ConfigurationBaseLoadDefaults.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ResetDefaults | (Overrides ConfigurationBaseResetDefaults.)
Protected method | SetValueT(String, T) | (Inherited from ConfigurationBase.)
Protected method | SetValueT(String, String, T) | (Inherited from ConfigurationBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Upgrade | (Overrides ConfigurationBaseUpgrade.)
Protected method | UpgradeFileT | Attempts to update configuration from a configuration file. The version of CodeSmith must be older than CodeSmith 5.1. (Inherited from ConfigurationBase.)
Top
See Also

Reference

CodeSmith.Engine Namespace


ActiveSnippetConfiguration Constructor

Initializes a new instance of the ActiveSnippetConfiguration class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ActiveSnippetConfiguration()
Public Sub New
See Also

Reference

ActiveSnippetConfiguration Class
CodeSmith.Engine Namespace


ActiveSnippetConfiguration Properties

The ActiveSnippetConfiguration type exposes the following members.

Properties
 | Name | Description
Public property | ConfigurationVersion | (Inherited from ConfigurationBase.)
 | Instance | Gets the current singleton instance of Configuration.
Protected property | NamePrefix | (Overrides ConfigurationBaseNamePrefix.)
Public property | SnippetMappings | A collection of Active Snippet maps.
Top
See Also

Reference

ActiveSnippetConfiguration Class
CodeSmith.Engine Namespace


ActiveSnippetConfiguration.Instance Property

ActiveSnippetConfigurationInstance Property

Gets the current singleton instance of Configuration.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static ActiveSnippetConfiguration Instance { get; }
Public Shared ReadOnly Property Instance As ActiveSnippetConfiguration
    Get

Property Value

Type: ActiveSnippetConfiguration
The current singleton instance.
Remarks
An instance of Configuration wont be created until the very first call to the sealed class. This is a CLR optimization that provides a properly lazy-loading singleton.
See Also

Reference

ActiveSnippetConfiguration Class
CodeSmith.Engine Namespace


ActiveSnippetConfiguration.NamePrefix Property

ActiveSnippetConfigurationNamePrefix Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected override string NamePrefix { get; }
Protected Overrides ReadOnly Property NamePrefix As String
    Get

Property Value

Type: String
See Also

Reference

ActiveSnippetConfiguration Class
CodeSmith.Engine Namespace


ActiveSnippetConfiguration.SnippetMappings Property

ActiveSnippetConfigurationSnippetMappings Property

A collection of Active Snippet maps.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public IList<ActiveSnippetMapping> SnippetMappings { get; set; }
Public Property SnippetMappings As IList(Of ActiveSnippetMapping)
    Get
    Set

Property Value

Type: IList ActiveSnippetMapping
Remarks
The key for the collection is the alias of the template map.
See Also

Reference

ActiveSnippetConfiguration Class
CodeSmith.Engine Namespace


ActiveSnippetConfiguration Methods

The ActiveSnippetConfiguration type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from ConfigurationBase.)
Public method | EnsureInitialize | This method is here purely to make sure that we don't make a double call to the Initialize method while initializing configuration. (Inherited from ConfigurationBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find | Finds the specified alias.
Public method | FindSimilar | Finds the ActiveSnippetMapping instance that match closest to the alias.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetValueT(String) | (Inherited from ConfigurationBase.)
Protected method | GetValueT(String, T) | (Inherited from ConfigurationBase.)
Protected method | GetValueT(String, Action) | (Inherited from ConfigurationBase.)
Protected method | GetValueT(String, T, FuncT, Boolean) | (Inherited from ConfigurationBase.)
Protected method | GetValueT(String, Action, FuncT, Boolean) | (Inherited from ConfigurationBase.)
Protected method | GetValueT(String, String, T) | (Inherited from ConfigurationBase.)
Protected method | GetValueT(String, String, Action) | (Inherited from ConfigurationBase.)
Protected method | GetValueT(String, String, T, FuncT, Boolean) | (Inherited from ConfigurationBase.)
Protected method | GetValueT(String, String, Action, FuncT, Boolean) | (Inherited from ConfigurationBase.)
Public method | Initialize | (Overrides ConfigurationBaseInitialize.)
Public method | LoadDefaults | (Overrides ConfigurationBaseLoadDefaults.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ResetDefaults | (Overrides ConfigurationBaseResetDefaults.)
Protected method | SetValueT(String, T) | (Inherited from ConfigurationBase.)
Protected method | SetValueT(String, String, T) | (Inherited from ConfigurationBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Upgrade | (Overrides ConfigurationBaseUpgrade.)
Protected method | UpgradeFileT | Attempts to update configuration from a configuration file. The version of CodeSmith must be older than CodeSmith 5.1. (Inherited from ConfigurationBase.)
Top
See Also

Reference

ActiveSnippetConfiguration Class
CodeSmith.Engine Namespace


ActiveSnippetConfiguration.Find Method

ActiveSnippetConfigurationFind Method

Finds the specified alias.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ActiveSnippetMapping Find(
    string alias,
    string targetExtension
)
Public Function Find (
    alias As String,
    targetExtension As String
) As ActiveSnippetMapping

Parameters

alias
Type: SystemString
The alias.
targetExtension
Type: SystemString
The target extension.

Return Value

Type: ActiveSnippetMapping
The ActiveSnippetMapping instance that match closest to the alias, extension pair.
See Also

Reference

ActiveSnippetConfiguration Class
CodeSmith.Engine Namespace


ActiveSnippetConfiguration.FindSimilar Method

ActiveSnippetConfigurationFindSimilar Method

Finds the ActiveSnippetMapping instance that match closest to the alias.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public IList<ActiveSnippetMapping> FindSimilar(
    string partialAlias,
    string targetExtension
)
Public Function FindSimilar (
    partialAlias As String,
    targetExtension As String
) As IList(Of ActiveSnippetMapping)

Parameters

partialAlias
Type: SystemString
The partial alias.
targetExtension
Type: SystemString
The target extension.

Return Value

Type: IList ActiveSnippetMapping
The ActiveSnippetMapping instance that match closest to the alias.
See Also

Reference

ActiveSnippetConfiguration Class
CodeSmith.Engine Namespace


ActiveSnippetConfiguration.Initialize Method

ActiveSnippetConfigurationInitialize Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override void Initialize()
Public Overrides Sub Initialize
See Also

Reference

ActiveSnippetConfiguration Class
CodeSmith.Engine Namespace


ActiveSnippetConfiguration.LoadDefaults Method

ActiveSnippetConfigurationLoadDefaults Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override void LoadDefaults()
Public Overrides Sub LoadDefaults
See Also

Reference

ActiveSnippetConfiguration Class
CodeSmith.Engine Namespace


ActiveSnippetConfiguration.ResetDefaults Method

ActiveSnippetConfigurationResetDefaults Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override void ResetDefaults()
Public Overrides Sub ResetDefaults
See Also

Reference

ActiveSnippetConfiguration Class
CodeSmith.Engine Namespace


ActiveSnippetConfiguration.Upgrade Method

ActiveSnippetConfigurationUpgrade Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override void Upgrade()
Public Overrides Sub Upgrade
See Also

Reference

ActiveSnippetConfiguration Class
CodeSmith.Engine Namespace


ActiveSnippetEventArgs Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
CodeSmith.EngineActiveSnippetEventArgs
CodeSmith.EngineActiveSnippetCompleteEventArgs

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
public class ActiveSnippetEventArgs : EventArgs
<SerializableAttribute>
Public Class ActiveSnippetEventArgs
    Inherits EventArgs

The ActiveSnippetEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ActiveSnippetEventArgs | Initializes a new instance of the ActiveSnippetEventArgs class
Top
Properties
 | Name | Description
Public property | LineLength |
Public property | LineNumber |
Public property | ShowUsage |
Public property | SourceText |
Public property | TargetExtension |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSmith.Engine Namespace


ActiveSnippetEventArgs Constructor

Initializes a new instance of the ActiveSnippetEventArgs class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ActiveSnippetEventArgs()
Public Sub New
See Also

Reference

ActiveSnippetEventArgs Class
CodeSmith.Engine Namespace


ActiveSnippetEventArgs Properties

The ActiveSnippetEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | LineLength |
Public property | LineNumber |
Public property | ShowUsage |
Public property | SourceText |
Public property | TargetExtension |
Top
See Also

Reference

ActiveSnippetEventArgs Class
CodeSmith.Engine Namespace


ActiveSnippetEventArgs.LineLength Property

ActiveSnippetEventArgsLineLength Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public int LineLength { get; set; }
Public Property LineLength As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

ActiveSnippetEventArgs Class
CodeSmith.Engine Namespace


ActiveSnippetEventArgs.LineNumber Property

ActiveSnippetEventArgsLineNumber Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public int LineNumber { get; set; }
Public Property LineNumber As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

ActiveSnippetEventArgs Class
CodeSmith.Engine Namespace


ActiveSnippetEventArgs.ShowUsage Property

ActiveSnippetEventArgsShowUsage Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool ShowUsage { get; set; }
Public Property ShowUsage As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

ActiveSnippetEventArgs Class
CodeSmith.Engine Namespace


ActiveSnippetEventArgs.SourceText Property

ActiveSnippetEventArgsSourceText Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string SourceText { get; set; }
Public Property SourceText As String
    Get
    Set

Property Value

Type: String
See Also

Reference

ActiveSnippetEventArgs Class
CodeSmith.Engine Namespace


ActiveSnippetEventArgs.TargetExtension Property

ActiveSnippetEventArgsTargetExtension Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string TargetExtension { get; set; }
Public Property TargetExtension As String
    Get
    Set

Property Value

Type: String
See Also

Reference

ActiveSnippetEventArgs Class
CodeSmith.Engine Namespace


ActiveSnippetEventArgs Methods

The ActiveSnippetEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ActiveSnippetEventArgs Class
CodeSmith.Engine Namespace


ActiveSnippetGenerator Class

Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
CodeSmith.EngineCodeGeneratorBase
CodeSmith.EngineActiveSnippetGenerator

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class ActiveSnippetGenerator : CodeGeneratorBase
Public Class ActiveSnippetGenerator
    Inherits CodeGeneratorBase

The ActiveSnippetGenerator type exposes the following members.

Constructors
 | Name | Description
Public method | ActiveSnippetGenerator | Initializes a new instance of the ActiveSnippetGenerator class
Top
Properties
 | Name | Description
Public property | Debug | (Inherited from CodeGeneratorBase.)
Public property | KeepTempFiles | (Inherited from CodeGeneratorBase.)
Public property | Properties | (Inherited from CodeGeneratorBase.)
Public property | Verbose | (Inherited from CodeGeneratorBase.)
Top
Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateSnippet | Generates the snippet.
Protected method | GetCodeTemplateInfo | (Inherited from CodeGeneratorBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetVariables | (Inherited from CodeGeneratorBase.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnGeneratorError(GeneratorErrorEventArgs) | (Inherited from CodeGeneratorBase.)
Protected method | OnGeneratorError(String, Exception) | (Inherited from CodeGeneratorBase.)
Protected method | OnGeneratorError(String, Boolean, Int32, String, Int32, Int32) | (Inherited from CodeGeneratorBase.)
Protected method | OnOutputString(MessageEventArgs) | (Inherited from CodeGeneratorBase.)
Protected method | OnOutputString(String) | (Inherited from CodeGeneratorBase.)
Protected method | OnOutputString(String, Object) | (Inherited from CodeGeneratorBase.)
Protected method | OnPreOutputWritten | (Inherited from CodeGeneratorBase.)
Protected method | OnProgress(GeneratorProgressEventArgs) | (Inherited from CodeGeneratorBase.)
Protected method | OnProgress(Int32, Int32) | (Inherited from CodeGeneratorBase.)
Protected method | OnStatusChanged(MessageEventArgs) | (Inherited from CodeGeneratorBase.)
Protected method | OnStatusChanged(String) | (Inherited from CodeGeneratorBase.)
Protected method | OutputCompilerErrors | (Inherited from CodeGeneratorBase.)
Public method | OutputUsage | Outputs the usage.
Protected method | ReplaceVariables | (Inherited from CodeGeneratorBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | WriteComment | (Inherited from CodeGeneratorBase.)
Protected method | WriteHeader | (Inherited from CodeGeneratorBase.)
Top
Events
 | Name | Description
Public event | GeneratorError | (Inherited from CodeGeneratorBase.)
Public event | OutputString | (Inherited from CodeGeneratorBase.)
Public event | PreOutputWritten | (Inherited from CodeGeneratorBase.)
Public event | Progress | (Inherited from CodeGeneratorBase.)
Public event | StatusChanged | (Inherited from CodeGeneratorBase.)
Top
See Also

Reference

CodeSmith.Engine Namespace


ActiveSnippetGenerator Constructor

Initializes a new instance of the ActiveSnippetGenerator class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ActiveSnippetGenerator()
Public Sub New
See Also

Reference

ActiveSnippetGenerator Class
CodeSmith.Engine Namespace


ActiveSnippetGenerator Properties

The ActiveSnippetGenerator type exposes the following members.

Properties
 | Name | Description
Public property | Debug | (Inherited from CodeGeneratorBase.)
Public property | KeepTempFiles | (Inherited from CodeGeneratorBase.)
Public property | Properties | (Inherited from CodeGeneratorBase.)
Public property | Verbose | (Inherited from CodeGeneratorBase.)
Top
See Also

Reference

ActiveSnippetGenerator Class
CodeSmith.Engine Namespace


ActiveSnippetGenerator Methods

The ActiveSnippetGenerator type exposes the following members.

Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateSnippet | Generates the snippet.
Protected method | GetCodeTemplateInfo | (Inherited from CodeGeneratorBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetVariables | (Inherited from CodeGeneratorBase.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnGeneratorError(GeneratorErrorEventArgs) | (Inherited from CodeGeneratorBase.)
Protected method | OnGeneratorError(String, Exception) | (Inherited from CodeGeneratorBase.)
Protected method | OnGeneratorError(String, Boolean, Int32, String, Int32, Int32) | (Inherited from CodeGeneratorBase.)
Protected method | OnOutputString(MessageEventArgs) | (Inherited from CodeGeneratorBase.)
Protected method | OnOutputString(String) | (Inherited from CodeGeneratorBase.)
Protected method | OnOutputString(String, Object) | (Inherited from CodeGeneratorBase.)
Protected method | OnPreOutputWritten | (Inherited from CodeGeneratorBase.)
Protected method | OnProgress(GeneratorProgressEventArgs) | (Inherited from CodeGeneratorBase.)
Protected method | OnProgress(Int32, Int32) | (Inherited from CodeGeneratorBase.)
Protected method | OnStatusChanged(MessageEventArgs) | (Inherited from CodeGeneratorBase.)
Protected method | OnStatusChanged(String) | (Inherited from CodeGeneratorBase.)
Protected method | OutputCompilerErrors | (Inherited from CodeGeneratorBase.)
Public method | OutputUsage | Outputs the usage.
Protected method | ReplaceVariables | (Inherited from CodeGeneratorBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | WriteComment | (Inherited from CodeGeneratorBase.)
Protected method | WriteHeader | (Inherited from CodeGeneratorBase.)
Top
See Also

Reference

ActiveSnippetGenerator Class
CodeSmith.Engine Namespace


ActiveSnippetGenerator.GenerateSnippet Method

ActiveSnippetGeneratorGenerateSnippet Method

Generates the snippet.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool GenerateSnippet(
    string rawLine,
    string targetExtension,
    out string output
)
Public Function GenerateSnippet (
    rawLine As String,
    targetExtension As String,
    <OutAttribute> ByRef output As String
) As Boolean

Parameters

rawLine
Type: SystemString
The raw line.
targetExtension
Type: SystemString
The target extension.
output
Type: SystemString
The snippet output.

Return Value

Type: Boolean
See Also

Reference

ActiveSnippetGenerator Class
CodeSmith.Engine Namespace


ActiveSnippetGenerator.OutputUsage Method

ActiveSnippetGeneratorOutputUsage Method

Outputs the usage.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void OutputUsage(
    string rawLine,
    string targetExtension
)
Public Sub OutputUsage (
    rawLine As String,
    targetExtension As String
)

Parameters

rawLine
Type: SystemString
The raw line.
targetExtension
Type: SystemString
The target extension.
See Also

Reference

ActiveSnippetGenerator Class
CodeSmith.Engine Namespace


ActiveSnippetGenerator Events

The ActiveSnippetGenerator type exposes the following members.

Events
 | Name | Description
Public event | GeneratorError | (Inherited from CodeGeneratorBase.)
Public event | OutputString | (Inherited from CodeGeneratorBase.)
Public event | PreOutputWritten | (Inherited from CodeGeneratorBase.)
Public event | Progress | (Inherited from CodeGeneratorBase.)
Public event | StatusChanged | (Inherited from CodeGeneratorBase.)
Top
See Also

Reference

ActiveSnippetGenerator Class
CodeSmith.Engine Namespace


ActiveSnippetMapping Class

Inheritance Hierarchy
SystemObject
CodeSmith.EngineBusinessObjectBase
CodeSmith.EngineActiveSnippetMapping

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class ActiveSnippetMapping : BusinessObjectBase,
    IIndexed
Public Class ActiveSnippetMapping
    Inherits BusinessObjectBase
    Implements IIndexed

The ActiveSnippetMapping type exposes the following members.

Constructors
 | Name | Description
Public method | ActiveSnippetMapping | Initializes a new instance of the ActiveSnippetMapping class
Top
Properties
 | Name | Description
Public property | Alias | Gets or sets the alias.
Public property | Arguments | Gets or sets the arguments.
Public property | DisplayName | Gets the name of the display.
Protected property | Errors | (Inherited from BusinessObjectBase.)
Public property | HasErrors | (Inherited from BusinessObjectBase.)
Public property | Index |
Public property | InEdit | (Inherited from BusinessObjectBase.)
Public property | IsDirty | (Inherited from BusinessObjectBase.)
Public property | PreviousTemplateFile | Returns the original template file name.
Public property | PropertySet | Gets or sets the property set.
Public property | SnippetUsage |
Public property | TargetExtensions | Gets or sets the target file extensions.
Public property | TargetLanguage | Gets or sets the target language.
Public property | TemplateFile | Gets or sets the template file.
Public property | TemplateName | Gets or sets the name of the template.
Public property | ValidationErrors |
Top
Methods
 | Name | Description
Public method | BeginEdit | (Inherited from BusinessObjectBase.)
Public method | CancelEdit | (Inherited from BusinessObjectBase.)
Protected method | ClearColumnError | (Inherited from BusinessObjectBase.)
Protected method | ClearColumnErrors | (Inherited from BusinessObjectBase.)
Public method | EndEdit | (Inherited from BusinessObjectBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FireRowResetEvent | (Inherited from BusinessObjectBase.)
Protected method | GetColumnError | (Inherited from BusinessObjectBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnBeginEdit | (Inherited from BusinessObjectBase.)
Protected method | OnCancelEdit | (Inherited from BusinessObjectBase.)
Protected method | OnEndEdit | (Inherited from BusinessObjectBase.)
Protected method | OnPropertyChanged | (Inherited from BusinessObjectBase.)
Protected method | OnValidate | (Overrides BusinessObjectBaseOnValidate.)
Protected method | RollbackChanges | (Inherited from BusinessObjectBase.)
Protected method | SaveState | (Inherited from BusinessObjectBase.)
Protected method | SetColumnError | (Inherited from BusinessObjectBase.)
Public method | ToString | (Overrides ObjectToString.)
Public method | Validate | (Inherited from BusinessObjectBase.)
Top
Events
 | Name | Description
Public event | PropertyChanged | (Inherited from BusinessObjectBase.)
Top
See Also

Reference

CodeSmith.Engine Namespace


ActiveSnippetMapping Constructor

Initializes a new instance of the ActiveSnippetMapping class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ActiveSnippetMapping()
Public Sub New
See Also

Reference

ActiveSnippetMapping Class
CodeSmith.Engine Namespace


ActiveSnippetMapping Properties

The ActiveSnippetMapping type exposes the following members.

Properties
 | Name | Description
Public property | Alias | Gets or sets the alias.
Public property | Arguments | Gets or sets the arguments.
Public property | DisplayName | Gets the name of the display.
Protected property | Errors | (Inherited from BusinessObjectBase.)
Public property | HasErrors | (Inherited from BusinessObjectBase.)
Public property | Index |
Public property | InEdit | (Inherited from BusinessObjectBase.)
Public property | IsDirty | (Inherited from BusinessObjectBase.)
Public property | PreviousTemplateFile | Returns the original template file name.
Public property | PropertySet | Gets or sets the property set.
Public property | SnippetUsage |
Public property | TargetExtensions | Gets or sets the target file extensions.
Public property | TargetLanguage | Gets or sets the target language.
Public property | TemplateFile | Gets or sets the template file.
Public property | TemplateName | Gets or sets the name of the template.
Public property | ValidationErrors |
Top
See Also

Reference

ActiveSnippetMapping Class
CodeSmith.Engine Namespace


ActiveSnippetMapping.Alias Property

ActiveSnippetMappingAlias Property

Gets or sets the alias.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string Alias { get; set; }
Public Property Alias As String
    Get
    Set

Property Value

Type: String
The alias.
See Also

Reference

ActiveSnippetMapping Class
CodeSmith.Engine Namespace


ActiveSnippetMapping.Arguments Property

ActiveSnippetMappingArguments Property

Gets or sets the arguments.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public DelimitedStringCollection Arguments { get; set; }
Public Property Arguments As DelimitedStringCollection
    Get
    Set

Property Value

Type: DelimitedStringCollection
The arguments.
See Also

Reference

ActiveSnippetMapping Class
CodeSmith.Engine Namespace


ActiveSnippetMapping.DisplayName Property

ActiveSnippetMappingDisplayName Property

Gets the name of the display.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string DisplayName { get; }
Public ReadOnly Property DisplayName As String
    Get

Property Value

Type: String
The name of the display.
See Also

Reference

ActiveSnippetMapping Class
CodeSmith.Engine Namespace


ActiveSnippetMapping.Index Property

ActiveSnippetMappingIndex Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public int Index { get; set; }
Public Property Index As Integer
    Get
    Set

Property Value

Type: Int32

Implements

IIndexedIndex
See Also

Reference

ActiveSnippetMapping Class
CodeSmith.Engine Namespace


ActiveSnippetMapping.PreviousTemplateFile Property

ActiveSnippetMappingPreviousTemplateFile Property

Returns the original template file name.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string PreviousTemplateFile { get; }
Public ReadOnly Property PreviousTemplateFile As String
    Get

Property Value

Type: String
See Also

Reference

ActiveSnippetMapping Class
CodeSmith.Engine Namespace


ActiveSnippetMapping.PropertySet Property

ActiveSnippetMappingPropertySet Property

Gets or sets the property set.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public PropertySet PropertySet { get; set; }
Public Property PropertySet As PropertySet
    Get
    Set

Property Value

Type: PropertySet
The property set.
See Also

Reference

ActiveSnippetMapping Class
CodeSmith.Engine Namespace


ActiveSnippetMapping.SnippetUsage Property

ActiveSnippetMappingSnippetUsage Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string SnippetUsage { get; }
Public ReadOnly Property SnippetUsage As String
    Get

Property Value

Type: String
See Also

Reference

ActiveSnippetMapping Class
CodeSmith.Engine Namespace


ActiveSnippetMapping.TargetExtensions Property

ActiveSnippetMappingTargetExtensions Property

Gets or sets the target file extensions.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string TargetExtensions { get; set; }
Public Property TargetExtensions As String
    Get
    Set

Property Value

Type: String
The target extensions.
See Also

Reference

ActiveSnippetMapping Class
CodeSmith.Engine Namespace


ActiveSnippetMapping.TargetLanguage Property

ActiveSnippetMappingTargetLanguage Property

Gets or sets the target language.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string TargetLanguage { get; set; }
Public Property TargetLanguage As String
    Get
    Set

Property Value

Type: String
The target language.
See Also

Reference

ActiveSnippetMapping Class
CodeSmith.Engine Namespace


ActiveSnippetMapping.TemplateFile Property

ActiveSnippetMappingTemplateFile Property

Gets or sets the template file.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string TemplateFile { get; set; }
Public Property TemplateFile As String
    Get
    Set

Property Value

Type: String
The template file.
See Also

Reference

ActiveSnippetMapping Class
CodeSmith.Engine Namespace


ActiveSnippetMapping.TemplateName Property

ActiveSnippetMappingTemplateName Property

Gets or sets the name of the template.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string TemplateName { get; set; }
Public Property TemplateName As String
    Get
    Set

Property Value

Type: String
The name of the template.
See Also

Reference

ActiveSnippetMapping Class
CodeSmith.Engine Namespace


ActiveSnippetMapping.ValidationErrors Property

ActiveSnippetMappingValidationErrors Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public IEnumerable<string> ValidationErrors { get; }
Public ReadOnly Property ValidationErrors As IEnumerable(Of String)
    Get

Property Value

Type: IEnumerable String
See Also

Reference

ActiveSnippetMapping Class
CodeSmith.Engine Namespace


ActiveSnippetMapping Methods

The ActiveSnippetMapping type exposes the following members.

Methods
 | Name | Description
Public method | BeginEdit | (Inherited from BusinessObjectBase.)
Public method | CancelEdit | (Inherited from BusinessObjectBase.)
Protected method | ClearColumnError | (Inherited from BusinessObjectBase.)
Protected method | ClearColumnErrors | (Inherited from BusinessObjectBase.)
Public method | EndEdit | (Inherited from BusinessObjectBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FireRowResetEvent | (Inherited from BusinessObjectBase.)
Protected method | GetColumnError | (Inherited from BusinessObjectBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnBeginEdit | (Inherited from BusinessObjectBase.)
Protected method | OnCancelEdit | (Inherited from BusinessObjectBase.)
Protected method | OnEndEdit | (Inherited from BusinessObjectBase.)
Protected method | OnPropertyChanged | (Inherited from BusinessObjectBase.)
Protected method | OnValidate | (Overrides BusinessObjectBaseOnValidate.)
Protected method | RollbackChanges | (Inherited from BusinessObjectBase.)
Protected method | SaveState | (Inherited from BusinessObjectBase.)
Protected method | SetColumnError | (Inherited from BusinessObjectBase.)
Public method | ToString | (Overrides ObjectToString.)
Public method | Validate | (Inherited from BusinessObjectBase.)
Top
See Also

Reference

ActiveSnippetMapping Class
CodeSmith.Engine Namespace


ActiveSnippetMapping.OnValidate Method

ActiveSnippetMappingOnValidate Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected override bool OnValidate()
Protected Overrides Function OnValidate As Boolean

Return Value

Type: Boolean
See Also

Reference

ActiveSnippetMapping Class
CodeSmith.Engine Namespace


ActiveSnippetMapping.ToString Method

ActiveSnippetMappingToString Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
See Also

Reference

ActiveSnippetMapping Class
CodeSmith.Engine Namespace


ActiveSnippetMapping Events

The ActiveSnippetMapping type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | (Inherited from BusinessObjectBase.)
Top
See Also

Reference

ActiveSnippetMapping Class
CodeSmith.Engine Namespace


ActiveSnippetMappingCollection Class

Inheritance Hierarchy
SystemObject
CodeSmith.EngineVirtualCollectionBase ActiveSnippetMapping
CodeSmith.EngineConfigurationCollectionBase ActiveSnippetMapping
CodeSmith.EngineActiveSnippetMappingCollection

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class ActiveSnippetMappingCollection : ConfigurationCollectionBase<ActiveSnippetMapping>
Public Class ActiveSnippetMappingCollection
    Inherits ConfigurationCollectionBase(Of ActiveSnippetMapping)

The ActiveSnippetMappingCollection type exposes the following members.

Constructors
 | Name | Description
Public method | ActiveSnippetMappingCollection | Initializes a new instance of the ActiveSnippetMappingCollection class
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from VirtualCollectionBaseT.)
Public property | Item | Gets or sets the type T at the specified index. (Inherited from VirtualCollectionBaseT.)
Protected property | SubKey | (Overrides ConfigurationCollectionBaseTSubKey.)
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from VirtualCollectionBaseT.)
Protected method | AddItem | (Overrides VirtualCollectionBaseTAddItem(T).)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from VirtualCollectionBaseT.)
Protected method | ClearItems | (Inherited from ConfigurationCollectionBaseT.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from VirtualCollectionBaseT.)
Public method | CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from VirtualCollectionBaseT.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetCount | (Inherited from ConfigurationCollectionBaseT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from VirtualCollectionBaseT.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetIndex | (Overrides VirtualCollectionBaseTGetIndex(T).)
Protected method | GetItem | (Inherited from ConfigurationCollectionBaseT.)
Protected method | GetItemFromRegistry | (Overrides ConfigurationCollectionBaseTGetItemFromRegistry(Int32).)
Protected method | GetItems | (Inherited from ConfigurationCollectionBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from VirtualCollectionBaseT.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from VirtualCollectionBaseT.)
Protected method | InsertItem | (Inherited from ConfigurationCollectionBaseT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | (Inherited from ConfigurationCollectionBaseT.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from VirtualCollectionBaseT.)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from VirtualCollectionBaseT.)
Protected method | RemoveItem | (Inherited from ConfigurationCollectionBaseT.)
Protected method | SetItem | (Inherited from ConfigurationCollectionBaseT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSmith.Engine Namespace


ActiveSnippetMappingCollection Constructor

Initializes a new instance of the ActiveSnippetMappingCollection class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ActiveSnippetMappingCollection()
Public Sub New
See Also

Reference

ActiveSnippetMappingCollection Class
CodeSmith.Engine Namespace


ActiveSnippetMappingCollection Properties

The ActiveSnippetMappingCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from VirtualCollectionBaseT.)
Public property | Item | Gets or sets the type T at the specified index. (Inherited from VirtualCollectionBaseT.)
Protected property | SubKey | (Overrides ConfigurationCollectionBaseTSubKey.)
Top
See Also

Reference

ActiveSnippetMappingCollection Class
CodeSmith.Engine Namespace


ActiveSnippetMappingCollection.SubKey Property

ActiveSnippetMappingCollectionSubKey Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected override string SubKey { get; }
Protected Overrides ReadOnly Property SubKey As String
    Get

Property Value

Type: String
See Also

Reference

ActiveSnippetMappingCollection Class
CodeSmith.Engine Namespace


ActiveSnippetMappingCollection Methods

The ActiveSnippetMappingCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from VirtualCollectionBaseT.)
Protected method | AddItem | (Overrides VirtualCollectionBaseTAddItem(T).)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from VirtualCollectionBaseT.)
Protected method | ClearItems | (Inherited from ConfigurationCollectionBaseT.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from VirtualCollectionBaseT.)
Public method | CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from VirtualCollectionBaseT.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetCount | (Inherited from ConfigurationCollectionBaseT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from VirtualCollectionBaseT.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetIndex | (Overrides VirtualCollectionBaseTGetIndex(T).)
Protected method | GetItem | (Inherited from ConfigurationCollectionBaseT.)
Protected method | GetItemFromRegistry | (Overrides ConfigurationCollectionBaseTGetItemFromRegistry(Int32).)
Protected method | GetItems | (Inherited from ConfigurationCollectionBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from VirtualCollectionBaseT.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from VirtualCollectionBaseT.)
Protected method | InsertItem | (Inherited from ConfigurationCollectionBaseT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | (Inherited from ConfigurationCollectionBaseT.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from VirtualCollectionBaseT.)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from VirtualCollectionBaseT.)
Protected method | RemoveItem | (Inherited from ConfigurationCollectionBaseT.)
Protected method | SetItem | (Inherited from ConfigurationCollectionBaseT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ActiveSnippetMappingCollection Class
CodeSmith.Engine Namespace


ActiveSnippetMappingCollection.AddItem Method

ActiveSnippetMappingCollectionAddItem Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected override int AddItem(
    ActiveSnippetMapping item
)
Protected Overrides Function AddItem (
    item As ActiveSnippetMapping
) As Integer

Parameters

item
Type: CodeSmith.EngineActiveSnippetMapping

Return Value

Type: Int32
See Also

Reference

ActiveSnippetMappingCollection Class
CodeSmith.Engine Namespace


ActiveSnippetMappingCollection.GetIndex Method

ActiveSnippetMappingCollectionGetIndex Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected override int GetIndex(
    ActiveSnippetMapping item
)
Protected Overrides Function GetIndex (
    item As ActiveSnippetMapping
) As Integer

Parameters

item
Type: CodeSmith.EngineActiveSnippetMapping

Return Value

Type: Int32
See Also

Reference

ActiveSnippetMappingCollection Class
CodeSmith.Engine Namespace


ActiveSnippetMappingCollection.GetItemFromRegistry Method

ActiveSnippetMappingCollectionGetItemFromRegistry Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected override ActiveSnippetMapping GetItemFromRegistry(
    int index
)
Protected Overrides Function GetItemFromRegistry (
    index As Integer
) As ActiveSnippetMapping

Parameters

index
Type: SystemInt32

Return Value

Type: ActiveSnippetMapping
See Also

Reference

ActiveSnippetMappingCollection Class
CodeSmith.Engine Namespace


AdoHelper(TFactory) Class

AdoHelperTFactory Class

The AdoHelper class is intended to encapsulate high performance, scalable best practices for common data access uses.
Inheritance Hierarchy
SystemObject
CodeSmith.EngineAdoHelperTFactory

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class AdoHelper<TFactory>
where TFactory : new(), DbProviderFactory

Public Class AdoHelper(Of TFactory As {New, DbProviderFactory})

Type Parameters

TFactory
The type of the factory.

The AdoHelperTFactory type exposes the following members.

Constructors
 | Name | Description
Public method | AdoHelperTFactory | Initializes a new instance of the AdoHelperTFactory class
Top
Methods
 | Name | Description
Protected method | AddUpdateEventHandlers | Provider specific code to set up the updating/ed event handlers used by UpdateDataset
Protected method | AssignParameterValues(IDataParameter, DataRow) | This method assigns dataRow column values to an array of IDataParameters
Protected method | AssignParameterValues(IDataParameter, Object) | This method assigns an array of values to an array of IDataParameters
Protected method | AssignParameterValues(IDataParameterCollection, DataRow) | This method assigns dataRow column values to an IDataParameterCollection
Protected method | AttachParameters | This method is used to attach array of IDataParameters to an IDbCommand. This method will assign a value of DbNull to any parameter with a direction of InputOutput and a value of null. This behavior will prevent default values from being used, but this will be the less common case than an intended pure output parameter (derived as InputOutput) where the user provided no input value.
Public method | CacheParameterSet(IDbConnection, String, IDataParameter) | Add parameter array to the cache
Public method | CacheParameterSet(String, String, IDataParameter) | Add parameter array to the cache
Public method | CleanParameterSyntax | This method cleans up the parameter syntax for the provider
Protected method | ClearCommand | This method clears (if necessary) the connection, transaction, command type and parameters from the provided command
 | CreateCommand(IDbConnection, String, String) | Simplify the creation of an IDbCommand object by allowing a stored procedure and optional parameters to be provided
 | CreateCommand(String, String, String) | Simplify the creation of an IDbCommand object by allowing a stored procedure and optional parameters to be provided
 | CreateCommand(IDbConnection, String, CommandType, IDataParameter) | Simplify the creation of an IDbCommand object by allowing a stored procedure and optional parameters to be provided
Public method | CreateCommand(String, String, CommandType, IDataParameter) | Simplify the creation of an IDbCommand object by allowing a stored procedure and optional parameters to be provided
Public method | DeriveParameters | Calls the CommandBuilder.DeriveParameters method for the specified provider, doing any setup and cleanup necessary
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | ExecuteDataset(IDbCommand) | Execute an IDbCommand (that returns a resultset) against the database specified in the connection String.
 | ExecuteDataset(IDbConnection, CommandType, String) | Execute an IDbCommand (that returns a resultset and takes no parameters) against the provided IDbConnection.
 | ExecuteDataset(IDbConnection, String, Object) | Execute a stored procedure via an IDbCommand (that returns a resultset) against the specified IDbConnection using the provided parameter values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on parameter order.
 | ExecuteDataset(IDbTransaction, CommandType, String) | Execute an IDbCommand (that returns a resultset and takes no parameters) against the provided IDbTransaction.
 | ExecuteDataset(IDbTransaction, String, Object) | Execute a stored procedure via an IDbCommand (that returns a resultset) against the specified IDbTransaction using the provided parameter values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on parameter order.
 | ExecuteDataset(String, CommandType, String) | Execute an IDbCommand (that returns a resultset and takes no parameters) against the database specified in the connection String.
 | ExecuteDataset(String, String, Object) | Execute a stored procedure via an IDbCommand (that returns a resultset) against the database specified in the connection string using the provided parameter values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on parameter order.
 | ExecuteDataset(IDbConnection, CommandType, String, IDataParameter) | Execute an IDbCommand (that returns a resultset) against the specified IDbConnection using the provided parameters.
 | ExecuteDataset(IDbTransaction, CommandType, String, IDataParameter) | Execute an IDbCommand (that returns a resultset) against the specified IDbTransaction using the provided parameters.
 | ExecuteDataset(String, CommandType, String, IDataParameter) | Execute an IDbCommand (that returns a resultset) against the database specified in the connection string using the provided parameters.
Public method | ExecuteDatasetTypedParams(IDbCommand, DataRow) | Execute a stored procedure via an IDbCommand (that returns a resultset) against the database specified in the connection string using the dataRow column values as the stored procedure's parameters values. This method will assign the paraemter values based on row values.
Public method | ExecuteDatasetTypedParams(IDbConnection, String, DataRow) | Execute a stored procedure via an IDbCommand (that returns a resultset) against the specified IDbConnection using the dataRow column values as the store procedure's parameters values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on row values.
Public method | ExecuteDatasetTypedParams(IDbTransaction, String, DataRow) | Execute a stored procedure via an IDbCommand (that returns a resultset) against the specified IDbTransaction using the dataRow column values as the stored procedure's parameters values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on row values.
Public method | ExecuteDatasetTypedParams(String, String, DataRow) | Execute a stored procedure via an IDbCommand (that returns a resultset) against the database specified in the connection string using the dataRow column values as the stored procedure's parameters values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on row values.
Public method | ExecuteNonQuery(IDbCommand) | Execute an IDbCommand (that returns no resultset) against the database
Public method | ExecuteNonQuery(IDbConnection, CommandType, String) | Execute an IDbCommand (that returns no resultset and takes no parameters) against the provided IDbConnection.
Public method | ExecuteNonQuery(IDbConnection, String, Object) | Execute a stored procedure via an IDbCommand (that returns no resultset) against the specified IDbConnection using the provided parameter values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on parameter order.
Public method | ExecuteNonQuery(IDbTransaction, CommandType, String) | Execute an IDbCommand (that returns no resultset and takes no parameters) against the provided IDbTransaction.
Public method | ExecuteNonQuery(IDbTransaction, String, Object) | Execute a stored procedure via an IDbCommand (that returns no resultset) against the specified IDbTransaction using the provided parameter values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on parameter order.
Public method | ExecuteNonQuery(String, CommandType, String) | Execute an IDbCommand (that returns no resultset and takes no parameters) against the database specified in the connection string
Public method | ExecuteNonQuery(String, String, Object) | Execute a stored procedure via an IDbCommand (that returns no resultset) against the database specified in the connection string using the provided parameter values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on parameter order.
Public method | ExecuteNonQuery(IDbConnection, CommandType, String, IDataParameter) | Execute an IDbCommand (that returns no resultset) against the specified IDbConnection using the provided parameters.
Public method | ExecuteNonQuery(IDbTransaction, CommandType, String, IDataParameter) | Execute an IDbCommand (that returns no resultset) against the specified IDbTransaction using the provided parameters.
Public method | ExecuteNonQuery(String, CommandType, String, IDataParameter) | Execute an IDbCommand (that returns no resultset) against the database specified in the connection string using the provided parameters
Public method | ExecuteNonQueryTypedParams(IDbCommand, DataRow) | Execute a stored procedure via an IDbCommand (that returns no resultset) against the database specified in the connection string using the dataRow column values as the stored procedure's parameters values. This method will assign the parameter values based on row values.
Public method | ExecuteNonQueryTypedParams(IDbConnection, String, DataRow) | Execute a stored procedure via an IDbCommand (that returns no resultset) against the specified IDbConnection using the dataRow column values as the stored procedure's parameters values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on row values.
Public method | ExecuteNonQueryTypedParams(IDbTransaction, String, DataRow) | Execute a stored procedure via an IDbCommand (that returns no resultset) against the specified IDbTransaction using the dataRow column values as the stored procedure's parameters values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on row values.
Public method | ExecuteNonQueryTypedParams(String, String, DataRow) | Execute a stored procedure via an IDbCommand (that returns no resultset) against the database specified in the connection string using the dataRow column values as the stored procedure's parameters values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on row values.
Public method | ExecuteReader(IDbCommand) | Execute an IDbCommand (that returns a resultset) against the database specified in the connection String.
Protected method | ExecuteReader(IDbCommand, AdoHelperTFactoryAdoConnectionOwnership) | Execute an IDbCommand (that returns a resultset) against the database specified in the connection String.
 | ExecuteReader(IDbConnection, CommandType, String) | Execute an IDbCommand (that returns a resultset and takes no parameters) against the provided IDbConnection.
 | ExecuteReader(IDbConnection, String, Object) | Execute a stored procedure via an IDbCommand (that returns a resultset) against the specified IDbConnection using the provided parameter values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on parameter order.
 | ExecuteReader(IDbTransaction, CommandType, String) | Execute an IDbCommand (that returns a resultset and takes no parameters) against the provided IDbTransaction.
 | ExecuteReader(IDbTransaction, String, Object) | Execute a stored procedure via an IDbCommand (that returns a resultset) against the specified IDbTransaction using the provided parameter values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on parameter order.
Public method | ExecuteReader(String, CommandType, String) | Execute an IDbCommand (that returns a resultset and takes no parameters) against the database specified in the connection String.
 | ExecuteReader(String, String, Object) | Execute a stored procedure via an IDbCommand (that returns a resultset) against the database specified in the connection string using the provided parameter values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on parameter order.
 | ExecuteReader(IDbConnection, CommandType, String, IDataParameter) | Execute an IDbCommand (that returns a resultset) against the specified IDbConnection using the provided parameters.
 | ExecuteReader(IDbTransaction, CommandType, String, IDataParameter) | Execute an IDbCommand (that returns a resultset) against the specified IDbTransaction using the provided parameters.
Public method | ExecuteReader(String, CommandType, String, IDataParameter) | Execute an IDbCommand (that returns a resultset) against the database specified in the connection string using the provided parameters.
Public method | ExecuteReaderTypedParams(IDbCommand, DataRow) | Execute a stored procedure via an IDbCommand (that returns a resultset) against the database specified in the connection string using the dataRow column values as the stored procedure's parameters values. This method will assign the parameter values based on parameter order.
Public method | ExecuteReaderTypedParams(IDbConnection, String, DataRow) | Execute a stored procedure via an IDbCommand (that returns a resultset) against the specified IDbConnection using the dataRow column values as the stored procedure's parameters values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on parameter order.
Public method | ExecuteReaderTypedParams(IDbTransaction, String, DataRow) | Execute a stored procedure via an IDbCommand (that returns a resultset) against the specified IDbTransaction using the dataRow column values as the stored procedure's parameters values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on parameter order.
Public method | ExecuteReaderTypedParams(String, String, DataRow) | Execute a stored procedure via an IDbCommand (that returns a resultset) against the database specified in the connection string using the dataRow column values as the stored procedure's parameters values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on parameter order.
Public method | ExecuteScalar(IDbCommand) | Execute an IDbCommand (that returns a 1x1 resultset) against the database specified in the connection String.
 | ExecuteScalar(IDbConnection, CommandType, String) | Execute an IDbCommand (that returns a 1x1 resultset and takes no parameters) against the provided IDbConnection.
 | ExecuteScalar(IDbConnection, String, Object) | Execute a stored procedure via an IDbCommand (that returns a 1x1 resultset) against the specified IDbConnection using the provided parameter values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on parameter order.
 | ExecuteScalar(IDbTransaction, CommandType, String) | Execute an IDbCommand (that returns a 1x1 resultset and takes no parameters) against the provided IDbTransaction.
 | ExecuteScalar(IDbTransaction, String, Object) | Execute a stored procedure via an IDbCommand (that returns a 1x1 resultset) against the specified IDbTransaction using the provided parameter values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on parameter order.
 | ExecuteScalar(String, CommandType, String) | Execute an IDbCommand (that returns a 1x1 resultset and takes no parameters) against the database specified in the connection String.
 | ExecuteScalar(String, String, Object) | Execute a stored procedure via an IDbCommand (that returns a 1x1 resultset) against the database specified in the connection string using the provided parameter values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on parameter order.
Public method | ExecuteScalar(IDbConnection, CommandType, String, IDataParameter) | Execute an IDbCommand (that returns a 1x1 resultset) against the specified IDbConnection using the provided parameters.
Public method | ExecuteScalar(IDbTransaction, CommandType, String, IDataParameter) | Execute an IDbCommand (that returns a 1x1 resultset) against the specified IDbTransaction using the provided parameters.
Public method | ExecuteScalar(String, CommandType, String, IDataParameter) | Execute an IDbCommand (that returns a 1x1 resultset) against the database specified in the connection string using the provided parameters.
Public method | ExecuteScalarTypedParams(IDbCommand, DataRow) | Execute a stored procedure via an IDbCommand (that returns a 1x1 resultset) against the database specified in the connection string using the dataRow column values as the stored procedure's parameters values. This method will assign the parameter values based on parameter order.
Public method | ExecuteScalarTypedParams(IDbConnection, String, DataRow) | Execute a stored procedure via an IDbCommand (that returns a 1x1 resultset) against the specified IDbConnection using the dataRow column values as the stored procedure's parameters values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on parameter order.
Public method | ExecuteScalarTypedParams(IDbTransaction, String, DataRow) | Execute a stored procedure via an IDbCommand (that returns a 1x1 resultset) against the specified IDbTransaction using the dataRow column values as the stored procedure's parameters values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on parameter order.
Public method | ExecuteScalarTypedParams(String, String, DataRow) | Execute a stored procedure via an IDbCommand (that returns a 1x1 resultset) against the database specified in the connection string using the dataRow column values as the stored procedure's parameters values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on parameter order.
Public method | FillDataset(IDbCommand, DataSet, String) | Execute an IDbCommand (that returns a resultset) against the database specified in the connection String.
 | FillDataset(IDbConnection, CommandType, String, DataSet, String) | Execute an IDbCommand (that returns a resultset and takes no parameters) against the provided IDbConnection.
 | FillDataset(IDbConnection, String, DataSet, String, Object) | Execute a stored procedure via an IDbCommand (that returns a resultset) against the specified IDbConnection using the provided parameter values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on parameter order.
 | FillDataset(IDbTransaction, CommandType, String, DataSet, String) | Execute an IDbCommand (that returns a resultset and takes no parameters) against the provided IDbTransaction.
 | FillDataset(IDbTransaction, String, DataSet, String, Object) | Execute a stored procedure via an IDbCommand (that returns a resultset) against the specified IDbTransaction using the provided parameter values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on parameter order.
 | FillDataset(String, CommandType, String, DataSet, String) | Execute an IDbCommand (that returns a resultset and takes no parameters) against the database specified in the connection String.
 | FillDataset(String, String, DataSet, String, Object) | Execute a stored procedure via an IDbCommand (that returns a resultset) against the database specified in the connection string using the provided parameter values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on parameter order.
Public method | FillDataset(IDbConnection, CommandType, String, DataSet, String, IDataParameter) | Execute an IDbCommand (that returns a resultset) against the specified IDbConnection using the provided parameters.
Public method | FillDataset(IDbTransaction, CommandType, String, DataSet, String, IDataParameter) | Execute an IDbCommand (that returns a resultset) against the specified IDbTransaction using the provided parameters.
Public method | FillDataset(String, CommandType, String, DataSet, String, IDataParameter) | Execute an IDbCommand (that returns a resultset) against the database specified in the connection string using the provided parameters.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetBlobParameter | Handle any provider-specific issues with BLOBs here by "washing" the IDataParameter and returning a new one that is set up appropriately for the provider.
Public method | GetCachedParameterSet(IDbConnection, String) | Retrieve a parameter array from the cache
Public method | GetCachedParameterSet(String, String) | Retrieve a parameter array from the cache
Public method | GetConnection | Returns an IDbConnection object for the given connection string
Public method | GetDataAdapter | Returns an IDbDataAdapter object
Protected method | GetDataParameters | Returns an array of IDataParameters of the specified size
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetParameter | Returns an IDataParameter object
Public method | GetParameter(String, Object) | Get an IDataParameter for use in a SQL command
Public method | GetParameter(String, DbType, Int32, ParameterDirection) | Get an IDataParameter for use in a SQL command
Public method | GetParameter(String, DbType, Int32, String, DataRowVersion) | Get an IDataParameter for use in a SQL command
Public method | GetSpParameterSet(IDbConnection, String) | Retrieves the set of IDataParameters appropriate for the stored procedure
Public method | GetSpParameterSet(String, String) | Retrieves the set of IDataParameters appropriate for the stored procedure
Public method | GetSpParameterSet(IDbConnection, String, Boolean) | Retrieves the set of IDataParameters appropriate for the stored procedure
Public method | GetSpParameterSet(String, String, Boolean) | Retrieves the set of IDataParameters appropriate for the stored procedure
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PrepareCommand | This method opens (if necessary) and assigns a connection, transaction, command type and parameters to the provided command
Protected method | RowUpdated | This method consumes the RowUpdatedEvent and passes it on to the consumer specifed in the call to UpdateDataset
Protected method | RowUpdating | This method consumes the RowUpdatingEvent and passes it on to the consumer specifed in the call to UpdateDataset
Protected method | SetCommand | Set up a command for updating a DataSet.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | UpdateDataset(IDbCommand, IDbCommand, IDbCommand, DataSet, String) | Executes the respective command for each inserted, updated, or deleted row in the DataSet.
 | UpdateDataset(IDbCommand, IDbCommand, IDbCommand, DataSet, String, AdoHelperTFactoryRowUpdatingHandler, AdoHelperTFactoryRowUpdatedHandler) | Executes the IDbCommand for each inserted, updated, or deleted row in the DataSet also implementing RowUpdating and RowUpdated Event Handlers
Top
Fields
 | Name | Description
Protected field | m_rowUpdated | Internal handler used for bubbling up the event to the user
Protected field | m_rowUpdating | Internal handler used for bubbling up the event to the user
Top
See Also

Reference

CodeSmith.Engine Namespace


AdoHelper(TFactory) Constructor

AdoHelperTFactory Constructor

Initializes a new instance of the AdoHelperTFactory class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public AdoHelper()
Public Sub New
See Also

Reference

AdoHelperTFactory Class
CodeSmith.Engine Namespace


AdoHelper(TFactory) Methods

AdoHelperTFactory Methods

The AdoHelperTFactory generic type exposes the following members.

Methods
 | Name | Description
Protected method | AddUpdateEventHandlers | Provider specific code to set up the updating/ed event handlers used by UpdateDataset
Protected method | AssignParameterValues(IDataParameter, DataRow) | This method assigns dataRow column values to an array of IDataParameters
Protected method | AssignParameterValues(IDataParameter, Object) | This method assigns an array of values to an array of IDataParameters
Protected method | AssignParameterValues(IDataParameterCollection, DataRow) | This method assigns dataRow column values to an IDataParameterCollection
Protected method | AttachParameters | This method is used to attach array of IDataParameters to an IDbCommand. This method will assign a value of DbNull to any parameter with a direction of InputOutput and a value of null. This behavior will prevent default values from being used, but this will be the less common case than an intended pure output parameter (derived as InputOutput) where the user provided no input value.
Public method | CacheParameterSet(IDbConnection, String, IDataParameter) | Add parameter array to the cache
Public method | CacheParameterSet(String, String, IDataParameter) | Add parameter array to the cache
Public method | CleanParameterSyntax | This method cleans up the parameter syntax for the provider
Protected method | ClearCommand | This method clears (if necessary) the connection, transaction, command type and parameters from the provided command
 | CreateCommand(IDbConnection, String, String) | Simplify the creation of an IDbCommand object by allowing a stored procedure and optional parameters to be provided
 | CreateCommand(String, String, String) | Simplify the creation of an IDbCommand object by allowing a stored procedure and optional parameters to be provided
 | CreateCommand(IDbConnection, String, CommandType, IDataParameter) | Simplify the creation of an IDbCommand object by allowing a stored procedure and optional parameters to be provided
Public method | CreateCommand(String, String, CommandType, IDataParameter) | Simplify the creation of an IDbCommand object by allowing a stored procedure and optional parameters to be provided
Public method | DeriveParameters | Calls the CommandBuilder.DeriveParameters method for the specified provider, doing any setup and cleanup necessary
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | ExecuteDataset(IDbCommand) | Execute an IDbCommand (that returns a resultset) against the database specified in the connection String.
 | ExecuteDataset(IDbConnection, CommandType, String) | Execute an IDbCommand (that returns a resultset and takes no parameters) against the provided IDbConnection.
 | ExecuteDataset(IDbConnection, String, Object) | Execute a stored procedure via an IDbCommand (that returns a resultset) against the specified IDbConnection using the provided parameter values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on parameter order.
 | ExecuteDataset(IDbTransaction, CommandType, String) | Execute an IDbCommand (that returns a resultset and takes no parameters) against the provided IDbTransaction.
 | ExecuteDataset(IDbTransaction, String, Object) | Execute a stored procedure via an IDbCommand (that returns a resultset) against the specified IDbTransaction using the provided parameter values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on parameter order.
 | ExecuteDataset(String, CommandType, String) | Execute an IDbCommand (that returns a resultset and takes no parameters) against the database specified in the connection String.
 | ExecuteDataset(String, String, Object) | Execute a stored procedure via an IDbCommand (that returns a resultset) against the database specified in the connection string using the provided parameter values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on parameter order.
 | ExecuteDataset(IDbConnection, CommandType, String, IDataParameter) | Execute an IDbCommand (that returns a resultset) against the specified IDbConnection using the provided parameters.
 | ExecuteDataset(IDbTransaction, CommandType, String, IDataParameter) | Execute an IDbCommand (that returns a resultset) against the specified IDbTransaction using the provided parameters.
 | ExecuteDataset(String, CommandType, String, IDataParameter) | Execute an IDbCommand (that returns a resultset) against the database specified in the connection string using the provided parameters.
Public method | ExecuteDatasetTypedParams(IDbCommand, DataRow) | Execute a stored procedure via an IDbCommand (that returns a resultset) against the database specified in the connection string using the dataRow column values as the stored procedure's parameters values. This method will assign the paraemter values based on row values.
Public method | ExecuteDatasetTypedParams(IDbConnection, String, DataRow) | Execute a stored procedure via an IDbCommand (that returns a resultset) against the specified IDbConnection using the dataRow column values as the store procedure's parameters values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on row values.
Public method | ExecuteDatasetTypedParams(IDbTransaction, String, DataRow) | Execute a stored procedure via an IDbCommand (that returns a resultset) against the specified IDbTransaction using the dataRow column values as the stored procedure's parameters values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on row values.
Public method | ExecuteDatasetTypedParams(String, String, DataRow) | Execute a stored procedure via an IDbCommand (that returns a resultset) against the database specified in the connection string using the dataRow column values as the stored procedure's parameters values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on row values.
Public method | ExecuteNonQuery(IDbCommand) | Execute an IDbCommand (that returns no resultset) against the database
Public method | ExecuteNonQuery(IDbConnection, CommandType, String) | Execute an IDbCommand (that returns no resultset and takes no parameters) against the provided IDbConnection.
Public method | ExecuteNonQuery(IDbConnection, String, Object) | Execute a stored procedure via an IDbCommand (that returns no resultset) against the specified IDbConnection using the provided parameter values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on parameter order.
Public method | ExecuteNonQuery(IDbTransaction, CommandType, String) | Execute an IDbCommand (that returns no resultset and takes no parameters) against the provided IDbTransaction.
Public method | ExecuteNonQuery(IDbTransaction, String, Object) | Execute a stored procedure via an IDbCommand (that returns no resultset) against the specified IDbTransaction using the provided parameter values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on parameter order.
Public method | ExecuteNonQuery(String, CommandType, String) | Execute an IDbCommand (that returns no resultset and takes no parameters) against the database specified in the connection string
Public method | ExecuteNonQuery(String, String, Object) | Execute a stored procedure via an IDbCommand (that returns no resultset) against the database specified in the connection string using the provided parameter values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on parameter order.
Public method | ExecuteNonQuery(IDbConnection, CommandType, String, IDataParameter) | Execute an IDbCommand (that returns no resultset) against the specified IDbConnection using the provided parameters.
Public method | ExecuteNonQuery(IDbTransaction, CommandType, String, IDataParameter) | Execute an IDbCommand (that returns no resultset) against the specified IDbTransaction using the provided parameters.
Public method | ExecuteNonQuery(String, CommandType, String, IDataParameter) | Execute an IDbCommand (that returns no resultset) against the database specified in the connection string using the provided parameters
Public method | ExecuteNonQueryTypedParams(IDbCommand, DataRow) | Execute a stored procedure via an IDbCommand (that returns no resultset) against the database specified in the connection string using the dataRow column values as the stored procedure's parameters values. This method will assign the parameter values based on row values.
Public method | ExecuteNonQueryTypedParams(IDbConnection, String, DataRow) | Execute a stored procedure via an IDbCommand (that returns no resultset) against the specified IDbConnection using the dataRow column values as the stored procedure's parameters values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on row values.
Public method | ExecuteNonQueryTypedParams(IDbTransaction, String, DataRow) | Execute a stored procedure via an IDbCommand (that returns no resultset) against the specified IDbTransaction using the dataRow column values as the stored procedure's parameters values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on row values.
Public method | ExecuteNonQueryTypedParams(String, String, DataRow) | Execute a stored procedure via an IDbCommand (that returns no resultset) against the database specified in the connection string using the dataRow column values as the stored procedure's parameters values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on row values.
Public method | ExecuteReader(IDbCommand) | Execute an IDbCommand (that returns a resultset) against the database specified in the connection String.
Protected method | ExecuteReader(IDbCommand, AdoHelperTFactoryAdoConnectionOwnership) | Execute an IDbCommand (that returns a resultset) against the database specified in the connection String.
 | ExecuteReader(IDbConnection, CommandType, String) | Execute an IDbCommand (that returns a resultset and takes no parameters) against the provided IDbConnection.
 | ExecuteReader(IDbConnection, String, Object) | Execute a stored procedure via an IDbCommand (that returns a resultset) against the specified IDbConnection using the provided parameter values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on parameter order.
 | ExecuteReader(IDbTransaction, CommandType, String) | Execute an IDbCommand (that returns a resultset and takes no parameters) against the provided IDbTransaction.
 | ExecuteReader(IDbTransaction, String, Object) | Execute a stored procedure via an IDbCommand (that returns a resultset) against the specified IDbTransaction using the provided parameter values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on parameter order.
Public method | ExecuteReader(String, CommandType, String) | Execute an IDbCommand (that returns a resultset and takes no parameters) against the database specified in the connection String.
 | ExecuteReader(String, String, Object) | Execute a stored procedure via an IDbCommand (that returns a resultset) against the database specified in the connection string using the provided parameter values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on parameter order.
 | ExecuteReader(IDbConnection, CommandType, String, IDataParameter) | Execute an IDbCommand (that returns a resultset) against the specified IDbConnection using the provided parameters.
 | ExecuteReader(IDbTransaction, CommandType, String, IDataParameter) | Execute an IDbCommand (that returns a resultset) against the specified IDbTransaction using the provided parameters.
Public method | ExecuteReader(String, CommandType, String, IDataParameter) | Execute an IDbCommand (that returns a resultset) against the database specified in the connection string using the provided parameters.
Public method | ExecuteReaderTypedParams(IDbCommand, DataRow) | Execute a stored procedure via an IDbCommand (that returns a resultset) against the database specified in the connection string using the dataRow column values as the stored procedure's parameters values. This method will assign the parameter values based on parameter order.
Public method | ExecuteReaderTypedParams(IDbConnection, String, DataRow) | Execute a stored procedure via an IDbCommand (that returns a resultset) against the specified IDbConnection using the dataRow column values as the stored procedure's parameters values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on parameter order.
Public method | ExecuteReaderTypedParams(IDbTransaction, String, DataRow) | Execute a stored procedure via an IDbCommand (that returns a resultset) against the specified IDbTransaction using the dataRow column values as the stored procedure's parameters values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on parameter order.
Public method | ExecuteReaderTypedParams(String, String, DataRow) | Execute a stored procedure via an IDbCommand (that returns a resultset) against the database specified in the connection string using the dataRow column values as the stored procedure's parameters values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on parameter order.
Public method | ExecuteScalar(IDbCommand) | Execute an IDbCommand (that returns a 1x1 resultset) against the database specified in the connection String.
 | ExecuteScalar(IDbConnection, CommandType, String) | Execute an IDbCommand (that returns a 1x1 resultset and takes no parameters) against the provided IDbConnection.
 | ExecuteScalar(IDbConnection, String, Object) | Execute a stored procedure via an IDbCommand (that returns a 1x1 resultset) against the specified IDbConnection using the provided parameter values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on parameter order.
 | ExecuteScalar(IDbTransaction, CommandType, String) | Execute an IDbCommand (that returns a 1x1 resultset and takes no parameters) against the provided IDbTransaction.
 | ExecuteScalar(IDbTransaction, String, Object) | Execute a stored procedure via an IDbCommand (that returns a 1x1 resultset) against the specified IDbTransaction using the provided parameter values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on parameter order.
 | ExecuteScalar(String, CommandType, String) | Execute an IDbCommand (that returns a 1x1 resultset and takes no parameters) against the database specified in the connection String.
 | ExecuteScalar(String, String, Object) | Execute a stored procedure via an IDbCommand (that returns a 1x1 resultset) against the database specified in the connection string using the provided parameter values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on parameter order.
Public method | ExecuteScalar(IDbConnection, CommandType, String, IDataParameter) | Execute an IDbCommand (that returns a 1x1 resultset) against the specified IDbConnection using the provided parameters.
Public method | ExecuteScalar(IDbTransaction, CommandType, String, IDataParameter) | Execute an IDbCommand (that returns a 1x1 resultset) against the specified IDbTransaction using the provided parameters.
Public method | ExecuteScalar(String, CommandType, String, IDataParameter) | Execute an IDbCommand (that returns a 1x1 resultset) against the database specified in the connection string using the provided parameters.
Public method | ExecuteScalarTypedParams(IDbCommand, DataRow) | Execute a stored procedure via an IDbCommand (that returns a 1x1 resultset) against the database specified in the connection string using the dataRow column values as the stored procedure's parameters values. This method will assign the parameter values based on parameter order.
Public method | ExecuteScalarTypedParams(IDbConnection, String, DataRow) | Execute a stored procedure via an IDbCommand (that returns a 1x1 resultset) against the specified IDbConnection using the dataRow column values as the stored procedure's parameters values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on parameter order.
Public method | ExecuteScalarTypedParams(IDbTransaction, String, DataRow) | Execute a stored procedure via an IDbCommand (that returns a 1x1 resultset) against the specified IDbTransaction using the dataRow column values as the stored procedure's parameters values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on parameter order.
Public method | ExecuteScalarTypedParams(String, String, DataRow) | Execute a stored procedure via an IDbCommand (that returns a 1x1 resultset) against the database specified in the connection string using the dataRow column values as the stored procedure's parameters values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on parameter order.
Public method | FillDataset(IDbCommand, DataSet, String) | Execute an IDbCommand (that returns a resultset) against the database specified in the connection String.
 | FillDataset(IDbConnection, CommandType, String, DataSet, String) | Execute an IDbCommand (that returns a resultset and takes no parameters) against the provided IDbConnection.
 | FillDataset(IDbConnection, String, DataSet, String, Object) | Execute a stored procedure via an IDbCommand (that returns a resultset) against the specified IDbConnection using the provided parameter values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on parameter order.
 | FillDataset(IDbTransaction, CommandType, String, DataSet, String) | Execute an IDbCommand (that returns a resultset and takes no parameters) against the provided IDbTransaction.
 | FillDataset(IDbTransaction, String, DataSet, String, Object) | Execute a stored procedure via an IDbCommand (that returns a resultset) against the specified IDbTransaction using the provided parameter values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on parameter order.
 | FillDataset(String, CommandType, String, DataSet, String) | Execute an IDbCommand (that returns a resultset and takes no parameters) against the database specified in the connection String.
 | FillDataset(String, String, DataSet, String, Object) | Execute a stored procedure via an IDbCommand (that returns a resultset) against the database specified in the connection string using the provided parameter values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on parameter order.
Public method | FillDataset(IDbConnection, CommandType, String, DataSet, String, IDataParameter) | Execute an IDbCommand (that returns a resultset) against the specified IDbConnection using the provided parameters.
Public method | FillDataset(IDbTransaction, CommandType, String, DataSet, String, IDataParameter) | Execute an IDbCommand (that returns a resultset) against the specified IDbTransaction using the provided parameters.
Public method | FillDataset(String, CommandType, String, DataSet, String, IDataParameter) | Execute an IDbCommand (that returns a resultset) against the database specified in the connection string using the provided parameters.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetBlobParameter | Handle any provider-specific issues with BLOBs here by "washing" the IDataParameter and returning a new one that is set up appropriately for the provider.
Public method | GetCachedParameterSet(IDbConnection, String) | Retrieve a parameter array from the cache
Public method | GetCachedParameterSet(String, String) | Retrieve a parameter array from the cache
Public method | GetConnection | Returns an IDbConnection object for the given connection string
Public method | GetDataAdapter | Returns an IDbDataAdapter object
Protected method | GetDataParameters | Returns an array of IDataParameters of the specified size
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetParameter | Returns an IDataParameter object
Public method | GetParameter(String, Object) | Get an IDataParameter for use in a SQL command
Public method | GetParameter(String, DbType, Int32, ParameterDirection) | Get an IDataParameter for use in a SQL command
Public method | GetParameter(String, DbType, Int32, String, DataRowVersion) | Get an IDataParameter for use in a SQL command
Public method | GetSpParameterSet(IDbConnection, String) | Retrieves the set of IDataParameters appropriate for the stored procedure
Public method | GetSpParameterSet(String, String) | Retrieves the set of IDataParameters appropriate for the stored procedure
Public method | GetSpParameterSet(IDbConnection, String, Boolean) | Retrieves the set of IDataParameters appropriate for the stored procedure
Public method | GetSpParameterSet(String, String, Boolean) | Retrieves the set of IDataParameters appropriate for the stored procedure
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PrepareCommand | This method opens (if necessary) and assigns a connection, transaction, command type and parameters to the provided command
Protected method | RowUpdated | This method consumes the RowUpdatedEvent and passes it on to the consumer specifed in the call to UpdateDataset
Protected method | RowUpdating | This method consumes the RowUpdatingEvent and passes it on to the consumer specifed in the call to UpdateDataset
Protected method | SetCommand | Set up a command for updating a DataSet.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | UpdateDataset(IDbCommand, IDbCommand, IDbCommand, DataSet, String) | Executes the respective command for each inserted, updated, or deleted row in the DataSet.
 | UpdateDataset(IDbCommand, IDbCommand, IDbCommand, DataSet, String, AdoHelperTFactoryRowUpdatingHandler, AdoHelperTFactoryRowUpdatedHandler) | Executes the IDbCommand for each inserted, updated, or deleted row in the DataSet also implementing RowUpdating and RowUpdated Event Handlers
Top
See Also

Reference

AdoHelperTFactory Class
CodeSmith.Engine Namespace


AdoHelper(TFactory).AddUpdateEventHandlers Method

AdoHelperTFactoryAddUpdateEventHandlers Method

Provider specific code to set up the updating/ed event handlers used by UpdateDataset

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual void AddUpdateEventHandlers(
    IDbDataAdapter dataAdapter,
    AdoHelperTFactoryRowUpdatingHandler rowUpdatingHandler,
    AdoHelperTFactoryRowUpdatedHandler rowUpdatedHandler
)
Protected Overridable Sub AddUpdateEventHandlers (
    dataAdapter As IDbDataAdapter,
    rowUpdatingHandler As AdoHelperTFactoryRowUpdatingHandler,
    rowUpdatedHandler As AdoHelperTFactoryRowUpdatedHandler
)

Parameters

dataAdapter
Type: System.DataIDbDataAdapter
DataAdapter to attach the event handlers to
rowUpdatingHandler
Type: CodeSmith.EngineAdoHelperTFactoryRowUpdatingHandler
The handler to be called when a row is updating
rowUpdatedHandler
Type: CodeSmith.EngineAdoHelperTFactoryRowUpdatedHandler
The handler to be called when a row is updated
See Also

Reference

AdoHelperTFactory Class
CodeSmith.Engine Namespace


AdoHelper(TFactory).AssignParameterValues Method

AdoHelperTFactoryAssignParameterValues Method

Overload List
 | Name | Description
Protected method | AssignParameterValues(IDataParameter, DataRow) | This method assigns dataRow column values to an array of IDataParameters
Protected method | AssignParameterValues(IDataParameter, Object) | This method assigns an array of values to an array of IDataParameters
Protected method | AssignParameterValues(IDataParameterCollection, DataRow) | This method assigns dataRow column values to an IDataParameterCollection
Top
See Also

Reference

AdoHelperTFactory Class
CodeSmith.Engine Namespace


AdoHelper(TFactory).AssignParameterValues Method (IDataParameter[], DataRow)

AdoHelperTFactoryAssignParameterValues Method (IDataParameter, DataRow)

This method assigns dataRow column values to an array of IDataParameters

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected void AssignParameterValues(
    IDataParameter[] commandParameters,
    DataRow dataRow
)
Protected Sub AssignParameterValues (
    commandParameters As IDataParameter(),
    dataRow As DataRow
)

Parameters

commandParameters
Type: System.DataIDataParameter
Array of IDataParameters to be assigned values
dataRow
Type: System.DataDataRow
The dataRow used to hold the stored procedure's parameter values
Exceptions
Exception | Condition
InvalidOperationException | Thrown if any of the parameter names are invalid.
See Also

Reference

AdoHelperTFactory Class
AssignParameterValues Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).AssignParameterValues Method (IDataParameter[], Object[])

AdoHelperTFactoryAssignParameterValues Method (IDataParameter, Object)

This method assigns an array of values to an array of IDataParameters

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected void AssignParameterValues(
    IDataParameter[] commandParameters,
    Object[] parameterValues
)
Protected Sub AssignParameterValues (
    commandParameters As IDataParameter(),
    parameterValues As Object()
)

Parameters

commandParameters
Type: System.DataIDataParameter
Array of IDataParameters to be assigned values
parameterValues
Type: SystemObject
Array of objects holding the values to be assigned
Exceptions
Exception | Condition
ArgumentException | Thrown if an incorrect number of parameters are passed.
See Also

Reference

AdoHelperTFactory Class
AssignParameterValues Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).AssignParameterValues Method (IDataParameterCollection, DataRow)

AdoHelperTFactoryAssignParameterValues Method (IDataParameterCollection, DataRow)

This method assigns dataRow column values to an IDataParameterCollection

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected void AssignParameterValues(
    IDataParameterCollection commandParameters,
    DataRow dataRow
)
Protected Sub AssignParameterValues (
    commandParameters As IDataParameterCollection,
    dataRow As DataRow
)

Parameters

commandParameters
Type: System.DataIDataParameterCollection
The IDataParameterCollection to be assigned values
dataRow
Type: System.DataDataRow
The dataRow used to hold the stored procedure's parameter values
Exceptions
Exception | Condition
InvalidOperationException | Thrown if any of the parameter names are invalid.
See Also

Reference

AdoHelperTFactory Class
AssignParameterValues Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).AttachParameters Method

AdoHelperTFactoryAttachParameters Method

This method is used to attach array of IDataParameters to an IDbCommand. This method will assign a value of DbNull to any parameter with a direction of InputOutput and a value of null. This behavior will prevent default values from being used, but this will be the less common case than an intended pure output parameter (derived as InputOutput) where the user provided no input value.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual void AttachParameters(
    IDbCommand command,
    IDataParameter[] commandParameters
)
Protected Overridable Sub AttachParameters (
    command As IDbCommand,
    commandParameters As IDataParameter()
)

Parameters

command
Type: System.DataIDbCommand
The command to which the parameters will be added
commandParameters
Type: System.DataIDataParameter
An array of IDataParameterParameters to be added to command
Exceptions
Exception | Condition
ArgumentNullException | Thrown if command is null.
See Also

Reference

AdoHelperTFactory Class
CodeSmith.Engine Namespace


AdoHelper(TFactory).CacheParameterSet Method

AdoHelperTFactoryCacheParameterSet Method

Overload List
 | Name | Description
Public method | CacheParameterSet(IDbConnection, String, IDataParameter) | Add parameter array to the cache
Public method | CacheParameterSet(String, String, IDataParameter) | Add parameter array to the cache
Top
See Also

Reference

AdoHelperTFactory Class
CodeSmith.Engine Namespace


AdoHelper(TFactory).CacheParameterSet Method (IDbConnection, String, IDataParameter[])

AdoHelperTFactoryCacheParameterSet Method (IDbConnection, String, IDataParameter)

Add parameter array to the cache

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void CacheParameterSet(
    IDbConnection connection,
    string commandText,
    params IDataParameter[] commandParameters
)
Public Sub CacheParameterSet (
    connection As IDbConnection,
    commandText As String,
    ParamArray commandParameters As IDataParameter()
)

Parameters

connection
Type: System.DataIDbConnection
A valid IDbConnection
commandText
Type: SystemString
The stored procedure name or SQL command
commandParameters
Type: System.DataIDataParameter
An array of IDataParameters to be cached
See Also

Reference

AdoHelperTFactory Class
CacheParameterSet Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).CacheParameterSet Method (String, String, IDataParameter[])

AdoHelperTFactoryCacheParameterSet Method (String, String, IDataParameter)

Add parameter array to the cache

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void CacheParameterSet(
    string connectionString,
    string commandText,
    params IDataParameter[] commandParameters
)
Public Sub CacheParameterSet (
    connectionString As String,
    commandText As String,
    ParamArray commandParameters As IDataParameter()
)

Parameters

connectionString
Type: SystemString
A valid connection string for an IDbConnection
commandText
Type: SystemString
The stored procedure name or SQL command
commandParameters
Type: System.DataIDataParameter
An array of IDataParameters to be cached
See Also

Reference

AdoHelperTFactory Class
CacheParameterSet Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).CleanParameterSyntax Method

AdoHelperTFactoryCleanParameterSyntax Method

This method cleans up the parameter syntax for the provider

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual void CleanParameterSyntax(
    IDbCommand command
)
Public Overridable Sub CleanParameterSyntax (
    command As IDbCommand
)

Parameters

command
Type: System.DataIDbCommand
The IDbCommand containing the parameters to clean up.
See Also

Reference

AdoHelperTFactory Class
CodeSmith.Engine Namespace


AdoHelper(TFactory).ClearCommand Method

AdoHelperTFactoryClearCommand Method

This method clears (if necessary) the connection, transaction, command type and parameters from the provided command

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual void ClearCommand(
    IDbCommand command
)
Protected Overridable Sub ClearCommand (
    command As IDbCommand
)

Parameters

command
Type: System.DataIDbCommand
The IDbCommand to be cleared
Remarks
Not implemented here because the behavior of this method differs on each data provider.
See Also

Reference

AdoHelperTFactory Class
CodeSmith.Engine Namespace


AdoHelper(TFactory).CreateCommand Method

AdoHelperTFactoryCreateCommand Method

Overload List
 | Name | Description
 | CreateCommand(IDbConnection, String, String) | Simplify the creation of an IDbCommand object by allowing a stored procedure and optional parameters to be provided
 | CreateCommand(String, String, String) | Simplify the creation of an IDbCommand object by allowing a stored procedure and optional parameters to be provided
 | CreateCommand(IDbConnection, String, CommandType, IDataParameter) | Simplify the creation of an IDbCommand object by allowing a stored procedure and optional parameters to be provided
Public method | CreateCommand(String, String, CommandType, IDataParameter) | Simplify the creation of an IDbCommand object by allowing a stored procedure and optional parameters to be provided
Top
See Also

Reference

AdoHelperTFactory Class
CodeSmith.Engine Namespace


AdoHelper(TFactory).CreateCommand Method (IDbConnection, String, String[])

AdoHelperTFactoryCreateCommand Method (IDbConnection, String, String)

Simplify the creation of an IDbCommand object by allowing a stored procedure and optional parameters to be provided

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual IDbCommand CreateCommand(
    IDbConnection connection,
    string spName,
    params string[] sourceColumns
)
Public Overridable Function CreateCommand (
    connection As IDbConnection,
    spName As String,
    ParamArray sourceColumns As String()
) As IDbCommand

Parameters

connection
Type: System.DataIDbConnection
A valid IDbConnection object
spName
Type: SystemString
The name of the stored procedure
sourceColumns
Type: SystemString
An array of string to be assigned as the source columns of the stored procedure parameters

Return Value

Type: IDbCommand
A valid IDbCommand object
Exceptions
Exception | Condition
ArgumentNullException | Thrown if spName is null
ArgumentNullException | Thrown if connection is null
Examples
Copy
IDbCommand command = helper.CreateCommand(conn, "AddCustomer", "CustomerID", "CustomerName");
See Also

Reference

AdoHelperTFactory Class
CreateCommand Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).CreateCommand Method (String, String, String[])

AdoHelperTFactoryCreateCommand Method (String, String, String)

Simplify the creation of an IDbCommand object by allowing a stored procedure and optional parameters to be provided

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual IDbCommand CreateCommand(
    string connectionString,
    string spName,
    params string[] sourceColumns
)
Public Overridable Function CreateCommand (
    connectionString As String,
    spName As String,
    ParamArray sourceColumns As String()
) As IDbCommand

Parameters

connectionString
Type: SystemString
A valid connection string for an IDbConnection
spName
Type: SystemString
The name of the stored procedure
sourceColumns
Type: SystemString
An array of string to be assigned as the source columns of the stored procedure parameters

Return Value

Type: IDbCommand
A valid IDbCommand object
Exceptions
Exception | Condition
ArgumentNullException | Thrown if connectionString is null
InvalidOperationException | Thrown if any of the IDataParameters.ParameterNames are null, or if the parameter count does not match the number of values supplied
ArgumentNullException | Thrown if spName is null
ArgumentException | Thrown if the parameter count does not match the number of values supplied
Examples
Copy
IDbCommand command = helper.CreateCommand(conn, "AddCustomer", "CustomerID", "CustomerName");
See Also

Reference

AdoHelperTFactory Class
CreateCommand Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).CreateCommand Method (IDbConnection, String, CommandType, IDataParameter[])

AdoHelperTFactoryCreateCommand Method (IDbConnection, String, CommandType, IDataParameter)

Simplify the creation of an IDbCommand object by allowing a stored procedure and optional parameters to be provided

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual IDbCommand CreateCommand(
    IDbConnection connection,
    string commandText,
    CommandType commandType,
    params IDataParameter[] commandParameters
)
Public Overridable Function CreateCommand (
    connection As IDbConnection,
    commandText As String,
    commandType As CommandType,
    ParamArray commandParameters As IDataParameter()
) As IDbCommand

Parameters

connection
Type: System.DataIDbConnection
A valid IDbConnection object
commandText
Type: SystemString
A valid SQL statement
commandType
Type: System.DataCommandType
A System.Data.CommandType
commandParameters
Type: System.DataIDataParameter
The parameters for the SQL statement

Return Value

Type: IDbCommand
A valid IDbCommand object
Examples
Copy
IDbCommand command = helper.CreateCommand(conn, "AddCustomer", "CustomerID", "CustomerName");
See Also

Reference

AdoHelperTFactory Class
CreateCommand Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).CreateCommand Method (String, String, CommandType, IDataParameter[])

AdoHelperTFactoryCreateCommand Method (String, String, CommandType, IDataParameter)

Simplify the creation of an IDbCommand object by allowing a stored procedure and optional parameters to be provided

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual IDbCommand CreateCommand(
    string connectionString,
    string commandText,
    CommandType commandType,
    params IDataParameter[] commandParameters
)
Public Overridable Function CreateCommand (
    connectionString As String,
    commandText As String,
    commandType As CommandType,
    ParamArray commandParameters As IDataParameter()
) As IDbCommand

Parameters

connectionString
Type: SystemString
A valid connection string for an IDbConnection
commandText
Type: SystemString
A valid SQL statement
commandType
Type: System.DataCommandType
A System.Data.CommandType
commandParameters
Type: System.DataIDataParameter
The parameters for the SQL statement

Return Value

Type: IDbCommand
A valid IDbCommand object
See Also

Reference

AdoHelperTFactory Class
CreateCommand Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).DeriveParameters Method

AdoHelperTFactoryDeriveParameters Method

Calls the CommandBuilder.DeriveParameters method for the specified provider, doing any setup and cleanup necessary

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual void DeriveParameters(
    IDbCommand cmd
)
Public Overridable Sub DeriveParameters (
    cmd As IDbCommand
)

Parameters

cmd
Type: System.DataIDbCommand
The IDbCommand referencing the stored procedure from which the parameter information is to be derived. The derived parameters are added to the Parameters collection of the IDbCommand.
See Also

Reference

AdoHelperTFactory Class
CodeSmith.Engine Namespace


AdoHelper(TFactory).ExecuteDataset Method

AdoHelperTFactoryExecuteDataset Method

Overload List
 | Name | Description
Public method | ExecuteDataset(IDbCommand) | Execute an IDbCommand (that returns a resultset) against the database specified in the connection String.
 | ExecuteDataset(IDbConnection, CommandType, String) | Execute an IDbCommand (that returns a resultset and takes no parameters) against the provided IDbConnection.
 | ExecuteDataset(IDbConnection, String, Object) | Execute a stored procedure via an IDbCommand (that returns a resultset) against the specified IDbConnection using the provided parameter values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on parameter order.
 | ExecuteDataset(IDbTransaction, CommandType, String) | Execute an IDbCommand (that returns a resultset and takes no parameters) against the provided IDbTransaction.
 | ExecuteDataset(IDbTransaction, String, Object) | Execute a stored procedure via an IDbCommand (that returns a resultset) against the specified IDbTransaction using the provided parameter values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on parameter order.
 | ExecuteDataset(String, CommandType, String) | Execute an IDbCommand (that returns a resultset and takes no parameters) against the database specified in the connection String.
 | ExecuteDataset(String, String, Object) | Execute a stored procedure via an IDbCommand (that returns a resultset) against the database specified in the connection string using the provided parameter values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on parameter order.
 | ExecuteDataset(IDbConnection, CommandType, String, IDataParameter) | Execute an IDbCommand (that returns a resultset) against the specified IDbConnection using the provided parameters.
 | ExecuteDataset(IDbTransaction, CommandType, String, IDataParameter) | Execute an IDbCommand (that returns a resultset) against the specified IDbTransaction using the provided parameters.
 | ExecuteDataset(String, CommandType, String, IDataParameter) | Execute an IDbCommand (that returns a resultset) against the database specified in the connection string using the provided parameters.
Top
See Also

Reference

AdoHelperTFactory Class
CodeSmith.Engine Namespace


AdoHelper(TFactory).ExecuteDataset Method (IDbCommand)

AdoHelperTFactoryExecuteDataset Method (IDbCommand)

Execute an IDbCommand (that returns a resultset) against the database specified in the connection String.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual DataSet ExecuteDataset(
    IDbCommand command
)
Public Overridable Function ExecuteDataset (
    command As IDbCommand
) As DataSet

Parameters

command
Type: System.DataIDbCommand
The IDbCommand object to use

Return Value

Type: DataSet
A DataSet containing the resultset generated by the command
Exceptions
Exception | Condition
ArgumentNullException | Thrown if command is null.
See Also

Reference

AdoHelperTFactory Class
ExecuteDataset Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).ExecuteDataset Method (IDbConnection, CommandType, String)

AdoHelperTFactoryExecuteDataset Method (IDbConnection, CommandType, String)

Execute an IDbCommand (that returns a resultset and takes no parameters) against the provided IDbConnection.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual DataSet ExecuteDataset(
    IDbConnection connection,
    CommandType commandType,
    string commandText
)
Public Overridable Function ExecuteDataset (
    connection As IDbConnection,
    commandType As CommandType,
    commandText As String
) As DataSet

Parameters

connection
Type: System.DataIDbConnection
A valid IDbConnection
commandType
Type: System.DataCommandType
The CommandType (stored procedure, text, etc.)
commandText
Type: SystemString
The stored procedure name or SQL command

Return Value

Type: DataSet
A DataSet containing the resultset generated by the command
Exceptions
Exception | Condition
ArgumentNullException | Thrown if commandText is null
ArgumentNullException | Thrown if connection is null
Examples
Copy
DataSet ds = helper.ExecuteDataset(conn, CommandType.StoredProcedure, "GetOrders");
See Also

Reference

AdoHelperTFactory Class
ExecuteDataset Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).ExecuteDataset Method (IDbConnection, String, Object[])

AdoHelperTFactoryExecuteDataset Method (IDbConnection, String, Object)

Execute a stored procedure via an IDbCommand (that returns a resultset) against the specified IDbConnection using the provided parameter values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on parameter order.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual DataSet ExecuteDataset(
    IDbConnection connection,
    string spName,
    params Object[] parameterValues
)
Public Overridable Function ExecuteDataset (
    connection As IDbConnection,
    spName As String,
    ParamArray parameterValues As Object()
) As DataSet

Parameters

connection
Type: System.DataIDbConnection
A valid IDbConnection
spName
Type: SystemString
The name of the stored procedure
parameterValues
Type: SystemObject
An array of objects to be assigned as the input values of the stored procedure

Return Value

Type: DataSet
A DataSet containing the resultset generated by the command
Exceptions
Exception | Condition
ArgumentNullException | Thrown if spName is null
ArgumentException | Thrown if the parameter count does not match the number of values supplied
ArgumentNullException | Thrown if connection is null
Remarks
This method provides no access to output parameters or the stored procedure's return value parameter.
Examples
Copy
DataSet ds = helper.ExecuteDataset(conn, "GetOrders", 24, 36);
See Also

Reference

AdoHelperTFactory Class
ExecuteDataset Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).ExecuteDataset Method (IDbTransaction, CommandType, String)

AdoHelperTFactoryExecuteDataset Method (IDbTransaction, CommandType, String)

Execute an IDbCommand (that returns a resultset and takes no parameters) against the provided IDbTransaction.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual DataSet ExecuteDataset(
    IDbTransaction transaction,
    CommandType commandType,
    string commandText
)
Public Overridable Function ExecuteDataset (
    transaction As IDbTransaction,
    commandType As CommandType,
    commandText As String
) As DataSet

Parameters

transaction
Type: System.DataIDbTransaction
A valid IDbTransaction
commandType
Type: System.DataCommandType
The CommandType (stored procedure, text, etc.)
commandText
Type: SystemString
The stored procedure name or SQL command

Return Value

Type: DataSet
A DataSet containing the resultset generated by the command
Exceptions
Exception | Condition
ArgumentNullException | Thrown if commandText is null
ArgumentNullException | Thrown if transaction is null
ArgumentNullException | Thrown if transaction.Connection is null
Examples
Copy
DataSet ds = helper.ExecuteDataset(trans, CommandType.StoredProcedure, "GetOrders");
See Also

Reference

AdoHelperTFactory Class
ExecuteDataset Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).ExecuteDataset Method (IDbTransaction, String, Object[])

AdoHelperTFactoryExecuteDataset Method (IDbTransaction, String, Object)

Execute a stored procedure via an IDbCommand (that returns a resultset) against the specified IDbTransaction using the provided parameter values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on parameter order.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual DataSet ExecuteDataset(
    IDbTransaction transaction,
    string spName,
    params Object[] parameterValues
)
Public Overridable Function ExecuteDataset (
    transaction As IDbTransaction,
    spName As String,
    ParamArray parameterValues As Object()
) As DataSet

Parameters

transaction
Type: System.DataIDbTransaction
A valid IDbTransaction
spName
Type: SystemString
The name of the stored procedure
parameterValues
Type: SystemObject
An array of objects to be assigned as the input values of the stored procedure

Return Value

Type: DataSet
A DataSet containing the resultset generated by the command
Exceptions
Exception | Condition
ArgumentNullException | Thrown if spName is null
ArgumentException | Thrown if the parameter count does not match the number of values supplied
ArgumentNullException | Thrown if transaction is null
ArgumentNullException | Thrown if transaction.Connection is null
Remarks
This method provides no access to output parameters or the stored procedure's return value parameter.
Examples
Copy
DataSet ds = helper.ExecuteDataset(tran, "GetOrders", 24, 36);
See Also

Reference

AdoHelperTFactory Class
ExecuteDataset Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).ExecuteDataset Method (String, CommandType, String)

AdoHelperTFactoryExecuteDataset Method (String, CommandType, String)

Execute an IDbCommand (that returns a resultset and takes no parameters) against the database specified in the connection String.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual DataSet ExecuteDataset(
    string connectionString,
    CommandType commandType,
    string commandText
)
Public Overridable Function ExecuteDataset (
    connectionString As String,
    commandType As CommandType,
    commandText As String
) As DataSet

Parameters

connectionString
Type: SystemString
A valid connection string for an IDbConnection
commandType
Type: System.DataCommandType
The CommandType (stored procedure, text, etc.)
commandText
Type: SystemString
The stored procedure name or SQL command

Return Value

Type: DataSet
A DataSet containing the resultset generated by the command

Return Value

Type: DataSet
A DataSet containing the resultset generated by the command
Exceptions
Exception | Condition
ArgumentNullException | Thrown if connectionString is null
ArgumentNullException | Thrown if commandText is null
Examples
Copy
DataSet ds = helper.ExecuteDataset(connString, CommandType.StoredProcedure, "GetOrders");
See Also

Reference

AdoHelperTFactory Class
ExecuteDataset Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).ExecuteDataset Method (String, String, Object[])

AdoHelperTFactoryExecuteDataset Method (String, String, Object)

Execute a stored procedure via an IDbCommand (that returns a resultset) against the database specified in the connection string using the provided parameter values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on parameter order.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual DataSet ExecuteDataset(
    string connectionString,
    string spName,
    params Object[] parameterValues
)
Public Overridable Function ExecuteDataset (
    connectionString As String,
    spName As String,
    ParamArray parameterValues As Object()
) As DataSet

Parameters

connectionString
Type: SystemString
A valid connection string for an IDbConnection
spName
Type: SystemString
The name of the stored procedure
parameterValues
Type: SystemObject
An array of objects to be assigned as the input values of the stored procedure

Return Value

Type: DataSet
A DataSet containing the resultset generated by the command
Exceptions
Exception | Condition
ArgumentNullException | Thrown if connectionString is null
ArgumentNullException | Thrown if spName is null
Remarks
This method provides no access to output parameters or the stored procedure's return value parameter.
Examples
Copy
DataSet ds = helper.ExecuteDataset(connString, "GetOrders", 24, 36);
See Also

Reference

AdoHelperTFactory Class
ExecuteDataset Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).ExecuteDataset Method (IDbConnection, CommandType, String, IDataParameter[])

AdoHelperTFactoryExecuteDataset Method (IDbConnection, CommandType, String, IDataParameter)

Execute an IDbCommand (that returns a resultset) against the specified IDbConnection using the provided parameters.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual DataSet ExecuteDataset(
    IDbConnection connection,
    CommandType commandType,
    string commandText,
    params IDataParameter[] commandParameters
)
Public Overridable Function ExecuteDataset (
    connection As IDbConnection,
    commandType As CommandType,
    commandText As String,
    ParamArray commandParameters As IDataParameter()
) As DataSet

Parameters

connection
Type: System.DataIDbConnection
A valid IDbConnection
commandType
Type: System.DataCommandType
The CommandType (stored procedure, text, etc.)
commandText
Type: SystemString
The stored procedure name or SQL command
commandParameters
Type: System.DataIDataParameter
An array of IDataParameters used to execute the command

Return Value

Type: DataSet
A DataSet containing the resultset generated by the command
Exceptions
Exception | Condition
InvalidOperationException | Thrown if any of the IDataParameters.ParameterNames are null, or if the parameter count does not match the number of values supplied
ArgumentNullException | Thrown if commandText is null
ArgumentException | Thrown if the parameter count does not match the number of values supplied
ArgumentNullException | Thrown if connection is null
Examples
Copy
DataSet ds = helper.ExecuteDataset(conn, CommandType.StoredProcedure, "GetOrders", new IDataParameter("@prodid", 24));
See Also

Reference

AdoHelperTFactory Class
ExecuteDataset Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).ExecuteDataset Method (IDbTransaction, CommandType, String, IDataParameter[])

AdoHelperTFactoryExecuteDataset Method (IDbTransaction, CommandType, String, IDataParameter)

Execute an IDbCommand (that returns a resultset) against the specified IDbTransaction using the provided parameters.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual DataSet ExecuteDataset(
    IDbTransaction transaction,
    CommandType commandType,
    string commandText,
    params IDataParameter[] commandParameters
)
Public Overridable Function ExecuteDataset (
    transaction As IDbTransaction,
    commandType As CommandType,
    commandText As String,
    ParamArray commandParameters As IDataParameter()
) As DataSet

Parameters

transaction
Type: System.DataIDbTransaction
A valid IDbTransaction
commandType
Type: System.DataCommandType
The CommandType (stored procedure, text, etc.)
commandText
Type: SystemString
The stored procedure name or SQL command
commandParameters
Type: System.DataIDataParameter
An array of IDataParameters used to execute the command

Return Value

Type: DataSet
A DataSet containing the resultset generated by the command
Exceptions
Exception | Condition
InvalidOperationException | Thrown if any of the IDataParameters.ParameterNames are null, or if the parameter count does not match the number of values supplied
ArgumentNullException | Thrown if commandText is null
ArgumentException | Thrown if the parameter count does not match the number of values supplied
ArgumentNullException | Thrown if transaction is null
ArgumentNullException | Thrown if transaction.Connection is null
Examples
Copy
DataSet ds = helper.ExecuteDataset(trans, CommandType.StoredProcedure, "GetOrders", new IDataParameter("@prodid", 24));
See Also

Reference

AdoHelperTFactory Class
ExecuteDataset Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).ExecuteDataset Method (String, CommandType, String, IDataParameter[])

AdoHelperTFactoryExecuteDataset Method (String, CommandType, String, IDataParameter)

Execute an IDbCommand (that returns a resultset) against the database specified in the connection string using the provided parameters.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual DataSet ExecuteDataset(
    string connectionString,
    CommandType commandType,
    string commandText,
    params IDataParameter[] commandParameters
)
Public Overridable Function ExecuteDataset (
    connectionString As String,
    commandType As CommandType,
    commandText As String,
    ParamArray commandParameters As IDataParameter()
) As DataSet

Parameters

connectionString
Type: SystemString
A valid connection string for an IDbConnection
commandType
Type: System.DataCommandType
The CommandType (stored procedure, text, etc.)
commandText
Type: SystemString
The stored procedure name or SQL command
commandParameters
Type: System.DataIDataParameter
An array of IDbParamters used to execute the command

Return Value

Type: DataSet
A DataSet containing the resultset generated by the command
Exceptions
Exception | Condition
ArgumentNullException | Thrown if connectionString is null
InvalidOperationException | Thrown if any of the IDataParameters.ParameterNames are null, or if the parameter count does not match the number of values supplied
ArgumentNullException | Thrown if commandText is null
ArgumentException | Thrown if the parameter count does not match the number of values supplied
Examples
Copy
DataSet ds = helper.ExecuteDataset(connString, CommandType.StoredProcedure, "GetOrders", new IDbParameter("@prodid", 24));
See Also

Reference

AdoHelperTFactory Class
ExecuteDataset Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).ExecuteDatasetTypedParams Method

AdoHelperTFactoryExecuteDatasetTypedParams Method

Overload List
 | Name | Description
Public method | ExecuteDatasetTypedParams(IDbCommand, DataRow) | Execute a stored procedure via an IDbCommand (that returns a resultset) against the database specified in the connection string using the dataRow column values as the stored procedure's parameters values. This method will assign the paraemter values based on row values.
Public method | ExecuteDatasetTypedParams(IDbConnection, String, DataRow) | Execute a stored procedure via an IDbCommand (that returns a resultset) against the specified IDbConnection using the dataRow column values as the store procedure's parameters values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on row values.
Public method | ExecuteDatasetTypedParams(IDbTransaction, String, DataRow) | Execute a stored procedure via an IDbCommand (that returns a resultset) against the specified IDbTransaction using the dataRow column values as the stored procedure's parameters values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on row values.
Public method | ExecuteDatasetTypedParams(String, String, DataRow) | Execute a stored procedure via an IDbCommand (that returns a resultset) against the database specified in the connection string using the dataRow column values as the stored procedure's parameters values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on row values.
Top
See Also

Reference

AdoHelperTFactory Class
CodeSmith.Engine Namespace


AdoHelper(TFactory).ExecuteDatasetTypedParams Method (IDbCommand, DataRow)

AdoHelperTFactoryExecuteDatasetTypedParams Method (IDbCommand, DataRow)

Execute a stored procedure via an IDbCommand (that returns a resultset) against the database specified in the connection string using the dataRow column values as the stored procedure's parameters values. This method will assign the paraemter values based on row values.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual DataSet ExecuteDatasetTypedParams(
    IDbCommand command,
    DataRow dataRow
)
Public Overridable Function ExecuteDatasetTypedParams (
    command As IDbCommand,
    dataRow As DataRow
) As DataSet

Parameters

command
Type: System.DataIDbCommand
The IDbCommand to execute
dataRow
Type: System.DataDataRow
The dataRow used to hold the stored procedure's parameter values.

Return Value

Type: DataSet
A DataSet containing the resultset generated by the command
Exceptions
Exception | Condition
ArgumentNullException | Thrown if command is null.
See Also

Reference

AdoHelperTFactory Class
ExecuteDatasetTypedParams Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).ExecuteDatasetTypedParams Method (IDbConnection, String, DataRow)

AdoHelperTFactoryExecuteDatasetTypedParams Method (IDbConnection, String, DataRow)

Execute a stored procedure via an IDbCommand (that returns a resultset) against the specified IDbConnection using the dataRow column values as the store procedure's parameters values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on row values.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual DataSet ExecuteDatasetTypedParams(
    IDbConnection connection,
    string spName,
    DataRow dataRow
)
Public Overridable Function ExecuteDatasetTypedParams (
    connection As IDbConnection,
    spName As String,
    dataRow As DataRow
) As DataSet

Parameters

connection
Type: System.DataIDbConnection
A valid IDbConnection object
spName
Type: SystemString
The name of the stored procedure
dataRow
Type: System.DataDataRow
The dataRow used to hold the stored procedure's parameter values.

Return Value

Type: DataSet
A DataSet containing the resultset generated by the command
Exceptions
Exception | Condition
ArgumentNullException | Thrown if spName is null
ArgumentNullException | Thrown if connection is null
See Also

Reference

AdoHelperTFactory Class
ExecuteDatasetTypedParams Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).ExecuteDatasetTypedParams Method (IDbTransaction, String, DataRow)

AdoHelperTFactoryExecuteDatasetTypedParams Method (IDbTransaction, String, DataRow)

Execute a stored procedure via an IDbCommand (that returns a resultset) against the specified IDbTransaction using the dataRow column values as the stored procedure's parameters values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on row values.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual DataSet ExecuteDatasetTypedParams(
    IDbTransaction transaction,
    string spName,
    DataRow dataRow
)
Public Overridable Function ExecuteDatasetTypedParams (
    transaction As IDbTransaction,
    spName As String,
    dataRow As DataRow
) As DataSet

Parameters

transaction
Type: System.DataIDbTransaction
A valid IDbTransaction object
spName
Type: SystemString
The name of the stored procedure
dataRow
Type: System.DataDataRow
The dataRow used to hold the stored procedure's parameter values.

Return Value

Type: DataSet
A DataSet containing the resultset generated by the command
Exceptions
Exception | Condition
ArgumentNullException | Thrown if spName is null
ArgumentNullException | Thrown if transaction is null
ArgumentNullException | Thrown if transaction.Connection is null
See Also

Reference

AdoHelperTFactory Class
ExecuteDatasetTypedParams Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).ExecuteDatasetTypedParams Method (String, String, DataRow)

AdoHelperTFactoryExecuteDatasetTypedParams Method (String, String, DataRow)

Execute a stored procedure via an IDbCommand (that returns a resultset) against the database specified in the connection string using the dataRow column values as the stored procedure's parameters values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on row values.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual DataSet ExecuteDatasetTypedParams(
    string connectionString,
    string spName,
    DataRow dataRow
)
Public Overridable Function ExecuteDatasetTypedParams (
    connectionString As String,
    spName As String,
    dataRow As DataRow
) As DataSet

Parameters

connectionString
Type: SystemString
A valid connection string for an IDbConnection
spName
Type: SystemString
The name of the stored procedure
dataRow
Type: System.DataDataRow
The dataRow used to hold the stored procedure's parameter values.

Return Value

Type: DataSet
A DataSet containing the resultset generated by the command
Exceptions
Exception | Condition
ArgumentNullException | Thrown if connectionString is null
ArgumentNullException | Thrown if spName is null
See Also

Reference

AdoHelperTFactory Class
ExecuteDatasetTypedParams Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).ExecuteNonQuery Method

AdoHelperTFactoryExecuteNonQuery Method

Overload List
 | Name | Description
Public method | ExecuteNonQuery(IDbCommand) | Execute an IDbCommand (that returns no resultset) against the database
Public method | ExecuteNonQuery(IDbConnection, CommandType, String) | Execute an IDbCommand (that returns no resultset and takes no parameters) against the provided IDbConnection.
Public method | ExecuteNonQuery(IDbConnection, String, Object) | Execute a stored procedure via an IDbCommand (that returns no resultset) against the specified IDbConnection using the provided parameter values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on parameter order.
Public method | ExecuteNonQuery(IDbTransaction, CommandType, String) | Execute an IDbCommand (that returns no resultset and takes no parameters) against the provided IDbTransaction.
Public method | ExecuteNonQuery(IDbTransaction, String, Object) | Execute a stored procedure via an IDbCommand (that returns no resultset) against the specified IDbTransaction using the provided parameter values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on parameter order.
Public method | ExecuteNonQuery(String, CommandType, String) | Execute an IDbCommand (that returns no resultset and takes no parameters) against the database specified in the connection string
Public method | ExecuteNonQuery(String, String, Object) | Execute a stored procedure via an IDbCommand (that returns no resultset) against the database specified in the connection string using the provided parameter values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on parameter order.
Public method | ExecuteNonQuery(IDbConnection, CommandType, String, IDataParameter) | Execute an IDbCommand (that returns no resultset) against the specified IDbConnection using the provided parameters.
Public method | ExecuteNonQuery(IDbTransaction, CommandType, String, IDataParameter) | Execute an IDbCommand (that returns no resultset) against the specified IDbTransaction using the provided parameters.
Public method | ExecuteNonQuery(String, CommandType, String, IDataParameter) | Execute an IDbCommand (that returns no resultset) against the database specified in the connection string using the provided parameters
Top
See Also

Reference

AdoHelperTFactory Class
CodeSmith.Engine Namespace


AdoHelper(TFactory).ExecuteNonQuery Method (IDbCommand)

AdoHelperTFactoryExecuteNonQuery Method (IDbCommand)

Execute an IDbCommand (that returns no resultset) against the database

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual int ExecuteNonQuery(
    IDbCommand command
)
Public Overridable Function ExecuteNonQuery (
    command As IDbCommand
) As Integer

Parameters

command
Type: System.DataIDbCommand
The IDbCommand to execute

Return Value

Type: Int32
An int representing the number of rows affected by the command
Exceptions
Exception | Condition
ArgumentNullException | Thrown if command is null.
See Also

Reference

AdoHelperTFactory Class
ExecuteNonQuery Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).ExecuteNonQuery Method (IDbConnection, CommandType, String)

AdoHelperTFactoryExecuteNonQuery Method (IDbConnection, CommandType, String)

Execute an IDbCommand (that returns no resultset and takes no parameters) against the provided IDbConnection.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual int ExecuteNonQuery(
    IDbConnection connection,
    CommandType commandType,
    string commandText
)
Public Overridable Function ExecuteNonQuery (
    connection As IDbConnection,
    commandType As CommandType,
    commandText As String
) As Integer

Parameters

connection
Type: System.DataIDbConnection
A valid IDbConnection
commandType
Type: System.DataCommandType
The CommandType (stored procedure, text, etc.)
commandText
Type: SystemString
The stored procedure name or SQL command

Return Value

Type: Int32
An int representing the number of rows affected by the command
Exceptions
Exception | Condition
ArgumentNullException | Thrown if commandText is null
ArgumentNullException | Thrown if connection is null
See Also

Reference

AdoHelperTFactory Class
ExecuteNonQuery Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).ExecuteNonQuery Method (IDbConnection, String, Object[])

AdoHelperTFactoryExecuteNonQuery Method (IDbConnection, String, Object)

Execute a stored procedure via an IDbCommand (that returns no resultset) against the specified IDbConnection using the provided parameter values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on parameter order.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual int ExecuteNonQuery(
    IDbConnection connection,
    string spName,
    params Object[] parameterValues
)
Public Overridable Function ExecuteNonQuery (
    connection As IDbConnection,
    spName As String,
    ParamArray parameterValues As Object()
) As Integer

Parameters

connection
Type: System.DataIDbConnection
A valid IDbConnection
spName
Type: SystemString
The name of the stored procedure
parameterValues
Type: SystemObject
An array of objects to be assigned as the input values of the stored procedure

Return Value

Type: Int32
An int representing the number of rows affected by the command
Exceptions
Exception | Condition
ArgumentNullException | Thrown if spName is null
ArgumentException | Thrown if the parameter count does not match the number of values supplied
ArgumentNullException | Thrown if connection is null
Remarks
This method provides no access to output parameters or the stored procedure's return value parameter.
See Also

Reference

AdoHelperTFactory Class
ExecuteNonQuery Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).ExecuteNonQuery Method (IDbTransaction, CommandType, String)

AdoHelperTFactoryExecuteNonQuery Method (IDbTransaction, CommandType, String)

Execute an IDbCommand (that returns no resultset and takes no parameters) against the provided IDbTransaction.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual int ExecuteNonQuery(
    IDbTransaction transaction,
    CommandType commandType,
    string commandText
)
Public Overridable Function ExecuteNonQuery (
    transaction As IDbTransaction,
    commandType As CommandType,
    commandText As String
) As Integer

Parameters

transaction
Type: System.DataIDbTransaction
A valid IDbTransaction
commandType
Type: System.DataCommandType
The CommandType (stored procedure, text, etc.)
commandText
Type: SystemString
The stored procedure name or SQL command

Return Value

Type: Int32
An int representing the number of rows affected by the command
Exceptions
Exception | Condition
ArgumentNullException | Thrown if commandText is null
ArgumentNullException | Thrown if transaction is null
ArgumentNullException | Thrown if transaction.Connection is null
See Also

Reference

AdoHelperTFactory Class
ExecuteNonQuery Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).ExecuteNonQuery Method (IDbTransaction, String, Object[])

AdoHelperTFactoryExecuteNonQuery Method (IDbTransaction, String, Object)

Execute a stored procedure via an IDbCommand (that returns no resultset) against the specified IDbTransaction using the provided parameter values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on parameter order.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual int ExecuteNonQuery(
    IDbTransaction transaction,
    string spName,
    params Object[] parameterValues
)
Public Overridable Function ExecuteNonQuery (
    transaction As IDbTransaction,
    spName As String,
    ParamArray parameterValues As Object()
) As Integer

Parameters

transaction
Type: System.DataIDbTransaction
A valid IDbTransaction
spName
Type: SystemString
The name of the stored procedure
parameterValues
Type: SystemObject
An array of objects to be assigned as the input values of the stored procedure

Return Value

Type: Int32
An int representing the number of rows affected by the command
Exceptions
Exception | Condition
ArgumentNullException | Thrown if spName is null
ArgumentException | Thrown if the parameter count does not match the number of values supplied
ArgumentNullException | Thrown if transaction is null
ArgumentNullException | Thrown if transaction.Connection is null
Remarks
This method provides no access to output parameters or the stored procedure's return value parameter.
See Also

Reference

AdoHelperTFactory Class
ExecuteNonQuery Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).ExecuteNonQuery Method (String, CommandType, String)

AdoHelperTFactoryExecuteNonQuery Method (String, CommandType, String)

Execute an IDbCommand (that returns no resultset and takes no parameters) against the database specified in the connection string

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual int ExecuteNonQuery(
    string connectionString,
    CommandType commandType,
    string commandText
)
Public Overridable Function ExecuteNonQuery (
    connectionString As String,
    commandType As CommandType,
    commandText As String
) As Integer

Parameters

connectionString
Type: SystemString
A valid connection string for an IDbConnection
commandType
Type: System.DataCommandType
The CommandType (stored procedure, text, etc.)
commandText
Type: SystemString
The stored procedure name or SQL command

Return Value

Type: Int32
An int representing the number of rows affected by the command
Exceptions
Exception | Condition
ArgumentNullException | Thrown if connectionString is null
ArgumentNullException | Thrown if commandText is null
See Also

Reference

AdoHelperTFactory Class
ExecuteNonQuery Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).ExecuteNonQuery Method (String, String, Object[])

AdoHelperTFactoryExecuteNonQuery Method (String, String, Object)

Execute a stored procedure via an IDbCommand (that returns no resultset) against the database specified in the connection string using the provided parameter values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on parameter order.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual int ExecuteNonQuery(
    string connectionString,
    string spName,
    params Object[] parameterValues
)
Public Overridable Function ExecuteNonQuery (
    connectionString As String,
    spName As String,
    ParamArray parameterValues As Object()
) As Integer

Parameters

connectionString
Type: SystemString
A valid connection string for an IDbConnection
spName
Type: SystemString
The name of the stored prcedure
parameterValues
Type: SystemObject
An array of objects to be assigned as the input values of the stored procedure

Return Value

Type: Int32
An int representing the number of rows affected by the command
Exceptions
Exception | Condition
ArgumentNullException | Thrown if connectionString is null
ArgumentNullException | Thrown if spName is null
ArgumentException | Thrown if the parameter count does not match the number of values supplied
Remarks
This method provides no access to output parameters or the stored procedure's return value parameter.
See Also

Reference

AdoHelperTFactory Class
ExecuteNonQuery Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).ExecuteNonQuery Method (IDbConnection, CommandType, String, IDataParameter[])

AdoHelperTFactoryExecuteNonQuery Method (IDbConnection, CommandType, String, IDataParameter)

Execute an IDbCommand (that returns no resultset) against the specified IDbConnection using the provided parameters.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual int ExecuteNonQuery(
    IDbConnection connection,
    CommandType commandType,
    string commandText,
    params IDataParameter[] commandParameters
)
Public Overridable Function ExecuteNonQuery (
    connection As IDbConnection,
    commandType As CommandType,
    commandText As String,
    ParamArray commandParameters As IDataParameter()
) As Integer

Parameters

connection
Type: System.DataIDbConnection
A valid IDbConnection
commandType
Type: System.DataCommandType
The CommandType (stored procedure, text, etc.)
commandText
Type: SystemString
The stored procedure name or SQL command
commandParameters
Type: System.DataIDataParameter
An array of IDbParamters used to execute the command

Return Value

Type: Int32
An int representing the number of rows affected by the command
Exceptions
Exception | Condition
InvalidOperationException | Thrown if any of the IDataParameters.ParameterNames are null, or if the parameter count does not match the number of values supplied
ArgumentNullException | Thrown if commandText is null
ArgumentException | Thrown if the parameter count does not match the number of values supplied
ArgumentNullException | Thrown if connection is null
Remarks
See Also

Reference

AdoHelperTFactory Class
ExecuteNonQuery Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).ExecuteNonQuery Method (IDbTransaction, CommandType, String, IDataParameter[])

AdoHelperTFactoryExecuteNonQuery Method (IDbTransaction, CommandType, String, IDataParameter)

Execute an IDbCommand (that returns no resultset) against the specified IDbTransaction using the provided parameters.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual int ExecuteNonQuery(
    IDbTransaction transaction,
    CommandType commandType,
    string commandText,
    params IDataParameter[] commandParameters
)
Public Overridable Function ExecuteNonQuery (
    transaction As IDbTransaction,
    commandType As CommandType,
    commandText As String,
    ParamArray commandParameters As IDataParameter()
) As Integer

Parameters

transaction
Type: System.DataIDbTransaction
A valid IDbTransaction
commandType
Type: System.DataCommandType
The CommandType (stored procedure, text, etc.)
commandText
Type: SystemString
The stored procedure name or SQL command
commandParameters
Type: System.DataIDataParameter
An array of IDataParameters used to execute the command

Return Value

Type: Int32
An int representing the number of rows affected by the command
Exceptions
Exception | Condition
InvalidOperationException | Thrown if any of the IDataParameters.ParameterNames are null, or if the parameter count does not match the number of values supplied
ArgumentNullException | Thrown if commandText is null
ArgumentException | Thrown if the parameter count does not match the number of values supplied
ArgumentNullException | Thrown if transaction is null
ArgumentNullException | Thrown if transaction.Connection is null
See Also

Reference

AdoHelperTFactory Class
ExecuteNonQuery Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).ExecuteNonQuery Method (String, CommandType, String, IDataParameter[])

AdoHelperTFactoryExecuteNonQuery Method (String, CommandType, String, IDataParameter)

Execute an IDbCommand (that returns no resultset) against the database specified in the connection string using the provided parameters

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual int ExecuteNonQuery(
    string connectionString,
    CommandType commandType,
    string commandText,
    params IDataParameter[] commandParameters
)
Public Overridable Function ExecuteNonQuery (
    connectionString As String,
    commandType As CommandType,
    commandText As String,
    ParamArray commandParameters As IDataParameter()
) As Integer

Parameters

connectionString
Type: SystemString
A valid connection string for an IDbConnection
commandType
Type: System.DataCommandType
The CommandType (stored procedure, text, etc.)
commandText
Type: SystemString
The stored procedure name or SQL command
commandParameters
Type: System.DataIDataParameter
An array of IDataParameters used to execute the command

Return Value

Type: Int32
An int representing the number of rows affected by the command
Exceptions
Exception | Condition
ArgumentNullException | Thrown if connectionString is null
InvalidOperationException | Thrown if any of the IDataParameters.ParameterNames are null, or if the parameter count does not match the number of values supplied
ArgumentNullException | Thrown if commandText is null
ArgumentException | Thrown if the parameter count does not match the number of values supplied
See Also

Reference

AdoHelperTFactory Class
ExecuteNonQuery Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).ExecuteNonQueryTypedParams Method

AdoHelperTFactoryExecuteNonQueryTypedParams Method

Overload List
 | Name | Description
Public method | ExecuteNonQueryTypedParams(IDbCommand, DataRow) | Execute a stored procedure via an IDbCommand (that returns no resultset) against the database specified in the connection string using the dataRow column values as the stored procedure's parameters values. This method will assign the parameter values based on row values.
Public method | ExecuteNonQueryTypedParams(IDbConnection, String, DataRow) | Execute a stored procedure via an IDbCommand (that returns no resultset) against the specified IDbConnection using the dataRow column values as the stored procedure's parameters values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on row values.
Public method | ExecuteNonQueryTypedParams(IDbTransaction, String, DataRow) | Execute a stored procedure via an IDbCommand (that returns no resultset) against the specified IDbTransaction using the dataRow column values as the stored procedure's parameters values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on row values.
Public method | ExecuteNonQueryTypedParams(String, String, DataRow) | Execute a stored procedure via an IDbCommand (that returns no resultset) against the database specified in the connection string using the dataRow column values as the stored procedure's parameters values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on row values.
Top
See Also

Reference

AdoHelperTFactory Class
CodeSmith.Engine Namespace


AdoHelper(TFactory).ExecuteNonQueryTypedParams Method (IDbCommand, DataRow)

AdoHelperTFactoryExecuteNonQueryTypedParams Method (IDbCommand, DataRow)

Execute a stored procedure via an IDbCommand (that returns no resultset) against the database specified in the connection string using the dataRow column values as the stored procedure's parameters values. This method will assign the parameter values based on row values.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual int ExecuteNonQueryTypedParams(
    IDbCommand command,
    DataRow dataRow
)
Public Overridable Function ExecuteNonQueryTypedParams (
    command As IDbCommand,
    dataRow As DataRow
) As Integer

Parameters

command
Type: System.DataIDbCommand
The IDbCommand to execute
dataRow
Type: System.DataDataRow
The dataRow used to hold the stored procedure's parameter values.

Return Value

Type: Int32
An int representing the number of rows affected by the command
Exceptions
Exception | Condition
ArgumentNullException | Thrown if command is null.
See Also

Reference

AdoHelperTFactory Class
ExecuteNonQueryTypedParams Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).ExecuteNonQueryTypedParams Method (IDbConnection, String, DataRow)

AdoHelperTFactoryExecuteNonQueryTypedParams Method (IDbConnection, String, DataRow)

Execute a stored procedure via an IDbCommand (that returns no resultset) against the specified IDbConnection using the dataRow column values as the stored procedure's parameters values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on row values.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual int ExecuteNonQueryTypedParams(
    IDbConnection connection,
    string spName,
    DataRow dataRow
)
Public Overridable Function ExecuteNonQueryTypedParams (
    connection As IDbConnection,
    spName As String,
    dataRow As DataRow
) As Integer

Parameters

connection
Type: System.DataIDbConnection
A valid IDbConnection object
spName
Type: SystemString
The name of the stored procedure
dataRow
Type: System.DataDataRow
The dataRow used to hold the stored procedure's parameter values.

Return Value

Type: Int32
An int representing the number of rows affected by the command
Exceptions
Exception | Condition
ArgumentNullException | Thrown if spName is null
ArgumentNullException | Thrown if connection is null
See Also

Reference

AdoHelperTFactory Class
ExecuteNonQueryTypedParams Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).ExecuteNonQueryTypedParams Method (IDbTransaction, String, DataRow)

AdoHelperTFactoryExecuteNonQueryTypedParams Method (IDbTransaction, String, DataRow)

Execute a stored procedure via an IDbCommand (that returns no resultset) against the specified IDbTransaction using the dataRow column values as the stored procedure's parameters values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on row values.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual int ExecuteNonQueryTypedParams(
    IDbTransaction transaction,
    string spName,
    DataRow dataRow
)
Public Overridable Function ExecuteNonQueryTypedParams (
    transaction As IDbTransaction,
    spName As String,
    dataRow As DataRow
) As Integer

Parameters

transaction
Type: System.DataIDbTransaction
A valid IDbTransaction object
spName
Type: SystemString
The name of the stored procedure
dataRow
Type: System.DataDataRow
The dataRow used to hold the stored procedure's parameter values.

Return Value

Type: Int32
An int representing the number of rows affected by the command
Exceptions
Exception | Condition
ArgumentNullException | Thrown if spName is null
ArgumentNullException | Thrown if transaction is null
ArgumentNullException | Thrown if transaction.Connection is null
See Also

Reference

AdoHelperTFactory Class
ExecuteNonQueryTypedParams Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).ExecuteNonQueryTypedParams Method (String, String, DataRow)

AdoHelperTFactoryExecuteNonQueryTypedParams Method (String, String, DataRow)

Execute a stored procedure via an IDbCommand (that returns no resultset) against the database specified in the connection string using the dataRow column values as the stored procedure's parameters values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on row values.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual int ExecuteNonQueryTypedParams(
    string connectionString,
    string spName,
    DataRow dataRow
)
Public Overridable Function ExecuteNonQueryTypedParams (
    connectionString As String,
    spName As String,
    dataRow As DataRow
) As Integer

Parameters

connectionString
Type: SystemString
A valid connection string for an IDbConnection
spName
Type: SystemString
The name of the stored procedure
dataRow
Type: System.DataDataRow
The dataRow used to hold the stored procedure's parameter values.

Return Value

Type: Int32
An int representing the number of rows affected by the command
Exceptions
Exception | Condition
ArgumentNullException | Thrown if connectionString is null
ArgumentNullException | Thrown if spName is null
See Also

Reference

AdoHelperTFactory Class
ExecuteNonQueryTypedParams Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).ExecuteReader Method

AdoHelperTFactoryExecuteReader Method

Overload List
 | Name | Description
Public method | ExecuteReader(IDbCommand) | Execute an IDbCommand (that returns a resultset) against the database specified in the connection String.
Protected method | ExecuteReader(IDbCommand, AdoHelperTFactoryAdoConnectionOwnership) | Execute an IDbCommand (that returns a resultset) against the database specified in the connection String.
 | ExecuteReader(IDbConnection, CommandType, String) | Execute an IDbCommand (that returns a resultset and takes no parameters) against the provided IDbConnection.
 | ExecuteReader(IDbConnection, String, Object) | Execute a stored procedure via an IDbCommand (that returns a resultset) against the specified IDbConnection using the provided parameter values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on parameter order.
 | ExecuteReader(IDbTransaction, CommandType, String) | Execute an IDbCommand (that returns a resultset and takes no parameters) against the provided IDbTransaction.
 | ExecuteReader(IDbTransaction, String, Object) | Execute a stored procedure via an IDbCommand (that returns a resultset) against the specified IDbTransaction using the provided parameter values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on parameter order.
Public method | ExecuteReader(String, CommandType, String) | Execute an IDbCommand (that returns a resultset and takes no parameters) against the database specified in the connection String.
 | ExecuteReader(String, String, Object) | Execute a stored procedure via an IDbCommand (that returns a resultset) against the database specified in the connection string using the provided parameter values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on parameter order.
 | ExecuteReader(IDbConnection, CommandType, String, IDataParameter) | Execute an IDbCommand (that returns a resultset) against the specified IDbConnection using the provided parameters.
 | ExecuteReader(IDbTransaction, CommandType, String, IDataParameter) | Execute an IDbCommand (that returns a resultset) against the specified IDbTransaction using the provided parameters.
Public method | ExecuteReader(String, CommandType, String, IDataParameter) | Execute an IDbCommand (that returns a resultset) against the database specified in the connection string using the provided parameters.
Top
See Also

Reference

AdoHelperTFactory Class
CodeSmith.Engine Namespace


AdoHelper(TFactory).ExecuteReader Method (IDbCommand)

AdoHelperTFactoryExecuteReader Method (IDbCommand)

Execute an IDbCommand (that returns a resultset) against the database specified in the connection String.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual IDataReader ExecuteReader(
    IDbCommand command
)
Public Overridable Function ExecuteReader (
    command As IDbCommand
) As IDataReader

Parameters

command
Type: System.DataIDbCommand
The IDbCommand object to use

Return Value

Type: IDataReader
A IDataReader containing the resultset generated by the command
Exceptions
Exception | Condition
ArgumentNullException | Thrown if command is null.
See Also

Reference

AdoHelperTFactory Class
ExecuteReader Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).ExecuteReader Method (IDbCommand, AdoHelper(TFactory).AdoConnectionOwnership)

AdoHelperTFactoryExecuteReader Method (IDbCommand, AdoHelperTFactoryAdoConnectionOwnership)

Execute an IDbCommand (that returns a resultset) against the database specified in the connection String.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual IDataReader ExecuteReader(
    IDbCommand command,
    AdoHelperTFactoryAdoConnectionOwnership connectionOwnership
)
Protected Overridable Function ExecuteReader (
    command As IDbCommand,
    connectionOwnership As AdoHelperTFactoryAdoConnectionOwnership
) As IDataReader

Parameters

command
Type: System.DataIDbCommand
The IDbCommand object to use
connectionOwnership
Type: CodeSmith.EngineAdoHelperTFactoryAdoConnectionOwnership
Enum indicating whether the connection was created internally or externally.

Return Value

Type: IDataReader
A IDataReader containing the resultset generated by the command
Exceptions
Exception | Condition
ArgumentNullException | Thrown if command is null.
See Also

Reference

AdoHelperTFactory Class
ExecuteReader Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).ExecuteReader Method (IDbConnection, CommandType, String)

AdoHelperTFactoryExecuteReader Method (IDbConnection, CommandType, String)

Execute an IDbCommand (that returns a resultset and takes no parameters) against the provided IDbConnection.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual IDataReader ExecuteReader(
    IDbConnection connection,
    CommandType commandType,
    string commandText
)
Public Overridable Function ExecuteReader (
    connection As IDbConnection,
    commandType As CommandType,
    commandText As String
) As IDataReader

Parameters

connection
Type: System.DataIDbConnection
A valid IDbConnection
commandType
Type: System.DataCommandType
The CommandType (stored procedure, text, etc.)
commandText
Type: SystemString
The stored procedure name or SQL command

Return Value

Type: IDataReader
an IDataReader containing the resultset generated by the command
Exceptions
Exception | Condition
ArgumentNullException | Thrown if commandText is null
Examples
Copy
IDataReader dr = helper.ExecuteReader(conn, CommandType.StoredProcedure, "GetOrders");
See Also

Reference

AdoHelperTFactory Class
ExecuteReader Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).ExecuteReader Method (IDbConnection, String, Object[])

AdoHelperTFactoryExecuteReader Method (IDbConnection, String, Object)

Execute a stored procedure via an IDbCommand (that returns a resultset) against the specified IDbConnection using the provided parameter values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on parameter order.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual IDataReader ExecuteReader(
    IDbConnection connection,
    string spName,
    params Object[] parameterValues
)
Public Overridable Function ExecuteReader (
    connection As IDbConnection,
    spName As String,
    ParamArray parameterValues As Object()
) As IDataReader

Parameters

connection
Type: System.DataIDbConnection
A valid IDbConnection
spName
Type: SystemString
The name of the stored procedure
parameterValues
Type: SystemObject
An array of objects to be assigned as the input values of the stored procedure

Return Value

Type: IDataReader
an IDataReader containing the resultset generated by the command
Exceptions
Exception | Condition
ArgumentNullException | Thrown if spName is null
ArgumentException | Thrown if the parameter count does not match the number of values supplied
ArgumentNullException | Thrown if connection is null
Remarks
This method provides no access to output parameters or the stored procedure's return value parameter.
Examples
Copy
IDataReader dr = helper.ExecuteReader(conn, "GetOrders", 24, 36);
See Also

Reference

AdoHelperTFactory Class
ExecuteReader Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).ExecuteReader Method (IDbTransaction, CommandType, String)

AdoHelperTFactoryExecuteReader Method (IDbTransaction, CommandType, String)

Execute an IDbCommand (that returns a resultset and takes no parameters) against the provided IDbTransaction.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual IDataReader ExecuteReader(
    IDbTransaction transaction,
    CommandType commandType,
    string commandText
)
Public Overridable Function ExecuteReader (
    transaction As IDbTransaction,
    commandType As CommandType,
    commandText As String
) As IDataReader

Parameters

transaction
Type: System.DataIDbTransaction
A valid IDbTransaction
commandType
Type: System.DataCommandType
The CommandType (stored procedure, text, etc.)
commandText
Type: SystemString
The stored procedure name or SQL command

Return Value

Type: IDataReader
A IDataReader containing the resultset generated by the command
Exceptions
Exception | Condition
ArgumentNullException | Thrown if commandText is null
Examples
Copy
IDataReader dr = helper.ExecuteReader(trans, CommandType.StoredProcedure, "GetOrders");
See Also

Reference

AdoHelperTFactory Class
ExecuteReader Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).ExecuteReader Method (IDbTransaction, String, Object[])

AdoHelperTFactoryExecuteReader Method (IDbTransaction, String, Object)

Execute a stored procedure via an IDbCommand (that returns a resultset) against the specified IDbTransaction using the provided parameter values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on parameter order.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual IDataReader ExecuteReader(
    IDbTransaction transaction,
    string spName,
    params Object[] parameterValues
)
Public Overridable Function ExecuteReader (
    transaction As IDbTransaction,
    spName As String,
    ParamArray parameterValues As Object()
) As IDataReader

Parameters

transaction
Type: System.DataIDbTransaction
A valid IDbTransaction
spName
Type: SystemString
The name of the stored procedure
parameterValues
Type: SystemObject
An array of objects to be assigned as the input values of the stored procedure

Return Value

Type: IDataReader
an IDataReader containing the resultset generated by the command
Exceptions
Exception | Condition
ArgumentNullException | Thrown if spName is null
ArgumentException | Thrown if the parameter count does not match the number of values supplied
ArgumentNullException | Thrown if transaction is null
ArgumentNullException | Thrown if transaction.Connection is null
Remarks
This method provides no access to output parameters or the stored procedure's return value parameter.
Examples
Copy
IDataReader dr = helper.ExecuteReader(tran, "GetOrders", 24, 36);
See Also

Reference

AdoHelperTFactory Class
ExecuteReader Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).ExecuteReader Method (String, CommandType, String)

AdoHelperTFactoryExecuteReader Method (String, CommandType, String)

Execute an IDbCommand (that returns a resultset and takes no parameters) against the database specified in the connection String.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual IDataReader ExecuteReader(
    string connectionString,
    CommandType commandType,
    string commandText
)
Public Overridable Function ExecuteReader (
    connectionString As String,
    commandType As CommandType,
    commandText As String
) As IDataReader

Parameters

connectionString
Type: SystemString
A valid connection string for an IDbConnection
commandType
Type: System.DataCommandType
The CommandType (stored procedure, text, etc.)
commandText
Type: SystemString
The stored procedure name or SQL command

Return Value

Type: IDataReader
A IDataReader containing the resultset generated by the command
Exceptions
Exception | Condition
ArgumentNullException | Thrown if connectionString is null
ArgumentNullException | Thrown if commandText is null
See Also

Reference

AdoHelperTFactory Class
ExecuteReader Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).ExecuteReader Method (String, String, Object[])

AdoHelperTFactoryExecuteReader Method (String, String, Object)

Execute a stored procedure via an IDbCommand (that returns a resultset) against the database specified in the connection string using the provided parameter values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on parameter order.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual IDataReader ExecuteReader(
    string connectionString,
    string spName,
    params Object[] parameterValues
)
Public Overridable Function ExecuteReader (
    connectionString As String,
    spName As String,
    ParamArray parameterValues As Object()
) As IDataReader

Parameters

connectionString
Type: SystemString
A valid connection string for an IDbConnection
spName
Type: SystemString
The name of the stored procedure
parameterValues
Type: SystemObject
An array of objects to be assigned as the input values of the stored procedure

Return Value

Type: IDataReader
an IDataReader containing the resultset generated by the command
Exceptions
Exception | Condition
ArgumentNullException | Thrown if connectionString is null
ArgumentNullException | Thrown if spName is null
ArgumentException | Thrown if the parameter count does not match the number of values supplied
Remarks
This method provides no access to output parameters or the stored procedure's return value parameter.
Examples
Copy
IDataReader dr = helper.ExecuteReader(connString, "GetOrders", 24, 36);
See Also

Reference

AdoHelperTFactory Class
ExecuteReader Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).ExecuteReader Method (IDbConnection, CommandType, String, IDataParameter[])

AdoHelperTFactoryExecuteReader Method (IDbConnection, CommandType, String, IDataParameter)

Execute an IDbCommand (that returns a resultset) against the specified IDbConnection using the provided parameters.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual IDataReader ExecuteReader(
    IDbConnection connection,
    CommandType commandType,
    string commandText,
    params IDataParameter[] commandParameters
)
Public Overridable Function ExecuteReader (
    connection As IDbConnection,
    commandType As CommandType,
    commandText As String,
    ParamArray commandParameters As IDataParameter()
) As IDataReader

Parameters

connection
Type: System.DataIDbConnection
A valid IDbConnection
commandType
Type: System.DataCommandType
The CommandType (stored procedure, text, etc.)
commandText
Type: SystemString
The stored procedure name or SQL command
commandParameters
Type: System.DataIDataParameter
An array of IDataParameters used to execute the command

Return Value

Type: IDataReader
an IDataReader containing the resultset generated by the command
Exceptions
Exception | Condition
InvalidOperationException | Thrown if any of the IDataParameters.ParameterNames are null, or if the parameter count does not match the number of values supplied
ArgumentNullException | Thrown if commandText is null
ArgumentException | Thrown if the parameter count does not match the number of values supplied
ArgumentNullException | Thrown if connection is null
Examples
Copy
IDataReader dr = helper.ExecuteReader(conn, CommandType.StoredProcedure, "GetOrders", new IDataParameter("@prodid", 24));
See Also

Reference

AdoHelperTFactory Class
ExecuteReader Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).ExecuteReader Method (IDbTransaction, CommandType, String, IDataParameter[])

AdoHelperTFactoryExecuteReader Method (IDbTransaction, CommandType, String, IDataParameter)

Execute an IDbCommand (that returns a resultset) against the specified IDbTransaction using the provided parameters.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual IDataReader ExecuteReader(
    IDbTransaction transaction,
    CommandType commandType,
    string commandText,
    params IDataParameter[] commandParameters
)
Public Overridable Function ExecuteReader (
    transaction As IDbTransaction,
    commandType As CommandType,
    commandText As String,
    ParamArray commandParameters As IDataParameter()
) As IDataReader

Parameters

transaction
Type: System.DataIDbTransaction
A valid IDbTransaction
commandType
Type: System.DataCommandType
The CommandType (stored procedure, text, etc.)
commandText
Type: SystemString
The stored procedure name or SQL command
commandParameters
Type: System.DataIDataParameter
An array of IDataParameters used to execute the command

Return Value

Type: IDataReader
A IDataReader containing the resultset generated by the command
Examples
Copy
IDataReader dr = helper.ExecuteReader(trans, CommandType.StoredProcedure, "GetOrders", new IDataParameter("@prodid", 24));
See Also

Reference

AdoHelperTFactory Class
ExecuteReader Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).ExecuteReader Method (String, CommandType, String, IDataParameter[])

AdoHelperTFactoryExecuteReader Method (String, CommandType, String, IDataParameter)

Execute an IDbCommand (that returns a resultset) against the database specified in the connection string using the provided parameters.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual IDataReader ExecuteReader(
    string connectionString,
    CommandType commandType,
    string commandText,
    params IDataParameter[] commandParameters
)
Public Overridable Function ExecuteReader (
    connectionString As String,
    commandType As CommandType,
    commandText As String,
    ParamArray commandParameters As IDataParameter()
) As IDataReader

Parameters

connectionString
Type: SystemString
A valid connection string for an IDbConnection
commandType
Type: System.DataCommandType
The CommandType (stored procedure, text, etc.)
commandText
Type: SystemString
The stored procedure name or SQL command
commandParameters
Type: System.DataIDataParameter
An array of IDataParameters used to execute the command

Return Value

Type: IDataReader
A IDataReader containing the resultset generated by the command
Exceptions
Exception | Condition
ArgumentNullException | Thrown if connectionString is null
InvalidOperationException | Thrown if any of the IDataParameters.ParameterNames are null, or if the parameter count does not match the number of values supplied
ArgumentNullException | Thrown if commandText is null
ArgumentException | Thrown if the parameter count does not match the number of values supplied
See Also

Reference

AdoHelperTFactory Class
ExecuteReader Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).ExecuteReaderTypedParams Method

AdoHelperTFactoryExecuteReaderTypedParams Method

Overload List
 | Name | Description
Public method | ExecuteReaderTypedParams(IDbCommand, DataRow) | Execute a stored procedure via an IDbCommand (that returns a resultset) against the database specified in the connection string using the dataRow column values as the stored procedure's parameters values. This method will assign the parameter values based on parameter order.
Public method | ExecuteReaderTypedParams(IDbConnection, String, DataRow) | Execute a stored procedure via an IDbCommand (that returns a resultset) against the specified IDbConnection using the dataRow column values as the stored procedure's parameters values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on parameter order.
Public method | ExecuteReaderTypedParams(IDbTransaction, String, DataRow) | Execute a stored procedure via an IDbCommand (that returns a resultset) against the specified IDbTransaction using the dataRow column values as the stored procedure's parameters values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on parameter order.
Public method | ExecuteReaderTypedParams(String, String, DataRow) | Execute a stored procedure via an IDbCommand (that returns a resultset) against the database specified in the connection string using the dataRow column values as the stored procedure's parameters values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on parameter order.
Top
See Also

Reference

AdoHelperTFactory Class
CodeSmith.Engine Namespace


AdoHelper(TFactory).ExecuteReaderTypedParams Method (IDbCommand, DataRow)

AdoHelperTFactoryExecuteReaderTypedParams Method (IDbCommand, DataRow)

Execute a stored procedure via an IDbCommand (that returns a resultset) against the database specified in the connection string using the dataRow column values as the stored procedure's parameters values. This method will assign the parameter values based on parameter order.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual IDataReader ExecuteReaderTypedParams(
    IDbCommand command,
    DataRow dataRow
)
Public Overridable Function ExecuteReaderTypedParams (
    command As IDbCommand,
    dataRow As DataRow
) As IDataReader

Parameters

command
Type: System.DataIDbCommand
The IDbCommand to execute
dataRow
Type: System.DataDataRow
The dataRow used to hold the stored procedure's parameter values.

Return Value

Type: IDataReader
A IDataReader containing the resultset generated by the command
Exceptions
Exception | Condition
ArgumentNullException | Thrown if command is null.
See Also

Reference

AdoHelperTFactory Class
ExecuteReaderTypedParams Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).ExecuteReaderTypedParams Method (IDbConnection, String, DataRow)

AdoHelperTFactoryExecuteReaderTypedParams Method (IDbConnection, String, DataRow)

Execute a stored procedure via an IDbCommand (that returns a resultset) against the specified IDbConnection using the dataRow column values as the stored procedure's parameters values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on parameter order.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual IDataReader ExecuteReaderTypedParams(
    IDbConnection connection,
    string spName,
    DataRow dataRow
)
Public Overridable Function ExecuteReaderTypedParams (
    connection As IDbConnection,
    spName As String,
    dataRow As DataRow
) As IDataReader

Parameters

connection
Type: System.DataIDbConnection
A valid IDbConnection object
spName
Type: SystemString
The name of the stored procedure
dataRow
Type: System.DataDataRow
The dataRow used to hold the stored procedure's parameter values.

Return Value

Type: IDataReader
A IDataReader containing the resultset generated by the command
Exceptions
Exception | Condition
ArgumentNullException | Thrown if spName is null
ArgumentNullException | Thrown if connection is null
See Also

Reference

AdoHelperTFactory Class
ExecuteReaderTypedParams Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).ExecuteReaderTypedParams Method (IDbTransaction, String, DataRow)

AdoHelperTFactoryExecuteReaderTypedParams Method (IDbTransaction, String, DataRow)

Execute a stored procedure via an IDbCommand (that returns a resultset) against the specified IDbTransaction using the dataRow column values as the stored procedure's parameters values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on parameter order.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual IDataReader ExecuteReaderTypedParams(
    IDbTransaction transaction,
    string spName,
    DataRow dataRow
)
Public Overridable Function ExecuteReaderTypedParams (
    transaction As IDbTransaction,
    spName As String,
    dataRow As DataRow
) As IDataReader

Parameters

transaction
Type: System.DataIDbTransaction
A valid IDbTransaction object
spName
Type: SystemString
The name of the stored procedure
dataRow
Type: System.DataDataRow
The dataRow used to hold the stored procedure's parameter values.

Return Value

Type: IDataReader
A IDataReader containing the resultset generated by the command
Exceptions
Exception | Condition
ArgumentNullException | Thrown if spName is null
ArgumentNullException | Thrown if transaction is null
ArgumentNullException | Thrown if transaction.Connection is null
See Also

Reference

AdoHelperTFactory Class
ExecuteReaderTypedParams Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).ExecuteReaderTypedParams Method (String, String, DataRow)

AdoHelperTFactoryExecuteReaderTypedParams Method (String, String, DataRow)

Execute a stored procedure via an IDbCommand (that returns a resultset) against the database specified in the connection string using the dataRow column values as the stored procedure's parameters values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on parameter order.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual IDataReader ExecuteReaderTypedParams(
    string connectionString,
    string spName,
    DataRow dataRow
)
Public Overridable Function ExecuteReaderTypedParams (
    connectionString As String,
    spName As String,
    dataRow As DataRow
) As IDataReader

Parameters

connectionString
Type: SystemString
A valid connection string for an IDbConnection
spName
Type: SystemString
The name of the stored procedure
dataRow
Type: System.DataDataRow
The dataRow used to hold the stored procedure's parameter values.

Return Value

Type: IDataReader
A IDataReader containing the resultset generated by the command
Exceptions
Exception | Condition
ArgumentNullException | Thrown if connectionString is null
ArgumentNullException | Thrown if spName is null
See Also

Reference

AdoHelperTFactory Class
ExecuteReaderTypedParams Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).ExecuteScalar Method

AdoHelperTFactoryExecuteScalar Method

Overload List
 | Name | Description
Public method | ExecuteScalar(IDbCommand) | Execute an IDbCommand (that returns a 1x1 resultset) against the database specified in the connection String.
 | ExecuteScalar(IDbConnection, CommandType, String) | Execute an IDbCommand (that returns a 1x1 resultset and takes no parameters) against the provided IDbConnection.
 | ExecuteScalar(IDbConnection, String, Object) | Execute a stored procedure via an IDbCommand (that returns a 1x1 resultset) against the specified IDbConnection using the provided parameter values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on parameter order.
 | ExecuteScalar(IDbTransaction, CommandType, String) | Execute an IDbCommand (that returns a 1x1 resultset and takes no parameters) against the provided IDbTransaction.
 | ExecuteScalar(IDbTransaction, String, Object) | Execute a stored procedure via an IDbCommand (that returns a 1x1 resultset) against the specified IDbTransaction using the provided parameter values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on parameter order.
 | ExecuteScalar(String, CommandType, String) | Execute an IDbCommand (that returns a 1x1 resultset and takes no parameters) against the database specified in the connection String.
 | ExecuteScalar(String, String, Object) | Execute a stored procedure via an IDbCommand (that returns a 1x1 resultset) against the database specified in the connection string using the provided parameter values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on parameter order.
Public method | ExecuteScalar(IDbConnection, CommandType, String, IDataParameter) | Execute an IDbCommand (that returns a 1x1 resultset) against the specified IDbConnection using the provided parameters.
Public method | ExecuteScalar(IDbTransaction, CommandType, String, IDataParameter) | Execute an IDbCommand (that returns a 1x1 resultset) against the specified IDbTransaction using the provided parameters.
Public method | ExecuteScalar(String, CommandType, String, IDataParameter) | Execute an IDbCommand (that returns a 1x1 resultset) against the database specified in the connection string using the provided parameters.
Top
See Also

Reference

AdoHelperTFactory Class
CodeSmith.Engine Namespace


AdoHelper(TFactory).ExecuteScalar Method (IDbCommand)

AdoHelperTFactoryExecuteScalar Method (IDbCommand)

Execute an IDbCommand (that returns a 1x1 resultset) against the database specified in the connection String.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual Object ExecuteScalar(
    IDbCommand command
)
Public Overridable Function ExecuteScalar (
    command As IDbCommand
) As Object

Parameters

command
Type: System.DataIDbCommand
The IDbCommand to execute

Return Value

Type: Object
An object containing the value in the 1x1 resultset generated by the command
Exceptions
Exception | Condition
ArgumentNullException | Thrown if command is null.
See Also

Reference

AdoHelperTFactory Class
ExecuteScalar Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).ExecuteScalar Method (IDbConnection, CommandType, String)

AdoHelperTFactoryExecuteScalar Method (IDbConnection, CommandType, String)

Execute an IDbCommand (that returns a 1x1 resultset and takes no parameters) against the provided IDbConnection.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual Object ExecuteScalar(
    IDbConnection connection,
    CommandType commandType,
    string commandText
)
Public Overridable Function ExecuteScalar (
    connection As IDbConnection,
    commandType As CommandType,
    commandText As String
) As Object

Parameters

connection
Type: System.DataIDbConnection
A valid IDbConnection
commandType
Type: System.DataCommandType
The CommandType (stored procedure, text, etc.)
commandText
Type: SystemString
The stored procedure name or SQL command

Return Value

Type: Object
An object containing the value in the 1x1 resultset generated by the command
Exceptions
Exception | Condition
ArgumentNullException | Thrown if commandText is null
Examples
Copy
int orderCount = (int)helper.ExecuteScalar(conn, CommandType.StoredProcedure, "GetOrderCount");
See Also

Reference

AdoHelperTFactory Class
ExecuteScalar Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).ExecuteScalar Method (IDbConnection, String, Object[])

AdoHelperTFactoryExecuteScalar Method (IDbConnection, String, Object)

Execute a stored procedure via an IDbCommand (that returns a 1x1 resultset) against the specified IDbConnection using the provided parameter values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on parameter order.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual Object ExecuteScalar(
    IDbConnection connection,
    string spName,
    params Object[] parameterValues
)
Public Overridable Function ExecuteScalar (
    connection As IDbConnection,
    spName As String,
    ParamArray parameterValues As Object()
) As Object

Parameters

connection
Type: System.DataIDbConnection
A valid IDbConnection
spName
Type: SystemString
The name of the stored procedure
parameterValues
Type: SystemObject
An array of objects to be assigned as the input values of the stored procedure

Return Value

Type: Object
An object containing the value in the 1x1 resultset generated by the command
Exceptions
Exception | Condition
ArgumentNullException | Thrown if spName is null
ArgumentException | Thrown if the parameter count does not match the number of values supplied
ArgumentNullException | Thrown if connection is null
Remarks
This method provides no access to output parameters or the stored procedure's return value parameter.
Examples
Copy
int orderCount = (int)helper.ExecuteScalar(conn, "GetOrderCount", 24, 36);
See Also

Reference

AdoHelperTFactory Class
ExecuteScalar Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).ExecuteScalar Method (IDbTransaction, CommandType, String)

AdoHelperTFactoryExecuteScalar Method (IDbTransaction, CommandType, String)

Execute an IDbCommand (that returns a 1x1 resultset and takes no parameters) against the provided IDbTransaction.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual Object ExecuteScalar(
    IDbTransaction transaction,
    CommandType commandType,
    string commandText
)
Public Overridable Function ExecuteScalar (
    transaction As IDbTransaction,
    commandType As CommandType,
    commandText As String
) As Object

Parameters

transaction
Type: System.DataIDbTransaction
A valid IDbTransaction
commandType
Type: System.DataCommandType
The CommandType (stored procedure, text, etc.)
commandText
Type: SystemString
The stored procedure name or SQL command

Return Value

Type: Object
An object containing the value in the 1x1 resultset generated by the command
Exceptions
Exception | Condition
ArgumentNullException | Thrown if commandText is null
Examples
Copy
int orderCount = (int)helper.ExecuteScalar(tran, CommandType.StoredProcedure, "GetOrderCount");
See Also

Reference

AdoHelperTFactory Class
ExecuteScalar Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).ExecuteScalar Method (IDbTransaction, String, Object[])

AdoHelperTFactoryExecuteScalar Method (IDbTransaction, String, Object)

Execute a stored procedure via an IDbCommand (that returns a 1x1 resultset) against the specified IDbTransaction using the provided parameter values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on parameter order.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual Object ExecuteScalar(
    IDbTransaction transaction,
    string spName,
    params Object[] parameterValues
)
Public Overridable Function ExecuteScalar (
    transaction As IDbTransaction,
    spName As String,
    ParamArray parameterValues As Object()
) As Object

Parameters

transaction
Type: System.DataIDbTransaction
A valid IDbTransaction
spName
Type: SystemString
The name of the stored procedure
parameterValues
Type: SystemObject
An array of objects to be assigned as the input values of the stored procedure

Return Value

Type: Object
An object containing the value in the 1x1 resultset generated by the command
Exceptions
Exception | Condition
InvalidOperationException | Thrown if any of the IDataParameters.ParameterNames are null, or if the parameter count does not match the number of values supplied
ArgumentNullException | Thrown if commandText is null
ArgumentNullException | Thrown if spName is null
ArgumentException | Thrown if the parameter count does not match the number of values supplied
ArgumentNullException | Thrown if transaction is null
ArgumentNullException | Thrown if transaction.Connection is null
ArgumentException | Thrown if the transaction is rolled back or commmitted
Remarks
This method provides no access to output parameters or the stored procedure's return value parameter.
Examples
Copy
int orderCount = (int)helper.ExecuteScalar(tran, "GetOrderCount", 24, 36);
See Also

Reference

AdoHelperTFactory Class
ExecuteScalar Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).ExecuteScalar Method (String, CommandType, String)

AdoHelperTFactoryExecuteScalar Method (String, CommandType, String)

Execute an IDbCommand (that returns a 1x1 resultset and takes no parameters) against the database specified in the connection String.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual Object ExecuteScalar(
    string connectionString,
    CommandType commandType,
    string commandText
)
Public Overridable Function ExecuteScalar (
    connectionString As String,
    commandType As CommandType,
    commandText As String
) As Object

Parameters

connectionString
Type: SystemString
A valid connection string for an IDbConnection
commandType
Type: System.DataCommandType
The CommandType (stored procedure, text, etc.)
commandText
Type: SystemString
The stored procedure name or SQL command

Return Value

Type: Object
An object containing the value in the 1x1 resultset generated by the command
Exceptions
Exception | Condition
ArgumentNullException | Thrown if connectionString is null
ArgumentNullException | Thrown if commandText is null
Examples
Copy
int orderCount = (int)helper.ExecuteScalar(connString, CommandType.StoredProcedure, "GetOrderCount");
See Also

Reference

AdoHelperTFactory Class
ExecuteScalar Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).ExecuteScalar Method (String, String, Object[])

AdoHelperTFactoryExecuteScalar Method (String, String, Object)

Execute a stored procedure via an IDbCommand (that returns a 1x1 resultset) against the database specified in the connection string using the provided parameter values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on parameter order.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual Object ExecuteScalar(
    string connectionString,
    string spName,
    params Object[] parameterValues
)
Public Overridable Function ExecuteScalar (
    connectionString As String,
    spName As String,
    ParamArray parameterValues As Object()
) As Object

Parameters

connectionString
Type: SystemString
A valid connection string for an IDbConnection
spName
Type: SystemString
The name of the stored procedure
parameterValues
Type: SystemObject
An array of objects to be assigned as the input values of the stored procedure

Return Value

Type: Object
An object containing the value in the 1x1 resultset generated by the command
Exceptions
Exception | Condition
ArgumentNullException | Thrown if connectionString is null
ArgumentNullException | Thrown if spName is null
ArgumentException | Thrown if the parameter count does not match the number of values supplied
Remarks
This method provides no access to output parameters or the stored procedure's return value parameter.
Examples
Copy
int orderCount = (int)helper.ExecuteScalar(connString, "GetOrderCount", 24, 36);
See Also

Reference

AdoHelperTFactory Class
ExecuteScalar Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).ExecuteScalar Method (IDbConnection, CommandType, String, IDataParameter[])

AdoHelperTFactoryExecuteScalar Method (IDbConnection, CommandType, String, IDataParameter)

Execute an IDbCommand (that returns a 1x1 resultset) against the specified IDbConnection using the provided parameters.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual Object ExecuteScalar(
    IDbConnection connection,
    CommandType commandType,
    string commandText,
    params IDataParameter[] commandParameters
)
Public Overridable Function ExecuteScalar (
    connection As IDbConnection,
    commandType As CommandType,
    commandText As String,
    ParamArray commandParameters As IDataParameter()
) As Object

Parameters

connection
Type: System.DataIDbConnection
A valid IDbConnection
commandType
Type: System.DataCommandType
The CommandType (stored procedure, text, etc.)
commandText
Type: SystemString
The stored procedure name or SQL command
commandParameters
Type: System.DataIDataParameter
An array of IDataParameters used to execute the command

Return Value

Type: Object
An object containing the value in the 1x1 resultset generated by the command
Exceptions
Exception | Condition
InvalidOperationException | Thrown if any of the IDataParameters.ParameterNames are null, or if the parameter count does not match the number of values supplied
ArgumentNullException | Thrown if commandText is null
ArgumentException | Thrown if the parameter count does not match the number of values supplied
ArgumentNullException | Thrown if connection is null
See Also

Reference

AdoHelperTFactory Class
ExecuteScalar Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).ExecuteScalar Method (IDbTransaction, CommandType, String, IDataParameter[])

AdoHelperTFactoryExecuteScalar Method (IDbTransaction, CommandType, String, IDataParameter)

Execute an IDbCommand (that returns a 1x1 resultset) against the specified IDbTransaction using the provided parameters.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual Object ExecuteScalar(
    IDbTransaction transaction,
    CommandType commandType,
    string commandText,
    params IDataParameter[] commandParameters
)
Public Overridable Function ExecuteScalar (
    transaction As IDbTransaction,
    commandType As CommandType,
    commandText As String,
    ParamArray commandParameters As IDataParameter()
) As Object

Parameters

transaction
Type: System.DataIDbTransaction
A valid IDbTransaction
commandType
Type: System.DataCommandType
The CommandType (stored procedure, text, etc.)
commandText
Type: SystemString
The stored procedure name or SQL command
commandParameters
Type: System.DataIDataParameter
An array of IDbParamters used to execute the command

Return Value

Type: Object
An object containing the value in the 1x1 resultset generated by the command
Exceptions
Exception | Condition
InvalidOperationException | Thrown if any of the IDataParameters.ParameterNames are null, or if the parameter count does not match the number of values supplied
ArgumentNullException | Thrown if commandText is null
ArgumentException | Thrown if the parameter count does not match the number of values supplied
ArgumentNullException | Thrown if transaction is null
ArgumentNullException | Thrown if transaction.Connection is null
See Also

Reference

AdoHelperTFactory Class
ExecuteScalar Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).ExecuteScalar Method (String, CommandType, String, IDataParameter[])

AdoHelperTFactoryExecuteScalar Method (String, CommandType, String, IDataParameter)

Execute an IDbCommand (that returns a 1x1 resultset) against the database specified in the connection string using the provided parameters.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual Object ExecuteScalar(
    string connectionString,
    CommandType commandType,
    string commandText,
    params IDataParameter[] commandParameters
)
Public Overridable Function ExecuteScalar (
    connectionString As String,
    commandType As CommandType,
    commandText As String,
    ParamArray commandParameters As IDataParameter()
) As Object

Parameters

connectionString
Type: SystemString
A valid connection string for an IDbConnection
commandType
Type: System.DataCommandType
The CommandType (stored procedure, text, etc.)
commandText
Type: SystemString
The stored procedure name or SQL command
commandParameters
Type: System.DataIDataParameter
An array of IDataParameters used to execute the command

Return Value

Type: Object
An object containing the value in the 1x1 resultset generated by the command
Exceptions
Exception | Condition
ArgumentNullException | Thrown if connectionString is null
InvalidOperationException | Thrown if any of the IDataParameters.ParameterNames are null, or if the parameter count does not match the number of values supplied
ArgumentNullException | Thrown if commandText is null
ArgumentException | Thrown if the parameter count does not match the number of values supplied
See Also

Reference

AdoHelperTFactory Class
ExecuteScalar Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).ExecuteScalarTypedParams Method

AdoHelperTFactoryExecuteScalarTypedParams Method

Overload List
 | Name | Description
Public method | ExecuteScalarTypedParams(IDbCommand, DataRow) | Execute a stored procedure via an IDbCommand (that returns a 1x1 resultset) against the database specified in the connection string using the dataRow column values as the stored procedure's parameters values. This method will assign the parameter values based on parameter order.
Public method | ExecuteScalarTypedParams(IDbConnection, String, DataRow) | Execute a stored procedure via an IDbCommand (that returns a 1x1 resultset) against the specified IDbConnection using the dataRow column values as the stored procedure's parameters values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on parameter order.
Public method | ExecuteScalarTypedParams(IDbTransaction, String, DataRow) | Execute a stored procedure via an IDbCommand (that returns a 1x1 resultset) against the specified IDbTransaction using the dataRow column values as the stored procedure's parameters values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on parameter order.
Public method | ExecuteScalarTypedParams(String, String, DataRow) | Execute a stored procedure via an IDbCommand (that returns a 1x1 resultset) against the database specified in the connection string using the dataRow column values as the stored procedure's parameters values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on parameter order.
Top
See Also

Reference

AdoHelperTFactory Class
CodeSmith.Engine Namespace


AdoHelper(TFactory).ExecuteScalarTypedParams Method (IDbCommand, DataRow)

AdoHelperTFactoryExecuteScalarTypedParams Method (IDbCommand, DataRow)

Execute a stored procedure via an IDbCommand (that returns a 1x1 resultset) against the database specified in the connection string using the dataRow column values as the stored procedure's parameters values. This method will assign the parameter values based on parameter order.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual Object ExecuteScalarTypedParams(
    IDbCommand command,
    DataRow dataRow
)
Public Overridable Function ExecuteScalarTypedParams (
    command As IDbCommand,
    dataRow As DataRow
) As Object

Parameters

command
Type: System.DataIDbCommand
The IDbCommand to execute
dataRow
Type: System.DataDataRow
The dataRow used to hold the stored procedure's parameter values.

Return Value

Type: Object
An object containing the value in the 1x1 resultset generated by the command
Exceptions
Exception | Condition
ArgumentNullException | Thrown if command is null.
See Also

Reference

AdoHelperTFactory Class
ExecuteScalarTypedParams Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).ExecuteScalarTypedParams Method (IDbConnection, String, DataRow)

AdoHelperTFactoryExecuteScalarTypedParams Method (IDbConnection, String, DataRow)

Execute a stored procedure via an IDbCommand (that returns a 1x1 resultset) against the specified IDbConnection using the dataRow column values as the stored procedure's parameters values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on parameter order.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual Object ExecuteScalarTypedParams(
    IDbConnection connection,
    string spName,
    DataRow dataRow
)
Public Overridable Function ExecuteScalarTypedParams (
    connection As IDbConnection,
    spName As String,
    dataRow As DataRow
) As Object

Parameters

connection
Type: System.DataIDbConnection
A valid IDbConnection object
spName
Type: SystemString
The name of the stored procedure
dataRow
Type: System.DataDataRow
The dataRow used to hold the stored procedure's parameter values.

Return Value

Type: Object
An object containing the value in the 1x1 resultset generated by the command
Exceptions
Exception | Condition
ArgumentNullException | Thrown if spName is null
ArgumentNullException | Thrown if connection is null
See Also

Reference

AdoHelperTFactory Class
ExecuteScalarTypedParams Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).ExecuteScalarTypedParams Method (IDbTransaction, String, DataRow)

AdoHelperTFactoryExecuteScalarTypedParams Method (IDbTransaction, String, DataRow)

Execute a stored procedure via an IDbCommand (that returns a 1x1 resultset) against the specified IDbTransaction using the dataRow column values as the stored procedure's parameters values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on parameter order.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual Object ExecuteScalarTypedParams(
    IDbTransaction transaction,
    string spName,
    DataRow dataRow
)
Public Overridable Function ExecuteScalarTypedParams (
    transaction As IDbTransaction,
    spName As String,
    dataRow As DataRow
) As Object

Parameters

transaction
Type: System.DataIDbTransaction
A valid IDbTransaction object
spName
Type: SystemString
The name of the stored procedure
dataRow
Type: System.DataDataRow
The dataRow used to hold the stored procedure's parameter values.

Return Value

Type: Object
An object containing the value in the 1x1 resultset generated by the command
Exceptions
Exception | Condition
ArgumentNullException | Thrown if spName is null
ArgumentNullException | Thrown if transaction is null
ArgumentNullException | Thrown if transaction.Connection is null
See Also

Reference

AdoHelperTFactory Class
ExecuteScalarTypedParams Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).ExecuteScalarTypedParams Method (String, String, DataRow)

AdoHelperTFactoryExecuteScalarTypedParams Method (String, String, DataRow)

Execute a stored procedure via an IDbCommand (that returns a 1x1 resultset) against the database specified in the connection string using the dataRow column values as the stored procedure's parameters values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on parameter order.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual Object ExecuteScalarTypedParams(
    string connectionString,
    string spName,
    DataRow dataRow
)
Public Overridable Function ExecuteScalarTypedParams (
    connectionString As String,
    spName As String,
    dataRow As DataRow
) As Object

Parameters

connectionString
Type: SystemString
A valid connection string for an IDbConnection
spName
Type: SystemString
The name of the stored procedure
dataRow
Type: System.DataDataRow
The dataRow used to hold the stored procedure's parameter values.

Return Value

Type: Object
An object containing the value in the 1x1 resultset generated by the command
Exceptions
Exception | Condition
ArgumentNullException | Thrown if connectionString is null
ArgumentNullException | Thrown if spName is null
See Also

Reference

AdoHelperTFactory Class
ExecuteScalarTypedParams Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).FillDataset Method

AdoHelperTFactoryFillDataset Method

Overload List
 | Name | Description
Public method | FillDataset(IDbCommand, DataSet, String) | Execute an IDbCommand (that returns a resultset) against the database specified in the connection String.
 | FillDataset(IDbConnection, CommandType, String, DataSet, String) | Execute an IDbCommand (that returns a resultset and takes no parameters) against the provided IDbConnection.
 | FillDataset(IDbConnection, String, DataSet, String, Object) | Execute a stored procedure via an IDbCommand (that returns a resultset) against the specified IDbConnection using the provided parameter values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on parameter order.
 | FillDataset(IDbTransaction, CommandType, String, DataSet, String) | Execute an IDbCommand (that returns a resultset and takes no parameters) against the provided IDbTransaction.
 | FillDataset(IDbTransaction, String, DataSet, String, Object) | Execute a stored procedure via an IDbCommand (that returns a resultset) against the specified IDbTransaction using the provided parameter values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on parameter order.
 | FillDataset(String, CommandType, String, DataSet, String) | Execute an IDbCommand (that returns a resultset and takes no parameters) against the database specified in the connection String.
 | FillDataset(String, String, DataSet, String, Object) | Execute a stored procedure via an IDbCommand (that returns a resultset) against the database specified in the connection string using the provided parameter values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on parameter order.
Public method | FillDataset(IDbConnection, CommandType, String, DataSet, String, IDataParameter) | Execute an IDbCommand (that returns a resultset) against the specified IDbConnection using the provided parameters.
Public method | FillDataset(IDbTransaction, CommandType, String, DataSet, String, IDataParameter) | Execute an IDbCommand (that returns a resultset) against the specified IDbTransaction using the provided parameters.
Public method | FillDataset(String, CommandType, String, DataSet, String, IDataParameter) | Execute an IDbCommand (that returns a resultset) against the database specified in the connection string using the provided parameters.
Top
See Also

Reference

AdoHelperTFactory Class
CodeSmith.Engine Namespace


AdoHelper(TFactory).FillDataset Method (IDbCommand, DataSet, String[])

AdoHelperTFactoryFillDataset Method (IDbCommand, DataSet, String)

Execute an IDbCommand (that returns a resultset) against the database specified in the connection String.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual void FillDataset(
    IDbCommand command,
    DataSet dataSet,
    string[] tableNames
)
Public Overridable Sub FillDataset (
    command As IDbCommand,
    dataSet As DataSet,
    tableNames As String()
)

Parameters

command
Type: System.DataIDbCommand
The IDbCommand to execute
dataSet
Type: System.DataDataSet
A DataSet wich will contain the resultset generated by the command
tableNames
Type: SystemString
This array will be used to create table mappings allowing the DataTables to be referenced by a user defined name (probably the actual table name)
Exceptions
Exception | Condition
ArgumentNullException | Thrown if command is null.
See Also

Reference

AdoHelperTFactory Class
FillDataset Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).FillDataset Method (IDbConnection, CommandType, String, DataSet, String[])

AdoHelperTFactoryFillDataset Method (IDbConnection, CommandType, String, DataSet, String)

Execute an IDbCommand (that returns a resultset and takes no parameters) against the provided IDbConnection.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual void FillDataset(
    IDbConnection connection,
    CommandType commandType,
    string commandText,
    DataSet dataSet,
    string[] tableNames
)
Public Overridable Sub FillDataset (
    connection As IDbConnection,
    commandType As CommandType,
    commandText As String,
    dataSet As DataSet,
    tableNames As String()
)

Parameters

connection
Type: System.DataIDbConnection
A valid IDbConnection
commandType
Type: System.DataCommandType
The CommandType (stored procedure, text, etc.)
commandText
Type: SystemString
The stored procedure name or SQL command
dataSet
Type: System.DataDataSet
A dataset wich will contain the resultset generated by the command
tableNames
Type: SystemString
This array will be used to create table mappings allowing the DataTables to be referenced by a user defined name (probably the actual table name)
Exceptions
Exception | Condition
ArgumentNullException | Thrown if commandText is null
ArgumentNullException | Thrown if connection is null
Examples
Copy
helper.FillDataset(conn, CommandType.StoredProcedure, "GetOrders", ds, new string[] {"orders"});
See Also

Reference

AdoHelperTFactory Class
FillDataset Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).FillDataset Method (IDbConnection, String, DataSet, String[], Object[])

AdoHelperTFactoryFillDataset Method (IDbConnection, String, DataSet, String, Object)

Execute a stored procedure via an IDbCommand (that returns a resultset) against the specified IDbConnection using the provided parameter values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on parameter order.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual void FillDataset(
    IDbConnection connection,
    string spName,
    DataSet dataSet,
    string[] tableNames,
    params Object[] parameterValues
)
Public Overridable Sub FillDataset (
    connection As IDbConnection,
    spName As String,
    dataSet As DataSet,
    tableNames As String(),
    ParamArray parameterValues As Object()
)

Parameters

connection
Type: System.DataIDbConnection
A valid IDbConnection
spName
Type: SystemString
The name of the stored procedure
dataSet
Type: System.DataDataSet
A dataset wich will contain the resultset generated by the command
tableNames
Type: SystemString
This array will be used to create table mappings allowing the DataTables to be referenced by a user defined name (probably the actual table name)
parameterValues
Type: SystemObject
An array of objects to be assigned as the input values of the stored procedure
Exceptions
Exception | Condition
ArgumentNullException | Thrown if spName is null
ArgumentNullException | Thrown if connection is null
Remarks
This method provides no access to output parameters or the stored procedure's return value parameter.
Examples
Copy
helper.FillDataset(conn, "GetOrders", ds, new string[] {"orders"}, 24, 36);
See Also

Reference

AdoHelperTFactory Class
FillDataset Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).FillDataset Method (IDbTransaction, CommandType, String, DataSet, String[])

AdoHelperTFactoryFillDataset Method (IDbTransaction, CommandType, String, DataSet, String)

Execute an IDbCommand (that returns a resultset and takes no parameters) against the provided IDbTransaction.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual void FillDataset(
    IDbTransaction transaction,
    CommandType commandType,
    string commandText,
    DataSet dataSet,
    string[] tableNames
)
Public Overridable Sub FillDataset (
    transaction As IDbTransaction,
    commandType As CommandType,
    commandText As String,
    dataSet As DataSet,
    tableNames As String()
)

Parameters

transaction
Type: System.DataIDbTransaction
A valid IDbTransaction
commandType
Type: System.DataCommandType
The CommandType (stored procedure, text, etc.)
commandText
Type: SystemString
The stored procedure name or SQL command
dataSet
Type: System.DataDataSet
A dataset wich will contain the resultset generated by the command
tableNames
Type: SystemString
This array will be used to create table mappings allowing the DataTables to be referenced by a user defined name (probably the actual table name)
Exceptions
Exception | Condition
ArgumentNullException | Thrown if commandText is null
ArgumentNullException | Thrown if transaction is null
ArgumentNullException | Thrown if transaction.Connection is null
Examples
Copy
helper.FillDataset(tran, CommandType.StoredProcedure, "GetOrders", ds, new string[] {"orders"});
See Also

Reference

AdoHelperTFactory Class
FillDataset Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).FillDataset Method (IDbTransaction, String, DataSet, String[], Object[])

AdoHelperTFactoryFillDataset Method (IDbTransaction, String, DataSet, String, Object)

Execute a stored procedure via an IDbCommand (that returns a resultset) against the specified IDbTransaction using the provided parameter values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on parameter order.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual void FillDataset(
    IDbTransaction transaction,
    string spName,
    DataSet dataSet,
    string[] tableNames,
    params Object[] parameterValues
)
Public Overridable Sub FillDataset (
    transaction As IDbTransaction,
    spName As String,
    dataSet As DataSet,
    tableNames As String(),
    ParamArray parameterValues As Object()
)

Parameters

transaction
Type: System.DataIDbTransaction
A valid IDbTransaction
spName
Type: SystemString
The name of the stored procedure
dataSet
Type: System.DataDataSet
A dataset wich will contain the resultset generated by the command
tableNames
Type: SystemString
This array will be used to create table mappings allowing the DataTables to be referenced by a user defined name (probably the actual table name)
parameterValues
Type: SystemObject
An array of objects to be assigned as the input values of the stored procedure
Exceptions
Exception | Condition
ArgumentNullException | Thrown if spName is null
ArgumentNullException | Thrown if transaction is null
ArgumentNullException | Thrown if transaction.Connection is null
Remarks
This method provides no access to output parameters or the stored procedure's return value parameter.
Examples
Copy
helper.FillDataset(tran, "GetOrders", ds, new string[] {"orders"}, 24, 36);
See Also

Reference

AdoHelperTFactory Class
FillDataset Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).FillDataset Method (String, CommandType, String, DataSet, String[])

AdoHelperTFactoryFillDataset Method (String, CommandType, String, DataSet, String)

Execute an IDbCommand (that returns a resultset and takes no parameters) against the database specified in the connection String.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual void FillDataset(
    string connectionString,
    CommandType commandType,
    string commandText,
    DataSet dataSet,
    string[] tableNames
)
Public Overridable Sub FillDataset (
    connectionString As String,
    commandType As CommandType,
    commandText As String,
    dataSet As DataSet,
    tableNames As String()
)

Parameters

connectionString
Type: SystemString
A valid connection string for an IDbConnection
commandType
Type: System.DataCommandType
The CommandType (stored procedure, text, etc.)
commandText
Type: SystemString
The stored procedure name or SQL command
dataSet
Type: System.DataDataSet
A DataSet wich will contain the resultset generated by the command
tableNames
Type: SystemString
This array will be used to create table mappings allowing the DataTables to be referenced by a user defined name (probably the actual table name)
Exceptions
Exception | Condition
ArgumentNullException | Thrown if connectionString is null
ArgumentNullException | Thrown if commandText is null
Examples
Copy
helper.FillDataset(connString, CommandType.StoredProcedure, "GetOrders", ds, new string[] {"orders"});
See Also

Reference

AdoHelperTFactory Class
FillDataset Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).FillDataset Method (String, String, DataSet, String[], Object[])

AdoHelperTFactoryFillDataset Method (String, String, DataSet, String, Object)

Execute a stored procedure via an IDbCommand (that returns a resultset) against the database specified in the connection string using the provided parameter values. This method will query the database to discover the parameters for the stored procedure (the first time each stored procedure is called), and assign the values based on parameter order.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual void FillDataset(
    string connectionString,
    string spName,
    DataSet dataSet,
    string[] tableNames,
    params Object[] parameterValues
)
Public Overridable Sub FillDataset (
    connectionString As String,
    spName As String,
    dataSet As DataSet,
    tableNames As String(),
    ParamArray parameterValues As Object()
)

Parameters

connectionString
Type: SystemString
A valid connection string for an IDbConnection
spName
Type: SystemString
The name of the stored procedure
dataSet
Type: System.DataDataSet
A dataset wich will contain the resultset generated by the command
tableNames
Type: SystemString
This array will be used to create table mappings allowing the DataTables to be referenced by a user defined name (probably the actual table name)
parameterValues
Type: SystemObject
An array of objects to be assigned as the input values of the stored procedure
Exceptions
Exception | Condition
ArgumentNullException | Thrown if connectionString is null
ArgumentNullException | Thrown if spName is null
ArgumentException | Thrown if the parameter count does not match the number of values supplied
Remarks
This method provides no access to output parameters or the stored procedure's return value parameter.
Examples
Copy
helper.FillDataset(connString, CommandType.StoredProcedure, "GetOrders", ds, new string[] {"orders"}, 24);
See Also

Reference

AdoHelperTFactory Class
FillDataset Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).FillDataset Method (IDbConnection, CommandType, String, DataSet, String[], IDataParameter[])

AdoHelperTFactoryFillDataset Method (IDbConnection, CommandType, String, DataSet, String, IDataParameter)

Execute an IDbCommand (that returns a resultset) against the specified IDbConnection using the provided parameters.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual void FillDataset(
    IDbConnection connection,
    CommandType commandType,
    string commandText,
    DataSet dataSet,
    string[] tableNames,
    params IDataParameter[] commandParameters
)
Public Overridable Sub FillDataset (
    connection As IDbConnection,
    commandType As CommandType,
    commandText As String,
    dataSet As DataSet,
    tableNames As String(),
    ParamArray commandParameters As IDataParameter()
)

Parameters

connection
Type: System.DataIDbConnection
A valid IDbConnection
commandType
Type: System.DataCommandType
The CommandType (stored procedure, text, etc.)
commandText
Type: SystemString
The stored procedure name or SQL command
dataSet
Type: System.DataDataSet
A DataSet wich will contain the resultset generated by the command
tableNames
Type: SystemString
This array will be used to create table mappings allowing the DataTables to be referenced by a user defined name (probably the actual table name)
commandParameters
Type: System.DataIDataParameter
An array of IDataParameters used to execute the command
Exceptions
Exception | Condition
ArgumentNullException | Thrown if commandText is null
ArgumentNullException | Thrown if connection is null
See Also

Reference

AdoHelperTFactory Class
FillDataset Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).FillDataset Method (IDbTransaction, CommandType, String, DataSet, String[], IDataParameter[])

AdoHelperTFactoryFillDataset Method (IDbTransaction, CommandType, String, DataSet, String, IDataParameter)

Execute an IDbCommand (that returns a resultset) against the specified IDbTransaction using the provided parameters.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual void FillDataset(
    IDbTransaction transaction,
    CommandType commandType,
    string commandText,
    DataSet dataSet,
    string[] tableNames,
    params IDataParameter[] commandParameters
)
Public Overridable Sub FillDataset (
    transaction As IDbTransaction,
    commandType As CommandType,
    commandText As String,
    dataSet As DataSet,
    tableNames As String(),
    ParamArray commandParameters As IDataParameter()
)

Parameters

transaction
Type: System.DataIDbTransaction
A valid IDbTransaction
commandType
Type: System.DataCommandType
The CommandType (stored procedure, text, etc.)
commandText
Type: SystemString
The stored procedure name or SQL command
dataSet
Type: System.DataDataSet
A DataSet wich will contain the resultset generated by the command
tableNames
Type: SystemString
This array will be used to create table mappings allowing the DataTables to be referenced by a user defined name (probably the actual table name)
commandParameters
Type: System.DataIDataParameter
An array of IDataParameters used to execute the command
Exceptions
Exception | Condition
ArgumentNullException | Thrown if commandText is null
ArgumentNullException | Thrown if transaction is null
ArgumentNullException | Thrown if transaction.Connection is null
See Also

Reference

AdoHelperTFactory Class
FillDataset Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).FillDataset Method (String, CommandType, String, DataSet, String[], IDataParameter[])

AdoHelperTFactoryFillDataset Method (String, CommandType, String, DataSet, String, IDataParameter)

Execute an IDbCommand (that returns a resultset) against the database specified in the connection string using the provided parameters.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual void FillDataset(
    string connectionString,
    CommandType commandType,
    string commandText,
    DataSet dataSet,
    string[] tableNames,
    params IDataParameter[] commandParameters
)
Public Overridable Sub FillDataset (
    connectionString As String,
    commandType As CommandType,
    commandText As String,
    dataSet As DataSet,
    tableNames As String(),
    ParamArray commandParameters As IDataParameter()
)

Parameters

connectionString
Type: SystemString
A valid connection string for an IDbConnection
commandType
Type: System.DataCommandType
The CommandType (stored procedure, text, etc.)
commandText
Type: SystemString
The stored procedure name or SQL command
dataSet
Type: System.DataDataSet
A DataSet wich will contain the resultset generated by the command
tableNames
Type: SystemString
This array will be used to create table mappings allowing the DataTables to be referenced by a user defined name (probably the actual table name)
commandParameters
Type: System.DataIDataParameter
An array of IDataParameters used to execute the command
Exceptions
Exception | Condition
ArgumentNullException | Thrown if connectionString is null
InvalidOperationException | Thrown if any of the IDataParameters.ParameterNames are null, or if the parameter count does not match the number of values supplied
ArgumentNullException | Thrown if commandText is null
ArgumentException | Thrown if the parameter count does not match the number of values supplied
See Also

Reference

AdoHelperTFactory Class
FillDataset Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).GetBlobParameter Method

AdoHelperTFactoryGetBlobParameter Method

Handle any provider-specific issues with BLOBs here by "washing" the IDataParameter and returning a new one that is set up appropriately for the provider.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual IDataParameter GetBlobParameter(
    IDbConnection connection,
    IDataParameter p
)
Protected Overridable Function GetBlobParameter (
    connection As IDbConnection,
    p As IDataParameter
) As IDataParameter

Parameters

connection
Type: System.DataIDbConnection
The IDbConnection to use in cleansing the parameter
p
Type: System.DataIDataParameter
The parameter before cleansing

Return Value

Type: IDataParameter
The parameter after it's been cleansed.
See Also

Reference

AdoHelperTFactory Class
CodeSmith.Engine Namespace


AdoHelper(TFactory).GetCachedParameterSet Method

AdoHelperTFactoryGetCachedParameterSet Method

Overload List
 | Name | Description
Public method | GetCachedParameterSet(IDbConnection, String) | Retrieve a parameter array from the cache
Public method | GetCachedParameterSet(String, String) | Retrieve a parameter array from the cache
Top
See Also

Reference

AdoHelperTFactory Class
CodeSmith.Engine Namespace


AdoHelper(TFactory).GetCachedParameterSet Method (IDbConnection, String)

AdoHelperTFactoryGetCachedParameterSet Method (IDbConnection, String)

Retrieve a parameter array from the cache

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public IDataParameter[] GetCachedParameterSet(
    IDbConnection connection,
    string commandText
)
Public Function GetCachedParameterSet (
    connection As IDbConnection,
    commandText As String
) As IDataParameter()

Parameters

connection
Type: System.DataIDbConnection
A valid IDbConnection object
commandText
Type: SystemString
The stored procedure name or SQL command

Return Value

Type: IDataParameter
An array of IDataParameters
Exceptions
Exception | Condition
ArgumentNullException | Thrown if commandText is null
ArgumentNullException | Thrown if connection is null
See Also

Reference

AdoHelperTFactory Class
GetCachedParameterSet Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).GetCachedParameterSet Method (String, String)

AdoHelperTFactoryGetCachedParameterSet Method (String, String)

Retrieve a parameter array from the cache

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public IDataParameter[] GetCachedParameterSet(
    string connectionString,
    string commandText
)
Public Function GetCachedParameterSet (
    connectionString As String,
    commandText As String
) As IDataParameter()

Parameters

connectionString
Type: SystemString
A valid connection string for an IDbConnection
commandText
Type: SystemString
The stored procedure name or SQL command

Return Value

Type: IDataParameter
An array of IDataParameters
Exceptions
Exception | Condition
ArgumentNullException | Thrown if connectionString is null
ArgumentNullException | Thrown if commandText is null
See Also

Reference

AdoHelperTFactory Class
GetCachedParameterSet Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).GetConnection Method

AdoHelperTFactoryGetConnection Method

Returns an IDbConnection object for the given connection string

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual IDbConnection GetConnection(
    string connectionString
)
Public Overridable Function GetConnection (
    connectionString As String
) As IDbConnection

Parameters

connectionString
Type: SystemString
The connection string to be used to create the connection

Return Value

Type: IDbConnection
An IDbConnection object
Exceptions
Exception | Condition
ArgumentNullException | Thrown if connectionString is null
See Also

Reference

AdoHelperTFactory Class
CodeSmith.Engine Namespace


AdoHelper(TFactory).GetDataAdapter Method

AdoHelperTFactoryGetDataAdapter Method

Returns an IDbDataAdapter object

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual IDbDataAdapter GetDataAdapter()
Public Overridable Function GetDataAdapter As IDbDataAdapter

Return Value

Type: IDbDataAdapter
The IDbDataAdapter
See Also

Reference

AdoHelperTFactory Class
CodeSmith.Engine Namespace


AdoHelper(TFactory).GetDataParameters Method

AdoHelperTFactoryGetDataParameters Method

Returns an array of IDataParameters of the specified size

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual IDataParameter[] GetDataParameters(
    int size
)
Protected Overridable Function GetDataParameters (
    size As Integer
) As IDataParameter()

Parameters

size
Type: SystemInt32
size of the array

Return Value

Type: IDataParameter
The array of IDataParameters
See Also

Reference

AdoHelperTFactory Class
CodeSmith.Engine Namespace


AdoHelper(TFactory).GetParameter Method

AdoHelperTFactoryGetParameter Method

Overload List
 | Name | Description
Public method | GetParameter | Returns an IDataParameter object
Public method | GetParameter(String, Object) | Get an IDataParameter for use in a SQL command
Public method | GetParameter(String, DbType, Int32, ParameterDirection) | Get an IDataParameter for use in a SQL command
Public method | GetParameter(String, DbType, Int32, String, DataRowVersion) | Get an IDataParameter for use in a SQL command
Top
See Also

Reference

AdoHelperTFactory Class
CodeSmith.Engine Namespace


AdoHelper(TFactory).GetParameter Method

AdoHelperTFactoryGetParameter Method

Returns an IDataParameter object

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual IDataParameter GetParameter()
Public Overridable Function GetParameter As IDataParameter

Return Value

Type: IDataParameter
The IDataParameter object
See Also

Reference

AdoHelperTFactory Class
GetParameter Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).GetParameter Method (String, Object)

AdoHelperTFactoryGetParameter Method (String, Object)

Get an IDataParameter for use in a SQL command

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual IDataParameter GetParameter(
    string name,
    Object value
)
Public Overridable Function GetParameter (
    name As String,
    value As Object
) As IDataParameter

Parameters

name
Type: SystemString
The name of the parameter to create
value
Type: SystemObject
The value of the specified parameter

Return Value

Type: IDataParameter
An IDataParameter object
See Also

Reference

AdoHelperTFactory Class
GetParameter Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).GetParameter Method (String, DbType, Int32, ParameterDirection)

AdoHelperTFactoryGetParameter Method (String, DbType, Int32, ParameterDirection)

Get an IDataParameter for use in a SQL command

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual IDataParameter GetParameter(
    string name,
    DbType dbType,
    int size,
    ParameterDirection direction
)
Public Overridable Function GetParameter (
    name As String,
    dbType As DbType,
    size As Integer,
    direction As ParameterDirection
) As IDataParameter

Parameters

name
Type: SystemString
The name of the parameter to create
dbType
Type: System.DataDbType
The System.Data.DbType of the parameter
size
Type: SystemInt32
The size of the parameter
direction
Type: System.DataParameterDirection
The System.Data.ParameterDirection of the parameter

Return Value

Type: IDataParameter
An IDataParameter object
See Also

Reference

AdoHelperTFactory Class
GetParameter Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).GetParameter Method (String, DbType, Int32, String, DataRowVersion)

AdoHelperTFactoryGetParameter Method (String, DbType, Int32, String, DataRowVersion)

Get an IDataParameter for use in a SQL command

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual IDataParameter GetParameter(
    string name,
    DbType dbType,
    int size,
    string sourceColumn,
    DataRowVersion sourceVersion
)
Public Overridable Function GetParameter (
    name As String,
    dbType As DbType,
    size As Integer,
    sourceColumn As String,
    sourceVersion As DataRowVersion
) As IDataParameter

Parameters

name
Type: SystemString
The name of the parameter to create
dbType
Type: System.DataDbType
The System.Data.DbType of the parameter
size
Type: SystemInt32
The size of the parameter
sourceColumn
Type: SystemString
The source column of the parameter
sourceVersion
Type: System.DataDataRowVersion
The System.Data.DataRowVersion of the parameter

Return Value

Type: IDataParameter
An IDataParameter object
See Also

Reference

AdoHelperTFactory Class
GetParameter Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).GetSpParameterSet Method

AdoHelperTFactoryGetSpParameterSet Method

Overload List
 | Name | Description
Public method | GetSpParameterSet(IDbConnection, String) | Retrieves the set of IDataParameters appropriate for the stored procedure
Public method | GetSpParameterSet(String, String) | Retrieves the set of IDataParameters appropriate for the stored procedure
Public method | GetSpParameterSet(IDbConnection, String, Boolean) | Retrieves the set of IDataParameters appropriate for the stored procedure
Public method | GetSpParameterSet(String, String, Boolean) | Retrieves the set of IDataParameters appropriate for the stored procedure
Top
See Also

Reference

AdoHelperTFactory Class
CodeSmith.Engine Namespace


AdoHelper(TFactory).GetSpParameterSet Method (IDbConnection, String)

AdoHelperTFactoryGetSpParameterSet Method (IDbConnection, String)

Retrieves the set of IDataParameters appropriate for the stored procedure

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual IDataParameter[] GetSpParameterSet(
    IDbConnection connection,
    string spName
)
Public Overridable Function GetSpParameterSet (
    connection As IDbConnection,
    spName As String
) As IDataParameter()

Parameters

connection
Type: System.DataIDbConnection
A valid IDataConnection object
spName
Type: SystemString
The name of the stored procedure

Return Value

Type: IDataParameter
An array of IDataParameters
Exceptions
Exception | Condition
ArgumentNullException | Thrown if spName is null
ArgumentNullException | Thrown if connection is null
Remarks
This method will query the database for this information, and then store it in a cache for future requests.
See Also

Reference

AdoHelperTFactory Class
GetSpParameterSet Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).GetSpParameterSet Method (String, String)

AdoHelperTFactoryGetSpParameterSet Method (String, String)

Retrieves the set of IDataParameters appropriate for the stored procedure

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual IDataParameter[] GetSpParameterSet(
    string connectionString,
    string spName
)
Public Overridable Function GetSpParameterSet (
    connectionString As String,
    spName As String
) As IDataParameter()

Parameters

connectionString
Type: SystemString
A valid connection string for an IDbConnection
spName
Type: SystemString
The name of the stored procedure

Return Value

Type: IDataParameter
An array of IDataParameterParameters
Exceptions
Exception | Condition
ArgumentNullException | Thrown if connectionString is null
ArgumentNullException | Thrown if spName is null
Remarks
This method will query the database for this information, and then store it in a cache for future requests.
See Also

Reference

AdoHelperTFactory Class
GetSpParameterSet Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).GetSpParameterSet Method (IDbConnection, String, Boolean)

AdoHelperTFactoryGetSpParameterSet Method (IDbConnection, String, Boolean)

Retrieves the set of IDataParameters appropriate for the stored procedure

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual IDataParameter[] GetSpParameterSet(
    IDbConnection connection,
    string spName,
    bool includeReturnValueParameter
)
Public Overridable Function GetSpParameterSet (
    connection As IDbConnection,
    spName As String,
    includeReturnValueParameter As Boolean
) As IDataParameter()

Parameters

connection
Type: System.DataIDbConnection
A valid IDbConnection object
spName
Type: SystemString
The name of the stored procedure
includeReturnValueParameter
Type: SystemBoolean
A bool value indicating whether the return value parameter should be included in the results

Return Value

Type: IDataParameter
An array of IDataParameters
Exceptions
Exception | Condition
ArgumentNullException | Thrown if spName is null
ArgumentNullException | Thrown if connection is null
Remarks
This method will query the database for this information, and then store it in a cache for future requests.
See Also

Reference

AdoHelperTFactory Class
GetSpParameterSet Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).GetSpParameterSet Method (String, String, Boolean)

AdoHelperTFactoryGetSpParameterSet Method (String, String, Boolean)

Retrieves the set of IDataParameters appropriate for the stored procedure

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual IDataParameter[] GetSpParameterSet(
    string connectionString,
    string spName,
    bool includeReturnValueParameter
)
Public Overridable Function GetSpParameterSet (
    connectionString As String,
    spName As String,
    includeReturnValueParameter As Boolean
) As IDataParameter()

Parameters

connectionString
Type: SystemString
A valid connection string for an IDbConnection
spName
Type: SystemString
The name of the stored procedure
includeReturnValueParameter
Type: SystemBoolean
A bool value indicating whether the return value parameter should be included in the results

Return Value

Type: IDataParameter
An array of IDataParameters
Exceptions
Exception | Condition
ArgumentNullException | Thrown if connectionString is null
ArgumentNullException | Thrown if spName is null
Remarks
This method will query the database for this information, and then store it in a cache for future requests.
See Also

Reference

AdoHelperTFactory Class
GetSpParameterSet Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).PrepareCommand Method

AdoHelperTFactoryPrepareCommand Method

This method opens (if necessary) and assigns a connection, transaction, command type and parameters to the provided command

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual void PrepareCommand(
    IDbCommand command,
    IDbConnection connection,
    IDbTransaction transaction,
    CommandType commandType,
    string commandText,
    IDataParameter[] commandParameters,
    out bool mustCloseConnection
)
Protected Overridable Sub PrepareCommand (
    command As IDbCommand,
    connection As IDbConnection,
    transaction As IDbTransaction,
    commandType As CommandType,
    commandText As String,
    commandParameters As IDataParameter(),
    <OutAttribute> ByRef mustCloseConnection As Boolean
)

Parameters

command
Type: System.DataIDbCommand
The IDbCommand to be prepared
connection
Type: System.DataIDbConnection
A valid IDbConnection, on which to execute this command
transaction
Type: System.DataIDbTransaction
A valid IDbTransaction, or 'null'
commandType
Type: System.DataCommandType
The CommandType (stored procedure, text, etc.)
commandText
Type: SystemString
The stored procedure name or SQL command
commandParameters
Type: System.DataIDataParameter
An array of IDataParameters to be associated with the command or 'null' if no parameters are required
mustCloseConnection
Type: SystemBoolean
true if the connection was opened by the method, otherwose is false.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if command is null.
ArgumentNullException | Thrown if commandText is null.
See Also

Reference

AdoHelperTFactory Class
CodeSmith.Engine Namespace


AdoHelper(TFactory).RowUpdated Method

AdoHelperTFactoryRowUpdated Method

This method consumes the RowUpdatedEvent and passes it on to the consumer specifed in the call to UpdateDataset

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected void RowUpdated(
    Object obj,
    RowUpdatedEventArgs e
)
Protected Sub RowUpdated (
    obj As Object,
    e As RowUpdatedEventArgs
)

Parameters

obj
Type: SystemObject
The object that generated the event
e
Type: System.Data.CommonRowUpdatedEventArgs
The System.Data.Common.RowUpdatingEventArgs
See Also

Reference

AdoHelperTFactory Class
CodeSmith.Engine Namespace


AdoHelper(TFactory).RowUpdating Method

AdoHelperTFactoryRowUpdating Method

This method consumes the RowUpdatingEvent and passes it on to the consumer specifed in the call to UpdateDataset

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected void RowUpdating(
    Object obj,
    RowUpdatingEventArgs e
)
Protected Sub RowUpdating (
    obj As Object,
    e As RowUpdatingEventArgs
)

Parameters

obj
Type: SystemObject
The object that generated the event
e
Type: System.Data.CommonRowUpdatingEventArgs
The System.Data.Common.RowUpdatingEventArgs
See Also

Reference

AdoHelperTFactory Class
CodeSmith.Engine Namespace


AdoHelper(TFactory).SetCommand Method

AdoHelperTFactorySetCommand Method

Set up a command for updating a DataSet.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual IDbCommand SetCommand(
    IDbCommand command,
    out bool mustCloseConnection
)
Protected Overridable Function SetCommand (
    command As IDbCommand,
    <OutAttribute> ByRef mustCloseConnection As Boolean
) As IDbCommand

Parameters

command
Type: System.DataIDbCommand
command object to prepare
mustCloseConnection
Type: SystemBoolean
output parameter specifying whether the connection used should be closed by the DAAB

Return Value

Type: IDbCommand
An IDbCommand object
See Also

Reference

AdoHelperTFactory Class
CodeSmith.Engine Namespace


AdoHelper(TFactory).UpdateDataset Method

AdoHelperTFactoryUpdateDataset Method

Overload List
Name | Description
UpdateDataset(IDbCommand, IDbCommand, IDbCommand, DataSet, String) | Executes the respective command for each inserted, updated, or deleted row in the DataSet.
UpdateDataset(IDbCommand, IDbCommand, IDbCommand, DataSet, String, AdoHelperTFactoryRowUpdatingHandler, AdoHelperTFactoryRowUpdatedHandler) | Executes the IDbCommand for each inserted, updated, or deleted row in the DataSet also implementing RowUpdating and RowUpdated Event Handlers
Top
See Also

Reference

AdoHelperTFactory Class
CodeSmith.Engine Namespace


AdoHelper(TFactory).UpdateDataset Method (IDbCommand, IDbCommand, IDbCommand, DataSet, String)

AdoHelperTFactoryUpdateDataset Method (IDbCommand, IDbCommand, IDbCommand, DataSet, String)

Executes the respective command for each inserted, updated, or deleted row in the DataSet.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual void UpdateDataset(
    IDbCommand insertCommand,
    IDbCommand deleteCommand,
    IDbCommand updateCommand,
    DataSet dataSet,
    string tableName
)
Public Overridable Sub UpdateDataset (
    insertCommand As IDbCommand,
    deleteCommand As IDbCommand,
    updateCommand As IDbCommand,
    dataSet As DataSet,
    tableName As String
)

Parameters

insertCommand
Type: System.DataIDbCommand
A valid SQL statement or stored procedure to insert new records into the data source
deleteCommand
Type: System.DataIDbCommand
A valid SQL statement or stored procedure to delete records from the data source
updateCommand
Type: System.DataIDbCommand
A valid SQL statement or stored procedure used to update records in the data source
dataSet
Type: System.DataDataSet
The DataSet used to update the data source
tableName
Type: SystemString
The DataTable used to update the data source.
Examples
Copy
helper.UpdateDataset(conn, insertCommand, deleteCommand, updateCommand, dataSet, "Order");
See Also

Reference

AdoHelperTFactory Class
UpdateDataset Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory).UpdateDataset Method (IDbCommand, IDbCommand, IDbCommand, DataSet, String, AdoHelper(TFactory).RowUpdatingHandler, AdoHelper(TFactory).RowUpdatedHandler)

AdoHelperTFactoryUpdateDataset Method (IDbCommand, IDbCommand, IDbCommand, DataSet, String, AdoHelperTFactoryRowUpdatingHandler, AdoHelperTFactoryRowUpdatedHandler)

Executes the IDbCommand for each inserted, updated, or deleted row in the DataSet also implementing RowUpdating and RowUpdated Event Handlers

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void UpdateDataset(
    IDbCommand insertCommand,
    IDbCommand deleteCommand,
    IDbCommand updateCommand,
    DataSet dataSet,
    string tableName,
    AdoHelperTFactoryRowUpdatingHandler rowUpdatingHandler,
    AdoHelperTFactoryRowUpdatedHandler rowUpdatedHandler
)
Public Sub UpdateDataset (
    insertCommand As IDbCommand,
    deleteCommand As IDbCommand,
    updateCommand As IDbCommand,
    dataSet As DataSet,
    tableName As String,
    rowUpdatingHandler As AdoHelperTFactoryRowUpdatingHandler,
    rowUpdatedHandler As AdoHelperTFactoryRowUpdatedHandler
)

Parameters

insertCommand
Type: System.DataIDbCommand
A valid SQL statement or stored procedure to insert new records into the data source
deleteCommand
Type: System.DataIDbCommand
A valid SQL statement or stored procedure to delete records from the data source
updateCommand
Type: System.DataIDbCommand
A valid SQL statement or stored procedure used to update records in the data source
dataSet
Type: System.DataDataSet
The DataSet used to update the data source
tableName
Type: SystemString
The DataTable used to update the data source.
rowUpdatingHandler
Type: CodeSmith.EngineAdoHelperTFactoryRowUpdatingHandler
RowUpdatingEventHandler
rowUpdatedHandler
Type: CodeSmith.EngineAdoHelperTFactoryRowUpdatedHandler
RowUpdatedEventHandler
Examples
Copy
RowUpdatingEventHandler rowUpdatingHandler = new RowUpdatingEventHandler( OnRowUpdating );
RowUpdatedEventHandler rowUpdatedHandler = new RowUpdatedEventHandler( OnRowUpdated );
helper.UpdateDataSet(sqlInsertCommand, sqlDeleteCommand, sqlUpdateCommand, dataSet, "Order", rowUpdatingHandler, rowUpdatedHandler);
See Also

Reference

AdoHelperTFactory Class
UpdateDataset Overload
CodeSmith.Engine Namespace


AdoHelper(TFactory) Fields

AdoHelperTFactory Fields

The AdoHelperTFactory generic type exposes the following members.

Fields
 | Name | Description
Protected field | m_rowUpdated | Internal handler used for bubbling up the event to the user
Protected field | m_rowUpdating | Internal handler used for bubbling up the event to the user
Top
See Also

Reference

AdoHelperTFactory Class
CodeSmith.Engine Namespace


AdoHelper(TFactory).m_rowUpdated Field

AdoHelperTFactorym_rowUpdated Field

Internal handler used for bubbling up the event to the user

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected AdoHelperTFactoryRowUpdatedHandler m_rowUpdated
Protected m_rowUpdated As AdoHelperTFactoryRowUpdatedHandler

Field Value

Type: AdoHelperTFactoryRowUpdatedHandler
See Also

Reference

AdoHelperTFactory Class
CodeSmith.Engine Namespace


AdoHelper(TFactory).m_rowUpdating Field

AdoHelperTFactorym_rowUpdating Field

Internal handler used for bubbling up the event to the user

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected AdoHelperTFactoryRowUpdatingHandler m_rowUpdating
Protected m_rowUpdating As AdoHelperTFactoryRowUpdatingHandler

Field Value

Type: AdoHelperTFactoryRowUpdatingHandler
See Also

Reference

AdoHelperTFactory Class
CodeSmith.Engine Namespace


AdoHelper(TFactory).AdoConnectionOwnership Enumeration

AdoHelperTFactoryAdoConnectionOwnership Enumeration

This enum is used to indicate whether the connection was provided by the caller, or created by AdoHelper, so that we can set the appropriate CommandBehavior when calling ExecuteReader()

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected enum AdoConnectionOwnership
Protected Enumeration AdoConnectionOwnership
Members
Member name | Value | Description
Internal | 0 | Connection is owned and managed by ADOHelper
External | 1 | Connection is owned and managed by the caller
See Also

Reference

CodeSmith.Engine Namespace


AdoHelper(TFactory).RowUpdatedHandler Delegate

AdoHelperTFactoryRowUpdatedHandler Delegate

Delegate for creating a RowUpdatedEvent handler

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public delegate void RowUpdatedHandler(
    Object sender,
    RowUpdatedEventArgs e
)
Public Delegate Sub RowUpdatedHandler (
    sender As Object,
    e As RowUpdatedEventArgs
)

Parameters

sender
Type: SystemObject
The object that published the event
e
Type: System.Data.CommonRowUpdatedEventArgs
The RowUpdatedEventArgs for the event
See Also

Reference

CodeSmith.Engine Namespace


AdoHelper(TFactory).RowUpdatingHandler Delegate

AdoHelperTFactoryRowUpdatingHandler Delegate

Delegate for creating a RowUpdatingEvent handler

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public delegate void RowUpdatingHandler(
    Object sender,
    RowUpdatingEventArgs e
)
Public Delegate Sub RowUpdatingHandler (
    sender As Object,
    e As RowUpdatingEventArgs
)

Parameters

sender
Type: SystemObject
The object that published the event
e
Type: System.Data.CommonRowUpdatingEventArgs
The RowUpdatingEventArgs for the event
See Also

Reference

CodeSmith.Engine Namespace


BusinessObjectBase Class

Note: This API is now obsolete.

Inheritance Hierarchy
SystemObject
CodeSmith.EngineBusinessObjectBase
CodeSmith.EngineActiveSnippetMapping

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
[ObsoleteAttribute]
public class BusinessObjectBase : INotifyPropertyChanged,
    IEditableObject, IDataErrorInfo, ICloneable
<SerializableAttribute>
<ObsoleteAttribute>
Public Class BusinessObjectBase
    Implements INotifyPropertyChanged, IEditableObject, IDataErrorInfo, ICloneable

The BusinessObjectBase type exposes the following members.

Constructors
 | Name | Description
Public method | BusinessObjectBase | Initializes a new instance of the BusinessObjectBase class
Top
Properties
 | Name | Description
Protected property | Errors |
Public property | HasErrors |
Public property | InEdit |
Public property | IsDirty |
Top
Methods
 | Name | Description
Public method | BeginEdit |
Public method | CancelEdit |
Protected method | ClearColumnError |
Protected method | ClearColumnErrors |
Public method | EndEdit |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FireRowResetEvent |
Protected method | GetColumnError |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnBeginEdit |
Protected method | OnCancelEdit |
Protected method | OnEndEdit |
Protected method | OnPropertyChanged |
Protected method | OnValidate |
Protected method | RollbackChanges |
Protected method | SaveState |
Protected method | SetColumnError |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate |
Top
Events
 | Name | Description
Public event | PropertyChanged |
Top
See Also

Reference

CodeSmith.Engine Namespace


BusinessObjectBase Constructor

Initializes a new instance of the BusinessObjectBase class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public BusinessObjectBase()
Public Sub New
See Also

Reference

BusinessObjectBase Class
CodeSmith.Engine Namespace


BusinessObjectBase Properties

The BusinessObjectBase type exposes the following members.

Properties
 | Name | Description
Protected property | Errors |
Public property | HasErrors |
Public property | InEdit |
Public property | IsDirty |
Top
See Also

Reference

BusinessObjectBase Class
CodeSmith.Engine Namespace


BusinessObjectBase.Errors Property

BusinessObjectBaseErrors Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected Dictionary<string, string> Errors { get; }
Protected ReadOnly Property Errors As Dictionary(Of String, String)
    Get

Property Value

Type: Dictionary String, String
See Also

Reference

BusinessObjectBase Class
CodeSmith.Engine Namespace


BusinessObjectBase.HasErrors Property

BusinessObjectBaseHasErrors Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool HasErrors { get; }
Public ReadOnly Property HasErrors As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

BusinessObjectBase Class
CodeSmith.Engine Namespace


BusinessObjectBase.InEdit Property

BusinessObjectBaseInEdit Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool InEdit { get; }
Public ReadOnly Property InEdit As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

BusinessObjectBase Class
CodeSmith.Engine Namespace


BusinessObjectBase.IsDirty Property

BusinessObjectBaseIsDirty Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual bool IsDirty { get; set; }
Public Overridable Property IsDirty As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

BusinessObjectBase Class
CodeSmith.Engine Namespace


BusinessObjectBase Methods

The BusinessObjectBase type exposes the following members.

Methods
 | Name | Description
Public method | BeginEdit |
Public method | CancelEdit |
Protected method | ClearColumnError |
Protected method | ClearColumnErrors |
Public method | EndEdit |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FireRowResetEvent |
Protected method | GetColumnError |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnBeginEdit |
Protected method | OnCancelEdit |
Protected method | OnEndEdit |
Protected method | OnPropertyChanged |
Protected method | OnValidate |
Protected method | RollbackChanges |
Protected method | SaveState |
Protected method | SetColumnError |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate |
Top
See Also

Reference

BusinessObjectBase Class
CodeSmith.Engine Namespace


BusinessObjectBase.BeginEdit Method

BusinessObjectBaseBeginEdit Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void BeginEdit()
Public Sub BeginEdit

Implements

IEditableObjectBeginEdit
See Also

Reference

BusinessObjectBase Class
CodeSmith.Engine Namespace


BusinessObjectBase.CancelEdit Method

BusinessObjectBaseCancelEdit Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void CancelEdit()
Public Sub CancelEdit

Implements

IEditableObjectCancelEdit
See Also

Reference

BusinessObjectBase Class
CodeSmith.Engine Namespace


BusinessObjectBase.ClearColumnError Method

BusinessObjectBaseClearColumnError Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected void ClearColumnError(
    string column
)
Protected Sub ClearColumnError (
    column As String
)

Parameters

column
Type: SystemString
See Also

Reference

BusinessObjectBase Class
CodeSmith.Engine Namespace


BusinessObjectBase.ClearColumnErrors Method

BusinessObjectBaseClearColumnErrors Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected void ClearColumnErrors()
Protected Sub ClearColumnErrors
See Also

Reference

BusinessObjectBase Class
CodeSmith.Engine Namespace


BusinessObjectBase.EndEdit Method

BusinessObjectBaseEndEdit Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void EndEdit()
Public Sub EndEdit

Implements

IEditableObjectEndEdit
See Also

Reference

BusinessObjectBase Class
CodeSmith.Engine Namespace


BusinessObjectBase.FireRowResetEvent Method

BusinessObjectBaseFireRowResetEvent Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected void FireRowResetEvent()
Protected Sub FireRowResetEvent
See Also

Reference

BusinessObjectBase Class
CodeSmith.Engine Namespace


BusinessObjectBase.GetColumnError Method

BusinessObjectBaseGetColumnError Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected string GetColumnError(
    string column
)
Protected Function GetColumnError (
    column As String
) As String

Parameters

column
Type: SystemString

Return Value

Type: String
See Also

Reference

BusinessObjectBase Class
CodeSmith.Engine Namespace


BusinessObjectBase.OnBeginEdit Method

BusinessObjectBaseOnBeginEdit Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual void OnBeginEdit()
Protected Overridable Sub OnBeginEdit
See Also

Reference

BusinessObjectBase Class
CodeSmith.Engine Namespace


BusinessObjectBase.OnCancelEdit Method

BusinessObjectBaseOnCancelEdit Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual void OnCancelEdit()
Protected Overridable Sub OnCancelEdit
See Also

Reference

BusinessObjectBase Class
CodeSmith.Engine Namespace


BusinessObjectBase.OnEndEdit Method

BusinessObjectBaseOnEndEdit Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual void OnEndEdit()
Protected Overridable Sub OnEndEdit
See Also

Reference

BusinessObjectBase Class
CodeSmith.Engine Namespace


BusinessObjectBase.OnPropertyChanged Method

BusinessObjectBaseOnPropertyChanged Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual void OnPropertyChanged(
    string propertyName
)
Protected Overridable Sub OnPropertyChanged (
    propertyName As String
)

Parameters

propertyName
Type: SystemString
See Also

Reference

BusinessObjectBase Class
CodeSmith.Engine Namespace


BusinessObjectBase.OnValidate Method

BusinessObjectBaseOnValidate Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual bool OnValidate()
Protected Overridable Function OnValidate As Boolean

Return Value

Type: Boolean
See Also

Reference

BusinessObjectBase Class
CodeSmith.Engine Namespace


BusinessObjectBase.RollbackChanges Method

BusinessObjectBaseRollbackChanges Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual void RollbackChanges()
Protected Overridable Sub RollbackChanges
See Also

Reference

BusinessObjectBase Class
CodeSmith.Engine Namespace


BusinessObjectBase.SaveState Method

BusinessObjectBaseSaveState Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual void SaveState(
    string propertyName,
    Object value
)
Protected Overridable Sub SaveState (
    propertyName As String,
    value As Object
)

Parameters

propertyName
Type: SystemString
value
Type: SystemObject
See Also

Reference

BusinessObjectBase Class
CodeSmith.Engine Namespace


BusinessObjectBase.SetColumnError Method

BusinessObjectBaseSetColumnError Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected void SetColumnError(
    string column,
    string error
)
Protected Sub SetColumnError (
    column As String,
    error As String
)

Parameters

column
Type: SystemString
error
Type: SystemString
See Also

Reference

BusinessObjectBase Class
CodeSmith.Engine Namespace


BusinessObjectBase.Validate Method

BusinessObjectBaseValidate Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool Validate()
Public Function Validate As Boolean

Return Value

Type: Boolean
See Also

Reference

BusinessObjectBase Class
CodeSmith.Engine Namespace


BusinessObjectBase Events

The BusinessObjectBase type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged |
Top
See Also

Reference

BusinessObjectBase Class
CodeSmith.Engine Namespace


BusinessObjectBase.PropertyChanged Event

BusinessObjectBasePropertyChanged Event

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public event PropertyChangedEventHandler PropertyChanged
Public Event PropertyChanged As PropertyChangedEventHandler

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

BusinessObjectBase Class
CodeSmith.Engine Namespace


CachedConfiguration Class

Inheritance Hierarchy
SystemObject
CodeSmith.EngineConfigurationBase
CodeSmith.EngineCachedConfiguration
CodeSmith.EngineConfiguration

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public abstract class CachedConfiguration : ConfigurationBase
Public MustInherit Class CachedConfiguration
    Inherits ConfigurationBase

The CachedConfiguration type exposes the following members.

Constructors
 | Name | Description
Protected method | CachedConfiguration | Initializes a new instance of the CachedConfiguration class
Top
Properties
 | Name | Description
Public property | ConfigurationVersion | (Inherited from ConfigurationBase.)
Protected property | NamePrefix | (Inherited from ConfigurationBase.)
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the CachedConfiguration (Overrides ConfigurationBaseDispose.)
Public method | EnsureInitialize | This method is here purely to make sure that we don't make a double call to the Initialize method while initializing configuration. (Inherited from ConfigurationBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetCachedValueT(String) |
Protected method | GetCachedValueT(String, T) |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetValueT(String) | (Inherited from ConfigurationBase.)
Protected method | GetValueT(String, T) | (Inherited from ConfigurationBase.)
Protected method | GetValueT(String, Action) | (Inherited from ConfigurationBase.)
Protected method | GetValueT(String, T, FuncT, Boolean) | (Inherited from ConfigurationBase.)
Protected method | GetValueT(String, Action, FuncT, Boolean) | (Inherited from ConfigurationBase.)
Protected method | GetValueT(String, String, T) | (Inherited from ConfigurationBase.)
Protected method | GetValueT(String, String, Action) | (Inherited from ConfigurationBase.)
Protected method | GetValueT(String, String, T, FuncT, Boolean) | (Inherited from ConfigurationBase.)
Protected method | GetValueT(String, String, Action, FuncT, Boolean) | (Inherited from ConfigurationBase.)
Public method | Initialize | (Inherited from ConfigurationBase.)
Public method | LoadDefaults | (Inherited from ConfigurationBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ResetDefaults | (Inherited from ConfigurationBase.)
Protected method | SetValueT(String, T) | (Inherited from ConfigurationBase.)
Protected method | SetValueT(String, String, T) | (Overrides ConfigurationBaseSetValueT(String, String, T).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Upgrade | (Inherited from ConfigurationBase.)
Protected method | UpgradeFileT | Attempts to update configuration from a configuration file. The version of CodeSmith must be older than CodeSmith 5.1. (Inherited from ConfigurationBase.)
Top
See Also

Reference

CodeSmith.Engine Namespace


CachedConfiguration Constructor

Initializes a new instance of the CachedConfiguration class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected CachedConfiguration()
Protected Sub New
See Also

Reference

CachedConfiguration Class
CodeSmith.Engine Namespace


CachedConfiguration Properties

The CachedConfiguration type exposes the following members.

Properties
 | Name | Description
Public property | ConfigurationVersion | (Inherited from ConfigurationBase.)
Protected property | NamePrefix | (Inherited from ConfigurationBase.)
Top
See Also

Reference

CachedConfiguration Class
CodeSmith.Engine Namespace


CachedConfiguration Methods

The CachedConfiguration type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Overrides ConfigurationBaseDispose.)
Public method | EnsureInitialize | This method is here purely to make sure that we don't make a double call to the Initialize method while initializing configuration. (Inherited from ConfigurationBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetCachedValueT(String) |
Protected method | GetCachedValueT(String, T) |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetValueT(String) | (Inherited from ConfigurationBase.)
Protected method | GetValueT(String, T) | (Inherited from ConfigurationBase.)
Protected method | GetValueT(String, Action) | (Inherited from ConfigurationBase.)
Protected method | GetValueT(String, T, FuncT, Boolean) | (Inherited from ConfigurationBase.)
Protected method | GetValueT(String, Action, FuncT, Boolean) | (Inherited from ConfigurationBase.)
Protected method | GetValueT(String, String, T) | (Inherited from ConfigurationBase.)
Protected method | GetValueT(String, String, Action) | (Inherited from ConfigurationBase.)
Protected method | GetValueT(String, String, T, FuncT, Boolean) | (Inherited from ConfigurationBase.)
Protected method | GetValueT(String, String, Action, FuncT, Boolean) | (Inherited from ConfigurationBase.)
Public method | Initialize | (Inherited from ConfigurationBase.)
Public method | LoadDefaults | (Inherited from ConfigurationBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ResetDefaults | (Inherited from ConfigurationBase.)
Protected method | SetValueT(String, T) | (Inherited from ConfigurationBase.)
Protected method | SetValueT(String, String, T) | (Overrides ConfigurationBaseSetValueT(String, String, T).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Upgrade | (Inherited from ConfigurationBase.)
Protected method | UpgradeFileT | Attempts to update configuration from a configuration file. The version of CodeSmith must be older than CodeSmith 5.1. (Inherited from ConfigurationBase.)
Top
See Also

Reference

CachedConfiguration Class
CodeSmith.Engine Namespace


CachedConfiguration.Dispose Method

CachedConfigurationDispose Method

Releases all resources used by the CachedConfiguration

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override void Dispose()
Public Overrides Sub Dispose

Implements

IDisposableDispose
See Also

Reference

CachedConfiguration Class
CodeSmith.Engine Namespace


CachedConfiguration.GetCachedValue Method

CachedConfigurationGetCachedValue Method

Overload List
 | Name | Description
Protected method | GetCachedValueT(String) |
Protected method | GetCachedValueT(String, T) |
Top
See Also

Reference

CachedConfiguration Class
CodeSmith.Engine Namespace


CachedConfiguration.GetCachedValue(T) Method (String)

CachedConfigurationGetCachedValueT Method (String)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected T GetCachedValue<T>(
    string name
)

Protected Function GetCachedValue(Of T) (
    name As String
) As T

Parameters

name
Type: SystemString

Type Parameters

T

Return Value

Type: T
See Also

Reference

CachedConfiguration Class
GetCachedValue Overload
CodeSmith.Engine Namespace


CachedConfiguration.GetCachedValue(T) Method (String, T)

CachedConfigurationGetCachedValueT Method (String, T)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual T GetCachedValue<T>(
    string name,
    T defaultValue
)

Protected Overridable Function GetCachedValue(Of T) (
    name As String,
    defaultValue As T
) As T

Parameters

name
Type: SystemString
defaultValue
Type: T

Type Parameters

T

Return Value

Type: T
See Also

Reference

CachedConfiguration Class
GetCachedValue Overload
CodeSmith.Engine Namespace


CachedConfiguration.SetValue Method

CachedConfigurationSetValue Method

Overload List
 | Name | Description
Protected method | SetValueT(String, T) | (Inherited from ConfigurationBase.)
Protected method | SetValueT(String, String, T) | (Overrides ConfigurationBaseSetValueT(String, String, T).)
Top
See Also

Reference

CachedConfiguration Class
CodeSmith.Engine Namespace


CachedConfiguration.SetValue(T) Method (String, String, T)

CachedConfigurationSetValueT Method (String, String, T)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected override void SetValue<T>(
    string subKey,
    string name,
    T value
)

Protected Overrides Sub SetValue(Of T) (
    subKey As String,
    name As String,
    value As T
)

Parameters

subKey
Type: SystemString
name
Type: SystemString
value
Type: T

Type Parameters

T
See Also

Reference

CachedConfiguration Class
SetValue Overload
CodeSmith.Engine Namespace


CodeGeneratorBase Class

Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
CodeSmith.EngineCodeGeneratorBase
CodeSmith.EngineActiveSnippetGenerator
CodeSmith.EngineProjectCodeGenerator

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
public abstract class CodeGeneratorBase : MarshalByRefObject
<SerializableAttribute>
Public MustInherit Class CodeGeneratorBase
    Inherits MarshalByRefObject

The CodeGeneratorBase type exposes the following members.

Constructors
 | Name | Description
Public method | CodeGeneratorBase | Initializes a new instance of the CodeGeneratorBase class
Top
Properties
 | Name | Description
Public property | Debug |
Public property | KeepTempFiles |
Public property | Properties |
Public property | Verbose |
Top
Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetCodeTemplateInfo |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetVariables |
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnGeneratorError(GeneratorErrorEventArgs) |
Protected method | OnGeneratorError(String, Exception) |
Protected method | OnGeneratorError(String, Boolean, Int32, String, Int32, Int32) |
Protected method | OnOutputString(MessageEventArgs) |
Protected method | OnOutputString(String) |
Protected method | OnOutputString(String, Object) |
Protected method | OnPreOutputWritten |
Protected method | OnProgress(GeneratorProgressEventArgs) |
Protected method | OnProgress(Int32, Int32) |
Protected method | OnStatusChanged(MessageEventArgs) |
Protected method | OnStatusChanged(String) |
Protected method | OutputCompilerErrors |
Protected method | ReplaceVariables |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | WriteComment |
Protected method | WriteHeader |
Top
Events
 | Name | Description
Public event | GeneratorError |
Public event | OutputString |
Public event | PreOutputWritten |
Public event | Progress |
Public event | StatusChanged |
Top
See Also

Reference

CodeSmith.Engine Namespace


CodeGeneratorBase Constructor

Initializes a new instance of the CodeGeneratorBase class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CodeGeneratorBase()
Public Sub New
See Also

Reference

CodeGeneratorBase Class
CodeSmith.Engine Namespace


CodeGeneratorBase Properties

The CodeGeneratorBase type exposes the following members.

Properties
 | Name | Description
Public property | Debug |
Public property | KeepTempFiles |
Public property | Properties |
Public property | Verbose |
Top
See Also

Reference

CodeGeneratorBase Class
CodeSmith.Engine Namespace


CodeGeneratorBase.Debug Property

CodeGeneratorBaseDebug Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool Debug { get; set; }
Public Property Debug As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

CodeGeneratorBase Class
CodeSmith.Engine Namespace


CodeGeneratorBase.KeepTempFiles Property

CodeGeneratorBaseKeepTempFiles Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool KeepTempFiles { get; set; }
Public Property KeepTempFiles As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

CodeGeneratorBase Class
CodeSmith.Engine Namespace


CodeGeneratorBase.Properties Property

CodeGeneratorBaseProperties Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public Hashtable Properties { get; set; }
Public Property Properties As Hashtable
    Get
    Set

Property Value

Type: Hashtable
See Also

Reference

CodeGeneratorBase Class
CodeSmith.Engine Namespace


CodeGeneratorBase.Verbose Property

CodeGeneratorBaseVerbose Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool Verbose { get; set; }
Public Property Verbose As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

CodeGeneratorBase Class
CodeSmith.Engine Namespace


CodeGeneratorBase Methods

The CodeGeneratorBase type exposes the following members.

Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetCodeTemplateInfo |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetVariables |
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnGeneratorError(GeneratorErrorEventArgs) |
Protected method | OnGeneratorError(String, Exception) |
Protected method | OnGeneratorError(String, Boolean, Int32, String, Int32, Int32) |
Protected method | OnOutputString(MessageEventArgs) |
Protected method | OnOutputString(String) |
Protected method | OnOutputString(String, Object) |
Protected method | OnPreOutputWritten |
Protected method | OnProgress(GeneratorProgressEventArgs) |
Protected method | OnProgress(Int32, Int32) |
Protected method | OnStatusChanged(MessageEventArgs) |
Protected method | OnStatusChanged(String) |
Protected method | OutputCompilerErrors |
Protected method | ReplaceVariables |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | WriteComment |
Protected method | WriteHeader |
Top
See Also

Reference

CodeGeneratorBase Class
CodeSmith.Engine Namespace


CodeGeneratorBase.GetCodeTemplateInfo Method

CodeGeneratorBaseGetCodeTemplateInfo Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected ICodeTemplateInfo GetCodeTemplateInfo(
    string inputFileName,
    XmlDocument doc,
    string nodePath
)
Protected Function GetCodeTemplateInfo (
    inputFileName As String,
    doc As XmlDocument,
    nodePath As String
) As ICodeTemplateInfo

Parameters

inputFileName
Type: SystemString
doc
Type: System.XmlXmlDocument
nodePath
Type: SystemString

Return Value

Type: ICodeTemplateInfo
See Also

Reference

CodeGeneratorBase Class
CodeSmith.Engine Namespace


CodeGeneratorBase.GetVariables Method

CodeGeneratorBaseGetVariables Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected Hashtable GetVariables(
    XmlDocument document
)
Protected Function GetVariables (
    document As XmlDocument
) As Hashtable

Parameters

document
Type: System.XmlXmlDocument

Return Value

Type: Hashtable
See Also

Reference

CodeGeneratorBase Class
CodeSmith.Engine Namespace


CodeGeneratorBase.OnGeneratorError Method

CodeGeneratorBaseOnGeneratorError Method

Overload List
 | Name | Description
Protected method | OnGeneratorError(GeneratorErrorEventArgs) |
Protected method | OnGeneratorError(String, Exception) |
Protected method | OnGeneratorError(String, Boolean, Int32, String, Int32, Int32) |
Top
See Also

Reference

CodeGeneratorBase Class
CodeSmith.Engine Namespace


CodeGeneratorBase.OnGeneratorError Method (GeneratorErrorEventArgs)

CodeGeneratorBaseOnGeneratorError Method (GeneratorErrorEventArgs)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual void OnGeneratorError(
    GeneratorErrorEventArgs e
)
Protected Overridable Sub OnGeneratorError (
    e As GeneratorErrorEventArgs
)

Parameters

e
Type: CodeSmith.EngineGeneratorErrorEventArgs
See Also

Reference

CodeGeneratorBase Class
OnGeneratorError Overload
CodeSmith.Engine Namespace


CodeGeneratorBase.OnGeneratorError Method (String, Exception)

CodeGeneratorBaseOnGeneratorError Method (String, Exception)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual void OnGeneratorError(
    string file,
    Exception ex
)
Protected Overridable Sub OnGeneratorError (
    file As String,
    ex As Exception
)

Parameters

file
Type: SystemString
ex
Type: SystemException
See Also

Reference

CodeGeneratorBase Class
OnGeneratorError Overload
CodeSmith.Engine Namespace


CodeGeneratorBase.OnGeneratorError Method (String, Boolean, Int32, String, Int32, Int32)

CodeGeneratorBaseOnGeneratorError Method (String, Boolean, Int32, String, Int32, Int32)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual void OnGeneratorError(
    string file,
    bool warning,
    int level,
    string message,
    int line,
    int column
)
Protected Overridable Sub OnGeneratorError (
    file As String,
    warning As Boolean,
    level As Integer,
    message As String,
    line As Integer,
    column As Integer
)

Parameters

file
Type: SystemString
warning
Type: SystemBoolean
level
Type: SystemInt32
message
Type: SystemString
line
Type: SystemInt32
column
Type: SystemInt32
See Also

Reference

CodeGeneratorBase Class
OnGeneratorError Overload
CodeSmith.Engine Namespace


CodeGeneratorBase.OnOutputString Method

CodeGeneratorBaseOnOutputString Method

Overload List
 | Name | Description
Protected method | OnOutputString(MessageEventArgs) |
Protected method | OnOutputString(String) |
Protected method | OnOutputString(String, Object) |
Top
See Also

Reference

CodeGeneratorBase Class
CodeSmith.Engine Namespace


CodeGeneratorBase.OnOutputString Method (MessageEventArgs)

CodeGeneratorBaseOnOutputString Method (MessageEventArgs)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual void OnOutputString(
    MessageEventArgs e
)
Protected Overridable Sub OnOutputString (
    e As MessageEventArgs
)

Parameters

e
Type: CodeSmith.EngineMessageEventArgs
See Also

Reference

CodeGeneratorBase Class
OnOutputString Overload
CodeSmith.Engine Namespace


CodeGeneratorBase.OnOutputString Method (String)

CodeGeneratorBaseOnOutputString Method (String)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual void OnOutputString(
    string message
)
Protected Overridable Sub OnOutputString (
    message As String
)

Parameters

message
Type: SystemString
See Also

Reference

CodeGeneratorBase Class
OnOutputString Overload
CodeSmith.Engine Namespace


CodeGeneratorBase.OnOutputString Method (String, Object[])

CodeGeneratorBaseOnOutputString Method (String, Object)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual void OnOutputString(
    string format,
    params Object[] args
)
Protected Overridable Sub OnOutputString (
    format As String,
    ParamArray args As Object()
)

Parameters

format
Type: SystemString
args
Type: SystemObject
See Also

Reference

CodeGeneratorBase Class
OnOutputString Overload
CodeSmith.Engine Namespace


CodeGeneratorBase.OnPreOutputWritten Method

CodeGeneratorBaseOnPreOutputWritten Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual void OnPreOutputWritten(
    OutputCancelEventArgs e
)
Protected Overridable Sub OnPreOutputWritten (
    e As OutputCancelEventArgs
)

Parameters

e
Type: CodeSmith.EngineOutputCancelEventArgs
See Also

Reference

CodeGeneratorBase Class
CodeSmith.Engine Namespace


CodeGeneratorBase.OnProgress Method

CodeGeneratorBaseOnProgress Method

Overload List
 | Name | Description
Protected method | OnProgress(GeneratorProgressEventArgs) |
Protected method | OnProgress(Int32, Int32) |
Top
See Also

Reference

CodeGeneratorBase Class
CodeSmith.Engine Namespace


CodeGeneratorBase.OnProgress Method (GeneratorProgressEventArgs)

CodeGeneratorBaseOnProgress Method (GeneratorProgressEventArgs)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual void OnProgress(
    GeneratorProgressEventArgs e
)
Protected Overridable Sub OnProgress (
    e As GeneratorProgressEventArgs
)

Parameters

e
Type: CodeSmith.EngineGeneratorProgressEventArgs
See Also

Reference

CodeGeneratorBase Class
OnProgress Overload
CodeSmith.Engine Namespace


CodeGeneratorBase.OnProgress Method (Int32, Int32)

CodeGeneratorBaseOnProgress Method (Int32, Int32)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual void OnProgress(
    int complete,
    int total
)
Protected Overridable Sub OnProgress (
    complete As Integer,
    total As Integer
)

Parameters

complete
Type: SystemInt32
total
Type: SystemInt32
See Also

Reference

CodeGeneratorBase Class
OnProgress Overload
CodeSmith.Engine Namespace


CodeGeneratorBase.OnStatusChanged Method

CodeGeneratorBaseOnStatusChanged Method

Overload List
 | Name | Description
Protected method | OnStatusChanged(MessageEventArgs) |
Protected method | OnStatusChanged(String) |
Top
See Also

Reference

CodeGeneratorBase Class
CodeSmith.Engine Namespace


CodeGeneratorBase.OnStatusChanged Method (MessageEventArgs)

CodeGeneratorBaseOnStatusChanged Method (MessageEventArgs)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual void OnStatusChanged(
    MessageEventArgs e
)
Protected Overridable Sub OnStatusChanged (
    e As MessageEventArgs
)

Parameters

e
Type: CodeSmith.EngineMessageEventArgs
See Also

Reference

CodeGeneratorBase Class
OnStatusChanged Overload
CodeSmith.Engine Namespace


CodeGeneratorBase.OnStatusChanged Method (String)

CodeGeneratorBaseOnStatusChanged Method (String)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected void OnStatusChanged(
    string status
)
Protected Sub OnStatusChanged (
    status As String
)

Parameters

status
Type: SystemString
See Also

Reference

CodeGeneratorBase Class
OnStatusChanged Overload
CodeSmith.Engine Namespace


CodeGeneratorBase.OutputCompilerErrors Method

CodeGeneratorBaseOutputCompilerErrors Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected void OutputCompilerErrors(
    CompilerErrorCollection errors
)
Protected Sub OutputCompilerErrors (
    errors As CompilerErrorCollection
)

Parameters

errors
Type: System.CodeDom.CompilerCompilerErrorCollection
See Also

Reference

CodeGeneratorBase Class
CodeSmith.Engine Namespace


CodeGeneratorBase.ReplaceVariables Method

CodeGeneratorBaseReplaceVariables Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected string ReplaceVariables(
    Hashtable variables,
    string value
)
Protected Function ReplaceVariables (
    variables As Hashtable,
    value As String
) As String

Parameters

variables
Type: System.CollectionsHashtable
value
Type: SystemString

Return Value

Type: String
See Also

Reference

CodeGeneratorBase Class
CodeSmith.Engine Namespace


CodeGeneratorBase.WriteComment Method

CodeGeneratorBaseWriteComment Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected void WriteComment(
    TextWriter writer,
    string commentFormat,
    string comment
)
Protected Sub WriteComment (
    writer As TextWriter,
    commentFormat As String,
    comment As String
)

Parameters

writer
Type: System.IOTextWriter
commentFormat
Type: SystemString
comment
Type: SystemString
See Also

Reference

CodeGeneratorBase Class
CodeSmith.Engine Namespace


CodeGeneratorBase.WriteHeader Method

CodeGeneratorBaseWriteHeader Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected void WriteHeader(
    TextWriter writer,
    string commentFormat
)
Protected Sub WriteHeader (
    writer As TextWriter,
    commentFormat As String
)

Parameters

writer
Type: System.IOTextWriter
commentFormat
Type: SystemString
See Also

Reference

CodeGeneratorBase Class
CodeSmith.Engine Namespace


CodeGeneratorBase Events

The CodeGeneratorBase type exposes the following members.

Events
 | Name | Description
Public event | GeneratorError |
Public event | OutputString |
Public event | PreOutputWritten |
Public event | Progress |
Public event | StatusChanged |
Top
See Also

Reference

CodeGeneratorBase Class
CodeSmith.Engine Namespace


CodeGeneratorBase.GeneratorError Event

CodeGeneratorBaseGeneratorError Event

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public event GeneratorErrorEventHandler GeneratorError
Public Event GeneratorError As GeneratorErrorEventHandler

Value

Type: CodeSmith.EngineGeneratorErrorEventHandler
See Also

Reference

CodeGeneratorBase Class
CodeSmith.Engine Namespace


CodeGeneratorBase.OutputString Event

CodeGeneratorBaseOutputString Event

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public event MessageEventHandler OutputString
Public Event OutputString As MessageEventHandler

Value

Type: CodeSmith.EngineMessageEventHandler
See Also

Reference

CodeGeneratorBase Class
CodeSmith.Engine Namespace


CodeGeneratorBase.PreOutputWritten Event

CodeGeneratorBasePreOutputWritten Event

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public event OutputCancelEventHandler PreOutputWritten
Public Event PreOutputWritten As OutputCancelEventHandler

Value

Type: CodeSmith.EngineOutputCancelEventHandler
See Also

Reference

CodeGeneratorBase Class
CodeSmith.Engine Namespace


CodeGeneratorBase.Progress Event

CodeGeneratorBaseProgress Event

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public event GeneratorProgressEventHandler Progress
Public Event Progress As GeneratorProgressEventHandler

Value

Type: CodeSmith.EngineGeneratorProgressEventHandler
See Also

Reference

CodeGeneratorBase Class
CodeSmith.Engine Namespace


CodeGeneratorBase.StatusChanged Event

CodeGeneratorBaseStatusChanged Event

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public event MessageEventHandler StatusChanged
Public Event StatusChanged As MessageEventHandler

Value

Type: CodeSmith.EngineMessageEventHandler
See Also

Reference

CodeGeneratorBase Class
CodeSmith.Engine Namespace


CodeSmithDomainFactory Class

Inheritance Hierarchy
SystemObject
CodeSmith.EngineCodeSmithDomainFactory

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class CodeSmithDomainFactory : IDisposable
Public Class CodeSmithDomainFactory
    Implements IDisposable

The CodeSmithDomainFactory type exposes the following members.

Constructors
 | Name | Description
Public method | CodeSmithDomainFactory | Initializes a new instance of the CodeSmithDomain class.
Public method | CodeSmithDomainFactory(String) | Initializes a new instance of the CodeSmithDomain class.
Top
Properties
 | Name | Description
Public property | CodeSmithDomain | Gets the CodeSmith AppDomain.
Top
Methods
 | Name | Description
Public method | CreateInstanceT | Creates an instance in the CodeSmithDomain.
Public method | CreateInstanceT(Object) | Creates an instance in the CodeSmithDomain.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the CodeSmithDomain is reclaimed by garbage collection. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSmith.Engine Namespace


CodeSmithDomainFactory Constructor

Overload List
 | Name | Description
Public method | CodeSmithDomainFactory | Initializes a new instance of the CodeSmithDomain class.
Public method | CodeSmithDomainFactory(String) | Initializes a new instance of the CodeSmithDomain class.
Top
See Also

Reference

CodeSmithDomainFactory Class
CodeSmith.Engine Namespace


CodeSmithDomainFactory Constructor

Initializes a new instance of the CodeSmithDomain class.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CodeSmithDomainFactory()
Public Sub New
See Also

Reference

CodeSmithDomainFactory Class
CodeSmithDomainFactory Overload
CodeSmith.Engine Namespace


CodeSmithDomainFactory Constructor (String)

Initializes a new instance of the CodeSmithDomain class.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CodeSmithDomainFactory(
    string friendlyName
)
Public Sub New (
    friendlyName As String
)

Parameters

friendlyName
Type: SystemString
Name of the friendly.
See Also

Reference

CodeSmithDomainFactory Class
CodeSmithDomainFactory Overload
CodeSmith.Engine Namespace


CodeSmithDomainFactory Properties

The CodeSmithDomainFactory type exposes the following members.

Properties
 | Name | Description
Public property | CodeSmithDomain | Gets the CodeSmith AppDomain.
Top
See Also

Reference

CodeSmithDomainFactory Class
CodeSmith.Engine Namespace


CodeSmithDomainFactory.CodeSmithDomain Property

CodeSmithDomainFactoryCodeSmithDomain Property

Gets the CodeSmith AppDomain.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public AppDomain CodeSmithDomain { get; }
Public ReadOnly Property CodeSmithDomain As AppDomain
    Get

Property Value

Type: AppDomain
The CodeSmith AppDomain.
See Also

Reference

CodeSmithDomainFactory Class
CodeSmith.Engine Namespace


CodeSmithDomainFactory Methods

The CodeSmithDomainFactory type exposes the following members.

Methods
 | Name | Description
Public method | CreateInstanceT | Creates an instance in the CodeSmithDomain.
Public method | CreateInstanceT(Object) | Creates an instance in the CodeSmithDomain.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the CodeSmithDomain is reclaimed by garbage collection. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSmithDomainFactory Class
CodeSmith.Engine Namespace


CodeSmithDomainFactory.CreateInstance Method

CodeSmithDomainFactoryCreateInstance Method

Overload List
 | Name | Description
Public method | CreateInstanceT | Creates an instance in the CodeSmithDomain.
Public method | CreateInstanceT(Object) | Creates an instance in the CodeSmithDomain.
Top
See Also

Reference

CodeSmithDomainFactory Class
CodeSmith.Engine Namespace


CodeSmithDomainFactory.CreateInstance(T) Method

CodeSmithDomainFactoryCreateInstanceT Method

Creates an instance in the CodeSmithDomain.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public T CreateInstance<T>()
where T : MarshalByRefObject

Public Function CreateInstance(Of T As MarshalByRefObject) As T

Type Parameters

T

Return Value

Type: T
See Also

Reference

CodeSmithDomainFactory Class
CreateInstance Overload
CodeSmith.Engine Namespace


CodeSmithDomainFactory.CreateInstance(T) Method (Object[])

CodeSmithDomainFactoryCreateInstanceT Method (Object)

Creates an instance in the CodeSmithDomain.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public T CreateInstance<T>(
    params Object[] args
)
where T : MarshalByRefObject

Public Function CreateInstance(Of T As MarshalByRefObject) (
    ParamArray args As Object()
) As T

Parameters

args
Type: SystemObject
The constructor args.

Type Parameters

T

Return Value

Type: T
See Also

Reference

CodeSmithDomainFactory Class
CreateInstance Overload
CodeSmith.Engine Namespace


CodeSmithDomainFactory.Dispose Method

CodeSmithDomainFactoryDispose Method

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

CodeSmithDomainFactory Class
CodeSmith.Engine Namespace


CodeSmithDomainFactory.Finalize Method

CodeSmithDomainFactoryFinalize Method

Releases unmanaged resources and performs other cleanup operations before the CodeSmithDomain is reclaimed by garbage collection.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected override void Finalize()
Protected Overrides Sub Finalize

Implements

ObjectFinalize
See Also

Reference

CodeSmithDomainFactory Class
CodeSmith.Engine Namespace


CodeTemplate Class

All templates must derive from this class.
Inheritance Hierarchy
SystemObject
CodeSmith.EngineControl
CodeSmith.EngineCodeTemplate
CodeSmith.BaseTemplatesOutputFileCodeTemplate

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class CodeTemplate : Control,
    INotifyPropertyChanged, IDisposable
Public Class CodeTemplate
    Inherits Control
    Implements INotifyPropertyChanged, IDisposable

The CodeTemplate type exposes the following members.

Constructors
 | Name | Description
Public method | CodeTemplate | Initializes a new instance of the CodeTemplate class
Top
Properties
 | Name | Description
Protected property | ChildControlsCreated | (Inherited from Control.)
Protected property | CodeTemplate | (Inherited from Control.)
Public property | CodeTemplateInfo | Gets the information for the current template.
Public property | ContextData | Contextual data items can be stored in this object and shared with sub-templates. This data will not be persisted with the template property set.
Protected property | Controls | (Inherited from Control.)
Protected property | Parent | (Inherited from Control.)
Public property | Progress | Provides a way to report execution progress for the template.
Public property | RegisteredOutputs |
Public property | RegisteredReferences |
Public property | Response | Response stream for the template output. You can write to the stream programmatically using this property.
Public property | State | State of this template instance.
Public property | ValidationErrors | Gets the validation errors for this template.
Protected property | Visible | (Overrides ControlVisible.)
Top
Methods
 | Name | Description
Protected method | ControlAdded | (Inherited from Control.)
Protected method | ControlRemoved | (Inherited from Control.)
Public method | CopyPropertiesTo(CodeTemplate) | Copies any matching properties to another CodeTemplate instance.
Public method | CopyPropertiesTo(CodeTemplate, Boolean) | Copies any matching properties to another CodeTemplate instance.
Public method | CopyPropertiesTo(CodeTemplate, ICollectionString) | Copies any matching properties to another CodeTemplate instance.
Public method | CopyPropertiesTo(CodeTemplate, Boolean, ICollectionString) | Copies any matching properties to another CodeTemplate instance.
Public method | CreateT | Gets an instance of the specified template type. Should be used with the Register directive.
Public method | CreateT(Boolean) | Gets an instance of the specified template type. Should be used with the Register directive.
Protected method | CreateChildControls | (Inherited from Control.)
Protected method | CreateControlCollection | (Inherited from Control.)
Public method | Dispose | Releases all resources used by the CodeTemplate
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the CodeTemplate and optionally releases the managed resources
Protected method | EnsureChildControls | (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | (Overrides ObjectFinalize.)
Public method | GetCodeTemplateInstance(String) | Gets an instance of the specified template.
Public method | GetCodeTemplateInstance(String, Boolean) | Gets an instance of the specified template.
Public method | GetCodeTemplateInstance(String, Boolean, Boolean) | Gets an instance of the specified template.
Public method | GetCustomValidationErrors | Allows the developer to add custom ValidationErrors to the validation collection.
Public method | GetFileName | Gets a default name for the template output. This can be overridden in your template to provide a suitable name for the output of the template based on the property values.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetProperties | Gets information on all of the properties on this template.
Public method | GetProperties(Boolean) | Gets information on all of the properties on this template.
Public method | GetProperty | Gets the value for the specified property.
Public method | GetPropertyAttribute | Gets the property attribute. Property attributes can be used to store various information at the property level.
Public method | GetPropertyDescription |
Public method | GetPropertyInfo |
Public method | GetRequiredProperties | Gets information on all of the required properties for this template.
Public method | GetTemplateAttribute | Gets the template attribute. Template attributes can be used to store various information at the template level.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControls | (Inherited from Control.)
Public method | IsPropertyRequired |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnError | This method can be overridden to perform logic when a template exception occurs.
Protected method | OnInit | This method can be overridden to perform logic when the template instance is created.
Protected method | OnOutputRegistered | This is the method that is responsible for notifying receivers that the event occurred
Protected method | OnPostRender | This method can be overridden to perform logic after the template is rendered.
Protected method | OnPreOutputWritten(OutputCancelEventArgs) | This is the method that is responsible for notifying receivers that the event occurred
Protected method | OnPreOutputWritten(String) | This is the method that is responsible for notifying receivers that the event occurred
Protected method | OnPreRender | This method can be overridden to perform logic before the template is rendered.
Protected method | OnPropertiesLoaded | This method can be overridden to perform logic when properties are loaded.
Protected method | OnPropertiesSaved | This method can be overridden to perform logic when properties are saved.
Protected method | OnPropertyChanged | This method can be overridden to perform logic when a property changes.
Protected method | OnReferenceRegistered | Raises the ItemRegisteredEventArgs event.
Public method | ParseDefaultValue | Parses the default value for properties. This can be overridden to provide custom default parsing logic.
Public method | RefreshProperties |
Public method | RefreshProperties(Boolean) |
Public method | RegisterOutput(OutputFile) |
Public method | RegisterOutput(String) |
Public method | RegisterReference | Registers the reference. When generating from within Visual Studio, these references will be added to the project.
Public method | Render | Renders to the template output to the specified writer. (Overrides ControlRender(TextWriter).)
Protected method | RenderChildren | (Inherited from Control.)
Public method | RenderToFile(OutputFile, Boolean) | Renders the template output to a file.
Public method | RenderToFile(String, IMergeStrategy) | Renders the template output to a file using a merge strategy.
Public method | RenderToFile(String, Boolean) | Renders the template output to a file.
Public method | RenderToFile(OutputFile, String, IMergeStrategy) | Renders the template output to a file using a merge strategy.
Public method | RenderToFile(String, String, IMergeStrategy) | Renders the template output to a file using a merge strategy.
Public method | RenderToFile(String, String, Boolean) | Renders the template output to a file.
Public method | RenderToString | Renders the template output to a String.
Public method | RenderToString(String, IMergeStrategy) | Renders the template output to a String.
Public method | RestorePropertiesFromHashtable | Restores the properties from a Hashtable.
Public method | RestorePropertiesFromPropertySet(PropertySet, String) |
Public method | RestorePropertiesFromPropertySet(PropertySet, String, Hashtable) |
Public method | RestorePropertiesFromSchema |
Public method | RestorePropertiesFromXml | Restores the properties from XML.
Public method | RestorePropertiesFromXmlFile | Restores the properties from XML file.
Public method | SavePropertiesToHashtable | Saves the properties to a Hashtable.
Public method | SavePropertiesToHashtable(Boolean) | Saves the properties to a Hashtable.
Public method | SavePropertiesToPropertySet |
Public method | SavePropertiesToXml | Saves the properties to XML.
Public method | SavePropertiesToXml(XmlWriter) | Saves the properties to XML.
Public method | SavePropertiesToXmlFile | Saves the properties to an XML file.
Protected method | SetContextData | Set the context data object for the template. Any items in the current ContextData object will be added to the new one. This method should only be called while a template is initializing.
Public method | SetProperty(PropertyInfo, Object) | Sets the value for the specified property.
Public method | SetProperty(String, Object) | Sets the value for the specified property.
Public method | SetProperty(XmlNode, String) |
Public method | SetPropertyAttribute | Sets the property attribute. Property attributes can be used to store various information at the property level.
Protected method | SetPropertyDefaults | This method is overridden in templates to set default values in a template instance.
Public method | SetTemplateAttribute | Sets the template attribute. Template attributes can be used to store various information at the template level.
Protected method | SetUnknownDirectiveAttributes | This method is overridden in templates to set unknown directive attributes in the ContextData.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates this template instance.
Top
Events
 | Name | Description
Public event | OutputRegistered | Raised when an output file is registered
Public event | PreOutputWritten | Raised prior to an output being written to disk
Public event | PropertiesLoaded |
Public event | PropertiesSaved |
Public event | PropertyChanged |
Public event | ReferenceRegistered | Occurs when a reference is registered.
Top
Fields
 | Name | Description
Protected field | _childControlsCreated | (Inherited from Control.)
Protected field | _codeTemplate | (Inherited from Control.)
Protected field | _controls | (Inherited from Control.)
Protected field | _parent | (Inherited from Control.)
Protected field | _visible | (Inherited from Control.)
Top
See Also

Reference

CodeSmith.Engine Namespace


CodeTemplate Constructor

Initializes a new instance of the CodeTemplate class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CodeTemplate()
Public Sub New
See Also

Reference

CodeTemplate Class
CodeSmith.Engine Namespace


CodeTemplate Properties

The CodeTemplate type exposes the following members.

Properties
 | Name | Description
Protected property | ChildControlsCreated | (Inherited from Control.)
Protected property | CodeTemplate | (Inherited from Control.)
Public property | CodeTemplateInfo | Gets the information for the current template.
Public property | ContextData | Contextual data items can be stored in this object and shared with sub-templates. This data will not be persisted with the template property set.
Protected property | Controls | (Inherited from Control.)
Protected property | Parent | (Inherited from Control.)
Public property | Progress | Provides a way to report execution progress for the template.
Public property | RegisteredOutputs |
Public property | RegisteredReferences |
Public property | Response | Response stream for the template output. You can write to the stream programmatically using this property.
Public property | State | State of this template instance.
Public property | ValidationErrors | Gets the validation errors for this template.
Protected property | Visible | (Overrides ControlVisible.)
Top
See Also

Reference

CodeTemplate Class
CodeSmith.Engine Namespace


CodeTemplate.CodeTemplateInfo Property

CodeTemplateCodeTemplateInfo Property

Gets the information for the current template.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual ICodeTemplateInfo CodeTemplateInfo { get; }
Public Overridable ReadOnly Property CodeTemplateInfo As ICodeTemplateInfo
    Get

Property Value

Type: ICodeTemplateInfo
See Also

Reference

CodeTemplate Class
CodeSmith.Engine Namespace


CodeTemplate.ContextData Property

CodeTemplateContextData Property

Contextual data items can be stored in this object and shared with sub-templates. This data will not be persisted with the template property set.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public NameValueCollection ContextData { get; }
Public ReadOnly Property ContextData As NameValueCollection
    Get

Property Value

Type: NameValueCollection
See Also

Reference

CodeTemplate Class
CodeSmith.Engine Namespace


CodeTemplate.Progress Property

CodeTemplateProgress Property

Provides a way to report execution progress for the template.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public Progress Progress { get; }
Public ReadOnly Property Progress As Progress
    Get

Property Value

Type: Progress
See Also

Reference

CodeTemplate Class
CodeSmith.Engine Namespace


CodeTemplate.RegisteredOutputs Property

CodeTemplateRegisteredOutputs Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ReadOnlyCollection<OutputFile> RegisteredOutputs { get; }
Public ReadOnly Property RegisteredOutputs As ReadOnlyCollection(Of OutputFile)
    Get

Property Value

Type: ReadOnlyCollection OutputFile
See Also

Reference

CodeTemplate Class
CodeSmith.Engine Namespace


CodeTemplate.RegisteredReferences Property

CodeTemplateRegisteredReferences Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ReadOnlyCollection<string> RegisteredReferences { get; }
Public ReadOnly Property RegisteredReferences As ReadOnlyCollection(Of String)
    Get

Property Value

Type: ReadOnlyCollection String
See Also

Reference

CodeTemplate Class
CodeSmith.Engine Namespace


CodeTemplate.Response Property

CodeTemplateResponse Property

Response stream for the template output. You can write to the stream programmatically using this property.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CodeTemplateWriter Response { get; set; }
Public Property Response As CodeTemplateWriter
    Get
    Set

Property Value

Type: CodeTemplateWriter
See Also

Reference

CodeTemplate Class
CodeSmith.Engine Namespace


CodeTemplate.State Property

CodeTemplateState Property

State of this template instance.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public TemplateState State { get; }
Public ReadOnly Property State As TemplateState
    Get

Property Value

Type: TemplateState
See Also

Reference

CodeTemplate Class
CodeSmith.Engine Namespace


CodeTemplate.ValidationErrors Property

CodeTemplateValidationErrors Property

Gets the validation errors for this template.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ValidationErrorCollection ValidationErrors { get; }
Public ReadOnly Property ValidationErrors As ValidationErrorCollection
    Get

Property Value

Type: ValidationErrorCollection
See Also

Reference

CodeTemplate Class
CodeSmith.Engine Namespace


CodeTemplate.Visible Property

CodeTemplateVisible Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected override bool Visible { get; set; }
Protected Overrides Property Visible As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

CodeTemplate Class
CodeSmith.Engine Namespace


CodeTemplate Methods

The CodeTemplate type exposes the following members.

Methods
 | Name | Description
Protected method | ControlAdded | (Inherited from Control.)
Protected method | ControlRemoved | (Inherited from Control.)
Public method | CopyPropertiesTo(CodeTemplate) | Copies any matching properties to another CodeTemplate instance.
Public method | CopyPropertiesTo(CodeTemplate, Boolean) | Copies any matching properties to another CodeTemplate instance.
Public method | CopyPropertiesTo(CodeTemplate, ICollectionString) | Copies any matching properties to another CodeTemplate instance.
Public method | CopyPropertiesTo(CodeTemplate, Boolean, ICollectionString) | Copies any matching properties to another CodeTemplate instance.
Public method | CreateT | Gets an instance of the specified template type. Should be used with the Register directive.
Public method | CreateT(Boolean) | Gets an instance of the specified template type. Should be used with the Register directive.
Protected method | CreateChildControls | (Inherited from Control.)
Protected method | CreateControlCollection | (Inherited from Control.)
Public method | Dispose |
Protected method | Dispose(Boolean) |
Protected method | EnsureChildControls | (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | (Overrides ObjectFinalize.)
Public method | GetCodeTemplateInstance(String) | Gets an instance of the specified template.
Public method | GetCodeTemplateInstance(String, Boolean) | Gets an instance of the specified template.
Public method | GetCodeTemplateInstance(String, Boolean, Boolean) | Gets an instance of the specified template.
Public method | GetCustomValidationErrors | Allows the developer to add custom ValidationErrors to the validation collection.
Public method | GetFileName | Gets a default name for the template output. This can be overridden in your template to provide a suitable name for the output of the template based on the property values.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetProperties | Gets information on all of the properties on this template.
Public method | GetProperties(Boolean) | Gets information on all of the properties on this template.
Public method | GetProperty | Gets the value for the specified property.
Public method | GetPropertyAttribute | Gets the property attribute. Property attributes can be used to store various information at the property level.
Public method | GetPropertyDescription |
Public method | GetPropertyInfo |
Public method | GetRequiredProperties | Gets information on all of the required properties for this template.
Public method | GetTemplateAttribute | Gets the template attribute. Template attributes can be used to store various information at the template level.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControls | (Inherited from Control.)
Public method | IsPropertyRequired |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnError | This method can be overridden to perform logic when a template exception occurs.
Protected method | OnInit | This method can be overridden to perform logic when the template instance is created.
Protected method | OnOutputRegistered | This is the method that is responsible for notifying receivers that the event occurred
Protected method | OnPostRender | This method can be overridden to perform logic after the template is rendered.
Protected method | OnPreOutputWritten(OutputCancelEventArgs) | This is the method that is responsible for notifying receivers that the event occurred
Protected method | OnPreOutputWritten(String) | This is the method that is responsible for notifying receivers that the event occurred
Protected method | OnPreRender | This method can be overridden to perform logic before the template is rendered.
Protected method | OnPropertiesLoaded | This method can be overridden to perform logic when properties are loaded.
Protected method | OnPropertiesSaved | This method can be overridden to perform logic when properties are saved.
Protected method | OnPropertyChanged | This method can be overridden to perform logic when a property changes.
Protected method | OnReferenceRegistered | Raises the ItemRegisteredEventArgs event.
Public method | ParseDefaultValue | Parses the default value for properties. This can be overridden to provide custom default parsing logic.
Public method | RefreshProperties |
Public method | RefreshProperties(Boolean) |
Public method | RegisterOutput(OutputFile) |
Public method | RegisterOutput(String) |
Public method | RegisterReference | Registers the reference. When generating from within Visual Studio, these references will be added to the project.
Public method | Render | Renders to the template output to the specified writer. (Overrides ControlRender(TextWriter).)
Protected method | RenderChildren | (Inherited from Control.)
Public method | RenderToFile(OutputFile, Boolean) | Renders the template output to a file.
Public method | RenderToFile(String, IMergeStrategy) | Renders the template output to a file using a merge strategy.
Public method | RenderToFile(String, Boolean) | Renders the template output to a file.
Public method | RenderToFile(OutputFile, String, IMergeStrategy) | Renders the template output to a file using a merge strategy.
Public method | RenderToFile(String, String, IMergeStrategy) | Renders the template output to a file using a merge strategy.
Public method | RenderToFile(String, String, Boolean) | Renders the template output to a file.
Public method | RenderToString | Renders the template output to a String.
Public method | RenderToString(String, IMergeStrategy) | Renders the template output to a String.
Public method | RestorePropertiesFromHashtable | Restores the properties from a Hashtable.
Public method | RestorePropertiesFromPropertySet(PropertySet, String) |
Public method | RestorePropertiesFromPropertySet(PropertySet, String, Hashtable) |
Public method | RestorePropertiesFromSchema |
Public method | RestorePropertiesFromXml | Restores the properties from XML.
Public method | RestorePropertiesFromXmlFile | Restores the properties from XML file.
Public method | SavePropertiesToHashtable | Saves the properties to a Hashtable.
Public method | SavePropertiesToHashtable(Boolean) | Saves the properties to a Hashtable.
Public method | SavePropertiesToPropertySet |
Public method | SavePropertiesToXml | Saves the properties to XML.
Public method | SavePropertiesToXml(XmlWriter) | Saves the properties to XML.
Public method | SavePropertiesToXmlFile | Saves the properties to an XML file.
Protected method | SetContextData | Set the context data object for the template. Any items in the current ContextData object will be added to the new one. This method should only be called while a template is initializing.
Public method | SetProperty(PropertyInfo, Object) | Sets the value for the specified property.
Public method | SetProperty(String, Object) | Sets the value for the specified property.
Public method | SetProperty(XmlNode, String) |
Public method | SetPropertyAttribute | Sets the property attribute. Property attributes can be used to store various information at the property level.
Protected method | SetPropertyDefaults | This method is overridden in templates to set default values in a template instance.
Public method | SetTemplateAttribute | Sets the template attribute. Template attributes can be used to store various information at the template level.
Protected method | SetUnknownDirectiveAttributes | This method is overridden in templates to set unknown directive attributes in the ContextData.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Validates this template instance.
Top
See Also

Reference

CodeTemplate Class
CodeSmith.Engine Namespace


CodeTemplate.CopyPropertiesTo Method

CodeTemplateCopyPropertiesTo Method

Overload List
 | Name | Description
Public method | CopyPropertiesTo(CodeTemplate) | Copies any matching properties to another CodeTemplate instance.
Public method | CopyPropertiesTo(CodeTemplate, Boolean) | Copies any matching properties to another CodeTemplate instance.
Public method | CopyPropertiesTo(CodeTemplate, ICollectionString) | Copies any matching properties to another CodeTemplate instance.
Public method | CopyPropertiesTo(CodeTemplate, Boolean, ICollectionString) | Copies any matching properties to another CodeTemplate instance.
Top
See Also

Reference

CodeTemplate Class
CodeSmith.Engine Namespace


CodeTemplate.CopyPropertiesTo Method (CodeTemplate)

CodeTemplateCopyPropertiesTo Method (CodeTemplate)

Copies any matching properties to another CodeTemplate instance.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void CopyPropertiesTo(
    CodeTemplate template
)
Public Sub CopyPropertiesTo (
    template As CodeTemplate
)

Parameters

template
Type: CodeSmith.EngineCodeTemplate
Template.
See Also

Reference

CodeTemplate Class
CopyPropertiesTo Overload
CodeSmith.Engine Namespace


CodeTemplate.CopyPropertiesTo Method (CodeTemplate, Boolean)

CodeTemplateCopyPropertiesTo Method (CodeTemplate, Boolean)

Copies any matching properties to another CodeTemplate instance.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void CopyPropertiesTo(
    CodeTemplate template,
    bool includeNonBrowsable
)
Public Sub CopyPropertiesTo (
    template As CodeTemplate,
    includeNonBrowsable As Boolean
)

Parameters

template
Type: CodeSmith.EngineCodeTemplate
Template.
includeNonBrowsable
Type: SystemBoolean
Whether non-browsable properties should be included.
See Also

Reference

CodeTemplate Class
CopyPropertiesTo Overload
CodeSmith.Engine Namespace


CodeTemplate.CopyPropertiesTo Method (CodeTemplate, ICollection(String))

CodeTemplateCopyPropertiesTo Method (CodeTemplate, ICollectionString)

Copies any matching properties to another CodeTemplate instance.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void CopyPropertiesTo(
    CodeTemplate template,
    ICollection<string> ignorePropertyNames
)
Public Sub CopyPropertiesTo (
    template As CodeTemplate,
    ignorePropertyNames As ICollection(Of String)
)

Parameters

template
Type: CodeSmith.EngineCodeTemplate
Template.
ignorePropertyNames
Type: System.Collections.GenericICollection String
Ignores the specified list of property names when copying properties to the template.
See Also

Reference

CodeTemplate Class
CopyPropertiesTo Overload
CodeSmith.Engine Namespace


CodeTemplate.CopyPropertiesTo Method (CodeTemplate, Boolean, ICollection(String))

CodeTemplateCopyPropertiesTo Method (CodeTemplate, Boolean, ICollectionString)

Copies any matching properties to another CodeTemplate instance.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void CopyPropertiesTo(
    CodeTemplate template,
    bool includeNonBrowsable,
    ICollection<string> ignorePropertyNames
)
Public Sub CopyPropertiesTo (
    template As CodeTemplate,
    includeNonBrowsable As Boolean,
    ignorePropertyNames As ICollection(Of String)
)

Parameters

template
Type: CodeSmith.EngineCodeTemplate
Template.
includeNonBrowsable
Type: SystemBoolean
Whether non-browsable properties should be included.
ignorePropertyNames
Type: System.Collections.GenericICollection String
Ignores the specified list of property names when copying properties to the template.
See Also

Reference

CodeTemplate Class
CopyPropertiesTo Overload
CodeSmith.Engine Namespace


CodeTemplate.Create Method

CodeTemplateCreate Method

Overload List
 | Name | Description
Public method | CreateT | Gets an instance of the specified template type. Should be used with the Register directive.
Public method | CreateT(Boolean) | Gets an instance of the specified template type. Should be used with the Register directive.
Top
See Also

Reference

CodeTemplate Class
CodeSmith.Engine Namespace


CodeTemplate.Create(T) Method

CodeTemplateCreateT Method

Gets an instance of the specified template type. Should be used with the Register directive.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public T Create<T>()
where T : new(), CodeTemplate

Public Function Create(Of T As {New, CodeTemplate}) As T

Type Parameters

T

Return Value

Type: T
The CodeTemplate instance.
See Also

Reference

CodeTemplate Class
Create Overload
CodeSmith.Engine Namespace


CodeTemplate.Create(T) Method (Boolean)

CodeTemplateCreateT Method (Boolean)

Gets an instance of the specified template type. Should be used with the Register directive.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public T Create<T>(
    bool shareContextData
)
where T : new(), CodeTemplate

Public Function Create(Of T As {New, CodeTemplate}) (
    shareContextData As Boolean
) As T

Parameters

shareContextData
Type: SystemBoolean
Share template context data with the child template instance.

Type Parameters

T

Return Value

Type: T
The CodeTemplate instance.
See Also

Reference

CodeTemplate Class
Create Overload
CodeSmith.Engine Namespace


CodeTemplate.Dispose Method

CodeTemplateDispose Method

Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the CodeTemplate
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the CodeTemplate and optionally releases the managed resources
Top
See Also

Reference

CodeTemplate Class
CodeSmith.Engine Namespace


CodeTemplate.Dispose Method

CodeTemplateDispose Method

Releases all resources used by the CodeTemplate

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

CodeTemplate Class
Dispose Overload
CodeSmith.Engine Namespace


CodeTemplate.Dispose Method (Boolean)

CodeTemplateDispose Method (Boolean)

Releases the unmanaged resources used by the CodeTemplate and optionally releases the managed resources

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected void Dispose(
    bool disposing
)
Protected Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also

Reference

CodeTemplate Class
Dispose Overload
CodeSmith.Engine Namespace


CodeTemplate.Finalize Method

CodeTemplateFinalize Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected override void Finalize()
Protected Overrides Sub Finalize

Implements

ObjectFinalize
See Also

Reference

CodeTemplate Class
CodeSmith.Engine Namespace


CodeTemplate.GetCodeTemplateInstance Method

CodeTemplateGetCodeTemplateInstance Method

Overload List
 | Name | Description
Public method | GetCodeTemplateInstance(String) | Gets an instance of the specified template.
Public method | GetCodeTemplateInstance(String, Boolean) | Gets an instance of the specified template.
Public method | GetCodeTemplateInstance(String, Boolean, Boolean) | Gets an instance of the specified template.
Top
See Also

Reference

CodeTemplate Class
CodeSmith.Engine Namespace


CodeTemplate.GetCodeTemplateInstance Method (String)

CodeTemplateGetCodeTemplateInstance Method (String)

Gets an instance of the specified template.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CodeTemplate GetCodeTemplateInstance(
    string templatePath
)
Public Function GetCodeTemplateInstance (
    templatePath As String
) As CodeTemplate

Parameters

templatePath
Type: SystemString
Path to the template.

Return Value

Type: CodeTemplate
See Also

Reference

CodeTemplate Class
GetCodeTemplateInstance Overload
CodeSmith.Engine Namespace


CodeTemplate.GetCodeTemplateInstance Method (String, Boolean)

CodeTemplateGetCodeTemplateInstance Method (String, Boolean)

Gets an instance of the specified template.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CodeTemplate GetCodeTemplateInstance(
    string templatePath,
    bool forceRecompile
)
Public Function GetCodeTemplateInstance (
    templatePath As String,
    forceRecompile As Boolean
) As CodeTemplate

Parameters

templatePath
Type: SystemString
Path to the template.
forceRecompile
Type: SystemBoolean
Forces the template to be recompiled instead of using the cache.

Return Value

Type: CodeTemplate
The CodeTemplate instance.
See Also

Reference

CodeTemplate Class
GetCodeTemplateInstance Overload
CodeSmith.Engine Namespace


CodeTemplate.GetCodeTemplateInstance Method (String, Boolean, Boolean)

CodeTemplateGetCodeTemplateInstance Method (String, Boolean, Boolean)

Gets an instance of the specified template.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CodeTemplate GetCodeTemplateInstance(
    string templatePath,
    bool forceRecompile,
    bool shareContextData
)
Public Function GetCodeTemplateInstance (
    templatePath As String,
    forceRecompile As Boolean,
    shareContextData As Boolean
) As CodeTemplate

Parameters

templatePath
Type: SystemString
Path to the template.
forceRecompile
Type: SystemBoolean
Forces the template to be recompiled instead of using the cache.
shareContextData
Type: SystemBoolean
Share template context data with the child template instance.

Return Value

Type: CodeTemplate
The CodeTemplate instance.
See Also

Reference

CodeTemplate Class
GetCodeTemplateInstance Overload
CodeSmith.Engine Namespace


CodeTemplate.GetCustomValidationErrors Method

CodeTemplateGetCustomValidationErrors Method

Allows the developer to add custom ValidationErrors to the validation collection.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual IEnumerable<ValidationError> GetCustomValidationErrors()
Public Overridable Function GetCustomValidationErrors As IEnumerable(Of ValidationError)

Return Value

Type: IEnumerable ValidationError
See Also

Reference

CodeTemplate Class
CodeSmith.Engine Namespace


CodeTemplate.GetFileName Method

CodeTemplateGetFileName Method

Gets a default name for the template output. This can be overridden in your template to provide a suitable name for the output of the template based on the property values.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual string GetFileName()
Public Overridable Function GetFileName As String

Return Value

Type: String
A file name (E.G., output.txt).
See Also

Reference

CodeTemplate Class
CodeSmith.Engine Namespace


CodeTemplate.GetProperties Method

CodeTemplateGetProperties Method

Overload List
 | Name | Description
Public method | GetProperties | Gets information on all of the properties on this template.
Public method | GetProperties(Boolean) | Gets information on all of the properties on this template.
Top
See Also

Reference

CodeTemplate Class
CodeSmith.Engine Namespace


CodeTemplate.GetProperties Method

CodeTemplateGetProperties Method

Gets information on all of the properties on this template.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public PropertyInfo[] GetProperties()
Public Function GetProperties As PropertyInfo()

Return Value

Type: PropertyInfo
See Also

Reference

CodeTemplate Class
GetProperties Overload
CodeSmith.Engine Namespace


CodeTemplate.GetProperties Method (Boolean)

CodeTemplateGetProperties Method (Boolean)

Gets information on all of the properties on this template.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public PropertyInfo[] GetProperties(
    bool includeNonBrowsable
)
Public Function GetProperties (
    includeNonBrowsable As Boolean
) As PropertyInfo()

Parameters

includeNonBrowsable
Type: SystemBoolean
Whether non-browsable properties should be included.

Return Value

Type: PropertyInfo
See Also

Reference

CodeTemplate Class
GetProperties Overload
CodeSmith.Engine Namespace


CodeTemplate.GetProperty Method

CodeTemplateGetProperty Method

Gets the value for the specified property.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public Object GetProperty(
    string name
)
Public Function GetProperty (
    name As String
) As Object

Parameters

name
Type: SystemString
Property name.

Return Value

Type: Object
See Also

Reference

CodeTemplate Class
CodeSmith.Engine Namespace


CodeTemplate.GetPropertyAttribute Method

CodeTemplateGetPropertyAttribute Method

Gets the property attribute. Property attributes can be used to store various information at the property level.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual string GetPropertyAttribute(
    string propertyName,
    string attributeName
)
Public Overridable Function GetPropertyAttribute (
    propertyName As String,
    attributeName As String
) As String

Parameters

propertyName
Type: SystemString
Name of the property.
attributeName
Type: SystemString
Name of the attribute.

Return Value

Type: String
The value of the attribute
See Also

Reference

CodeTemplate Class
CodeSmith.Engine Namespace


CodeTemplate.GetPropertyDescription Method

CodeTemplateGetPropertyDescription Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string GetPropertyDescription(
    PropertyInfo property
)
Public Function GetPropertyDescription (
    property As PropertyInfo
) As String

Parameters

property
Type: System.ReflectionPropertyInfo

Return Value

Type: String
See Also

Reference

CodeTemplate Class
CodeSmith.Engine Namespace


CodeTemplate.GetPropertyInfo Method

CodeTemplateGetPropertyInfo Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public PropertyInfo GetPropertyInfo(
    string name,
    bool ignoreCase
)
Public Function GetPropertyInfo (
    name As String,
    ignoreCase As Boolean
) As PropertyInfo

Parameters

name
Type: SystemString
ignoreCase
Type: SystemBoolean

Return Value

Type: PropertyInfo
See Also

Reference

CodeTemplate Class
CodeSmith.Engine Namespace


CodeTemplate.GetRequiredProperties Method

CodeTemplateGetRequiredProperties Method

Gets information on all of the required properties for this template.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public PropertyInfo[] GetRequiredProperties()
Public Function GetRequiredProperties As PropertyInfo()

Return Value

Type: PropertyInfo
See Also

Reference

CodeTemplate Class
CodeSmith.Engine Namespace


CodeTemplate.GetTemplateAttribute Method

CodeTemplateGetTemplateAttribute Method

Gets the template attribute. Template attributes can be used to store various information at the template level.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual string GetTemplateAttribute(
    string attributeName
)
Public Overridable Function GetTemplateAttribute (
    attributeName As String
) As String

Parameters

attributeName
Type: SystemString
Name of the attribute.

Return Value

Type: String
The value of the attribute
See Also

Reference

CodeTemplate Class
CodeSmith.Engine Namespace


CodeTemplate.IsPropertyRequired Method

CodeTemplateIsPropertyRequired Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool IsPropertyRequired(
    PropertyInfo property
)
Public Function IsPropertyRequired (
    property As PropertyInfo
) As Boolean

Parameters

property
Type: System.ReflectionPropertyInfo

Return Value

Type: Boolean
See Also

Reference

CodeTemplate Class
CodeSmith.Engine Namespace


CodeTemplate.OnError Method

CodeTemplateOnError Method

This method can be overridden to perform logic when a template exception occurs.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual void OnError(
    Exception e
)
Protected Overridable Sub OnError (
    e As Exception
)

Parameters

e
Type: SystemException
See Also

Reference

CodeTemplate Class
CodeSmith.Engine Namespace


CodeTemplate.OnInit Method

CodeTemplateOnInit Method

This method can be overridden to perform logic when the template instance is created.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual void OnInit()
Protected Overridable Sub OnInit
See Also

Reference

CodeTemplate Class
CodeSmith.Engine Namespace


CodeTemplate.OnOutputRegistered Method

CodeTemplateOnOutputRegistered Method

This is the method that is responsible for notifying receivers that the event occurred

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual void OnOutputRegistered(
    OutputRegisteredEventArgs e
)
Protected Overridable Sub OnOutputRegistered (
    e As OutputRegisteredEventArgs
)

Parameters

e
Type: CodeSmith.EngineOutputRegisteredEventArgs
See Also

Reference

CodeTemplate Class
CodeSmith.Engine Namespace


CodeTemplate.OnPostRender Method

CodeTemplateOnPostRender Method

This method can be overridden to perform logic after the template is rendered.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual void OnPostRender(
    string result
)
Protected Overridable Sub OnPostRender (
    result As String
)

Parameters

result
Type: SystemString
The template output.
See Also

Reference

CodeTemplate Class
CodeSmith.Engine Namespace


CodeTemplate.OnPreOutputWritten Method

CodeTemplateOnPreOutputWritten Method

Overload List
 | Name | Description
Protected method | OnPreOutputWritten(OutputCancelEventArgs) | This is the method that is responsible for notifying receivers that the event occurred
Protected method | OnPreOutputWritten(String) | This is the method that is responsible for notifying receivers that the event occurred
Top
See Also

Reference

CodeTemplate Class
CodeSmith.Engine Namespace


CodeTemplate.OnPreOutputWritten Method (OutputCancelEventArgs)

CodeTemplateOnPreOutputWritten Method (OutputCancelEventArgs)

This is the method that is responsible for notifying receivers that the event occurred

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual void OnPreOutputWritten(
    OutputCancelEventArgs e
)
Protected Overridable Sub OnPreOutputWritten (
    e As OutputCancelEventArgs
)

Parameters

e
Type: CodeSmith.EngineOutputCancelEventArgs
See Also

Reference

CodeTemplate Class
OnPreOutputWritten Overload
CodeSmith.Engine Namespace


CodeTemplate.OnPreOutputWritten Method (String)

CodeTemplateOnPreOutputWritten Method (String)

This is the method that is responsible for notifying receivers that the event occurred

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual void OnPreOutputWritten(
    string outputPath
)
Protected Overridable Sub OnPreOutputWritten (
    outputPath As String
)

Parameters

outputPath
Type: SystemString
See Also

Reference

CodeTemplate Class
OnPreOutputWritten Overload
CodeSmith.Engine Namespace


CodeTemplate.OnPreRender Method

CodeTemplateOnPreRender Method

This method can be overridden to perform logic before the template is rendered.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual void OnPreRender()
Protected Overridable Sub OnPreRender
See Also

Reference

CodeTemplate Class
CodeSmith.Engine Namespace


CodeTemplate.OnPropertiesLoaded Method

CodeTemplateOnPropertiesLoaded Method

This method can be overridden to perform logic when properties are loaded.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual void OnPropertiesLoaded()
Protected Overridable Sub OnPropertiesLoaded
See Also

Reference

CodeTemplate Class
CodeSmith.Engine Namespace


CodeTemplate.OnPropertiesSaved Method

CodeTemplateOnPropertiesSaved Method

This method can be overridden to perform logic when properties are saved.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual void OnPropertiesSaved()
Protected Overridable Sub OnPropertiesSaved
See Also

Reference

CodeTemplate Class
CodeSmith.Engine Namespace


CodeTemplate.OnPropertyChanged Method

CodeTemplateOnPropertyChanged Method

This method can be overridden to perform logic when a property changes.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual void OnPropertyChanged(
    string propertyName
)
Protected Overridable Sub OnPropertyChanged (
    propertyName As String
)

Parameters

propertyName
Type: SystemString
See Also

Reference

CodeTemplate Class
CodeSmith.Engine Namespace


CodeTemplate.OnReferenceRegistered Method

CodeTemplateOnReferenceRegistered Method

Raises the ItemRegisteredEventArgs event.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual void OnReferenceRegistered(
    ItemRegisteredEventArgs e
)
Protected Overridable Sub OnReferenceRegistered (
    e As ItemRegisteredEventArgs
)

Parameters

e
Type: CodeSmith.EngineItemRegisteredEventArgs
The ItemRegisteredEventArgs instance containing the event data.
See Also

Reference

CodeTemplate Class
CodeSmith.Engine Namespace


CodeTemplate.ParseDefaultValue Method

CodeTemplateParseDefaultValue Method

Parses the default value for properties. This can be overridden to provide custom default parsing logic.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual void ParseDefaultValue(
    PropertyInfo targetProperty,
    string defaultValue
)
Public Overridable Sub ParseDefaultValue (
    targetProperty As PropertyInfo,
    defaultValue As String
)

Parameters

targetProperty
Type: System.ReflectionPropertyInfo
Target property.
defaultValue
Type: SystemString
Default value.
See Also

Reference

CodeTemplate Class
CodeSmith.Engine Namespace


CodeTemplate.RefreshProperties Method

CodeTemplateRefreshProperties Method

Overload List
 | Name | Description
Public method | RefreshProperties |
Public method | RefreshProperties(Boolean) |
Top
See Also

Reference

CodeTemplate Class
CodeSmith.Engine Namespace


CodeTemplate.RefreshProperties Method

CodeTemplateRefreshProperties Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void RefreshProperties()
Public Sub RefreshProperties
See Also

Reference

CodeTemplate Class
RefreshProperties Overload
CodeSmith.Engine Namespace


CodeTemplate.RefreshProperties Method (Boolean)

CodeTemplateRefreshProperties Method (Boolean)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void RefreshProperties(
    bool includeNonBrowsable
)
Public Sub RefreshProperties (
    includeNonBrowsable As Boolean
)

Parameters

includeNonBrowsable
Type: SystemBoolean
See Also

Reference

CodeTemplate Class
RefreshProperties Overload
CodeSmith.Engine Namespace


CodeTemplate.RegisterOutput Method

CodeTemplateRegisterOutput Method

Overload List
 | Name | Description
Public method | RegisterOutput(OutputFile) |
Public method | RegisterOutput(String) |
Top
See Also

Reference

CodeTemplate Class
CodeSmith.Engine Namespace


CodeTemplate.RegisterOutput Method (OutputFile)

CodeTemplateRegisterOutput Method (OutputFile)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void RegisterOutput(
    OutputFile outputFile
)
Public Sub RegisterOutput (
    outputFile As OutputFile
)

Parameters

outputFile
Type: CodeSmith.EngineOutputFile
See Also

Reference

CodeTemplate Class
RegisterOutput Overload
CodeSmith.Engine Namespace


CodeTemplate.RegisterOutput Method (String)

CodeTemplateRegisterOutput Method (String)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void RegisterOutput(
    string outputFile
)
Public Sub RegisterOutput (
    outputFile As String
)

Parameters

outputFile
Type: SystemString
See Also

Reference

CodeTemplate Class
RegisterOutput Overload
CodeSmith.Engine Namespace


CodeTemplate.RegisterReference Method

CodeTemplateRegisterReference Method

Registers the reference. When generating from within Visual Studio, these references will be added to the project.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void RegisterReference(
    string referenceName
)
Public Sub RegisterReference (
    referenceName As String
)

Parameters

referenceName
Type: SystemString
Name of the reference.
See Also

Reference

CodeTemplate Class
CodeSmith.Engine Namespace


CodeTemplate.Render Method

CodeTemplateRender Method

Renders to the template output to the specified writer.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override void Render(
    TextWriter writer
)
Public Overrides Sub Render (
    writer As TextWriter
)

Parameters

writer
Type: System.IOTextWriter
Writer.
See Also

Reference

CodeTemplate Class
CodeSmith.Engine Namespace


CodeTemplate.RenderToFile Method

CodeTemplateRenderToFile Method

Overload List
 | Name | Description
Public method | RenderToFile(OutputFile, Boolean) | Renders the template output to a file.
Public method | RenderToFile(String, IMergeStrategy) | Renders the template output to a file using a merge strategy.
Public method | RenderToFile(String, Boolean) | Renders the template output to a file.
Public method | RenderToFile(OutputFile, String, IMergeStrategy) | Renders the template output to a file using a merge strategy.
Public method | RenderToFile(String, String, IMergeStrategy) | Renders the template output to a file using a merge strategy.
Public method | RenderToFile(String, String, Boolean) | Renders the template output to a file.
Top
See Also

Reference

CodeTemplate Class
CodeSmith.Engine Namespace


CodeTemplate.RenderToFile Method (OutputFile, Boolean)

CodeTemplateRenderToFile Method (OutputFile, Boolean)

Renders the template output to a file.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void RenderToFile(
    OutputFile outputFile,
    bool overwrite
)
Public Sub RenderToFile (
    outputFile As OutputFile,
    overwrite As Boolean
)

Parameters

outputFile
Type: CodeSmith.EngineOutputFile
The output file.
overwrite
Type: SystemBoolean
if set to true overwrite file.
See Also

Reference

CodeTemplate Class
RenderToFile Overload
CodeSmith.Engine Namespace


CodeTemplate.RenderToFile Method (String, IMergeStrategy)

CodeTemplateRenderToFile Method (String, IMergeStrategy)

Renders the template output to a file using a merge strategy.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void RenderToFile(
    string path,
    IMergeStrategy strategy
)
Public Sub RenderToFile (
    path As String,
    strategy As IMergeStrategy
)

Parameters

path
Type: SystemString
The output path.
strategy
Type: CodeSmith.EngineIMergeStrategy
The merge strategy to use.
See Also

Reference

CodeTemplate Class
RenderToFile Overload
CodeSmith.Engine Namespace


CodeTemplate.RenderToFile Method (String, Boolean)

CodeTemplateRenderToFile Method (String, Boolean)

Renders the template output to a file.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void RenderToFile(
    string path,
    bool overwrite
)
Public Sub RenderToFile (
    path As String,
    overwrite As Boolean
)

Parameters

path
Type: SystemString
The output file path.
overwrite
Type: SystemBoolean
if set to true overwrite file.
See Also

Reference

CodeTemplate Class
RenderToFile Overload
CodeSmith.Engine Namespace


CodeTemplate.RenderToFile Method (OutputFile, String, IMergeStrategy)

CodeTemplateRenderToFile Method (OutputFile, String, IMergeStrategy)

Renders the template output to a file using a merge strategy.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void RenderToFile(
    OutputFile outputFile,
    string sourcePath,
    IMergeStrategy strategy
)
Public Sub RenderToFile (
    outputFile As OutputFile,
    sourcePath As String,
    strategy As IMergeStrategy
)

Parameters

outputFile
Type: CodeSmith.EngineOutputFile
The output file.
sourcePath
Type: SystemString
The source file to base the merge on.
strategy
Type: CodeSmith.EngineIMergeStrategy
The merge strategy to use.
See Also

Reference

CodeTemplate Class
RenderToFile Overload
CodeSmith.Engine Namespace


CodeTemplate.RenderToFile Method (String, String, IMergeStrategy)

CodeTemplateRenderToFile Method (String, String, IMergeStrategy)

Renders the template output to a file using a merge strategy.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void RenderToFile(
    string path,
    string sourcePath,
    IMergeStrategy strategy
)
Public Sub RenderToFile (
    path As String,
    sourcePath As String,
    strategy As IMergeStrategy
)

Parameters

path
Type: SystemString
The output path.
sourcePath
Type: SystemString
The source file to base the merge on.
strategy
Type: CodeSmith.EngineIMergeStrategy
The merge strategy to use.
See Also

Reference

CodeTemplate Class
RenderToFile Overload
CodeSmith.Engine Namespace


CodeTemplate.RenderToFile Method (String, String, Boolean)

CodeTemplateRenderToFile Method (String, String, Boolean)

Renders the template output to a file.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void RenderToFile(
    string path,
    string dependentUpon,
    bool overwrite
)
Public Sub RenderToFile (
    path As String,
    dependentUpon As String,
    overwrite As Boolean
)

Parameters

path
Type: SystemString
The output file path.
dependentUpon
Type: SystemString
The file that the output is dependent upon.
overwrite
Type: SystemBoolean
if set to true overwrite file.
See Also

Reference

CodeTemplate Class
RenderToFile Overload
CodeSmith.Engine Namespace


CodeTemplate.RenderToString Method

CodeTemplateRenderToString Method

Overload List
 | Name | Description
Public method | RenderToString | Renders the template output to a String.
Public method | RenderToString(String, IMergeStrategy) | Renders the template output to a String.
Top
See Also

Reference

CodeTemplate Class
CodeSmith.Engine Namespace


CodeTemplate.RenderToString Method

CodeTemplateRenderToString Method

Renders the template output to a String.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string RenderToString()
Public Function RenderToString As String

Return Value

Type: String
See Also

Reference

CodeTemplate Class
RenderToString Overload
CodeSmith.Engine Namespace


CodeTemplate.RenderToString Method (String, IMergeStrategy)

CodeTemplateRenderToString Method (String, IMergeStrategy)

Renders the template output to a String.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string RenderToString(
    string sourcePath,
    IMergeStrategy strategy
)
Public Function RenderToString (
    sourcePath As String,
    strategy As IMergeStrategy
) As String

Parameters

sourcePath
Type: SystemString
strategy
Type: CodeSmith.EngineIMergeStrategy

Return Value

Type: String
See Also

Reference

CodeTemplate Class
RenderToString Overload
CodeSmith.Engine Namespace


CodeTemplate.RestorePropertiesFromHashtable Method

CodeTemplateRestorePropertiesFromHashtable Method

Restores the properties from a Hashtable.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void RestorePropertiesFromHashtable(
    Hashtable properties
)
Public Sub RestorePropertiesFromHashtable (
    properties As Hashtable
)

Parameters

properties
Type: System.CollectionsHashtable
Properties.
See Also

Reference

CodeTemplate Class
CodeSmith.Engine Namespace


CodeTemplate.RestorePropertiesFromPropertySet Method

CodeTemplateRestorePropertiesFromPropertySet Method

Overload List
 | Name | Description
Public method | RestorePropertiesFromPropertySet(PropertySet, String) |
Public method | RestorePropertiesFromPropertySet(PropertySet, String, Hashtable) |
Top
See Also

Reference

CodeTemplate Class
CodeSmith.Engine Namespace


CodeTemplate.RestorePropertiesFromPropertySet Method (PropertySet, String)

CodeTemplateRestorePropertiesFromPropertySet Method (PropertySet, String)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void RestorePropertiesFromPropertySet(
    PropertySet propertySet,
    string baseDirectory
)
Public Sub RestorePropertiesFromPropertySet (
    propertySet As PropertySet,
    baseDirectory As String
)

Parameters

propertySet
Type: CodeSmith.Engine.SchemaPropertySet
baseDirectory
Type: SystemString
See Also

Reference

CodeTemplate Class
RestorePropertiesFromPropertySet Overload
CodeSmith.Engine Namespace


CodeTemplate.RestorePropertiesFromPropertySet Method (PropertySet, String, Hashtable)

CodeTemplateRestorePropertiesFromPropertySet Method (PropertySet, String, Hashtable)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void RestorePropertiesFromPropertySet(
    PropertySet propertySet,
    string baseDirectory,
    Hashtable propertyOverrides
)
Public Sub RestorePropertiesFromPropertySet (
    propertySet As PropertySet,
    baseDirectory As String,
    propertyOverrides As Hashtable
)

Parameters

propertySet
Type: CodeSmith.Engine.SchemaPropertySet
baseDirectory
Type: SystemString
propertyOverrides
Type: System.CollectionsHashtable
See Also

Reference

CodeTemplate Class
RestorePropertiesFromPropertySet Overload
CodeSmith.Engine Namespace


CodeTemplate.RestorePropertiesFromSchema Method

CodeTemplateRestorePropertiesFromSchema Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void RestorePropertiesFromSchema(
    CodeSmithProject csp,
    string targetDirectory
)
Public Sub RestorePropertiesFromSchema (
    csp As CodeSmithProject,
    targetDirectory As String
)

Parameters

csp
Type: CodeSmith.Engine.SchemaCodeSmithProject
targetDirectory
Type: SystemString
See Also

Reference

CodeTemplate Class
CodeSmith.Engine Namespace


CodeTemplate.RestorePropertiesFromXml Method

CodeTemplateRestorePropertiesFromXml Method

Restores the properties from XML.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void RestorePropertiesFromXml(
    string xmlFragment,
    string baseDirectory
)
Public Sub RestorePropertiesFromXml (
    xmlFragment As String,
    baseDirectory As String
)

Parameters

xmlFragment
Type: SystemString
The XML fragment.
baseDirectory
Type: SystemString
The base directory to resolve file references.
See Also

Reference

CodeTemplate Class
CodeSmith.Engine Namespace


CodeTemplate.RestorePropertiesFromXmlFile Method

CodeTemplateRestorePropertiesFromXmlFile Method

Restores the properties from XML file.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void RestorePropertiesFromXmlFile(
    string xmlFilePath
)
Public Sub RestorePropertiesFromXmlFile (
    xmlFilePath As String
)

Parameters

xmlFilePath
Type: SystemString
XML file path.
See Also

Reference

CodeTemplate Class
CodeSmith.Engine Namespace


CodeTemplate.SavePropertiesToHashtable Method

CodeTemplateSavePropertiesToHashtable Method

Overload List
 | Name | Description
Public method | SavePropertiesToHashtable | Saves the properties to a Hashtable.
Public method | SavePropertiesToHashtable(Boolean) | Saves the properties to a Hashtable.
Top
See Also

Reference

CodeTemplate Class
CodeSmith.Engine Namespace


CodeTemplate.SavePropertiesToHashtable Method

CodeTemplateSavePropertiesToHashtable Method

Saves the properties to a Hashtable.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public Hashtable SavePropertiesToHashtable()
Public Function SavePropertiesToHashtable As Hashtable

Return Value

Type: Hashtable
See Also

Reference

CodeTemplate Class
SavePropertiesToHashtable Overload
CodeSmith.Engine Namespace


CodeTemplate.SavePropertiesToHashtable Method (Boolean)

CodeTemplateSavePropertiesToHashtable Method (Boolean)

Saves the properties to a Hashtable.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public Hashtable SavePropertiesToHashtable(
    bool includeNonBrowsable
)
Public Function SavePropertiesToHashtable (
    includeNonBrowsable As Boolean
) As Hashtable

Parameters

includeNonBrowsable
Type: SystemBoolean
Whether non-browsable properties should be included.

Return Value

Type: Hashtable
See Also

Reference

CodeTemplate Class
SavePropertiesToHashtable Overload
CodeSmith.Engine Namespace


CodeTemplate.SavePropertiesToPropertySet Method

CodeTemplateSavePropertiesToPropertySet Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public PropertySet SavePropertiesToPropertySet()
Public Function SavePropertiesToPropertySet As PropertySet

Return Value

Type: PropertySet
See Also

Reference

CodeTemplate Class
CodeSmith.Engine Namespace


CodeTemplate.SavePropertiesToXml Method

CodeTemplateSavePropertiesToXml Method

Overload List
 | Name | Description
Public method | SavePropertiesToXml | Saves the properties to XML.
Public method | SavePropertiesToXml(XmlWriter) | Saves the properties to XML.
Top
See Also

Reference

CodeTemplate Class
CodeSmith.Engine Namespace


CodeTemplate.SavePropertiesToXml Method

CodeTemplateSavePropertiesToXml Method

Saves the properties to XML.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string SavePropertiesToXml()
Public Function SavePropertiesToXml As String

Return Value

Type: String
See Also

Reference

CodeTemplate Class
SavePropertiesToXml Overload
CodeSmith.Engine Namespace


CodeTemplate.SavePropertiesToXml Method (XmlWriter)

CodeTemplateSavePropertiesToXml Method (XmlWriter)

Saves the properties to XML.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void SavePropertiesToXml(
    XmlWriter xmlwriter
)
Public Sub SavePropertiesToXml (
    xmlwriter As XmlWriter
)

Parameters

xmlwriter
Type: System.XmlXmlWriter
XmlWriter.
See Also

Reference

CodeTemplate Class
SavePropertiesToXml Overload
CodeSmith.Engine Namespace


CodeTemplate.SavePropertiesToXmlFile Method

CodeTemplateSavePropertiesToXmlFile Method

Saves the properties to an XML file.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void SavePropertiesToXmlFile(
    string xmlFilePath
)
Public Sub SavePropertiesToXmlFile (
    xmlFilePath As String
)

Parameters

xmlFilePath
Type: SystemString
XML file path.
See Also

Reference

CodeTemplate Class
CodeSmith.Engine Namespace


CodeTemplate.SetContextData Method

CodeTemplateSetContextData Method

Set the context data object for the template. Any items in the current ContextData object will be added to the new one. This method should only be called while a template is initializing.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected void SetContextData(
    NameValueCollection contextData
)
Protected Sub SetContextData (
    contextData As NameValueCollection
)

Parameters

contextData
Type: System.Collections.SpecializedNameValueCollection
The context data object.
See Also

Reference

CodeTemplate Class
CodeSmith.Engine Namespace


CodeTemplate.SetProperty Method

CodeTemplateSetProperty Method

Overload List
 | Name | Description
Public method | SetProperty(PropertyInfo, Object) | Sets the value for the specified property.
Public method | SetProperty(String, Object) | Sets the value for the specified property.
Public method | SetProperty(XmlNode, String) |
Top
See Also

Reference

CodeTemplate Class
CodeSmith.Engine Namespace


CodeTemplate.SetProperty Method (PropertyInfo, Object)

CodeTemplateSetProperty Method (PropertyInfo, Object)

Sets the value for the specified property.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void SetProperty(
    PropertyInfo propertyInfo,
    Object value
)
Public Sub SetProperty (
    propertyInfo As PropertyInfo,
    value As Object
)

Parameters

propertyInfo
Type: System.ReflectionPropertyInfo
Information about the target property.
value
Type: SystemObject
Value to assign.
See Also

Reference

CodeTemplate Class
SetProperty Overload
CodeSmith.Engine Namespace


CodeTemplate.SetProperty Method (String, Object)

CodeTemplateSetProperty Method (String, Object)

Sets the value for the specified property.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void SetProperty(
    string name,
    Object value
)
Public Sub SetProperty (
    name As String,
    value As Object
)

Parameters

name
Type: SystemString
Property name.
value
Type: SystemObject
Value to assign.
See Also

Reference

CodeTemplate Class
SetProperty Overload
CodeSmith.Engine Namespace


CodeTemplate.SetProperty Method (XmlNode, String)

CodeTemplateSetProperty Method (XmlNode, String)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void SetProperty(
    XmlNode propertyNode,
    string baseDirectory
)
Public Sub SetProperty (
    propertyNode As XmlNode,
    baseDirectory As String
)

Parameters

propertyNode
Type: System.XmlXmlNode
baseDirectory
Type: SystemString
See Also

Reference

CodeTemplate Class
SetProperty Overload
CodeSmith.Engine Namespace


CodeTemplate.SetPropertyAttribute Method

CodeTemplateSetPropertyAttribute Method

Sets the property attribute. Property attributes can be used to store various information at the property level.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual void SetPropertyAttribute(
    string propertyName,
    string attributeName,
    string attributeValue
)
Public Overridable Sub SetPropertyAttribute (
    propertyName As String,
    attributeName As String,
    attributeValue As String
)

Parameters

propertyName
Type: SystemString
Name of the property.
attributeName
Type: SystemString
Name of the attribute.
attributeValue
Type: SystemString
The attribute value.
See Also

Reference

CodeTemplate Class
CodeSmith.Engine Namespace


CodeTemplate.SetPropertyDefaults Method

CodeTemplateSetPropertyDefaults Method

This method is overridden in templates to set default values in a template instance.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual void SetPropertyDefaults()
Protected Overridable Sub SetPropertyDefaults
See Also

Reference

CodeTemplate Class
CodeSmith.Engine Namespace


CodeTemplate.SetTemplateAttribute Method

CodeTemplateSetTemplateAttribute Method

Sets the template attribute. Template attributes can be used to store various information at the template level.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual void SetTemplateAttribute(
    string attributeName,
    string attributeValue
)
Public Overridable Sub SetTemplateAttribute (
    attributeName As String,
    attributeValue As String
)

Parameters

attributeName
Type: SystemString
Name of the attribute.
attributeValue
Type: SystemString
The attribute value.
See Also

Reference

CodeTemplate Class
CodeSmith.Engine Namespace


CodeTemplate.SetUnknownDirectiveAttributes Method

CodeTemplateSetUnknownDirectiveAttributes Method

This method is overridden in templates to set unknown directive attributes in the ContextData.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual void SetUnknownDirectiveAttributes()
Protected Overridable Sub SetUnknownDirectiveAttributes
See Also

Reference

CodeTemplate Class
CodeSmith.Engine Namespace


CodeTemplate.Validate Method

CodeTemplateValidate Method

Validates this template instance.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void Validate()
Public Sub Validate
See Also

Reference

CodeTemplate Class
CodeSmith.Engine Namespace


CodeTemplate Events

The CodeTemplate type exposes the following members.

Events
 | Name | Description
Public event | OutputRegistered | Raised when an output file is registered
Public event | PreOutputWritten | Raised prior to an output being written to disk
Public event | PropertiesLoaded |
Public event | PropertiesSaved |
Public event | PropertyChanged |
Public event | ReferenceRegistered | Occurs when a reference is registered.
Top
See Also

Reference

CodeTemplate Class
CodeSmith.Engine Namespace


CodeTemplate.OutputRegistered Event

CodeTemplateOutputRegistered Event

Raised when an output file is registered

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public event OutputRegisteredEventHandler OutputRegistered
Public Event OutputRegistered As OutputRegisteredEventHandler

Value

Type: CodeSmith.EngineOutputRegisteredEventHandler
See Also

Reference

CodeTemplate Class
CodeSmith.Engine Namespace


CodeTemplate.PreOutputWritten Event

CodeTemplatePreOutputWritten Event

Raised prior to an output being written to disk

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public event OutputCancelEventHandler PreOutputWritten
Public Event PreOutputWritten As OutputCancelEventHandler

Value

Type: CodeSmith.EngineOutputCancelEventHandler
See Also

Reference

CodeTemplate Class
CodeSmith.Engine Namespace


CodeTemplate.PropertiesLoaded Event

CodeTemplatePropertiesLoaded Event

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public event EventHandler PropertiesLoaded
Public Event PropertiesLoaded As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

CodeTemplate Class
CodeSmith.Engine Namespace


CodeTemplate.PropertiesSaved Event

CodeTemplatePropertiesSaved Event

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public event EventHandler PropertiesSaved
Public Event PropertiesSaved As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

CodeTemplate Class
CodeSmith.Engine Namespace


CodeTemplate.PropertyChanged Event

CodeTemplatePropertyChanged Event

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public event PropertyChangedEventHandler PropertyChanged
Public Event PropertyChanged As PropertyChangedEventHandler

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

CodeTemplate Class
CodeSmith.Engine Namespace


CodeTemplate.ReferenceRegistered Event

CodeTemplateReferenceRegistered Event

Occurs when a reference is registered.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public event EventHandler<ItemRegisteredEventArgs> ReferenceRegistered
Public Event ReferenceRegistered As EventHandler(Of ItemRegisteredEventArgs)

Value

Type: SystemEventHandler ItemRegisteredEventArgs
See Also

Reference

CodeTemplate Class
CodeSmith.Engine Namespace


CodeTemplate Fields

The CodeTemplate type exposes the following members.

Fields
 | Name | Description
Protected field | _childControlsCreated | (Inherited from Control.)
Protected field | _codeTemplate | (Inherited from Control.)
Protected field | _controls | (Inherited from Control.)
Protected field | _parent | (Inherited from Control.)
Protected field | _visible | (Inherited from Control.)
Top
See Also

Reference

CodeTemplate Class
CodeSmith.Engine Namespace


CodeTemplateCompiler Class

This class can be used to compile templates.
Inheritance Hierarchy
SystemObject
DisposableBase
CodeSmith.EngineCodeTemplateCompiler

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class CodeTemplateCompiler : DisposableBase
Public Class CodeTemplateCompiler
    Inherits DisposableBase

The CodeTemplateCompiler type exposes the following members.

Constructors
 | Name | Description
Public method | CodeTemplateCompiler(ICodeTemplateInfo) | Creates a new CodeTemplateCompiler instance.
Public method | CodeTemplateCompiler(String) | Creates a new CodeTemplateCompiler instance.
Top
Properties
 | Name | Description
Public property | CodeTemplateInfo | Gets the code template information.
Public property | CompiledAssembly | Provides access to the compiled assembly.
Public property | CompileResult |
Public property | CompilerOutputWriter | Gets or sets the compiler output writer.
Public property | Debug | Gets or sets a value indicating whether the template should be compiled in debug mode or not.
Public property | Errors | Gets the errors.
Public property | GeneratedAssemblySourceCode | Provides access to the generated source code.
Public property | KeepTempFiles | Gets or sets a value indicating whether the temp files should be kept.
Public property | LinePragmas | Gets or sets a value indicating whether line pragmas should be output in the compiled source code.
Public property | Namespace | Namespace that the compiled template should be a member of.
Public property | TypeName | Gets or sets the type name of the compiled template.
Top
Methods
 | Name | Description
Public method | Compile | Compiles the specified template and outputs an assembly to the output path.
Public method | Compile(Boolean) | Compiles the specified template and outputs an assembly to the output path.
Public method | Compile(String) | Compiles the specified template and outputs an assembly to the output path.
Public method | Compile(String, Boolean) | Compiles the specified template and outputs an assembly to the output path.
Public method | Compile(String, Boolean, Boolean) | Compiles the specified template and outputs an assembly to the output path.
Public method | CreateInstance | Creates an instance of the compiled template. You must compile the template first.
Public method | Dispose | (Inherited from DisposableBase.)
Protected method | Dispose(Boolean) | (Inherited from DisposableBase.)
Protected method | DisposeManagedResources | (Inherited from DisposableBase.)
Protected method | DisposeUnmanagedResources | (Inherited from DisposableBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | (Inherited from DisposableBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSmith.Engine Namespace


CodeTemplateCompiler Constructor

Overload List
 | Name | Description
Public method | CodeTemplateCompiler(ICodeTemplateInfo) | Creates a new CodeTemplateCompiler instance.
Public method | CodeTemplateCompiler(String) | Creates a new CodeTemplateCompiler instance.
Top
See Also

Reference

CodeTemplateCompiler Class
CodeSmith.Engine Namespace


CodeTemplateCompiler Constructor (ICodeTemplateInfo)

Creates a new CodeTemplateCompiler instance.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CodeTemplateCompiler(
    ICodeTemplateInfo codeTemplateInfo
)
Public Sub New (
    codeTemplateInfo As ICodeTemplateInfo
)

Parameters

codeTemplateInfo
Type: CodeSmith.EngineICodeTemplateInfo
Code template info.
See Also

Reference

CodeTemplateCompiler Class
CodeTemplateCompiler Overload
CodeSmith.Engine Namespace


CodeTemplateCompiler Constructor (String)

Creates a new CodeTemplateCompiler instance.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CodeTemplateCompiler(
    string path
)
Public Sub New (
    path As String
)

Parameters

path
Type: SystemString
Path.
See Also

Reference

CodeTemplateCompiler Class
CodeTemplateCompiler Overload
CodeSmith.Engine Namespace


CodeTemplateCompiler Properties

The CodeTemplateCompiler type exposes the following members.

Properties
 | Name | Description
Public property | CodeTemplateInfo | Gets the code template information.
Public property | CompiledAssembly | Provides access to the compiled assembly.
Public property | CompileResult |
Public property | CompilerOutputWriter | Gets or sets the compiler output writer.
Public property | Debug | Gets or sets a value indicating whether the template should be compiled in debug mode or not.
Public property | Errors | Gets the errors.
Public property | GeneratedAssemblySourceCode | Provides access to the generated source code.
Public property | KeepTempFiles | Gets or sets a value indicating whether the temp files should be kept.
Public property | LinePragmas | Gets or sets a value indicating whether line pragmas should be output in the compiled source code.
Public property | Namespace | Namespace that the compiled template should be a member of.
Public property | TypeName | Gets or sets the type name of the compiled template.
Top
See Also

Reference

CodeTemplateCompiler Class
CodeSmith.Engine Namespace


CodeTemplateCompiler.CodeTemplateInfo Property

CodeTemplateCompilerCodeTemplateInfo Property

Gets the code template information.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ICodeTemplateInfo CodeTemplateInfo { get; }
Public ReadOnly Property CodeTemplateInfo As ICodeTemplateInfo
    Get

Property Value

Type: ICodeTemplateInfo
See Also

Reference

CodeTemplateCompiler Class
CodeSmith.Engine Namespace


CodeTemplateCompiler.CompiledAssembly Property

CodeTemplateCompilerCompiledAssembly Property

Provides access to the compiled assembly.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public Assembly CompiledAssembly { get; }
Public ReadOnly Property CompiledAssembly As Assembly
    Get

Property Value

Type: Assembly
See Also

Reference

CodeTemplateCompiler Class
CodeSmith.Engine Namespace


CodeTemplateCompiler.CompileResult Property

CodeTemplateCompilerCompileResult Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CompileTemplateResult CompileResult { get; }
Public ReadOnly Property CompileResult As CompileTemplateResult
    Get

Property Value

Type: CompileTemplateResult
See Also

Reference

CodeTemplateCompiler Class
CodeSmith.Engine Namespace


CodeTemplateCompiler.CompilerOutputWriter Property

CodeTemplateCompilerCompilerOutputWriter Property

Gets or sets the compiler output writer.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public TextWriter CompilerOutputWriter { get; set; }
Public Property CompilerOutputWriter As TextWriter
    Get
    Set

Property Value

Type: TextWriter
See Also

Reference

CodeTemplateCompiler Class
CodeSmith.Engine Namespace


CodeTemplateCompiler.Debug Property

CodeTemplateCompilerDebug Property

Gets or sets a value indicating whether the template should be compiled in debug mode or not.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool Debug { get; set; }
Public Property Debug As Boolean
    Get
    Set

Property Value

Type: Boolean
true if debug; otherwise, false.
See Also

Reference

CodeTemplateCompiler Class
CodeSmith.Engine Namespace


CodeTemplateCompiler.Errors Property

CodeTemplateCompilerErrors Property

Gets the errors.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CompilerErrorCollection Errors { get; }
Public ReadOnly Property Errors As CompilerErrorCollection
    Get

Property Value

Type: CompilerErrorCollection
See Also

Reference

CodeTemplateCompiler Class
CodeSmith.Engine Namespace


CodeTemplateCompiler.GeneratedAssemblySourceCode Property

CodeTemplateCompilerGeneratedAssemblySourceCode Property

Provides access to the generated source code.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string GeneratedAssemblySourceCode { get; }
Public ReadOnly Property GeneratedAssemblySourceCode As String
    Get

Property Value

Type: String
See Also

Reference

CodeTemplateCompiler Class
CodeSmith.Engine Namespace


CodeTemplateCompiler.KeepTempFiles Property

CodeTemplateCompilerKeepTempFiles Property

Gets or sets a value indicating whether the temp files should be kept.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool KeepTempFiles { get; set; }
Public Property KeepTempFiles As Boolean
    Get
    Set

Property Value

Type: Boolean
true if you want to keep the temp files; otherwise, false.
See Also

Reference

CodeTemplateCompiler Class
CodeSmith.Engine Namespace


CodeTemplateCompiler.LinePragmas Property

CodeTemplateCompilerLinePragmas Property

Gets or sets a value indicating whether line pragmas should be output in the compiled source code.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool LinePragmas { get; set; }
Public Property LinePragmas As Boolean
    Get
    Set

Property Value

Type: Boolean
true if line pragmas should be generated; otherwise, false.
See Also

Reference

CodeTemplateCompiler Class
CodeSmith.Engine Namespace


CodeTemplateCompiler.Namespace Property

CodeTemplateCompilerNamespace Property

Namespace that the compiled template should be a member of.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string Namespace { get; set; }
Public Property Namespace As String
    Get
    Set

Property Value

Type: String
See Also

Reference

CodeTemplateCompiler Class
CodeSmith.Engine Namespace


CodeTemplateCompiler.TypeName Property

CodeTemplateCompilerTypeName Property

Gets or sets the type name of the compiled template.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string TypeName { get; set; }
Public Property TypeName As String
    Get
    Set

Property Value

Type: String
See Also

Reference

CodeTemplateCompiler Class
CodeSmith.Engine Namespace


CodeTemplateCompiler Methods

The CodeTemplateCompiler type exposes the following members.

Methods
 | Name | Description
Public method | Compile | Compiles the specified template and outputs an assembly to the output path.
Public method | Compile(Boolean) | Compiles the specified template and outputs an assembly to the output path.
Public method | Compile(String) | Compiles the specified template and outputs an assembly to the output path.
Public method | Compile(String, Boolean) | Compiles the specified template and outputs an assembly to the output path.
Public method | Compile(String, Boolean, Boolean) | Compiles the specified template and outputs an assembly to the output path.
Public method | CreateInstance | Creates an instance of the compiled template. You must compile the template first.
Public method | Dispose | (Inherited from DisposableBase.)
Protected method | Dispose(Boolean) | (Inherited from DisposableBase.)
Protected method | DisposeManagedResources | (Inherited from DisposableBase.)
Protected method | DisposeUnmanagedResources | (Inherited from DisposableBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | (Inherited from DisposableBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeTemplateCompiler Class
CodeSmith.Engine Namespace


CodeTemplateCompiler.Compile Method

CodeTemplateCompilerCompile Method

Overload List
 | Name | Description
Public method | Compile | Compiles the specified template and outputs an assembly to the output path.
Public method | Compile(Boolean) | Compiles the specified template and outputs an assembly to the output path.
Public method | Compile(String) | Compiles the specified template and outputs an assembly to the output path.
Public method | Compile(String, Boolean) | Compiles the specified template and outputs an assembly to the output path.
Public method | Compile(String, Boolean, Boolean) | Compiles the specified template and outputs an assembly to the output path.
Top
See Also

Reference

CodeTemplateCompiler Class
CodeSmith.Engine Namespace


CodeTemplateCompiler.Compile Method

CodeTemplateCompilerCompile Method

Compiles the specified template and outputs an assembly to the output path.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void Compile()
Public Sub Compile
See Also

Reference

CodeTemplateCompiler Class
Compile Overload
CodeSmith.Engine Namespace


CodeTemplateCompiler.Compile Method (Boolean)

CodeTemplateCompilerCompile Method (Boolean)

Compiles the specified template and outputs an assembly to the output path.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void Compile(
    bool forceRecompile
)
Public Sub Compile (
    forceRecompile As Boolean
)

Parameters

forceRecompile
Type: SystemBoolean
Force recompile.
See Also

Reference

CodeTemplateCompiler Class
Compile Overload
CodeSmith.Engine Namespace


CodeTemplateCompiler.Compile Method (String)

CodeTemplateCompilerCompile Method (String)

Compiles the specified template and outputs an assembly to the output path.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void Compile(
    string outputPath
)
Public Sub Compile (
    outputPath As String
)

Parameters

outputPath
Type: SystemString
Output path.
See Also

Reference

CodeTemplateCompiler Class
Compile Overload
CodeSmith.Engine Namespace


CodeTemplateCompiler.Compile Method (String, Boolean)

CodeTemplateCompilerCompile Method (String, Boolean)

Compiles the specified template and outputs an assembly to the output path.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void Compile(
    string outputPath,
    bool forceRecompile
)
Public Sub Compile (
    outputPath As String,
    forceRecompile As Boolean
)

Parameters

outputPath
Type: SystemString
Output path.
forceRecompile
Type: SystemBoolean
Force recompile.
See Also

Reference

CodeTemplateCompiler Class
Compile Overload
CodeSmith.Engine Namespace


CodeTemplateCompiler.Compile Method (String, Boolean, Boolean)

CodeTemplateCompilerCompile Method (String, Boolean, Boolean)

Compiles the specified template and outputs an assembly to the output path.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void Compile(
    string outputPath,
    bool forceRecompile,
    bool inMemory
)
Public Sub Compile (
    outputPath As String,
    forceRecompile As Boolean,
    inMemory As Boolean
)

Parameters

outputPath
Type: SystemString
Output path.
forceRecompile
Type: SystemBoolean
Force recompile.
inMemory
Type: SystemBoolean
See Also

Reference

CodeTemplateCompiler Class
Compile Overload
CodeSmith.Engine Namespace


CodeTemplateCompiler.CreateInstance Method

CodeTemplateCompilerCreateInstance Method

Creates an instance of the compiled template. You must compile the template first.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CodeTemplate CreateInstance()
Public Function CreateInstance As CodeTemplate

Return Value

Type: CodeTemplate
See Also

Reference

CodeTemplateCompiler Class
CodeSmith.Engine Namespace


CodeTemplateInfo Class

Inheritance Hierarchy
SystemObject
DisposableBase
CodeSmith.EngineCodeTemplateInfo
CodeSmith.EngineInMemoryCodeTemplateInfo

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
public class CodeTemplateInfo : DisposableBase,
    ICodeTemplateInfo
<SerializableAttribute>
Public Class CodeTemplateInfo
    Inherits DisposableBase
    Implements ICodeTemplateInfo

The CodeTemplateInfo type exposes the following members.

Constructors
 | Name | Description
Public method | CodeTemplateInfo | Initializes a new instance of the CodeTemplateInfo class
Public method | CodeTemplateInfo(String) | Initializes a new instance of the CodeTemplateInfo class
Top
Properties
 | Name | Description
Public property | AssemblyDependencies |
Public property | CodeBehind |
Public property | CodeSmithVersion |
Public property | CompilerVersion |
Public property | ContentHashCode | Gets the hash code based on the template content and all template Dependencies.
Public property | DateCreated | Gets the date the template was created.
Public property | DateModified | Gets the date the template was modified.
Public property | Description | Gets the description.
Public property | DirectoryName | Gets the name of the directory the template is located in.
Public property | FileDependencies |
Public property | FileName | Gets the name of the template file.
Public property | FullPath | Gets the full path to the template.
Public property | InMemory |
Public property | Language | Gets the template language.
Public property | OutputType | Gets the type of the output for this template.
Public property | TargetLanguage | Gets the target language.
Public property | TemplateEncoding | Gets the response encoding.
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from DisposableBase.)
Protected method | Dispose(Boolean) | (Inherited from DisposableBase.)
Protected method | DisposeManagedResources | (Inherited from DisposableBase.)
Protected method | DisposeUnmanagedResources | (Inherited from DisposableBase.)
Protected method | EnsureTemplateInfo |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | (Inherited from DisposableBase.)
 | GetCodeTemplateInfo |
 | GetCodeTemplateInfoByDirectory |
Public method | GetContent |
Protected method | GetFileInfo |
Public method | GetHashCode | Gets the hash code based on the template dependencies. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnLanguageChanged |
Public method | Refresh |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | LanguageChanged |
Top
Fields
 | Name | Description
Protected field | _assemblyDependencies |
Protected field | _codeBehind |
Protected field | _compilerVersion |
Protected field | _dateCreated |
Protected field | _dateModified |
Protected field | _description |
Protected field | _directoryName |
Protected field | _fileContent |
Protected field | _fileDependencies |
Protected field | _fileName |
Protected field | _fullPath |
Protected field | _hashCode |
Protected field | _inMemory |
Protected field | _language |
Protected field | _outputType |
Protected field | _targetLanguage |
Protected field | _templateEncoding |
Protected field | _templateInfoRetrieved |
Top
See Also

Reference

CodeSmith.Engine Namespace


CodeTemplateInfo Constructor

Overload List
 | Name | Description
Public method | CodeTemplateInfo | Initializes a new instance of the CodeTemplateInfo class
Public method | CodeTemplateInfo(String) | Initializes a new instance of the CodeTemplateInfo class
Top
See Also

Reference

CodeTemplateInfo Class
CodeSmith.Engine Namespace


CodeTemplateInfo Constructor

Initializes a new instance of the CodeTemplateInfo class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CodeTemplateInfo()
Public Sub New
See Also

Reference

CodeTemplateInfo Class
CodeTemplateInfo Overload
CodeSmith.Engine Namespace


CodeTemplateInfo Constructor (String)

Initializes a new instance of the CodeTemplateInfo class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CodeTemplateInfo(
    string path
)
Public Sub New (
    path As String
)

Parameters

path
Type: SystemString
See Also

Reference

CodeTemplateInfo Class
CodeTemplateInfo Overload
CodeSmith.Engine Namespace


CodeTemplateInfo Properties

The CodeTemplateInfo type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyDependencies |
Public property | CodeBehind |
Public property | CodeSmithVersion |
Public property | CompilerVersion |
Public property | ContentHashCode | Gets the hash code based on the template content and all template Dependencies.
Public property | DateCreated | Gets the date the template was created.
Public property | DateModified | Gets the date the template was modified.
Public property | Description | Gets the description.
Public property | DirectoryName | Gets the name of the directory the template is located in.
Public property | FileDependencies |
Public property | FileName | Gets the name of the template file.
Public property | FullPath | Gets the full path to the template.
Public property | InMemory |
Public property | Language | Gets the template language.
Public property | OutputType | Gets the type of the output for this template.
Public property | TargetLanguage | Gets the target language.
Public property | TemplateEncoding | Gets the response encoding.
Top
See Also

Reference

CodeTemplateInfo Class
CodeSmith.Engine Namespace


CodeTemplateInfo.AssemblyDependencies Property

CodeTemplateInfoAssemblyDependencies Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string[] AssemblyDependencies { get; }
Public ReadOnly Property AssemblyDependencies As String()
    Get

Property Value

Type: String

Implements

ICodeTemplateInfoAssemblyDependencies
See Also

Reference

CodeTemplateInfo Class
CodeSmith.Engine Namespace


CodeTemplateInfo.CodeBehind Property

CodeTemplateInfoCodeBehind Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string CodeBehind { get; }
Public ReadOnly Property CodeBehind As String
    Get

Property Value

Type: String

Implements

ICodeTemplateInfoCodeBehind
See Also

Reference

CodeTemplateInfo Class
CodeSmith.Engine Namespace


CodeTemplateInfo.CodeSmithVersion Property

CodeTemplateInfoCodeSmithVersion Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string CodeSmithVersion { get; }
Public ReadOnly Property CodeSmithVersion As String
    Get

Property Value

Type: String

Implements

ICodeTemplateInfoCodeSmithVersion
See Also

Reference

CodeTemplateInfo Class
CodeSmith.Engine Namespace


CodeTemplateInfo.CompilerVersion Property

CodeTemplateInfoCompilerVersion Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string CompilerVersion { get; }
Public ReadOnly Property CompilerVersion As String
    Get

Property Value

Type: String
See Also

Reference

CodeTemplateInfo Class
CodeSmith.Engine Namespace


CodeTemplateInfo.ContentHashCode Property

CodeTemplateInfoContentHashCode Property

Gets the hash code based on the template content and all template Dependencies.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public int ContentHashCode { get; }
Public ReadOnly Property ContentHashCode As Integer
    Get

Property Value

Type: Int32
See Also

Reference

CodeTemplateInfo Class
CodeSmith.Engine Namespace


CodeTemplateInfo.DateCreated Property

CodeTemplateInfoDateCreated Property

Gets the date the template was created.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public DateTime DateCreated { get; }
Public ReadOnly Property DateCreated As DateTime
    Get

Property Value

Type: DateTime

Implements

ICodeTemplateInfoDateCreated
See Also

Reference

CodeTemplateInfo Class
CodeSmith.Engine Namespace


CodeTemplateInfo.DateModified Property

CodeTemplateInfoDateModified Property

Gets the date the template was modified.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public DateTime DateModified { get; }
Public ReadOnly Property DateModified As DateTime
    Get

Property Value

Type: DateTime

Implements

ICodeTemplateInfoDateModified
See Also

Reference

CodeTemplateInfo Class
CodeSmith.Engine Namespace


CodeTemplateInfo.Description Property

CodeTemplateInfoDescription Property

Gets the description.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string Description { get; }
Public ReadOnly Property Description As String
    Get

Property Value

Type: String

Implements

ICodeTemplateInfoDescription
See Also

Reference

CodeTemplateInfo Class
CodeSmith.Engine Namespace


CodeTemplateInfo.DirectoryName Property

CodeTemplateInfoDirectoryName Property

Gets the name of the directory the template is located in.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string DirectoryName { get; }
Public ReadOnly Property DirectoryName As String
    Get

Property Value

Type: String

Implements

ICodeTemplateInfoDirectoryName
See Also

Reference

CodeTemplateInfo Class
CodeSmith.Engine Namespace


CodeTemplateInfo.FileDependencies Property

CodeTemplateInfoFileDependencies Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string[] FileDependencies { get; }
Public ReadOnly Property FileDependencies As String()
    Get

Property Value

Type: String

Implements

ICodeTemplateInfoFileDependencies
See Also

Reference

CodeTemplateInfo Class
CodeSmith.Engine Namespace


CodeTemplateInfo.FileName Property

CodeTemplateInfoFileName Property

Gets the name of the template file.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string FileName { get; }
Public ReadOnly Property FileName As String
    Get

Property Value

Type: String

Implements

ICodeTemplateInfoFileName
See Also

Reference

CodeTemplateInfo Class
CodeSmith.Engine Namespace


CodeTemplateInfo.FullPath Property

CodeTemplateInfoFullPath Property

Gets the full path to the template.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string FullPath { get; set; }
Public Property FullPath As String
    Get
    Set

Property Value

Type: String

Implements

ICodeTemplateInfoFullPath
See Also

Reference

CodeTemplateInfo Class
CodeSmith.Engine Namespace


CodeTemplateInfo.InMemory Property

CodeTemplateInfoInMemory Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool InMemory { get; }
Public ReadOnly Property InMemory As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

CodeTemplateInfo Class
CodeSmith.Engine Namespace


CodeTemplateInfo.Language Property

CodeTemplateInfoLanguage Property

Gets the template language.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string Language { get; }
Public ReadOnly Property Language As String
    Get

Property Value

Type: String

Implements

ICodeTemplateInfoLanguage
See Also

Reference

CodeTemplateInfo Class
CodeSmith.Engine Namespace


CodeTemplateInfo.OutputType Property

CodeTemplateInfoOutputType Property

Gets the type of the output for this template.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CodeTemplateOutputType OutputType { get; }
Public ReadOnly Property OutputType As CodeTemplateOutputType
    Get

Property Value

Type: CodeTemplateOutputType
The type of the output.

Implements

ICodeTemplateInfoOutputType
See Also

Reference

CodeTemplateInfo Class
CodeSmith.Engine Namespace


CodeTemplateInfo.TargetLanguage Property

CodeTemplateInfoTargetLanguage Property

Gets the target language.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string TargetLanguage { get; }
Public ReadOnly Property TargetLanguage As String
    Get

Property Value

Type: String

Implements

ICodeTemplateInfoTargetLanguage
See Also

Reference

CodeTemplateInfo Class
CodeSmith.Engine Namespace


CodeTemplateInfo.TemplateEncoding Property

CodeTemplateInfoTemplateEncoding Property

Gets the response encoding.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string TemplateEncoding { get; }
Public ReadOnly Property TemplateEncoding As String
    Get

Property Value

Type: String

Implements

ICodeTemplateInfoTemplateEncoding
See Also

Reference

CodeTemplateInfo Class
CodeSmith.Engine Namespace


CodeTemplateInfo Methods

The CodeTemplateInfo type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from DisposableBase.)
Protected method | Dispose(Boolean) | (Inherited from DisposableBase.)
Protected method | DisposeManagedResources | (Inherited from DisposableBase.)
Protected method | DisposeUnmanagedResources | (Inherited from DisposableBase.)
Protected method | EnsureTemplateInfo |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | (Inherited from DisposableBase.)
 | GetCodeTemplateInfo |
 | GetCodeTemplateInfoByDirectory |
Public method | GetContent |
Protected method | GetFileInfo |
Public method | GetHashCode | Gets the hash code based on the template dependencies. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnLanguageChanged |
Public method | Refresh |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeTemplateInfo Class
CodeSmith.Engine Namespace


CodeTemplateInfo.EnsureTemplateInfo Method

CodeTemplateInfoEnsureTemplateInfo Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected void EnsureTemplateInfo()
Protected Sub EnsureTemplateInfo
See Also

Reference

CodeTemplateInfo Class
CodeSmith.Engine Namespace


CodeTemplateInfo.GetCodeTemplateInfo Method

CodeTemplateInfoGetCodeTemplateInfo Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static CodeTemplateInfo GetCodeTemplateInfo(
    string path
)
Public Shared Function GetCodeTemplateInfo (
    path As String
) As CodeTemplateInfo

Parameters

path
Type: SystemString

Return Value

Type: CodeTemplateInfo
See Also

Reference

CodeTemplateInfo Class
CodeSmith.Engine Namespace


CodeTemplateInfo.GetCodeTemplateInfoByDirectory Method

CodeTemplateInfoGetCodeTemplateInfoByDirectory Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static CodeTemplateInfo[] GetCodeTemplateInfoByDirectory(
    string directory,
    bool includeSubDirectories
)
Public Shared Function GetCodeTemplateInfoByDirectory (
    directory As String,
    includeSubDirectories As Boolean
) As CodeTemplateInfo()

Parameters

directory
Type: SystemString
includeSubDirectories
Type: SystemBoolean

Return Value

Type: CodeTemplateInfo
See Also

Reference

CodeTemplateInfo Class
CodeSmith.Engine Namespace


CodeTemplateInfo.GetContent Method

CodeTemplateInfoGetContent Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual string GetContent()
Public Overridable Function GetContent As String

Return Value

Type: String

Implements

ICodeTemplateInfoGetContent
See Also

Reference

CodeTemplateInfo Class
CodeSmith.Engine Namespace


CodeTemplateInfo.GetFileInfo Method

CodeTemplateInfoGetFileInfo Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected void GetFileInfo()
Protected Sub GetFileInfo
See Also

Reference

CodeTemplateInfo Class
CodeSmith.Engine Namespace


CodeTemplateInfo.GetHashCode Method

CodeTemplateInfoGetHashCode Method

Gets the hash code based on the template dependencies.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Field Value

Type: Int32
See Also

Reference

CodeTemplateInfo Class
CodeSmith.Engine Namespace


CodeTemplateInfo.OnLanguageChanged Method

CodeTemplateInfoOnLanguageChanged Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual void OnLanguageChanged(
    EventArgs e
)
Protected Overridable Sub OnLanguageChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
See Also

Reference

CodeTemplateInfo Class
CodeSmith.Engine Namespace


CodeTemplateInfo.Refresh Method

CodeTemplateInfoRefresh Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual void Refresh()
Public Overridable Sub Refresh

Implements

ICodeTemplateInfoRefresh
See Also

Reference

CodeTemplateInfo Class
CodeSmith.Engine Namespace


CodeTemplateInfo Events

The CodeTemplateInfo type exposes the following members.

Events
 | Name | Description
Public event | LanguageChanged |
Top
See Also

Reference

CodeTemplateInfo Class
CodeSmith.Engine Namespace


CodeTemplateInfo.LanguageChanged Event

CodeTemplateInfoLanguageChanged Event

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public event EventHandler LanguageChanged
Public Event LanguageChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

CodeTemplateInfo Class
CodeSmith.Engine Namespace


CodeTemplateInfo Fields

The CodeTemplateInfo type exposes the following members.

Fields
 | Name | Description
Protected field | _assemblyDependencies |
Protected field | _codeBehind |
Protected field | _compilerVersion |
Protected field | _dateCreated |
Protected field | _dateModified |
Protected field | _description |
Protected field | _directoryName |
Protected field | _fileContent |
Protected field | _fileDependencies |
Protected field | _fileName |
Protected field | _fullPath |
Protected field | _hashCode |
Protected field | _inMemory |
Protected field | _language |
Protected field | _outputType |
Protected field | _targetLanguage |
Protected field | _templateEncoding |
Protected field | _templateInfoRetrieved |
Top
See Also

Reference

CodeTemplateInfo Class
CodeSmith.Engine Namespace


CodeTemplateInfo._assemblyDependencies Field

CodeTemplateInfo_assemblyDependencies Field

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected string[] _assemblyDependencies
Protected _assemblyDependencies As String()

Field Value

Type: String
See Also

Reference

CodeTemplateInfo Class
CodeSmith.Engine Namespace


CodeTemplateInfo._codeBehind Field

CodeTemplateInfo_codeBehind Field

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected string _codeBehind
Protected _codeBehind As String

Field Value

Type: String
See Also

Reference

CodeTemplateInfo Class
CodeSmith.Engine Namespace


CodeTemplateInfo._compilerVersion Field

CodeTemplateInfo_compilerVersion Field

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected string _compilerVersion
Protected _compilerVersion As String

Field Value

Type: String
See Also

Reference

CodeTemplateInfo Class
CodeSmith.Engine Namespace


CodeTemplateInfo._dateCreated Field

CodeTemplateInfo_dateCreated Field

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected DateTime _dateCreated
Protected _dateCreated As DateTime

Field Value

Type: DateTime
See Also

Reference

CodeTemplateInfo Class
CodeSmith.Engine Namespace


CodeTemplateInfo._dateModified Field

CodeTemplateInfo_dateModified Field

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected DateTime _dateModified
Protected _dateModified As DateTime

Field Value

Type: DateTime
See Also

Reference

CodeTemplateInfo Class
CodeSmith.Engine Namespace


CodeTemplateInfo._description Field

CodeTemplateInfo_description Field

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected string _description
Protected _description As String

Field Value

Type: String
See Also

Reference

CodeTemplateInfo Class
CodeSmith.Engine Namespace


CodeTemplateInfo._directoryName Field

CodeTemplateInfo_directoryName Field

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected string _directoryName
Protected _directoryName As String

Field Value

Type: String
See Also

Reference

CodeTemplateInfo Class
CodeSmith.Engine Namespace


CodeTemplateInfo._fileContent Field

CodeTemplateInfo_fileContent Field

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected string _fileContent
Protected _fileContent As String

Field Value

Type: String
See Also

Reference

CodeTemplateInfo Class
CodeSmith.Engine Namespace


CodeTemplateInfo._fileDependencies Field

CodeTemplateInfo_fileDependencies Field

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected string[] _fileDependencies
Protected _fileDependencies As String()

Field Value

Type: String
See Also

Reference

CodeTemplateInfo Class
CodeSmith.Engine Namespace


CodeTemplateInfo._fileName Field

CodeTemplateInfo_fileName Field

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected string _fileName
Protected _fileName As String

Field Value

Type: String
See Also

Reference

CodeTemplateInfo Class
CodeSmith.Engine Namespace


CodeTemplateInfo._fullPath Field

CodeTemplateInfo_fullPath Field

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected string _fullPath
Protected _fullPath As String

Field Value

Type: String
See Also

Reference

CodeTemplateInfo Class
CodeSmith.Engine Namespace


CodeTemplateInfo._hashCode Field

CodeTemplateInfo_hashCode Field

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected int _hashCode
Protected _hashCode As Integer

Field Value

Type: Int32
See Also

Reference

CodeTemplateInfo Class
CodeSmith.Engine Namespace


CodeTemplateInfo._inMemory Field

CodeTemplateInfo_inMemory Field

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected bool _inMemory
Protected _inMemory As Boolean

Field Value

Type: Boolean
See Also

Reference

CodeTemplateInfo Class
CodeSmith.Engine Namespace


CodeTemplateInfo._language Field

CodeTemplateInfo_language Field

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected string _language
Protected _language As String

Field Value

Type: String
See Also

Reference

CodeTemplateInfo Class
CodeSmith.Engine Namespace


CodeTemplateInfo._outputType Field

CodeTemplateInfo_outputType Field

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected CodeTemplateOutputType _outputType
Protected _outputType As CodeTemplateOutputType

Field Value

Type: CodeTemplateOutputType
See Also

Reference

CodeTemplateInfo Class
CodeSmith.Engine Namespace


CodeTemplateInfo._targetLanguage Field

CodeTemplateInfo_targetLanguage Field

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected string _targetLanguage
Protected _targetLanguage As String

Field Value

Type: String
See Also

Reference

CodeTemplateInfo Class
CodeSmith.Engine Namespace


CodeTemplateInfo._templateEncoding Field

CodeTemplateInfo_templateEncoding Field

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected string _templateEncoding
Protected _templateEncoding As String

Field Value

Type: String
See Also

Reference

CodeTemplateInfo Class
CodeSmith.Engine Namespace


CodeTemplateInfo._templateInfoRetrieved Field

CodeTemplateInfo_templateInfoRetrieved Field

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected bool _templateInfoRetrieved
Protected _templateInfoRetrieved As Boolean

Field Value

Type: Boolean
See Also

Reference

CodeTemplateInfo Class
CodeSmith.Engine Namespace


CodeTemplateOutputType Enumeration

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public enum CodeTemplateOutputType
Public Enumeration CodeTemplateOutputType
Members
Member name | Value | Description
Normal | 0 |
Trace | 1 |
None | 2 |
See Also

Reference

CodeSmith.Engine Namespace


CodeTemplatePropertyAttribute Class

Note: This API is now obsolete.

Inheritance Hierarchy
SystemObject
SystemAttribute
CodeSmith.EngineCodeTemplatePropertyAttribute

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
[ObsoleteAttribute("The CodeTemplatePropertyAttribute has been deprecated, use the OptionalAttribute and the NotCheckedAttribute instead.")]
public sealed class CodeTemplatePropertyAttribute : Attribute
<SerializableAttribute>
<ObsoleteAttribute("The CodeTemplatePropertyAttribute has been deprecated, use the OptionalAttribute and the NotCheckedAttribute instead.")>
Public NotInheritable Class CodeTemplatePropertyAttribute
    Inherits Attribute

The CodeTemplatePropertyAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | CodeTemplatePropertyAttribute | Initializes a new instance of the CodeTemplatePropertyAttribute class
Top
Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | Value |
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSmith.Engine Namespace


CodeTemplatePropertyAttribute Constructor

Initializes a new instance of the CodeTemplatePropertyAttribute class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CodeTemplatePropertyAttribute(
    CodeTemplatePropertyOption value
)
Public Sub New (
    value As CodeTemplatePropertyOption
)

Parameters

value
Type: CodeSmith.EngineCodeTemplatePropertyOption
See Also

Reference

CodeTemplatePropertyAttribute Class
CodeSmith.Engine Namespace


CodeTemplatePropertyAttribute Properties

The CodeTemplatePropertyAttribute type exposes the following members.

Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | Value |
Top
See Also

Reference

CodeTemplatePropertyAttribute Class
CodeSmith.Engine Namespace


CodeTemplatePropertyAttribute.Value Property

CodeTemplatePropertyAttributeValue Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CodeTemplatePropertyOption Value { get; }
Public ReadOnly Property Value As CodeTemplatePropertyOption
    Get

Property Value

Type: CodeTemplatePropertyOption
See Also

Reference

CodeTemplatePropertyAttribute Class
CodeSmith.Engine Namespace


CodeTemplatePropertyAttribute Methods

The CodeTemplatePropertyAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeTemplatePropertyAttribute Class
CodeSmith.Engine Namespace


CodeTemplatePropertyOption Enumeration

Note: This API is now obsolete.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[ObsoleteAttribute("The CodeTemplatePropertyAttribute has been deprecated, use the OptionalAttribute and the NotCheckedAttribute instead.")]
public enum CodeTemplatePropertyOption
<ObsoleteAttribute("The CodeTemplatePropertyAttribute has been deprecated, use the OptionalAttribute and the NotCheckedAttribute instead.")>
Public Enumeration CodeTemplatePropertyOption
Members
Member name | Value | Description
Required | 0 |
Optional | 1 |
NotChecked | 2 |
See Also

Reference

CodeSmith.Engine Namespace


CodeTemplateValidationException Class

Inheritance Hierarchy
SystemObject
SystemException
CodeSmith.EngineCodeTemplateValidationException

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
public class CodeTemplateValidationException : Exception
<SerializableAttribute>
Public Class CodeTemplateValidationException
    Inherits Exception

The CodeTemplateValidationException type exposes the following members.

Constructors
 | Name | Description
Public method | CodeTemplateValidationException(ValidationErrorCollection) | Initializes a new instance of the CodeTemplateValidationException class
Protected method | CodeTemplateValidationException(SerializationInfo, StreamingContext) | Initializes a new instance of the CodeTemplateValidationException class
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Public property | ValidationErrors |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | (Overrides ExceptionGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

CodeSmith.Engine Namespace


CodeTemplateValidationException Constructor

Overload List
 | Name | Description
Public method | CodeTemplateValidationException(ValidationErrorCollection) | Initializes a new instance of the CodeTemplateValidationException class
Protected method | CodeTemplateValidationException(SerializationInfo, StreamingContext) | Initializes a new instance of the CodeTemplateValidationException class
Top
See Also

Reference

CodeTemplateValidationException Class
CodeSmith.Engine Namespace


CodeTemplateValidationException Constructor (ValidationErrorCollection)

Initializes a new instance of the CodeTemplateValidationException class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CodeTemplateValidationException(
    ValidationErrorCollection errors
)
Public Sub New (
    errors As ValidationErrorCollection
)

Parameters

errors
Type: CodeSmith.EngineValidationErrorCollection
See Also

Reference

CodeTemplateValidationException Class
CodeTemplateValidationException Overload
CodeSmith.Engine Namespace


CodeTemplateValidationException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the CodeTemplateValidationException class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected CodeTemplateValidationException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

CodeTemplateValidationException Class
CodeTemplateValidationException Overload
CodeSmith.Engine Namespace


CodeTemplateValidationException Properties

The CodeTemplateValidationException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Public property | ValidationErrors |
Top
See Also

Reference

CodeTemplateValidationException Class
CodeSmith.Engine Namespace


CodeTemplateValidationException.ValidationErrors Property

CodeTemplateValidationExceptionValidationErrors Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ValidationErrorCollection ValidationErrors { get; }
Public ReadOnly Property ValidationErrors As ValidationErrorCollection
    Get

Property Value

Type: ValidationErrorCollection
See Also

Reference

CodeTemplateValidationException Class
CodeSmith.Engine Namespace


CodeTemplateValidationException Methods

The CodeTemplateValidationException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | (Overrides ExceptionGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

CodeTemplateValidationException Class
CodeSmith.Engine Namespace


CodeTemplateValidationException.GetObjectData Method

CodeTemplateValidationExceptionGetObjectData Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
_ExceptionGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

CodeTemplateValidationException Class
CodeSmith.Engine Namespace


CodeTemplateValidationException Events

The CodeTemplateValidationException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

CodeTemplateValidationException Class
CodeSmith.Engine Namespace


CodeTemplateWriter Class

Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.IOTextWriter
CodeSmith.EngineCodeTemplateWriter

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class CodeTemplateWriter : TextWriter
Public Class CodeTemplateWriter
    Inherits TextWriter

The CodeTemplateWriter type exposes the following members.

Constructors
 | Name | Description
Public method | CodeTemplateWriter | Initializes a new instance of the CodeTemplateWriter class
Public method | CodeTemplateWriter(Encoding) | Initializes a new instance of the CodeTemplateWriter class
Public method | CodeTemplateWriter(TextWriter) | Initializes a new instance of the CodeTemplateWriter class
Public method | CodeTemplateWriter(TextWriter, String) | Initializes a new instance of the CodeTemplateWriter class
Top
Properties
 | Name | Description
Public property | Encoding | (Overrides TextWriterEncoding.)
Public property | FormatProvider | Gets an object that controls formatting. (Inherited from TextWriter.)
Public property | IndentLevel | The number of tabs or spaces the generated output should indent.
Public property | IndentValue | This value is outputted once for each Indent Level. IndentValue defaults to one tab.
Public property | NewLine | (Overrides TextWriterNewLine.)
Public property | TargetWriters |
Top
Methods
 | Name | Description
Public method | AddTextWriter |
Public method | Close | (Overrides TextWriterClose.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the TextWriter object. (Inherited from TextWriter.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the TextWriter and optionally releases the managed resources. (Inherited from TextWriter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | (Overrides TextWriterFlush.)
Public method | FlushAsync | Asynchronously clears all buffers for the current writer and causes any buffered data to be written to the underlying device. (Inherited from TextWriter.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Indent | Increments the IndentLevel by one.
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OutputTabs |
Public method | RemoveTextWriter |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Unindent |
Public method | Write(Boolean) | (Overrides TextWriterWrite(Boolean).)
Public method | Write(Char) | (Overrides TextWriterWrite(Char).)
Public method | Write(Char) | (Overrides TextWriterWrite(Char).)
Public method | Write(Decimal) | (Overrides TextWriterWrite(Decimal).)
Public method | Write(Double) | (Overrides TextWriterWrite(Double).)
Public method | Write(Int32) | (Overrides TextWriterWrite(Int32).)
Public method | Write(Int64) | (Overrides TextWriterWrite(Int64).)
Public method | Write(Object) | (Overrides TextWriterWrite(Object).)
Public method | Write(Single) | (Overrides TextWriterWrite(Single).)
Public method | Write(String) | (Overrides TextWriterWrite(String).)
Public method | Write(UInt32) | (Overrides TextWriterWrite(UInt32).)
Public method | Write(UInt64) | (Overrides TextWriterWrite(UInt64).)
Public method | Write(String, Object) | (Overrides TextWriterWrite(String, Object).)
Public method | Write(String, Object) | (Overrides TextWriterWrite(String, Object).)
Public method | Write(Char, Int32, Int32) | (Overrides TextWriterWrite(Char, Int32, Int32).)
Public method | Write(String, Object, Object) | (Overrides TextWriterWrite(String, Object, Object).)
Public method | Write(String, Object, Object, Object) | (Overrides TextWriterWrite(String, Object, Object, Object).)
Public method | WriteAsync(Char) | Writes a character to the text string or stream asynchronously. (Inherited from TextWriter.)
Public method | WriteAsync(Char) | Writes a character array to the text string or stream asynchronously. (Inherited from TextWriter.)
Public method | WriteAsync(String) | Writes a string to the text string or stream asynchronously. (Inherited from TextWriter.)
Public method | WriteAsync(Char, Int32, Int32) | Writes a subarray of characters to the text string or stream asynchronously. (Inherited from TextWriter.)
Public method | WriteLine | (Overrides TextWriterWriteLine.)
Public method | WriteLine(Boolean) | (Overrides TextWriterWriteLine(Boolean).)
Public method | WriteLine(Char) | (Overrides TextWriterWriteLine(Char).)
Public method | WriteLine(Char) | (Overrides TextWriterWriteLine(Char).)
Public method | WriteLine(Decimal) | (Overrides TextWriterWriteLine(Decimal).)
Public method | WriteLine(Double) | (Overrides TextWriterWriteLine(Double).)
Public method | WriteLine(Int32) | (Overrides TextWriterWriteLine(Int32).)
Public method | WriteLine(Int64) | (Overrides TextWriterWriteLine(Int64).)
Public method | WriteLine(Object) | (Overrides TextWriterWriteLine(Object).)
Public method | WriteLine(Single) | (Overrides TextWriterWriteLine(Single).)
Public method | WriteLine(String) | (Overrides TextWriterWriteLine(String).)
Public method | WriteLine(UInt32) | (Overrides TextWriterWriteLine(UInt32).)
Public method | WriteLine(UInt64) | (Overrides TextWriterWriteLine(UInt64).)
Public method | WriteLine(String, Object) | (Overrides TextWriterWriteLine(String, Object).)
Public method | WriteLine(String, Object) | (Overrides TextWriterWriteLine(String, Object).)
Public method | WriteLine(Char, Int32, Int32) | (Overrides TextWriterWriteLine(Char, Int32, Int32).)
Public method | WriteLine(String, Object, Object) | (Overrides TextWriterWriteLine(String, Object, Object).)
Public method | WriteLine(String, Object, Object, Object) | (Overrides TextWriterWriteLine(String, Object, Object, Object).)
Public method | WriteLineAsync | Writes a line terminator asynchronously to the text string or stream. (Inherited from TextWriter.)
Public method | WriteLineAsync(Char) | Writes a character followed by a line terminator asynchronously to the text string or stream. (Inherited from TextWriter.)
Public method | WriteLineAsync(Char) | Writes an array of characters followed by a line terminator asynchronously to the text string or stream. (Inherited from TextWriter.)
Public method | WriteLineAsync(String) | Writes a string followed by a line terminator asynchronously to the text string or stream. (Inherited from TextWriter.)
Public method | WriteLineAsync(Char, Int32, Int32) | Writes a subarray of characters followed by a line terminator asynchronously to the text string or stream. (Inherited from TextWriter.)
Public method | WriteLineNoIndent |
Top
Operators
Name | Description
Addition |
Subtraction |
Top
Fields
 | Name | Description
Protected field | CoreNewLine | Stores the newline characters used for this TextWriter. (Inherited from TextWriter.)
 | DefaultNewLine |
 | DefaultTabString |
Top
See Also

Reference

CodeSmith.Engine Namespace


CodeTemplateWriter Constructor

Overload List
 | Name | Description
Public method | CodeTemplateWriter | Initializes a new instance of the CodeTemplateWriter class
Public method | CodeTemplateWriter(Encoding) | Initializes a new instance of the CodeTemplateWriter class
Public method | CodeTemplateWriter(TextWriter) | Initializes a new instance of the CodeTemplateWriter class
Public method | CodeTemplateWriter(TextWriter, String) | Initializes a new instance of the CodeTemplateWriter class
Top
See Also

Reference

CodeTemplateWriter Class
CodeSmith.Engine Namespace


CodeTemplateWriter Constructor

Initializes a new instance of the CodeTemplateWriter class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CodeTemplateWriter()
Public Sub New
See Also

Reference

CodeTemplateWriter Class
CodeTemplateWriter Overload
CodeSmith.Engine Namespace


CodeTemplateWriter Constructor (Encoding)

Initializes a new instance of the CodeTemplateWriter class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CodeTemplateWriter(
    Encoding encoding
)
Public Sub New (
    encoding As Encoding
)

Parameters

encoding
Type: System.TextEncoding
See Also

Reference

CodeTemplateWriter Class
CodeTemplateWriter Overload
CodeSmith.Engine Namespace


CodeTemplateWriter Constructor (TextWriter)

Initializes a new instance of the CodeTemplateWriter class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CodeTemplateWriter(
    TextWriter writer
)
Public Sub New (
    writer As TextWriter
)

Parameters

writer
Type: System.IOTextWriter
See Also

Reference

CodeTemplateWriter Class
CodeTemplateWriter Overload
CodeSmith.Engine Namespace


CodeTemplateWriter Constructor (TextWriter, String)

Initializes a new instance of the CodeTemplateWriter class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CodeTemplateWriter(
    TextWriter writer,
    string indentValue
)
Public Sub New (
    writer As TextWriter,
    indentValue As String
)

Parameters

writer
Type: System.IOTextWriter
indentValue
Type: SystemString
See Also

Reference

CodeTemplateWriter Class
CodeTemplateWriter Overload
CodeSmith.Engine Namespace


CodeTemplateWriter Properties

The CodeTemplateWriter type exposes the following members.

Properties
 | Name | Description
Public property | Encoding | (Overrides TextWriterEncoding.)
Public property | FormatProvider | Gets an object that controls formatting. (Inherited from TextWriter.)
Public property | IndentLevel | The number of tabs or spaces the generated output should indent.
Public property | IndentValue | This value is outputted once for each Indent Level. IndentValue defaults to one tab.
Public property | NewLine | (Overrides TextWriterNewLine.)
Public property | TargetWriters |
Top
See Also

Reference

CodeTemplateWriter Class
CodeSmith.Engine Namespace


CodeTemplateWriter.Encoding Property

CodeTemplateWriterEncoding Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override Encoding Encoding { get; }
Public Overrides ReadOnly Property Encoding As Encoding
    Get

Property Value

Type: Encoding
See Also

Reference

CodeTemplateWriter Class
CodeSmith.Engine Namespace


CodeTemplateWriter.IndentLevel Property

CodeTemplateWriterIndentLevel Property

The number of tabs or spaces the generated output should indent.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public int IndentLevel { get; set; }
Public Property IndentLevel As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

CodeTemplateWriter Class
CodeSmith.Engine Namespace


CodeTemplateWriter.IndentValue Property

CodeTemplateWriterIndentValue Property

This value is outputted once for each Indent Level. IndentValue defaults to one tab.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string IndentValue { get; set; }
Public Property IndentValue As String
    Get
    Set

Property Value

Type: String
See Also

Reference

CodeTemplateWriter Class
CodeSmith.Engine Namespace


CodeTemplateWriter.NewLine Property

CodeTemplateWriterNewLine Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override string NewLine { get; set; }
Public Overrides Property NewLine As String
    Get
    Set

Property Value

Type: String
See Also

Reference

CodeTemplateWriter Class
CodeSmith.Engine Namespace


CodeTemplateWriter.TargetWriters Property

CodeTemplateWriterTargetWriters Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public TextWriterCollection TargetWriters { get; }
Public ReadOnly Property TargetWriters As TextWriterCollection
    Get

Property Value

Type: TextWriterCollection
See Also

Reference

CodeTemplateWriter Class
CodeSmith.Engine Namespace


CodeTemplateWriter Methods

The CodeTemplateWriter type exposes the following members.

Methods
 | Name | Description
Public method | AddTextWriter |
Public method | Close | (Overrides TextWriterClose.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the TextWriter object. (Inherited from TextWriter.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the TextWriter and optionally releases the managed resources. (Inherited from TextWriter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | (Overrides TextWriterFlush.)
Public method | FlushAsync | Asynchronously clears all buffers for the current writer and causes any buffered data to be written to the underlying device. (Inherited from TextWriter.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Indent | Increments the IndentLevel by one.
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OutputTabs |
Public method | RemoveTextWriter |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Unindent |
Public method | Write(Boolean) | (Overrides TextWriterWrite(Boolean).)
Public method | Write(Char) | (Overrides TextWriterWrite(Char).)
Public method | Write(Char) | (Overrides TextWriterWrite(Char).)
Public method | Write(Decimal) | (Overrides TextWriterWrite(Decimal).)
Public method | Write(Double) | (Overrides TextWriterWrite(Double).)
Public method | Write(Int32) | (Overrides TextWriterWrite(Int32).)
Public method | Write(Int64) | (Overrides TextWriterWrite(Int64).)
Public method | Write(Object) | (Overrides TextWriterWrite(Object).)
Public method | Write(Single) | (Overrides TextWriterWrite(Single).)
Public method | Write(String) | (Overrides TextWriterWrite(String).)
Public method | Write(UInt32) | (Overrides TextWriterWrite(UInt32).)
Public method | Write(UInt64) | (Overrides TextWriterWrite(UInt64).)
Public method | Write(String, Object) | (Overrides TextWriterWrite(String, Object).)
Public method | Write(String, Object) | (Overrides TextWriterWrite(String, Object).)
Public method | Write(Char, Int32, Int32) | (Overrides TextWriterWrite(Char, Int32, Int32).)
Public method | Write(String, Object, Object) | (Overrides TextWriterWrite(String, Object, Object).)
Public method | Write(String, Object, Object, Object) | (Overrides TextWriterWrite(String, Object, Object, Object).)
Public method | WriteAsync(Char) | Writes a character to the text string or stream asynchronously. (Inherited from TextWriter.)
Public method | WriteAsync(Char) | Writes a character array to the text string or stream asynchronously. (Inherited from TextWriter.)
Public method | WriteAsync(String) | Writes a string to the text string or stream asynchronously. (Inherited from TextWriter.)
Public method | WriteAsync(Char, Int32, Int32) | Writes a subarray of characters to the text string or stream asynchronously. (Inherited from TextWriter.)
Public method | WriteLine | (Overrides TextWriterWriteLine.)
Public method | WriteLine(Boolean) | (Overrides TextWriterWriteLine(Boolean).)
Public method | WriteLine(Char) | (Overrides TextWriterWriteLine(Char).)
Public method | WriteLine(Char) | (Overrides TextWriterWriteLine(Char).)
Public method | WriteLine(Decimal) | (Overrides TextWriterWriteLine(Decimal).)
Public method | WriteLine(Double) | (Overrides TextWriterWriteLine(Double).)
Public method | WriteLine(Int32) | (Overrides TextWriterWriteLine(Int32).)
Public method | WriteLine(Int64) | (Overrides TextWriterWriteLine(Int64).)
Public method | WriteLine(Object) | (Overrides TextWriterWriteLine(Object).)
Public method | WriteLine(Single) | (Overrides TextWriterWriteLine(Single).)
Public method | WriteLine(String) | (Overrides TextWriterWriteLine(String).)
Public method | WriteLine(UInt32) | (Overrides TextWriterWriteLine(UInt32).)
Public method | WriteLine(UInt64) | (Overrides TextWriterWriteLine(UInt64).)
Public method | WriteLine(String, Object) | (Overrides TextWriterWriteLine(String, Object).)
Public method | WriteLine(String, Object) | (Overrides TextWriterWriteLine(String, Object).)
Public method | WriteLine(Char, Int32, Int32) | (Overrides TextWriterWriteLine(Char, Int32, Int32).)
Public method | WriteLine(String, Object, Object) | (Overrides TextWriterWriteLine(String, Object, Object).)
Public method | WriteLine(String, Object, Object, Object) | (Overrides TextWriterWriteLine(String, Object, Object, Object).)
Public method | WriteLineAsync | Writes a line terminator asynchronously to the text string or stream. (Inherited from TextWriter.)
Public method | WriteLineAsync(Char) | Writes a character followed by a line terminator asynchronously to the text string or stream. (Inherited from TextWriter.)
Public method | WriteLineAsync(Char) | Writes an array of characters followed by a line terminator asynchronously to the text string or stream. (Inherited from TextWriter.)
Public method | WriteLineAsync(String) | Writes a string followed by a line terminator asynchronously to the text string or stream. (Inherited from TextWriter.)
Public method | WriteLineAsync(Char, Int32, Int32) | Writes a subarray of characters followed by a line terminator asynchronously to the text string or stream. (Inherited from TextWriter.)
Public method | WriteLineNoIndent |
Top
See Also

Reference

CodeTemplateWriter Class
CodeSmith.Engine Namespace


CodeTemplateWriter.AddTextWriter Method

CodeTemplateWriterAddTextWriter Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void AddTextWriter(
    TextWriter writer
)
Public Sub AddTextWriter (
    writer As TextWriter
)

Parameters

writer
Type: System.IOTextWriter
See Also

Reference

CodeTemplateWriter Class
CodeSmith.Engine Namespace


CodeTemplateWriter.Close Method

CodeTemplateWriterClose Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override void Close()
Public Overrides Sub Close
See Also

Reference

CodeTemplateWriter Class
CodeSmith.Engine Namespace


CodeTemplateWriter.Flush Method

CodeTemplateWriterFlush Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override void Flush()
Public Overrides Sub Flush
See Also

Reference

CodeTemplateWriter Class
CodeSmith.Engine Namespace


CodeTemplateWriter.Indent Method

CodeTemplateWriterIndent Method

Increments the IndentLevel by one.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void Indent()
Public Sub Indent
See Also

Reference

CodeTemplateWriter Class
CodeSmith.Engine Namespace


CodeTemplateWriter.OutputTabs Method

CodeTemplateWriterOutputTabs Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual void OutputTabs()
Protected Overridable Sub OutputTabs
See Also

Reference

CodeTemplateWriter Class
CodeSmith.Engine Namespace


CodeTemplateWriter.RemoveTextWriter Method

CodeTemplateWriterRemoveTextWriter Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void RemoveTextWriter(
    TextWriter writer
)
Public Sub RemoveTextWriter (
    writer As TextWriter
)

Parameters

writer
Type: System.IOTextWriter
See Also

Reference

CodeTemplateWriter Class
CodeSmith.Engine Namespace


CodeTemplateWriter.Unindent Method

CodeTemplateWriterUnindent Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void Unindent()
Public Sub Unindent
See Also

Reference

CodeTemplateWriter Class
CodeSmith.Engine Namespace


CodeTemplateWriter.Write Method

CodeTemplateWriterWrite Method

Overload List
 | Name | Description
Public method | Write(Boolean) | (Overrides TextWriterWrite(Boolean).)
Public method | Write(Char) | (Overrides TextWriterWrite(Char).)
Public method | Write(Char) | (Overrides TextWriterWrite(Char).)
Public method | Write(Decimal) | (Overrides TextWriterWrite(Decimal).)
Public method | Write(Double) | (Overrides TextWriterWrite(Double).)
Public method | Write(Int32) | (Overrides TextWriterWrite(Int32).)
Public method | Write(Int64) | (Overrides TextWriterWrite(Int64).)
Public method | Write(Object) | (Overrides TextWriterWrite(Object).)
Public method | Write(Single) | (Overrides TextWriterWrite(Single).)
Public method | Write(String) | (Overrides TextWriterWrite(String).)
Public method | Write(UInt32) | (Overrides TextWriterWrite(UInt32).)
Public method | Write(UInt64) | (Overrides TextWriterWrite(UInt64).)
Public method | Write(String, Object) | (Overrides TextWriterWrite(String, Object).)
Public method | Write(String, Object) | (Overrides TextWriterWrite(String, Object).)
Public method | Write(Char, Int32, Int32) | (Overrides TextWriterWrite(Char, Int32, Int32).)
Public method | Write(String, Object, Object) | (Overrides TextWriterWrite(String, Object, Object).)
Public method | Write(String, Object, Object, Object) | (Overrides TextWriterWrite(String, Object, Object, Object).)
Top
See Also

Reference

CodeTemplateWriter Class
CodeSmith.Engine Namespace


CodeTemplateWriter.Write Method (Boolean)

CodeTemplateWriterWrite Method (Boolean)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override void Write(
    bool value
)
Public Overrides Sub Write (
    value As Boolean
)

Parameters

value
Type: SystemBoolean
See Also

Reference

CodeTemplateWriter Class
Write Overload
CodeSmith.Engine Namespace


CodeTemplateWriter.Write Method (Char)

CodeTemplateWriterWrite Method (Char)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override void Write(
    char value
)
Public Overrides Sub Write (
    value As Char
)

Parameters

value
Type: SystemChar
See Also

Reference

CodeTemplateWriter Class
Write Overload
CodeSmith.Engine Namespace


CodeTemplateWriter.Write Method (Char[])

CodeTemplateWriterWrite Method (Char)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override void Write(
    char[] value
)
Public Overrides Sub Write (
    value As Char()
)

Parameters

value
Type: SystemChar
See Also

Reference

CodeTemplateWriter Class
Write Overload
CodeSmith.Engine Namespace


CodeTemplateWriter.Write Method (Decimal)

CodeTemplateWriterWrite Method (Decimal)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override void Write(
    decimal value
)
Public Overrides Sub Write (
    value As Decimal
)

Parameters

value
Type: SystemDecimal
See Also

Reference

CodeTemplateWriter Class
Write Overload
CodeSmith.Engine Namespace


CodeTemplateWriter.Write Method (Double)

CodeTemplateWriterWrite Method (Double)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override void Write(
    double value
)
Public Overrides Sub Write (
    value As Double
)

Parameters

value
Type: SystemDouble
See Also

Reference

CodeTemplateWriter Class
Write Overload
CodeSmith.Engine Namespace


CodeTemplateWriter.Write Method (Int32)

CodeTemplateWriterWrite Method (Int32)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override void Write(
    int value
)
Public Overrides Sub Write (
    value As Integer
)

Parameters

value
Type: SystemInt32
See Also

Reference

CodeTemplateWriter Class
Write Overload
CodeSmith.Engine Namespace


CodeTemplateWriter.Write Method (Int64)

CodeTemplateWriterWrite Method (Int64)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override void Write(
    long value
)
Public Overrides Sub Write (
    value As Long
)

Parameters

value
Type: SystemInt64
See Also

Reference

CodeTemplateWriter Class
Write Overload
CodeSmith.Engine Namespace


CodeTemplateWriter.Write Method (Object)

CodeTemplateWriterWrite Method (Object)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override void Write(
    Object value
)
Public Overrides Sub Write (
    value As Object
)

Parameters

value
Type: SystemObject
See Also

Reference

CodeTemplateWriter Class
Write Overload
CodeSmith.Engine Namespace


CodeTemplateWriter.Write Method (Single)

CodeTemplateWriterWrite Method (Single)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override void Write(
    float value
)
Public Overrides Sub Write (
    value As Single
)

Parameters

value
Type: SystemSingle
See Also

Reference

CodeTemplateWriter Class
Write Overload
CodeSmith.Engine Namespace


CodeTemplateWriter.Write Method (String)

CodeTemplateWriterWrite Method (String)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override void Write(
    string value
)
Public Overrides Sub Write (
    value As String
)

Parameters

value
Type: SystemString
See Also

Reference

CodeTemplateWriter Class
Write Overload
CodeSmith.Engine Namespace


CodeTemplateWriter.Write Method (UInt32)

CodeTemplateWriterWrite Method (UInt32)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override void Write(
    uint value
)
Public Overrides Sub Write (
    value As UInteger
)

Parameters

value
Type: SystemUInt32
See Also

Reference

CodeTemplateWriter Class
Write Overload
CodeSmith.Engine Namespace


CodeTemplateWriter.Write Method (UInt64)

CodeTemplateWriterWrite Method (UInt64)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override void Write(
    ulong value
)
Public Overrides Sub Write (
    value As ULong
)

Parameters

value
Type: SystemUInt64
See Also

Reference

CodeTemplateWriter Class
Write Overload
CodeSmith.Engine Namespace


CodeTemplateWriter.Write Method (String, Object)

CodeTemplateWriterWrite Method (String, Object)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override void Write(
    string format,
    Object arg
)
Public Overrides Sub Write (
    format As String,
    arg As Object
)

Parameters

format
Type: SystemString
arg
Type: SystemObject
See Also

Reference

CodeTemplateWriter Class
Write Overload
CodeSmith.Engine Namespace


CodeTemplateWriter.Write Method (String, Object[])

CodeTemplateWriterWrite Method (String, Object)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override void Write(
    string format,
    params Object[] args
)
Public Overrides Sub Write (
    format As String,
    ParamArray args As Object()
)

Parameters

format
Type: SystemString
args
Type: SystemObject
See Also

Reference

CodeTemplateWriter Class
Write Overload
CodeSmith.Engine Namespace


CodeTemplateWriter.Write Method (Char[], Int32, Int32)

CodeTemplateWriterWrite Method (Char, Int32, Int32)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override void Write(
    char[] buffer,
    int index,
    int count
)
Public Overrides Sub Write (
    buffer As Char(),
    index As Integer,
    count As Integer
)

Parameters

buffer
Type: SystemChar
index
Type: SystemInt32
count
Type: SystemInt32
See Also

Reference

CodeTemplateWriter Class
Write Overload
CodeSmith.Engine Namespace


CodeTemplateWriter.Write Method (String, Object, Object)

CodeTemplateWriterWrite Method (String, Object, Object)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override void Write(
    string format,
    Object arg0,
    Object arg1
)
Public Overrides Sub Write (
    format As String,
    arg0 As Object,
    arg1 As Object
)

Parameters

format
Type: SystemString
arg0
Type: SystemObject
arg1
Type: SystemObject
See Also

Reference

CodeTemplateWriter Class
Write Overload
CodeSmith.Engine Namespace


CodeTemplateWriter.Write Method (String, Object, Object, Object)

CodeTemplateWriterWrite Method (String, Object, Object, Object)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override void Write(
    string format,
    Object arg0,
    Object arg1,
    Object arg2
)
Public Overrides Sub Write (
    format As String,
    arg0 As Object,
    arg1 As Object,
    arg2 As Object
)

Parameters

format
Type: SystemString
arg0
Type: SystemObject
arg1
Type: SystemObject
arg2
Type: SystemObject
See Also

Reference

CodeTemplateWriter Class
Write Overload
CodeSmith.Engine Namespace


CodeTemplateWriter.WriteLine Method

CodeTemplateWriterWriteLine Method

Overload List
 | Name | Description
Public method | WriteLine | (Overrides TextWriterWriteLine.)
Public method | WriteLine(Boolean) | (Overrides TextWriterWriteLine(Boolean).)
Public method | WriteLine(Char) | (Overrides TextWriterWriteLine(Char).)
Public method | WriteLine(Char) | (Overrides TextWriterWriteLine(Char).)
Public method | WriteLine(Decimal) | (Overrides TextWriterWriteLine(Decimal).)
Public method | WriteLine(Double) | (Overrides TextWriterWriteLine(Double).)
Public method | WriteLine(Int32) | (Overrides TextWriterWriteLine(Int32).)
Public method | WriteLine(Int64) | (Overrides TextWriterWriteLine(Int64).)
Public method | WriteLine(Object) | (Overrides TextWriterWriteLine(Object).)
Public method | WriteLine(Single) | (Overrides TextWriterWriteLine(Single).)
Public method | WriteLine(String) | (Overrides TextWriterWriteLine(String).)
Public method | WriteLine(UInt32) | (Overrides TextWriterWriteLine(UInt32).)
Public method | WriteLine(UInt64) | (Overrides TextWriterWriteLine(UInt64).)
Public method | WriteLine(String, Object) | (Overrides TextWriterWriteLine(String, Object).)
Public method | WriteLine(String, Object) | (Overrides TextWriterWriteLine(String, Object).)
Public method | WriteLine(Char, Int32, Int32) | (Overrides TextWriterWriteLine(Char, Int32, Int32).)
Public method | WriteLine(String, Object, Object) | (Overrides TextWriterWriteLine(String, Object, Object).)
Public method | WriteLine(String, Object, Object, Object) | (Overrides TextWriterWriteLine(String, Object, Object, Object).)
Top
See Also

Reference

CodeTemplateWriter Class
CodeSmith.Engine Namespace


CodeTemplateWriter.WriteLine Method

CodeTemplateWriterWriteLine Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override void WriteLine()
Public Overrides Sub WriteLine
See Also

Reference

CodeTemplateWriter Class
WriteLine Overload
CodeSmith.Engine Namespace


CodeTemplateWriter.WriteLine Method (Boolean)

CodeTemplateWriterWriteLine Method (Boolean)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override void WriteLine(
    bool value
)
Public Overrides Sub WriteLine (
    value As Boolean
)

Parameters

value
Type: SystemBoolean
See Also

Reference

CodeTemplateWriter Class
WriteLine Overload
CodeSmith.Engine Namespace


CodeTemplateWriter.WriteLine Method (Char)

CodeTemplateWriterWriteLine Method (Char)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override void WriteLine(
    char value
)
Public Overrides Sub WriteLine (
    value As Char
)

Parameters

value
Type: SystemChar
See Also

Reference

CodeTemplateWriter Class
WriteLine Overload
CodeSmith.Engine Namespace


CodeTemplateWriter.WriteLine Method (Char[])

CodeTemplateWriterWriteLine Method (Char)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override void WriteLine(
    char[] value
)
Public Overrides Sub WriteLine (
    value As Char()
)

Parameters

value
Type: SystemChar
See Also

Reference

CodeTemplateWriter Class
WriteLine Overload
CodeSmith.Engine Namespace


CodeTemplateWriter.WriteLine Method (Decimal)

CodeTemplateWriterWriteLine Method (Decimal)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override void WriteLine(
    decimal value
)
Public Overrides Sub WriteLine (
    value As Decimal
)

Parameters

value
Type: SystemDecimal
See Also

Reference

CodeTemplateWriter Class
WriteLine Overload
CodeSmith.Engine Namespace


CodeTemplateWriter.WriteLine Method (Double)

CodeTemplateWriterWriteLine Method (Double)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override void WriteLine(
    double value
)
Public Overrides Sub WriteLine (
    value As Double
)

Parameters

value
Type: SystemDouble
See Also

Reference

CodeTemplateWriter Class
WriteLine Overload
CodeSmith.Engine Namespace


CodeTemplateWriter.WriteLine Method (Int32)

CodeTemplateWriterWriteLine Method (Int32)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override void WriteLine(
    int value
)
Public Overrides Sub WriteLine (
    value As Integer
)

Parameters

value
Type: SystemInt32
See Also

Reference

CodeTemplateWriter Class
WriteLine Overload
CodeSmith.Engine Namespace


CodeTemplateWriter.WriteLine Method (Int64)

CodeTemplateWriterWriteLine Method (Int64)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override void WriteLine(
    long value
)
Public Overrides Sub WriteLine (
    value As Long
)

Parameters

value
Type: SystemInt64
See Also

Reference

CodeTemplateWriter Class
WriteLine Overload
CodeSmith.Engine Namespace


CodeTemplateWriter.WriteLine Method (Object)

CodeTemplateWriterWriteLine Method (Object)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override void WriteLine(
    Object value
)
Public Overrides Sub WriteLine (
    value As Object
)

Parameters

value
Type: SystemObject
See Also

Reference

CodeTemplateWriter Class
WriteLine Overload
CodeSmith.Engine Namespace


CodeTemplateWriter.WriteLine Method (Single)

CodeTemplateWriterWriteLine Method (Single)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override void WriteLine(
    float value
)
Public Overrides Sub WriteLine (
    value As Single
)

Parameters

value
Type: SystemSingle
See Also

Reference

CodeTemplateWriter Class
WriteLine Overload
CodeSmith.Engine Namespace


CodeTemplateWriter.WriteLine Method (String)

CodeTemplateWriterWriteLine Method (String)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override void WriteLine(
    string value
)
Public Overrides Sub WriteLine (
    value As String
)

Parameters

value
Type: SystemString
See Also

Reference

CodeTemplateWriter Class
WriteLine Overload
CodeSmith.Engine Namespace


CodeTemplateWriter.WriteLine Method (UInt32)

CodeTemplateWriterWriteLine Method (UInt32)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override void WriteLine(
    uint value
)
Public Overrides Sub WriteLine (
    value As UInteger
)

Parameters

value
Type: SystemUInt32
See Also

Reference

CodeTemplateWriter Class
WriteLine Overload
CodeSmith.Engine Namespace


CodeTemplateWriter.WriteLine Method (UInt64)

CodeTemplateWriterWriteLine Method (UInt64)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override void WriteLine(
    ulong value
)
Public Overrides Sub WriteLine (
    value As ULong
)

Parameters

value
Type: SystemUInt64
See Also

Reference

CodeTemplateWriter Class
WriteLine Overload
CodeSmith.Engine Namespace


CodeTemplateWriter.WriteLine Method (String, Object)

CodeTemplateWriterWriteLine Method (String, Object)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override void WriteLine(
    string format,
    Object arg
)
Public Overrides Sub WriteLine (
    format As String,
    arg As Object
)

Parameters

format
Type: SystemString
arg
Type: SystemObject
See Also

Reference

CodeTemplateWriter Class
WriteLine Overload
CodeSmith.Engine Namespace


CodeTemplateWriter.WriteLine Method (String, Object[])

CodeTemplateWriterWriteLine Method (String, Object)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override void WriteLine(
    string format,
    params Object[] args
)
Public Overrides Sub WriteLine (
    format As String,
    ParamArray args As Object()
)

Parameters

format
Type: SystemString
args
Type: SystemObject
See Also

Reference

CodeTemplateWriter Class
WriteLine Overload
CodeSmith.Engine Namespace


CodeTemplateWriter.WriteLine Method (Char[], Int32, Int32)

CodeTemplateWriterWriteLine Method (Char, Int32, Int32)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override void WriteLine(
    char[] buffer,
    int index,
    int count
)
Public Overrides Sub WriteLine (
    buffer As Char(),
    index As Integer,
    count As Integer
)

Parameters

buffer
Type: SystemChar
index
Type: SystemInt32
count
Type: SystemInt32
See Also

Reference

CodeTemplateWriter Class
WriteLine Overload
CodeSmith.Engine Namespace


CodeTemplateWriter.WriteLine Method (String, Object, Object)

CodeTemplateWriterWriteLine Method (String, Object, Object)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override void WriteLine(
    string format,
    Object arg0,
    Object arg1
)
Public Overrides Sub WriteLine (
    format As String,
    arg0 As Object,
    arg1 As Object
)

Parameters

format
Type: SystemString
arg0
Type: SystemObject
arg1
Type: SystemObject
See Also

Reference

CodeTemplateWriter Class
WriteLine Overload
CodeSmith.Engine Namespace


CodeTemplateWriter.WriteLine Method (String, Object, Object, Object)

CodeTemplateWriterWriteLine Method (String, Object, Object, Object)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override void WriteLine(
    string format,
    Object arg0,
    Object arg1,
    Object arg2
)
Public Overrides Sub WriteLine (
    format As String,
    arg0 As Object,
    arg1 As Object,
    arg2 As Object
)

Parameters

format
Type: SystemString
arg0
Type: SystemObject
arg1
Type: SystemObject
arg2
Type: SystemObject
See Also

Reference

CodeTemplateWriter Class
WriteLine Overload
CodeSmith.Engine Namespace


CodeTemplateWriter.WriteLineNoIndent Method

CodeTemplateWriterWriteLineNoIndent Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void WriteLineNoIndent(
    string value
)
Public Sub WriteLineNoIndent (
    value As String
)

Parameters

value
Type: SystemString
See Also

Reference

CodeTemplateWriter Class
CodeSmith.Engine Namespace


CodeTemplateWriter Operators

The CodeTemplateWriter type exposes the following members.

Operators
Name | Description
Addition |
Subtraction |
Top
See Also

Reference

CodeTemplateWriter Class
CodeSmith.Engine Namespace


CodeTemplateWriter.Addition Operator

CodeTemplateWriterAddition Operator

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static CodeTemplateWriter operator +(
    CodeTemplateWriter lhs,
    TextWriter rhs
)
Public Shared Operator + (
    lhs As CodeTemplateWriter,
    rhs As TextWriter
) As CodeTemplateWriter

Parameters

lhs
Type: CodeSmith.EngineCodeTemplateWriter
rhs
Type: System.IOTextWriter

Return Value

Type: CodeTemplateWriter
See Also

Reference

CodeTemplateWriter Class
CodeSmith.Engine Namespace


CodeTemplateWriter.Subtraction Operator

CodeTemplateWriterSubtraction Operator

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static CodeTemplateWriter operator -(
    CodeTemplateWriter lhs,
    TextWriter rhs
)
Public Shared Operator - (
    lhs As CodeTemplateWriter,
    rhs As TextWriter
) As CodeTemplateWriter

Parameters

lhs
Type: CodeSmith.EngineCodeTemplateWriter
rhs
Type: System.IOTextWriter

Return Value

Type: CodeTemplateWriter
See Also

Reference

CodeTemplateWriter Class
CodeSmith.Engine Namespace


CodeTemplateWriter Fields

The CodeTemplateWriter type exposes the following members.

Fields
 | Name | Description
Protected field | CoreNewLine | Stores the newline characters used for this TextWriter. (Inherited from TextWriter.)
 | DefaultNewLine |
 | DefaultTabString |
Top
See Also

Reference

CodeTemplateWriter Class
CodeSmith.Engine Namespace


CodeTemplateWriter.DefaultNewLine Field

CodeTemplateWriterDefaultNewLine Field

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public const string DefaultNewLine = ""
Public Const DefaultNewLine As String = ""

Field Value

Type: String
See Also

Reference

CodeTemplateWriter Class
CodeSmith.Engine Namespace


CodeTemplateWriter.DefaultTabString Field

CodeTemplateWriterDefaultTabString Field

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public const string DefaultTabString = ""
Public Const DefaultTabString As String = ""

Field Value

Type: String
See Also

Reference

CodeTemplateWriter Class
CodeSmith.Engine Namespace


CompileTemplateResult Class

Inheritance Hierarchy
SystemObject
CodeSmith.EngineCompileTemplateResult

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class CompileTemplateResult
Public Class CompileTemplateResult

The CompileTemplateResult type exposes the following members.

Constructors
 | Name | Description
Public method | CompileTemplateResult | Initializes a new instance of the CompileTemplateResult class
Public method | CompileTemplateResult(CacheEntry, TimeSpan) | Initializes a new instance of the CompileTemplateResult class
Public method | CompileTemplateResult(CompileResult, TimeSpan) | Initializes a new instance of the CompileTemplateResult class
Public method | CompileTemplateResult(TemplateParseResult, TimeSpan) | Initializes a new instance of the CompileTemplateResult class
Top
Properties
 | Name | Description
Public property | CodeBehind |
Public property | CompiledAssembly |
Public property | CompilerVersion |
Public property | DependenciesHashCode |
Public property | Description |
Public property | Duration |
Public property | Encoding |
Public property | Errors |
Public property | FileDependencies |
Public property | FullPath |
Public property | FullTypeName |
Public property | IsFromCache |
Public property | Language |
Public property | OutputDirectory |
Public property | OutputType |
Public property | PathToAssembly |
Public property | Success |
Public property | TargetLanguage |
Top
Methods
 | Name | Description
Public method | CreateTemplateInstance |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HaveDependenciesBeenModified |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSmith.Engine Namespace


CompileTemplateResult Constructor

Overload List
 | Name | Description
Public method | CompileTemplateResult | Initializes a new instance of the CompileTemplateResult class
Public method | CompileTemplateResult(CacheEntry, TimeSpan) | Initializes a new instance of the CompileTemplateResult class
Public method | CompileTemplateResult(CompileResult, TimeSpan) | Initializes a new instance of the CompileTemplateResult class
Public method | CompileTemplateResult(TemplateParseResult, TimeSpan) | Initializes a new instance of the CompileTemplateResult class
Top
See Also

Reference

CompileTemplateResult Class
CodeSmith.Engine Namespace


CompileTemplateResult Constructor

Initializes a new instance of the CompileTemplateResult class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CompileTemplateResult()
Public Sub New
See Also

Reference

CompileTemplateResult Class
CompileTemplateResult Overload
CodeSmith.Engine Namespace


CompileTemplateResult Constructor (CacheEntry, TimeSpan)

Initializes a new instance of the CompileTemplateResult class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CompileTemplateResult(
    CacheEntry cacheEntry,
    TimeSpan duration
)
Public Sub New (
    cacheEntry As CacheEntry,
    duration As TimeSpan
)

Parameters

cacheEntry
Type: CodeSmith.Engine.CompilerCacheEntry
duration
Type: SystemTimeSpan
See Also

Reference

CompileTemplateResult Class
CompileTemplateResult Overload
CodeSmith.Engine Namespace


CompileTemplateResult Constructor (CompileResult, TimeSpan)

Initializes a new instance of the CompileTemplateResult class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CompileTemplateResult(
    CompileResult result,
    TimeSpan duration
)
Public Sub New (
    result As CompileResult,
    duration As TimeSpan
)

Parameters

result
Type: CodeSmith.Engine.CompilerCompileResult
duration
Type: SystemTimeSpan
See Also

Reference

CompileTemplateResult Class
CompileTemplateResult Overload
CodeSmith.Engine Namespace


CompileTemplateResult Constructor (TemplateParseResult, TimeSpan)

Initializes a new instance of the CompileTemplateResult class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CompileTemplateResult(
    TemplateParseResult parseResult,
    TimeSpan duration
)
Public Sub New (
    parseResult As TemplateParseResult,
    duration As TimeSpan
)

Parameters

parseResult
Type: CodeSmith.EngineTemplateParseResult
duration
Type: SystemTimeSpan
See Also

Reference

CompileTemplateResult Class
CompileTemplateResult Overload
CodeSmith.Engine Namespace


CompileTemplateResult Properties

The CompileTemplateResult type exposes the following members.

Properties
 | Name | Description
Public property | CodeBehind |
Public property | CompiledAssembly |
Public property | CompilerVersion |
Public property | DependenciesHashCode |
Public property | Description |
Public property | Duration |
Public property | Encoding |
Public property | Errors |
Public property | FileDependencies |
Public property | FullPath |
Public property | FullTypeName |
Public property | IsFromCache |
Public property | Language |
Public property | OutputDirectory |
Public property | OutputType |
Public property | PathToAssembly |
Public property | Success |
Public property | TargetLanguage |
Top
See Also

Reference

CompileTemplateResult Class
CodeSmith.Engine Namespace


CompileTemplateResult.CodeBehind Property

CompileTemplateResultCodeBehind Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string CodeBehind { get; }
Public ReadOnly Property CodeBehind As String
    Get

Property Value

Type: String
See Also

Reference

CompileTemplateResult Class
CodeSmith.Engine Namespace


CompileTemplateResult.CompiledAssembly Property

CompileTemplateResultCompiledAssembly Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public Assembly CompiledAssembly { get; }
Public ReadOnly Property CompiledAssembly As Assembly
    Get

Property Value

Type: Assembly
See Also

Reference

CompileTemplateResult Class
CodeSmith.Engine Namespace


CompileTemplateResult.CompilerVersion Property

CompileTemplateResultCompilerVersion Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string CompilerVersion { get; }
Public ReadOnly Property CompilerVersion As String
    Get

Property Value

Type: String
See Also

Reference

CompileTemplateResult Class
CodeSmith.Engine Namespace


CompileTemplateResult.DependenciesHashCode Property

CompileTemplateResultDependenciesHashCode Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public int DependenciesHashCode { get; }
Public ReadOnly Property DependenciesHashCode As Integer
    Get

Property Value

Type: Int32
See Also

Reference

CompileTemplateResult Class
CodeSmith.Engine Namespace


CompileTemplateResult.Description Property

CompileTemplateResultDescription Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string Description { get; }
Public ReadOnly Property Description As String
    Get

Property Value

Type: String
See Also

Reference

CompileTemplateResult Class
CodeSmith.Engine Namespace


CompileTemplateResult.Duration Property

CompileTemplateResultDuration Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public TimeSpan Duration { get; }
Public ReadOnly Property Duration As TimeSpan
    Get

Property Value

Type: TimeSpan
See Also

Reference

CompileTemplateResult Class
CodeSmith.Engine Namespace


CompileTemplateResult.Encoding Property

CompileTemplateResultEncoding Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string Encoding { get; }
Public ReadOnly Property Encoding As String
    Get

Property Value

Type: String
See Also

Reference

CompileTemplateResult Class
CodeSmith.Engine Namespace


CompileTemplateResult.Errors Property

CompileTemplateResultErrors Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public TemplateErrorCollection Errors { get; }
Public ReadOnly Property Errors As TemplateErrorCollection
    Get

Property Value

Type: TemplateErrorCollection
See Also

Reference

CompileTemplateResult Class
CodeSmith.Engine Namespace


CompileTemplateResult.FileDependencies Property

CompileTemplateResultFileDependencies Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ISet<string> FileDependencies { get; }
Public ReadOnly Property FileDependencies As ISet(Of String)
    Get

Property Value

Type: ISet String
See Also

Reference

CompileTemplateResult Class
CodeSmith.Engine Namespace


CompileTemplateResult.FullPath Property

CompileTemplateResultFullPath Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string FullPath { get; }
Public ReadOnly Property FullPath As String
    Get

Property Value

Type: String
See Also

Reference

CompileTemplateResult Class
CodeSmith.Engine Namespace


CompileTemplateResult.FullTypeName Property

CompileTemplateResultFullTypeName Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string FullTypeName { get; }
Public ReadOnly Property FullTypeName As String
    Get

Property Value

Type: String
See Also

Reference

CompileTemplateResult Class
CodeSmith.Engine Namespace


CompileTemplateResult.IsFromCache Property

CompileTemplateResultIsFromCache Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool IsFromCache { get; }
Public ReadOnly Property IsFromCache As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

CompileTemplateResult Class
CodeSmith.Engine Namespace


CompileTemplateResult.Language Property

CompileTemplateResultLanguage Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string Language { get; }
Public ReadOnly Property Language As String
    Get

Property Value

Type: String
See Also

Reference

CompileTemplateResult Class
CodeSmith.Engine Namespace


CompileTemplateResult.OutputDirectory Property

CompileTemplateResultOutputDirectory Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string OutputDirectory { get; }
Public ReadOnly Property OutputDirectory As String
    Get

Property Value

Type: String
See Also

Reference

CompileTemplateResult Class
CodeSmith.Engine Namespace


CompileTemplateResult.OutputType Property

CompileTemplateResultOutputType Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CodeTemplateOutputType OutputType { get; }
Public ReadOnly Property OutputType As CodeTemplateOutputType
    Get

Property Value

Type: CodeTemplateOutputType
See Also

Reference

CompileTemplateResult Class
CodeSmith.Engine Namespace


CompileTemplateResult.PathToAssembly Property

CompileTemplateResultPathToAssembly Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string PathToAssembly { get; }
Public ReadOnly Property PathToAssembly As String
    Get

Property Value

Type: String
See Also

Reference

CompileTemplateResult Class
CodeSmith.Engine Namespace


CompileTemplateResult.Success Property

CompileTemplateResultSuccess Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool Success { get; }
Public ReadOnly Property Success As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

CompileTemplateResult Class
CodeSmith.Engine Namespace


CompileTemplateResult.TargetLanguage Property

CompileTemplateResultTargetLanguage Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string TargetLanguage { get; }
Public ReadOnly Property TargetLanguage As String
    Get

Property Value

Type: String
See Also

Reference

CompileTemplateResult Class
CodeSmith.Engine Namespace


CompileTemplateResult Methods

The CompileTemplateResult type exposes the following members.

Methods
 | Name | Description
Public method | CreateTemplateInstance |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HaveDependenciesBeenModified |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CompileTemplateResult Class
CodeSmith.Engine Namespace


CompileTemplateResult.CreateTemplateInstance Method

CompileTemplateResultCreateTemplateInstance Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CodeTemplate CreateTemplateInstance()
Public Function CreateTemplateInstance As CodeTemplate

Return Value

Type: CodeTemplate
See Also

Reference

CompileTemplateResult Class
CodeSmith.Engine Namespace


CompileTemplateResult.HaveDependenciesBeenModified Method

CompileTemplateResultHaveDependenciesBeenModified Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool HaveDependenciesBeenModified()
Public Function HaveDependenciesBeenModified As Boolean

Return Value

Type: Boolean
See Also

Reference

CompileTemplateResult Class
CodeSmith.Engine Namespace


Configuration Class

Inheritance Hierarchy
SystemObject
CodeSmith.EngineConfigurationBase
CodeSmith.EngineCachedConfiguration
CodeSmith.EngineConfiguration

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class Configuration : CachedConfiguration
Public Class Configuration
    Inherits CachedConfiguration

The Configuration type exposes the following members.

Constructors
 | Name | Description
Protected method | Configuration | Initializes a new instance of the Configuration class.
Top
Properties
 | Name | Description
 | ApplicationConfigurationDirectory |
Public property | ApplicationDirectory | Gets or sets the application directory.
Public property | AverageCostPerHour | Gets or sets the average cost per hour.
Public property | AverageLinesPerHour | Gets or sets the average lines per hour.
Public property | CodeSmithBaseSampleDirectory | Gets or sets the base CodeSmith sample directory.
Public property | CodeSmithDataDirectory | Gets or sets the CodeSmith data directory.
Public property | CodeSmithMapsDirectory | Gets or sets the CodeSmith maps directory.
Public property | CodeSmithSampleDirectory | Gets or sets the CodeSmith sample directory.
Public property | CodeSmithTemplatesDirectory | Gets or sets the CodeSmith templates directory.
Public property | ConditionalCompilation | Gets the conditional compilation statements for the compiler.
Public property | ConfigurationVersion | (Inherited from ConfigurationBase.)
Public property | CustomerExperienceImprovementProgramEnabled | Controls whether the Customer Experience Improvement Program is enabled.
 | Instance | Gets the current singleton instance of Configuration.
Public property | LanguageRegionDefinitions | Gets the language region definitions.
Public property | LinesGenerated | Gets or sets the number of lines generated.
Public property | MergeStrategyAliases | Gets the merge strategy aliases.
Protected property | NamePrefix | (Overrides ConfigurationBaseNamePrefix.)
Public property | ProbingPath | Gets or sets the semicolon delimited list of assembly probing paths. The path is relative to ApplicationDirectory.
Public property | PropertyDesignerMaps | Gets the property designer maps.
Public property | PropertySetCacheDirectory | Gets or sets the property set cache directory.
Public property | TemplateCacheDirectory | Gets or sets the template cache directory.
Public property | TrackLinesGenerated | Gets or sets a value indicating whether to track lines generated.
 | UserConfigurationDirectory |
Top
Methods
 | Name | Description
 | DeleteLicenseFiles |
Public method | Dispose | (Inherited from CachedConfiguration.)
Public method | EnsureInitialize | This method is here purely to make sure that we don't make a double call to the Initialize method while initializing configuration. (Inherited from ConfigurationBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetCachedValueT(String) | (Inherited from CachedConfiguration.)
Protected method | GetCachedValueT(String, T) | (Inherited from CachedConfiguration.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetHoursSaved | Returns the numbers of hours saved by using CodeSmith.
Public method | GetIconResourcePath | Returns the path to the icon resource dll.
 | GetLicenseDirectory |
Public method | GetMoneySaved | Returns the amount of money saved by using CodeSmith.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetValueT(String) | (Inherited from ConfigurationBase.)
Protected method | GetValueT(String, T) | (Inherited from ConfigurationBase.)
Protected method | GetValueT(String, Action) | (Inherited from ConfigurationBase.)
Protected method | GetValueT(String, T, FuncT, Boolean) | (Inherited from ConfigurationBase.)
Protected method | GetValueT(String, Action, FuncT, Boolean) | (Inherited from ConfigurationBase.)
Protected method | GetValueT(String, String, T) | (Inherited from ConfigurationBase.)
Protected method | GetValueT(String, String, Action) | (Inherited from ConfigurationBase.)
Protected method | GetValueT(String, String, T, FuncT, Boolean) | (Inherited from ConfigurationBase.)
Protected method | GetValueT(String, String, Action, FuncT, Boolean) | (Inherited from ConfigurationBase.)
Public method | Initialize | (Overrides ConfigurationBaseInitialize.)
Public method | LoadDefaults | This method will safely upgrade the default values for collections and overwrite any directory settings. (Overrides ConfigurationBaseLoadDefaults.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ResetDefaults | (Overrides ConfigurationBaseResetDefaults.)
 | SetLicenseAssembly | Checks an assembly for an embedded license.
Protected method | SetValueT(String, T) | (Inherited from ConfigurationBase.)
Protected method | SetValueT(String, String, T) | (Inherited from CachedConfiguration.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateLinesGenerated | Updates Lines Generated based off of the passed in string containing source code.
Public method | Upgrade | (Overrides ConfigurationBaseUpgrade.)
Protected method | UpgradeFileT | Attempts to update configuration from a configuration file. The version of CodeSmith must be older than CodeSmith 5.1. (Inherited from ConfigurationBase.)
Top
Fields
Name | Description
EMBEDDED_LICENSE_FILE |
LICENSE_FILE |
Top
See Also

Reference

CodeSmith.Engine Namespace


Configuration Constructor

Initializes a new instance of the Configuration class.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected Configuration()
Protected Sub New
See Also

Reference

Configuration Class
CodeSmith.Engine Namespace


Configuration Properties

The Configuration type exposes the following members.

Properties
 | Name | Description
 | ApplicationConfigurationDirectory |
Public property | ApplicationDirectory | Gets or sets the application directory.
Public property | AverageCostPerHour | Gets or sets the average cost per hour.
Public property | AverageLinesPerHour | Gets or sets the average lines per hour.
Public property | CodeSmithBaseSampleDirectory | Gets or sets the base CodeSmith sample directory.
Public property | CodeSmithDataDirectory | Gets or sets the CodeSmith data directory.
Public property | CodeSmithMapsDirectory | Gets or sets the CodeSmith maps directory.
Public property | CodeSmithSampleDirectory | Gets or sets the CodeSmith sample directory.
Public property | CodeSmithTemplatesDirectory | Gets or sets the CodeSmith templates directory.
Public property | ConditionalCompilation | Gets the conditional compilation statements for the compiler.
Public property | ConfigurationVersion | (Inherited from ConfigurationBase.)
Public property | CustomerExperienceImprovementProgramEnabled | Controls whether the Customer Experience Improvement Program is enabled.
 | Instance | Gets the current singleton instance of Configuration.
Public property | LanguageRegionDefinitions | Gets the language region definitions.
Public property | LinesGenerated | Gets or sets the number of lines generated.
Public property | MergeStrategyAliases | Gets the merge strategy aliases.
Protected property | NamePrefix | (Overrides ConfigurationBaseNamePrefix.)
Public property | ProbingPath | Gets or sets the semicolon delimited list of assembly probing paths. The path is relative to ApplicationDirectory.
Public property | PropertyDesignerMaps | Gets the property designer maps.
Public property | PropertySetCacheDirectory | Gets or sets the property set cache directory.
Public property | TemplateCacheDirectory | Gets or sets the template cache directory.
Public property | TrackLinesGenerated | Gets or sets a value indicating whether to track lines generated.
 | UserConfigurationDirectory |
Top
See Also

Reference

Configuration Class
CodeSmith.Engine Namespace


Configuration.ApplicationConfigurationDirectory Property

ConfigurationApplicationConfigurationDirectory Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static string ApplicationConfigurationDirectory { get; }
Public Shared ReadOnly Property ApplicationConfigurationDirectory As String
    Get

Property Value

Type: String
See Also

Reference

Configuration Class
CodeSmith.Engine Namespace


Configuration.ApplicationDirectory Property

ConfigurationApplicationDirectory Property

Gets or sets the application directory.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string ApplicationDirectory { get; }
Public ReadOnly Property ApplicationDirectory As String
    Get

Property Value

Type: String
The application directory.
See Also

Reference

Configuration Class
CodeSmith.Engine Namespace


Configuration.AverageCostPerHour Property

ConfigurationAverageCostPerHour Property

Gets or sets the average cost per hour.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public decimal AverageCostPerHour { get; set; }
Public Property AverageCostPerHour As Decimal
    Get
    Set

Property Value

Type: Decimal
The average cost per hour.
See Also

Reference

Configuration Class
CodeSmith.Engine Namespace


Configuration.AverageLinesPerHour Property

ConfigurationAverageLinesPerHour Property

Gets or sets the average lines per hour.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public int AverageLinesPerHour { get; set; }
Public Property AverageLinesPerHour As Integer
    Get
    Set

Property Value

Type: Int32
The average lines per hour.
See Also

Reference

Configuration Class
CodeSmith.Engine Namespace


Configuration.CodeSmithBaseSampleDirectory Property

ConfigurationCodeSmithBaseSampleDirectory Property

Gets or sets the base CodeSmith sample directory.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string CodeSmithBaseSampleDirectory { get; set; }
Public Property CodeSmithBaseSampleDirectory As String
    Get
    Set

Property Value

Type: String
The CodeSmith sample directory.
See Also

Reference

Configuration Class
CodeSmith.Engine Namespace


Configuration.CodeSmithDataDirectory Property

ConfigurationCodeSmithDataDirectory Property

Gets or sets the CodeSmith data directory.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string CodeSmithDataDirectory { get; set; }
Public Property CodeSmithDataDirectory As String
    Get
    Set

Property Value

Type: String
The CodeSmith data directory.
See Also

Reference

Configuration Class
CodeSmith.Engine Namespace


Configuration.CodeSmithMapsDirectory Property

ConfigurationCodeSmithMapsDirectory Property

Gets or sets the CodeSmith maps directory.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string CodeSmithMapsDirectory { get; set; }
Public Property CodeSmithMapsDirectory As String
    Get
    Set

Property Value

Type: String
The CodeSmith maps directory.
See Also

Reference

Configuration Class
CodeSmith.Engine Namespace


Configuration.CodeSmithSampleDirectory Property

ConfigurationCodeSmithSampleDirectory Property

Gets or sets the CodeSmith sample directory.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string CodeSmithSampleDirectory { get; set; }
Public Property CodeSmithSampleDirectory As String
    Get
    Set

Property Value

Type: String
The CodeSmith sample directory.
See Also

Reference

Configuration Class
CodeSmith.Engine Namespace


Configuration.CodeSmithTemplatesDirectory Property

ConfigurationCodeSmithTemplatesDirectory Property

Gets or sets the CodeSmith templates directory.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string CodeSmithTemplatesDirectory { get; set; }
Public Property CodeSmithTemplatesDirectory As String
    Get
    Set

Property Value

Type: String
The CodeSmith templates directory.
See Also

Reference

Configuration Class
CodeSmith.Engine Namespace


Configuration.ConditionalCompilation Property

ConfigurationConditionalCompilation Property

Gets the conditional compilation statements for the compiler.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public DelimitedStringCollection ConditionalCompilation { get; set; }
Public Property ConditionalCompilation As DelimitedStringCollection
    Get
    Set

Property Value

Type: DelimitedStringCollection
The conditional compilation.
See Also

Reference

Configuration Class
CodeSmith.Engine Namespace


Configuration.CustomerExperienceImprovementProgramEnabled Property

ConfigurationCustomerExperienceImprovementProgramEnabled Property

Controls whether the Customer Experience Improvement Program is enabled.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool CustomerExperienceImprovementProgramEnabled { get; set; }
Public Property CustomerExperienceImprovementProgramEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

Configuration Class
CodeSmith.Engine Namespace


Configuration.Instance Property

ConfigurationInstance Property

Gets the current singleton instance of Configuration.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static Configuration Instance { get; }
Public Shared ReadOnly Property Instance As Configuration
    Get

Property Value

Type: Configuration
The current singleton instance.
Remarks
An instance of Configuration wont be created until the very first call to the sealed class. This is a CLR optimization that provides a properly lazy-loading singleton.
See Also

Reference

Configuration Class
CodeSmith.Engine Namespace


Configuration.LanguageRegionDefinitions Property

ConfigurationLanguageRegionDefinitions Property

Gets the language region definitions.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public LanguageRegionDefinitionCollection LanguageRegionDefinitions { get; set; }
Public Property LanguageRegionDefinitions As LanguageRegionDefinitionCollection
    Get
    Set

Property Value

Type: LanguageRegionDefinitionCollection
The language region definitions.
See Also

Reference

Configuration Class
CodeSmith.Engine Namespace


Configuration.LinesGenerated Property

ConfigurationLinesGenerated Property

Gets or sets the number of lines generated.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public long LinesGenerated { get; set; }
Public Property LinesGenerated As Long
    Get
    Set

Property Value

Type: Int64
The number of lines generated.
See Also

Reference

Configuration Class
CodeSmith.Engine Namespace


Configuration.MergeStrategyAliases Property

ConfigurationMergeStrategyAliases Property

Gets the merge strategy aliases.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public MergeStrategyAliasCollection MergeStrategyAliases { get; set; }
Public Property MergeStrategyAliases As MergeStrategyAliasCollection
    Get
    Set

Property Value

Type: MergeStrategyAliasCollection
The merge strategy aliases.
See Also

Reference

Configuration Class
CodeSmith.Engine Namespace


Configuration.NamePrefix Property

ConfigurationNamePrefix Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected override string NamePrefix { get; }
Protected Overrides ReadOnly Property NamePrefix As String
    Get

Property Value

Type: String
See Also

Reference

Configuration Class
CodeSmith.Engine Namespace


Configuration.ProbingPath Property

ConfigurationProbingPath Property

Gets or sets the semicolon delimited list of assembly probing paths. The path is relative to ApplicationDirectory.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string ProbingPath { get; set; }
Public Property ProbingPath As String
    Get
    Set

Property Value

Type: String
The semicolon delimited list of assembly probing paths.
See Also

Reference

Configuration Class
CodeSmith.Engine Namespace


Configuration.PropertyDesignerMaps Property

ConfigurationPropertyDesignerMaps Property

Gets the property designer maps.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public PropertyDesignerMapCollection PropertyDesignerMaps { get; set; }
Public Property PropertyDesignerMaps As PropertyDesignerMapCollection
    Get
    Set

Property Value

Type: PropertyDesignerMapCollection
The property designer maps.
See Also

Reference

Configuration Class
CodeSmith.Engine Namespace


Configuration.PropertySetCacheDirectory Property

ConfigurationPropertySetCacheDirectory Property

Gets or sets the property set cache directory.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string PropertySetCacheDirectory { get; set; }
Public Property PropertySetCacheDirectory As String
    Get
    Set

Property Value

Type: String
The property set cache directory.
See Also

Reference

Configuration Class
CodeSmith.Engine Namespace


Configuration.TemplateCacheDirectory Property

ConfigurationTemplateCacheDirectory Property

Gets or sets the template cache directory.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string TemplateCacheDirectory { get; set; }
Public Property TemplateCacheDirectory As String
    Get
    Set

Property Value

Type: String
The template cache directory.
See Also

Reference

Configuration Class
CodeSmith.Engine Namespace


Configuration.TrackLinesGenerated Property

ConfigurationTrackLinesGenerated Property

Gets or sets a value indicating whether to track lines generated.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool TrackLinesGenerated { get; set; }
Public Property TrackLinesGenerated As Boolean
    Get
    Set

Property Value

Type: Boolean
true to track lines generated; otherwise, false.
See Also

Reference

Configuration Class
CodeSmith.Engine Namespace


Configuration.UserConfigurationDirectory Property

ConfigurationUserConfigurationDirectory Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static string UserConfigurationDirectory { get; }
Public Shared ReadOnly Property UserConfigurationDirectory As String
    Get

Property Value

Type: String
See Also

Reference

Configuration Class
CodeSmith.Engine Namespace


Configuration Methods

The Configuration type exposes the following members.

Methods
 | Name | Description
 | DeleteLicenseFiles |
Public method | Dispose | (Inherited from CachedConfiguration.)
Public method | EnsureInitialize | This method is here purely to make sure that we don't make a double call to the Initialize method while initializing configuration. (Inherited from ConfigurationBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetCachedValueT(String) | (Inherited from CachedConfiguration.)
Protected method | GetCachedValueT(String, T) | (Inherited from CachedConfiguration.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetHoursSaved | Returns the numbers of hours saved by using CodeSmith.
Public method | GetIconResourcePath | Returns the path to the icon resource dll.
 | GetLicenseDirectory |
Public method | GetMoneySaved | Returns the amount of money saved by using CodeSmith.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetValueT(String) | (Inherited from ConfigurationBase.)
Protected method | GetValueT(String, T) | (Inherited from ConfigurationBase.)
Protected method | GetValueT(String, Action) | (Inherited from ConfigurationBase.)
Protected method | GetValueT(String, T, FuncT, Boolean) | (Inherited from ConfigurationBase.)
Protected method | GetValueT(String, Action, FuncT, Boolean) | (Inherited from ConfigurationBase.)
Protected method | GetValueT(String, String, T) | (Inherited from ConfigurationBase.)
Protected method | GetValueT(String, String, Action) | (Inherited from ConfigurationBase.)
Protected method | GetValueT(String, String, T, FuncT, Boolean) | (Inherited from ConfigurationBase.)
Protected method | GetValueT(String, String, Action, FuncT, Boolean) | (Inherited from ConfigurationBase.)
Public method | Initialize | (Overrides ConfigurationBaseInitialize.)
Public method | LoadDefaults | This method will safely upgrade the default values for collections and overwrite any directory settings. (Overrides ConfigurationBaseLoadDefaults.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ResetDefaults | (Overrides ConfigurationBaseResetDefaults.)
 | SetLicenseAssembly | Checks an assembly for an embedded license.
Protected method | SetValueT(String, T) | (Inherited from ConfigurationBase.)
Protected method | SetValueT(String, String, T) | (Inherited from CachedConfiguration.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateLinesGenerated | Updates Lines Generated based off of the passed in string containing source code.
Public method | Upgrade | (Overrides ConfigurationBaseUpgrade.)
Protected method | UpgradeFileT | Attempts to update configuration from a configuration file. The version of CodeSmith must be older than CodeSmith 5.1. (Inherited from ConfigurationBase.)
Top
See Also

Reference

Configuration Class
CodeSmith.Engine Namespace


Configuration.DeleteLicenseFiles Method

ConfigurationDeleteLicenseFiles Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static bool DeleteLicenseFiles()
Public Shared Function DeleteLicenseFiles As Boolean

Return Value

Type: Boolean
See Also

Reference

Configuration Class
CodeSmith.Engine Namespace


Configuration.GetHoursSaved Method

ConfigurationGetHoursSaved Method

Returns the numbers of hours saved by using CodeSmith.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public decimal GetHoursSaved()
Public Function GetHoursSaved As Decimal

Return Value

Type: Decimal
Returns the numbers of hours saved by using CodeSmith.
See Also

Reference

Configuration Class
CodeSmith.Engine Namespace


Configuration.GetIconResourcePath Method

ConfigurationGetIconResourcePath Method

Returns the path to the icon resource dll.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string GetIconResourcePath()
Public Function GetIconResourcePath As String

Return Value

Type: String
Returns the path to the icon resource dll.
See Also

Reference

Configuration Class
CodeSmith.Engine Namespace


Configuration.GetLicenseDirectory Method

ConfigurationGetLicenseDirectory Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static string GetLicenseDirectory()
Public Shared Function GetLicenseDirectory As String

Return Value

Type: String
See Also

Reference

Configuration Class
CodeSmith.Engine Namespace


Configuration.GetMoneySaved Method

ConfigurationGetMoneySaved Method

Returns the amount of money saved by using CodeSmith.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public decimal GetMoneySaved()
Public Function GetMoneySaved As Decimal

Return Value

Type: Decimal
Returns the amount of money saved by using CodeSmith.
See Also

Reference

Configuration Class
CodeSmith.Engine Namespace


Configuration.Initialize Method

ConfigurationInitialize Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override void Initialize()
Public Overrides Sub Initialize
See Also

Reference

Configuration Class
CodeSmith.Engine Namespace


Configuration.LoadDefaults Method

ConfigurationLoadDefaults Method

This method will safely upgrade the default values for collections and overwrite any directory settings.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override void LoadDefaults()
Public Overrides Sub LoadDefaults
See Also

Reference

Configuration Class
CodeSmith.Engine Namespace


Configuration.ResetDefaults Method

ConfigurationResetDefaults Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override void ResetDefaults()
Public Overrides Sub ResetDefaults
See Also

Reference

Configuration Class
CodeSmith.Engine Namespace


Configuration.SetLicenseAssembly Method

ConfigurationSetLicenseAssembly Method

Checks an assembly for an embedded license.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static void SetLicenseAssembly(
    Assembly assembly
)
Public Shared Sub SetLicenseAssembly (
    assembly As Assembly
)

Parameters

assembly
Type: System.ReflectionAssembly
The assembly with the embedded license.
See Also

Reference

Configuration Class
CodeSmith.Engine Namespace


Configuration.UpdateLinesGenerated Method

ConfigurationUpdateLinesGenerated Method

Updates Lines Generated based off of the passed in string containing source code.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void UpdateLinesGenerated(
    string generatedCode
)
Public Sub UpdateLinesGenerated (
    generatedCode As String
)

Parameters

generatedCode
Type: SystemString
Source code.
See Also

Reference

Configuration Class
CodeSmith.Engine Namespace


Configuration.Upgrade Method

ConfigurationUpgrade Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override void Upgrade()
Public Overrides Sub Upgrade
See Also

Reference

Configuration Class
CodeSmith.Engine Namespace


Configuration Fields

The Configuration type exposes the following members.

Fields
Name | Description
EMBEDDED_LICENSE_FILE |
LICENSE_FILE |
Top
See Also

Reference

Configuration Class
CodeSmith.Engine Namespace


Configuration.EMBEDDED_LICENSE_FILE Field

ConfigurationEMBEDDED_LICENSE_FILE Field

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public const string EMBEDDED_LICENSE_FILE = "CodeSmith85.embedded.lic"
Public Const EMBEDDED_LICENSE_FILE As String = "CodeSmith85.embedded.lic"

Field Value

Type: String
See Also

Reference

Configuration Class
CodeSmith.Engine Namespace


Configuration.LICENSE_FILE Field

ConfigurationLICENSE_FILE Field

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public const string LICENSE_FILE = "CodeSmith85.lic"
Public Const LICENSE_FILE As String = "CodeSmith85.lic"

Field Value

Type: String
See Also

Reference

Configuration Class
CodeSmith.Engine Namespace


ConfigurationBase Class

Inheritance Hierarchy
SystemObject
CodeSmith.EngineConfigurationBase
CodeSmith.EngineActiveSnippetConfiguration
CodeSmith.EngineCachedConfiguration
SchemaExplorerConfiguration

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public abstract class ConfigurationBase : IDisposable
Public MustInherit Class ConfigurationBase
    Implements IDisposable

The ConfigurationBase type exposes the following members.

Constructors
 | Name | Description
Protected method | ConfigurationBase | Initializes a new instance of the ConfigurationBase class
Top
Properties
 | Name | Description
Public property | ConfigurationVersion |
Protected property | NamePrefix |
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | EnsureInitialize | This method is here purely to make sure that we don't make a double call to the Initialize method while initializing configuration.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetValueT(String) |
Protected method | GetValueT(String, T) |
Protected method | GetValueT(String, Action) |
Protected method | GetValueT(String, T, FuncT, Boolean) |
Protected method | GetValueT(String, Action, FuncT, Boolean) |
Protected method | GetValueT(String, String, T) |
Protected method | GetValueT(String, String, Action) |
Protected method | GetValueT(String, String, T, FuncT, Boolean) |
Protected method | GetValueT(String, String, Action, FuncT, Boolean) |
Public method | Initialize |
Public method | LoadDefaults |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ResetDefaults |
Protected method | SetValueT(String, T) |
Protected method | SetValueT(String, String, T) |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Upgrade |
Protected method | UpgradeFileT | Attempts to update configuration from a configuration file. The version of CodeSmith must be older than CodeSmith 5.1.
Top
See Also

Reference

CodeSmith.Engine Namespace


ConfigurationBase Constructor

Initializes a new instance of the ConfigurationBase class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected ConfigurationBase()
Protected Sub New
See Also

Reference

ConfigurationBase Class
CodeSmith.Engine Namespace


ConfigurationBase Properties

The ConfigurationBase type exposes the following members.

Properties
 | Name | Description
Public property | ConfigurationVersion |
Protected property | NamePrefix |
Top
See Also

Reference

ConfigurationBase Class
CodeSmith.Engine Namespace


ConfigurationBase.ConfigurationVersion Property

ConfigurationBaseConfigurationVersion Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string ConfigurationVersion { get; set; }
Public Property ConfigurationVersion As String
    Get
    Set

Property Value

Type: String
See Also

Reference

ConfigurationBase Class
CodeSmith.Engine Namespace


ConfigurationBase.NamePrefix Property

ConfigurationBaseNamePrefix Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected abstract string NamePrefix { get; }
Protected MustOverride ReadOnly Property NamePrefix As String
    Get

Property Value

Type: String
See Also

Reference

ConfigurationBase Class
CodeSmith.Engine Namespace


ConfigurationBase Methods

The ConfigurationBase type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | EnsureInitialize | This method is here purely to make sure that we don't make a double call to the Initialize method while initializing configuration.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetValueT(String) |
Protected method | GetValueT(String, T) |
Protected method | GetValueT(String, Action) |
Protected method | GetValueT(String, T, FuncT, Boolean) |
Protected method | GetValueT(String, Action, FuncT, Boolean) |
Protected method | GetValueT(String, String, T) |
Protected method | GetValueT(String, String, Action) |
Protected method | GetValueT(String, String, T, FuncT, Boolean) |
Protected method | GetValueT(String, String, Action, FuncT, Boolean) |
Public method | Initialize |
Public method | LoadDefaults |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ResetDefaults |
Protected method | SetValueT(String, T) |
Protected method | SetValueT(String, String, T) |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Upgrade |
Protected method | UpgradeFileT | Attempts to update configuration from a configuration file. The version of CodeSmith must be older than CodeSmith 5.1.
Top
See Also

Reference

ConfigurationBase Class
CodeSmith.Engine Namespace


ConfigurationBase.Dispose Method

ConfigurationBaseDispose Method

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual void Dispose()
Public Overridable Sub Dispose

Implements

IDisposableDispose
See Also

Reference

ConfigurationBase Class
CodeSmith.Engine Namespace


ConfigurationBase.EnsureInitialize Method

ConfigurationBaseEnsureInitialize Method

This method is here purely to make sure that we don't make a double call to the Initialize method while initializing configuration.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void EnsureInitialize()
Public Sub EnsureInitialize
See Also

Reference

ConfigurationBase Class
CodeSmith.Engine Namespace


ConfigurationBase.GetValue Method

ConfigurationBaseGetValue Method

Overload List
 | Name | Description
Protected method | GetValueT(String) |
Protected method | GetValueT(String, T) |
Protected method | GetValueT(String, Action) |
Protected method | GetValueT(String, T, FuncT, Boolean) |
Protected method | GetValueT(String, Action, FuncT, Boolean) |
Protected method | GetValueT(String, String, T) |
Protected method | GetValueT(String, String, Action) |
Protected method | GetValueT(String, String, T, FuncT, Boolean) |
Protected method | GetValueT(String, String, Action, FuncT, Boolean) |
Top
See Also

Reference

ConfigurationBase Class
CodeSmith.Engine Namespace


ConfigurationBase.GetValue(T) Method (String)

ConfigurationBaseGetValueT Method (String)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected T GetValue<T>(
    string name
)

Protected Function GetValue(Of T) (
    name As String
) As T

Parameters

name
Type: SystemString

Type Parameters

T

Return Value

Type: T
See Also

Reference

ConfigurationBase Class
GetValue Overload
CodeSmith.Engine Namespace


ConfigurationBase.GetValue(T) Method (String, T)

ConfigurationBaseGetValueT Method (String, T)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual T GetValue<T>(
    string name,
    T defaultValue
)

Protected Overridable Function GetValue(Of T) (
    name As String,
    defaultValue As T
) As T

Parameters

name
Type: SystemString
defaultValue
Type: T

Type Parameters

T

Return Value

Type: T
See Also

Reference

ConfigurationBase Class
GetValue Overload
CodeSmith.Engine Namespace


ConfigurationBase.GetValue(T) Method (String, Action)

ConfigurationBaseGetValueT Method (String, Action)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual T GetValue<T>(
    string name,
    Action defaultMethod
)

Protected Overridable Function GetValue(Of T) (
    name As String,
    defaultMethod As Action
) As T

Parameters

name
Type: SystemString
defaultMethod
Type: SystemAction

Type Parameters

T

Return Value

Type: T
See Also

Reference

ConfigurationBase Class
GetValue Overload
CodeSmith.Engine Namespace


ConfigurationBase.GetValue(T) Method (String, T, Func(T, Boolean))

ConfigurationBaseGetValueT Method (String, T, FuncT, Boolean)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual T GetValue<T>(
    string name,
    T defaultValue,
    Func<T, bool> expression
)

Protected Overridable Function GetValue(Of T) (
    name As String,
    defaultValue As T,
    expression As Func(Of T, Boolean)
) As T

Parameters

name
Type: SystemString
defaultValue
Type: T
expression
Type: SystemFunc T, Boolean

Type Parameters

T

Return Value

Type: T
See Also

Reference

ConfigurationBase Class
GetValue Overload
CodeSmith.Engine Namespace


ConfigurationBase.GetValue(T) Method (String, Action, Func(T, Boolean))

ConfigurationBaseGetValueT Method (String, Action, FuncT, Boolean)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual T GetValue<T>(
    string name,
    Action defaultMethod,
    Func<T, bool> expression
)

Protected Overridable Function GetValue(Of T) (
    name As String,
    defaultMethod As Action,
    expression As Func(Of T, Boolean)
) As T

Parameters

name
Type: SystemString
defaultMethod
Type: SystemAction
expression
Type: SystemFunc T, Boolean

Type Parameters

T

Return Value

Type: T
See Also

Reference

ConfigurationBase Class
GetValue Overload
CodeSmith.Engine Namespace


ConfigurationBase.GetValue(T) Method (String, String, T)

ConfigurationBaseGetValueT Method (String, String, T)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual T GetValue<T>(
    string subKey,
    string name,
    T defaultValue
)

Protected Overridable Function GetValue(Of T) (
    subKey As String,
    name As String,
    defaultValue As T
) As T

Parameters

subKey
Type: SystemString
name
Type: SystemString
defaultValue
Type: T

Type Parameters

T

Return Value

Type: T
See Also

Reference

ConfigurationBase Class
GetValue Overload
CodeSmith.Engine Namespace


ConfigurationBase.GetValue(T) Method (String, String, Action)

ConfigurationBaseGetValueT Method (String, String, Action)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual T GetValue<T>(
    string subKey,
    string name,
    Action defaultMethod
)

Protected Overridable Function GetValue(Of T) (
    subKey As String,
    name As String,
    defaultMethod As Action
) As T

Parameters

subKey
Type: SystemString
name
Type: SystemString
defaultMethod
Type: SystemAction

Type Parameters

T

Return Value

Type: T
See Also

Reference

ConfigurationBase Class
GetValue Overload
CodeSmith.Engine Namespace


ConfigurationBase.GetValue(T) Method (String, String, T, Func(T, Boolean))

ConfigurationBaseGetValueT Method (String, String, T, FuncT, Boolean)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual T GetValue<T>(
    string subKey,
    string name,
    T defaultValue,
    Func<T, bool> expression
)

Protected Overridable Function GetValue(Of T) (
    subKey As String,
    name As String,
    defaultValue As T,
    expression As Func(Of T, Boolean)
) As T

Parameters

subKey
Type: SystemString
name
Type: SystemString
defaultValue
Type: T
expression
Type: SystemFunc T, Boolean

Type Parameters

T

Return Value

Type: T
See Also

Reference

ConfigurationBase Class
GetValue Overload
CodeSmith.Engine Namespace


ConfigurationBase.GetValue(T) Method (String, String, Action, Func(T, Boolean))

ConfigurationBaseGetValueT Method (String, String, Action, FuncT, Boolean)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual T GetValue<T>(
    string subKey,
    string name,
    Action defaultMethod,
    Func<T, bool> expression
)

Protected Overridable Function GetValue(Of T) (
    subKey As String,
    name As String,
    defaultMethod As Action,
    expression As Func(Of T, Boolean)
) As T

Parameters

subKey
Type: SystemString
name
Type: SystemString
defaultMethod
Type: SystemAction
expression
Type: SystemFunc T, Boolean

Type Parameters

T

Return Value

Type: T
See Also

Reference

ConfigurationBase Class
GetValue Overload
CodeSmith.Engine Namespace


ConfigurationBase.Initialize Method

ConfigurationBaseInitialize Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public abstract void Initialize()
Public MustOverride Sub Initialize
See Also

Reference

ConfigurationBase Class
CodeSmith.Engine Namespace


ConfigurationBase.LoadDefaults Method

ConfigurationBaseLoadDefaults Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public abstract void LoadDefaults()
Public MustOverride Sub LoadDefaults
See Also

Reference

ConfigurationBase Class
CodeSmith.Engine Namespace


ConfigurationBase.ResetDefaults Method

ConfigurationBaseResetDefaults Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public abstract void ResetDefaults()
Public MustOverride Sub ResetDefaults
See Also

Reference

ConfigurationBase Class
CodeSmith.Engine Namespace


ConfigurationBase.SetValue Method

ConfigurationBaseSetValue Method

Overload List
 | Name | Description
Protected method | SetValueT(String, T) |
Protected method | SetValueT(String, String, T) |
Top
See Also

Reference

ConfigurationBase Class
CodeSmith.Engine Namespace


ConfigurationBase.SetValue(T) Method (String, T)

ConfigurationBaseSetValueT Method (String, T)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual void SetValue<T>(
    string name,
    T value
)

Protected Overridable Sub SetValue(Of T) (
    name As String,
    value As T
)

Parameters

name
Type: SystemString
value
Type: T

Type Parameters

T
See Also

Reference

ConfigurationBase Class
SetValue Overload
CodeSmith.Engine Namespace


ConfigurationBase.SetValue(T) Method (String, String, T)

ConfigurationBaseSetValueT Method (String, String, T)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual void SetValue<T>(
    string subKey,
    string name,
    T value
)

Protected Overridable Sub SetValue(Of T) (
    subKey As String,
    name As String,
    value As T
)

Parameters

subKey
Type: SystemString
name
Type: SystemString
value
Type: T

Type Parameters

T
See Also

Reference

ConfigurationBase Class
SetValue Overload
CodeSmith.Engine Namespace


ConfigurationBase.Upgrade Method

ConfigurationBaseUpgrade Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public abstract void Upgrade()
Public MustOverride Sub Upgrade
See Also

Reference

ConfigurationBase Class
CodeSmith.Engine Namespace


ConfigurationBase.UpgradeFile(T) Method

ConfigurationBaseUpgradeFileT Method

Attempts to update configuration from a configuration file. The version of CodeSmith must be older than CodeSmith 5.1.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected T UpgradeFile<T>(
    string fileName
)
where T : class

Protected Function UpgradeFile(Of T As Class) (
    fileName As String
) As T

Parameters

fileName
Type: SystemString
The configuration filename.

Type Parameters

T
Type of the configuration class.

Return Value

Type: T
Updated Configuration file if a configuration file was found.
See Also

Reference

ConfigurationBase Class
CodeSmith.Engine Namespace


ConfigurationBase(T) Class

ConfigurationBaseT Class

Note: This API is now obsolete.

Inheritance Hierarchy
SystemObject
CodeSmith.EngineConfigurationBaseT

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[ObsoleteAttribute]
public abstract class ConfigurationBase<T>
where T : ConfigurationBase

<ObsoleteAttribute>
Public MustInherit Class ConfigurationBase(Of T As ConfigurationBase)

Type Parameters

T

The ConfigurationBaseT type exposes the following members.

Constructors
 | Name | Description
Protected method | ConfigurationBaseT | Initializes a new instance of the ConfigurationBaseT class
Top
Properties
Name | Description
Instance | Obsolete. Gets the singleton instance.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | LoadSettings | Obsolete. Loads this instance.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SaveSettings | Obsolete. Saves this instance.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
Name | Description
SettingChanged | Obsolete.
Top
See Also

Reference

CodeSmith.Engine Namespace


ConfigurationBase(T) Constructor

ConfigurationBaseT Constructor

Initializes a new instance of the ConfigurationBaseT class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected ConfigurationBase()
Protected Sub New
See Also

Reference

ConfigurationBaseT Class
CodeSmith.Engine Namespace


ConfigurationBase(T) Properties

ConfigurationBaseT Properties

The ConfigurationBaseT generic type exposes the following members.

Properties
Name | Description
Instance | Obsolete. Gets the singleton instance.
Top
See Also

Reference

ConfigurationBaseT Class
CodeSmith.Engine Namespace


ConfigurationBase(T).Instance Property

ConfigurationBaseTInstance Property

Note: This API is now obsolete.

Gets the singleton instance.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[ObsoleteAttribute]
public static T Instance { get; }
<ObsoleteAttribute>
Public Shared ReadOnly Property Instance As T
    Get

Property Value

Type: T
The singleton instance.
See Also

Reference

ConfigurationBaseT Class
CodeSmith.Engine Namespace


ConfigurationBase(T) Methods

ConfigurationBaseT Methods

The ConfigurationBaseT generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | LoadSettings | Obsolete. Loads this instance.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SaveSettings | Obsolete. Saves this instance.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ConfigurationBaseT Class
CodeSmith.Engine Namespace


ConfigurationBase(T).LoadSettings Method

ConfigurationBaseTLoadSettings Method

Note: This API is now obsolete.

Loads this instance.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[ObsoleteAttribute]
public static void LoadSettings()
<ObsoleteAttribute>
Public Shared Sub LoadSettings
See Also

Reference

ConfigurationBaseT Class
CodeSmith.Engine Namespace


ConfigurationBase(T).SaveSettings Method

ConfigurationBaseTSaveSettings Method

Note: This API is now obsolete.

Saves this instance.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[ObsoleteAttribute]
public static void SaveSettings()
<ObsoleteAttribute>
Public Shared Sub SaveSettings
See Also

Reference

ConfigurationBaseT Class
CodeSmith.Engine Namespace


ConfigurationBase(T) Events

ConfigurationBaseT Events

The ConfigurationBaseT generic type exposes the following members.

Events
Name | Description
SettingChanged | Obsolete.
Top
See Also

Reference

ConfigurationBaseT Class
CodeSmith.Engine Namespace


ConfigurationBase(T).SettingChanged Event

ConfigurationBaseTSettingChanged Event

Note: This API is now obsolete.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[ObsoleteAttribute]
public static event EventHandler SettingChanged
<ObsoleteAttribute>
Public Shared Event SettingChanged As EventHandler

Value

Type: SystemEventHandler
See Also

Reference

ConfigurationBaseT Class
CodeSmith.Engine Namespace


ConfigurationCollectionBase(T) Class

ConfigurationCollectionBaseT Class

Inheritance Hierarchy
SystemObject
CodeSmith.EngineVirtualCollectionBase T
CodeSmith.EngineConfigurationCollectionBaseT
CodeSmith.EngineActiveSnippetMappingCollection
CodeSmith.EngineLanguageRegionDefinitionCollection
CodeSmith.EngineMergeStrategyAliasCollection
CodeSmith.EnginePropertyDesignerMapCollection

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public abstract class ConfigurationCollectionBase<T> : VirtualCollectionBase<T>
where T : class, IIndexed, INotifyPropertyChanged

Public MustInherit Class ConfigurationCollectionBase(Of T As {Class, IIndexed, INotifyPropertyChanged})
    Inherits VirtualCollectionBase(Of T)

Type Parameters

T

The ConfigurationCollectionBaseT type exposes the following members.

Constructors
 | Name | Description
Protected method | ConfigurationCollectionBaseT | Initializes a new instance of the ConfigurationCollectionBaseT class
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from VirtualCollectionBaseT.)
Public property | Item | Gets or sets the type T at the specified index. (Inherited from VirtualCollectionBaseT.)
Protected property | SubKey |
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from VirtualCollectionBaseT.)
Protected method | AddItem | Adds the item. (Inherited from VirtualCollectionBaseT.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from VirtualCollectionBaseT.)
Protected method | ClearItems | (Overrides VirtualCollectionBaseTClearItems.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from VirtualCollectionBaseT.)
Public method | CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from VirtualCollectionBaseT.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetCount | (Overrides VirtualCollectionBaseTGetCount.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from VirtualCollectionBaseT.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetIndex | Gets the index. (Inherited from VirtualCollectionBaseT.)
Protected method | GetItem | (Overrides VirtualCollectionBaseTGetItem(Int32).)
Protected method | GetItemFromRegistry |
Protected method | GetItems | (Overrides VirtualCollectionBaseTGetItems.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from VirtualCollectionBaseT.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from VirtualCollectionBaseT.)
Protected method | InsertItem | (Overrides VirtualCollectionBaseTInsertItem(Int32, T).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged |
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from VirtualCollectionBaseT.)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from VirtualCollectionBaseT.)
Protected method | RemoveItem | (Overrides VirtualCollectionBaseTRemoveItem(Int32).)
Protected method | SetItem | (Overrides VirtualCollectionBaseTSetItem(Int32, T).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSmith.Engine Namespace


ConfigurationCollectionBase(T) Constructor

ConfigurationCollectionBaseT Constructor

Initializes a new instance of the ConfigurationCollectionBaseT class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected ConfigurationCollectionBase()
Protected Sub New
See Also

Reference

ConfigurationCollectionBaseT Class
CodeSmith.Engine Namespace


ConfigurationCollectionBase(T) Properties

ConfigurationCollectionBaseT Properties

The ConfigurationCollectionBaseT generic type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from VirtualCollectionBaseT.)
Public property | Item | Gets or sets the type T at the specified index. (Inherited from VirtualCollectionBaseT.)
Protected property | SubKey |
Top
See Also

Reference

ConfigurationCollectionBaseT Class
CodeSmith.Engine Namespace


ConfigurationCollectionBase(T).SubKey Property

ConfigurationCollectionBaseTSubKey Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected abstract string SubKey { get; }
Protected MustOverride ReadOnly Property SubKey As String
    Get

Property Value

Type: String
See Also

Reference

ConfigurationCollectionBaseT Class
CodeSmith.Engine Namespace


ConfigurationCollectionBase(T) Methods

ConfigurationCollectionBaseT Methods

The ConfigurationCollectionBaseT generic type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from VirtualCollectionBaseT.)
Protected method | AddItem | Adds the item. (Inherited from VirtualCollectionBaseT.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from VirtualCollectionBaseT.)
Protected method | ClearItems | (Overrides VirtualCollectionBaseTClearItems.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from VirtualCollectionBaseT.)
Public method | CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from VirtualCollectionBaseT.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetCount | (Overrides VirtualCollectionBaseTGetCount.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from VirtualCollectionBaseT.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetIndex | Gets the index. (Inherited from VirtualCollectionBaseT.)
Protected method | GetItem | (Overrides VirtualCollectionBaseTGetItem(Int32).)
Protected method | GetItemFromRegistry |
Protected method | GetItems | (Overrides VirtualCollectionBaseTGetItems.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from VirtualCollectionBaseT.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from VirtualCollectionBaseT.)
Protected method | InsertItem | (Overrides VirtualCollectionBaseTInsertItem(Int32, T).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged |
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from VirtualCollectionBaseT.)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from VirtualCollectionBaseT.)
Protected method | RemoveItem | (Overrides VirtualCollectionBaseTRemoveItem(Int32).)
Protected method | SetItem | (Overrides VirtualCollectionBaseTSetItem(Int32, T).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ConfigurationCollectionBaseT Class
CodeSmith.Engine Namespace


ConfigurationCollectionBase(T).ClearItems Method

ConfigurationCollectionBaseTClearItems Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected override void ClearItems()
Protected Overrides Sub ClearItems
See Also

Reference

ConfigurationCollectionBaseT Class
CodeSmith.Engine Namespace


ConfigurationCollectionBase(T).GetCount Method

ConfigurationCollectionBaseTGetCount Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected override int GetCount()
Protected Overrides Function GetCount As Integer

Return Value

Type: Int32
See Also

Reference

ConfigurationCollectionBaseT Class
CodeSmith.Engine Namespace


ConfigurationCollectionBase(T).GetItem Method

ConfigurationCollectionBaseTGetItem Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected override T GetItem(
    int index
)
Protected Overrides Function GetItem (
    index As Integer
) As T

Parameters

index
Type: SystemInt32

Return Value

Type: T
See Also

Reference

ConfigurationCollectionBaseT Class
CodeSmith.Engine Namespace


ConfigurationCollectionBase(T).GetItemFromRegistry Method

ConfigurationCollectionBaseTGetItemFromRegistry Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected abstract T GetItemFromRegistry(
    int index
)
Protected MustOverride Function GetItemFromRegistry (
    index As Integer
) As T

Parameters

index
Type: SystemInt32

Return Value

Type: T
See Also

Reference

ConfigurationCollectionBaseT Class
CodeSmith.Engine Namespace


ConfigurationCollectionBase(T).GetItems Method

ConfigurationCollectionBaseTGetItems Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected override IList<T> GetItems()
Protected Overrides Function GetItems As IList(Of T)

Return Value

Type: IList T
See Also

Reference

ConfigurationCollectionBaseT Class
CodeSmith.Engine Namespace


ConfigurationCollectionBase(T).InsertItem Method

ConfigurationCollectionBaseTInsertItem Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected override void InsertItem(
    int index,
    T item
)
Protected Overrides Sub InsertItem (
    index As Integer,
    item As T
)

Parameters

index
Type: SystemInt32
item
Type: T
See Also

Reference

ConfigurationCollectionBaseT Class
CodeSmith.Engine Namespace


ConfigurationCollectionBase(T).OnPropertyChanged Method

ConfigurationCollectionBaseTOnPropertyChanged Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual void OnPropertyChanged(
    Object sender,
    PropertyChangedEventArgs e
)
Protected Overridable Sub OnPropertyChanged (
    sender As Object,
    e As PropertyChangedEventArgs
)

Parameters

sender
Type: SystemObject
e
Type: System.ComponentModelPropertyChangedEventArgs
See Also

Reference

ConfigurationCollectionBaseT Class
CodeSmith.Engine Namespace


ConfigurationCollectionBase(T).RemoveItem Method

ConfigurationCollectionBaseTRemoveItem Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected override void RemoveItem(
    int index
)
Protected Overrides Sub RemoveItem (
    index As Integer
)

Parameters

index
Type: SystemInt32
See Also

Reference

ConfigurationCollectionBaseT Class
CodeSmith.Engine Namespace


ConfigurationCollectionBase(T).SetItem Method

ConfigurationCollectionBaseTSetItem Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected override void SetItem(
    int index,
    T item
)
Protected Overrides Sub SetItem (
    index As Integer,
    item As T
)

Parameters

index
Type: SystemInt32
item
Type: T
See Also

Reference

ConfigurationCollectionBaseT Class
CodeSmith.Engine Namespace


ConfigurationItemBase Class

Inheritance Hierarchy
SystemObject
CodeSmith.EngineConfigurationItemBase
CodeSmith.EngineLanguageRegionDefinition
CodeSmith.EngineMergeStrategyAlias
CodeSmith.EnginePropertyDesignerMap

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public abstract class ConfigurationItemBase : IIndexed,
    INotifyPropertyChanged
Public MustInherit Class ConfigurationItemBase
    Implements IIndexed, INotifyPropertyChanged

The ConfigurationItemBase type exposes the following members.

Constructors
 | Name | Description
Protected method | ConfigurationItemBase | Initializes a new instance of the ConfigurationItemBase class.
Protected method | ConfigurationItemBase(Int32) | Initializes a new instance of the ConfigurationItemBase class.
Top
Properties
 | Name | Description
Public property | Index | Gets or sets the index.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes.
Top
See Also

Reference

CodeSmith.Engine Namespace


ConfigurationItemBase Constructor

Overload List
 | Name | Description
Protected method | ConfigurationItemBase | Initializes a new instance of the ConfigurationItemBase class.
Protected method | ConfigurationItemBase(Int32) | Initializes a new instance of the ConfigurationItemBase class.
Top
See Also

Reference

ConfigurationItemBase Class
CodeSmith.Engine Namespace


ConfigurationItemBase Constructor

Initializes a new instance of the ConfigurationItemBase class.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected ConfigurationItemBase()
Protected Sub New
See Also

Reference

ConfigurationItemBase Class
ConfigurationItemBase Overload
CodeSmith.Engine Namespace


ConfigurationItemBase Constructor (Int32)

Initializes a new instance of the ConfigurationItemBase class.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected ConfigurationItemBase(
    int index
)
Protected Sub New (
    index As Integer
)

Parameters

index
Type: SystemInt32
The index.
See Also

Reference

ConfigurationItemBase Class
ConfigurationItemBase Overload
CodeSmith.Engine Namespace


ConfigurationItemBase Properties

The ConfigurationItemBase type exposes the following members.

Properties
 | Name | Description
Public property | Index | Gets or sets the index.
Top
See Also

Reference

ConfigurationItemBase Class
CodeSmith.Engine Namespace


ConfigurationItemBase.Index Property

ConfigurationItemBaseIndex Property

Gets or sets the index.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public int Index { get; set; }
Public Property Index As Integer
    Get
    Set

Property Value

Type: Int32
The index.

Implements

IIndexedIndex
See Also

Reference

ConfigurationItemBase Class
CodeSmith.Engine Namespace


ConfigurationItemBase Methods

The ConfigurationItemBase type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ConfigurationItemBase Class
CodeSmith.Engine Namespace


ConfigurationItemBase.OnPropertyChanged Method

ConfigurationItemBaseOnPropertyChanged Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected void OnPropertyChanged(
    string propertyName
)
Protected Sub OnPropertyChanged (
    propertyName As String
)

Parameters

propertyName
Type: SystemString
See Also

Reference

ConfigurationItemBase Class
CodeSmith.Engine Namespace


ConfigurationItemBase Events

The ConfigurationItemBase type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes.
Top
See Also

Reference

ConfigurationItemBase Class
CodeSmith.Engine Namespace


ConfigurationItemBase.PropertyChanged Event

ConfigurationItemBasePropertyChanged Event

Occurs when a property value changes.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public event PropertyChangedEventHandler PropertyChanged
Public Event PropertyChanged As PropertyChangedEventHandler

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

ConfigurationItemBase Class
CodeSmith.Engine Namespace


ContextItem Class

Inheritance Hierarchy
SystemObject
CodeSmith.EngineContextItem

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
public class ContextItem
<SerializableAttribute>
Public Class ContextItem

The ContextItem type exposes the following members.

Constructors
 | Name | Description
Public method | ContextItem | Initializes a new instance of the ContextItem class
Top
Properties
 | Name | Description
Public property | Name |
Public property | Value |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSmith.Engine Namespace


ContextItem Constructor

Initializes a new instance of the ContextItem class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ContextItem()
Public Sub New
See Also

Reference

ContextItem Class
CodeSmith.Engine Namespace


ContextItem Properties

The ContextItem type exposes the following members.

Properties
 | Name | Description
Public property | Name |
Public property | Value |
Top
See Also

Reference

ContextItem Class
CodeSmith.Engine Namespace


ContextItem.Name Property

ContextItemName Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set

Property Value

Type: String
See Also

Reference

ContextItem Class
CodeSmith.Engine Namespace


ContextItem.Value Property

ContextItemValue Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string Value { get; set; }
Public Property Value As String
    Get
    Set

Property Value

Type: String
See Also

Reference

ContextItem Class
CodeSmith.Engine Namespace


ContextItem Methods

The ContextItem type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ContextItem Class
CodeSmith.Engine Namespace


Control Class

Inheritance Hierarchy
SystemObject
CodeSmith.EngineControl
CodeSmith.EngineCodeTemplate
CodeSmith.EngineDelegateControl

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public abstract class Control
Public MustInherit Class Control

The Control type exposes the following members.

Constructors
 | Name | Description
Public method | Control | Initializes a new instance of the Control class
Top
Properties
 | Name | Description
Protected property | ChildControlsCreated |
Protected property | CodeTemplate |
Protected property | Controls |
Protected property | Parent |
Protected property | Visible |
Top
Methods
 | Name | Description
Protected method | ControlAdded |
Protected method | ControlRemoved |
Protected method | CreateChildControls |
Protected method | CreateControlCollection |
Protected method | EnsureChildControls |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControls |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Render |
Protected method | RenderChildren |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _childControlsCreated |
Protected field | _codeTemplate |
Protected field | _controls |
Protected field | _parent |
Protected field | _visible |
Top
See Also

Reference

CodeSmith.Engine Namespace


Control Constructor

Initializes a new instance of the Control class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public Control()
Public Sub New
See Also

Reference

Control Class
CodeSmith.Engine Namespace


Control Properties

The Control type exposes the following members.

Properties
 | Name | Description
Protected property | ChildControlsCreated |
Protected property | CodeTemplate |
Protected property | Controls |
Protected property | Parent |
Protected property | Visible |
Top
See Also

Reference

Control Class
CodeSmith.Engine Namespace


Control.ChildControlsCreated Property

ControlChildControlsCreated Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected bool ChildControlsCreated { get; }
Protected ReadOnly Property ChildControlsCreated As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

Control Class
CodeSmith.Engine Namespace


Control.CodeTemplate Property

ControlCodeTemplate Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected CodeTemplate CodeTemplate { get; }
Protected ReadOnly Property CodeTemplate As CodeTemplate
    Get

Property Value

Type: CodeTemplate
See Also

Reference

Control Class
CodeSmith.Engine Namespace


Control.Controls Property

ControlControls Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected ControlCollection Controls { get; }
Protected ReadOnly Property Controls As ControlCollection
    Get

Property Value

Type: ControlCollection
See Also

Reference

Control Class
CodeSmith.Engine Namespace


Control.Parent Property

ControlParent Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected Control Parent { get; }
Protected ReadOnly Property Parent As Control
    Get

Property Value

Type: Control
See Also

Reference

Control Class
CodeSmith.Engine Namespace


Control.Visible Property

ControlVisible Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual bool Visible { get; set; }
Protected Overridable Property Visible As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

Control Class
CodeSmith.Engine Namespace


Control Methods

The Control type exposes the following members.

Methods
 | Name | Description
Protected method | ControlAdded |
Protected method | ControlRemoved |
Protected method | CreateChildControls |
Protected method | CreateControlCollection |
Protected method | EnsureChildControls |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControls |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Render |
Protected method | RenderChildren |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Control Class
CodeSmith.Engine Namespace


Control.ControlAdded Method

ControlControlAdded Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual void ControlAdded(
    Control control,
    int index
)
Protected Overridable Sub ControlAdded (
    control As Control,
    index As Integer
)

Parameters

control
Type: CodeSmith.EngineControl
index
Type: SystemInt32
See Also

Reference

Control Class
CodeSmith.Engine Namespace


Control.ControlRemoved Method

ControlControlRemoved Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual void ControlRemoved(
    Control control
)
Protected Overridable Sub ControlRemoved (
    control As Control
)

Parameters

control
Type: CodeSmith.EngineControl
See Also

Reference

Control Class
CodeSmith.Engine Namespace


Control.CreateChildControls Method

ControlCreateChildControls Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual void CreateChildControls()
Protected Overridable Sub CreateChildControls
See Also

Reference

Control Class
CodeSmith.Engine Namespace


Control.CreateControlCollection Method

ControlCreateControlCollection Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual ControlCollection CreateControlCollection()
Protected Overridable Function CreateControlCollection As ControlCollection

Return Value

Type: ControlCollection
See Also

Reference

Control Class
CodeSmith.Engine Namespace


Control.EnsureChildControls Method

ControlEnsureChildControls Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected void EnsureChildControls()
Protected Sub EnsureChildControls
See Also

Reference

Control Class
CodeSmith.Engine Namespace


Control.HasControls Method

ControlHasControls Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual bool HasControls()
Protected Overridable Function HasControls As Boolean

Return Value

Type: Boolean
See Also

Reference

Control Class
CodeSmith.Engine Namespace


Control.Render Method

ControlRender Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual void Render(
    TextWriter writer
)
Public Overridable Sub Render (
    writer As TextWriter
)

Parameters

writer
Type: System.IOTextWriter
See Also

Reference

Control Class
CodeSmith.Engine Namespace


Control.RenderChildren Method

ControlRenderChildren Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual void RenderChildren(
    TextWriter writer
)
Protected Overridable Sub RenderChildren (
    writer As TextWriter
)

Parameters

writer
Type: System.IOTextWriter
See Also

Reference

Control Class
CodeSmith.Engine Namespace


Control Fields

The Control type exposes the following members.

Fields
 | Name | Description
Protected field | _childControlsCreated |
Protected field | _codeTemplate |
Protected field | _controls |
Protected field | _parent |
Protected field | _visible |
Top
See Also

Reference

Control Class
CodeSmith.Engine Namespace


Control._childControlsCreated Field

Control_childControlsCreated Field

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected bool _childControlsCreated
Protected _childControlsCreated As Boolean

Field Value

Type: Boolean
See Also

Reference

Control Class
CodeSmith.Engine Namespace


Control._codeTemplate Field

Control_codeTemplate Field

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected CodeTemplate _codeTemplate
Protected _codeTemplate As CodeTemplate

Field Value

Type: CodeTemplate
See Also

Reference

Control Class
CodeSmith.Engine Namespace


Control._controls Field

Control_controls Field

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected ControlCollection _controls
Protected _controls As ControlCollection

Field Value

Type: ControlCollection
See Also

Reference

Control Class
CodeSmith.Engine Namespace


Control._parent Field

Control_parent Field

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected Control _parent
Protected _parent As Control

Field Value

Type: Control
See Also

Reference

Control Class
CodeSmith.Engine Namespace


Control._visible Field

Control_visible Field

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected bool _visible
Protected _visible As Boolean

Field Value

Type: Boolean
See Also

Reference

Control Class
CodeSmith.Engine Namespace


ControlCollection Class

Inheritance Hierarchy
SystemObject
CodeSmith.EngineControlCollection
CodeSmith.EngineEmptyControlCollection

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class ControlCollection : ICollection,
    IEnumerable
Public Class ControlCollection
    Implements ICollection, IEnumerable

The ControlCollection type exposes the following members.

Constructors
 | Name | Description
Public method | ControlCollection | Initializes a new instance of the ControlCollection class
Top
Properties
 | Name | Description
Public property | Count |
Public property | IsReadOnly |
Public property | IsSynchronized |
Public property | Item |
Public property | Owner |
Public property | SyncRoot |
Top
Methods
 | Name | Description
Public method | Add |
Public method | AddAt |
Public method | Clear |
Public method | Contains |
Public method | CopyTo |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove |
Public method | RemoveAt |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSmith.Engine Namespace


ControlCollection Constructor

Initializes a new instance of the ControlCollection class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ControlCollection(
    Control owner
)
Public Sub New (
    owner As Control
)

Parameters

owner
Type: CodeSmith.EngineControl
See Also

Reference

ControlCollection Class
CodeSmith.Engine Namespace


ControlCollection Properties

The ControlCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count |
Public property | IsReadOnly |
Public property | IsSynchronized |
Public property | Item |
Public property | Owner |
Public property | SyncRoot |
Top
See Also

Reference

ControlCollection Class
CodeSmith.Engine Namespace


ControlCollection.Count Property

ControlCollectionCount Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Implements

ICollectionCount
See Also

Reference

ControlCollection Class
CodeSmith.Engine Namespace


ControlCollection.IsReadOnly Property

ControlCollectionIsReadOnly Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

ControlCollection Class
CodeSmith.Engine Namespace


ControlCollection.IsSynchronized Property

ControlCollectionIsSynchronized Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get

Property Value

Type: Boolean

Implements

ICollectionIsSynchronized
See Also

Reference

ControlCollection Class
CodeSmith.Engine Namespace


ControlCollection.Item Property

ControlCollectionItem Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public Control this[
    int index
] { get; }
Public ReadOnly Default Property Item (
    index As Integer
) As Control
    Get

Parameters

index
Type: SystemInt32

Property Value

Type: Control
See Also

Reference

ControlCollection Class
CodeSmith.Engine Namespace


ControlCollection.Owner Property

ControlCollectionOwner Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public Control Owner { get; }
Public ReadOnly Property Owner As Control
    Get

Property Value

Type: Control
See Also

Reference

ControlCollection Class
CodeSmith.Engine Namespace


ControlCollection.SyncRoot Property

ControlCollectionSyncRoot Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get

Property Value

Type: Object

Implements

ICollectionSyncRoot
See Also

Reference

ControlCollection Class
CodeSmith.Engine Namespace


ControlCollection Methods

The ControlCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add |
Public method | AddAt |
Public method | Clear |
Public method | Contains |
Public method | CopyTo |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove |
Public method | RemoveAt |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ControlCollection Class
CodeSmith.Engine Namespace


ControlCollection.Add Method

ControlCollectionAdd Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual void Add(
    Control child
)
Public Overridable Sub Add (
    child As Control
)

Parameters

child
Type: CodeSmith.EngineControl
See Also

Reference

ControlCollection Class
CodeSmith.Engine Namespace


ControlCollection.AddAt Method

ControlCollectionAddAt Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual void AddAt(
    int index,
    Control child
)
Public Overridable Sub AddAt (
    index As Integer,
    child As Control
)

Parameters

index
Type: SystemInt32
child
Type: CodeSmith.EngineControl
See Also

Reference

ControlCollection Class
CodeSmith.Engine Namespace


ControlCollection.Clear Method

ControlCollectionClear Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual void Clear()
Public Overridable Sub Clear
See Also

Reference

ControlCollection Class
CodeSmith.Engine Namespace


ControlCollection.Contains Method

ControlCollectionContains Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual bool Contains(
    Control control
)
Public Overridable Function Contains (
    control As Control
) As Boolean

Parameters

control
Type: CodeSmith.EngineControl

Return Value

Type: Boolean
See Also

Reference

ControlCollection Class
CodeSmith.Engine Namespace


ControlCollection.CopyTo Method

ControlCollectionCopyTo Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual void CopyTo(
    Array array,
    int index
)
Public Overridable Sub CopyTo (
    array As Array,
    index As Integer
)

Parameters

array
Type: SystemArray
index
Type: SystemInt32

Implements

ICollectionCopyTo(Array, Int32)
See Also

Reference

ControlCollection Class
CodeSmith.Engine Namespace


ControlCollection.GetEnumerator Method

ControlCollectionGetEnumerator Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator

Implements

IEnumerableGetEnumerator
See Also

Reference

ControlCollection Class
CodeSmith.Engine Namespace


ControlCollection.IndexOf Method

ControlCollectionIndexOf Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual int IndexOf(
    Control value
)
Public Overridable Function IndexOf (
    value As Control
) As Integer

Parameters

value
Type: CodeSmith.EngineControl

Return Value

Type: Int32
See Also

Reference

ControlCollection Class
CodeSmith.Engine Namespace


ControlCollection.Remove Method

ControlCollectionRemove Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual void Remove(
    Control value
)
Public Overridable Sub Remove (
    value As Control
)

Parameters

value
Type: CodeSmith.EngineControl
See Also

Reference

ControlCollection Class
CodeSmith.Engine Namespace


ControlCollection.RemoveAt Method

ControlCollectionRemoveAt Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual void RemoveAt(
    int index
)
Public Overridable Sub RemoveAt (
    index As Integer
)

Parameters

index
Type: SystemInt32
See Also

Reference

ControlCollection Class
CodeSmith.Engine Namespace


ControlCollection.ControlCollectionEnumerator Class

ControlCollectionControlCollectionEnumerator Class

Inheritance Hierarchy
SystemObject
CodeSmith.EngineControlCollectionControlCollectionEnumerator

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class ControlCollectionEnumerator : IEnumerator
Public Class ControlCollectionEnumerator
    Implements IEnumerator

The ControlCollectionControlCollectionEnumerator type exposes the following members.

Constructors
 | Name | Description
Public method | ControlCollectionControlCollectionEnumerator | Initializes a new instance of the ControlCollectionControlCollectionEnumerator class
Top
Properties
 | Name | Description
Public property | Current |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveNext |
Public method | Reset |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSmith.Engine Namespace


ControlCollection.ControlCollectionEnumerator Constructor

ControlCollectionControlCollectionEnumerator Constructor

Initializes a new instance of the ControlCollectionControlCollectionEnumerator class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ControlCollectionEnumerator(
    ControlCollection mappings
)
Public Sub New (
    mappings As ControlCollection
)

Parameters

mappings
Type: CodeSmith.EngineControlCollection
See Also

Reference

ControlCollectionControlCollectionEnumerator Class
CodeSmith.Engine Namespace


ControlCollectionEnumerator Properties

The ControlCollectionControlCollectionEnumerator type exposes the following members.

Properties
 | Name | Description
Public property | Current |
Top
See Also

Reference

ControlCollectionControlCollectionEnumerator Class
CodeSmith.Engine Namespace


ControlCollection.ControlCollectionEnumerator.Current Property

ControlCollectionControlCollectionEnumeratorCurrent Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public Control Current { get; }
Public ReadOnly Property Current As Control
    Get

Property Value

Type: Control
See Also

Reference

ControlCollectionControlCollectionEnumerator Class
CodeSmith.Engine Namespace


ControlCollectionEnumerator Methods

The ControlCollectionControlCollectionEnumerator type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveNext |
Public method | Reset |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ControlCollectionControlCollectionEnumerator Class
CodeSmith.Engine Namespace


ControlCollection.ControlCollectionEnumerator.MoveNext Method

ControlCollectionControlCollectionEnumeratorMoveNext Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool MoveNext()
Public Function MoveNext As Boolean

Return Value

Type: Boolean
See Also

Reference

ControlCollectionControlCollectionEnumerator Class
CodeSmith.Engine Namespace


ControlCollection.ControlCollectionEnumerator.Reset Method

ControlCollectionControlCollectionEnumeratorReset Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void Reset()
Public Sub Reset
See Also

Reference

ControlCollectionControlCollectionEnumerator Class
CodeSmith.Engine Namespace


DefaultEngineHost Class

Inheritance Hierarchy
SystemObject
CodeSmith.EngineEngineHostBase
CodeSmith.EngineDefaultEngineHost

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class DefaultEngineHost : EngineHostBase
Public Class DefaultEngineHost
    Inherits EngineHostBase

The DefaultEngineHost type exposes the following members.

Constructors
 | Name | Description
Public method | DefaultEngineHost | Initializes a new instance of the DefaultEngineHost class
Top
Properties
 | Name | Description
Public property | BasePath | (Inherited from EngineHostBase.)
Public property | DefaultBaseClass | (Inherited from EngineHostBase.)
Public property | DefaultClassName | (Inherited from EngineHostBase.)
Public property | DefaultImports | (Inherited from EngineHostBase.)
Public property | DefaultNamespace | (Inherited from EngineHostBase.)
Public property | DefaultReferences | (Inherited from EngineHostBase.)
Public property | RegisteredContent | (Inherited from EngineHostBase.)
Top
Methods
 | Name | Description
Public method | ContentExists | (Inherited from EngineHostBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetContent(String, Boolean) | (Inherited from EngineHostBase.)
Public method | GetContent(String, String, Boolean) | (Overrides EngineHostBaseGetContent(String, String, Boolean).)
Public method | GetFullPath(String) | (Inherited from EngineHostBase.)
Public method | GetFullPath(String, String) | (Overrides EngineHostBaseGetFullPath(String, String).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PostProcessCompileResult | (Inherited from EngineHostBase.)
Public method | PostProcessParseResult | (Overrides EngineHostBasePostProcessParseResult(TemplateParseResult).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSmith.Engine Namespace


DefaultEngineHost Constructor

Initializes a new instance of the DefaultEngineHost class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public DefaultEngineHost(
    string basePath
)
Public Sub New (
    basePath As String
)

Parameters

basePath
Type: SystemString
See Also

Reference

DefaultEngineHost Class
CodeSmith.Engine Namespace


DefaultEngineHost Properties

The DefaultEngineHost type exposes the following members.

Properties
 | Name | Description
Public property | BasePath | (Inherited from EngineHostBase.)
Public property | DefaultBaseClass | (Inherited from EngineHostBase.)
Public property | DefaultClassName | (Inherited from EngineHostBase.)
Public property | DefaultImports | (Inherited from EngineHostBase.)
Public property | DefaultNamespace | (Inherited from EngineHostBase.)
Public property | DefaultReferences | (Inherited from EngineHostBase.)
Public property | RegisteredContent | (Inherited from EngineHostBase.)
Top
See Also

Reference

DefaultEngineHost Class
CodeSmith.Engine Namespace


DefaultEngineHost Methods

The DefaultEngineHost type exposes the following members.

Methods
 | Name | Description
Public method | ContentExists | (Inherited from EngineHostBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetContent(String, Boolean) | (Inherited from EngineHostBase.)
Public method | GetContent(String, String, Boolean) | (Overrides EngineHostBaseGetContent(String, String, Boolean).)
Public method | GetFullPath(String) | (Inherited from EngineHostBase.)
Public method | GetFullPath(String, String) | (Overrides EngineHostBaseGetFullPath(String, String).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PostProcessCompileResult | (Inherited from EngineHostBase.)
Public method | PostProcessParseResult | (Overrides EngineHostBasePostProcessParseResult(TemplateParseResult).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DefaultEngineHost Class
CodeSmith.Engine Namespace


DefaultEngineHost.GetContent Method

DefaultEngineHostGetContent Method

Overload List
 | Name | Description
Public method | GetContent(String, Boolean) | (Inherited from EngineHostBase.)
Public method | GetContent(String, String, Boolean) | (Overrides EngineHostBaseGetContent(String, String, Boolean).)
Top
See Also

Reference

DefaultEngineHost Class
CodeSmith.Engine Namespace


DefaultEngineHost.GetContent Method (String, String, Boolean)

DefaultEngineHostGetContent Method (String, String, Boolean)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override string GetContent(
    string basePath,
    string path,
    bool useRegisteredContent = true
)
Public Overrides Function GetContent (
    basePath As String,
    path As String,
    Optional useRegisteredContent As Boolean = true
) As String

Parameters

basePath
Type: SystemString
path
Type: SystemString
useRegisteredContent (Optional)
Type: SystemBoolean

Return Value

Type: String

Implements

IEngineHostGetContent(String, String, Boolean)
See Also

Reference

DefaultEngineHost Class
GetContent Overload
CodeSmith.Engine Namespace


DefaultEngineHost.GetFullPath Method

DefaultEngineHostGetFullPath Method

Overload List
 | Name | Description
Public method | GetFullPath(String) | (Inherited from EngineHostBase.)
Public method | GetFullPath(String, String) | (Overrides EngineHostBaseGetFullPath(String, String).)
Top
See Also

Reference

DefaultEngineHost Class
CodeSmith.Engine Namespace


DefaultEngineHost.GetFullPath Method (String, String)

DefaultEngineHostGetFullPath Method (String, String)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override string GetFullPath(
    string basePath,
    string path
)
Public Overrides Function GetFullPath (
    basePath As String,
    path As String
) As String

Parameters

basePath
Type: SystemString
path
Type: SystemString

Return Value

Type: String

Implements

IEngineHostGetFullPath(String, String)
See Also

Reference

DefaultEngineHost Class
GetFullPath Overload
CodeSmith.Engine Namespace


DefaultEngineHost.PostProcessParseResult Method

DefaultEngineHostPostProcessParseResult Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override void PostProcessParseResult(
    TemplateParseResult templateResult
)
Public Overrides Sub PostProcessParseResult (
    templateResult As TemplateParseResult
)

Parameters

templateResult
Type: CodeSmith.EngineTemplateParseResult

Implements

IEngineHostPostProcessParseResult(TemplateParseResult)
See Also

Reference

DefaultEngineHost Class
CodeSmith.Engine Namespace


DefaultLogger Class

Inheritance Hierarchy
SystemObject
CodeSmith.EngineDefaultLogger

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class DefaultLogger : ILogger
Public Class DefaultLogger
    Implements ILogger

The DefaultLogger type exposes the following members.

Constructors
 | Name | Description
Public method | DefaultLogger | Initializes a new instance of the DefaultLogger class
Top
Methods
 | Name | Description
Public method | Debug(Exception) |
Public method | Debug(String) |
Public method | Debug(Exception, String) |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Error(Exception) |
Public method | Error(String) |
Public method | Error(Exception, String) |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Info(Exception) |
Public method | Info(String) |
Public method | Info(Exception, String) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Warn(Exception) |
Public method | Warn(String) |
Public method | Warn(Exception, String) |
Protected method | WriteDebugLog |
Protected method | WriteErrorLog |
Protected method | WriteInfoLog |
Protected method | WriteWarningLog |
Top
See Also

Reference

CodeSmith.Engine Namespace


DefaultLogger Constructor

Initializes a new instance of the DefaultLogger class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public DefaultLogger()
Public Sub New
See Also

Reference

DefaultLogger Class
CodeSmith.Engine Namespace


DefaultLogger Methods

The DefaultLogger type exposes the following members.

Methods
 | Name | Description
Public method | Debug(Exception) |
Public method | Debug(String) |
Public method | Debug(Exception, String) |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Error(Exception) |
Public method | Error(String) |
Public method | Error(Exception, String) |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Info(Exception) |
Public method | Info(String) |
Public method | Info(Exception, String) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Warn(Exception) |
Public method | Warn(String) |
Public method | Warn(Exception, String) |
Protected method | WriteDebugLog |
Protected method | WriteErrorLog |
Protected method | WriteInfoLog |
Protected method | WriteWarningLog |
Top
See Also

Reference

DefaultLogger Class
CodeSmith.Engine Namespace


DefaultLogger.Debug Method

DefaultLoggerDebug Method

Overload List
 | Name | Description
Public method | Debug(Exception) |
Public method | Debug(String) |
Public method | Debug(Exception, String) |
Top
See Also

Reference

DefaultLogger Class
CodeSmith.Engine Namespace


DefaultLogger.Debug Method (Exception)

DefaultLoggerDebug Method (Exception)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void Debug(
    Exception exception
)
Public Sub Debug (
    exception As Exception
)

Parameters

exception
Type: SystemException

Implements

ILoggerDebug(Exception)
See Also

Reference

DefaultLogger Class
Debug Overload
CodeSmith.Engine Namespace


DefaultLogger.Debug Method (String)

DefaultLoggerDebug Method (String)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void Debug(
    string message
)
Public Sub Debug (
    message As String
)

Parameters

message
Type: SystemString

Implements

ILoggerDebug(String)
See Also

Reference

DefaultLogger Class
Debug Overload
CodeSmith.Engine Namespace


DefaultLogger.Debug Method (Exception, String)

DefaultLoggerDebug Method (Exception, String)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void Debug(
    Exception exception,
    string message
)
Public Sub Debug (
    exception As Exception,
    message As String
)

Parameters

exception
Type: SystemException
message
Type: SystemString

Implements

ILoggerDebug(Exception, String)
See Also

Reference

DefaultLogger Class
Debug Overload
CodeSmith.Engine Namespace


DefaultLogger.Error Method

DefaultLoggerError Method

Overload List
 | Name | Description
Public method | Error(Exception) |
Public method | Error(String) |
Public method | Error(Exception, String) |
Top
See Also

Reference

DefaultLogger Class
CodeSmith.Engine Namespace


DefaultLogger.Error Method (Exception)

DefaultLoggerError Method (Exception)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void Error(
    Exception exception
)
Public Sub Error (
    exception As Exception
)

Parameters

exception
Type: SystemException

Implements

ILoggerError(Exception)
See Also

Reference

DefaultLogger Class
Error Overload
CodeSmith.Engine Namespace


DefaultLogger.Error Method (String)

DefaultLoggerError Method (String)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void Error(
    string message
)
Public Sub Error (
    message As String
)

Parameters

message
Type: SystemString

Implements

ILoggerError(String)
See Also

Reference

DefaultLogger Class
Error Overload
CodeSmith.Engine Namespace


DefaultLogger.Error Method (Exception, String)

DefaultLoggerError Method (Exception, String)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void Error(
    Exception exception,
    string message
)
Public Sub Error (
    exception As Exception,
    message As String
)

Parameters

exception
Type: SystemException
message
Type: SystemString

Implements

ILoggerError(Exception, String)
See Also

Reference

DefaultLogger Class
Error Overload
CodeSmith.Engine Namespace


DefaultLogger.Info Method

DefaultLoggerInfo Method

Overload List
 | Name | Description
Public method | Info(Exception) |
Public method | Info(String) |
Public method | Info(Exception, String) |
Top
See Also

Reference

DefaultLogger Class
CodeSmith.Engine Namespace


DefaultLogger.Info Method (Exception)

DefaultLoggerInfo Method (Exception)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void Info(
    Exception exception
)
Public Sub Info (
    exception As Exception
)

Parameters

exception
Type: SystemException

Implements

ILoggerInfo(Exception)
See Also

Reference

DefaultLogger Class
Info Overload
CodeSmith.Engine Namespace


DefaultLogger.Info Method (String)

DefaultLoggerInfo Method (String)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void Info(
    string message
)
Public Sub Info (
    message As String
)

Parameters

message
Type: SystemString

Implements

ILoggerInfo(String)
See Also

Reference

DefaultLogger Class
Info Overload
CodeSmith.Engine Namespace


DefaultLogger.Info Method (Exception, String)

DefaultLoggerInfo Method (Exception, String)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void Info(
    Exception exception,
    string message
)
Public Sub Info (
    exception As Exception,
    message As String
)

Parameters

exception
Type: SystemException
message
Type: SystemString

Implements

ILoggerInfo(Exception, String)
See Also

Reference

DefaultLogger Class
Info Overload
CodeSmith.Engine Namespace


DefaultLogger.Warn Method

DefaultLoggerWarn Method

Overload List
 | Name | Description
Public method | Warn(Exception) |
Public method | Warn(String) |
Public method | Warn(Exception, String) |
Top
See Also

Reference

DefaultLogger Class
CodeSmith.Engine Namespace


DefaultLogger.Warn Method (Exception)

DefaultLoggerWarn Method (Exception)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void Warn(
    Exception exception
)
Public Sub Warn (
    exception As Exception
)

Parameters

exception
Type: SystemException

Implements

ILoggerWarn(Exception)
See Also

Reference

DefaultLogger Class
Warn Overload
CodeSmith.Engine Namespace


DefaultLogger.Warn Method (String)

DefaultLoggerWarn Method (String)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void Warn(
    string message
)
Public Sub Warn (
    message As String
)

Parameters

message
Type: SystemString

Implements

ILoggerWarn(String)
See Also

Reference

DefaultLogger Class
Warn Overload
CodeSmith.Engine Namespace


DefaultLogger.Warn Method (Exception, String)

DefaultLoggerWarn Method (Exception, String)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void Warn(
    Exception exception,
    string message
)
Public Sub Warn (
    exception As Exception,
    message As String
)

Parameters

exception
Type: SystemException
message
Type: SystemString

Implements

ILoggerWarn(Exception, String)
See Also

Reference

DefaultLogger Class
Warn Overload
CodeSmith.Engine Namespace


DefaultLogger.WriteDebugLog Method

DefaultLoggerWriteDebugLog Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual void WriteDebugLog(
    string message
)
Protected Overridable Sub WriteDebugLog (
    message As String
)

Parameters

message
Type: SystemString
See Also

Reference

DefaultLogger Class
CodeSmith.Engine Namespace


DefaultLogger.WriteErrorLog Method

DefaultLoggerWriteErrorLog Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual void WriteErrorLog(
    string message
)
Protected Overridable Sub WriteErrorLog (
    message As String
)

Parameters

message
Type: SystemString
See Also

Reference

DefaultLogger Class
CodeSmith.Engine Namespace


DefaultLogger.WriteInfoLog Method

DefaultLoggerWriteInfoLog Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual void WriteInfoLog(
    string message
)
Protected Overridable Sub WriteInfoLog (
    message As String
)

Parameters

message
Type: SystemString
See Also

Reference

DefaultLogger Class
CodeSmith.Engine Namespace


DefaultLogger.WriteWarningLog Method

DefaultLoggerWriteWarningLog Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual void WriteWarningLog(
    string message
)
Protected Overridable Sub WriteWarningLog (
    message As String
)

Parameters

message
Type: SystemString
See Also

Reference

DefaultLogger Class
CodeSmith.Engine Namespace


DelegateControl Class

Inheritance Hierarchy
SystemObject
CodeSmith.EngineControl
CodeSmith.EngineDelegateControl

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class DelegateControl : Control,
    IEnumerator
Public Class DelegateControl
    Inherits Control
    Implements IEnumerator

The DelegateControl type exposes the following members.

Constructors
 | Name | Description
Public method | DelegateControl | Initializes a new instance of the DelegateControl class
Public method | DelegateControl(RenderMethod) | Initializes a new instance of the DelegateControl class
Top
Properties
 | Name | Description
Protected property | ChildControlsCreated | (Inherited from Control.)
Protected property | CodeTemplate | (Inherited from Control.)
Protected property | Controls | (Inherited from Control.)
Public property | Current |
Protected property | Parent | (Inherited from Control.)
Public property | RenderMethod |
Protected property | Visible | (Inherited from Control.)
Top
Methods
 | Name | Description
Protected method | ControlAdded | (Inherited from Control.)
Protected method | ControlRemoved | (Inherited from Control.)
Protected method | CreateChildControls | (Inherited from Control.)
Protected method | CreateControlCollection | (Overrides ControlCreateControlCollection.)
Protected method | EnsureChildControls | (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControls | (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveNext |
Public method | Render | (Overrides ControlRender(TextWriter).)
Protected method | RenderChildren | (Inherited from Control.)
Public method | Reset |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | _childControlsCreated | (Inherited from Control.)
Protected field | _codeTemplate | (Inherited from Control.)
Protected field | _controls | (Inherited from Control.)
Protected field | _parent | (Inherited from Control.)
Protected field | _visible | (Inherited from Control.)
Top
See Also

Reference

CodeSmith.Engine Namespace


DelegateControl Constructor

Overload List
 | Name | Description
Public method | DelegateControl | Initializes a new instance of the DelegateControl class
Public method | DelegateControl(RenderMethod) | Initializes a new instance of the DelegateControl class
Top
See Also

Reference

DelegateControl Class
CodeSmith.Engine Namespace


DelegateControl Constructor

Initializes a new instance of the DelegateControl class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public DelegateControl()
Public Sub New
See Also

Reference

DelegateControl Class
DelegateControl Overload
CodeSmith.Engine Namespace


DelegateControl Constructor (RenderMethod)

Initializes a new instance of the DelegateControl class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public DelegateControl(
    RenderMethod renderMethod
)
Public Sub New (
    renderMethod As RenderMethod
)

Parameters

renderMethod
Type: CodeSmith.EngineRenderMethod
See Also

Reference

DelegateControl Class
DelegateControl Overload
CodeSmith.Engine Namespace


DelegateControl Properties

The DelegateControl type exposes the following members.

Properties
 | Name | Description
Protected property | ChildControlsCreated | (Inherited from Control.)
Protected property | CodeTemplate | (Inherited from Control.)
Protected property | Controls | (Inherited from Control.)
Public property | Current |
Protected property | Parent | (Inherited from Control.)
Public property | RenderMethod |
Protected property | Visible | (Inherited from Control.)
Top
See Also

Reference

DelegateControl Class
CodeSmith.Engine Namespace


DelegateControl.Current Property

DelegateControlCurrent Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public Object Current { get; }
Public ReadOnly Property Current As Object
    Get

Property Value

Type: Object

Implements

IEnumeratorCurrent
See Also

Reference

DelegateControl Class
CodeSmith.Engine Namespace


DelegateControl.RenderMethod Property

DelegateControlRenderMethod Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public RenderMethod RenderMethod { get; set; }
Public Property RenderMethod As RenderMethod
    Get
    Set

Property Value

Type: RenderMethod
See Also

Reference

DelegateControl Class
CodeSmith.Engine Namespace


DelegateControl Methods

The DelegateControl type exposes the following members.

Methods
 | Name | Description
Protected method | ControlAdded | (Inherited from Control.)
Protected method | ControlRemoved | (Inherited from Control.)
Protected method | CreateChildControls | (Inherited from Control.)
Protected method | CreateControlCollection | (Overrides ControlCreateControlCollection.)
Protected method | EnsureChildControls | (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HasControls | (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveNext |
Public method | Render | (Overrides ControlRender(TextWriter).)
Protected method | RenderChildren | (Inherited from Control.)
Public method | Reset |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DelegateControl Class
CodeSmith.Engine Namespace


DelegateControl.CreateControlCollection Method

DelegateControlCreateControlCollection Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected override ControlCollection CreateControlCollection()
Protected Overrides Function CreateControlCollection As ControlCollection

Return Value

Type: ControlCollection
See Also

Reference

DelegateControl Class
CodeSmith.Engine Namespace


DelegateControl.MoveNext Method

DelegateControlMoveNext Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool MoveNext()
Public Function MoveNext As Boolean

Return Value

Type: Boolean

Implements

IEnumeratorMoveNext
See Also

Reference

DelegateControl Class
CodeSmith.Engine Namespace


DelegateControl.Render Method

DelegateControlRender Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override void Render(
    TextWriter writer
)
Public Overrides Sub Render (
    writer As TextWriter
)

Parameters

writer
Type: System.IOTextWriter
See Also

Reference

DelegateControl Class
CodeSmith.Engine Namespace


DelegateControl.Reset Method

DelegateControlReset Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void Reset()
Public Sub Reset

Implements

IEnumeratorReset
See Also

Reference

DelegateControl Class
CodeSmith.Engine Namespace


DelegateControl Fields

The DelegateControl type exposes the following members.

Fields
 | Name | Description
Protected field | _childControlsCreated | (Inherited from Control.)
Protected field | _codeTemplate | (Inherited from Control.)
Protected field | _controls | (Inherited from Control.)
Protected field | _parent | (Inherited from Control.)
Protected field | _visible | (Inherited from Control.)
Top
See Also

Reference

DelegateControl Class
CodeSmith.Engine Namespace


DelimitedStringCollection Class

A collection that provides notifications when items get added, removed, or when the whole list is refreshed.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection String
System.Collections.ObjectModelObservableCollection String
CodeSmith.EngineDelimitedStringCollection

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
[TypeConverterAttribute(typeof(DelimitedStringCollectionDelimitedStringTypeConverter))]
public class DelimitedStringCollection : ObservableCollection<string>
<SerializableAttribute>
<TypeConverterAttribute(GetType(DelimitedStringCollectionDelimitedStringTypeConverter))>
Public Class DelimitedStringCollection
    Inherits ObservableCollection(Of String)

The DelimitedStringCollection type exposes the following members.

Constructors
 | Name | Description
Public method | DelimitedStringCollection | Initializes a new instance of the DelimitedStringCollection class.
Public method | DelimitedStringCollection(IEnumerableString) | Initializes a new instance of the DelimitedStringCollection class.
Public method | DelimitedStringCollection(String) | Initializes a new instance of the DelimitedStringCollection class.
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection String .)
Public property | Delimiter | Gets or sets the string delimiter.
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection String .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection String .)
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection String .)
Public method | AddDelimited | Adds the split values from delimitedValues to the collection. The string is split using the Delimiter property.
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollection String .)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollection String .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection String .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from ObservableCollection String .)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection String .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection String .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection String .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection String .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection String .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from ObservableCollection String .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection String .)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection String .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from ObservableCollection String .)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from ObservableCollection String .)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection String .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection String .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from ObservableCollection String .)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ObservableCollection String .)
Public method | ToArray | Returns an array of strings that represents the current collection.
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
 | ToString(IEnumerableString) | Returns a String that represents the values.
 | ToString(IEnumerableString, String) | Returns a String that represents the values.
Top
Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection String .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection String .)
Top
See Also

Reference

CodeSmith.Engine Namespace


DelimitedStringCollection Constructor

Overload List
 | Name | Description
Public method | DelimitedStringCollection | Initializes a new instance of the DelimitedStringCollection class.
Public method | DelimitedStringCollection(IEnumerableString) | Initializes a new instance of the DelimitedStringCollection class.
Public method | DelimitedStringCollection(String) | Initializes a new instance of the DelimitedStringCollection class.
Top
See Also

Reference

DelimitedStringCollection Class
CodeSmith.Engine Namespace


DelimitedStringCollection Constructor

Initializes a new instance of the DelimitedStringCollection class.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public DelimitedStringCollection()
Public Sub New
See Also

Reference

DelimitedStringCollection Class
DelimitedStringCollection Overload
CodeSmith.Engine Namespace


DelimitedStringCollection Constructor (IEnumerable(String))

DelimitedStringCollection Constructor (IEnumerableString)

Initializes a new instance of the DelimitedStringCollection class.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public DelimitedStringCollection(
    IEnumerable<string> collection
)
Public Sub New (
    collection As IEnumerable(Of String)
)

Parameters

collection
Type: System.Collections.GenericIEnumerable String
The collection.
See Also

Reference

DelimitedStringCollection Class
DelimitedStringCollection Overload
CodeSmith.Engine Namespace


DelimitedStringCollection Constructor (String)

Initializes a new instance of the DelimitedStringCollection class.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public DelimitedStringCollection(
    string delimitedValues
)
Public Sub New (
    delimitedValues As String
)

Parameters

delimitedValues
Type: SystemString
The delimited values.
See Also

Reference

DelimitedStringCollection Class
DelimitedStringCollection Overload
CodeSmith.Engine Namespace


DelimitedStringCollection Properties

The DelimitedStringCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection String .)
Public property | Delimiter | Gets or sets the string delimiter.
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection String .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection String .)
Top
See Also

Reference

DelimitedStringCollection Class
CodeSmith.Engine Namespace


DelimitedStringCollection.Delimiter Property

DelimitedStringCollectionDelimiter Property

Gets or sets the string delimiter.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string Delimiter { get; set; }
Public Property Delimiter As String
    Get
    Set

Property Value

Type: String
The string delimiter.
See Also

Reference

DelimitedStringCollection Class
CodeSmith.Engine Namespace


DelimitedStringCollection Methods

The DelimitedStringCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection String .)
Public method | AddDelimited | Adds the split values from delimitedValues to the collection. The string is split using the Delimiter property.
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollection String .)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollection String .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection String .)
Protected method | ClearItems | Removes all items from the collection. (Inherited from ObservableCollection String .)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection String .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection String .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection String .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection String .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection String .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from ObservableCollection String .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection String .)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection String .)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from ObservableCollection String .)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from ObservableCollection String .)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection String .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection String .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from ObservableCollection String .)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ObservableCollection String .)
Public method | ToArray | Returns an array of strings that represents the current collection.
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
 | ToString(IEnumerableString) | Returns a String that represents the values.
 | ToString(IEnumerableString, String) | Returns a String that represents the values.
Top
See Also

Reference

DelimitedStringCollection Class
CodeSmith.Engine Namespace


DelimitedStringCollection.AddDelimited Method

DelimitedStringCollectionAddDelimited Method

Adds the split values from delimitedValues to the collection. The string is split using the Delimiter property.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public int AddDelimited(
    string delimitedValues
)
Public Function AddDelimited (
    delimitedValues As String
) As Integer

Parameters

delimitedValues
Type: SystemString
The delimited values.

Return Value

Type: Int32
The number of values added.
Exceptions
Exception | Condition
ArgumentNullException | Thrown when delimitedValues is null.
See Also

Reference

DelimitedStringCollection Class
CodeSmith.Engine Namespace


DelimitedStringCollection.ToArray Method

DelimitedStringCollectionToArray Method

Returns an array of strings that represents the current collection.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string[] ToArray()
Public Function ToArray As String()

Return Value

Type: String
An array of strings that represents the current collection.
See Also

Reference

DelimitedStringCollection Class
CodeSmith.Engine Namespace


DelimitedStringCollection.ToString Method

DelimitedStringCollectionToString Method

Overload List
 | Name | Description
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
 | ToString(IEnumerableString) | Returns a String that represents the values.
 | ToString(IEnumerableString, String) | Returns a String that represents the values.
Top
See Also

Reference

DelimitedStringCollection Class
CodeSmith.Engine Namespace


DelimitedStringCollection.ToString Method

DelimitedStringCollectionToString Method

Returns a String that represents the current Object.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String that represents the current Object.
See Also

Reference

DelimitedStringCollection Class
ToString Overload
CodeSmith.Engine Namespace


DelimitedStringCollection.ToString Method (IEnumerable(String))

DelimitedStringCollectionToString Method (IEnumerableString)

Returns a String that represents the values.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static string ToString(
    IEnumerable<string> values
)
Public Shared Function ToString (
    values As IEnumerable(Of String)
) As String

Parameters

values
Type: System.Collections.GenericIEnumerable String
The values.

Return Value

Type: String
A String that represents the current Object.
See Also

Reference

DelimitedStringCollection Class
ToString Overload
CodeSmith.Engine Namespace


DelimitedStringCollection.ToString Method (IEnumerable(String), String)

DelimitedStringCollectionToString Method (IEnumerableString, String)

Returns a String that represents the values.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static string ToString(
    IEnumerable<string> values,
    string delimiter
)
Public Shared Function ToString (
    values As IEnumerable(Of String),
    delimiter As String
) As String

Parameters

values
Type: System.Collections.GenericIEnumerable String
The values.
delimiter
Type: SystemString
The delimiter.

Return Value

Type: String
A String that represents the current Object.
See Also

Reference

DelimitedStringCollection Class
ToString Overload
CodeSmith.Engine Namespace


DelimitedStringCollection Events

The DelimitedStringCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection String .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection String .)
Top
See Also

Reference

DelimitedStringCollection Class
CodeSmith.Engine Namespace


DelimitedStringCollection.DelimitedStringTypeConverter Class

DelimitedStringCollectionDelimitedStringTypeConverter Class

A type converter for the DelimitedStringCollection.
Inheritance Hierarchy
SystemObject
System.ComponentModelTypeConverter
CodeSmith.EngineDelimitedStringCollectionDelimitedStringTypeConverter

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class DelimitedStringTypeConverter : TypeConverter
Public Class DelimitedStringTypeConverter
    Inherits TypeConverter

The DelimitedStringCollectionDelimitedStringTypeConverter type exposes the following members.

Constructors
 | Name | Description
Public method | DelimitedStringCollectionDelimitedStringTypeConverter | Initializes a new instance of the DelimitedStringCollectionDelimitedStringTypeConverter class
Top
Methods
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context. (Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Returns whether this converter can convert the object to the specified type, using the specified context. (Overrides TypeConverterCanConvertTo(ITypeDescriptorContext, Type).)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts the given object to the type of this converter, using the specified context and culture information. (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
Public method | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified type, using the specified context and culture information. (Overrides TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Public method | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
Public method | CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Protected method | GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object, Attribute) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported | Returns whether this object supports properties. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | Returns whether this object supports properties, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValues | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
Public method | GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
Public method | IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSmith.Engine Namespace


DelimitedStringCollection.DelimitedStringTypeConverter Constructor

DelimitedStringCollectionDelimitedStringTypeConverter Constructor

Initializes a new instance of the DelimitedStringCollectionDelimitedStringTypeConverter class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public DelimitedStringTypeConverter()
Public Sub New
See Also

Reference

DelimitedStringCollectionDelimitedStringTypeConverter Class
CodeSmith.Engine Namespace


DelimitedStringTypeConverter Methods

The DelimitedStringCollectionDelimitedStringTypeConverter type exposes the following members.

Methods
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context. (Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Returns whether this converter can convert the object to the specified type, using the specified context. (Overrides TypeConverterCanConvertTo(ITypeDescriptorContext, Type).)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts the given object to the type of this converter, using the specified context and culture information. (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
Public method | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified type, using the specified context and culture information. (Overrides TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Public method | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
Public method | CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Protected method | GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object, Attribute) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported | Returns whether this object supports properties. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | Returns whether this object supports properties, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValues | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
Public method | GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
Public method | IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DelimitedStringCollectionDelimitedStringTypeConverter Class
CodeSmith.Engine Namespace


DelimitedStringTypeConverter.CanConvertFrom Method

DelimitedStringTypeConverterCanConvertFrom Method

Overload List
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context. (Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Top
See Also

Reference

DelimitedStringCollectionDelimitedStringTypeConverter Class
CodeSmith.Engine Namespace


DelimitedStringCollection.DelimitedStringTypeConverter.CanConvertFrom Method (ITypeDescriptorContext, Type)

DelimitedStringCollectionDelimitedStringTypeConverterCanConvertFrom Method (ITypeDescriptorContext, Type)

Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override bool CanConvertFrom(
    ITypeDescriptorContext context,
    Type sourceType
)
Public Overrides Function CanConvertFrom (
    context As ITypeDescriptorContext,
    sourceType As Type
) As Boolean

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
sourceType
Type: SystemType
A Type that represents the type you want to convert from.

Return Value

Type: Boolean
true if this converter can perform the conversion; otherwise, false.
See Also

Reference

DelimitedStringCollectionDelimitedStringTypeConverter Class
CanConvertFrom Overload
CodeSmith.Engine Namespace


DelimitedStringTypeConverter.CanConvertTo Method

DelimitedStringTypeConverterCanConvertTo Method

Overload List
 | Name | Description
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Returns whether this converter can convert the object to the specified type, using the specified context. (Overrides TypeConverterCanConvertTo(ITypeDescriptorContext, Type).)
Top
See Also

Reference

DelimitedStringCollectionDelimitedStringTypeConverter Class
CodeSmith.Engine Namespace


DelimitedStringCollection.DelimitedStringTypeConverter.CanConvertTo Method (ITypeDescriptorContext, Type)

DelimitedStringCollectionDelimitedStringTypeConverterCanConvertTo Method (ITypeDescriptorContext, Type)

Returns whether this converter can convert the object to the specified type, using the specified context.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override bool CanConvertTo(
    ITypeDescriptorContext context,
    Type destinationType
)
Public Overrides Function CanConvertTo (
    context As ITypeDescriptorContext,
    destinationType As Type
) As Boolean

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
destinationType
Type: SystemType
A Type that represents the type you want to convert to.

Return Value

Type: Boolean
true if this converter can perform the conversion; otherwise, false.
See Also

Reference

DelimitedStringCollectionDelimitedStringTypeConverter Class
CanConvertTo Overload
CodeSmith.Engine Namespace


DelimitedStringTypeConverter.ConvertFrom Method

DelimitedStringTypeConverterConvertFrom Method

Overload List
 | Name | Description
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts the given object to the type of this converter, using the specified context and culture information. (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Top
See Also

Reference

DelimitedStringCollectionDelimitedStringTypeConverter Class
CodeSmith.Engine Namespace


DelimitedStringCollection.DelimitedStringTypeConverter.ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

DelimitedStringCollectionDelimitedStringTypeConverterConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

Converts the given object to the type of this converter, using the specified context and culture information.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override Object ConvertFrom(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value
)
Public Overrides Function ConvertFrom (
    context As ITypeDescriptorContext,
    culture As CultureInfo,
    value As Object
) As Object

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
culture
Type: System.GlobalizationCultureInfo
The CultureInfo to use as the current culture.
value
Type: SystemObject
The Object to convert.

Return Value

Type: Object
An Object that represents the converted value.
Exceptions
Exception | Condition
NotSupportedException | The conversion cannot be performed.
See Also

Reference

DelimitedStringCollectionDelimitedStringTypeConverter Class
ConvertFrom Overload
CodeSmith.Engine Namespace


DelimitedStringTypeConverter.ConvertTo Method

DelimitedStringTypeConverterConvertTo Method

Overload List
 | Name | Description
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified type, using the specified context and culture information. (Overrides TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Top
See Also

Reference

DelimitedStringCollectionDelimitedStringTypeConverter Class
CodeSmith.Engine Namespace


DelimitedStringCollection.DelimitedStringTypeConverter.ConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)

DelimitedStringCollectionDelimitedStringTypeConverterConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)

Converts the given value object to the specified type, using the specified context and culture information.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override Object ConvertTo(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value,
    Type destinationType
)
Public Overrides Function ConvertTo (
    context As ITypeDescriptorContext,
    culture As CultureInfo,
    value As Object,
    destinationType As Type
) As Object

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
An ITypeDescriptorContext that provides a format context.
culture
Type: System.GlobalizationCultureInfo
A CultureInfo. If null is passed, the current culture is assumed.
value
Type: SystemObject
The Object to convert.
destinationType
Type: SystemType
The Type to convert the value parameter to.

Return Value

Type: Object
An Object that represents the converted value.
Exceptions
Exception | Condition
ArgumentNullException | The destinationType parameter is null.
NotSupportedException | The conversion cannot be performed.
See Also

Reference

DelimitedStringCollectionDelimitedStringTypeConverter Class
ConvertTo Overload
CodeSmith.Engine Namespace


DidNotAcceptTrialException Class

Inheritance Hierarchy
SystemObject
SystemException
SystemApplicationException
CodeSmith.EngineDidNotAcceptTrialException

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
public class DidNotAcceptTrialException : ApplicationException
<SerializableAttribute>
Public Class DidNotAcceptTrialException
    Inherits ApplicationException

The DidNotAcceptTrialException type exposes the following members.

Constructors
 | Name | Description
Public method | DidNotAcceptTrialException | Initializes a new instance of the DidNotAcceptTrialException class
Protected method | DidNotAcceptTrialException(SerializationInfo, StreamingContext) | Initializes a new instance of the DidNotAcceptTrialException class
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | (Overrides ExceptionMessage.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

CodeSmith.Engine Namespace


DidNotAcceptTrialException Constructor

Overload List
 | Name | Description
Public method | DidNotAcceptTrialException | Initializes a new instance of the DidNotAcceptTrialException class
Protected method | DidNotAcceptTrialException(SerializationInfo, StreamingContext) | Initializes a new instance of the DidNotAcceptTrialException class
Top
See Also

Reference

DidNotAcceptTrialException Class
CodeSmith.Engine Namespace


DidNotAcceptTrialException Constructor

Initializes a new instance of the DidNotAcceptTrialException class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public DidNotAcceptTrialException()
Public Sub New
See Also

Reference

DidNotAcceptTrialException Class
DidNotAcceptTrialException Overload
CodeSmith.Engine Namespace


DidNotAcceptTrialException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the DidNotAcceptTrialException class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected DidNotAcceptTrialException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

DidNotAcceptTrialException Class
DidNotAcceptTrialException Overload
CodeSmith.Engine Namespace


DidNotAcceptTrialException Properties

The DidNotAcceptTrialException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | (Overrides ExceptionMessage.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

DidNotAcceptTrialException Class
CodeSmith.Engine Namespace


DidNotAcceptTrialException.Message Property

DidNotAcceptTrialExceptionMessage Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override string Message { get; }
Public Overrides ReadOnly Property Message As String
    Get

Property Value

Type: String

Implements

_ExceptionMessage
See Also

Reference

DidNotAcceptTrialException Class
CodeSmith.Engine Namespace


DidNotAcceptTrialException Methods

The DidNotAcceptTrialException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

DidNotAcceptTrialException Class
CodeSmith.Engine Namespace


DidNotAcceptTrialException Events

The DidNotAcceptTrialException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

DidNotAcceptTrialException Class
CodeSmith.Engine Namespace


EmptyControlCollection Class

Inheritance Hierarchy
SystemObject
CodeSmith.EngineControlCollection
CodeSmith.EngineEmptyControlCollection

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class EmptyControlCollection : ControlCollection
Public Class EmptyControlCollection
    Inherits ControlCollection

The EmptyControlCollection type exposes the following members.

Constructors
 | Name | Description
Public method | EmptyControlCollection | Initializes a new instance of the EmptyControlCollection class
Top
Properties
 | Name | Description
Public property | Count | (Inherited from ControlCollection.)
Public property | IsReadOnly | (Inherited from ControlCollection.)
Public property | IsSynchronized | (Inherited from ControlCollection.)
Public property | Item | (Inherited from ControlCollection.)
Public property | Owner | (Inherited from ControlCollection.)
Public property | SyncRoot | (Inherited from ControlCollection.)
Top
Methods
 | Name | Description
Public method | Add | (Overrides ControlCollectionAdd(Control).)
Public method | AddAt | (Overrides ControlCollectionAddAt(Int32, Control).)
Public method | Clear | (Inherited from ControlCollection.)
Public method | Contains | (Inherited from ControlCollection.)
Public method | CopyTo | (Inherited from ControlCollection.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | (Inherited from ControlCollection.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | (Inherited from ControlCollection.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | (Inherited from ControlCollection.)
Public method | RemoveAt | (Inherited from ControlCollection.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSmith.Engine Namespace


EmptyControlCollection Constructor

Initializes a new instance of the EmptyControlCollection class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public EmptyControlCollection(
    Control owner
)
Public Sub New (
    owner As Control
)

Parameters

owner
Type: CodeSmith.EngineControl
See Also

Reference

EmptyControlCollection Class
CodeSmith.Engine Namespace


EmptyControlCollection Properties

The EmptyControlCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | (Inherited from ControlCollection.)
Public property | IsReadOnly | (Inherited from ControlCollection.)
Public property | IsSynchronized | (Inherited from ControlCollection.)
Public property | Item | (Inherited from ControlCollection.)
Public property | Owner | (Inherited from ControlCollection.)
Public property | SyncRoot | (Inherited from ControlCollection.)
Top
See Also

Reference

EmptyControlCollection Class
CodeSmith.Engine Namespace


EmptyControlCollection Methods

The EmptyControlCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | (Overrides ControlCollectionAdd(Control).)
Public method | AddAt | (Overrides ControlCollectionAddAt(Int32, Control).)
Public method | Clear | (Inherited from ControlCollection.)
Public method | Contains | (Inherited from ControlCollection.)
Public method | CopyTo | (Inherited from ControlCollection.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | (Inherited from ControlCollection.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | (Inherited from ControlCollection.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | (Inherited from ControlCollection.)
Public method | RemoveAt | (Inherited from ControlCollection.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

EmptyControlCollection Class
CodeSmith.Engine Namespace


EmptyControlCollection.Add Method

EmptyControlCollectionAdd Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override void Add(
    Control child
)
Public Overrides Sub Add (
    child As Control
)

Parameters

child
Type: CodeSmith.EngineControl
See Also

Reference

EmptyControlCollection Class
CodeSmith.Engine Namespace


EmptyControlCollection.AddAt Method

EmptyControlCollectionAddAt Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override void AddAt(
    int index,
    Control child
)
Public Overrides Sub AddAt (
    index As Integer,
    child As Control
)

Parameters

index
Type: SystemInt32
child
Type: CodeSmith.EngineControl
See Also

Reference

EmptyControlCollection Class
CodeSmith.Engine Namespace


EngineConstants Class

Inheritance Hierarchy
SystemObject
CodeSmith.EngineEngineConstants

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static class EngineConstants
Public NotInheritable Class EngineConstants

The EngineConstants type exposes the following members.

Fields
Name | Description
MapFileExtension |
ProjectFileExtension |
TemplateFileExtension |
Top
See Also

Reference

CodeSmith.Engine Namespace


EngineConstants Fields

The EngineConstants type exposes the following members.

Fields
Name | Description
MapFileExtension |
ProjectFileExtension |
TemplateFileExtension |
Top
See Also

Reference

EngineConstants Class
CodeSmith.Engine Namespace


EngineConstants.MapFileExtension Field

EngineConstantsMapFileExtension Field

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public const string MapFileExtension = ".csmap"
Public Const MapFileExtension As String = ".csmap"

Field Value

Type: String
See Also

Reference

EngineConstants Class
CodeSmith.Engine Namespace


EngineConstants.ProjectFileExtension Field

EngineConstantsProjectFileExtension Field

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public const string ProjectFileExtension = ".csp"
Public Const ProjectFileExtension As String = ".csp"

Field Value

Type: String
See Also

Reference

EngineConstants Class
CodeSmith.Engine Namespace


EngineConstants.TemplateFileExtension Field

EngineConstantsTemplateFileExtension Field

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public const string TemplateFileExtension = ".cst"
Public Const TemplateFileExtension As String = ".cst"

Field Value

Type: String
See Also

Reference

EngineConstants Class
CodeSmith.Engine Namespace


EngineHostBase Class

Inheritance Hierarchy
SystemObject
CodeSmith.EngineEngineHostBase
CodeSmith.EngineDefaultEngineHost

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public abstract class EngineHostBase : IEngineHost
Public MustInherit Class EngineHostBase
    Implements IEngineHost

The EngineHostBase type exposes the following members.

Constructors
 | Name | Description
Protected method | EngineHostBase | Initializes a new instance of the EngineHostBase class
Top
Properties
 | Name | Description
Public property | BasePath |
Public property | DefaultBaseClass |
Public property | DefaultClassName |
Public property | DefaultImports |
Public property | DefaultNamespace |
Public property | DefaultReferences |
Public property | RegisteredContent |
Top
Methods
 | Name | Description
Public method | ContentExists |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetContent(String, Boolean) |
Public method | GetContent(String, String, Boolean) |
Public method | GetFullPath(String) |
Public method | GetFullPath(String, String) |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PostProcessCompileResult |
Public method | PostProcessParseResult |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSmith.Engine Namespace


EngineHostBase Constructor

Initializes a new instance of the EngineHostBase class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected EngineHostBase()
Protected Sub New
See Also

Reference

EngineHostBase Class
CodeSmith.Engine Namespace


EngineHostBase Properties

The EngineHostBase type exposes the following members.

Properties
 | Name | Description
Public property | BasePath |
Public property | DefaultBaseClass |
Public property | DefaultClassName |
Public property | DefaultImports |
Public property | DefaultNamespace |
Public property | DefaultReferences |
Public property | RegisteredContent |
Top
See Also

Reference

EngineHostBase Class
CodeSmith.Engine Namespace


EngineHostBase.BasePath Property

EngineHostBaseBasePath Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string BasePath { get; set; }
Public Property BasePath As String
    Get
    Set

Property Value

Type: String
See Also

Reference

EngineHostBase Class
CodeSmith.Engine Namespace


EngineHostBase.DefaultBaseClass Property

EngineHostBaseDefaultBaseClass Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string DefaultBaseClass { get; set; }
Public Property DefaultBaseClass As String
    Get
    Set

Property Value

Type: String

Implements

IEngineHostDefaultBaseClass
See Also

Reference

EngineHostBase Class
CodeSmith.Engine Namespace


EngineHostBase.DefaultClassName Property

EngineHostBaseDefaultClassName Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string DefaultClassName { get; set; }
Public Property DefaultClassName As String
    Get
    Set

Property Value

Type: String
See Also

Reference

EngineHostBase Class
CodeSmith.Engine Namespace


EngineHostBase.DefaultImports Property

EngineHostBaseDefaultImports Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ISet<string> DefaultImports { get; set; }
Public Property DefaultImports As ISet(Of String)
    Get
    Set

Property Value

Type: ISet String

Implements

IEngineHostDefaultImports
See Also

Reference

EngineHostBase Class
CodeSmith.Engine Namespace


EngineHostBase.DefaultNamespace Property

EngineHostBaseDefaultNamespace Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string DefaultNamespace { get; set; }
Public Property DefaultNamespace As String
    Get
    Set

Property Value

Type: String

Implements

IEngineHostDefaultNamespace
See Also

Reference

EngineHostBase Class
CodeSmith.Engine Namespace


EngineHostBase.DefaultReferences Property

EngineHostBaseDefaultReferences Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ISet<AssemblyReference> DefaultReferences { get; set; }
Public Property DefaultReferences As ISet(Of AssemblyReference)
    Get
    Set

Property Value

Type: ISet AssemblyReference

Implements

IEngineHostDefaultReferences
See Also

Reference

EngineHostBase Class
CodeSmith.Engine Namespace


EngineHostBase.RegisteredContent Property

EngineHostBaseRegisteredContent Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public RegisteredContent RegisteredContent { get; }
Public ReadOnly Property RegisteredContent As RegisteredContent
    Get

Property Value

Type: RegisteredContent

Implements

IEngineHostRegisteredContent
See Also

Reference

EngineHostBase Class
CodeSmith.Engine Namespace


EngineHostBase Methods

The EngineHostBase type exposes the following members.

Methods
 | Name | Description
Public method | ContentExists |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetContent(String, Boolean) |
Public method | GetContent(String, String, Boolean) |
Public method | GetFullPath(String) |
Public method | GetFullPath(String, String) |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PostProcessCompileResult |
Public method | PostProcessParseResult |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

EngineHostBase Class
CodeSmith.Engine Namespace


EngineHostBase.ContentExists Method

EngineHostBaseContentExists Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual bool ContentExists(
    string path
)
Public Overridable Function ContentExists (
    path As String
) As Boolean

Parameters

path
Type: SystemString

Return Value

Type: Boolean

Implements

IEngineHostContentExists(String)
See Also

Reference

EngineHostBase Class
CodeSmith.Engine Namespace


EngineHostBase.GetContent Method

EngineHostBaseGetContent Method

Overload List
 | Name | Description
Public method | GetContent(String, Boolean) |
Public method | GetContent(String, String, Boolean) |
Top
See Also

Reference

EngineHostBase Class
CodeSmith.Engine Namespace


EngineHostBase.GetContent Method (String, Boolean)

EngineHostBaseGetContent Method (String, Boolean)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string GetContent(
    string path,
    bool useRegisteredContent = true
)
Public Function GetContent (
    path As String,
    Optional useRegisteredContent As Boolean = true
) As String

Parameters

path
Type: SystemString
useRegisteredContent (Optional)
Type: SystemBoolean

Return Value

Type: String

Implements

IEngineHostGetContent(String, Boolean)
See Also

Reference

EngineHostBase Class
GetContent Overload
CodeSmith.Engine Namespace


EngineHostBase.GetContent Method (String, String, Boolean)

EngineHostBaseGetContent Method (String, String, Boolean)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual string GetContent(
    string basePath,
    string path,
    bool useRegisteredContent = true
)
Public Overridable Function GetContent (
    basePath As String,
    path As String,
    Optional useRegisteredContent As Boolean = true
) As String

Parameters

basePath
Type: SystemString
path
Type: SystemString
useRegisteredContent (Optional)
Type: SystemBoolean

Return Value

Type: String

Implements

IEngineHostGetContent(String, String, Boolean)
See Also

Reference

EngineHostBase Class
GetContent Overload
CodeSmith.Engine Namespace


EngineHostBase.GetFullPath Method

EngineHostBaseGetFullPath Method

Overload List
 | Name | Description
Public method | GetFullPath(String) |
Public method | GetFullPath(String, String) |
Top
See Also

Reference

EngineHostBase Class
CodeSmith.Engine Namespace


EngineHostBase.GetFullPath Method (String)

EngineHostBaseGetFullPath Method (String)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string GetFullPath(
    string path
)
Public Function GetFullPath (
    path As String
) As String

Parameters

path
Type: SystemString

Return Value

Type: String

Implements

IEngineHostGetFullPath(String)
See Also

Reference

EngineHostBase Class
GetFullPath Overload
CodeSmith.Engine Namespace


EngineHostBase.GetFullPath Method (String, String)

EngineHostBaseGetFullPath Method (String, String)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual string GetFullPath(
    string basePath,
    string path
)
Public Overridable Function GetFullPath (
    basePath As String,
    path As String
) As String

Parameters

basePath
Type: SystemString
path
Type: SystemString

Return Value

Type: String

Implements

IEngineHostGetFullPath(String, String)
See Also

Reference

EngineHostBase Class
GetFullPath Overload
CodeSmith.Engine Namespace


EngineHostBase.PostProcessCompileResult Method

EngineHostBasePostProcessCompileResult Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual void PostProcessCompileResult(
    CompileTemplateResult templateResult
)
Public Overridable Sub PostProcessCompileResult (
    templateResult As CompileTemplateResult
)

Parameters

templateResult
Type: CodeSmith.EngineCompileTemplateResult

Implements

IEngineHostPostProcessCompileResult(CompileTemplateResult)
See Also

Reference

EngineHostBase Class
CodeSmith.Engine Namespace


EngineHostBase.PostProcessParseResult Method

EngineHostBasePostProcessParseResult Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual void PostProcessParseResult(
    TemplateParseResult templateResult
)
Public Overridable Sub PostProcessParseResult (
    templateResult As TemplateParseResult
)

Parameters

templateResult
Type: CodeSmith.EngineTemplateParseResult

Implements

IEngineHostPostProcessParseResult(TemplateParseResult)
See Also

Reference

EngineHostBase Class
CodeSmith.Engine Namespace


FeatureNotAllowedException Class

Inheritance Hierarchy
SystemObject
SystemException
SystemApplicationException
CodeSmith.EngineFeatureNotAllowedException

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
public class FeatureNotAllowedException : ApplicationException
<SerializableAttribute>
Public Class FeatureNotAllowedException
    Inherits ApplicationException

The FeatureNotAllowedException type exposes the following members.

Constructors
 | Name | Description
Public method | FeatureNotAllowedException | Initializes a new instance of the FeatureNotAllowedException class
Public method | FeatureNotAllowedException(String) | Initializes a new instance of the FeatureNotAllowedException class
Protected method | FeatureNotAllowedException(SerializationInfo, StreamingContext) | Initializes a new instance of the FeatureNotAllowedException class
Public method | FeatureNotAllowedException(String, String) | Initializes a new instance of the FeatureNotAllowedException class
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | (Overrides ExceptionMessage.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
Fields
Name | Description
FeatureNotAllowedMessage |
Top
See Also

Reference

CodeSmith.Engine Namespace


FeatureNotAllowedException Constructor

Overload List
 | Name | Description
Public method | FeatureNotAllowedException | Initializes a new instance of the FeatureNotAllowedException class
Public method | FeatureNotAllowedException(String) | Initializes a new instance of the FeatureNotAllowedException class
Protected method | FeatureNotAllowedException(SerializationInfo, StreamingContext) | Initializes a new instance of the FeatureNotAllowedException class
Public method | FeatureNotAllowedException(String, String) | Initializes a new instance of the FeatureNotAllowedException class
Top
See Also

Reference

FeatureNotAllowedException Class
CodeSmith.Engine Namespace


FeatureNotAllowedException Constructor

Initializes a new instance of the FeatureNotAllowedException class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public FeatureNotAllowedException()
Public Sub New
See Also

Reference

FeatureNotAllowedException Class
FeatureNotAllowedException Overload
CodeSmith.Engine Namespace


FeatureNotAllowedException Constructor (String)

Initializes a new instance of the FeatureNotAllowedException class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public FeatureNotAllowedException(
    string message
)
Public Sub New (
    message As String
)

Parameters

message
Type: SystemString
See Also

Reference

FeatureNotAllowedException Class
FeatureNotAllowedException Overload
CodeSmith.Engine Namespace


FeatureNotAllowedException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the FeatureNotAllowedException class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected FeatureNotAllowedException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

FeatureNotAllowedException Class
FeatureNotAllowedException Overload
CodeSmith.Engine Namespace


FeatureNotAllowedException Constructor (String, String)

Initializes a new instance of the FeatureNotAllowedException class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public FeatureNotAllowedException(
    string feature,
    string requiredVersion
)
Public Sub New (
    feature As String,
    requiredVersion As String
)

Parameters

feature
Type: SystemString
requiredVersion
Type: SystemString
See Also

Reference

FeatureNotAllowedException Class
FeatureNotAllowedException Overload
CodeSmith.Engine Namespace


FeatureNotAllowedException Properties

The FeatureNotAllowedException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | (Overrides ExceptionMessage.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

FeatureNotAllowedException Class
CodeSmith.Engine Namespace


FeatureNotAllowedException.Message Property

FeatureNotAllowedExceptionMessage Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override string Message { get; }
Public Overrides ReadOnly Property Message As String
    Get

Property Value

Type: String

Implements

_ExceptionMessage
See Also

Reference

FeatureNotAllowedException Class
CodeSmith.Engine Namespace


FeatureNotAllowedException Methods

The FeatureNotAllowedException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

FeatureNotAllowedException Class
CodeSmith.Engine Namespace


FeatureNotAllowedException Events

The FeatureNotAllowedException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

FeatureNotAllowedException Class
CodeSmith.Engine Namespace


FeatureNotAllowedException Fields

The FeatureNotAllowedException type exposes the following members.

Fields
Name | Description
FeatureNotAllowedMessage |
Top
See Also

Reference

FeatureNotAllowedException Class
CodeSmith.Engine Namespace


FeatureNotAllowedException.FeatureNotAllowedMessage Field

FeatureNotAllowedExceptionFeatureNotAllowedMessage Field

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public const string FeatureNotAllowedMessage = "The feature you are trying to access ({0}) requires a Generator {1} license.  Your license is a Generator {2} license.  If you would like to upgrade your license, please visit our website http://www.codesmithtools.com/ or contact sales@codesmithtools.com."
Public Const FeatureNotAllowedMessage As String = "The feature you are trying to access ({0}) requires a Generator {1} license.  Your license is a Generator {2} license.  If you would like to upgrade your license, please visit our website http://www.codesmithtools.com/ or contact sales@codesmithtools.com."

Field Value

Type: String
See Also

Reference

FeatureNotAllowedException Class
CodeSmith.Engine Namespace


GenerateCodeResult Class

Inheritance Hierarchy
SystemObject
CodeSmith.EngineGenerateCodeResult

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class GenerateCodeResult
Public Class GenerateCodeResult

The GenerateCodeResult type exposes the following members.

Constructors
 | Name | Description
Public method | GenerateCodeResult | Initializes a new instance of the GenerateCodeResult class
Top
Properties
 | Name | Description
Public property | Source |
Public property | TypeName |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSmith.Engine Namespace


GenerateCodeResult Constructor

Initializes a new instance of the GenerateCodeResult class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public GenerateCodeResult()
Public Sub New
See Also

Reference

GenerateCodeResult Class
CodeSmith.Engine Namespace


GenerateCodeResult Properties

The GenerateCodeResult type exposes the following members.

Properties
 | Name | Description
Public property | Source |
Public property | TypeName |
Top
See Also

Reference

GenerateCodeResult Class
CodeSmith.Engine Namespace


GenerateCodeResult.Source Property

GenerateCodeResultSource Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string Source { get; set; }
Public Property Source As String
    Get
    Set

Property Value

Type: String
See Also

Reference

GenerateCodeResult Class
CodeSmith.Engine Namespace


GenerateCodeResult.TypeName Property

GenerateCodeResultTypeName Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string TypeName { get; set; }
Public Property TypeName As String
    Get
    Set

Property Value

Type: String
See Also

Reference

GenerateCodeResult Class
CodeSmith.Engine Namespace


GenerateCodeResult Methods

The GenerateCodeResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GenerateCodeResult Class
CodeSmith.Engine Namespace


GenerateEndEventArgs Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
CodeSmith.EngineGenerateEndEventArgs

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
public class GenerateEndEventArgs : EventArgs
<SerializableAttribute>
Public Class GenerateEndEventArgs
    Inherits EventArgs

The GenerateEndEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | GenerateEndEventArgs | Initializes a new instance of the GenerateEndEventArgs class
Public method | GenerateEndEventArgs(String) | Initializes a new instance of the GenerateEndEventArgs class
Top
Properties
 | Name | Description
Public property | ProjectFile |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSmith.Engine Namespace


GenerateEndEventArgs Constructor

Overload List
 | Name | Description
Public method | GenerateEndEventArgs | Initializes a new instance of the GenerateEndEventArgs class
Public method | GenerateEndEventArgs(String) | Initializes a new instance of the GenerateEndEventArgs class
Top
See Also

Reference

GenerateEndEventArgs Class
CodeSmith.Engine Namespace


GenerateEndEventArgs Constructor

Initializes a new instance of the GenerateEndEventArgs class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public GenerateEndEventArgs()
Public Sub New
See Also

Reference

GenerateEndEventArgs Class
GenerateEndEventArgs Overload
CodeSmith.Engine Namespace


GenerateEndEventArgs Constructor (String)

Initializes a new instance of the GenerateEndEventArgs class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public GenerateEndEventArgs(
    string projectFile
)
Public Sub New (
    projectFile As String
)

Parameters

projectFile
Type: SystemString
See Also

Reference

GenerateEndEventArgs Class
GenerateEndEventArgs Overload
CodeSmith.Engine Namespace


GenerateEndEventArgs Properties

The GenerateEndEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | ProjectFile |
Top
See Also

Reference

GenerateEndEventArgs Class
CodeSmith.Engine Namespace


GenerateEndEventArgs.ProjectFile Property

GenerateEndEventArgsProjectFile Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string ProjectFile { get; set; }
Public Property ProjectFile As String
    Get
    Set

Property Value

Type: String
See Also

Reference

GenerateEndEventArgs Class
CodeSmith.Engine Namespace


GenerateEndEventArgs Methods

The GenerateEndEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GenerateEndEventArgs Class
CodeSmith.Engine Namespace


GenerateEndEventHandler Delegate

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public delegate void GenerateEndEventHandler(
    Object sender,
    GenerateEndEventArgs e
)
Public Delegate Sub GenerateEndEventHandler (
    sender As Object,
    e As GenerateEndEventArgs
)

Parameters

sender
Type: SystemObject
e
Type: CodeSmith.EngineGenerateEndEventArgs
See Also

Reference

CodeSmith.Engine Namespace


GenerateEventArgs Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
CodeSmith.EngineGenerateEventArgs

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
public class GenerateEventArgs : EventArgs
<SerializableAttribute>
Public Class GenerateEventArgs
    Inherits EventArgs

The GenerateEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | GenerateEventArgs | Initializes a new instance of the GenerateEventArgs class
Top
Properties
 | Name | Description
Public property | ContextData |
Public property | Debug |
Public property | FilePath |
Public property | Verbose |
Top
Methods
 | Name | Description
Public method | AddContextData |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSmith.Engine Namespace


GenerateEventArgs Constructor

Initializes a new instance of the GenerateEventArgs class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public GenerateEventArgs()
Public Sub New
See Also

Reference

GenerateEventArgs Class
CodeSmith.Engine Namespace


GenerateEventArgs Properties

The GenerateEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | ContextData |
Public property | Debug |
Public property | FilePath |
Public property | Verbose |
Top
See Also

Reference

GenerateEventArgs Class
CodeSmith.Engine Namespace


GenerateEventArgs.ContextData Property

GenerateEventArgsContextData Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ICollection<ContextItem> ContextData { get; }
Public ReadOnly Property ContextData As ICollection(Of ContextItem)
    Get

Property Value

Type: ICollection ContextItem
See Also

Reference

GenerateEventArgs Class
CodeSmith.Engine Namespace


GenerateEventArgs.Debug Property

GenerateEventArgsDebug Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool Debug { get; set; }
Public Property Debug As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

GenerateEventArgs Class
CodeSmith.Engine Namespace


GenerateEventArgs.FilePath Property

GenerateEventArgsFilePath Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string FilePath { get; set; }
Public Property FilePath As String
    Get
    Set

Property Value

Type: String
See Also

Reference

GenerateEventArgs Class
CodeSmith.Engine Namespace


GenerateEventArgs.Verbose Property

GenerateEventArgsVerbose Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool Verbose { get; set; }
Public Property Verbose As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

GenerateEventArgs Class
CodeSmith.Engine Namespace


GenerateEventArgs Methods

The GenerateEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | AddContextData |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GenerateEventArgs Class
CodeSmith.Engine Namespace


GenerateEventArgs.AddContextData Method

GenerateEventArgsAddContextData Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ContextItem AddContextData(
    string name,
    string value
)
Public Function AddContextData (
    name As String,
    value As String
) As ContextItem

Parameters

name
Type: SystemString
value
Type: SystemString

Return Value

Type: ContextItem
See Also

Reference

GenerateEventArgs Class
CodeSmith.Engine Namespace


GenerateStartEventArgs Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
CodeSmith.EngineGenerateStartEventArgs

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
public class GenerateStartEventArgs : EventArgs
<SerializableAttribute>
Public Class GenerateStartEventArgs
    Inherits EventArgs

The GenerateStartEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | GenerateStartEventArgs | Initializes a new instance of the GenerateStartEventArgs class
Public method | GenerateStartEventArgs(String) | Initializes a new instance of the GenerateStartEventArgs class
Top
Properties
 | Name | Description
Public property | ProjectFile |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSmith.Engine Namespace


GenerateStartEventArgs Constructor

Overload List
 | Name | Description
Public method | GenerateStartEventArgs | Initializes a new instance of the GenerateStartEventArgs class
Public method | GenerateStartEventArgs(String) | Initializes a new instance of the GenerateStartEventArgs class
Top
See Also

Reference

GenerateStartEventArgs Class
CodeSmith.Engine Namespace


GenerateStartEventArgs Constructor

Initializes a new instance of the GenerateStartEventArgs class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public GenerateStartEventArgs()
Public Sub New
See Also

Reference

GenerateStartEventArgs Class
GenerateStartEventArgs Overload
CodeSmith.Engine Namespace


GenerateStartEventArgs Constructor (String)

Initializes a new instance of the GenerateStartEventArgs class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public GenerateStartEventArgs(
    string projectFile
)
Public Sub New (
    projectFile As String
)

Parameters

projectFile
Type: SystemString
See Also

Reference

GenerateStartEventArgs Class
GenerateStartEventArgs Overload
CodeSmith.Engine Namespace


GenerateStartEventArgs Properties

The GenerateStartEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | ProjectFile |
Top
See Also

Reference

GenerateStartEventArgs Class
CodeSmith.Engine Namespace


GenerateStartEventArgs.ProjectFile Property

GenerateStartEventArgsProjectFile Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string ProjectFile { get; set; }
Public Property ProjectFile As String
    Get
    Set

Property Value

Type: String
See Also

Reference

GenerateStartEventArgs Class
CodeSmith.Engine Namespace


GenerateStartEventArgs Methods

The GenerateStartEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GenerateStartEventArgs Class
CodeSmith.Engine Namespace


GenerateStartEventHandler Delegate

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public delegate void GenerateStartEventHandler(
    Object sender,
    GenerateStartEventArgs e
)
Public Delegate Sub GenerateStartEventHandler (
    sender As Object,
    e As GenerateStartEventArgs
)

Parameters

sender
Type: SystemObject
e
Type: CodeSmith.EngineGenerateStartEventArgs
See Also

Reference

CodeSmith.Engine Namespace


GenerateTemplateResult Class

Inheritance Hierarchy
SystemObject
CodeSmith.EngineGenerateTemplateResult

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
public class GenerateTemplateResult
<SerializableAttribute>
Public Class GenerateTemplateResult

The GenerateTemplateResult type exposes the following members.

Constructors
 | Name | Description
Public method | GenerateTemplateResult | Initializes a new instance of the GenerateTemplateResult class
Top
Properties
 | Name | Description
Public property | DefaultFileName |
Public property | DefaultFullPath |
Public property | Encoding |
Public property | Language |
Public property | Output |
Public property | OutputType |
Public property | Success |
Public property | TemplatePath |
Public property | TemplatePropertySet |
Public property | ValidationErrors |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSmith.Engine Namespace


GenerateTemplateResult Constructor

Initializes a new instance of the GenerateTemplateResult class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public GenerateTemplateResult()
Public Sub New
See Also

Reference

GenerateTemplateResult Class
CodeSmith.Engine Namespace


GenerateTemplateResult Properties

The GenerateTemplateResult type exposes the following members.

Properties
 | Name | Description
Public property | DefaultFileName |
Public property | DefaultFullPath |
Public property | Encoding |
Public property | Language |
Public property | Output |
Public property | OutputType |
Public property | Success |
Public property | TemplatePath |
Public property | TemplatePropertySet |
Public property | ValidationErrors |
Top
See Also

Reference

GenerateTemplateResult Class
CodeSmith.Engine Namespace


GenerateTemplateResult.DefaultFileName Property

GenerateTemplateResultDefaultFileName Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string DefaultFileName { get; set; }
Public Property DefaultFileName As String
    Get
    Set

Property Value

Type: String
See Also

Reference

GenerateTemplateResult Class
CodeSmith.Engine Namespace


GenerateTemplateResult.DefaultFullPath Property

GenerateTemplateResultDefaultFullPath Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string DefaultFullPath { get; }
Public ReadOnly Property DefaultFullPath As String
    Get

Property Value

Type: String
See Also

Reference

GenerateTemplateResult Class
CodeSmith.Engine Namespace


GenerateTemplateResult.Encoding Property

GenerateTemplateResultEncoding Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public Encoding Encoding { get; set; }
Public Property Encoding As Encoding
    Get
    Set

Property Value

Type: Encoding
See Also

Reference

GenerateTemplateResult Class
CodeSmith.Engine Namespace


GenerateTemplateResult.Language Property

GenerateTemplateResultLanguage Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string Language { get; set; }
Public Property Language As String
    Get
    Set

Property Value

Type: String
See Also

Reference

GenerateTemplateResult Class
CodeSmith.Engine Namespace


GenerateTemplateResult.Output Property

GenerateTemplateResultOutput Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string Output { get; set; }
Public Property Output As String
    Get
    Set

Property Value

Type: String
See Also

Reference

GenerateTemplateResult Class
CodeSmith.Engine Namespace


GenerateTemplateResult.OutputType Property

GenerateTemplateResultOutputType Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CodeTemplateOutputType OutputType { get; set; }
Public Property OutputType As CodeTemplateOutputType
    Get
    Set

Property Value

Type: CodeTemplateOutputType
See Also

Reference

GenerateTemplateResult Class
CodeSmith.Engine Namespace


GenerateTemplateResult.Success Property

GenerateTemplateResultSuccess Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual bool Success { get; }
Public Overridable ReadOnly Property Success As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

GenerateTemplateResult Class
CodeSmith.Engine Namespace


GenerateTemplateResult.TemplatePath Property

GenerateTemplateResultTemplatePath Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string TemplatePath { get; set; }
Public Property TemplatePath As String
    Get
    Set

Property Value

Type: String
See Also

Reference

GenerateTemplateResult Class
CodeSmith.Engine Namespace


GenerateTemplateResult.TemplatePropertySet Property

GenerateTemplateResultTemplatePropertySet Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string TemplatePropertySet { get; set; }
Public Property TemplatePropertySet As String
    Get
    Set

Property Value

Type: String
See Also

Reference

GenerateTemplateResult Class
CodeSmith.Engine Namespace


GenerateTemplateResult.ValidationErrors Property

GenerateTemplateResultValidationErrors Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ValidationErrorCollection ValidationErrors { get; set; }
Public Property ValidationErrors As ValidationErrorCollection
    Get
    Set

Property Value

Type: ValidationErrorCollection
See Also

Reference

GenerateTemplateResult Class
CodeSmith.Engine Namespace


GenerateTemplateResult Methods

The GenerateTemplateResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GenerateTemplateResult Class
CodeSmith.Engine Namespace


GeneratorCompleteEventArgs Class

EventArgs derived type which holds the custom event fields
Inheritance Hierarchy
SystemObject
SystemEventArgs
CodeSmith.EngineGeneratorCompleteEventArgs

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
public class GeneratorCompleteEventArgs : EventArgs
<SerializableAttribute>
Public Class GeneratorCompleteEventArgs
    Inherits EventArgs

The GeneratorCompleteEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | GeneratorCompleteEventArgs | Initializes a new instance of the GeneratorCompleteEventArgs class
Public method | GeneratorCompleteEventArgs(Exception) | Initializes a new instance of the GeneratorCompleteEventArgs class.
Public method | GeneratorCompleteEventArgs(Boolean, ICollectionOutputFile) | Initializes a new instance of the GeneratorCompleteEventArgs class.
Public method | GeneratorCompleteEventArgs(Boolean, ICollectionOutputFile, ICollectionString) | Initializes a new instance of the GeneratorCompleteEventArgs class.
Public method | GeneratorCompleteEventArgs(Boolean, ICollectionOutputFile, ICollectionString, String) | Initializes a new instance of the GeneratorCompleteEventArgs class.
Top
Properties
 | Name | Description
Public property | ContextData |
Public property | Error |
Public property | ProjectFile |
Public property | RegisteredOutputs |
Public property | RegisteredReferences |
Public property | Result |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetContextData |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSmith.Engine Namespace


GeneratorCompleteEventArgs Constructor

Overload List
 | Name | Description
Public method | GeneratorCompleteEventArgs | Initializes a new instance of the GeneratorCompleteEventArgs class
Public method | GeneratorCompleteEventArgs(Exception) | Initializes a new instance of the GeneratorCompleteEventArgs class.
Public method | GeneratorCompleteEventArgs(Boolean, ICollectionOutputFile) | Initializes a new instance of the GeneratorCompleteEventArgs class.
Public method | GeneratorCompleteEventArgs(Boolean, ICollectionOutputFile, ICollectionString) | Initializes a new instance of the GeneratorCompleteEventArgs class.
Public method | GeneratorCompleteEventArgs(Boolean, ICollectionOutputFile, ICollectionString, String) | Initializes a new instance of the GeneratorCompleteEventArgs class.
Top
See Also

Reference

GeneratorCompleteEventArgs Class
CodeSmith.Engine Namespace


GeneratorCompleteEventArgs Constructor

Initializes a new instance of the GeneratorCompleteEventArgs class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public GeneratorCompleteEventArgs()
Public Sub New
See Also

Reference

GeneratorCompleteEventArgs Class
GeneratorCompleteEventArgs Overload
CodeSmith.Engine Namespace


GeneratorCompleteEventArgs Constructor (Exception)

Initializes a new instance of the GeneratorCompleteEventArgs class.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public GeneratorCompleteEventArgs(
    Exception error
)
Public Sub New (
    error As Exception
)

Parameters

error
Type: SystemException
The error.
See Also

Reference

GeneratorCompleteEventArgs Class
GeneratorCompleteEventArgs Overload
CodeSmith.Engine Namespace


GeneratorCompleteEventArgs Constructor (Boolean, ICollection(OutputFile))

GeneratorCompleteEventArgs Constructor (Boolean, ICollectionOutputFile)

Initializes a new instance of the GeneratorCompleteEventArgs class.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public GeneratorCompleteEventArgs(
    bool result,
    ICollection<OutputFile> registeredOutputs
)
Public Sub New (
    result As Boolean,
    registeredOutputs As ICollection(Of OutputFile)
)

Parameters

result
Type: SystemBoolean
if set to true generation was successful.
registeredOutputs
Type: System.Collections.GenericICollection OutputFile
The registered outputs.
See Also

Reference

GeneratorCompleteEventArgs Class
GeneratorCompleteEventArgs Overload
CodeSmith.Engine Namespace


GeneratorCompleteEventArgs Constructor (Boolean, ICollection(OutputFile), ICollection(String))

GeneratorCompleteEventArgs Constructor (Boolean, ICollectionOutputFile, ICollectionString)

Initializes a new instance of the GeneratorCompleteEventArgs class.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public GeneratorCompleteEventArgs(
    bool result,
    ICollection<OutputFile> registeredOutputs,
    ICollection<string> registeredReferences
)
Public Sub New (
    result As Boolean,
    registeredOutputs As ICollection(Of OutputFile),
    registeredReferences As ICollection(Of String)
)

Parameters

result
Type: SystemBoolean
if set to true [result].
registeredOutputs
Type: System.Collections.GenericICollection OutputFile
The registered outputs.
registeredReferences
Type: System.Collections.GenericICollection String
The registered references.
See Also

Reference

GeneratorCompleteEventArgs Class
GeneratorCompleteEventArgs Overload
CodeSmith.Engine Namespace


GeneratorCompleteEventArgs Constructor (Boolean, ICollection(OutputFile), ICollection(String), String)

GeneratorCompleteEventArgs Constructor (Boolean, ICollectionOutputFile, ICollectionString, String)

Initializes a new instance of the GeneratorCompleteEventArgs class.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public GeneratorCompleteEventArgs(
    bool result,
    ICollection<OutputFile> registeredOutputs,
    ICollection<string> registeredReferences,
    string cspFileName
)
Public Sub New (
    result As Boolean,
    registeredOutputs As ICollection(Of OutputFile),
    registeredReferences As ICollection(Of String),
    cspFileName As String
)

Parameters

result
Type: SystemBoolean
if set to true [result].
registeredOutputs
Type: System.Collections.GenericICollection OutputFile
The registered outputs.
registeredReferences
Type: System.Collections.GenericICollection String
The registered references.
cspFileName
Type: SystemString
The file path of the CodeSmith project file.
See Also

Reference

GeneratorCompleteEventArgs Class
GeneratorCompleteEventArgs Overload
CodeSmith.Engine Namespace


GeneratorCompleteEventArgs Properties

The GeneratorCompleteEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | ContextData |
Public property | Error |
Public property | ProjectFile |
Public property | RegisteredOutputs |
Public property | RegisteredReferences |
Public property | Result |
Top
See Also

Reference

GeneratorCompleteEventArgs Class
CodeSmith.Engine Namespace


GeneratorCompleteEventArgs.ContextData Property

GeneratorCompleteEventArgsContextData Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ICollection<ContextItem> ContextData { get; }
Public ReadOnly Property ContextData As ICollection(Of ContextItem)
    Get

Property Value

Type: ICollection ContextItem
See Also

Reference

GeneratorCompleteEventArgs Class
CodeSmith.Engine Namespace


GeneratorCompleteEventArgs.Error Property

GeneratorCompleteEventArgsError Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public Exception Error { get; set; }
Public Property Error As Exception
    Get
    Set

Property Value

Type: Exception
See Also

Reference

GeneratorCompleteEventArgs Class
CodeSmith.Engine Namespace


GeneratorCompleteEventArgs.ProjectFile Property

GeneratorCompleteEventArgsProjectFile Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string ProjectFile { get; set; }
Public Property ProjectFile As String
    Get
    Set

Property Value

Type: String
See Also

Reference

GeneratorCompleteEventArgs Class
CodeSmith.Engine Namespace


GeneratorCompleteEventArgs.RegisteredOutputs Property

GeneratorCompleteEventArgsRegisteredOutputs Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ICollection<OutputFile> RegisteredOutputs { get; }
Public ReadOnly Property RegisteredOutputs As ICollection(Of OutputFile)
    Get

Property Value

Type: ICollection OutputFile
See Also

Reference

GeneratorCompleteEventArgs Class
CodeSmith.Engine Namespace


GeneratorCompleteEventArgs.RegisteredReferences Property

GeneratorCompleteEventArgsRegisteredReferences Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ICollection<string> RegisteredReferences { get; }
Public ReadOnly Property RegisteredReferences As ICollection(Of String)
    Get

Property Value

Type: ICollection String
See Also

Reference

GeneratorCompleteEventArgs Class
CodeSmith.Engine Namespace


GeneratorCompleteEventArgs.Result Property

GeneratorCompleteEventArgsResult Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool Result { get; set; }
Public Property Result As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

GeneratorCompleteEventArgs Class
CodeSmith.Engine Namespace


GeneratorCompleteEventArgs Methods

The GeneratorCompleteEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetContextData |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GeneratorCompleteEventArgs Class
CodeSmith.Engine Namespace


GeneratorCompleteEventArgs.SetContextData Method

GeneratorCompleteEventArgsSetContextData Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void SetContextData(
    NameValueCollection contextData
)
Public Sub SetContextData (
    contextData As NameValueCollection
)

Parameters

contextData
Type: System.Collections.SpecializedNameValueCollection
See Also

Reference

GeneratorCompleteEventArgs Class
CodeSmith.Engine Namespace


GeneratorCompleteEventHandler Delegate

This represents the delegate method prototype that event receivers must implement

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public delegate void GeneratorCompleteEventHandler(
    Object sender,
    GeneratorCompleteEventArgs e
)
Public Delegate Sub GeneratorCompleteEventHandler (
    sender As Object,
    e As GeneratorCompleteEventArgs
)

Parameters

sender
Type: SystemObject
e
Type: CodeSmith.EngineGeneratorCompleteEventArgs
See Also

Reference

CodeSmith.Engine Namespace


GeneratorErrorEventArgs Class

EventArgs derived type which holds the custom event fields
Inheritance Hierarchy
SystemObject
SystemEventArgs
CodeSmith.EngineGeneratorErrorEventArgs

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
public class GeneratorErrorEventArgs : EventArgs
<SerializableAttribute>
Public Class GeneratorErrorEventArgs
    Inherits EventArgs

The GeneratorErrorEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | GeneratorErrorEventArgs | Initializes a new instance of the GeneratorErrorEventArgs class
Public method | GeneratorErrorEventArgs(String, Boolean, Int32, String, Int32, Int32) | Use this constructor to initialize the event arguments object with the custom event fields
Top
Properties
 | Name | Description
Public property | Column |
Public property | File |
Public property | Level |
Public property | Line |
Public property | Message |
Public property | Warning |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides ObjectToString.)
Top
See Also

Reference

CodeSmith.Engine Namespace


GeneratorErrorEventArgs Constructor

Overload List
 | Name | Description
Public method | GeneratorErrorEventArgs | Initializes a new instance of the GeneratorErrorEventArgs class
Public method | GeneratorErrorEventArgs(String, Boolean, Int32, String, Int32, Int32) | Use this constructor to initialize the event arguments object with the custom event fields
Top
See Also

Reference

GeneratorErrorEventArgs Class
CodeSmith.Engine Namespace


GeneratorErrorEventArgs Constructor

Initializes a new instance of the GeneratorErrorEventArgs class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public GeneratorErrorEventArgs()
Public Sub New
See Also

Reference

GeneratorErrorEventArgs Class
GeneratorErrorEventArgs Overload
CodeSmith.Engine Namespace


GeneratorErrorEventArgs Constructor (String, Boolean, Int32, String, Int32, Int32)

Use this constructor to initialize the event arguments object with the custom event fields

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public GeneratorErrorEventArgs(
    string file,
    bool warning,
    int level,
    string message,
    int line,
    int column
)
Public Sub New (
    file As String,
    warning As Boolean,
    level As Integer,
    message As String,
    line As Integer,
    column As Integer
)

Parameters

file
Type: SystemString
warning
Type: SystemBoolean
level
Type: SystemInt32
message
Type: SystemString
line
Type: SystemInt32
column
Type: SystemInt32
See Also

Reference

GeneratorErrorEventArgs Class
GeneratorErrorEventArgs Overload
CodeSmith.Engine Namespace


GeneratorErrorEventArgs Properties

The GeneratorErrorEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Column |
Public property | File |
Public property | Level |
Public property | Line |
Public property | Message |
Public property | Warning |
Top
See Also

Reference

GeneratorErrorEventArgs Class
CodeSmith.Engine Namespace


GeneratorErrorEventArgs.Column Property

GeneratorErrorEventArgsColumn Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public int Column { get; set; }
Public Property Column As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

GeneratorErrorEventArgs Class
CodeSmith.Engine Namespace


GeneratorErrorEventArgs.File Property

GeneratorErrorEventArgsFile Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string File { get; set; }
Public Property File As String
    Get
    Set

Property Value

Type: String
See Also

Reference

GeneratorErrorEventArgs Class
CodeSmith.Engine Namespace


GeneratorErrorEventArgs.Level Property

GeneratorErrorEventArgsLevel Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public int Level { get; set; }
Public Property Level As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

GeneratorErrorEventArgs Class
CodeSmith.Engine Namespace


GeneratorErrorEventArgs.Line Property

GeneratorErrorEventArgsLine Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public int Line { get; set; }
Public Property Line As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

GeneratorErrorEventArgs Class
CodeSmith.Engine Namespace


GeneratorErrorEventArgs.Message Property

GeneratorErrorEventArgsMessage Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string Message { get; set; }
Public Property Message As String
    Get
    Set

Property Value

Type: String
See Also

Reference

GeneratorErrorEventArgs Class
CodeSmith.Engine Namespace


GeneratorErrorEventArgs.Warning Property

GeneratorErrorEventArgsWarning Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool Warning { get; set; }
Public Property Warning As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

GeneratorErrorEventArgs Class
CodeSmith.Engine Namespace


GeneratorErrorEventArgs Methods

The GeneratorErrorEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides ObjectToString.)
Top
See Also

Reference

GeneratorErrorEventArgs Class
CodeSmith.Engine Namespace


GeneratorErrorEventArgs.ToString Method

GeneratorErrorEventArgsToString Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
See Also

Reference

GeneratorErrorEventArgs Class
CodeSmith.Engine Namespace


GeneratorErrorEventHandler Delegate

This represents the delegate method prototype that event receivers must implement

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public delegate void GeneratorErrorEventHandler(
    Object sender,
    GeneratorErrorEventArgs e
)
Public Delegate Sub GeneratorErrorEventHandler (
    sender As Object,
    e As GeneratorErrorEventArgs
)

Parameters

sender
Type: SystemObject
e
Type: CodeSmith.EngineGeneratorErrorEventArgs
See Also

Reference

CodeSmith.Engine Namespace


GeneratorEventsCallbackBase Class

Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
CodeSmith.EngineGeneratorEventsCallbackBase

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public abstract class GeneratorEventsCallbackBase : MarshalByRefObject
Public MustInherit Class GeneratorEventsCallbackBase
    Inherits MarshalByRefObject

The GeneratorEventsCallbackBase type exposes the following members.

Constructors
 | Name | Description
Protected method | GeneratorEventsCallbackBase | Initializes a new instance of the GeneratorEventsCallbackBase class
Top
Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateCompleteCallback |
Public method | GeneratorErrorCallback |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InternalGenerateCompleteCallback |
Protected method | InternalGeneratorErrorCallback |
Protected method | InternalOutputStringCallback |
Protected method | InternalPreOutputWrittenCallback |
Protected method | InternalProgressCallback |
Protected method | InternalStatusChangedCallback |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | OutputStringCallback |
Public method | PreOutputWrittenCallback |
Public method | ProgressCallback |
Public method | StatusChangedCallback |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSmith.Engine Namespace


GeneratorEventsCallbackBase Constructor

Initializes a new instance of the GeneratorEventsCallbackBase class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected GeneratorEventsCallbackBase()
Protected Sub New
See Also

Reference

GeneratorEventsCallbackBase Class
CodeSmith.Engine Namespace


GeneratorEventsCallbackBase Methods

The GeneratorEventsCallbackBase type exposes the following members.

Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateCompleteCallback |
Public method | GeneratorErrorCallback |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InternalGenerateCompleteCallback |
Protected method | InternalGeneratorErrorCallback |
Protected method | InternalOutputStringCallback |
Protected method | InternalPreOutputWrittenCallback |
Protected method | InternalProgressCallback |
Protected method | InternalStatusChangedCallback |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | OutputStringCallback |
Public method | PreOutputWrittenCallback |
Public method | ProgressCallback |
Public method | StatusChangedCallback |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GeneratorEventsCallbackBase Class
CodeSmith.Engine Namespace


GeneratorEventsCallbackBase.GenerateCompleteCallback Method

GeneratorEventsCallbackBaseGenerateCompleteCallback Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void GenerateCompleteCallback(
    Object sender,
    GeneratorCompleteEventArgs e
)
Public Sub GenerateCompleteCallback (
    sender As Object,
    e As GeneratorCompleteEventArgs
)

Parameters

sender
Type: SystemObject
e
Type: CodeSmith.EngineGeneratorCompleteEventArgs
See Also

Reference

GeneratorEventsCallbackBase Class
CodeSmith.Engine Namespace


GeneratorEventsCallbackBase.GeneratorErrorCallback Method

GeneratorEventsCallbackBaseGeneratorErrorCallback Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void GeneratorErrorCallback(
    Object sender,
    GeneratorErrorEventArgs e
)
Public Sub GeneratorErrorCallback (
    sender As Object,
    e As GeneratorErrorEventArgs
)

Parameters

sender
Type: SystemObject
e
Type: CodeSmith.EngineGeneratorErrorEventArgs
See Also

Reference

GeneratorEventsCallbackBase Class
CodeSmith.Engine Namespace


GeneratorEventsCallbackBase.InternalGenerateCompleteCallback Method

GeneratorEventsCallbackBaseInternalGenerateCompleteCallback Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual void InternalGenerateCompleteCallback(
    Object sender,
    GeneratorCompleteEventArgs e
)
Protected Overridable Sub InternalGenerateCompleteCallback (
    sender As Object,
    e As GeneratorCompleteEventArgs
)

Parameters

sender
Type: SystemObject
e
Type: CodeSmith.EngineGeneratorCompleteEventArgs
See Also

Reference

GeneratorEventsCallbackBase Class
CodeSmith.Engine Namespace


GeneratorEventsCallbackBase.InternalGeneratorErrorCallback Method

GeneratorEventsCallbackBaseInternalGeneratorErrorCallback Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected abstract void InternalGeneratorErrorCallback(
    Object sender,
    GeneratorErrorEventArgs e
)
Protected MustOverride Sub InternalGeneratorErrorCallback (
    sender As Object,
    e As GeneratorErrorEventArgs
)

Parameters

sender
Type: SystemObject
e
Type: CodeSmith.EngineGeneratorErrorEventArgs
See Also

Reference

GeneratorEventsCallbackBase Class
CodeSmith.Engine Namespace


GeneratorEventsCallbackBase.InternalOutputStringCallback Method

GeneratorEventsCallbackBaseInternalOutputStringCallback Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected abstract void InternalOutputStringCallback(
    Object sender,
    MessageEventArgs e
)
Protected MustOverride Sub InternalOutputStringCallback (
    sender As Object,
    e As MessageEventArgs
)

Parameters

sender
Type: SystemObject
e
Type: CodeSmith.EngineMessageEventArgs
See Also

Reference

GeneratorEventsCallbackBase Class
CodeSmith.Engine Namespace


GeneratorEventsCallbackBase.InternalPreOutputWrittenCallback Method

GeneratorEventsCallbackBaseInternalPreOutputWrittenCallback Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected abstract void InternalPreOutputWrittenCallback(
    Object sender,
    OutputCancelEventArgs e
)
Protected MustOverride Sub InternalPreOutputWrittenCallback (
    sender As Object,
    e As OutputCancelEventArgs
)

Parameters

sender
Type: SystemObject
e
Type: CodeSmith.EngineOutputCancelEventArgs
See Also

Reference

GeneratorEventsCallbackBase Class
CodeSmith.Engine Namespace


GeneratorEventsCallbackBase.InternalProgressCallback Method

GeneratorEventsCallbackBaseInternalProgressCallback Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected abstract void InternalProgressCallback(
    Object sender,
    GeneratorProgressEventArgs e
)
Protected MustOverride Sub InternalProgressCallback (
    sender As Object,
    e As GeneratorProgressEventArgs
)

Parameters

sender
Type: SystemObject
e
Type: CodeSmith.EngineGeneratorProgressEventArgs
See Also

Reference

GeneratorEventsCallbackBase Class
CodeSmith.Engine Namespace


GeneratorEventsCallbackBase.InternalStatusChangedCallback Method

GeneratorEventsCallbackBaseInternalStatusChangedCallback Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected abstract void InternalStatusChangedCallback(
    Object sender,
    MessageEventArgs e
)
Protected MustOverride Sub InternalStatusChangedCallback (
    sender As Object,
    e As MessageEventArgs
)

Parameters

sender
Type: SystemObject
e
Type: CodeSmith.EngineMessageEventArgs
See Also

Reference

GeneratorEventsCallbackBase Class
CodeSmith.Engine Namespace


GeneratorEventsCallbackBase.OutputStringCallback Method

GeneratorEventsCallbackBaseOutputStringCallback Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void OutputStringCallback(
    Object sender,
    MessageEventArgs e
)
Public Sub OutputStringCallback (
    sender As Object,
    e As MessageEventArgs
)

Parameters

sender
Type: SystemObject
e
Type: CodeSmith.EngineMessageEventArgs
See Also

Reference

GeneratorEventsCallbackBase Class
CodeSmith.Engine Namespace


GeneratorEventsCallbackBase.PreOutputWrittenCallback Method

GeneratorEventsCallbackBasePreOutputWrittenCallback Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void PreOutputWrittenCallback(
    Object sender,
    OutputCancelEventArgs e
)
Public Sub PreOutputWrittenCallback (
    sender As Object,
    e As OutputCancelEventArgs
)

Parameters

sender
Type: SystemObject
e
Type: CodeSmith.EngineOutputCancelEventArgs
See Also

Reference

GeneratorEventsCallbackBase Class
CodeSmith.Engine Namespace


GeneratorEventsCallbackBase.ProgressCallback Method

GeneratorEventsCallbackBaseProgressCallback Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void ProgressCallback(
    Object sender,
    GeneratorProgressEventArgs e
)
Public Sub ProgressCallback (
    sender As Object,
    e As GeneratorProgressEventArgs
)

Parameters

sender
Type: SystemObject
e
Type: CodeSmith.EngineGeneratorProgressEventArgs
See Also

Reference

GeneratorEventsCallbackBase Class
CodeSmith.Engine Namespace


GeneratorEventsCallbackBase.StatusChangedCallback Method

GeneratorEventsCallbackBaseStatusChangedCallback Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void StatusChangedCallback(
    Object sender,
    MessageEventArgs e
)
Public Sub StatusChangedCallback (
    sender As Object,
    e As MessageEventArgs
)

Parameters

sender
Type: SystemObject
e
Type: CodeSmith.EngineMessageEventArgs
See Also

Reference

GeneratorEventsCallbackBase Class
CodeSmith.Engine Namespace


GeneratorProgressEventArgs Class

EventArgs derived type which holds the custom event fields
Inheritance Hierarchy
SystemObject
SystemEventArgs
CodeSmith.EngineGeneratorProgressEventArgs

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
public class GeneratorProgressEventArgs : EventArgs
<SerializableAttribute>
Public Class GeneratorProgressEventArgs
    Inherits EventArgs

The GeneratorProgressEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | GeneratorProgressEventArgs(Int32) | Initializes a new instance of the GeneratorProgressEventArgs class
Public method | GeneratorProgressEventArgs(Int32, Int32) | Initializes a new instance of the GeneratorProgressEventArgs class
Top
Properties
 | Name | Description
Public property | Complete |
Public property | Total |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSmith.Engine Namespace


GeneratorProgressEventArgs Constructor

Overload List
 | Name | Description
Public method | GeneratorProgressEventArgs(Int32) | Initializes a new instance of the GeneratorProgressEventArgs class
Public method | GeneratorProgressEventArgs(Int32, Int32) | Initializes a new instance of the GeneratorProgressEventArgs class
Top
See Also

Reference

GeneratorProgressEventArgs Class
CodeSmith.Engine Namespace


GeneratorProgressEventArgs Constructor (Int32)

Initializes a new instance of the GeneratorProgressEventArgs class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public GeneratorProgressEventArgs(
    int progressPercentage
)
Public Sub New (
    progressPercentage As Integer
)

Parameters

progressPercentage
Type: SystemInt32
See Also

Reference

GeneratorProgressEventArgs Class
GeneratorProgressEventArgs Overload
CodeSmith.Engine Namespace


GeneratorProgressEventArgs Constructor (Int32, Int32)

Initializes a new instance of the GeneratorProgressEventArgs class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public GeneratorProgressEventArgs(
    int progressPercentage,
    int total
)
Public Sub New (
    progressPercentage As Integer,
    total As Integer
)

Parameters

progressPercentage
Type: SystemInt32
total
Type: SystemInt32
See Also

Reference

GeneratorProgressEventArgs Class
GeneratorProgressEventArgs Overload
CodeSmith.Engine Namespace


GeneratorProgressEventArgs Properties

The GeneratorProgressEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Complete |
Public property | Total |
Top
See Also

Reference

GeneratorProgressEventArgs Class
CodeSmith.Engine Namespace


GeneratorProgressEventArgs.Complete Property

GeneratorProgressEventArgsComplete Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public int Complete { get; set; }
Public Property Complete As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

GeneratorProgressEventArgs Class
CodeSmith.Engine Namespace


GeneratorProgressEventArgs.Total Property

GeneratorProgressEventArgsTotal Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public int Total { get; set; }
Public Property Total As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

GeneratorProgressEventArgs Class
CodeSmith.Engine Namespace


GeneratorProgressEventArgs Methods

The GeneratorProgressEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

GeneratorProgressEventArgs Class
CodeSmith.Engine Namespace


GeneratorProgressEventHandler Delegate

This represents the delegate method prototype that event receivers must implement

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public delegate void GeneratorProgressEventHandler(
    Object sender,
    GeneratorProgressEventArgs e
)
Public Delegate Sub GeneratorProgressEventHandler (
    sender As Object,
    e As GeneratorProgressEventArgs
)

Parameters

sender
Type: SystemObject
e
Type: CodeSmith.EngineGeneratorProgressEventArgs
See Also

Reference

CodeSmith.Engine Namespace


HashCodeCombiner Class

Inheritance Hierarchy
SystemObject
CodeSmith.EngineHashCodeCombiner

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class HashCodeCombiner
Public Class HashCodeCombiner

The HashCodeCombiner type exposes the following members.

Constructors
 | Name | Description
Public method | HashCodeCombiner | Initializes a new instance of the HashCodeCombiner class
Top
Properties
 | Name | Description
Public property | CombinedHash |
Public property | CombinedHash32 |
Public property | CombinedHashString |
Top
Methods
 | Name | Description
Public method | Add(DateTime) |
Public method | Add(Int32) |
Public method | Add(Int64) |
Public method | Add(Object) |
Public method | Add(String) |
Public method | AddCaseInsensitiveString |
Public method | AddDirectory |
Public method | AddFile |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSmith.Engine Namespace


HashCodeCombiner Constructor

Initializes a new instance of the HashCodeCombiner class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public HashCodeCombiner()
Public Sub New
See Also

Reference

HashCodeCombiner Class
CodeSmith.Engine Namespace


HashCodeCombiner Properties

The HashCodeCombiner type exposes the following members.

Properties
 | Name | Description
Public property | CombinedHash |
Public property | CombinedHash32 |
Public property | CombinedHashString |
Top
See Also

Reference

HashCodeCombiner Class
CodeSmith.Engine Namespace


HashCodeCombiner.CombinedHash Property

HashCodeCombinerCombinedHash Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public long CombinedHash { get; }
Public ReadOnly Property CombinedHash As Long
    Get

Property Value

Type: Int64
See Also

Reference

HashCodeCombiner Class
CodeSmith.Engine Namespace


HashCodeCombiner.CombinedHash32 Property

HashCodeCombinerCombinedHash32 Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public int CombinedHash32 { get; }
Public ReadOnly Property CombinedHash32 As Integer
    Get

Property Value

Type: Int32
See Also

Reference

HashCodeCombiner Class
CodeSmith.Engine Namespace


HashCodeCombiner.CombinedHashString Property

HashCodeCombinerCombinedHashString Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string CombinedHashString { get; }
Public ReadOnly Property CombinedHashString As String
    Get

Property Value

Type: String
See Also

Reference

HashCodeCombiner Class
CodeSmith.Engine Namespace


HashCodeCombiner Methods

The HashCodeCombiner type exposes the following members.

Methods
 | Name | Description
Public method | Add(DateTime) |
Public method | Add(Int32) |
Public method | Add(Int64) |
Public method | Add(Object) |
Public method | Add(String) |
Public method | AddCaseInsensitiveString |
Public method | AddDirectory |
Public method | AddFile |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

HashCodeCombiner Class
CodeSmith.Engine Namespace


HashCodeCombiner.Add Method

HashCodeCombinerAdd Method

Overload List
 | Name | Description
Public method | Add(DateTime) |
Public method | Add(Int32) |
Public method | Add(Int64) |
Public method | Add(Object) |
Public method | Add(String) |
Top
See Also

Reference

HashCodeCombiner Class
CodeSmith.Engine Namespace


HashCodeCombiner.Add Method (DateTime)

HashCodeCombinerAdd Method (DateTime)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void Add(
    DateTime dt
)
Public Sub Add (
    dt As DateTime
)

Parameters

dt
Type: SystemDateTime
See Also

Reference

HashCodeCombiner Class
Add Overload
CodeSmith.Engine Namespace


HashCodeCombiner.Add Method (Int32)

HashCodeCombinerAdd Method (Int32)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void Add(
    int n
)
Public Sub Add (
    n As Integer
)

Parameters

n
Type: SystemInt32
See Also

Reference

HashCodeCombiner Class
Add Overload
CodeSmith.Engine Namespace


HashCodeCombiner.Add Method (Int64)

HashCodeCombinerAdd Method (Int64)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void Add(
    long n
)
Public Sub Add (
    n As Long
)

Parameters

n
Type: SystemInt64
See Also

Reference

HashCodeCombiner Class
Add Overload
CodeSmith.Engine Namespace


HashCodeCombiner.Add Method (Object)

HashCodeCombinerAdd Method (Object)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void Add(
    Object o
)
Public Sub Add (
    o As Object
)

Parameters

o
Type: SystemObject
See Also

Reference

HashCodeCombiner Class
Add Overload
CodeSmith.Engine Namespace


HashCodeCombiner.Add Method (String)

HashCodeCombinerAdd Method (String)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void Add(
    string s
)
Public Sub Add (
    s As String
)

Parameters

s
Type: SystemString
See Also

Reference

HashCodeCombiner Class
Add Overload
CodeSmith.Engine Namespace


HashCodeCombiner.AddCaseInsensitiveString Method

HashCodeCombinerAddCaseInsensitiveString Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void AddCaseInsensitiveString(
    string s
)
Public Sub AddCaseInsensitiveString (
    s As String
)

Parameters

s
Type: SystemString
See Also

Reference

HashCodeCombiner Class
CodeSmith.Engine Namespace


HashCodeCombiner.AddDirectory Method

HashCodeCombinerAddDirectory Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void AddDirectory(
    string directoryName
)
Public Sub AddDirectory (
    directoryName As String
)

Parameters

directoryName
Type: SystemString
See Also

Reference

HashCodeCombiner Class
CodeSmith.Engine Namespace


HashCodeCombiner.AddFile Method

HashCodeCombinerAddFile Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void AddFile(
    string fileName
)
Public Sub AddFile (
    fileName As String
)

Parameters

fileName
Type: SystemString
See Also

Reference

HashCodeCombiner Class
CodeSmith.Engine Namespace


ICodeTemplateInfo Interface

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public interface ICodeTemplateInfo
Public Interface ICodeTemplateInfo

The ICodeTemplateInfo type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyDependencies |
Public property | CodeBehind |
Public property | CodeSmithVersion |
Public property | DateCreated |
Public property | DateModified |
Public property | Description |
Public property | DirectoryName |
Public property | FileDependencies |
Public property | FileName |
Public property | FullPath |
Public property | Language |
Public property | OutputType |
Public property | TargetLanguage |
Public property | TemplateEncoding |
Top
Methods
 | Name | Description
Public method | GetContent |
Public method | Refresh |
Top
See Also

Reference

CodeSmith.Engine Namespace


ICodeTemplateInfo Properties

The ICodeTemplateInfo type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyDependencies |
Public property | CodeBehind |
Public property | CodeSmithVersion |
Public property | DateCreated |
Public property | DateModified |
Public property | Description |
Public property | DirectoryName |
Public property | FileDependencies |
Public property | FileName |
Public property | FullPath |
Public property | Language |
Public property | OutputType |
Public property | TargetLanguage |
Public property | TemplateEncoding |
Top
See Also

Reference

ICodeTemplateInfo Interface
CodeSmith.Engine Namespace


ICodeTemplateInfo.AssemblyDependencies Property

ICodeTemplateInfoAssemblyDependencies Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
string[] AssemblyDependencies { get; }
ReadOnly Property AssemblyDependencies As String()
    Get

Property Value

Type: String
See Also

Reference

ICodeTemplateInfo Interface
CodeSmith.Engine Namespace


ICodeTemplateInfo.CodeBehind Property

ICodeTemplateInfoCodeBehind Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
string CodeBehind { get; }
ReadOnly Property CodeBehind As String
    Get

Property Value

Type: String
See Also

Reference

ICodeTemplateInfo Interface
CodeSmith.Engine Namespace


ICodeTemplateInfo.CodeSmithVersion Property

ICodeTemplateInfoCodeSmithVersion Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
string CodeSmithVersion { get; }
ReadOnly Property CodeSmithVersion As String
    Get

Property Value

Type: String
See Also

Reference

ICodeTemplateInfo Interface
CodeSmith.Engine Namespace


ICodeTemplateInfo.DateCreated Property

ICodeTemplateInfoDateCreated Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
DateTime DateCreated { get; }
ReadOnly Property DateCreated As DateTime
    Get

Property Value

Type: DateTime
See Also

Reference

ICodeTemplateInfo Interface
CodeSmith.Engine Namespace


ICodeTemplateInfo.DateModified Property

ICodeTemplateInfoDateModified Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
DateTime DateModified { get; }
ReadOnly Property DateModified As DateTime
    Get

Property Value

Type: DateTime
See Also

Reference

ICodeTemplateInfo Interface
CodeSmith.Engine Namespace


ICodeTemplateInfo.Description Property

ICodeTemplateInfoDescription Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
string Description { get; }
ReadOnly Property Description As String
    Get

Property Value

Type: String
See Also

Reference

ICodeTemplateInfo Interface
CodeSmith.Engine Namespace


ICodeTemplateInfo.DirectoryName Property

ICodeTemplateInfoDirectoryName Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
string DirectoryName { get; }
ReadOnly Property DirectoryName As String
    Get

Property Value

Type: String
See Also

Reference

ICodeTemplateInfo Interface
CodeSmith.Engine Namespace


ICodeTemplateInfo.FileDependencies Property

ICodeTemplateInfoFileDependencies Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
string[] FileDependencies { get; }
ReadOnly Property FileDependencies As String()
    Get

Property Value

Type: String
See Also

Reference

ICodeTemplateInfo Interface
CodeSmith.Engine Namespace


ICodeTemplateInfo.FileName Property

ICodeTemplateInfoFileName Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
string FileName { get; }
ReadOnly Property FileName As String
    Get

Property Value

Type: String
See Also

Reference

ICodeTemplateInfo Interface
CodeSmith.Engine Namespace


ICodeTemplateInfo.FullPath Property

ICodeTemplateInfoFullPath Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
string FullPath { get; }
ReadOnly Property FullPath As String
    Get

Property Value

Type: String
See Also

Reference

ICodeTemplateInfo Interface
CodeSmith.Engine Namespace


ICodeTemplateInfo.Language Property

ICodeTemplateInfoLanguage Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
string Language { get; }
ReadOnly Property Language As String
    Get

Property Value

Type: String
See Also

Reference

ICodeTemplateInfo Interface
CodeSmith.Engine Namespace


ICodeTemplateInfo.OutputType Property

ICodeTemplateInfoOutputType Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
CodeTemplateOutputType OutputType { get; }
ReadOnly Property OutputType As CodeTemplateOutputType
    Get

Property Value

Type: CodeTemplateOutputType
See Also

Reference

ICodeTemplateInfo Interface
CodeSmith.Engine Namespace


ICodeTemplateInfo.TargetLanguage Property

ICodeTemplateInfoTargetLanguage Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
string TargetLanguage { get; }
ReadOnly Property TargetLanguage As String
    Get

Property Value

Type: String
See Also

Reference

ICodeTemplateInfo Interface
CodeSmith.Engine Namespace


ICodeTemplateInfo.TemplateEncoding Property

ICodeTemplateInfoTemplateEncoding Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
string TemplateEncoding { get; }
ReadOnly Property TemplateEncoding As String
    Get

Property Value

Type: String
See Also

Reference

ICodeTemplateInfo Interface
CodeSmith.Engine Namespace


ICodeTemplateInfo Methods

The ICodeTemplateInfo type exposes the following members.

Methods
 | Name | Description
Public method | GetContent |
Public method | Refresh |
Top
See Also

Reference

ICodeTemplateInfo Interface
CodeSmith.Engine Namespace


ICodeTemplateInfo.GetContent Method

ICodeTemplateInfoGetContent Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
string GetContent()
Function GetContent As String

Return Value

Type: String
See Also

Reference

ICodeTemplateInfo Interface
CodeSmith.Engine Namespace


ICodeTemplateInfo.Refresh Method

ICodeTemplateInfoRefresh Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
void Refresh()
Sub Refresh
See Also

Reference

ICodeTemplateInfo Interface
CodeSmith.Engine Namespace


IConfiguration Interface

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public interface IConfiguration
Public Interface IConfiguration

The IConfiguration type exposes the following members.

Properties
 | Name | Description
Public property | CanWatchFile | Gets a value indicating whether this instance can watch file.
Public property | ConfigurationFile | Gets the configuration file.
Public property | ConfigurationVersion | Gets or sets the configuration version.
Public property | IsBackwardCompatible | Gets a value indicating whether this configuration is backward compatible.
Top
Methods
 | Name | Description
Public method | LoadDefaultSettings | Loads the default settings.
Public method | UpgradeFile | Upgrades the file.
Public method | UpgradeSettings | Upgrades the settings.
Top
See Also

Reference

CodeSmith.Engine Namespace


IConfiguration Properties

The IConfiguration type exposes the following members.

Properties
 | Name | Description
Public property | CanWatchFile | Gets a value indicating whether this instance can watch file.
Public property | ConfigurationFile | Gets the configuration file.
Public property | ConfigurationVersion | Gets or sets the configuration version.
Public property | IsBackwardCompatible | Gets a value indicating whether this configuration is backward compatible.
Top
See Also

Reference

IConfiguration Interface
CodeSmith.Engine Namespace


IConfiguration.CanWatchFile Property

IConfigurationCanWatchFile Property

Gets a value indicating whether this instance can watch file.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
bool CanWatchFile { get; }
ReadOnly Property CanWatchFile As Boolean
    Get

Property Value

Type: Boolean
true if this instance can watch file; otherwise, false.
See Also

Reference

IConfiguration Interface
CodeSmith.Engine Namespace


IConfiguration.ConfigurationFile Property

IConfigurationConfigurationFile Property

Gets the configuration file.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
FileInfo ConfigurationFile { get; }
ReadOnly Property ConfigurationFile As FileInfo
    Get

Property Value

Type: FileInfo
The configuration file.
See Also

Reference

IConfiguration Interface
CodeSmith.Engine Namespace


IConfiguration.ConfigurationVersion Property

IConfigurationConfigurationVersion Property

Gets or sets the configuration version.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
string ConfigurationVersion { get; set; }
Property ConfigurationVersion As String
    Get
    Set

Property Value

Type: String
The configuration version.
See Also

Reference

IConfiguration Interface
CodeSmith.Engine Namespace


IConfiguration.IsBackwardCompatible Property

IConfigurationIsBackwardCompatible Property

Gets a value indicating whether this configuration is backward compatible.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
bool IsBackwardCompatible { get; }
ReadOnly Property IsBackwardCompatible As Boolean
    Get

Property Value

Type: Boolean
true if this configuration is backward compatible; otherwise, false.
See Also

Reference

IConfiguration Interface
CodeSmith.Engine Namespace


IConfiguration Methods

The IConfiguration type exposes the following members.

Methods
 | Name | Description
Public method | LoadDefaultSettings | Loads the default settings.
Public method | UpgradeFile | Upgrades the file.
Public method | UpgradeSettings | Upgrades the settings.
Top
See Also

Reference

IConfiguration Interface
CodeSmith.Engine Namespace


IConfiguration.LoadDefaultSettings Method

IConfigurationLoadDefaultSettings Method

Loads the default settings.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
void LoadDefaultSettings()
Sub LoadDefaultSettings
Remarks
This method is called when existing config file is not found. Use this method to populate the configuration class with default values.
See Also

Reference

IConfiguration Interface
CodeSmith.Engine Namespace


IConfiguration.UpgradeFile Method

IConfigurationUpgradeFile Method

Upgrades the file.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
void UpgradeFile(
    ref FileInfo file
)
Sub UpgradeFile (
    ByRef file As FileInfo
)

Parameters

file
Type: System.IOFileInfo
The file to upgrade.
Remarks
This method is called just before loading a previous config file. Use this method to modify the file before it is loaded.
See Also

Reference

IConfiguration Interface
CodeSmith.Engine Namespace


IConfiguration.UpgradeSettings Method

IConfigurationUpgradeSettings Method

Upgrades the settings.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
void UpgradeSettings()
Sub UpgradeSettings
Remarks
This method is called after loading a previous config file. Use this method to change any existing configurations to work with the latest version.
See Also

Reference

IConfiguration Interface
CodeSmith.Engine Namespace


IEngineHost Interface

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public interface IEngineHost
Public Interface IEngineHost

The IEngineHost type exposes the following members.

Properties
 | Name | Description
Public property | DefaultBaseClass |
Public property | DefaultImports |
Public property | DefaultNamespace |
Public property | DefaultReferences |
Public property | RegisteredContent |
Top
Methods
 | Name | Description
Public method | ContentExists |
Public method | GetContent(String, Boolean) |
Public method | GetContent(String, String, Boolean) |
Public method | GetFullPath(String) |
Public method | GetFullPath(String, String) |
Public method | PostProcessCompileResult |
Public method | PostProcessParseResult |
Top
See Also

Reference

CodeSmith.Engine Namespace


IEngineHost Properties

The IEngineHost type exposes the following members.

Properties
 | Name | Description
Public property | DefaultBaseClass |
Public property | DefaultImports |
Public property | DefaultNamespace |
Public property | DefaultReferences |
Public property | RegisteredContent |
Top
See Also

Reference

IEngineHost Interface
CodeSmith.Engine Namespace


IEngineHost.DefaultBaseClass Property

IEngineHostDefaultBaseClass Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
string DefaultBaseClass { get; set; }
Property DefaultBaseClass As String
    Get
    Set

Property Value

Type: String
See Also

Reference

IEngineHost Interface
CodeSmith.Engine Namespace


IEngineHost.DefaultImports Property

IEngineHostDefaultImports Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
ISet<string> DefaultImports { get; set; }
Property DefaultImports As ISet(Of String)
    Get
    Set

Property Value

Type: ISet String
See Also

Reference

IEngineHost Interface
CodeSmith.Engine Namespace


IEngineHost.DefaultNamespace Property

IEngineHostDefaultNamespace Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
string DefaultNamespace { get; set; }
Property DefaultNamespace As String
    Get
    Set

Property Value

Type: String
See Also

Reference

IEngineHost Interface
CodeSmith.Engine Namespace


IEngineHost.DefaultReferences Property

IEngineHostDefaultReferences Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
ISet<AssemblyReference> DefaultReferences { get; set; }
Property DefaultReferences As ISet(Of AssemblyReference)
    Get
    Set

Property Value

Type: ISet AssemblyReference
See Also

Reference

IEngineHost Interface
CodeSmith.Engine Namespace


IEngineHost.RegisteredContent Property

IEngineHostRegisteredContent Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
RegisteredContent RegisteredContent { get; }
ReadOnly Property RegisteredContent As RegisteredContent
    Get

Property Value

Type: RegisteredContent
See Also

Reference

IEngineHost Interface
CodeSmith.Engine Namespace


IEngineHost Methods

The IEngineHost type exposes the following members.

Methods
 | Name | Description
Public method | ContentExists |
Public method | GetContent(String, Boolean) |
Public method | GetContent(String, String, Boolean) |
Public method | GetFullPath(String) |
Public method | GetFullPath(String, String) |
Public method | PostProcessCompileResult |
Public method | PostProcessParseResult |
Top
See Also

Reference

IEngineHost Interface
CodeSmith.Engine Namespace


IEngineHost.ContentExists Method

IEngineHostContentExists Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
bool ContentExists(
    string path
)
Function ContentExists (
    path As String
) As Boolean

Parameters

path
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

IEngineHost Interface
CodeSmith.Engine Namespace


IEngineHost.GetContent Method

IEngineHostGetContent Method

Overload List
 | Name | Description
Public method | GetContent(String, Boolean) |
Public method | GetContent(String, String, Boolean) |
Top
See Also

Reference

IEngineHost Interface
CodeSmith.Engine Namespace


IEngineHost.GetContent Method (String, Boolean)

IEngineHostGetContent Method (String, Boolean)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
string GetContent(
    string path,
    bool useRegisteredContent = true
)
Function GetContent (
    path As String,
    Optional useRegisteredContent As Boolean = true
) As String

Parameters

path
Type: SystemString
useRegisteredContent (Optional)
Type: SystemBoolean

Return Value

Type: String
See Also

Reference

IEngineHost Interface
GetContent Overload
CodeSmith.Engine Namespace


IEngineHost.GetContent Method (String, String, Boolean)

IEngineHostGetContent Method (String, String, Boolean)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
string GetContent(
    string basePath,
    string path,
    bool useRegisteredContent = true
)
Function GetContent (
    basePath As String,
    path As String,
    Optional useRegisteredContent As Boolean = true
) As String

Parameters

basePath
Type: SystemString
path
Type: SystemString
useRegisteredContent (Optional)
Type: SystemBoolean

Return Value

Type: String
See Also

Reference

IEngineHost Interface
GetContent Overload
CodeSmith.Engine Namespace


IEngineHost.GetFullPath Method

IEngineHostGetFullPath Method

Overload List
 | Name | Description
Public method | GetFullPath(String) |
Public method | GetFullPath(String, String) |
Top
See Also

Reference

IEngineHost Interface
CodeSmith.Engine Namespace


IEngineHost.GetFullPath Method (String)

IEngineHostGetFullPath Method (String)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
string GetFullPath(
    string path
)
Function GetFullPath (
    path As String
) As String

Parameters

path
Type: SystemString

Return Value

Type: String
See Also

Reference

IEngineHost Interface
GetFullPath Overload
CodeSmith.Engine Namespace


IEngineHost.GetFullPath Method (String, String)

IEngineHostGetFullPath Method (String, String)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
string GetFullPath(
    string basePath,
    string path
)
Function GetFullPath (
    basePath As String,
    path As String
) As String

Parameters

basePath
Type: SystemString
path
Type: SystemString

Return Value

Type: String
See Also

Reference

IEngineHost Interface
GetFullPath Overload
CodeSmith.Engine Namespace


IEngineHost.PostProcessCompileResult Method

IEngineHostPostProcessCompileResult Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
void PostProcessCompileResult(
    CompileTemplateResult templateResult
)
Sub PostProcessCompileResult (
    templateResult As CompileTemplateResult
)

Parameters

templateResult
Type: CodeSmith.EngineCompileTemplateResult
See Also

Reference

IEngineHost Interface
CodeSmith.Engine Namespace


IEngineHost.PostProcessParseResult Method

IEngineHostPostProcessParseResult Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
void PostProcessParseResult(
    TemplateParseResult templateResult
)
Sub PostProcessParseResult (
    templateResult As TemplateParseResult
)

Parameters

templateResult
Type: CodeSmith.EngineTemplateParseResult
See Also

Reference

IEngineHost Interface
CodeSmith.Engine Namespace


IIndexed Interface

Interface defining an indexed object.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public interface IIndexed
Public Interface IIndexed

The IIndexed type exposes the following members.

Properties
 | Name | Description
Public property | Index | Gets or sets the index.
Top
See Also

Reference

CodeSmith.Engine Namespace


IIndexed Properties

The IIndexed type exposes the following members.

Properties
 | Name | Description
Public property | Index | Gets or sets the index.
Top
See Also

Reference

IIndexed Interface
CodeSmith.Engine Namespace


IIndexed.Index Property

IIndexedIndex Property

Gets or sets the index.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
int Index { get; set; }
Property Index As Integer
    Get
    Set

Property Value

Type: Int32
The index.
See Also

Reference

IIndexed Interface
CodeSmith.Engine Namespace


ILogger Interface

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public interface ILogger
Public Interface ILogger
Methods
 | Name | Description
Public method | Debug(Exception) |
Public method | Debug(String) |
Public method | Debug(Exception, String) |
Public method | Error(Exception) |
Public method | Error(String) |
Public method | Error(Exception, String) |
Public method | Info(Exception) |
Public method | Info(String) |
Public method | Info(Exception, String) |
Public method | Warn(Exception) |
Public method | Warn(String) |
Public method | Warn(Exception, String) |
Top
See Also

Reference

CodeSmith.Engine Namespace


ILogger Methods

Methods
 | Name | Description
Public method | Debug(Exception) |
Public method | Debug(String) |
Public method | Debug(Exception, String) |
Public method | Error(Exception) |
Public method | Error(String) |
Public method | Error(Exception, String) |
Public method | Info(Exception) |
Public method | Info(String) |
Public method | Info(Exception, String) |
Public method | Warn(Exception) |
Public method | Warn(String) |
Public method | Warn(Exception, String) |
Top
See Also

Reference

ILogger Interface
CodeSmith.Engine Namespace


ILogger.Debug Method

ILoggerDebug Method

Overload List
 | Name | Description
Public method | Debug(Exception) |
Public method | Debug(String) |
Public method | Debug(Exception, String) |
Top
See Also

Reference

ILogger Interface
CodeSmith.Engine Namespace


ILogger.Debug Method (Exception)

ILoggerDebug Method (Exception)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
void Debug(
    Exception exception
)
Sub Debug (
    exception As Exception
)

Parameters

exception
Type: SystemException
See Also

Reference

ILogger Interface
Debug Overload
CodeSmith.Engine Namespace


ILogger.Debug Method (String)

ILoggerDebug Method (String)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
void Debug(
    string message
)
Sub Debug (
    message As String
)

Parameters

message
Type: SystemString
See Also

Reference

ILogger Interface
Debug Overload
CodeSmith.Engine Namespace


ILogger.Debug Method (Exception, String)

ILoggerDebug Method (Exception, String)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
void Debug(
    Exception exception,
    string message
)
Sub Debug (
    exception As Exception,
    message As String
)

Parameters

exception
Type: SystemException
message
Type: SystemString
See Also

Reference

ILogger Interface
Debug Overload
CodeSmith.Engine Namespace


ILogger.Error Method

ILoggerError Method

Overload List
 | Name | Description
Public method | Error(Exception) |
Public method | Error(String) |
Public method | Error(Exception, String) |
Top
See Also

Reference

ILogger Interface
CodeSmith.Engine Namespace


ILogger.Error Method (Exception)

ILoggerError Method (Exception)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
void Error(
    Exception exception
)
Sub Error (
    exception As Exception
)

Parameters

exception
Type: SystemException
See Also

Reference

ILogger Interface
Error Overload
CodeSmith.Engine Namespace


ILogger.Error Method (String)

ILoggerError Method (String)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
void Error(
    string message
)
Sub Error (
    message As String
)

Parameters

message
Type: SystemString
See Also

Reference

ILogger Interface
Error Overload
CodeSmith.Engine Namespace


ILogger.Error Method (Exception, String)

ILoggerError Method (Exception, String)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
void Error(
    Exception exception,
    string message
)
Sub Error (
    exception As Exception,
    message As String
)

Parameters

exception
Type: SystemException
message
Type: SystemString
See Also

Reference

ILogger Interface
Error Overload
CodeSmith.Engine Namespace


ILogger.Info Method

ILoggerInfo Method

Overload List
 | Name | Description
Public method | Info(Exception) |
Public method | Info(String) |
Public method | Info(Exception, String) |
Top
See Also

Reference

ILogger Interface
CodeSmith.Engine Namespace


ILogger.Info Method (Exception)

ILoggerInfo Method (Exception)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
void Info(
    Exception exception
)
Sub Info (
    exception As Exception
)

Parameters

exception
Type: SystemException
See Also

Reference

ILogger Interface
Info Overload
CodeSmith.Engine Namespace


ILogger.Info Method (String)

ILoggerInfo Method (String)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
void Info(
    string message
)
Sub Info (
    message As String
)

Parameters

message
Type: SystemString
See Also

Reference

ILogger Interface
Info Overload
CodeSmith.Engine Namespace


ILogger.Info Method (Exception, String)

ILoggerInfo Method (Exception, String)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
void Info(
    Exception exception,
    string message
)
Sub Info (
    exception As Exception,
    message As String
)

Parameters

exception
Type: SystemException
message
Type: SystemString
See Also

Reference

ILogger Interface
Info Overload
CodeSmith.Engine Namespace


ILogger.Warn Method

ILoggerWarn Method

Overload List
 | Name | Description
Public method | Warn(Exception) |
Public method | Warn(String) |
Public method | Warn(Exception, String) |
Top
See Also

Reference

ILogger Interface
CodeSmith.Engine Namespace


ILogger.Warn Method (Exception)

ILoggerWarn Method (Exception)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
void Warn(
    Exception exception
)
Sub Warn (
    exception As Exception
)

Parameters

exception
Type: SystemException
See Also

Reference

ILogger Interface
Warn Overload
CodeSmith.Engine Namespace


ILogger.Warn Method (String)

ILoggerWarn Method (String)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
void Warn(
    string message
)
Sub Warn (
    message As String
)

Parameters

message
Type: SystemString
See Also

Reference

ILogger Interface
Warn Overload
CodeSmith.Engine Namespace


ILogger.Warn Method (Exception, String)

ILoggerWarn Method (Exception, String)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
void Warn(
    Exception exception,
    string message
)
Sub Warn (
    exception As Exception,
    message As String
)

Parameters

exception
Type: SystemException
message
Type: SystemString
See Also

Reference

ILogger Interface
Warn Overload
CodeSmith.Engine Namespace


IMergeStrategy Interface

This interface can be implemented to create a merge strategy.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public interface IMergeStrategy
Public Interface IMergeStrategy

The IMergeStrategy type exposes the following members.

Methods
 | Name | Description
Public method | Init | Initialize the merge strategy by passing in an initialization String.
Public method | Merge | Merge the template output with the existing content.
Top
See Also

Reference

CodeSmith.Engine Namespace


IMergeStrategy Methods

The IMergeStrategy type exposes the following members.

Methods
 | Name | Description
Public method | Init | Initialize the merge strategy by passing in an initialization String.
Public method | Merge | Merge the template output with the existing content.
Top
See Also

Reference

IMergeStrategy Interface
CodeSmith.Engine Namespace


IMergeStrategy.Init Method

IMergeStrategyInit Method

Initialize the merge strategy by passing in an initialization String.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
void Init(
    string init
)
Sub Init (
    init As String
)

Parameters

init
Type: SystemString
Initialization String.
See Also

Reference

IMergeStrategy Interface
CodeSmith.Engine Namespace


IMergeStrategy.Merge Method

IMergeStrategyMerge Method

Merge the template output with the existing content.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
string Merge(
    MergeContext context
)
Function Merge (
    context As MergeContext
) As String

Parameters

context
Type: CodeSmith.EngineMergeContext
A reference to the MergeContext.

Return Value

Type: String
See Also

Reference

IMergeStrategy Interface
CodeSmith.Engine Namespace


IndexedEnumerable Class

IndexedEnumerable makes enumerating over collections much easier by implementing properties like: IsEven, IsOdd, IsLast.
Inheritance Hierarchy
SystemObject
CodeSmith.EngineIndexedEnumerable

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static class IndexedEnumerable
<ExtensionAttribute>
Public NotInheritable Class IndexedEnumerable

The IndexedEnumerable type exposes the following members.

Methods
Name | Description
AsIndexedEnumerableT | Returns an IndexedEnumerable from any collection implementing IEnumerable<T>
CreateT | Returns an IndexedEnumerable from any collection implementing IEnumerable<T>
Top
See Also

Reference

CodeSmith.Engine Namespace


IndexedEnumerable Methods

The IndexedEnumerable type exposes the following members.

Methods
Name | Description
AsIndexedEnumerableT | Returns an IndexedEnumerable from any collection implementing IEnumerable<T>
CreateT | Returns an IndexedEnumerable from any collection implementing IEnumerable<T>
Top
See Also

Reference

IndexedEnumerable Class
CodeSmith.Engine Namespace


IndexedEnumerable.AsIndexedEnumerable(T) Method

IndexedEnumerableAsIndexedEnumerableT Method

Returns an IndexedEnumerable from any collection implementing IEnumerable<T>

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static IndexedEnumerable<T> AsIndexedEnumerable<T>(
    this IEnumerable<T> source
)

<ExtensionAttribute>
Public Shared Function AsIndexedEnumerable(Of T) (
    source As IEnumerable(Of T)
) As IndexedEnumerable(Of T)

Parameters

source
Type: System.Collections.GenericIEnumerable T
Source enumerable

Type Parameters

T
Type of enumerable

Return Value

Type: IndexedEnumerable T
A new IndexedEnumerable<T>.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IEnumerable T. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

IndexedEnumerable Class
CodeSmith.Engine Namespace


IndexedEnumerable.Create(T) Method

IndexedEnumerableCreateT Method

Returns an IndexedEnumerable from any collection implementing IEnumerable<T>

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static IndexedEnumerable<T> Create<T>(
    IEnumerable<T> source
)

Public Shared Function Create(Of T) (
    source As IEnumerable(Of T)
) As IndexedEnumerable(Of T)

Parameters

source
Type: System.Collections.GenericIEnumerable T
Source enumerable

Type Parameters

T
Type of enumerable

Return Value

Type: IndexedEnumerable T
A new IndexedEnumerable<T>.
See Also

Reference

IndexedEnumerable Class
CodeSmith.Engine Namespace


IndexedEnumerable(T) Class

IndexedEnumerableT Class

IndexedEnumerable makes enumerating over collections much easier by implementing properties like: IsEven, IsOdd, IsLast.
Inheritance Hierarchy
SystemObject
CodeSmith.EngineIndexedEnumerableT

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class IndexedEnumerable<T> : IEnumerable<IndexedEnumerableTEntryItem>,
    IEnumerable

Public Class IndexedEnumerable(Of T)
    Implements IEnumerable(Of IndexedEnumerableTEntryItem), IEnumerable

Type Parameters

T
Type to iterate over

The IndexedEnumerableT type exposes the following members.

Constructors
 | Name | Description
Public method | IndexedEnumerableT | Constructor that takes an IEnumerable<T>
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumeration of Entry objects.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AsIndexedEnumerableIndexedEnumerableTEntryItem | Returns an IndexedEnumerable from any collection implementing IEnumerable<T> (Defined by IndexedEnumerable.)
Top
See Also

Reference

CodeSmith.Engine Namespace


IndexedEnumerable(T) Constructor

IndexedEnumerableT Constructor

Constructor that takes an IEnumerable<T>

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public IndexedEnumerable(
    IEnumerable<T> enumerable
)
Public Sub New (
    enumerable As IEnumerable(Of T)
)

Parameters

enumerable
Type: System.Collections.GenericIEnumerable T
The collection to enumerate.
See Also

Reference

IndexedEnumerableT Class
CodeSmith.Engine Namespace


IndexedEnumerable(T) Methods

IndexedEnumerableT Methods

The IndexedEnumerableT generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumeration of Entry objects.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AsIndexedEnumerableIndexedEnumerableTEntryItem | Returns an IndexedEnumerable from any collection implementing IEnumerable<T> (Defined by IndexedEnumerable.)
Top
See Also

Reference

IndexedEnumerableT Class
CodeSmith.Engine Namespace


IndexedEnumerable(T).GetEnumerator Method

IndexedEnumerableTGetEnumerator Method

Returns an enumeration of Entry objects.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public IEnumerator<IndexedEnumerableTEntryItem> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of IndexedEnumerableTEntryItem)

Return Value

Type: IEnumerator IndexedEnumerableTEntryItem

Implements

IEnumerableTGetEnumerator
See Also

Reference

IndexedEnumerableT Class
CodeSmith.Engine Namespace


IndexedEnumerable(T).EntryItem Class

IndexedEnumerableTEntryItem Class

Represents each entry returned within a collection, containing the _value and whether it is the first and/or the last entry in the collection's. enumeration
Inheritance Hierarchy
SystemObject
CodeSmith.EngineIndexedEnumerableTEntryItem

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class EntryItem
Public Class EntryItem

The IndexedEnumerableTEntryItem generic type exposes the following members.

Properties
 | Name | Description
Public property | Index | The index of the current item in the collection.
Public property | IsEven | Returns true if the current item has an even index
Public property | IsFirst | Returns true if it is the first item in the collection.
Public property | IsLast | Returns true if it is the last item in the collection.
Public property | IsOdd | Returns true if the current item has an odd index
Public property | Value | The Entry Value.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSmith.Engine Namespace


EntryItem Properties

The IndexedEnumerableTEntryItem type exposes the following members.

Properties
 | Name | Description
Public property | Index | The index of the current item in the collection.
Public property | IsEven | Returns true if the current item has an even index
Public property | IsFirst | Returns true if it is the first item in the collection.
Public property | IsLast | Returns true if it is the last item in the collection.
Public property | IsOdd | Returns true if the current item has an odd index
Public property | Value | The Entry Value.
Top
See Also

Reference

IndexedEnumerableTEntryItem Class
CodeSmith.Engine Namespace


IndexedEnumerable(T).EntryItem.Index Property

IndexedEnumerableTEntryItemIndex Property

The index of the current item in the collection.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public int Index { get; }
Public ReadOnly Property Index As Integer
    Get

Property Value

Type: Int32
See Also

Reference

IndexedEnumerableTEntryItem Class
CodeSmith.Engine Namespace


IndexedEnumerable(T).EntryItem.IsEven Property

IndexedEnumerableTEntryItemIsEven Property

Returns true if the current item has an even index

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool IsEven { get; }
Public ReadOnly Property IsEven As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

IndexedEnumerableTEntryItem Class
CodeSmith.Engine Namespace


IndexedEnumerable(T).EntryItem.IsFirst Property

IndexedEnumerableTEntryItemIsFirst Property

Returns true if it is the first item in the collection.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool IsFirst { get; }
Public ReadOnly Property IsFirst As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

IndexedEnumerableTEntryItem Class
CodeSmith.Engine Namespace


IndexedEnumerable(T).EntryItem.IsLast Property

IndexedEnumerableTEntryItemIsLast Property

Returns true if it is the last item in the collection.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool IsLast { get; }
Public ReadOnly Property IsLast As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

IndexedEnumerableTEntryItem Class
CodeSmith.Engine Namespace


IndexedEnumerable(T).EntryItem.IsOdd Property

IndexedEnumerableTEntryItemIsOdd Property

Returns true if the current item has an odd index

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool IsOdd { get; }
Public ReadOnly Property IsOdd As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

IndexedEnumerableTEntryItem Class
CodeSmith.Engine Namespace


IndexedEnumerable(T).EntryItem.Value Property

IndexedEnumerableTEntryItemValue Property

The Entry Value.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public T Value { get; }
Public ReadOnly Property Value As T
    Get

Property Value

Type: T
See Also

Reference

IndexedEnumerableTEntryItem Class
CodeSmith.Engine Namespace


EntryItem Methods

The IndexedEnumerableTEntryItem type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IndexedEnumerableTEntryItem Class
CodeSmith.Engine Namespace


InMemoryCodeTemplateInfo Class

Inheritance Hierarchy
SystemObject
DisposableBase
CodeSmith.EngineCodeTemplateInfo
CodeSmith.EngineInMemoryCodeTemplateInfo

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class InMemoryCodeTemplateInfo : CodeTemplateInfo
Public Class InMemoryCodeTemplateInfo
    Inherits CodeTemplateInfo

The InMemoryCodeTemplateInfo type exposes the following members.

Constructors
 | Name | Description
Public method | InMemoryCodeTemplateInfo | Initializes a new instance of the InMemoryCodeTemplateInfo class
Top
Properties
 | Name | Description
Public property | AssemblyDependencies | (Inherited from CodeTemplateInfo.)
Public property | CodeBehind | (Inherited from CodeTemplateInfo.)
Public property | CodeSmithVersion | (Inherited from CodeTemplateInfo.)
Public property | CompilerVersion | (Inherited from CodeTemplateInfo.)
Public property | ContentHashCode | Gets the hash code based on the template content and all template Dependencies. (Inherited from CodeTemplateInfo.)
Public property | DateCreated | Gets the date the template was created. (Inherited from CodeTemplateInfo.)
Public property | DateModified | Gets the date the template was modified. (Inherited from CodeTemplateInfo.)
Public property | Description | Gets the description. (Inherited from CodeTemplateInfo.)
Public property | DirectoryName | Gets the name of the directory the template is located in. (Inherited from CodeTemplateInfo.)
Public property | FileDependencies | (Inherited from CodeTemplateInfo.)
Public property | FileName | Gets the name of the template file. (Inherited from CodeTemplateInfo.)
Public property | FullPath | Gets the full path to the template. (Inherited from CodeTemplateInfo.)
Public property | InMemory | (Inherited from CodeTemplateInfo.)
Public property | Language | Gets the template language. (Inherited from CodeTemplateInfo.)
Public property | OutputType | Gets the type of the output for this template. (Inherited from CodeTemplateInfo.)
Public property | TargetLanguage | Gets the target language. (Inherited from CodeTemplateInfo.)
Public property | TemplateEncoding | Gets the response encoding. (Inherited from CodeTemplateInfo.)
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from DisposableBase.)
Protected method | Dispose(Boolean) | (Inherited from DisposableBase.)
Protected method | DisposeManagedResources | (Inherited from DisposableBase.)
Protected method | DisposeUnmanagedResources | (Inherited from DisposableBase.)
Protected method | EnsureTemplateInfo | (Inherited from CodeTemplateInfo.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | (Inherited from DisposableBase.)
Public method | GetContent | (Overrides CodeTemplateInfoGetContent.)
Protected method | GetFileInfo | (Inherited from CodeTemplateInfo.)
Public method | GetHashCode | Gets the hash code based on the template dependencies. (Inherited from CodeTemplateInfo.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnLanguageChanged | (Inherited from CodeTemplateInfo.)
Public method | Refresh | (Inherited from CodeTemplateInfo.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | LanguageChanged | (Inherited from CodeTemplateInfo.)
Top
Fields
 | Name | Description
Protected field | _assemblyDependencies | (Inherited from CodeTemplateInfo.)
Protected field | _codeBehind | (Inherited from CodeTemplateInfo.)
Protected field | _compilerVersion | (Inherited from CodeTemplateInfo.)
Protected field | _dateCreated | (Inherited from CodeTemplateInfo.)
Protected field | _dateModified | (Inherited from CodeTemplateInfo.)
Protected field | _description | (Inherited from CodeTemplateInfo.)
Protected field | _directoryName | (Inherited from CodeTemplateInfo.)
Protected field | _fileContent | (Inherited from CodeTemplateInfo.)
Protected field | _fileDependencies | (Inherited from CodeTemplateInfo.)
Protected field | _fileName | (Inherited from CodeTemplateInfo.)
Protected field | _fullPath | (Inherited from CodeTemplateInfo.)
Protected field | _hashCode | (Inherited from CodeTemplateInfo.)
Protected field | _inMemory | (Inherited from CodeTemplateInfo.)
Protected field | _language | (Inherited from CodeTemplateInfo.)
Protected field | _outputType | (Inherited from CodeTemplateInfo.)
Protected field | _targetLanguage | (Inherited from CodeTemplateInfo.)
Protected field | _templateEncoding | (Inherited from CodeTemplateInfo.)
Protected field | _templateInfoRetrieved | (Inherited from CodeTemplateInfo.)
Top
See Also

Reference

CodeSmith.Engine Namespace


InMemoryCodeTemplateInfo Constructor

Initializes a new instance of the InMemoryCodeTemplateInfo class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public InMemoryCodeTemplateInfo(
    string content,
    string fullPath
)
Public Sub New (
    content As String,
    fullPath As String
)

Parameters

content
Type: SystemString
fullPath
Type: SystemString
See Also

Reference

InMemoryCodeTemplateInfo Class
CodeSmith.Engine Namespace


InMemoryCodeTemplateInfo Properties

The InMemoryCodeTemplateInfo type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyDependencies | (Inherited from CodeTemplateInfo.)
Public property | CodeBehind | (Inherited from CodeTemplateInfo.)
Public property | CodeSmithVersion | (Inherited from CodeTemplateInfo.)
Public property | CompilerVersion | (Inherited from CodeTemplateInfo.)
Public property | ContentHashCode | Gets the hash code based on the template content and all template Dependencies. (Inherited from CodeTemplateInfo.)
Public property | DateCreated | Gets the date the template was created. (Inherited from CodeTemplateInfo.)
Public property | DateModified | Gets the date the template was modified. (Inherited from CodeTemplateInfo.)
Public property | Description | Gets the description. (Inherited from CodeTemplateInfo.)
Public property | DirectoryName | Gets the name of the directory the template is located in. (Inherited from CodeTemplateInfo.)
Public property | FileDependencies | (Inherited from CodeTemplateInfo.)
Public property | FileName | Gets the name of the template file. (Inherited from CodeTemplateInfo.)
Public property | FullPath | Gets the full path to the template. (Inherited from CodeTemplateInfo.)
Public property | InMemory | (Inherited from CodeTemplateInfo.)
Public property | Language | Gets the template language. (Inherited from CodeTemplateInfo.)
Public property | OutputType | Gets the type of the output for this template. (Inherited from CodeTemplateInfo.)
Public property | TargetLanguage | Gets the target language. (Inherited from CodeTemplateInfo.)
Public property | TemplateEncoding | Gets the response encoding. (Inherited from CodeTemplateInfo.)
Top
See Also

Reference

InMemoryCodeTemplateInfo Class
CodeSmith.Engine Namespace


InMemoryCodeTemplateInfo Methods

The InMemoryCodeTemplateInfo type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from DisposableBase.)
Protected method | Dispose(Boolean) | (Inherited from DisposableBase.)
Protected method | DisposeManagedResources | (Inherited from DisposableBase.)
Protected method | DisposeUnmanagedResources | (Inherited from DisposableBase.)
Protected method | EnsureTemplateInfo | (Inherited from CodeTemplateInfo.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | (Inherited from DisposableBase.)
Public method | GetContent | (Overrides CodeTemplateInfoGetContent.)
Protected method | GetFileInfo | (Inherited from CodeTemplateInfo.)
Public method | GetHashCode | Gets the hash code based on the template dependencies. (Inherited from CodeTemplateInfo.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnLanguageChanged | (Inherited from CodeTemplateInfo.)
Public method | Refresh | (Inherited from CodeTemplateInfo.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

InMemoryCodeTemplateInfo Class
CodeSmith.Engine Namespace


InMemoryCodeTemplateInfo.GetContent Method

InMemoryCodeTemplateInfoGetContent Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override string GetContent()
Public Overrides Function GetContent As String

Return Value

Type: String

Implements

ICodeTemplateInfoGetContent
See Also

Reference

InMemoryCodeTemplateInfo Class
CodeSmith.Engine Namespace


InMemoryCodeTemplateInfo Events

The InMemoryCodeTemplateInfo type exposes the following members.

Events
 | Name | Description
Public event | LanguageChanged | (Inherited from CodeTemplateInfo.)
Top
See Also

Reference

InMemoryCodeTemplateInfo Class
CodeSmith.Engine Namespace


InMemoryCodeTemplateInfo Fields

The InMemoryCodeTemplateInfo type exposes the following members.

Fields
 | Name | Description
Protected field | _assemblyDependencies | (Inherited from CodeTemplateInfo.)
Protected field | _codeBehind | (Inherited from CodeTemplateInfo.)
Protected field | _compilerVersion | (Inherited from CodeTemplateInfo.)
Protected field | _dateCreated | (Inherited from CodeTemplateInfo.)
Protected field | _dateModified | (Inherited from CodeTemplateInfo.)
Protected field | _description | (Inherited from CodeTemplateInfo.)
Protected field | _directoryName | (Inherited from CodeTemplateInfo.)
Protected field | _fileContent | (Inherited from CodeTemplateInfo.)
Protected field | _fileDependencies | (Inherited from CodeTemplateInfo.)
Protected field | _fileName | (Inherited from CodeTemplateInfo.)
Protected field | _fullPath | (Inherited from CodeTemplateInfo.)
Protected field | _hashCode | (Inherited from CodeTemplateInfo.)
Protected field | _inMemory | (Inherited from CodeTemplateInfo.)
Protected field | _language | (Inherited from CodeTemplateInfo.)
Protected field | _outputType | (Inherited from CodeTemplateInfo.)
Protected field | _targetLanguage | (Inherited from CodeTemplateInfo.)
Protected field | _templateEncoding | (Inherited from CodeTemplateInfo.)
Protected field | _templateInfoRetrieved | (Inherited from CodeTemplateInfo.)
Top
See Also

Reference

InMemoryCodeTemplateInfo Class
CodeSmith.Engine Namespace


InsertRegionMergeStrategy Class

This merge strategy can be used to insert the template output into a named region inside an existing file and preserve the rest of the content in the file. The initialization string should be of the format: "RegionName=<RegionName>;Language=<Language>"
Inheritance Hierarchy
SystemObject
CodeSmith.EngineInsertRegionMergeStrategy

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class InsertRegionMergeStrategy : IMergeStrategy
Public Class InsertRegionMergeStrategy
    Implements IMergeStrategy

The InsertRegionMergeStrategy type exposes the following members.

Constructors
 | Name | Description
Public method | InsertRegionMergeStrategy | Initializes a new instance of the InsertRegionMergeStrategy class
Public method | InsertRegionMergeStrategy(String) | Initializes a new instance of the InsertRegionMergeStrategy class
Public method | InsertRegionMergeStrategy(String, String) | Initializes a new instance of the InsertRegionMergeStrategy class
Top
Properties
 | Name | Description
Public property | Language |
Public property | RegionName |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Init |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Merge |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSmith.Engine Namespace


InsertRegionMergeStrategy Constructor

Overload List
 | Name | Description
Public method | InsertRegionMergeStrategy | Initializes a new instance of the InsertRegionMergeStrategy class
Public method | InsertRegionMergeStrategy(String) | Initializes a new instance of the InsertRegionMergeStrategy class
Public method | InsertRegionMergeStrategy(String, String) | Initializes a new instance of the InsertRegionMergeStrategy class
Top
See Also

Reference

InsertRegionMergeStrategy Class
CodeSmith.Engine Namespace


InsertRegionMergeStrategy Constructor

Initializes a new instance of the InsertRegionMergeStrategy class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public InsertRegionMergeStrategy()
Public Sub New
See Also

Reference

InsertRegionMergeStrategy Class
InsertRegionMergeStrategy Overload
CodeSmith.Engine Namespace


InsertRegionMergeStrategy Constructor (String)

Initializes a new instance of the InsertRegionMergeStrategy class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public InsertRegionMergeStrategy(
    string regionName
)
Public Sub New (
    regionName As String
)

Parameters

regionName
Type: SystemString
See Also

Reference

InsertRegionMergeStrategy Class
InsertRegionMergeStrategy Overload
CodeSmith.Engine Namespace


InsertRegionMergeStrategy Constructor (String, String)

Initializes a new instance of the InsertRegionMergeStrategy class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public InsertRegionMergeStrategy(
    string regionName,
    string language
)
Public Sub New (
    regionName As String,
    language As String
)

Parameters

regionName
Type: SystemString
language
Type: SystemString
See Also

Reference

InsertRegionMergeStrategy Class
InsertRegionMergeStrategy Overload
CodeSmith.Engine Namespace


InsertRegionMergeStrategy Properties

The InsertRegionMergeStrategy type exposes the following members.

Properties
 | Name | Description
Public property | Language |
Public property | RegionName |
Top
See Also

Reference

InsertRegionMergeStrategy Class
CodeSmith.Engine Namespace


InsertRegionMergeStrategy.Language Property

InsertRegionMergeStrategyLanguage Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string Language { get; set; }
Public Property Language As String
    Get
    Set

Property Value

Type: String
See Also

Reference

InsertRegionMergeStrategy Class
CodeSmith.Engine Namespace


InsertRegionMergeStrategy.RegionName Property

InsertRegionMergeStrategyRegionName Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string RegionName { get; set; }
Public Property RegionName As String
    Get
    Set

Property Value

Type: String
See Also

Reference

InsertRegionMergeStrategy Class
CodeSmith.Engine Namespace


InsertRegionMergeStrategy Methods

The InsertRegionMergeStrategy type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Init |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Merge |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

InsertRegionMergeStrategy Class
CodeSmith.Engine Namespace


InsertRegionMergeStrategy.Init Method

InsertRegionMergeStrategyInit Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void Init(
    string init
)
Public Sub Init (
    init As String
)

Parameters

init
Type: SystemString

Implements

IMergeStrategyInit(String)
See Also

Reference

InsertRegionMergeStrategy Class
CodeSmith.Engine Namespace


InsertRegionMergeStrategy.Merge Method

InsertRegionMergeStrategyMerge Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string Merge(
    MergeContext context
)
Public Function Merge (
    context As MergeContext
) As String

Parameters

context
Type: CodeSmith.EngineMergeContext

Return Value

Type: String

Implements

IMergeStrategyMerge(MergeContext)
See Also

Reference

InsertRegionMergeStrategy Class
CodeSmith.Engine Namespace


InvalidPublisherException Class

Inheritance Hierarchy
SystemObject
SystemException
SystemApplicationException
CodeSmith.EngineInvalidPublisherException

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
public class InvalidPublisherException : ApplicationException
<SerializableAttribute>
Public Class InvalidPublisherException
    Inherits ApplicationException

The InvalidPublisherException type exposes the following members.

Constructors
 | Name | Description
Public method | InvalidPublisherException | Initializes a new instance of the InvalidPublisherException class
Protected method | InvalidPublisherException(SerializationInfo, StreamingContext) | Initializes a new instance of the InvalidPublisherException class
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | (Overrides ExceptionMessage.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

CodeSmith.Engine Namespace


InvalidPublisherException Constructor

Overload List
 | Name | Description
Public method | InvalidPublisherException | Initializes a new instance of the InvalidPublisherException class
Protected method | InvalidPublisherException(SerializationInfo, StreamingContext) | Initializes a new instance of the InvalidPublisherException class
Top
See Also

Reference

InvalidPublisherException Class
CodeSmith.Engine Namespace


InvalidPublisherException Constructor

Initializes a new instance of the InvalidPublisherException class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public InvalidPublisherException()
Public Sub New
See Also

Reference

InvalidPublisherException Class
InvalidPublisherException Overload
CodeSmith.Engine Namespace


InvalidPublisherException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the InvalidPublisherException class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected InvalidPublisherException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
context
Type: System.Runtime.SerializationStreamingContext
See Also

Reference

InvalidPublisherException Class
InvalidPublisherException Overload
CodeSmith.Engine Namespace


InvalidPublisherException Properties

The InvalidPublisherException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | (Overrides ExceptionMessage.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

InvalidPublisherException Class
CodeSmith.Engine Namespace


InvalidPublisherException.Message Property

InvalidPublisherExceptionMessage Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override string Message { get; }
Public Overrides ReadOnly Property Message As String
    Get

Property Value

Type: String

Implements

_ExceptionMessage
See Also

Reference

InvalidPublisherException Class
CodeSmith.Engine Namespace


InvalidPublisherException Methods

The InvalidPublisherException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

InvalidPublisherException Class
CodeSmith.Engine Namespace


InvalidPublisherException Events

The InvalidPublisherException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

InvalidPublisherException Class
CodeSmith.Engine Namespace


IPropertyRefresher Interface

Interface that all property refreshers must implement.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public interface IPropertyRefresher
Public Interface IPropertyRefresher

The IPropertyRefresher type exposes the following members.

Methods
 | Name | Description
Public method | Refresh |
Top
See Also

Reference

CodeSmith.Engine Namespace


IPropertyRefresher Methods

The IPropertyRefresher type exposes the following members.

Methods
 | Name | Description
Public method | Refresh |
Top
See Also

Reference

IPropertyRefresher Interface
CodeSmith.Engine Namespace


IPropertyRefresher.Refresh Method

IPropertyRefresherRefresh Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
Object Refresh(
    PropertyRefresherContext context
)
Function Refresh (
    context As PropertyRefresherContext
) As Object

Parameters

context
Type: CodeSmith.EnginePropertyRefresherContext

Return Value

Type: Object
See Also

Reference

IPropertyRefresher Interface
CodeSmith.Engine Namespace


IPropertySerializer Interface

Interface that all property serializers must implement.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public interface IPropertySerializer
Public Interface IPropertySerializer

The IPropertySerializer type exposes the following members.

Methods
 | Name | Description
Public method | LoadProperty | This method will be used to restore the property value after a template has been compiled.
Public method | ParseDefaultValue | This method will be used to parse a default value for a property when a template is being instantiated.
Public method | ReadPropertyXml | This method will be used when deserializing the property from an XML property set.
Public method | SaveProperty | This method will be used to save the property value when a template is being compiled.
Public method | WritePropertyXml | This method will be used when serializing the property value to an XML property set.
Top
See Also

Reference

CodeSmith.Engine Namespace


IPropertySerializer Methods

The IPropertySerializer type exposes the following members.

Methods
 | Name | Description
Public method | LoadProperty | This method will be used to restore the property value after a template has been compiled.
Public method | ParseDefaultValue | This method will be used to parse a default value for a property when a template is being instantiated.
Public method | ReadPropertyXml | This method will be used when deserializing the property from an XML property set.
Public method | SaveProperty | This method will be used to save the property value when a template is being compiled.
Public method | WritePropertyXml | This method will be used when serializing the property value to an XML property set.
Top
See Also

Reference

IPropertySerializer Interface
CodeSmith.Engine Namespace


IPropertySerializer.LoadProperty Method

IPropertySerializerLoadProperty Method

This method will be used to restore the property value after a template has been compiled.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
Object LoadProperty(
    PropertySerializerContext context,
    Object propertyValue
)
Function LoadProperty (
    context As PropertySerializerContext,
    propertyValue As Object
) As Object

Parameters

context
Type: CodeSmith.EnginePropertySerializerContext
Context information of the target property.
propertyValue
Type: SystemObject
The property to be loaded.

Return Value

Type: Object
The value to be assigned to the template property after it has been compiled.
See Also

Reference

IPropertySerializer Interface
CodeSmith.Engine Namespace


IPropertySerializer.ParseDefaultValue Method

IPropertySerializerParseDefaultValue Method

This method will be used to parse a default value for a property when a template is being instantiated.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
Object ParseDefaultValue(
    PropertySerializerContext context,
    string defaultValue
)
Function ParseDefaultValue (
    context As PropertySerializerContext,
    defaultValue As String
) As Object

Parameters

context
Type: CodeSmith.EnginePropertySerializerContext
Context information of the target property.
defaultValue
Type: SystemString
The default value.

Return Value

Type: Object
An object that will be assigned to the template property.
See Also

Reference

IPropertySerializer Interface
CodeSmith.Engine Namespace


IPropertySerializer.ReadPropertyXml Method

IPropertySerializerReadPropertyXml Method

This method will be used when deserializing the property from an XML property set.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
Object ReadPropertyXml(
    PropertySerializerContext context,
    XmlNode propertyValue
)
Function ReadPropertyXml (
    context As PropertySerializerContext,
    propertyValue As XmlNode
) As Object

Parameters

context
Type: CodeSmith.EnginePropertySerializerContext
Context information of the target property.
propertyValue
Type: System.XmlXmlNode
The XML node to read the property value from.

Return Value

Type: Object
The value to be assigned to the template property.
See Also

Reference

IPropertySerializer Interface
CodeSmith.Engine Namespace


IPropertySerializer.SaveProperty Method

IPropertySerializerSaveProperty Method

This method will be used to save the property value when a template is being compiled.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
Object SaveProperty(
    PropertySerializerContext context,
    Object propertyValue
)
Function SaveProperty (
    context As PropertySerializerContext,
    propertyValue As Object
) As Object

Parameters

context
Type: CodeSmith.EnginePropertySerializerContext
Context information of the target property.
propertyValue
Type: SystemObject
The property to be saved.

Return Value

Type: Object
An object that will be stored in a Hashtable during template compilation.
See Also

Reference

IPropertySerializer Interface
CodeSmith.Engine Namespace


IPropertySerializer.WritePropertyXml Method

IPropertySerializerWritePropertyXml Method

This method will be used when serializing the property value to an XML property set.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
void WritePropertyXml(
    PropertySerializerContext context,
    XmlWriter writer,
    Object propertyValue
)
Sub WritePropertyXml (
    context As PropertySerializerContext,
    writer As XmlWriter,
    propertyValue As Object
)

Parameters

context
Type: CodeSmith.EnginePropertySerializerContext
Context information of the target property.
writer
Type: System.XmlXmlWriter
The XML writer that the property value will be written to.
propertyValue
Type: SystemObject
The property to be serialized.
See Also

Reference

IPropertySerializer Interface
CodeSmith.Engine Namespace


ItemRegisteredEventArgs Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
CodeSmith.EngineItemRegisteredEventArgs

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
public class ItemRegisteredEventArgs : EventArgs
<SerializableAttribute>
Public Class ItemRegisteredEventArgs
    Inherits EventArgs

The ItemRegisteredEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ItemRegisteredEventArgs | Initializes a new instance of the ItemRegisteredEventArgs class
Public method | ItemRegisteredEventArgs(String) | Initializes a new instance of the ItemRegisteredEventArgs class.
Top
Properties
 | Name | Description
Public property | ItemName | Gets or sets the name of the item.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSmith.Engine Namespace


ItemRegisteredEventArgs Constructor

Overload List
 | Name | Description
Public method | ItemRegisteredEventArgs | Initializes a new instance of the ItemRegisteredEventArgs class
Public method | ItemRegisteredEventArgs(String) | Initializes a new instance of the ItemRegisteredEventArgs class.
Top
See Also

Reference

ItemRegisteredEventArgs Class
CodeSmith.Engine Namespace


ItemRegisteredEventArgs Constructor

Initializes a new instance of the ItemRegisteredEventArgs class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ItemRegisteredEventArgs()
Public Sub New
See Also

Reference

ItemRegisteredEventArgs Class
ItemRegisteredEventArgs Overload
CodeSmith.Engine Namespace


ItemRegisteredEventArgs Constructor (String)

Initializes a new instance of the ItemRegisteredEventArgs class.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ItemRegisteredEventArgs(
    string itemName
)
Public Sub New (
    itemName As String
)

Parameters

itemName
Type: SystemString
Name of the item.
See Also

Reference

ItemRegisteredEventArgs Class
ItemRegisteredEventArgs Overload
CodeSmith.Engine Namespace


ItemRegisteredEventArgs Properties

The ItemRegisteredEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | ItemName | Gets or sets the name of the item.
Top
See Also

Reference

ItemRegisteredEventArgs Class
CodeSmith.Engine Namespace


ItemRegisteredEventArgs.ItemName Property

ItemRegisteredEventArgsItemName Property

Gets or sets the name of the item.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string ItemName { get; set; }
Public Property ItemName As String
    Get
    Set

Property Value

Type: String
The name of the item.
See Also

Reference

ItemRegisteredEventArgs Class
CodeSmith.Engine Namespace


ItemRegisteredEventArgs Methods

The ItemRegisteredEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ItemRegisteredEventArgs Class
CodeSmith.Engine Namespace


LanguageKind Enumeration

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public enum LanguageKind
Public Enumeration LanguageKind
Members
Member name | Value | Description
CSharp | 0 |
VisualBasic | 1 |
JavaScript | 2 |
Other | 3 |
See Also

Reference

CodeSmith.Engine Namespace


LanguageRegionDefinition Class

Inheritance Hierarchy
SystemObject
CodeSmith.EngineConfigurationItemBase
CodeSmith.EngineLanguageRegionDefinition

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class LanguageRegionDefinition : ConfigurationItemBase
Public Class LanguageRegionDefinition
    Inherits ConfigurationItemBase

The LanguageRegionDefinition type exposes the following members.

Constructors
 | Name | Description
Public method | LanguageRegionDefinition | Initializes a new instance of the LanguageRegionDefinition class
Top
Properties
 | Name | Description
Public property | Index | Gets or sets the index. (Inherited from ConfigurationItemBase.)
Public property | LanguageKeys | Gets the list of language keys for the region defintion.
Public property | RegionEndRegex | Gets or sets the region end regex.
Public property | RegionStartRegex | Gets or sets the region start regex.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | (Inherited from ConfigurationItemBase.)
Public method | ToString | (Overrides ObjectToString.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from ConfigurationItemBase.)
Top
See Also

Reference

CodeSmith.Engine Namespace


LanguageRegionDefinition Constructor

Initializes a new instance of the LanguageRegionDefinition class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public LanguageRegionDefinition()
Public Sub New
See Also

Reference

LanguageRegionDefinition Class
CodeSmith.Engine Namespace


LanguageRegionDefinition Properties

The LanguageRegionDefinition type exposes the following members.

Properties
 | Name | Description
Public property | Index | Gets or sets the index. (Inherited from ConfigurationItemBase.)
Public property | LanguageKeys | Gets the list of language keys for the region defintion.
Public property | RegionEndRegex | Gets or sets the region end regex.
Public property | RegionStartRegex | Gets or sets the region start regex.
Top
See Also

Reference

LanguageRegionDefinition Class
CodeSmith.Engine Namespace


LanguageRegionDefinition.LanguageKeys Property

LanguageRegionDefinitionLanguageKeys Property

Gets the list of language keys for the region defintion.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public DelimitedStringCollection LanguageKeys { get; }
Public ReadOnly Property LanguageKeys As DelimitedStringCollection
    Get

Property Value

Type: DelimitedStringCollection
The language keys.
See Also

Reference

LanguageRegionDefinition Class
CodeSmith.Engine Namespace


LanguageRegionDefinition.RegionEndRegex Property

LanguageRegionDefinitionRegionEndRegex Property

Gets or sets the region end regex.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string RegionEndRegex { get; set; }
Public Property RegionEndRegex As String
    Get
    Set

Property Value

Type: String
The region end regex.
See Also

Reference

LanguageRegionDefinition Class
CodeSmith.Engine Namespace


LanguageRegionDefinition.RegionStartRegex Property

LanguageRegionDefinitionRegionStartRegex Property

Gets or sets the region start regex.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string RegionStartRegex { get; set; }
Public Property RegionStartRegex As String
    Get
    Set

Property Value

Type: String
The region start regex.
See Also

Reference

LanguageRegionDefinition Class
CodeSmith.Engine Namespace


LanguageRegionDefinition Methods

The LanguageRegionDefinition type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | (Inherited from ConfigurationItemBase.)
Public method | ToString | (Overrides ObjectToString.)
Top
See Also

Reference

LanguageRegionDefinition Class
CodeSmith.Engine Namespace


LanguageRegionDefinition.ToString Method

LanguageRegionDefinitionToString Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
See Also

Reference

LanguageRegionDefinition Class
CodeSmith.Engine Namespace


LanguageRegionDefinition Events

The LanguageRegionDefinition type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from ConfigurationItemBase.)
Top
See Also

Reference

LanguageRegionDefinition Class
CodeSmith.Engine Namespace


LanguageRegionDefinitionCollection Class

Inheritance Hierarchy
SystemObject
CodeSmith.EngineVirtualCollectionBase LanguageRegionDefinition
CodeSmith.EngineConfigurationCollectionBase LanguageRegionDefinition
CodeSmith.EngineLanguageRegionDefinitionCollection

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class LanguageRegionDefinitionCollection : ConfigurationCollectionBase<LanguageRegionDefinition>
Public Class LanguageRegionDefinitionCollection
    Inherits ConfigurationCollectionBase(Of LanguageRegionDefinition)

The LanguageRegionDefinitionCollection type exposes the following members.

Constructors
 | Name | Description
Public method | LanguageRegionDefinitionCollection | Initializes a new instance of the LanguageRegionDefinitionCollection class
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from VirtualCollectionBaseT.)
Public property | Item | Gets or sets the type T at the specified index. (Inherited from VirtualCollectionBaseT.)
Protected property | SubKey | (Overrides ConfigurationCollectionBaseTSubKey.)
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from VirtualCollectionBaseT.)
Protected method | AddItem | (Overrides VirtualCollectionBaseTAddItem(T).)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from VirtualCollectionBaseT.)
Protected method | ClearItems | (Inherited from ConfigurationCollectionBaseT.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from VirtualCollectionBaseT.)
Public method | CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from VirtualCollectionBaseT.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetCount | (Inherited from ConfigurationCollectionBaseT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from VirtualCollectionBaseT.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetIndex | (Overrides VirtualCollectionBaseTGetIndex(T).)
Protected method | GetItem | (Inherited from ConfigurationCollectionBaseT.)
Protected method | GetItemFromRegistry | (Overrides ConfigurationCollectionBaseTGetItemFromRegistry(Int32).)
Protected method | GetItems | (Inherited from ConfigurationCollectionBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from VirtualCollectionBaseT.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from VirtualCollectionBaseT.)
Protected method | InsertItem | (Inherited from ConfigurationCollectionBaseT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | (Inherited from ConfigurationCollectionBaseT.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from VirtualCollectionBaseT.)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from VirtualCollectionBaseT.)
Protected method | RemoveItem | (Inherited from ConfigurationCollectionBaseT.)
Protected method | SetItem | (Inherited from ConfigurationCollectionBaseT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSmith.Engine Namespace


LanguageRegionDefinitionCollection Constructor

Initializes a new instance of the LanguageRegionDefinitionCollection class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public LanguageRegionDefinitionCollection()
Public Sub New
See Also

Reference

LanguageRegionDefinitionCollection Class
CodeSmith.Engine Namespace


LanguageRegionDefinitionCollection Properties

The LanguageRegionDefinitionCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from VirtualCollectionBaseT.)
Public property | Item | Gets or sets the type T at the specified index. (Inherited from VirtualCollectionBaseT.)
Protected property | SubKey | (Overrides ConfigurationCollectionBaseTSubKey.)
Top
See Also

Reference

LanguageRegionDefinitionCollection Class
CodeSmith.Engine Namespace


LanguageRegionDefinitionCollection.SubKey Property

LanguageRegionDefinitionCollectionSubKey Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected override string SubKey { get; }
Protected Overrides ReadOnly Property SubKey As String
    Get

Property Value

Type: String
See Also

Reference

LanguageRegionDefinitionCollection Class
CodeSmith.Engine Namespace


LanguageRegionDefinitionCollection Methods

The LanguageRegionDefinitionCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from VirtualCollectionBaseT.)
Protected method | AddItem | (Overrides VirtualCollectionBaseTAddItem(T).)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from VirtualCollectionBaseT.)
Protected method | ClearItems | (Inherited from ConfigurationCollectionBaseT.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from VirtualCollectionBaseT.)
Public method | CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from VirtualCollectionBaseT.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetCount | (Inherited from ConfigurationCollectionBaseT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from VirtualCollectionBaseT.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetIndex | (Overrides VirtualCollectionBaseTGetIndex(T).)
Protected method | GetItem | (Inherited from ConfigurationCollectionBaseT.)
Protected method | GetItemFromRegistry | (Overrides ConfigurationCollectionBaseTGetItemFromRegistry(Int32).)
Protected method | GetItems | (Inherited from ConfigurationCollectionBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from VirtualCollectionBaseT.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from VirtualCollectionBaseT.)
Protected method | InsertItem | (Inherited from ConfigurationCollectionBaseT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | (Inherited from ConfigurationCollectionBaseT.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from VirtualCollectionBaseT.)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from VirtualCollectionBaseT.)
Protected method | RemoveItem | (Inherited from ConfigurationCollectionBaseT.)
Protected method | SetItem | (Inherited from ConfigurationCollectionBaseT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LanguageRegionDefinitionCollection Class
CodeSmith.Engine Namespace


LanguageRegionDefinitionCollection.AddItem Method

LanguageRegionDefinitionCollectionAddItem Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected override int AddItem(
    LanguageRegionDefinition item
)
Protected Overrides Function AddItem (
    item As LanguageRegionDefinition
) As Integer

Parameters

item
Type: CodeSmith.EngineLanguageRegionDefinition

Return Value

Type: Int32
See Also

Reference

LanguageRegionDefinitionCollection Class
CodeSmith.Engine Namespace


LanguageRegionDefinitionCollection.GetIndex Method

LanguageRegionDefinitionCollectionGetIndex Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected override int GetIndex(
    LanguageRegionDefinition item
)
Protected Overrides Function GetIndex (
    item As LanguageRegionDefinition
) As Integer

Parameters

item
Type: CodeSmith.EngineLanguageRegionDefinition

Return Value

Type: Int32
See Also

Reference

LanguageRegionDefinitionCollection Class
CodeSmith.Engine Namespace


LanguageRegionDefinitionCollection.GetItemFromRegistry Method

LanguageRegionDefinitionCollectionGetItemFromRegistry Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected override LanguageRegionDefinition GetItemFromRegistry(
    int index
)
Protected Overrides Function GetItemFromRegistry (
    index As Integer
) As LanguageRegionDefinition

Parameters

index
Type: SystemInt32

Return Value

Type: LanguageRegionDefinition
See Also

Reference

LanguageRegionDefinitionCollection Class
CodeSmith.Engine Namespace


Logger Class

Inheritance Hierarchy
SystemObject
CodeSmith.EngineLogger

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class Logger
Public Class Logger

The Logger type exposes the following members.

Constructors
 | Name | Description
Public method | Logger | Initializes a new instance of the Logger class
Top
Properties
Name | Description
Log | Gets the current logger instance or falls back to a default logger.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RegisterInstance |
 | RegisterTypeT |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSmith.Engine Namespace


Logger Constructor

Initializes a new instance of the Logger class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public Logger()
Public Sub New
See Also

Reference

Logger Class
CodeSmith.Engine Namespace


Logger Properties

The Logger type exposes the following members.

Properties
Name | Description
Log | Gets the current logger instance or falls back to a default logger.
Top
See Also

Reference

Logger Class
CodeSmith.Engine Namespace


Logger.Log Property

LoggerLog Property

Gets the current logger instance or falls back to a default logger.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static ILogger Log { get; }
Public Shared ReadOnly Property Log As ILogger
    Get

Property Value

Type: ILogger
See Also

Reference

Logger Class
CodeSmith.Engine Namespace


Logger Methods

The Logger type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RegisterInstance |
 | RegisterTypeT |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Logger Class
CodeSmith.Engine Namespace


Logger.RegisterInstance Method

LoggerRegisterInstance Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static void RegisterInstance(
    ILogger logger
)
Public Shared Sub RegisterInstance (
    logger As ILogger
)

Parameters

logger
Type: CodeSmith.EngineILogger
See Also

Reference

Logger Class
CodeSmith.Engine Namespace


Logger.RegisterType(T) Method

LoggerRegisterTypeT Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static void RegisterType<T>()
where T : new(), ILogger

Public Shared Sub RegisterType(Of T As {New, ILogger})

Type Parameters

T
See Also

Reference

Logger Class
CodeSmith.Engine Namespace


LogLevel Enumeration

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public enum LogLevel
Public Enumeration LogLevel
Members
Member name | Value | Description
Info | 0 |
Debug | 1 |
Warn | 2 |
Error | 3 |
See Also

Reference

CodeSmith.Engine Namespace


Map Class

Inheritance Hierarchy
SystemObject
CodeSmith.EngineMap

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class Map
Public Class Map

The Map type exposes the following members.

Constructors
 | Name | Description
Public method | Map | Initializes a new instance of the Map class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetMapFiles | Gets the map files.
 | GetMapFolders |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Load | Loads the specified name.
 | LoadFromName | Loads the map with the specified name by trying to resolve the path.
 | LoadMergedFromName | Loads the map with the specified name by merging any maps with this name found in the global map folder and local template folders.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ResolveMapNamePaths |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | TryResolvePath | Tries the resolve path.
Top
Fields
Name | Description
DefaultExtension |
DefaultNamespace |
Top
See Also

Reference

CodeSmith.Engine Namespace


Map Constructor

Initializes a new instance of the Map class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public Map()
Public Sub New
See Also

Reference

Map Class
CodeSmith.Engine Namespace


Map Methods

The Map type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetMapFiles | Gets the map files.
 | GetMapFolders |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Load | Loads the specified name.
 | LoadFromName | Loads the map with the specified name by trying to resolve the path.
 | LoadMergedFromName | Loads the map with the specified name by merging any maps with this name found in the global map folder and local template folders.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ResolveMapNamePaths |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | TryResolvePath | Tries the resolve path.
Top
See Also

Reference

Map Class
CodeSmith.Engine Namespace


Map.GetMapFiles Method

MapGetMapFiles Method

Gets the map files.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static List<FileInfo> GetMapFiles()
Public Shared Function GetMapFiles As List(Of FileInfo)

Return Value

Type: List FileInfo
See Also

Reference

Map Class
CodeSmith.Engine Namespace


Map.GetMapFolders Method

MapGetMapFolders Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static List<DirectoryInfo> GetMapFolders()
Public Shared Function GetMapFolders As List(Of DirectoryInfo)

Return Value

Type: List DirectoryInfo
See Also

Reference

Map Class
CodeSmith.Engine Namespace


Map.Load Method

MapLoad Method

Loads the specified name.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static MapCollection Load(
    string fullPath
)
Public Shared Function Load (
    fullPath As String
) As MapCollection

Parameters

fullPath
Type: SystemString
The path.

Return Value

Type: MapCollection
See Also

Reference

Map Class
CodeSmith.Engine Namespace


Map.LoadFromName Method

MapLoadFromName Method

Loads the map with the specified name by trying to resolve the path.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static MapCollection LoadFromName(
    string name,
    string baseDirectory = null
)
Public Shared Function LoadFromName (
    name As String,
    Optional baseDirectory As String = Nothing
) As MapCollection

Parameters

name
Type: SystemString
The name of the map.
baseDirectory (Optional)
Type: SystemString

Return Value

Type: MapCollection
See Also

Reference

Map Class
CodeSmith.Engine Namespace


Map.LoadMergedFromName Method

MapLoadMergedFromName Method

Loads the map with the specified name by merging any maps with this name found in the global map folder and local template folders.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static MapCollection LoadMergedFromName(
    string name,
    string baseDirectory = null
)
Public Shared Function LoadMergedFromName (
    name As String,
    Optional baseDirectory As String = Nothing
) As MapCollection

Parameters

name
Type: SystemString
The name of the map.
baseDirectory (Optional)
Type: SystemString
The base directory.

Return Value

Type: MapCollection
See Also

Reference

Map Class
CodeSmith.Engine Namespace


Map.ResolveMapNamePaths Method

MapResolveMapNamePaths Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static string[] ResolveMapNamePaths(
    string mapName,
    string baseDirectory
)
Public Shared Function ResolveMapNamePaths (
    mapName As String,
    baseDirectory As String
) As String()

Parameters

mapName
Type: SystemString
baseDirectory
Type: SystemString

Return Value

Type: String
See Also

Reference

Map Class
CodeSmith.Engine Namespace


Map.TryResolvePath Method

MapTryResolvePath Method

Tries the resolve path.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static bool TryResolvePath(
    string mapName,
    string baseDirectory,
    out string fullPath
)
Public Shared Function TryResolvePath (
    mapName As String,
    baseDirectory As String,
    <OutAttribute> ByRef fullPath As String
) As Boolean

Parameters

mapName
Type: SystemString
Name of the map.
baseDirectory
Type: SystemString
The base directory.
fullPath
Type: SystemString
The full path.

Return Value

Type: Boolean
See Also

Reference

Map Class
CodeSmith.Engine Namespace


Map Fields

The Map type exposes the following members.

Fields
Name | Description
DefaultExtension |
DefaultNamespace |
Top
See Also

Reference

Map Class
CodeSmith.Engine Namespace


Map.DefaultExtension Field

MapDefaultExtension Field

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public const string DefaultExtension = ".csmap"
Public Const DefaultExtension As String = ".csmap"

Field Value

Type: String
See Also

Reference

Map Class
CodeSmith.Engine Namespace


Map.DefaultNamespace Field

MapDefaultNamespace Field

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public const string DefaultNamespace = "http://www.codesmithtools.com/schema/csmap.xsd"
Public Const DefaultNamespace As String = "http://www.codesmithtools.com/schema/csmap.xsd"

Field Value

Type: String
See Also

Reference

Map Class
CodeSmith.Engine Namespace


MapCollection Class

Inheritance Hierarchy
SystemObject
CodeSmith.EngineMapCollection

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class MapCollection : IDictionary<string, string>,
    ICollection<KeyValuePair<string, string>>, IEnumerable<KeyValuePair<string, string>>,
    IEnumerable, IDictionary, ICollection, ISerializable, IDeserializationCallback
Public Class MapCollection
    Implements IDictionary(Of String, String),
    ICollection(Of KeyValuePair(Of String, String)), IEnumerable(Of KeyValuePair(Of String, String)),
    IEnumerable, IDictionary, ICollection, ISerializable, IDeserializationCallback

The MapCollection type exposes the following members.

Constructors
 | Name | Description
Public method | MapCollection | Initializes a new instance of the MapCollection class.
Public method | MapCollection(Boolean) | Initializes a new instance of the MapCollection class.
Public method | MapCollection(String) | Initializes a new instance of the MapCollection class.
Public method | MapCollection(String, Boolean) | Initializes a new instance of the MapCollection class.
Public method | MapCollection(String, Boolean, String) | Initializes a new instance of the MapCollection class.
Top
Properties
 | Name | Description
Public property | CaseSensitive | Whether the map lookups should be case Sensitive.
Public property | Count | Gets the number of elements contained in the ICollectionT.
Public property | DefaultValue | Gets or sets the default value for when the key is not found.
Public property | Description | Gets or sets the description.
Public property | FileName | Gets the name of the file.
Protected property | InnerDictionary |
Public property | ItemString | Gets or sets the String with the specified key.
Public property | ItemString, String | Gets the String with the specified key.
Public property | Keys | Gets an ICollectionT containing the keys of the IDictionaryTKey, TValue.
Public property | ReturnKeyWhenNotFound | Gets or sets a value indicating whether to return the key when its not found in the collection.
Public property | Reversed | Gets a value indicating whether this MapCollection key value pair is reversed.
Public property | Values | Gets an ICollectionT containing the values in the IDictionaryTKey, TValue.
Top
Methods
 | Name | Description
Public method | Add | Adds an element with the provided key and value to the IDictionaryTKey, TValue.
Public method | Clear | Removes all items from the ICollectionT.
Public method | ContainsKey | Determines whether the IDictionaryTKey, TValue contains an element with the specified key.
Public method | ContainsValue | Determines whether the specified value contains value.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Gets the enumerator.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Load(String) | Loads the specified map file name.
 | Load(String, Boolean) | Loads the specified map file name.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Merge | Merges two maps, any duplicates in the current map will be overridden.
Public method | OnDeserialization | Runs when the entire object graph has been deserialized.
Protected method | ParseFile |
Public method | Remove | Removes the element with the specified key from the IDictionaryTKey, TValue.
Public method | Save(String) | Saves the specified map file name.
Public method | Save(XmlWriter) |
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Public method | TryGetValue | Tries the get value.
Top
Extension Methods
 | Name | Description
Public Extension Method | AsIndexedEnumerableKeyValuePairString, String | Returns an IndexedEnumerable from any collection implementing IEnumerable<T> (Defined by IndexedEnumerable.)
Top
See Also

Reference

CodeSmith.Engine Namespace


MapCollection Constructor

Overload List
 | Name | Description
Public method | MapCollection | Initializes a new instance of the MapCollection class.
Public method | MapCollection(Boolean) | Initializes a new instance of the MapCollection class.
Public method | MapCollection(String) | Initializes a new instance of the MapCollection class.
Public method | MapCollection(String, Boolean) | Initializes a new instance of the MapCollection class.
Public method | MapCollection(String, Boolean, String) | Initializes a new instance of the MapCollection class.
Top
See Also

Reference

MapCollection Class
CodeSmith.Engine Namespace


MapCollection Constructor

Initializes a new instance of the MapCollection class.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public MapCollection()
Public Sub New
See Also

Reference

MapCollection Class
MapCollection Overload
CodeSmith.Engine Namespace


MapCollection Constructor (Boolean)

Initializes a new instance of the MapCollection class.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public MapCollection(
    bool caseSensitive
)
Public Sub New (
    caseSensitive As Boolean
)

Parameters

caseSensitive
Type: SystemBoolean
Whether map lookups should be case sensitive or not.
See Also

Reference

MapCollection Class
MapCollection Overload
CodeSmith.Engine Namespace


MapCollection Constructor (String)

Initializes a new instance of the MapCollection class.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public MapCollection(
    string mapFileName
)
Public Sub New (
    mapFileName As String
)

Parameters

mapFileName
Type: SystemString
Name of the map file.
See Also

Reference

MapCollection Class
MapCollection Overload
CodeSmith.Engine Namespace


MapCollection Constructor (String, Boolean)

Initializes a new instance of the MapCollection class.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public MapCollection(
    string mapFileName,
    bool reverse
)
Public Sub New (
    mapFileName As String,
    reverse As Boolean
)

Parameters

mapFileName
Type: SystemString
Name of the map file.
reverse
Type: SystemBoolean
if set to true the key and value will be reversed.
See Also

Reference

MapCollection Class
MapCollection Overload
CodeSmith.Engine Namespace


MapCollection Constructor (String, Boolean, String)

Initializes a new instance of the MapCollection class.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public MapCollection(
    string mapFileName,
    bool reverse,
    string defaultValue
)
Public Sub New (
    mapFileName As String,
    reverse As Boolean,
    defaultValue As String
)

Parameters

mapFileName
Type: SystemString
Name of the map file.
reverse
Type: SystemBoolean
if set to true the key and value will be reversed.
defaultValue
Type: SystemString
The default value.
See Also

Reference

MapCollection Class
MapCollection Overload
CodeSmith.Engine Namespace


MapCollection Properties

The MapCollection type exposes the following members.

Properties
 | Name | Description
Public property | CaseSensitive | Whether the map lookups should be case Sensitive.
Public property | Count | Gets the number of elements contained in the ICollectionT.
Public property | DefaultValue | Gets or sets the default value for when the key is not found.
Public property | Description | Gets or sets the description.
Public property | FileName | Gets the name of the file.
Protected property | InnerDictionary |
Public property | ItemString | Gets or sets the String with the specified key.
Public property | ItemString, String | Gets the String with the specified key.
Public property | Keys | Gets an ICollectionT containing the keys of the IDictionaryTKey, TValue.
Public property | ReturnKeyWhenNotFound | Gets or sets a value indicating whether to return the key when its not found in the collection.
Public property | Reversed | Gets a value indicating whether this MapCollection key value pair is reversed.
Public property | Values | Gets an ICollectionT containing the values in the IDictionaryTKey, TValue.
Top
See Also

Reference

MapCollection Class
CodeSmith.Engine Namespace


MapCollection.CaseSensitive Property

MapCollectionCaseSensitive Property

Whether the map lookups should be case Sensitive.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool CaseSensitive { get; }
Public ReadOnly Property CaseSensitive As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

MapCollection Class
CodeSmith.Engine Namespace


MapCollection.Count Property

MapCollectionCount Property

Gets the number of elements contained in the ICollectionT.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
The number of elements contained in the ICollectionT.

Implements

ICollectionTCount
ICollectionCount
See Also

Reference

MapCollection Class
CodeSmith.Engine Namespace


MapCollection.DefaultValue Property

MapCollectionDefaultValue Property

Gets or sets the default value for when the key is not found.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string DefaultValue { get; set; }
Public Property DefaultValue As String
    Get
    Set

Property Value

Type: String
The default value.
See Also

Reference

MapCollection Class
CodeSmith.Engine Namespace


MapCollection.Description Property

MapCollectionDescription Property

Gets or sets the description.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set

Property Value

Type: String
The description.
See Also

Reference

MapCollection Class
CodeSmith.Engine Namespace


MapCollection.FileName Property

MapCollectionFileName Property

Gets the name of the file.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string FileName { get; }
Public ReadOnly Property FileName As String
    Get

Property Value

Type: String
The name of the file.
See Also

Reference

MapCollection Class
CodeSmith.Engine Namespace


MapCollection.InnerDictionary Property

MapCollectionInnerDictionary Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected Dictionary<string, string> InnerDictionary { get; }
Protected ReadOnly Property InnerDictionary As Dictionary(Of String, String)
    Get

Property Value

Type: Dictionary String, String
See Also

Reference

MapCollection Class
CodeSmith.Engine Namespace


MapCollection.Item Property

MapCollectionItem Property

Overload List
 | Name | Description
Public property | ItemString | Gets or sets the String with the specified key.
Public property | ItemString, String | Gets the String with the specified key.
Top
See Also

Reference

MapCollection Class
CodeSmith.Engine Namespace


MapCollection.Item Property (String)

MapCollectionItem Property (String)

Gets or sets the String with the specified key.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string this[
    string key
] { get; set; }
Public Default Property Item (
    key As String
) As String
    Get
    Set

Parameters

key
Type: SystemString

Property Value

Type: String

Implements

IDictionaryTKey, TValueItemTKey
See Also

Reference

MapCollection Class
Item Overload
CodeSmith.Engine Namespace


MapCollection.Item Property (String, String)

MapCollectionItem Property (String, String)

Gets the String with the specified key.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string this[
    string key,
    string defaultValue
] { get; }
Public ReadOnly Default Property Item (
    key As String,
    defaultValue As String
) As String
    Get

Parameters

key
Type: SystemString
defaultValue
Type: SystemString

Property Value

Type: String
See Also

Reference

MapCollection Class
Item Overload
CodeSmith.Engine Namespace


MapCollection.Keys Property

MapCollectionKeys Property

Gets an ICollectionT containing the keys of the IDictionaryTKey, TValue.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ICollection<string> Keys { get; }
Public ReadOnly Property Keys As ICollection(Of String)
    Get

Property Value

Type: ICollection String

Return Value

Type: ICollection String
An ICollectionT containing the keys of the object that implements IDictionaryTKey, TValue.

Implements

IDictionaryTKey, TValueKeys
See Also

Reference

MapCollection Class
CodeSmith.Engine Namespace


MapCollection.ReturnKeyWhenNotFound Property

MapCollectionReturnKeyWhenNotFound Property

Gets or sets a value indicating whether to return the key when its not found in the collection.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool ReturnKeyWhenNotFound { get; set; }
Public Property ReturnKeyWhenNotFound As Boolean
    Get
    Set

Property Value

Type: Boolean
true to return the key; otherwise, false.
See Also

Reference

MapCollection Class
CodeSmith.Engine Namespace


MapCollection.Reversed Property

MapCollectionReversed Property

Gets a value indicating whether this MapCollection key value pair is reversed.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool Reversed { get; }
Public ReadOnly Property Reversed As Boolean
    Get

Property Value

Type: Boolean
true if reversed; otherwise, false.
See Also

Reference

MapCollection Class
CodeSmith.Engine Namespace


MapCollection.Values Property

MapCollectionValues Property

Gets an ICollectionT containing the values in the IDictionaryTKey, TValue.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ICollection<string> Values { get; }
Public ReadOnly Property Values As ICollection(Of String)
    Get

Property Value

Type: ICollection String

Return Value

Type: ICollection String
An ICollectionT containing the values in the object that implements IDictionaryTKey, TValue.

Implements

IDictionaryTKey, TValueValues
See Also

Reference

MapCollection Class
CodeSmith.Engine Namespace


MapCollection Methods

The MapCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an element with the provided key and value to the IDictionaryTKey, TValue.
Public method | Clear | Removes all items from the ICollectionT.
Public method | ContainsKey | Determines whether the IDictionaryTKey, TValue contains an element with the specified key.
Public method | ContainsValue | Determines whether the specified value contains value.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Gets the enumerator.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Load(String) | Loads the specified map file name.
 | Load(String, Boolean) | Loads the specified map file name.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Merge | Merges two maps, any duplicates in the current map will be overridden.
Public method | OnDeserialization | Runs when the entire object graph has been deserialized.
Protected method | ParseFile |
Public method | Remove | Removes the element with the specified key from the IDictionaryTKey, TValue.
Public method | Save(String) | Saves the specified map file name.
Public method | Save(XmlWriter) |
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Public method | TryGetValue | Tries the get value.
Top
Extension Methods
 | Name | Description
Public Extension Method | AsIndexedEnumerableKeyValuePairString, String | Returns an IndexedEnumerable from any collection implementing IEnumerable<T> (Defined by IndexedEnumerable.)
Top
See Also

Reference

MapCollection Class
CodeSmith.Engine Namespace


MapCollection.Add Method

MapCollectionAdd Method

Adds an element with the provided key and value to the IDictionaryTKey, TValue.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void Add(
    string key,
    string value
)
Public Sub Add (
    key As String,
    value As String
)

Parameters

key
Type: SystemString
The object to use as the key of the element to add.
value
Type: SystemString
The object to use as the value of the element to add.

Implements

IDictionaryTKey, TValueAdd(TKey, TValue)
Exceptions
Exception | Condition
NotSupportedException | The IDictionaryTKey, TValue is read-only.
ArgumentException | An element with the same key already exists in the IDictionaryTKey, TValue.
ArgumentNullException | key is null.
See Also

Reference

MapCollection Class
CodeSmith.Engine Namespace


MapCollection.Clear Method

MapCollectionClear Method

Removes all items from the ICollectionT.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void Clear()
Public Sub Clear

Implements

ICollectionTClear
IDictionaryClear
Exceptions
Exception | Condition
NotSupportedException | The ICollectionT is read-only.
See Also

Reference

MapCollection Class
CodeSmith.Engine Namespace


MapCollection.ContainsKey Method

MapCollectionContainsKey Method

Determines whether the IDictionaryTKey, TValue contains an element with the specified key.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool ContainsKey(
    string key
)
Public Function ContainsKey (
    key As String
) As Boolean

Parameters

key
Type: SystemString
The key to locate in the IDictionaryTKey, TValue.

Return Value

Type: Boolean
true if the IDictionaryTKey, TValue contains an element with the key; otherwise, false.

Implements

IDictionaryTKey, TValueContainsKey(TKey)
Exceptions
Exception | Condition
ArgumentNullException | key is null.
See Also

Reference

MapCollection Class
CodeSmith.Engine Namespace


MapCollection.ContainsValue Method

MapCollectionContainsValue Method

Determines whether the specified value contains value.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool ContainsValue(
    string value
)
Public Function ContainsValue (
    value As String
) As Boolean

Parameters

value
Type: SystemString
The value.

Return Value

Type: Boolean
true if the specified value contains value; otherwise, false.
See Also

Reference

MapCollection Class
CodeSmith.Engine Namespace


MapCollection.GetEnumerator Method

MapCollectionGetEnumerator Method

Gets the enumerator.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public DictionaryTKey, TValueEnumerator GetEnumerator()
Public Function GetEnumerator As DictionaryTKey, TValueEnumerator

Return Value

Type: DictionaryTKey, TValueEnumerator
See Also

Reference

MapCollection Class
CodeSmith.Engine Namespace


MapCollection.GetObjectData Method

MapCollectionGetObjectData Method

Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
SecurityException | The caller does not have the required permission.
See Also

Reference

MapCollection Class
CodeSmith.Engine Namespace


MapCollection.Load Method

MapCollectionLoad Method

Overload List
Name | Description
Load(String) | Loads the specified map file name.
Load(String, Boolean) | Loads the specified map file name.
Top
See Also

Reference

MapCollection Class
CodeSmith.Engine Namespace


MapCollection.Load Method (String)

MapCollectionLoad Method (String)

Loads the specified map file name.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static MapCollection Load(
    string mapFileName
)
Public Shared Function Load (
    mapFileName As String
) As MapCollection

Parameters

mapFileName
Type: SystemString
Name of the map file.

Return Value

Type: MapCollection
See Also

Reference

MapCollection Class
Load Overload
CodeSmith.Engine Namespace


MapCollection.Load Method (String, Boolean)

MapCollectionLoad Method (String, Boolean)

Loads the specified map file name.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static MapCollection Load(
    string mapFileName,
    bool reverse
)
Public Shared Function Load (
    mapFileName As String,
    reverse As Boolean
) As MapCollection

Parameters

mapFileName
Type: SystemString
Name of the map file.
reverse
Type: SystemBoolean
if set to true [reverse].

Return Value

Type: MapCollection
See Also

Reference

MapCollection Class
Load Overload
CodeSmith.Engine Namespace


MapCollection.Merge Method

MapCollectionMerge Method

Merges two maps, any duplicates in the current map will be overridden.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void Merge(
    MapCollection source
)
Public Sub Merge (
    source As MapCollection
)

Parameters

source
Type: CodeSmith.EngineMapCollection
The source MapCollection.
See Also

Reference

MapCollection Class
CodeSmith.Engine Namespace


MapCollection.OnDeserialization Method

MapCollectionOnDeserialization Method

Runs when the entire object graph has been deserialized.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void OnDeserialization(
    Object sender
)
Public Sub OnDeserialization (
    sender As Object
)

Parameters

sender
Type: SystemObject
The object that initiated the callback. The functionality for this parameter is not currently implemented.

Implements

IDeserializationCallbackOnDeserialization(Object)
See Also

Reference

MapCollection Class
CodeSmith.Engine Namespace


MapCollection.ParseFile Method

MapCollectionParseFile Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual void ParseFile(
    XmlReader reader
)
Protected Overridable Sub ParseFile (
    reader As XmlReader
)

Parameters

reader
Type: System.XmlXmlReader
See Also

Reference

MapCollection Class
CodeSmith.Engine Namespace


MapCollection.Remove Method

MapCollectionRemove Method

Removes the element with the specified key from the IDictionaryTKey, TValue.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool Remove(
    string key
)
Public Function Remove (
    key As String
) As Boolean

Parameters

key
Type: SystemString
The key of the element to remove.

Return Value

Type: Boolean
true if the element is successfully removed; otherwise, false. This method also returns false if key was not found in the original IDictionaryTKey, TValue.

Implements

IDictionaryTKey, TValueRemove(TKey)
Exceptions
Exception | Condition
NotSupportedException | The IDictionaryTKey, TValue is read-only.
ArgumentNullException | key is null.
See Also

Reference

MapCollection Class
CodeSmith.Engine Namespace


MapCollection.Save Method

MapCollectionSave Method

Overload List
 | Name | Description
Public method | Save(String) | Saves the specified map file name.
Public method | Save(XmlWriter) |
Top
See Also

Reference

MapCollection Class
CodeSmith.Engine Namespace


MapCollection.Save Method (String)

MapCollectionSave Method (String)

Saves the specified map file name.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void Save(
    string mapFileName
)
Public Sub Save (
    mapFileName As String
)

Parameters

mapFileName
Type: SystemString
Name of the map file.
See Also

Reference

MapCollection Class
Save Overload
CodeSmith.Engine Namespace


MapCollection.Save Method (XmlWriter)

MapCollectionSave Method (XmlWriter)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual void Save(
    XmlWriter writer
)
Public Overridable Sub Save (
    writer As XmlWriter
)

Parameters

writer
Type: System.XmlXmlWriter
See Also

Reference

MapCollection Class
Save Overload
CodeSmith.Engine Namespace


MapCollection.ToString Method

MapCollectionToString Method

Returns a String that represents the current Object.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String that represents the current Object.
See Also

Reference

MapCollection Class
CodeSmith.Engine Namespace


MapCollection.TryGetValue Method

MapCollectionTryGetValue Method

Tries the get value.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool TryGetValue(
    string key,
    out string value
)
Public Function TryGetValue (
    key As String,
    <OutAttribute> ByRef value As String
) As Boolean

Parameters

key
Type: SystemString
The key.
value
Type: SystemString
The value.

Return Value

Type: Boolean

Implements

IDictionaryTKey, TValueTryGetValue(TKey, TValue)
See Also

Reference

MapCollection Class
CodeSmith.Engine Namespace


MergeContext Class

Inheritance Hierarchy
SystemObject
CodeSmith.EngineMergeContext

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class MergeContext
Public Class MergeContext

The MergeContext type exposes the following members.

Constructors
 | Name | Description
Public method | MergeContext | Initializes a new instance of the MergeContext class
Top
Properties
 | Name | Description
Public property | OutputContent | The content that the template generated.
Public property | OutputFile | The file path that is being modified.
Public property | SourceContent | The previous content waiting to be merged.
Public property | Template |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSmith.Engine Namespace


MergeContext Constructor

Initializes a new instance of the MergeContext class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public MergeContext(
    CodeTemplate template,
    OutputFile outputFile,
    string sourceContent,
    string outputContent
)
Public Sub New (
    template As CodeTemplate,
    outputFile As OutputFile,
    sourceContent As String,
    outputContent As String
)

Parameters

template
Type: CodeSmith.EngineCodeTemplate
outputFile
Type: CodeSmith.EngineOutputFile
sourceContent
Type: SystemString
outputContent
Type: SystemString
See Also

Reference

MergeContext Class
CodeSmith.Engine Namespace


MergeContext Properties

The MergeContext type exposes the following members.

Properties
 | Name | Description
Public property | OutputContent | The content that the template generated.
Public property | OutputFile | The file path that is being modified.
Public property | SourceContent | The previous content waiting to be merged.
Public property | Template |
Top
See Also

Reference

MergeContext Class
CodeSmith.Engine Namespace


MergeContext.OutputContent Property

MergeContextOutputContent Property

The content that the template generated.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string OutputContent { get; }
Public ReadOnly Property OutputContent As String
    Get

Property Value

Type: String
See Also

Reference

MergeContext Class
CodeSmith.Engine Namespace


MergeContext.OutputFile Property

MergeContextOutputFile Property

The file path that is being modified.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public OutputFile OutputFile { get; }
Public ReadOnly Property OutputFile As OutputFile
    Get

Property Value

Type: OutputFile
See Also

Reference

MergeContext Class
CodeSmith.Engine Namespace


MergeContext.SourceContent Property

MergeContextSourceContent Property

The previous content waiting to be merged.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string SourceContent { get; }
Public ReadOnly Property SourceContent As String
    Get

Property Value

Type: String
See Also

Reference

MergeContext Class
CodeSmith.Engine Namespace


MergeContext.Template Property

MergeContextTemplate Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CodeTemplate Template { get; }
Public ReadOnly Property Template As CodeTemplate
    Get

Property Value

Type: CodeTemplate
See Also

Reference

MergeContext Class
CodeSmith.Engine Namespace


MergeContext Methods

The MergeContext type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MergeContext Class
CodeSmith.Engine Namespace


MergeStrategyAlias Class

Inheritance Hierarchy
SystemObject
CodeSmith.EngineConfigurationItemBase
CodeSmith.EngineMergeStrategyAlias

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class MergeStrategyAlias : ConfigurationItemBase
Public Class MergeStrategyAlias
    Inherits ConfigurationItemBase

The MergeStrategyAlias type exposes the following members.

Constructors
 | Name | Description
Public method | MergeStrategyAlias | Initializes a new instance of the MergeStrategyAlias class
Public method | MergeStrategyAlias(String, String) | Initializes a new instance of the MergeStrategyAlias class
Top
Properties
 | Name | Description
Public property | Index | Gets or sets the index. (Inherited from ConfigurationItemBase.)
Public property | Name | Gets or sets the name of the merge strategy alias.
Public property | TypeName | Gets or sets the fully qualified type name for the merge strategy.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | (Inherited from ConfigurationItemBase.)
Public method | ToString | (Overrides ObjectToString.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from ConfigurationItemBase.)
Top
See Also

Reference

CodeSmith.Engine Namespace


MergeStrategyAlias Constructor

Overload List
 | Name | Description
Public method | MergeStrategyAlias | Initializes a new instance of the MergeStrategyAlias class
Public method | MergeStrategyAlias(String, String) | Initializes a new instance of the MergeStrategyAlias class
Top
See Also

Reference

MergeStrategyAlias Class
CodeSmith.Engine Namespace


MergeStrategyAlias Constructor

Initializes a new instance of the MergeStrategyAlias class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public MergeStrategyAlias()
Public Sub New
See Also

Reference

MergeStrategyAlias Class
MergeStrategyAlias Overload
CodeSmith.Engine Namespace


MergeStrategyAlias Constructor (String, String)

Initializes a new instance of the MergeStrategyAlias class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public MergeStrategyAlias(
    string name,
    string typeName
)
Public Sub New (
    name As String,
    typeName As String
)

Parameters

name
Type: SystemString
typeName
Type: SystemString
See Also

Reference

MergeStrategyAlias Class
MergeStrategyAlias Overload
CodeSmith.Engine Namespace


MergeStrategyAlias Properties

The MergeStrategyAlias type exposes the following members.

Properties
 | Name | Description
Public property | Index | Gets or sets the index. (Inherited from ConfigurationItemBase.)
Public property | Name | Gets or sets the name of the merge strategy alias.
Public property | TypeName | Gets or sets the fully qualified type name for the merge strategy.
Top
See Also

Reference

MergeStrategyAlias Class
CodeSmith.Engine Namespace


MergeStrategyAlias.Name Property

MergeStrategyAliasName Property

Gets or sets the name of the merge strategy alias.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set

Property Value

Type: String
The merge strategy alias name.
See Also

Reference

MergeStrategyAlias Class
CodeSmith.Engine Namespace


MergeStrategyAlias.TypeName Property

MergeStrategyAliasTypeName Property

Gets or sets the fully qualified type name for the merge strategy.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string TypeName { get; set; }
Public Property TypeName As String
    Get
    Set

Property Value

Type: String
The name of the type.
See Also

Reference

MergeStrategyAlias Class
CodeSmith.Engine Namespace


MergeStrategyAlias Methods

The MergeStrategyAlias type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | (Inherited from ConfigurationItemBase.)
Public method | ToString | (Overrides ObjectToString.)
Top
See Also

Reference

MergeStrategyAlias Class
CodeSmith.Engine Namespace


MergeStrategyAlias.ToString Method

MergeStrategyAliasToString Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
See Also

Reference

MergeStrategyAlias Class
CodeSmith.Engine Namespace


MergeStrategyAlias Events

The MergeStrategyAlias type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from ConfigurationItemBase.)
Top
See Also

Reference

MergeStrategyAlias Class
CodeSmith.Engine Namespace


MergeStrategyAliasCollection Class

Inheritance Hierarchy
SystemObject
CodeSmith.EngineVirtualCollectionBase MergeStrategyAlias
CodeSmith.EngineConfigurationCollectionBase MergeStrategyAlias
CodeSmith.EngineMergeStrategyAliasCollection

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class MergeStrategyAliasCollection : ConfigurationCollectionBase<MergeStrategyAlias>
Public Class MergeStrategyAliasCollection
    Inherits ConfigurationCollectionBase(Of MergeStrategyAlias)

The MergeStrategyAliasCollection type exposes the following members.

Constructors
 | Name | Description
Public method | MergeStrategyAliasCollection | Initializes a new instance of the MergeStrategyAliasCollection class
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from VirtualCollectionBaseT.)
Public property | Item | Gets or sets the type T at the specified index. (Inherited from VirtualCollectionBaseT.)
Protected property | SubKey | (Overrides ConfigurationCollectionBaseTSubKey.)
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from VirtualCollectionBaseT.)
Protected method | AddItem | (Overrides VirtualCollectionBaseTAddItem(T).)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from VirtualCollectionBaseT.)
Protected method | ClearItems | (Inherited from ConfigurationCollectionBaseT.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from VirtualCollectionBaseT.)
Public method | CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from VirtualCollectionBaseT.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetCount | (Inherited from ConfigurationCollectionBaseT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from VirtualCollectionBaseT.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetIndex | (Overrides VirtualCollectionBaseTGetIndex(T).)
Protected method | GetItem | (Inherited from ConfigurationCollectionBaseT.)
Protected method | GetItemFromRegistry | (Overrides ConfigurationCollectionBaseTGetItemFromRegistry(Int32).)
Protected method | GetItems | (Inherited from ConfigurationCollectionBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from VirtualCollectionBaseT.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from VirtualCollectionBaseT.)
Protected method | InsertItem | (Inherited from ConfigurationCollectionBaseT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | (Inherited from ConfigurationCollectionBaseT.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from VirtualCollectionBaseT.)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from VirtualCollectionBaseT.)
Protected method | RemoveItem | (Inherited from ConfigurationCollectionBaseT.)
Protected method | SetItem | (Inherited from ConfigurationCollectionBaseT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSmith.Engine Namespace


MergeStrategyAliasCollection Constructor

Initializes a new instance of the MergeStrategyAliasCollection class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public MergeStrategyAliasCollection()
Public Sub New
See Also

Reference

MergeStrategyAliasCollection Class
CodeSmith.Engine Namespace


MergeStrategyAliasCollection Properties

The MergeStrategyAliasCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from VirtualCollectionBaseT.)
Public property | Item | Gets or sets the type T at the specified index. (Inherited from VirtualCollectionBaseT.)
Protected property | SubKey | (Overrides ConfigurationCollectionBaseTSubKey.)
Top
See Also

Reference

MergeStrategyAliasCollection Class
CodeSmith.Engine Namespace


MergeStrategyAliasCollection.SubKey Property

MergeStrategyAliasCollectionSubKey Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected override string SubKey { get; }
Protected Overrides ReadOnly Property SubKey As String
    Get

Property Value

Type: String
See Also

Reference

MergeStrategyAliasCollection Class
CodeSmith.Engine Namespace


MergeStrategyAliasCollection Methods

The MergeStrategyAliasCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from VirtualCollectionBaseT.)
Protected method | AddItem | (Overrides VirtualCollectionBaseTAddItem(T).)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from VirtualCollectionBaseT.)
Protected method | ClearItems | (Inherited from ConfigurationCollectionBaseT.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from VirtualCollectionBaseT.)
Public method | CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from VirtualCollectionBaseT.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetCount | (Inherited from ConfigurationCollectionBaseT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from VirtualCollectionBaseT.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetIndex | (Overrides VirtualCollectionBaseTGetIndex(T).)
Protected method | GetItem | (Inherited from ConfigurationCollectionBaseT.)
Protected method | GetItemFromRegistry | (Overrides ConfigurationCollectionBaseTGetItemFromRegistry(Int32).)
Protected method | GetItems | (Inherited from ConfigurationCollectionBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from VirtualCollectionBaseT.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from VirtualCollectionBaseT.)
Protected method | InsertItem | (Inherited from ConfigurationCollectionBaseT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | (Inherited from ConfigurationCollectionBaseT.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from VirtualCollectionBaseT.)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from VirtualCollectionBaseT.)
Protected method | RemoveItem | (Inherited from ConfigurationCollectionBaseT.)
Protected method | SetItem | (Inherited from ConfigurationCollectionBaseT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MergeStrategyAliasCollection Class
CodeSmith.Engine Namespace


MergeStrategyAliasCollection.AddItem Method

MergeStrategyAliasCollectionAddItem Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected override int AddItem(
    MergeStrategyAlias item
)
Protected Overrides Function AddItem (
    item As MergeStrategyAlias
) As Integer

Parameters

item
Type: CodeSmith.EngineMergeStrategyAlias

Return Value

Type: Int32
See Also

Reference

MergeStrategyAliasCollection Class
CodeSmith.Engine Namespace


MergeStrategyAliasCollection.GetIndex Method

MergeStrategyAliasCollectionGetIndex Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected override int GetIndex(
    MergeStrategyAlias item
)
Protected Overrides Function GetIndex (
    item As MergeStrategyAlias
) As Integer

Parameters

item
Type: CodeSmith.EngineMergeStrategyAlias

Return Value

Type: Int32
See Also

Reference

MergeStrategyAliasCollection Class
CodeSmith.Engine Namespace


MergeStrategyAliasCollection.GetItemFromRegistry Method

MergeStrategyAliasCollectionGetItemFromRegistry Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected override MergeStrategyAlias GetItemFromRegistry(
    int index
)
Protected Overrides Function GetItemFromRegistry (
    index As Integer
) As MergeStrategyAlias

Parameters

index
Type: SystemInt32

Return Value

Type: MergeStrategyAlias
See Also

Reference

MergeStrategyAliasCollection Class
CodeSmith.Engine Namespace


MessageEventArgs Class

EventArgs derived type which holds the custom event fields
Inheritance Hierarchy
SystemObject
SystemEventArgs
CodeSmith.EngineMessageEventArgs

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
public class MessageEventArgs : EventArgs
<SerializableAttribute>
Public Class MessageEventArgs
    Inherits EventArgs

The MessageEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | MessageEventArgs | Initializes a new instance of the MessageEventArgs class
Public method | MessageEventArgs(String) | Use this constructor to initialize the event arguments object with the custom event fields
Top
Properties
 | Name | Description
Public property | Message |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides ObjectToString.)
Top
See Also

Reference

CodeSmith.Engine Namespace


MessageEventArgs Constructor

Overload List
 | Name | Description
Public method | MessageEventArgs | Initializes a new instance of the MessageEventArgs class
Public method | MessageEventArgs(String) | Use this constructor to initialize the event arguments object with the custom event fields
Top
See Also

Reference

MessageEventArgs Class
CodeSmith.Engine Namespace


MessageEventArgs Constructor

Initializes a new instance of the MessageEventArgs class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public MessageEventArgs()
Public Sub New
See Also

Reference

MessageEventArgs Class
MessageEventArgs Overload
CodeSmith.Engine Namespace


MessageEventArgs Constructor (String)

Use this constructor to initialize the event arguments object with the custom event fields

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public MessageEventArgs(
    string message
)
Public Sub New (
    message As String
)

Parameters

message
Type: SystemString
See Also

Reference

MessageEventArgs Class
MessageEventArgs Overload
CodeSmith.Engine Namespace


MessageEventArgs Properties

The MessageEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Message |
Top
See Also

Reference

MessageEventArgs Class
CodeSmith.Engine Namespace


MessageEventArgs.Message Property

MessageEventArgsMessage Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string Message { get; set; }
Public Property Message As String
    Get
    Set

Property Value

Type: String
See Also

Reference

MessageEventArgs Class
CodeSmith.Engine Namespace


MessageEventArgs Methods

The MessageEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides ObjectToString.)
Top
See Also

Reference

MessageEventArgs Class
CodeSmith.Engine Namespace


MessageEventArgs.ToString Method

MessageEventArgsToString Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
See Also

Reference

MessageEventArgs Class
CodeSmith.Engine Namespace


MessageEventHandler Delegate

This represents the delegate method prototype that event receivers must implement

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public delegate void MessageEventHandler(
    Object sender,
    MessageEventArgs e
)
Public Delegate Sub MessageEventHandler (
    sender As Object,
    e As MessageEventArgs
)

Parameters

sender
Type: SystemObject
e
Type: CodeSmith.EngineMessageEventArgs
See Also

Reference

CodeSmith.Engine Namespace


MethodPropertyRefresher Class

Inheritance Hierarchy
SystemObject
CodeSmith.EngineMethodPropertyRefresher

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class MethodPropertyRefresher : IPropertyRefresher
Public Class MethodPropertyRefresher
    Implements IPropertyRefresher

The MethodPropertyRefresher type exposes the following members.

Constructors
 | Name | Description
Public method | MethodPropertyRefresher | Initializes a new instance of the MethodPropertyRefresher class
Public method | MethodPropertyRefresher(String) | Initializes a new instance of the MethodPropertyRefresher class
Top
Properties
 | Name | Description
Public property | MethodName |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSmith.Engine Namespace


MethodPropertyRefresher Constructor

Overload List
 | Name | Description
Public method | MethodPropertyRefresher | Initializes a new instance of the MethodPropertyRefresher class
Public method | MethodPropertyRefresher(String) | Initializes a new instance of the MethodPropertyRefresher class
Top
See Also

Reference

MethodPropertyRefresher Class
CodeSmith.Engine Namespace


MethodPropertyRefresher Constructor

Initializes a new instance of the MethodPropertyRefresher class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public MethodPropertyRefresher()
Public Sub New
See Also

Reference

MethodPropertyRefresher Class
MethodPropertyRefresher Overload
CodeSmith.Engine Namespace


MethodPropertyRefresher Constructor (String)

Initializes a new instance of the MethodPropertyRefresher class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public MethodPropertyRefresher(
    string methodName
)
Public Sub New (
    methodName As String
)

Parameters

methodName
Type: SystemString
See Also

Reference

MethodPropertyRefresher Class
MethodPropertyRefresher Overload
CodeSmith.Engine Namespace


MethodPropertyRefresher Properties

The MethodPropertyRefresher type exposes the following members.

Properties
 | Name | Description
Public property | MethodName |
Top
See Also

Reference

MethodPropertyRefresher Class
CodeSmith.Engine Namespace


MethodPropertyRefresher.MethodName Property

MethodPropertyRefresherMethodName Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string MethodName { get; set; }
Public Property MethodName As String
    Get
    Set

Property Value

Type: String
See Also

Reference

MethodPropertyRefresher Class
CodeSmith.Engine Namespace


MethodPropertyRefresher Methods

The MethodPropertyRefresher type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MethodPropertyRefresher Class
CodeSmith.Engine Namespace


MethodPropertyRefresher.Refresh Method

MethodPropertyRefresherRefresh Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public Object Refresh(
    PropertyRefresherContext context
)
Public Function Refresh (
    context As PropertyRefresherContext
) As Object

Parameters

context
Type: CodeSmith.EnginePropertyRefresherContext

Return Value

Type: Object

Implements

IPropertyRefresherRefresh(PropertyRefresherContext)
See Also

Reference

MethodPropertyRefresher Class
CodeSmith.Engine Namespace


NotCheckedAttribute Class

Excludes a property from being required.
Inheritance Hierarchy
SystemObject
SystemAttribute
CodeSmith.EngineNotCheckedAttribute

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
public sealed class NotCheckedAttribute : Attribute
<SerializableAttribute>
Public NotInheritable Class NotCheckedAttribute
    Inherits Attribute

The NotCheckedAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | NotCheckedAttribute | Initializes a new instance of the NotCheckedAttribute class
Top
Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSmith.Engine Namespace


NotCheckedAttribute Constructor

Initializes a new instance of the NotCheckedAttribute class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public NotCheckedAttribute()
Public Sub New
See Also

Reference

NotCheckedAttribute Class
CodeSmith.Engine Namespace


NotCheckedAttribute Properties

The NotCheckedAttribute type exposes the following members.

Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

NotCheckedAttribute Class
CodeSmith.Engine Namespace


NotCheckedAttribute Methods

The NotCheckedAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

NotCheckedAttribute Class
CodeSmith.Engine Namespace


OptionalAttribute Class

Marks a property as optional.
Inheritance Hierarchy
SystemObject
SystemAttribute
CodeSmith.EngineOptionalAttribute

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
public sealed class OptionalAttribute : Attribute
<SerializableAttribute>
Public NotInheritable Class OptionalAttribute
    Inherits Attribute

The OptionalAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | OptionalAttribute | Initializes a new instance of the OptionalAttribute class
Top
Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSmith.Engine Namespace


OptionalAttribute Constructor

Initializes a new instance of the OptionalAttribute class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public OptionalAttribute()
Public Sub New
See Also

Reference

OptionalAttribute Class
CodeSmith.Engine Namespace


OptionalAttribute Properties

The OptionalAttribute type exposes the following members.

Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

OptionalAttribute Class
CodeSmith.Engine Namespace


OptionalAttribute Methods

The OptionalAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OptionalAttribute Class
CodeSmith.Engine Namespace


OutputCancelEventArgs Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
CodeSmith.EngineOutputRegisteredEventArgs
CodeSmith.EngineOutputCancelEventArgs

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
public class OutputCancelEventArgs : OutputRegisteredEventArgs
<SerializableAttribute>
Public Class OutputCancelEventArgs
    Inherits OutputRegisteredEventArgs

The OutputCancelEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | OutputCancelEventArgs | Initializes a new instance of the OutputCancelEventArgs class.
Public method | OutputCancelEventArgs(OutputFile) | Initializes a new instance of the OutputCancelEventArgs class.
Public method | OutputCancelEventArgs(String) | Initializes a new instance of the OutputCancelEventArgs class.
Top
Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether this output is canceled
Public property | OutputFile | Gets or sets the output file. (Inherited from OutputRegisteredEventArgs.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSmith.Engine Namespace


OutputCancelEventArgs Constructor

Overload List
 | Name | Description
Public method | OutputCancelEventArgs | Initializes a new instance of the OutputCancelEventArgs class.
Public method | OutputCancelEventArgs(OutputFile) | Initializes a new instance of the OutputCancelEventArgs class.
Public method | OutputCancelEventArgs(String) | Initializes a new instance of the OutputCancelEventArgs class.
Top
See Also

Reference

OutputCancelEventArgs Class
CodeSmith.Engine Namespace


OutputCancelEventArgs Constructor

Initializes a new instance of the OutputCancelEventArgs class.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public OutputCancelEventArgs()
Public Sub New
See Also

Reference

OutputCancelEventArgs Class
OutputCancelEventArgs Overload
CodeSmith.Engine Namespace


OutputCancelEventArgs Constructor (OutputFile)

Initializes a new instance of the OutputCancelEventArgs class.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public OutputCancelEventArgs(
    OutputFile outputFile
)
Public Sub New (
    outputFile As OutputFile
)

Parameters

outputFile
Type: CodeSmith.EngineOutputFile
The output file.
See Also

Reference

OutputCancelEventArgs Class
OutputCancelEventArgs Overload
CodeSmith.Engine Namespace


OutputCancelEventArgs Constructor (String)

Initializes a new instance of the OutputCancelEventArgs class.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public OutputCancelEventArgs(
    string outputFile
)
Public Sub New (
    outputFile As String
)

Parameters

outputFile
Type: SystemString
See Also

Reference

OutputCancelEventArgs Class
OutputCancelEventArgs Overload
CodeSmith.Engine Namespace


OutputCancelEventArgs Properties

The OutputCancelEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether this output is canceled
Public property | OutputFile | Gets or sets the output file. (Inherited from OutputRegisteredEventArgs.)
Top
See Also

Reference

OutputCancelEventArgs Class
CodeSmith.Engine Namespace


OutputCancelEventArgs.Cancel Property

OutputCancelEventArgsCancel Property

Gets or sets a value indicating whether this output is canceled

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool Cancel { get; set; }
Public Property Cancel As Boolean
    Get
    Set

Property Value

Type: Boolean
true if cancel; otherwise, false.
See Also

Reference

OutputCancelEventArgs Class
CodeSmith.Engine Namespace


OutputCancelEventArgs Methods

The OutputCancelEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OutputCancelEventArgs Class
CodeSmith.Engine Namespace


OutputCancelEventHandler Delegate

This represents the delegate method prototype that event receivers must implement

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public delegate void OutputCancelEventHandler(
    Object sender,
    OutputCancelEventArgs args
)
Public Delegate Sub OutputCancelEventHandler (
    sender As Object,
    args As OutputCancelEventArgs
)

Parameters

sender
Type: SystemObject
args
Type: CodeSmith.EngineOutputCancelEventArgs
See Also

Reference

CodeSmith.Engine Namespace


OutputFile Class

A class representing a template output file.
Inheritance Hierarchy
SystemObject
CodeSmith.EngineOutputFile

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
public class OutputFile : IComparable, IComparable<string>,
    IComparable<OutputFile>, IEquatable<string>, IEquatable<OutputFile>
<SerializableAttribute>
Public Class OutputFile
    Implements IComparable, IComparable(Of String),
    IComparable(Of OutputFile), IEquatable(Of String), IEquatable(Of OutputFile)

The OutputFile type exposes the following members.

Constructors
 | Name | Description
Public method | OutputFile | Initializes a new instance of the OutputFile class
Public method | OutputFile(String) | Initializes a new instance of the OutputFile class.
Public method | OutputFile(String, IDictionaryString, Object) | Initializes a new instance of the OutputFile class.
Public method | OutputFile(String, String) | Initializes a new instance of the OutputFile class.
Public method | OutputFile(String, String, IDictionaryString, Object) | Initializes a new instance of the OutputFile class.
Top
Properties
 | Name | Description
Public property | DependentUpon | Gets or sets the dependent upon file.
Public property | Metadata | Gets the metadata.
Public property | OutputFileName | Gets the name of the output file.
Top
Methods
 | Name | Description
Public method | CompareTo(OutputFile) |
Public method | CompareTo(String) |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(OutputFile) |
Public method | Equals(String) |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides ObjectToString.)
Top
Operators
Name | Description
(OutputFile to String) | Performs an implicit conversion from OutputFile to String.
(String to OutputFile) | Performs an implicit conversion from String to OutputFile.
Top
See Also

Reference

CodeSmith.Engine Namespace


OutputFile Constructor

Overload List
 | Name | Description
Public method | OutputFile | Initializes a new instance of the OutputFile class
Public method | OutputFile(String) | Initializes a new instance of the OutputFile class.
Public method | OutputFile(String, IDictionaryString, Object) | Initializes a new instance of the OutputFile class.
Public method | OutputFile(String, String) | Initializes a new instance of the OutputFile class.
Public method | OutputFile(String, String, IDictionaryString, Object) | Initializes a new instance of the OutputFile class.
Top
See Also

Reference

OutputFile Class
CodeSmith.Engine Namespace


OutputFile Constructor

Initializes a new instance of the OutputFile class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public OutputFile()
Public Sub New
See Also

Reference

OutputFile Class
OutputFile Overload
CodeSmith.Engine Namespace


OutputFile Constructor (String)

Initializes a new instance of the OutputFile class.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public OutputFile(
    string outputFile
)
Public Sub New (
    outputFile As String
)

Parameters

outputFile
Type: SystemString
The output file.
See Also

Reference

OutputFile Class
OutputFile Overload
CodeSmith.Engine Namespace


OutputFile Constructor (String, IDictionary(String, Object))

OutputFile Constructor (String, IDictionaryString, Object)

Initializes a new instance of the OutputFile class.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public OutputFile(
    string outputFile,
    IDictionary<string, Object> metadata
)
Public Sub New (
    outputFile As String,
    metadata As IDictionary(Of String, Object)
)

Parameters

outputFile
Type: SystemString
The output file.
metadata
Type: System.Collections.GenericIDictionary String, Object
The metadata.
See Also

Reference

OutputFile Class
OutputFile Overload
CodeSmith.Engine Namespace


OutputFile Constructor (String, String)

Initializes a new instance of the OutputFile class.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public OutputFile(
    string outputFile,
    string dependentUpon
)
Public Sub New (
    outputFile As String,
    dependentUpon As String
)

Parameters

outputFile
Type: SystemString
The output file.
dependentUpon
Type: SystemString
The file that output is dependent upon.
See Also

Reference

OutputFile Class
OutputFile Overload
CodeSmith.Engine Namespace


OutputFile Constructor (String, String, IDictionary(String, Object))

OutputFile Constructor (String, String, IDictionaryString, Object)

Initializes a new instance of the OutputFile class.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public OutputFile(
    string outputFile,
    string dependentUpon,
    IDictionary<string, Object> metadata
)
Public Sub New (
    outputFile As String,
    dependentUpon As String,
    metadata As IDictionary(Of String, Object)
)

Parameters

outputFile
Type: SystemString
The output file.
dependentUpon
Type: SystemString
The file that output is dependent upon.
metadata
Type: System.Collections.GenericIDictionary String, Object
The metadata.
See Also

Reference

OutputFile Class
OutputFile Overload
CodeSmith.Engine Namespace


OutputFile Properties

The OutputFile type exposes the following members.

Properties
 | Name | Description
Public property | DependentUpon | Gets or sets the dependent upon file.
Public property | Metadata | Gets the metadata.
Public property | OutputFileName | Gets the name of the output file.
Top
See Also

Reference

OutputFile Class
CodeSmith.Engine Namespace


OutputFile.DependentUpon Property

OutputFileDependentUpon Property

Gets or sets the dependent upon file.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string DependentUpon { get; set; }
Public Property DependentUpon As String
    Get
    Set

Property Value

Type: String
The dependent upon file.
See Also

Reference

OutputFile Class
CodeSmith.Engine Namespace


OutputFile.Metadata Property

OutputFileMetadata Property

Gets the metadata.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public IDictionary<string, Object> Metadata { get; }
Public ReadOnly Property Metadata As IDictionary(Of String, Object)
    Get

Property Value

Type: IDictionary String, Object
The metadata.
See Also

Reference

OutputFile Class
CodeSmith.Engine Namespace


OutputFile.OutputFileName Property

OutputFileOutputFileName Property

Gets the name of the output file.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string OutputFileName { get; set; }
Public Property OutputFileName As String
    Get
    Set

Property Value

Type: String
The name of the output file.
See Also

Reference

OutputFile Class
CodeSmith.Engine Namespace


OutputFile Methods

The OutputFile type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(OutputFile) |
Public method | CompareTo(String) |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(OutputFile) |
Public method | Equals(String) |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides ObjectToString.)
Top
See Also

Reference

OutputFile Class
CodeSmith.Engine Namespace


OutputFile.CompareTo Method

OutputFileCompareTo Method

Overload List
 | Name | Description
Public method | CompareTo(OutputFile) |
Public method | CompareTo(String) |
Top
See Also

Reference

OutputFile Class
CodeSmith.Engine Namespace


OutputFile.CompareTo Method (OutputFile)

OutputFileCompareTo Method (OutputFile)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public int CompareTo(
    OutputFile other
)
Public Function CompareTo (
    other As OutputFile
) As Integer

Parameters

other
Type: CodeSmith.EngineOutputFile

Return Value

Type: Int32

Implements

IComparableTCompareTo(T)
See Also

Reference

OutputFile Class
CompareTo Overload
CodeSmith.Engine Namespace


OutputFile.CompareTo Method (String)

OutputFileCompareTo Method (String)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public int CompareTo(
    string other
)
Public Function CompareTo (
    other As String
) As Integer

Parameters

other
Type: SystemString

Return Value

Type: Int32

Implements

IComparableTCompareTo(T)
See Also

Reference

OutputFile Class
CompareTo Overload
CodeSmith.Engine Namespace


OutputFile.Equals Method

OutputFileEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(OutputFile) |
Public method | Equals(String) |
Top
See Also

Reference

OutputFile Class
CodeSmith.Engine Namespace


OutputFile.Equals Method (Object)

OutputFileEquals Method (Object)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject

Return Value

Type: Boolean
See Also

Reference

OutputFile Class
Equals Overload
CodeSmith.Engine Namespace


OutputFile.Equals Method (OutputFile)

OutputFileEquals Method (OutputFile)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool Equals(
    OutputFile other
)
Public Function Equals (
    other As OutputFile
) As Boolean

Parameters

other
Type: CodeSmith.EngineOutputFile

Return Value

Type: Boolean

Implements

IEquatableTEquals(T)
See Also

Reference

OutputFile Class
Equals Overload
CodeSmith.Engine Namespace


OutputFile.Equals Method (String)

OutputFileEquals Method (String)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool Equals(
    string other
)
Public Function Equals (
    other As String
) As Boolean

Parameters

other
Type: SystemString

Return Value

Type: Boolean

Implements

IEquatableTEquals(T)
See Also

Reference

OutputFile Class
Equals Overload
CodeSmith.Engine Namespace


OutputFile.GetHashCode Method

OutputFileGetHashCode Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
See Also

Reference

OutputFile Class
CodeSmith.Engine Namespace


OutputFile.ToString Method

OutputFileToString Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
See Also

Reference

OutputFile Class
CodeSmith.Engine Namespace


OutputFile Type Conversions

Operators
Name | Description
(OutputFile to String) | Performs an implicit conversion from OutputFile to String.
(String to OutputFile) | Performs an implicit conversion from String to OutputFile.
Top
See Also

Reference

OutputFile Class
CodeSmith.Engine Namespace


OutputFile Implicit Conversion Operators

OutputFile Conversion Operators

Overload List
Name | Description
(OutputFile to String) | Performs an implicit conversion from OutputFile to String.
(String to OutputFile) | Performs an implicit conversion from String to OutputFile.
Top
See Also

Reference

OutputFile Class
CodeSmith.Engine Namespace


OutputFile Implicit Conversion (OutputFile to String)

OutputFile Conversion (OutputFile to String)

Performs an implicit conversion from OutputFile to String.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static implicit operator string (
    OutputFile outputFile
)
Public Shared Widening Operator CType (
    outputFile As OutputFile
) As String

Parameters

outputFile
Type: CodeSmith.EngineOutputFile
The output file.

Return Value

Type: String
The result of the conversion.
See Also

Reference

OutputFile Class
Overload
CodeSmith.Engine Namespace


OutputFile Implicit Conversion (String to OutputFile)

OutputFile Conversion (String to OutputFile)

Performs an implicit conversion from String to OutputFile.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static implicit operator OutputFile (
    string outputFile
)
Public Shared Widening Operator CType (
    outputFile As String
) As OutputFile

Parameters

outputFile
Type: SystemString
The output file.

Return Value

Type: OutputFile
The result of the conversion.
See Also

Reference

OutputFile Class
Overload
CodeSmith.Engine Namespace


OutputLanguage Enumeration

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public enum OutputLanguage
Public Enumeration OutputLanguage
Members
Member name | Value | Description
CS | 0 |
VB | 1 |
See Also

Reference

CodeSmith.Engine Namespace


OutputRegisteredEventArgs Class

EventArgs derived type which holds the custom event fields
Inheritance Hierarchy
SystemObject
SystemEventArgs
CodeSmith.EngineOutputRegisteredEventArgs
CodeSmith.EngineOutputCancelEventArgs

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
public class OutputRegisteredEventArgs : EventArgs
<SerializableAttribute>
Public Class OutputRegisteredEventArgs
    Inherits EventArgs

The OutputRegisteredEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | OutputRegisteredEventArgs | Initializes a new instance of the OutputRegisteredEventArgs class
Public method | OutputRegisteredEventArgs(OutputFile) | Initializes a new instance of the OutputRegisteredEventArgs class.
Public method | OutputRegisteredEventArgs(String) | Initializes a new instance of the OutputRegisteredEventArgs class.
Top
Properties
 | Name | Description
Public property | OutputFile | Gets or sets the output file.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSmith.Engine Namespace


OutputRegisteredEventArgs Constructor

Overload List
 | Name | Description
Public method | OutputRegisteredEventArgs | Initializes a new instance of the OutputRegisteredEventArgs class
Public method | OutputRegisteredEventArgs(OutputFile) | Initializes a new instance of the OutputRegisteredEventArgs class.
Public method | OutputRegisteredEventArgs(String) | Initializes a new instance of the OutputRegisteredEventArgs class.
Top
See Also

Reference

OutputRegisteredEventArgs Class
CodeSmith.Engine Namespace


OutputRegisteredEventArgs Constructor

Initializes a new instance of the OutputRegisteredEventArgs class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public OutputRegisteredEventArgs()
Public Sub New
See Also

Reference

OutputRegisteredEventArgs Class
OutputRegisteredEventArgs Overload
CodeSmith.Engine Namespace


OutputRegisteredEventArgs Constructor (OutputFile)

Initializes a new instance of the OutputRegisteredEventArgs class.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public OutputRegisteredEventArgs(
    OutputFile outputFile
)
Public Sub New (
    outputFile As OutputFile
)

Parameters

outputFile
Type: CodeSmith.EngineOutputFile
The output file.
See Also

Reference

OutputRegisteredEventArgs Class
OutputRegisteredEventArgs Overload
CodeSmith.Engine Namespace


OutputRegisteredEventArgs Constructor (String)

Initializes a new instance of the OutputRegisteredEventArgs class.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public OutputRegisteredEventArgs(
    string outputFile
)
Public Sub New (
    outputFile As String
)

Parameters

outputFile
Type: SystemString
The output file.
See Also

Reference

OutputRegisteredEventArgs Class
OutputRegisteredEventArgs Overload
CodeSmith.Engine Namespace


OutputRegisteredEventArgs Properties

The OutputRegisteredEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | OutputFile | Gets or sets the output file.
Top
See Also

Reference

OutputRegisteredEventArgs Class
CodeSmith.Engine Namespace


OutputRegisteredEventArgs.OutputFile Property

OutputRegisteredEventArgsOutputFile Property

Gets or sets the output file.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public OutputFile OutputFile { get; set; }
Public Property OutputFile As OutputFile
    Get
    Set

Property Value

Type: OutputFile
The output file.
See Also

Reference

OutputRegisteredEventArgs Class
CodeSmith.Engine Namespace


OutputRegisteredEventArgs Methods

The OutputRegisteredEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OutputRegisteredEventArgs Class
CodeSmith.Engine Namespace


OutputRegisteredEventHandler Delegate

This represents the delegate method prototype that event receivers must implement

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public delegate void OutputRegisteredEventHandler(
    Object sender,
    OutputRegisteredEventArgs args
)
Public Delegate Sub OutputRegisteredEventHandler (
    sender As Object,
    args As OutputRegisteredEventArgs
)

Parameters

sender
Type: SystemObject
args
Type: CodeSmith.EngineOutputRegisteredEventArgs
See Also

Reference

CodeSmith.Engine Namespace


PreserveRegionsMergeStrategy Class

This merge strategy can be used to preserve designated custom regions inside an existing file and regenerate the rest of the content in the file. The initialization string should be of the format: "RegionNameRegex=<RegexExpression>;Language=<Language>"
Inheritance Hierarchy
SystemObject
CodeSmith.EnginePreserveRegionsMergeStrategy

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class PreserveRegionsMergeStrategy : IMergeStrategy
Public Class PreserveRegionsMergeStrategy
    Implements IMergeStrategy

The PreserveRegionsMergeStrategy type exposes the following members.

Constructors
 | Name | Description
Public method | PreserveRegionsMergeStrategy | Initializes a new instance of the PreserveRegionsMergeStrategy class
Public method | PreserveRegionsMergeStrategy(String) | Initializes a new instance of the PreserveRegionsMergeStrategy class
Public method | PreserveRegionsMergeStrategy(String, String) | Initializes a new instance of the PreserveRegionsMergeStrategy class
Top
Properties
 | Name | Description
Public property | Language |
Public property | RegionNameRegex |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Init |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Merge |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSmith.Engine Namespace


PreserveRegionsMergeStrategy Constructor

Overload List
 | Name | Description
Public method | PreserveRegionsMergeStrategy | Initializes a new instance of the PreserveRegionsMergeStrategy class
Public method | PreserveRegionsMergeStrategy(String) | Initializes a new instance of the PreserveRegionsMergeStrategy class
Public method | PreserveRegionsMergeStrategy(String, String) | Initializes a new instance of the PreserveRegionsMergeStrategy class
Top
See Also

Reference

PreserveRegionsMergeStrategy Class
CodeSmith.Engine Namespace


PreserveRegionsMergeStrategy Constructor

Initializes a new instance of the PreserveRegionsMergeStrategy class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public PreserveRegionsMergeStrategy()
Public Sub New
See Also

Reference

PreserveRegionsMergeStrategy Class
PreserveRegionsMergeStrategy Overload
CodeSmith.Engine Namespace


PreserveRegionsMergeStrategy Constructor (String)

Initializes a new instance of the PreserveRegionsMergeStrategy class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public PreserveRegionsMergeStrategy(
    string regionNameRegex
)
Public Sub New (
    regionNameRegex As String
)

Parameters

regionNameRegex
Type: SystemString
See Also

Reference

PreserveRegionsMergeStrategy Class
PreserveRegionsMergeStrategy Overload
CodeSmith.Engine Namespace


PreserveRegionsMergeStrategy Constructor (String, String)

Initializes a new instance of the PreserveRegionsMergeStrategy class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public PreserveRegionsMergeStrategy(
    string regionNameRegex,
    string language
)
Public Sub New (
    regionNameRegex As String,
    language As String
)

Parameters

regionNameRegex
Type: SystemString
language
Type: SystemString
See Also

Reference

PreserveRegionsMergeStrategy Class
PreserveRegionsMergeStrategy Overload
CodeSmith.Engine Namespace


PreserveRegionsMergeStrategy Properties

The PreserveRegionsMergeStrategy type exposes the following members.

Properties
 | Name | Description
Public property | Language |
Public property | RegionNameRegex |
Top
See Also

Reference

PreserveRegionsMergeStrategy Class
CodeSmith.Engine Namespace


PreserveRegionsMergeStrategy.Language Property

PreserveRegionsMergeStrategyLanguage Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string Language { get; set; }
Public Property Language As String
    Get
    Set

Property Value

Type: String
See Also

Reference

PreserveRegionsMergeStrategy Class
CodeSmith.Engine Namespace


PreserveRegionsMergeStrategy.RegionNameRegex Property

PreserveRegionsMergeStrategyRegionNameRegex Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string RegionNameRegex { get; set; }
Public Property RegionNameRegex As String
    Get
    Set

Property Value

Type: String
See Also

Reference

PreserveRegionsMergeStrategy Class
CodeSmith.Engine Namespace


PreserveRegionsMergeStrategy Methods

The PreserveRegionsMergeStrategy type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Init |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Merge |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PreserveRegionsMergeStrategy Class
CodeSmith.Engine Namespace


PreserveRegionsMergeStrategy.Init Method

PreserveRegionsMergeStrategyInit Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void Init(
    string init
)
Public Sub Init (
    init As String
)

Parameters

init
Type: SystemString

Implements

IMergeStrategyInit(String)
See Also

Reference

PreserveRegionsMergeStrategy Class
CodeSmith.Engine Namespace


PreserveRegionsMergeStrategy.Merge Method

PreserveRegionsMergeStrategyMerge Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string Merge(
    MergeContext context
)
Public Function Merge (
    context As MergeContext
) As String

Parameters

context
Type: CodeSmith.EngineMergeContext

Return Value

Type: String

Implements

IMergeStrategyMerge(MergeContext)
See Also

Reference

PreserveRegionsMergeStrategy Class
CodeSmith.Engine Namespace


Progress Class

Progress information.
Inheritance Hierarchy
SystemObject
CodeSmith.EngineProgress

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class Progress
Public Class Progress

The Progress type exposes the following members.

Constructors
 | Name | Description
Public method | Progress | Initializes a new instance of the Progress class
Top
Properties
 | Name | Description
Public property | MaximumValue | Maximum progress value.
Public property | MinimumValue | Minimum progress value.
Public property | Status | Current status for the operation.
Public property | Step | Gets or sets the step increment value.
Public property | Value | Gets or sets the current progress value.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Increment | Increments the current progress value by the specified amount.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PerformStep | Performs a progress step.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | OnProgress | Occurs when the progress value has been changed.
Public event | OnStatusChanged | Occurs when the progress value has been changed.
Top
See Also

Reference

CodeSmith.Engine Namespace


Progress Constructor

Initializes a new instance of the Progress class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public Progress()
Public Sub New
See Also

Reference

Progress Class
CodeSmith.Engine Namespace


Progress Properties

The Progress type exposes the following members.

Properties
 | Name | Description
Public property | MaximumValue | Maximum progress value.
Public property | MinimumValue | Minimum progress value.
Public property | Status | Current status for the operation.
Public property | Step | Gets or sets the step increment value.
Public property | Value | Gets or sets the current progress value.
Top
See Also

Reference

Progress Class
CodeSmith.Engine Namespace


Progress.MaximumValue Property

ProgressMaximumValue Property

Maximum progress value.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public int MaximumValue { get; set; }
Public Property MaximumValue As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

Progress Class
CodeSmith.Engine Namespace


Progress.MinimumValue Property

ProgressMinimumValue Property

Minimum progress value.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public int MinimumValue { get; set; }
Public Property MinimumValue As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

Progress Class
CodeSmith.Engine Namespace


Progress.Status Property

ProgressStatus Property

Current status for the operation.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string Status { get; set; }
Public Property Status As String
    Get
    Set

Property Value

Type: String
See Also

Reference

Progress Class
CodeSmith.Engine Namespace


Progress.Step Property

ProgressStep Property

Gets or sets the step increment value.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public int Step { get; set; }
Public Property Step As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

Progress Class
CodeSmith.Engine Namespace


Progress.Value Property

ProgressValue Property

Gets or sets the current progress value.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public int Value { get; set; }
Public Property Value As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

Progress Class
CodeSmith.Engine Namespace


Progress Methods

The Progress type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Increment | Increments the current progress value by the specified amount.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PerformStep | Performs a progress step.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Progress Class
CodeSmith.Engine Namespace


Progress.Increment Method

ProgressIncrement Method

Increments the current progress value by the specified amount.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void Increment(
    int value
)
Public Sub Increment (
    value As Integer
)

Parameters

value
Type: SystemInt32
Value.
See Also

Reference

Progress Class
CodeSmith.Engine Namespace


Progress.PerformStep Method

ProgressPerformStep Method

Performs a progress step.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void PerformStep()
Public Sub PerformStep
See Also

Reference

Progress Class
CodeSmith.Engine Namespace


Progress Events

The Progress type exposes the following members.

Events
 | Name | Description
Public event | OnProgress | Occurs when the progress value has been changed.
Public event | OnStatusChanged | Occurs when the progress value has been changed.
Top
See Also

Reference

Progress Class
CodeSmith.Engine Namespace


Progress.OnProgress Event

ProgressOnProgress Event

Occurs when the progress value has been changed.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public event ProgressEventHandler OnProgress
Public Event OnProgress As ProgressEventHandler

Value

Type: CodeSmith.EngineProgressEventHandler
See Also

Reference

Progress Class
CodeSmith.Engine Namespace


Progress.OnStatusChanged Event

ProgressOnStatusChanged Event

Occurs when the progress value has been changed.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public event StatusChangedEventHandler OnStatusChanged
Public Event OnStatusChanged As StatusChangedEventHandler

Value

Type: CodeSmith.EngineStatusChangedEventHandler
See Also

Reference

Progress Class
CodeSmith.Engine Namespace


ProgressEventArgs Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
CodeSmith.EngineProgressEventArgs

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
public class ProgressEventArgs : EventArgs
<SerializableAttribute>
Public Class ProgressEventArgs
    Inherits EventArgs

The ProgressEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ProgressEventArgs | Initializes a new instance of the ProgressEventArgs class
Top
Properties
 | Name | Description
Public property | MaximumValue |
Public property | MinimumValue |
Public property | Value |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSmith.Engine Namespace


ProgressEventArgs Constructor

Initializes a new instance of the ProgressEventArgs class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ProgressEventArgs(
    int minimumValue,
    int maximumValue,
    int value
)
Public Sub New (
    minimumValue As Integer,
    maximumValue As Integer,
    value As Integer
)

Parameters

minimumValue
Type: SystemInt32
maximumValue
Type: SystemInt32
value
Type: SystemInt32
See Also

Reference

ProgressEventArgs Class
CodeSmith.Engine Namespace


ProgressEventArgs Properties

The ProgressEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | MaximumValue |
Public property | MinimumValue |
Public property | Value |
Top
See Also

Reference

ProgressEventArgs Class
CodeSmith.Engine Namespace


ProgressEventArgs.MaximumValue Property

ProgressEventArgsMaximumValue Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public int MaximumValue { get; }
Public ReadOnly Property MaximumValue As Integer
    Get

Property Value

Type: Int32
See Also

Reference

ProgressEventArgs Class
CodeSmith.Engine Namespace


ProgressEventArgs.MinimumValue Property

ProgressEventArgsMinimumValue Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public int MinimumValue { get; }
Public ReadOnly Property MinimumValue As Integer
    Get

Property Value

Type: Int32
See Also

Reference

ProgressEventArgs Class
CodeSmith.Engine Namespace


ProgressEventArgs.Value Property

ProgressEventArgsValue Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public int Value { get; }
Public ReadOnly Property Value As Integer
    Get

Property Value

Type: Int32
See Also

Reference

ProgressEventArgs Class
CodeSmith.Engine Namespace


ProgressEventArgs Methods

The ProgressEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ProgressEventArgs Class
CodeSmith.Engine Namespace


ProgressEventHandler Delegate

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public delegate void ProgressEventHandler(
    Object sender,
    ProgressEventArgs e
)
Public Delegate Sub ProgressEventHandler (
    sender As Object,
    e As ProgressEventArgs
)

Parameters

sender
Type: SystemObject
e
Type: CodeSmith.EngineProgressEventArgs
See Also

Reference

CodeSmith.Engine Namespace


ProjectCodeGenerator Class

Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
CodeSmith.EngineCodeGeneratorBase
CodeSmith.EngineProjectCodeGenerator

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
public class ProjectCodeGenerator : CodeGeneratorBase
<SerializableAttribute>
Public Class ProjectCodeGenerator
    Inherits CodeGeneratorBase

The ProjectCodeGenerator type exposes the following members.

Constructors
 | Name | Description
Public method | ProjectCodeGenerator | Initializes a new instance of the ProjectCodeGenerator class
Top
Properties
 | Name | Description
Public property | ContextData |
Public property | Debug | (Inherited from CodeGeneratorBase.)
 | IsGenerating | Returns true while generating.
Public property | KeepTempFiles | (Inherited from CodeGeneratorBase.)
Public property | Properties | (Inherited from CodeGeneratorBase.)
Public property | RegisteredOutputs |
Public property | RegisteredReferences |
Public property | Verbose | (Inherited from CodeGeneratorBase.)
Top
Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateCode(CodeSmithProject) | Generates a CodeSmith Generator Project.
Public method | GenerateCode(String) | Generates a CodeSmith Generator Project file (.csp) based on the file path to the .csp.
Public method | GenerateCode(String, String) | Generates a CodeSmith Generator Project file (.csp) based on the file path to the .csp and the .csp's file content.
Public method | GenerateCodeAsync(CodeSmithProject) | Generates a CodeSmith Generator Project.
Public method | GenerateCodeAsync(String) | Begin generating code asynchronous
Public method | GenerateCodeAsync(String, String) | Generates a CodeSmith Generator Project file (.csp) based on the file path to the .csp and the .csp's file content.
Protected method | GetCodeTemplateInfo | (Inherited from CodeGeneratorBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetVariables | (Inherited from CodeGeneratorBase.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnGeneratorComplete |
Protected method | OnGeneratorError(GeneratorErrorEventArgs) | (Inherited from CodeGeneratorBase.)
Protected method | OnGeneratorError(String, Exception) | (Inherited from CodeGeneratorBase.)
Protected method | OnGeneratorError(String, Boolean, Int32, String, Int32, Int32) | (Inherited from CodeGeneratorBase.)
Protected method | OnOutputString(MessageEventArgs) | (Inherited from CodeGeneratorBase.)
Protected method | OnOutputString(String) | (Inherited from CodeGeneratorBase.)
Protected method | OnOutputString(String, Object) | (Inherited from CodeGeneratorBase.)
Protected method | OnPreOutputWritten | (Inherited from CodeGeneratorBase.)
Protected method | OnProgress(GeneratorProgressEventArgs) | (Inherited from CodeGeneratorBase.)
Protected method | OnProgress(Int32, Int32) | (Inherited from CodeGeneratorBase.)
Protected method | OnStatusChanged(MessageEventArgs) | (Inherited from CodeGeneratorBase.)
Protected method | OnStatusChanged(String) | (Inherited from CodeGeneratorBase.)
Protected method | OutputCompilerErrors | (Inherited from CodeGeneratorBase.)
Protected method | ReplaceVariables | (Inherited from CodeGeneratorBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | WriteComment | (Inherited from CodeGeneratorBase.)
Protected method | WriteHeader | (Inherited from CodeGeneratorBase.)
Top
Events
 | Name | Description
 | GenerateEnd |
 | GenerateStart |
Public event | GeneratorComplete |
Public event | GeneratorError | (Inherited from CodeGeneratorBase.)
Public event | OutputString | (Inherited from CodeGeneratorBase.)
Public event | PreOutputWritten | (Inherited from CodeGeneratorBase.)
Public event | Progress | (Inherited from CodeGeneratorBase.)
Public event | StatusChanged | (Inherited from CodeGeneratorBase.)
Top
See Also

Reference

CodeSmith.Engine Namespace


ProjectCodeGenerator Constructor

Initializes a new instance of the ProjectCodeGenerator class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ProjectCodeGenerator()
Public Sub New
See Also

Reference

ProjectCodeGenerator Class
CodeSmith.Engine Namespace


ProjectCodeGenerator Properties

The ProjectCodeGenerator type exposes the following members.

Properties
 | Name | Description
Public property | ContextData |
Public property | Debug | (Inherited from CodeGeneratorBase.)
 | IsGenerating | Returns true while generating.
Public property | KeepTempFiles | (Inherited from CodeGeneratorBase.)
Public property | Properties | (Inherited from CodeGeneratorBase.)
Public property | RegisteredOutputs |
Public property | RegisteredReferences |
Public property | Verbose | (Inherited from CodeGeneratorBase.)
Top
See Also

Reference

ProjectCodeGenerator Class
CodeSmith.Engine Namespace


ProjectCodeGenerator.ContextData Property

ProjectCodeGeneratorContextData Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public NameValueCollection ContextData { get; set; }
Public Property ContextData As NameValueCollection
    Get
    Set

Property Value

Type: NameValueCollection
See Also

Reference

ProjectCodeGenerator Class
CodeSmith.Engine Namespace


ProjectCodeGenerator.IsGenerating Property

ProjectCodeGeneratorIsGenerating Property

Returns true while generating.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static bool IsGenerating { get; }
Public Shared ReadOnly Property IsGenerating As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

ProjectCodeGenerator Class
CodeSmith.Engine Namespace


ProjectCodeGenerator.RegisteredOutputs Property

ProjectCodeGeneratorRegisteredOutputs Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ReadOnlyCollection<OutputFile> RegisteredOutputs { get; }
Public ReadOnly Property RegisteredOutputs As ReadOnlyCollection(Of OutputFile)
    Get

Property Value

Type: ReadOnlyCollection OutputFile
See Also

Reference

ProjectCodeGenerator Class
CodeSmith.Engine Namespace


ProjectCodeGenerator.RegisteredReferences Property

ProjectCodeGeneratorRegisteredReferences Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ReadOnlyCollection<string> RegisteredReferences { get; }
Public ReadOnly Property RegisteredReferences As ReadOnlyCollection(Of String)
    Get

Property Value

Type: ReadOnlyCollection String
See Also

Reference

ProjectCodeGenerator Class
CodeSmith.Engine Namespace


ProjectCodeGenerator Methods

The ProjectCodeGenerator type exposes the following members.

Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateCode(CodeSmithProject) | Generates a CodeSmith Generator Project.
Public method | GenerateCode(String) | Generates a CodeSmith Generator Project file (.csp) based on the file path to the .csp.
Public method | GenerateCode(String, String) | Generates a CodeSmith Generator Project file (.csp) based on the file path to the .csp and the .csp's file content.
Public method | GenerateCodeAsync(CodeSmithProject) | Generates a CodeSmith Generator Project.
Public method | GenerateCodeAsync(String) | Begin generating code asynchronous
Public method | GenerateCodeAsync(String, String) | Generates a CodeSmith Generator Project file (.csp) based on the file path to the .csp and the .csp's file content.
Protected method | GetCodeTemplateInfo | (Inherited from CodeGeneratorBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetVariables | (Inherited from CodeGeneratorBase.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnGeneratorComplete |
Protected method | OnGeneratorError(GeneratorErrorEventArgs) | (Inherited from CodeGeneratorBase.)
Protected method | OnGeneratorError(String, Exception) | (Inherited from CodeGeneratorBase.)
Protected method | OnGeneratorError(String, Boolean, Int32, String, Int32, Int32) | (Inherited from CodeGeneratorBase.)
Protected method | OnOutputString(MessageEventArgs) | (Inherited from CodeGeneratorBase.)
Protected method | OnOutputString(String) | (Inherited from CodeGeneratorBase.)
Protected method | OnOutputString(String, Object) | (Inherited from CodeGeneratorBase.)
Protected method | OnPreOutputWritten | (Inherited from CodeGeneratorBase.)
Protected method | OnProgress(GeneratorProgressEventArgs) | (Inherited from CodeGeneratorBase.)
Protected method | OnProgress(Int32, Int32) | (Inherited from CodeGeneratorBase.)
Protected method | OnStatusChanged(MessageEventArgs) | (Inherited from CodeGeneratorBase.)
Protected method | OnStatusChanged(String) | (Inherited from CodeGeneratorBase.)
Protected method | OutputCompilerErrors | (Inherited from CodeGeneratorBase.)
Protected method | ReplaceVariables | (Inherited from CodeGeneratorBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | WriteComment | (Inherited from CodeGeneratorBase.)
Protected method | WriteHeader | (Inherited from CodeGeneratorBase.)
Top
See Also

Reference

ProjectCodeGenerator Class
CodeSmith.Engine Namespace


ProjectCodeGenerator.GenerateCode Method

ProjectCodeGeneratorGenerateCode Method

Overload List
 | Name | Description
Public method | GenerateCode(CodeSmithProject) | Generates a CodeSmith Generator Project.
Public method | GenerateCode(String) | Generates a CodeSmith Generator Project file (.csp) based on the file path to the .csp.
Public method | GenerateCode(String, String) | Generates a CodeSmith Generator Project file (.csp) based on the file path to the .csp and the .csp's file content.
Top
See Also

Reference

ProjectCodeGenerator Class
CodeSmith.Engine Namespace


ProjectCodeGenerator.GenerateCode Method (CodeSmithProject)

ProjectCodeGeneratorGenerateCode Method (CodeSmithProject)

Generates a CodeSmith Generator Project.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool GenerateCode(
    CodeSmithProject project
)
Public Function GenerateCode (
    project As CodeSmithProject
) As Boolean

Parameters

project
Type: CodeSmith.Engine.SchemaCodeSmithProject
The CodeSmith Generator Project file.

Return Value

Type: Boolean
true if the CodeSmith Generator Project file (.csp) was generated.
See Also

Reference

ProjectCodeGenerator Class
GenerateCode Overload
CodeSmith.Engine Namespace


ProjectCodeGenerator.GenerateCode Method (String)

ProjectCodeGeneratorGenerateCode Method (String)

Generates a CodeSmith Generator Project file (.csp) based on the file path to the .csp.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool GenerateCode(
    string xmlFilePath
)
Public Function GenerateCode (
    xmlFilePath As String
) As Boolean

Parameters

xmlFilePath
Type: SystemString
File path to the CodeSmith Generator Project file (.csp) file.

Return Value

Type: Boolean
true if the CodeSmith Generator Project file (.csp) was generated.
See Also

Reference

ProjectCodeGenerator Class
GenerateCode Overload
CodeSmith.Engine Namespace


ProjectCodeGenerator.GenerateCode Method (String, String)

ProjectCodeGeneratorGenerateCode Method (String, String)

Generates a CodeSmith Generator Project file (.csp) based on the file path to the .csp and the .csp's file content.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool GenerateCode(
    string xmlFilePath,
    string xmlFragment
)
Public Function GenerateCode (
    xmlFilePath As String,
    xmlFragment As String
) As Boolean

Parameters

xmlFilePath
Type: SystemString
File path to the CodeSmith Generator Project file (.csp) file.
xmlFragment
Type: SystemString
The content of the CodeSmith Generator Project file (.csp) file.

Return Value

Type: Boolean
true if the CodeSmith Generator Project file (.csp) was generated.
See Also

Reference

ProjectCodeGenerator Class
GenerateCode Overload
CodeSmith.Engine Namespace


ProjectCodeGenerator.GenerateCodeAsync Method

ProjectCodeGeneratorGenerateCodeAsync Method

Overload List
 | Name | Description
Public method | GenerateCodeAsync(CodeSmithProject) | Generates a CodeSmith Generator Project.
Public method | GenerateCodeAsync(String) | Begin generating code asynchronous
Public method | GenerateCodeAsync(String, String) | Generates a CodeSmith Generator Project file (.csp) based on the file path to the .csp and the .csp's file content.
Top
See Also

Reference

ProjectCodeGenerator Class
CodeSmith.Engine Namespace


ProjectCodeGenerator.GenerateCodeAsync Method (CodeSmithProject)

ProjectCodeGeneratorGenerateCodeAsync Method (CodeSmithProject)

Generates a CodeSmith Generator Project.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void GenerateCodeAsync(
    CodeSmithProject project
)
Public Sub GenerateCodeAsync (
    project As CodeSmithProject
)

Parameters

project
Type: CodeSmith.Engine.SchemaCodeSmithProject
The CodeSmith Generator Project file.

Return Value

Type:
true if the CodeSmith Generator Project file (.csp) was generated.
See Also

Reference

ProjectCodeGenerator Class
GenerateCodeAsync Overload
CodeSmith.Engine Namespace


ProjectCodeGenerator.GenerateCodeAsync Method (String)

ProjectCodeGeneratorGenerateCodeAsync Method (String)

Begin generating code asynchronous

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void GenerateCodeAsync(
    string xmlFilePath
)
Public Sub GenerateCodeAsync (
    xmlFilePath As String
)

Parameters

xmlFilePath
Type: SystemString
The project file to generate
See Also

Reference

ProjectCodeGenerator Class
GenerateCodeAsync Overload
CodeSmith.Engine Namespace


ProjectCodeGenerator.GenerateCodeAsync Method (String, String)

ProjectCodeGeneratorGenerateCodeAsync Method (String, String)

Generates a CodeSmith Generator Project file (.csp) based on the file path to the .csp and the .csp's file content.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void GenerateCodeAsync(
    string xmlFilePath,
    string xmlFragment
)
Public Sub GenerateCodeAsync (
    xmlFilePath As String,
    xmlFragment As String
)

Parameters

xmlFilePath
Type: SystemString
File path to the CodeSmith Generator Project file (.csp) file.
xmlFragment
Type: SystemString
The content of the CodeSmith Generator Project file (.csp) file.

Return Value

Type:
true if the CodeSmith Generator Project file (.csp) was generated.
See Also

Reference

ProjectCodeGenerator Class
GenerateCodeAsync Overload
CodeSmith.Engine Namespace


ProjectCodeGenerator.OnGeneratorComplete Method

ProjectCodeGeneratorOnGeneratorComplete Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual void OnGeneratorComplete(
    GeneratorCompleteEventArgs e
)
Protected Overridable Sub OnGeneratorComplete (
    e As GeneratorCompleteEventArgs
)

Parameters

e
Type: CodeSmith.EngineGeneratorCompleteEventArgs
See Also

Reference

ProjectCodeGenerator Class
CodeSmith.Engine Namespace


ProjectCodeGenerator Events

The ProjectCodeGenerator type exposes the following members.

Events
 | Name | Description
 | GenerateEnd |
 | GenerateStart |
Public event | GeneratorComplete |
Public event | GeneratorError | (Inherited from CodeGeneratorBase.)
Public event | OutputString | (Inherited from CodeGeneratorBase.)
Public event | PreOutputWritten | (Inherited from CodeGeneratorBase.)
Public event | Progress | (Inherited from CodeGeneratorBase.)
Public event | StatusChanged | (Inherited from CodeGeneratorBase.)
Top
See Also

Reference

ProjectCodeGenerator Class
CodeSmith.Engine Namespace


ProjectCodeGenerator.GenerateEnd Event

ProjectCodeGeneratorGenerateEnd Event

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static event GenerateEndEventHandler GenerateEnd
Public Shared Event GenerateEnd As GenerateEndEventHandler

Value

Type: CodeSmith.EngineGenerateEndEventHandler
See Also

Reference

ProjectCodeGenerator Class
CodeSmith.Engine Namespace


ProjectCodeGenerator.GenerateStart Event

ProjectCodeGeneratorGenerateStart Event

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static event GenerateStartEventHandler GenerateStart
Public Shared Event GenerateStart As GenerateStartEventHandler

Value

Type: CodeSmith.EngineGenerateStartEventHandler
See Also

Reference

ProjectCodeGenerator Class
CodeSmith.Engine Namespace


ProjectCodeGenerator.GeneratorComplete Event

ProjectCodeGeneratorGeneratorComplete Event

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public event GeneratorCompleteEventHandler GeneratorComplete
Public Event GeneratorComplete As GeneratorCompleteEventHandler

Value

Type: CodeSmith.EngineGeneratorCompleteEventHandler
See Also

Reference

ProjectCodeGenerator Class
CodeSmith.Engine Namespace


PropertyDesignerMap Class

Inheritance Hierarchy
SystemObject
CodeSmith.EngineConfigurationItemBase
CodeSmith.EnginePropertyDesignerMap

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class PropertyDesignerMap : ConfigurationItemBase
Public Class PropertyDesignerMap
    Inherits ConfigurationItemBase

The PropertyDesignerMap type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyDesignerMap | Initializes a new instance of the PropertyDesignerMap class
Top
Properties
 | Name | Description
Public property | DataTypes | Gets the list of data types the designer should be used for.
Public property | EditorType | Gets or sets the type of the editor.
Public property | Index | Gets or sets the index. (Inherited from ConfigurationItemBase.)
Public property | SerializerType | Gets or sets the type of the serializer.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | (Inherited from ConfigurationItemBase.)
Public method | ToString | (Overrides ObjectToString.)
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from ConfigurationItemBase.)
Top
See Also

Reference

CodeSmith.Engine Namespace


PropertyDesignerMap Constructor

Initializes a new instance of the PropertyDesignerMap class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public PropertyDesignerMap()
Public Sub New
See Also

Reference

PropertyDesignerMap Class
CodeSmith.Engine Namespace


PropertyDesignerMap Properties

The PropertyDesignerMap type exposes the following members.

Properties
 | Name | Description
Public property | DataTypes | Gets the list of data types the designer should be used for.
Public property | EditorType | Gets or sets the type of the editor.
Public property | Index | Gets or sets the index. (Inherited from ConfigurationItemBase.)
Public property | SerializerType | Gets or sets the type of the serializer.
Top
See Also

Reference

PropertyDesignerMap Class
CodeSmith.Engine Namespace


PropertyDesignerMap.DataTypes Property

PropertyDesignerMapDataTypes Property

Gets the list of data types the designer should be used for.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public DelimitedStringCollection DataTypes { get; }
Public ReadOnly Property DataTypes As DelimitedStringCollection
    Get

Property Value

Type: DelimitedStringCollection
The data types.
See Also

Reference

PropertyDesignerMap Class
CodeSmith.Engine Namespace


PropertyDesignerMap.EditorType Property

PropertyDesignerMapEditorType Property

Gets or sets the type of the editor.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string EditorType { get; set; }
Public Property EditorType As String
    Get
    Set

Property Value

Type: String
The type of the editor.
See Also

Reference

PropertyDesignerMap Class
CodeSmith.Engine Namespace


PropertyDesignerMap.SerializerType Property

PropertyDesignerMapSerializerType Property

Gets or sets the type of the serializer.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string SerializerType { get; set; }
Public Property SerializerType As String
    Get
    Set

Property Value

Type: String
The type of the serializer.
See Also

Reference

PropertyDesignerMap Class
CodeSmith.Engine Namespace


PropertyDesignerMap Methods

The PropertyDesignerMap type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | (Inherited from ConfigurationItemBase.)
Public method | ToString | (Overrides ObjectToString.)
Top
See Also

Reference

PropertyDesignerMap Class
CodeSmith.Engine Namespace


PropertyDesignerMap.ToString Method

PropertyDesignerMapToString Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
See Also

Reference

PropertyDesignerMap Class
CodeSmith.Engine Namespace


PropertyDesignerMap Events

The PropertyDesignerMap type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from ConfigurationItemBase.)
Top
See Also

Reference

PropertyDesignerMap Class
CodeSmith.Engine Namespace


PropertyDesignerMapCollection Class

Inheritance Hierarchy
SystemObject
CodeSmith.EngineVirtualCollectionBase PropertyDesignerMap
CodeSmith.EngineConfigurationCollectionBase PropertyDesignerMap
CodeSmith.EnginePropertyDesignerMapCollection

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class PropertyDesignerMapCollection : ConfigurationCollectionBase<PropertyDesignerMap>
Public Class PropertyDesignerMapCollection
    Inherits ConfigurationCollectionBase(Of PropertyDesignerMap)

The PropertyDesignerMapCollection type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyDesignerMapCollection | Initializes a new instance of the PropertyDesignerMapCollection class
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from VirtualCollectionBaseT.)
Public property | Item | Gets or sets the type T at the specified index. (Inherited from VirtualCollectionBaseT.)
Protected property | SubKey | (Overrides ConfigurationCollectionBaseTSubKey.)
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from VirtualCollectionBaseT.)
Protected method | AddItem | (Overrides VirtualCollectionBaseTAddItem(T).)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from VirtualCollectionBaseT.)
Protected method | ClearItems | (Inherited from ConfigurationCollectionBaseT.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from VirtualCollectionBaseT.)
Public method | CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from VirtualCollectionBaseT.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetCount | (Inherited from ConfigurationCollectionBaseT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from VirtualCollectionBaseT.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetIndex | (Overrides VirtualCollectionBaseTGetIndex(T).)
Protected method | GetItem | (Inherited from ConfigurationCollectionBaseT.)
Protected method | GetItemFromRegistry | (Overrides ConfigurationCollectionBaseTGetItemFromRegistry(Int32).)
Protected method | GetItems | (Inherited from ConfigurationCollectionBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from VirtualCollectionBaseT.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from VirtualCollectionBaseT.)
Protected method | InsertItem | (Inherited from ConfigurationCollectionBaseT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | (Inherited from ConfigurationCollectionBaseT.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from VirtualCollectionBaseT.)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from VirtualCollectionBaseT.)
Protected method | RemoveItem | (Inherited from ConfigurationCollectionBaseT.)
Protected method | SetItem | (Inherited from ConfigurationCollectionBaseT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSmith.Engine Namespace


PropertyDesignerMapCollection Constructor

Initializes a new instance of the PropertyDesignerMapCollection class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public PropertyDesignerMapCollection()
Public Sub New
See Also

Reference

PropertyDesignerMapCollection Class
CodeSmith.Engine Namespace


PropertyDesignerMapCollection Properties

The PropertyDesignerMapCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from VirtualCollectionBaseT.)
Public property | Item | Gets or sets the type T at the specified index. (Inherited from VirtualCollectionBaseT.)
Protected property | SubKey | (Overrides ConfigurationCollectionBaseTSubKey.)
Top
See Also

Reference

PropertyDesignerMapCollection Class
CodeSmith.Engine Namespace


PropertyDesignerMapCollection.SubKey Property

PropertyDesignerMapCollectionSubKey Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected override string SubKey { get; }
Protected Overrides ReadOnly Property SubKey As String
    Get

Property Value

Type: String
See Also

Reference

PropertyDesignerMapCollection Class
CodeSmith.Engine Namespace


PropertyDesignerMapCollection Methods

The PropertyDesignerMapCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from VirtualCollectionBaseT.)
Protected method | AddItem | (Overrides VirtualCollectionBaseTAddItem(T).)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from VirtualCollectionBaseT.)
Protected method | ClearItems | (Inherited from ConfigurationCollectionBaseT.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from VirtualCollectionBaseT.)
Public method | CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from VirtualCollectionBaseT.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetCount | (Inherited from ConfigurationCollectionBaseT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from VirtualCollectionBaseT.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetIndex | (Overrides VirtualCollectionBaseTGetIndex(T).)
Protected method | GetItem | (Inherited from ConfigurationCollectionBaseT.)
Protected method | GetItemFromRegistry | (Overrides ConfigurationCollectionBaseTGetItemFromRegistry(Int32).)
Protected method | GetItems | (Inherited from ConfigurationCollectionBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from VirtualCollectionBaseT.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from VirtualCollectionBaseT.)
Protected method | InsertItem | (Inherited from ConfigurationCollectionBaseT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | (Inherited from ConfigurationCollectionBaseT.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from VirtualCollectionBaseT.)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from VirtualCollectionBaseT.)
Protected method | RemoveItem | (Inherited from ConfigurationCollectionBaseT.)
Protected method | SetItem | (Inherited from ConfigurationCollectionBaseT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PropertyDesignerMapCollection Class
CodeSmith.Engine Namespace


PropertyDesignerMapCollection.AddItem Method

PropertyDesignerMapCollectionAddItem Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected override int AddItem(
    PropertyDesignerMap item
)
Protected Overrides Function AddItem (
    item As PropertyDesignerMap
) As Integer

Parameters

item
Type: CodeSmith.EnginePropertyDesignerMap

Return Value

Type: Int32
See Also

Reference

PropertyDesignerMapCollection Class
CodeSmith.Engine Namespace


PropertyDesignerMapCollection.GetIndex Method

PropertyDesignerMapCollectionGetIndex Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected override int GetIndex(
    PropertyDesignerMap item
)
Protected Overrides Function GetIndex (
    item As PropertyDesignerMap
) As Integer

Parameters

item
Type: CodeSmith.EnginePropertyDesignerMap

Return Value

Type: Int32
See Also

Reference

PropertyDesignerMapCollection Class
CodeSmith.Engine Namespace


PropertyDesignerMapCollection.GetItemFromRegistry Method

PropertyDesignerMapCollectionGetItemFromRegistry Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected override PropertyDesignerMap GetItemFromRegistry(
    int index
)
Protected Overrides Function GetItemFromRegistry (
    index As Integer
) As PropertyDesignerMap

Parameters

index
Type: SystemInt32

Return Value

Type: PropertyDesignerMap
See Also

Reference

PropertyDesignerMapCollection Class
CodeSmith.Engine Namespace


PropertyRefresherAttribute Class

Inheritance Hierarchy
SystemObject
SystemAttribute
CodeSmith.EnginePropertyRefresherAttribute

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public sealed class PropertyRefresherAttribute : Attribute
Public NotInheritable Class PropertyRefresherAttribute
    Inherits Attribute

The PropertyRefresherAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyRefresherAttribute(String) | Initializes a new instance of the PropertyRefresherAttribute class
Public method | PropertyRefresherAttribute(Type) | Initializes a new instance of the PropertyRefresherAttribute class
Public method | PropertyRefresherAttribute(Type, Object) | Initializes a new instance of the PropertyRefresherAttribute class
Top
Properties
 | Name | Description
Public property | RefresherParameters |
Public property | RefresherTypeName |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | (Overrides AttributeEquals(Object).)
Public method | GetHashCode | (Overrides AttributeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSmith.Engine Namespace


PropertyRefresherAttribute Constructor

Overload List
 | Name | Description
Public method | PropertyRefresherAttribute(String) | Initializes a new instance of the PropertyRefresherAttribute class
Public method | PropertyRefresherAttribute(Type) | Initializes a new instance of the PropertyRefresherAttribute class
Public method | PropertyRefresherAttribute(Type, Object) | Initializes a new instance of the PropertyRefresherAttribute class
Top
See Also

Reference

PropertyRefresherAttribute Class
CodeSmith.Engine Namespace


PropertyRefresherAttribute Constructor (String)

Initializes a new instance of the PropertyRefresherAttribute class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public PropertyRefresherAttribute(
    string refresherTypeName
)
Public Sub New (
    refresherTypeName As String
)

Parameters

refresherTypeName
Type: SystemString
See Also

Reference

PropertyRefresherAttribute Class
PropertyRefresherAttribute Overload
CodeSmith.Engine Namespace


PropertyRefresherAttribute Constructor (Type)

Initializes a new instance of the PropertyRefresherAttribute class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public PropertyRefresherAttribute(
    Type refresherType
)
Public Sub New (
    refresherType As Type
)

Parameters

refresherType
Type: SystemType
See Also

Reference

PropertyRefresherAttribute Class
PropertyRefresherAttribute Overload
CodeSmith.Engine Namespace


PropertyRefresherAttribute Constructor (Type, Object[])

PropertyRefresherAttribute Constructor (Type, Object)

Initializes a new instance of the PropertyRefresherAttribute class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public PropertyRefresherAttribute(
    Type refresherType,
    params Object[] parameters
)
Public Sub New (
    refresherType As Type,
    ParamArray parameters As Object()
)

Parameters

refresherType
Type: SystemType
parameters
Type: SystemObject
See Also

Reference

PropertyRefresherAttribute Class
PropertyRefresherAttribute Overload
CodeSmith.Engine Namespace


PropertyRefresherAttribute Properties

The PropertyRefresherAttribute type exposes the following members.

Properties
 | Name | Description
Public property | RefresherParameters |
Public property | RefresherTypeName |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

PropertyRefresherAttribute Class
CodeSmith.Engine Namespace


PropertyRefresherAttribute.RefresherParameters Property

PropertyRefresherAttributeRefresherParameters Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public Object[] RefresherParameters { get; }
Public ReadOnly Property RefresherParameters As Object()
    Get

Property Value

Type: Object
See Also

Reference

PropertyRefresherAttribute Class
CodeSmith.Engine Namespace


PropertyRefresherAttribute.RefresherTypeName Property

PropertyRefresherAttributeRefresherTypeName Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string RefresherTypeName { get; }
Public ReadOnly Property RefresherTypeName As String
    Get

Property Value

Type: String
See Also

Reference

PropertyRefresherAttribute Class
CodeSmith.Engine Namespace


PropertyRefresherAttribute Methods

The PropertyRefresherAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Overrides AttributeEquals(Object).)
Public method | GetHashCode | (Overrides AttributeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PropertyRefresherAttribute Class
CodeSmith.Engine Namespace


PropertyRefresherAttribute.Equals Method

PropertyRefresherAttributeEquals Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override bool Equals(
    Object o
)
Public Overrides Function Equals (
    o As Object
) As Boolean

Parameters

o
Type: SystemObject

Return Value

Type: Boolean
See Also

Reference

PropertyRefresherAttribute Class
CodeSmith.Engine Namespace


PropertyRefresherAttribute.GetHashCode Method

PropertyRefresherAttributeGetHashCode Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
See Also

Reference

PropertyRefresherAttribute Class
CodeSmith.Engine Namespace


PropertyRefresherContext Class

Context information passed into the IPropertyRefresher methods.
Inheritance Hierarchy
SystemObject
CodeSmith.EnginePropertyRefresherContext

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class PropertyRefresherContext
Public Class PropertyRefresherContext

The PropertyRefresherContext type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyRefresherContext(PropertyInfo, CodeTemplate) | Initializes a new instance of the PropertyRefresherContext class
Public method | PropertyRefresherContext(PropertyInfo, CodeTemplate, String) | Initializes a new instance of the PropertyRefresherContext class
Top
Properties
 | Name | Description
Public property | Instance | The CodeTemplate instance that the context points to.
Public property | PropertyInfo | The property that the context points to.
Public property | WorkingDirectory | The working directory for resolving and creating relative paths.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSmith.Engine Namespace


PropertyRefresherContext Constructor

Overload List
 | Name | Description
Public method | PropertyRefresherContext(PropertyInfo, CodeTemplate) | Initializes a new instance of the PropertyRefresherContext class
Public method | PropertyRefresherContext(PropertyInfo, CodeTemplate, String) | Initializes a new instance of the PropertyRefresherContext class
Top
See Also

Reference

PropertyRefresherContext Class
CodeSmith.Engine Namespace


PropertyRefresherContext Constructor (PropertyInfo, CodeTemplate)

Initializes a new instance of the PropertyRefresherContext class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public PropertyRefresherContext(
    PropertyInfo propertyInfo,
    CodeTemplate instance
)
Public Sub New (
    propertyInfo As PropertyInfo,
    instance As CodeTemplate
)

Parameters

propertyInfo
Type: System.ReflectionPropertyInfo
instance
Type: CodeSmith.EngineCodeTemplate
See Also

Reference

PropertyRefresherContext Class
PropertyRefresherContext Overload
CodeSmith.Engine Namespace


PropertyRefresherContext Constructor (PropertyInfo, CodeTemplate, String)

Initializes a new instance of the PropertyRefresherContext class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public PropertyRefresherContext(
    PropertyInfo propertyInfo,
    CodeTemplate instance,
    string workingDirectory
)
Public Sub New (
    propertyInfo As PropertyInfo,
    instance As CodeTemplate,
    workingDirectory As String
)

Parameters

propertyInfo
Type: System.ReflectionPropertyInfo
instance
Type: CodeSmith.EngineCodeTemplate
workingDirectory
Type: SystemString
See Also

Reference

PropertyRefresherContext Class
PropertyRefresherContext Overload
CodeSmith.Engine Namespace


PropertyRefresherContext Properties

The PropertyRefresherContext type exposes the following members.

Properties
 | Name | Description
Public property | Instance | The CodeTemplate instance that the context points to.
Public property | PropertyInfo | The property that the context points to.
Public property | WorkingDirectory | The working directory for resolving and creating relative paths.
Top
See Also

Reference

PropertyRefresherContext Class
CodeSmith.Engine Namespace


PropertyRefresherContext.Instance Property

PropertyRefresherContextInstance Property

The CodeTemplate instance that the context points to.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CodeTemplate Instance { get; }
Public ReadOnly Property Instance As CodeTemplate
    Get

Property Value

Type: CodeTemplate
See Also

Reference

PropertyRefresherContext Class
CodeSmith.Engine Namespace


PropertyRefresherContext.PropertyInfo Property

PropertyRefresherContextPropertyInfo Property

The property that the context points to.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public PropertyInfo PropertyInfo { get; }
Public ReadOnly Property PropertyInfo As PropertyInfo
    Get

Property Value

Type: PropertyInfo
See Also

Reference

PropertyRefresherContext Class
CodeSmith.Engine Namespace


PropertyRefresherContext.WorkingDirectory Property

PropertyRefresherContextWorkingDirectory Property

The working directory for resolving and creating relative paths.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string WorkingDirectory { get; }
Public ReadOnly Property WorkingDirectory As String
    Get

Property Value

Type: String
See Also

Reference

PropertyRefresherContext Class
CodeSmith.Engine Namespace


PropertyRefresherContext Methods

The PropertyRefresherContext type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PropertyRefresherContext Class
CodeSmith.Engine Namespace


PropertyRequiredValidationError Class

Inheritance Hierarchy
SystemObject
CodeSmith.EngineValidationError
CodeSmith.EnginePropertyRequiredValidationError

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
public class PropertyRequiredValidationError : ValidationError
<SerializableAttribute>
Public Class PropertyRequiredValidationError
    Inherits ValidationError

The PropertyRequiredValidationError type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyRequiredValidationError | Initializes a new instance of the PropertyRequiredValidationError class
Top
Properties
 | Name | Description
Public property | Column |
Public property | FilePath |
Public property | IsSubTemplate |
Public property | Line |
Public property | Message | (Overrides ValidationErrorMessage.)
Public property | PropertyName | The name of the Property. (Inherited from ValidationError.)
Public property | SourceFilePath |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSmith.Engine Namespace


PropertyRequiredValidationError Constructor

Initializes a new instance of the PropertyRequiredValidationError class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public PropertyRequiredValidationError(
    string filePath,
    string property
)
Public Sub New (
    filePath As String,
    property As String
)

Parameters

filePath
Type: SystemString
property
Type: SystemString
See Also

Reference

PropertyRequiredValidationError Class
CodeSmith.Engine Namespace


PropertyRequiredValidationError Properties

The PropertyRequiredValidationError type exposes the following members.

Properties
 | Name | Description
Public property | Column |
Public property | FilePath |
Public property | IsSubTemplate |
Public property | Line |
Public property | Message | (Overrides ValidationErrorMessage.)
Public property | PropertyName | The name of the Property. (Inherited from ValidationError.)
Public property | SourceFilePath |
Top
See Also

Reference

PropertyRequiredValidationError Class
CodeSmith.Engine Namespace


PropertyRequiredValidationError.Column Property

PropertyRequiredValidationErrorColumn Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public int Column { get; set; }
Public Property Column As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

PropertyRequiredValidationError Class
CodeSmith.Engine Namespace


PropertyRequiredValidationError.FilePath Property

PropertyRequiredValidationErrorFilePath Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string FilePath { get; set; }
Public Property FilePath As String
    Get
    Set

Property Value

Type: String
See Also

Reference

PropertyRequiredValidationError Class
CodeSmith.Engine Namespace


PropertyRequiredValidationError.IsSubTemplate Property

PropertyRequiredValidationErrorIsSubTemplate Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool IsSubTemplate { get; }
Public ReadOnly Property IsSubTemplate As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

PropertyRequiredValidationError Class
CodeSmith.Engine Namespace


PropertyRequiredValidationError.Line Property

PropertyRequiredValidationErrorLine Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public int Line { get; set; }
Public Property Line As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

PropertyRequiredValidationError Class
CodeSmith.Engine Namespace


PropertyRequiredValidationError.Message Property

PropertyRequiredValidationErrorMessage Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override string Message { get; }
Public Overrides ReadOnly Property Message As String
    Get

Property Value

Type: String
See Also

Reference

PropertyRequiredValidationError Class
CodeSmith.Engine Namespace


PropertyRequiredValidationError.SourceFilePath Property

PropertyRequiredValidationErrorSourceFilePath Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string SourceFilePath { get; set; }
Public Property SourceFilePath As String
    Get
    Set

Property Value

Type: String
See Also

Reference

PropertyRequiredValidationError Class
CodeSmith.Engine Namespace


PropertyRequiredValidationError Methods

The PropertyRequiredValidationError type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PropertyRequiredValidationError Class
CodeSmith.Engine Namespace


PropertySerializerAttribute Class

Inheritance Hierarchy
SystemObject
SystemAttribute
CodeSmith.EnginePropertySerializerAttribute

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public sealed class PropertySerializerAttribute : Attribute
Public NotInheritable Class PropertySerializerAttribute
    Inherits Attribute

The PropertySerializerAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | PropertySerializerAttribute(String) | Initializes a new instance of the PropertySerializerAttribute class
Public method | PropertySerializerAttribute(Type) | Initializes a new instance of the PropertySerializerAttribute class
Top
Properties
 | Name | Description
Public property | SerializerTypeName |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | (Overrides AttributeEquals(Object).)
Public method | GetHashCode | (Overrides AttributeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSmith.Engine Namespace


PropertySerializerAttribute Constructor

Overload List
 | Name | Description
Public method | PropertySerializerAttribute(String) | Initializes a new instance of the PropertySerializerAttribute class
Public method | PropertySerializerAttribute(Type) | Initializes a new instance of the PropertySerializerAttribute class
Top
See Also

Reference

PropertySerializerAttribute Class
CodeSmith.Engine Namespace


PropertySerializerAttribute Constructor (String)

Initializes a new instance of the PropertySerializerAttribute class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public PropertySerializerAttribute(
    string serializerTypeName
)
Public Sub New (
    serializerTypeName As String
)

Parameters

serializerTypeName
Type: SystemString
See Also

Reference

PropertySerializerAttribute Class
PropertySerializerAttribute Overload
CodeSmith.Engine Namespace


PropertySerializerAttribute Constructor (Type)

Initializes a new instance of the PropertySerializerAttribute class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public PropertySerializerAttribute(
    Type serializerType
)
Public Sub New (
    serializerType As Type
)

Parameters

serializerType
Type: SystemType
See Also

Reference

PropertySerializerAttribute Class
PropertySerializerAttribute Overload
CodeSmith.Engine Namespace


PropertySerializerAttribute Properties

The PropertySerializerAttribute type exposes the following members.

Properties
 | Name | Description
Public property | SerializerTypeName |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

PropertySerializerAttribute Class
CodeSmith.Engine Namespace


PropertySerializerAttribute.SerializerTypeName Property

PropertySerializerAttributeSerializerTypeName Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string SerializerTypeName { get; }
Public ReadOnly Property SerializerTypeName As String
    Get

Property Value

Type: String
See Also

Reference

PropertySerializerAttribute Class
CodeSmith.Engine Namespace


PropertySerializerAttribute Methods

The PropertySerializerAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Overrides AttributeEquals(Object).)
Public method | GetHashCode | (Overrides AttributeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PropertySerializerAttribute Class
CodeSmith.Engine Namespace


PropertySerializerAttribute.Equals Method

PropertySerializerAttributeEquals Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override bool Equals(
    Object o
)
Public Overrides Function Equals (
    o As Object
) As Boolean

Parameters

o
Type: SystemObject

Return Value

Type: Boolean
See Also

Reference

PropertySerializerAttribute Class
CodeSmith.Engine Namespace


PropertySerializerAttribute.GetHashCode Method

PropertySerializerAttributeGetHashCode Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
See Also

Reference

PropertySerializerAttribute Class
CodeSmith.Engine Namespace


PropertySerializerContext Class

Context information passed into the IPropertySerializer methods.
Inheritance Hierarchy
SystemObject
CodeSmith.EnginePropertySerializerContext

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class PropertySerializerContext
Public Class PropertySerializerContext

The PropertySerializerContext type exposes the following members.

Constructors
 | Name | Description
Public method | PropertySerializerContext(ITypeDescriptorContext) | Initializes a new instance of the PropertySerializerContext class
Public method | PropertySerializerContext(PropertyInfo, CodeTemplate) | Initializes a new instance of the PropertySerializerContext class.
Public method | PropertySerializerContext(PropertyInfo, CodeTemplate, String) | Initializes a new instance of the PropertySerializerContext class.
Top
Properties
 | Name | Description
Public property | Instance | The CodeTemplate instance that the context points to.
Public property | PropertyInfo | The property that the context points to.
Public property | WorkingDirectory | The working directory for resolving and creating relative paths.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSmith.Engine Namespace


PropertySerializerContext Constructor

Overload List
 | Name | Description
Public method | PropertySerializerContext(ITypeDescriptorContext) | Initializes a new instance of the PropertySerializerContext class
Public method | PropertySerializerContext(PropertyInfo, CodeTemplate) | Initializes a new instance of the PropertySerializerContext class.
Public method | PropertySerializerContext(PropertyInfo, CodeTemplate, String) | Initializes a new instance of the PropertySerializerContext class.
Top
See Also

Reference

PropertySerializerContext Class
CodeSmith.Engine Namespace


PropertySerializerContext Constructor (ITypeDescriptorContext)

Initializes a new instance of the PropertySerializerContext class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public PropertySerializerContext(
    ITypeDescriptorContext context
)
Public Sub New (
    context As ITypeDescriptorContext
)

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
See Also

Reference

PropertySerializerContext Class
PropertySerializerContext Overload
CodeSmith.Engine Namespace


PropertySerializerContext Constructor (PropertyInfo, CodeTemplate)

Initializes a new instance of the PropertySerializerContext class.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public PropertySerializerContext(
    PropertyInfo propertyInfo,
    CodeTemplate instance
)
Public Sub New (
    propertyInfo As PropertyInfo,
    instance As CodeTemplate
)

Parameters

propertyInfo
Type: System.ReflectionPropertyInfo
The property that the context points to.
instance
Type: CodeSmith.EngineCodeTemplate
The CodeTemplate instance that the context points to.
See Also

Reference

PropertySerializerContext Class
PropertySerializerContext Overload
CodeSmith.Engine Namespace


PropertySerializerContext Constructor (PropertyInfo, CodeTemplate, String)

Initializes a new instance of the PropertySerializerContext class.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public PropertySerializerContext(
    PropertyInfo propertyInfo,
    CodeTemplate instance,
    string workingDirectory
)
Public Sub New (
    propertyInfo As PropertyInfo,
    instance As CodeTemplate,
    workingDirectory As String
)

Parameters

propertyInfo
Type: System.ReflectionPropertyInfo
The property info.
instance
Type: CodeSmith.EngineCodeTemplate
The instance.
workingDirectory
Type: SystemString
The working directory.
See Also

Reference

PropertySerializerContext Class
PropertySerializerContext Overload
CodeSmith.Engine Namespace


PropertySerializerContext Properties

The PropertySerializerContext type exposes the following members.

Properties
 | Name | Description
Public property | Instance | The CodeTemplate instance that the context points to.
Public property | PropertyInfo | The property that the context points to.
Public property | WorkingDirectory | The working directory for resolving and creating relative paths.
Top
See Also

Reference

PropertySerializerContext Class
CodeSmith.Engine Namespace


PropertySerializerContext.Instance Property

PropertySerializerContextInstance Property

The CodeTemplate instance that the context points to.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CodeTemplate Instance { get; }
Public ReadOnly Property Instance As CodeTemplate
    Get

Property Value

Type: CodeTemplate
See Also

Reference

PropertySerializerContext Class
CodeSmith.Engine Namespace


PropertySerializerContext.PropertyInfo Property

PropertySerializerContextPropertyInfo Property

The property that the context points to.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public PropertyInfo PropertyInfo { get; }
Public ReadOnly Property PropertyInfo As PropertyInfo
    Get

Property Value

Type: PropertyInfo
See Also

Reference

PropertySerializerContext Class
CodeSmith.Engine Namespace


PropertySerializerContext.WorkingDirectory Property

PropertySerializerContextWorkingDirectory Property

The working directory for resolving and creating relative paths.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string WorkingDirectory { get; }
Public ReadOnly Property WorkingDirectory As String
    Get

Property Value

Type: String
See Also

Reference

PropertySerializerContext Class
CodeSmith.Engine Namespace


PropertySerializerContext Methods

The PropertySerializerContext type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PropertySerializerContext Class
CodeSmith.Engine Namespace


PropertySetCache Class

Inheritance Hierarchy
SystemObject
CodeSmith.EnginePropertySetCache

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class PropertySetCache
Public Class PropertySetCache

The PropertySetCache type exposes the following members.

Constructors
 | Name | Description
Public method | PropertySetCache | Initializes a new instance of the PropertySetCache class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | LoadPropertySetFromCache |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SavePropertySetToCache |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSmith.Engine Namespace


PropertySetCache Constructor

Initializes a new instance of the PropertySetCache class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public PropertySetCache()
Public Sub New
See Also

Reference

PropertySetCache Class
CodeSmith.Engine Namespace


PropertySetCache Methods

The PropertySetCache type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | LoadPropertySetFromCache |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SavePropertySetToCache |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PropertySetCache Class
CodeSmith.Engine Namespace


PropertySetCache.LoadPropertySetFromCache Method

PropertySetCacheLoadPropertySetFromCache Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static void LoadPropertySetFromCache(
    CodeTemplate template
)
Public Shared Sub LoadPropertySetFromCache (
    template As CodeTemplate
)

Parameters

template
Type: CodeSmith.EngineCodeTemplate
See Also

Reference

PropertySetCache Class
CodeSmith.Engine Namespace


PropertySetCache.SavePropertySetToCache Method

PropertySetCacheSavePropertySetToCache Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static void SavePropertySetToCache(
    CodeTemplate template
)
Public Shared Sub SavePropertySetToCache (
    template As CodeTemplate
)

Parameters

template
Type: CodeSmith.EngineCodeTemplate
See Also

Reference

PropertySetCache Class
CodeSmith.Engine Namespace


RegisteredContent Class

Inheritance Hierarchy
SystemObject
CodeSmith.EngineRegisteredContent

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class RegisteredContent : IDictionary<string, string>,
    ICollection<KeyValuePair<string, string>>, IEnumerable<KeyValuePair<string, string>>,
    IEnumerable
Public Class RegisteredContent
    Implements IDictionary(Of String, String),
    ICollection(Of KeyValuePair(Of String, String)), IEnumerable(Of KeyValuePair(Of String, String)),
    IEnumerable

The RegisteredContent type exposes the following members.

Constructors
 | Name | Description
Public method | RegisteredContent | Initializes a new instance of the RegisteredContent class
Top
Properties
 | Name | Description
Public property | Count |
Public property | ItemString |
Public property | ItemString, String |
Public property | Keys |
Public property | Values |
Top
Methods
 | Name | Description
Public method | Add(String, String) |
Public method | Add(String, String, String) |
Public method | Clear |
Public method | ContainsKey(String) |
Public method | ContainsKey(String, String) |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsOriginalContent | Checks to see if the in memory content is the same as the original source content.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(String) |
Public method | Remove(String, String) |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryGetValue(String, String) |
Public method | TryGetValue(String, String, String) |
Top
Extension Methods
 | Name | Description
Public Extension Method | AsIndexedEnumerableKeyValuePairString, String | Returns an IndexedEnumerable from any collection implementing IEnumerable<T> (Defined by IndexedEnumerable.)
Top
See Also

Reference

CodeSmith.Engine Namespace


RegisteredContent Constructor

Initializes a new instance of the RegisteredContent class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public RegisteredContent(
    IEngineHost host
)
Public Sub New (
    host As IEngineHost
)

Parameters

host
Type: CodeSmith.EngineIEngineHost
See Also

Reference

RegisteredContent Class
CodeSmith.Engine Namespace


RegisteredContent Properties

The RegisteredContent type exposes the following members.

Properties
 | Name | Description
Public property | Count |
Public property | ItemString |
Public property | ItemString, String |
Public property | Keys |
Public property | Values |
Top
See Also

Reference

RegisteredContent Class
CodeSmith.Engine Namespace


RegisteredContent.Count Property

RegisteredContentCount Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Implements

ICollectionTCount
See Also

Reference

RegisteredContent Class
CodeSmith.Engine Namespace


RegisteredContent.Item Property

RegisteredContentItem Property

Overload List
 | Name | Description
Public property | ItemString |
Public property | ItemString, String |
Top
See Also

Reference

RegisteredContent Class
CodeSmith.Engine Namespace


RegisteredContent.Item Property (String)

RegisteredContentItem Property (String)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string this[
    string path
] { get; set; }
Public Default Property Item (
    path As String
) As String
    Get
    Set

Parameters

path
Type: SystemString

Property Value

Type: String

Implements

IDictionaryTKey, TValueItemTKey
See Also

Reference

RegisteredContent Class
Item Overload
CodeSmith.Engine Namespace


RegisteredContent.Item Property (String, String)

RegisteredContentItem Property (String, String)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string this[
    string basePath,
    string path
] { get; set; }
Public Default Property Item (
    basePath As String,
    path As String
) As String
    Get
    Set

Parameters

basePath
Type: SystemString
path
Type: SystemString

Property Value

Type: String
See Also

Reference

RegisteredContent Class
Item Overload
CodeSmith.Engine Namespace


RegisteredContent.Keys Property

RegisteredContentKeys Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ICollection<string> Keys { get; }
Public ReadOnly Property Keys As ICollection(Of String)
    Get

Property Value

Type: ICollection String

Implements

IDictionaryTKey, TValueKeys
See Also

Reference

RegisteredContent Class
CodeSmith.Engine Namespace


RegisteredContent.Values Property

RegisteredContentValues Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ICollection<string> Values { get; }
Public ReadOnly Property Values As ICollection(Of String)
    Get

Property Value

Type: ICollection String

Implements

IDictionaryTKey, TValueValues
See Also

Reference

RegisteredContent Class
CodeSmith.Engine Namespace


RegisteredContent Methods

The RegisteredContent type exposes the following members.

Methods
 | Name | Description
Public method | Add(String, String) |
Public method | Add(String, String, String) |
Public method | Clear |
Public method | ContainsKey(String) |
Public method | ContainsKey(String, String) |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator |
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsOriginalContent | Checks to see if the in memory content is the same as the original source content.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(String) |
Public method | Remove(String, String) |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryGetValue(String, String) |
Public method | TryGetValue(String, String, String) |
Top
Extension Methods
 | Name | Description
Public Extension Method | AsIndexedEnumerableKeyValuePairString, String | Returns an IndexedEnumerable from any collection implementing IEnumerable<T> (Defined by IndexedEnumerable.)
Top
See Also

Reference

RegisteredContent Class
CodeSmith.Engine Namespace


RegisteredContent.Add Method

RegisteredContentAdd Method

Overload List
 | Name | Description
Public method | Add(String, String) |
Public method | Add(String, String, String) |
Top
See Also

Reference

RegisteredContent Class
CodeSmith.Engine Namespace


RegisteredContent.Add Method (String, String)

RegisteredContentAdd Method (String, String)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void Add(
    string path,
    string content
)
Public Sub Add (
    path As String,
    content As String
)

Parameters

path
Type: SystemString
content
Type: SystemString

Implements

IDictionaryTKey, TValueAdd(TKey, TValue)
See Also

Reference

RegisteredContent Class
Add Overload
CodeSmith.Engine Namespace


RegisteredContent.Add Method (String, String, String)

RegisteredContentAdd Method (String, String, String)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void Add(
    string basePath,
    string path,
    string content
)
Public Sub Add (
    basePath As String,
    path As String,
    content As String
)

Parameters

basePath
Type: SystemString
path
Type: SystemString
content
Type: SystemString
See Also

Reference

RegisteredContent Class
Add Overload
CodeSmith.Engine Namespace


RegisteredContent.Clear Method

RegisteredContentClear Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void Clear()
Public Sub Clear

Implements

ICollectionTClear
See Also

Reference

RegisteredContent Class
CodeSmith.Engine Namespace


RegisteredContent.ContainsKey Method

RegisteredContentContainsKey Method

Overload List
 | Name | Description
Public method | ContainsKey(String) |
Public method | ContainsKey(String, String) |
Top
See Also

Reference

RegisteredContent Class
CodeSmith.Engine Namespace


RegisteredContent.ContainsKey Method (String)

RegisteredContentContainsKey Method (String)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool ContainsKey(
    string path
)
Public Function ContainsKey (
    path As String
) As Boolean

Parameters

path
Type: SystemString

Return Value

Type: Boolean

Implements

IDictionaryTKey, TValueContainsKey(TKey)
See Also

Reference

RegisteredContent Class
ContainsKey Overload
CodeSmith.Engine Namespace


RegisteredContent.ContainsKey Method (String, String)

RegisteredContentContainsKey Method (String, String)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool ContainsKey(
    string basePath,
    string path
)
Public Function ContainsKey (
    basePath As String,
    path As String
) As Boolean

Parameters

basePath
Type: SystemString
path
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

RegisteredContent Class
ContainsKey Overload
CodeSmith.Engine Namespace


RegisteredContent.GetEnumerator Method

RegisteredContentGetEnumerator Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public IEnumerator<KeyValuePair<string, string>> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of KeyValuePair(Of String, String))

Return Value

Type: IEnumerator KeyValuePair String, String

Implements

IEnumerableTGetEnumerator
See Also

Reference

RegisteredContent Class
CodeSmith.Engine Namespace


RegisteredContent.GetHashCode Method

RegisteredContentGetHashCode Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
See Also

Reference

RegisteredContent Class
CodeSmith.Engine Namespace


RegisteredContent.IsOriginalContent Method

RegisteredContentIsOriginalContent Method

Checks to see if the in memory content is the same as the original source content.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual bool IsOriginalContent()
Public Overridable Function IsOriginalContent As Boolean

Return Value

Type: Boolean
See Also

Reference

RegisteredContent Class
CodeSmith.Engine Namespace


RegisteredContent.Remove Method

RegisteredContentRemove Method

Overload List
 | Name | Description
Public method | Remove(String) |
Public method | Remove(String, String) |
Top
See Also

Reference

RegisteredContent Class
CodeSmith.Engine Namespace


RegisteredContent.Remove Method (String)

RegisteredContentRemove Method (String)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool Remove(
    string path
)
Public Function Remove (
    path As String
) As Boolean

Parameters

path
Type: SystemString

Return Value

Type: Boolean

Implements

IDictionaryTKey, TValueRemove(TKey)
See Also

Reference

RegisteredContent Class
Remove Overload
CodeSmith.Engine Namespace


RegisteredContent.Remove Method (String, String)

RegisteredContentRemove Method (String, String)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool Remove(
    string basePath,
    string path
)
Public Function Remove (
    basePath As String,
    path As String
) As Boolean

Parameters

basePath
Type: SystemString
path
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

RegisteredContent Class
Remove Overload
CodeSmith.Engine Namespace


RegisteredContent.TryGetValue Method

RegisteredContentTryGetValue Method

Overload List
 | Name | Description
Public method | TryGetValue(String, String) |
Public method | TryGetValue(String, String, String) |
Top
See Also

Reference

RegisteredContent Class
CodeSmith.Engine Namespace


RegisteredContent.TryGetValue Method (String, String)

RegisteredContentTryGetValue Method (String, String)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool TryGetValue(
    string path,
    out string content
)
Public Function TryGetValue (
    path As String,
    <OutAttribute> ByRef content As String
) As Boolean

Parameters

path
Type: SystemString
content
Type: SystemString

Return Value

Type: Boolean

Implements

IDictionaryTKey, TValueTryGetValue(TKey, TValue)
See Also

Reference

RegisteredContent Class
TryGetValue Overload
CodeSmith.Engine Namespace


RegisteredContent.TryGetValue Method (String, String, String)

RegisteredContentTryGetValue Method (String, String, String)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool TryGetValue(
    string basePath,
    string path,
    out string content
)
Public Function TryGetValue (
    basePath As String,
    path As String,
    <OutAttribute> ByRef content As String
) As Boolean

Parameters

basePath
Type: SystemString
path
Type: SystemString
content
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

RegisteredContent Class
TryGetValue Overload
CodeSmith.Engine Namespace


RenderMethod Delegate

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public delegate void RenderMethod(
    TextWriter writer,
    Control container
)
Public Delegate Sub RenderMethod (
    writer As TextWriter,
    container As Control
)

Parameters

writer
Type: System.IOTextWriter
container
Type: CodeSmith.EngineControl
See Also

Reference

CodeSmith.Engine Namespace


SafeDataReader Class

This is a DataReader that 'fixes' any null values before they are returned to our business code.
Inheritance Hierarchy
SystemObject
CodeSmith.EngineSafeDataReader

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class SafeDataReader : IDataReader,
    IDisposable, IDataRecord
Public Class SafeDataReader
    Implements IDataReader, IDisposable, IDataRecord

The SafeDataReader type exposes the following members.

Constructors
 | Name | Description
Public method | SafeDataReader | Initializes the SafeDataReader object to use data from the provided DataReader object.
Top
Properties
 | Name | Description
Protected property | DataReader | Get a reference to the underlying data reader object that actually contains the data from the data source.
Public property | Depth | Returns the depth property value from the datareader.
Public property | FieldCount | Returns the FieldCount property from the datareader.
Public property | IsClosed | Returns the IsClosed property value from the datareader.
Public property | ItemInt32 | Returns a value from the datareader.
Public property | ItemString | Returns a value from the datareader.
Public property | RecordsAffected | Returns the RecordsAffected property value from the underlying datareader.
Top
Methods
 | Name | Description
Public method | Close | Closes the datareader.
Public method | Dispose | Disposes the object.
Protected method | Dispose(Boolean) | Disposes the object.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Object finalizer. (Overrides ObjectFinalize.)
Public method | GetBoolean(Int32) | Gets a boolean value from the datareader.
Public method | GetBoolean(String) | Gets a boolean value from the datareader.
Public method | GetByte(Int32) | Gets a byte value from the datareader.
Public method | GetByte(String) | Gets a byte value from the datareader.
Public method | GetBytes(Int32, Int64, Byte, Int32, Int32) | Invokes the GetBytes method of the underlying datareader.
Public method | GetBytes(String, Int64, Byte, Int32, Int32) | Invokes the GetBytes method of the underlying datareader.
Public method | GetChar(Int32) | Gets a char value from the datareader.
Public method | GetChar(String) | Gets a char value from the datareader.
Public method | GetChars(Int32, Int64, Char, Int32, Int32) | Invokes the GetChars method of the underlying datareader.
Public method | GetChars(String, Int64, Char, Int32, Int32) | Invokes the GetChars method of the underlying datareader.
Public method | GetData(Int32) | Invokes the GetData method of the underlying datareader.
Public method | GetData(String) | Invokes the GetData method of the underlying datareader.
Public method | GetDataTypeName(Int32) | Invokes the GetDataTypeName method of the underlying datareader.
Public method | GetDataTypeName(String) | Invokes the GetDataTypeName method of the underlying datareader.
Public method | GetDateTime(Int32) | Gets a date value from the datareader.
Public method | GetDateTime(String) | Gets a date value from the datareader.
Public method | GetDecimal(Int32) | Gets a decimal value from the datareader.
Public method | GetDecimal(String) | Gets a decimal value from the datareader.
Public method | GetDouble(Int32) | Gets a double from the datareader.
Public method | GetDouble(String) | Gets a double from the datareader.
Public method | GetFieldType(Int32) | Invokes the GetFieldType method of the underlying datareader.
Public method | GetFieldType(String) | Invokes the GetFieldType method of the underlying datareader.
Public method | GetFloat(Int32) | Gets a Single value from the datareader.
Public method | GetFloat(String) | Gets a Single value from the datareader.
Public method | GetGuid(Int32) | Gets a Guid value from the datareader.
Public method | GetGuid(String) | Gets a Guid value from the datareader.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInt16(Int32) | Gets a Short value from the datareader.
Public method | GetInt16(String) | Gets a Short value from the datareader.
Public method | GetInt32(Int32) | Gets an integer from the datareader.
Public method | GetInt32(String) | Gets an integer from the datareader.
Public method | GetInt64(Int32) | Gets a Long value from the datareader.
Public method | GetInt64(String) | Gets a Long value from the datareader.
Public method | GetName | Invokes the GetName method of the underlying datareader.
Public method | GetOrdinal | Gets an ordinal value from the datareader.
Public method | GetSchemaTable | Invokes the GetSchemaTable method of the underlying datareader.
Public method | GetString(Int32) | Gets a string value from the datareader.
Public method | GetString(String) | Gets a string value from the datareader.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue(Int32) | Gets a value of type Object from the datareader.
Public method | GetValue(String) | Gets a value of type Object from the datareader.
Public method | GetValues | Invokes the GetValues method of the underlying datareader.
Public method | IsDBNull(Int32) | Invokes the IsDBNull method of the underlying datareader.
Public method | IsDBNull(String) | Invokes the IsDBNull method of the underlying datareader.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextResult | Moves to the next result set in the datareader.
Public method | Read | Reads the next row of data from the datareader.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSmith.Engine Namespace


SafeDataReader Constructor

Initializes the SafeDataReader object to use data from the provided DataReader object.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public SafeDataReader(
    IDataReader dataReader
)
Public Sub New (
    dataReader As IDataReader
)

Parameters

dataReader
Type: System.DataIDataReader
The source DataReader object containing the data.
See Also

Reference

SafeDataReader Class
CodeSmith.Engine Namespace


SafeDataReader Properties

The SafeDataReader type exposes the following members.

Properties
 | Name | Description
Protected property | DataReader | Get a reference to the underlying data reader object that actually contains the data from the data source.
Public property | Depth | Returns the depth property value from the datareader.
Public property | FieldCount | Returns the FieldCount property from the datareader.
Public property | IsClosed | Returns the IsClosed property value from the datareader.
Public property | ItemInt32 | Returns a value from the datareader.
Public property | ItemString | Returns a value from the datareader.
Public property | RecordsAffected | Returns the RecordsAffected property value from the underlying datareader.
Top
See Also

Reference

SafeDataReader Class
CodeSmith.Engine Namespace


SafeDataReader.DataReader Property

SafeDataReaderDataReader Property

Get a reference to the underlying data reader object that actually contains the data from the data source.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected IDataReader DataReader { get; }
Protected ReadOnly Property DataReader As IDataReader
    Get

Property Value

Type: IDataReader
See Also

Reference

SafeDataReader Class
CodeSmith.Engine Namespace


SafeDataReader.Depth Property

SafeDataReaderDepth Property

Returns the depth property value from the datareader.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public int Depth { get; }
Public ReadOnly Property Depth As Integer
    Get

Property Value

Type: Int32

Implements

IDataReaderDepth
See Also

Reference

SafeDataReader Class
CodeSmith.Engine Namespace


SafeDataReader.FieldCount Property

SafeDataReaderFieldCount Property

Returns the FieldCount property from the datareader.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public int FieldCount { get; }
Public ReadOnly Property FieldCount As Integer
    Get

Property Value

Type: Int32

Implements

IDataRecordFieldCount
See Also

Reference

SafeDataReader Class
CodeSmith.Engine Namespace


SafeDataReader.IsClosed Property

SafeDataReaderIsClosed Property

Returns the IsClosed property value from the datareader.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool IsClosed { get; }
Public ReadOnly Property IsClosed As Boolean
    Get

Property Value

Type: Boolean

Implements

IDataReaderIsClosed
See Also

Reference

SafeDataReader Class
CodeSmith.Engine Namespace


SafeDataReader.Item Property

SafeDataReaderItem Property

Overload List
 | Name | Description
Public property | ItemInt32 | Returns a value from the datareader.
Public property | ItemString | Returns a value from the datareader.
Top
See Also

Reference

SafeDataReader Class
CodeSmith.Engine Namespace


SafeDataReader.Item Property (Int32)

SafeDataReaderItem Property (Int32)

Returns a value from the datareader.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual Object this[
    int i
] { get; }
Public Overridable ReadOnly Default Property Item (
    i As Integer
) As Object
    Get

Parameters

i
Type: SystemInt32
Ordinal column position of the value.

Property Value

Type: Object

Implements

IDataRecordItemInt32
See Also

Reference

SafeDataReader Class
Item Overload
CodeSmith.Engine Namespace


SafeDataReader.Item Property (String)

SafeDataReaderItem Property (String)

Returns a value from the datareader.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public Object this[
    string name
] { get; }
Public ReadOnly Default Property Item (
    name As String
) As Object
    Get

Parameters

name
Type: SystemString
Name of the column containing the value.

Property Value

Type: Object

Implements

IDataRecordItemString
See Also

Reference

SafeDataReader Class
Item Overload
CodeSmith.Engine Namespace


SafeDataReader.RecordsAffected Property

SafeDataReaderRecordsAffected Property

Returns the RecordsAffected property value from the underlying datareader.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public int RecordsAffected { get; }
Public ReadOnly Property RecordsAffected As Integer
    Get

Property Value

Type: Int32

Implements

IDataReaderRecordsAffected
See Also

Reference

SafeDataReader Class
CodeSmith.Engine Namespace


SafeDataReader Methods

The SafeDataReader type exposes the following members.

Methods
 | Name | Description
Public method | Close | Closes the datareader.
Public method | Dispose | Disposes the object.
Protected method | Dispose(Boolean) | Disposes the object.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Object finalizer. (Overrides ObjectFinalize.)
Public method | GetBoolean(Int32) | Gets a boolean value from the datareader.
Public method | GetBoolean(String) | Gets a boolean value from the datareader.
Public method | GetByte(Int32) | Gets a byte value from the datareader.
Public method | GetByte(String) | Gets a byte value from the datareader.
Public method | GetBytes(Int32, Int64, Byte, Int32, Int32) | Invokes the GetBytes method of the underlying datareader.
Public method | GetBytes(String, Int64, Byte, Int32, Int32) | Invokes the GetBytes method of the underlying datareader.
Public method | GetChar(Int32) | Gets a char value from the datareader.
Public method | GetChar(String) | Gets a char value from the datareader.
Public method | GetChars(Int32, Int64, Char, Int32, Int32) | Invokes the GetChars method of the underlying datareader.
Public method | GetChars(String, Int64, Char, Int32, Int32) | Invokes the GetChars method of the underlying datareader.
Public method | GetData(Int32) | Invokes the GetData method of the underlying datareader.
Public method | GetData(String) | Invokes the GetData method of the underlying datareader.
Public method | GetDataTypeName(Int32) | Invokes the GetDataTypeName method of the underlying datareader.
Public method | GetDataTypeName(String) | Invokes the GetDataTypeName method of the underlying datareader.
Public method | GetDateTime(Int32) | Gets a date value from the datareader.
Public method | GetDateTime(String) | Gets a date value from the datareader.
Public method | GetDecimal(Int32) | Gets a decimal value from the datareader.
Public method | GetDecimal(String) | Gets a decimal value from the datareader.
Public method | GetDouble(Int32) | Gets a double from the datareader.
Public method | GetDouble(String) | Gets a double from the datareader.
Public method | GetFieldType(Int32) | Invokes the GetFieldType method of the underlying datareader.
Public method | GetFieldType(String) | Invokes the GetFieldType method of the underlying datareader.
Public method | GetFloat(Int32) | Gets a Single value from the datareader.
Public method | GetFloat(String) | Gets a Single value from the datareader.
Public method | GetGuid(Int32) | Gets a Guid value from the datareader.
Public method | GetGuid(String) | Gets a Guid value from the datareader.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetInt16(Int32) | Gets a Short value from the datareader.
Public method | GetInt16(String) | Gets a Short value from the datareader.
Public method | GetInt32(Int32) | Gets an integer from the datareader.
Public method | GetInt32(String) | Gets an integer from the datareader.
Public method | GetInt64(Int32) | Gets a Long value from the datareader.
Public method | GetInt64(String) | Gets a Long value from the datareader.
Public method | GetName | Invokes the GetName method of the underlying datareader.
Public method | GetOrdinal | Gets an ordinal value from the datareader.
Public method | GetSchemaTable | Invokes the GetSchemaTable method of the underlying datareader.
Public method | GetString(Int32) | Gets a string value from the datareader.
Public method | GetString(String) | Gets a string value from the datareader.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue(Int32) | Gets a value of type Object from the datareader.
Public method | GetValue(String) | Gets a value of type Object from the datareader.
Public method | GetValues | Invokes the GetValues method of the underlying datareader.
Public method | IsDBNull(Int32) | Invokes the IsDBNull method of the underlying datareader.
Public method | IsDBNull(String) | Invokes the IsDBNull method of the underlying datareader.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextResult | Moves to the next result set in the datareader.
Public method | Read | Reads the next row of data from the datareader.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SafeDataReader Class
CodeSmith.Engine Namespace


SafeDataReader.Close Method

SafeDataReaderClose Method

Closes the datareader.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void Close()
Public Sub Close

Implements

IDataReaderClose
See Also

Reference

SafeDataReader Class
CodeSmith.Engine Namespace


SafeDataReader.Dispose Method

SafeDataReaderDispose Method

Overload List
 | Name | Description
Public method | Dispose | Disposes the object.
Protected method | Dispose(Boolean) | Disposes the object.
Top
See Also

Reference

SafeDataReader Class
CodeSmith.Engine Namespace


SafeDataReader.Dispose Method

SafeDataReaderDispose Method

Disposes the object.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

SafeDataReader Class
Dispose Overload
CodeSmith.Engine Namespace


SafeDataReader.Dispose Method (Boolean)

SafeDataReaderDispose Method (Boolean)

Disposes the object.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
True if called by the public Dispose method.
See Also

Reference

SafeDataReader Class
Dispose Overload
CodeSmith.Engine Namespace


SafeDataReader.Finalize Method

SafeDataReaderFinalize Method

Object finalizer.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected override void Finalize()
Protected Overrides Sub Finalize

Implements

ObjectFinalize
See Also

Reference

SafeDataReader Class
CodeSmith.Engine Namespace


SafeDataReader.GetBoolean Method

SafeDataReaderGetBoolean Method

Overload List
 | Name | Description
Public method | GetBoolean(Int32) | Gets a boolean value from the datareader.
Public method | GetBoolean(String) | Gets a boolean value from the datareader.
Top
See Also

Reference

SafeDataReader Class
CodeSmith.Engine Namespace


SafeDataReader.GetBoolean Method (Int32)

SafeDataReaderGetBoolean Method (Int32)

Gets a boolean value from the datareader.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual bool GetBoolean(
    int i
)
Public Overridable Function GetBoolean (
    i As Integer
) As Boolean

Parameters

i
Type: SystemInt32
Ordinal column position of the value.

Return Value

Type: Boolean

Implements

IDataRecordGetBoolean(Int32)
Remarks
Returns for null.
See Also

Reference

SafeDataReader Class
GetBoolean Overload
CodeSmith.Engine Namespace


SafeDataReader.GetBoolean Method (String)

SafeDataReaderGetBoolean Method (String)

Gets a boolean value from the datareader.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool GetBoolean(
    string name
)
Public Function GetBoolean (
    name As String
) As Boolean

Parameters

name
Type: SystemString
Name of the column containing the value.

Return Value

Type: Boolean
Remarks
Returns for null.
See Also

Reference

SafeDataReader Class
GetBoolean Overload
CodeSmith.Engine Namespace


SafeDataReader.GetByte Method

SafeDataReaderGetByte Method

Overload List
 | Name | Description
Public method | GetByte(Int32) | Gets a byte value from the datareader.
Public method | GetByte(String) | Gets a byte value from the datareader.
Top
See Also

Reference

SafeDataReader Class
CodeSmith.Engine Namespace


SafeDataReader.GetByte Method (Int32)

SafeDataReaderGetByte Method (Int32)

Gets a byte value from the datareader.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual byte GetByte(
    int i
)
Public Overridable Function GetByte (
    i As Integer
) As Byte

Parameters

i
Type: SystemInt32
Ordinal column position of the value.

Return Value

Type: Byte

Implements

IDataRecordGetByte(Int32)
Remarks
Returns 0 for null.
See Also

Reference

SafeDataReader Class
GetByte Overload
CodeSmith.Engine Namespace


SafeDataReader.GetByte Method (String)

SafeDataReaderGetByte Method (String)

Gets a byte value from the datareader.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public byte GetByte(
    string name
)
Public Function GetByte (
    name As String
) As Byte

Parameters

name
Type: SystemString
Name of the column containing the value.

Return Value

Type: Byte
Remarks
Returns 0 for null.
See Also

Reference

SafeDataReader Class
GetByte Overload
CodeSmith.Engine Namespace


SafeDataReader.GetBytes Method

SafeDataReaderGetBytes Method

Overload List
 | Name | Description
Public method | GetBytes(Int32, Int64, Byte, Int32, Int32) | Invokes the GetBytes method of the underlying datareader.
Public method | GetBytes(String, Int64, Byte, Int32, Int32) | Invokes the GetBytes method of the underlying datareader.
Top
See Also

Reference

SafeDataReader Class
CodeSmith.Engine Namespace


SafeDataReader.GetBytes Method (Int32, Int64, Byte[], Int32, Int32)

SafeDataReaderGetBytes Method (Int32, Int64, Byte, Int32, Int32)

Invokes the GetBytes method of the underlying datareader.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual long GetBytes(
    int i,
    long fieldOffset,
    byte[] buffer,
    int bufferOffset,
    int length
)
Public Overridable Function GetBytes (
    i As Integer,
    fieldOffset As Long,
    buffer As Byte(),
    bufferOffset As Integer,
    length As Integer
) As Long

Parameters

i
Type: SystemInt32
Ordinal column position of the value.
fieldOffset
Type: SystemInt64
Offset position within the field.
buffer
Type: SystemByte
Array containing the data.
bufferOffset
Type: SystemInt32
Offset position within the buffer.
length
Type: SystemInt32
Length of data to read.

Return Value

Type: Int64

Implements

IDataRecordGetBytes(Int32, Int64, Byte, Int32, Int32)
Remarks
Returns 0 for null.
See Also

Reference

SafeDataReader Class
GetBytes Overload
CodeSmith.Engine Namespace


SafeDataReader.GetBytes Method (String, Int64, Byte[], Int32, Int32)

SafeDataReaderGetBytes Method (String, Int64, Byte, Int32, Int32)

Invokes the GetBytes method of the underlying datareader.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public long GetBytes(
    string name,
    long fieldOffset,
    byte[] buffer,
    int bufferOffset,
    int length
)
Public Function GetBytes (
    name As String,
    fieldOffset As Long,
    buffer As Byte(),
    bufferOffset As Integer,
    length As Integer
) As Long

Parameters

name
Type: SystemString
Name of the column containing the value.
fieldOffset
Type: SystemInt64
Offset position within the field.
buffer
Type: SystemByte
Array containing the data.
bufferOffset
Type: SystemInt32
Offset position within the buffer.
length
Type: SystemInt32
Length of data to read.

Return Value

Type: Int64
Remarks
Returns 0 for null.
See Also

Reference

SafeDataReader Class
GetBytes Overload
CodeSmith.Engine Namespace


SafeDataReader.GetChar Method

SafeDataReaderGetChar Method

Overload List
 | Name | Description
Public method | GetChar(Int32) | Gets a char value from the datareader.
Public method | GetChar(String) | Gets a char value from the datareader.
Top
See Also

Reference

SafeDataReader Class
CodeSmith.Engine Namespace


SafeDataReader.GetChar Method (Int32)

SafeDataReaderGetChar Method (Int32)

Gets a char value from the datareader.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual char GetChar(
    int i
)
Public Overridable Function GetChar (
    i As Integer
) As Char

Parameters

i
Type: SystemInt32
Ordinal column position of the value.

Return Value

Type: Char

Implements

IDataRecordGetChar(Int32)
Remarks
Returns Char.MinValue for null.
See Also

Reference

SafeDataReader Class
GetChar Overload
CodeSmith.Engine Namespace


SafeDataReader.GetChar Method (String)

SafeDataReaderGetChar Method (String)

Gets a char value from the datareader.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public char GetChar(
    string name
)
Public Function GetChar (
    name As String
) As Char

Parameters

name
Type: SystemString
Name of the column containing the value.

Return Value

Type: Char
Remarks
Returns Char.MinValue for null.
See Also

Reference

SafeDataReader Class
GetChar Overload
CodeSmith.Engine Namespace


SafeDataReader.GetChars Method

SafeDataReaderGetChars Method

Overload List
 | Name | Description
Public method | GetChars(Int32, Int64, Char, Int32, Int32) | Invokes the GetChars method of the underlying datareader.
Public method | GetChars(String, Int64, Char, Int32, Int32) | Invokes the GetChars method of the underlying datareader.
Top
See Also

Reference

SafeDataReader Class
CodeSmith.Engine Namespace


SafeDataReader.GetChars Method (Int32, Int64, Char[], Int32, Int32)

SafeDataReaderGetChars Method (Int32, Int64, Char, Int32, Int32)

Invokes the GetChars method of the underlying datareader.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual long GetChars(
    int i,
    long fieldOffset,
    char[] buffer,
    int bufferOffset,
    int length
)
Public Overridable Function GetChars (
    i As Integer,
    fieldOffset As Long,
    buffer As Char(),
    bufferOffset As Integer,
    length As Integer
) As Long

Parameters

i
Type: SystemInt32
Ordinal column position of the value.
fieldOffset
Type: SystemInt64
Offset position within the field.
buffer
Type: SystemChar
Array containing the data.
bufferOffset
Type: SystemInt32
Offset position within the buffer.
length
Type: SystemInt32
Length of data to read.

Return Value

Type: Int64

Implements

IDataRecordGetChars(Int32, Int64, Char, Int32, Int32)
Remarks
Returns 0 for null.
See Also

Reference

SafeDataReader Class
GetChars Overload
CodeSmith.Engine Namespace


SafeDataReader.GetChars Method (String, Int64, Char[], Int32, Int32)

SafeDataReaderGetChars Method (String, Int64, Char, Int32, Int32)

Invokes the GetChars method of the underlying datareader.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public long GetChars(
    string name,
    long fieldOffset,
    char[] buffer,
    int bufferOffset,
    int length
)
Public Function GetChars (
    name As String,
    fieldOffset As Long,
    buffer As Char(),
    bufferOffset As Integer,
    length As Integer
) As Long

Parameters

name
Type: SystemString
Name of the column containing the value.
fieldOffset
Type: SystemInt64
Offset position within the field.
buffer
Type: SystemChar
Array containing the data.
bufferOffset
Type: SystemInt32
Offset position within the buffer.
length
Type: SystemInt32
Length of data to read.

Return Value

Type: Int64
Remarks
Returns 0 for null.
See Also

Reference

SafeDataReader Class
GetChars Overload
CodeSmith.Engine Namespace


SafeDataReader.GetData Method

SafeDataReaderGetData Method

Overload List
 | Name | Description
Public method | GetData(Int32) | Invokes the GetData method of the underlying datareader.
Public method | GetData(String) | Invokes the GetData method of the underlying datareader.
Top
See Also

Reference

SafeDataReader Class
CodeSmith.Engine Namespace


SafeDataReader.GetData Method (Int32)

SafeDataReaderGetData Method (Int32)

Invokes the GetData method of the underlying datareader.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual IDataReader GetData(
    int i
)
Public Overridable Function GetData (
    i As Integer
) As IDataReader

Parameters

i
Type: SystemInt32
Ordinal column position of the value.

Return Value

Type: IDataReader

Implements

IDataRecordGetData(Int32)
See Also

Reference

SafeDataReader Class
GetData Overload
CodeSmith.Engine Namespace


SafeDataReader.GetData Method (String)

SafeDataReaderGetData Method (String)

Invokes the GetData method of the underlying datareader.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public IDataReader GetData(
    string name
)
Public Function GetData (
    name As String
) As IDataReader

Parameters

name
Type: SystemString
Name of the column containing the value.

Return Value

Type: IDataReader
See Also

Reference

SafeDataReader Class
GetData Overload
CodeSmith.Engine Namespace


SafeDataReader.GetDataTypeName Method

SafeDataReaderGetDataTypeName Method

Overload List
 | Name | Description
Public method | GetDataTypeName(Int32) | Invokes the GetDataTypeName method of the underlying datareader.
Public method | GetDataTypeName(String) | Invokes the GetDataTypeName method of the underlying datareader.
Top
See Also

Reference

SafeDataReader Class
CodeSmith.Engine Namespace


SafeDataReader.GetDataTypeName Method (Int32)

SafeDataReaderGetDataTypeName Method (Int32)

Invokes the GetDataTypeName method of the underlying datareader.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual string GetDataTypeName(
    int i
)
Public Overridable Function GetDataTypeName (
    i As Integer
) As String

Parameters

i
Type: SystemInt32
Ordinal column position of the value.

Return Value

Type: String

Implements

IDataRecordGetDataTypeName(Int32)
See Also

Reference

SafeDataReader Class
GetDataTypeName Overload
CodeSmith.Engine Namespace


SafeDataReader.GetDataTypeName Method (String)

SafeDataReaderGetDataTypeName Method (String)

Invokes the GetDataTypeName method of the underlying datareader.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string GetDataTypeName(
    string name
)
Public Function GetDataTypeName (
    name As String
) As String

Parameters

name
Type: SystemString
Name of the column containing the value.

Return Value

Type: String
See Also

Reference

SafeDataReader Class
GetDataTypeName Overload
CodeSmith.Engine Namespace


SafeDataReader.GetDateTime Method

SafeDataReaderGetDateTime Method

Overload List
 | Name | Description
Public method | GetDateTime(Int32) | Gets a date value from the datareader.
Public method | GetDateTime(String) | Gets a date value from the datareader.
Top
See Also

Reference

SafeDataReader Class
CodeSmith.Engine Namespace


SafeDataReader.GetDateTime Method (Int32)

SafeDataReaderGetDateTime Method (Int32)

Gets a date value from the datareader.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual DateTime GetDateTime(
    int i
)
Public Overridable Function GetDateTime (
    i As Integer
) As DateTime

Parameters

i
Type: SystemInt32
Ordinal column position of the value.

Return Value

Type: DateTime

Implements

IDataRecordGetDateTime(Int32)
Remarks
Returns DateTime.MinValue for null.
See Also

Reference

SafeDataReader Class
GetDateTime Overload
CodeSmith.Engine Namespace


SafeDataReader.GetDateTime Method (String)

SafeDataReaderGetDateTime Method (String)

Gets a date value from the datareader.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual DateTime GetDateTime(
    string name
)
Public Overridable Function GetDateTime (
    name As String
) As DateTime

Parameters

name
Type: SystemString
Name of the column containing the value.

Return Value

Type: DateTime
Remarks
Returns DateTime.MinValue for null.
See Also

Reference

SafeDataReader Class
GetDateTime Overload
CodeSmith.Engine Namespace


SafeDataReader.GetDecimal Method

SafeDataReaderGetDecimal Method

Overload List
 | Name | Description
Public method | GetDecimal(Int32) | Gets a decimal value from the datareader.
Public method | GetDecimal(String) | Gets a decimal value from the datareader.
Top
See Also

Reference

SafeDataReader Class
CodeSmith.Engine Namespace


SafeDataReader.GetDecimal Method (Int32)

SafeDataReaderGetDecimal Method (Int32)

Gets a decimal value from the datareader.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual decimal GetDecimal(
    int i
)
Public Overridable Function GetDecimal (
    i As Integer
) As Decimal

Parameters

i
Type: SystemInt32
Ordinal column position of the value.

Return Value

Type: Decimal

Implements

IDataRecordGetDecimal(Int32)
Remarks
Returns 0 for null.
See Also

Reference

SafeDataReader Class
GetDecimal Overload
CodeSmith.Engine Namespace


SafeDataReader.GetDecimal Method (String)

SafeDataReaderGetDecimal Method (String)

Gets a decimal value from the datareader.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public decimal GetDecimal(
    string name
)
Public Function GetDecimal (
    name As String
) As Decimal

Parameters

name
Type: SystemString
Name of the column containing the value.

Return Value

Type: Decimal
Remarks
Returns 0 for null.
See Also

Reference

SafeDataReader Class
GetDecimal Overload
CodeSmith.Engine Namespace


SafeDataReader.GetDouble Method

SafeDataReaderGetDouble Method

Overload List
 | Name | Description
Public method | GetDouble(Int32) | Gets a double from the datareader.
Public method | GetDouble(String) | Gets a double from the datareader.
Top
See Also

Reference

SafeDataReader Class
CodeSmith.Engine Namespace


SafeDataReader.GetDouble Method (Int32)

SafeDataReaderGetDouble Method (Int32)

Gets a double from the datareader.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual double GetDouble(
    int i
)
Public Overridable Function GetDouble (
    i As Integer
) As Double

Parameters

i
Type: SystemInt32
Ordinal column position of the value.

Return Value

Type: Double

Implements

IDataRecordGetDouble(Int32)
Remarks
Returns 0 for null.
See Also

Reference

SafeDataReader Class
GetDouble Overload
CodeSmith.Engine Namespace


SafeDataReader.GetDouble Method (String)

SafeDataReaderGetDouble Method (String)

Gets a double from the datareader.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public double GetDouble(
    string name
)
Public Function GetDouble (
    name As String
) As Double

Parameters

name
Type: SystemString
Name of the column containing the value.

Return Value

Type: Double
Remarks
Returns 0 for null.
See Also

Reference

SafeDataReader Class
GetDouble Overload
CodeSmith.Engine Namespace


SafeDataReader.GetFieldType Method

SafeDataReaderGetFieldType Method

Overload List
 | Name | Description
Public method | GetFieldType(Int32) | Invokes the GetFieldType method of the underlying datareader.
Public method | GetFieldType(String) | Invokes the GetFieldType method of the underlying datareader.
Top
See Also

Reference

SafeDataReader Class
CodeSmith.Engine Namespace


SafeDataReader.GetFieldType Method (Int32)

SafeDataReaderGetFieldType Method (Int32)

Invokes the GetFieldType method of the underlying datareader.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual Type GetFieldType(
    int i
)
Public Overridable Function GetFieldType (
    i As Integer
) As Type

Parameters

i
Type: SystemInt32
Ordinal column position of the value.

Return Value

Type: Type

Implements

IDataRecordGetFieldType(Int32)
See Also

Reference

SafeDataReader Class
GetFieldType Overload
CodeSmith.Engine Namespace


SafeDataReader.GetFieldType Method (String)

SafeDataReaderGetFieldType Method (String)

Invokes the GetFieldType method of the underlying datareader.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public Type GetFieldType(
    string name
)
Public Function GetFieldType (
    name As String
) As Type

Parameters

name
Type: SystemString
Name of the column containing the value.

Return Value

Type: Type
See Also

Reference

SafeDataReader Class
GetFieldType Overload
CodeSmith.Engine Namespace


SafeDataReader.GetFloat Method

SafeDataReaderGetFloat Method

Overload List
 | Name | Description
Public method | GetFloat(Int32) | Gets a Single value from the datareader.
Public method | GetFloat(String) | Gets a Single value from the datareader.
Top
See Also

Reference

SafeDataReader Class
CodeSmith.Engine Namespace


SafeDataReader.GetFloat Method (Int32)

SafeDataReaderGetFloat Method (Int32)

Gets a Single value from the datareader.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual float GetFloat(
    int i
)
Public Overridable Function GetFloat (
    i As Integer
) As Single

Parameters

i
Type: SystemInt32
Ordinal column position of the value.

Return Value

Type: Single

Implements

IDataRecordGetFloat(Int32)
Remarks
Returns 0 for null.
See Also

Reference

SafeDataReader Class
GetFloat Overload
CodeSmith.Engine Namespace


SafeDataReader.GetFloat Method (String)

SafeDataReaderGetFloat Method (String)

Gets a Single value from the datareader.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public float GetFloat(
    string name
)
Public Function GetFloat (
    name As String
) As Single

Parameters

name
Type: SystemString
Name of the column containing the value.

Return Value

Type: Single
Remarks
Returns 0 for null.
See Also

Reference

SafeDataReader Class
GetFloat Overload
CodeSmith.Engine Namespace


SafeDataReader.GetGuid Method

SafeDataReaderGetGuid Method

Overload List
 | Name | Description
Public method | GetGuid(Int32) | Gets a Guid value from the datareader.
Public method | GetGuid(String) | Gets a Guid value from the datareader.
Top
See Also

Reference

SafeDataReader Class
CodeSmith.Engine Namespace


SafeDataReader.GetGuid Method (Int32)

SafeDataReaderGetGuid Method (Int32)

Gets a Guid value from the datareader.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual Guid GetGuid(
    int i
)
Public Overridable Function GetGuid (
    i As Integer
) As Guid

Parameters

i
Type: SystemInt32
Ordinal column position of the value.

Return Value

Type: Guid

Implements

IDataRecordGetGuid(Int32)
Remarks
Returns Guid.Empty for null.
See Also

Reference

SafeDataReader Class
GetGuid Overload
CodeSmith.Engine Namespace


SafeDataReader.GetGuid Method (String)

SafeDataReaderGetGuid Method (String)

Gets a Guid value from the datareader.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public Guid GetGuid(
    string name
)
Public Function GetGuid (
    name As String
) As Guid

Parameters

name
Type: SystemString
Name of the column containing the value.

Return Value

Type: Guid
Remarks
Returns Guid.Empty for null.
See Also

Reference

SafeDataReader Class
GetGuid Overload
CodeSmith.Engine Namespace


SafeDataReader.GetInt16 Method

SafeDataReaderGetInt16 Method

Overload List
 | Name | Description
Public method | GetInt16(Int32) | Gets a Short value from the datareader.
Public method | GetInt16(String) | Gets a Short value from the datareader.
Top
See Also

Reference

SafeDataReader Class
CodeSmith.Engine Namespace


SafeDataReader.GetInt16 Method (Int32)

SafeDataReaderGetInt16 Method (Int32)

Gets a Short value from the datareader.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual short GetInt16(
    int i
)
Public Overridable Function GetInt16 (
    i As Integer
) As Short

Parameters

i
Type: SystemInt32
Ordinal column position of the value.

Return Value

Type: Int16

Implements

IDataRecordGetInt16(Int32)
Remarks
Returns 0 for null.
See Also

Reference

SafeDataReader Class
GetInt16 Overload
CodeSmith.Engine Namespace


SafeDataReader.GetInt16 Method (String)

SafeDataReaderGetInt16 Method (String)

Gets a Short value from the datareader.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public short GetInt16(
    string name
)
Public Function GetInt16 (
    name As String
) As Short

Parameters

name
Type: SystemString
Name of the column containing the value.

Return Value

Type: Int16
Remarks
Returns 0 for null.
See Also

Reference

SafeDataReader Class
GetInt16 Overload
CodeSmith.Engine Namespace


SafeDataReader.GetInt32 Method

SafeDataReaderGetInt32 Method

Overload List
 | Name | Description
Public method | GetInt32(Int32) | Gets an integer from the datareader.
Public method | GetInt32(String) | Gets an integer from the datareader.
Top
See Also

Reference

SafeDataReader Class
CodeSmith.Engine Namespace


SafeDataReader.GetInt32 Method (Int32)

SafeDataReaderGetInt32 Method (Int32)

Gets an integer from the datareader.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual int GetInt32(
    int i
)
Public Overridable Function GetInt32 (
    i As Integer
) As Integer

Parameters

i
Type: SystemInt32
Ordinal column position of the value.

Return Value

Type: Int32

Implements

IDataRecordGetInt32(Int32)
Remarks
Returns 0 for null.
See Also

Reference

SafeDataReader Class
GetInt32 Overload
CodeSmith.Engine Namespace


SafeDataReader.GetInt32 Method (String)

SafeDataReaderGetInt32 Method (String)

Gets an integer from the datareader.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public int GetInt32(
    string name
)
Public Function GetInt32 (
    name As String
) As Integer

Parameters

name
Type: SystemString
Name of the column containing the value.

Return Value

Type: Int32
Remarks
Returns 0 for null.
See Also

Reference

SafeDataReader Class
GetInt32 Overload
CodeSmith.Engine Namespace


SafeDataReader.GetInt64 Method

SafeDataReaderGetInt64 Method

Overload List
 | Name | Description
Public method | GetInt64(Int32) | Gets a Long value from the datareader.
Public method | GetInt64(String) | Gets a Long value from the datareader.
Top
See Also

Reference

SafeDataReader Class
CodeSmith.Engine Namespace


SafeDataReader.GetInt64 Method (Int32)

SafeDataReaderGetInt64 Method (Int32)

Gets a Long value from the datareader.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual long GetInt64(
    int i
)
Public Overridable Function GetInt64 (
    i As Integer
) As Long

Parameters

i
Type: SystemInt32
Ordinal column position of the value.

Return Value

Type: Int64

Implements

IDataRecordGetInt64(Int32)
Remarks
Returns 0 for null.
See Also

Reference

SafeDataReader Class
GetInt64 Overload
CodeSmith.Engine Namespace


SafeDataReader.GetInt64 Method (String)

SafeDataReaderGetInt64 Method (String)

Gets a Long value from the datareader.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public long GetInt64(
    string name
)
Public Function GetInt64 (
    name As String
) As Long

Parameters

name
Type: SystemString
Name of the column containing the value.

Return Value

Type: Int64
Remarks
Returns 0 for null.
See Also

Reference

SafeDataReader Class
GetInt64 Overload
CodeSmith.Engine Namespace


SafeDataReader.GetName Method

SafeDataReaderGetName Method

Invokes the GetName method of the underlying datareader.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual string GetName(
    int i
)
Public Overridable Function GetName (
    i As Integer
) As String

Parameters

i
Type: SystemInt32
Ordinal column position of the value.

Return Value

Type: String

Implements

IDataRecordGetName(Int32)
See Also

Reference

SafeDataReader Class
CodeSmith.Engine Namespace


SafeDataReader.GetOrdinal Method

SafeDataReaderGetOrdinal Method

Gets an ordinal value from the datareader.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public int GetOrdinal(
    string name
)
Public Function GetOrdinal (
    name As String
) As Integer

Parameters

name
Type: SystemString
Name of the column containing the value.

Return Value

Type: Int32

Implements

IDataRecordGetOrdinal(String)
See Also

Reference

SafeDataReader Class
CodeSmith.Engine Namespace


SafeDataReader.GetSchemaTable Method

SafeDataReaderGetSchemaTable Method

Invokes the GetSchemaTable method of the underlying datareader.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public DataTable GetSchemaTable()
Public Function GetSchemaTable As DataTable

Return Value

Type: DataTable

Implements

IDataReaderGetSchemaTable
See Also

Reference

SafeDataReader Class
CodeSmith.Engine Namespace


SafeDataReader.GetString Method

SafeDataReaderGetString Method

Overload List
 | Name | Description
Public method | GetString(Int32) | Gets a string value from the datareader.
Public method | GetString(String) | Gets a string value from the datareader.
Top
See Also

Reference

SafeDataReader Class
CodeSmith.Engine Namespace


SafeDataReader.GetString Method (Int32)

SafeDataReaderGetString Method (Int32)

Gets a string value from the datareader.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual string GetString(
    int i
)
Public Overridable Function GetString (
    i As Integer
) As String

Parameters

i
Type: SystemInt32
Ordinal column position of the value.

Return Value

Type: String

Implements

IDataRecordGetString(Int32)
Remarks
Returns empty string for null.
See Also

Reference

SafeDataReader Class
GetString Overload
CodeSmith.Engine Namespace


SafeDataReader.GetString Method (String)

SafeDataReaderGetString Method (String)

Gets a string value from the datareader.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string GetString(
    string name
)
Public Function GetString (
    name As String
) As String

Parameters

name
Type: SystemString
Name of the column containing the value.

Return Value

Type: String
Remarks
Returns empty string for null.
See Also

Reference

SafeDataReader Class
GetString Overload
CodeSmith.Engine Namespace


SafeDataReader.GetValue Method

SafeDataReaderGetValue Method

Overload List
 | Name | Description
Public method | GetValue(Int32) | Gets a value of type Object from the datareader.
Public method | GetValue(String) | Gets a value of type Object from the datareader.
Top
See Also

Reference

SafeDataReader Class
CodeSmith.Engine Namespace


SafeDataReader.GetValue Method (Int32)

SafeDataReaderGetValue Method (Int32)

Gets a value of type Object from the datareader.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual Object GetValue(
    int i
)
Public Overridable Function GetValue (
    i As Integer
) As Object

Parameters

i
Type: SystemInt32
Ordinal column position of the value.

Return Value

Type: Object

Implements

IDataRecordGetValue(Int32)
See Also

Reference

SafeDataReader Class
GetValue Overload
CodeSmith.Engine Namespace


SafeDataReader.GetValue Method (String)

SafeDataReaderGetValue Method (String)

Gets a value of type Object from the datareader.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public Object GetValue(
    string name
)
Public Function GetValue (
    name As String
) As Object

Parameters

name
Type: SystemString
Name of the column containing the value.

Return Value

Type: Object
See Also

Reference

SafeDataReader Class
GetValue Overload
CodeSmith.Engine Namespace


SafeDataReader.GetValues Method

SafeDataReaderGetValues Method

Invokes the GetValues method of the underlying datareader.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public int GetValues(
    Object[] values
)
Public Function GetValues (
    values As Object()
) As Integer

Parameters

values
Type: SystemObject
An array of System.Object to copy the values into.

Return Value

Type: Int32

Implements

IDataRecordGetValues(Object)
See Also

Reference

SafeDataReader Class
CodeSmith.Engine Namespace


SafeDataReader.IsDBNull Method

SafeDataReaderIsDBNull Method

Overload List
 | Name | Description
Public method | IsDBNull(Int32) | Invokes the IsDBNull method of the underlying datareader.
Public method | IsDBNull(String) | Invokes the IsDBNull method of the underlying datareader.
Top
See Also

Reference

SafeDataReader Class
CodeSmith.Engine Namespace


SafeDataReader.IsDBNull Method (Int32)

SafeDataReaderIsDBNull Method (Int32)

Invokes the IsDBNull method of the underlying datareader.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual bool IsDBNull(
    int i
)
Public Overridable Function IsDBNull (
    i As Integer
) As Boolean

Parameters

i
Type: SystemInt32
Ordinal column position of the value.

Return Value

Type: Boolean

Implements

IDataRecordIsDBNull(Int32)
See Also

Reference

SafeDataReader Class
IsDBNull Overload
CodeSmith.Engine Namespace


SafeDataReader.IsDBNull Method (String)

SafeDataReaderIsDBNull Method (String)

Invokes the IsDBNull method of the underlying datareader.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual bool IsDBNull(
    string name
)
Public Overridable Function IsDBNull (
    name As String
) As Boolean

Parameters

name
Type: SystemString
Name of the column containing the value.

Return Value

Type: Boolean
See Also

Reference

SafeDataReader Class
IsDBNull Overload
CodeSmith.Engine Namespace


SafeDataReader.NextResult Method

SafeDataReaderNextResult Method

Moves to the next result set in the datareader.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool NextResult()
Public Function NextResult As Boolean

Return Value

Type: Boolean

Implements

IDataReaderNextResult
See Also

Reference

SafeDataReader Class
CodeSmith.Engine Namespace


SafeDataReader.Read Method

SafeDataReaderRead Method

Reads the next row of data from the datareader.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool Read()
Public Function Read As Boolean

Return Value

Type: Boolean

Implements

IDataReaderRead
See Also

Reference

SafeDataReader Class
CodeSmith.Engine Namespace


SchemaArguments Class

Inheritance Hierarchy
SystemObject
CodeSmith.EngineSchemaArguments

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class SchemaArguments
Public Class SchemaArguments

The SchemaArguments type exposes the following members.

Constructors
 | Name | Description
Public method | SchemaArguments | Initializes a new instance of the SchemaArguments class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | AssemblyName |
Public field | Language |
Public field | Namespace |
Public field | Output |
Public field | Schema |
Top
See Also

Reference

CodeSmith.Engine Namespace


SchemaArguments Constructor

Initializes a new instance of the SchemaArguments class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public SchemaArguments()
Public Sub New
See Also

Reference

SchemaArguments Class
CodeSmith.Engine Namespace


SchemaArguments Methods

The SchemaArguments type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SchemaArguments Class
CodeSmith.Engine Namespace


SchemaArguments Fields

The SchemaArguments type exposes the following members.

Fields
 | Name | Description
Public field | AssemblyName |
Public field | Language |
Public field | Namespace |
Public field | Output |
Public field | Schema |
Top
See Also

Reference

SchemaArguments Class
CodeSmith.Engine Namespace


SchemaArguments.AssemblyName Field

SchemaArgumentsAssemblyName Field

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string AssemblyName
Public AssemblyName As String

Field Value

Type: String
See Also

Reference

SchemaArguments Class
CodeSmith.Engine Namespace


SchemaArguments.Language Field

SchemaArgumentsLanguage Field

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public OutputLanguage Language
Public Language As OutputLanguage

Field Value

Type: OutputLanguage
See Also

Reference

SchemaArguments Class
CodeSmith.Engine Namespace


SchemaArguments.Namespace Field

SchemaArgumentsNamespace Field

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string Namespace
Public Namespace As String

Field Value

Type: String
See Also

Reference

SchemaArguments Class
CodeSmith.Engine Namespace


SchemaArguments.Output Field

SchemaArgumentsOutput Field

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string Output
Public Output As String

Field Value

Type: String
See Also

Reference

SchemaArguments Class
CodeSmith.Engine Namespace


SchemaArguments.Schema Field

SchemaArgumentsSchema Field

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string Schema
Public Schema As String

Field Value

Type: String
See Also

Reference

SchemaArguments Class
CodeSmith.Engine Namespace


SerializableDictionary(TKey, TValue) Class

SerializableDictionaryTKey, TValue Class

Represents a xml serializable collection of keys and values.
Inheritance Hierarchy
SystemObject
System.Collections.GenericDictionary TKey, TValue
CodeSmith.EngineSerializableDictionaryTKey, TValue

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
public class SerializableDictionary<TKey, TValue> : Dictionary<TKey, TValue>,
    IXmlSerializable

<SerializableAttribute>
Public Class SerializableDictionary(Of TKey, TValue)
    Inherits Dictionary(Of TKey, TValue)
    Implements IXmlSerializable

Type Parameters

TKey
The type of the keys in the dictionary.
TValue
The type of the values in the dictionary.

The SerializableDictionaryTKey, TValue type exposes the following members.

Constructors
 | Name | Description
Public method | SerializableDictionaryTKey, TValue | Initializes a new instance of the SerializableDictionaryTKey, TValue class.
Public method | SerializableDictionaryTKey, TValue(IDictionaryTKey, TValue) | Initializes a new instance of the SerializableDictionaryTKey, TValue class.
Public method | SerializableDictionaryTKey, TValue(IEqualityComparerTKey) | Initializes a new instance of the SerializableDictionaryTKey, TValue class.
Public method | SerializableDictionaryTKey, TValue(Int32) | Initializes a new instance of the SerializableDictionaryTKey, TValue class.
Public method | SerializableDictionaryTKey, TValue(IDictionaryTKey, TValue, IEqualityComparerTKey) | Initializes a new instance of the SerializableDictionaryTKey, TValue class.
Public method | SerializableDictionaryTKey, TValue(Int32, IEqualityComparerTKey) | Initializes a new instance of the SerializableDictionaryTKey, TValue class.
Protected method | SerializableDictionaryTKey, TValue(SerializationInfo, StreamingContext) | Initializes a new instance of the SerializableDictionaryTKey, TValue class.
Top
Properties
 | Name | Description
Public property | Comparer | Gets the IEqualityComparerT that is used to determine equality of keys for the dictionary. (Inherited from Dictionary TKey, TValue.)
Public property | Count | Gets the number of key/value pairs contained in the DictionaryTKey, TValue. (Inherited from Dictionary TKey, TValue.)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary TKey, TValue.)
Public property | Keys | Gets a collection containing the keys in the DictionaryTKey, TValue. (Inherited from Dictionary TKey, TValue.)
Public property | Values | Gets a collection containing the values in the DictionaryTKey, TValue. (Inherited from Dictionary TKey, TValue.)
Top
Methods
 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary TKey, TValue.)
Public method | Clear | Removes all keys and values from the DictionaryTKey, TValue. (Inherited from Dictionary TKey, TValue.)
Public method | ContainsKey | Determines whether the DictionaryTKey, TValue contains the specified key. (Inherited from Dictionary TKey, TValue.)
Public method | ContainsValue | Determines whether the DictionaryTKey, TValue contains a specific value. (Inherited from Dictionary TKey, TValue.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the DictionaryTKey, TValue. (Inherited from Dictionary TKey, TValue.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the DictionaryTKey, TValue instance. (Inherited from Dictionary TKey, TValue.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary TKey, TValue.)
Public method | Remove | Removes the value with the specified key from the DictionaryTKey, TValue. (Inherited from Dictionary TKey, TValue.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary TKey, TValue.)
Top
See Also

Reference

CodeSmith.Engine Namespace


SerializableDictionary(TKey, TValue) Constructor

SerializableDictionaryTKey, TValue Constructor

Overload List
 | Name | Description
Public method | SerializableDictionaryTKey, TValue | Initializes a new instance of the SerializableDictionaryTKey, TValue class.
Public method | SerializableDictionaryTKey, TValue(IDictionaryTKey, TValue) | Initializes a new instance of the SerializableDictionaryTKey, TValue class.
Public method | SerializableDictionaryTKey, TValue(IEqualityComparerTKey) | Initializes a new instance of the SerializableDictionaryTKey, TValue class.
Public method | SerializableDictionaryTKey, TValue(Int32) | Initializes a new instance of the SerializableDictionaryTKey, TValue class.
Public method | SerializableDictionaryTKey, TValue(IDictionaryTKey, TValue, IEqualityComparerTKey) | Initializes a new instance of the SerializableDictionaryTKey, TValue class.
Public method | SerializableDictionaryTKey, TValue(Int32, IEqualityComparerTKey) | Initializes a new instance of the SerializableDictionaryTKey, TValue class.
Protected method | SerializableDictionaryTKey, TValue(SerializationInfo, StreamingContext) | Initializes a new instance of the SerializableDictionaryTKey, TValue class.
Top
See Also

Reference

SerializableDictionaryTKey, TValue Class
CodeSmith.Engine Namespace


SerializableDictionary(TKey, TValue) Constructor

SerializableDictionaryTKey, TValue Constructor

Initializes a new instance of the SerializableDictionaryTKey, TValue class.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public SerializableDictionary()
Public Sub New
See Also

Reference

SerializableDictionaryTKey, TValue Class
SerializableDictionaryTKey, TValue Overload
CodeSmith.Engine Namespace


SerializableDictionary(TKey, TValue) Constructor (IDictionary(TKey, TValue))

SerializableDictionaryTKey, TValue Constructor (IDictionaryTKey, TValue)

Initializes a new instance of the SerializableDictionaryTKey, TValue class.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public SerializableDictionary(
    IDictionary<TKey, TValue> dictionary
)
Public Sub New (
    dictionary As IDictionary(Of TKey, TValue)
)

Parameters

dictionary
Type: System.Collections.GenericIDictionary TKey, TValue
The dictionary.
See Also

Reference

SerializableDictionaryTKey, TValue Class
SerializableDictionaryTKey, TValue Overload
CodeSmith.Engine Namespace


SerializableDictionary(TKey, TValue) Constructor (IEqualityComparer(TKey))

SerializableDictionaryTKey, TValue Constructor (IEqualityComparerTKey)

Initializes a new instance of the SerializableDictionaryTKey, TValue class.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public SerializableDictionary(
    IEqualityComparer<TKey> comparer
)
Public Sub New (
    comparer As IEqualityComparer(Of TKey)
)

Parameters

comparer
Type: System.Collections.GenericIEqualityComparer TKey
The comparer.
See Also

Reference

SerializableDictionaryTKey, TValue Class
SerializableDictionaryTKey, TValue Overload
CodeSmith.Engine Namespace


SerializableDictionary(TKey, TValue) Constructor (Int32)

SerializableDictionaryTKey, TValue Constructor (Int32)

Initializes a new instance of the SerializableDictionaryTKey, TValue class.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public SerializableDictionary(
    int capacity
)
Public Sub New (
    capacity As Integer
)

Parameters

capacity
Type: SystemInt32
The capacity.
See Also

Reference

SerializableDictionaryTKey, TValue Class
SerializableDictionaryTKey, TValue Overload
CodeSmith.Engine Namespace


SerializableDictionary(TKey, TValue) Constructor (IDictionary(TKey, TValue), IEqualityComparer(TKey))

SerializableDictionaryTKey, TValue Constructor (IDictionaryTKey, TValue, IEqualityComparerTKey)

Initializes a new instance of the SerializableDictionaryTKey, TValue class.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public SerializableDictionary(
    IDictionary<TKey, TValue> dictionary,
    IEqualityComparer<TKey> comparer
)
Public Sub New (
    dictionary As IDictionary(Of TKey, TValue),
    comparer As IEqualityComparer(Of TKey)
)

Parameters

dictionary
Type: System.Collections.GenericIDictionary TKey, TValue
The dictionary.
comparer
Type: System.Collections.GenericIEqualityComparer TKey
The comparer.
See Also

Reference

SerializableDictionaryTKey, TValue Class
SerializableDictionaryTKey, TValue Overload
CodeSmith.Engine Namespace


SerializableDictionary(TKey, TValue) Constructor (Int32, IEqualityComparer(TKey))

SerializableDictionaryTKey, TValue Constructor (Int32, IEqualityComparerTKey)

Initializes a new instance of the SerializableDictionaryTKey, TValue class.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public SerializableDictionary(
    int capacity,
    IEqualityComparer<TKey> comparer
)
Public Sub New (
    capacity As Integer,
    comparer As IEqualityComparer(Of TKey)
)

Parameters

capacity
Type: SystemInt32
The capacity.
comparer
Type: System.Collections.GenericIEqualityComparer TKey
The comparer.
See Also

Reference

SerializableDictionaryTKey, TValue Class
SerializableDictionaryTKey, TValue Overload
CodeSmith.Engine Namespace


SerializableDictionary(TKey, TValue) Constructor (SerializationInfo, StreamingContext)

SerializableDictionaryTKey, TValue Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the SerializableDictionaryTKey, TValue class.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected SerializableDictionary(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
A SerializationInfo object containing the information required to serialize the DictionaryTKey, TValue.
context
Type: System.Runtime.SerializationStreamingContext
A StreamingContext structure containing the source and destination of the serialized stream associated with the DictionaryTKey, TValue.
See Also

Reference

SerializableDictionaryTKey, TValue Class
SerializableDictionaryTKey, TValue Overload
CodeSmith.Engine Namespace


SerializableDictionary(TKey, TValue) Properties

SerializableDictionaryTKey, TValue Properties

The SerializableDictionaryTKey, TValue generic type exposes the following members.

Properties
 | Name | Description
Public property | Comparer | Gets the IEqualityComparerT that is used to determine equality of keys for the dictionary. (Inherited from Dictionary TKey, TValue .)
Public property | Count | Gets the number of key/value pairs contained in the DictionaryTKey, TValue. (Inherited from Dictionary TKey, TValue .)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary TKey, TValue .)
Public property | Keys | Gets a collection containing the keys in the DictionaryTKey, TValue. (Inherited from Dictionary TKey, TValue .)
Public property | Values | Gets a collection containing the values in the DictionaryTKey, TValue. (Inherited from Dictionary TKey, TValue .)
Top
See Also

Reference

SerializableDictionaryTKey, TValue Class
CodeSmith.Engine Namespace


SerializableDictionary(TKey, TValue) Methods

SerializableDictionaryTKey, TValue Methods

The SerializableDictionaryTKey, TValue generic type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary TKey, TValue .)
Public method | Clear | Removes all keys and values from the DictionaryTKey, TValue. (Inherited from Dictionary TKey, TValue .)
Public method | ContainsKey | Determines whether the DictionaryTKey, TValue contains the specified key. (Inherited from Dictionary TKey, TValue .)
Public method | ContainsValue | Determines whether the DictionaryTKey, TValue contains a specific value. (Inherited from Dictionary TKey, TValue .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the DictionaryTKey, TValue. (Inherited from Dictionary TKey, TValue .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the DictionaryTKey, TValue instance. (Inherited from Dictionary TKey, TValue .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary TKey, TValue .)
Public method | Remove | Removes the value with the specified key from the DictionaryTKey, TValue. (Inherited from Dictionary TKey, TValue .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary TKey, TValue .)
Top
See Also

Reference

SerializableDictionaryTKey, TValue Class
CodeSmith.Engine Namespace


ShowDialogEventArgs Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
CodeSmith.EngineShowDialogEventArgs

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
public class ShowDialogEventArgs : EventArgs
<SerializableAttribute>
Public Class ShowDialogEventArgs
    Inherits EventArgs

The ShowDialogEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ShowDialogEventArgs | Initializes a new instance of the ShowDialogEventArgs class
Top
Properties
 | Name | Description
Public property | Name |
Public property | ParentWindow |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSmith.Engine Namespace


ShowDialogEventArgs Constructor

Initializes a new instance of the ShowDialogEventArgs class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ShowDialogEventArgs()
Public Sub New
See Also

Reference

ShowDialogEventArgs Class
CodeSmith.Engine Namespace


ShowDialogEventArgs Properties

The ShowDialogEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Name |
Public property | ParentWindow |
Top
See Also

Reference

ShowDialogEventArgs Class
CodeSmith.Engine Namespace


ShowDialogEventArgs.Name Property

ShowDialogEventArgsName Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set

Property Value

Type: String
See Also

Reference

ShowDialogEventArgs Class
CodeSmith.Engine Namespace


ShowDialogEventArgs.ParentWindow Property

ShowDialogEventArgsParentWindow Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public IntPtr ParentWindow { get; set; }
Public Property ParentWindow As IntPtr
    Get
    Set

Property Value

Type: IntPtr
See Also

Reference

ShowDialogEventArgs Class
CodeSmith.Engine Namespace


ShowDialogEventArgs Methods

The ShowDialogEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ShowDialogEventArgs Class
CodeSmith.Engine Namespace


StatusChangedEventArgs Class

Inheritance Hierarchy
SystemObject
SystemEventArgs
CodeSmith.EngineStatusChangedEventArgs

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class StatusChangedEventArgs : EventArgs
Public Class StatusChangedEventArgs
    Inherits EventArgs

The StatusChangedEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | StatusChangedEventArgs | Initializes a new instance of the StatusChangedEventArgs class
Public method | StatusChangedEventArgs(String) | Initializes a new instance of the StatusChangedEventArgs class
Top
Properties
 | Name | Description
Public property | Status |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSmith.Engine Namespace


StatusChangedEventArgs Constructor

Overload List
 | Name | Description
Public method | StatusChangedEventArgs | Initializes a new instance of the StatusChangedEventArgs class
Public method | StatusChangedEventArgs(String) | Initializes a new instance of the StatusChangedEventArgs class
Top
See Also

Reference

StatusChangedEventArgs Class
CodeSmith.Engine Namespace


StatusChangedEventArgs Constructor

Initializes a new instance of the StatusChangedEventArgs class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public StatusChangedEventArgs()
Public Sub New
See Also

Reference

StatusChangedEventArgs Class
StatusChangedEventArgs Overload
CodeSmith.Engine Namespace


StatusChangedEventArgs Constructor (String)

Initializes a new instance of the StatusChangedEventArgs class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public StatusChangedEventArgs(
    string status
)
Public Sub New (
    status As String
)

Parameters

status
Type: SystemString
See Also

Reference

StatusChangedEventArgs Class
StatusChangedEventArgs Overload
CodeSmith.Engine Namespace


StatusChangedEventArgs Properties

The StatusChangedEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Status |
Top
See Also

Reference

StatusChangedEventArgs Class
CodeSmith.Engine Namespace


StatusChangedEventArgs.Status Property

StatusChangedEventArgsStatus Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string Status { get; }
Public ReadOnly Property Status As String
    Get

Property Value

Type: String
See Also

Reference

StatusChangedEventArgs Class
CodeSmith.Engine Namespace


StatusChangedEventArgs Methods

The StatusChangedEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

StatusChangedEventArgs Class
CodeSmith.Engine Namespace


StatusChangedEventHandler Delegate

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public delegate void StatusChangedEventHandler(
    Object sender,
    StatusChangedEventArgs e
)
Public Delegate Sub StatusChangedEventHandler (
    sender As Object,
    e As StatusChangedEventArgs
)

Parameters

sender
Type: SystemObject
e
Type: CodeSmith.EngineStatusChangedEventArgs
See Also

Reference

CodeSmith.Engine Namespace


StringUtil Class

Inheritance Hierarchy
SystemObject
CodeSmith.EngineStringUtil

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class StringUtil
Public Class StringUtil

The StringUtil type exposes the following members.

Methods
 | Name | Description
 | AppendOrdinalSuffix(Int32) | Takes a number and appends the ordinal suffix. ie. 1 = 1st, 13 = 13th.
 | AppendOrdinalSuffix(String) | Takes a number and appends the ordinal suffix. ie. 1 = 1st, 13 = 13th.
 | CalculateMd5Hash(String) |
 | CalculateMd5Hash(String, Encoding) |
 | CalculateSafeDirectoryName |
 | ContainsSpace | Determines if a string value contains a space.
 | ContainsString | Determines if a string value contains any of the strings passed in.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetCompilerVersion |
 | GetFileContent(String) |
 | GetFileContent(String, Encoding) |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetHashCode(String) |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | HtmlDecode |
 | IsNumeric | Determines if a string is a numeric value.
 | IsPlural(String) | Determines if a string is in plural form based on some simple rules.
 | IsPlural(String, MapCollection) | Determines if a string is in plural form based on some simple rules.
 | IsPlural(String, String) | Determines if a string is in plural form based on some simple rules.
 | IsSingular(String) | Determines if a string is in singular form based on some simple rules.
 | IsSingular(String, MapCollection) | Determines if a string is in singular form based on some simple rules.
 | IsSingular(String, String) | Determines if a string is in singular form based on some simple rules.
 | LineCount |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NormalizeLineEndings |
 | ParseBoolean |
 | ParseConfigString |
 | PrepareStatement |
 | ToCamelCase | Converts a string to use camelCase.
 | ToPascalCase | Converts a string to use PascalCase.
 | ToPlural(String) | Converts a string to plural based on some simple rules.
 | ToPlural(String, MapCollection) | Converts a string to plural based on some simple rules.
 | ToPlural(String, String) | Converts a string to plural based on some simple rules.
 | ToSameCase | Ensures that the value has the same casing as the original value.
 | ToSingular(String) | Converts a string to singular based on some simple rules.
 | ToSingular(String, MapCollection) | Converts a string to singular based on some simple rules.
 | ToSingular(String, String) | Converts a string to singular based on some simple rules.
 | ToSpacedWords | Takes a NameIdentifier and spaces it out into words "Name Identifier".
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | XmlEncode |
Top
See Also

Reference

CodeSmith.Engine Namespace


StringUtil Methods

The StringUtil type exposes the following members.

Methods
 | Name | Description
 | AppendOrdinalSuffix(Int32) | Takes a number and appends the ordinal suffix. ie. 1 = 1st, 13 = 13th.
 | AppendOrdinalSuffix(String) | Takes a number and appends the ordinal suffix. ie. 1 = 1st, 13 = 13th.
 | CalculateMd5Hash(String) |
 | CalculateMd5Hash(String, Encoding) |
 | CalculateSafeDirectoryName |
 | ContainsSpace | Determines if a string value contains a space.
 | ContainsString | Determines if a string value contains any of the strings passed in.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetCompilerVersion |
 | GetFileContent(String) |
 | GetFileContent(String, Encoding) |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetHashCode(String) |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | HtmlDecode |
 | IsNumeric | Determines if a string is a numeric value.
 | IsPlural(String) | Determines if a string is in plural form based on some simple rules.
 | IsPlural(String, MapCollection) | Determines if a string is in plural form based on some simple rules.
 | IsPlural(String, String) | Determines if a string is in plural form based on some simple rules.
 | IsSingular(String) | Determines if a string is in singular form based on some simple rules.
 | IsSingular(String, MapCollection) | Determines if a string is in singular form based on some simple rules.
 | IsSingular(String, String) | Determines if a string is in singular form based on some simple rules.
 | LineCount |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NormalizeLineEndings |
 | ParseBoolean |
 | ParseConfigString |
 | PrepareStatement |
 | ToCamelCase | Converts a string to use camelCase.
 | ToPascalCase | Converts a string to use PascalCase.
 | ToPlural(String) | Converts a string to plural based on some simple rules.
 | ToPlural(String, MapCollection) | Converts a string to plural based on some simple rules.
 | ToPlural(String, String) | Converts a string to plural based on some simple rules.
 | ToSameCase | Ensures that the value has the same casing as the original value.
 | ToSingular(String) | Converts a string to singular based on some simple rules.
 | ToSingular(String, MapCollection) | Converts a string to singular based on some simple rules.
 | ToSingular(String, String) | Converts a string to singular based on some simple rules.
 | ToSpacedWords | Takes a NameIdentifier and spaces it out into words "Name Identifier".
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | XmlEncode |
Top
See Also

Reference

StringUtil Class
CodeSmith.Engine Namespace


StringUtil.AppendOrdinalSuffix Method

StringUtilAppendOrdinalSuffix Method

Overload List
Name | Description
AppendOrdinalSuffix(Int32) | Takes a number and appends the ordinal suffix. ie. 1 = 1st, 13 = 13th.
AppendOrdinalSuffix(String) | Takes a number and appends the ordinal suffix. ie. 1 = 1st, 13 = 13th.
Top
See Also

Reference

StringUtil Class
CodeSmith.Engine Namespace


StringUtil.AppendOrdinalSuffix Method (Int32)

StringUtilAppendOrdinalSuffix Method (Int32)

Takes a number and appends the ordinal suffix. ie. 1 = 1st, 13 = 13th.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static string AppendOrdinalSuffix(
    int number
)
Public Shared Function AppendOrdinalSuffix (
    number As Integer
) As String

Parameters

number
Type: SystemInt32

Return Value

Type: String
See Also

Reference

StringUtil Class
AppendOrdinalSuffix Overload
CodeSmith.Engine Namespace


StringUtil.AppendOrdinalSuffix Method (String)

StringUtilAppendOrdinalSuffix Method (String)

Takes a number and appends the ordinal suffix. ie. 1 = 1st, 13 = 13th.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static string AppendOrdinalSuffix(
    string number
)
Public Shared Function AppendOrdinalSuffix (
    number As String
) As String

Parameters

number
Type: SystemString

Return Value

Type: String
See Also

Reference

StringUtil Class
AppendOrdinalSuffix Overload
CodeSmith.Engine Namespace


StringUtil.CalculateMd5Hash Method

StringUtilCalculateMd5Hash Method

Overload List
Name | Description
CalculateMd5Hash(String) |
CalculateMd5Hash(String, Encoding) |
Top
See Also

Reference

StringUtil Class
CodeSmith.Engine Namespace


StringUtil.CalculateMd5Hash Method (String)

StringUtilCalculateMd5Hash Method (String)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static string CalculateMd5Hash(
    string text
)
Public Shared Function CalculateMd5Hash (
    text As String
) As String

Parameters

text
Type: SystemString

Return Value

Type: String
See Also

Reference

StringUtil Class
CalculateMd5Hash Overload
CodeSmith.Engine Namespace


StringUtil.CalculateMd5Hash Method (String, Encoding)

StringUtilCalculateMd5Hash Method (String, Encoding)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static string CalculateMd5Hash(
    string text,
    Encoding encoding
)
Public Shared Function CalculateMd5Hash (
    text As String,
    encoding As Encoding
) As String

Parameters

text
Type: SystemString
encoding
Type: System.TextEncoding

Return Value

Type: String
See Also

Reference

StringUtil Class
CalculateMd5Hash Overload
CodeSmith.Engine Namespace


StringUtil.CalculateSafeDirectoryName Method

StringUtilCalculateSafeDirectoryName Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static string CalculateSafeDirectoryName(
    string text
)
Public Shared Function CalculateSafeDirectoryName (
    text As String
) As String

Parameters

text
Type: SystemString

Return Value

Type: String
See Also

Reference

StringUtil Class
CodeSmith.Engine Namespace


StringUtil.ContainsSpace Method

StringUtilContainsSpace Method

Determines if a string value contains a space.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static bool ContainsSpace(
    string value
)
Public Shared Function ContainsSpace (
    value As String
) As Boolean

Parameters

value
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

StringUtil Class
CodeSmith.Engine Namespace


StringUtil.ContainsString Method

StringUtilContainsString Method

Determines if a string value contains any of the strings passed in.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static bool ContainsString(
    string source,
    IEnumerable<string> wordList
)
Public Shared Function ContainsString (
    source As String,
    wordList As IEnumerable(Of String)
) As Boolean

Parameters

source
Type: SystemString
wordList
Type: System.Collections.GenericIEnumerable String

Return Value

Type: Boolean
See Also

Reference

StringUtil Class
CodeSmith.Engine Namespace


StringUtil.GetCompilerVersion Method

StringUtilGetCompilerVersion Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static Version GetCompilerVersion(
    string version
)
Public Shared Function GetCompilerVersion (
    version As String
) As Version

Parameters

version
Type: SystemString

Return Value

Type: Version
See Also

Reference

StringUtil Class
CodeSmith.Engine Namespace


StringUtil.GetFileContent Method

StringUtilGetFileContent Method

Overload List
Name | Description
GetFileContent(String) |
GetFileContent(String, Encoding) |
Top
See Also

Reference

StringUtil Class
CodeSmith.Engine Namespace


StringUtil.GetFileContent Method (String)

StringUtilGetFileContent Method (String)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static string GetFileContent(
    string path
)
Public Shared Function GetFileContent (
    path As String
) As String

Parameters

path
Type: SystemString

Return Value

Type: String
See Also

Reference

StringUtil Class
GetFileContent Overload
CodeSmith.Engine Namespace


StringUtil.GetFileContent Method (String, Encoding)

StringUtilGetFileContent Method (String, Encoding)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static string GetFileContent(
    string path,
    Encoding encoding
)
Public Shared Function GetFileContent (
    path As String,
    encoding As Encoding
) As String

Parameters

path
Type: SystemString
encoding
Type: System.TextEncoding

Return Value

Type: String
See Also

Reference

StringUtil Class
GetFileContent Overload
CodeSmith.Engine Namespace


StringUtil.GetHashCode Method

StringUtilGetHashCode Method

Overload List
 | Name | Description
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetHashCode(String) |
Top
See Also

Reference

StringUtil Class
CodeSmith.Engine Namespace


StringUtil.GetHashCode Method (String)

StringUtilGetHashCode Method (String)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static int GetHashCode(
    string s
)
Public Shared Function GetHashCode (
    s As String
) As Integer

Parameters

s
Type: SystemString

Return Value

Type: Int32
See Also

Reference

StringUtil Class
GetHashCode Overload
CodeSmith.Engine Namespace


StringUtil.HtmlDecode Method

StringUtilHtmlDecode Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static string HtmlDecode(
    string text
)
Public Shared Function HtmlDecode (
    text As String
) As String

Parameters

text
Type: SystemString

Return Value

Type: String
See Also

Reference

StringUtil Class
CodeSmith.Engine Namespace


StringUtil.IsNumeric Method

StringUtilIsNumeric Method

Determines if a string is a numeric value.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static bool IsNumeric(
    string value
)
Public Shared Function IsNumeric (
    value As String
) As Boolean

Parameters

value
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

StringUtil Class
CodeSmith.Engine Namespace


StringUtil.IsPlural Method

StringUtilIsPlural Method

Overload List
Name | Description
IsPlural(String) | Determines if a string is in plural form based on some simple rules.
IsPlural(String, MapCollection) | Determines if a string is in plural form based on some simple rules.
IsPlural(String, String) | Determines if a string is in plural form based on some simple rules.
Top
See Also

Reference

StringUtil Class
CodeSmith.Engine Namespace


StringUtil.IsPlural Method (String)

StringUtilIsPlural Method (String)

Determines if a string is in plural form based on some simple rules.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static bool IsPlural(
    string value
)
Public Shared Function IsPlural (
    value As String
) As Boolean

Parameters

value
Type: SystemString
The value to check.

Return Value

Type: Boolean
True, if the value is plural
See Also

Reference

StringUtil Class
IsPlural Overload
CodeSmith.Engine Namespace


StringUtil.IsPlural Method (String, MapCollection)

StringUtilIsPlural Method (String, MapCollection)

Determines if a string is in plural form based on some simple rules.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static bool IsPlural(
    string value,
    MapCollection pluralOverridesMap
)
Public Shared Function IsPlural (
    value As String,
    pluralOverridesMap As MapCollection
) As Boolean

Parameters

value
Type: SystemString
The value to check.
pluralOverridesMap
Type: CodeSmith.EngineMapCollection
The plural overrides map.

Return Value

Type: Boolean
True, if the value is plural
See Also

Reference

StringUtil Class
IsPlural Overload
CodeSmith.Engine Namespace


StringUtil.IsPlural Method (String, String)

StringUtilIsPlural Method (String, String)

Determines if a string is in plural form based on some simple rules.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static bool IsPlural(
    string value,
    string pluralOverridesMapFile
)
Public Shared Function IsPlural (
    value As String,
    pluralOverridesMapFile As String
) As Boolean

Parameters

value
Type: SystemString
The value to check.
pluralOverridesMapFile
Type: SystemString
The name of the plural overrides mapping file.

Return Value

Type: Boolean
True, if the value is plural
See Also

Reference

StringUtil Class
IsPlural Overload
CodeSmith.Engine Namespace


StringUtil.IsSingular Method

StringUtilIsSingular Method

Overload List
Name | Description
IsSingular(String) | Determines if a string is in singular form based on some simple rules.
IsSingular(String, MapCollection) | Determines if a string is in singular form based on some simple rules.
IsSingular(String, String) | Determines if a string is in singular form based on some simple rules.
Top
See Also

Reference

StringUtil Class
CodeSmith.Engine Namespace


StringUtil.IsSingular Method (String)

StringUtilIsSingular Method (String)

Determines if a string is in singular form based on some simple rules.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static bool IsSingular(
    string value
)
Public Shared Function IsSingular (
    value As String
) As Boolean

Parameters

value
Type: SystemString
The value to check.

Return Value

Type: Boolean
True, if the value is singular
See Also

Reference

StringUtil Class
IsSingular Overload
CodeSmith.Engine Namespace


StringUtil.IsSingular Method (String, MapCollection)

StringUtilIsSingular Method (String, MapCollection)

Determines if a string is in singular form based on some simple rules.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static bool IsSingular(
    string value,
    MapCollection pluralOverridesMap
)
Public Shared Function IsSingular (
    value As String,
    pluralOverridesMap As MapCollection
) As Boolean

Parameters

value
Type: SystemString
The value to check.
pluralOverridesMap
Type: CodeSmith.EngineMapCollection
The plural overrides map.

Return Value

Type: Boolean
True, if the value is singular
See Also

Reference

StringUtil Class
IsSingular Overload
CodeSmith.Engine Namespace


StringUtil.IsSingular Method (String, String)

StringUtilIsSingular Method (String, String)

Determines if a string is in singular form based on some simple rules.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static bool IsSingular(
    string value,
    string pluralOverridesMapFile
)
Public Shared Function IsSingular (
    value As String,
    pluralOverridesMapFile As String
) As Boolean

Parameters

value
Type: SystemString
The value to check.
pluralOverridesMapFile
Type: SystemString
The name of the plural overrides mapping file.

Return Value

Type: Boolean
True, if the value is singular
See Also

Reference

StringUtil Class
IsSingular Overload
CodeSmith.Engine Namespace


StringUtil.LineCount Method

StringUtilLineCount Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static int LineCount(
    string text,
    int offset,
    int newOffset
)
Public Shared Function LineCount (
    text As String,
    offset As Integer,
    newOffset As Integer
) As Integer

Parameters

text
Type: SystemString
offset
Type: SystemInt32
newOffset
Type: SystemInt32

Return Value

Type: Int32
See Also

Reference

StringUtil Class
CodeSmith.Engine Namespace


StringUtil.NormalizeLineEndings Method

StringUtilNormalizeLineEndings Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static string NormalizeLineEndings(
    string text
)
Public Shared Function NormalizeLineEndings (
    text As String
) As String

Parameters

text
Type: SystemString

Return Value

Type: String
See Also

Reference

StringUtil Class
CodeSmith.Engine Namespace


StringUtil.ParseBoolean Method

StringUtilParseBoolean Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static bool ParseBoolean(
    string value
)
Public Shared Function ParseBoolean (
    value As String
) As Boolean

Parameters

value
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

StringUtil Class
CodeSmith.Engine Namespace


StringUtil.ParseConfigString Method

StringUtilParseConfigString Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static Dictionary<string, string> ParseConfigString(
    string config
)
Public Shared Function ParseConfigString (
    config As String
) As Dictionary(Of String, String)

Parameters

config
Type: SystemString

Return Value

Type: Dictionary String, String
See Also

Reference

StringUtil Class
CodeSmith.Engine Namespace


StringUtil.PrepareStatement Method

StringUtilPrepareStatement Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static string PrepareStatement(
    string statement
)
Public Shared Function PrepareStatement (
    statement As String
) As String

Parameters

statement
Type: SystemString

Return Value

Type: String
See Also

Reference

StringUtil Class
CodeSmith.Engine Namespace


StringUtil.ToCamelCase Method

StringUtilToCamelCase Method

Converts a string to use camelCase.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static string ToCamelCase(
    string value
)
Public Shared Function ToCamelCase (
    value As String
) As String

Parameters

value
Type: SystemString

Return Value

Type: String
See Also

Reference

StringUtil Class
CodeSmith.Engine Namespace


StringUtil.ToPascalCase Method

StringUtilToPascalCase Method

Converts a string to use PascalCase.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static string ToPascalCase(
    string value
)
Public Shared Function ToPascalCase (
    value As String
) As String

Parameters

value
Type: SystemString
Text to convert

Return Value

Type: String
See Also

Reference

StringUtil Class
CodeSmith.Engine Namespace


StringUtil.ToPlural Method

StringUtilToPlural Method

Overload List
Name | Description
ToPlural(String) | Converts a string to plural based on some simple rules.
ToPlural(String, MapCollection) | Converts a string to plural based on some simple rules.
ToPlural(String, String) | Converts a string to plural based on some simple rules.
Top
See Also

Reference

StringUtil Class
CodeSmith.Engine Namespace


StringUtil.ToPlural Method (String)

StringUtilToPlural Method (String)

Converts a string to plural based on some simple rules.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static string ToPlural(
    string value
)
Public Shared Function ToPlural (
    value As String
) As String

Parameters

value
Type: SystemString
The value to convert.

Return Value

Type: String
See Also

Reference

StringUtil Class
ToPlural Overload
CodeSmith.Engine Namespace


StringUtil.ToPlural Method (String, MapCollection)

StringUtilToPlural Method (String, MapCollection)

Converts a string to plural based on some simple rules.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static string ToPlural(
    string value,
    MapCollection pluralOverridesMap
)
Public Shared Function ToPlural (
    value As String,
    pluralOverridesMap As MapCollection
) As String

Parameters

value
Type: SystemString
The value to convert.
pluralOverridesMap
Type: CodeSmith.EngineMapCollection
The plural overrides map.

Return Value

Type: String
See Also

Reference

StringUtil Class
ToPlural Overload
CodeSmith.Engine Namespace


StringUtil.ToPlural Method (String, String)

StringUtilToPlural Method (String, String)

Converts a string to plural based on some simple rules.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static string ToPlural(
    string value,
    string pluralOverridesMapFile
)
Public Shared Function ToPlural (
    value As String,
    pluralOverridesMapFile As String
) As String

Parameters

value
Type: SystemString
The value to convert.
pluralOverridesMapFile
Type: SystemString
The plural overrides map file.

Return Value

Type: String
See Also

Reference

StringUtil Class
ToPlural Overload
CodeSmith.Engine Namespace


StringUtil.ToSameCase Method

StringUtilToSameCase Method

Ensures that the value has the same casing as the original value.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static string ToSameCase(
    string original,
    string value
)
Public Shared Function ToSameCase (
    original As String,
    value As String
) As String

Parameters

original
Type: SystemString
value
Type: SystemString

Return Value

Type: String
See Also

Reference

StringUtil Class
CodeSmith.Engine Namespace


StringUtil.ToSingular Method

StringUtilToSingular Method

Overload List
Name | Description
ToSingular(String) | Converts a string to singular based on some simple rules.
ToSingular(String, MapCollection) | Converts a string to singular based on some simple rules.
ToSingular(String, String) | Converts a string to singular based on some simple rules.
Top
See Also

Reference

StringUtil Class
CodeSmith.Engine Namespace


StringUtil.ToSingular Method (String)

StringUtilToSingular Method (String)

Converts a string to singular based on some simple rules.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static string ToSingular(
    string value
)
Public Shared Function ToSingular (
    value As String
) As String

Parameters

value
Type: SystemString
The value to convert.

Return Value

Type: String
See Also

Reference

StringUtil Class
ToSingular Overload
CodeSmith.Engine Namespace


StringUtil.ToSingular Method (String, MapCollection)

StringUtilToSingular Method (String, MapCollection)

Converts a string to singular based on some simple rules.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static string ToSingular(
    string value,
    MapCollection pluralOverridesMap
)
Public Shared Function ToSingular (
    value As String,
    pluralOverridesMap As MapCollection
) As String

Parameters

value
Type: SystemString
The value to convert.
pluralOverridesMap
Type: CodeSmith.EngineMapCollection
The plural overrides map.

Return Value

Type: String
See Also

Reference

StringUtil Class
ToSingular Overload
CodeSmith.Engine Namespace


StringUtil.ToSingular Method (String, String)

StringUtilToSingular Method (String, String)

Converts a string to singular based on some simple rules.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static string ToSingular(
    string value,
    string pluralOverridesMapFile
)
Public Shared Function ToSingular (
    value As String,
    pluralOverridesMapFile As String
) As String

Parameters

value
Type: SystemString
The value to convert.
pluralOverridesMapFile
Type: SystemString
The plural overrides map file.

Return Value

Type: String
See Also

Reference

StringUtil Class
ToSingular Overload
CodeSmith.Engine Namespace


StringUtil.ToSpacedWords Method

StringUtilToSpacedWords Method

Takes a NameIdentifier and spaces it out into words "Name Identifier".

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static string ToSpacedWords(
    string value
)
Public Shared Function ToSpacedWords (
    value As String
) As String

Parameters

value
Type: SystemString

Return Value

Type: String
See Also

Reference

StringUtil Class
CodeSmith.Engine Namespace


StringUtil.XmlEncode Method

StringUtilXmlEncode Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static string XmlEncode(
    string value
)
Public Shared Function XmlEncode (
    value As String
) As String

Parameters

value
Type: SystemString

Return Value

Type: String
See Also

Reference

StringUtil Class
CodeSmith.Engine Namespace


TemplateContext Class

Inheritance Hierarchy
SystemObject
CodeSmith.EngineTemplateContext

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class TemplateContext : IDisposable
Public Class TemplateContext
    Implements IDisposable

The TemplateContext type exposes the following members.

Constructors
 | Name | Description
Public method | TemplateContext | Initializes a new instance of the TemplateContext class
Top
Properties
 | Name | Description
Public property | CodeTemplate | Returns the CodeTemplate that is being rendered in the current executing Thread.
 | Current | Returns the TemplateContext data associated with the current executing Thread.
Public property | ParentCodeTemplate | Returns the Parent CodeTemplate that is being rendered in the current executing Thread.
Public property | RootCodeTemplate | Returns the Root CodeTemplate that is being rendered in the current executing Thread.
Top
Methods
 | Name | Description
Public method | Dispose | Cleans up all resources associated with the TemplateContext.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SetContext | Adds a CodeTemplate instance to the current thread's TemplateContext.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSmith.Engine Namespace


TemplateContext Constructor

Initializes a new instance of the TemplateContext class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public TemplateContext()
Public Sub New
See Also

Reference

TemplateContext Class
CodeSmith.Engine Namespace


TemplateContext Properties

The TemplateContext type exposes the following members.

Properties
 | Name | Description
Public property | CodeTemplate | Returns the CodeTemplate that is being rendered in the current executing Thread.
 | Current | Returns the TemplateContext data associated with the current executing Thread.
Public property | ParentCodeTemplate | Returns the Parent CodeTemplate that is being rendered in the current executing Thread.
Public property | RootCodeTemplate | Returns the Root CodeTemplate that is being rendered in the current executing Thread.
Top
See Also

Reference

TemplateContext Class
CodeSmith.Engine Namespace


TemplateContext.CodeTemplate Property

TemplateContextCodeTemplate Property

Returns the CodeTemplate that is being rendered in the current executing Thread.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CodeTemplate CodeTemplate { get; }
Public ReadOnly Property CodeTemplate As CodeTemplate
    Get

Property Value

Type: CodeTemplate
See Also

Reference

TemplateContext Class
CodeSmith.Engine Namespace


TemplateContext.Current Property

TemplateContextCurrent Property

Returns the TemplateContext data associated with the current executing Thread.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static TemplateContext Current { get; }
Public Shared ReadOnly Property Current As TemplateContext
    Get

Property Value

Type: TemplateContext
See Also

Reference

TemplateContext Class
CodeSmith.Engine Namespace


TemplateContext.ParentCodeTemplate Property

TemplateContextParentCodeTemplate Property

Returns the Parent CodeTemplate that is being rendered in the current executing Thread.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CodeTemplate ParentCodeTemplate { get; }
Public ReadOnly Property ParentCodeTemplate As CodeTemplate
    Get

Property Value

Type: CodeTemplate
See Also

Reference

TemplateContext Class
CodeSmith.Engine Namespace


TemplateContext.RootCodeTemplate Property

TemplateContextRootCodeTemplate Property

Returns the Root CodeTemplate that is being rendered in the current executing Thread.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CodeTemplate RootCodeTemplate { get; }
Public ReadOnly Property RootCodeTemplate As CodeTemplate
    Get

Property Value

Type: CodeTemplate
See Also

Reference

TemplateContext Class
CodeSmith.Engine Namespace


TemplateContext Methods

The TemplateContext type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Cleans up all resources associated with the TemplateContext.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SetContext | Adds a CodeTemplate instance to the current thread's TemplateContext.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TemplateContext Class
CodeSmith.Engine Namespace


TemplateContext.Dispose Method

TemplateContextDispose Method

Cleans up all resources associated with the TemplateContext.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

TemplateContext Class
CodeSmith.Engine Namespace


TemplateContext.SetContext Method

TemplateContextSetContext Method

Adds a CodeTemplate instance to the current thread's TemplateContext.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static TemplateContext SetContext(
    CodeTemplate template
)
Public Shared Function SetContext (
    template As CodeTemplate
) As TemplateContext

Parameters

template
Type: CodeSmith.EngineCodeTemplate
The currently executing CodeTemplate

Return Value

Type: TemplateContext
An instance of the current TemplateContext.
See Also

Reference

TemplateContext Class
CodeSmith.Engine Namespace


TemplateEngine Class

Inheritance Hierarchy
SystemObject
CodeSmith.EngineTemplateEngine

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class TemplateEngine
Public Class TemplateEngine

The TemplateEngine type exposes the following members.

Constructors
 | Name | Description
Public method | TemplateEngine(IEngineHost) | Initializes a new instance of the TemplateEngine class
Public method | TemplateEngine(String) | Initializes a new instance of the TemplateEngine class
Top
Properties
 | Name | Description
Public property | Host |
Top
Methods
 | Name | Description
Public method | Compile(String) |
Public method | Compile(String, Boolean) |
Public method | CompileAsync |
 | CompileFile(String) |
 | CompileFile(String, Boolean) |
 | CompileFile(String, String) |
 | CompileFile(String, String, Boolean) |
 | CompileFileAsync(String) |
 | CompileFileAsync(String, CancellationToken) |
 | CompileFileAsync(String, String, CancellationToken) |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateTemplateSource |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Parse |
Public method | ParseAsync |
 | ParseFile(String) |
 | ParseFile(String, String) |
 | ParseFileAsync(String) |
 | ParseFileAsync(String, CancellationToken) |
 | ParseFileAsync(String, String, CancellationToken) |
 | ParseFileInfo(String) |
 | ParseFileInfo(String, String) |
 | ParseFileInfoAsync(String, CancellationToken) |
 | ParseFileInfoAsync(String, String, CancellationToken) |
Public method | ParseInfo |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSmith.Engine Namespace


TemplateEngine Constructor

Overload List
 | Name | Description
Public method | TemplateEngine(IEngineHost) | Initializes a new instance of the TemplateEngine class
Public method | TemplateEngine(String) | Initializes a new instance of the TemplateEngine class
Top
See Also

Reference

TemplateEngine Class
CodeSmith.Engine Namespace


TemplateEngine Constructor (IEngineHost)

Initializes a new instance of the TemplateEngine class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public TemplateEngine(
    IEngineHost host
)
Public Sub New (
    host As IEngineHost
)

Parameters

host
Type: CodeSmith.EngineIEngineHost
See Also

Reference

TemplateEngine Class
TemplateEngine Overload
CodeSmith.Engine Namespace


TemplateEngine Constructor (String)

Initializes a new instance of the TemplateEngine class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public TemplateEngine(
    string rootDirectory
)
Public Sub New (
    rootDirectory As String
)

Parameters

rootDirectory
Type: SystemString
See Also

Reference

TemplateEngine Class
TemplateEngine Overload
CodeSmith.Engine Namespace


TemplateEngine Properties

The TemplateEngine type exposes the following members.

Properties
 | Name | Description
Public property | Host |
Top
See Also

Reference

TemplateEngine Class
CodeSmith.Engine Namespace


TemplateEngine.Host Property

TemplateEngineHost Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public IEngineHost Host { get; set; }
Public Property Host As IEngineHost
    Get
    Set

Property Value

Type: IEngineHost
See Also

Reference

TemplateEngine Class
CodeSmith.Engine Namespace


TemplateEngine Methods

The TemplateEngine type exposes the following members.

Methods
 | Name | Description
Public method | Compile(String) |
Public method | Compile(String, Boolean) |
Public method | CompileAsync |
 | CompileFile(String) |
 | CompileFile(String, Boolean) |
 | CompileFile(String, String) |
 | CompileFile(String, String, Boolean) |
 | CompileFileAsync(String) |
 | CompileFileAsync(String, CancellationToken) |
 | CompileFileAsync(String, String, CancellationToken) |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateTemplateSource |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Parse |
Public method | ParseAsync |
 | ParseFile(String) |
 | ParseFile(String, String) |
 | ParseFileAsync(String) |
 | ParseFileAsync(String, CancellationToken) |
 | ParseFileAsync(String, String, CancellationToken) |
 | ParseFileInfo(String) |
 | ParseFileInfo(String, String) |
 | ParseFileInfoAsync(String, CancellationToken) |
 | ParseFileInfoAsync(String, String, CancellationToken) |
Public method | ParseInfo |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TemplateEngine Class
CodeSmith.Engine Namespace


TemplateEngine.Compile Method

TemplateEngineCompile Method

Overload List
 | Name | Description
Public method | Compile(String) |
Public method | Compile(String, Boolean) |
Top
See Also

Reference

TemplateEngine Class
CodeSmith.Engine Namespace


TemplateEngine.Compile Method (String)

TemplateEngineCompile Method (String)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CompileTemplateResult Compile(
    string path
)
Public Function Compile (
    path As String
) As CompileTemplateResult

Parameters

path
Type: SystemString

Return Value

Type: CompileTemplateResult
See Also

Reference

TemplateEngine Class
Compile Overload
CodeSmith.Engine Namespace


TemplateEngine.Compile Method (String, Boolean)

TemplateEngineCompile Method (String, Boolean)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CompileTemplateResult Compile(
    string path,
    bool useCache
)
Public Function Compile (
    path As String,
    useCache As Boolean
) As CompileTemplateResult

Parameters

path
Type: SystemString
useCache
Type: SystemBoolean

Return Value

Type: CompileTemplateResult
See Also

Reference

TemplateEngine Class
Compile Overload
CodeSmith.Engine Namespace


TemplateEngine.CompileAsync Method

TemplateEngineCompileAsync Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public Task<CompileTemplateResult> CompileAsync(
    string path,
    bool useCache,
    CancellationToken cancellationToken
)
Public Function CompileAsync (
    path As String,
    useCache As Boolean,
    cancellationToken As CancellationToken
) As Task(Of CompileTemplateResult)

Parameters

path
Type: SystemString
useCache
Type: SystemBoolean
cancellationToken
Type: System.ThreadingCancellationToken

Return Value

Type: Task CompileTemplateResult
See Also

Reference

TemplateEngine Class
CodeSmith.Engine Namespace


TemplateEngine.CompileFile Method

TemplateEngineCompileFile Method

Overload List
Name | Description
CompileFile(String) |
CompileFile(String, Boolean) |
CompileFile(String, String) |
CompileFile(String, String, Boolean) |
Top
See Also

Reference

TemplateEngine Class
CodeSmith.Engine Namespace


TemplateEngine.CompileFile Method (String)

TemplateEngineCompileFile Method (String)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static CompileTemplateResult CompileFile(
    string filePath
)
Public Shared Function CompileFile (
    filePath As String
) As CompileTemplateResult

Parameters

filePath
Type: SystemString

Return Value

Type: CompileTemplateResult
See Also

Reference

TemplateEngine Class
CompileFile Overload
CodeSmith.Engine Namespace


TemplateEngine.CompileFile Method (String, Boolean)

TemplateEngineCompileFile Method (String, Boolean)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static CompileTemplateResult CompileFile(
    string filePath,
    bool useCache
)
Public Shared Function CompileFile (
    filePath As String,
    useCache As Boolean
) As CompileTemplateResult

Parameters

filePath
Type: SystemString
useCache
Type: SystemBoolean

Return Value

Type: CompileTemplateResult
See Also

Reference

TemplateEngine Class
CompileFile Overload
CodeSmith.Engine Namespace


TemplateEngine.CompileFile Method (String, String)

TemplateEngineCompileFile Method (String, String)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static CompileTemplateResult CompileFile(
    string filePath,
    string content
)
Public Shared Function CompileFile (
    filePath As String,
    content As String
) As CompileTemplateResult

Parameters

filePath
Type: SystemString
content
Type: SystemString

Return Value

Type: CompileTemplateResult
See Also

Reference

TemplateEngine Class
CompileFile Overload
CodeSmith.Engine Namespace


TemplateEngine.CompileFile Method (String, String, Boolean)

TemplateEngineCompileFile Method (String, String, Boolean)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static CompileTemplateResult CompileFile(
    string filePath,
    string content,
    bool useCache
)
Public Shared Function CompileFile (
    filePath As String,
    content As String,
    useCache As Boolean
) As CompileTemplateResult

Parameters

filePath
Type: SystemString
content
Type: SystemString
useCache
Type: SystemBoolean

Return Value

Type: CompileTemplateResult
See Also

Reference

TemplateEngine Class
CompileFile Overload
CodeSmith.Engine Namespace


TemplateEngine.CompileFileAsync Method

TemplateEngineCompileFileAsync Method

Overload List
Name | Description
CompileFileAsync(String) |
CompileFileAsync(String, CancellationToken) |
CompileFileAsync(String, String, CancellationToken) |
Top
See Also

Reference

TemplateEngine Class
CodeSmith.Engine Namespace


TemplateEngine.CompileFileAsync Method (String)

TemplateEngineCompileFileAsync Method (String)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static Task<CompileTemplateResult> CompileFileAsync(
    string filePath
)
Public Shared Function CompileFileAsync (
    filePath As String
) As Task(Of CompileTemplateResult)

Parameters

filePath
Type: SystemString

Return Value

Type: Task CompileTemplateResult
See Also

Reference

TemplateEngine Class
CompileFileAsync Overload
CodeSmith.Engine Namespace


TemplateEngine.CompileFileAsync Method (String, CancellationToken)

TemplateEngineCompileFileAsync Method (String, CancellationToken)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static Task<CompileTemplateResult> CompileFileAsync(
    string filePath,
    CancellationToken cancellationToken
)
Public Shared Function CompileFileAsync (
    filePath As String,
    cancellationToken As CancellationToken
) As Task(Of CompileTemplateResult)

Parameters

filePath
Type: SystemString
cancellationToken
Type: System.ThreadingCancellationToken

Return Value

Type: Task CompileTemplateResult
See Also

Reference

TemplateEngine Class
CompileFileAsync Overload
CodeSmith.Engine Namespace


TemplateEngine.CompileFileAsync Method (String, String, CancellationToken)

TemplateEngineCompileFileAsync Method (String, String, CancellationToken)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static Task<CompileTemplateResult> CompileFileAsync(
    string filePath,
    string content,
    CancellationToken cancellationToken
)
Public Shared Function CompileFileAsync (
    filePath As String,
    content As String,
    cancellationToken As CancellationToken
) As Task(Of CompileTemplateResult)

Parameters

filePath
Type: SystemString
content
Type: SystemString
cancellationToken
Type: System.ThreadingCancellationToken

Return Value

Type: Task CompileTemplateResult
See Also

Reference

TemplateEngine Class
CompileFileAsync Overload
CodeSmith.Engine Namespace


TemplateEngine.GenerateTemplateSource Method

TemplateEngineGenerateTemplateSource Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string GenerateTemplateSource(
    TemplateParseResult parseResult
)
Public Function GenerateTemplateSource (
    parseResult As TemplateParseResult
) As String

Parameters

parseResult
Type: CodeSmith.EngineTemplateParseResult

Return Value

Type: String
See Also

Reference

TemplateEngine Class
CodeSmith.Engine Namespace


TemplateEngine.Parse Method

TemplateEngineParse Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public TemplateParseResult Parse(
    string path
)
Public Function Parse (
    path As String
) As TemplateParseResult

Parameters

path
Type: SystemString

Return Value

Type: TemplateParseResult
See Also

Reference

TemplateEngine Class
CodeSmith.Engine Namespace


TemplateEngine.ParseAsync Method

TemplateEngineParseAsync Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public Task<TemplateParseResult> ParseAsync(
    string path,
    CancellationToken cancellationToken
)
Public Function ParseAsync (
    path As String,
    cancellationToken As CancellationToken
) As Task(Of TemplateParseResult)

Parameters

path
Type: SystemString
cancellationToken
Type: System.ThreadingCancellationToken

Return Value

Type: Task TemplateParseResult
See Also

Reference

TemplateEngine Class
CodeSmith.Engine Namespace


TemplateEngine.ParseFile Method

TemplateEngineParseFile Method

Overload List
Name | Description
ParseFile(String) |
ParseFile(String, String) |
Top
See Also

Reference

TemplateEngine Class
CodeSmith.Engine Namespace


TemplateEngine.ParseFile Method (String)

TemplateEngineParseFile Method (String)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static TemplateParseResult ParseFile(
    string filePath
)
Public Shared Function ParseFile (
    filePath As String
) As TemplateParseResult

Parameters

filePath
Type: SystemString

Return Value

Type: TemplateParseResult
See Also

Reference

TemplateEngine Class
ParseFile Overload
CodeSmith.Engine Namespace


TemplateEngine.ParseFile Method (String, String)

TemplateEngineParseFile Method (String, String)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static TemplateParseResult ParseFile(
    string filePath,
    string content
)
Public Shared Function ParseFile (
    filePath As String,
    content As String
) As TemplateParseResult

Parameters

filePath
Type: SystemString
content
Type: SystemString

Return Value

Type: TemplateParseResult
See Also

Reference

TemplateEngine Class
ParseFile Overload
CodeSmith.Engine Namespace


TemplateEngine.ParseFileAsync Method

TemplateEngineParseFileAsync Method

Overload List
Name | Description
ParseFileAsync(String) |
ParseFileAsync(String, CancellationToken) |
ParseFileAsync(String, String, CancellationToken) |
Top
See Also

Reference

TemplateEngine Class
CodeSmith.Engine Namespace


TemplateEngine.ParseFileAsync Method (String)

TemplateEngineParseFileAsync Method (String)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static Task<TemplateParseResult> ParseFileAsync(
    string filePath
)
Public Shared Function ParseFileAsync (
    filePath As String
) As Task(Of TemplateParseResult)

Parameters

filePath
Type: SystemString

Return Value

Type: Task TemplateParseResult
See Also

Reference

TemplateEngine Class
ParseFileAsync Overload
CodeSmith.Engine Namespace


TemplateEngine.ParseFileAsync Method (String, CancellationToken)

TemplateEngineParseFileAsync Method (String, CancellationToken)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static Task<TemplateParseResult> ParseFileAsync(
    string filePath,
    CancellationToken cancellationToken
)
Public Shared Function ParseFileAsync (
    filePath As String,
    cancellationToken As CancellationToken
) As Task(Of TemplateParseResult)

Parameters

filePath
Type: SystemString
cancellationToken
Type: System.ThreadingCancellationToken

Return Value

Type: Task TemplateParseResult
See Also

Reference

TemplateEngine Class
ParseFileAsync Overload
CodeSmith.Engine Namespace


TemplateEngine.ParseFileAsync Method (String, String, CancellationToken)

TemplateEngineParseFileAsync Method (String, String, CancellationToken)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static Task<TemplateParseResult> ParseFileAsync(
    string filePath,
    string content,
    CancellationToken cancellationToken
)
Public Shared Function ParseFileAsync (
    filePath As String,
    content As String,
    cancellationToken As CancellationToken
) As Task(Of TemplateParseResult)

Parameters

filePath
Type: SystemString
content
Type: SystemString
cancellationToken
Type: System.ThreadingCancellationToken

Return Value

Type: Task TemplateParseResult
See Also

Reference

TemplateEngine Class
ParseFileAsync Overload
CodeSmith.Engine Namespace


TemplateEngine.ParseFileInfo Method

TemplateEngineParseFileInfo Method

Overload List
Name | Description
ParseFileInfo(String) |
ParseFileInfo(String, String) |
Top
See Also

Reference

TemplateEngine Class
CodeSmith.Engine Namespace


TemplateEngine.ParseFileInfo Method (String)

TemplateEngineParseFileInfo Method (String)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static TemplateParseResult ParseFileInfo(
    string filePath
)
Public Shared Function ParseFileInfo (
    filePath As String
) As TemplateParseResult

Parameters

filePath
Type: SystemString

Return Value

Type: TemplateParseResult
See Also

Reference

TemplateEngine Class
ParseFileInfo Overload
CodeSmith.Engine Namespace


TemplateEngine.ParseFileInfo Method (String, String)

TemplateEngineParseFileInfo Method (String, String)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static TemplateParseResult ParseFileInfo(
    string filePath,
    string content
)
Public Shared Function ParseFileInfo (
    filePath As String,
    content As String
) As TemplateParseResult

Parameters

filePath
Type: SystemString
content
Type: SystemString

Return Value

Type: TemplateParseResult
See Also

Reference

TemplateEngine Class
ParseFileInfo Overload
CodeSmith.Engine Namespace


TemplateEngine.ParseFileInfoAsync Method

TemplateEngineParseFileInfoAsync Method

Overload List
Name | Description
ParseFileInfoAsync(String, CancellationToken) |
ParseFileInfoAsync(String, String, CancellationToken) |
Top
See Also

Reference

TemplateEngine Class
CodeSmith.Engine Namespace


TemplateEngine.ParseFileInfoAsync Method (String, CancellationToken)

TemplateEngineParseFileInfoAsync Method (String, CancellationToken)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static Task<TemplateParseResult> ParseFileInfoAsync(
    string filePath,
    CancellationToken cancellationToken
)
Public Shared Function ParseFileInfoAsync (
    filePath As String,
    cancellationToken As CancellationToken
) As Task(Of TemplateParseResult)

Parameters

filePath
Type: SystemString
cancellationToken
Type: System.ThreadingCancellationToken

Return Value

Type: Task TemplateParseResult
See Also

Reference

TemplateEngine Class
ParseFileInfoAsync Overload
CodeSmith.Engine Namespace


TemplateEngine.ParseFileInfoAsync Method (String, String, CancellationToken)

TemplateEngineParseFileInfoAsync Method (String, String, CancellationToken)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static Task<TemplateParseResult> ParseFileInfoAsync(
    string filePath,
    string content,
    CancellationToken cancellationToken
)
Public Shared Function ParseFileInfoAsync (
    filePath As String,
    content As String,
    cancellationToken As CancellationToken
) As Task(Of TemplateParseResult)

Parameters

filePath
Type: SystemString
content
Type: SystemString
cancellationToken
Type: System.ThreadingCancellationToken

Return Value

Type: Task TemplateParseResult
See Also

Reference

TemplateEngine Class
ParseFileInfoAsync Overload
CodeSmith.Engine Namespace


TemplateEngine.ParseInfo Method

TemplateEngineParseInfo Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public TemplateParseResult ParseInfo(
    string path
)
Public Function ParseInfo (
    path As String
) As TemplateParseResult

Parameters

path
Type: SystemString

Return Value

Type: TemplateParseResult
See Also

Reference

TemplateEngine Class
CodeSmith.Engine Namespace


TemplateError Class

Inheritance Hierarchy
SystemObject
CodeSmith.EngineTemplateError

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
public class TemplateError : IParseError,
    IEquatable<TemplateError>, IComparable<TemplateError>
<SerializableAttribute>
Public Class TemplateError
    Implements IParseError, IEquatable(Of TemplateError),
    IComparable(Of TemplateError)

The TemplateError type exposes the following members.

Constructors
 | Name | Description
Public method | TemplateError(CompilerError) | Initializes a new instance of the TemplateError class
Public method | TemplateError(ValidationError) | Initializes a new instance of the TemplateError class
Public method | TemplateError(IParseError, String) | Initializes a new instance of the TemplateError class
Public method | TemplateError(ITemplateAstNode, String) | Initializes a new instance of the TemplateError class
Public method | TemplateError(TemplateError, String) | Creates a new Template Error while setting the SourceFilePath property.
Public method | TemplateError(ITemplateAstNode, String, String) | Initializes a new instance of the TemplateError class
Public method | TemplateError(ITemplateAstNode, String, String, Boolean) | Initializes a new instance of the TemplateError class
Public method | TemplateError(String, String, String, TextPositionRange, TemplateErrorLevel, TemplateErrorType) | Initializes a new instance of the TemplateError class
Public method | TemplateError(String, String, String, TextPositionRange, TemplateErrorLevel, TemplateErrorType, IClassificationType) | Initializes a new instance of the TemplateError class
Top
Properties
 | Name | Description
Public property | Description |
Public property | ErrorNumber |
Public property | FileName |
Public property | FilePath |
Public property | IsError |
Public property | IsMessage |
Public property | IsWarning |
Public property | Level |
Public property | PositionRange |
Public property | SourceFilePath |
Public property | Type |
Top
Methods
 | Name | Description
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(TemplateError) |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides ObjectToString.)
Top
See Also

Reference

CodeSmith.Engine Namespace


TemplateError Constructor

Overload List
 | Name | Description
Public method | TemplateError(CompilerError) | Initializes a new instance of the TemplateError class
Public method | TemplateError(ValidationError) | Initializes a new instance of the TemplateError class
Public method | TemplateError(IParseError, String) | Initializes a new instance of the TemplateError class
Public method | TemplateError(ITemplateAstNode, String) | Initializes a new instance of the TemplateError class
Public method | TemplateError(TemplateError, String) | Creates a new Template Error while setting the SourceFilePath property.
Public method | TemplateError(ITemplateAstNode, String, String) | Initializes a new instance of the TemplateError class
Public method | TemplateError(ITemplateAstNode, String, String, Boolean) | Initializes a new instance of the TemplateError class
Public method | TemplateError(String, String, String, TextPositionRange, TemplateErrorLevel, TemplateErrorType) | Initializes a new instance of the TemplateError class
Public method | TemplateError(String, String, String, TextPositionRange, TemplateErrorLevel, TemplateErrorType, IClassificationType) | Initializes a new instance of the TemplateError class
Top
See Also

Reference

TemplateError Class
CodeSmith.Engine Namespace


TemplateError Constructor (CompilerError)

Initializes a new instance of the TemplateError class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public TemplateError(
    CompilerError error
)
Public Sub New (
    error As CompilerError
)

Parameters

error
Type: System.CodeDom.CompilerCompilerError
See Also

Reference

TemplateError Class
TemplateError Overload
CodeSmith.Engine Namespace


TemplateError Constructor (ValidationError)

Initializes a new instance of the TemplateError class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public TemplateError(
    ValidationError error
)
Public Sub New (
    error As ValidationError
)

Parameters

error
Type: CodeSmith.EngineValidationError
See Also

Reference

TemplateError Class
TemplateError Overload
CodeSmith.Engine Namespace


TemplateError Constructor (IParseError, String)

Initializes a new instance of the TemplateError class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public TemplateError(
    IParseError error,
    string filePath
)
Public Sub New (
    error As IParseError,
    filePath As String
)

Parameters

error
Type: IParseError
filePath
Type: SystemString
See Also

Reference

TemplateError Class
TemplateError Overload
CodeSmith.Engine Namespace


TemplateError Constructor (ITemplateAstNode, String)

Initializes a new instance of the TemplateError class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public TemplateError(
    ITemplateAstNode node,
    string description
)
Public Sub New (
    node As ITemplateAstNode,
    description As String
)

Parameters

node
Type: ITemplateAstNode
description
Type: SystemString
See Also

Reference

TemplateError Class
TemplateError Overload
CodeSmith.Engine Namespace


TemplateError Constructor (TemplateError, String)

Creates a new Template Error while setting the SourceFilePath property.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public TemplateError(
    TemplateError error,
    string filePath
)
Public Sub New (
    error As TemplateError,
    filePath As String
)

Parameters

error
Type: CodeSmith.EngineTemplateError
filePath
Type: SystemString
See Also

Reference

TemplateError Class
TemplateError Overload
CodeSmith.Engine Namespace


TemplateError Constructor (ITemplateAstNode, String, String)

Initializes a new instance of the TemplateError class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public TemplateError(
    ITemplateAstNode node,
    string number,
    string description
)
Public Sub New (
    node As ITemplateAstNode,
    number As String,
    description As String
)

Parameters

node
Type: ITemplateAstNode
number
Type: SystemString
description
Type: SystemString
See Also

Reference

TemplateError Class
TemplateError Overload
CodeSmith.Engine Namespace


TemplateError Constructor (ITemplateAstNode, String, String, Boolean)

Initializes a new instance of the TemplateError class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public TemplateError(
    ITemplateAstNode node,
    string number,
    string description,
    bool isWarning
)
Public Sub New (
    node As ITemplateAstNode,
    number As String,
    description As String,
    isWarning As Boolean
)

Parameters

node
Type: ITemplateAstNode
number
Type: SystemString
description
Type: SystemString
isWarning
Type: SystemBoolean
See Also

Reference

TemplateError Class
TemplateError Overload
CodeSmith.Engine Namespace


TemplateError Constructor (String, String, String, TextPositionRange, TemplateErrorLevel, TemplateErrorType)

Initializes a new instance of the TemplateError class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public TemplateError(
    string errorNumber,
    string description,
    string filePath,
    TextPositionRange positionRange,
    TemplateErrorLevel level,
    TemplateErrorType errorType
)
Public Sub New (
    errorNumber As String,
    description As String,
    filePath As String,
    positionRange As TextPositionRange,
    level As TemplateErrorLevel,
    errorType As TemplateErrorType
)

Parameters

errorNumber
Type: SystemString
description
Type: SystemString
filePath
Type: SystemString
positionRange
Type: TextPositionRange
level
Type: CodeSmith.EngineTemplateErrorLevel
errorType
Type: CodeSmith.EngineTemplateErrorType
See Also

Reference

TemplateError Class
TemplateError Overload
CodeSmith.Engine Namespace


TemplateError Constructor (String, String, String, TextPositionRange, TemplateErrorLevel, TemplateErrorType, IClassificationType)

Initializes a new instance of the TemplateError class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public TemplateError(
    string errorNumber,
    string description,
    string filePath,
    TextPositionRange positionRange,
    TemplateErrorLevel level,
    TemplateErrorType errorType,
    IClassificationType classificationType
)
Public Sub New (
    errorNumber As String,
    description As String,
    filePath As String,
    positionRange As TextPositionRange,
    level As TemplateErrorLevel,
    errorType As TemplateErrorType,
    classificationType As IClassificationType
)

Parameters

errorNumber
Type: SystemString
description
Type: SystemString
filePath
Type: SystemString
positionRange
Type: TextPositionRange
level
Type: CodeSmith.EngineTemplateErrorLevel
errorType
Type: CodeSmith.EngineTemplateErrorType
classificationType
Type: IClassificationType
See Also

Reference

TemplateError Class
TemplateError Overload
CodeSmith.Engine Namespace


TemplateError Properties

The TemplateError type exposes the following members.

Properties
 | Name | Description
Public property | Description |
Public property | ErrorNumber |
Public property | FileName |
Public property | FilePath |
Public property | IsError |
Public property | IsMessage |
Public property | IsWarning |
Public property | Level |
Public property | PositionRange |
Public property | SourceFilePath |
Public property | Type |
Top
See Also

Reference

TemplateError Class
CodeSmith.Engine Namespace


TemplateError.Description Property

TemplateErrorDescription Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string Description { get; }
Public ReadOnly Property Description As String
    Get

Property Value

Type: String

Implements

IParseError.Description
See Also

Reference

TemplateError Class
CodeSmith.Engine Namespace


TemplateError.ErrorNumber Property

TemplateErrorErrorNumber Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string ErrorNumber { get; }
Public ReadOnly Property ErrorNumber As String
    Get

Property Value

Type: String
See Also

Reference

TemplateError Class
CodeSmith.Engine Namespace


TemplateError.FileName Property

TemplateErrorFileName Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string FileName { get; }
Public ReadOnly Property FileName As String
    Get

Property Value

Type: String
See Also

Reference

TemplateError Class
CodeSmith.Engine Namespace


TemplateError.FilePath Property

TemplateErrorFilePath Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string FilePath { get; }
Public ReadOnly Property FilePath As String
    Get

Property Value

Type: String
See Also

Reference

TemplateError Class
CodeSmith.Engine Namespace


TemplateError.IsError Property

TemplateErrorIsError Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool IsError { get; }
Public ReadOnly Property IsError As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

TemplateError Class
CodeSmith.Engine Namespace


TemplateError.IsMessage Property

TemplateErrorIsMessage Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool IsMessage { get; }
Public ReadOnly Property IsMessage As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

TemplateError Class
CodeSmith.Engine Namespace


TemplateError.IsWarning Property

TemplateErrorIsWarning Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool IsWarning { get; }
Public ReadOnly Property IsWarning As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

TemplateError Class
CodeSmith.Engine Namespace


TemplateError.Level Property

TemplateErrorLevel Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public TemplateErrorLevel Level { get; }
Public ReadOnly Property Level As TemplateErrorLevel
    Get

Property Value

Type: TemplateErrorLevel
See Also

Reference

TemplateError Class
CodeSmith.Engine Namespace


TemplateError.PositionRange Property

TemplateErrorPositionRange Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public TextPositionRange PositionRange { get; }
Public ReadOnly Property PositionRange As TextPositionRange
    Get

Property Value

Type: TextPositionRange

Implements

IParseError.PositionRange
See Also

Reference

TemplateError Class
CodeSmith.Engine Namespace


TemplateError.SourceFilePath Property

TemplateErrorSourceFilePath Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string SourceFilePath { get; }
Public ReadOnly Property SourceFilePath As String
    Get

Property Value

Type: String
See Also

Reference

TemplateError Class
CodeSmith.Engine Namespace


TemplateError.Type Property

TemplateErrorType Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public TemplateErrorType Type { get; }
Public ReadOnly Property Type As TemplateErrorType
    Get

Property Value

Type: TemplateErrorType
See Also

Reference

TemplateError Class
CodeSmith.Engine Namespace


TemplateError Methods

The TemplateError type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(TemplateError) |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides ObjectToString.)
Top
See Also

Reference

TemplateError Class
CodeSmith.Engine Namespace


TemplateError.Equals Method

TemplateErrorEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Public method | Equals(TemplateError) |
Top
See Also

Reference

TemplateError Class
CodeSmith.Engine Namespace


TemplateError.Equals Method (Object)

TemplateErrorEquals Method (Object)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject

Return Value

Type: Boolean
See Also

Reference

TemplateError Class
Equals Overload
CodeSmith.Engine Namespace


TemplateError.Equals Method (TemplateError)

TemplateErrorEquals Method (TemplateError)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool Equals(
    TemplateError other
)
Public Function Equals (
    other As TemplateError
) As Boolean

Parameters

other
Type: CodeSmith.EngineTemplateError

Return Value

Type: Boolean

Implements

IEquatableTEquals(T)
See Also

Reference

TemplateError Class
Equals Overload
CodeSmith.Engine Namespace


TemplateError.GetHashCode Method

TemplateErrorGetHashCode Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
See Also

Reference

TemplateError Class
CodeSmith.Engine Namespace


TemplateError.ToString Method

TemplateErrorToString Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
See Also

Reference

TemplateError Class
CodeSmith.Engine Namespace


TemplateErrorCollection Class

Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection TemplateError
System.Collections.ObjectModelObservableCollection TemplateError
SmartObservableCollectionTemplateError
CodeSmith.EngineTemplateErrorCollection

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
public class TemplateErrorCollection : SmartObservableCollection<TemplateError>
<SerializableAttribute>
Public Class TemplateErrorCollection
    Inherits SmartObservableCollection(Of TemplateError)

The TemplateErrorCollection type exposes the following members.

Constructors
 | Name | Description
Public method | TemplateErrorCollection | Initializes a new instance of the TemplateErrorCollection class
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection TemplateError .)
Public property | HasErrors |
Public property | HasParserErrors |
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection TemplateError .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection TemplateError .)
Top
Methods
 | Name | Description
Public method | Add(CompilerError) |
Public method | Add(CompilerErrorCollection) |
Public method | Add(T) | Adds an object to the end of the CollectionT. (Inherited from Collection TemplateError .)
Public method | Add(ITemplateAstNode, String) |
Public method | Add(TemplateError, String) |
Public method | Add(ITemplateAstNode, String, String) |
Public method | Add(ITemplateAstNode, String, String, Boolean) |
Public method | AddRange(IEnumerableValidationError) |
Public method | AddRange(IEnumerableIParseError, String) |
Public method | AddRange(TemplateErrorCollection, String) |
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollection TemplateError .)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollection TemplateError .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection TemplateError .)
Public method | Clear(TemplateErrorType) |
Public method | Clear(String, NullableTemplateErrorType) |
Protected method | ClearItems | Removes all items from the collection. (Inherited from ObservableCollection TemplateError .)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection TemplateError .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection TemplateError .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection TemplateError .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasFileErrors |
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection TemplateError .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection TemplateError .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from ObservableCollection TemplateError .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection TemplateError .)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection TemplateError .)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from ObservableCollection TemplateError .)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection TemplateError .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection TemplateError .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from ObservableCollection TemplateError .)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ObservableCollection TemplateError .)
Public method | ToCompilerErrorCollection |
Public method | ToString | (Overrides ObjectToString.)
Top
Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection TemplateError .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection TemplateError .)
Top
See Also

Reference

CodeSmith.Engine Namespace


TemplateErrorCollection Constructor

Initializes a new instance of the TemplateErrorCollection class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public TemplateErrorCollection()
Public Sub New
See Also

Reference

TemplateErrorCollection Class
CodeSmith.Engine Namespace


TemplateErrorCollection Properties

The TemplateErrorCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection TemplateError .)
Public property | HasErrors |
Public property | HasParserErrors |
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection TemplateError .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection TemplateError .)
Top
See Also

Reference

TemplateErrorCollection Class
CodeSmith.Engine Namespace


TemplateErrorCollection.HasErrors Property

TemplateErrorCollectionHasErrors Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool HasErrors { get; }
Public ReadOnly Property HasErrors As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

TemplateErrorCollection Class
CodeSmith.Engine Namespace


TemplateErrorCollection.HasParserErrors Property

TemplateErrorCollectionHasParserErrors Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool HasParserErrors { get; }
Public ReadOnly Property HasParserErrors As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

TemplateErrorCollection Class
CodeSmith.Engine Namespace


TemplateErrorCollection Methods

The TemplateErrorCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add(CompilerError) |
Public method | Add(CompilerErrorCollection) |
Public method | Add(T) | Adds an object to the end of the CollectionT. (Inherited from Collection TemplateError .)
Public method | Add(ITemplateAstNode, String) |
Public method | Add(TemplateError, String) |
Public method | Add(ITemplateAstNode, String, String) |
Public method | Add(ITemplateAstNode, String, String, Boolean) |
Public method | AddRange(IEnumerableValidationError) |
Public method | AddRange(IEnumerableIParseError, String) |
Public method | AddRange(TemplateErrorCollection, String) |
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollection TemplateError .)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollection TemplateError .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection TemplateError .)
Public method | Clear(TemplateErrorType) |
Public method | Clear(String, NullableTemplateErrorType) |
Protected method | ClearItems | Removes all items from the collection. (Inherited from ObservableCollection TemplateError .)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection TemplateError .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection TemplateError .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection TemplateError .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasFileErrors |
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection TemplateError .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection TemplateError .)
Protected method | InsertItem | Inserts an item into the collection at the specified index. (Inherited from ObservableCollection TemplateError .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection TemplateError .)
Protected method | MoveItem | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection TemplateError .)
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from ObservableCollection TemplateError .)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection TemplateError .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection TemplateError .)
Protected method | RemoveItem | Removes the item at the specified index of the collection. (Inherited from ObservableCollection TemplateError .)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ObservableCollection TemplateError .)
Public method | ToCompilerErrorCollection |
Public method | ToString | (Overrides ObjectToString.)
Top
See Also

Reference

TemplateErrorCollection Class
CodeSmith.Engine Namespace


TemplateErrorCollection.Add Method

TemplateErrorCollectionAdd Method

Overload List
 | Name | Description
Public method | Add(CompilerError) |
Public method | Add(CompilerErrorCollection) |
Public method | Add(T) | Adds an object to the end of the CollectionT. (Inherited from Collection TemplateError .)
Public method | Add(ITemplateAstNode, String) |
Public method | Add(TemplateError, String) |
Public method | Add(ITemplateAstNode, String, String) |
Public method | Add(ITemplateAstNode, String, String, Boolean) |
Top
See Also

Reference

TemplateErrorCollection Class
CodeSmith.Engine Namespace


TemplateErrorCollection.Add Method (CompilerError)

TemplateErrorCollectionAdd Method (CompilerError)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void Add(
    CompilerError error
)
Public Sub Add (
    error As CompilerError
)

Parameters

error
Type: System.CodeDom.CompilerCompilerError
See Also

Reference

TemplateErrorCollection Class
Add Overload
CodeSmith.Engine Namespace


TemplateErrorCollection.Add Method (CompilerErrorCollection)

TemplateErrorCollectionAdd Method (CompilerErrorCollection)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void Add(
    CompilerErrorCollection errors
)
Public Sub Add (
    errors As CompilerErrorCollection
)

Parameters

errors
Type: System.CodeDom.CompilerCompilerErrorCollection
See Also

Reference

TemplateErrorCollection Class
Add Overload
CodeSmith.Engine Namespace


TemplateErrorCollection.Add Method (ITemplateAstNode, String)

TemplateErrorCollectionAdd Method (ITemplateAstNode, String)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void Add(
    ITemplateAstNode node,
    string description
)
Public Sub Add (
    node As ITemplateAstNode,
    description As String
)

Parameters

node
Type: ITemplateAstNode
description
Type: SystemString
See Also

Reference

TemplateErrorCollection Class
Add Overload
CodeSmith.Engine Namespace


TemplateErrorCollection.Add Method (TemplateError, String)

TemplateErrorCollectionAdd Method (TemplateError, String)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void Add(
    TemplateError error,
    string filePath
)
Public Sub Add (
    error As TemplateError,
    filePath As String
)

Parameters

error
Type: CodeSmith.EngineTemplateError
filePath
Type: SystemString
See Also

Reference

TemplateErrorCollection Class
Add Overload
CodeSmith.Engine Namespace


TemplateErrorCollection.Add Method (ITemplateAstNode, String, String)

TemplateErrorCollectionAdd Method (ITemplateAstNode, String, String)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void Add(
    ITemplateAstNode node,
    string number,
    string description
)
Public Sub Add (
    node As ITemplateAstNode,
    number As String,
    description As String
)

Parameters

node
Type: ITemplateAstNode
number
Type: SystemString
description
Type: SystemString
See Also

Reference

TemplateErrorCollection Class
Add Overload
CodeSmith.Engine Namespace


TemplateErrorCollection.Add Method (ITemplateAstNode, String, String, Boolean)

TemplateErrorCollectionAdd Method (ITemplateAstNode, String, String, Boolean)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void Add(
    ITemplateAstNode node,
    string number,
    string description,
    bool isWarning
)
Public Sub Add (
    node As ITemplateAstNode,
    number As String,
    description As String,
    isWarning As Boolean
)

Parameters

node
Type: ITemplateAstNode
number
Type: SystemString
description
Type: SystemString
isWarning
Type: SystemBoolean
See Also

Reference

TemplateErrorCollection Class
Add Overload
CodeSmith.Engine Namespace


TemplateErrorCollection.AddRange Method

TemplateErrorCollectionAddRange Method

Overload List
 | Name | Description
Public method | AddRange(IEnumerableValidationError) |
Public method | AddRange(IEnumerableIParseError, String) |
Public method | AddRange(TemplateErrorCollection, String) |
Top
See Also

Reference

TemplateErrorCollection Class
CodeSmith.Engine Namespace


TemplateErrorCollection.AddRange Method (IEnumerable(ValidationError))

TemplateErrorCollectionAddRange Method (IEnumerableValidationError)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void AddRange(
    IEnumerable<ValidationError> errors
)
Public Sub AddRange (
    errors As IEnumerable(Of ValidationError)
)

Parameters

errors
Type: System.Collections.GenericIEnumerable ValidationError
See Also

Reference

TemplateErrorCollection Class
AddRange Overload
CodeSmith.Engine Namespace


TemplateErrorCollection.AddRange Method (IEnumerable(IParseError), String)

TemplateErrorCollectionAddRange Method (IEnumerableIParseError, String)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void AddRange(
    IEnumerable<IParseError> errors,
    string filePath
)
Public Sub AddRange (
    errors As IEnumerable(Of IParseError),
    filePath As String
)

Parameters

errors
Type: System.Collections.GenericIEnumerable IParseError
filePath
Type: SystemString
See Also

Reference

TemplateErrorCollection Class
AddRange Overload
CodeSmith.Engine Namespace


TemplateErrorCollection.AddRange Method (TemplateErrorCollection, String)

TemplateErrorCollectionAddRange Method (TemplateErrorCollection, String)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void AddRange(
    TemplateErrorCollection errors,
    string filePath
)
Public Sub AddRange (
    errors As TemplateErrorCollection,
    filePath As String
)

Parameters

errors
Type: CodeSmith.EngineTemplateErrorCollection
filePath
Type: SystemString
See Also

Reference

TemplateErrorCollection Class
AddRange Overload
CodeSmith.Engine Namespace


TemplateErrorCollection.Clear Method

TemplateErrorCollectionClear Method

Overload List
 | Name | Description
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection TemplateError .)
Public method | Clear(TemplateErrorType) |
Public method | Clear(String, NullableTemplateErrorType) |
Top
See Also

Reference

TemplateErrorCollection Class
CodeSmith.Engine Namespace


TemplateErrorCollection.Clear Method (TemplateErrorType[])

TemplateErrorCollectionClear Method (TemplateErrorType)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void Clear(
    params TemplateErrorType[] errorTypes
)
Public Sub Clear (
    ParamArray errorTypes As TemplateErrorType()
)

Parameters

errorTypes
Type: CodeSmith.EngineTemplateErrorType
See Also

Reference

TemplateErrorCollection Class
Clear Overload
CodeSmith.Engine Namespace


TemplateErrorCollection.Clear Method (String, Nullable(TemplateErrorType))

TemplateErrorCollectionClear Method (String, NullableTemplateErrorType)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void Clear(
    string filePath,
    TemplateErrorType? errorType = null
)
Public Sub Clear (
    filePath As String,
    Optional errorType As TemplateErrorType? = Nothing
)

Parameters

filePath
Type: SystemString
errorType (Optional)
Type: SystemNullable TemplateErrorType
See Also

Reference

TemplateErrorCollection Class
Clear Overload
CodeSmith.Engine Namespace


TemplateErrorCollection.HasFileErrors Method

TemplateErrorCollectionHasFileErrors Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool HasFileErrors(
    string filePath
)
Public Function HasFileErrors (
    filePath As String
) As Boolean

Parameters

filePath
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

TemplateErrorCollection Class
CodeSmith.Engine Namespace


TemplateErrorCollection.ToCompilerErrorCollection Method

TemplateErrorCollectionToCompilerErrorCollection Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CompilerErrorCollection ToCompilerErrorCollection()
Public Function ToCompilerErrorCollection As CompilerErrorCollection

Return Value

Type: CompilerErrorCollection
See Also

Reference

TemplateErrorCollection Class
CodeSmith.Engine Namespace


TemplateErrorCollection.ToString Method

TemplateErrorCollectionToString Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
See Also

Reference

TemplateErrorCollection Class
CodeSmith.Engine Namespace


TemplateErrorCollection Events

The TemplateErrorCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection TemplateError .)
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection TemplateError .)
Top
See Also

Reference

TemplateErrorCollection Class
CodeSmith.Engine Namespace


TemplateErrorLevel Enumeration

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public enum TemplateErrorLevel
Public Enumeration TemplateErrorLevel
Members
Member name | Value | Description
Warning | 0 |
Error | 1 |
Message | 2 |
See Also

Reference

CodeSmith.Engine Namespace


TemplateErrorType Enumeration

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public enum TemplateErrorType
Public Enumeration TemplateErrorType
Members
Member name | Value | Description
Parse | 0 |
TranslatedParse | 1 |
Compile | 2 |
Validation | 3 |
See Also

Reference

CodeSmith.Engine Namespace


TemplateParseResult Class

Inheritance Hierarchy
SystemObject
CodeSmith.EngineTemplateParseResult

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class TemplateParseResult
Public Class TemplateParseResult

The TemplateParseResult type exposes the following members.

Constructors
 | Name | Description
Public method | TemplateParseResult | Initializes a new instance of the TemplateParseResult class
Top
Properties
 | Name | Description
Public property | AssemblyReferences |
Public property | ClassName |
Public property | CodeBehind |
Public property | CompilationUnit |
Public property | CompilerVersion |
Public property | Debug |
Public property | Description |
Public property | Duration |
Public property | Encoding |
Public property | Errors |
Public property | FullPath |
Public property | IncludeFiles |
Public property | Inherits |
Public property | Language |
Public property | LanguageKind |
Public property | LinePragmas |
Public property | Namespace |
Public property | NoWarn |
Public property | OutputType |
Public property | Snapshot |
Public property | SourceFiles |
Public property | SourceXSDFiles |
Public property | SubTemplates |
Public property | Success |
Public property | TargetLanguage |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetFileDependencies |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSmith.Engine Namespace


TemplateParseResult Constructor

Initializes a new instance of the TemplateParseResult class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public TemplateParseResult()
Public Sub New
See Also

Reference

TemplateParseResult Class
CodeSmith.Engine Namespace


TemplateParseResult Properties

The TemplateParseResult type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyReferences |
Public property | ClassName |
Public property | CodeBehind |
Public property | CompilationUnit |
Public property | CompilerVersion |
Public property | Debug |
Public property | Description |
Public property | Duration |
Public property | Encoding |
Public property | Errors |
Public property | FullPath |
Public property | IncludeFiles |
Public property | Inherits |
Public property | Language |
Public property | LanguageKind |
Public property | LinePragmas |
Public property | Namespace |
Public property | NoWarn |
Public property | OutputType |
Public property | Snapshot |
Public property | SourceFiles |
Public property | SourceXSDFiles |
Public property | SubTemplates |
Public property | Success |
Public property | TargetLanguage |
Top
See Also

Reference

TemplateParseResult Class
CodeSmith.Engine Namespace


TemplateParseResult.AssemblyReferences Property

TemplateParseResultAssemblyReferences Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public AssemblyReferenceSet AssemblyReferences { get; protected set; }
Public Property AssemblyReferences As AssemblyReferenceSet
    Get
    Protected Set

Property Value

Type: AssemblyReferenceSet
See Also

Reference

TemplateParseResult Class
CodeSmith.Engine Namespace


TemplateParseResult.ClassName Property

TemplateParseResultClassName Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string ClassName { get; set; }
Public Property ClassName As String
    Get
    Set

Property Value

Type: String
See Also

Reference

TemplateParseResult Class
CodeSmith.Engine Namespace


TemplateParseResult.CodeBehind Property

TemplateParseResultCodeBehind Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string CodeBehind { get; set; }
Public Property CodeBehind As String
    Get
    Set

Property Value

Type: String
See Also

Reference

TemplateParseResult Class
CodeSmith.Engine Namespace


TemplateParseResult.CompilationUnit Property

TemplateParseResultCompilationUnit Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CompilationUnitNode CompilationUnit { get; set; }
Public Property CompilationUnit As CompilationUnitNode
    Get
    Set

Property Value

Type: CompilationUnitNode
See Also

Reference

TemplateParseResult Class
CodeSmith.Engine Namespace


TemplateParseResult.CompilerVersion Property

TemplateParseResultCompilerVersion Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string CompilerVersion { get; set; }
Public Property CompilerVersion As String
    Get
    Set

Property Value

Type: String
See Also

Reference

TemplateParseResult Class
CodeSmith.Engine Namespace


TemplateParseResult.Debug Property

TemplateParseResultDebug Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool Debug { get; set; }
Public Property Debug As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

TemplateParseResult Class
CodeSmith.Engine Namespace


TemplateParseResult.Description Property

TemplateParseResultDescription Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set

Property Value

Type: String
See Also

Reference

TemplateParseResult Class
CodeSmith.Engine Namespace


TemplateParseResult.Duration Property

TemplateParseResultDuration Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public TimeSpan Duration { get; set; }
Public Property Duration As TimeSpan
    Get
    Set

Property Value

Type: TimeSpan
See Also

Reference

TemplateParseResult Class
CodeSmith.Engine Namespace


TemplateParseResult.Encoding Property

TemplateParseResultEncoding Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string Encoding { get; set; }
Public Property Encoding As String
    Get
    Set

Property Value

Type: String
See Also

Reference

TemplateParseResult Class
CodeSmith.Engine Namespace


TemplateParseResult.Errors Property

TemplateParseResultErrors Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public TemplateErrorCollection Errors { get; protected set; }
Public Property Errors As TemplateErrorCollection
    Get
    Protected Set

Property Value

Type: TemplateErrorCollection
See Also

Reference

TemplateParseResult Class
CodeSmith.Engine Namespace


TemplateParseResult.FullPath Property

TemplateParseResultFullPath Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string FullPath { get; set; }
Public Property FullPath As String
    Get
    Set

Property Value

Type: String
See Also

Reference

TemplateParseResult Class
CodeSmith.Engine Namespace


TemplateParseResult.IncludeFiles Property

TemplateParseResultIncludeFiles Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ISet<string> IncludeFiles { get; protected set; }
Public Property IncludeFiles As ISet(Of String)
    Get
    Protected Set

Property Value

Type: ISet String
See Also

Reference

TemplateParseResult Class
CodeSmith.Engine Namespace


TemplateParseResult.Inherits Property

TemplateParseResultInherits Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string Inherits { get; set; }
Public Property Inherits As String
    Get
    Set

Property Value

Type: String
See Also

Reference

TemplateParseResult Class
CodeSmith.Engine Namespace


TemplateParseResult.Language Property

TemplateParseResultLanguage Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string Language { get; set; }
Public Property Language As String
    Get
    Set

Property Value

Type: String
See Also

Reference

TemplateParseResult Class
CodeSmith.Engine Namespace


TemplateParseResult.LanguageKind Property

TemplateParseResultLanguageKind Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public LanguageKind LanguageKind { get; protected set; }
Public Property LanguageKind As LanguageKind
    Get
    Protected Set

Property Value

Type: LanguageKind
See Also

Reference

TemplateParseResult Class
CodeSmith.Engine Namespace


TemplateParseResult.LinePragmas Property

TemplateParseResultLinePragmas Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool LinePragmas { get; set; }
Public Property LinePragmas As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

TemplateParseResult Class
CodeSmith.Engine Namespace


TemplateParseResult.Namespace Property

TemplateParseResultNamespace Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string Namespace { get; set; }
Public Property Namespace As String
    Get
    Set

Property Value

Type: String
See Also

Reference

TemplateParseResult Class
CodeSmith.Engine Namespace


TemplateParseResult.NoWarn Property

TemplateParseResultNoWarn Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string NoWarn { get; set; }
Public Property NoWarn As String
    Get
    Set

Property Value

Type: String
See Also

Reference

TemplateParseResult Class
CodeSmith.Engine Namespace


TemplateParseResult.OutputType Property

TemplateParseResultOutputType Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CodeTemplateOutputType OutputType { get; set; }
Public Property OutputType As CodeTemplateOutputType
    Get
    Set

Property Value

Type: CodeTemplateOutputType
See Also

Reference

TemplateParseResult Class
CodeSmith.Engine Namespace


TemplateParseResult.Snapshot Property

TemplateParseResultSnapshot Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ITextSnapshot Snapshot { get; set; }
Public Property Snapshot As ITextSnapshot
    Get
    Set

Property Value

Type: ITextSnapshot
See Also

Reference

TemplateParseResult Class
CodeSmith.Engine Namespace


TemplateParseResult.SourceFiles Property

TemplateParseResultSourceFiles Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ISet<string> SourceFiles { get; protected set; }
Public Property SourceFiles As ISet(Of String)
    Get
    Protected Set

Property Value

Type: ISet String
See Also

Reference

TemplateParseResult Class
CodeSmith.Engine Namespace


TemplateParseResult.SourceXSDFiles Property

TemplateParseResultSourceXSDFiles Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ISet<string> SourceXSDFiles { get; protected set; }
Public Property SourceXSDFiles As ISet(Of String)
    Get
    Protected Set

Property Value

Type: ISet String
See Also

Reference

TemplateParseResult Class
CodeSmith.Engine Namespace


TemplateParseResult.SubTemplates Property

TemplateParseResultSubTemplates Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public IDictionary<string, TemplateParseResult> SubTemplates { get; protected set; }
Public Property SubTemplates As IDictionary(Of String, TemplateParseResult)
    Get
    Protected Set

Property Value

Type: IDictionary String, TemplateParseResult
See Also

Reference

TemplateParseResult Class
CodeSmith.Engine Namespace


TemplateParseResult.Success Property

TemplateParseResultSuccess Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool Success { get; }
Public ReadOnly Property Success As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

TemplateParseResult Class
CodeSmith.Engine Namespace


TemplateParseResult.TargetLanguage Property

TemplateParseResultTargetLanguage Property

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string TargetLanguage { get; set; }
Public Property TargetLanguage As String
    Get
    Set

Property Value

Type: String
See Also

Reference

TemplateParseResult Class
CodeSmith.Engine Namespace


TemplateParseResult Methods

The TemplateParseResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetFileDependencies |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TemplateParseResult Class
CodeSmith.Engine Namespace


TemplateParseResult.GetFileDependencies Method

TemplateParseResultGetFileDependencies Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public IEnumerable<string> GetFileDependencies()
Public Function GetFileDependencies As IEnumerable(Of String)

Return Value

Type: IEnumerable String
See Also

Reference

TemplateParseResult Class
CodeSmith.Engine Namespace


TemplateState Enumeration

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public enum TemplateState
Public Enumeration TemplateState
Members
Member name | Value | Description
Default | 0 |
SavingProperties | 1 |
RestoringProperties | 2 |
Validating | 3 |
Rendering | 4 |
Initializing | 5 |
See Also

Reference

CodeSmith.Engine Namespace


TextWriterCollection Class

Inheritance Hierarchy
SystemObject
System.Collections.GenericList TextWriter
CodeSmith.EngineTextWriterCollection

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
public class TextWriterCollection : List<TextWriter>
<SerializableAttribute>
Public Class TextWriterCollection
    Inherits List(Of TextWriter)

The TextWriterCollection type exposes the following members.

Constructors
 | Name | Description
Public method | TextWriterCollection | Initializes a new instance of the TextWriterCollection class
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List TextWriter .)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from List TextWriter .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from List TextWriter .)
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from List TextWriter .)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from List TextWriter .)
Public method | AsReadOnly | Returns a read-only ReadOnlyCollectionT wrapper for the current collection. (Inherited from List TextWriter .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from List TextWriter .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List TextWriter .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List TextWriter .)
Public method | Clear | Removes all elements from the ListT. (Inherited from List TextWriter .)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from List TextWriter .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from List TextWriter .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List TextWriter .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List TextWriter .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List TextWriter .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from List TextWriter .)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from List TextWriter .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List TextWriter .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from List TextWriter .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from List TextWriter .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from List TextWriter .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from List TextWriter .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from List TextWriter .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from List TextWriter .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from List TextWriter .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from List TextWriter .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from List TextWriter .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from List TextWriter .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from List TextWriter .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from List TextWriter .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from List TextWriter .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from List TextWriter .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from List TextWriter .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from List TextWriter .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from List TextWriter .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from List TextWriter .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from List TextWriter .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from List TextWriter .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from List TextWriter .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from List TextWriter .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from List TextWriter .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List TextWriter .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from List TextWriter .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from List TextWriter .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from List TextWriter .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from List TextWriter .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from List TextWriter .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from List TextWriter .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from List TextWriter .)
Top
See Also

Reference

CodeSmith.Engine Namespace


TextWriterCollection Constructor

Initializes a new instance of the TextWriterCollection class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public TextWriterCollection()
Public Sub New
See Also

Reference

TextWriterCollection Class
CodeSmith.Engine Namespace


TextWriterCollection Properties

The TextWriterCollection type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List TextWriter .)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from List TextWriter .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from List TextWriter .)
Top
See Also

Reference

TextWriterCollection Class
CodeSmith.Engine Namespace


TextWriterCollection Methods

The TextWriterCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from List TextWriter .)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from List TextWriter .)
Public method | AsReadOnly | Returns a read-only ReadOnlyCollectionT wrapper for the current collection. (Inherited from List TextWriter .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from List TextWriter .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List TextWriter .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List TextWriter .)
Public method | Clear | Removes all elements from the ListT. (Inherited from List TextWriter .)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from List TextWriter .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from List TextWriter .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List TextWriter .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List TextWriter .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List TextWriter .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from List TextWriter .)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from List TextWriter .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List TextWriter .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from List TextWriter .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from List TextWriter .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from List TextWriter .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from List TextWriter .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from List TextWriter .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from List TextWriter .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from List TextWriter .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from List TextWriter .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from List TextWriter .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from List TextWriter .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from List TextWriter .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from List TextWriter .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from List TextWriter .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from List TextWriter .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from List TextWriter .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from List TextWriter .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from List TextWriter .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from List TextWriter .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from List TextWriter .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from List TextWriter .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from List TextWriter .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from List TextWriter .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from List TextWriter .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List TextWriter .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from List TextWriter .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from List TextWriter .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from List TextWriter .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from List TextWriter .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from List TextWriter .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from List TextWriter .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from List TextWriter .)
Top
See Also

Reference

TextWriterCollection Class
CodeSmith.Engine Namespace


Util Class

Inheritance Hierarchy
SystemObject
CodeSmith.EngineUtil

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class Util
Public Class Util

The Util type exposes the following members.

Methods
 | Name | Description
 | CreateFile(String, String) |
 | CreateFile(String, String, Encoding) |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetEncoding |
 | GetFilesHashCode |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetLangaugeRegionRegex |
 | GetMergeType |
 | GetResourceStreamText |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ResolveAssemblyPath |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | TryGetValue | Safely returns a value if GetValue succeeded, otherwise it returns null.
Top
See Also

Reference

CodeSmith.Engine Namespace


Util Methods

The Util type exposes the following members.

Methods
 | Name | Description
 | CreateFile(String, String) |
 | CreateFile(String, String, Encoding) |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetEncoding |
 | GetFilesHashCode |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetLangaugeRegionRegex |
 | GetMergeType |
 | GetResourceStreamText |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ResolveAssemblyPath |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | TryGetValue | Safely returns a value if GetValue succeeded, otherwise it returns null.
Top
See Also

Reference

Util Class
CodeSmith.Engine Namespace


Util.CreateFile Method

UtilCreateFile Method

Overload List
Name | Description
CreateFile(String, String) |
CreateFile(String, String, Encoding) |
Top
See Also

Reference

Util Class
CodeSmith.Engine Namespace


Util.CreateFile Method (String, String)

UtilCreateFile Method (String, String)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static void CreateFile(
    string fileName,
    string contents
)
Public Shared Sub CreateFile (
    fileName As String,
    contents As String
)

Parameters

fileName
Type: SystemString
contents
Type: SystemString
See Also

Reference

Util Class
CreateFile Overload
CodeSmith.Engine Namespace


Util.CreateFile Method (String, String, Encoding)

UtilCreateFile Method (String, String, Encoding)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static void CreateFile(
    string fileName,
    string contents,
    Encoding encoding
)
Public Shared Sub CreateFile (
    fileName As String,
    contents As String,
    encoding As Encoding
)

Parameters

fileName
Type: SystemString
contents
Type: SystemString
encoding
Type: System.TextEncoding
See Also

Reference

Util Class
CreateFile Overload
CodeSmith.Engine Namespace


Util.GetEncoding Method

UtilGetEncoding Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static Encoding GetEncoding(
    string encoding,
    Encoding defaultEncoding
)
Public Shared Function GetEncoding (
    encoding As String,
    defaultEncoding As Encoding
) As Encoding

Parameters

encoding
Type: SystemString
defaultEncoding
Type: System.TextEncoding

Return Value

Type: Encoding
See Also

Reference

Util Class
CodeSmith.Engine Namespace


Util.GetFilesHashCode Method

UtilGetFilesHashCode Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static int GetFilesHashCode(
    IEnumerable<string> fileDependencies
)
Public Shared Function GetFilesHashCode (
    fileDependencies As IEnumerable(Of String)
) As Integer

Parameters

fileDependencies
Type: System.Collections.GenericIEnumerable String

Return Value

Type: Int32
See Also

Reference

Util Class
CodeSmith.Engine Namespace


Util.GetLangaugeRegionRegex Method

UtilGetLangaugeRegionRegex Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static Regex GetLangaugeRegionRegex(
    string language,
    string defaultLanguage
)
Public Shared Function GetLangaugeRegionRegex (
    language As String,
    defaultLanguage As String
) As Regex

Parameters

language
Type: SystemString
defaultLanguage
Type: SystemString

Return Value

Type: Regex
See Also

Reference

Util Class
CodeSmith.Engine Namespace


Util.GetMergeType Method

UtilGetMergeType Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static Type GetMergeType(
    string mergeTypeName
)
Public Shared Function GetMergeType (
    mergeTypeName As String
) As Type

Parameters

mergeTypeName
Type: SystemString

Return Value

Type: Type
See Also

Reference

Util Class
CodeSmith.Engine Namespace


Util.GetResourceStreamText Method

UtilGetResourceStreamText Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static string GetResourceStreamText(
    string name
)
Public Shared Function GetResourceStreamText (
    name As String
) As String

Parameters

name
Type: SystemString

Return Value

Type: String
See Also

Reference

Util Class
CodeSmith.Engine Namespace


Util.ResolveAssemblyPath Method

UtilResolveAssemblyPath Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static string ResolveAssemblyPath(
    string assemblyName,
    IEnumerable<string> probingDirectories
)
Public Shared Function ResolveAssemblyPath (
    assemblyName As String,
    probingDirectories As IEnumerable(Of String)
) As String

Parameters

assemblyName
Type: SystemString
probingDirectories
Type: System.Collections.GenericIEnumerable String

Return Value

Type: String
See Also

Reference

Util Class
CodeSmith.Engine Namespace


Util.TryGetValue Method

UtilTryGetValue Method

Safely returns a value if GetValue succeeded, otherwise it returns null.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static Object TryGetValue(
    PropertyInfo property,
    Object value,
    Object[] index
)
Public Shared Function TryGetValue (
    property As PropertyInfo,
    value As Object,
    index As Object()
) As Object

Parameters

property
Type: System.ReflectionPropertyInfo
The Source Property
value
Type: SystemObject
The object whose property value will be returned.
index
Type: SystemObject
Optional index values for indexed properties. This value should be null for non-indexed properties.

Return Value

Type: Object
See Also

Reference

Util Class
CodeSmith.Engine Namespace


ValidationError Class

Provides information about a template validation error.
Inheritance Hierarchy
SystemObject
CodeSmith.EngineValidationError
CodeSmith.EnginePropertyRequiredValidationError

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
public class ValidationError
<SerializableAttribute>
Public Class ValidationError

The ValidationError type exposes the following members.

Constructors
 | Name | Description
Public method | ValidationError | Initializes a new instance of the ValidationError class
Public method | ValidationError(String) | Initializes a new instance of the ValidationError class
Public method | ValidationError(String, String) | Initializes a new instance of the ValidationError class
Top
Properties
 | Name | Description
Public property | Message | The Validation Message
Public property | PropertyName | The name of the Property.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSmith.Engine Namespace


ValidationError Constructor

Overload List
 | Name | Description
Public method | ValidationError | Initializes a new instance of the ValidationError class
Public method | ValidationError(String) | Initializes a new instance of the ValidationError class
Public method | ValidationError(String, String) | Initializes a new instance of the ValidationError class
Top
See Also

Reference

ValidationError Class
CodeSmith.Engine Namespace


ValidationError Constructor

Initializes a new instance of the ValidationError class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ValidationError()
Public Sub New
See Also

Reference

ValidationError Class
ValidationError Overload
CodeSmith.Engine Namespace


ValidationError Constructor (String)

Initializes a new instance of the ValidationError class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ValidationError(
    string message
)
Public Sub New (
    message As String
)

Parameters

message
Type: SystemString
See Also

Reference

ValidationError Class
ValidationError Overload
CodeSmith.Engine Namespace


ValidationError Constructor (String, String)

Initializes a new instance of the ValidationError class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ValidationError(
    string message,
    string propertyName
)
Public Sub New (
    message As String,
    propertyName As String
)

Parameters

message
Type: SystemString
propertyName
Type: SystemString
See Also

Reference

ValidationError Class
ValidationError Overload
CodeSmith.Engine Namespace


ValidationError Properties

The ValidationError type exposes the following members.

Properties
 | Name | Description
Public property | Message | The Validation Message
Public property | PropertyName | The name of the Property.
Top
See Also

Reference

ValidationError Class
CodeSmith.Engine Namespace


ValidationError.Message Property

ValidationErrorMessage Property

The Validation Message

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual string Message { get; set; }
Public Overridable Property Message As String
    Get
    Set

Property Value

Type: String
See Also

Reference

ValidationError Class
CodeSmith.Engine Namespace


ValidationError.PropertyName Property

ValidationErrorPropertyName Property

The name of the Property.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual string PropertyName { get; set; }
Public Overridable Property PropertyName As String
    Get
    Set

Property Value

Type: String
See Also

Reference

ValidationError Class
CodeSmith.Engine Namespace


ValidationError Methods

The ValidationError type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ValidationError Class
CodeSmith.Engine Namespace


ValidationErrorCollection Class

Inheritance Hierarchy
SystemObject
System.Collections.GenericList ValidationError
CodeSmith.EngineValidationErrorCollection

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
public class ValidationErrorCollection : List<ValidationError>
<SerializableAttribute>
Public Class ValidationErrorCollection
    Inherits List(Of ValidationError)

The ValidationErrorCollection type exposes the following members.

Constructors
 | Name | Description
Public method | ValidationErrorCollection | Initializes a new instance of the ValidationErrorCollection class
Public method | ValidationErrorCollection(IEnumerableValidationError) | Initializes a new instance of the ValidationErrorCollection class
Top
Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List ValidationError .)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from List ValidationError .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from List ValidationError .)
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from List ValidationError .)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from List ValidationError .)
Public method | AsReadOnly | Returns a read-only ReadOnlyCollectionT wrapper for the current collection. (Inherited from List ValidationError .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from List ValidationError .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List ValidationError .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List ValidationError .)
Public method | Clear | Removes all elements from the ListT. (Inherited from List ValidationError .)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from List ValidationError .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from List ValidationError .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List ValidationError .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List ValidationError .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List ValidationError .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from List ValidationError .)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from List ValidationError .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List ValidationError .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from List ValidationError .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from List ValidationError .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from List ValidationError .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from List ValidationError .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from List ValidationError .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from List ValidationError .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from List ValidationError .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from List ValidationError .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from List ValidationError .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from List ValidationError .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from List ValidationError .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from List ValidationError .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from List ValidationError .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from List ValidationError .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from List ValidationError .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from List ValidationError .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from List ValidationError .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from List ValidationError .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from List ValidationError .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from List ValidationError .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from List ValidationError .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from List ValidationError .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from List ValidationError .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List ValidationError .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from List ValidationError .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from List ValidationError .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from List ValidationError .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from List ValidationError .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from List ValidationError .)
Public method | ToString | (Overrides ObjectToString.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from List ValidationError .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from List ValidationError .)
Top
See Also

Reference

CodeSmith.Engine Namespace


ValidationErrorCollection Constructor

Overload List
 | Name | Description
Public method | ValidationErrorCollection | Initializes a new instance of the ValidationErrorCollection class
Public method | ValidationErrorCollection(IEnumerableValidationError) | Initializes a new instance of the ValidationErrorCollection class
Top
See Also

Reference

ValidationErrorCollection Class
CodeSmith.Engine Namespace


ValidationErrorCollection Constructor

Initializes a new instance of the ValidationErrorCollection class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ValidationErrorCollection()
Public Sub New
See Also

Reference

ValidationErrorCollection Class
ValidationErrorCollection Overload
CodeSmith.Engine Namespace


ValidationErrorCollection Constructor (IEnumerable(ValidationError))

ValidationErrorCollection Constructor (IEnumerableValidationError)

Initializes a new instance of the ValidationErrorCollection class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ValidationErrorCollection(
    IEnumerable<ValidationError> list
)
Public Sub New (
    list As IEnumerable(Of ValidationError)
)

Parameters

list
Type: System.Collections.GenericIEnumerable ValidationError
See Also

Reference

ValidationErrorCollection Class
ValidationErrorCollection Overload
CodeSmith.Engine Namespace


ValidationErrorCollection Properties

The ValidationErrorCollection type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List ValidationError .)
Public property | Count | Gets the number of elements contained in the ListT. (Inherited from List ValidationError .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from List ValidationError .)
Top
See Also

Reference

ValidationErrorCollection Class
CodeSmith.Engine Namespace


ValidationErrorCollection Methods

The ValidationErrorCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the ListT. (Inherited from List ValidationError .)
Public method | AddRange | Adds the elements of the specified collection to the end of the ListT. (Inherited from List ValidationError .)
Public method | AsReadOnly | Returns a read-only ReadOnlyCollectionT wrapper for the current collection. (Inherited from List ValidationError .)
Public method | BinarySearch(T) | Searches the entire sorted ListT for an element using the default comparer and returns the zero-based index of the element. (Inherited from List ValidationError .)
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List ValidationError .)
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ListT for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List ValidationError .)
Public method | Clear | Removes all elements from the ListT. (Inherited from List ValidationError .)
Public method | Contains | Determines whether an element is in the ListT. (Inherited from List ValidationError .)
Public method | ConvertAllTOutput | Converts the elements in the current ListT to another type, and returns a list containing the converted elements. (Inherited from List ValidationError .)
Public method | CopyTo(T) | Copies the entire ListT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List ValidationError .)
Public method | CopyTo(T, Int32) | Copies the entire ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List ValidationError .)
Public method | CopyTo(Int32, T, Int32, Int32) | Copies a range of elements from the ListT to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List ValidationError .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Exists | Determines whether the ListT contains elements that match the conditions defined by the specified predicate. (Inherited from List ValidationError .)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ListT. (Inherited from List ValidationError .)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List ValidationError .)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from List ValidationError .)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from List ValidationError .)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from List ValidationError .)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ListT. (Inherited from List ValidationError .)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from List ValidationError .)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from List ValidationError .)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from List ValidationError .)
Public method | ForEach | Performs the specified action on each element of the ListT. (Inherited from List ValidationError .)
Public method | GetEnumerator | Returns an enumerator that iterates through the ListT. (Inherited from List ValidationError .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ListT. (Inherited from List ValidationError .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ListT. (Inherited from List ValidationError .)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that extends from the specified index to the last element. (Inherited from List ValidationError .)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ListT that starts at the specified index and contains the specified number of elements. (Inherited from List ValidationError .)
Public method | Insert | Inserts an element into the ListT at the specified index. (Inherited from List ValidationError .)
Public method | InsertRange | Inserts the elements of a collection into the ListT at the specified index. (Inherited from List ValidationError .)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ListT. (Inherited from List ValidationError .)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that extends from the first element to the specified index. (Inherited from List ValidationError .)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ListT that contains the specified number of elements and ends at the specified index. (Inherited from List ValidationError .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the ListT. (Inherited from List ValidationError .)
Public method | RemoveAll | Removes all the elements that match the conditions defined by the specified predicate. (Inherited from List ValidationError .)
Public method | RemoveAt | Removes the element at the specified index of the ListT. (Inherited from List ValidationError .)
Public method | RemoveRange | Removes a range of elements from the ListT. (Inherited from List ValidationError .)
Public method | Reverse | Reverses the order of the elements in the entire ListT. (Inherited from List ValidationError .)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List ValidationError .)
Public method | Sort | Sorts the elements in the entire ListT using the default comparer. (Inherited from List ValidationError .)
Public method | Sort(ComparisonT) | Sorts the elements in the entire ListT using the specified ComparisonT. (Inherited from List ValidationError .)
Public method | Sort(IComparerT) | Sorts the elements in the entire ListT using the specified comparer. (Inherited from List ValidationError .)
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in ListT using the specified comparer. (Inherited from List ValidationError .)
Public method | ToArray | Copies the elements of the ListT to a new array. (Inherited from List ValidationError .)
Public method | ToString | (Overrides ObjectToString.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the ListT, if that number is less than a threshold value. (Inherited from List ValidationError .)
Public method | TrueForAll | Determines whether every element in the ListT matches the conditions defined by the specified predicate. (Inherited from List ValidationError .)
Top
See Also

Reference

ValidationErrorCollection Class
CodeSmith.Engine Namespace


ValidationErrorCollection.ToString Method

ValidationErrorCollectionToString Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
See Also

Reference

ValidationErrorCollection Class
CodeSmith.Engine Namespace


VersionCheck Class

Inheritance Hierarchy
SystemObject
CodeSmith.EngineVersionCheck

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class VersionCheck
Public Class VersionCheck

The VersionCheck type exposes the following members.

Constructors
 | Name | Description
Public method | VersionCheck | Initializes a new instance of the VersionCheck class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetCurrentVersion | Returns the Assembly file version information for the CodeSmith.Engine assembly.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetLatestVersionInfo | Gets the latest released version number of CodeSmith that has been released.
 | GetShortBuild | Returns the current version information in the following format: 5.2.0000 (Major.Minor.Build)
 | GetShortVersion | Returns the current version information in the following format: 5.2.0000 (Major.Minor.Revision)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | GetVersionNumber | Returns the current version information in the following format: 5.2 (Major.Minor)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSmith.Engine Namespace


VersionCheck Constructor

Initializes a new instance of the VersionCheck class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public VersionCheck()
Public Sub New
See Also

Reference

VersionCheck Class
CodeSmith.Engine Namespace


VersionCheck Methods

The VersionCheck type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetCurrentVersion | Returns the Assembly file version information for the CodeSmith.Engine assembly.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetLatestVersionInfo | Gets the latest released version number of CodeSmith that has been released.
 | GetShortBuild | Returns the current version information in the following format: 5.2.0000 (Major.Minor.Build)
 | GetShortVersion | Returns the current version information in the following format: 5.2.0000 (Major.Minor.Revision)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | GetVersionNumber | Returns the current version information in the following format: 5.2 (Major.Minor)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VersionCheck Class
CodeSmith.Engine Namespace


VersionCheck.GetCurrentVersion Method

VersionCheckGetCurrentVersion Method

Returns the Assembly file version information for the CodeSmith.Engine assembly.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static Version GetCurrentVersion()
Public Shared Function GetCurrentVersion As Version

Return Value

Type: Version
Returns the Assembly file version information for the CodeSmith.Engine assembly.
See Also

Reference

VersionCheck Class
CodeSmith.Engine Namespace


VersionCheck.GetLatestVersionInfo Method

VersionCheckGetLatestVersionInfo Method

Gets the latest released version number of CodeSmith that has been released.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static VersionInfo GetLatestVersionInfo()
Public Shared Function GetLatestVersionInfo As VersionInfo

Return Value

Type: VersionInfo
If an internet connection was detected it will return the version information of the latest released version of CodeSmith. If an internet connection could not be found then it returns null.
See Also

Reference

VersionCheck Class
CodeSmith.Engine Namespace


VersionCheck.GetShortBuild Method

VersionCheckGetShortBuild Method

Returns the current version information in the following format: 5.2.0000 (Major.Minor.Build)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static string GetShortBuild()
Public Shared Function GetShortBuild As String

Return Value

Type: String
Returns the current version information in the following format: 5.2.0000 (Major.Minor.Build)
See Also

Reference

VersionCheck Class
CodeSmith.Engine Namespace


VersionCheck.GetShortVersion Method

VersionCheckGetShortVersion Method

Returns the current version information in the following format: 5.2.0000 (Major.Minor.Revision)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static string GetShortVersion()
Public Shared Function GetShortVersion As String

Return Value

Type: String
Returns the current version information in the following format: 5.2.0000 (Major.Minor.Revision)
See Also

Reference

VersionCheck Class
CodeSmith.Engine Namespace


VersionCheck.GetVersionNumber Method

VersionCheckGetVersionNumber Method

Returns the current version information in the following format: 5.2 (Major.Minor)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static string GetVersionNumber()
Public Shared Function GetVersionNumber As String

Return Value

Type: String
Returns the current version information in the following format: 5.2 (Major.Minor)
See Also

Reference

VersionCheck Class
CodeSmith.Engine Namespace


VersionInfo Class

Inheritance Hierarchy
SystemObject
CodeSmith.EngineVersionInfo

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class VersionInfo
Public Class VersionInfo

The VersionInfo type exposes the following members.

Constructors
 | Name | Description
Public method | VersionInfo | Initializes a new instance of the VersionInfo class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | Location |
Public field | Version |
Top
See Also

Reference

CodeSmith.Engine Namespace


VersionInfo Constructor

Initializes a new instance of the VersionInfo class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public VersionInfo(
    Version version,
    string location
)
Public Sub New (
    version As Version,
    location As String
)

Parameters

version
Type: SystemVersion
location
Type: SystemString
See Also

Reference

VersionInfo Class
CodeSmith.Engine Namespace


VersionInfo Methods

The VersionInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VersionInfo Class
CodeSmith.Engine Namespace


VersionInfo Fields

The VersionInfo type exposes the following members.

Fields
 | Name | Description
Public field | Location |
Public field | Version |
Top
See Also

Reference

VersionInfo Class
CodeSmith.Engine Namespace


VersionInfo.Location Field

VersionInfoLocation Field

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public readonly string Location
Public ReadOnly Location As String

Field Value

Type: String
See Also

Reference

VersionInfo Class
CodeSmith.Engine Namespace


VersionInfo.Version Field

VersionInfoVersion Field

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public readonly Version Version
Public ReadOnly Version As Version

Field Value

Type: Version
See Also

Reference

VersionInfo Class
CodeSmith.Engine Namespace


VirtualCollectionBase(T) Class

VirtualCollectionBaseT Class

A base Collection used to load data on depand from database.
Inheritance Hierarchy
SystemObject
CodeSmith.EngineVirtualCollectionBaseT
CodeSmith.EngineConfigurationCollectionBaseT

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
public abstract class VirtualCollectionBase<T> : IList<T>,
    ICollection<T>, IEnumerable<T>, IEnumerable, IList, ICollection
where T : IIndexed

<SerializableAttribute>
Public MustInherit Class VirtualCollectionBase(Of T As IIndexed)
    Implements IList(Of T), ICollection(Of T),
    IEnumerable(Of T), IEnumerable, IList, ICollection

Type Parameters

T

The VirtualCollectionBaseT type exposes the following members.

Constructors
 | Name | Description
Protected method | VirtualCollectionBaseT | Initializes a new instance of the VirtualCollectionBaseT class
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT.
Public property | Item | Gets or sets the type T at the specified index.
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT.
Protected method | AddItem | Adds the item.
Public method | Clear | Removes all items from the ICollectionT.
Protected method | ClearItems | Clears the items.
Public method | Contains | Determines whether the ICollectionT contains a specific value.
Public method | CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetCount | Gets the count.
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetIndex | Gets the index.
Protected method | GetItem | Gets the item.
Protected method | GetItems | Gets the items.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT.
Public method | Insert | Inserts an item to the IListT at the specified index.
Protected method | InsertItem | Inserts an element into the Collection at the specified index.
 | IsCompatibleObject | Determines whether the specified value is compatible with Collection.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT.
Public method | RemoveAt | Removes the IListT item at the specified index.
Protected method | RemoveItem | Removes the element at the specified index of the Collection.
Protected method | SetItem | Replaces the element at the specified index.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | VerifyValueType | Verifies the type of the value.
Top
Extension Methods
 | Name | Description
Public Extension Method | AsIndexedEnumerableT | Returns an IndexedEnumerable from any collection implementing IEnumerable<T> (Defined by IndexedEnumerable.)
Top
See Also

Reference

CodeSmith.Engine Namespace


VirtualCollectionBase(T) Constructor

VirtualCollectionBaseT Constructor

Initializes a new instance of the VirtualCollectionBaseT class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected VirtualCollectionBase()
Protected Sub New
See Also

Reference

VirtualCollectionBaseT Class
CodeSmith.Engine Namespace


VirtualCollectionBase(T) Properties

VirtualCollectionBaseT Properties

The VirtualCollectionBaseT generic type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT.
Public property | Item | Gets or sets the type T at the specified index.
Top
See Also

Reference

VirtualCollectionBaseT Class
CodeSmith.Engine Namespace


VirtualCollectionBase(T).Count Property

VirtualCollectionBaseTCount Property

Gets the number of elements contained in the ICollectionT.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
The number of elements contained in the ICollectionT.

Implements

ICollectionTCount
ICollectionCount
See Also

Reference

VirtualCollectionBaseT Class
CodeSmith.Engine Namespace


VirtualCollectionBase(T).Item Property

VirtualCollectionBaseTItem Property

Gets or sets the type T at the specified index.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public T this[
    int index
] { get; set; }
Public Default Property Item (
    index As Integer
) As T
    Get
    Set

Parameters

index
Type: SystemInt32

Property Value

Type: T

Implements

IListTItemInt32
See Also

Reference

VirtualCollectionBaseT Class
CodeSmith.Engine Namespace


VirtualCollectionBase(T) Methods

VirtualCollectionBaseT Methods

The VirtualCollectionBaseT generic type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT.
Protected method | AddItem | Adds the item.
Public method | Clear | Removes all items from the ICollectionT.
Protected method | ClearItems | Clears the items.
Public method | Contains | Determines whether the ICollectionT contains a specific value.
Public method | CopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetCount | Gets the count.
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetIndex | Gets the index.
Protected method | GetItem | Gets the item.
Protected method | GetItems | Gets the items.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT.
Public method | Insert | Inserts an item to the IListT at the specified index.
Protected method | InsertItem | Inserts an element into the Collection at the specified index.
 | IsCompatibleObject | Determines whether the specified value is compatible with Collection.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT.
Public method | RemoveAt | Removes the IListT item at the specified index.
Protected method | RemoveItem | Removes the element at the specified index of the Collection.
Protected method | SetItem | Replaces the element at the specified index.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | VerifyValueType | Verifies the type of the value.
Top
Extension Methods
 | Name | Description
Public Extension Method | AsIndexedEnumerableT | Returns an IndexedEnumerable from any collection implementing IEnumerable<T> (Defined by IndexedEnumerable.)
Top
See Also

Reference

VirtualCollectionBaseT Class
CodeSmith.Engine Namespace


VirtualCollectionBase(T).Add Method

VirtualCollectionBaseTAdd Method

Adds an item to the ICollectionT.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void Add(
    T item
)
Public Sub Add (
    item As T
)

Parameters

item
Type: T
The object to add to the ICollectionT.

Implements

ICollectionTAdd(T)
Exceptions
Exception | Condition
NotSupportedException | The ICollectionT is read-only.
See Also

Reference

VirtualCollectionBaseT Class
CodeSmith.Engine Namespace


VirtualCollectionBase(T).AddItem Method

VirtualCollectionBaseTAddItem Method

Adds the item.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected abstract int AddItem(
    T item
)
Protected MustOverride Function AddItem (
    item As T
) As Integer

Parameters

item
Type: T
The item.

Return Value

Type: Int32
See Also

Reference

VirtualCollectionBaseT Class
CodeSmith.Engine Namespace


VirtualCollectionBase(T).Clear Method

VirtualCollectionBaseTClear Method

Removes all items from the ICollectionT.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void Clear()
Public Sub Clear

Implements

ICollectionTClear
IListClear
Exceptions
Exception | Condition
NotSupportedException | The ICollectionT is read-only.
See Also

Reference

VirtualCollectionBaseT Class
CodeSmith.Engine Namespace


VirtualCollectionBase(T).ClearItems Method

VirtualCollectionBaseTClearItems Method

Clears the items.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected abstract void ClearItems()
Protected MustOverride Sub ClearItems
See Also

Reference

VirtualCollectionBaseT Class
CodeSmith.Engine Namespace


VirtualCollectionBase(T).Contains Method

VirtualCollectionBaseTContains Method

Determines whether the ICollectionT contains a specific value.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool Contains(
    T item
)
Public Function Contains (
    item As T
) As Boolean

Parameters

item
Type: T
The object to locate in the ICollectionT.

Return Value

Type: Boolean
true if item is found in the ICollectionT; otherwise, false.

Implements

ICollectionTContains(T)
See Also

Reference

VirtualCollectionBaseT Class
CodeSmith.Engine Namespace


VirtualCollectionBase(T).CopyTo Method

VirtualCollectionBaseTCopyTo Method

Copies the elements of the ICollection to an Array, starting at a particular Array index.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void CopyTo(
    T[] array,
    int index
)
Public Sub CopyTo (
    array As T(),
    index As Integer
)

Parameters

array
Type: T
The one-dimensional Array that is the destination of the elements copied from ICollection. The Array must have zero-based indexing.
index
Type: SystemInt32
The zero-based index in array at which copying begins.

Implements

ICollectionTCopyTo(T, Int32)
See Also

Reference

VirtualCollectionBaseT Class
CodeSmith.Engine Namespace


VirtualCollectionBase(T).GetCount Method

VirtualCollectionBaseTGetCount Method

Gets the count.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected abstract int GetCount()
Protected MustOverride Function GetCount As Integer

Return Value

Type: Int32
See Also

Reference

VirtualCollectionBaseT Class
CodeSmith.Engine Namespace


VirtualCollectionBase(T).GetEnumerator Method

VirtualCollectionBaseTGetEnumerator Method

Returns an enumerator that iterates through the collection.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public IEnumerator<T> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of T)

Return Value

Type: IEnumerator T
A IEnumeratorT that can be used to iterate through the collection.

Implements

IEnumerableTGetEnumerator
See Also

Reference

VirtualCollectionBaseT Class
CodeSmith.Engine Namespace


VirtualCollectionBase(T).GetIndex Method

VirtualCollectionBaseTGetIndex Method

Gets the index.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected abstract int GetIndex(
    T item
)
Protected MustOverride Function GetIndex (
    item As T
) As Integer

Parameters

item
Type: T
The item.

Return Value

Type: Int32
See Also

Reference

VirtualCollectionBaseT Class
CodeSmith.Engine Namespace


VirtualCollectionBase(T).GetItem Method

VirtualCollectionBaseTGetItem Method

Gets the item.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected abstract T GetItem(
    int index
)
Protected MustOverride Function GetItem (
    index As Integer
) As T

Parameters

index
Type: SystemInt32
The index.

Return Value

Type: T
See Also

Reference

VirtualCollectionBaseT Class
CodeSmith.Engine Namespace


VirtualCollectionBase(T).GetItems Method

VirtualCollectionBaseTGetItems Method

Gets the items.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected abstract IList<T> GetItems()
Protected MustOverride Function GetItems As IList(Of T)

Return Value

Type: IList T
See Also

Reference

VirtualCollectionBaseT Class
CodeSmith.Engine Namespace


VirtualCollectionBase(T).IndexOf Method

VirtualCollectionBaseTIndexOf Method

Determines the index of a specific item in the IListT.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public int IndexOf(
    T item
)
Public Function IndexOf (
    item As T
) As Integer

Parameters

item
Type: T
The object to locate in the IListT.

Return Value

Type: Int32
The index of item if found in the list; otherwise, -1.

Implements

IListTIndexOf(T)
See Also

Reference

VirtualCollectionBaseT Class
CodeSmith.Engine Namespace


VirtualCollectionBase(T).Insert Method

VirtualCollectionBaseTInsert Method

Inserts an item to the IListT at the specified index.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void Insert(
    int index,
    T item
)
Public Sub Insert (
    index As Integer,
    item As T
)

Parameters

index
Type: SystemInt32
The zero-based index at which item should be inserted.
item
Type: T
The object to insert into the IListT.

Implements

IListTInsert(Int32, T)
Exceptions
Exception | Condition
ArgumentOutOfRangeException | index is not a valid index in the IListT.
NotSupportedException | The IListT is read-only.
See Also

Reference

VirtualCollectionBaseT Class
CodeSmith.Engine Namespace


VirtualCollectionBase(T).InsertItem Method

VirtualCollectionBaseTInsertItem Method

Inserts an element into the Collection at the specified index.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected abstract void InsertItem(
    int index,
    T item
)
Protected MustOverride Sub InsertItem (
    index As Integer,
    item As T
)

Parameters

index
Type: SystemInt32
The zero-based index at which item should be inserted.
item
Type: T
The object to insert. The value can be null (Nothing in Visual Basic) for reference types.
See Also

Reference

VirtualCollectionBaseT Class
CodeSmith.Engine Namespace


VirtualCollectionBase(T).IsCompatibleObject Method

VirtualCollectionBaseTIsCompatibleObject Method

Determines whether the specified value is compatible with Collection.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected static bool IsCompatibleObject(
    Object value
)
Protected Shared Function IsCompatibleObject (
    value As Object
) As Boolean

Parameters

value
Type: SystemObject
The value to check.

Return Value

Type: Boolean
true if is a compatible object; otherwise, false.
See Also

Reference

VirtualCollectionBaseT Class
CodeSmith.Engine Namespace


VirtualCollectionBase(T).Remove Method

VirtualCollectionBaseTRemove Method

Removes the first occurrence of a specific object from the ICollectionT.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool Remove(
    T item
)
Public Function Remove (
    item As T
) As Boolean

Parameters

item
Type: T
The object to remove from the ICollectionT.

Return Value

Type: Boolean
true if item was successfully removed from the ICollectionT; otherwise, false. This method also returns false if item is not found in the original ICollectionT.

Implements

ICollectionTRemove(T)
Exceptions
Exception | Condition
NotSupportedException | The ICollectionT is read-only.
See Also

Reference

VirtualCollectionBaseT Class
CodeSmith.Engine Namespace


VirtualCollectionBase(T).RemoveAt Method

VirtualCollectionBaseTRemoveAt Method

Removes the IListT item at the specified index.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void RemoveAt(
    int index
)
Public Sub RemoveAt (
    index As Integer
)

Parameters

index
Type: SystemInt32
The zero-based index of the item to remove.

Implements

IListTRemoveAt(Int32)
IListRemoveAt(Int32)
Exceptions
Exception | Condition
ArgumentOutOfRangeException | index is not a valid index in the IListT.
NotSupportedException | The IListT is read-only.
See Also

Reference

VirtualCollectionBaseT Class
CodeSmith.Engine Namespace


VirtualCollectionBase(T).RemoveItem Method

VirtualCollectionBaseTRemoveItem Method

Removes the element at the specified index of the Collection.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected abstract void RemoveItem(
    int index
)
Protected MustOverride Sub RemoveItem (
    index As Integer
)

Parameters

index
Type: SystemInt32
The zero-based index of the element to remove.
See Also

Reference

VirtualCollectionBaseT Class
CodeSmith.Engine Namespace


VirtualCollectionBase(T).SetItem Method

VirtualCollectionBaseTSetItem Method

Replaces the element at the specified index.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected abstract void SetItem(
    int index,
    T item
)
Protected MustOverride Sub SetItem (
    index As Integer,
    item As T
)

Parameters

index
Type: SystemInt32
The zero-based index of the element to replace.
item
Type: T
The new value for the element at the specified index. The value can be null (Nothing in Visual Basic) for reference types.
See Also

Reference

VirtualCollectionBaseT Class
CodeSmith.Engine Namespace


VirtualCollectionBase(T).VerifyValueType Method

VirtualCollectionBaseTVerifyValueType Method

Verifies the type of the value.

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected static void VerifyValueType(
    Object value
)
Protected Shared Sub VerifyValueType (
    value As Object
)

Parameters

value
Type: SystemObject
The value to check.
See Also

Reference

VirtualCollectionBaseT Class
CodeSmith.Engine Namespace


XmlPropertyDirectiveTypeConverter Class

This class can be used to convert to and from an XmlNode for a class that supports XML serialization.
Inheritance Hierarchy
SystemObject
System.ComponentModelTypeConverter
CodeSmith.EngineXmlPropertyDirectiveTypeConverter

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class XmlPropertyDirectiveTypeConverter : TypeConverter
Public Class XmlPropertyDirectiveTypeConverter
    Inherits TypeConverter

The XmlPropertyDirectiveTypeConverter type exposes the following members.

Constructors
 | Name | Description
Public method | XmlPropertyDirectiveTypeConverter | Initializes a new instance of the XmlPropertyDirectiveTypeConverter class
Top
Methods
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | (Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | (Overrides TypeConverterCanConvertTo(ITypeDescriptorContext, Type).)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
Public method | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | (Overrides TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Public method | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
Public method | CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Protected method | GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object, Attribute) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported | Returns whether this object supports properties. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | Returns whether this object supports properties, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValues | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
Public method | GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
Public method | IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSmith.Engine Namespace


XmlPropertyDirectiveTypeConverter Constructor

Initializes a new instance of the XmlPropertyDirectiveTypeConverter class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public XmlPropertyDirectiveTypeConverter()
Public Sub New
See Also

Reference

XmlPropertyDirectiveTypeConverter Class
CodeSmith.Engine Namespace


XmlPropertyDirectiveTypeConverter Methods

The XmlPropertyDirectiveTypeConverter type exposes the following members.

Methods
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | (Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | (Overrides TypeConverterCanConvertTo(ITypeDescriptorContext, Type).)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
Public method | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | (Overrides TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Public method | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
Public method | CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Protected method | GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object, Attribute) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported | Returns whether this object supports properties. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | Returns whether this object supports properties, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValues | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
Public method | GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
Public method | IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XmlPropertyDirectiveTypeConverter Class
CodeSmith.Engine Namespace


XmlPropertyDirectiveTypeConverter.CanConvertFrom Method

XmlPropertyDirectiveTypeConverterCanConvertFrom Method

Overload List
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | (Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Top
See Also

Reference

XmlPropertyDirectiveTypeConverter Class
CodeSmith.Engine Namespace


XmlPropertyDirectiveTypeConverter.CanConvertFrom Method (ITypeDescriptorContext, Type)

XmlPropertyDirectiveTypeConverterCanConvertFrom Method (ITypeDescriptorContext, Type)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override bool CanConvertFrom(
    ITypeDescriptorContext context,
    Type sourceType
)
Public Overrides Function CanConvertFrom (
    context As ITypeDescriptorContext,
    sourceType As Type
) As Boolean

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
sourceType
Type: SystemType

Return Value

Type: Boolean
See Also

Reference

XmlPropertyDirectiveTypeConverter Class
CanConvertFrom Overload
CodeSmith.Engine Namespace


XmlPropertyDirectiveTypeConverter.CanConvertTo Method

XmlPropertyDirectiveTypeConverterCanConvertTo Method

Overload List
 | Name | Description
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | (Overrides TypeConverterCanConvertTo(ITypeDescriptorContext, Type).)
Top
See Also

Reference

XmlPropertyDirectiveTypeConverter Class
CodeSmith.Engine Namespace


XmlPropertyDirectiveTypeConverter.CanConvertTo Method (ITypeDescriptorContext, Type)

XmlPropertyDirectiveTypeConverterCanConvertTo Method (ITypeDescriptorContext, Type)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override bool CanConvertTo(
    ITypeDescriptorContext context,
    Type destinationType
)
Public Overrides Function CanConvertTo (
    context As ITypeDescriptorContext,
    destinationType As Type
) As Boolean

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
destinationType
Type: SystemType

Return Value

Type: Boolean
See Also

Reference

XmlPropertyDirectiveTypeConverter Class
CanConvertTo Overload
CodeSmith.Engine Namespace


XmlPropertyDirectiveTypeConverter.ConvertFrom Method

XmlPropertyDirectiveTypeConverterConvertFrom Method

Overload List
 | Name | Description
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Top
See Also

Reference

XmlPropertyDirectiveTypeConverter Class
CodeSmith.Engine Namespace


XmlPropertyDirectiveTypeConverter.ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

XmlPropertyDirectiveTypeConverterConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override Object ConvertFrom(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value
)
Public Overrides Function ConvertFrom (
    context As ITypeDescriptorContext,
    culture As CultureInfo,
    value As Object
) As Object

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
culture
Type: System.GlobalizationCultureInfo
value
Type: SystemObject

Return Value

Type: Object
See Also

Reference

XmlPropertyDirectiveTypeConverter Class
ConvertFrom Overload
CodeSmith.Engine Namespace


XmlPropertyDirectiveTypeConverter.ConvertTo Method

XmlPropertyDirectiveTypeConverterConvertTo Method

Overload List
 | Name | Description
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | (Overrides TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Top
See Also

Reference

XmlPropertyDirectiveTypeConverter Class
CodeSmith.Engine Namespace


XmlPropertyDirectiveTypeConverter.ConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)

XmlPropertyDirectiveTypeConverterConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override Object ConvertTo(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value,
    Type destinationType
)
Public Overrides Function ConvertTo (
    context As ITypeDescriptorContext,
    culture As CultureInfo,
    value As Object,
    destinationType As Type
) As Object

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
culture
Type: System.GlobalizationCultureInfo
value
Type: SystemObject
destinationType
Type: SystemType

Return Value

Type: Object
See Also

Reference

XmlPropertyDirectiveTypeConverter Class
ConvertTo Overload
CodeSmith.Engine Namespace


XmlPropertyFilePicker Class

This type editor can be used on a class that supports XML serialization to allow the user to pick an XML file and have that XML file deserialized into the target class.
Inheritance Hierarchy
SystemObject
System.Drawing.DesignUITypeEditor
CodeSmith.EngineXmlPropertyFilePicker

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class XmlPropertyFilePicker : UITypeEditor
Public Class XmlPropertyFilePicker
    Inherits UITypeEditor

The XmlPropertyFilePicker type exposes the following members.

Constructors
 | Name | Description
Public method | XmlPropertyFilePicker | Initializes a new instance of the XmlPropertyFilePicker class
Top
Properties
 | Name | Description
Public property | IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Inherited from UITypeEditor.)
Top
Methods
 | Name | Description
Public method | EditValue(IServiceProvider, Object) | Edits the value of the specified object using the editor style indicated by the GetEditStyle method. (Inherited from UITypeEditor.)
Public method | EditValue(ITypeDescriptorContext, IServiceProvider, Object) | (Overrides UITypeEditorEditValue(ITypeDescriptorContext, IServiceProvider, Object).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEditStyle | Gets the editor style used by the EditValue(IServiceProvider, Object) method. (Inherited from UITypeEditor.)
Public method | GetEditStyle(ITypeDescriptorContext) | (Overrides UITypeEditorGetEditStyle(ITypeDescriptorContext).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetPaintValueSupported | Indicates whether this editor supports painting a representation of an object's value. (Inherited from UITypeEditor.)
Public method | GetPaintValueSupported(ITypeDescriptorContext) | Indicates whether the specified context supports painting a representation of an object's value within the specified context. (Inherited from UITypeEditor.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PaintValue(PaintValueEventArgs) | Paints a representation of the value of an object using the specified PaintValueEventArgs. (Inherited from UITypeEditor.)
Public method | PaintValue(Object, Graphics, Rectangle) | Paints a representation of the value of the specified object to the specified canvas. (Inherited from UITypeEditor.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSmith.Engine Namespace


XmlPropertyFilePicker Constructor

Initializes a new instance of the XmlPropertyFilePicker class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public XmlPropertyFilePicker()
Public Sub New
See Also

Reference

XmlPropertyFilePicker Class
CodeSmith.Engine Namespace


XmlPropertyFilePicker Properties

The XmlPropertyFilePicker type exposes the following members.

Properties
 | Name | Description
Public property | IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Inherited from UITypeEditor.)
Top
See Also

Reference

XmlPropertyFilePicker Class
CodeSmith.Engine Namespace


XmlPropertyFilePicker Methods

The XmlPropertyFilePicker type exposes the following members.

Methods
 | Name | Description
Public method | EditValue(IServiceProvider, Object) | Edits the value of the specified object using the editor style indicated by the GetEditStyle method. (Inherited from UITypeEditor.)
Public method | EditValue(ITypeDescriptorContext, IServiceProvider, Object) | (Overrides UITypeEditorEditValue(ITypeDescriptorContext, IServiceProvider, Object).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEditStyle | Gets the editor style used by the EditValue(IServiceProvider, Object) method. (Inherited from UITypeEditor.)
Public method | GetEditStyle(ITypeDescriptorContext) | (Overrides UITypeEditorGetEditStyle(ITypeDescriptorContext).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetPaintValueSupported | Indicates whether this editor supports painting a representation of an object's value. (Inherited from UITypeEditor.)
Public method | GetPaintValueSupported(ITypeDescriptorContext) | Indicates whether the specified context supports painting a representation of an object's value within the specified context. (Inherited from UITypeEditor.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PaintValue(PaintValueEventArgs) | Paints a representation of the value of an object using the specified PaintValueEventArgs. (Inherited from UITypeEditor.)
Public method | PaintValue(Object, Graphics, Rectangle) | Paints a representation of the value of the specified object to the specified canvas. (Inherited from UITypeEditor.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XmlPropertyFilePicker Class
CodeSmith.Engine Namespace


XmlPropertyFilePicker.EditValue Method

XmlPropertyFilePickerEditValue Method

Overload List
 | Name | Description
Public method | EditValue(IServiceProvider, Object) | Edits the value of the specified object using the editor style indicated by the GetEditStyle method. (Inherited from UITypeEditor.)
Public method | EditValue(ITypeDescriptorContext, IServiceProvider, Object) | (Overrides UITypeEditorEditValue(ITypeDescriptorContext, IServiceProvider, Object).)
Top
See Also

Reference

XmlPropertyFilePicker Class
CodeSmith.Engine Namespace


XmlPropertyFilePicker.EditValue Method (ITypeDescriptorContext, IServiceProvider, Object)

XmlPropertyFilePickerEditValue Method (ITypeDescriptorContext, IServiceProvider, Object)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override Object EditValue(
    ITypeDescriptorContext context,
    IServiceProvider provider,
    Object value
)
Public Overrides Function EditValue (
    context As ITypeDescriptorContext,
    provider As IServiceProvider,
    value As Object
) As Object

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
provider
Type: SystemIServiceProvider
value
Type: SystemObject

Return Value

Type: Object
See Also

Reference

XmlPropertyFilePicker Class
EditValue Overload
CodeSmith.Engine Namespace


XmlPropertyFilePicker.GetEditStyle Method

XmlPropertyFilePickerGetEditStyle Method

Overload List
 | Name | Description
Public method | GetEditStyle | Gets the editor style used by the EditValue(IServiceProvider, Object) method. (Inherited from UITypeEditor.)
Public method | GetEditStyle(ITypeDescriptorContext) | (Overrides UITypeEditorGetEditStyle(ITypeDescriptorContext).)
Top
See Also

Reference

XmlPropertyFilePicker Class
CodeSmith.Engine Namespace


XmlPropertyFilePicker.GetEditStyle Method (ITypeDescriptorContext)

XmlPropertyFilePickerGetEditStyle Method (ITypeDescriptorContext)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override UITypeEditorEditStyle GetEditStyle(
    ITypeDescriptorContext context
)
Public Overrides Function GetEditStyle (
    context As ITypeDescriptorContext
) As UITypeEditorEditStyle

Parameters

context
Type: System.ComponentModelITypeDescriptorContext

Return Value

Type: UITypeEditorEditStyle
See Also

Reference

XmlPropertyFilePicker Class
GetEditStyle Overload
CodeSmith.Engine Namespace


XmlPropertyRefresher Class

Inheritance Hierarchy
SystemObject
CodeSmith.EngineXmlPropertyRefresher

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class XmlPropertyRefresher : IPropertyRefresher
Public Class XmlPropertyRefresher
    Implements IPropertyRefresher

The XmlPropertyRefresher type exposes the following members.

Constructors
 | Name | Description
Public method | XmlPropertyRefresher | Initializes a new instance of the XmlPropertyRefresher class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSmith.Engine Namespace


XmlPropertyRefresher Constructor

Initializes a new instance of the XmlPropertyRefresher class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public XmlPropertyRefresher()
Public Sub New
See Also

Reference

XmlPropertyRefresher Class
CodeSmith.Engine Namespace


XmlPropertyRefresher Methods

The XmlPropertyRefresher type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XmlPropertyRefresher Class
CodeSmith.Engine Namespace


XmlPropertyRefresher.Refresh Method

XmlPropertyRefresherRefresh Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public Object Refresh(
    PropertyRefresherContext context
)
Public Function Refresh (
    context As PropertyRefresherContext
) As Object

Parameters

context
Type: CodeSmith.EnginePropertyRefresherContext

Return Value

Type: Object

Implements

IPropertyRefresherRefresh(PropertyRefresherContext)
See Also

Reference

XmlPropertyRefresher Class
CodeSmith.Engine Namespace


XmlPropertySerializer Class

Inheritance Hierarchy
SystemObject
CodeSmith.EngineXmlPropertySerializer

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class XmlPropertySerializer : IPropertySerializer
Public Class XmlPropertySerializer
    Implements IPropertySerializer

The XmlPropertySerializer type exposes the following members.

Constructors
 | Name | Description
Public method | XmlPropertySerializer | Initializes a new instance of the XmlPropertySerializer class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadProperty |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseDefaultValue |
Public method | ReadPropertyXml |
Public method | SaveProperty |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WritePropertyXml |
Top
See Also

Reference

CodeSmith.Engine Namespace


XmlPropertySerializer Constructor

Initializes a new instance of the XmlPropertySerializer class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public XmlPropertySerializer()
Public Sub New
See Also

Reference

XmlPropertySerializer Class
CodeSmith.Engine Namespace


XmlPropertySerializer Methods

The XmlPropertySerializer type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadProperty |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseDefaultValue |
Public method | ReadPropertyXml |
Public method | SaveProperty |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WritePropertyXml |
Top
See Also

Reference

XmlPropertySerializer Class
CodeSmith.Engine Namespace


XmlPropertySerializer.LoadProperty Method

XmlPropertySerializerLoadProperty Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public Object LoadProperty(
    PropertySerializerContext context,
    Object propertyValue
)
Public Function LoadProperty (
    context As PropertySerializerContext,
    propertyValue As Object
) As Object

Parameters

context
Type: CodeSmith.EnginePropertySerializerContext
propertyValue
Type: SystemObject

Return Value

Type: Object

Implements

IPropertySerializerLoadProperty(PropertySerializerContext, Object)
See Also

Reference

XmlPropertySerializer Class
CodeSmith.Engine Namespace


XmlPropertySerializer.ParseDefaultValue Method

XmlPropertySerializerParseDefaultValue Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public Object ParseDefaultValue(
    PropertySerializerContext context,
    string defaultValue
)
Public Function ParseDefaultValue (
    context As PropertySerializerContext,
    defaultValue As String
) As Object

Parameters

context
Type: CodeSmith.EnginePropertySerializerContext
defaultValue
Type: SystemString

Return Value

Type: Object

Implements

IPropertySerializerParseDefaultValue(PropertySerializerContext, String)
See Also

Reference

XmlPropertySerializer Class
CodeSmith.Engine Namespace


XmlPropertySerializer.ReadPropertyXml Method

XmlPropertySerializerReadPropertyXml Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public Object ReadPropertyXml(
    PropertySerializerContext context,
    XmlNode propertyValue
)
Public Function ReadPropertyXml (
    context As PropertySerializerContext,
    propertyValue As XmlNode
) As Object

Parameters

context
Type: CodeSmith.EnginePropertySerializerContext
propertyValue
Type: System.XmlXmlNode

Return Value

Type: Object

Implements

IPropertySerializerReadPropertyXml(PropertySerializerContext, XmlNode)
See Also

Reference

XmlPropertySerializer Class
CodeSmith.Engine Namespace


XmlPropertySerializer.SaveProperty Method

XmlPropertySerializerSaveProperty Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public Object SaveProperty(
    PropertySerializerContext context,
    Object propertyValue
)
Public Function SaveProperty (
    context As PropertySerializerContext,
    propertyValue As Object
) As Object

Parameters

context
Type: CodeSmith.EnginePropertySerializerContext
propertyValue
Type: SystemObject

Return Value

Type: Object

Implements

IPropertySerializerSaveProperty(PropertySerializerContext, Object)
See Also

Reference

XmlPropertySerializer Class
CodeSmith.Engine Namespace


XmlPropertySerializer.WritePropertyXml Method

XmlPropertySerializerWritePropertyXml Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void WritePropertyXml(
    PropertySerializerContext context,
    XmlWriter writer,
    Object propertyValue
)
Public Sub WritePropertyXml (
    context As PropertySerializerContext,
    writer As XmlWriter,
    propertyValue As Object
)

Parameters

context
Type: CodeSmith.EnginePropertySerializerContext
writer
Type: System.XmlXmlWriter
propertyValue
Type: SystemObject

Implements

IPropertySerializerWritePropertyXml(PropertySerializerContext, XmlWriter, Object)
See Also

Reference

XmlPropertySerializer Class
CodeSmith.Engine Namespace


XmlPropertyTypeConverter Class

This class can be used to convert to and from an XmlNode for a class that supports XML serialization.
Inheritance Hierarchy
SystemObject
System.ComponentModelTypeConverter
CodeSmith.EngineXmlPropertyTypeConverter

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class XmlPropertyTypeConverter : TypeConverter
Public Class XmlPropertyTypeConverter
    Inherits TypeConverter

The XmlPropertyTypeConverter type exposes the following members.

Constructors
 | Name | Description
Public method | XmlPropertyTypeConverter | Initializes a new instance of the XmlPropertyTypeConverter class
Top
Methods
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | (Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | (Overrides TypeConverterCanConvertTo(ITypeDescriptorContext, Type).)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
Public method | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | (Overrides TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Public method | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
Public method | CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Protected method | GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object, Attribute) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported | Returns whether this object supports properties. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | Returns whether this object supports properties, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValues | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
Public method | GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
Public method | IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSmith.Engine Namespace


XmlPropertyTypeConverter Constructor

Initializes a new instance of the XmlPropertyTypeConverter class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public XmlPropertyTypeConverter()
Public Sub New
See Also

Reference

XmlPropertyTypeConverter Class
CodeSmith.Engine Namespace


XmlPropertyTypeConverter Methods

The XmlPropertyTypeConverter type exposes the following members.

Methods
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | (Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | (Overrides TypeConverterCanConvertTo(ITypeDescriptorContext, Type).)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
Public method | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | (Overrides TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Public method | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
Public method | CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Protected method | GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object, Attribute) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported | Returns whether this object supports properties. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | Returns whether this object supports properties, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValues | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
Public method | GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
Public method | IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XmlPropertyTypeConverter Class
CodeSmith.Engine Namespace


XmlPropertyTypeConverter.CanConvertFrom Method

XmlPropertyTypeConverterCanConvertFrom Method

Overload List
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | (Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Top
See Also

Reference

XmlPropertyTypeConverter Class
CodeSmith.Engine Namespace


XmlPropertyTypeConverter.CanConvertFrom Method (ITypeDescriptorContext, Type)

XmlPropertyTypeConverterCanConvertFrom Method (ITypeDescriptorContext, Type)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override bool CanConvertFrom(
    ITypeDescriptorContext context,
    Type sourceType
)
Public Overrides Function CanConvertFrom (
    context As ITypeDescriptorContext,
    sourceType As Type
) As Boolean

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
sourceType
Type: SystemType

Return Value

Type: Boolean
See Also

Reference

XmlPropertyTypeConverter Class
CanConvertFrom Overload
CodeSmith.Engine Namespace


XmlPropertyTypeConverter.CanConvertTo Method

XmlPropertyTypeConverterCanConvertTo Method

Overload List
 | Name | Description
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | (Overrides TypeConverterCanConvertTo(ITypeDescriptorContext, Type).)
Top
See Also

Reference

XmlPropertyTypeConverter Class
CodeSmith.Engine Namespace


XmlPropertyTypeConverter.CanConvertTo Method (ITypeDescriptorContext, Type)

XmlPropertyTypeConverterCanConvertTo Method (ITypeDescriptorContext, Type)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override bool CanConvertTo(
    ITypeDescriptorContext context,
    Type destinationType
)
Public Overrides Function CanConvertTo (
    context As ITypeDescriptorContext,
    destinationType As Type
) As Boolean

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
destinationType
Type: SystemType

Return Value

Type: Boolean
See Also

Reference

XmlPropertyTypeConverter Class
CanConvertTo Overload
CodeSmith.Engine Namespace


XmlPropertyTypeConverter.ConvertFrom Method

XmlPropertyTypeConverterConvertFrom Method

Overload List
 | Name | Description
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Top
See Also

Reference

XmlPropertyTypeConverter Class
CodeSmith.Engine Namespace


XmlPropertyTypeConverter.ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

XmlPropertyTypeConverterConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override Object ConvertFrom(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value
)
Public Overrides Function ConvertFrom (
    context As ITypeDescriptorContext,
    culture As CultureInfo,
    value As Object
) As Object

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
culture
Type: System.GlobalizationCultureInfo
value
Type: SystemObject

Return Value

Type: Object
See Also

Reference

XmlPropertyTypeConverter Class
ConvertFrom Overload
CodeSmith.Engine Namespace


XmlPropertyTypeConverter.ConvertTo Method

XmlPropertyTypeConverterConvertTo Method

Overload List
 | Name | Description
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | (Overrides TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Top
See Also

Reference

XmlPropertyTypeConverter Class
CodeSmith.Engine Namespace


XmlPropertyTypeConverter.ConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)

XmlPropertyTypeConverterConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override Object ConvertTo(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value,
    Type destinationType
)
Public Overrides Function ConvertTo (
    context As ITypeDescriptorContext,
    culture As CultureInfo,
    value As Object,
    destinationType As Type
) As Object

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
culture
Type: System.GlobalizationCultureInfo
value
Type: SystemObject
destinationType
Type: SystemType

Return Value

Type: Object
See Also

Reference

XmlPropertyTypeConverter Class
ConvertTo Overload
CodeSmith.Engine Namespace


XmlSchemaFilePicker Class

Allows you to browse for an XSD Schema.
Inheritance Hierarchy
SystemObject
System.Drawing.DesignUITypeEditor
CodeSmith.EngineXmlSchemaFilePicker

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class XmlSchemaFilePicker : UITypeEditor
Public Class XmlSchemaFilePicker
    Inherits UITypeEditor

The XmlSchemaFilePicker type exposes the following members.

Constructors
 | Name | Description
Public method | XmlSchemaFilePicker | Initializes a new instance of the XmlSchemaFilePicker class
Top
Properties
 | Name | Description
Public property | IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Inherited from UITypeEditor.)
Top
Methods
 | Name | Description
Public method | EditValue(IServiceProvider, Object) | Edits the value of the specified object using the editor style indicated by the GetEditStyle method. (Inherited from UITypeEditor.)
Public method | EditValue(ITypeDescriptorContext, IServiceProvider, Object) | (Overrides UITypeEditorEditValue(ITypeDescriptorContext, IServiceProvider, Object).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEditStyle | Gets the editor style used by the EditValue(IServiceProvider, Object) method. (Inherited from UITypeEditor.)
Public method | GetEditStyle(ITypeDescriptorContext) | (Overrides UITypeEditorGetEditStyle(ITypeDescriptorContext).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetPaintValueSupported | Indicates whether this editor supports painting a representation of an object's value. (Inherited from UITypeEditor.)
Public method | GetPaintValueSupported(ITypeDescriptorContext) | Indicates whether the specified context supports painting a representation of an object's value within the specified context. (Inherited from UITypeEditor.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PaintValue(PaintValueEventArgs) | Paints a representation of the value of an object using the specified PaintValueEventArgs. (Inherited from UITypeEditor.)
Public method | PaintValue(Object, Graphics, Rectangle) | Paints a representation of the value of the specified object to the specified canvas. (Inherited from UITypeEditor.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSmith.Engine Namespace


XmlSchemaFilePicker Constructor

Initializes a new instance of the XmlSchemaFilePicker class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public XmlSchemaFilePicker()
Public Sub New
See Also

Reference

XmlSchemaFilePicker Class
CodeSmith.Engine Namespace


XmlSchemaFilePicker Properties

The XmlSchemaFilePicker type exposes the following members.

Properties
 | Name | Description
Public property | IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Inherited from UITypeEditor.)
Top
See Also

Reference

XmlSchemaFilePicker Class
CodeSmith.Engine Namespace


XmlSchemaFilePicker Methods

The XmlSchemaFilePicker type exposes the following members.

Methods
 | Name | Description
Public method | EditValue(IServiceProvider, Object) | Edits the value of the specified object using the editor style indicated by the GetEditStyle method. (Inherited from UITypeEditor.)
Public method | EditValue(ITypeDescriptorContext, IServiceProvider, Object) | (Overrides UITypeEditorEditValue(ITypeDescriptorContext, IServiceProvider, Object).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEditStyle | Gets the editor style used by the EditValue(IServiceProvider, Object) method. (Inherited from UITypeEditor.)
Public method | GetEditStyle(ITypeDescriptorContext) | (Overrides UITypeEditorGetEditStyle(ITypeDescriptorContext).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetPaintValueSupported | Indicates whether this editor supports painting a representation of an object's value. (Inherited from UITypeEditor.)
Public method | GetPaintValueSupported(ITypeDescriptorContext) | Indicates whether the specified context supports painting a representation of an object's value within the specified context. (Inherited from UITypeEditor.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PaintValue(PaintValueEventArgs) | Paints a representation of the value of an object using the specified PaintValueEventArgs. (Inherited from UITypeEditor.)
Public method | PaintValue(Object, Graphics, Rectangle) | Paints a representation of the value of the specified object to the specified canvas. (Inherited from UITypeEditor.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

XmlSchemaFilePicker Class
CodeSmith.Engine Namespace


XmlSchemaFilePicker.EditValue Method

XmlSchemaFilePickerEditValue Method

Overload List
 | Name | Description
Public method | EditValue(IServiceProvider, Object) | Edits the value of the specified object using the editor style indicated by the GetEditStyle method. (Inherited from UITypeEditor.)
Public method | EditValue(ITypeDescriptorContext, IServiceProvider, Object) | (Overrides UITypeEditorEditValue(ITypeDescriptorContext, IServiceProvider, Object).)
Top
See Also

Reference

XmlSchemaFilePicker Class
CodeSmith.Engine Namespace


XmlSchemaFilePicker.EditValue Method (ITypeDescriptorContext, IServiceProvider, Object)

XmlSchemaFilePickerEditValue Method (ITypeDescriptorContext, IServiceProvider, Object)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override Object EditValue(
    ITypeDescriptorContext context,
    IServiceProvider provider,
    Object value
)
Public Overrides Function EditValue (
    context As ITypeDescriptorContext,
    provider As IServiceProvider,
    value As Object
) As Object

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
provider
Type: SystemIServiceProvider
value
Type: SystemObject

Return Value

Type: Object
See Also

Reference

XmlSchemaFilePicker Class
EditValue Overload
CodeSmith.Engine Namespace


XmlSchemaFilePicker.GetEditStyle Method

XmlSchemaFilePickerGetEditStyle Method

Overload List
 | Name | Description
Public method | GetEditStyle | Gets the editor style used by the EditValue(IServiceProvider, Object) method. (Inherited from UITypeEditor.)
Public method | GetEditStyle(ITypeDescriptorContext) | (Overrides UITypeEditorGetEditStyle(ITypeDescriptorContext).)
Top
See Also

Reference

XmlSchemaFilePicker Class
CodeSmith.Engine Namespace


XmlSchemaFilePicker.GetEditStyle Method (ITypeDescriptorContext)

XmlSchemaFilePickerGetEditStyle Method (ITypeDescriptorContext)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override UITypeEditorEditStyle GetEditStyle(
    ITypeDescriptorContext context
)
Public Overrides Function GetEditStyle (
    context As ITypeDescriptorContext
) As UITypeEditorEditStyle

Parameters

context
Type: System.ComponentModelITypeDescriptorContext

Return Value

Type: UITypeEditorEditStyle
See Also

Reference

XmlSchemaFilePicker Class
GetEditStyle Overload
CodeSmith.Engine Namespace


XmlSchemaSerializer Class

Inheritance Hierarchy
SystemObject
CodeSmith.EngineXmlSchemaSerializer

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class XmlSchemaSerializer : IPropertySerializer
Public Class XmlSchemaSerializer
    Implements IPropertySerializer

The XmlSchemaSerializer type exposes the following members.

Constructors
 | Name | Description
Public method | XmlSchemaSerializer | Initializes a new instance of the XmlSchemaSerializer class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadProperty |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseDefaultValue |
Public method | ReadPropertyXml |
Public method | SaveProperty |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WritePropertyXml |
Top
See Also

Reference

CodeSmith.Engine Namespace


XmlSchemaSerializer Constructor

Initializes a new instance of the XmlSchemaSerializer class

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public XmlSchemaSerializer()
Public Sub New
See Also

Reference

XmlSchemaSerializer Class
CodeSmith.Engine Namespace


XmlSchemaSerializer Methods

The XmlSchemaSerializer type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadProperty |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseDefaultValue |
Public method | ReadPropertyXml |
Public method | SaveProperty |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WritePropertyXml |
Top
See Also

Reference

XmlSchemaSerializer Class
CodeSmith.Engine Namespace


XmlSchemaSerializer.LoadProperty Method

XmlSchemaSerializerLoadProperty Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public Object LoadProperty(
    PropertySerializerContext context,
    Object propertyValue
)
Public Function LoadProperty (
    context As PropertySerializerContext,
    propertyValue As Object
) As Object

Parameters

context
Type: CodeSmith.EnginePropertySerializerContext
propertyValue
Type: SystemObject

Return Value

Type: Object

Implements

IPropertySerializerLoadProperty(PropertySerializerContext, Object)
See Also

Reference

XmlSchemaSerializer Class
CodeSmith.Engine Namespace


XmlSchemaSerializer.ParseDefaultValue Method

XmlSchemaSerializerParseDefaultValue Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public Object ParseDefaultValue(
    PropertySerializerContext context,
    string defaultValue
)
Public Function ParseDefaultValue (
    context As PropertySerializerContext,
    defaultValue As String
) As Object

Parameters

context
Type: CodeSmith.EnginePropertySerializerContext
defaultValue
Type: SystemString

Return Value

Type: Object

Implements

IPropertySerializerParseDefaultValue(PropertySerializerContext, String)
See Also

Reference

XmlSchemaSerializer Class
CodeSmith.Engine Namespace


XmlSchemaSerializer.ReadPropertyXml Method

XmlSchemaSerializerReadPropertyXml Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public Object ReadPropertyXml(
    PropertySerializerContext context,
    XmlNode propertyValue
)
Public Function ReadPropertyXml (
    context As PropertySerializerContext,
    propertyValue As XmlNode
) As Object

Parameters

context
Type: CodeSmith.EnginePropertySerializerContext
propertyValue
Type: System.XmlXmlNode

Return Value

Type: Object

Implements

IPropertySerializerReadPropertyXml(PropertySerializerContext, XmlNode)
See Also

Reference

XmlSchemaSerializer Class
CodeSmith.Engine Namespace


XmlSchemaSerializer.SaveProperty Method

XmlSchemaSerializerSaveProperty Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public Object SaveProperty(
    PropertySerializerContext context,
    Object propertyValue
)
Public Function SaveProperty (
    context As PropertySerializerContext,
    propertyValue As Object
) As Object

Parameters

context
Type: CodeSmith.EnginePropertySerializerContext
propertyValue
Type: SystemObject

Return Value

Type: Object

Implements

IPropertySerializerSaveProperty(PropertySerializerContext, Object)
See Also

Reference

XmlSchemaSerializer Class
CodeSmith.Engine Namespace


XmlSchemaSerializer.WritePropertyXml Method

XmlSchemaSerializerWritePropertyXml Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void WritePropertyXml(
    PropertySerializerContext context,
    XmlWriter writer,
    Object propertyValue
)
Public Sub WritePropertyXml (
    context As PropertySerializerContext,
    writer As XmlWriter,
    propertyValue As Object
)

Parameters

context
Type: CodeSmith.EnginePropertySerializerContext
writer
Type: System.XmlXmlWriter
propertyValue
Type: SystemObject

Implements

IPropertySerializerWritePropertyXml(PropertySerializerContext, XmlWriter, Object)
See Also

Reference

XmlSchemaSerializer Class
CodeSmith.Engine Namespace


XsdHelper Class

Inheritance Hierarchy
SystemObject
CodeSmith.EngineXsdHelper

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static class XsdHelper
Public NotInheritable Class XsdHelper

The XsdHelper type exposes the following members.

Methods
Name | Description
CompileAssemblyFromSchema |
CreateSchemaCodeDom(String, String, String, CodeNamespace, ActionTemplateError) |
CreateSchemaCodeDom(String, String, String, String, CodeNamespace, ActionTemplateError) |
GenerateCodeForSchemaTypes |
IsValidSchema |
Top
See Also

Reference

CodeSmith.Engine Namespace


XsdHelper Methods

The XsdHelper type exposes the following members.

Methods
Name | Description
CompileAssemblyFromSchema |
CreateSchemaCodeDom(String, String, String, CodeNamespace, ActionTemplateError) |
CreateSchemaCodeDom(String, String, String, String, CodeNamespace, ActionTemplateError) |
GenerateCodeForSchemaTypes |
IsValidSchema |
Top
See Also

Reference

XsdHelper Class
CodeSmith.Engine Namespace


XsdHelper.CompileAssemblyFromSchema Method

XsdHelperCompileAssemblyFromSchema Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static CompilerResults CompileAssemblyFromSchema(
    SchemaArguments sa
)
Public Shared Function CompileAssemblyFromSchema (
    sa As SchemaArguments
) As CompilerResults

Parameters

sa
Type: CodeSmith.EngineSchemaArguments

Return Value

Type: CompilerResults
See Also

Reference

XsdHelper Class
CodeSmith.Engine Namespace


XsdHelper.CreateSchemaCodeDom Method

XsdHelperCreateSchemaCodeDom Method

Overload List
Name | Description
CreateSchemaCodeDom(String, String, String, CodeNamespace, ActionTemplateError) |
CreateSchemaCodeDom(String, String, String, String, CodeNamespace, ActionTemplateError) |
Top
See Also

Reference

XsdHelper Class
CodeSmith.Engine Namespace


XsdHelper.CreateSchemaCodeDom Method (String, String, String, CodeNamespace, Action(TemplateError))

XsdHelperCreateSchemaCodeDom Method (String, String, String, CodeNamespace, ActionTemplateError)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static void CreateSchemaCodeDom(
    string schemaFile,
    string classNamespace,
    out string defaultTypeName,
    out CodeNamespace schemaCodeNamespace,
    Action<TemplateError> reportErrorAction
)
Public Shared Sub CreateSchemaCodeDom (
    schemaFile As String,
    classNamespace As String,
    <OutAttribute> ByRef defaultTypeName As String,
    <OutAttribute> ByRef schemaCodeNamespace As CodeNamespace,
    reportErrorAction As Action(Of TemplateError)
)

Parameters

schemaFile
Type: SystemString
classNamespace
Type: SystemString
defaultTypeName
Type: SystemString
schemaCodeNamespace
Type: System.CodeDomCodeNamespace
reportErrorAction
Type: SystemAction TemplateError
See Also

Reference

XsdHelper Class
CreateSchemaCodeDom Overload
CodeSmith.Engine Namespace


XsdHelper.CreateSchemaCodeDom Method (String, String, String, String, CodeNamespace, Action(TemplateError))

XsdHelperCreateSchemaCodeDom Method (String, String, String, String, CodeNamespace, ActionTemplateError)

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static void CreateSchemaCodeDom(
    string schemaFile,
    string classNamespace,
    string schemacontent,
    out string defaultTypeName,
    out CodeNamespace schemaCodeNamespace,
    Action<TemplateError> reportErrorAction
)
Public Shared Sub CreateSchemaCodeDom (
    schemaFile As String,
    classNamespace As String,
    schemacontent As String,
    <OutAttribute> ByRef defaultTypeName As String,
    <OutAttribute> ByRef schemaCodeNamespace As CodeNamespace,
    reportErrorAction As Action(Of TemplateError)
)

Parameters

schemaFile
Type: SystemString
classNamespace
Type: SystemString
schemacontent
Type: SystemString
defaultTypeName
Type: SystemString
schemaCodeNamespace
Type: System.CodeDomCodeNamespace
reportErrorAction
Type: SystemAction TemplateError
See Also

Reference

XsdHelper Class
CreateSchemaCodeDom Overload
CodeSmith.Engine Namespace


XsdHelper.GenerateCodeForSchemaTypes Method

XsdHelperGenerateCodeForSchemaTypes Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static GenerateCodeResult GenerateCodeForSchemaTypes(
    string schemaPath,
    string schemacontent,
    OutputLanguage language,
    Action<TemplateError> reportErrorAction
)
Public Shared Function GenerateCodeForSchemaTypes (
    schemaPath As String,
    schemacontent As String,
    language As OutputLanguage,
    reportErrorAction As Action(Of TemplateError)
) As GenerateCodeResult

Parameters

schemaPath
Type: SystemString
schemacontent
Type: SystemString
language
Type: CodeSmith.EngineOutputLanguage
reportErrorAction
Type: SystemAction TemplateError

Return Value

Type: GenerateCodeResult
See Also

Reference

XsdHelper Class
CodeSmith.Engine Namespace


XsdHelper.IsValidSchema Method

XsdHelperIsValidSchema Method

Namespace: CodeSmith.Engine
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static bool IsValidSchema(
    string fileName,
    string content = null
)
Public Shared Function IsValidSchema (
    fileName As String,
    Optional content As String = Nothing
) As Boolean

Parameters

fileName
Type: SystemString
content (Optional)
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

XsdHelper Class
CodeSmith.Engine Namespace


CodeSmith.Engine.Compiler Namespace

Classes
 | Class | Description
Public class | AssemblyReference |
Public class | AssemblyReferenceSet |
Public class | AssemblyResolver |
Public class | CachedCompiler |
Protected class | CachedCompilerCompileContext |
Public class | CacheEntry |
Public class | CacheManager |
Public class | CompileRequest |
Public class | CompileResult |


AssemblyReference Class

Inheritance Hierarchy
SystemObject
CodeSmith.Engine.CompilerAssemblyReference

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class AssemblyReference
Public Class AssemblyReference

The AssemblyReference type exposes the following members.

Constructors
 | Name | Description
Public method | AssemblyReference | Initializes a new instance of the AssemblyReference class.
Top
Properties
 | Name | Description
Public property | CopyLocal | Gets or sets a value indicating the assembly should be copied local.
Public property | FullName | Gets or sets the full assembly name.
Public property | FullPath | Gets or sets the full path to the assembly.
Public property | GlobalAssemblyCache | Gets a value indicating whether the assembly was loaded from the global assembly cache.
Public property | Name | Gets or sets the assembly name.
Public property | Original | Gets or sets the original name used to request the assembly resolve.
Top
Methods
 | Name | Description
Public method | Equals | (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSmith.Engine.Compiler Namespace


AssemblyReference Constructor

Initializes a new instance of the AssemblyReference class.

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public AssemblyReference()
Public Sub New
See Also

Reference

AssemblyReference Class
CodeSmith.Engine.Compiler Namespace


AssemblyReference Properties

The AssemblyReference type exposes the following members.

Properties
 | Name | Description
Public property | CopyLocal | Gets or sets a value indicating the assembly should be copied local.
Public property | FullName | Gets or sets the full assembly name.
Public property | FullPath | Gets or sets the full path to the assembly.
Public property | GlobalAssemblyCache | Gets a value indicating whether the assembly was loaded from the global assembly cache.
Public property | Name | Gets or sets the assembly name.
Public property | Original | Gets or sets the original name used to request the assembly resolve.
Top
See Also

Reference

AssemblyReference Class
CodeSmith.Engine.Compiler Namespace


AssemblyReference.CopyLocal Property

AssemblyReferenceCopyLocal Property

Gets or sets a value indicating the assembly should be copied local.

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool CopyLocal { get; set; }
Public Property CopyLocal As Boolean
    Get
    Set

Property Value

Type: Boolean
true if copy local; otherwise, false.
See Also

Reference

AssemblyReference Class
CodeSmith.Engine.Compiler Namespace


AssemblyReference.FullName Property

AssemblyReferenceFullName Property

Gets or sets the full assembly name.

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string FullName { get; set; }
Public Property FullName As String
    Get
    Set

Property Value

Type: String
The full assembly name.
See Also

Reference

AssemblyReference Class
CodeSmith.Engine.Compiler Namespace


AssemblyReference.FullPath Property

AssemblyReferenceFullPath Property

Gets or sets the full path to the assembly.

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string FullPath { get; set; }
Public Property FullPath As String
    Get
    Set

Property Value

Type: String
The path to the assembly.
See Also

Reference

AssemblyReference Class
CodeSmith.Engine.Compiler Namespace


AssemblyReference.GlobalAssemblyCache Property

AssemblyReferenceGlobalAssemblyCache Property

Gets a value indicating whether the assembly was loaded from the global assembly cache.

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool GlobalAssemblyCache { get; }
Public ReadOnly Property GlobalAssemblyCache As Boolean
    Get

Property Value

Type: Boolean
true if the assembly was loaded from the global assembly cache; otherwise, false.
See Also

Reference

AssemblyReference Class
CodeSmith.Engine.Compiler Namespace


AssemblyReference.Name Property

AssemblyReferenceName Property

Gets or sets the assembly name.

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set

Property Value

Type: String
The assembly name.
See Also

Reference

AssemblyReference Class
CodeSmith.Engine.Compiler Namespace


AssemblyReference.Original Property

AssemblyReferenceOriginal Property

Gets or sets the original name used to request the assembly resolve.

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string Original { get; set; }
Public Property Original As String
    Get
    Set

Property Value

Type: String
The original name.
See Also

Reference

AssemblyReference Class
CodeSmith.Engine.Compiler Namespace


AssemblyReference Methods

The AssemblyReference type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AssemblyReference Class
CodeSmith.Engine.Compiler Namespace


AssemblyReference.Equals Method

AssemblyReferenceEquals Method

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject

Return Value

Type: Boolean
See Also

Reference

AssemblyReference Class
CodeSmith.Engine.Compiler Namespace


AssemblyReference.GetHashCode Method

AssemblyReferenceGetHashCode Method

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
See Also

Reference

AssemblyReference Class
CodeSmith.Engine.Compiler Namespace


AssemblyReferenceSet Class

Inheritance Hierarchy
SystemObject
System.Collections.GenericHashSet AssemblyReference
CodeSmith.Engine.CompilerAssemblyReferenceSet

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class AssemblyReferenceSet : HashSet<AssemblyReference>
Public Class AssemblyReferenceSet
    Inherits HashSet(Of AssemblyReference)

The AssemblyReferenceSet type exposes the following members.

Constructors
 | Name | Description
Public method | AssemblyReferenceSet | Initializes a new instance of the AssemblyReferenceSet class
Top
Properties
 | Name | Description
Public property | Comparer | Gets the IEqualityComparerT object that is used to determine equality for the values in the set. (Inherited from HashSet AssemblyReference .)
Public property | Count | Gets the number of elements that are contained in a set. (Inherited from HashSet AssemblyReference .)
Top
Methods
 | Name | Description
Public method | Add(T) | Adds the specified element to a set. (Inherited from HashSet AssemblyReference .)
Public method | Add(IEnumerableString) |
Public method | Add(String) |
Public method | Add(IEnumerableString, String) |
Public method | Add(String, String) |
Public method | Add(IEnumerableString, IEnumerableString, Boolean) |
Public method | Add(String, IEnumerableString, Boolean) |
Public method | Add(IEnumerableString, IEnumerableString, IEnumerableString, Boolean) |
Public method | Add(String, IEnumerableString, IEnumerableString, Boolean) |
Public method | Clear | Removes all elements from a HashSetT object. (Inherited from HashSet AssemblyReference .)
Public method | Contains | Determines whether a HashSetT object contains the specified element. (Inherited from HashSet AssemblyReference .)
Public method | CopyTo(T) | Copies the elements of a HashSetT object to an array. (Inherited from HashSet AssemblyReference .)
Public method | CopyTo(T, Int32) | Copies the elements of a HashSetT object to an array, starting at the specified array index. (Inherited from HashSet AssemblyReference .)
Public method | CopyTo(T, Int32, Int32) | Copies the specified number of elements of a HashSetT object to an array, starting at the specified array index. (Inherited from HashSet AssemblyReference .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | ExceptWith | Removes all elements in the specified collection from the current HashSetT object. (Inherited from HashSet AssemblyReference .)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through a HashSetT object. (Inherited from HashSet AssemblyReference .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize a HashSetT object. (Inherited from HashSet AssemblyReference .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IntersectWith | Modifies the current HashSetT object to contain only elements that are present in that object and in the specified collection. (Inherited from HashSet AssemblyReference .)
Public method | IsProperSubsetOf | Determines whether a HashSetT object is a proper subset of the specified collection. (Inherited from HashSet AssemblyReference .)
Public method | IsProperSupersetOf | Determines whether a HashSetT object is a proper superset of the specified collection. (Inherited from HashSet AssemblyReference .)
Public method | IsSubsetOf | Determines whether a HashSetT object is a subset of the specified collection. (Inherited from HashSet AssemblyReference .)
Public method | IsSupersetOf | Determines whether a HashSetT object is a superset of the specified collection. (Inherited from HashSet AssemblyReference .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from HashSet AssemblyReference .)
Public method | Overlaps | Determines whether the current HashSetT object and a specified collection share common elements. (Inherited from HashSet AssemblyReference .)
Public method | Remove | Removes the specified element from a HashSetT object. (Inherited from HashSet AssemblyReference .)
Public method | RemoveWhere | Removes all elements that match the conditions defined by the specified predicate from a HashSetT collection. (Inherited from HashSet AssemblyReference .)
Public method | SetEquals | Determines whether a HashSetT object and the specified collection contain the same elements. (Inherited from HashSet AssemblyReference .)
Public method | ShadowCopy |
Public method | SymmetricExceptWith | Modifies the current HashSetT object to contain only elements that are present either in that object or in the specified collection, but not both. (Inherited from HashSet AssemblyReference .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity of a HashSetT object to the actual number of elements it contains, rounded up to a nearby, implementation-specific value. (Inherited from HashSet AssemblyReference .)
Public method | TryGetValue | Searches the set for a given value and returns the equal value it finds, if any. (Inherited from HashSet AssemblyReference .)
Public method | UnionWith | Modifies the current HashSetT object to contain all elements that are present in itself, the specified collection, or both. (Inherited from HashSet AssemblyReference .)
Top
See Also

Reference

CodeSmith.Engine.Compiler Namespace


AssemblyReferenceSet Constructor

Initializes a new instance of the AssemblyReferenceSet class

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public AssemblyReferenceSet()
Public Sub New
See Also

Reference

AssemblyReferenceSet Class
CodeSmith.Engine.Compiler Namespace


AssemblyReferenceSet Properties

The AssemblyReferenceSet type exposes the following members.

Properties
 | Name | Description
Public property | Comparer | Gets the IEqualityComparerT object that is used to determine equality for the values in the set. (Inherited from HashSet AssemblyReference .)
Public property | Count | Gets the number of elements that are contained in a set. (Inherited from HashSet AssemblyReference .)
Top
See Also

Reference

AssemblyReferenceSet Class
CodeSmith.Engine.Compiler Namespace


AssemblyReferenceSet Methods

The AssemblyReferenceSet type exposes the following members.

Methods
 | Name | Description
Public method | Add(T) | Adds the specified element to a set. (Inherited from HashSet AssemblyReference .)
Public method | Add(IEnumerableString) |
Public method | Add(String) |
Public method | Add(IEnumerableString, String) |
Public method | Add(String, String) |
Public method | Add(IEnumerableString, IEnumerableString, Boolean) |
Public method | Add(String, IEnumerableString, Boolean) |
Public method | Add(IEnumerableString, IEnumerableString, IEnumerableString, Boolean) |
Public method | Add(String, IEnumerableString, IEnumerableString, Boolean) |
Public method | Clear | Removes all elements from a HashSetT object. (Inherited from HashSet AssemblyReference .)
Public method | Contains | Determines whether a HashSetT object contains the specified element. (Inherited from HashSet AssemblyReference .)
Public method | CopyTo(T) | Copies the elements of a HashSetT object to an array. (Inherited from HashSet AssemblyReference .)
Public method | CopyTo(T, Int32) | Copies the elements of a HashSetT object to an array, starting at the specified array index. (Inherited from HashSet AssemblyReference .)
Public method | CopyTo(T, Int32, Int32) | Copies the specified number of elements of a HashSetT object to an array, starting at the specified array index. (Inherited from HashSet AssemblyReference .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | ExceptWith | Removes all elements in the specified collection from the current HashSetT object. (Inherited from HashSet AssemblyReference .)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through a HashSetT object. (Inherited from HashSet AssemblyReference .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize a HashSetT object. (Inherited from HashSet AssemblyReference .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IntersectWith | Modifies the current HashSetT object to contain only elements that are present in that object and in the specified collection. (Inherited from HashSet AssemblyReference .)
Public method | IsProperSubsetOf | Determines whether a HashSetT object is a proper subset of the specified collection. (Inherited from HashSet AssemblyReference .)
Public method | IsProperSupersetOf | Determines whether a HashSetT object is a proper superset of the specified collection. (Inherited from HashSet AssemblyReference .)
Public method | IsSubsetOf | Determines whether a HashSetT object is a subset of the specified collection. (Inherited from HashSet AssemblyReference .)
Public method | IsSupersetOf | Determines whether a HashSetT object is a superset of the specified collection. (Inherited from HashSet AssemblyReference .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from HashSet AssemblyReference .)
Public method | Overlaps | Determines whether the current HashSetT object and a specified collection share common elements. (Inherited from HashSet AssemblyReference .)
Public method | Remove | Removes the specified element from a HashSetT object. (Inherited from HashSet AssemblyReference .)
Public method | RemoveWhere | Removes all elements that match the conditions defined by the specified predicate from a HashSetT collection. (Inherited from HashSet AssemblyReference .)
Public method | SetEquals | Determines whether a HashSetT object and the specified collection contain the same elements. (Inherited from HashSet AssemblyReference .)
Public method | ShadowCopy |
Public method | SymmetricExceptWith | Modifies the current HashSetT object to contain only elements that are present either in that object or in the specified collection, but not both. (Inherited from HashSet AssemblyReference .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity of a HashSetT object to the actual number of elements it contains, rounded up to a nearby, implementation-specific value. (Inherited from HashSet AssemblyReference .)
Public method | TryGetValue | Searches the set for a given value and returns the equal value it finds, if any. (Inherited from HashSet AssemblyReference .)
Public method | UnionWith | Modifies the current HashSetT object to contain all elements that are present in itself, the specified collection, or both. (Inherited from HashSet AssemblyReference .)
Top
See Also

Reference

AssemblyReferenceSet Class
CodeSmith.Engine.Compiler Namespace


AssemblyReferenceSet.Add Method

AssemblyReferenceSetAdd Method

Overload List
 | Name | Description
Public method | Add(T) | Adds the specified element to a set. (Inherited from HashSet AssemblyReference .)
Public method | Add(IEnumerableString) |
Public method | Add(String) |
Public method | Add(IEnumerableString, String) |
Public method | Add(String, String) |
Public method | Add(IEnumerableString, IEnumerableString, Boolean) |
Public method | Add(String, IEnumerableString, Boolean) |
Public method | Add(IEnumerableString, IEnumerableString, IEnumerableString, Boolean) |
Public method | Add(String, IEnumerableString, IEnumerableString, Boolean) |
Top
See Also

Reference

AssemblyReferenceSet Class
CodeSmith.Engine.Compiler Namespace


AssemblyReferenceSet.Add Method (IEnumerable(String))

AssemblyReferenceSetAdd Method (IEnumerableString)

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public IEnumerable<AssemblyReference> Add(
    IEnumerable<string> assemblyNames
)
Public Function Add (
    assemblyNames As IEnumerable(Of String)
) As IEnumerable(Of AssemblyReference)

Parameters

assemblyNames
Type: System.Collections.GenericIEnumerable String

Return Value

Type: IEnumerable AssemblyReference
See Also

Reference

AssemblyReferenceSet Class
Add Overload
CodeSmith.Engine.Compiler Namespace


AssemblyReferenceSet.Add Method (String)

AssemblyReferenceSetAdd Method (String)

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool Add(
    string assembly
)
Public Function Add (
    assembly As String
) As Boolean

Parameters

assembly
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

AssemblyReferenceSet Class
Add Overload
CodeSmith.Engine.Compiler Namespace


AssemblyReferenceSet.Add Method (IEnumerable(String), String)

AssemblyReferenceSetAdd Method (IEnumerableString, String)

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public IEnumerable<AssemblyReference> Add(
    IEnumerable<string> assemblyNames,
    string baseDirectory
)
Public Function Add (
    assemblyNames As IEnumerable(Of String),
    baseDirectory As String
) As IEnumerable(Of AssemblyReference)

Parameters

assemblyNames
Type: System.Collections.GenericIEnumerable String
baseDirectory
Type: SystemString

Return Value

Type: IEnumerable AssemblyReference
See Also

Reference

AssemblyReferenceSet Class
Add Overload
CodeSmith.Engine.Compiler Namespace


AssemblyReferenceSet.Add Method (String, String)

AssemblyReferenceSetAdd Method (String, String)

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool Add(
    string assembly,
    string baseDirectory
)
Public Function Add (
    assembly As String,
    baseDirectory As String
) As Boolean

Parameters

assembly
Type: SystemString
baseDirectory
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

AssemblyReferenceSet Class
Add Overload
CodeSmith.Engine.Compiler Namespace


AssemblyReferenceSet.Add Method (IEnumerable(String), IEnumerable(String), Boolean)

AssemblyReferenceSetAdd Method (IEnumerableString, IEnumerableString, Boolean)

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public IEnumerable<AssemblyReference> Add(
    IEnumerable<string> assemblyNames,
    IEnumerable<string> baseDirectories,
    bool useCache
)
Public Function Add (
    assemblyNames As IEnumerable(Of String),
    baseDirectories As IEnumerable(Of String),
    useCache As Boolean
) As IEnumerable(Of AssemblyReference)

Parameters

assemblyNames
Type: System.Collections.GenericIEnumerable String
baseDirectories
Type: System.Collections.GenericIEnumerable String
useCache
Type: SystemBoolean

Return Value

Type: IEnumerable AssemblyReference
See Also

Reference

AssemblyReferenceSet Class
Add Overload
CodeSmith.Engine.Compiler Namespace


AssemblyReferenceSet.Add Method (String, IEnumerable(String), Boolean)

AssemblyReferenceSetAdd Method (String, IEnumerableString, Boolean)

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool Add(
    string assembly,
    IEnumerable<string> baseDirectories,
    bool useCache
)
Public Function Add (
    assembly As String,
    baseDirectories As IEnumerable(Of String),
    useCache As Boolean
) As Boolean

Parameters

assembly
Type: SystemString
baseDirectories
Type: System.Collections.GenericIEnumerable String
useCache
Type: SystemBoolean

Return Value

Type: Boolean
See Also

Reference

AssemblyReferenceSet Class
Add Overload
CodeSmith.Engine.Compiler Namespace


AssemblyReferenceSet.Add Method (IEnumerable(String), IEnumerable(String), IEnumerable(String), Boolean)

AssemblyReferenceSetAdd Method (IEnumerableString, IEnumerableString, IEnumerableString, Boolean)

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public IEnumerable<AssemblyReference> Add(
    IEnumerable<string> assemblyNames,
    IEnumerable<string> candidates,
    IEnumerable<string> baseDirectories,
    bool useCache
)
Public Function Add (
    assemblyNames As IEnumerable(Of String),
    candidates As IEnumerable(Of String),
    baseDirectories As IEnumerable(Of String),
    useCache As Boolean
) As IEnumerable(Of AssemblyReference)

Parameters

assemblyNames
Type: System.Collections.GenericIEnumerable String
candidates
Type: System.Collections.GenericIEnumerable String
baseDirectories
Type: System.Collections.GenericIEnumerable String
useCache
Type: SystemBoolean

Return Value

Type: IEnumerable AssemblyReference
See Also

Reference

AssemblyReferenceSet Class
Add Overload
CodeSmith.Engine.Compiler Namespace


AssemblyReferenceSet.Add Method (String, IEnumerable(String), IEnumerable(String), Boolean)

AssemblyReferenceSetAdd Method (String, IEnumerableString, IEnumerableString, Boolean)

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool Add(
    string assembly,
    IEnumerable<string> candidates,
    IEnumerable<string> baseDirectories,
    bool useCache
)
Public Function Add (
    assembly As String,
    candidates As IEnumerable(Of String),
    baseDirectories As IEnumerable(Of String),
    useCache As Boolean
) As Boolean

Parameters

assembly
Type: SystemString
candidates
Type: System.Collections.GenericIEnumerable String
baseDirectories
Type: System.Collections.GenericIEnumerable String
useCache
Type: SystemBoolean

Return Value

Type: Boolean
See Also

Reference

AssemblyReferenceSet Class
Add Overload
CodeSmith.Engine.Compiler Namespace


AssemblyReferenceSet.ShadowCopy Method

AssemblyReferenceSetShadowCopy Method

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public IEnumerable<string> ShadowCopy(
    string directory
)
Public Function ShadowCopy (
    directory As String
) As IEnumerable(Of String)

Parameters

directory
Type: SystemString

Return Value

Type: IEnumerable String
See Also

Reference

AssemblyReferenceSet Class
CodeSmith.Engine.Compiler Namespace


AssemblyResolver Class

Inheritance Hierarchy
SystemObject
DisposableBase
CodeSmith.Engine.CompilerAssemblyResolver

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class AssemblyResolver : DisposableBase
Public Class AssemblyResolver
    Inherits DisposableBase

The AssemblyResolver type exposes the following members.

Properties
Name | Description
Current | Gets the current instance of AssemblyResolver.
Top
Methods
 | Name | Description
Public method | Dispose | (Inherited from DisposableBase.)
Protected method | Dispose(Boolean) | (Inherited from DisposableBase.)
Protected method | DisposeManagedResources | (Inherited from DisposableBase.)
Protected method | DisposeUnmanagedResources | (Inherited from DisposableBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | (Inherited from DisposableBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ResolveAssemblyPath(IEnumerableString) |
Public method | ResolveAssemblyPath(String) |
Public method | ResolveAssemblyPath(IEnumerableString, String) |
Public method | ResolveAssemblyPath(String, String) |
Public method | ResolveAssemblyPath(IEnumerableString, IEnumerableString, Boolean) |
Public method | ResolveAssemblyPath(String, IEnumerableString, Boolean) |
Public method | ResolveAssemblyPath(IEnumerableString, IEnumerableString, IEnumerableString, Boolean) |
Public method | ResolveAssemblyPath(String, IEnumerableString, IEnumerableString, Boolean) |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSmith.Engine.Compiler Namespace


AssemblyResolver Properties

The AssemblyResolver type exposes the following members.

Properties
Name | Description
Current | Gets the current instance of AssemblyResolver.
Top
See Also

Reference

AssemblyResolver Class
CodeSmith.Engine.Compiler Namespace


AssemblyResolver.Current Property

AssemblyResolverCurrent Property

Gets the current instance of AssemblyResolver.

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static AssemblyResolver Current { get; }
Public Shared ReadOnly Property Current As AssemblyResolver
    Get

Property Value

Type: AssemblyResolver
The current instance.
See Also

Reference

AssemblyResolver Class
CodeSmith.Engine.Compiler Namespace


AssemblyResolver Methods

The AssemblyResolver type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from DisposableBase.)
Protected method | Dispose(Boolean) | (Inherited from DisposableBase.)
Protected method | DisposeManagedResources | (Inherited from DisposableBase.)
Protected method | DisposeUnmanagedResources | (Inherited from DisposableBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | (Inherited from DisposableBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ResolveAssemblyPath(IEnumerableString) |
Public method | ResolveAssemblyPath(String) |
Public method | ResolveAssemblyPath(IEnumerableString, String) |
Public method | ResolveAssemblyPath(String, String) |
Public method | ResolveAssemblyPath(IEnumerableString, IEnumerableString, Boolean) |
Public method | ResolveAssemblyPath(String, IEnumerableString, Boolean) |
Public method | ResolveAssemblyPath(IEnumerableString, IEnumerableString, IEnumerableString, Boolean) |
Public method | ResolveAssemblyPath(String, IEnumerableString, IEnumerableString, Boolean) |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AssemblyResolver Class
CodeSmith.Engine.Compiler Namespace


AssemblyResolver.ResolveAssemblyPath Method

AssemblyResolverResolveAssemblyPath Method

Overload List
 | Name | Description
Public method | ResolveAssemblyPath(IEnumerableString) |
Public method | ResolveAssemblyPath(String) |
Public method | ResolveAssemblyPath(IEnumerableString, String) |
Public method | ResolveAssemblyPath(String, String) |
Public method | ResolveAssemblyPath(IEnumerableString, IEnumerableString, Boolean) |
Public method | ResolveAssemblyPath(String, IEnumerableString, Boolean) |
Public method | ResolveAssemblyPath(IEnumerableString, IEnumerableString, IEnumerableString, Boolean) |
Public method | ResolveAssemblyPath(String, IEnumerableString, IEnumerableString, Boolean) |
Top
See Also

Reference

AssemblyResolver Class
CodeSmith.Engine.Compiler Namespace


AssemblyResolver.ResolveAssemblyPath Method (IEnumerable(String))

AssemblyResolverResolveAssemblyPath Method (IEnumerableString)

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public IEnumerable<AssemblyReference> ResolveAssemblyPath(
    IEnumerable<string> assemblyNames
)
Public Function ResolveAssemblyPath (
    assemblyNames As IEnumerable(Of String)
) As IEnumerable(Of AssemblyReference)

Parameters

assemblyNames
Type: System.Collections.GenericIEnumerable String

Return Value

Type: IEnumerable AssemblyReference
See Also

Reference

AssemblyResolver Class
ResolveAssemblyPath Overload
CodeSmith.Engine.Compiler Namespace


AssemblyResolver.ResolveAssemblyPath Method (String)

AssemblyResolverResolveAssemblyPath Method (String)

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public AssemblyReference ResolveAssemblyPath(
    string assembly
)
Public Function ResolveAssemblyPath (
    assembly As String
) As AssemblyReference

Parameters

assembly
Type: SystemString

Return Value

Type: AssemblyReference
See Also

Reference

AssemblyResolver Class
ResolveAssemblyPath Overload
CodeSmith.Engine.Compiler Namespace


AssemblyResolver.ResolveAssemblyPath Method (IEnumerable(String), String)

AssemblyResolverResolveAssemblyPath Method (IEnumerableString, String)

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public IEnumerable<AssemblyReference> ResolveAssemblyPath(
    IEnumerable<string> assemblyNames,
    string baseDirectory
)
Public Function ResolveAssemblyPath (
    assemblyNames As IEnumerable(Of String),
    baseDirectory As String
) As IEnumerable(Of AssemblyReference)

Parameters

assemblyNames
Type: System.Collections.GenericIEnumerable String
baseDirectory
Type: SystemString

Return Value

Type: IEnumerable AssemblyReference
See Also

Reference

AssemblyResolver Class
ResolveAssemblyPath Overload
CodeSmith.Engine.Compiler Namespace


AssemblyResolver.ResolveAssemblyPath Method (String, String)

AssemblyResolverResolveAssemblyPath Method (String, String)

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public AssemblyReference ResolveAssemblyPath(
    string assembly,
    string baseDirectory
)
Public Function ResolveAssemblyPath (
    assembly As String,
    baseDirectory As String
) As AssemblyReference

Parameters

assembly
Type: SystemString
baseDirectory
Type: SystemString

Return Value

Type: AssemblyReference
See Also

Reference

AssemblyResolver Class
ResolveAssemblyPath Overload
CodeSmith.Engine.Compiler Namespace


AssemblyResolver.ResolveAssemblyPath Method (IEnumerable(String), IEnumerable(String), Boolean)

AssemblyResolverResolveAssemblyPath Method (IEnumerableString, IEnumerableString, Boolean)

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public IEnumerable<AssemblyReference> ResolveAssemblyPath(
    IEnumerable<string> assemblyNames,
    IEnumerable<string> baseDirectories,
    bool useCache
)
Public Function ResolveAssemblyPath (
    assemblyNames As IEnumerable(Of String),
    baseDirectories As IEnumerable(Of String),
    useCache As Boolean
) As IEnumerable(Of AssemblyReference)

Parameters

assemblyNames
Type: System.Collections.GenericIEnumerable String
baseDirectories
Type: System.Collections.GenericIEnumerable String
useCache
Type: SystemBoolean

Return Value

Type: IEnumerable AssemblyReference
See Also

Reference

AssemblyResolver Class
ResolveAssemblyPath Overload
CodeSmith.Engine.Compiler Namespace


AssemblyResolver.ResolveAssemblyPath Method (String, IEnumerable(String), Boolean)

AssemblyResolverResolveAssemblyPath Method (String, IEnumerableString, Boolean)

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public AssemblyReference ResolveAssemblyPath(
    string assembly,
    IEnumerable<string> baseDirectories,
    bool useCache
)
Public Function ResolveAssemblyPath (
    assembly As String,
    baseDirectories As IEnumerable(Of String),
    useCache As Boolean
) As AssemblyReference

Parameters

assembly
Type: SystemString
baseDirectories
Type: System.Collections.GenericIEnumerable String
useCache
Type: SystemBoolean

Return Value

Type: AssemblyReference
See Also

Reference

AssemblyResolver Class
ResolveAssemblyPath Overload
CodeSmith.Engine.Compiler Namespace


AssemblyResolver.ResolveAssemblyPath Method (IEnumerable(String), IEnumerable(String), IEnumerable(String), Boolean)

AssemblyResolverResolveAssemblyPath Method (IEnumerableString, IEnumerableString, IEnumerableString, Boolean)

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public IEnumerable<AssemblyReference> ResolveAssemblyPath(
    IEnumerable<string> assemblyNames,
    IEnumerable<string> candidates,
    IEnumerable<string> baseDirectories,
    bool useCache
)
Public Function ResolveAssemblyPath (
    assemblyNames As IEnumerable(Of String),
    candidates As IEnumerable(Of String),
    baseDirectories As IEnumerable(Of String),
    useCache As Boolean
) As IEnumerable(Of AssemblyReference)

Parameters

assemblyNames
Type: System.Collections.GenericIEnumerable String
candidates
Type: System.Collections.GenericIEnumerable String
baseDirectories
Type: System.Collections.GenericIEnumerable String
useCache
Type: SystemBoolean

Return Value

Type: IEnumerable AssemblyReference
See Also

Reference

AssemblyResolver Class
ResolveAssemblyPath Overload
CodeSmith.Engine.Compiler Namespace


AssemblyResolver.ResolveAssemblyPath Method (String, IEnumerable(String), IEnumerable(String), Boolean)

AssemblyResolverResolveAssemblyPath Method (String, IEnumerableString, IEnumerableString, Boolean)

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public AssemblyReference ResolveAssemblyPath(
    string assembly,
    IEnumerable<string> candidates,
    IEnumerable<string> baseDirectories,
    bool useCache
)
Public Function ResolveAssemblyPath (
    assembly As String,
    candidates As IEnumerable(Of String),
    baseDirectories As IEnumerable(Of String),
    useCache As Boolean
) As AssemblyReference

Parameters

assembly
Type: SystemString
candidates
Type: System.Collections.GenericIEnumerable String
baseDirectories
Type: System.Collections.GenericIEnumerable String
useCache
Type: SystemBoolean

Return Value

Type: AssemblyReference
See Also

Reference

AssemblyResolver Class
ResolveAssemblyPath Overload
CodeSmith.Engine.Compiler Namespace


CachedCompiler Class

Inheritance Hierarchy
SystemObject
CodeSmith.Engine.CompilerCachedCompiler

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class CachedCompiler
Public Class CachedCompiler

The CachedCompiler type exposes the following members.

Constructors
 | Name | Description
Public method | CachedCompiler | Initializes a new instance of the CachedCompiler class
Top
Methods
 | Name | Description
Public method | Compile |
Protected method | CreateProvider |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GenerateCodeDomSource |
Protected method | GetCacheKey |
Protected method | GetCompilerOptions |
Protected method | GetCompilerParameters |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSmith.Engine.Compiler Namespace


CachedCompiler Constructor

Initializes a new instance of the CachedCompiler class

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CachedCompiler()
Public Sub New
See Also

Reference

CachedCompiler Class
CodeSmith.Engine.Compiler Namespace


CachedCompiler Methods

The CachedCompiler type exposes the following members.

Methods
 | Name | Description
Public method | Compile |
Protected method | CreateProvider |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GenerateCodeDomSource |
Protected method | GetCacheKey |
Protected method | GetCompilerOptions |
Protected method | GetCompilerParameters |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CachedCompiler Class
CodeSmith.Engine.Compiler Namespace


CachedCompiler.Compile Method

CachedCompilerCompile Method

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CompileResult Compile(
    CompileRequest request
)
Public Function Compile (
    request As CompileRequest
) As CompileResult

Parameters

request
Type: CodeSmith.Engine.CompilerCompileRequest

Return Value

Type: CompileResult
See Also

Reference

CachedCompiler Class
CodeSmith.Engine.Compiler Namespace


CachedCompiler.CreateProvider Method

CachedCompilerCreateProvider Method

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual void CreateProvider(
    CachedCompilerCompileContext context
)
Protected Overridable Sub CreateProvider (
    context As CachedCompilerCompileContext
)

Parameters

context
Type: CodeSmith.Engine.CompilerCachedCompilerCompileContext
See Also

Reference

CachedCompiler Class
CodeSmith.Engine.Compiler Namespace


CachedCompiler.GenerateCodeDomSource Method

CachedCompilerGenerateCodeDomSource Method

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual void GenerateCodeDomSource(
    CachedCompilerCompileContext context
)
Protected Overridable Sub GenerateCodeDomSource (
    context As CachedCompilerCompileContext
)

Parameters

context
Type: CodeSmith.Engine.CompilerCachedCompilerCompileContext
See Also

Reference

CachedCompiler Class
CodeSmith.Engine.Compiler Namespace


CachedCompiler.GetCacheKey Method

CachedCompilerGetCacheKey Method

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual string GetCacheKey(
    CachedCompilerCompileContext context
)
Protected Overridable Function GetCacheKey (
    context As CachedCompilerCompileContext
) As String

Parameters

context
Type: CodeSmith.Engine.CompilerCachedCompilerCompileContext

Return Value

Type: String
See Also

Reference

CachedCompiler Class
CodeSmith.Engine.Compiler Namespace


CachedCompiler.GetCompilerOptions Method

CachedCompilerGetCompilerOptions Method

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual void GetCompilerOptions(
    CachedCompilerCompileContext context
)
Protected Overridable Sub GetCompilerOptions (
    context As CachedCompilerCompileContext
)

Parameters

context
Type: CodeSmith.Engine.CompilerCachedCompilerCompileContext
See Also

Reference

CachedCompiler Class
CodeSmith.Engine.Compiler Namespace


CachedCompiler.GetCompilerParameters Method

CachedCompilerGetCompilerParameters Method

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual void GetCompilerParameters(
    CachedCompilerCompileContext context
)
Protected Overridable Sub GetCompilerParameters (
    context As CachedCompilerCompileContext
)

Parameters

context
Type: CodeSmith.Engine.CompilerCachedCompilerCompileContext
See Also

Reference

CachedCompiler Class
CodeSmith.Engine.Compiler Namespace


CachedCompiler.CompileContext Class

CachedCompilerCompileContext Class

Inheritance Hierarchy
SystemObject
CodeSmith.Engine.CompilerCachedCompilerCompileContext

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected class CompileContext
Protected Class CompileContext

The CachedCompilerCompileContext type exposes the following members.

Constructors
 | Name | Description
Public method | CachedCompilerCompileContext | Initializes a new instance of the CachedCompilerCompileContext class
Top
Properties
 | Name | Description
Public property | AssemblyName |
Public property | CacheKey |
Public property | CacheManager |
Public property | Compiler |
Public property | OutputDirectory |
Public property | Parameters |
Public property | Provider |
Public property | Request |
Public property | SourceFiles |
Public property | TempFiles |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSmith.Engine.Compiler Namespace


CachedCompiler.CompileContext Constructor

CachedCompilerCompileContext Constructor

Initializes a new instance of the CachedCompilerCompileContext class

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CompileContext()
Public Sub New
See Also

Reference

CachedCompilerCompileContext Class
CodeSmith.Engine.Compiler Namespace


CompileContext Properties

The CachedCompilerCompileContext type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyName |
Public property | CacheKey |
Public property | CacheManager |
Public property | Compiler |
Public property | OutputDirectory |
Public property | Parameters |
Public property | Provider |
Public property | Request |
Public property | SourceFiles |
Public property | TempFiles |
Top
See Also

Reference

CachedCompilerCompileContext Class
CodeSmith.Engine.Compiler Namespace


CachedCompiler.CompileContext.AssemblyName Property

CachedCompilerCompileContextAssemblyName Property

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string AssemblyName { get; set; }
Public Property AssemblyName As String
    Get
    Set

Property Value

Type: String
See Also

Reference

CachedCompilerCompileContext Class
CodeSmith.Engine.Compiler Namespace


CachedCompiler.CompileContext.CacheKey Property

CachedCompilerCompileContextCacheKey Property

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string CacheKey { get; set; }
Public Property CacheKey As String
    Get
    Set

Property Value

Type: String
See Also

Reference

CachedCompilerCompileContext Class
CodeSmith.Engine.Compiler Namespace


CachedCompiler.CompileContext.CacheManager Property

CachedCompilerCompileContextCacheManager Property

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CacheManager CacheManager { get; set; }
Public Property CacheManager As CacheManager
    Get
    Set

Property Value

Type: CacheManager
See Also

Reference

CachedCompilerCompileContext Class
CodeSmith.Engine.Compiler Namespace


CachedCompiler.CompileContext.Compiler Property

CachedCompilerCompileContextCompiler Property

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ICodeCompiler Compiler { get; set; }
Public Property Compiler As ICodeCompiler
    Get
    Set

Property Value

Type: ICodeCompiler
See Also

Reference

CachedCompilerCompileContext Class
CodeSmith.Engine.Compiler Namespace


CachedCompiler.CompileContext.OutputDirectory Property

CachedCompilerCompileContextOutputDirectory Property

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string OutputDirectory { get; set; }
Public Property OutputDirectory As String
    Get
    Set

Property Value

Type: String
See Also

Reference

CachedCompilerCompileContext Class
CodeSmith.Engine.Compiler Namespace


CachedCompiler.CompileContext.Parameters Property

CachedCompilerCompileContextParameters Property

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CompilerParameters Parameters { get; set; }
Public Property Parameters As CompilerParameters
    Get
    Set

Property Value

Type: CompilerParameters
See Also

Reference

CachedCompilerCompileContext Class
CodeSmith.Engine.Compiler Namespace


CachedCompiler.CompileContext.Provider Property

CachedCompilerCompileContextProvider Property

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CodeDomProvider Provider { get; set; }
Public Property Provider As CodeDomProvider
    Get
    Set

Property Value

Type: CodeDomProvider
See Also

Reference

CachedCompilerCompileContext Class
CodeSmith.Engine.Compiler Namespace


CachedCompiler.CompileContext.Request Property

CachedCompilerCompileContextRequest Property

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CompileRequest Request { get; set; }
Public Property Request As CompileRequest
    Get
    Set

Property Value

Type: CompileRequest
See Also

Reference

CachedCompilerCompileContext Class
CodeSmith.Engine.Compiler Namespace


CachedCompiler.CompileContext.SourceFiles Property

CachedCompilerCompileContextSourceFiles Property

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ISet<string> SourceFiles { get; set; }
Public Property SourceFiles As ISet(Of String)
    Get
    Set

Property Value

Type: ISet String
See Also

Reference

CachedCompilerCompileContext Class
CodeSmith.Engine.Compiler Namespace


CachedCompiler.CompileContext.TempFiles Property

CachedCompilerCompileContextTempFiles Property

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public TempFileCollection TempFiles { get; set; }
Public Property TempFiles As TempFileCollection
    Get
    Set

Property Value

Type: TempFileCollection
See Also

Reference

CachedCompilerCompileContext Class
CodeSmith.Engine.Compiler Namespace


CompileContext Methods

The CachedCompilerCompileContext type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CachedCompilerCompileContext Class
CodeSmith.Engine.Compiler Namespace


CacheEntry Class

Inheritance Hierarchy
SystemObject
CodeSmith.Engine.CompilerCacheEntry

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class CacheEntry
Public Class CacheEntry

The CacheEntry type exposes the following members.

Constructors
 | Name | Description
Public method | CacheEntry | Initializes a new instance of the CacheEntry class
Top
Properties
 | Name | Description
Public property | CacheKey |
Public property | CompilerVersion |
Public property | ExpirationDate |
Public property | FileDependencies |
Public property | HashCode |
Public property | Metadata |
Public property | PathToAssembly |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValid |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSmith.Engine.Compiler Namespace


CacheEntry Constructor

Initializes a new instance of the CacheEntry class

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CacheEntry()
Public Sub New
See Also

Reference

CacheEntry Class
CodeSmith.Engine.Compiler Namespace


CacheEntry Properties

The CacheEntry type exposes the following members.

Properties
 | Name | Description
Public property | CacheKey |
Public property | CompilerVersion |
Public property | ExpirationDate |
Public property | FileDependencies |
Public property | HashCode |
Public property | Metadata |
Public property | PathToAssembly |
Top
See Also

Reference

CacheEntry Class
CodeSmith.Engine.Compiler Namespace


CacheEntry.CacheKey Property

CacheEntryCacheKey Property

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string CacheKey { get; set; }
Public Property CacheKey As String
    Get
    Set

Property Value

Type: String
See Also

Reference

CacheEntry Class
CodeSmith.Engine.Compiler Namespace


CacheEntry.CompilerVersion Property

CacheEntryCompilerVersion Property

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string CompilerVersion { get; set; }
Public Property CompilerVersion As String
    Get
    Set

Property Value

Type: String
See Also

Reference

CacheEntry Class
CodeSmith.Engine.Compiler Namespace


CacheEntry.ExpirationDate Property

CacheEntryExpirationDate Property

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public DateTime ExpirationDate { get; set; }
Public Property ExpirationDate As DateTime
    Get
    Set

Property Value

Type: DateTime
See Also

Reference

CacheEntry Class
CodeSmith.Engine.Compiler Namespace


CacheEntry.FileDependencies Property

CacheEntryFileDependencies Property

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ISet<string> FileDependencies { get; set; }
Public Property FileDependencies As ISet(Of String)
    Get
    Set

Property Value

Type: ISet String
See Also

Reference

CacheEntry Class
CodeSmith.Engine.Compiler Namespace


CacheEntry.HashCode Property

CacheEntryHashCode Property

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public int HashCode { get; set; }
Public Property HashCode As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

CacheEntry Class
CodeSmith.Engine.Compiler Namespace


CacheEntry.Metadata Property

CacheEntryMetadata Property

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public Dictionary<string, string> Metadata { get; }
Public ReadOnly Property Metadata As Dictionary(Of String, String)
    Get

Property Value

Type: Dictionary String, String
See Also

Reference

CacheEntry Class
CodeSmith.Engine.Compiler Namespace


CacheEntry.PathToAssembly Property

CacheEntryPathToAssembly Property

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string PathToAssembly { get; set; }
Public Property PathToAssembly As String
    Get
    Set

Property Value

Type: String
See Also

Reference

CacheEntry Class
CodeSmith.Engine.Compiler Namespace


CacheEntry Methods

The CacheEntry type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValid |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CacheEntry Class
CodeSmith.Engine.Compiler Namespace


CacheEntry.IsValid Method

CacheEntryIsValid Method

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool IsValid()
Public Function IsValid As Boolean

Return Value

Type: Boolean
See Also

Reference

CacheEntry Class
CodeSmith.Engine.Compiler Namespace


CacheManager Class

Inheritance Hierarchy
SystemObject
CodeSmith.Engine.CompilerCacheManager

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class CacheManager
Public Class CacheManager

The CacheManager type exposes the following members.

Methods
 | Name | Description
Public method | Add |
Public method | Cleanup |
Public method | Clear |
Public method | Delete |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get |
Public method | GetCacheEntries |
Public method | GetCacheEntry |
Public method | GetCacheEntryDataDirectory |
Public method | GetCacheEntryDirectory |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetManager |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSmith.Engine.Compiler Namespace


CacheManager Methods

The CacheManager type exposes the following members.

Methods
 | Name | Description
Public method | Add |
Public method | Cleanup |
Public method | Clear |
Public method | Delete |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get |
Public method | GetCacheEntries |
Public method | GetCacheEntry |
Public method | GetCacheEntryDataDirectory |
Public method | GetCacheEntryDirectory |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetManager |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CacheManager Class
CodeSmith.Engine.Compiler Namespace


CacheManager.Add Method

CacheManagerAdd Method

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void Add(
    CacheEntry entry
)
Public Sub Add (
    entry As CacheEntry
)

Parameters

entry
Type: CodeSmith.Engine.CompilerCacheEntry
See Also

Reference

CacheManager Class
CodeSmith.Engine.Compiler Namespace


CacheManager.Cleanup Method

CacheManagerCleanup Method

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void Cleanup()
Public Sub Cleanup
See Also

Reference

CacheManager Class
CodeSmith.Engine.Compiler Namespace


CacheManager.Clear Method

CacheManagerClear Method

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void Clear()
Public Sub Clear
See Also

Reference

CacheManager Class
CodeSmith.Engine.Compiler Namespace


CacheManager.Delete Method

CacheManagerDelete Method

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void Delete(
    CacheEntry entry
)
Public Sub Delete (
    entry As CacheEntry
)

Parameters

entry
Type: CodeSmith.Engine.CompilerCacheEntry
See Also

Reference

CacheManager Class
CodeSmith.Engine.Compiler Namespace


CacheManager.Get Method

CacheManagerGet Method

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CacheEntry Get(
    string key
)
Public Function Get (
    key As String
) As CacheEntry

Parameters

key
Type: SystemString

Return Value

Type: CacheEntry
See Also

Reference

CacheManager Class
CodeSmith.Engine.Compiler Namespace


CacheManager.GetCacheEntries Method

CacheManagerGetCacheEntries Method

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public List<CacheEntry> GetCacheEntries()
Public Function GetCacheEntries As List(Of CacheEntry)

Return Value

Type: List CacheEntry
See Also

Reference

CacheManager Class
CodeSmith.Engine.Compiler Namespace


CacheManager.GetCacheEntry Method

CacheManagerGetCacheEntry Method

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CacheEntry GetCacheEntry(
    string filePath
)
Public Function GetCacheEntry (
    filePath As String
) As CacheEntry

Parameters

filePath
Type: SystemString

Return Value

Type: CacheEntry
See Also

Reference

CacheManager Class
CodeSmith.Engine.Compiler Namespace


CacheManager.GetCacheEntryDataDirectory Method

CacheManagerGetCacheEntryDataDirectory Method

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string GetCacheEntryDataDirectory(
    string key
)
Public Function GetCacheEntryDataDirectory (
    key As String
) As String

Parameters

key
Type: SystemString

Return Value

Type: String
See Also

Reference

CacheManager Class
CodeSmith.Engine.Compiler Namespace


CacheManager.GetCacheEntryDirectory Method

CacheManagerGetCacheEntryDirectory Method

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string GetCacheEntryDirectory(
    string key
)
Public Function GetCacheEntryDirectory (
    key As String
) As String

Parameters

key
Type: SystemString

Return Value

Type: String
See Also

Reference

CacheManager Class
CodeSmith.Engine.Compiler Namespace


CacheManager.GetManager Method

CacheManagerGetManager Method

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static CacheManager GetManager(
    string rootDirectory
)
Public Shared Function GetManager (
    rootDirectory As String
) As CacheManager

Parameters

rootDirectory
Type: SystemString

Return Value

Type: CacheManager
See Also

Reference

CacheManager Class
CodeSmith.Engine.Compiler Namespace


CompileRequest Class

Inheritance Hierarchy
SystemObject
CodeSmith.Engine.CompilerCompileRequest

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class CompileRequest
Public Class CompileRequest

The CompileRequest type exposes the following members.

Constructors
 | Name | Description
Public method | CompileRequest | Initializes a new instance of the CompileRequest class
Top
Properties
 | Name | Description
Public property | AssemblyName |
Public property | AssemblyReferences |
Public property | CacheDirectory |
Public property | CacheKey |
Public property | CodeCompileUnit |
Public property | ConditionalCompilationDirectives |
Public property | Debug |
Public property | DisabledWarnings |
Public property | FileDependencies |
Public property | ForceRecompile |
Public property | GenerateDocXml |
Public property | KeepTempFiles |
Public property | Language |
Public property | Metadata |
Public property | OutputDirectory |
Public property | ShadowCopy |
Public property | SourceContent |
Public property | SourceFiles |
Public property | TreatWarningsAsErrors |
Public property | UseCache |
Public property | UseSimpleCacheKey |
Public property | WarningLevel |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSmith.Engine.Compiler Namespace


CompileRequest Constructor

Initializes a new instance of the CompileRequest class

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CompileRequest()
Public Sub New
See Also

Reference

CompileRequest Class
CodeSmith.Engine.Compiler Namespace


CompileRequest Properties

The CompileRequest type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyName |
Public property | AssemblyReferences |
Public property | CacheDirectory |
Public property | CacheKey |
Public property | CodeCompileUnit |
Public property | ConditionalCompilationDirectives |
Public property | Debug |
Public property | DisabledWarnings |
Public property | FileDependencies |
Public property | ForceRecompile |
Public property | GenerateDocXml |
Public property | KeepTempFiles |
Public property | Language |
Public property | Metadata |
Public property | OutputDirectory |
Public property | ShadowCopy |
Public property | SourceContent |
Public property | SourceFiles |
Public property | TreatWarningsAsErrors |
Public property | UseCache |
Public property | UseSimpleCacheKey |
Public property | WarningLevel |
Top
See Also

Reference

CompileRequest Class
CodeSmith.Engine.Compiler Namespace


CompileRequest.AssemblyName Property

CompileRequestAssemblyName Property

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string AssemblyName { get; set; }
Public Property AssemblyName As String
    Get
    Set

Property Value

Type: String
See Also

Reference

CompileRequest Class
CodeSmith.Engine.Compiler Namespace


CompileRequest.AssemblyReferences Property

CompileRequestAssemblyReferences Property

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public AssemblyReferenceSet AssemblyReferences { get; }
Public ReadOnly Property AssemblyReferences As AssemblyReferenceSet
    Get

Property Value

Type: AssemblyReferenceSet
See Also

Reference

CompileRequest Class
CodeSmith.Engine.Compiler Namespace


CompileRequest.CacheDirectory Property

CompileRequestCacheDirectory Property

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string CacheDirectory { get; set; }
Public Property CacheDirectory As String
    Get
    Set

Property Value

Type: String
See Also

Reference

CompileRequest Class
CodeSmith.Engine.Compiler Namespace


CompileRequest.CacheKey Property

CompileRequestCacheKey Property

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string CacheKey { get; set; }
Public Property CacheKey As String
    Get
    Set

Property Value

Type: String
See Also

Reference

CompileRequest Class
CodeSmith.Engine.Compiler Namespace


CompileRequest.CodeCompileUnit Property

CompileRequestCodeCompileUnit Property

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CodeCompileUnit CodeCompileUnit { get; set; }
Public Property CodeCompileUnit As CodeCompileUnit
    Get
    Set

Property Value

Type: CodeCompileUnit
See Also

Reference

CompileRequest Class
CodeSmith.Engine.Compiler Namespace


CompileRequest.ConditionalCompilationDirectives Property

CompileRequestConditionalCompilationDirectives Property

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ISet<string> ConditionalCompilationDirectives { get; }
Public ReadOnly Property ConditionalCompilationDirectives As ISet(Of String)
    Get

Property Value

Type: ISet String
See Also

Reference

CompileRequest Class
CodeSmith.Engine.Compiler Namespace


CompileRequest.Debug Property

CompileRequestDebug Property

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool Debug { get; set; }
Public Property Debug As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

CompileRequest Class
CodeSmith.Engine.Compiler Namespace


CompileRequest.DisabledWarnings Property

CompileRequestDisabledWarnings Property

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ISet<string> DisabledWarnings { get; }
Public ReadOnly Property DisabledWarnings As ISet(Of String)
    Get

Property Value

Type: ISet String
See Also

Reference

CompileRequest Class
CodeSmith.Engine.Compiler Namespace


CompileRequest.FileDependencies Property

CompileRequestFileDependencies Property

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ISet<string> FileDependencies { get; }
Public ReadOnly Property FileDependencies As ISet(Of String)
    Get

Property Value

Type: ISet String
See Also

Reference

CompileRequest Class
CodeSmith.Engine.Compiler Namespace


CompileRequest.ForceRecompile Property

CompileRequestForceRecompile Property

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool ForceRecompile { get; set; }
Public Property ForceRecompile As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

CompileRequest Class
CodeSmith.Engine.Compiler Namespace


CompileRequest.GenerateDocXml Property

CompileRequestGenerateDocXml Property

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool GenerateDocXml { get; set; }
Public Property GenerateDocXml As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

CompileRequest Class
CodeSmith.Engine.Compiler Namespace


CompileRequest.KeepTempFiles Property

CompileRequestKeepTempFiles Property

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool? KeepTempFiles { get; set; }
Public Property KeepTempFiles As Boolean?
    Get
    Set

Property Value

Type: Nullable Boolean
See Also

Reference

CompileRequest Class
CodeSmith.Engine.Compiler Namespace


CompileRequest.Language Property

CompileRequestLanguage Property

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string Language { get; set; }
Public Property Language As String
    Get
    Set

Property Value

Type: String
See Also

Reference

CompileRequest Class
CodeSmith.Engine.Compiler Namespace


CompileRequest.Metadata Property

CompileRequestMetadata Property

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public Dictionary<string, string> Metadata { get; }
Public ReadOnly Property Metadata As Dictionary(Of String, String)
    Get

Property Value

Type: Dictionary String, String
See Also

Reference

CompileRequest Class
CodeSmith.Engine.Compiler Namespace


CompileRequest.OutputDirectory Property

CompileRequestOutputDirectory Property

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string OutputDirectory { get; set; }
Public Property OutputDirectory As String
    Get
    Set

Property Value

Type: String
See Also

Reference

CompileRequest Class
CodeSmith.Engine.Compiler Namespace


CompileRequest.ShadowCopy Property

CompileRequestShadowCopy Property

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool ShadowCopy { get; set; }
Public Property ShadowCopy As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

CompileRequest Class
CodeSmith.Engine.Compiler Namespace


CompileRequest.SourceContent Property

CompileRequestSourceContent Property

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public IList<string> SourceContent { get; }
Public ReadOnly Property SourceContent As IList(Of String)
    Get

Property Value

Type: IList String
See Also

Reference

CompileRequest Class
CodeSmith.Engine.Compiler Namespace


CompileRequest.SourceFiles Property

CompileRequestSourceFiles Property

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ISet<string> SourceFiles { get; }
Public ReadOnly Property SourceFiles As ISet(Of String)
    Get

Property Value

Type: ISet String
See Also

Reference

CompileRequest Class
CodeSmith.Engine.Compiler Namespace


CompileRequest.TreatWarningsAsErrors Property

CompileRequestTreatWarningsAsErrors Property

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool? TreatWarningsAsErrors { get; set; }
Public Property TreatWarningsAsErrors As Boolean?
    Get
    Set

Property Value

Type: Nullable Boolean
See Also

Reference

CompileRequest Class
CodeSmith.Engine.Compiler Namespace


CompileRequest.UseCache Property

CompileRequestUseCache Property

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool UseCache { get; set; }
Public Property UseCache As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

CompileRequest Class
CodeSmith.Engine.Compiler Namespace


CompileRequest.UseSimpleCacheKey Property

CompileRequestUseSimpleCacheKey Property

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool UseSimpleCacheKey { get; set; }
Public Property UseSimpleCacheKey As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

CompileRequest Class
CodeSmith.Engine.Compiler Namespace


CompileRequest.WarningLevel Property

CompileRequestWarningLevel Property

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public int? WarningLevel { get; set; }
Public Property WarningLevel As Integer?
    Get
    Set

Property Value

Type: Nullable Int32
See Also

Reference

CompileRequest Class
CodeSmith.Engine.Compiler Namespace


CompileRequest Methods

The CompileRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CompileRequest Class
CodeSmith.Engine.Compiler Namespace


CompileResult Class

Inheritance Hierarchy
SystemObject
CodeSmith.Engine.CompilerCompileResult

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class CompileResult
Public Class CompileResult

The CompileResult type exposes the following members.

Constructors
 | Name | Description
Public method | CompileResult(CacheEntry, TimeSpan) | Initializes a new instance of the CompileResult class
Public method | CompileResult(CompilerResults, ISetString, DictionaryString, String, TimeSpan) | Initializes a new instance of the CompileResult class
Top
Properties
 | Name | Description
Public property | CompiledAssembly |
Public property | CompilerVersion |
Public property | Duration |
Public property | Errors |
Public property | FileDependencies |
Public property | IsFromCache |
Public property | Metadata |
Public property | OutputDirectory |
Public property | PathToAssembly |
Public property | Success |
Top
Methods
 | Name | Description
Public method | CreateInstance |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSmith.Engine.Compiler Namespace


CompileResult Constructor

Overload List
 | Name | Description
Public method | CompileResult(CacheEntry, TimeSpan) | Initializes a new instance of the CompileResult class
Public method | CompileResult(CompilerResults, ISetString, DictionaryString, String, TimeSpan) | Initializes a new instance of the CompileResult class
Top
See Also

Reference

CompileResult Class
CodeSmith.Engine.Compiler Namespace


CompileResult Constructor (CacheEntry, TimeSpan)

Initializes a new instance of the CompileResult class

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CompileResult(
    CacheEntry cacheEntry,
    TimeSpan duration
)
Public Sub New (
    cacheEntry As CacheEntry,
    duration As TimeSpan
)

Parameters

cacheEntry
Type: CodeSmith.Engine.CompilerCacheEntry
duration
Type: SystemTimeSpan
See Also

Reference

CompileResult Class
CompileResult Overload
CodeSmith.Engine.Compiler Namespace


CompileResult Constructor (CompilerResults, ISet(String), Dictionary(String, String), TimeSpan)

CompileResult Constructor (CompilerResults, ISetString, DictionaryString, String, TimeSpan)

Initializes a new instance of the CompileResult class

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CompileResult(
    CompilerResults results,
    ISet<string> fileDependencies,
    Dictionary<string, string> metadata,
    TimeSpan duration
)
Public Sub New (
    results As CompilerResults,
    fileDependencies As ISet(Of String),
    metadata As Dictionary(Of String, String),
    duration As TimeSpan
)

Parameters

results
Type: System.CodeDom.CompilerCompilerResults
fileDependencies
Type: System.Collections.GenericISet String
metadata
Type: System.Collections.GenericDictionary String, String
duration
Type: SystemTimeSpan
See Also

Reference

CompileResult Class
CompileResult Overload
CodeSmith.Engine.Compiler Namespace


CompileResult Properties

The CompileResult type exposes the following members.

Properties
 | Name | Description
Public property | CompiledAssembly |
Public property | CompilerVersion |
Public property | Duration |
Public property | Errors |
Public property | FileDependencies |
Public property | IsFromCache |
Public property | Metadata |
Public property | OutputDirectory |
Public property | PathToAssembly |
Public property | Success |
Top
See Also

Reference

CompileResult Class
CodeSmith.Engine.Compiler Namespace


CompileResult.CompiledAssembly Property

CompileResultCompiledAssembly Property

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public Assembly CompiledAssembly { get; }
Public ReadOnly Property CompiledAssembly As Assembly
    Get

Property Value

Type: Assembly
See Also

Reference

CompileResult Class
CodeSmith.Engine.Compiler Namespace


CompileResult.CompilerVersion Property

CompileResultCompilerVersion Property

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string CompilerVersion { get; }
Public ReadOnly Property CompilerVersion As String
    Get

Property Value

Type: String
See Also

Reference

CompileResult Class
CodeSmith.Engine.Compiler Namespace


CompileResult.Duration Property

CompileResultDuration Property

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public TimeSpan Duration { get; }
Public ReadOnly Property Duration As TimeSpan
    Get

Property Value

Type: TimeSpan
See Also

Reference

CompileResult Class
CodeSmith.Engine.Compiler Namespace


CompileResult.Errors Property

CompileResultErrors Property

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CompilerErrorCollection Errors { get; }
Public ReadOnly Property Errors As CompilerErrorCollection
    Get

Property Value

Type: CompilerErrorCollection
See Also

Reference

CompileResult Class
CodeSmith.Engine.Compiler Namespace


CompileResult.FileDependencies Property

CompileResultFileDependencies Property

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ISet<string> FileDependencies { get; }
Public ReadOnly Property FileDependencies As ISet(Of String)
    Get

Property Value

Type: ISet String
See Also

Reference

CompileResult Class
CodeSmith.Engine.Compiler Namespace


CompileResult.IsFromCache Property

CompileResultIsFromCache Property

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool IsFromCache { get; }
Public ReadOnly Property IsFromCache As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

CompileResult Class
CodeSmith.Engine.Compiler Namespace


CompileResult.Metadata Property

CompileResultMetadata Property

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public Dictionary<string, string> Metadata { get; }
Public ReadOnly Property Metadata As Dictionary(Of String, String)
    Get

Property Value

Type: Dictionary String, String
See Also

Reference

CompileResult Class
CodeSmith.Engine.Compiler Namespace


CompileResult.OutputDirectory Property

CompileResultOutputDirectory Property

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string OutputDirectory { get; }
Public ReadOnly Property OutputDirectory As String
    Get

Property Value

Type: String
See Also

Reference

CompileResult Class
CodeSmith.Engine.Compiler Namespace


CompileResult.PathToAssembly Property

CompileResultPathToAssembly Property

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string PathToAssembly { get; }
Public ReadOnly Property PathToAssembly As String
    Get

Property Value

Type: String
See Also

Reference

CompileResult Class
CodeSmith.Engine.Compiler Namespace


CompileResult.Success Property

CompileResultSuccess Property

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool Success { get; }
Public ReadOnly Property Success As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

CompileResult Class
CodeSmith.Engine.Compiler Namespace


CompileResult Methods

The CompileResult type exposes the following members.

Methods
 | Name | Description
Public method | CreateInstance |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CompileResult Class
CodeSmith.Engine.Compiler Namespace


CompileResult.CreateInstance Method

CompileResultCreateInstance Method

Namespace: CodeSmith.Engine.Compiler
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public Object CreateInstance(
    string typeName
)
Public Function CreateInstance (
    typeName As String
) As Object

Parameters

typeName
Type: SystemString

Return Value

Type: Object
See Also

Reference

CompileResult Class
CodeSmith.Engine.Compiler Namespace


CodeSmith.Engine.Schema Namespace

Classes
 | Class | Description
Public class | CodeSmithProject |
Public class | DefaultTemplate |
Public class | Property |
Public class | PropertyCollection |
Public class | PropertySet |
Public class | SchemaHelper |
Public class | SingleOutput |
Public class | Variable |
Public class | VariableCollection |


CodeSmithProject Class

Inheritance Hierarchy
SystemObject
ObservableBase
CodeSmith.Engine.SchemaCodeSmithProject

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
public class CodeSmithProject : ObservableBase,
    ICloneable
<SerializableAttribute>
Public Class CodeSmithProject
    Inherits ObservableBase
    Implements ICloneable

The CodeSmithProject type exposes the following members.

Constructors
 | Name | Description
Public method | CodeSmithProject | Initializes a new instance of the CodeSmithProject class
Top
Properties
 | Name | Description
Public property | DefaultProperties |
Public property | DefaultTemplate |
Public property | FileName |
Public property | HasDefaultTemplate |
Public property | HasSingleOutput |
Public property | PropertySets |
Public property | SingleOutput |
Public property | StopOnError |
Public property | UseRelativePaths |
Public property | Variables |
Top
Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
 | CreateInstance |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | InsertVariables | Inserts variables into the property set where the value matches.
 | LoadFile(String) | Loads the project from a file.
 | LoadFile(String, Boolean) | Loads the project from a file.
 | LoadFromString(String) | Loads the project from a String.
 | LoadFromString(String, Boolean) | Loads from String.
Public method | MakePathsRelative | Makes the paths relative to the directory of FileName.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ReplaceVariables | Replaces variables in the property set with the variables value.
Public method | SaveFile(String) | Saves the project to a file.
Public method | SaveFile(String, Boolean) | Saves the project to a file.
Public method | SaveToString | Saves project to String.
Public method | SaveToString(Boolean) | Saves project to String.
Public method | ShouldSerializeDefaultProperties |
Public method | ShouldSerializeDefaultTemplate |
Public method | ShouldSerializePropertySets |
Public method | ShouldSerializeSingleOutput |
Public method | ShouldSerializeVariables |
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Public method | UpdateDisplayNames |
Top
Fields
Name | Description
DefaultNamespace |
Top
See Also

Reference

CodeSmith.Engine.Schema Namespace


CodeSmithProject Constructor

Initializes a new instance of the CodeSmithProject class

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CodeSmithProject()
Public Sub New
See Also

Reference

CodeSmithProject Class
CodeSmith.Engine.Schema Namespace


CodeSmithProject Properties

The CodeSmithProject type exposes the following members.

Properties
 | Name | Description
Public property | DefaultProperties |
Public property | DefaultTemplate |
Public property | FileName |
Public property | HasDefaultTemplate |
Public property | HasSingleOutput |
Public property | PropertySets |
Public property | SingleOutput |
Public property | StopOnError |
Public property | UseRelativePaths |
Public property | Variables |
Top
See Also

Reference

CodeSmithProject Class
CodeSmith.Engine.Schema Namespace


CodeSmithProject.DefaultProperties Property

CodeSmithProjectDefaultProperties Property

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public PropertyCollection DefaultProperties { get; set; }
Public Property DefaultProperties As PropertyCollection
    Get
    Set

Property Value

Type: PropertyCollection
Remarks
See Also

Reference

CodeSmithProject Class
CodeSmith.Engine.Schema Namespace


CodeSmithProject.DefaultTemplate Property

CodeSmithProjectDefaultTemplate Property

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public DefaultTemplate DefaultTemplate { get; set; }
Public Property DefaultTemplate As DefaultTemplate
    Get
    Set

Property Value

Type: DefaultTemplate
Remarks
See Also

Reference

CodeSmithProject Class
CodeSmith.Engine.Schema Namespace


CodeSmithProject.FileName Property

CodeSmithProjectFileName Property

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string FileName { get; set; }
Public Property FileName As String
    Get
    Set

Property Value

Type: String
See Also

Reference

CodeSmithProject Class
CodeSmith.Engine.Schema Namespace


CodeSmithProject.HasDefaultTemplate Property

CodeSmithProjectHasDefaultTemplate Property

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool HasDefaultTemplate { get; }
Public ReadOnly Property HasDefaultTemplate As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

CodeSmithProject Class
CodeSmith.Engine.Schema Namespace


CodeSmithProject.HasSingleOutput Property

CodeSmithProjectHasSingleOutput Property

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool HasSingleOutput { get; }
Public ReadOnly Property HasSingleOutput As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

CodeSmithProject Class
CodeSmith.Engine.Schema Namespace


CodeSmithProject.PropertySets Property

CodeSmithProjectPropertySets Property

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ObservableCollection<PropertySet> PropertySets { get; set; }
Public Property PropertySets As ObservableCollection(Of PropertySet)
    Get
    Set

Property Value

Type: ObservableCollection PropertySet
Remarks
See Also

Reference

CodeSmithProject Class
CodeSmith.Engine.Schema Namespace


CodeSmithProject.SingleOutput Property

CodeSmithProjectSingleOutput Property

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public SingleOutput SingleOutput { get; set; }
Public Property SingleOutput As SingleOutput
    Get
    Set

Property Value

Type: SingleOutput
Remarks
See Also

Reference

CodeSmithProject Class
CodeSmith.Engine.Schema Namespace


CodeSmithProject.StopOnError Property

CodeSmithProjectStopOnError Property

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool StopOnError { get; set; }
Public Property StopOnError As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

CodeSmithProject Class
CodeSmith.Engine.Schema Namespace


CodeSmithProject.UseRelativePaths Property

CodeSmithProjectUseRelativePaths Property

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool UseRelativePaths { get; set; }
Public Property UseRelativePaths As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

CodeSmithProject Class
CodeSmith.Engine.Schema Namespace


CodeSmithProject.Variables Property

CodeSmithProjectVariables Property

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public VariableCollection Variables { get; set; }
Public Property Variables As VariableCollection
    Get
    Set

Property Value

Type: VariableCollection
Remarks
See Also

Reference

CodeSmithProject Class
CodeSmith.Engine.Schema Namespace


CodeSmithProject Methods

The CodeSmithProject type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
 | CreateInstance |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | InsertVariables | Inserts variables into the property set where the value matches.
 | LoadFile(String) | Loads the project from a file.
 | LoadFile(String, Boolean) | Loads the project from a file.
 | LoadFromString(String) | Loads the project from a String.
 | LoadFromString(String, Boolean) | Loads from String.
Public method | MakePathsRelative | Makes the paths relative to the directory of FileName.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ReplaceVariables | Replaces variables in the property set with the variables value.
Public method | SaveFile(String) | Saves the project to a file.
Public method | SaveFile(String, Boolean) | Saves the project to a file.
Public method | SaveToString | Saves project to String.
Public method | SaveToString(Boolean) | Saves project to String.
Public method | ShouldSerializeDefaultProperties |
Public method | ShouldSerializeDefaultTemplate |
Public method | ShouldSerializePropertySets |
Public method | ShouldSerializeSingleOutput |
Public method | ShouldSerializeVariables |
Public method | ToString | Returns a String that represents the current Object. (Overrides ObjectToString.)
Public method | UpdateDisplayNames |
Top
See Also

Reference

CodeSmithProject Class
CodeSmith.Engine.Schema Namespace


CodeSmithProject.Clone Method

CodeSmithProjectClone Method

Creates a new object that is a copy of the current instance.

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CodeSmithProject Clone()
Public Function Clone As CodeSmithProject

Return Value

Type: CodeSmithProject
A new object that is a copy of this instance.
See Also

Reference

CodeSmithProject Class
CodeSmith.Engine.Schema Namespace


CodeSmithProject.CreateInstance Method

CodeSmithProjectCreateInstance Method

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static CodeSmithProject CreateInstance()
Public Shared Function CreateInstance As CodeSmithProject

Return Value

Type: CodeSmithProject
See Also

Reference

CodeSmithProject Class
CodeSmith.Engine.Schema Namespace


CodeSmithProject.InsertVariables Method

CodeSmithProjectInsertVariables Method

Inserts variables into the property set where the value matches.

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static CodeSmithProject InsertVariables(
    CodeSmithProject csp
)
Public Shared Function InsertVariables (
    csp As CodeSmithProject
) As CodeSmithProject

Parameters

csp
Type: CodeSmith.Engine.SchemaCodeSmithProject
The original project.

Return Value

Type: CodeSmithProject
A new instance of CodeSmithProject.
See Also

Reference

CodeSmithProject Class
CodeSmith.Engine.Schema Namespace


CodeSmithProject.LoadFile Method

CodeSmithProjectLoadFile Method

Overload List
Name | Description
LoadFile(String) | Loads the project from a file.
LoadFile(String, Boolean) | Loads the project from a file.
Top
See Also

Reference

CodeSmithProject Class
CodeSmith.Engine.Schema Namespace


CodeSmithProject.LoadFile Method (String)

CodeSmithProjectLoadFile Method (String)

Loads the project from a file.

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static CodeSmithProject LoadFile(
    string fileName
)
Public Shared Function LoadFile (
    fileName As String
) As CodeSmithProject

Parameters

fileName
Type: SystemString
Name of the file.

Return Value

Type: CodeSmithProject
See Also

Reference

CodeSmithProject Class
LoadFile Overload
CodeSmith.Engine.Schema Namespace


CodeSmithProject.LoadFile Method (String, Boolean)

CodeSmithProjectLoadFile Method (String, Boolean)

Loads the project from a file.

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static CodeSmithProject LoadFile(
    string fileName,
    bool replaceVariables
)
Public Shared Function LoadFile (
    fileName As String,
    replaceVariables As Boolean
) As CodeSmithProject

Parameters

fileName
Type: SystemString
Name of the file.
replaceVariables
Type: SystemBoolean
if set to true replace variables.

Return Value

Type: CodeSmithProject
See Also

Reference

CodeSmithProject Class
LoadFile Overload
CodeSmith.Engine.Schema Namespace


CodeSmithProject.LoadFromString Method

CodeSmithProjectLoadFromString Method

Overload List
Name | Description
LoadFromString(String) | Loads the project from a String.
LoadFromString(String, Boolean) | Loads from String.
Top
See Also

Reference

CodeSmithProject Class
CodeSmith.Engine.Schema Namespace


CodeSmithProject.LoadFromString Method (String)

CodeSmithProjectLoadFromString Method (String)

Loads the project from a String.

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static CodeSmithProject LoadFromString(
    string xmlFragment
)
Public Shared Function LoadFromString (
    xmlFragment As String
) As CodeSmithProject

Parameters

xmlFragment
Type: SystemString
The XML fragment.

Return Value

Type: CodeSmithProject
See Also

Reference

CodeSmithProject Class
LoadFromString Overload
CodeSmith.Engine.Schema Namespace


CodeSmithProject.LoadFromString Method (String, Boolean)

CodeSmithProjectLoadFromString Method (String, Boolean)

Loads from String.

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static CodeSmithProject LoadFromString(
    string xmlFragment,
    bool replaceVariables
)
Public Shared Function LoadFromString (
    xmlFragment As String,
    replaceVariables As Boolean
) As CodeSmithProject

Parameters

xmlFragment
Type: SystemString
The XML fragment.
replaceVariables
Type: SystemBoolean
if set to true replace variables.

Return Value

Type: CodeSmithProject
See Also

Reference

CodeSmithProject Class
LoadFromString Overload
CodeSmith.Engine.Schema Namespace


CodeSmithProject.MakePathsRelative Method

CodeSmithProjectMakePathsRelative Method

Makes the paths relative to the directory of FileName.

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void MakePathsRelative()
Public Sub MakePathsRelative
See Also

Reference

CodeSmithProject Class
CodeSmith.Engine.Schema Namespace


CodeSmithProject.ReplaceVariables Method

CodeSmithProjectReplaceVariables Method

Replaces variables in the property set with the variables value.

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static CodeSmithProject ReplaceVariables(
    CodeSmithProject csp
)
Public Shared Function ReplaceVariables (
    csp As CodeSmithProject
) As CodeSmithProject

Parameters

csp
Type: CodeSmith.Engine.SchemaCodeSmithProject
The original project.

Return Value

Type: CodeSmithProject
A new instance of CodeSmithProject.
See Also

Reference

CodeSmithProject Class
CodeSmith.Engine.Schema Namespace


CodeSmithProject.SaveFile Method

CodeSmithProjectSaveFile Method

Overload List
 | Name | Description
Public method | SaveFile(String) | Saves the project to a file.
Public method | SaveFile(String, Boolean) | Saves the project to a file.
Top
See Also

Reference

CodeSmithProject Class
CodeSmith.Engine.Schema Namespace


CodeSmithProject.SaveFile Method (String)

CodeSmithProjectSaveFile Method (String)

Saves the project to a file.

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void SaveFile(
    string fileName
)
Public Sub SaveFile (
    fileName As String
)

Parameters

fileName
Type: SystemString
Name of the file.
See Also

Reference

CodeSmithProject Class
SaveFile Overload
CodeSmith.Engine.Schema Namespace


CodeSmithProject.SaveFile Method (String, Boolean)

CodeSmithProjectSaveFile Method (String, Boolean)

Saves the project to a file.

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void SaveFile(
    string fileName,
    bool relativePaths
)
Public Sub SaveFile (
    fileName As String,
    relativePaths As Boolean
)

Parameters

fileName
Type: SystemString
Name of the file.
relativePaths
Type: SystemBoolean
if set to true make paths relative.
See Also

Reference

CodeSmithProject Class
SaveFile Overload
CodeSmith.Engine.Schema Namespace


CodeSmithProject.SaveToString Method

CodeSmithProjectSaveToString Method

Overload List
 | Name | Description
Public method | SaveToString | Saves project to String.
Public method | SaveToString(Boolean) | Saves project to String.
Top
See Also

Reference

CodeSmithProject Class
CodeSmith.Engine.Schema Namespace


CodeSmithProject.SaveToString Method

CodeSmithProjectSaveToString Method

Saves project to String.

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string SaveToString()
Public Function SaveToString As String

Return Value

Type: String
An XML string of the project.
See Also

Reference

CodeSmithProject Class
SaveToString Overload
CodeSmith.Engine.Schema Namespace


CodeSmithProject.SaveToString Method (Boolean)

CodeSmithProjectSaveToString Method (Boolean)

Saves project to String.

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string SaveToString(
    bool applyVariables
)
Public Function SaveToString (
    applyVariables As Boolean
) As String

Parameters

applyVariables
Type: SystemBoolean
if set to true apply variables.

Return Value

Type: String
An XML string of the project.
See Also

Reference

CodeSmithProject Class
SaveToString Overload
CodeSmith.Engine.Schema Namespace


CodeSmithProject.ShouldSerializeDefaultProperties Method

CodeSmithProjectShouldSerializeDefaultProperties Method

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool ShouldSerializeDefaultProperties()
Public Function ShouldSerializeDefaultProperties As Boolean

Return Value

Type: Boolean
See Also

Reference

CodeSmithProject Class
CodeSmith.Engine.Schema Namespace


CodeSmithProject.ShouldSerializeDefaultTemplate Method

CodeSmithProjectShouldSerializeDefaultTemplate Method

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool ShouldSerializeDefaultTemplate()
Public Function ShouldSerializeDefaultTemplate As Boolean

Return Value

Type: Boolean
See Also

Reference

CodeSmithProject Class
CodeSmith.Engine.Schema Namespace


CodeSmithProject.ShouldSerializePropertySets Method

CodeSmithProjectShouldSerializePropertySets Method

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool ShouldSerializePropertySets()
Public Function ShouldSerializePropertySets As Boolean

Return Value

Type: Boolean
See Also

Reference

CodeSmithProject Class
CodeSmith.Engine.Schema Namespace


CodeSmithProject.ShouldSerializeSingleOutput Method

CodeSmithProjectShouldSerializeSingleOutput Method

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool ShouldSerializeSingleOutput()
Public Function ShouldSerializeSingleOutput As Boolean

Return Value

Type: Boolean
See Also

Reference

CodeSmithProject Class
CodeSmith.Engine.Schema Namespace


CodeSmithProject.ShouldSerializeVariables Method

CodeSmithProjectShouldSerializeVariables Method

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool ShouldSerializeVariables()
Public Function ShouldSerializeVariables As Boolean

Return Value

Type: Boolean
See Also

Reference

CodeSmithProject Class
CodeSmith.Engine.Schema Namespace


CodeSmithProject.ToString Method

CodeSmithProjectToString Method

Returns a String that represents the current Object.

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String that represents the current Object.
See Also

Reference

CodeSmithProject Class
CodeSmith.Engine.Schema Namespace


CodeSmithProject.UpdateDisplayNames Method

CodeSmithProjectUpdateDisplayNames Method

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void UpdateDisplayNames()
Public Sub UpdateDisplayNames
See Also

Reference

CodeSmithProject Class
CodeSmith.Engine.Schema Namespace


CodeSmithProject Fields

The CodeSmithProject type exposes the following members.

Fields
Name | Description
DefaultNamespace |
Top
See Also

Reference

CodeSmithProject Class
CodeSmith.Engine.Schema Namespace


CodeSmithProject.DefaultNamespace Field

CodeSmithProjectDefaultNamespace Field

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public const string DefaultNamespace = "http://www.codesmithtools.com/schema/csp.xsd"
Public Const DefaultNamespace As String = "http://www.codesmithtools.com/schema/csp.xsd"

Field Value

Type: String
See Also

Reference

CodeSmithProject Class
CodeSmith.Engine.Schema Namespace


DefaultTemplate Class

Inheritance Hierarchy
SystemObject
ObservableBase
CodeSmith.Engine.SchemaDefaultTemplate

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
public class DefaultTemplate : ObservableBase
<SerializableAttribute>
Public Class DefaultTemplate
    Inherits ObservableBase

The DefaultTemplate type exposes the following members.

Constructors
 | Name | Description
Public method | DefaultTemplate | Initializes a new instance of the DefaultTemplate class
Top
Properties
 | Name | Description
Public property | Path |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSmith.Engine.Schema Namespace


DefaultTemplate Constructor

Initializes a new instance of the DefaultTemplate class

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public DefaultTemplate()
Public Sub New
See Also

Reference

DefaultTemplate Class
CodeSmith.Engine.Schema Namespace


DefaultTemplate Properties

The DefaultTemplate type exposes the following members.

Properties
 | Name | Description
Public property | Path |
Top
See Also

Reference

DefaultTemplate Class
CodeSmith.Engine.Schema Namespace


DefaultTemplate.Path Property

DefaultTemplatePath Property

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string Path { get; set; }
Public Property Path As String
    Get
    Set

Property Value

Type: String
Remarks
See Also

Reference

DefaultTemplate Class
CodeSmith.Engine.Schema Namespace


DefaultTemplate Methods

The DefaultTemplate type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DefaultTemplate Class
CodeSmith.Engine.Schema Namespace


Property Class

Inheritance Hierarchy
SystemObject
ObservableBase
CodeSmith.Engine.SchemaProperty

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
public class Property : ObservableBase, ICloneable
<SerializableAttribute>
Public Class Property
    Inherits ObservableBase
    Implements ICloneable

The Property type exposes the following members.

Constructors
 | Name | Description
Public method | Property | Initializes a new instance of the Property class
Public method | Property(String, String) | Initializes a new instance of the Property class
Top
Properties
 | Name | Description
Public property | ChildNodes |
Public property | IsComplexType |
Public property | Name |
Public property | PropertyNode |
Public property | Value |
Top
Methods
 | Name | Description
Public method | Clone |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSmith.Engine.Schema Namespace


Property Constructor

Overload List
 | Name | Description
Public method | Property | Initializes a new instance of the Property class
Public method | Property(String, String) | Initializes a new instance of the Property class
Top
See Also

Reference

Property Class
CodeSmith.Engine.Schema Namespace


Property Constructor

Initializes a new instance of the Property class

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public Property()
Public Sub New
See Also

Reference

Property Class
Property Overload
CodeSmith.Engine.Schema Namespace


Property Constructor (String, String)

Initializes a new instance of the Property class

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public Property(
    string name,
    string value
)
Public Sub New (
    name As String,
    value As String
)

Parameters

name
Type: SystemString
value
Type: SystemString
See Also

Reference

Property Class
Property Overload
CodeSmith.Engine.Schema Namespace


Property Properties

The Property type exposes the following members.

Properties
 | Name | Description
Public property | ChildNodes |
Public property | IsComplexType |
Public property | Name |
Public property | PropertyNode |
Public property | Value |
Top
See Also

Reference

Property Class
CodeSmith.Engine.Schema Namespace


Property.ChildNodes Property

PropertyChildNodes Property

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public List<XmlNode> ChildNodes { get; set; }
Public Property ChildNodes As List(Of XmlNode)
    Get
    Set

Property Value

Type: List XmlNode
Remarks
See Also

Reference

Property Class
CodeSmith.Engine.Schema Namespace


Property.IsComplexType Property

PropertyIsComplexType Property

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool IsComplexType { get; }
Public ReadOnly Property IsComplexType As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

Property Class
CodeSmith.Engine.Schema Namespace


Property.Name Property

PropertyName Property

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set

Property Value

Type: String
Remarks
See Also

Reference

Property Class
CodeSmith.Engine.Schema Namespace


Property.PropertyNode Property

PropertyPropertyNode Property

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public XmlNode PropertyNode { get; }
Public ReadOnly Property PropertyNode As XmlNode
    Get

Property Value

Type: XmlNode
See Also

Reference

Property Class
CodeSmith.Engine.Schema Namespace


Property.Value Property

PropertyValue Property

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string Value { get; set; }
Public Property Value As String
    Get
    Set

Property Value

Type: String
Remarks
See Also

Reference

Property Class
CodeSmith.Engine.Schema Namespace


Property Methods

The Property type exposes the following members.

Methods
 | Name | Description
Public method | Clone |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Property Class
CodeSmith.Engine.Schema Namespace


Property.Clone Method

PropertyClone Method

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public Object Clone()
Public Function Clone As Object

Return Value

Type: Object

Implements

ICloneableClone
See Also

Reference

Property Class
CodeSmith.Engine.Schema Namespace


PropertyCollection Class

Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection Property
System.Collections.ObjectModelKeyedCollection String, Property
CodeSmith.Engine.SchemaPropertyCollection

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
public class PropertyCollection : KeyedCollection<string, Property>
<SerializableAttribute>
Public Class PropertyCollection
    Inherits KeyedCollection(Of String, Property)

The PropertyCollection type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyCollection | Initializes a new instance of the PropertyCollection class
Top
Properties
 | Name | Description
Public property | Comparer | Gets the generic equality comparer that is used to determine equality of keys in the collection. (Inherited from KeyedCollection String, Property .)
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection Property .)
Protected property | Dictionary | Gets the lookup dictionary of the KeyedCollectionTKey, TItem. (Inherited from KeyedCollection String, Property .)
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from Collection Property .)
Public property | ItemTKey | Gets the element with the specified key. (Inherited from KeyedCollection String, Property .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection Property .)
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection Property .)
Protected method | ChangeItemKey | Changes the key associated with the specified element in the lookup dictionary. (Inherited from KeyedCollection String, Property .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection Property .)
Protected method | ClearItems | Removes all elements from the KeyedCollectionTKey, TItem. (Inherited from KeyedCollection String, Property .)
Public method | Contains(T) | Determines whether an element is in the CollectionT. (Inherited from Collection Property .)
Public method | Contains(TKey) | Determines whether the collection contains an element with the specified key. (Inherited from KeyedCollection String, Property .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection Property .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection Property .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetKeyForItem | (Overrides KeyedCollectionTKey, TItemGetKeyForItem(TItem).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection Property .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection Property .)
Protected method | InsertItem | Inserts an element into the KeyedCollectionTKey, TItem at the specified index. (Inherited from KeyedCollection String, Property .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(T) | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection Property .)
Public method | Remove(TKey) | Removes the element with the specified key from the KeyedCollectionTKey, TItem. (Inherited from KeyedCollection String, Property .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection Property .)
Protected method | RemoveItem | Removes the element at the specified index of the KeyedCollectionTKey, TItem. (Inherited from KeyedCollection String, Property .)
Protected method | SetItem | Replaces the item at the specified index with the specified item. (Inherited from KeyedCollection String, Property .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSmith.Engine.Schema Namespace


PropertyCollection Constructor

Initializes a new instance of the PropertyCollection class

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public PropertyCollection()
Public Sub New
See Also

Reference

PropertyCollection Class
CodeSmith.Engine.Schema Namespace


PropertyCollection Properties

The PropertyCollection type exposes the following members.

Properties
 | Name | Description
Public property | Comparer | Gets the generic equality comparer that is used to determine equality of keys in the collection. (Inherited from KeyedCollection String, Property .)
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection Property .)
Protected property | Dictionary | Gets the lookup dictionary of the KeyedCollectionTKey, TItem. (Inherited from KeyedCollection String, Property .)
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from Collection Property .)
Public property | ItemTKey | Gets the element with the specified key. (Inherited from KeyedCollection String, Property .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection Property .)
Top
See Also

Reference

PropertyCollection Class
CodeSmith.Engine.Schema Namespace


PropertyCollection Methods

The PropertyCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection Property .)
Protected method | ChangeItemKey | Changes the key associated with the specified element in the lookup dictionary. (Inherited from KeyedCollection String, Property .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection Property .)
Protected method | ClearItems | Removes all elements from the KeyedCollectionTKey, TItem. (Inherited from KeyedCollection String, Property .)
Public method | Contains(T) | Determines whether an element is in the CollectionT. (Inherited from Collection Property .)
Public method | Contains(TKey) | Determines whether the collection contains an element with the specified key. (Inherited from KeyedCollection String, Property .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection Property .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection Property .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetKeyForItem | (Overrides KeyedCollectionTKey, TItemGetKeyForItem(TItem).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection Property .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection Property .)
Protected method | InsertItem | Inserts an element into the KeyedCollectionTKey, TItem at the specified index. (Inherited from KeyedCollection String, Property .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(T) | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection Property .)
Public method | Remove(TKey) | Removes the element with the specified key from the KeyedCollectionTKey, TItem. (Inherited from KeyedCollection String, Property .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection Property .)
Protected method | RemoveItem | Removes the element at the specified index of the KeyedCollectionTKey, TItem. (Inherited from KeyedCollection String, Property .)
Protected method | SetItem | Replaces the item at the specified index with the specified item. (Inherited from KeyedCollection String, Property .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PropertyCollection Class
CodeSmith.Engine.Schema Namespace


PropertyCollection.GetKeyForItem Method

PropertyCollectionGetKeyForItem Method

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected override string GetKeyForItem(
    Property item
)
Protected Overrides Function GetKeyForItem (
    item As Property
) As String

Parameters

item
Type: CodeSmith.Engine.SchemaProperty

Return Value

Type: String
See Also

Reference

PropertyCollection Class
CodeSmith.Engine.Schema Namespace


PropertySet Class

Inheritance Hierarchy
SystemObject
ObservableBase
CodeSmith.Engine.SchemaPropertySet

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
public class PropertySet : ObservableBase
<SerializableAttribute>
Public Class PropertySet
    Inherits ObservableBase

The PropertySet type exposes the following members.

Constructors
 | Name | Description
Public method | PropertySet | Initializes a new instance of the PropertySet class
Top
Properties
 | Name | Description
Public property | DisplayName |
Public property | DisplayTemplate |
Public property | Enabled |
Public property | MergeInit |
Public property | MergeType |
Public property | Name |
Public property | Output |
Public property | Project |
Public property | Properties |
Public property | Template |
Top
Methods
 | Name | Description
 | CreateInstance |
 | Deserializer |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ShouldSerializeProperties |
Public method | ToString | (Overrides ObjectToString.)
Top
See Also

Reference

CodeSmith.Engine.Schema Namespace


PropertySet Constructor

Initializes a new instance of the PropertySet class

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public PropertySet()
Public Sub New
See Also

Reference

PropertySet Class
CodeSmith.Engine.Schema Namespace


PropertySet Properties

The PropertySet type exposes the following members.

Properties
 | Name | Description
Public property | DisplayName |
Public property | DisplayTemplate |
Public property | Enabled |
Public property | MergeInit |
Public property | MergeType |
Public property | Name |
Public property | Output |
Public property | Project |
Public property | Properties |
Public property | Template |
Top
See Also

Reference

PropertySet Class
CodeSmith.Engine.Schema Namespace


PropertySet.DisplayName Property

PropertySetDisplayName Property

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string DisplayName { get; set; }
Public Property DisplayName As String
    Get
    Set

Property Value

Type: String
See Also

Reference

PropertySet Class
CodeSmith.Engine.Schema Namespace


PropertySet.DisplayTemplate Property

PropertySetDisplayTemplate Property

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string DisplayTemplate { get; set; }
Public Property DisplayTemplate As String
    Get
    Set

Property Value

Type: String
See Also

Reference

PropertySet Class
CodeSmith.Engine.Schema Namespace


PropertySet.Enabled Property

PropertySetEnabled Property

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool Enabled { get; set; }
Public Property Enabled As Boolean
    Get
    Set

Property Value

Type: Boolean
Remarks
See Also

Reference

PropertySet Class
CodeSmith.Engine.Schema Namespace


PropertySet.MergeInit Property

PropertySetMergeInit Property

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string MergeInit { get; set; }
Public Property MergeInit As String
    Get
    Set

Property Value

Type: String
Remarks
See Also

Reference

PropertySet Class
CodeSmith.Engine.Schema Namespace


PropertySet.MergeType Property

PropertySetMergeType Property

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string MergeType { get; set; }
Public Property MergeType As String
    Get
    Set

Property Value

Type: String
Remarks
See Also

Reference

PropertySet Class
CodeSmith.Engine.Schema Namespace


PropertySet.Name Property

PropertySetName Property

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set

Property Value

Type: String
Remarks
See Also

Reference

PropertySet Class
CodeSmith.Engine.Schema Namespace


PropertySet.Output Property

PropertySetOutput Property

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string Output { get; set; }
Public Property Output As String
    Get
    Set

Property Value

Type: String
Remarks
See Also

Reference

PropertySet Class
CodeSmith.Engine.Schema Namespace


PropertySet.Project Property

PropertySetProject Property

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CodeSmithProject Project { get; }
Public ReadOnly Property Project As CodeSmithProject
    Get

Property Value

Type: CodeSmithProject
See Also

Reference

PropertySet Class
CodeSmith.Engine.Schema Namespace


PropertySet.Properties Property

PropertySetProperties Property

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public PropertyCollection Properties { get; set; }
Public Property Properties As PropertyCollection
    Get
    Set

Property Value

Type: PropertyCollection
Remarks
See Also

Reference

PropertySet Class
CodeSmith.Engine.Schema Namespace


PropertySet.Template Property

PropertySetTemplate Property

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string Template { get; set; }
Public Property Template As String
    Get
    Set

Property Value

Type: String
Remarks
See Also

Reference

PropertySet Class
CodeSmith.Engine.Schema Namespace


PropertySet Methods

The PropertySet type exposes the following members.

Methods
 | Name | Description
 | CreateInstance |
 | Deserializer |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ShouldSerializeProperties |
Public method | ToString | (Overrides ObjectToString.)
Top
See Also

Reference

PropertySet Class
CodeSmith.Engine.Schema Namespace


PropertySet.CreateInstance Method

PropertySetCreateInstance Method

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static PropertySet CreateInstance()
Public Shared Function CreateInstance As PropertySet

Return Value

Type: PropertySet
See Also

Reference

PropertySet Class
CodeSmith.Engine.Schema Namespace


PropertySet.Deserializer Method

PropertySetDeserializer Method

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static PropertySet Deserializer(
    string xmlFragment
)
Public Shared Function Deserializer (
    xmlFragment As String
) As PropertySet

Parameters

xmlFragment
Type: SystemString

Return Value

Type: PropertySet
See Also

Reference

PropertySet Class
CodeSmith.Engine.Schema Namespace


PropertySet.ShouldSerializeProperties Method

PropertySetShouldSerializeProperties Method

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool ShouldSerializeProperties()
Public Function ShouldSerializeProperties As Boolean

Return Value

Type: Boolean
See Also

Reference

PropertySet Class
CodeSmith.Engine.Schema Namespace


PropertySet.ToString Method

PropertySetToString Method

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
See Also

Reference

PropertySet Class
CodeSmith.Engine.Schema Namespace


SchemaHelper Class

Inheritance Hierarchy
SystemObject
CodeSmith.Engine.SchemaSchemaHelper

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class SchemaHelper
Public Class SchemaHelper

The SchemaHelper type exposes the following members.

Constructors
 | Name | Description
Public method | SchemaHelper | Initializes a new instance of the SchemaHelper class
Top
Properties
 | Name | Description
Public property | IsVaild |
Public property | ValidationErrors |
Top
Methods
 | Name | Description
Public method | CheckFileForNamespace |
Public method | CheckXmlForNamespace |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpgradeFile |
Public method | UpgradeXml |
Public method | ValidateFile |
Public method | ValidateXml |
Top
See Also

Reference

CodeSmith.Engine.Schema Namespace


SchemaHelper Constructor

Initializes a new instance of the SchemaHelper class

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public SchemaHelper()
Public Sub New
See Also

Reference

SchemaHelper Class
CodeSmith.Engine.Schema Namespace


SchemaHelper Properties

The SchemaHelper type exposes the following members.

Properties
 | Name | Description
Public property | IsVaild |
Public property | ValidationErrors |
Top
See Also

Reference

SchemaHelper Class
CodeSmith.Engine.Schema Namespace


SchemaHelper.IsVaild Property

SchemaHelperIsVaild Property

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool IsVaild { get; }
Public ReadOnly Property IsVaild As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

SchemaHelper Class
CodeSmith.Engine.Schema Namespace


SchemaHelper.ValidationErrors Property

SchemaHelperValidationErrors Property

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public List<ValidationEventArgs> ValidationErrors { get; }
Public ReadOnly Property ValidationErrors As List(Of ValidationEventArgs)
    Get

Property Value

Type: List ValidationEventArgs
See Also

Reference

SchemaHelper Class
CodeSmith.Engine.Schema Namespace


SchemaHelper Methods

The SchemaHelper type exposes the following members.

Methods
 | Name | Description
Public method | CheckFileForNamespace |
Public method | CheckXmlForNamespace |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpgradeFile |
Public method | UpgradeXml |
Public method | ValidateFile |
Public method | ValidateXml |
Top
See Also

Reference

SchemaHelper Class
CodeSmith.Engine.Schema Namespace


SchemaHelper.CheckFileForNamespace Method

SchemaHelperCheckFileForNamespace Method

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool CheckFileForNamespace(
    string filename
)
Public Function CheckFileForNamespace (
    filename As String
) As Boolean

Parameters

filename
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

SchemaHelper Class
CodeSmith.Engine.Schema Namespace


SchemaHelper.CheckXmlForNamespace Method

SchemaHelperCheckXmlForNamespace Method

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool CheckXmlForNamespace(
    string xmlFragment
)
Public Function CheckXmlForNamespace (
    xmlFragment As String
) As Boolean

Parameters

xmlFragment
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

SchemaHelper Class
CodeSmith.Engine.Schema Namespace


SchemaHelper.UpgradeFile Method

SchemaHelperUpgradeFile Method

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool UpgradeFile(
    string oldFile,
    string newFile
)
Public Function UpgradeFile (
    oldFile As String,
    newFile As String
) As Boolean

Parameters

oldFile
Type: SystemString
newFile
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

SchemaHelper Class
CodeSmith.Engine.Schema Namespace


SchemaHelper.UpgradeXml Method

SchemaHelperUpgradeXml Method

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string UpgradeXml(
    string xmlFragment
)
Public Function UpgradeXml (
    xmlFragment As String
) As String

Parameters

xmlFragment
Type: SystemString

Return Value

Type: String
See Also

Reference

SchemaHelper Class
CodeSmith.Engine.Schema Namespace


SchemaHelper.ValidateFile Method

SchemaHelperValidateFile Method

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool ValidateFile(
    string xmlFile
)
Public Function ValidateFile (
    xmlFile As String
) As Boolean

Parameters

xmlFile
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

SchemaHelper Class
CodeSmith.Engine.Schema Namespace


SchemaHelper.ValidateXml Method

SchemaHelperValidateXml Method

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool ValidateXml(
    string xmlFragment
)
Public Function ValidateXml (
    xmlFragment As String
) As Boolean

Parameters

xmlFragment
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

SchemaHelper Class
CodeSmith.Engine.Schema Namespace


SingleOutput Class

Inheritance Hierarchy
SystemObject
ObservableBase
CodeSmith.Engine.SchemaSingleOutput

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
public class SingleOutput : ObservableBase
<SerializableAttribute>
Public Class SingleOutput
    Inherits ObservableBase

The SingleOutput type exposes the following members.

Constructors
 | Name | Description
Public method | SingleOutput | Initializes a new instance of the SingleOutput class
Top
Properties
 | Name | Description
Public property | Enabled |
Public property | Footer |
Public property | Header |
Public property | Path |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CodeSmith.Engine.Schema Namespace


SingleOutput Constructor

Initializes a new instance of the SingleOutput class

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public SingleOutput()
Public Sub New
See Also

Reference

SingleOutput Class
CodeSmith.Engine.Schema Namespace


SingleOutput Properties

The SingleOutput type exposes the following members.

Properties
 | Name | Description
Public property | Enabled |
Public property | Footer |
Public property | Header |
Public property | Path |
Top
See Also

Reference

SingleOutput Class
CodeSmith.Engine.Schema Namespace


SingleOutput.Enabled Property

SingleOutputEnabled Property

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool Enabled { get; set; }
Public Property Enabled As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

SingleOutput Class
CodeSmith.Engine.Schema Namespace


SingleOutput.Footer Property

SingleOutputFooter Property

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string Footer { get; set; }
Public Property Footer As String
    Get
    Set

Property Value

Type: String
See Also

Reference

SingleOutput Class
CodeSmith.Engine.Schema Namespace


SingleOutput.Header Property

SingleOutputHeader Property

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string Header { get; set; }
Public Property Header As String
    Get
    Set

Property Value

Type: String
See Also

Reference

SingleOutput Class
CodeSmith.Engine.Schema Namespace


SingleOutput.Path Property

SingleOutputPath Property

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string Path { get; set; }
Public Property Path As String
    Get
    Set

Property Value

Type: String
Remarks
See Also

Reference

SingleOutput Class
CodeSmith.Engine.Schema Namespace


SingleOutput Methods

The SingleOutput type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SingleOutput Class
CodeSmith.Engine.Schema Namespace


Variable Class

Inheritance Hierarchy
SystemObject
ObservableBase
CodeSmith.Engine.SchemaVariable

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
public class Variable : ObservableBase
<SerializableAttribute>
Public Class Variable
    Inherits ObservableBase

The Variable type exposes the following members.

Constructors
 | Name | Description
Public method | Variable | Initializes a new instance of the Variable class
Public method | Variable(String, String) | Initializes a new instance of the Variable class
Top
Properties
 | Name | Description
Public property | Key |
Public property | KeyFormated |
Public property | OriginalKey |
Public property | OriginalKeyFormated |
Public property | OriginalValue |
Public property | Value |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides ObjectToString.)
Top
See Also

Reference

CodeSmith.Engine.Schema Namespace


Variable Constructor

Overload List
 | Name | Description
Public method | Variable | Initializes a new instance of the Variable class
Public method | Variable(String, String) | Initializes a new instance of the Variable class
Top
See Also

Reference

Variable Class
CodeSmith.Engine.Schema Namespace


Variable Constructor

Initializes a new instance of the Variable class

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public Variable()
Public Sub New
See Also

Reference

Variable Class
Variable Overload
CodeSmith.Engine.Schema Namespace


Variable Constructor (String, String)

Initializes a new instance of the Variable class

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public Variable(
    string key,
    string value
)
Public Sub New (
    key As String,
    value As String
)

Parameters

key
Type: SystemString
value
Type: SystemString
See Also

Reference

Variable Class
Variable Overload
CodeSmith.Engine.Schema Namespace


Variable Properties

The Variable type exposes the following members.

Properties
 | Name | Description
Public property | Key |
Public property | KeyFormated |
Public property | OriginalKey |
Public property | OriginalKeyFormated |
Public property | OriginalValue |
Public property | Value |
Top
See Also

Reference

Variable Class
CodeSmith.Engine.Schema Namespace


Variable.Key Property

VariableKey Property

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string Key { get; set; }
Public Property Key As String
    Get
    Set

Property Value

Type: String
Remarks
See Also

Reference

Variable Class
CodeSmith.Engine.Schema Namespace


Variable.KeyFormated Property

VariableKeyFormated Property

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string KeyFormated { get; }
Public ReadOnly Property KeyFormated As String
    Get

Property Value

Type: String
See Also

Reference

Variable Class
CodeSmith.Engine.Schema Namespace


Variable.OriginalKey Property

VariableOriginalKey Property

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string OriginalKey { get; }
Public ReadOnly Property OriginalKey As String
    Get

Property Value

Type: String
See Also

Reference

Variable Class
CodeSmith.Engine.Schema Namespace


Variable.OriginalKeyFormated Property

VariableOriginalKeyFormated Property

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string OriginalKeyFormated { get; }
Public ReadOnly Property OriginalKeyFormated As String
    Get

Property Value

Type: String
See Also

Reference

Variable Class
CodeSmith.Engine.Schema Namespace


Variable.OriginalValue Property

VariableOriginalValue Property

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string OriginalValue { get; }
Public ReadOnly Property OriginalValue As String
    Get

Property Value

Type: String
See Also

Reference

Variable Class
CodeSmith.Engine.Schema Namespace


Variable.Value Property

VariableValue Property

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string Value { get; set; }
Public Property Value As String
    Get
    Set

Property Value

Type: String
Remarks
See Also

Reference

Variable Class
CodeSmith.Engine.Schema Namespace


Variable Methods

The Variable type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides ObjectToString.)
Top
See Also

Reference

Variable Class
CodeSmith.Engine.Schema Namespace


Variable.ToString Method

VariableToString Method

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
See Also

Reference

Variable Class
CodeSmith.Engine.Schema Namespace


VariableCollection Class

Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection Variable
System.Collections.ObjectModelKeyedCollection String, Variable
CodeSmith.Engine.SchemaVariableCollection

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
public class VariableCollection : KeyedCollection<string, Variable>
<SerializableAttribute>
Public Class VariableCollection
    Inherits KeyedCollection(Of String, Variable)

The VariableCollection type exposes the following members.

Constructors
 | Name | Description
Public method | VariableCollection | Initializes a new instance of the VariableCollection class
Top
Properties
 | Name | Description
Public property | Comparer | Gets the generic equality comparer that is used to determine equality of keys in the collection. (Inherited from KeyedCollection String, Variable .)
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection Variable .)
Protected property | Dictionary | Gets the lookup dictionary of the KeyedCollectionTKey, TItem. (Inherited from KeyedCollection String, Variable .)
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from Collection Variable .)
Public property | ItemTKey | Gets the element with the specified key. (Inherited from KeyedCollection String, Variable .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection Variable .)
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection Variable .)
Protected method | ChangeItemKey | Changes the key associated with the specified element in the lookup dictionary. (Inherited from KeyedCollection String, Variable .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection Variable .)
Protected method | ClearItems | Removes all elements from the KeyedCollectionTKey, TItem. (Inherited from KeyedCollection String, Variable .)
Public method | Contains(TKey) | Determines whether the collection contains an element with the specified key. (Inherited from KeyedCollection String, Variable .)
Public method | Contains(T) | Determines whether an element is in the CollectionT. (Inherited from Collection Variable .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection Variable .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection Variable .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetKeyForItem | (Overrides KeyedCollectionTKey, TItemGetKeyForItem(TItem).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection Variable .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection Variable .)
Protected method | InsertItem | Inserts an element into the KeyedCollectionTKey, TItem at the specified index. (Inherited from KeyedCollection String, Variable .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(TKey) | Removes the element with the specified key from the KeyedCollectionTKey, TItem. (Inherited from KeyedCollection String, Variable .)
Public method | Remove(T) | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection Variable .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection Variable .)
Protected method | RemoveItem | Removes the element at the specified index of the KeyedCollectionTKey, TItem. (Inherited from KeyedCollection String, Variable .)
Protected method | SetItem | Replaces the item at the specified index with the specified item. (Inherited from KeyedCollection String, Variable .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryGetByValue |
Top
See Also

Reference

CodeSmith.Engine.Schema Namespace


VariableCollection Constructor

Initializes a new instance of the VariableCollection class

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public VariableCollection()
Public Sub New
See Also

Reference

VariableCollection Class
CodeSmith.Engine.Schema Namespace


VariableCollection Properties

The VariableCollection type exposes the following members.

Properties
 | Name | Description
Public property | Comparer | Gets the generic equality comparer that is used to determine equality of keys in the collection. (Inherited from KeyedCollection String, Variable .)
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection Variable .)
Protected property | Dictionary | Gets the lookup dictionary of the KeyedCollectionTKey, TItem. (Inherited from KeyedCollection String, Variable .)
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from Collection Variable .)
Public property | ItemTKey | Gets the element with the specified key. (Inherited from KeyedCollection String, Variable .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection Variable .)
Top
See Also

Reference

VariableCollection Class
CodeSmith.Engine.Schema Namespace


VariableCollection Methods

The VariableCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection Variable .)
Protected method | ChangeItemKey | Changes the key associated with the specified element in the lookup dictionary. (Inherited from KeyedCollection String, Variable .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection Variable .)
Protected method | ClearItems | Removes all elements from the KeyedCollectionTKey, TItem. (Inherited from KeyedCollection String, Variable .)
Public method | Contains(TKey) | Determines whether the collection contains an element with the specified key. (Inherited from KeyedCollection String, Variable .)
Public method | Contains(T) | Determines whether an element is in the CollectionT. (Inherited from Collection Variable .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection Variable .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection Variable .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetKeyForItem | (Overrides KeyedCollectionTKey, TItemGetKeyForItem(TItem).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection Variable .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection Variable .)
Protected method | InsertItem | Inserts an element into the KeyedCollectionTKey, TItem at the specified index. (Inherited from KeyedCollection String, Variable .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(TKey) | Removes the element with the specified key from the KeyedCollectionTKey, TItem. (Inherited from KeyedCollection String, Variable .)
Public method | Remove(T) | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection Variable .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection Variable .)
Protected method | RemoveItem | Removes the element at the specified index of the KeyedCollectionTKey, TItem. (Inherited from KeyedCollection String, Variable .)
Protected method | SetItem | Replaces the item at the specified index with the specified item. (Inherited from KeyedCollection String, Variable .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryGetByValue |
Top
See Also

Reference

VariableCollection Class
CodeSmith.Engine.Schema Namespace


VariableCollection.GetKeyForItem Method

VariableCollectionGetKeyForItem Method

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected override string GetKeyForItem(
    Variable item
)
Protected Overrides Function GetKeyForItem (
    item As Variable
) As String

Parameters

item
Type: CodeSmith.Engine.SchemaVariable

Return Value

Type: String
See Also

Reference

VariableCollection Class
CodeSmith.Engine.Schema Namespace


VariableCollection.TryGetByValue Method

VariableCollectionTryGetByValue Method

Namespace: CodeSmith.Engine.Schema
Assembly: CodeSmith.Engine (in CodeSmith.Engine.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool TryGetByValue(
    string value,
    out Variable variable
)
Public Function TryGetByValue (
    value As String,
    <OutAttribute> ByRef variable As Variable
) As Boolean

Parameters

value
Type: SystemString
variable
Type: CodeSmith.Engine.SchemaVariable

Return Value

Type: Boolean
See Also

Reference

VariableCollection Class
CodeSmith.Engine.Schema Namespace


SchemaExplorer Namespace

Allows programmatic discovery of database schema information.
Classes
 | Class | Description
Public class | CachedSchemaProviderProxy |
Public class | ColumnSchema | Provides information about a table column.
Public class | ColumnSchemaCollection | Implements a strongly typed collection of ColumnSchema elements.
Public class | CommandResultColumnSchema | Provides information about a command result column.
Public class | CommandResultColumnSchemaCollection | Implements a strongly typed collection of CommandResultColumnSchema elements.
Public class | CommandResultSchema | Summary description for CommandResultSchema.
Public class | CommandResultSchemaCollection | Implements a strongly typed collection of CommandResultSchema elements.
Public class | CommandSchema | Provides information about a command.
Public class | CommandSchemaCollection | Implements a strongly typed collection of CommandSchema elements.
Public class | Configuration |
Public class | ConfigurationImport | A class used to import old schema explorer configuration files.
Public class | DatabaseSchema | This class allows programmatic discovery of a database schema.
Public class | DataObjectBase | Provides a common base for all schema objects that describe a data field.
Public class | DataObjectBaseCollection | Obsolete. Implements a strongly typed collection of DataObjectBase elements.
Public class | DataObjectBaseCollectionT | Implements a strongly typed collection of DataObjectBase elements.
Public class | DataSource | Used to store information about a data source.
Public class | DataSourceCollection | Implements a strongly typed collection of DataSource elements.
Public class | DataSourceManager |
Public class | ExtendedProperty |
Public class | ExtendedPropertyCollection | Implements a strongly typed collection of ExtendedProperty elements.
Public class | ExtendedPropertyCollectionTypeConverter |
Public class | ExtendedPropertyNames |
Public class | IDbSchemaProviderCollection | Implements a strongly typed collection of IDbSchemaProvider elements.
Public class | IndexSchema | Provides information about an index.
Public class | IndexSchemaCollection | Implements a strongly typed collection of IndexSchema elements.
Public class | MemberColumnSchema | Wraps a ColumnSchema object and allows for storing extended properties specific to this instance of the member column.
Public class | MemberColumnSchemaCollection | Implements a strongly typed collection of MemberColumnSchema elements.
Public class | ParameterSchema | Provides information about a parameter.
Public class | ParameterSchemaCollection | Implements a strongly typed collection of ParameterSchema elements.
Public class | PrimaryKeySchema | Provides information about a table primary key.
Public class | PropertyComparer |
Public class | PropertyComparerT |
Public class | SchemaObjectBase | Provides a base for all schema objects to derive from.
Public class | SchemaObjectBaseCollection |
Public class | SchemaObjectCollectionT | Implements a strongly typed collection of ISchemaObject elements.
Public class | SchemaObjectWithOwnerBase | Provides a base for all schema objects to derive from.
Public class | SchemaObjectWithOwnerCollectionT |
Public class | SchemaProvider |
Public class | SchemaSelector | A DatabaseSchema extension allowing for flexible schema object selection.
Public class | SchemaSelectorExtensions | Extension methods to filter schema to selected items.
Public class | SchemaUtility | Summary description for SchemaUtility.
Public class | TableDependancyComparer | Sorts TableSchema objects based on their dependencies.
Public class | TableKeySchema | Provides information about a table key.
Public class | TableKeySchemaCollection | Implements a strongly typed collection of TableKeySchema elements.
Public class | TableSchema | Provides information about a database table.
Public class | TableSchemaCollection | Implements a strongly typed collection of TableSchema elements.
Public class | TabularObject |
Public class | TabularObjectBase | Provides a common base for all tabular schema objects.
Public class | TabularObjectBaseCollection | Implements a strongly typed collection of SchemaObjectWithOwnerCollectionT elements.
Public class | ViewColumnSchema | Provides information about a view column.
Public class | ViewColumnSchemaCollection | Implements a strongly typed collection of ViewColumnSchema elements.
Public class | ViewSchema | Provides information about a database table.
Public class | ViewSchemaCollection | Implements a strongly typed collection of ViewSchema elements.
Public class | WrappedNamedObjectCollectionTBase, TActual |
Public class | WrappedSchemaObjectCollectionTBase, TActual |
Public class | WrappedSchemaObjectWithOwnerCollectionTBase, TActual |
Structures
 | Structure | Description
Public structure | SortExpression |
Interfaces
 | Interface | Description
Public interface | IColumnSchema |
Public interface | ICommandResultColumnSchema |
Public interface | ICommandResultSchema |
Public interface | ICommandSchema |
Public interface | IDatabaseSchema |
Public interface | IDataObject |
Public interface | IDbConnectionStringEditor |
Public interface | IDbSchemaProvider | This interface is used to implement a custom schema provider for SchemaExplorer. To create your own schema provider simply create a new assembly which includes a public class that implements this interface. Also, the assembly name must end with SchemaProvider.dll (ie. MySampleSchemaProvider.dll). Once you have done this, just put the assembly in the same directory as CodeSmith and that's it.
Public interface | IExtendedProperty |
Public interface | IIndexSchema |
Public interface | IMemberColumnSchema |
Public interface | IParameterSchema |
Public interface | IPrimaryKeySchema |
Public interface | IReadOnlySchemaObjectCollectionT |
Public interface | IReadOnlySchemaObjectWithOwnerCollectionT |
Public interface | ISchemaObject |
Public interface | ISchemaObjectCollectionT |
Public interface | ISchemaObjectWithOwner |
Public interface | ISchemaObjectWithOwnerCollectionT |
Public interface | ITableKeySchema |
Public interface | ITableSchema |
Public interface | ITabularObject |
Public interface | IViewColumnSchema |
Public interface | IViewSchema |
Enumerations
 | Enumeration | Description
Public enumeration | PropertyStateEnum |
Public enumeration | SelectMode |
Public enumeration | TableSortOrder |


CachedSchemaProviderProxy Class

Inheritance Hierarchy
SystemObject
SchemaExplorerCachedSchemaProviderProxy

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class CachedSchemaProviderProxy : IDbSchemaProvider,
    IDbConnectionStringEditor
Public Class CachedSchemaProviderProxy
    Implements IDbSchemaProvider, IDbConnectionStringEditor

The CachedSchemaProviderProxy type exposes the following members.

Constructors
 | Name | Description
Public method | CachedSchemaProviderProxy | Initializes a new instance of the CachedSchemaProviderProxy class
Top
Properties
 | Name | Description
Public property | ConnectionString |
Public property | ConnectionStringEditor |
Public property | Description |
Public property | EditorAvailable |
Public property | Name |
Public property | Provider |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCommandParameters |
Public method | GetCommandResultSchemas |
Public method | GetCommands |
Public method | GetCommandText |
Public method | GetDatabaseName |
Public method | GetExtendedProperties |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetTableColumns |
Public method | GetTableData |
Public method | GetTableIndexes |
Public method | GetTableKeys |
Public method | GetTablePrimaryKey |
Public method | GetTables |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetViewColumns |
Public method | GetViewData |
Public method | GetViews |
Public method | GetViewText |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetExtendedProperties |
Public method | ShowEditor |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SchemaExplorer Namespace


CachedSchemaProviderProxy Constructor

Initializes a new instance of the CachedSchemaProviderProxy class

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CachedSchemaProviderProxy(
    IDbSchemaProvider provider
)
Public Sub New (
    provider As IDbSchemaProvider
)

Parameters

provider
Type: SchemaExplorerIDbSchemaProvider
See Also

Reference

CachedSchemaProviderProxy Class
SchemaExplorer Namespace


CachedSchemaProviderProxy Properties

The CachedSchemaProviderProxy type exposes the following members.

Properties
 | Name | Description
Public property | ConnectionString |
Public property | ConnectionStringEditor |
Public property | Description |
Public property | EditorAvailable |
Public property | Name |
Public property | Provider |
Top
See Also

Reference

CachedSchemaProviderProxy Class
SchemaExplorer Namespace


CachedSchemaProviderProxy.ConnectionString Property

CachedSchemaProviderProxyConnectionString Property

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string ConnectionString { get; }
Public ReadOnly Property ConnectionString As String
    Get

Property Value

Type: String

Implements

IDbConnectionStringEditorConnectionString
See Also

Reference

CachedSchemaProviderProxy Class
SchemaExplorer Namespace


CachedSchemaProviderProxy.ConnectionStringEditor Property

CachedSchemaProviderProxyConnectionStringEditor Property

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public IDbConnectionStringEditor ConnectionStringEditor { get; }
Public ReadOnly Property ConnectionStringEditor As IDbConnectionStringEditor
    Get

Property Value

Type: IDbConnectionStringEditor
See Also

Reference

CachedSchemaProviderProxy Class
SchemaExplorer Namespace


CachedSchemaProviderProxy.Description Property

CachedSchemaProviderProxyDescription Property

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string Description { get; }
Public ReadOnly Property Description As String
    Get

Property Value

Type: String

Implements

IDbSchemaProviderDescription
See Also

Reference

CachedSchemaProviderProxy Class
SchemaExplorer Namespace


CachedSchemaProviderProxy.EditorAvailable Property

CachedSchemaProviderProxyEditorAvailable Property

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool EditorAvailable { get; }
Public ReadOnly Property EditorAvailable As Boolean
    Get

Property Value

Type: Boolean

Implements

IDbConnectionStringEditorEditorAvailable
See Also

Reference

CachedSchemaProviderProxy Class
SchemaExplorer Namespace


CachedSchemaProviderProxy.Name Property

CachedSchemaProviderProxyName Property

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get

Property Value

Type: String
See Also

Reference

CachedSchemaProviderProxy Class
SchemaExplorer Namespace


CachedSchemaProviderProxy.Provider Property

CachedSchemaProviderProxyProvider Property

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public IDbSchemaProvider Provider { get; }
Public ReadOnly Property Provider As IDbSchemaProvider
    Get

Property Value

Type: IDbSchemaProvider
See Also

Reference

CachedSchemaProviderProxy Class
SchemaExplorer Namespace


CachedSchemaProviderProxy Methods

The CachedSchemaProviderProxy type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCommandParameters |
Public method | GetCommandResultSchemas |
Public method | GetCommands |
Public method | GetCommandText |
Public method | GetDatabaseName |
Public method | GetExtendedProperties |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetTableColumns |
Public method | GetTableData |
Public method | GetTableIndexes |
Public method | GetTableKeys |
Public method | GetTablePrimaryKey |
Public method | GetTables |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetViewColumns |
Public method | GetViewData |
Public method | GetViews |
Public method | GetViewText |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetExtendedProperties |
Public method | ShowEditor |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CachedSchemaProviderProxy Class
SchemaExplorer Namespace


CachedSchemaProviderProxy.GetCommandParameters Method

CachedSchemaProviderProxyGetCommandParameters Method

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ParameterSchema[] GetCommandParameters(
    string connectionString,
    CommandSchema command
)
Public Function GetCommandParameters (
    connectionString As String,
    command As CommandSchema
) As ParameterSchema()

Parameters

connectionString
Type: SystemString
command
Type: SchemaExplorerCommandSchema

Return Value

Type: ParameterSchema

Implements

IDbSchemaProviderGetCommandParameters(String, CommandSchema)
See Also

Reference

CachedSchemaProviderProxy Class
SchemaExplorer Namespace


CachedSchemaProviderProxy.GetCommandResultSchemas Method

CachedSchemaProviderProxyGetCommandResultSchemas Method

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CommandResultSchema[] GetCommandResultSchemas(
    string connectionString,
    CommandSchema command
)
Public Function GetCommandResultSchemas (
    connectionString As String,
    command As CommandSchema
) As CommandResultSchema()

Parameters

connectionString
Type: SystemString
command
Type: SchemaExplorerCommandSchema

Return Value

Type: CommandResultSchema

Implements

IDbSchemaProviderGetCommandResultSchemas(String, CommandSchema)
See Also

Reference

CachedSchemaProviderProxy Class
SchemaExplorer Namespace


CachedSchemaProviderProxy.GetCommands Method

CachedSchemaProviderProxyGetCommands Method

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CommandSchema[] GetCommands(
    string connectionString,
    DatabaseSchema database
)
Public Function GetCommands (
    connectionString As String,
    database As DatabaseSchema
) As CommandSchema()

Parameters

connectionString
Type: SystemString
database
Type: SchemaExplorerDatabaseSchema

Return Value

Type: CommandSchema

Implements

IDbSchemaProviderGetCommands(String, DatabaseSchema)
See Also

Reference

CachedSchemaProviderProxy Class
SchemaExplorer Namespace


CachedSchemaProviderProxy.GetCommandText Method

CachedSchemaProviderProxyGetCommandText Method

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string GetCommandText(
    string connectionString,
    CommandSchema command
)
Public Function GetCommandText (
    connectionString As String,
    command As CommandSchema
) As String

Parameters

connectionString
Type: SystemString
command
Type: SchemaExplorerCommandSchema

Return Value

Type: String

Implements

IDbSchemaProviderGetCommandText(String, CommandSchema)
See Also

Reference

CachedSchemaProviderProxy Class
SchemaExplorer Namespace


CachedSchemaProviderProxy.GetDatabaseName Method

CachedSchemaProviderProxyGetDatabaseName Method

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string GetDatabaseName(
    string connectionString
)
Public Function GetDatabaseName (
    connectionString As String
) As String

Parameters

connectionString
Type: SystemString

Return Value

Type: String

Implements

IDbSchemaProviderGetDatabaseName(String)
See Also

Reference

CachedSchemaProviderProxy Class
SchemaExplorer Namespace


CachedSchemaProviderProxy.GetExtendedProperties Method

CachedSchemaProviderProxyGetExtendedProperties Method

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ExtendedProperty[] GetExtendedProperties(
    string connectionString,
    SchemaObjectBase schemaObject
)
Public Function GetExtendedProperties (
    connectionString As String,
    schemaObject As SchemaObjectBase
) As ExtendedProperty()

Parameters

connectionString
Type: SystemString
schemaObject
Type: SchemaExplorerSchemaObjectBase

Return Value

Type: ExtendedProperty

Implements

IDbSchemaProviderGetExtendedProperties(String, SchemaObjectBase)
See Also

Reference

CachedSchemaProviderProxy Class
SchemaExplorer Namespace


CachedSchemaProviderProxy.GetTableColumns Method

CachedSchemaProviderProxyGetTableColumns Method

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ColumnSchema[] GetTableColumns(
    string connectionString,
    TableSchema table
)
Public Function GetTableColumns (
    connectionString As String,
    table As TableSchema
) As ColumnSchema()

Parameters

connectionString
Type: SystemString
table
Type: SchemaExplorerTableSchema

Return Value

Type: ColumnSchema

Implements

IDbSchemaProviderGetTableColumns(String, TableSchema)
See Also

Reference

CachedSchemaProviderProxy Class
SchemaExplorer Namespace


CachedSchemaProviderProxy.GetTableData Method

CachedSchemaProviderProxyGetTableData Method

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public DataTable GetTableData(
    string connectionString,
    TableSchema table
)
Public Function GetTableData (
    connectionString As String,
    table As TableSchema
) As DataTable

Parameters

connectionString
Type: SystemString
table
Type: SchemaExplorerTableSchema

Return Value

Type: DataTable

Implements

IDbSchemaProviderGetTableData(String, TableSchema)
See Also

Reference

CachedSchemaProviderProxy Class
SchemaExplorer Namespace


CachedSchemaProviderProxy.GetTableIndexes Method

CachedSchemaProviderProxyGetTableIndexes Method

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public IndexSchema[] GetTableIndexes(
    string connectionString,
    TableSchema table
)
Public Function GetTableIndexes (
    connectionString As String,
    table As TableSchema
) As IndexSchema()

Parameters

connectionString
Type: SystemString
table
Type: SchemaExplorerTableSchema

Return Value

Type: IndexSchema

Implements

IDbSchemaProviderGetTableIndexes(String, TableSchema)
See Also

Reference

CachedSchemaProviderProxy Class
SchemaExplorer Namespace


CachedSchemaProviderProxy.GetTableKeys Method

CachedSchemaProviderProxyGetTableKeys Method

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public TableKeySchema[] GetTableKeys(
    string connectionString,
    TableSchema table
)
Public Function GetTableKeys (
    connectionString As String,
    table As TableSchema
) As TableKeySchema()

Parameters

connectionString
Type: SystemString
table
Type: SchemaExplorerTableSchema

Return Value

Type: TableKeySchema

Implements

IDbSchemaProviderGetTableKeys(String, TableSchema)
See Also

Reference

CachedSchemaProviderProxy Class
SchemaExplorer Namespace


CachedSchemaProviderProxy.GetTablePrimaryKey Method

CachedSchemaProviderProxyGetTablePrimaryKey Method

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public PrimaryKeySchema GetTablePrimaryKey(
    string connectionString,
    TableSchema table
)
Public Function GetTablePrimaryKey (
    connectionString As String,
    table As TableSchema
) As PrimaryKeySchema

Parameters

connectionString
Type: SystemString
table
Type: SchemaExplorerTableSchema

Return Value

Type: PrimaryKeySchema

Implements

IDbSchemaProviderGetTablePrimaryKey(String, TableSchema)
See Also

Reference

CachedSchemaProviderProxy Class
SchemaExplorer Namespace


CachedSchemaProviderProxy.GetTables Method

CachedSchemaProviderProxyGetTables Method

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public TableSchema[] GetTables(
    string connectionString,
    DatabaseSchema database
)
Public Function GetTables (
    connectionString As String,
    database As DatabaseSchema
) As TableSchema()

Parameters

connectionString
Type: SystemString
database
Type: SchemaExplorerDatabaseSchema

Return Value

Type: TableSchema

Implements

IDbSchemaProviderGetTables(String, DatabaseSchema)
See Also

Reference

CachedSchemaProviderProxy Class
SchemaExplorer Namespace


CachedSchemaProviderProxy.GetViewColumns Method

CachedSchemaProviderProxyGetViewColumns Method

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ViewColumnSchema[] GetViewColumns(
    string connectionString,
    ViewSchema view
)
Public Function GetViewColumns (
    connectionString As String,
    view As ViewSchema
) As ViewColumnSchema()

Parameters

connectionString
Type: SystemString
view
Type: SchemaExplorerViewSchema

Return Value

Type: ViewColumnSchema

Implements

IDbSchemaProviderGetViewColumns(String, ViewSchema)
See Also

Reference

CachedSchemaProviderProxy Class
SchemaExplorer Namespace


CachedSchemaProviderProxy.GetViewData Method

CachedSchemaProviderProxyGetViewData Method

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public DataTable GetViewData(
    string connectionString,
    ViewSchema view
)
Public Function GetViewData (
    connectionString As String,
    view As ViewSchema
) As DataTable

Parameters

connectionString
Type: SystemString
view
Type: SchemaExplorerViewSchema

Return Value

Type: DataTable

Implements

IDbSchemaProviderGetViewData(String, ViewSchema)
See Also

Reference

CachedSchemaProviderProxy Class
SchemaExplorer Namespace


CachedSchemaProviderProxy.GetViews Method

CachedSchemaProviderProxyGetViews Method

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ViewSchema[] GetViews(
    string connectionString,
    DatabaseSchema database
)
Public Function GetViews (
    connectionString As String,
    database As DatabaseSchema
) As ViewSchema()

Parameters

connectionString
Type: SystemString
database
Type: SchemaExplorerDatabaseSchema

Return Value

Type: ViewSchema

Implements

IDbSchemaProviderGetViews(String, DatabaseSchema)
See Also

Reference

CachedSchemaProviderProxy Class
SchemaExplorer Namespace


CachedSchemaProviderProxy.GetViewText Method

CachedSchemaProviderProxyGetViewText Method

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string GetViewText(
    string connectionString,
    ViewSchema view
)
Public Function GetViewText (
    connectionString As String,
    view As ViewSchema
) As String

Parameters

connectionString
Type: SystemString
view
Type: SchemaExplorerViewSchema

Return Value

Type: String

Implements

IDbSchemaProviderGetViewText(String, ViewSchema)
See Also

Reference

CachedSchemaProviderProxy Class
SchemaExplorer Namespace


CachedSchemaProviderProxy.SetExtendedProperties Method

CachedSchemaProviderProxySetExtendedProperties Method

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void SetExtendedProperties(
    string connectionString,
    SchemaObjectBase schemaObject
)
Public Sub SetExtendedProperties (
    connectionString As String,
    schemaObject As SchemaObjectBase
)

Parameters

connectionString
Type: SystemString
schemaObject
Type: SchemaExplorerSchemaObjectBase

Implements

IDbSchemaProviderSetExtendedProperties(String, SchemaObjectBase)
See Also

Reference

CachedSchemaProviderProxy Class
SchemaExplorer Namespace


CachedSchemaProviderProxy.ShowEditor Method

CachedSchemaProviderProxyShowEditor Method

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool ShowEditor(
    string currentConnectionString
)
Public Function ShowEditor (
    currentConnectionString As String
) As Boolean

Parameters

currentConnectionString
Type: SystemString

Return Value

Type: Boolean

Implements

IDbConnectionStringEditorShowEditor(String)
See Also

Reference

CachedSchemaProviderProxy Class
SchemaExplorer Namespace


ColumnSchema Class

Provides information about a table column.
Inheritance Hierarchy
SystemObject
NamedObjectBase
SchemaExplorerSchemaObjectBase
SchemaExplorerDataObjectBase
SchemaExplorerColumnSchema
SchemaExplorerMemberColumnSchema

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
public class ColumnSchema : DataObjectBase,
    IColumnSchema, IDataObject, ISchemaObject
<SerializableAttribute>
Public Class ColumnSchema
    Inherits DataObjectBase
    Implements IColumnSchema, IDataObject, ISchemaObject

The ColumnSchema type exposes the following members.

Constructors
 | Name | Description
Public method | ColumnSchema(TableSchema, String, DbType, String, Int32, Byte, Int32, Boolean) | Creates a new instance of the ColumnSchema object.
Public method | ColumnSchema(TableSchema, String, DbType, String, Int32, Byte, Int32, Boolean, ExtendedProperty) | Creates a new instance of the ColumnSchema object.
Top
Properties
 | Name | Description
Public property | AllowDBNull | Whether or not the data object allows null values. (Inherited from DataObjectBase.)
Public property | Database | Allows access to the DatabaseSchema object that contains this schema object. (Inherited from SchemaObjectBase.)
Public property | DataType | The data type of a (column) parameter is specific to the .NET Framework data provider. Specifying the type converts the value of the Parameter to the data provider Type before passing the value to the data source. see also: http://msdn.microsoft.com/en-us/library/system.data.dbtype.aspx example: DbType.AnsiString (Inherited from DataObjectBase.)
Public property | DateCreated | Returns the date this table was created. (Inherited from SchemaObjectBase.)
Public property | DeepLoad | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from SchemaObjectBase.)
Public property | Description | The description of the object. (Inherited from SchemaObjectBase.)
Public property | ExtendedProperties | Used to store any additional information about the schema object. (Inherited from SchemaObjectBase.)
Public property | FullName | Returns the owner and name. (Inherited from DataObjectBase.)
Public property | IncludeFunctions | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from SchemaObjectBase.)
Public property | IsForeignKeyMember | Whether or not the column is a foreign key member.
Public property | IsPrimaryKeyMember | Whether or not the column is a primary key member.
Public property | IsUnique | Whether or not this column is unique.
Public property | NativeType | This is the native data type from the database. example: nvarchar (Inherited from DataObjectBase.)
Public property | Parent | The Parent Schema Object. (Inherited from DataObjectBase.)
Public property | Precision | The precision of the data object. (Inherited from DataObjectBase.)
Public property | Scale | The scale of the data object. (Inherited from DataObjectBase.)
Public property | Size | The size of the data object. (Inherited from DataObjectBase.)
Public property | SortName | Gets the name used to sort in 'Name (Parent)' format. (Inherited from DataObjectBase.)
Public property | SystemType | The System Type that is resolved from DataType. example: typeof(System.String) (Inherited from DataObjectBase.)
Public property | Table | The table that contains this column.
Top
Methods
 | Name | Description
Public method | Equals | Determines if another view column is the same as this view column. (Inherited from DataObjectBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns a hashcode based on the database, view and name of the view column. (Inherited from DataObjectBase.)
Public method | GetLoadedExtendedProperties | Gets the existing ExtendedProperties without causing a lazy load. (Inherited from SchemaObjectBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MarkLoaded | (Inherited from SchemaObjectBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh | Used to refresh this instance. (Inherited from DataObjectBase.)
Public method | ToString | Returns the name of the column. (Inherited from DataObjectBase.)
Top
Fields
 | Name | Description
Protected field | _allowDBNull | (Inherited from DataObjectBase.)
Protected field | _database | (Inherited from SchemaObjectBase.)
Protected field | _dataType | (Inherited from DataObjectBase.)
Protected field | _dateCreated | (Inherited from SchemaObjectBase.)
Protected field | _defaultExtendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _extendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _gotExtendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _nativeType | (Inherited from DataObjectBase.)
Protected field | _parent | (Inherited from DataObjectBase.)
Protected field | _precision | (Inherited from DataObjectBase.)
Protected field | _scale | (Inherited from DataObjectBase.)
Protected field | _size | (Inherited from DataObjectBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Selected | Determines if the specified item is selected using the rules defined in SchemaSelector. (Defined by SchemaSelectorExtensions.)
Top
See Also

Reference

SchemaExplorer Namespace


ColumnSchema Constructor

Overload List
 | Name | Description
Public method | ColumnSchema(TableSchema, String, DbType, String, Int32, Byte, Int32, Boolean) | Creates a new instance of the ColumnSchema object.
Public method | ColumnSchema(TableSchema, String, DbType, String, Int32, Byte, Int32, Boolean, ExtendedProperty) | Creates a new instance of the ColumnSchema object.
Top
See Also

Reference

ColumnSchema Class
SchemaExplorer Namespace


ColumnSchema Constructor (TableSchema, String, DbType, String, Int32, Byte, Int32, Boolean)

Creates a new instance of the ColumnSchema object.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ColumnSchema(
    TableSchema table,
    string name,
    DbType dataType,
    string nativeType,
    int size,
    byte precision,
    int scale,
    bool allowDBNull
)
Public Sub New (
    table As TableSchema,
    name As String,
    dataType As DbType,
    nativeType As String,
    size As Integer,
    precision As Byte,
    scale As Integer,
    allowDBNull As Boolean
)

Parameters

table
Type: SchemaExplorerTableSchema
The table that the column belongs to.
name
Type: SystemString
The name of the column.
dataType
Type: System.DataDbType
The columns data type.
nativeType
Type: SystemString
The columns native type.
size
Type: SystemInt32
The size of the column.
precision
Type: SystemByte
The precision of the column.
scale
Type: SystemInt32
The scale of the column.
allowDBNull
Type: SystemBoolean
Whether the column allows null values.
See Also

Reference

ColumnSchema Class
ColumnSchema Overload
SchemaExplorer Namespace


ColumnSchema Constructor (TableSchema, String, DbType, String, Int32, Byte, Int32, Boolean, ExtendedProperty[])

ColumnSchema Constructor (TableSchema, String, DbType, String, Int32, Byte, Int32, Boolean, ExtendedProperty)

Creates a new instance of the ColumnSchema object.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ColumnSchema(
    TableSchema table,
    string name,
    DbType dataType,
    string nativeType,
    int size,
    byte precision,
    int scale,
    bool allowDBNull,
    ExtendedProperty[] extendedProperties
)
Public Sub New (
    table As TableSchema,
    name As String,
    dataType As DbType,
    nativeType As String,
    size As Integer,
    precision As Byte,
    scale As Integer,
    allowDBNull As Boolean,
    extendedProperties As ExtendedProperty()
)

Parameters

table
Type: SchemaExplorerTableSchema
The table that the column belongs to.
name
Type: SystemString
The name of the column.
dataType
Type: System.DataDbType
The columns data type.
nativeType
Type: SystemString
The columns native type.
size
Type: SystemInt32
The size of the column.
precision
Type: SystemByte
The precision of the column.
scale
Type: SystemInt32
The scale of the column.
allowDBNull
Type: SystemBoolean
Whether the column allows null values.
extendedProperties
Type: SchemaExplorerExtendedProperty
The array of extended properties for the column.
See Also

Reference

ColumnSchema Class
ColumnSchema Overload
SchemaExplorer Namespace


ColumnSchema Properties

The ColumnSchema type exposes the following members.

Properties
 | Name | Description
Public property | AllowDBNull | Whether or not the data object allows null values. (Inherited from DataObjectBase.)
Public property | Database | Allows access to the DatabaseSchema object that contains this schema object. (Inherited from SchemaObjectBase.)
Public property | DataType | The data type of a (column) parameter is specific to the .NET Framework data provider. Specifying the type converts the value of the Parameter to the data provider Type before passing the value to the data source. see also: http://msdn.microsoft.com/en-us/library/system.data.dbtype.aspx example: DbType.AnsiString (Inherited from DataObjectBase.)
Public property | DateCreated | Returns the date this table was created. (Inherited from SchemaObjectBase.)
Public property | DeepLoad | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from SchemaObjectBase.)
Public property | Description | The description of the object. (Inherited from SchemaObjectBase.)
Public property | ExtendedProperties | Used to store any additional information about the schema object. (Inherited from SchemaObjectBase.)
Public property | FullName | Returns the owner and name. (Inherited from DataObjectBase.)
Public property | IncludeFunctions | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from SchemaObjectBase.)
Public property | IsForeignKeyMember | Whether or not the column is a foreign key member.
Public property | IsPrimaryKeyMember | Whether or not the column is a primary key member.
Public property | IsUnique | Whether or not this column is unique.
Public property | NativeType | This is the native data type from the database. example: nvarchar (Inherited from DataObjectBase.)
Public property | Parent | The Parent Schema Object. (Inherited from DataObjectBase.)
Public property | Precision | The precision of the data object. (Inherited from DataObjectBase.)
Public property | Scale | The scale of the data object. (Inherited from DataObjectBase.)
Public property | Size | The size of the data object. (Inherited from DataObjectBase.)
Public property | SortName | Gets the name used to sort in 'Name (Parent)' format. (Inherited from DataObjectBase.)
Public property | SystemType | The System Type that is resolved from DataType. example: typeof(System.String) (Inherited from DataObjectBase.)
Public property | Table | The table that contains this column.
Top
See Also

Reference

ColumnSchema Class
SchemaExplorer Namespace


ColumnSchema.IsForeignKeyMember Property

ColumnSchemaIsForeignKeyMember Property

Whether or not the column is a foreign key member.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual bool IsForeignKeyMember { get; }
Public Overridable ReadOnly Property IsForeignKeyMember As Boolean
    Get

Property Value

Type: Boolean

Implements

IColumnSchemaIsForeignKeyMember
See Also

Reference

ColumnSchema Class
SchemaExplorer Namespace


ColumnSchema.IsPrimaryKeyMember Property

ColumnSchemaIsPrimaryKeyMember Property

Whether or not the column is a primary key member.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual bool IsPrimaryKeyMember { get; }
Public Overridable ReadOnly Property IsPrimaryKeyMember As Boolean
    Get

Property Value

Type: Boolean

Implements

IColumnSchemaIsPrimaryKeyMember
See Also

Reference

ColumnSchema Class
SchemaExplorer Namespace


ColumnSchema.IsUnique Property

ColumnSchemaIsUnique Property

Whether or not this column is unique.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual bool IsUnique { get; }
Public Overridable ReadOnly Property IsUnique As Boolean
    Get

Property Value

Type: Boolean

Implements

IColumnSchemaIsUnique
See Also

Reference

ColumnSchema Class
SchemaExplorer Namespace


ColumnSchema.Table Property

ColumnSchemaTable Property

The table that contains this column.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual TableSchema Table { get; }
Public Overridable ReadOnly Property Table As TableSchema
    Get

Property Value

Type: TableSchema
See Also

Reference

ColumnSchema Class
SchemaExplorer Namespace


ColumnSchema Methods

The ColumnSchema type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines if another view column is the same as this view column. (Inherited from DataObjectBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns a hashcode based on the database, view and name of the view column. (Inherited from DataObjectBase.)
Public method | GetLoadedExtendedProperties | Gets the existing ExtendedProperties without causing a lazy load. (Inherited from SchemaObjectBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MarkLoaded | (Inherited from SchemaObjectBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh | Used to refresh this instance. (Inherited from DataObjectBase.)
Public method | ToString | Returns the name of the column. (Inherited from DataObjectBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Selected | Determines if the specified item is selected using the rules defined in SchemaSelector. (Defined by SchemaSelectorExtensions.)
Top
See Also

Reference

ColumnSchema Class
SchemaExplorer Namespace


ColumnSchema Fields

The ColumnSchema type exposes the following members.

Fields
 | Name | Description
Protected field | _allowDBNull | (Inherited from DataObjectBase.)
Protected field | _database | (Inherited from SchemaObjectBase.)
Protected field | _dataType | (Inherited from DataObjectBase.)
Protected field | _dateCreated | (Inherited from SchemaObjectBase.)
Protected field | _defaultExtendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _extendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _gotExtendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _nativeType | (Inherited from DataObjectBase.)
Protected field | _parent | (Inherited from DataObjectBase.)
Protected field | _precision | (Inherited from DataObjectBase.)
Protected field | _scale | (Inherited from DataObjectBase.)
Protected field | _size | (Inherited from DataObjectBase.)
Top
See Also

Reference

ColumnSchema Class
SchemaExplorer Namespace


ColumnSchemaCollection Class

Implements a strongly typed collection of ColumnSchema elements.
Inheritance Hierarchy
SystemObject
ObservableListColumnSchema
NamedObjectCollectionColumnSchema
SchemaExplorerSchemaObjectCollection ColumnSchema
SchemaExplorerDataObjectBaseCollection ColumnSchema
SchemaExplorerColumnSchemaCollection

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
public class ColumnSchemaCollection : DataObjectBaseCollection<ColumnSchema>
<SerializableAttribute>
Public Class ColumnSchemaCollection
    Inherits DataObjectBaseCollection(Of ColumnSchema)

The ColumnSchemaCollection type exposes the following members.

Constructors
 | Name | Description
Public method | ColumnSchemaCollection | Initializes a new instance of the ColumnSchemaCollection class.
Public method | ColumnSchemaCollection(IEnumerableColumnSchema) | Initializes a new instance of the ColumnSchemaCollection class.
Public method | ColumnSchemaCollection(Int32) | Initializes a new instance of the ColumnSchemaCollection class.
Top
Methods
 | Name | Description
Public method | Clone | (Inherited from SchemaObjectCollectionT.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh | (Inherited from SchemaObjectCollectionT.)
Public method | ToString | (Inherited from SchemaObjectCollectionT.)
Top
Remarks
ColumnSchemaCollection provides an DataObjectBaseCollectionT that is strongly typed for ColumnSchema elements.
See Also

Reference

SchemaExplorer Namespace


ColumnSchemaCollection Constructor

Overload List
 | Name | Description
Public method | ColumnSchemaCollection | Initializes a new instance of the ColumnSchemaCollection class.
Public method | ColumnSchemaCollection(IEnumerableColumnSchema) | Initializes a new instance of the ColumnSchemaCollection class.
Public method | ColumnSchemaCollection(Int32) | Initializes a new instance of the ColumnSchemaCollection class.
Top
See Also

Reference

ColumnSchemaCollection Class
SchemaExplorer Namespace


ColumnSchemaCollection Constructor

Initializes a new instance of the ColumnSchemaCollection class.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ColumnSchemaCollection()
Public Sub New
See Also

Reference

ColumnSchemaCollection Class
ColumnSchemaCollection Overload
SchemaExplorer Namespace


ColumnSchemaCollection Constructor (IEnumerable(ColumnSchema))

ColumnSchemaCollection Constructor (IEnumerableColumnSchema)

Initializes a new instance of the ColumnSchemaCollection class.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ColumnSchemaCollection(
    IEnumerable<ColumnSchema> collection
)
Public Sub New (
    collection As IEnumerable(Of ColumnSchema)
)

Parameters

collection
Type: System.Collections.GenericIEnumerable ColumnSchema
The collection from which the elements are copied.
See Also

Reference

ColumnSchemaCollection Class
ColumnSchemaCollection Overload
SchemaExplorer Namespace


ColumnSchemaCollection Constructor (Int32)

Initializes a new instance of the ColumnSchemaCollection class.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ColumnSchemaCollection(
    int capacity
)
Public Sub New (
    capacity As Integer
)

Parameters

capacity
Type: SystemInt32
The number of elements that the new list can initially store.
See Also

Reference

ColumnSchemaCollection Class
ColumnSchemaCollection Overload
SchemaExplorer Namespace


ColumnSchemaCollection Methods

The ColumnSchemaCollection type exposes the following members.

Methods
 | Name | Description
Public method | Clone | (Inherited from SchemaObjectCollectionT.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh | (Inherited from SchemaObjectCollectionT.)
Public method | ToString | (Inherited from SchemaObjectCollectionT.)
Top
See Also

Reference

ColumnSchemaCollection Class
SchemaExplorer Namespace


CommandResultColumnSchema Class

Provides information about a command result column.
Inheritance Hierarchy
SystemObject
NamedObjectBase
SchemaExplorerSchemaObjectBase
SchemaExplorerDataObjectBase
SchemaExplorerCommandResultColumnSchema

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
public class CommandResultColumnSchema : DataObjectBase,
    ICommandResultColumnSchema, IDataObject, ISchemaObject
<SerializableAttribute>
Public Class CommandResultColumnSchema
    Inherits DataObjectBase
    Implements ICommandResultColumnSchema, IDataObject, ISchemaObject

The CommandResultColumnSchema type exposes the following members.

Constructors
 | Name | Description
Public method | CommandResultColumnSchema(CommandSchema, String, DbType, String, Int32, Byte, Int32, Boolean) | Creates a new instance of the CommandResultColumnSchema object.
Public method | CommandResultColumnSchema(CommandSchema, String, DbType, String, Int32, Byte, Int32, Boolean, ExtendedProperty) | Creates a new instance of the CommandResultColumnSchema object.
Top
Properties
 | Name | Description
Public property | AllowDBNull | Whether or not the data object allows null values. (Inherited from DataObjectBase.)
Public property | Command | The command that contains this column.
Public property | Database | Allows access to the DatabaseSchema object that contains this schema object. (Inherited from SchemaObjectBase.)
Public property | DataType | The data type of a (column) parameter is specific to the .NET Framework data provider. Specifying the type converts the value of the Parameter to the data provider Type before passing the value to the data source. see also: http://msdn.microsoft.com/en-us/library/system.data.dbtype.aspx example: DbType.AnsiString (Inherited from DataObjectBase.)
Public property | DateCreated | Returns the date this table was created. (Inherited from SchemaObjectBase.)
Public property | DeepLoad | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from SchemaObjectBase.)
Public property | Description | The description of the object. (Inherited from SchemaObjectBase.)
Public property | ExtendedProperties | Used to store any additional information about the schema object. (Inherited from SchemaObjectBase.)
Public property | FullName | Returns the owner and name. (Inherited from DataObjectBase.)
Public property | IncludeFunctions | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from SchemaObjectBase.)
Public property | NativeType | This is the native data type from the database. example: nvarchar (Inherited from DataObjectBase.)
Public property | Parent | The Parent Schema Object. (Inherited from DataObjectBase.)
Public property | Precision | The precision of the data object. (Inherited from DataObjectBase.)
Public property | Scale | The scale of the data object. (Inherited from DataObjectBase.)
Public property | Size | The size of the data object. (Inherited from DataObjectBase.)
Public property | SortName | Gets the name used to sort in 'Name (Parent)' format. (Inherited from DataObjectBase.)
Public property | SystemType | The System Type that is resolved from DataType. example: typeof(System.String) (Inherited from DataObjectBase.)
Top
Methods
 | Name | Description
Public method | Equals | Determines if another view column is the same as this view column. (Inherited from DataObjectBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns a hashcode based on the database, view and name of the view column. (Inherited from DataObjectBase.)
Public method | GetLoadedExtendedProperties | Gets the existing ExtendedProperties without causing a lazy load. (Inherited from SchemaObjectBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MarkLoaded | (Inherited from SchemaObjectBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh | Used to refresh this instance. (Inherited from DataObjectBase.)
Public method | ToString | Returns the name of the column. (Inherited from DataObjectBase.)
Top
Fields
 | Name | Description
Protected field | _allowDBNull | (Inherited from DataObjectBase.)
Protected field | _database | (Inherited from SchemaObjectBase.)
Protected field | _dataType | (Inherited from DataObjectBase.)
Protected field | _dateCreated | (Inherited from SchemaObjectBase.)
Protected field | _defaultExtendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _extendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _gotExtendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _nativeType | (Inherited from DataObjectBase.)
Protected field | _parent | (Inherited from DataObjectBase.)
Protected field | _precision | (Inherited from DataObjectBase.)
Protected field | _scale | (Inherited from DataObjectBase.)
Protected field | _size | (Inherited from DataObjectBase.)
Top
See Also

Reference

SchemaExplorer Namespace


CommandResultColumnSchema Constructor

Overload List
 | Name | Description
Public method | CommandResultColumnSchema(CommandSchema, String, DbType, String, Int32, Byte, Int32, Boolean) | Creates a new instance of the CommandResultColumnSchema object.
Public method | CommandResultColumnSchema(CommandSchema, String, DbType, String, Int32, Byte, Int32, Boolean, ExtendedProperty) | Creates a new instance of the CommandResultColumnSchema object.
Top
See Also

Reference

CommandResultColumnSchema Class
SchemaExplorer Namespace


CommandResultColumnSchema Constructor (CommandSchema, String, DbType, String, Int32, Byte, Int32, Boolean)

Creates a new instance of the CommandResultColumnSchema object.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CommandResultColumnSchema(
    CommandSchema command,
    string name,
    DbType dataType,
    string nativeType,
    int size,
    byte precision,
    int scale,
    bool allowDBNull
)
Public Sub New (
    command As CommandSchema,
    name As String,
    dataType As DbType,
    nativeType As String,
    size As Integer,
    precision As Byte,
    scale As Integer,
    allowDBNull As Boolean
)

Parameters

command
Type: SchemaExplorerCommandSchema
The command that the column belongs to.
name
Type: SystemString
The name of the column.
dataType
Type: System.DataDbType
The columns data type.
nativeType
Type: SystemString
The columns native type.
size
Type: SystemInt32
The size of the column.
precision
Type: SystemByte
The precision of the column.
scale
Type: SystemInt32
The scale of the column.
allowDBNull
Type: SystemBoolean
Whether the column allows null values.
See Also

Reference

CommandResultColumnSchema Class
CommandResultColumnSchema Overload
SchemaExplorer Namespace


CommandResultColumnSchema Constructor (CommandSchema, String, DbType, String, Int32, Byte, Int32, Boolean, ExtendedProperty[])

CommandResultColumnSchema Constructor (CommandSchema, String, DbType, String, Int32, Byte, Int32, Boolean, ExtendedProperty)

Creates a new instance of the CommandResultColumnSchema object.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CommandResultColumnSchema(
    CommandSchema command,
    string name,
    DbType dataType,
    string nativeType,
    int size,
    byte precision,
    int scale,
    bool allowDBNull,
    ExtendedProperty[] extendedProperties
)
Public Sub New (
    command As CommandSchema,
    name As String,
    dataType As DbType,
    nativeType As String,
    size As Integer,
    precision As Byte,
    scale As Integer,
    allowDBNull As Boolean,
    extendedProperties As ExtendedProperty()
)

Parameters

command
Type: SchemaExplorerCommandSchema
The command that the column belongs to.
name
Type: SystemString
The name of the column.
dataType
Type: System.DataDbType
The columns data type.
nativeType
Type: SystemString
The columns native type.
size
Type: SystemInt32
The size of the column.
precision
Type: SystemByte
The precision of the column.
scale
Type: SystemInt32
The scale of the column.
allowDBNull
Type: SystemBoolean
Whether the column allows null values.
extendedProperties
Type: SchemaExplorerExtendedProperty
The array of extended properties for the column.
See Also

Reference

CommandResultColumnSchema Class
CommandResultColumnSchema Overload
SchemaExplorer Namespace


CommandResultColumnSchema Properties

The CommandResultColumnSchema type exposes the following members.

Properties
 | Name | Description
Public property | AllowDBNull | Whether or not the data object allows null values. (Inherited from DataObjectBase.)
Public property | Command | The command that contains this column.
Public property | Database | Allows access to the DatabaseSchema object that contains this schema object. (Inherited from SchemaObjectBase.)
Public property | DataType | The data type of a (column) parameter is specific to the .NET Framework data provider. Specifying the type converts the value of the Parameter to the data provider Type before passing the value to the data source. see also: http://msdn.microsoft.com/en-us/library/system.data.dbtype.aspx example: DbType.AnsiString (Inherited from DataObjectBase.)
Public property | DateCreated | Returns the date this table was created. (Inherited from SchemaObjectBase.)
Public property | DeepLoad | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from SchemaObjectBase.)
Public property | Description | The description of the object. (Inherited from SchemaObjectBase.)
Public property | ExtendedProperties | Used to store any additional information about the schema object. (Inherited from SchemaObjectBase.)
Public property | FullName | Returns the owner and name. (Inherited from DataObjectBase.)
Public property | IncludeFunctions | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from SchemaObjectBase.)
Public property | NativeType | This is the native data type from the database. example: nvarchar (Inherited from DataObjectBase.)
Public property | Parent | The Parent Schema Object. (Inherited from DataObjectBase.)
Public property | Precision | The precision of the data object. (Inherited from DataObjectBase.)
Public property | Scale | The scale of the data object. (Inherited from DataObjectBase.)
Public property | Size | The size of the data object. (Inherited from DataObjectBase.)
Public property | SortName | Gets the name used to sort in 'Name (Parent)' format. (Inherited from DataObjectBase.)
Public property | SystemType | The System Type that is resolved from DataType. example: typeof(System.String) (Inherited from DataObjectBase.)
Top
See Also

Reference

CommandResultColumnSchema Class
SchemaExplorer Namespace


CommandResultColumnSchema.Command Property

CommandResultColumnSchemaCommand Property

The command that contains this column.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CommandSchema Command { get; }
Public ReadOnly Property Command As CommandSchema
    Get

Property Value

Type: CommandSchema
See Also

Reference

CommandResultColumnSchema Class
SchemaExplorer Namespace


CommandResultColumnSchema Methods

The CommandResultColumnSchema type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines if another view column is the same as this view column. (Inherited from DataObjectBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns a hashcode based on the database, view and name of the view column. (Inherited from DataObjectBase.)
Public method | GetLoadedExtendedProperties | Gets the existing ExtendedProperties without causing a lazy load. (Inherited from SchemaObjectBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MarkLoaded | (Inherited from SchemaObjectBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh | Used to refresh this instance. (Inherited from DataObjectBase.)
Public method | ToString | Returns the name of the column. (Inherited from DataObjectBase.)
Top
See Also

Reference

CommandResultColumnSchema Class
SchemaExplorer Namespace


CommandResultColumnSchema Fields

The CommandResultColumnSchema type exposes the following members.

Fields
 | Name | Description
Protected field | _allowDBNull | (Inherited from DataObjectBase.)
Protected field | _database | (Inherited from SchemaObjectBase.)
Protected field | _dataType | (Inherited from DataObjectBase.)
Protected field | _dateCreated | (Inherited from SchemaObjectBase.)
Protected field | _defaultExtendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _extendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _gotExtendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _nativeType | (Inherited from DataObjectBase.)
Protected field | _parent | (Inherited from DataObjectBase.)
Protected field | _precision | (Inherited from DataObjectBase.)
Protected field | _scale | (Inherited from DataObjectBase.)
Protected field | _size | (Inherited from DataObjectBase.)
Top
See Also

Reference

CommandResultColumnSchema Class
SchemaExplorer Namespace


CommandResultColumnSchemaCollection Class

Implements a strongly typed collection of CommandResultColumnSchema elements.
Inheritance Hierarchy
SystemObject
ObservableListCommandResultColumnSchema
NamedObjectCollectionCommandResultColumnSchema
SchemaExplorerSchemaObjectCollection CommandResultColumnSchema
SchemaExplorerDataObjectBaseCollection CommandResultColumnSchema
SchemaExplorerCommandResultColumnSchemaCollection

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
public class CommandResultColumnSchemaCollection : DataObjectBaseCollection<CommandResultColumnSchema>
<SerializableAttribute>
Public Class CommandResultColumnSchemaCollection
    Inherits DataObjectBaseCollection(Of CommandResultColumnSchema)

The CommandResultColumnSchemaCollection type exposes the following members.

Constructors
 | Name | Description
Public method | CommandResultColumnSchemaCollection | Initializes a new instance of the ColumnSchemaCollection class.
Public method | CommandResultColumnSchemaCollection(IEnumerableCommandResultColumnSchema) | Initializes a new instance of the ColumnSchemaCollection class.
Public method | CommandResultColumnSchemaCollection(Int32) | Initializes a new instance of the ColumnSchemaCollection class.
Top
Methods
 | Name | Description
Public method | Clone | (Inherited from SchemaObjectCollectionT.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh | (Inherited from SchemaObjectCollectionT.)
Public method | ToString | (Inherited from SchemaObjectCollectionT.)
Top
Remarks
CommandResultColumnSchemaCollection provides an DataObjectBaseCollectionT that is strongly typed for CommandResultColumnSchema elements.
See Also

Reference

SchemaExplorer Namespace


CommandResultColumnSchemaCollection Constructor

Overload List
 | Name | Description
Public method | CommandResultColumnSchemaCollection | Initializes a new instance of the ColumnSchemaCollection class.
Public method | CommandResultColumnSchemaCollection(IEnumerableCommandResultColumnSchema) | Initializes a new instance of the ColumnSchemaCollection class.
Public method | CommandResultColumnSchemaCollection(Int32) | Initializes a new instance of the ColumnSchemaCollection class.
Top
See Also

Reference

CommandResultColumnSchemaCollection Class
SchemaExplorer Namespace


CommandResultColumnSchemaCollection Constructor

Initializes a new instance of the ColumnSchemaCollection class.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CommandResultColumnSchemaCollection()
Public Sub New
See Also

Reference

CommandResultColumnSchemaCollection Class
CommandResultColumnSchemaCollection Overload
SchemaExplorer Namespace


CommandResultColumnSchemaCollection Constructor (IEnumerable(CommandResultColumnSchema))

CommandResultColumnSchemaCollection Constructor (IEnumerableCommandResultColumnSchema)

Initializes a new instance of the ColumnSchemaCollection class.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CommandResultColumnSchemaCollection(
    IEnumerable<CommandResultColumnSchema> collection
)
Public Sub New (
    collection As IEnumerable(Of CommandResultColumnSchema)
)

Parameters

collection
Type: System.Collections.GenericIEnumerable CommandResultColumnSchema
The collection from which the elements are copied.
See Also

Reference

CommandResultColumnSchemaCollection Class
CommandResultColumnSchemaCollection Overload
SchemaExplorer Namespace


CommandResultColumnSchemaCollection Constructor (Int32)

Initializes a new instance of the ColumnSchemaCollection class.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CommandResultColumnSchemaCollection(
    int capacity
)
Public Sub New (
    capacity As Integer
)

Parameters

capacity
Type: SystemInt32
The number of elements that the new list can initially store.
See Also

Reference

CommandResultColumnSchemaCollection Class
CommandResultColumnSchemaCollection Overload
SchemaExplorer Namespace


CommandResultColumnSchemaCollection Methods

The CommandResultColumnSchemaCollection type exposes the following members.

Methods
 | Name | Description
Public method | Clone | (Inherited from SchemaObjectCollectionT.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh | (Inherited from SchemaObjectCollectionT.)
Public method | ToString | (Inherited from SchemaObjectCollectionT.)
Top
See Also

Reference

CommandResultColumnSchemaCollection Class
SchemaExplorer Namespace


CommandResultSchema Class

Summary description for CommandResultSchema.
Inheritance Hierarchy
SystemObject
NamedObjectBase
SchemaExplorerSchemaObjectBase
SchemaExplorerSchemaObjectWithOwnerBase
SchemaExplorerTabularObjectBase
SchemaExplorerCommandResultSchema

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
public class CommandResultSchema : TabularObjectBase,
    ICommandResultSchema, ITabularObject, ISchemaObjectWithOwner, ISchemaObject
<SerializableAttribute>
Public Class CommandResultSchema
    Inherits TabularObjectBase
    Implements ICommandResultSchema, ITabularObject, ISchemaObjectWithOwner, ISchemaObject

The CommandResultSchema type exposes the following members.

Constructors
 | Name | Description
Public method | CommandResultSchema(CommandSchema, String, IEnumerableCommandResultColumnSchema) | Initializes a new instance of the CommandResultSchema class
Public method | CommandResultSchema(CommandSchema, String, IEnumerableCommandResultColumnSchema, ExtendedProperty) | Initializes a new instance of the CommandResultSchema class
Top
Properties
 | Name | Description
Public property | Columns | Provides information about the command result columns.
Public property | Command | Provides access to the command that this command result schema belongs to.
Public property | Database | Allows access to the DatabaseSchema object that contains this schema object. (Inherited from SchemaObjectBase.)
Public property | DataObjects | Provides information about the schema objects columns. (Inherited from TabularObjectBase.)
Public property | DateCreated | Returns the date this table was created. (Inherited from SchemaObjectBase.)
Public property | DeepLoad | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from SchemaObjectBase.)
Public property | Description | The description of the object. (Inherited from SchemaObjectBase.)
Public property | ExtendedProperties | Used to store any additional information about the schema object. (Inherited from SchemaObjectBase.)
Public property | FullName | Returns the owner and name of the table. (Inherited from SchemaObjectWithOwnerBase.)
Public property | IncludeFunctions | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from SchemaObjectBase.)
Public property | Item | Index to allow easy access to the columns in this schema object. (Inherited from TabularObjectBase.)
Public property | Owner | Returns the owner of the table. (Inherited from SchemaObjectWithOwnerBase.)
Public property | SortName | Gets the name used to sort in 'Table (Owner)' format. (Inherited from SchemaObjectWithOwnerBase.)
Top
Methods
 | Name | Description
Public method | Equals | Determines if another table is the same as this table. (Inherited from SchemaObjectWithOwnerBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetData | Gets the data contained within the table. (Inherited from TabularObjectBase.)
Public method | GetHashCode | Returns a HashCode based on the database and name of the table. (Inherited from SchemaObjectWithOwnerBase.)
Public method | GetLoadedExtendedProperties | Gets the existing ExtendedProperties without causing a lazy load. (Inherited from SchemaObjectBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MarkLoaded | (Inherited from SchemaObjectBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh | Used to refresh this instance. (Overrides TabularObjectBaseRefresh.)
Public method | ToString | Returns the name of the table. (Inherited from SchemaObjectWithOwnerBase.)
Top
Fields
 | Name | Description
Protected field | _database | (Inherited from SchemaObjectBase.)
Protected field | _dataObjects | (Inherited from TabularObjectBase.)
Protected field | _dateCreated | (Inherited from SchemaObjectBase.)
Protected field | _defaultExtendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _extendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _gotExtendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _owner | (Inherited from SchemaObjectWithOwnerBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Selected | Determines if the specified item is selected using the rules defined in SchemaSelector. (Defined by SchemaSelectorExtensions.)
Top
See Also

Reference

SchemaExplorer Namespace


CommandResultSchema Constructor

Overload List
 | Name | Description
Public method | CommandResultSchema(CommandSchema, String, IEnumerableCommandResultColumnSchema) | Initializes a new instance of the CommandResultSchema class
Public method | CommandResultSchema(CommandSchema, String, IEnumerableCommandResultColumnSchema, ExtendedProperty) | Initializes a new instance of the CommandResultSchema class
Top
See Also

Reference

CommandResultSchema Class
SchemaExplorer Namespace


CommandResultSchema Constructor (CommandSchema, String, IEnumerable(CommandResultColumnSchema))

CommandResultSchema Constructor (CommandSchema, String, IEnumerableCommandResultColumnSchema)

Initializes a new instance of the CommandResultSchema class

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CommandResultSchema(
    CommandSchema command,
    string name,
    IEnumerable<CommandResultColumnSchema> columns
)
Public Sub New (
    command As CommandSchema,
    name As String,
    columns As IEnumerable(Of CommandResultColumnSchema)
)

Parameters

command
Type: SchemaExplorerCommandSchema
The command that the command result schema belongs to.
name
Type: SystemString
The name of this command result schema.
columns
Type: System.Collections.GenericIEnumerable CommandResultColumnSchema
The columns that make up this command result schema.
See Also

Reference

CommandResultSchema Class
CommandResultSchema Overload
SchemaExplorer Namespace


CommandResultSchema Constructor (CommandSchema, String, IEnumerable(CommandResultColumnSchema), ExtendedProperty[])

CommandResultSchema Constructor (CommandSchema, String, IEnumerableCommandResultColumnSchema, ExtendedProperty)

Initializes a new instance of the CommandResultSchema class

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CommandResultSchema(
    CommandSchema command,
    string name,
    IEnumerable<CommandResultColumnSchema> columns,
    ExtendedProperty[] extendedProperties
)
Public Sub New (
    command As CommandSchema,
    name As String,
    columns As IEnumerable(Of CommandResultColumnSchema),
    extendedProperties As ExtendedProperty()
)

Parameters

command
Type: SchemaExplorerCommandSchema
The command that the command result schema belongs to.
name
Type: SystemString
The name of this command result schema.
columns
Type: System.Collections.GenericIEnumerable CommandResultColumnSchema
The columns that make up this command result schema.
extendedProperties
Type: SchemaExplorerExtendedProperty
The array of extended properties for the column.
See Also

Reference

CommandResultSchema Class
CommandResultSchema Overload
SchemaExplorer Namespace


CommandResultSchema Properties

The CommandResultSchema type exposes the following members.

Properties
 | Name | Description
Public property | Columns | Provides information about the command result columns.
Public property | Command | Provides access to the command that this command result schema belongs to.
Public property | Database | Allows access to the DatabaseSchema object that contains this schema object. (Inherited from SchemaObjectBase.)
Public property | DataObjects | Provides information about the schema objects columns. (Inherited from TabularObjectBase.)
Public property | DateCreated | Returns the date this table was created. (Inherited from SchemaObjectBase.)
Public property | DeepLoad | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from SchemaObjectBase.)
Public property | Description | The description of the object. (Inherited from SchemaObjectBase.)
Public property | ExtendedProperties | Used to store any additional information about the schema object. (Inherited from SchemaObjectBase.)
Public property | FullName | Returns the owner and name of the table. (Inherited from SchemaObjectWithOwnerBase.)
Public property | IncludeFunctions | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from SchemaObjectBase.)
Public property | Item | Index to allow easy access to the columns in this schema object. (Inherited from TabularObjectBase.)
Public property | Owner | Returns the owner of the table. (Inherited from SchemaObjectWithOwnerBase.)
Public property | SortName | Gets the name used to sort in 'Table (Owner)' format. (Inherited from SchemaObjectWithOwnerBase.)
Top
See Also

Reference

CommandResultSchema Class
SchemaExplorer Namespace


CommandResultSchema.Columns Property

CommandResultSchemaColumns Property

Provides information about the command result columns.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CommandResultColumnSchemaCollection Columns { get; }
Public ReadOnly Property Columns As CommandResultColumnSchemaCollection
    Get

Property Value

Type: CommandResultColumnSchemaCollection
See Also

Reference

CommandResultSchema Class
SchemaExplorer Namespace


CommandResultSchema.Command Property

CommandResultSchemaCommand Property

Provides access to the command that this command result schema belongs to.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CommandSchema Command { get; }
Public ReadOnly Property Command As CommandSchema
    Get

Property Value

Type: CommandSchema
See Also

Reference

CommandResultSchema Class
SchemaExplorer Namespace


CommandResultSchema Methods

The CommandResultSchema type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines if another table is the same as this table. (Inherited from SchemaObjectWithOwnerBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetData | Gets the data contained within the table. (Inherited from TabularObjectBase.)
Public method | GetHashCode | Returns a HashCode based on the database and name of the table. (Inherited from SchemaObjectWithOwnerBase.)
Public method | GetLoadedExtendedProperties | Gets the existing ExtendedProperties without causing a lazy load. (Inherited from SchemaObjectBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MarkLoaded | (Inherited from SchemaObjectBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh | Used to refresh this instance. (Overrides TabularObjectBaseRefresh.)
Public method | ToString | Returns the name of the table. (Inherited from SchemaObjectWithOwnerBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Selected | Determines if the specified item is selected using the rules defined in SchemaSelector. (Defined by SchemaSelectorExtensions.)
Top
See Also

Reference

CommandResultSchema Class
SchemaExplorer Namespace


CommandResultSchema.Refresh Method

CommandResultSchemaRefresh Method

Used to refresh this instance.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override void Refresh()
Public Overrides Sub Refresh

Implements

ISchemaObjectRefresh
ISchemaObjectRefresh
ISchemaObjectRefresh
See Also

Reference

CommandResultSchema Class
SchemaExplorer Namespace


CommandResultSchema Fields

The CommandResultSchema type exposes the following members.

Fields
 | Name | Description
Protected field | _database | (Inherited from SchemaObjectBase.)
Protected field | _dataObjects | (Inherited from TabularObjectBase.)
Protected field | _dateCreated | (Inherited from SchemaObjectBase.)
Protected field | _defaultExtendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _extendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _gotExtendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _owner | (Inherited from SchemaObjectWithOwnerBase.)
Top
See Also

Reference

CommandResultSchema Class
SchemaExplorer Namespace


CommandResultSchemaCollection Class

Implements a strongly typed collection of CommandResultSchema elements.
Inheritance Hierarchy
SystemObject
ObservableListCommandResultSchema
NamedObjectCollectionCommandResultSchema
SchemaExplorerSchemaObjectCollection CommandResultSchema
SchemaExplorerSchemaObjectWithOwnerCollection CommandResultSchema
SchemaExplorerCommandResultSchemaCollection

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
public class CommandResultSchemaCollection : SchemaObjectWithOwnerCollection<CommandResultSchema>
<SerializableAttribute>
Public Class CommandResultSchemaCollection
    Inherits SchemaObjectWithOwnerCollection(Of CommandResultSchema)

The CommandResultSchemaCollection type exposes the following members.

Constructors
 | Name | Description
Public method | CommandResultSchemaCollection | Initializes a new instance of the CommandResultSchemaCollection class.
Public method | CommandResultSchemaCollection(IEnumerableCommandResultSchema) | Initializes a new instance of the CommandResultSchemaCollection class.
Public method | CommandResultSchemaCollection(Int32) | Initializes a new instance of the CommandResultSchemaCollection class.
Top
Properties
 | Name | Description
Public property | Item | Gets the TableSchema with the specified owner and name. (Inherited from SchemaObjectWithOwnerCollectionT.)
Top
Methods
 | Name | Description
Public method | Clone | (Inherited from SchemaObjectCollectionT.)
Public method | Contains | Determines whether an element is in the collection with the specified owner and name. (Inherited from SchemaObjectWithOwnerCollectionT.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of an item with the specified owner and name. (Inherited from SchemaObjectWithOwnerCollectionT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh | (Inherited from SchemaObjectCollectionT.)
Public method | ToString | (Inherited from SchemaObjectCollectionT.)
Top
Remarks
CommandResultSchemaCollection provides an [!:TabularObjectBaseCollection<T>] that is strongly typed for CommandResultSchema elements.
See Also

Reference

SchemaExplorer Namespace


CommandResultSchemaCollection Constructor

Overload List
 | Name | Description
Public method | CommandResultSchemaCollection | Initializes a new instance of the CommandResultSchemaCollection class.
Public method | CommandResultSchemaCollection(IEnumerableCommandResultSchema) | Initializes a new instance of the CommandResultSchemaCollection class.
Public method | CommandResultSchemaCollection(Int32) | Initializes a new instance of the CommandResultSchemaCollection class.
Top
See Also

Reference

CommandResultSchemaCollection Class
SchemaExplorer Namespace


CommandResultSchemaCollection Constructor

Initializes a new instance of the CommandResultSchemaCollection class.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CommandResultSchemaCollection()
Public Sub New
See Also

Reference

CommandResultSchemaCollection Class
CommandResultSchemaCollection Overload
SchemaExplorer Namespace


CommandResultSchemaCollection Constructor (IEnumerable(CommandResultSchema))

CommandResultSchemaCollection Constructor (IEnumerableCommandResultSchema)

Initializes a new instance of the CommandResultSchemaCollection class.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CommandResultSchemaCollection(
    IEnumerable<CommandResultSchema> collection
)
Public Sub New (
    collection As IEnumerable(Of CommandResultSchema)
)

Parameters

collection
Type: System.Collections.GenericIEnumerable CommandResultSchema
The collection from which the elements are copied.
See Also

Reference

CommandResultSchemaCollection Class
CommandResultSchemaCollection Overload
SchemaExplorer Namespace


CommandResultSchemaCollection Constructor (Int32)

Initializes a new instance of the CommandResultSchemaCollection class.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CommandResultSchemaCollection(
    int capacity
)
Public Sub New (
    capacity As Integer
)

Parameters

capacity
Type: SystemInt32
The number of elements that the new list can initially store.
See Also

Reference

CommandResultSchemaCollection Class
CommandResultSchemaCollection Overload
SchemaExplorer Namespace


CommandResultSchemaCollection Properties

The CommandResultSchemaCollection type exposes the following members.

Properties
 | Name | Description
Public property | Item | Gets the TableSchema with the specified owner and name. (Inherited from SchemaObjectWithOwnerCollectionT.)
Top
See Also

Reference

CommandResultSchemaCollection Class
SchemaExplorer Namespace


CommandResultSchemaCollection Methods

The CommandResultSchemaCollection type exposes the following members.

Methods
 | Name | Description
Public method | Clone | (Inherited from SchemaObjectCollectionT.)
Public method | Contains | Determines whether an element is in the collection with the specified owner and name. (Inherited from SchemaObjectWithOwnerCollectionT.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of an item with the specified owner and name. (Inherited from SchemaObjectWithOwnerCollectionT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh | (Inherited from SchemaObjectCollectionT.)
Public method | ToString | (Inherited from SchemaObjectCollectionT.)
Top
See Also

Reference

CommandResultSchemaCollection Class
SchemaExplorer Namespace


CommandSchema Class

Provides information about a command.
Inheritance Hierarchy
SystemObject
NamedObjectBase
SchemaExplorerSchemaObjectBase
SchemaExplorerSchemaObjectWithOwnerBase
SchemaExplorerCommandSchema

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
public class CommandSchema : SchemaObjectWithOwnerBase,
    ICommandSchema, ISchemaObjectWithOwner, ISchemaObject
<SerializableAttribute>
Public Class CommandSchema
    Inherits SchemaObjectWithOwnerBase
    Implements ICommandSchema, ISchemaObjectWithOwner, ISchemaObject

The CommandSchema type exposes the following members.

Constructors
 | Name | Description
Public method | CommandSchema(DatabaseSchema, String, String, DateTime) | Creates a new instance of the CommandSchema object.
Public method | CommandSchema(DatabaseSchema, String, String, DateTime, ExtendedProperty) | Creates a new instance of the CommandSchema object.
Top
Properties
 | Name | Description
Public property | AllInputParameters | Input and InputOutput parameters for this command.
Public property | AllOutputParameters | Output and InputOutput parameters for this command.
Public property | CommandResults | Provides access to information about the results and column schema information returned when executing this command.
Public property | CommandText | Gets the command text for this command.
Public property | Database | Allows access to the DatabaseSchema object that contains this schema object. (Inherited from SchemaObjectBase.)
Public property | DateCreated | Returns the date this table was created. (Inherited from SchemaObjectBase.)
Public property | DeepLoad | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from SchemaObjectBase.)
Public property | Description | The description of the object. (Inherited from SchemaObjectBase.)
Public property | ExtendedProperties | Used to store any additional information about the schema object. (Inherited from SchemaObjectBase.)
Public property | FullName | Returns the owner and name of the table. (Inherited from SchemaObjectWithOwnerBase.)
Public property | IncludeFunctions | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from SchemaObjectBase.)
Public property | InputOutputParameters | InputOutput parameters for this command.
Public property | InputParameters | Input parameters for this command.
Public property | NonReturnValueParameters | All parameters except the return value parameter.
Public property | OutputParameters | Output parameters for this command.
Public property | Owner | Returns the owner of the table. (Inherited from SchemaObjectWithOwnerBase.)
Public property | Parameters | Parameters for this command.
Public property | ReturnValueParameter | The return value parameter for this command.
Public property | SortName | Gets the name used to sort in 'Table (Owner)' format. (Inherited from SchemaObjectWithOwnerBase.)
Top
Methods
 | Name | Description
Public method | Equals | Determines if another table is the same as this table. (Inherited from SchemaObjectWithOwnerBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns a HashCode based on the database and name of the table. (Inherited from SchemaObjectWithOwnerBase.)
Public method | GetLoadedExtendedProperties | Gets the existing ExtendedProperties without causing a lazy load. (Inherited from SchemaObjectBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MarkLoaded | (Inherited from SchemaObjectBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh | Refresh this instance. (Overrides SchemaObjectBaseRefresh.)
Public method | ToString | Returns the name of the table. (Inherited from SchemaObjectWithOwnerBase.)
Top
Fields
 | Name | Description
Protected field | _database | (Inherited from SchemaObjectBase.)
Protected field | _dateCreated | (Inherited from SchemaObjectBase.)
Protected field | _defaultExtendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _extendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _gotExtendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _owner | (Inherited from SchemaObjectWithOwnerBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Selected | Determines if the specified item is selected using the rules defined in SchemaSelector. (Defined by SchemaSelectorExtensions.)
Top
See Also

Reference

SchemaExplorer Namespace


CommandSchema Constructor

Overload List
 | Name | Description
Public method | CommandSchema(DatabaseSchema, String, String, DateTime) | Creates a new instance of the CommandSchema object.
Public method | CommandSchema(DatabaseSchema, String, String, DateTime, ExtendedProperty) | Creates a new instance of the CommandSchema object.
Top
See Also

Reference

CommandSchema Class
SchemaExplorer Namespace


CommandSchema Constructor (DatabaseSchema, String, String, DateTime)

Creates a new instance of the CommandSchema object.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CommandSchema(
    DatabaseSchema database,
    string name,
    string owner,
    DateTime dateCreated
)
Public Sub New (
    database As DatabaseSchema,
    name As String,
    owner As String,
    dateCreated As DateTime
)

Parameters

database
Type: SchemaExplorerDatabaseSchema
The database that the command belongs to.
name
Type: SystemString
The name of the command.
owner
Type: SystemString
The owner of the command.
dateCreated
Type: SystemDateTime
The date this command was created.
See Also

Reference

CommandSchema Class
CommandSchema Overload
SchemaExplorer Namespace


CommandSchema Constructor (DatabaseSchema, String, String, DateTime, ExtendedProperty[])

CommandSchema Constructor (DatabaseSchema, String, String, DateTime, ExtendedProperty)

Creates a new instance of the CommandSchema object.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CommandSchema(
    DatabaseSchema database,
    string name,
    string owner,
    DateTime dateCreated,
    ExtendedProperty[] extendedProperties
)
Public Sub New (
    database As DatabaseSchema,
    name As String,
    owner As String,
    dateCreated As DateTime,
    extendedProperties As ExtendedProperty()
)

Parameters

database
Type: SchemaExplorerDatabaseSchema
The database that the command belongs to.
name
Type: SystemString
The name of the command.
owner
Type: SystemString
The owner of the command.
dateCreated
Type: SystemDateTime
The date this command was created.
extendedProperties
Type: SchemaExplorerExtendedProperty
The array of extended properties for the command.
See Also

Reference

CommandSchema Class
CommandSchema Overload
SchemaExplorer Namespace


CommandSchema Properties

The CommandSchema type exposes the following members.

Properties
 | Name | Description
Public property | AllInputParameters | Input and InputOutput parameters for this command.
Public property | AllOutputParameters | Output and InputOutput parameters for this command.
Public property | CommandResults | Provides access to information about the results and column schema information returned when executing this command.
Public property | CommandText | Gets the command text for this command.
Public property | Database | Allows access to the DatabaseSchema object that contains this schema object. (Inherited from SchemaObjectBase.)
Public property | DateCreated | Returns the date this table was created. (Inherited from SchemaObjectBase.)
Public property | DeepLoad | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from SchemaObjectBase.)
Public property | Description | The description of the object. (Inherited from SchemaObjectBase.)
Public property | ExtendedProperties | Used to store any additional information about the schema object. (Inherited from SchemaObjectBase.)
Public property | FullName | Returns the owner and name of the table. (Inherited from SchemaObjectWithOwnerBase.)
Public property | IncludeFunctions | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from SchemaObjectBase.)
Public property | InputOutputParameters | InputOutput parameters for this command.
Public property | InputParameters | Input parameters for this command.
Public property | NonReturnValueParameters | All parameters except the return value parameter.
Public property | OutputParameters | Output parameters for this command.
Public property | Owner | Returns the owner of the table. (Inherited from SchemaObjectWithOwnerBase.)
Public property | Parameters | Parameters for this command.
Public property | ReturnValueParameter | The return value parameter for this command.
Public property | SortName | Gets the name used to sort in 'Table (Owner)' format. (Inherited from SchemaObjectWithOwnerBase.)
Top
See Also

Reference

CommandSchema Class
SchemaExplorer Namespace


CommandSchema.AllInputParameters Property

CommandSchemaAllInputParameters Property

Input and InputOutput parameters for this command.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ParameterSchemaCollection AllInputParameters { get; }
Public ReadOnly Property AllInputParameters As ParameterSchemaCollection
    Get

Property Value

Type: ParameterSchemaCollection
See Also

Reference

CommandSchema Class
SchemaExplorer Namespace


CommandSchema.AllOutputParameters Property

CommandSchemaAllOutputParameters Property

Output and InputOutput parameters for this command.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ParameterSchemaCollection AllOutputParameters { get; }
Public ReadOnly Property AllOutputParameters As ParameterSchemaCollection
    Get

Property Value

Type: ParameterSchemaCollection
See Also

Reference

CommandSchema Class
SchemaExplorer Namespace


CommandSchema.CommandResults Property

CommandSchemaCommandResults Property

Provides access to information about the results and column schema information returned when executing this command.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CommandResultSchemaCollection CommandResults { get; }
Public ReadOnly Property CommandResults As CommandResultSchemaCollection
    Get

Property Value

Type: CommandResultSchemaCollection
See Also

Reference

CommandSchema Class
SchemaExplorer Namespace


CommandSchema.CommandText Property

CommandSchemaCommandText Property

Gets the command text for this command.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string CommandText { get; }
Public ReadOnly Property CommandText As String
    Get

Property Value

Type: String

Implements

ICommandSchemaCommandText
See Also

Reference

CommandSchema Class
SchemaExplorer Namespace


CommandSchema.InputOutputParameters Property

CommandSchemaInputOutputParameters Property

InputOutput parameters for this command.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ParameterSchemaCollection InputOutputParameters { get; }
Public ReadOnly Property InputOutputParameters As ParameterSchemaCollection
    Get

Property Value

Type: ParameterSchemaCollection
See Also

Reference

CommandSchema Class
SchemaExplorer Namespace


CommandSchema.InputParameters Property

CommandSchemaInputParameters Property

Input parameters for this command.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ParameterSchemaCollection InputParameters { get; }
Public ReadOnly Property InputParameters As ParameterSchemaCollection
    Get

Property Value

Type: ParameterSchemaCollection
See Also

Reference

CommandSchema Class
SchemaExplorer Namespace


CommandSchema.NonReturnValueParameters Property

CommandSchemaNonReturnValueParameters Property

All parameters except the return value parameter.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ParameterSchemaCollection NonReturnValueParameters { get; }
Public ReadOnly Property NonReturnValueParameters As ParameterSchemaCollection
    Get

Property Value

Type: ParameterSchemaCollection
See Also

Reference

CommandSchema Class
SchemaExplorer Namespace


CommandSchema.OutputParameters Property

CommandSchemaOutputParameters Property

Output parameters for this command.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ParameterSchemaCollection OutputParameters { get; }
Public ReadOnly Property OutputParameters As ParameterSchemaCollection
    Get

Property Value

Type: ParameterSchemaCollection
See Also

Reference

CommandSchema Class
SchemaExplorer Namespace


CommandSchema.Parameters Property

CommandSchemaParameters Property

Parameters for this command.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ParameterSchemaCollection Parameters { get; set; }
Public Property Parameters As ParameterSchemaCollection
    Get
    Set

Property Value

Type: ParameterSchemaCollection
See Also

Reference

CommandSchema Class
SchemaExplorer Namespace


CommandSchema.ReturnValueParameter Property

CommandSchemaReturnValueParameter Property

The return value parameter for this command.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ParameterSchema ReturnValueParameter { get; }
Public ReadOnly Property ReturnValueParameter As ParameterSchema
    Get

Property Value

Type: ParameterSchema
See Also

Reference

CommandSchema Class
SchemaExplorer Namespace


CommandSchema Methods

The CommandSchema type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines if another table is the same as this table. (Inherited from SchemaObjectWithOwnerBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns a HashCode based on the database and name of the table. (Inherited from SchemaObjectWithOwnerBase.)
Public method | GetLoadedExtendedProperties | Gets the existing ExtendedProperties without causing a lazy load. (Inherited from SchemaObjectBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MarkLoaded | (Inherited from SchemaObjectBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh | Refresh this instance. (Overrides SchemaObjectBaseRefresh.)
Public method | ToString | Returns the name of the table. (Inherited from SchemaObjectWithOwnerBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Selected | Determines if the specified item is selected using the rules defined in SchemaSelector. (Defined by SchemaSelectorExtensions.)
Top
See Also

Reference

CommandSchema Class
SchemaExplorer Namespace


CommandSchema.Refresh Method

CommandSchemaRefresh Method

Refresh this instance.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override void Refresh()
Public Overrides Sub Refresh

Implements

ISchemaObjectRefresh
ISchemaObjectRefresh
See Also

Reference

CommandSchema Class
SchemaExplorer Namespace


CommandSchema Fields

The CommandSchema type exposes the following members.

Fields
 | Name | Description
Protected field | _database | (Inherited from SchemaObjectBase.)
Protected field | _dateCreated | (Inherited from SchemaObjectBase.)
Protected field | _defaultExtendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _extendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _gotExtendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _owner | (Inherited from SchemaObjectWithOwnerBase.)
Top
See Also

Reference

CommandSchema Class
SchemaExplorer Namespace


CommandSchemaCollection Class

Implements a strongly typed collection of CommandSchema elements.
Inheritance Hierarchy
SystemObject
ObservableListCommandSchema
NamedObjectCollectionCommandSchema
SchemaExplorerSchemaObjectCollection CommandSchema
SchemaExplorerSchemaObjectWithOwnerCollection CommandSchema
SchemaExplorerCommandSchemaCollection

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
public class CommandSchemaCollection : SchemaObjectWithOwnerCollection<CommandSchema>
<SerializableAttribute>
Public Class CommandSchemaCollection
    Inherits SchemaObjectWithOwnerCollection(Of CommandSchema)

The CommandSchemaCollection type exposes the following members.

Constructors
 | Name | Description
Public method | CommandSchemaCollection | Initializes a new instance of the CommandSchemaCollection class.
Public method | CommandSchemaCollection(IEnumerableCommandSchema) | Initializes a new instance of the CommandSchemaCollection class.
Public method | CommandSchemaCollection(Int32) | Initializes a new instance of the CommandSchemaCollection class.
Top
Properties
 | Name | Description
Public property | Item | Gets the TableSchema with the specified owner and name. (Inherited from SchemaObjectWithOwnerCollectionT.)
Top
Methods
 | Name | Description
Public method | Clone | (Inherited from SchemaObjectCollectionT.)
Public method | Contains | Determines whether an element is in the collection with the specified owner and name. (Inherited from SchemaObjectWithOwnerCollectionT.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of an item with the specified owner and name. (Inherited from SchemaObjectWithOwnerCollectionT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh | (Inherited from SchemaObjectCollectionT.)
Public method | ToString | (Inherited from SchemaObjectCollectionT.)
Top
Remarks
CommandSchemaCollection provides an SchemaObjectWithOwnerCollectionT that is strongly typed for CommandSchema elements.
See Also

Reference

SchemaExplorer Namespace


CommandSchemaCollection Constructor

Overload List
 | Name | Description
Public method | CommandSchemaCollection | Initializes a new instance of the CommandSchemaCollection class.
Public method | CommandSchemaCollection(IEnumerableCommandSchema) | Initializes a new instance of the CommandSchemaCollection class.
Public method | CommandSchemaCollection(Int32) | Initializes a new instance of the CommandSchemaCollection class.
Top
See Also

Reference

CommandSchemaCollection Class
SchemaExplorer Namespace


CommandSchemaCollection Constructor

Initializes a new instance of the CommandSchemaCollection class.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CommandSchemaCollection()
Public Sub New
See Also

Reference

CommandSchemaCollection Class
CommandSchemaCollection Overload
SchemaExplorer Namespace


CommandSchemaCollection Constructor (IEnumerable(CommandSchema))

CommandSchemaCollection Constructor (IEnumerableCommandSchema)

Initializes a new instance of the CommandSchemaCollection class.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CommandSchemaCollection(
    IEnumerable<CommandSchema> collection
)
Public Sub New (
    collection As IEnumerable(Of CommandSchema)
)

Parameters

collection
Type: System.Collections.GenericIEnumerable CommandSchema
The collection from which the elements are copied.
See Also

Reference

CommandSchemaCollection Class
CommandSchemaCollection Overload
SchemaExplorer Namespace


CommandSchemaCollection Constructor (Int32)

Initializes a new instance of the CommandSchemaCollection class.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CommandSchemaCollection(
    int capacity
)
Public Sub New (
    capacity As Integer
)

Parameters

capacity
Type: SystemInt32
The number of elements that the new list can initially store.
See Also

Reference

CommandSchemaCollection Class
CommandSchemaCollection Overload
SchemaExplorer Namespace


CommandSchemaCollection Properties

The CommandSchemaCollection type exposes the following members.

Properties
 | Name | Description
Public property | Item | Gets the TableSchema with the specified owner and name. (Inherited from SchemaObjectWithOwnerCollectionT.)
Top
See Also

Reference

CommandSchemaCollection Class
SchemaExplorer Namespace


CommandSchemaCollection Methods

The CommandSchemaCollection type exposes the following members.

Methods
 | Name | Description
Public method | Clone | (Inherited from SchemaObjectCollectionT.)
Public method | Contains | Determines whether an element is in the collection with the specified owner and name. (Inherited from SchemaObjectWithOwnerCollectionT.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of an item with the specified owner and name. (Inherited from SchemaObjectWithOwnerCollectionT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh | (Inherited from SchemaObjectCollectionT.)
Public method | ToString | (Inherited from SchemaObjectCollectionT.)
Top
See Also

Reference

CommandSchemaCollection Class
SchemaExplorer Namespace


Configuration Class

Inheritance Hierarchy
SystemObject
CodeSmith.EngineConfigurationBase
SchemaExplorerConfiguration

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class Configuration : ConfigurationBase
Public Class Configuration
    Inherits ConfigurationBase

The Configuration type exposes the following members.

Constructors
 | Name | Description
Protected method | Configuration | Initializes a new instance of the Configuration class.
Top
Properties
 | Name | Description
Public property | ConfigurationVersion | (Inherited from ConfigurationBase.)
Public property | DataSourceCollection |
 | Instance | Gets the current singleton instance of Configuration.
Public property | LastSelectedDataSource |
Protected property | NamePrefix | (Overrides ConfigurationBaseNamePrefix.)
Public property | SchemaProviders |
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from ConfigurationBase.)
Public method | EnsureInitialize | This method is here purely to make sure that we don't make a double call to the Initialize method while initializing configuration. (Inherited from ConfigurationBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetValueT(String) | (Inherited from ConfigurationBase.)
Protected method | GetValueT(String, T) | (Inherited from ConfigurationBase.)
Protected method | GetValueT(String, Action) | (Inherited from ConfigurationBase.)
Protected method | GetValueT(String, T, FuncT, Boolean) | (Inherited from ConfigurationBase.)
Protected method | GetValueT(String, Action, FuncT, Boolean) | (Inherited from ConfigurationBase.)
Protected method | GetValueT(String, String, T) | (Inherited from ConfigurationBase.)
Protected method | GetValueT(String, String, Action) | (Inherited from ConfigurationBase.)
Protected method | GetValueT(String, String, T, FuncT, Boolean) | (Inherited from ConfigurationBase.)
Protected method | GetValueT(String, String, Action, FuncT, Boolean) | (Inherited from ConfigurationBase.)
Public method | Initialize | (Overrides ConfigurationBaseInitialize.)
Public method | LoadDefaults | (Overrides ConfigurationBaseLoadDefaults.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ResetDefaults | (Overrides ConfigurationBaseResetDefaults.)
Protected method | SetValueT(String, T) | (Inherited from ConfigurationBase.)
Protected method | SetValueT(String, String, T) | (Inherited from ConfigurationBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Upgrade | (Overrides ConfigurationBaseUpgrade.)
Protected method | UpgradeFileT | Attempts to update configuration from a configuration file. The version of CodeSmith must be older than CodeSmith 5.1. (Inherited from ConfigurationBase.)
Top
See Also

Reference

SchemaExplorer Namespace


Configuration Constructor

Initializes a new instance of the Configuration class.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected Configuration()
Protected Sub New
See Also

Reference

Configuration Class
SchemaExplorer Namespace


Configuration Properties

The Configuration type exposes the following members.

Properties
 | Name | Description
Public property | ConfigurationVersion | (Inherited from ConfigurationBase.)
Public property | DataSourceCollection |
 | Instance | Gets the current singleton instance of Configuration.
Public property | LastSelectedDataSource |
Protected property | NamePrefix | (Overrides ConfigurationBaseNamePrefix.)
Public property | SchemaProviders |
Top
See Also

Reference

Configuration Class
SchemaExplorer Namespace


Configuration.DataSourceCollection Property

ConfigurationDataSourceCollection Property

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public DataSourceCollection DataSourceCollection { get; }
Public ReadOnly Property DataSourceCollection As DataSourceCollection
    Get

Property Value

Type: DataSourceCollection
See Also

Reference

Configuration Class
SchemaExplorer Namespace


Configuration.Instance Property

ConfigurationInstance Property

Gets the current singleton instance of Configuration.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static Configuration Instance { get; }
Public Shared ReadOnly Property Instance As Configuration
    Get

Property Value

Type: Configuration
The current singleton instance.
Remarks
An instance of Configuration wont be created until the very first call to the sealed class. This is a CLR optimization that provides a properly lazy-loading singleton.
See Also

Reference

Configuration Class
SchemaExplorer Namespace


Configuration.LastSelectedDataSource Property

ConfigurationLastSelectedDataSource Property

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public DataSource LastSelectedDataSource { get; set; }
Public Property LastSelectedDataSource As DataSource
    Get
    Set

Property Value

Type: DataSource
See Also

Reference

Configuration Class
SchemaExplorer Namespace


Configuration.NamePrefix Property

ConfigurationNamePrefix Property

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected override string NamePrefix { get; }
Protected Overrides ReadOnly Property NamePrefix As String
    Get

Property Value

Type: String
See Also

Reference

Configuration Class
SchemaExplorer Namespace


Configuration.SchemaProviders Property

ConfigurationSchemaProviders Property

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public IList<SchemaProvider> SchemaProviders { get; }
Public ReadOnly Property SchemaProviders As IList(Of SchemaProvider)
    Get

Property Value

Type: IList SchemaProvider
See Also

Reference

Configuration Class
SchemaExplorer Namespace


Configuration Methods

The Configuration type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from ConfigurationBase.)
Public method | EnsureInitialize | This method is here purely to make sure that we don't make a double call to the Initialize method while initializing configuration. (Inherited from ConfigurationBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetValueT(String) | (Inherited from ConfigurationBase.)
Protected method | GetValueT(String, T) | (Inherited from ConfigurationBase.)
Protected method | GetValueT(String, Action) | (Inherited from ConfigurationBase.)
Protected method | GetValueT(String, T, FuncT, Boolean) | (Inherited from ConfigurationBase.)
Protected method | GetValueT(String, Action, FuncT, Boolean) | (Inherited from ConfigurationBase.)
Protected method | GetValueT(String, String, T) | (Inherited from ConfigurationBase.)
Protected method | GetValueT(String, String, Action) | (Inherited from ConfigurationBase.)
Protected method | GetValueT(String, String, T, FuncT, Boolean) | (Inherited from ConfigurationBase.)
Protected method | GetValueT(String, String, Action, FuncT, Boolean) | (Inherited from ConfigurationBase.)
Public method | Initialize | (Overrides ConfigurationBaseInitialize.)
Public method | LoadDefaults | (Overrides ConfigurationBaseLoadDefaults.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ResetDefaults | (Overrides ConfigurationBaseResetDefaults.)
Protected method | SetValueT(String, T) | (Inherited from ConfigurationBase.)
Protected method | SetValueT(String, String, T) | (Inherited from ConfigurationBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Upgrade | (Overrides ConfigurationBaseUpgrade.)
Protected method | UpgradeFileT | Attempts to update configuration from a configuration file. The version of CodeSmith must be older than CodeSmith 5.1. (Inherited from ConfigurationBase.)
Top
See Also

Reference

Configuration Class
SchemaExplorer Namespace


Configuration.Initialize Method

ConfigurationInitialize Method

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override void Initialize()
Public Overrides Sub Initialize
See Also

Reference

Configuration Class
SchemaExplorer Namespace


Configuration.LoadDefaults Method

ConfigurationLoadDefaults Method

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override void LoadDefaults()
Public Overrides Sub LoadDefaults
See Also

Reference

Configuration Class
SchemaExplorer Namespace


Configuration.ResetDefaults Method

ConfigurationResetDefaults Method

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override void ResetDefaults()
Public Overrides Sub ResetDefaults
See Also

Reference

Configuration Class
SchemaExplorer Namespace


Configuration.Upgrade Method

ConfigurationUpgrade Method

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override void Upgrade()
Public Overrides Sub Upgrade
See Also

Reference

Configuration Class
SchemaExplorer Namespace


ConfigurationImport Class

A class used to import old schema explorer configuration files.
Inheritance Hierarchy
SystemObject
SchemaExplorerConfigurationImport

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class ConfigurationImport
Public Class ConfigurationImport

The ConfigurationImport type exposes the following members.

Constructors
 | Name | Description
Public method | ConfigurationImport | Initializes a new instance of the ConfigurationImport class
Top
Properties
 | Name | Description
Public property | DataSourceCollection |
Public property | LastSelectedDataSource |
Public property | SchemaProviders |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SchemaExplorer Namespace


ConfigurationImport Constructor

Initializes a new instance of the ConfigurationImport class

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ConfigurationImport()
Public Sub New
See Also

Reference

ConfigurationImport Class
SchemaExplorer Namespace


ConfigurationImport Properties

The ConfigurationImport type exposes the following members.

Properties
 | Name | Description
Public property | DataSourceCollection |
Public property | LastSelectedDataSource |
Public property | SchemaProviders |
Top
See Also

Reference

ConfigurationImport Class
SchemaExplorer Namespace


ConfigurationImport.DataSourceCollection Property

ConfigurationImportDataSourceCollection Property

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public DataSourceCollection DataSourceCollection { get; set; }
Public Property DataSourceCollection As DataSourceCollection
    Get
    Set

Property Value

Type: DataSourceCollection
See Also

Reference

ConfigurationImport Class
SchemaExplorer Namespace


ConfigurationImport.LastSelectedDataSource Property

ConfigurationImportLastSelectedDataSource Property

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public DataSource LastSelectedDataSource { get; set; }
Public Property LastSelectedDataSource As DataSource
    Get
    Set

Property Value

Type: DataSource
See Also

Reference

ConfigurationImport Class
SchemaExplorer Namespace


ConfigurationImport.SchemaProviders Property

ConfigurationImportSchemaProviders Property

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public List<string> SchemaProviders { get; set; }
Public Property SchemaProviders As List(Of String)
    Get
    Set

Property Value

Type: List String
See Also

Reference

ConfigurationImport Class
SchemaExplorer Namespace


ConfigurationImport Methods

The ConfigurationImport type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ConfigurationImport Class
SchemaExplorer Namespace


DatabaseSchema Class

This class allows programmatic discovery of a database schema.
Inheritance Hierarchy
SystemObject
NamedObjectBase
SchemaExplorerSchemaObjectBase
SchemaExplorerDatabaseSchema
SchemaExplorerSchemaSelector

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
public class DatabaseSchema : SchemaObjectBase,
    IDatabaseSchema, ISchemaObject
<SerializableAttribute>
Public Class DatabaseSchema
    Inherits SchemaObjectBase
    Implements IDatabaseSchema, ISchemaObject

The DatabaseSchema type exposes the following members.

Constructors
 | Name | Description
Public method | DatabaseSchema | This is the default constructor.
Public method | DatabaseSchema(IDbSchemaProvider, String) | This constructor allows you to specify your own schema provider and set the connection string.
Top
Properties
 | Name | Description
Public property | Commands | Provides access to the commands contained in the database.
Public property | ConnectionString | Gets or sets the current connection string for this instance.
Public property | Database | Allows access to the DatabaseSchema object that contains this schema object. (Inherited from SchemaObjectBase.)
Public property | DateCreated | Returns the date this table was created. (Inherited from SchemaObjectBase.)
Public property | DeepLoad | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from SchemaObjectBase.)
Public property | Description | The description of the object. (Inherited from SchemaObjectBase.)
Public property | ExtendedProperties | Used to store any additional information about the schema object. (Inherited from SchemaObjectBase.)
Public property | FullName | Returns the owner and name of the table. (Inherited from SchemaObjectBase.)
Public property | IncludeFunctions | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from SchemaObjectBase.)
Public property | Name | The name of the database. (Overrides NamedObjectBase.Name.)
Public property | Provider | Gets or sets the current provider for this instance.
Public property | SortName | Gets the name used to sort in 'Table (Owner)' format. (Inherited from SchemaObjectBase.)
Public property | Tables | Provides access to the tables contained in the database.
Public property | Views | Provides access to the views contained in the database.
Top
Methods
 | Name | Description
Public method | Equals | Determines if another database is the same as this database. (Overrides SchemaObjectBaseEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns a hashcode based on the database. (Overrides SchemaObjectBaseGetHashCode.)
Public method | GetLoadedExtendedProperties | Gets the existing ExtendedProperties without causing a lazy load. (Inherited from SchemaObjectBase.)
Public method | GetProvider | Obsolete. Gets a provider by name.
Public method | GetProviders | Obsolete. Returns a collection of available providers.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MarkLoaded | (Inherited from SchemaObjectBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh | Allows for programmatic refreshing of the database schema. (Overrides SchemaObjectBaseRefresh.)
Public method | ToString | Returns the name of the database. (Overrides NamedObjectBase.ToString.)
Top
Fields
 | Name | Description
Protected field | _database | (Inherited from SchemaObjectBase.)
Protected field | _dateCreated | (Inherited from SchemaObjectBase.)
Protected field | _defaultExtendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _extendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _gotExtendedProperties | (Inherited from SchemaObjectBase.)
Top
See Also

Reference

SchemaExplorer Namespace


DatabaseSchema Constructor

Overload List
 | Name | Description
Public method | DatabaseSchema | This is the default constructor.
Public method | DatabaseSchema(IDbSchemaProvider, String) | This constructor allows you to specify your own schema provider and set the connection string.
Top
See Also

Reference

DatabaseSchema Class
SchemaExplorer Namespace


DatabaseSchema Constructor

This is the default constructor.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public DatabaseSchema()
Public Sub New
See Also

Reference

DatabaseSchema Class
DatabaseSchema Overload
SchemaExplorer Namespace


DatabaseSchema Constructor (IDbSchemaProvider, String)

This constructor allows you to specify your own schema provider and set the connection string.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public DatabaseSchema(
    IDbSchemaProvider provider,
    string connectionString
)
Public Sub New (
    provider As IDbSchemaProvider,
    connectionString As String
)

Parameters

provider
Type: SchemaExplorerIDbSchemaProvider
The provider to use for this instance.
connectionString
Type: SystemString
The connection string to use for this instance.
See Also

Reference

DatabaseSchema Class
DatabaseSchema Overload
SchemaExplorer Namespace


DatabaseSchema Properties

The DatabaseSchema type exposes the following members.

Properties
 | Name | Description
Public property | Commands | Provides access to the commands contained in the database.
Public property | ConnectionString | Gets or sets the current connection string for this instance.
Public property | Database | Allows access to the DatabaseSchema object that contains this schema object. (Inherited from SchemaObjectBase.)
Public property | DateCreated | Returns the date this table was created. (Inherited from SchemaObjectBase.)
Public property | DeepLoad | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from SchemaObjectBase.)
Public property | Description | The description of the object. (Inherited from SchemaObjectBase.)
Public property | ExtendedProperties | Used to store any additional information about the schema object. (Inherited from SchemaObjectBase.)
Public property | FullName | Returns the owner and name of the table. (Inherited from SchemaObjectBase.)
Public property | IncludeFunctions | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from SchemaObjectBase.)
Public property | Name | The name of the database. (Overrides NamedObjectBase.Name.)
Public property | Provider | Gets or sets the current provider for this instance.
Public property | SortName | Gets the name used to sort in 'Table (Owner)' format. (Inherited from SchemaObjectBase.)
Public property | Tables | Provides access to the tables contained in the database.
Public property | Views | Provides access to the views contained in the database.
Top
See Also

Reference

DatabaseSchema Class
SchemaExplorer Namespace


DatabaseSchema.Commands Property

DatabaseSchemaCommands Property

Provides access to the commands contained in the database.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CommandSchemaCollection Commands { get; }
Public ReadOnly Property Commands As CommandSchemaCollection
    Get

Property Value

Type: CommandSchemaCollection
See Also

Reference

DatabaseSchema Class
SchemaExplorer Namespace


DatabaseSchema.ConnectionString Property

DatabaseSchemaConnectionString Property

Gets or sets the current connection string for this instance.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string ConnectionString { get; set; }
Public Property ConnectionString As String
    Get
    Set

Property Value

Type: String

Implements

IDatabaseSchemaConnectionString
See Also

Reference

DatabaseSchema Class
SchemaExplorer Namespace


DatabaseSchema.Name Property

DatabaseSchemaName Property

The name of the database.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override string Name { get; }
Public Overrides ReadOnly Property Name As String
    Get

Property Value

Type: String
See Also

Reference

DatabaseSchema Class
SchemaExplorer Namespace


DatabaseSchema.Provider Property

DatabaseSchemaProvider Property

Gets or sets the current provider for this instance.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public IDbSchemaProvider Provider { get; set; }
Public Property Provider As IDbSchemaProvider
    Get
    Set

Property Value

Type: IDbSchemaProvider

Implements

IDatabaseSchemaProvider
See Also

Reference

DatabaseSchema Class
SchemaExplorer Namespace


DatabaseSchema.Tables Property

DatabaseSchemaTables Property

Provides access to the tables contained in the database.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public TableSchemaCollection Tables { get; }
Public ReadOnly Property Tables As TableSchemaCollection
    Get

Property Value

Type: TableSchemaCollection
See Also

Reference

DatabaseSchema Class
SchemaExplorer Namespace


DatabaseSchema.Views Property

DatabaseSchemaViews Property

Provides access to the views contained in the database.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ViewSchemaCollection Views { get; }
Public ReadOnly Property Views As ViewSchemaCollection
    Get

Property Value

Type: ViewSchemaCollection
See Also

Reference

DatabaseSchema Class
SchemaExplorer Namespace


DatabaseSchema Methods

The DatabaseSchema type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines if another database is the same as this database. (Overrides SchemaObjectBaseEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns a hashcode based on the database. (Overrides SchemaObjectBaseGetHashCode.)
Public method | GetLoadedExtendedProperties | Gets the existing ExtendedProperties without causing a lazy load. (Inherited from SchemaObjectBase.)
Public method | GetProvider | Obsolete. Gets a provider by name.
Public method | GetProviders | Obsolete. Returns a collection of available providers.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MarkLoaded | (Inherited from SchemaObjectBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh | Allows for programmatic refreshing of the database schema. (Overrides SchemaObjectBaseRefresh.)
Public method | ToString | Returns the name of the database. (Overrides NamedObjectBase.ToString.)
Top
See Also

Reference

DatabaseSchema Class
SchemaExplorer Namespace


DatabaseSchema.Equals Method

DatabaseSchemaEquals Method

Determines if another database is the same as this database.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
The database to check against.

Return Value

Type: Boolean
true/false
See Also

Reference

DatabaseSchema Class
SchemaExplorer Namespace


DatabaseSchema.GetHashCode Method

DatabaseSchemaGetHashCode Method

Returns a hashcode based on the database.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
See Also

Reference

DatabaseSchema Class
SchemaExplorer Namespace


DatabaseSchema.GetProvider Method

DatabaseSchemaGetProvider Method

Note: This API is now obsolete.

Gets a provider by name.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[ObsoleteAttribute("User DataSourceManager.GetProviders instead.")]
public IDbSchemaProvider GetProvider(
    string name
)
<ObsoleteAttribute("User DataSourceManager.GetProviders instead.")>
Public Function GetProvider (
    name As String
) As IDbSchemaProvider

Parameters

name
Type: SystemString
The name of the provider.

Return Value

Type: IDbSchemaProvider
IDbSchemaProvider
See Also

Reference

DatabaseSchema Class
SchemaExplorer Namespace


DatabaseSchema.GetProviders Method

DatabaseSchemaGetProviders Method

Note: This API is now obsolete.

Returns a collection of available providers.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[ObsoleteAttribute("Use DataSourceManager.GetProviders instead.")]
public IDbSchemaProviderCollection GetProviders()
<ObsoleteAttribute("Use DataSourceManager.GetProviders instead.")>
Public Function GetProviders As IDbSchemaProviderCollection

Return Value

Type: IDbSchemaProviderCollection
IDbSchemaProviderCollection
See Also

Reference

DatabaseSchema Class
SchemaExplorer Namespace


DatabaseSchema.Refresh Method

DatabaseSchemaRefresh Method

Allows for programmatic refreshing of the database schema.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override void Refresh()
Public Overrides Sub Refresh

Implements

ISchemaObjectRefresh
ISchemaObjectRefresh
See Also

Reference

DatabaseSchema Class
SchemaExplorer Namespace


DatabaseSchema.ToString Method

DatabaseSchemaToString Method

Returns the name of the database.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
See Also

Reference

DatabaseSchema Class
SchemaExplorer Namespace


DatabaseSchema Fields

The DatabaseSchema type exposes the following members.

Fields
 | Name | Description
Protected field | _database | (Inherited from SchemaObjectBase.)
Protected field | _dateCreated | (Inherited from SchemaObjectBase.)
Protected field | _defaultExtendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _extendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _gotExtendedProperties | (Inherited from SchemaObjectBase.)
Top
See Also

Reference

DatabaseSchema Class
SchemaExplorer Namespace


DataObjectBase Class

Provides a common base for all schema objects that describe a data field.
Inheritance Hierarchy
SystemObject
NamedObjectBase
SchemaExplorerSchemaObjectBase
SchemaExplorerDataObjectBase
SchemaExplorerColumnSchema
SchemaExplorerCommandResultColumnSchema
SchemaExplorerParameterSchema
SchemaExplorerViewColumnSchema

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
public abstract class DataObjectBase : SchemaObjectBase,
    IDataObject, ISchemaObject
<SerializableAttribute>
Public MustInherit Class DataObjectBase
    Inherits SchemaObjectBase
    Implements IDataObject, ISchemaObject

The DataObjectBase type exposes the following members.

Constructors
 | Name | Description
Public method | DataObjectBase(ISchemaObject, String, DbType, String, Int32, Byte, Int32) | Obsolete. Creates a new instance of the ViewColumnSchema object.
Public method | DataObjectBase(ISchemaObject, String, DbType, String, Int32, Byte, Int32, ExtendedProperty) | Obsolete. Creates a new instance of the ViewColumnSchema object.
Public method | DataObjectBase(ISchemaObject, String, DbType, String, Int32, Byte, Int32, Boolean) | Creates a new instance of the ViewColumnSchema object.
Public method | DataObjectBase(ISchemaObject, String, DbType, String, Int32, Byte, Int32, Boolean, ExtendedProperty) | Creates a new instance of the ViewColumnSchema object.
Top
Properties
 | Name | Description
Public property | AllowDBNull | Whether or not the data object allows null values.
Public property | Database | Allows access to the DatabaseSchema object that contains this schema object. (Inherited from SchemaObjectBase.)
Public property | DataType | The data type of a (column) parameter is specific to the .NET Framework data provider. Specifying the type converts the value of the Parameter to the data provider Type before passing the value to the data source. see also: http://msdn.microsoft.com/en-us/library/system.data.dbtype.aspx example: DbType.AnsiString
Public property | DateCreated | Returns the date this table was created. (Inherited from SchemaObjectBase.)
Public property | DeepLoad | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from SchemaObjectBase.)
Public property | Description | The description of the object. (Inherited from SchemaObjectBase.)
Public property | ExtendedProperties | Used to store any additional information about the schema object. (Inherited from SchemaObjectBase.)
Public property | FullName | Returns the owner and name. (Overrides SchemaObjectBaseFullName.)
Public property | IncludeFunctions | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from SchemaObjectBase.)
Public property | NativeType | This is the native data type from the database. example: nvarchar
Public property | Parent | The Parent Schema Object.
Public property | Precision | The precision of the data object.
Public property | Scale | The scale of the data object.
Public property | Size | The size of the data object.
Public property | SortName | Gets the name used to sort in 'Name (Parent)' format. (Overrides SchemaObjectBaseSortName.)
Public property | SystemType | The System Type that is resolved from DataType. example: typeof(System.String)
Top
Methods
 | Name | Description
Public method | Equals | Determines if another view column is the same as this view column. (Overrides SchemaObjectBaseEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns a hashcode based on the database, view and name of the view column. (Overrides SchemaObjectBaseGetHashCode.)
Public method | GetLoadedExtendedProperties | Gets the existing ExtendedProperties without causing a lazy load. (Inherited from SchemaObjectBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MarkLoaded | (Inherited from SchemaObjectBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh | Used to refresh this instance. (Overrides SchemaObjectBaseRefresh.)
Public method | ToString | Returns the name of the column. (Overrides NamedObjectBase.ToString.)
Top
Fields
 | Name | Description
Protected field | _allowDBNull |
Protected field | _database | (Inherited from SchemaObjectBase.)
Protected field | _dataType |
Protected field | _dateCreated | (Inherited from SchemaObjectBase.)
Protected field | _defaultExtendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _extendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _gotExtendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _nativeType |
Protected field | _parent |
Protected field | _precision |
Protected field | _scale |
Protected field | _size |
Top
See Also

Reference

SchemaExplorer Namespace


DataObjectBase Constructor

Overload List
 | Name | Description
Public method | DataObjectBase(ISchemaObject, String, DbType, String, Int32, Byte, Int32) | Obsolete. Creates a new instance of the ViewColumnSchema object.
Public method | DataObjectBase(ISchemaObject, String, DbType, String, Int32, Byte, Int32, ExtendedProperty) | Obsolete. Creates a new instance of the ViewColumnSchema object.
Public method | DataObjectBase(ISchemaObject, String, DbType, String, Int32, Byte, Int32, Boolean) | Creates a new instance of the ViewColumnSchema object.
Public method | DataObjectBase(ISchemaObject, String, DbType, String, Int32, Byte, Int32, Boolean, ExtendedProperty) | Creates a new instance of the ViewColumnSchema object.
Top
See Also

Reference

DataObjectBase Class
SchemaExplorer Namespace


DataObjectBase Constructor (ISchemaObject, String, DbType, String, Int32, Byte, Int32)

Note: This API is now obsolete.

Creates a new instance of the ViewColumnSchema object.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[ObsoleteAttribute("Please use the constructors that contain the allowDBNull parameter.",
    false)]
public DataObjectBase(
    ISchemaObject parent,
    string name,
    DbType dataType,
    string nativeType,
    int size,
    byte precision,
    int scale
)
<ObsoleteAttribute("Please use the constructors that contain the allowDBNull parameter.",
    false)>
Public Sub New (
    parent As ISchemaObject,
    name As String,
    dataType As DbType,
    nativeType As String,
    size As Integer,
    precision As Byte,
    scale As Integer
)

Parameters

parent
Type: SchemaExplorerISchemaObject
The object that the column belongs to.
name
Type: SystemString
The name of the column.
dataType
Type: System.DataDbType
The columns data type.
nativeType
Type: SystemString
The columns native type.
size
Type: SystemInt32
The size of the column.
precision
Type: SystemByte
The precision of the column.
scale
Type: SystemInt32
The scale of the column.
See Also

Reference

DataObjectBase Class
DataObjectBase Overload
SchemaExplorer Namespace


DataObjectBase Constructor (ISchemaObject, String, DbType, String, Int32, Byte, Int32, ExtendedProperty[])

DataObjectBase Constructor (ISchemaObject, String, DbType, String, Int32, Byte, Int32, ExtendedProperty)

Note: This API is now obsolete.

Creates a new instance of the ViewColumnSchema object.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[ObsoleteAttribute("Please use the constructors that contain the allowDBNull parameter.",
    false)]
public DataObjectBase(
    ISchemaObject parent,
    string name,
    DbType dataType,
    string nativeType,
    int size,
    byte precision,
    int scale,
    ExtendedProperty[] extendedProperties
)
<ObsoleteAttribute("Please use the constructors that contain the allowDBNull parameter.",
    false)>
Public Sub New (
    parent As ISchemaObject,
    name As String,
    dataType As DbType,
    nativeType As String,
    size As Integer,
    precision As Byte,
    scale As Integer,
    extendedProperties As ExtendedProperty()
)

Parameters

parent
Type: SchemaExplorerISchemaObject
The object that the column belongs to.
name
Type: SystemString
The name of the column.
dataType
Type: System.DataDbType
The columns data type.
nativeType
Type: SystemString
The columns native type.
size
Type: SystemInt32
The size of the column.
precision
Type: SystemByte
The precision of the column.
scale
Type: SystemInt32
The scale of the column.
extendedProperties
Type: SchemaExplorerExtendedProperty
The array of extended properties for this column.
See Also

Reference

DataObjectBase Class
DataObjectBase Overload
SchemaExplorer Namespace


DataObjectBase Constructor (ISchemaObject, String, DbType, String, Int32, Byte, Int32, Boolean)

Creates a new instance of the ViewColumnSchema object.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public DataObjectBase(
    ISchemaObject parent,
    string name,
    DbType dataType,
    string nativeType,
    int size,
    byte precision,
    int scale,
    bool allowDBNull
)
Public Sub New (
    parent As ISchemaObject,
    name As String,
    dataType As DbType,
    nativeType As String,
    size As Integer,
    precision As Byte,
    scale As Integer,
    allowDBNull As Boolean
)

Parameters

parent
Type: SchemaExplorerISchemaObject
The object that the column belongs to.
name
Type: SystemString
The name of the column.
dataType
Type: System.DataDbType
The columns data type.
nativeType
Type: SystemString
The columns native type.
size
Type: SystemInt32
The size of the column.
precision
Type: SystemByte
The precision of the column.
scale
Type: SystemInt32
The scale of the column.
allowDBNull
Type: SystemBoolean
Whether the column allows null values.
See Also

Reference

DataObjectBase Class
DataObjectBase Overload
SchemaExplorer Namespace


DataObjectBase Constructor (ISchemaObject, String, DbType, String, Int32, Byte, Int32, Boolean, ExtendedProperty[])

DataObjectBase Constructor (ISchemaObject, String, DbType, String, Int32, Byte, Int32, Boolean, ExtendedProperty)

Creates a new instance of the ViewColumnSchema object.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public DataObjectBase(
    ISchemaObject parent,
    string name,
    DbType dataType,
    string nativeType,
    int size,
    byte precision,
    int scale,
    bool allowDBNull,
    ExtendedProperty[] extendedProperties
)
Public Sub New (
    parent As ISchemaObject,
    name As String,
    dataType As DbType,
    nativeType As String,
    size As Integer,
    precision As Byte,
    scale As Integer,
    allowDBNull As Boolean,
    extendedProperties As ExtendedProperty()
)

Parameters

parent
Type: SchemaExplorerISchemaObject
The object that the column belongs to.
name
Type: SystemString
The name of the column.
dataType
Type: System.DataDbType
The columns data type.
nativeType
Type: SystemString
The columns native type.
size
Type: SystemInt32
The size of the column.
precision
Type: SystemByte
The precision of the column.
scale
Type: SystemInt32
The scale of the column.
allowDBNull
Type: SystemBoolean
Whether the column allows null values.
extendedProperties
Type: SchemaExplorerExtendedProperty
The array of extended properties for this column.
See Also

Reference

DataObjectBase Class
DataObjectBase Overload
SchemaExplorer Namespace


DataObjectBase Properties

The DataObjectBase type exposes the following members.

Properties
 | Name | Description
Public property | AllowDBNull | Whether or not the data object allows null values.
Public property | Database | Allows access to the DatabaseSchema object that contains this schema object. (Inherited from SchemaObjectBase.)
Public property | DataType | The data type of a (column) parameter is specific to the .NET Framework data provider. Specifying the type converts the value of the Parameter to the data provider Type before passing the value to the data source. see also: http://msdn.microsoft.com/en-us/library/system.data.dbtype.aspx example: DbType.AnsiString
Public property | DateCreated | Returns the date this table was created. (Inherited from SchemaObjectBase.)
Public property | DeepLoad | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from SchemaObjectBase.)
Public property | Description | The description of the object. (Inherited from SchemaObjectBase.)
Public property | ExtendedProperties | Used to store any additional information about the schema object. (Inherited from SchemaObjectBase.)
Public property | FullName | Returns the owner and name. (Overrides SchemaObjectBaseFullName.)
Public property | IncludeFunctions | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from SchemaObjectBase.)
Public property | NativeType | This is the native data type from the database. example: nvarchar
Public property | Parent | The Parent Schema Object.
Public property | Precision | The precision of the data object.
Public property | Scale | The scale of the data object.
Public property | Size | The size of the data object.
Public property | SortName | Gets the name used to sort in 'Name (Parent)' format. (Overrides SchemaObjectBaseSortName.)
Public property | SystemType | The System Type that is resolved from DataType. example: typeof(System.String)
Top
See Also

Reference

DataObjectBase Class
SchemaExplorer Namespace


DataObjectBase.AllowDBNull Property

DataObjectBaseAllowDBNull Property

Whether or not the data object allows null values.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual bool AllowDBNull { get; }
Public Overridable ReadOnly Property AllowDBNull As Boolean
    Get

Property Value

Type: Boolean

Implements

IDataObjectAllowDBNull
See Also

Reference

DataObjectBase Class
SchemaExplorer Namespace


DataObjectBase.DataType Property

DataObjectBaseDataType Property

The data type of a (column) parameter is specific to the .NET Framework data provider. Specifying the type converts the value of the Parameter to the data provider Type before passing the value to the data source. see also: http://msdn.microsoft.com/en-us/library/system.data.dbtype.aspx example: DbType.AnsiString

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual DbType DataType { get; }
Public Overridable ReadOnly Property DataType As DbType
    Get

Property Value

Type: DbType

Implements

IDataObjectDataType
See Also

Reference

DataObjectBase Class
SchemaExplorer Namespace


DataObjectBase.FullName Property

DataObjectBaseFullName Property

Returns the owner and name.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override string FullName { get; }
Public Overrides ReadOnly Property FullName As String
    Get

Return Value

Type: String

Implements

ISchemaObjectFullName
ISchemaObjectFullName
See Also

Reference

DataObjectBase Class
SchemaExplorer Namespace


DataObjectBase.NativeType Property

DataObjectBaseNativeType Property

This is the native data type from the database. example: nvarchar

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual string NativeType { get; }
Public Overridable ReadOnly Property NativeType As String
    Get

Property Value

Type: String

Implements

IDataObjectNativeType
See Also

Reference

DataObjectBase Class
SchemaExplorer Namespace


DataObjectBase.Parent Property

DataObjectBaseParent Property

The Parent Schema Object.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual ISchemaObject Parent { get; }
Public Overridable ReadOnly Property Parent As ISchemaObject
    Get

Property Value

Type: ISchemaObject

Implements

IDataObjectParent
See Also

Reference

DataObjectBase Class
SchemaExplorer Namespace


DataObjectBase.Precision Property

DataObjectBasePrecision Property

The precision of the data object.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual byte Precision { get; }
Public Overridable ReadOnly Property Precision As Byte
    Get

Property Value

Type: Byte

Implements

IDataObjectPrecision
See Also

Reference

DataObjectBase Class
SchemaExplorer Namespace


DataObjectBase.Scale Property

DataObjectBaseScale Property

The scale of the data object.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual int Scale { get; }
Public Overridable ReadOnly Property Scale As Integer
    Get

Property Value

Type: Int32

Implements

IDataObjectScale
See Also

Reference

DataObjectBase Class
SchemaExplorer Namespace


DataObjectBase.Size Property

DataObjectBaseSize Property

The size of the data object.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual int Size { get; }
Public Overridable ReadOnly Property Size As Integer
    Get

Property Value

Type: Int32

Implements

IDataObjectSize
See Also

Reference

DataObjectBase Class
SchemaExplorer Namespace


DataObjectBase.SortName Property

DataObjectBaseSortName Property

Gets the name used to sort in 'Name (Parent)' format.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override string SortName { get; }
Public Overrides ReadOnly Property SortName As String
    Get

Property Value

Type: String
The name used to sort.

Implements

ISchemaObjectSortName
ISchemaObjectSortName
See Also

Reference

DataObjectBase Class
SchemaExplorer Namespace


DataObjectBase.SystemType Property

DataObjectBaseSystemType Property

The System Type that is resolved from DataType. example: typeof(System.String)

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual Type SystemType { get; }
Public Overridable ReadOnly Property SystemType As Type
    Get

Property Value

Type: Type

Implements

IDataObjectSystemType
See Also

Reference

DataObjectBase Class
SchemaExplorer Namespace


DataObjectBase Methods

The DataObjectBase type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines if another view column is the same as this view column. (Overrides SchemaObjectBaseEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns a hashcode based on the database, view and name of the view column. (Overrides SchemaObjectBaseGetHashCode.)
Public method | GetLoadedExtendedProperties | Gets the existing ExtendedProperties without causing a lazy load. (Inherited from SchemaObjectBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MarkLoaded | (Inherited from SchemaObjectBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh | Used to refresh this instance. (Overrides SchemaObjectBaseRefresh.)
Public method | ToString | Returns the name of the column. (Overrides NamedObjectBase.ToString.)
Top
See Also

Reference

DataObjectBase Class
SchemaExplorer Namespace


DataObjectBase.Equals Method

DataObjectBaseEquals Method

Determines if another view column is the same as this view column.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
The view column to check against.

Return Value

Type: Boolean
true/false
See Also

Reference

DataObjectBase Class
SchemaExplorer Namespace


DataObjectBase.GetHashCode Method

DataObjectBaseGetHashCode Method

Returns a hashcode based on the database, view and name of the view column.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
See Also

Reference

DataObjectBase Class
SchemaExplorer Namespace


DataObjectBase.Refresh Method

DataObjectBaseRefresh Method

Used to refresh this instance.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override void Refresh()
Public Overrides Sub Refresh

Implements

ISchemaObjectRefresh
ISchemaObjectRefresh
See Also

Reference

DataObjectBase Class
SchemaExplorer Namespace


DataObjectBase.ToString Method

DataObjectBaseToString Method

Returns the name of the column.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
See Also

Reference

DataObjectBase Class
SchemaExplorer Namespace


DataObjectBase Fields

The DataObjectBase type exposes the following members.

Fields
 | Name | Description
Protected field | _allowDBNull |
Protected field | _database | (Inherited from SchemaObjectBase.)
Protected field | _dataType |
Protected field | _dateCreated | (Inherited from SchemaObjectBase.)
Protected field | _defaultExtendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _extendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _gotExtendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _nativeType |
Protected field | _parent |
Protected field | _precision |
Protected field | _scale |
Protected field | _size |
Top
See Also

Reference

DataObjectBase Class
SchemaExplorer Namespace


DataObjectBase._allowDBNull Field

DataObjectBase_allowDBNull Field

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected bool _allowDBNull
Protected _allowDBNull As Boolean

Field Value

Type: Boolean
See Also

Reference

DataObjectBase Class
SchemaExplorer Namespace


DataObjectBase._dataType Field

DataObjectBase_dataType Field

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected DbType _dataType
Protected _dataType As DbType

Field Value

Type: DbType
See Also

Reference

DataObjectBase Class
SchemaExplorer Namespace


DataObjectBase._nativeType Field

DataObjectBase_nativeType Field

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected string _nativeType
Protected _nativeType As String

Field Value

Type: String
See Also

Reference

DataObjectBase Class
SchemaExplorer Namespace


DataObjectBase._parent Field

DataObjectBase_parent Field

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected ISchemaObject _parent
Protected _parent As ISchemaObject

Field Value

Type: ISchemaObject
See Also

Reference

DataObjectBase Class
SchemaExplorer Namespace


DataObjectBase._precision Field

DataObjectBase_precision Field

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected byte _precision
Protected _precision As Byte

Field Value

Type: Byte
See Also

Reference

DataObjectBase Class
SchemaExplorer Namespace


DataObjectBase._scale Field

DataObjectBase_scale Field

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected int _scale
Protected _scale As Integer

Field Value

Type: Int32
See Also

Reference

DataObjectBase Class
SchemaExplorer Namespace


DataObjectBase._size Field

DataObjectBase_size Field

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected int _size
Protected _size As Integer

Field Value

Type: Int32
See Also

Reference

DataObjectBase Class
SchemaExplorer Namespace


DataObjectBaseCollection Class

Note: This API is now obsolete.

Implements a strongly typed collection of DataObjectBase elements.
Inheritance Hierarchy
SystemObject
ObservableListDataObjectBase
NamedObjectCollectionDataObjectBase
SchemaExplorerSchemaObjectCollection DataObjectBase
SchemaExplorerDataObjectBaseCollection

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
[ObsoleteAttribute("Please use DataObjectBaseCollection{T} instead.")]
public class DataObjectBaseCollection : SchemaObjectCollection<DataObjectBase>
<SerializableAttribute>
<ObsoleteAttribute("Please use DataObjectBaseCollection{T} instead.")>
Public Class DataObjectBaseCollection
    Inherits SchemaObjectCollection(Of DataObjectBase)

The DataObjectBaseCollection type exposes the following members.

Constructors
 | Name | Description
Public method | DataObjectBaseCollection | Initializes a new instance of the DataObjectBaseCollection class.
Public method | DataObjectBaseCollection(IEnumerableDataObjectBase) | Initializes a new instance of the DataObjectBaseCollection class.
Public method | DataObjectBaseCollection(Int32) | Initializes a new instance of the DataObjectBaseCollection class.
Top
Methods
 | Name | Description
Public method | Clone | (Inherited from SchemaObjectCollectionT.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh | (Inherited from SchemaObjectCollectionT.)
Public method | ToString | (Inherited from SchemaObjectCollectionT.)
Top
Remarks
DataObjectBaseCollection provides an SchemaObjectCollectionT that is strongly typed for DataObjectBase elements.
See Also

Reference

SchemaExplorer Namespace


DataObjectBaseCollection Constructor

Overload List
 | Name | Description
Public method | DataObjectBaseCollection | Initializes a new instance of the DataObjectBaseCollection class.
Public method | DataObjectBaseCollection(IEnumerableDataObjectBase) | Initializes a new instance of the DataObjectBaseCollection class.
Public method | DataObjectBaseCollection(Int32) | Initializes a new instance of the DataObjectBaseCollection class.
Top
See Also

Reference

DataObjectBaseCollection Class
SchemaExplorer Namespace


DataObjectBaseCollection Constructor

Initializes a new instance of the DataObjectBaseCollection class.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public DataObjectBaseCollection()
Public Sub New
See Also

Reference

DataObjectBaseCollection Class
DataObjectBaseCollection Overload
SchemaExplorer Namespace


DataObjectBaseCollection Constructor (IEnumerable(DataObjectBase))

DataObjectBaseCollection Constructor (IEnumerableDataObjectBase)

Initializes a new instance of the DataObjectBaseCollection class.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public DataObjectBaseCollection(
    IEnumerable<DataObjectBase> collection
)
Public Sub New (
    collection As IEnumerable(Of DataObjectBase)
)

Parameters

collection
Type: System.Collections.GenericIEnumerable DataObjectBase
The collection from which the elements are copied.
See Also

Reference

DataObjectBaseCollection Class
DataObjectBaseCollection Overload
SchemaExplorer Namespace


DataObjectBaseCollection Constructor (Int32)

Initializes a new instance of the DataObjectBaseCollection class.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public DataObjectBaseCollection(
    int capacity
)
Public Sub New (
    capacity As Integer
)

Parameters

capacity
Type: SystemInt32
The number of elements that the new list can initially store.
See Also

Reference

DataObjectBaseCollection Class
DataObjectBaseCollection Overload
SchemaExplorer Namespace


DataObjectBaseCollection Methods

The DataObjectBaseCollection type exposes the following members.

Methods
 | Name | Description
Public method | Clone | (Inherited from SchemaObjectCollectionT.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh | (Inherited from SchemaObjectCollectionT.)
Public method | ToString | (Inherited from SchemaObjectCollectionT.)
Top
See Also

Reference

DataObjectBaseCollection Class
SchemaExplorer Namespace


DataObjectBaseCollection(T) Class

DataObjectBaseCollectionT Class

Implements a strongly typed collection of DataObjectBase elements.
Inheritance Hierarchy
SystemObject
ObservableListT
NamedObjectCollectionT
SchemaExplorerSchemaObjectCollection T
SchemaExplorerDataObjectBaseCollectionT
SchemaExplorerColumnSchemaCollection
SchemaExplorerCommandResultColumnSchemaCollection
SchemaExplorerViewColumnSchemaCollection

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
public class DataObjectBaseCollection<T> : SchemaObjectCollection<T>
where T : IDataObject

<SerializableAttribute>
Public Class DataObjectBaseCollection(Of T As IDataObject)
    Inherits SchemaObjectCollection(Of T)

Type Parameters

T

The DataObjectBaseCollectionT type exposes the following members.

Constructors
 | Name | Description
Public method | DataObjectBaseCollectionT | Initializes a new instance of the DataObjectBaseCollectionT class.
Public method | DataObjectBaseCollectionT(IEnumerableT) | Initializes a new instance of the DataObjectBaseCollectionT class.
Public method | DataObjectBaseCollectionT(Int32) | Initializes a new instance of the DataObjectBaseCollectionT class.
Top
Methods
 | Name | Description
Public method | Clone | (Inherited from SchemaObjectCollectionT.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh | (Inherited from SchemaObjectCollectionT.)
Public method | ToString | (Inherited from SchemaObjectCollectionT.)
Top
Remarks
DataObjectBaseCollection provides an SchemaObjectCollectionT that is strongly typed for IDataObject elements.
See Also

Reference

SchemaExplorer Namespace


DataObjectBaseCollection(T) Constructor

DataObjectBaseCollectionT Constructor

Overload List
 | Name | Description
Public method | DataObjectBaseCollectionT | Initializes a new instance of the DataObjectBaseCollectionT class.
Public method | DataObjectBaseCollectionT(IEnumerableT) | Initializes a new instance of the DataObjectBaseCollectionT class.
Public method | DataObjectBaseCollectionT(Int32) | Initializes a new instance of the DataObjectBaseCollectionT class.
Top
See Also

Reference

DataObjectBaseCollectionT Class
SchemaExplorer Namespace


DataObjectBaseCollection(T) Constructor

DataObjectBaseCollectionT Constructor

Initializes a new instance of the DataObjectBaseCollectionT class.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public DataObjectBaseCollection()
Public Sub New
See Also

Reference

DataObjectBaseCollectionT Class
DataObjectBaseCollectionT Overload
SchemaExplorer Namespace


DataObjectBaseCollection(T) Constructor (IEnumerable(T))

DataObjectBaseCollectionT Constructor (IEnumerableT)

Initializes a new instance of the DataObjectBaseCollectionT class.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public DataObjectBaseCollection(
    IEnumerable<T> collection
)
Public Sub New (
    collection As IEnumerable(Of T)
)

Parameters

collection
Type: System.Collections.GenericIEnumerable T
The collection from which the elements are copied.
See Also

Reference

DataObjectBaseCollectionT Class
DataObjectBaseCollectionT Overload
SchemaExplorer Namespace


DataObjectBaseCollection(T) Constructor (Int32)

DataObjectBaseCollectionT Constructor (Int32)

Initializes a new instance of the DataObjectBaseCollectionT class.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public DataObjectBaseCollection(
    int capacity
)
Public Sub New (
    capacity As Integer
)

Parameters

capacity
Type: SystemInt32
The number of elements that the new list can initially store.
See Also

Reference

DataObjectBaseCollectionT Class
DataObjectBaseCollectionT Overload
SchemaExplorer Namespace


DataObjectBaseCollection(T) Methods

DataObjectBaseCollectionT Methods

The DataObjectBaseCollectionT generic type exposes the following members.

Methods
 | Name | Description
Public method | Clone | (Inherited from SchemaObjectCollectionT.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh | (Inherited from SchemaObjectCollectionT.)
Public method | ToString | (Inherited from SchemaObjectCollectionT.)
Top
See Also

Reference

DataObjectBaseCollectionT Class
SchemaExplorer Namespace


DataSource Class

Used to store information about a data source.
Inheritance Hierarchy
SystemObject
SchemaExplorerDataSource

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
public class DataSource : INotifyPropertyChanged, IEquatable<DataSource>
<SerializableAttribute>
Public Class DataSource
    Implements INotifyPropertyChanged, IEquatable(Of DataSource)

The DataSource type exposes the following members.

Constructors
 | Name | Description
Public method | DataSource | Initializes a new instance of the DataSource class
Public method | DataSource(String, String, String) | Initializes a new instance of the DataSource class
Public method | DataSource(String, String, Type) | Initializes a new instance of the DataSource class
Public method | DataSource(String, String, String, Boolean) | Initializes a new instance of the DataSource class
Public method | DataSource(String, String, Type, Boolean) | Initializes a new instance of the DataSource class
Top
Properties
 | Name | Description
Public property | ConnectionString |
Public property | IsSelected |
Public property | Name |
Public property | OriginalName |
Public property | ProviderType |
Public property | ProviderTypeName |
Public property | SchemaProvider |
Top
Methods
 | Name | Description
Public method | CreateInstance |
Public method | Equals(DataSource) |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaisePropertyChanged(PropertyChangedEventArgs) |
Protected method | RaisePropertyChanged(String) |
Public method | TestConnection |
Public method | ToString | (Overrides ObjectToString.)
Top
Events
 | Name | Description
Public event | PropertyChanged |
Top
Operators
Name | Description
Equality |
Inequality |
Top
See Also

Reference

SchemaExplorer Namespace


DataSource Constructor

Overload List
 | Name | Description
Public method | DataSource | Initializes a new instance of the DataSource class
Public method | DataSource(String, String, String) | Initializes a new instance of the DataSource class
Public method | DataSource(String, String, Type) | Initializes a new instance of the DataSource class
Public method | DataSource(String, String, String, Boolean) | Initializes a new instance of the DataSource class
Public method | DataSource(String, String, Type, Boolean) | Initializes a new instance of the DataSource class
Top
See Also

Reference

DataSource Class
SchemaExplorer Namespace


DataSource Constructor

Initializes a new instance of the DataSource class

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public DataSource()
Public Sub New
See Also

Reference

DataSource Class
DataSource Overload
SchemaExplorer Namespace


DataSource Constructor (String, String, String)

Initializes a new instance of the DataSource class

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public DataSource(
    string name,
    string connectionString,
    string providerType
)
Public Sub New (
    name As String,
    connectionString As String,
    providerType As String
)

Parameters

name
Type: SystemString
connectionString
Type: SystemString
providerType
Type: SystemString
See Also

Reference

DataSource Class
DataSource Overload
SchemaExplorer Namespace


DataSource Constructor (String, String, Type)

Initializes a new instance of the DataSource class

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public DataSource(
    string name,
    string connectionString,
    Type providerType
)
Public Sub New (
    name As String,
    connectionString As String,
    providerType As Type
)

Parameters

name
Type: SystemString
connectionString
Type: SystemString
providerType
Type: SystemType
See Also

Reference

DataSource Class
DataSource Overload
SchemaExplorer Namespace


DataSource Constructor (String, String, String, Boolean)

Initializes a new instance of the DataSource class

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public DataSource(
    string name,
    string connectionString,
    string providerType,
    bool isSelected
)
Public Sub New (
    name As String,
    connectionString As String,
    providerType As String,
    isSelected As Boolean
)

Parameters

name
Type: SystemString
connectionString
Type: SystemString
providerType
Type: SystemString
isSelected
Type: SystemBoolean
See Also

Reference

DataSource Class
DataSource Overload
SchemaExplorer Namespace


DataSource Constructor (String, String, Type, Boolean)

Initializes a new instance of the DataSource class

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public DataSource(
    string name,
    string connectionString,
    Type providerType,
    bool isSelected
)
Public Sub New (
    name As String,
    connectionString As String,
    providerType As Type,
    isSelected As Boolean
)

Parameters

name
Type: SystemString
connectionString
Type: SystemString
providerType
Type: SystemType
isSelected
Type: SystemBoolean
See Also

Reference

DataSource Class
DataSource Overload
SchemaExplorer Namespace


DataSource Properties

The DataSource type exposes the following members.

Properties
 | Name | Description
Public property | ConnectionString |
Public property | IsSelected |
Public property | Name |
Public property | OriginalName |
Public property | ProviderType |
Public property | ProviderTypeName |
Public property | SchemaProvider |
Top
See Also

Reference

DataSource Class
SchemaExplorer Namespace


DataSource.ConnectionString Property

DataSourceConnectionString Property

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string ConnectionString { get; set; }
Public Property ConnectionString As String
    Get
    Set

Property Value

Type: String
See Also

Reference

DataSource Class
SchemaExplorer Namespace


DataSource.IsSelected Property

DataSourceIsSelected Property

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool IsSelected { get; set; }
Public Property IsSelected As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

DataSource Class
SchemaExplorer Namespace


DataSource.Name Property

DataSourceName Property

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set

Property Value

Type: String
See Also

Reference

DataSource Class
SchemaExplorer Namespace


DataSource.OriginalName Property

DataSourceOriginalName Property

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string OriginalName { get; set; }
Public Property OriginalName As String
    Get
    Set

Property Value

Type: String
See Also

Reference

DataSource Class
SchemaExplorer Namespace


DataSource.ProviderType Property

DataSourceProviderType Property

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public Type ProviderType { get; set; }
Public Property ProviderType As Type
    Get
    Set

Property Value

Type: Type
See Also

Reference

DataSource Class
SchemaExplorer Namespace


DataSource.ProviderTypeName Property

DataSourceProviderTypeName Property

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string ProviderTypeName { get; set; }
Public Property ProviderTypeName As String
    Get
    Set

Property Value

Type: String
See Also

Reference

DataSource Class
SchemaExplorer Namespace


DataSource.SchemaProvider Property

DataSourceSchemaProvider Property

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public SchemaProvider SchemaProvider { get; set; }
Public Property SchemaProvider As SchemaProvider
    Get
    Set

Property Value

Type: SchemaProvider
See Also

Reference

DataSource Class
SchemaExplorer Namespace


DataSource Methods

The DataSource type exposes the following members.

Methods
 | Name | Description
Public method | CreateInstance |
Public method | Equals(DataSource) |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaisePropertyChanged(PropertyChangedEventArgs) |
Protected method | RaisePropertyChanged(String) |
Public method | TestConnection |
Public method | ToString | (Overrides ObjectToString.)
Top
See Also

Reference

DataSource Class
SchemaExplorer Namespace


DataSource.CreateInstance Method

DataSourceCreateInstance Method

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public DatabaseSchema CreateInstance()
Public Function CreateInstance As DatabaseSchema

Return Value

Type: DatabaseSchema
See Also

Reference

DataSource Class
SchemaExplorer Namespace


DataSource.Equals Method

DataSourceEquals Method

Overload List
 | Name | Description
Public method | Equals(DataSource) |
Public method | Equals(Object) | (Overrides ObjectEquals(Object).)
Top
See Also

Reference

DataSource Class
SchemaExplorer Namespace


DataSource.Equals Method (DataSource)

DataSourceEquals Method (DataSource)

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool Equals(
    DataSource other
)
Public Function Equals (
    other As DataSource
) As Boolean

Parameters

other
Type: SchemaExplorerDataSource

Return Value

Type: Boolean

Implements

IEquatableTEquals(T)
See Also

Reference

DataSource Class
Equals Overload
SchemaExplorer Namespace


DataSource.Equals Method (Object)

DataSourceEquals Method (Object)

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject

Return Value

Type: Boolean
See Also

Reference

DataSource Class
Equals Overload
SchemaExplorer Namespace


DataSource.GetHashCode Method

DataSourceGetHashCode Method

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
See Also

Reference

DataSource Class
SchemaExplorer Namespace


DataSource.RaisePropertyChanged Method

DataSourceRaisePropertyChanged Method

Overload List
 | Name | Description
Protected method | RaisePropertyChanged(PropertyChangedEventArgs) |
Protected method | RaisePropertyChanged(String) |
Top
See Also

Reference

DataSource Class
SchemaExplorer Namespace


DataSource.RaisePropertyChanged Method (PropertyChangedEventArgs)

DataSourceRaisePropertyChanged Method (PropertyChangedEventArgs)

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected void RaisePropertyChanged(
    PropertyChangedEventArgs e
)
Protected Sub RaisePropertyChanged (
    e As PropertyChangedEventArgs
)

Parameters

e
Type: System.ComponentModelPropertyChangedEventArgs
See Also

Reference

DataSource Class
RaisePropertyChanged Overload
SchemaExplorer Namespace


DataSource.RaisePropertyChanged Method (String)

DataSourceRaisePropertyChanged Method (String)

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected void RaisePropertyChanged(
    string name
)
Protected Sub RaisePropertyChanged (
    name As String
)

Parameters

name
Type: SystemString
See Also

Reference

DataSource Class
RaisePropertyChanged Overload
SchemaExplorer Namespace


DataSource.TestConnection Method

DataSourceTestConnection Method

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool TestConnection()
Public Function TestConnection As Boolean

Return Value

Type: Boolean
See Also

Reference

DataSource Class
SchemaExplorer Namespace


DataSource.ToString Method

DataSourceToString Method

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
See Also

Reference

DataSource Class
SchemaExplorer Namespace


DataSource Events

The DataSource type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged |
Top
See Also

Reference

DataSource Class
SchemaExplorer Namespace


DataSource.PropertyChanged Event

DataSourcePropertyChanged Event

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public event PropertyChangedEventHandler PropertyChanged
Public Event PropertyChanged As PropertyChangedEventHandler

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

DataSource Class
SchemaExplorer Namespace


DataSource Operators

The DataSource type exposes the following members.

Operators
Name | Description
Equality |
Inequality |
Top
See Also

Reference

DataSource Class
SchemaExplorer Namespace


DataSource.Equality Operator

DataSourceEquality Operator

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static bool operator ==(
    DataSource left,
    DataSource right
)
Public Shared Operator = (
    left As DataSource,
    right As DataSource
) As Boolean

Parameters

left
Type: SchemaExplorerDataSource
right
Type: SchemaExplorerDataSource

Return Value

Type: Boolean
See Also

Reference

DataSource Class
SchemaExplorer Namespace


DataSource.Inequality Operator

DataSourceInequality Operator

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static bool operator !=(
    DataSource left,
    DataSource right
)
Public Shared Operator <> (
    left As DataSource,
    right As DataSource
) As Boolean

Parameters

left
Type: SchemaExplorerDataSource
right
Type: SchemaExplorerDataSource

Return Value

Type: Boolean
See Also

Reference

DataSource Class
SchemaExplorer Namespace


DataSourceCollection Class

Implements a strongly typed collection of DataSource elements.
Inheritance Hierarchy
SystemObject
ObservableListDataSource
SchemaExplorerDataSourceCollection

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
public class DataSourceCollection : ObservableList<DataSource>
<SerializableAttribute>
Public Class DataSourceCollection
    Inherits ObservableList(Of DataSource)

The DataSourceCollection type exposes the following members.

Constructors
 | Name | Description
Public method | DataSourceCollection | Initializes a new instance of the DataSourceCollection class.
Public method | DataSourceCollection(IEnumerableDataSource) | Initializes a new instance of the DataSourceCollection class.
Public method | DataSourceCollection(Int32) | Initializes a new instance of the DataSourceCollection class.
Top
Properties
 | Name | Description
Public property | Item | Gets the DataSource with the specified name.
Top
Methods
 | Name | Description
Public method | Clone |
Public method | Contains | Determines whether an element is in the collection with the specified name.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the list.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Remarks
DataSourceCollection provides an ObservableList that is strongly typed for DataSource elements.
See Also

Reference

SchemaExplorer Namespace


DataSourceCollection Constructor

Overload List
 | Name | Description
Public method | DataSourceCollection | Initializes a new instance of the DataSourceCollection class.
Public method | DataSourceCollection(IEnumerableDataSource) | Initializes a new instance of the DataSourceCollection class.
Public method | DataSourceCollection(Int32) | Initializes a new instance of the DataSourceCollection class.
Top
See Also

Reference

DataSourceCollection Class
SchemaExplorer Namespace


DataSourceCollection Constructor

Initializes a new instance of the DataSourceCollection class.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public DataSourceCollection()
Public Sub New
See Also

Reference

DataSourceCollection Class
DataSourceCollection Overload
SchemaExplorer Namespace


DataSourceCollection Constructor (IEnumerable(DataSource))

DataSourceCollection Constructor (IEnumerableDataSource)

Initializes a new instance of the DataSourceCollection class.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public DataSourceCollection(
    IEnumerable<DataSource> collection
)
Public Sub New (
    collection As IEnumerable(Of DataSource)
)

Parameters

collection
Type: System.Collections.GenericIEnumerable DataSource
The collection from which the elements are copied.
See Also

Reference

DataSourceCollection Class
DataSourceCollection Overload
SchemaExplorer Namespace


DataSourceCollection Constructor (Int32)

Initializes a new instance of the DataSourceCollection class.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public DataSourceCollection(
    int capacity
)
Public Sub New (
    capacity As Integer
)

Parameters

capacity
Type: SystemInt32
The number of elements that the new list can initially store.
See Also

Reference

DataSourceCollection Class
DataSourceCollection Overload
SchemaExplorer Namespace


DataSourceCollection Properties

The DataSourceCollection type exposes the following members.

Properties
 | Name | Description
Public property | Item | Gets the DataSource with the specified name.
Top
See Also

Reference

DataSourceCollection Class
SchemaExplorer Namespace


DataSourceCollection.Item Property

DataSourceCollectionItem Property

Gets the DataSource with the specified name.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public DataSource this[
    string name
] { get; }
Public ReadOnly Default Property Item (
    name As String
) As DataSource
    Get

Parameters

name
Type: SystemString

Return Value

Type: DataSource
The DataSource with the specified name.
See Also

Reference

DataSourceCollection Class
SchemaExplorer Namespace


DataSourceCollection Methods

The DataSourceCollection type exposes the following members.

Methods
 | Name | Description
Public method | Clone |
Public method | Contains | Determines whether an element is in the collection with the specified name.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the list.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DataSourceCollection Class
SchemaExplorer Namespace


DataSourceCollection.Clone Method

DataSourceCollectionClone Method

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual Object Clone()
Public Overridable Function Clone As Object

Return Value

Type: Object
See Also

Reference

DataSourceCollection Class
SchemaExplorer Namespace


DataSourceCollection.Contains Method

DataSourceCollectionContains Method

Determines whether an element is in the collection with the specified name.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool Contains(
    string name
)
Public Function Contains (
    name As String
) As Boolean

Parameters

name
Type: SystemString
The name of the item to locate in the collection.

Return Value

Type: Boolean
true if item is found in the collection; otherwise, false.
See Also

Reference

DataSourceCollection Class
SchemaExplorer Namespace


DataSourceCollection.IndexOf Method

DataSourceCollectionIndexOf Method

Determines the index of a specific item in the list.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public int IndexOf(
    string name
)
Public Function IndexOf (
    name As String
) As Integer

Parameters

name
Type: SystemString
The name of the item to locate in the list.

Return Value

Type: Int32
The index of item if found in the list; otherwise, -1.
See Also

Reference

DataSourceCollection Class
SchemaExplorer Namespace


DataSourceManager Class

Inheritance Hierarchy
SystemObject
SchemaExplorerDataSourceManager

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class DataSourceManager
Public Class DataSourceManager

The DataSourceManager type exposes the following members.

Constructors
 | Name | Description
Public method | DataSourceManager | Initializes a new instance of the DataSourceManager class
Top
Properties
Name | Description
DataSources |
LastSelectedDataSource |
SchemaProviders |
Top
Methods
 | Name | Description
 | Delete |
 | DeleteProviders |
 | DeleteProviders(IEnumerableSchemaProvider) |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | Exists |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FindProviders |
 | GetDataSources |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetProviders |
 | GetProviders(Boolean) |
 | GetSelected |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Save |
 | SaveProvider |
 | SaveProviders(IEnumerableSchemaProvider) |
 | SaveProviders(IEnumerableString) |
 | Serialize |
 | SetSelected |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SchemaExplorer Namespace


DataSourceManager Constructor

Initializes a new instance of the DataSourceManager class

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public DataSourceManager()
Public Sub New
See Also

Reference

DataSourceManager Class
SchemaExplorer Namespace


DataSourceManager Properties

The DataSourceManager type exposes the following members.

Properties
Name | Description
DataSources |
LastSelectedDataSource |
SchemaProviders |
Top
See Also

Reference

DataSourceManager Class
SchemaExplorer Namespace


DataSourceManager.DataSources Property

DataSourceManagerDataSources Property

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static DataSourceCollection DataSources { get; }
Public Shared ReadOnly Property DataSources As DataSourceCollection
    Get

Property Value

Type: DataSourceCollection
See Also

Reference

DataSourceManager Class
SchemaExplorer Namespace


DataSourceManager.LastSelectedDataSource Property

DataSourceManagerLastSelectedDataSource Property

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static DataSource LastSelectedDataSource { get; set; }
Public Shared Property LastSelectedDataSource As DataSource
    Get
    Set

Property Value

Type: DataSource
See Also

Reference

DataSourceManager Class
SchemaExplorer Namespace


DataSourceManager.SchemaProviders Property

DataSourceManagerSchemaProviders Property

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static IList<SchemaProvider> SchemaProviders { get; }
Public Shared ReadOnly Property SchemaProviders As IList(Of SchemaProvider)
    Get

Property Value

Type: IList SchemaProvider
See Also

Reference

DataSourceManager Class
SchemaExplorer Namespace


DataSourceManager Methods

The DataSourceManager type exposes the following members.

Methods
 | Name | Description
 | Delete |
 | DeleteProviders |
 | DeleteProviders(IEnumerableSchemaProvider) |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | Exists |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FindProviders |
 | GetDataSources |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetProviders |
 | GetProviders(Boolean) |
 | GetSelected |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Save |
 | SaveProvider |
 | SaveProviders(IEnumerableSchemaProvider) |
 | SaveProviders(IEnumerableString) |
 | Serialize |
 | SetSelected |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DataSourceManager Class
SchemaExplorer Namespace


DataSourceManager.Delete Method

DataSourceManagerDelete Method

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static void Delete(
    DataSource dataSource
)
Public Shared Sub Delete (
    dataSource As DataSource
)

Parameters

dataSource
Type: SchemaExplorerDataSource
See Also

Reference

DataSourceManager Class
SchemaExplorer Namespace


DataSourceManager.DeleteProviders Method

DataSourceManagerDeleteProviders Method

Overload List
Name | Description
DeleteProviders |
DeleteProviders(IEnumerableSchemaProvider) |
Top
See Also

Reference

DataSourceManager Class
SchemaExplorer Namespace


DataSourceManager.DeleteProviders Method

DataSourceManagerDeleteProviders Method

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static void DeleteProviders()
Public Shared Sub DeleteProviders
See Also

Reference

DataSourceManager Class
DeleteProviders Overload
SchemaExplorer Namespace


DataSourceManager.DeleteProviders Method (IEnumerable(SchemaProvider))

DataSourceManagerDeleteProviders Method (IEnumerableSchemaProvider)

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static void DeleteProviders(
    IEnumerable<SchemaProvider> providers
)
Public Shared Sub DeleteProviders (
    providers As IEnumerable(Of SchemaProvider)
)

Parameters

providers
Type: System.Collections.GenericIEnumerable SchemaProvider
See Also

Reference

DataSourceManager Class
DeleteProviders Overload
SchemaExplorer Namespace


DataSourceManager.Exists Method

DataSourceManagerExists Method

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static bool Exists(
    DataSource dataSource
)
Public Shared Function Exists (
    dataSource As DataSource
) As Boolean

Parameters

dataSource
Type: SchemaExplorerDataSource

Return Value

Type: Boolean
See Also

Reference

DataSourceManager Class
SchemaExplorer Namespace


DataSourceManager.FindProviders Method

DataSourceManagerFindProviders Method

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static IEnumerable<SchemaProvider> FindProviders()
Public Shared Function FindProviders As IEnumerable(Of SchemaProvider)

Return Value

Type: IEnumerable SchemaProvider
See Also

Reference

DataSourceManager Class
SchemaExplorer Namespace


DataSourceManager.GetDataSources Method

DataSourceManagerGetDataSources Method

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static DataSourceCollection GetDataSources()
Public Shared Function GetDataSources As DataSourceCollection

Return Value

Type: DataSourceCollection
See Also

Reference

DataSourceManager Class
SchemaExplorer Namespace


DataSourceManager.GetProviders Method

DataSourceManagerGetProviders Method

Overload List
Name | Description
GetProviders |
GetProviders(Boolean) |
Top
See Also

Reference

DataSourceManager Class
SchemaExplorer Namespace


DataSourceManager.GetProviders Method

DataSourceManagerGetProviders Method

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static IEnumerable<SchemaProvider> GetProviders()
Public Shared Function GetProviders As IEnumerable(Of SchemaProvider)

Return Value

Type: IEnumerable SchemaProvider
See Also

Reference

DataSourceManager Class
GetProviders Overload
SchemaExplorer Namespace


DataSourceManager.GetProviders Method (Boolean)

DataSourceManagerGetProviders Method (Boolean)

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static IEnumerable<SchemaProvider> GetProviders(
    bool probe
)
Public Shared Function GetProviders (
    probe As Boolean
) As IEnumerable(Of SchemaProvider)

Parameters

probe
Type: SystemBoolean

Return Value

Type: IEnumerable SchemaProvider
See Also

Reference

DataSourceManager Class
GetProviders Overload
SchemaExplorer Namespace


DataSourceManager.GetSelected Method

DataSourceManagerGetSelected Method

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static DataSource GetSelected()
Public Shared Function GetSelected As DataSource

Return Value

Type: DataSource
See Also

Reference

DataSourceManager Class
SchemaExplorer Namespace


DataSourceManager.Save Method

DataSourceManagerSave Method

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static void Save(
    DataSource dataSource
)
Public Shared Sub Save (
    dataSource As DataSource
)

Parameters

dataSource
Type: SchemaExplorerDataSource
See Also

Reference

DataSourceManager Class
SchemaExplorer Namespace


DataSourceManager.SaveProvider Method

DataSourceManagerSaveProvider Method

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static void SaveProvider(
    SchemaProvider provider
)
Public Shared Sub SaveProvider (
    provider As SchemaProvider
)

Parameters

provider
Type: SchemaExplorerSchemaProvider
See Also

Reference

DataSourceManager Class
SchemaExplorer Namespace


DataSourceManager.SaveProviders Method

DataSourceManagerSaveProviders Method

Overload List
Name | Description
SaveProviders(IEnumerableSchemaProvider) |
SaveProviders(IEnumerableString) |
Top
See Also

Reference

DataSourceManager Class
SchemaExplorer Namespace


DataSourceManager.SaveProviders Method (IEnumerable(SchemaProvider))

DataSourceManagerSaveProviders Method (IEnumerableSchemaProvider)

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static void SaveProviders(
    IEnumerable<SchemaProvider> providers
)
Public Shared Sub SaveProviders (
    providers As IEnumerable(Of SchemaProvider)
)

Parameters

providers
Type: System.Collections.GenericIEnumerable SchemaProvider
See Also

Reference

DataSourceManager Class
SaveProviders Overload
SchemaExplorer Namespace


DataSourceManager.SaveProviders Method (IEnumerable(String))

DataSourceManagerSaveProviders Method (IEnumerableString)

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static void SaveProviders(
    IEnumerable<string> providers
)
Public Shared Sub SaveProviders (
    providers As IEnumerable(Of String)
)

Parameters

providers
Type: System.Collections.GenericIEnumerable String
See Also

Reference

DataSourceManager Class
SaveProviders Overload
SchemaExplorer Namespace


DataSourceManager.Serialize Method

DataSourceManagerSerialize Method

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static void Serialize()
Public Shared Sub Serialize
See Also

Reference

DataSourceManager Class
SchemaExplorer Namespace


DataSourceManager.SetSelected Method

DataSourceManagerSetSelected Method

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static void SetSelected(
    DataSource dataSource
)
Public Shared Sub SetSelected (
    dataSource As DataSource
)

Parameters

dataSource
Type: SchemaExplorerDataSource
See Also

Reference

DataSourceManager Class
SchemaExplorer Namespace


ExtendedProperty Class

Inheritance Hierarchy
SystemObject
SchemaExplorerExtendedProperty

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
public class ExtendedProperty : IExtendedProperty,
    INotifyPropertyChanged
<SerializableAttribute>
Public Class ExtendedProperty
    Implements IExtendedProperty, INotifyPropertyChanged

The ExtendedProperty type exposes the following members.

Constructors
 | Name | Description
Public method | ExtendedProperty | Initializes a new instance of the ExtendedProperty class
Public method | ExtendedProperty(String, Object, DbType) | Initializes a new instance of the ExtendedProperty class
Public method | ExtendedProperty(String, Object, DbType, PropertyStateEnum) | Initializes a new instance of the ExtendedProperty class
Top
Properties
 | Name | Description
Public property | DataType | The data type of this extended property.
Public property | Name | The name of this extended property.
Public property | PropertyState |
Public property | Value | The value of this extended property.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged(PropertyChangedEventArgs) |
Protected method | OnPropertyChanged(String) |
 | Readonly(String, Boolean) |
 | Readonly(String, Int32) |
 | Readonly(String, Int64) |
 | Readonly(String, String) |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Events
 | Name | Description
Public event | PropertyChanged |
Top
See Also

Reference

SchemaExplorer Namespace


ExtendedProperty Constructor

Overload List
 | Name | Description
Public method | ExtendedProperty | Initializes a new instance of the ExtendedProperty class
Public method | ExtendedProperty(String, Object, DbType) | Initializes a new instance of the ExtendedProperty class
Public method | ExtendedProperty(String, Object, DbType, PropertyStateEnum) | Initializes a new instance of the ExtendedProperty class
Top
See Also

Reference

ExtendedProperty Class
SchemaExplorer Namespace


ExtendedProperty Constructor

Initializes a new instance of the ExtendedProperty class

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ExtendedProperty()
Public Sub New
See Also

Reference

ExtendedProperty Class
ExtendedProperty Overload
SchemaExplorer Namespace


ExtendedProperty Constructor (String, Object, DbType)

Initializes a new instance of the ExtendedProperty class

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ExtendedProperty(
    string name,
    Object value,
    DbType dataType
)
Public Sub New (
    name As String,
    value As Object,
    dataType As DbType
)

Parameters

name
Type: SystemString
value
Type: SystemObject
dataType
Type: System.DataDbType
See Also

Reference

ExtendedProperty Class
ExtendedProperty Overload
SchemaExplorer Namespace


ExtendedProperty Constructor (String, Object, DbType, PropertyStateEnum)

Initializes a new instance of the ExtendedProperty class

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ExtendedProperty(
    string name,
    Object value,
    DbType dataType,
    PropertyStateEnum state
)
Public Sub New (
    name As String,
    value As Object,
    dataType As DbType,
    state As PropertyStateEnum
)

Parameters

name
Type: SystemString
value
Type: SystemObject
dataType
Type: System.DataDbType
state
Type: SchemaExplorerPropertyStateEnum
See Also

Reference

ExtendedProperty Class
ExtendedProperty Overload
SchemaExplorer Namespace


ExtendedProperty Properties

The ExtendedProperty type exposes the following members.

Properties
 | Name | Description
Public property | DataType | The data type of this extended property.
Public property | Name | The name of this extended property.
Public property | PropertyState |
Public property | Value | The value of this extended property.
Top
See Also

Reference

ExtendedProperty Class
SchemaExplorer Namespace


ExtendedProperty.DataType Property

ExtendedPropertyDataType Property

The data type of this extended property.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public DbType DataType { get; }
Public ReadOnly Property DataType As DbType
    Get

Property Value

Type: DbType

Implements

IExtendedPropertyDataType
See Also

Reference

ExtendedProperty Class
SchemaExplorer Namespace


ExtendedProperty.Name Property

ExtendedPropertyName Property

The name of this extended property.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get

Property Value

Type: String
See Also

Reference

ExtendedProperty Class
SchemaExplorer Namespace


ExtendedProperty.PropertyState Property

ExtendedPropertyPropertyState Property

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public PropertyStateEnum PropertyState { get; set; }
Public Property PropertyState As PropertyStateEnum
    Get
    Set

Property Value

Type: PropertyStateEnum

Implements

IExtendedPropertyPropertyState
See Also

Reference

ExtendedProperty Class
SchemaExplorer Namespace


ExtendedProperty.Value Property

ExtendedPropertyValue Property

The value of this extended property.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public Object Value { get; set; }
Public Property Value As Object
    Get
    Set

Property Value

Type: Object

Implements

IExtendedPropertyValue
See Also

Reference

ExtendedProperty Class
SchemaExplorer Namespace


ExtendedProperty Methods

The ExtendedProperty type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged(PropertyChangedEventArgs) |
Protected method | OnPropertyChanged(String) |
 | Readonly(String, Boolean) |
 | Readonly(String, Int32) |
 | Readonly(String, Int64) |
 | Readonly(String, String) |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ExtendedProperty Class
SchemaExplorer Namespace


ExtendedProperty.OnPropertyChanged Method

ExtendedPropertyOnPropertyChanged Method

Overload List
 | Name | Description
Protected method | OnPropertyChanged(PropertyChangedEventArgs) |
Protected method | OnPropertyChanged(String) |
Top
See Also

Reference

ExtendedProperty Class
SchemaExplorer Namespace


ExtendedProperty.OnPropertyChanged Method (PropertyChangedEventArgs)

ExtendedPropertyOnPropertyChanged Method (PropertyChangedEventArgs)

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual void OnPropertyChanged(
    PropertyChangedEventArgs e
)
Protected Overridable Sub OnPropertyChanged (
    e As PropertyChangedEventArgs
)

Parameters

e
Type: System.ComponentModelPropertyChangedEventArgs
See Also

Reference

ExtendedProperty Class
OnPropertyChanged Overload
SchemaExplorer Namespace


ExtendedProperty.OnPropertyChanged Method (String)

ExtendedPropertyOnPropertyChanged Method (String)

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual void OnPropertyChanged(
    string propertyName
)
Protected Overridable Sub OnPropertyChanged (
    propertyName As String
)

Parameters

propertyName
Type: SystemString
See Also

Reference

ExtendedProperty Class
OnPropertyChanged Overload
SchemaExplorer Namespace


ExtendedProperty.Readonly Method

ExtendedPropertyReadonly Method

Overload List
Name | Description
Readonly(String, Boolean) |
Readonly(String, Int32) |
Readonly(String, Int64) |
Readonly(String, String) |
Top
See Also

Reference

ExtendedProperty Class
SchemaExplorer Namespace


ExtendedProperty.Readonly Method (String, Boolean)

ExtendedPropertyReadonly Method (String, Boolean)

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static ExtendedProperty Readonly(
    string name,
    bool value
)
Public Shared Function Readonly (
    name As String,
    value As Boolean
) As ExtendedProperty

Parameters

name
Type: SystemString
value
Type: SystemBoolean

Return Value

Type: ExtendedProperty
See Also

Reference

ExtendedProperty Class
Readonly Overload
SchemaExplorer Namespace


ExtendedProperty.Readonly Method (String, Int32)

ExtendedPropertyReadonly Method (String, Int32)

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static ExtendedProperty Readonly(
    string name,
    int value
)
Public Shared Function Readonly (
    name As String,
    value As Integer
) As ExtendedProperty

Parameters

name
Type: SystemString
value
Type: SystemInt32

Return Value

Type: ExtendedProperty
See Also

Reference

ExtendedProperty Class
Readonly Overload
SchemaExplorer Namespace


ExtendedProperty.Readonly Method (String, Int64)

ExtendedPropertyReadonly Method (String, Int64)

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static ExtendedProperty Readonly(
    string name,
    long value
)
Public Shared Function Readonly (
    name As String,
    value As Long
) As ExtendedProperty

Parameters

name
Type: SystemString
value
Type: SystemInt64

Return Value

Type: ExtendedProperty
See Also

Reference

ExtendedProperty Class
Readonly Overload
SchemaExplorer Namespace


ExtendedProperty.Readonly Method (String, String)

ExtendedPropertyReadonly Method (String, String)

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static ExtendedProperty Readonly(
    string name,
    string value
)
Public Shared Function Readonly (
    name As String,
    value As String
) As ExtendedProperty

Parameters

name
Type: SystemString
value
Type: SystemString

Return Value

Type: ExtendedProperty
See Also

Reference

ExtendedProperty Class
Readonly Overload
SchemaExplorer Namespace


ExtendedProperty Events

The ExtendedProperty type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged |
Top
See Also

Reference

ExtendedProperty Class
SchemaExplorer Namespace


ExtendedProperty.PropertyChanged Event

ExtendedPropertyPropertyChanged Event

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public event PropertyChangedEventHandler PropertyChanged
Public Event PropertyChanged As PropertyChangedEventHandler

Value

Type: System.ComponentModelPropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

ExtendedProperty Class
SchemaExplorer Namespace


ExtendedPropertyCollection Class

Implements a strongly typed collection of ExtendedProperty elements.
Inheritance Hierarchy
SystemObject
ObservableListExtendedProperty
NamedObjectCollectionExtendedProperty
SchemaExplorerExtendedPropertyCollection

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
[TypeConverterAttribute(typeof(ExtendedPropertyCollectionTypeConverter))]
public class ExtendedPropertyCollection : NamedObjectCollection<ExtendedProperty>
<SerializableAttribute>
<TypeConverterAttribute(GetType(ExtendedPropertyCollectionTypeConverter))>
Public Class ExtendedPropertyCollection
    Inherits NamedObjectCollection(Of ExtendedProperty)

The ExtendedPropertyCollection type exposes the following members.

Constructors
 | Name | Description
Public method | ExtendedPropertyCollection | Initializes a new instance of the ExtendedPropertyCollection class.
Public method | ExtendedPropertyCollection(IEnumerableExtendedProperty) | Initializes a new instance of the ExtendedPropertyCollection class.
Public method | ExtendedPropertyCollection(Int32) | Initializes a new instance of the ExtendedPropertyCollection class.
Top
Methods
 | Name | Description
Public method | Clone |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Top
Remarks
ExtendedPropertyCollection provides an ObservableList that is strongly typed for ExtendedProperty elements.
See Also

Reference

SchemaExplorer Namespace


ExtendedPropertyCollection Constructor

Overload List
 | Name | Description
Public method | ExtendedPropertyCollection | Initializes a new instance of the ExtendedPropertyCollection class.
Public method | ExtendedPropertyCollection(IEnumerableExtendedProperty) | Initializes a new instance of the ExtendedPropertyCollection class.
Public method | ExtendedPropertyCollection(Int32) | Initializes a new instance of the ExtendedPropertyCollection class.
Top
See Also

Reference

ExtendedPropertyCollection Class
SchemaExplorer Namespace


ExtendedPropertyCollection Constructor

Initializes a new instance of the ExtendedPropertyCollection class.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ExtendedPropertyCollection()
Public Sub New
See Also

Reference

ExtendedPropertyCollection Class
ExtendedPropertyCollection Overload
SchemaExplorer Namespace


ExtendedPropertyCollection Constructor (IEnumerable(ExtendedProperty))

ExtendedPropertyCollection Constructor (IEnumerableExtendedProperty)

Initializes a new instance of the ExtendedPropertyCollection class.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ExtendedPropertyCollection(
    IEnumerable<ExtendedProperty> collection
)
Public Sub New (
    collection As IEnumerable(Of ExtendedProperty)
)

Parameters

collection
Type: System.Collections.GenericIEnumerable ExtendedProperty
The collection from which the elements are copied.
See Also

Reference

ExtendedPropertyCollection Class
ExtendedPropertyCollection Overload
SchemaExplorer Namespace


ExtendedPropertyCollection Constructor (Int32)

Initializes a new instance of the ExtendedPropertyCollection class.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ExtendedPropertyCollection(
    int capacity
)
Public Sub New (
    capacity As Integer
)

Parameters

capacity
Type: SystemInt32
The number of elements that the new list can initially store.
See Also

Reference

ExtendedPropertyCollection Class
ExtendedPropertyCollection Overload
SchemaExplorer Namespace


ExtendedPropertyCollection Methods

The ExtendedPropertyCollection type exposes the following members.

Methods
 | Name | Description
Public method | Clone |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Top
See Also

Reference

ExtendedPropertyCollection Class
SchemaExplorer Namespace


ExtendedPropertyCollection.Clone Method

ExtendedPropertyCollectionClone Method

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual Object Clone()
Public Overridable Function Clone As Object

Return Value

Type: Object
See Also

Reference

ExtendedPropertyCollection Class
SchemaExplorer Namespace


ExtendedPropertyCollectionTypeConverter Class

Inheritance Hierarchy
SystemObject
System.ComponentModelTypeConverter
SchemaExplorerExtendedPropertyCollectionTypeConverter

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class ExtendedPropertyCollectionTypeConverter : TypeConverter
Public Class ExtendedPropertyCollectionTypeConverter
    Inherits TypeConverter

The ExtendedPropertyCollectionTypeConverter type exposes the following members.

Constructors
 | Name | Description
Public method | ExtendedPropertyCollectionTypeConverter | Initializes a new instance of the ExtendedPropertyCollectionTypeConverter class
Top
Methods
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context. (Inherited from TypeConverter.)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | (Overrides TypeConverterCanConvertTo(ITypeDescriptorContext, Type).)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts the given object to the type of this converter, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
Public method | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | (Overrides TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Public method | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
Public method | CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Protected method | GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object, Attribute) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported | Returns whether this object supports properties. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | Returns whether this object supports properties, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValues | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
Public method | GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
Public method | IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SchemaExplorer Namespace


ExtendedPropertyCollectionTypeConverter Constructor

Initializes a new instance of the ExtendedPropertyCollectionTypeConverter class

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ExtendedPropertyCollectionTypeConverter()
Public Sub New
See Also

Reference

ExtendedPropertyCollectionTypeConverter Class
SchemaExplorer Namespace


ExtendedPropertyCollectionTypeConverter Methods

The ExtendedPropertyCollectionTypeConverter type exposes the following members.

Methods
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context. (Inherited from TypeConverter.)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | (Overrides TypeConverterCanConvertTo(ITypeDescriptorContext, Type).)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts the given object to the type of this converter, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
Public method | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | (Overrides TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Public method | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
Public method | CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Protected method | GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object, Attribute) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported | Returns whether this object supports properties. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | Returns whether this object supports properties, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValues | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
Public method | GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
Public method | IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ExtendedPropertyCollectionTypeConverter Class
SchemaExplorer Namespace


ExtendedPropertyCollectionTypeConverter.CanConvertTo Method

ExtendedPropertyCollectionTypeConverterCanConvertTo Method

Overload List
 | Name | Description
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | (Overrides TypeConverterCanConvertTo(ITypeDescriptorContext, Type).)
Top
See Also

Reference

ExtendedPropertyCollectionTypeConverter Class
SchemaExplorer Namespace


ExtendedPropertyCollectionTypeConverter.CanConvertTo Method (ITypeDescriptorContext, Type)

ExtendedPropertyCollectionTypeConverterCanConvertTo Method (ITypeDescriptorContext, Type)

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override bool CanConvertTo(
    ITypeDescriptorContext context,
    Type destinationType
)
Public Overrides Function CanConvertTo (
    context As ITypeDescriptorContext,
    destinationType As Type
) As Boolean

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
destinationType
Type: SystemType

Return Value

Type: Boolean
See Also

Reference

ExtendedPropertyCollectionTypeConverter Class
CanConvertTo Overload
SchemaExplorer Namespace


ExtendedPropertyCollectionTypeConverter.ConvertTo Method

ExtendedPropertyCollectionTypeConverterConvertTo Method

Overload List
 | Name | Description
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | (Overrides TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Top
See Also

Reference

ExtendedPropertyCollectionTypeConverter Class
SchemaExplorer Namespace


ExtendedPropertyCollectionTypeConverter.ConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)

ExtendedPropertyCollectionTypeConverterConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override Object ConvertTo(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value,
    Type destinationType
)
Public Overrides Function ConvertTo (
    context As ITypeDescriptorContext,
    culture As CultureInfo,
    value As Object,
    destinationType As Type
) As Object

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
culture
Type: System.GlobalizationCultureInfo
value
Type: SystemObject
destinationType
Type: SystemType

Return Value

Type: Object
See Also

Reference

ExtendedPropertyCollectionTypeConverter Class
ConvertTo Overload
SchemaExplorer Namespace


ExtendedPropertyNames Class

Inheritance Hierarchy
SystemObject
SchemaExplorerExtendedPropertyNames

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class ExtendedPropertyNames
Public Class ExtendedPropertyNames

The ExtendedPropertyNames type exposes the following members.

Constructors
 | Name | Description
Public method | ExtendedPropertyNames | Initializes a new instance of the ExtendedPropertyNames class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name | Description
CascadeDelete |
CascadeUpdate |
Collation | The collation setting
Comment | A comment.
ComputedDefinition | The statement that defines the computed field
ConstraintDefinitionFormat |
ConstraintNameFormat |
ConstraintTypeFormat |
DatabaseMajorVersion | Major Version.
DatabaseVersion | Version.
DefaultValue | The default value
Description | The Description
DRIIndex | The index is used to maintain a declarative referential constraint. Click here for more information.
DRIPrimaryKey | The index implements a SQL Server PRIMARY KEY constraint. A value is returned only. Click here for more information.
DRIUniqueKey | The index implements a UNIQUE constraint on a table not constrained by primary key. The index is a candidate key. Click here for more information.
DropExist | Optimizes index creation when an existing index is rebuilt. Click here for more information.
FileGroup | The FileGroup property identifies the file group used to store Microsoft SQL Server table or index data. Click here for more information.
IdentityIncrement | Identity Increment
IdentitySeed | Identity Seed
IgnoreDuplicateKey | Controls error generation when an INSERT or UPDATE operation could cause a constraint violation and the index implements a PRIMARY KEY or UNIQUE constraint. Click here for more information.
IsAggregateFunction | Scalar Function.
IsAutoStatistics | The StatisticsIndex property directs Index object property evaluation when the object is used to create a Microsoft SQL Server index. Click here for more information.
IsCLR | CLR Procedure or Function.
IsClustered | The index is clustered. SQL Server supports a single clustered index on any table. Click here for more information.
IsComputed | Computed Column or Index
IsConstraint |
IsDescending |
IsDeterministic | Column is Deterministic. True if Deterministic (results are consistent). False if Indeterminate (results might differ with a given set of input values).
IsFullTextKey | The IsFullTextKey property identifies the index used by Microsoft Search to support row identification. Click here for more information.
IsHypothetical | Redirects index creation, mapping Index object manipulation to CREATE STATISTICS and DROP STATISTICS statements. Click here for more information.
IsIdentity | Identity Column
IsInlineTableValuedFunction | Inline-Table-Valued Function.
IsMultiStatementTableValuedFunction | Multi-Statement-Table-Valued Function
IsNotForReplication |
IsRowGuidColumn | The Column is a Row Guid
IsScalarFunction | Scalar Function.
IsSchemaAlias | Returns true if the Schema Object is aliased. Some relational database management systems (RDBMS) like DB2 support aliasing of schema objects. Click here for more information.
IsStatistics | The StatisticsIndex property directs Index object property evaluation when the object is used to create a Microsoft SQL Server index. Click here for more information.
IsTableIndex |
IsTableValuedFunction | Table-Valued Function
IsTrigger |
IsUserDefinedTableType | User Defined Table Type.
NoRecompute | Creates index with statistics computation off. Click here for more information.
NumberOfResultSets | Number of result sets that a command can return. Click here for more information.
ObjectID |
ObjectType | The object type of a Schema Object.
OriginalFillFactor | The FillFactor property exposes the percent of each page used to store index data when the index is created. Click here for more information.
PadIndex | Index nodes are padded using a fill factor. Click here for more information.
ParameterID |
Sequence |
SourceSchemaName | If the schema is aliased, then the Extended Property value should contain Schema Object name that is aliased. Some relational database management systems (RDBMS) like DB2 support aliasing of schema objects. Click here for more information.
SourceSchemaOwner | If the schema is aliased, then the Extended Property value should contain Schema Object owner that is aliased. Some relational database management systems (RDBMS) like DB2 support aliasing of schema objects. Click here for more information.
SpecificName | Use a specific name to declare an identifier for a UDR that is unique in the database or name space. Use the Specific Name segment whenever you see a reference to a specific name in a syntax diagram. Click here for more information. Click here for more information.
SystemType | The System Type (E.G., System.String)
UserDefinedType |
WithNoCheck |
Top
See Also

Reference

SchemaExplorer Namespace


ExtendedPropertyNames Constructor

Initializes a new instance of the ExtendedPropertyNames class

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ExtendedPropertyNames()
Public Sub New
See Also

Reference

ExtendedPropertyNames Class
SchemaExplorer Namespace


ExtendedPropertyNames Methods

The ExtendedPropertyNames type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ExtendedPropertyNames Class
SchemaExplorer Namespace


ExtendedPropertyNames Fields

The ExtendedPropertyNames type exposes the following members.

Fields
Name | Description
CascadeDelete |
CascadeUpdate |
Collation | The collation setting
Comment | A comment.
ComputedDefinition | The statement that defines the computed field
ConstraintDefinitionFormat |
ConstraintNameFormat |
ConstraintTypeFormat |
DatabaseMajorVersion | Major Version.
DatabaseVersion | Version.
DefaultValue | The default value
Description | The Description
DRIIndex | The index is used to maintain a declarative referential constraint. Click here for more information.
DRIPrimaryKey | The index implements a SQL Server PRIMARY KEY constraint. A value is returned only. Click here for more information.
DRIUniqueKey | The index implements a UNIQUE constraint on a table not constrained by primary key. The index is a candidate key. Click here for more information.
DropExist | Optimizes index creation when an existing index is rebuilt. Click here for more information.
FileGroup | The FileGroup property identifies the file group used to store Microsoft SQL Server table or index data. Click here for more information.
IdentityIncrement | Identity Increment
IdentitySeed | Identity Seed
IgnoreDuplicateKey | Controls error generation when an INSERT or UPDATE operation could cause a constraint violation and the index implements a PRIMARY KEY or UNIQUE constraint. Click here for more information.
IsAggregateFunction | Scalar Function.
IsAutoStatistics | The StatisticsIndex property directs Index object property evaluation when the object is used to create a Microsoft SQL Server index. Click here for more information.
IsCLR | CLR Procedure or Function.
IsClustered | The index is clustered. SQL Server supports a single clustered index on any table. Click here for more information.
IsComputed | Computed Column or Index
IsConstraint |
IsDescending |
IsDeterministic | Column is Deterministic. True if Deterministic (results are consistent). False if Indeterminate (results might differ with a given set of input values).
IsFullTextKey | The IsFullTextKey property identifies the index used by Microsoft Search to support row identification. Click here for more information.
IsHypothetical | Redirects index creation, mapping Index object manipulation to CREATE STATISTICS and DROP STATISTICS statements. Click here for more information.
IsIdentity | Identity Column
IsInlineTableValuedFunction | Inline-Table-Valued Function.
IsMultiStatementTableValuedFunction | Multi-Statement-Table-Valued Function
IsNotForReplication |
IsRowGuidColumn | The Column is a Row Guid
IsScalarFunction | Scalar Function.
IsSchemaAlias | Returns true if the Schema Object is aliased. Some relational database management systems (RDBMS) like DB2 support aliasing of schema objects. Click here for more information.
IsStatistics | The StatisticsIndex property directs Index object property evaluation when the object is used to create a Microsoft SQL Server index. Click here for more information.
IsTableIndex |
IsTableValuedFunction | Table-Valued Function
IsTrigger |
IsUserDefinedTableType | User Defined Table Type.
NoRecompute | Creates index with statistics computation off. Click here for more information.
NumberOfResultSets | Number of result sets that a command can return. Click here for more information.
ObjectID |
ObjectType | The object type of a Schema Object.
OriginalFillFactor | The FillFactor property exposes the percent of each page used to store index data when the index is created. Click here for more information.
PadIndex | Index nodes are padded using a fill factor. Click here for more information.
ParameterID |
Sequence |
SourceSchemaName | If the schema is aliased, then the Extended Property value should contain Schema Object name that is aliased. Some relational database management systems (RDBMS) like DB2 support aliasing of schema objects. Click here for more information.
SourceSchemaOwner | If the schema is aliased, then the Extended Property value should contain Schema Object owner that is aliased. Some relational database management systems (RDBMS) like DB2 support aliasing of schema objects. Click here for more information.
SpecificName | Use a specific name to declare an identifier for a UDR that is unique in the database or name space. Use the Specific Name segment whenever you see a reference to a specific name in a syntax diagram. Click here for more information. Click here for more information.
SystemType | The System Type (E.G., System.String)
UserDefinedType |
WithNoCheck |
Top
See Also

Reference

ExtendedPropertyNames Class
SchemaExplorer Namespace


ExtendedPropertyNames.CascadeDelete Field

ExtendedPropertyNamesCascadeDelete Field

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public const string CascadeDelete = "CS_CascadeDelete"
Public Const CascadeDelete As String = "CS_CascadeDelete"

Field Value

Type: String
See Also

Reference

ExtendedPropertyNames Class
SchemaExplorer Namespace


ExtendedPropertyNames.CascadeUpdate Field

ExtendedPropertyNamesCascadeUpdate Field

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public const string CascadeUpdate = "CS_CascadeUpdate"
Public Const CascadeUpdate As String = "CS_CascadeUpdate"

Field Value

Type: String
See Also

Reference

ExtendedPropertyNames Class
SchemaExplorer Namespace


ExtendedPropertyNames.Collation Field

ExtendedPropertyNamesCollation Field

The collation setting

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public const string Collation = "CS_Collation"
Public Const Collation As String = "CS_Collation"

Field Value

Type: String
See Also

Reference

ExtendedPropertyNames Class
SchemaExplorer Namespace


ExtendedPropertyNames.Comment Field

ExtendedPropertyNamesComment Field

A comment.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public const string Comment = "CS_Comment"
Public Const Comment As String = "CS_Comment"

Field Value

Type: String
See Also

Reference

ExtendedPropertyNames Class
SchemaExplorer Namespace


ExtendedPropertyNames.ComputedDefinition Field

ExtendedPropertyNamesComputedDefinition Field

The statement that defines the computed field

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public const string ComputedDefinition = "CS_ComputedDefinition"
Public Const ComputedDefinition As String = "CS_ComputedDefinition"

Field Value

Type: String
See Also

Reference

ExtendedPropertyNames Class
SchemaExplorer Namespace


ExtendedPropertyNames.ConstraintDefinitionFormat Field

ExtendedPropertyNamesConstraintDefinitionFormat Field

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public const string ConstraintDefinitionFormat = "CS_Constraint_{0}_Definition"
Public Const ConstraintDefinitionFormat As String = "CS_Constraint_{0}_Definition"

Field Value

Type: String
See Also

Reference

ExtendedPropertyNames Class
SchemaExplorer Namespace


ExtendedPropertyNames.ConstraintNameFormat Field

ExtendedPropertyNamesConstraintNameFormat Field

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public const string ConstraintNameFormat = "CS_Constraint_{0}_Name"
Public Const ConstraintNameFormat As String = "CS_Constraint_{0}_Name"

Field Value

Type: String
See Also

Reference

ExtendedPropertyNames Class
SchemaExplorer Namespace


ExtendedPropertyNames.ConstraintTypeFormat Field

ExtendedPropertyNamesConstraintTypeFormat Field

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public const string ConstraintTypeFormat = "CS_Constraint_{0}_Type"
Public Const ConstraintTypeFormat As String = "CS_Constraint_{0}_Type"

Field Value

Type: String
See Also

Reference

ExtendedPropertyNames Class
SchemaExplorer Namespace


ExtendedPropertyNames.DatabaseMajorVersion Field

ExtendedPropertyNamesDatabaseMajorVersion Field

Major Version.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public const string DatabaseMajorVersion = "CS_DatabaseMajorVersion"
Public Const DatabaseMajorVersion As String = "CS_DatabaseMajorVersion"

Field Value

Type: String
See Also

Reference

ExtendedPropertyNames Class
SchemaExplorer Namespace


ExtendedPropertyNames.DatabaseVersion Field

ExtendedPropertyNamesDatabaseVersion Field

Version.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public const string DatabaseVersion = "CS_DatabaseVersion"
Public Const DatabaseVersion As String = "CS_DatabaseVersion"

Field Value

Type: String
See Also

Reference

ExtendedPropertyNames Class
SchemaExplorer Namespace


ExtendedPropertyNames.DefaultValue Field

ExtendedPropertyNamesDefaultValue Field

The default value

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public const string DefaultValue = "CS_Default"
Public Const DefaultValue As String = "CS_Default"

Field Value

Type: String
See Also

Reference

ExtendedPropertyNames Class
SchemaExplorer Namespace


ExtendedPropertyNames.Description Field

ExtendedPropertyNamesDescription Field

The Description

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public const string Description = "CS_Description"
Public Const Description As String = "CS_Description"

Field Value

Type: String
See Also

Reference

ExtendedPropertyNames Class
SchemaExplorer Namespace


ExtendedPropertyNames.DRIIndex Field

ExtendedPropertyNamesDRIIndex Field

The index is used to maintain a declarative referential constraint. Click here for more information.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public const string DRIIndex = "CS_DRIIndex"
Public Const DRIIndex As String = "CS_DRIIndex"

Field Value

Type: String
See Also

Reference

ExtendedPropertyNames Class
SchemaExplorer Namespace


ExtendedPropertyNames.DRIPrimaryKey Field

ExtendedPropertyNamesDRIPrimaryKey Field

The index implements a SQL Server PRIMARY KEY constraint. A value is returned only. Click here for more information.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public const string DRIPrimaryKey = "CS_DRIPrimaryKey"
Public Const DRIPrimaryKey As String = "CS_DRIPrimaryKey"

Field Value

Type: String
See Also

Reference

ExtendedPropertyNames Class
SchemaExplorer Namespace


ExtendedPropertyNames.DRIUniqueKey Field

ExtendedPropertyNamesDRIUniqueKey Field

The index implements a UNIQUE constraint on a table not constrained by primary key. The index is a candidate key. Click here for more information.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public const string DRIUniqueKey = "CS_DRIUniqueKey"
Public Const DRIUniqueKey As String = "CS_DRIUniqueKey"

Field Value

Type: String
See Also

Reference

ExtendedPropertyNames Class
SchemaExplorer Namespace


ExtendedPropertyNames.DropExist Field

ExtendedPropertyNamesDropExist Field

Optimizes index creation when an existing index is rebuilt. Click here for more information.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public const string DropExist = "CS_DropExist"
Public Const DropExist As String = "CS_DropExist"

Field Value

Type: String
See Also

Reference

ExtendedPropertyNames Class
SchemaExplorer Namespace


ExtendedPropertyNames.FileGroup Field

ExtendedPropertyNamesFileGroup Field

The FileGroup property identifies the file group used to store Microsoft SQL Server table or index data. Click here for more information.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public const string FileGroup = "CS_FileGroup"
Public Const FileGroup As String = "CS_FileGroup"

Field Value

Type: String
See Also

Reference

ExtendedPropertyNames Class
SchemaExplorer Namespace


ExtendedPropertyNames.IdentityIncrement Field

ExtendedPropertyNamesIdentityIncrement Field

Identity Increment

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public const string IdentityIncrement = "CS_IdentityIncrement"
Public Const IdentityIncrement As String = "CS_IdentityIncrement"

Field Value

Type: String
See Also

Reference

ExtendedPropertyNames Class
SchemaExplorer Namespace


ExtendedPropertyNames.IdentitySeed Field

ExtendedPropertyNamesIdentitySeed Field

Identity Seed

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public const string IdentitySeed = "CS_IdentitySeed"
Public Const IdentitySeed As String = "CS_IdentitySeed"

Field Value

Type: String
See Also

Reference

ExtendedPropertyNames Class
SchemaExplorer Namespace


ExtendedPropertyNames.IgnoreDuplicateKey Field

ExtendedPropertyNamesIgnoreDuplicateKey Field

Controls error generation when an INSERT or UPDATE operation could cause a constraint violation and the index implements a PRIMARY KEY or UNIQUE constraint. Click here for more information.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public const string IgnoreDuplicateKey = "CS_IgnoreDupKey"
Public Const IgnoreDuplicateKey As String = "CS_IgnoreDupKey"

Field Value

Type: String
See Also

Reference

ExtendedPropertyNames Class
SchemaExplorer Namespace


ExtendedPropertyNames.IsAggregateFunction Field

ExtendedPropertyNamesIsAggregateFunction Field

Scalar Function.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public const string IsAggregateFunction = "CS_IsAggregateFunction"
Public Const IsAggregateFunction As String = "CS_IsAggregateFunction"

Field Value

Type: String
See Also

Reference

ExtendedPropertyNames Class
SchemaExplorer Namespace


ExtendedPropertyNames.IsAutoStatistics Field

ExtendedPropertyNamesIsAutoStatistics Field

The StatisticsIndex property directs Index object property evaluation when the object is used to create a Microsoft SQL Server index. Click here for more information.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public const string IsAutoStatistics = "CS_IsAutoStatistics"
Public Const IsAutoStatistics As String = "CS_IsAutoStatistics"

Field Value

Type: String
See Also

Reference

ExtendedPropertyNames Class
SchemaExplorer Namespace


ExtendedPropertyNames.IsCLR Field

ExtendedPropertyNamesIsCLR Field

CLR Procedure or Function.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public const string IsCLR = "CS_IsCLR"
Public Const IsCLR As String = "CS_IsCLR"

Field Value

Type: String
See Also

Reference

ExtendedPropertyNames Class
SchemaExplorer Namespace


ExtendedPropertyNames.IsClustered Field

ExtendedPropertyNamesIsClustered Field

The index is clustered. SQL Server supports a single clustered index on any table. Click here for more information.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public const string IsClustered = "CS_IsClustered"
Public Const IsClustered As String = "CS_IsClustered"

Field Value

Type: String
See Also

Reference

ExtendedPropertyNames Class
SchemaExplorer Namespace


ExtendedPropertyNames.IsComputed Field

ExtendedPropertyNamesIsComputed Field

Computed Column or Index

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public const string IsComputed = "CS_IsComputed"
Public Const IsComputed As String = "CS_IsComputed"

Field Value

Type: String
See Also

Reference

ExtendedPropertyNames Class
SchemaExplorer Namespace


ExtendedPropertyNames.IsConstraint Field

ExtendedPropertyNamesIsConstraint Field

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public const string IsConstraint = "CS_IsConstraint"
Public Const IsConstraint As String = "CS_IsConstraint"

Field Value

Type: String
See Also

Reference

ExtendedPropertyNames Class
SchemaExplorer Namespace


ExtendedPropertyNames.IsDescending Field

ExtendedPropertyNamesIsDescending Field

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public const string IsDescending = "CS_IsDescending"
Public Const IsDescending As String = "CS_IsDescending"

Field Value

Type: String
See Also

Reference

ExtendedPropertyNames Class
SchemaExplorer Namespace


ExtendedPropertyNames.IsDeterministic Field

ExtendedPropertyNamesIsDeterministic Field

Column is Deterministic. True if Deterministic (results are consistent). False if Indeterminate (results might differ with a given set of input values).

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public const string IsDeterministic = "CS_IsDeterministic"
Public Const IsDeterministic As String = "CS_IsDeterministic"

Field Value

Type: String
See Also

Reference

ExtendedPropertyNames Class
SchemaExplorer Namespace


ExtendedPropertyNames.IsFullTextKey Field

ExtendedPropertyNamesIsFullTextKey Field

The IsFullTextKey property identifies the index used by Microsoft Search to support row identification. Click here for more information.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public const string IsFullTextKey = "CS_IsFullTextKey"
Public Const IsFullTextKey As String = "CS_IsFullTextKey"

Field Value

Type: String
See Also

Reference

ExtendedPropertyNames Class
SchemaExplorer Namespace


ExtendedPropertyNames.IsHypothetical Field

ExtendedPropertyNamesIsHypothetical Field

Redirects index creation, mapping Index object manipulation to CREATE STATISTICS and DROP STATISTICS statements. Click here for more information.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public const string IsHypothetical = "CS_IsHypothetical"
Public Const IsHypothetical As String = "CS_IsHypothetical"

Field Value

Type: String
See Also

Reference

ExtendedPropertyNames Class
SchemaExplorer Namespace


ExtendedPropertyNames.IsIdentity Field

ExtendedPropertyNamesIsIdentity Field

Identity Column

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public const string IsIdentity = "CS_IsIdentity"
Public Const IsIdentity As String = "CS_IsIdentity"

Field Value

Type: String
See Also

Reference

ExtendedPropertyNames Class
SchemaExplorer Namespace


ExtendedPropertyNames.IsInlineTableValuedFunction Field

ExtendedPropertyNamesIsInlineTableValuedFunction Field

Inline-Table-Valued Function.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public const string IsInlineTableValuedFunction = "CS_IsInlineTableValuedFunction"
Public Const IsInlineTableValuedFunction As String = "CS_IsInlineTableValuedFunction"

Field Value

Type: String
See Also

Reference

ExtendedPropertyNames Class
SchemaExplorer Namespace


ExtendedPropertyNames.IsMultiStatementTableValuedFunction Field

ExtendedPropertyNamesIsMultiStatementTableValuedFunction Field

Multi-Statement-Table-Valued Function

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public const string IsMultiStatementTableValuedFunction = "CS_IsMultiStatementTableValuedFunction"
Public Const IsMultiStatementTableValuedFunction As String = "CS_IsMultiStatementTableValuedFunction"

Field Value

Type: String
See Also

Reference

ExtendedPropertyNames Class
SchemaExplorer Namespace


ExtendedPropertyNames.IsNotForReplication Field

ExtendedPropertyNamesIsNotForReplication Field

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public const string IsNotForReplication = "CS_IsNotForReplication"
Public Const IsNotForReplication As String = "CS_IsNotForReplication"

Field Value

Type: String
See Also

Reference

ExtendedPropertyNames Class
SchemaExplorer Namespace


ExtendedPropertyNames.IsRowGuidColumn Field

ExtendedPropertyNamesIsRowGuidColumn Field

The Column is a Row Guid

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public const string IsRowGuidColumn = "CS_IsRowGuidCol"
Public Const IsRowGuidColumn As String = "CS_IsRowGuidCol"

Field Value

Type: String
See Also

Reference

ExtendedPropertyNames Class
SchemaExplorer Namespace


ExtendedPropertyNames.IsScalarFunction Field

ExtendedPropertyNamesIsScalarFunction Field

Scalar Function.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public const string IsScalarFunction = "CS_IsScalarFunction"
Public Const IsScalarFunction As String = "CS_IsScalarFunction"

Field Value

Type: String
See Also

Reference

ExtendedPropertyNames Class
SchemaExplorer Namespace


ExtendedPropertyNames.IsSchemaAlias Field

ExtendedPropertyNamesIsSchemaAlias Field

Returns true if the Schema Object is aliased. Some relational database management systems (RDBMS) like DB2 support aliasing of schema objects. Click here for more information.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public const string IsSchemaAlias = "CS_IsSchemaAlias"
Public Const IsSchemaAlias As String = "CS_IsSchemaAlias"

Field Value

Type: String
See Also

Reference

ExtendedPropertyNames Class
SchemaExplorer Namespace


ExtendedPropertyNames.IsStatistics Field

ExtendedPropertyNamesIsStatistics Field

The StatisticsIndex property directs Index object property evaluation when the object is used to create a Microsoft SQL Server index. Click here for more information.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public const string IsStatistics = "CS_IsStatistics"
Public Const IsStatistics As String = "CS_IsStatistics"

Field Value

Type: String
See Also

Reference

ExtendedPropertyNames Class
SchemaExplorer Namespace


ExtendedPropertyNames.IsTableIndex Field

ExtendedPropertyNamesIsTableIndex Field

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public const string IsTableIndex = "CS_IsTable"
Public Const IsTableIndex As String = "CS_IsTable"

Field Value

Type: String
See Also

Reference

ExtendedPropertyNames Class
SchemaExplorer Namespace


ExtendedPropertyNames.IsTableValuedFunction Field

ExtendedPropertyNamesIsTableValuedFunction Field

Table-Valued Function

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public const string IsTableValuedFunction = "CS_IsTableValuedFunction"
Public Const IsTableValuedFunction As String = "CS_IsTableValuedFunction"

Field Value

Type: String
See Also

Reference

ExtendedPropertyNames Class
SchemaExplorer Namespace


ExtendedPropertyNames.IsTrigger Field

ExtendedPropertyNamesIsTrigger Field

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public const string IsTrigger = "CS_IsTrigger"
Public Const IsTrigger As String = "CS_IsTrigger"

Field Value

Type: String
See Also

Reference

ExtendedPropertyNames Class
SchemaExplorer Namespace


ExtendedPropertyNames.IsUserDefinedTableType Field

ExtendedPropertyNamesIsUserDefinedTableType Field

User Defined Table Type.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public const string IsUserDefinedTableType = "CS_IsUserDefinedTableType"
Public Const IsUserDefinedTableType As String = "CS_IsUserDefinedTableType"

Field Value

Type: String
See Also

Reference

ExtendedPropertyNames Class
SchemaExplorer Namespace


ExtendedPropertyNames.NoRecompute Field

ExtendedPropertyNamesNoRecompute Field

Creates index with statistics computation off. Click here for more information.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public const string NoRecompute = "CS_NoRecompute"
Public Const NoRecompute As String = "CS_NoRecompute"

Field Value

Type: String
See Also

Reference

ExtendedPropertyNames Class
SchemaExplorer Namespace


ExtendedPropertyNames.NumberOfResultSets Field

ExtendedPropertyNamesNumberOfResultSets Field

Number of result sets that a command can return. Click here for more information.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public const string NumberOfResultSets = "CS_NumberOfResultSets"
Public Const NumberOfResultSets As String = "CS_NumberOfResultSets"

Field Value

Type: String
See Also

Reference

ExtendedPropertyNames Class
SchemaExplorer Namespace


ExtendedPropertyNames.ObjectID Field

ExtendedPropertyNamesObjectID Field

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public const string ObjectID = "CS_ObjectID"
Public Const ObjectID As String = "CS_ObjectID"

Field Value

Type: String
See Also

Reference

ExtendedPropertyNames Class
SchemaExplorer Namespace


ExtendedPropertyNames.ObjectType Field

ExtendedPropertyNamesObjectType Field

The object type of a Schema Object.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public const string ObjectType = "CS_ObjectType"
Public Const ObjectType As String = "CS_ObjectType"

Field Value

Type: String
See Also

Reference

ExtendedPropertyNames Class
SchemaExplorer Namespace


ExtendedPropertyNames.OriginalFillFactor Field

ExtendedPropertyNamesOriginalFillFactor Field

The FillFactor property exposes the percent of each page used to store index data when the index is created. Click here for more information.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public const string OriginalFillFactor = "CS_OrigFillFactor"
Public Const OriginalFillFactor As String = "CS_OrigFillFactor"

Field Value

Type: String
See Also

Reference

ExtendedPropertyNames Class
SchemaExplorer Namespace


ExtendedPropertyNames.PadIndex Field

ExtendedPropertyNamesPadIndex Field

Index nodes are padded using a fill factor. Click here for more information.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public const string PadIndex = "CS_PadIndex"
Public Const PadIndex As String = "CS_PadIndex"

Field Value

Type: String
See Also

Reference

ExtendedPropertyNames Class
SchemaExplorer Namespace


ExtendedPropertyNames.ParameterID Field

ExtendedPropertyNamesParameterID Field

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public const string ParameterID = "CS_ParameterID"
Public Const ParameterID As String = "CS_ParameterID"

Field Value

Type: String
See Also

Reference

ExtendedPropertyNames Class
SchemaExplorer Namespace


ExtendedPropertyNames.Sequence Field

ExtendedPropertyNamesSequence Field

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public const string Sequence = "CS_Sequence"
Public Const Sequence As String = "CS_Sequence"

Field Value

Type: String
See Also

Reference

ExtendedPropertyNames Class
SchemaExplorer Namespace


ExtendedPropertyNames.SourceSchemaName Field

ExtendedPropertyNamesSourceSchemaName Field

If the schema is aliased, then the Extended Property value should contain Schema Object name that is aliased. Some relational database management systems (RDBMS) like DB2 support aliasing of schema objects. Click here for more information.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public const string SourceSchemaName = "CS_SourceSchemaName"
Public Const SourceSchemaName As String = "CS_SourceSchemaName"

Field Value

Type: String
See Also

Reference

ExtendedPropertyNames Class
SchemaExplorer Namespace


ExtendedPropertyNames.SourceSchemaOwner Field

ExtendedPropertyNamesSourceSchemaOwner Field

If the schema is aliased, then the Extended Property value should contain Schema Object owner that is aliased. Some relational database management systems (RDBMS) like DB2 support aliasing of schema objects. Click here for more information.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public const string SourceSchemaOwner = "CS_SourceSchemaOwner"
Public Const SourceSchemaOwner As String = "CS_SourceSchemaOwner"

Field Value

Type: String
See Also

Reference

ExtendedPropertyNames Class
SchemaExplorer Namespace


ExtendedPropertyNames.SpecificName Field

ExtendedPropertyNamesSpecificName Field

Use a specific name to declare an identifier for a UDR that is unique in the database or name space. Use the Specific Name segment whenever you see a reference to a specific name in a syntax diagram. Click here for more information. Click here for more information.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public const string SpecificName = "CS_SpecificName"
Public Const SpecificName As String = "CS_SpecificName"

Field Value

Type: String
See Also

Reference

ExtendedPropertyNames Class
SchemaExplorer Namespace


ExtendedPropertyNames.SystemType Field

ExtendedPropertyNamesSystemType Field

The System Type (E.G., System.String)

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public const string SystemType = "CS_SystemType"
Public Const SystemType As String = "CS_SystemType"

Field Value

Type: String
See Also

Reference

ExtendedPropertyNames Class
SchemaExplorer Namespace


ExtendedPropertyNames.UserDefinedType Field

ExtendedPropertyNamesUserDefinedType Field

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public const string UserDefinedType = "CS_UserDefinedType"
Public Const UserDefinedType As String = "CS_UserDefinedType"

Field Value

Type: String
See Also

Reference

ExtendedPropertyNames Class
SchemaExplorer Namespace


ExtendedPropertyNames.WithNoCheck Field

ExtendedPropertyNamesWithNoCheck Field

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public const string WithNoCheck = "CS_WithNoCheck"
Public Const WithNoCheck As String = "CS_WithNoCheck"

Field Value

Type: String
See Also

Reference

ExtendedPropertyNames Class
SchemaExplorer Namespace


IColumnSchema Interface

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public interface IColumnSchema : IDataObject,
    ISchemaObject
Public Interface IColumnSchema
    Inherits IDataObject, ISchemaObject

The IColumnSchema type exposes the following members.

Properties
 | Name | Description
Public property | AllowDBNull | Whether or not the data object allows null values. (Inherited from IDataObject.)
Public property | Database | Allows access to the DatabaseSchema object that contains this schema object. (Inherited from ISchemaObject.)
Public property | DataType | The data type of a (column) parameter is specific to the .NET Framework data provider. Specifying the type converts the value of the Parameter to the data provider Type before passing the value to the data source. seealso: http://msdn.microsoft.com/en-us/library/system.data.dbtype.aspx example: DbType.AnsiString (Inherited from IDataObject.)
Public property | DateCreated | Returns the date this table was created. (Inherited from ISchemaObject.)
Public property | DeepLoad | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from ISchemaObject.)
Public property | DefaultExtendedProperties | (Inherited from ISchemaObject.)
Public property | Description | The description of the object. (Inherited from ISchemaObject.)
Public property | ExtendedProperties | Used to store any additional information about the schema object. (Inherited from ISchemaObject.)
Public property | FullName | Returns the owner and name of the table. (Inherited from ISchemaObject.)
Public property | IncludeFunctions | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from ISchemaObject.)
Public property | IsForeignKeyMember | Whether or not the column is a foreign key member.
Public property | IsPrimaryKeyMember | Whether or not the column is a primary key member.
Public property | IsUnique | Whether or not this column is unique.
Public property | NativeType | This is the native data type from the database. example: nvarchar (Inherited from IDataObject.)
Public property | Parent | The Parent Schema Object. (Inherited from IDataObject.)
Public property | Precision | The precision of the data object. (Inherited from IDataObject.)
Public property | Scale | The scale of the data object. (Inherited from IDataObject.)
Public property | Size | The size of the data object. (Inherited from IDataObject.)
Public property | SortName | Gets the name used to sort in 'Table (Owner)' format. (Inherited from ISchemaObject.)
Public property | SystemType | The System Type that is resolved from DataType. example: typeof(System.String) (Inherited from IDataObject.)
Public property | Table | The table that contains this column.
Top
Methods
 | Name | Description
Public method | Refresh | Allows the object to be refreshed. (Inherited from ISchemaObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Selected | Determines if the specified item is selected using the rules defined in SchemaSelector. (Defined by SchemaSelectorExtensions.)
Top
See Also

Reference

SchemaExplorer Namespace


IColumnSchema Properties

The IColumnSchema type exposes the following members.

Properties
 | Name | Description
Public property | AllowDBNull | Whether or not the data object allows null values. (Inherited from IDataObject.)
Public property | Database | Allows access to the DatabaseSchema object that contains this schema object. (Inherited from ISchemaObject.)
Public property | DataType | The data type of a (column) parameter is specific to the .NET Framework data provider. Specifying the type converts the value of the Parameter to the data provider Type before passing the value to the data source. seealso: http://msdn.microsoft.com/en-us/library/system.data.dbtype.aspx example: DbType.AnsiString (Inherited from IDataObject.)
Public property | DateCreated | Returns the date this table was created. (Inherited from ISchemaObject.)
Public property | DeepLoad | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from ISchemaObject.)
Public property | DefaultExtendedProperties | (Inherited from ISchemaObject.)
Public property | Description | The description of the object. (Inherited from ISchemaObject.)
Public property | ExtendedProperties | Used to store any additional information about the schema object. (Inherited from ISchemaObject.)
Public property | FullName | Returns the owner and name of the table. (Inherited from ISchemaObject.)
Public property | IncludeFunctions | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from ISchemaObject.)
Public property | IsForeignKeyMember | Whether or not the column is a foreign key member.
Public property | IsPrimaryKeyMember | Whether or not the column is a primary key member.
Public property | IsUnique | Whether or not this column is unique.
Public property | NativeType | This is the native data type from the database. example: nvarchar (Inherited from IDataObject.)
Public property | Parent | The Parent Schema Object. (Inherited from IDataObject.)
Public property | Precision | The precision of the data object. (Inherited from IDataObject.)
Public property | Scale | The scale of the data object. (Inherited from IDataObject.)
Public property | Size | The size of the data object. (Inherited from IDataObject.)
Public property | SortName | Gets the name used to sort in 'Table (Owner)' format. (Inherited from ISchemaObject.)
Public property | SystemType | The System Type that is resolved from DataType. example: typeof(System.String) (Inherited from IDataObject.)
Public property | Table | The table that contains this column.
Top
See Also

Reference

IColumnSchema Interface
SchemaExplorer Namespace


IColumnSchema.IsForeignKeyMember Property

IColumnSchemaIsForeignKeyMember Property

Whether or not the column is a foreign key member.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
bool IsForeignKeyMember { get; }
ReadOnly Property IsForeignKeyMember As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

IColumnSchema Interface
SchemaExplorer Namespace


IColumnSchema.IsPrimaryKeyMember Property

IColumnSchemaIsPrimaryKeyMember Property

Whether or not the column is a primary key member.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
bool IsPrimaryKeyMember { get; }
ReadOnly Property IsPrimaryKeyMember As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

IColumnSchema Interface
SchemaExplorer Namespace


IColumnSchema.IsUnique Property

IColumnSchemaIsUnique Property

Whether or not this column is unique.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
bool IsUnique { get; }
ReadOnly Property IsUnique As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

IColumnSchema Interface
SchemaExplorer Namespace


IColumnSchema.Table Property

IColumnSchemaTable Property

The table that contains this column.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
ITableSchema Table { get; }
ReadOnly Property Table As ITableSchema
    Get

Property Value

Type: ITableSchema
See Also

Reference

IColumnSchema Interface
SchemaExplorer Namespace


IColumnSchema Methods

The IColumnSchema type exposes the following members.

Methods
 | Name | Description
Public method | Refresh | Allows the object to be refreshed. (Inherited from ISchemaObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Selected | Determines if the specified item is selected using the rules defined in SchemaSelector. (Defined by SchemaSelectorExtensions.)
Top
See Also

Reference

IColumnSchema Interface
SchemaExplorer Namespace


ICommandResultColumnSchema Interface

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public interface ICommandResultColumnSchema : IDataObject,
    ISchemaObject
Public Interface ICommandResultColumnSchema
    Inherits IDataObject, ISchemaObject

The ICommandResultColumnSchema type exposes the following members.

Properties
 | Name | Description
Public property | AllowDBNull | Whether or not the data object allows null values. (Inherited from IDataObject.)
Public property | Command | The command that contains this column.
Public property | Database | Allows access to the DatabaseSchema object that contains this schema object. (Inherited from ISchemaObject.)
Public property | DataType | The data type of a (column) parameter is specific to the .NET Framework data provider. Specifying the type converts the value of the Parameter to the data provider Type before passing the value to the data source. seealso: http://msdn.microsoft.com/en-us/library/system.data.dbtype.aspx example: DbType.AnsiString (Inherited from IDataObject.)
Public property | DateCreated | Returns the date this table was created. (Inherited from ISchemaObject.)
Public property | DeepLoad | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from ISchemaObject.)
Public property | DefaultExtendedProperties | (Inherited from ISchemaObject.)
Public property | Description | The description of the object. (Inherited from ISchemaObject.)
Public property | ExtendedProperties | Used to store any additional information about the schema object. (Inherited from ISchemaObject.)
Public property | FullName | Returns the owner and name of the table. (Inherited from ISchemaObject.)
Public property | IncludeFunctions | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from ISchemaObject.)
Public property | NativeType | This is the native data type from the database. example: nvarchar (Inherited from IDataObject.)
Public property | Parent | The Parent Schema Object. (Inherited from IDataObject.)
Public property | Precision | The precision of the data object. (Inherited from IDataObject.)
Public property | Scale | The scale of the data object. (Inherited from IDataObject.)
Public property | Size | The size of the data object. (Inherited from IDataObject.)
Public property | SortName | Gets the name used to sort in 'Table (Owner)' format. (Inherited from ISchemaObject.)
Public property | SystemType | The System Type that is resolved from DataType. example: typeof(System.String) (Inherited from IDataObject.)
Top
Methods
 | Name | Description
Public method | Refresh | Allows the object to be refreshed. (Inherited from ISchemaObject.)
Top
See Also

Reference

SchemaExplorer Namespace


ICommandResultColumnSchema Properties

The ICommandResultColumnSchema type exposes the following members.

Properties
 | Name | Description
Public property | AllowDBNull | Whether or not the data object allows null values. (Inherited from IDataObject.)
Public property | Command | The command that contains this column.
Public property | Database | Allows access to the DatabaseSchema object that contains this schema object. (Inherited from ISchemaObject.)
Public property | DataType | The data type of a (column) parameter is specific to the .NET Framework data provider. Specifying the type converts the value of the Parameter to the data provider Type before passing the value to the data source. seealso: http://msdn.microsoft.com/en-us/library/system.data.dbtype.aspx example: DbType.AnsiString (Inherited from IDataObject.)
Public property | DateCreated | Returns the date this table was created. (Inherited from ISchemaObject.)
Public property | DeepLoad | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from ISchemaObject.)
Public property | DefaultExtendedProperties | (Inherited from ISchemaObject.)
Public property | Description | The description of the object. (Inherited from ISchemaObject.)
Public property | ExtendedProperties | Used to store any additional information about the schema object. (Inherited from ISchemaObject.)
Public property | FullName | Returns the owner and name of the table. (Inherited from ISchemaObject.)
Public property | IncludeFunctions | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from ISchemaObject.)
Public property | NativeType | This is the native data type from the database. example: nvarchar (Inherited from IDataObject.)
Public property | Parent | The Parent Schema Object. (Inherited from IDataObject.)
Public property | Precision | The precision of the data object. (Inherited from IDataObject.)
Public property | Scale | The scale of the data object. (Inherited from IDataObject.)
Public property | Size | The size of the data object. (Inherited from IDataObject.)
Public property | SortName | Gets the name used to sort in 'Table (Owner)' format. (Inherited from ISchemaObject.)
Public property | SystemType | The System Type that is resolved from DataType. example: typeof(System.String) (Inherited from IDataObject.)
Top
See Also

Reference

ICommandResultColumnSchema Interface
SchemaExplorer Namespace


ICommandResultColumnSchema.Command Property

ICommandResultColumnSchemaCommand Property

The command that contains this column.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
ICommandSchema Command { get; }
ReadOnly Property Command As ICommandSchema
    Get

Property Value

Type: ICommandSchema
See Also

Reference

ICommandResultColumnSchema Interface
SchemaExplorer Namespace


ICommandResultColumnSchema Methods

The ICommandResultColumnSchema type exposes the following members.

Methods
 | Name | Description
Public method | Refresh | Allows the object to be refreshed. (Inherited from ISchemaObject.)
Top
See Also

Reference

ICommandResultColumnSchema Interface
SchemaExplorer Namespace


ICommandResultSchema Interface

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public interface ICommandResultSchema : ITabularObject,
    ISchemaObjectWithOwner, ISchemaObject
Public Interface ICommandResultSchema
    Inherits ITabularObject, ISchemaObjectWithOwner, ISchemaObject

The ICommandResultSchema type exposes the following members.

Properties
 | Name | Description
Public property | Columns | Provides information about the command result columns.
Public property | Command | Provides access to the command that this command result schema belongs to.
Public property | Database | Allows access to the DatabaseSchema object that contains this schema object. (Inherited from ISchemaObject.)
Public property | DataObjects | Provides information about the schema objects columns. (Inherited from ITabularObject.)
Public property | DateCreated | Returns the date this table was created. (Inherited from ISchemaObject.)
Public property | DeepLoad | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from ISchemaObject.)
Public property | DefaultExtendedProperties | (Inherited from ISchemaObject.)
Public property | Description | The description of the object. (Inherited from ISchemaObject.)
Public property | ExtendedProperties | Used to store any additional information about the schema object. (Inherited from ISchemaObject.)
Public property | FullName | Returns the owner and name of the table. (Inherited from ISchemaObject.)
Public property | IncludeFunctions | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from ISchemaObject.)
Public property | Item | Index to allow easy access to the columns in this schema object. (Inherited from ITabularObject.)
Public property | Owner | Returns the owner of the table. (Inherited from ISchemaObjectWithOwner.)
Public property | SortName | Gets the name used to sort in 'Table (Owner)' format. (Inherited from ISchemaObject.)
Top
Methods
 | Name | Description
Public method | GetData | Gets the data contained within the schema object. (Inherited from ITabularObject.)
Public method | Refresh | Allows the object to be refreshed. (Inherited from ISchemaObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Selected | Determines if the specified item is selected using the rules defined in SchemaSelector. (Defined by SchemaSelectorExtensions.)
Top
See Also

Reference

SchemaExplorer Namespace


ICommandResultSchema Properties

The ICommandResultSchema type exposes the following members.

Properties
 | Name | Description
Public property | Columns | Provides information about the command result columns.
Public property | Command | Provides access to the command that this command result schema belongs to.
Public property | Database | Allows access to the DatabaseSchema object that contains this schema object. (Inherited from ISchemaObject.)
Public property | DataObjects | Provides information about the schema objects columns. (Inherited from ITabularObject.)
Public property | DateCreated | Returns the date this table was created. (Inherited from ISchemaObject.)
Public property | DeepLoad | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from ISchemaObject.)
Public property | DefaultExtendedProperties | (Inherited from ISchemaObject.)
Public property | Description | The description of the object. (Inherited from ISchemaObject.)
Public property | ExtendedProperties | Used to store any additional information about the schema object. (Inherited from ISchemaObject.)
Public property | FullName | Returns the owner and name of the table. (Inherited from ISchemaObject.)
Public property | IncludeFunctions | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from ISchemaObject.)
Public property | Item | Index to allow easy access to the columns in this schema object. (Inherited from ITabularObject.)
Public property | Owner | Returns the owner of the table. (Inherited from ISchemaObjectWithOwner.)
Public property | SortName | Gets the name used to sort in 'Table (Owner)' format. (Inherited from ISchemaObject.)
Top
See Also

Reference

ICommandResultSchema Interface
SchemaExplorer Namespace


ICommandResultSchema.Columns Property

ICommandResultSchemaColumns Property

Provides information about the command result columns.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
IReadOnlyNamedObjectCollection<ICommandResultColumnSchema> Columns { get; }
ReadOnly Property Columns As IReadOnlyNamedObjectCollection(Of ICommandResultColumnSchema)
    Get

Property Value

Type: IReadOnlyNamedObjectCollectionICommandResultColumnSchema
See Also

Reference

ICommandResultSchema Interface
SchemaExplorer Namespace


ICommandResultSchema.Command Property

ICommandResultSchemaCommand Property

Provides access to the command that this command result schema belongs to.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
ICommandSchema Command { get; }
ReadOnly Property Command As ICommandSchema
    Get

Property Value

Type: ICommandSchema
See Also

Reference

ICommandResultSchema Interface
SchemaExplorer Namespace


ICommandResultSchema Methods

The ICommandResultSchema type exposes the following members.

Methods
 | Name | Description
Public method | GetData | Gets the data contained within the schema object. (Inherited from ITabularObject.)
Public method | Refresh | Allows the object to be refreshed. (Inherited from ISchemaObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Selected | Determines if the specified item is selected using the rules defined in SchemaSelector. (Defined by SchemaSelectorExtensions.)
Top
See Also

Reference

ICommandResultSchema Interface
SchemaExplorer Namespace


ICommandSchema Interface

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public interface ICommandSchema : ISchemaObjectWithOwner,
    ISchemaObject
Public Interface ICommandSchema
    Inherits ISchemaObjectWithOwner, ISchemaObject

The ICommandSchema type exposes the following members.

Properties
 | Name | Description
Public property | AllInputParameters | Input and InputOutput parameters for this command.
Public property | AllOutputParameters | Output and InputOutput parameters for this command.
Public property | CommandResults | Provides access to information about the results and column schema information returned when executing this command.
Public property | CommandText | Gets the command text for this command.
Public property | Database | Allows access to the DatabaseSchema object that contains this schema object. (Inherited from ISchemaObject.)
Public property | DateCreated | Returns the date this table was created. (Inherited from ISchemaObject.)
Public property | DeepLoad | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from ISchemaObject.)
Public property | DefaultExtendedProperties | (Inherited from ISchemaObject.)
Public property | Description | The description of the object. (Inherited from ISchemaObject.)
Public property | ExtendedProperties | Used to store any additional information about the schema object. (Inherited from ISchemaObject.)
Public property | FullName | Returns the owner and name of the table. (Inherited from ISchemaObject.)
Public property | IncludeFunctions | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from ISchemaObject.)
Public property | InputOutputParameters | InputOutput parameters for this command.
Public property | InputParameters | Input parameters for this command.
Public property | NonReturnValueParameters | All parameters except the return value parameter.
Public property | OutputParameters | Output parameters for this command.
Public property | Owner | Returns the owner of the table. (Inherited from ISchemaObjectWithOwner.)
Public property | Parameters | Parameters for this command.
Public property | ReturnValueParameter | The return value parameter for this command.
Public property | SortName | Gets the name used to sort in 'Table (Owner)' format. (Inherited from ISchemaObject.)
Top
Methods
 | Name | Description
Public method | Refresh | Allows the object to be refreshed. (Inherited from ISchemaObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Selected | Determines if the specified item is selected using the rules defined in SchemaSelector. (Defined by SchemaSelectorExtensions.)
Top
See Also

Reference

SchemaExplorer Namespace


ICommandSchema Properties

The ICommandSchema type exposes the following members.

Properties
 | Name | Description
Public property | AllInputParameters | Input and InputOutput parameters for this command.
Public property | AllOutputParameters | Output and InputOutput parameters for this command.
Public property | CommandResults | Provides access to information about the results and column schema information returned when executing this command.
Public property | CommandText | Gets the command text for this command.
Public property | Database | Allows access to the DatabaseSchema object that contains this schema object. (Inherited from ISchemaObject.)
Public property | DateCreated | Returns the date this table was created. (Inherited from ISchemaObject.)
Public property | DeepLoad | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from ISchemaObject.)
Public property | DefaultExtendedProperties | (Inherited from ISchemaObject.)
Public property | Description | The description of the object. (Inherited from ISchemaObject.)
Public property | ExtendedProperties | Used to store any additional information about the schema object. (Inherited from ISchemaObject.)
Public property | FullName | Returns the owner and name of the table. (Inherited from ISchemaObject.)
Public property | IncludeFunctions | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from ISchemaObject.)
Public property | InputOutputParameters | InputOutput parameters for this command.
Public property | InputParameters | Input parameters for this command.
Public property | NonReturnValueParameters | All parameters except the return value parameter.
Public property | OutputParameters | Output parameters for this command.
Public property | Owner | Returns the owner of the table. (Inherited from ISchemaObjectWithOwner.)
Public property | Parameters | Parameters for this command.
Public property | ReturnValueParameter | The return value parameter for this command.
Public property | SortName | Gets the name used to sort in 'Table (Owner)' format. (Inherited from ISchemaObject.)
Top
See Also

Reference

ICommandSchema Interface
SchemaExplorer Namespace


ICommandSchema.AllInputParameters Property

ICommandSchemaAllInputParameters Property

Input and InputOutput parameters for this command.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
IReadOnlyNamedObjectCollection<IParameterSchema> AllInputParameters { get; }
ReadOnly Property AllInputParameters As IReadOnlyNamedObjectCollection(Of IParameterSchema)
    Get

Property Value

Type: IReadOnlyNamedObjectCollectionIParameterSchema
See Also

Reference

ICommandSchema Interface
SchemaExplorer Namespace


ICommandSchema.AllOutputParameters Property

ICommandSchemaAllOutputParameters Property

Output and InputOutput parameters for this command.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
IReadOnlyNamedObjectCollection<IParameterSchema> AllOutputParameters { get; }
ReadOnly Property AllOutputParameters As IReadOnlyNamedObjectCollection(Of IParameterSchema)
    Get

Property Value

Type: IReadOnlyNamedObjectCollectionIParameterSchema
See Also

Reference

ICommandSchema Interface
SchemaExplorer Namespace


ICommandSchema.CommandResults Property

ICommandSchemaCommandResults Property

Provides access to information about the results and column schema information returned when executing this command.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
IReadOnlyNamedObjectCollection<ICommandResultSchema> CommandResults { get; }
ReadOnly Property CommandResults As IReadOnlyNamedObjectCollection(Of ICommandResultSchema)
    Get

Property Value

Type: IReadOnlyNamedObjectCollectionICommandResultSchema
See Also

Reference

ICommandSchema Interface
SchemaExplorer Namespace


ICommandSchema.CommandText Property

ICommandSchemaCommandText Property

Gets the command text for this command.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
string CommandText { get; }
ReadOnly Property CommandText As String
    Get

Property Value

Type: String
See Also

Reference

ICommandSchema Interface
SchemaExplorer Namespace


ICommandSchema.InputOutputParameters Property

ICommandSchemaInputOutputParameters Property

InputOutput parameters for this command.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
IReadOnlyNamedObjectCollection<IParameterSchema> InputOutputParameters { get; }
ReadOnly Property InputOutputParameters As IReadOnlyNamedObjectCollection(Of IParameterSchema)
    Get

Property Value

Type: IReadOnlyNamedObjectCollectionIParameterSchema
See Also

Reference

ICommandSchema Interface
SchemaExplorer Namespace


ICommandSchema.InputParameters Property

ICommandSchemaInputParameters Property

Input parameters for this command.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
IReadOnlyNamedObjectCollection<IParameterSchema> InputParameters { get; }
ReadOnly Property InputParameters As IReadOnlyNamedObjectCollection(Of IParameterSchema)
    Get

Property Value

Type: IReadOnlyNamedObjectCollectionIParameterSchema
See Also

Reference

ICommandSchema Interface
SchemaExplorer Namespace


ICommandSchema.NonReturnValueParameters Property

ICommandSchemaNonReturnValueParameters Property

All parameters except the return value parameter.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
IReadOnlyNamedObjectCollection<IParameterSchema> NonReturnValueParameters { get; }
ReadOnly Property NonReturnValueParameters As IReadOnlyNamedObjectCollection(Of IParameterSchema)
    Get

Property Value

Type: IReadOnlyNamedObjectCollectionIParameterSchema
See Also

Reference

ICommandSchema Interface
SchemaExplorer Namespace


ICommandSchema.OutputParameters Property

ICommandSchemaOutputParameters Property

Output parameters for this command.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
IReadOnlyNamedObjectCollection<IParameterSchema> OutputParameters { get; }
ReadOnly Property OutputParameters As IReadOnlyNamedObjectCollection(Of IParameterSchema)
    Get

Property Value

Type: IReadOnlyNamedObjectCollectionIParameterSchema
See Also

Reference

ICommandSchema Interface
SchemaExplorer Namespace


ICommandSchema.Parameters Property

ICommandSchemaParameters Property

Parameters for this command.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
IReadOnlyNamedObjectCollection<IParameterSchema> Parameters { get; }
ReadOnly Property Parameters As IReadOnlyNamedObjectCollection(Of IParameterSchema)
    Get

Property Value

Type: IReadOnlyNamedObjectCollectionIParameterSchema
See Also

Reference

ICommandSchema Interface
SchemaExplorer Namespace


ICommandSchema.ReturnValueParameter Property

ICommandSchemaReturnValueParameter Property

The return value parameter for this command.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
IParameterSchema ReturnValueParameter { get; }
ReadOnly Property ReturnValueParameter As IParameterSchema
    Get

Property Value

Type: IParameterSchema
See Also

Reference

ICommandSchema Interface
SchemaExplorer Namespace


ICommandSchema Methods

The ICommandSchema type exposes the following members.

Methods
 | Name | Description
Public method | Refresh | Allows the object to be refreshed. (Inherited from ISchemaObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Selected | Determines if the specified item is selected using the rules defined in SchemaSelector. (Defined by SchemaSelectorExtensions.)
Top
See Also

Reference

ICommandSchema Interface
SchemaExplorer Namespace


IDatabaseSchema Interface

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public interface IDatabaseSchema : ISchemaObject
Public Interface IDatabaseSchema
    Inherits ISchemaObject

The IDatabaseSchema type exposes the following members.

Properties
 | Name | Description
Public property | Commands | Provides access to the commands contained in the database.
Public property | ConnectionString | Gets or sets the current connection string for this instance.
Public property | Database | Allows access to the DatabaseSchema object that contains this schema object. (Inherited from ISchemaObject.)
Public property | DateCreated | Returns the date this table was created. (Inherited from ISchemaObject.)
Public property | DeepLoad | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from ISchemaObject.)
Public property | DefaultExtendedProperties | (Inherited from ISchemaObject.)
Public property | Description | The description of the object. (Inherited from ISchemaObject.)
Public property | ExtendedProperties | Used to store any additional information about the schema object. (Inherited from ISchemaObject.)
Public property | FullName | Returns the owner and name of the table. (Inherited from ISchemaObject.)
Public property | IncludeFunctions | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from ISchemaObject.)
Public property | Provider | Gets or sets the current provider for this instance.
Public property | SortName | Gets the name used to sort in 'Table (Owner)' format. (Inherited from ISchemaObject.)
Public property | Tables | Provides access to the tables contained in the database.
Public property | Views | Provides access to the views contained in the database.
Top
Methods
 | Name | Description
Public method | Refresh | Allows the object to be refreshed. (Inherited from ISchemaObject.)
Top
See Also

Reference

SchemaExplorer Namespace


IDatabaseSchema Properties

The IDatabaseSchema type exposes the following members.

Properties
 | Name | Description
Public property | Commands | Provides access to the commands contained in the database.
Public property | ConnectionString | Gets or sets the current connection string for this instance.
Public property | Database | Allows access to the DatabaseSchema object that contains this schema object. (Inherited from ISchemaObject.)
Public property | DateCreated | Returns the date this table was created. (Inherited from ISchemaObject.)
Public property | DeepLoad | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from ISchemaObject.)
Public property | DefaultExtendedProperties | (Inherited from ISchemaObject.)
Public property | Description | The description of the object. (Inherited from ISchemaObject.)
Public property | ExtendedProperties | Used to store any additional information about the schema object. (Inherited from ISchemaObject.)
Public property | FullName | Returns the owner and name of the table. (Inherited from ISchemaObject.)
Public property | IncludeFunctions | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from ISchemaObject.)
Public property | Provider | Gets or sets the current provider for this instance.
Public property | SortName | Gets the name used to sort in 'Table (Owner)' format. (Inherited from ISchemaObject.)
Public property | Tables | Provides access to the tables contained in the database.
Public property | Views | Provides access to the views contained in the database.
Top
See Also

Reference

IDatabaseSchema Interface
SchemaExplorer Namespace


IDatabaseSchema.Commands Property

IDatabaseSchemaCommands Property

Provides access to the commands contained in the database.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
IReadOnlySchemaObjectWithOwnerCollection<ICommandSchema> Commands { get; }
ReadOnly Property Commands As IReadOnlySchemaObjectWithOwnerCollection(Of ICommandSchema)
    Get

Property Value

Type: IReadOnlySchemaObjectWithOwnerCollection ICommandSchema
See Also

Reference

IDatabaseSchema Interface
SchemaExplorer Namespace


IDatabaseSchema.ConnectionString Property

IDatabaseSchemaConnectionString Property

Gets or sets the current connection string for this instance.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
string ConnectionString { get; set; }
Property ConnectionString As String
    Get
    Set

Property Value

Type: String
See Also

Reference

IDatabaseSchema Interface
SchemaExplorer Namespace


IDatabaseSchema.Provider Property

IDatabaseSchemaProvider Property

Gets or sets the current provider for this instance.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
IDbSchemaProvider Provider { get; set; }
Property Provider As IDbSchemaProvider
    Get
    Set

Property Value

Type: IDbSchemaProvider
See Also

Reference

IDatabaseSchema Interface
SchemaExplorer Namespace


IDatabaseSchema.Tables Property

IDatabaseSchemaTables Property

Provides access to the tables contained in the database.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
IReadOnlySchemaObjectWithOwnerCollection<ITableSchema> Tables { get; }
ReadOnly Property Tables As IReadOnlySchemaObjectWithOwnerCollection(Of ITableSchema)
    Get

Property Value

Type: IReadOnlySchemaObjectWithOwnerCollection ITableSchema
See Also

Reference

IDatabaseSchema Interface
SchemaExplorer Namespace


IDatabaseSchema.Views Property

IDatabaseSchemaViews Property

Provides access to the views contained in the database.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
IReadOnlySchemaObjectWithOwnerCollection<IViewSchema> Views { get; }
ReadOnly Property Views As IReadOnlySchemaObjectWithOwnerCollection(Of IViewSchema)
    Get

Property Value

Type: IReadOnlySchemaObjectWithOwnerCollection IViewSchema
See Also

Reference

IDatabaseSchema Interface
SchemaExplorer Namespace


IDatabaseSchema Methods

The IDatabaseSchema type exposes the following members.

Methods
 | Name | Description
Public method | Refresh | Allows the object to be refreshed. (Inherited from ISchemaObject.)
Top
See Also

Reference

IDatabaseSchema Interface
SchemaExplorer Namespace


IDataObject Interface

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public interface IDataObject : ISchemaObject
Public Interface IDataObject
    Inherits ISchemaObject

The IDataObject type exposes the following members.

Properties
 | Name | Description
Public property | AllowDBNull | Whether or not the data object allows null values.
Public property | Database | Allows access to the DatabaseSchema object that contains this schema object. (Inherited from ISchemaObject.)
Public property | DataType | The data type of a (column) parameter is specific to the .NET Framework data provider. Specifying the type converts the value of the Parameter to the data provider Type before passing the value to the data source. seealso: http://msdn.microsoft.com/en-us/library/system.data.dbtype.aspx example: DbType.AnsiString
Public property | DateCreated | Returns the date this table was created. (Inherited from ISchemaObject.)
Public property | DeepLoad | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from ISchemaObject.)
Public property | DefaultExtendedProperties | (Inherited from ISchemaObject.)
Public property | Description | The description of the object. (Inherited from ISchemaObject.)
Public property | ExtendedProperties | Used to store any additional information about the schema object. (Inherited from ISchemaObject.)
Public property | FullName | Returns the owner and name of the table. (Inherited from ISchemaObject.)
Public property | IncludeFunctions | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from ISchemaObject.)
Public property | NativeType | This is the native data type from the database. example: nvarchar
Public property | Parent | The Parent Schema Object.
Public property | Precision | The precision of the data object.
Public property | Scale | The scale of the data object.
Public property | Size | The size of the data object.
Public property | SortName | Gets the name used to sort in 'Table (Owner)' format. (Inherited from ISchemaObject.)
Public property | SystemType | The System Type that is resolved from DataType. example: typeof(System.String)
Top
Methods
 | Name | Description
Public method | Refresh | Allows the object to be refreshed. (Inherited from ISchemaObject.)
Top
See Also

Reference

SchemaExplorer Namespace


IDataObject Properties

The IDataObject type exposes the following members.

Properties
 | Name | Description
Public property | AllowDBNull | Whether or not the data object allows null values.
Public property | Database | Allows access to the DatabaseSchema object that contains this schema object. (Inherited from ISchemaObject.)
Public property | DataType | The data type of a (column) parameter is specific to the .NET Framework data provider. Specifying the type converts the value of the Parameter to the data provider Type before passing the value to the data source. seealso: http://msdn.microsoft.com/en-us/library/system.data.dbtype.aspx example: DbType.AnsiString
Public property | DateCreated | Returns the date this table was created. (Inherited from ISchemaObject.)
Public property | DeepLoad | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from ISchemaObject.)
Public property | DefaultExtendedProperties | (Inherited from ISchemaObject.)
Public property | Description | The description of the object. (Inherited from ISchemaObject.)
Public property | ExtendedProperties | Used to store any additional information about the schema object. (Inherited from ISchemaObject.)
Public property | FullName | Returns the owner and name of the table. (Inherited from ISchemaObject.)
Public property | IncludeFunctions | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from ISchemaObject.)
Public property | NativeType | This is the native data type from the database. example: nvarchar
Public property | Parent | The Parent Schema Object.
Public property | Precision | The precision of the data object.
Public property | Scale | The scale of the data object.
Public property | Size | The size of the data object.
Public property | SortName | Gets the name used to sort in 'Table (Owner)' format. (Inherited from ISchemaObject.)
Public property | SystemType | The System Type that is resolved from DataType. example: typeof(System.String)
Top
See Also

Reference

IDataObject Interface
SchemaExplorer Namespace


IDataObject.AllowDBNull Property

IDataObjectAllowDBNull Property

Whether or not the data object allows null values.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
bool AllowDBNull { get; }
ReadOnly Property AllowDBNull As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

IDataObject Interface
SchemaExplorer Namespace


IDataObject.DataType Property

IDataObjectDataType Property

The data type of a (column) parameter is specific to the .NET Framework data provider. Specifying the type converts the value of the Parameter to the data provider Type before passing the value to the data source. seealso: http://msdn.microsoft.com/en-us/library/system.data.dbtype.aspx example: DbType.AnsiString

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
DbType DataType { get; }
ReadOnly Property DataType As DbType
    Get

Property Value

Type: DbType
See Also

Reference

IDataObject Interface
SchemaExplorer Namespace


IDataObject.NativeType Property

IDataObjectNativeType Property

This is the native data type from the database. example: nvarchar

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
string NativeType { get; }
ReadOnly Property NativeType As String
    Get

Property Value

Type: String
See Also

Reference

IDataObject Interface
SchemaExplorer Namespace


IDataObject.Parent Property

IDataObjectParent Property

The Parent Schema Object.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
ISchemaObject Parent { get; }
ReadOnly Property Parent As ISchemaObject
    Get

Property Value

Type: ISchemaObject
See Also

Reference

IDataObject Interface
SchemaExplorer Namespace


IDataObject.Precision Property

IDataObjectPrecision Property

The precision of the data object.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
byte Precision { get; }
ReadOnly Property Precision As Byte
    Get

Property Value

Type: Byte
See Also

Reference

IDataObject Interface
SchemaExplorer Namespace


IDataObject.Scale Property

IDataObjectScale Property

The scale of the data object.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
int Scale { get; }
ReadOnly Property Scale As Integer
    Get

Property Value

Type: Int32
See Also

Reference

IDataObject Interface
SchemaExplorer Namespace


IDataObject.Size Property

IDataObjectSize Property

The size of the data object.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
int Size { get; }
ReadOnly Property Size As Integer
    Get

Property Value

Type: Int32
See Also

Reference

IDataObject Interface
SchemaExplorer Namespace


IDataObject.SystemType Property

IDataObjectSystemType Property

The System Type that is resolved from DataType. example: typeof(System.String)

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
Type SystemType { get; }
ReadOnly Property SystemType As Type
    Get

Property Value

Type: Type
See Also

Reference

IDataObject Interface
SchemaExplorer Namespace


IDataObject Methods

The IDataObject type exposes the following members.

Methods
 | Name | Description
Public method | Refresh | Allows the object to be refreshed. (Inherited from ISchemaObject.)
Top
See Also

Reference

IDataObject Interface
SchemaExplorer Namespace


IDbConnectionStringEditor Interface

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public interface IDbConnectionStringEditor
Public Interface IDbConnectionStringEditor

The IDbConnectionStringEditor type exposes the following members.

Properties
 | Name | Description
Public property | ConnectionString |
Public property | EditorAvailable |
Top
Methods
 | Name | Description
Public method | ShowEditor |
Top
See Also

Reference

SchemaExplorer Namespace


IDbConnectionStringEditor Properties

The IDbConnectionStringEditor type exposes the following members.

Properties
 | Name | Description
Public property | ConnectionString |
Public property | EditorAvailable |
Top
See Also

Reference

IDbConnectionStringEditor Interface
SchemaExplorer Namespace


IDbConnectionStringEditor.ConnectionString Property

IDbConnectionStringEditorConnectionString Property

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
string ConnectionString { get; }
ReadOnly Property ConnectionString As String
    Get

Property Value

Type: String
See Also

Reference

IDbConnectionStringEditor Interface
SchemaExplorer Namespace


IDbConnectionStringEditor.EditorAvailable Property

IDbConnectionStringEditorEditorAvailable Property

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
bool EditorAvailable { get; }
ReadOnly Property EditorAvailable As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

IDbConnectionStringEditor Interface
SchemaExplorer Namespace


IDbConnectionStringEditor Methods

The IDbConnectionStringEditor type exposes the following members.

Methods
 | Name | Description
Public method | ShowEditor |
Top
See Also

Reference

IDbConnectionStringEditor Interface
SchemaExplorer Namespace


IDbConnectionStringEditor.ShowEditor Method

IDbConnectionStringEditorShowEditor Method

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
bool ShowEditor(
    string currentConnectionString
)
Function ShowEditor (
    currentConnectionString As String
) As Boolean

Parameters

currentConnectionString
Type: SystemString

Return Value

Type: Boolean
See Also

Reference

IDbConnectionStringEditor Interface
SchemaExplorer Namespace


IDbSchemaProvider Interface

This interface is used to implement a custom schema provider for SchemaExplorer. To create your own schema provider simply create a new assembly which includes a public class that implements this interface. Also, the assembly name must end with SchemaProvider.dll (ie. MySampleSchemaProvider.dll). Once you have done this, just put the assembly in the same directory as CodeSmith and that's it.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public interface IDbSchemaProvider
Public Interface IDbSchemaProvider

The IDbSchemaProvider type exposes the following members.

Properties
 | Name | Description
Public property | Description | Gets the description for the schema provider (E.G. SQL Server Schema Provider)..
Top
Methods
 | Name | Description
Public method | GetCommandParameters | Gets the parameters for a given command.
Public method | GetCommandResultSchemas | Gets schema information about the results of a given command.
Public method | GetCommands | Gets all commands for the given database.
Public method | GetCommandText | Gets the definition for a given command.
Public method | GetDatabaseName | Gets the name of the database.
Public method | GetExtendedProperties | Gets the extended property collection for a given schema object.
Public method | GetTableColumns | Gets all columns for a given table.
Public method | GetTableData | Gets the data from the given table.
Public method | GetTableIndexes | Gats all of the indexes for a given table.
Public method | GetTableKeys | Gets all of the table keys for a given table.
Public method | GetTablePrimaryKey | Gets the primary key for a given table.
Public method | GetTables | Gets all of the tables available in the database.
Public method | GetViewColumns | Gets the columns for a given view.
Public method | GetViewData | Gets the data from a given view.
Public method | GetViews | Gets all the views available for a given database.
Public method | GetViewText | Gets the definition for a given view.
Public method | SetExtendedProperties | Sets the extended properties.
Top
See Also

Reference

SchemaExplorer Namespace


IDbSchemaProvider Properties

The IDbSchemaProvider type exposes the following members.

Properties
 | Name | Description
Public property | Description | Gets the description for the schema provider (E.G. SQL Server Schema Provider)..
Top
See Also

Reference

IDbSchemaProvider Interface
SchemaExplorer Namespace


IDbSchemaProvider.Description Property

IDbSchemaProviderDescription Property

Gets the description for the schema provider (E.G. SQL Server Schema Provider)..

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
string Description { get; }
ReadOnly Property Description As String
    Get

Property Value

Type: String
See Also

Reference

IDbSchemaProvider Interface
SchemaExplorer Namespace


IDbSchemaProvider Methods

The IDbSchemaProvider type exposes the following members.

Methods
 | Name | Description
Public method | GetCommandParameters | Gets the parameters for a given command.
Public method | GetCommandResultSchemas | Gets schema information about the results of a given command.
Public method | GetCommands | Gets all commands for the given database.
Public method | GetCommandText | Gets the definition for a given command.
Public method | GetDatabaseName | Gets the name of the database.
Public method | GetExtendedProperties | Gets the extended property collection for a given schema object.
Public method | GetTableColumns | Gets all columns for a given table.
Public method | GetTableData | Gets the data from the given table.
Public method | GetTableIndexes | Gats all of the indexes for a given table.
Public method | GetTableKeys | Gets all of the table keys for a given table.
Public method | GetTablePrimaryKey | Gets the primary key for a given table.
Public method | GetTables | Gets all of the tables available in the database.
Public method | GetViewColumns | Gets the columns for a given view.
Public method | GetViewData | Gets the data from a given view.
Public method | GetViews | Gets all the views available for a given database.
Public method | GetViewText | Gets the definition for a given view.
Public method | SetExtendedProperties | Sets the extended properties.
Top
See Also

Reference

IDbSchemaProvider Interface
SchemaExplorer Namespace


IDbSchemaProvider.GetCommandParameters Method

IDbSchemaProviderGetCommandParameters Method

Gets the parameters for a given command.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
ParameterSchema[] GetCommandParameters(
    string connectionString,
    CommandSchema command
)
Function GetCommandParameters (
    connectionString As String,
    command As CommandSchema
) As ParameterSchema()

Parameters

connectionString
Type: SystemString
The connection string used to connect to the target database.
command
Type: SchemaExplorerCommandSchema
The command schema.

Return Value

Type: ParameterSchema
An array of parameters.
See Also

Reference

IDbSchemaProvider Interface
SchemaExplorer Namespace


IDbSchemaProvider.GetCommandResultSchemas Method

IDbSchemaProviderGetCommandResultSchemas Method

Gets schema information about the results of a given command.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
CommandResultSchema[] GetCommandResultSchemas(
    string connectionString,
    CommandSchema command
)
Function GetCommandResultSchemas (
    connectionString As String,
    command As CommandSchema
) As CommandResultSchema()

Parameters

connectionString
Type: SystemString
The connection string used to connect to the target database.
command
Type: SchemaExplorerCommandSchema
The command schema.

Return Value

Type: CommandResultSchema
An array of command results.
See Also

Reference

IDbSchemaProvider Interface
SchemaExplorer Namespace


IDbSchemaProvider.GetCommands Method

IDbSchemaProviderGetCommands Method

Gets all commands for the given database.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
CommandSchema[] GetCommands(
    string connectionString,
    DatabaseSchema database
)
Function GetCommands (
    connectionString As String,
    database As DatabaseSchema
) As CommandSchema()

Parameters

connectionString
Type: SystemString
The connection string used to connect to the target database.
database
Type: SchemaExplorerDatabaseSchema
The database schema.

Return Value

Type: CommandSchema
An array of commands.
See Also

Reference

IDbSchemaProvider Interface
SchemaExplorer Namespace


IDbSchemaProvider.GetCommandText Method

IDbSchemaProviderGetCommandText Method

Gets the definition for a given command.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
string GetCommandText(
    string connectionString,
    CommandSchema command
)
Function GetCommandText (
    connectionString As String,
    command As CommandSchema
) As String

Parameters

connectionString
Type: SystemString
The connection string used to connect to the target database.
command
Type: SchemaExplorerCommandSchema
The command schema.

Return Value

Type: String
The definition of a command.
See Also

Reference

IDbSchemaProvider Interface
SchemaExplorer Namespace


IDbSchemaProvider.GetDatabaseName Method

IDbSchemaProviderGetDatabaseName Method

Gets the name of the database.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
string GetDatabaseName(
    string connectionString
)
Function GetDatabaseName (
    connectionString As String
) As String

Parameters

connectionString
Type: SystemString
The connection string used to connect to the target database.

Return Value

Type: String
The name of the database
See Also

Reference

IDbSchemaProvider Interface
SchemaExplorer Namespace


IDbSchemaProvider.GetExtendedProperties Method

IDbSchemaProviderGetExtendedProperties Method

Gets the extended property collection for a given schema object.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
ExtendedProperty[] GetExtendedProperties(
    string connectionString,
    SchemaObjectBase schemaObject
)
Function GetExtendedProperties (
    connectionString As String,
    schemaObject As SchemaObjectBase
) As ExtendedProperty()

Parameters

connectionString
Type: SystemString
The connection string used to connect to the target database.
schemaObject
Type: SchemaExplorerSchemaObjectBase
Any type that derives from SchemaObjectBase. (E.G. DatabaseSchema, TableSchema, ColumnSchema, ViewSchema, ViewColumnSchema, IndexSchema, CommandSchema, ParameterSchema, PrimaryKeySchema, TableKeySchema)

Return Value

Type: ExtendedProperty
An array of ExtendedProperties for a specific SchemaObjectBase.
See Also

Reference

IDbSchemaProvider Interface
SchemaExplorer Namespace


IDbSchemaProvider.GetTableColumns Method

IDbSchemaProviderGetTableColumns Method

Gets all columns for a given table.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
ColumnSchema[] GetTableColumns(
    string connectionString,
    TableSchema table
)
Function GetTableColumns (
    connectionString As String,
    table As TableSchema
) As ColumnSchema()

Parameters

connectionString
Type: SystemString
The connection string used to connect to the target database.
table
Type: SchemaExplorerTableSchema
The table schema.

Return Value

Type: ColumnSchema
An array of view columns for a specific table.
See Also

Reference

IDbSchemaProvider Interface
SchemaExplorer Namespace


IDbSchemaProvider.GetTableData Method

IDbSchemaProviderGetTableData Method

Gets the data from the given table.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
DataTable GetTableData(
    string connectionString,
    TableSchema table
)
Function GetTableData (
    connectionString As String,
    table As TableSchema
) As DataTable

Parameters

connectionString
Type: SystemString
The connection string used to connect to the target database.
table
Type: SchemaExplorerTableSchema
The table schema.

Return Value

Type: DataTable
A DataTable containing the data of the specific table.
See Also

Reference

IDbSchemaProvider Interface
SchemaExplorer Namespace


IDbSchemaProvider.GetTableIndexes Method

IDbSchemaProviderGetTableIndexes Method

Gats all of the indexes for a given table.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
IndexSchema[] GetTableIndexes(
    string connectionString,
    TableSchema table
)
Function GetTableIndexes (
    connectionString As String,
    table As TableSchema
) As IndexSchema()

Parameters

connectionString
Type: SystemString
The connection string used to connect to the target database.
table
Type: SchemaExplorerTableSchema
The table schema.

Return Value

Type: IndexSchema
An array of indexes for a specific table.
See Also

Reference

IDbSchemaProvider Interface
SchemaExplorer Namespace


IDbSchemaProvider.GetTableKeys Method

IDbSchemaProviderGetTableKeys Method

Gets all of the table keys for a given table.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
TableKeySchema[] GetTableKeys(
    string connectionString,
    TableSchema table
)
Function GetTableKeys (
    connectionString As String,
    table As TableSchema
) As TableKeySchema()

Parameters

connectionString
Type: SystemString
The connection string used to connect to the target database.
table
Type: SchemaExplorerTableSchema
The table schema.

Return Value

Type: TableKeySchema
An array of keys for a specific table.
See Also

Reference

IDbSchemaProvider Interface
SchemaExplorer Namespace


IDbSchemaProvider.GetTablePrimaryKey Method

IDbSchemaProviderGetTablePrimaryKey Method

Gets the primary key for a given table.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
PrimaryKeySchema GetTablePrimaryKey(
    string connectionString,
    TableSchema table
)
Function GetTablePrimaryKey (
    connectionString As String,
    table As TableSchema
) As PrimaryKeySchema

Parameters

connectionString
Type: SystemString
The connection string used to connect to the target database.
table
Type: SchemaExplorerTableSchema
The table schema.

Return Value

Type: PrimaryKeySchema
An the primary key for a specific table.
See Also

Reference

IDbSchemaProvider Interface
SchemaExplorer Namespace


IDbSchemaProvider.GetTables Method

IDbSchemaProviderGetTables Method

Gets all of the tables available in the database.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
TableSchema[] GetTables(
    string connectionString,
    DatabaseSchema database
)
Function GetTables (
    connectionString As String,
    database As DatabaseSchema
) As TableSchema()

Parameters

connectionString
Type: SystemString
The connection string used to connect to the target database.
database
Type: SchemaExplorerDatabaseSchema
The database schema.

Return Value

Type: TableSchema
An array of tables for a specific database.
See Also

Reference

IDbSchemaProvider Interface
SchemaExplorer Namespace


IDbSchemaProvider.GetViewColumns Method

IDbSchemaProviderGetViewColumns Method

Gets the columns for a given view.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
ViewColumnSchema[] GetViewColumns(
    string connectionString,
    ViewSchema view
)
Function GetViewColumns (
    connectionString As String,
    view As ViewSchema
) As ViewColumnSchema()

Parameters

connectionString
Type: SystemString
The connection string used to connect to the target database.
view
Type: SchemaExplorerViewSchema
The view schema.

Return Value

Type: ViewColumnSchema
An array of view columns for a specific view.
See Also

Reference

IDbSchemaProvider Interface
SchemaExplorer Namespace


IDbSchemaProvider.GetViewData Method

IDbSchemaProviderGetViewData Method

Gets the data from a given view.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
DataTable GetViewData(
    string connectionString,
    ViewSchema view
)
Function GetViewData (
    connectionString As String,
    view As ViewSchema
) As DataTable

Parameters

connectionString
Type: SystemString
The connection string used to connect to the target database.
view
Type: SchemaExplorerViewSchema
The view schema.

Return Value

Type: DataTable
A DataTable containing the data of the specific view.
See Also

Reference

IDbSchemaProvider Interface
SchemaExplorer Namespace


IDbSchemaProvider.GetViews Method

IDbSchemaProviderGetViews Method

Gets all the views available for a given database.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
ViewSchema[] GetViews(
    string connectionString,
    DatabaseSchema database
)
Function GetViews (
    connectionString As String,
    database As DatabaseSchema
) As ViewSchema()

Parameters

connectionString
Type: SystemString
The connection string used to connect to the target database.
database
Type: SchemaExplorerDatabaseSchema
The database schema.

Return Value

Type: ViewSchema
An array of views for a specific database.
See Also

Reference

IDbSchemaProvider Interface
SchemaExplorer Namespace


IDbSchemaProvider.GetViewText Method

IDbSchemaProviderGetViewText Method

Gets the definition for a given view.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
string GetViewText(
    string connectionString,
    ViewSchema view
)
Function GetViewText (
    connectionString As String,
    view As ViewSchema
) As String

Parameters

connectionString
Type: SystemString
The connection string used to connect to the target database.
view
Type: SchemaExplorerViewSchema
The view schema.

Return Value

Type: String
The definition of a view.
See Also

Reference

IDbSchemaProvider Interface
SchemaExplorer Namespace


IDbSchemaProvider.SetExtendedProperties Method

IDbSchemaProviderSetExtendedProperties Method

Sets the extended properties.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
void SetExtendedProperties(
    string connectionString,
    SchemaObjectBase schemaObject
)
Sub SetExtendedProperties (
    connectionString As String,
    schemaObject As SchemaObjectBase
)

Parameters

connectionString
Type: SystemString
The connection string used to connect to the target database.
schemaObject
Type: SchemaExplorerSchemaObjectBase
Any type that derives from SchemaObjectBase. (E.G. DatabaseSchema, TableSchema, ColumnSchema, ViewSchema, ViewColumnSchema, IndexSchema, CommandSchema, ParameterSchema, PrimaryKeySchema, TableKeySchema)
See Also

Reference

IDbSchemaProvider Interface
SchemaExplorer Namespace


IDbSchemaProviderCollection Class

Implements a strongly typed collection of IDbSchemaProvider elements.
Inheritance Hierarchy
SystemObject
ObservableListIDbSchemaProvider
NamedObjectCollectionIDbSchemaProvider
SchemaExplorerIDbSchemaProviderCollection

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
public class IDbSchemaProviderCollection : NamedObjectCollection<IDbSchemaProvider>
<SerializableAttribute>
Public Class IDbSchemaProviderCollection
    Inherits NamedObjectCollection(Of IDbSchemaProvider)

The IDbSchemaProviderCollection type exposes the following members.

Constructors
 | Name | Description
Public method | IDbSchemaProviderCollection | Initializes a new instance of the IDbSchemaProviderCollection class.
Public method | IDbSchemaProviderCollection(IEnumerableIDbSchemaProvider) | Initializes a new instance of the IDbSchemaProviderCollection class.
Public method | IDbSchemaProviderCollection(Int32) | Initializes a new instance of the IDbSchemaProviderCollection class.
Top
Properties
 | Name | Description
Public property | Item | Gets the IDbSchemaProvider with the specified name.
Top
Methods
 | Name | Description
Public method | Clone |
Public method | Contains | Determines whether an element is in the collection with the specified name.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the list.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Top
Remarks
IDbSchemaProviderCollection provides an ObservableList that is strongly typed for IDbSchemaProvider elements.
See Also

Reference

SchemaExplorer Namespace


IDbSchemaProviderCollection Constructor

Overload List
 | Name | Description
Public method | IDbSchemaProviderCollection | Initializes a new instance of the IDbSchemaProviderCollection class.
Public method | IDbSchemaProviderCollection(IEnumerableIDbSchemaProvider) | Initializes a new instance of the IDbSchemaProviderCollection class.
Public method | IDbSchemaProviderCollection(Int32) | Initializes a new instance of the IDbSchemaProviderCollection class.
Top
See Also

Reference

IDbSchemaProviderCollection Class
SchemaExplorer Namespace


IDbSchemaProviderCollection Constructor

Initializes a new instance of the IDbSchemaProviderCollection class.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public IDbSchemaProviderCollection()
Public Sub New
See Also

Reference

IDbSchemaProviderCollection Class
IDbSchemaProviderCollection Overload
SchemaExplorer Namespace


IDbSchemaProviderCollection Constructor (IEnumerable(IDbSchemaProvider))

IDbSchemaProviderCollection Constructor (IEnumerableIDbSchemaProvider)

Initializes a new instance of the IDbSchemaProviderCollection class.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public IDbSchemaProviderCollection(
    IEnumerable<IDbSchemaProvider> collection
)
Public Sub New (
    collection As IEnumerable(Of IDbSchemaProvider)
)

Parameters

collection
Type: System.Collections.GenericIEnumerable IDbSchemaProvider
The collection from which the elements are copied.
See Also

Reference

IDbSchemaProviderCollection Class
IDbSchemaProviderCollection Overload
SchemaExplorer Namespace


IDbSchemaProviderCollection Constructor (Int32)

Initializes a new instance of the IDbSchemaProviderCollection class.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public IDbSchemaProviderCollection(
    int capacity
)
Public Sub New (
    capacity As Integer
)

Parameters

capacity
Type: SystemInt32
The number of elements that the new list can initially store.
See Also

Reference

IDbSchemaProviderCollection Class
IDbSchemaProviderCollection Overload
SchemaExplorer Namespace


IDbSchemaProviderCollection Properties

The IDbSchemaProviderCollection type exposes the following members.

Properties
 | Name | Description
Public property | Item | Gets the IDbSchemaProvider with the specified name.
Top
See Also

Reference

IDbSchemaProviderCollection Class
SchemaExplorer Namespace


IDbSchemaProviderCollection.Item Property

IDbSchemaProviderCollectionItem Property

Gets the IDbSchemaProvider with the specified name.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public IDbSchemaProvider this[
    string name
] { get; }
Public ReadOnly Default Property Item (
    name As String
) As IDbSchemaProvider
    Get

Parameters

name
Type: SystemString

Return Value

Type: IDbSchemaProvider
The IDbSchemaProvider with the specified name.
See Also

Reference

IDbSchemaProviderCollection Class
SchemaExplorer Namespace


IDbSchemaProviderCollection Methods

The IDbSchemaProviderCollection type exposes the following members.

Methods
 | Name | Description
Public method | Clone |
Public method | Contains | Determines whether an element is in the collection with the specified name.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the list.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Top
See Also

Reference

IDbSchemaProviderCollection Class
SchemaExplorer Namespace


IDbSchemaProviderCollection.Clone Method

IDbSchemaProviderCollectionClone Method

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual Object Clone()
Public Overridable Function Clone As Object

Return Value

Type: Object
See Also

Reference

IDbSchemaProviderCollection Class
SchemaExplorer Namespace


IDbSchemaProviderCollection.Contains Method

IDbSchemaProviderCollectionContains Method

Determines whether an element is in the collection with the specified name.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool Contains(
    string name
)
Public Function Contains (
    name As String
) As Boolean

Parameters

name
Type: SystemString
The name of the item to locate in the collection.

Return Value

Type: Boolean
true if item is found in the collection; otherwise, false.
See Also

Reference

IDbSchemaProviderCollection Class
SchemaExplorer Namespace


IDbSchemaProviderCollection.IndexOf Method

IDbSchemaProviderCollectionIndexOf Method

Determines the index of a specific item in the list.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public int IndexOf(
    string name
)
Public Function IndexOf (
    name As String
) As Integer

Parameters

name
Type: SystemString
The name of the item to locate in the list.

Return Value

Type: Int32
The index of item if found in the list; otherwise, -1.
See Also

Reference

IDbSchemaProviderCollection Class
SchemaExplorer Namespace


IExtendedProperty Interface

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public interface IExtendedProperty : INotifyPropertyChanged
Public Interface IExtendedProperty
    Inherits INotifyPropertyChanged

The IExtendedProperty type exposes the following members.

Properties
 | Name | Description
Public property | DataType | The data type of this extended property.
Public property | PropertyState |
Public property | Value | The value of this extended property.
Top
Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

SchemaExplorer Namespace


IExtendedProperty Properties

The IExtendedProperty type exposes the following members.

Properties
 | Name | Description
Public property | DataType | The data type of this extended property.
Public property | PropertyState |
Public property | Value | The value of this extended property.
Top
See Also

Reference

IExtendedProperty Interface
SchemaExplorer Namespace


IExtendedProperty.DataType Property

IExtendedPropertyDataType Property

The data type of this extended property.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
DbType DataType { get; }
ReadOnly Property DataType As DbType
    Get

Property Value

Type: DbType
See Also

Reference

IExtendedProperty Interface
SchemaExplorer Namespace


IExtendedProperty.PropertyState Property

IExtendedPropertyPropertyState Property

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
PropertyStateEnum PropertyState { get; set; }
Property PropertyState As PropertyStateEnum
    Get
    Set

Property Value

Type: PropertyStateEnum
See Also

Reference

IExtendedProperty Interface
SchemaExplorer Namespace


IExtendedProperty.Value Property

IExtendedPropertyValue Property

The value of this extended property.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
Object Value { get; set; }
Property Value As Object
    Get
    Set

Property Value

Type: Object
See Also

Reference

IExtendedProperty Interface
SchemaExplorer Namespace


IExtendedProperty Events

The IExtendedProperty type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

IExtendedProperty Interface
SchemaExplorer Namespace


IIndexSchema Interface

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public interface IIndexSchema : ISchemaObject
Public Interface IIndexSchema
    Inherits ISchemaObject

The IIndexSchema type exposes the following members.

Properties
 | Name | Description
Public property | Database | Allows access to the DatabaseSchema object that contains this schema object. (Inherited from ISchemaObject.)
Public property | DateCreated | Returns the date this table was created. (Inherited from ISchemaObject.)
Public property | DeepLoad | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from ISchemaObject.)
Public property | DefaultExtendedProperties | (Inherited from ISchemaObject.)
Public property | Description | The description of the object. (Inherited from ISchemaObject.)
Public property | ExtendedProperties | Used to store any additional information about the schema object. (Inherited from ISchemaObject.)
Public property | FullName | Returns the owner and name of the table. (Inherited from ISchemaObject.)
Public property | IncludeFunctions | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from ISchemaObject.)
Public property | IsClustered | Whether this is a clustered index.
Public property | IsPrimaryKey | Whether this is the index for the primary key or not.
Public property | IsUnique | Whether this is a unique index.
Public property | MemberColumns | The columns that make up this index.
Public property | SortName | Gets the name used to sort in 'Table (Owner)' format. (Inherited from ISchemaObject.)
Public property | Table | The table that contains this index.
Top
Methods
 | Name | Description
Public method | Refresh | Allows the object to be refreshed. (Inherited from ISchemaObject.)
Top
See Also

Reference

SchemaExplorer Namespace


IIndexSchema Properties

The IIndexSchema type exposes the following members.

Properties
 | Name | Description
Public property | Database | Allows access to the DatabaseSchema object that contains this schema object. (Inherited from ISchemaObject.)
Public property | DateCreated | Returns the date this table was created. (Inherited from ISchemaObject.)
Public property | DeepLoad | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from ISchemaObject.)
Public property | DefaultExtendedProperties | (Inherited from ISchemaObject.)
Public property | Description | The description of the object. (Inherited from ISchemaObject.)
Public property | ExtendedProperties | Used to store any additional information about the schema object. (Inherited from ISchemaObject.)
Public property | FullName | Returns the owner and name of the table. (Inherited from ISchemaObject.)
Public property | IncludeFunctions | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from ISchemaObject.)
Public property | IsClustered | Whether this is a clustered index.
Public property | IsPrimaryKey | Whether this is the index for the primary key or not.
Public property | IsUnique | Whether this is a unique index.
Public property | MemberColumns | The columns that make up this index.
Public property | SortName | Gets the name used to sort in 'Table (Owner)' format. (Inherited from ISchemaObject.)
Public property | Table | The table that contains this index.
Top
See Also

Reference

IIndexSchema Interface
SchemaExplorer Namespace


IIndexSchema.IsClustered Property

IIndexSchemaIsClustered Property

Whether this is a clustered index.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
bool IsClustered { get; }
ReadOnly Property IsClustered As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

IIndexSchema Interface
SchemaExplorer Namespace


IIndexSchema.IsPrimaryKey Property

IIndexSchemaIsPrimaryKey Property

Whether this is the index for the primary key or not.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
bool IsPrimaryKey { get; }
ReadOnly Property IsPrimaryKey As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

IIndexSchema Interface
SchemaExplorer Namespace


IIndexSchema.IsUnique Property

IIndexSchemaIsUnique Property

Whether this is a unique index.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
bool IsUnique { get; }
ReadOnly Property IsUnique As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

IIndexSchema Interface
SchemaExplorer Namespace


IIndexSchema.MemberColumns Property

IIndexSchemaMemberColumns Property

The columns that make up this index.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
IReadOnlyNamedObjectCollection<IMemberColumnSchema> MemberColumns { get; }
ReadOnly Property MemberColumns As IReadOnlyNamedObjectCollection(Of IMemberColumnSchema)
    Get

Property Value

Type: IReadOnlyNamedObjectCollectionIMemberColumnSchema
See Also

Reference

IIndexSchema Interface
SchemaExplorer Namespace


IIndexSchema.Table Property

IIndexSchemaTable Property

The table that contains this index.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
ITableSchema Table { get; }
ReadOnly Property Table As ITableSchema
    Get

Property Value

Type: ITableSchema
See Also

Reference

IIndexSchema Interface
SchemaExplorer Namespace


IIndexSchema Methods

The IIndexSchema type exposes the following members.

Methods
 | Name | Description
Public method | Refresh | Allows the object to be refreshed. (Inherited from ISchemaObject.)
Top
See Also

Reference

IIndexSchema Interface
SchemaExplorer Namespace


IMemberColumnSchema Interface

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public interface IMemberColumnSchema : IColumnSchema,
    IDataObject, ISchemaObject
Public Interface IMemberColumnSchema
    Inherits IColumnSchema, IDataObject, ISchemaObject

The IMemberColumnSchema type exposes the following members.

Properties
 | Name | Description
Public property | AllowDBNull | Whether or not the data object allows null values. (Inherited from IDataObject.)
Public property | Column | The column that this member column object wraps.
Public property | ColumnExtendedProperties | The underlying column's extended properties.
Public property | Database | Allows access to the DatabaseSchema object that contains this schema object. (Inherited from ISchemaObject.)
Public property | DataType | The data type of a (column) parameter is specific to the .NET Framework data provider. Specifying the type converts the value of the Parameter to the data provider Type before passing the value to the data source. seealso: http://msdn.microsoft.com/en-us/library/system.data.dbtype.aspx example: DbType.AnsiString (Inherited from IDataObject.)
Public property | DateCreated | Returns the date this table was created. (Inherited from ISchemaObject.)
Public property | DeepLoad | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from ISchemaObject.)
Public property | DefaultExtendedProperties | (Inherited from ISchemaObject.)
Public property | Description | The description of the object. (Inherited from ISchemaObject.)
Public property | ExtendedProperties | Used to store any additional information about the schema object. (Inherited from ISchemaObject.)
Public property | FullName | Returns the owner and name of the table. (Inherited from ISchemaObject.)
Public property | IncludeFunctions | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from ISchemaObject.)
Public property | IsForeignKeyMember | Whether or not the column is a foreign key member. (Inherited from IColumnSchema.)
Public property | IsPrimaryKeyMember | Whether or not the column is a primary key member. (Inherited from IColumnSchema.)
Public property | IsUnique | Whether or not this column is unique. (Inherited from IColumnSchema.)
Public property | NativeType | This is the native data type from the database. example: nvarchar (Inherited from IDataObject.)
Public property | Parent | The Parent Schema Object. (Inherited from IDataObject.)
Public property | Precision | The precision of the data object. (Inherited from IDataObject.)
Public property | Scale | The scale of the data object. (Inherited from IDataObject.)
Public property | Size | The size of the data object. (Inherited from IDataObject.)
Public property | SortName | Gets the name used to sort in 'Table (Owner)' format. (Inherited from ISchemaObject.)
Public property | SystemType | The System Type that is resolved from DataType. example: typeof(System.String) (Inherited from IDataObject.)
Public property | Table | The table that contains this column. (Inherited from IColumnSchema.)
Top
Methods
 | Name | Description
Public method | Refresh | Allows the object to be refreshed. (Inherited from ISchemaObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Selected | Determines if the specified item is selected using the rules defined in SchemaSelector. (Defined by SchemaSelectorExtensions.)
Top
See Also

Reference

SchemaExplorer Namespace


IMemberColumnSchema Properties

The IMemberColumnSchema type exposes the following members.

Properties
 | Name | Description
Public property | AllowDBNull | Whether or not the data object allows null values. (Inherited from IDataObject.)
Public property | Column | The column that this member column object wraps.
Public property | ColumnExtendedProperties | The underlying column's extended properties.
Public property | Database | Allows access to the DatabaseSchema object that contains this schema object. (Inherited from ISchemaObject.)
Public property | DataType | The data type of a (column) parameter is specific to the .NET Framework data provider. Specifying the type converts the value of the Parameter to the data provider Type before passing the value to the data source. seealso: http://msdn.microsoft.com/en-us/library/system.data.dbtype.aspx example: DbType.AnsiString (Inherited from IDataObject.)
Public property | DateCreated | Returns the date this table was created. (Inherited from ISchemaObject.)
Public property | DeepLoad | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from ISchemaObject.)
Public property | DefaultExtendedProperties | (Inherited from ISchemaObject.)
Public property | Description | The description of the object. (Inherited from ISchemaObject.)
Public property | ExtendedProperties | Used to store any additional information about the schema object. (Inherited from ISchemaObject.)
Public property | FullName | Returns the owner and name of the table. (Inherited from ISchemaObject.)
Public property | IncludeFunctions | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from ISchemaObject.)
Public property | IsForeignKeyMember | Whether or not the column is a foreign key member. (Inherited from IColumnSchema.)
Public property | IsPrimaryKeyMember | Whether or not the column is a primary key member. (Inherited from IColumnSchema.)
Public property | IsUnique | Whether or not this column is unique. (Inherited from IColumnSchema.)
Public property | NativeType | This is the native data type from the database. example: nvarchar (Inherited from IDataObject.)
Public property | Parent | The Parent Schema Object. (Inherited from IDataObject.)
Public property | Precision | The precision of the data object. (Inherited from IDataObject.)
Public property | Scale | The scale of the data object. (Inherited from IDataObject.)
Public property | Size | The size of the data object. (Inherited from IDataObject.)
Public property | SortName | Gets the name used to sort in 'Table (Owner)' format. (Inherited from ISchemaObject.)
Public property | SystemType | The System Type that is resolved from DataType. example: typeof(System.String) (Inherited from IDataObject.)
Public property | Table | The table that contains this column. (Inherited from IColumnSchema.)
Top
See Also

Reference

IMemberColumnSchema Interface
SchemaExplorer Namespace


IMemberColumnSchema.Column Property

IMemberColumnSchemaColumn Property

The column that this member column object wraps.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
IColumnSchema Column { get; }
ReadOnly Property Column As IColumnSchema
    Get

Property Value

Type: IColumnSchema
See Also

Reference

IMemberColumnSchema Interface
SchemaExplorer Namespace


IMemberColumnSchema.ColumnExtendedProperties Property

IMemberColumnSchemaColumnExtendedProperties Property

The underlying column's extended properties.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
INamedObjectCollection<IExtendedProperty> ColumnExtendedProperties { get; }
ReadOnly Property ColumnExtendedProperties As INamedObjectCollection(Of IExtendedProperty)
    Get

Property Value

Type: INamedObjectCollectionIExtendedProperty
See Also

Reference

IMemberColumnSchema Interface
SchemaExplorer Namespace


IMemberColumnSchema Methods

The IMemberColumnSchema type exposes the following members.

Methods
 | Name | Description
Public method | Refresh | Allows the object to be refreshed. (Inherited from ISchemaObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Selected | Determines if the specified item is selected using the rules defined in SchemaSelector. (Defined by SchemaSelectorExtensions.)
Top
See Also

Reference

IMemberColumnSchema Interface
SchemaExplorer Namespace


IndexSchema Class

Provides information about an index.
Inheritance Hierarchy
SystemObject
NamedObjectBase
SchemaExplorerSchemaObjectBase
SchemaExplorerIndexSchema

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
public class IndexSchema : SchemaObjectBase,
    IIndexSchema, ISchemaObject
<SerializableAttribute>
Public Class IndexSchema
    Inherits SchemaObjectBase
    Implements IIndexSchema, ISchemaObject

The IndexSchema type exposes the following members.

Constructors
 | Name | Description
Public method | IndexSchema(TableSchema, String, Boolean, Boolean, Boolean) | Initializes a new instance of the IndexSchema class
Public method | IndexSchema(TableSchema, String, Boolean, Boolean, Boolean, ExtendedProperty) | Initializes a new instance of the IndexSchema class
Public method | IndexSchema(TableSchema, String, Boolean, Boolean, Boolean, String) | Initializes a new instance of the IndexSchema class
Public method | IndexSchema(TableSchema, String, Boolean, Boolean, Boolean, String, ExtendedProperty) | Initializes a new instance of the IndexSchema class
Top
Properties
 | Name | Description
Public property | Database | Allows access to the DatabaseSchema object that contains this schema object. (Inherited from SchemaObjectBase.)
Public property | DateCreated | Returns the date this table was created. (Inherited from SchemaObjectBase.)
Public property | DeepLoad | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from SchemaObjectBase.)
Public property | Description | The description of the object. (Inherited from SchemaObjectBase.)
Public property | ExtendedProperties | Used to store any additional information about the schema object. (Inherited from SchemaObjectBase.)
Public property | FullName | Returns the owner and name of the table. (Inherited from SchemaObjectBase.)
Public property | IncludeFunctions | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from SchemaObjectBase.)
Public property | IsClustered | Whether this is a clustered index.
Public property | IsPrimaryKey | Whether this is the index for the primary key or not.
Public property | IsUnique | Whether this is a unique index.
Public property | MemberColumns | The columns that make up this index.
Public property | SortName | Gets the name used to sort in 'Table (Owner)' format. (Inherited from SchemaObjectBase.)
Public property | Table | The table that contains this index.
Top
Methods
 | Name | Description
Public method | Equals | Determines if another index is the same as this index. (Overrides SchemaObjectBaseEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FormatFullName | Formats the full name.
Public method | GetHashCode | Returns a hashcode based on the database, table and name of the index. (Overrides SchemaObjectBaseGetHashCode.)
Public method | GetLoadedExtendedProperties | Gets the existing ExtendedProperties without causing a lazy load. (Inherited from SchemaObjectBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MarkLoaded | (Inherited from SchemaObjectBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh | (Overrides SchemaObjectBaseRefresh.)
Top
Fields
 | Name | Description
Protected field | _database | (Inherited from SchemaObjectBase.)
Protected field | _dateCreated | (Inherited from SchemaObjectBase.)
Protected field | _defaultExtendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _extendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _gotExtendedProperties | (Inherited from SchemaObjectBase.)
Top
See Also

Reference

SchemaExplorer Namespace


IndexSchema Constructor

Overload List
 | Name | Description
Public method | IndexSchema(TableSchema, String, Boolean, Boolean, Boolean) | Initializes a new instance of the IndexSchema class
Public method | IndexSchema(TableSchema, String, Boolean, Boolean, Boolean, ExtendedProperty) | Initializes a new instance of the IndexSchema class
Public method | IndexSchema(TableSchema, String, Boolean, Boolean, Boolean, String) | Initializes a new instance of the IndexSchema class
Public method | IndexSchema(TableSchema, String, Boolean, Boolean, Boolean, String, ExtendedProperty) | Initializes a new instance of the IndexSchema class
Top
See Also

Reference

IndexSchema Class
SchemaExplorer Namespace


IndexSchema Constructor (TableSchema, String, Boolean, Boolean, Boolean)

Initializes a new instance of the IndexSchema class

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public IndexSchema(
    TableSchema table,
    string name,
    bool isPrimaryKey,
    bool isUnique,
    bool isClustered
)
Public Sub New (
    table As TableSchema,
    name As String,
    isPrimaryKey As Boolean,
    isUnique As Boolean,
    isClustered As Boolean
)

Parameters

table
Type: SchemaExplorerTableSchema
name
Type: SystemString
isPrimaryKey
Type: SystemBoolean
isUnique
Type: SystemBoolean
isClustered
Type: SystemBoolean
See Also

Reference

IndexSchema Class
IndexSchema Overload
SchemaExplorer Namespace


IndexSchema Constructor (TableSchema, String, Boolean, Boolean, Boolean, ExtendedProperty[])

IndexSchema Constructor (TableSchema, String, Boolean, Boolean, Boolean, ExtendedProperty)

Initializes a new instance of the IndexSchema class

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public IndexSchema(
    TableSchema table,
    string name,
    bool isPrimaryKey,
    bool isUnique,
    bool isClustered,
    ExtendedProperty[] extendedProperties
)
Public Sub New (
    table As TableSchema,
    name As String,
    isPrimaryKey As Boolean,
    isUnique As Boolean,
    isClustered As Boolean,
    extendedProperties As ExtendedProperty()
)

Parameters

table
Type: SchemaExplorerTableSchema
name
Type: SystemString
isPrimaryKey
Type: SystemBoolean
isUnique
Type: SystemBoolean
isClustered
Type: SystemBoolean
extendedProperties
Type: SchemaExplorerExtendedProperty
See Also

Reference

IndexSchema Class
IndexSchema Overload
SchemaExplorer Namespace


IndexSchema Constructor (TableSchema, String, Boolean, Boolean, Boolean, String[])

IndexSchema Constructor (TableSchema, String, Boolean, Boolean, Boolean, String)

Initializes a new instance of the IndexSchema class

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public IndexSchema(
    TableSchema table,
    string name,
    bool isPrimaryKey,
    bool isUnique,
    bool isClustered,
    string[] memberColumns
)
Public Sub New (
    table As TableSchema,
    name As String,
    isPrimaryKey As Boolean,
    isUnique As Boolean,
    isClustered As Boolean,
    memberColumns As String()
)

Parameters

table
Type: SchemaExplorerTableSchema
name
Type: SystemString
isPrimaryKey
Type: SystemBoolean
isUnique
Type: SystemBoolean
isClustered
Type: SystemBoolean
memberColumns
Type: SystemString
See Also

Reference

IndexSchema Class
IndexSchema Overload
SchemaExplorer Namespace


IndexSchema Constructor (TableSchema, String, Boolean, Boolean, Boolean, String[], ExtendedProperty[])

IndexSchema Constructor (TableSchema, String, Boolean, Boolean, Boolean, String, ExtendedProperty)

Initializes a new instance of the IndexSchema class

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public IndexSchema(
    TableSchema table,
    string name,
    bool isPrimaryKey,
    bool isUnique,
    bool isClustered,
    string[] memberColumns,
    ExtendedProperty[] extendedProperties
)
Public Sub New (
    table As TableSchema,
    name As String,
    isPrimaryKey As Boolean,
    isUnique As Boolean,
    isClustered As Boolean,
    memberColumns As String(),
    extendedProperties As ExtendedProperty()
)

Parameters

table
Type: SchemaExplorerTableSchema
name
Type: SystemString
isPrimaryKey
Type: SystemBoolean
isUnique
Type: SystemBoolean
isClustered
Type: SystemBoolean
memberColumns
Type: SystemString
extendedProperties
Type: SchemaExplorerExtendedProperty
See Also

Reference

IndexSchema Class
IndexSchema Overload
SchemaExplorer Namespace


IndexSchema Properties

The IndexSchema type exposes the following members.

Properties
 | Name | Description
Public property | Database | Allows access to the DatabaseSchema object that contains this schema object. (Inherited from SchemaObjectBase.)
Public property | DateCreated | Returns the date this table was created. (Inherited from SchemaObjectBase.)
Public property | DeepLoad | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from SchemaObjectBase.)
Public property | Description | The description of the object. (Inherited from SchemaObjectBase.)
Public property | ExtendedProperties | Used to store any additional information about the schema object. (Inherited from SchemaObjectBase.)
Public property | FullName | Returns the owner and name of the table. (Inherited from SchemaObjectBase.)
Public property | IncludeFunctions | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from SchemaObjectBase.)
Public property | IsClustered | Whether this is a clustered index.
Public property | IsPrimaryKey | Whether this is the index for the primary key or not.
Public property | IsUnique | Whether this is a unique index.
Public property | MemberColumns | The columns that make up this index.
Public property | SortName | Gets the name used to sort in 'Table (Owner)' format. (Inherited from SchemaObjectBase.)
Public property | Table | The table that contains this index.
Top
See Also

Reference

IndexSchema Class
SchemaExplorer Namespace


IndexSchema.IsClustered Property

IndexSchemaIsClustered Property

Whether this is a clustered index.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool IsClustered { get; }
Public ReadOnly Property IsClustered As Boolean
    Get

Property Value

Type: Boolean

Implements

IIndexSchemaIsClustered
See Also

Reference

IndexSchema Class
SchemaExplorer Namespace


IndexSchema.IsPrimaryKey Property

IndexSchemaIsPrimaryKey Property

Whether this is the index for the primary key or not.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool IsPrimaryKey { get; }
Public ReadOnly Property IsPrimaryKey As Boolean
    Get

Property Value

Type: Boolean

Implements

IIndexSchemaIsPrimaryKey
See Also

Reference

IndexSchema Class
SchemaExplorer Namespace


IndexSchema.IsUnique Property

IndexSchemaIsUnique Property

Whether this is a unique index.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool IsUnique { get; }
Public ReadOnly Property IsUnique As Boolean
    Get

Property Value

Type: Boolean

Implements

IIndexSchemaIsUnique
See Also

Reference

IndexSchema Class
SchemaExplorer Namespace


IndexSchema.MemberColumns Property

IndexSchemaMemberColumns Property

The columns that make up this index.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public MemberColumnSchemaCollection MemberColumns { get; }
Public ReadOnly Property MemberColumns As MemberColumnSchemaCollection
    Get

Property Value

Type: MemberColumnSchemaCollection
See Also

Reference

IndexSchema Class
SchemaExplorer Namespace


IndexSchema.Table Property

IndexSchemaTable Property

The table that contains this index.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public TableSchema Table { get; }
Public ReadOnly Property Table As TableSchema
    Get

Property Value

Type: TableSchema
See Also

Reference

IndexSchema Class
SchemaExplorer Namespace


IndexSchema Methods

The IndexSchema type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines if another index is the same as this index. (Overrides SchemaObjectBaseEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FormatFullName | Formats the full name.
Public method | GetHashCode | Returns a hashcode based on the database, table and name of the index. (Overrides SchemaObjectBaseGetHashCode.)
Public method | GetLoadedExtendedProperties | Gets the existing ExtendedProperties without causing a lazy load. (Inherited from SchemaObjectBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MarkLoaded | (Inherited from SchemaObjectBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh | (Overrides SchemaObjectBaseRefresh.)
Top
See Also

Reference

IndexSchema Class
SchemaExplorer Namespace


IndexSchema.Equals Method

IndexSchemaEquals Method

Determines if another index is the same as this index.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
The index to check against.

Return Value

Type: Boolean
true/false
See Also

Reference

IndexSchema Class
SchemaExplorer Namespace


IndexSchema.FormatFullName Method

IndexSchemaFormatFullName Method

Formats the full name.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static string FormatFullName(
    string owner,
    string tableName,
    string indexName
)
Public Shared Function FormatFullName (
    owner As String,
    tableName As String,
    indexName As String
) As String

Parameters

owner
Type: SystemString
The owner.
tableName
Type: SystemString
Name of the table.
indexName
Type: SystemString
Name of the index.

Return Value

Type: String
See Also

Reference

IndexSchema Class
SchemaExplorer Namespace


IndexSchema.GetHashCode Method

IndexSchemaGetHashCode Method

Returns a hashcode based on the database, table and name of the index.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
See Also

Reference

IndexSchema Class
SchemaExplorer Namespace


IndexSchema.Refresh Method

IndexSchemaRefresh Method

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override void Refresh()
Public Overrides Sub Refresh

Implements

ISchemaObjectRefresh
ISchemaObjectRefresh
See Also

Reference

IndexSchema Class
SchemaExplorer Namespace


IndexSchema Fields

The IndexSchema type exposes the following members.

Fields
 | Name | Description
Protected field | _database | (Inherited from SchemaObjectBase.)
Protected field | _dateCreated | (Inherited from SchemaObjectBase.)
Protected field | _defaultExtendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _extendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _gotExtendedProperties | (Inherited from SchemaObjectBase.)
Top
See Also

Reference

IndexSchema Class
SchemaExplorer Namespace


IndexSchemaCollection Class

Implements a strongly typed collection of IndexSchema elements.
Inheritance Hierarchy
SystemObject
ObservableListIndexSchema
NamedObjectCollectionIndexSchema
SchemaExplorerSchemaObjectCollection IndexSchema
SchemaExplorerIndexSchemaCollection

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
public class IndexSchemaCollection : SchemaObjectCollection<IndexSchema>
<SerializableAttribute>
Public Class IndexSchemaCollection
    Inherits SchemaObjectCollection(Of IndexSchema)

The IndexSchemaCollection type exposes the following members.

Constructors
 | Name | Description
Public method | IndexSchemaCollection | Initializes a new instance of the IndexSchemaCollection class.
Public method | IndexSchemaCollection(IEnumerableIndexSchema) | Initializes a new instance of the IndexSchemaCollection class.
Public method | IndexSchemaCollection(Int32) | Initializes a new instance of the IndexSchemaCollection class.
Top
Methods
 | Name | Description
Public method | Clone | (Inherited from SchemaObjectCollectionT.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh | (Inherited from SchemaObjectCollectionT.)
Public method | ToString | (Inherited from SchemaObjectCollectionT.)
Top
Remarks
IndexSchemaCollection provides an SchemaObjectCollectionT that is strongly typed for IndexSchema elements.
See Also

Reference

SchemaExplorer Namespace


IndexSchemaCollection Constructor

Overload List
 | Name | Description
Public method | IndexSchemaCollection | Initializes a new instance of the IndexSchemaCollection class.
Public method | IndexSchemaCollection(IEnumerableIndexSchema) | Initializes a new instance of the IndexSchemaCollection class.
Public method | IndexSchemaCollection(Int32) | Initializes a new instance of the IndexSchemaCollection class.
Top
See Also

Reference

IndexSchemaCollection Class
SchemaExplorer Namespace


IndexSchemaCollection Constructor

Initializes a new instance of the IndexSchemaCollection class.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public IndexSchemaCollection()
Public Sub New
See Also

Reference

IndexSchemaCollection Class
IndexSchemaCollection Overload
SchemaExplorer Namespace


IndexSchemaCollection Constructor (IEnumerable(IndexSchema))

IndexSchemaCollection Constructor (IEnumerableIndexSchema)

Initializes a new instance of the IndexSchemaCollection class.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public IndexSchemaCollection(
    IEnumerable<IndexSchema> collection
)
Public Sub New (
    collection As IEnumerable(Of IndexSchema)
)

Parameters

collection
Type: System.Collections.GenericIEnumerable IndexSchema
The collection from which the elements are copied.
See Also

Reference

IndexSchemaCollection Class
IndexSchemaCollection Overload
SchemaExplorer Namespace


IndexSchemaCollection Constructor (Int32)

Initializes a new instance of the IndexSchemaCollection class.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public IndexSchemaCollection(
    int capacity
)
Public Sub New (
    capacity As Integer
)

Parameters

capacity
Type: SystemInt32
The number of elements that the new list can initially store.
See Also

Reference

IndexSchemaCollection Class
IndexSchemaCollection Overload
SchemaExplorer Namespace


IndexSchemaCollection Methods

The IndexSchemaCollection type exposes the following members.

Methods
 | Name | Description
Public method | Clone | (Inherited from SchemaObjectCollectionT.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh | (Inherited from SchemaObjectCollectionT.)
Public method | ToString | (Inherited from SchemaObjectCollectionT.)
Top
See Also

Reference

IndexSchemaCollection Class
SchemaExplorer Namespace


IParameterSchema Interface

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public interface IParameterSchema : IDataObject,
    ISchemaObject
Public Interface IParameterSchema
    Inherits IDataObject, ISchemaObject

The IParameterSchema type exposes the following members.

Properties
 | Name | Description
Public property | AllowDBNull | Whether or not the data object allows null values. (Inherited from IDataObject.)
Public property | Command | The command that contains this parameter.
Public property | Database | Allows access to the DatabaseSchema object that contains this schema object. (Inherited from ISchemaObject.)
Public property | DataType | The data type of a (column) parameter is specific to the .NET Framework data provider. Specifying the type converts the value of the Parameter to the data provider Type before passing the value to the data source. seealso: http://msdn.microsoft.com/en-us/library/system.data.dbtype.aspx example: DbType.AnsiString (Inherited from IDataObject.)
Public property | DateCreated | Returns the date this table was created. (Inherited from ISchemaObject.)
Public property | DeepLoad | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from ISchemaObject.)
Public property | DefaultExtendedProperties | (Inherited from ISchemaObject.)
Public property | Description | The description of the object. (Inherited from ISchemaObject.)
Public property | Direction | The parameter direction.
Public property | ExtendedProperties | Used to store any additional information about the schema object. (Inherited from ISchemaObject.)
Public property | FullName | Returns the owner and name of the table. (Inherited from ISchemaObject.)
Public property | IncludeFunctions | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from ISchemaObject.)
Public property | NativeType | This is the native data type from the database. example: nvarchar (Inherited from IDataObject.)
Public property | Parent | The Parent Schema Object. (Inherited from IDataObject.)
Public property | Precision | The precision of the data object. (Inherited from IDataObject.)
Public property | Scale | The scale of the data object. (Inherited from IDataObject.)
Public property | Size | The size of the data object. (Inherited from IDataObject.)
Public property | SortName | Gets the name used to sort in 'Table (Owner)' format. (Inherited from ISchemaObject.)
Public property | SystemType | The System Type that is resolved from DataType. example: typeof(System.String) (Inherited from IDataObject.)
Top
Methods
 | Name | Description
Public method | Refresh | Allows the object to be refreshed. (Inherited from ISchemaObject.)
Top
See Also

Reference

SchemaExplorer Namespace


IParameterSchema Properties

The IParameterSchema type exposes the following members.

Properties
 | Name | Description
Public property | AllowDBNull | Whether or not the data object allows null values. (Inherited from IDataObject.)
Public property | Command | The command that contains this parameter.
Public property | Database | Allows access to the DatabaseSchema object that contains this schema object. (Inherited from ISchemaObject.)
Public property | DataType | The data type of a (column) parameter is specific to the .NET Framework data provider. Specifying the type converts the value of the Parameter to the data provider Type before passing the value to the data source. seealso: http://msdn.microsoft.com/en-us/library/system.data.dbtype.aspx example: DbType.AnsiString (Inherited from IDataObject.)
Public property | DateCreated | Returns the date this table was created. (Inherited from ISchemaObject.)
Public property | DeepLoad | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from ISchemaObject.)
Public property | DefaultExtendedProperties | (Inherited from ISchemaObject.)
Public property | Description | The description of the object. (Inherited from ISchemaObject.)
Public property | Direction | The parameter direction.
Public property | ExtendedProperties | Used to store any additional information about the schema object. (Inherited from ISchemaObject.)
Public property | FullName | Returns the owner and name of the table. (Inherited from ISchemaObject.)
Public property | IncludeFunctions | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from ISchemaObject.)
Public property | NativeType | This is the native data type from the database. example: nvarchar (Inherited from IDataObject.)
Public property | Parent | The Parent Schema Object. (Inherited from IDataObject.)
Public property | Precision | The precision of the data object. (Inherited from IDataObject.)
Public property | Scale | The scale of the data object. (Inherited from IDataObject.)
Public property | Size | The size of the data object. (Inherited from IDataObject.)
Public property | SortName | Gets the name used to sort in 'Table (Owner)' format. (Inherited from ISchemaObject.)
Public property | SystemType | The System Type that is resolved from DataType. example: typeof(System.String) (Inherited from IDataObject.)
Top
See Also

Reference

IParameterSchema Interface
SchemaExplorer Namespace


IParameterSchema.Command Property

IParameterSchemaCommand Property

The command that contains this parameter.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
ICommandSchema Command { get; }
ReadOnly Property Command As ICommandSchema
    Get

Property Value

Type: ICommandSchema
See Also

Reference

IParameterSchema Interface
SchemaExplorer Namespace


IParameterSchema.Direction Property

IParameterSchemaDirection Property

The parameter direction.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
ParameterDirection Direction { get; }
ReadOnly Property Direction As ParameterDirection
    Get

Property Value

Type: ParameterDirection
See Also

Reference

IParameterSchema Interface
SchemaExplorer Namespace


IParameterSchema Methods

The IParameterSchema type exposes the following members.

Methods
 | Name | Description
Public method | Refresh | Allows the object to be refreshed. (Inherited from ISchemaObject.)
Top
See Also

Reference

IParameterSchema Interface
SchemaExplorer Namespace


IPrimaryKeySchema Interface

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public interface IPrimaryKeySchema : ISchemaObject
Public Interface IPrimaryKeySchema
    Inherits ISchemaObject

The IPrimaryKeySchema type exposes the following members.

Properties
 | Name | Description
Public property | Database | Allows access to the DatabaseSchema object that contains this schema object. (Inherited from ISchemaObject.)
Public property | DateCreated | Returns the date this table was created. (Inherited from ISchemaObject.)
Public property | DeepLoad | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from ISchemaObject.)
Public property | DefaultExtendedProperties | (Inherited from ISchemaObject.)
Public property | Description | The description of the object. (Inherited from ISchemaObject.)
Public property | ExtendedProperties | Used to store any additional information about the schema object. (Inherited from ISchemaObject.)
Public property | FullName | Returns the owner and name of the table. (Inherited from ISchemaObject.)
Public property | IncludeFunctions | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from ISchemaObject.)
Public property | MemberColumns | The primary key's member columns.
Public property | SortName | Gets the name used to sort in 'Table (Owner)' format. (Inherited from ISchemaObject.)
Public property | Table | The table that contains this primary key.
Top
Methods
 | Name | Description
Public method | Refresh | Allows the object to be refreshed. (Inherited from ISchemaObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Selected | Determines if the specified item is selected using the rules defined in SchemaSelector. All tables and columns that are part of the key need to be selected for the key to be considered selected. (Defined by SchemaSelectorExtensions.)
Top
See Also

Reference

SchemaExplorer Namespace


IPrimaryKeySchema Properties

The IPrimaryKeySchema type exposes the following members.

Properties
 | Name | Description
Public property | Database | Allows access to the DatabaseSchema object that contains this schema object. (Inherited from ISchemaObject.)
Public property | DateCreated | Returns the date this table was created. (Inherited from ISchemaObject.)
Public property | DeepLoad | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from ISchemaObject.)
Public property | DefaultExtendedProperties | (Inherited from ISchemaObject.)
Public property | Description | The description of the object. (Inherited from ISchemaObject.)
Public property | ExtendedProperties | Used to store any additional information about the schema object. (Inherited from ISchemaObject.)
Public property | FullName | Returns the owner and name of the table. (Inherited from ISchemaObject.)
Public property | IncludeFunctions | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from ISchemaObject.)
Public property | MemberColumns | The primary key's member columns.
Public property | SortName | Gets the name used to sort in 'Table (Owner)' format. (Inherited from ISchemaObject.)
Public property | Table | The table that contains this primary key.
Top
See Also

Reference

IPrimaryKeySchema Interface
SchemaExplorer Namespace


IPrimaryKeySchema.MemberColumns Property

IPrimaryKeySchemaMemberColumns Property

The primary key's member columns.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
IReadOnlyNamedObjectCollection<IMemberColumnSchema> MemberColumns { get; }
ReadOnly Property MemberColumns As IReadOnlyNamedObjectCollection(Of IMemberColumnSchema)
    Get

Property Value

Type: IReadOnlyNamedObjectCollectionIMemberColumnSchema
See Also

Reference

IPrimaryKeySchema Interface
SchemaExplorer Namespace


IPrimaryKeySchema.Table Property

IPrimaryKeySchemaTable Property

The table that contains this primary key.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
ITableSchema Table { get; }
ReadOnly Property Table As ITableSchema
    Get

Property Value

Type: ITableSchema
See Also

Reference

IPrimaryKeySchema Interface
SchemaExplorer Namespace


IPrimaryKeySchema Methods

The IPrimaryKeySchema type exposes the following members.

Methods
 | Name | Description
Public method | Refresh | Allows the object to be refreshed. (Inherited from ISchemaObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Selected | Determines if the specified item is selected using the rules defined in SchemaSelector. All tables and columns that are part of the key need to be selected for the key to be considered selected. (Defined by SchemaSelectorExtensions.)
Top
See Also

Reference

IPrimaryKeySchema Interface
SchemaExplorer Namespace


IReadOnlySchemaObjectCollection(T) Interface

IReadOnlySchemaObjectCollectionT Interface

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public interface IReadOnlySchemaObjectCollection<out T> : IEnumerable<T>,
    IEnumerable
where T : ISchemaObject

Public Interface IReadOnlySchemaObjectCollection(Of Out T As ISchemaObject)
    Inherits IEnumerable(Of T), IEnumerable

Type Parameters

T

The IReadOnlySchemaObjectCollectionT type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable T.)
Public method | Refresh | Refreshes the schema object.
Top
Extension Methods
 | Name | Description
Public Extension Method | AsIndexedEnumerableT | Returns an IndexedEnumerable from any collection implementing IEnumerable<T> (Defined by IndexedEnumerable.)
Top
See Also

Reference

SchemaExplorer Namespace


IReadOnlySchemaObjectCollection(T) Methods

IReadOnlySchemaObjectCollectionT Methods

The IReadOnlySchemaObjectCollectionT generic type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable T .)
Public method | Refresh | Refreshes the schema object.
Top
Extension Methods
 | Name | Description
Public Extension Method | AsIndexedEnumerableT | Returns an IndexedEnumerable from any collection implementing IEnumerable<T> (Defined by IndexedEnumerable.)
Top
See Also

Reference

IReadOnlySchemaObjectCollectionT Interface
SchemaExplorer Namespace


IReadOnlySchemaObjectCollection(T).Refresh Method

IReadOnlySchemaObjectCollectionTRefresh Method

Refreshes the schema object.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
void Refresh()
Sub Refresh
See Also

Reference

IReadOnlySchemaObjectCollectionT Interface
SchemaExplorer Namespace


IReadOnlySchemaObjectWithOwnerCollection(T) Interface

IReadOnlySchemaObjectWithOwnerCollectionT Interface

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public interface IReadOnlySchemaObjectWithOwnerCollection<out T> : IReadOnlySchemaObjectCollection<T>,
    IEnumerable<T>, IEnumerable
where T : ISchemaObjectWithOwner

Public Interface IReadOnlySchemaObjectWithOwnerCollection(Of Out T As ISchemaObjectWithOwner)
    Inherits IReadOnlySchemaObjectCollection(Of T), IEnumerable(Of T), IEnumerable

Type Parameters

T

The IReadOnlySchemaObjectWithOwnerCollectionT type exposes the following members.

Properties
 | Name | Description
Public property | Item | Gets the TableSchema with the specified owner and name.
Top
Methods
 | Name | Description
Public method | Contains | Determines whether an element is in the collection with the specified owner and name.
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable T.)
Public method | IndexOf | Determines the index of an item with the specified owner and name.
Public method | Refresh | Refreshes the schema object. (Inherited from IReadOnlySchemaObjectCollectionT.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AsIndexedEnumerableT | Returns an IndexedEnumerable from any collection implementing IEnumerable<T> (Defined by IndexedEnumerable.)
Top
See Also

Reference

SchemaExplorer Namespace


IReadOnlySchemaObjectWithOwnerCollection(T) Properties

IReadOnlySchemaObjectWithOwnerCollectionT Properties

The IReadOnlySchemaObjectWithOwnerCollectionT generic type exposes the following members.

Properties
 | Name | Description
Public property | Item | Gets the TableSchema with the specified owner and name.
Top
See Also

Reference

IReadOnlySchemaObjectWithOwnerCollectionT Interface
SchemaExplorer Namespace


IReadOnlySchemaObjectWithOwnerCollection(T).Item Property

IReadOnlySchemaObjectWithOwnerCollectionTItem Property

Gets the TableSchema with the specified owner and name.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
T this[
    string owner,
    string name
] { get; }
ReadOnly Default Property Item (
    owner As String,
    name As String
) As T
    Get

Parameters

owner
Type: SystemString
name
Type: SystemString

Return Value

Type: T
The TableSchema with the specified owner and name.
See Also

Reference

IReadOnlySchemaObjectWithOwnerCollectionT Interface
SchemaExplorer Namespace


IReadOnlySchemaObjectWithOwnerCollection(T) Methods

IReadOnlySchemaObjectWithOwnerCollectionT Methods

The IReadOnlySchemaObjectWithOwnerCollectionT generic type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Determines whether an element is in the collection with the specified owner and name.
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable T .)
Public method | IndexOf | Determines the index of an item with the specified owner and name.
Public method | Refresh | Refreshes the schema object. (Inherited from IReadOnlySchemaObjectCollectionT.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AsIndexedEnumerableT | Returns an IndexedEnumerable from any collection implementing IEnumerable<T> (Defined by IndexedEnumerable.)
Top
See Also

Reference

IReadOnlySchemaObjectWithOwnerCollectionT Interface
SchemaExplorer Namespace


IReadOnlySchemaObjectWithOwnerCollection(T).Contains Method

IReadOnlySchemaObjectWithOwnerCollectionTContains Method

Determines whether an element is in the collection with the specified owner and name.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
bool Contains(
    string owner,
    string name
)
Function Contains (
    owner As String,
    name As String
) As Boolean

Parameters

owner
Type: SystemString
The owner of the item to locate in the collection.
name
Type: SystemString
The name of the item to locate in the collection.

Return Value

Type: Boolean
true if item is found in the collection; otherwise, false.
See Also

Reference

IReadOnlySchemaObjectWithOwnerCollectionT Interface
SchemaExplorer Namespace


IReadOnlySchemaObjectWithOwnerCollection(T).IndexOf Method

IReadOnlySchemaObjectWithOwnerCollectionTIndexOf Method

Determines the index of an item with the specified owner and name.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
int IndexOf(
    string owner,
    string name
)
Function IndexOf (
    owner As String,
    name As String
) As Integer

Parameters

owner
Type: SystemString
The owner of the item to locate in the collection.
name
Type: SystemString
The name of the item to locate in the collection.

Return Value

Type: Int32
The index of item if found in the list; otherwise, -1.
See Also

Reference

IReadOnlySchemaObjectWithOwnerCollectionT Interface
SchemaExplorer Namespace


ISchemaObject Interface

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public interface ISchemaObject
Public Interface ISchemaObject

The ISchemaObject type exposes the following members.

Properties
 | Name | Description
Public property | Database | Allows access to the DatabaseSchema object that contains this schema object.
Public property | DateCreated | Returns the date this table was created.
Public property | DeepLoad | Gets or sets a value indicating this schema object and all its children will be loaded.
Public property | DefaultExtendedProperties |
Public property | Description | The description of the object.
Public property | ExtendedProperties | Used to store any additional information about the schema object.
Public property | FullName | Returns the owner and name of the table.
Public property | IncludeFunctions | Gets or sets a value indicating this schema object and all its children will be loaded.
Public property | SortName | Gets the name used to sort in 'Table (Owner)' format.
Top
Methods
 | Name | Description
Public method | Refresh | Allows the object to be refreshed.
Top
See Also

Reference

SchemaExplorer Namespace


ISchemaObject Properties

The ISchemaObject type exposes the following members.

Properties
 | Name | Description
Public property | Database | Allows access to the DatabaseSchema object that contains this schema object.
Public property | DateCreated | Returns the date this table was created.
Public property | DeepLoad | Gets or sets a value indicating this schema object and all its children will be loaded.
Public property | DefaultExtendedProperties |
Public property | Description | The description of the object.
Public property | ExtendedProperties | Used to store any additional information about the schema object.
Public property | FullName | Returns the owner and name of the table.
Public property | IncludeFunctions | Gets or sets a value indicating this schema object and all its children will be loaded.
Public property | SortName | Gets the name used to sort in 'Table (Owner)' format.
Top
See Also

Reference

ISchemaObject Interface
SchemaExplorer Namespace


ISchemaObject.Database Property

ISchemaObjectDatabase Property

Allows access to the DatabaseSchema object that contains this schema object.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
IDatabaseSchema Database { get; }
ReadOnly Property Database As IDatabaseSchema
    Get

Property Value

Type: IDatabaseSchema
See Also

Reference

ISchemaObject Interface
SchemaExplorer Namespace


ISchemaObject.DateCreated Property

ISchemaObjectDateCreated Property

Returns the date this table was created.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
DateTime DateCreated { get; }
ReadOnly Property DateCreated As DateTime
    Get

Property Value

Type: DateTime
See Also

Reference

ISchemaObject Interface
SchemaExplorer Namespace


ISchemaObject.DeepLoad Property

ISchemaObjectDeepLoad Property

Gets or sets a value indicating this schema object and all its children will be loaded.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
bool DeepLoad { get; set; }
Property DeepLoad As Boolean
    Get
    Set

Property Value

Type: Boolean
true if deep load; otherwise, false.
See Also

Reference

ISchemaObject Interface
SchemaExplorer Namespace


ISchemaObject.DefaultExtendedProperties Property

ISchemaObjectDefaultExtendedProperties Property

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
IExtendedProperty[] DefaultExtendedProperties { get; }
ReadOnly Property DefaultExtendedProperties As IExtendedProperty()
    Get

Property Value

Type: IExtendedProperty
See Also

Reference

ISchemaObject Interface
SchemaExplorer Namespace


ISchemaObject.Description Property

ISchemaObjectDescription Property

The description of the object.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
string Description { get; set; }
Property Description As String
    Get
    Set

Property Value

Type: String
See Also

Reference

ISchemaObject Interface
SchemaExplorer Namespace


ISchemaObject.ExtendedProperties Property

ISchemaObjectExtendedProperties Property

Used to store any additional information about the schema object.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
INamedObjectCollection<IExtendedProperty> ExtendedProperties { get; }
ReadOnly Property ExtendedProperties As INamedObjectCollection(Of IExtendedProperty)
    Get

Property Value

Type: INamedObjectCollectionIExtendedProperty
See Also

Reference

ISchemaObject Interface
SchemaExplorer Namespace


ISchemaObject.FullName Property

ISchemaObjectFullName Property

Returns the owner and name of the table.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
string FullName { get; }
ReadOnly Property FullName As String
    Get

Return Value

Type: String
See Also

Reference

ISchemaObject Interface
SchemaExplorer Namespace


ISchemaObject.IncludeFunctions Property

ISchemaObjectIncludeFunctions Property

Gets or sets a value indicating this schema object and all its children will be loaded.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
bool IncludeFunctions { get; set; }
Property IncludeFunctions As Boolean
    Get
    Set

Property Value

Type: Boolean
true if functions should be included; otherwise, false.
See Also

Reference

ISchemaObject Interface
SchemaExplorer Namespace


ISchemaObject.SortName Property

ISchemaObjectSortName Property

Gets the name used to sort in 'Table (Owner)' format.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
string SortName { get; }
ReadOnly Property SortName As String
    Get

Property Value

Type: String
The name used to sort.
See Also

Reference

ISchemaObject Interface
SchemaExplorer Namespace


ISchemaObject Methods

The ISchemaObject type exposes the following members.

Methods
 | Name | Description
Public method | Refresh | Allows the object to be refreshed.
Top
See Also

Reference

ISchemaObject Interface
SchemaExplorer Namespace


ISchemaObject.Refresh Method

ISchemaObjectRefresh Method

Allows the object to be refreshed.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
void Refresh()
Sub Refresh
See Also

Reference

ISchemaObject Interface
SchemaExplorer Namespace


ISchemaObjectCollection(T) Interface

ISchemaObjectCollectionT Interface

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public interface ISchemaObjectCollection<T> : IList<T>,
    ICollection<T>, IEnumerable<T>, IEnumerable, INotifyCollectionChanged, INotifyPropertyChanged
where T : ISchemaObject

Public Interface ISchemaObjectCollection(Of T As ISchemaObject)
    Inherits IList(Of T), ICollection(Of T), IEnumerable(Of T),
    IEnumerable, INotifyCollectionChanged, INotifyPropertyChanged

Type Parameters

T

The ISchemaObjectCollectionT type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollection T.)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollection T.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IList T.)
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollection T.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollection T.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection T.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection T.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable T.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IList T.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IList T.)
Public method | Refresh | Refreshes the schema object.
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection T.)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IList T.)
Top
Events
 | Name | Description
Public event | CollectionChanged | Occurs when the collection changes. (Inherited from INotifyCollectionChanged.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AsIndexedEnumerableT | Returns an IndexedEnumerable from any collection implementing IEnumerable<T> (Defined by IndexedEnumerable.)
Top
See Also

Reference

SchemaExplorer Namespace


ISchemaObjectCollection(T) Properties

ISchemaObjectCollectionT Properties

The ISchemaObjectCollectionT generic type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollection T .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollection T .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IList T .)
Top
See Also

Reference

ISchemaObjectCollectionT Interface
SchemaExplorer Namespace


ISchemaObjectCollection(T) Methods

ISchemaObjectCollectionT Methods

The ISchemaObjectCollectionT generic type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollection T .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollection T .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection T .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection T .)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable T .)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IList T .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IList T .)
Public method | Refresh | Refreshes the schema object.
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection T .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IList T .)
Top
Extension Methods
 | Name | Description
Public Extension Method | AsIndexedEnumerableT | Returns an IndexedEnumerable from any collection implementing IEnumerable<T> (Defined by IndexedEnumerable.)
Top
See Also

Reference

ISchemaObjectCollectionT Interface
SchemaExplorer Namespace


ISchemaObjectCollection(T).Refresh Method

ISchemaObjectCollectionTRefresh Method

Refreshes the schema object.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
void Refresh()
Sub Refresh
See Also

Reference

ISchemaObjectCollectionT Interface
SchemaExplorer Namespace


ISchemaObjectCollection(T) Events

ISchemaObjectCollectionT Events

The ISchemaObjectCollectionT generic type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Occurs when the collection changes. (Inherited from INotifyCollectionChanged.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

ISchemaObjectCollectionT Interface
SchemaExplorer Namespace


ISchemaObjectWithOwner Interface

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public interface ISchemaObjectWithOwner : ISchemaObject
Public Interface ISchemaObjectWithOwner
    Inherits ISchemaObject

The ISchemaObjectWithOwner type exposes the following members.

Properties
 | Name | Description
Public property | Database | Allows access to the DatabaseSchema object that contains this schema object. (Inherited from ISchemaObject.)
Public property | DateCreated | Returns the date this table was created. (Inherited from ISchemaObject.)
Public property | DeepLoad | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from ISchemaObject.)
Public property | DefaultExtendedProperties | (Inherited from ISchemaObject.)
Public property | Description | The description of the object. (Inherited from ISchemaObject.)
Public property | ExtendedProperties | Used to store any additional information about the schema object. (Inherited from ISchemaObject.)
Public property | FullName | Returns the owner and name of the table. (Inherited from ISchemaObject.)
Public property | IncludeFunctions | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from ISchemaObject.)
Public property | Owner | Returns the owner of the table.
Public property | SortName | Gets the name used to sort in 'Table (Owner)' format. (Inherited from ISchemaObject.)
Top
Methods
 | Name | Description
Public method | Refresh | Allows the object to be refreshed. (Inherited from ISchemaObject.)
Top
See Also

Reference

SchemaExplorer Namespace


ISchemaObjectWithOwner Properties

The ISchemaObjectWithOwner type exposes the following members.

Properties
 | Name | Description
Public property | Database | Allows access to the DatabaseSchema object that contains this schema object. (Inherited from ISchemaObject.)
Public property | DateCreated | Returns the date this table was created. (Inherited from ISchemaObject.)
Public property | DeepLoad | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from ISchemaObject.)
Public property | DefaultExtendedProperties | (Inherited from ISchemaObject.)
Public property | Description | The description of the object. (Inherited from ISchemaObject.)
Public property | ExtendedProperties | Used to store any additional information about the schema object. (Inherited from ISchemaObject.)
Public property | FullName | Returns the owner and name of the table. (Inherited from ISchemaObject.)
Public property | IncludeFunctions | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from ISchemaObject.)
Public property | Owner | Returns the owner of the table.
Public property | SortName | Gets the name used to sort in 'Table (Owner)' format. (Inherited from ISchemaObject.)
Top
See Also

Reference

ISchemaObjectWithOwner Interface
SchemaExplorer Namespace


ISchemaObjectWithOwner.Owner Property

ISchemaObjectWithOwnerOwner Property

Returns the owner of the table.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
string Owner { get; }
ReadOnly Property Owner As String
    Get

Return Value

Type: String
See Also

Reference

ISchemaObjectWithOwner Interface
SchemaExplorer Namespace


ISchemaObjectWithOwner Methods

The ISchemaObjectWithOwner type exposes the following members.

Methods
 | Name | Description
Public method | Refresh | Allows the object to be refreshed. (Inherited from ISchemaObject.)
Top
See Also

Reference

ISchemaObjectWithOwner Interface
SchemaExplorer Namespace


ISchemaObjectWithOwnerCollection(T) Interface

ISchemaObjectWithOwnerCollectionT Interface

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public interface ISchemaObjectWithOwnerCollection<T> : ISchemaObjectCollection<T>,
    IList<T>, ICollection<T>, IEnumerable<T>, IEnumerable, INotifyCollectionChanged,
    INotifyPropertyChanged
where T : ISchemaObjectWithOwner

Public Interface ISchemaObjectWithOwnerCollection(Of T As ISchemaObjectWithOwner)
    Inherits ISchemaObjectCollection(Of T), IList(Of T), ICollection(Of T),
    IEnumerable(Of T), IEnumerable, INotifyCollectionChanged, INotifyPropertyChanged

Type Parameters

T

The ISchemaObjectWithOwnerCollectionT type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollection T.)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollection T.)
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from IList T.)
Public property | ItemString, String | Gets the TableSchema with the specified owner and name.
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollection T.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollection T.)
Public method | Contains(T) | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection T.)
Public method | Contains(String, String) | Determines whether an element is in the collection with the specified owner and name.
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection T.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable T.)
Public method | IndexOf(T) | Determines the index of a specific item in the IListT. (Inherited from IList T.)
Public method | IndexOf(String, String) | Determines the index of an item with the specified owner and name.
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IList T.)
Public method | Refresh | Refreshes the schema object. (Inherited from ISchemaObjectCollectionT.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection T.)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IList T.)
Top
Events
 | Name | Description
Public event | CollectionChanged | Occurs when the collection changes. (Inherited from INotifyCollectionChanged.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AsIndexedEnumerableT | Returns an IndexedEnumerable from any collection implementing IEnumerable<T> (Defined by IndexedEnumerable.)
Top
See Also

Reference

SchemaExplorer Namespace


ISchemaObjectWithOwnerCollection(T) Properties

ISchemaObjectWithOwnerCollectionT Properties

The ISchemaObjectWithOwnerCollectionT generic type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollection T .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollection T .)
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from IList T .)
Public property | ItemString, String | Gets the TableSchema with the specified owner and name.
Top
See Also

Reference

ISchemaObjectWithOwnerCollectionT Interface
SchemaExplorer Namespace


ISchemaObjectWithOwnerCollection(T).Item Property

ISchemaObjectWithOwnerCollectionTItem Property

Overload List
 | Name | Description
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from IList T .)
Public property | ItemString, String | Gets the TableSchema with the specified owner and name.
Top
See Also

Reference

ISchemaObjectWithOwnerCollectionT Interface
SchemaExplorer Namespace


ISchemaObjectWithOwnerCollection(T).Item Property (String, String)

ISchemaObjectWithOwnerCollectionTItem Property (String, String)

Gets the TableSchema with the specified owner and name.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
T this[
    string owner,
    string name
] { get; }
ReadOnly Default Property Item (
    owner As String,
    name As String
) As T
    Get

Parameters

owner
Type: SystemString
name
Type: SystemString

Return Value

Type: T
The TableSchema with the specified owner and name.
See Also

Reference

ISchemaObjectWithOwnerCollectionT Interface
Item Overload
SchemaExplorer Namespace


ISchemaObjectWithOwnerCollection(T) Methods

ISchemaObjectWithOwnerCollectionT Methods

The ISchemaObjectWithOwnerCollectionT generic type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollection T .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollection T .)
Public method | Contains(T) | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection T .)
Public method | Contains(String, String) | Determines whether an element is in the collection with the specified owner and name.
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection T .)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable T .)
Public method | IndexOf(T) | Determines the index of a specific item in the IListT. (Inherited from IList T .)
Public method | IndexOf(String, String) | Determines the index of an item with the specified owner and name.
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IList T .)
Public method | Refresh | Refreshes the schema object. (Inherited from ISchemaObjectCollectionT.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection T .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IList T .)
Top
Extension Methods
 | Name | Description
Public Extension Method | AsIndexedEnumerableT | Returns an IndexedEnumerable from any collection implementing IEnumerable<T> (Defined by IndexedEnumerable.)
Top
See Also

Reference

ISchemaObjectWithOwnerCollectionT Interface
SchemaExplorer Namespace


ISchemaObjectWithOwnerCollection(T).Contains Method

ISchemaObjectWithOwnerCollectionTContains Method

Overload List
 | Name | Description
Public method | Contains(T) | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection T .)
Public method | Contains(String, String) | Determines whether an element is in the collection with the specified owner and name.
Top
See Also

Reference

ISchemaObjectWithOwnerCollectionT Interface
SchemaExplorer Namespace


ISchemaObjectWithOwnerCollection(T).Contains Method (String, String)

ISchemaObjectWithOwnerCollectionTContains Method (String, String)

Determines whether an element is in the collection with the specified owner and name.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
bool Contains(
    string owner,
    string name
)
Function Contains (
    owner As String,
    name As String
) As Boolean

Parameters

owner
Type: SystemString
The owner of the item to locate in the collection.
name
Type: SystemString
The name of the item to locate in the collection.

Return Value

Type: Boolean
true if item is found in the collection; otherwise, false.
See Also

Reference

ISchemaObjectWithOwnerCollectionT Interface
Contains Overload
SchemaExplorer Namespace


ISchemaObjectWithOwnerCollection(T).IndexOf Method

ISchemaObjectWithOwnerCollectionTIndexOf Method

Overload List
 | Name | Description
Public method | IndexOf(T) | Determines the index of a specific item in the IListT. (Inherited from IList T .)
Public method | IndexOf(String, String) | Determines the index of an item with the specified owner and name.
Top
See Also

Reference

ISchemaObjectWithOwnerCollectionT Interface
SchemaExplorer Namespace


ISchemaObjectWithOwnerCollection(T).IndexOf Method (String, String)

ISchemaObjectWithOwnerCollectionTIndexOf Method (String, String)

Determines the index of an item with the specified owner and name.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
int IndexOf(
    string owner,
    string name
)
Function IndexOf (
    owner As String,
    name As String
) As Integer

Parameters

owner
Type: SystemString
The owner of the item to locate in the collection.
name
Type: SystemString
The name of the item to locate in the collection.

Return Value

Type: Int32
The index of item if found in the list; otherwise, -1.
See Also

Reference

ISchemaObjectWithOwnerCollectionT Interface
IndexOf Overload
SchemaExplorer Namespace


ISchemaObjectWithOwnerCollection(T) Events

ISchemaObjectWithOwnerCollectionT Events

The ISchemaObjectWithOwnerCollectionT generic type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Occurs when the collection changes. (Inherited from INotifyCollectionChanged.)
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)
Top
See Also

Reference

ISchemaObjectWithOwnerCollectionT Interface
SchemaExplorer Namespace


ITableKeySchema Interface

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public interface ITableKeySchema : ISchemaObject
Public Interface ITableKeySchema
    Inherits ISchemaObject

The ITableKeySchema type exposes the following members.

Properties
 | Name | Description
Public property | Database | Allows access to the DatabaseSchema object that contains this schema object. (Inherited from ISchemaObject.)
Public property | DateCreated | Returns the date this table was created. (Inherited from ISchemaObject.)
Public property | DeepLoad | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from ISchemaObject.)
Public property | DefaultExtendedProperties | (Inherited from ISchemaObject.)
Public property | Description | The description of the object. (Inherited from ISchemaObject.)
Public property | ExtendedProperties | Used to store any additional information about the schema object. (Inherited from ISchemaObject.)
Public property | ForeignKeyMemberColumns | The foreign key table columns that make up this key.
Public property | ForeignKeyTable | The foreign key table.
Public property | FullName | Returns the owner and name of the table. (Inherited from ISchemaObject.)
Public property | IncludeFunctions | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from ISchemaObject.)
Public property | PrimaryKey | The primary key for the table that this key refers to.
Public property | PrimaryKeyMemberColumns | The primary key table columns that make up this key.
Public property | PrimaryKeyTable | The primary key table.
Public property | SortName | Gets the name used to sort in 'Table (Owner)' format. (Inherited from ISchemaObject.)
Top
Methods
 | Name | Description
Public method | Refresh | Allows the object to be refreshed. (Inherited from ISchemaObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Selected | Determines if the specified item is selected using the rules defined in SchemaSelector. All tables and columns that are part of the key need to be selected for the key to be considered selected. (Defined by SchemaSelectorExtensions.)
Top
See Also

Reference

SchemaExplorer Namespace


ITableKeySchema Properties

The ITableKeySchema type exposes the following members.

Properties
 | Name | Description
Public property | Database | Allows access to the DatabaseSchema object that contains this schema object. (Inherited from ISchemaObject.)
Public property | DateCreated | Returns the date this table was created. (Inherited from ISchemaObject.)
Public property | DeepLoad | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from ISchemaObject.)
Public property | DefaultExtendedProperties | (Inherited from ISchemaObject.)
Public property | Description | The description of the object. (Inherited from ISchemaObject.)
Public property | ExtendedProperties | Used to store any additional information about the schema object. (Inherited from ISchemaObject.)
Public property | ForeignKeyMemberColumns | The foreign key table columns that make up this key.
Public property | ForeignKeyTable | The foreign key table.
Public property | FullName | Returns the owner and name of the table. (Inherited from ISchemaObject.)
Public property | IncludeFunctions | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from ISchemaObject.)
Public property | PrimaryKey | The primary key for the table that this key refers to.
Public property | PrimaryKeyMemberColumns | The primary key table columns that make up this key.
Public property | PrimaryKeyTable | The primary key table.
Public property | SortName | Gets the name used to sort in 'Table (Owner)' format. (Inherited from ISchemaObject.)
Top
See Also

Reference

ITableKeySchema Interface
SchemaExplorer Namespace


ITableKeySchema.ForeignKeyMemberColumns Property

ITableKeySchemaForeignKeyMemberColumns Property

The foreign key table columns that make up this key.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
IReadOnlyNamedObjectCollection<IMemberColumnSchema> ForeignKeyMemberColumns { get; }
ReadOnly Property ForeignKeyMemberColumns As IReadOnlyNamedObjectCollection(Of IMemberColumnSchema)
    Get

Property Value

Type: IReadOnlyNamedObjectCollectionIMemberColumnSchema
See Also

Reference

ITableKeySchema Interface
SchemaExplorer Namespace


ITableKeySchema.ForeignKeyTable Property

ITableKeySchemaForeignKeyTable Property

The foreign key table.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
ITableSchema ForeignKeyTable { get; }
ReadOnly Property ForeignKeyTable As ITableSchema
    Get

Property Value

Type: ITableSchema
See Also

Reference

ITableKeySchema Interface
SchemaExplorer Namespace


ITableKeySchema.PrimaryKey Property

ITableKeySchemaPrimaryKey Property

The primary key for the table that this key refers to.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
IPrimaryKeySchema PrimaryKey { get; }
ReadOnly Property PrimaryKey As IPrimaryKeySchema
    Get

Property Value

Type: IPrimaryKeySchema
See Also

Reference

ITableKeySchema Interface
SchemaExplorer Namespace


ITableKeySchema.PrimaryKeyMemberColumns Property

ITableKeySchemaPrimaryKeyMemberColumns Property

The primary key table columns that make up this key.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
IReadOnlyNamedObjectCollection<IMemberColumnSchema> PrimaryKeyMemberColumns { get; }
ReadOnly Property PrimaryKeyMemberColumns As IReadOnlyNamedObjectCollection(Of IMemberColumnSchema)
    Get

Property Value

Type: IReadOnlyNamedObjectCollectionIMemberColumnSchema
See Also

Reference

ITableKeySchema Interface
SchemaExplorer Namespace


ITableKeySchema.PrimaryKeyTable Property

ITableKeySchemaPrimaryKeyTable Property

The primary key table.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
ITableSchema PrimaryKeyTable { get; }
ReadOnly Property PrimaryKeyTable As ITableSchema
    Get

Property Value

Type: ITableSchema
See Also

Reference

ITableKeySchema Interface
SchemaExplorer Namespace


ITableKeySchema Methods

The ITableKeySchema type exposes the following members.

Methods
 | Name | Description
Public method | Refresh | Allows the object to be refreshed. (Inherited from ISchemaObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Selected | Determines if the specified item is selected using the rules defined in SchemaSelector. All tables and columns that are part of the key need to be selected for the key to be considered selected. (Defined by SchemaSelectorExtensions.)
Top
See Also

Reference

ITableKeySchema Interface
SchemaExplorer Namespace


ITableSchema Interface

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public interface ITableSchema : ITabularObject,
    ISchemaObjectWithOwner, ISchemaObject
Public Interface ITableSchema
    Inherits ITabularObject, ISchemaObjectWithOwner, ISchemaObject

The ITableSchema type exposes the following members.

Properties
 | Name | Description
Public property | Columns | Provides information about the table columns.
Public property | Database | Allows access to the DatabaseSchema object that contains this schema object. (Inherited from ISchemaObject.)
Public property | DataObjects | Provides information about the schema objects columns. (Inherited from ITabularObject.)
Public property | DateCreated | Returns the date this table was created. (Inherited from ISchemaObject.)
Public property | DeepLoad | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from ISchemaObject.)
Public property | DefaultExtendedProperties | (Inherited from ISchemaObject.)
Public property | Description | The description of the object. (Inherited from ISchemaObject.)
Public property | ExtendedProperties | Used to store any additional information about the schema object. (Inherited from ISchemaObject.)
Public property | ForeignKeyColumns | Provides information about all columns who are members of a foreign key.
Public property | ForeignKeys | Provides information about the foreign keys (keys where the current table is the foreign table) contained in the table.
Public property | FullName | Returns the owner and name of the table. (Inherited from ISchemaObject.)
Public property | HasPrimaryKey | Provides information about the primary key of the table.
Public property | IncludeFunctions | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from ISchemaObject.)
Public property | Indexes | Provides information about the indexes contained in the table.
Public property | Item | Index to allow easy access to the columns in this schema object. (Inherited from ITabularObject.)
Public property | Keys | Provides information about the keys contained in the table.
Public property | NonForeignKeyColumns | Provides information about all columns who are not members of a foreign key.
Public property | NonKeyColumns | Provides information about all non-key columns.
Public property | NonPrimaryKeyColumns | Provides information about all non-primary key table columns.
Public property | Owner | Returns the owner of the table. (Inherited from ISchemaObjectWithOwner.)
Public property | PrimaryKey | Provides information about the primary key of the table.
Public property | PrimaryKeys | Provides information about the primary keys (keys where the current table is the primary table) contained in the table.
Public property | SortName | Gets the name used to sort in 'Table (Owner)' format. (Inherited from ISchemaObject.)
Top
Methods
 | Name | Description
Public method | GetData | Gets the data contained within the schema object. (Inherited from ITabularObject.)
Public method | GetTableData | Gets the data contained within the table.
Public method | Refresh | Allows the object to be refreshed. (Inherited from ISchemaObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Selected | Determines if the specified item is selected using the rules defined in SchemaSelector. (Defined by SchemaSelectorExtensions.)
Top
See Also

Reference

SchemaExplorer Namespace


ITableSchema Properties

The ITableSchema type exposes the following members.

Properties
 | Name | Description
Public property | Columns | Provides information about the table columns.
Public property | Database | Allows access to the DatabaseSchema object that contains this schema object. (Inherited from ISchemaObject.)
Public property | DataObjects | Provides information about the schema objects columns. (Inherited from ITabularObject.)
Public property | DateCreated | Returns the date this table was created. (Inherited from ISchemaObject.)
Public property | DeepLoad | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from ISchemaObject.)
Public property | DefaultExtendedProperties | (Inherited from ISchemaObject.)
Public property | Description | The description of the object. (Inherited from ISchemaObject.)
Public property | ExtendedProperties | Used to store any additional information about the schema object. (Inherited from ISchemaObject.)
Public property | ForeignKeyColumns | Provides information about all columns who are members of a foreign key.
Public property | ForeignKeys | Provides information about the foreign keys (keys where the current table is the foreign table) contained in the table.
Public property | FullName | Returns the owner and name of the table. (Inherited from ISchemaObject.)
Public property | HasPrimaryKey | Provides information about the primary key of the table.
Public property | IncludeFunctions | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from ISchemaObject.)
Public property | Indexes | Provides information about the indexes contained in the table.
Public property | Item | Index to allow easy access to the columns in this schema object. (Inherited from ITabularObject.)
Public property | Keys | Provides information about the keys contained in the table.
Public property | NonForeignKeyColumns | Provides information about all columns who are not members of a foreign key.
Public property | NonKeyColumns | Provides information about all non-key columns.
Public property | NonPrimaryKeyColumns | Provides information about all non-primary key table columns.
Public property | Owner | Returns the owner of the table. (Inherited from ISchemaObjectWithOwner.)
Public property | PrimaryKey | Provides information about the primary key of the table.
Public property | PrimaryKeys | Provides information about the primary keys (keys where the current table is the primary table) contained in the table.
Public property | SortName | Gets the name used to sort in 'Table (Owner)' format. (Inherited from ISchemaObject.)
Top
See Also

Reference

ITableSchema Interface
SchemaExplorer Namespace


ITableSchema.Columns Property

ITableSchemaColumns Property

Provides information about the table columns.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
IReadOnlyNamedObjectCollection<IColumnSchema> Columns { get; }
ReadOnly Property Columns As IReadOnlyNamedObjectCollection(Of IColumnSchema)
    Get

Property Value

Type: IReadOnlyNamedObjectCollectionIColumnSchema
See Also

Reference

ITableSchema Interface
SchemaExplorer Namespace


ITableSchema.ForeignKeyColumns Property

ITableSchemaForeignKeyColumns Property

Provides information about all columns who are members of a foreign key.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
IReadOnlyNamedObjectCollection<IColumnSchema> ForeignKeyColumns { get; }
ReadOnly Property ForeignKeyColumns As IReadOnlyNamedObjectCollection(Of IColumnSchema)
    Get

Property Value

Type: IReadOnlyNamedObjectCollectionIColumnSchema
See Also

Reference

ITableSchema Interface
SchemaExplorer Namespace


ITableSchema.ForeignKeys Property

ITableSchemaForeignKeys Property

Provides information about the foreign keys (keys where the current table is the foreign table) contained in the table.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
IReadOnlyNamedObjectCollection<ITableKeySchema> ForeignKeys { get; }
ReadOnly Property ForeignKeys As IReadOnlyNamedObjectCollection(Of ITableKeySchema)
    Get

Property Value

Type: IReadOnlyNamedObjectCollectionITableKeySchema
See Also

Reference

ITableSchema Interface
SchemaExplorer Namespace


ITableSchema.HasPrimaryKey Property

ITableSchemaHasPrimaryKey Property

Provides information about the primary key of the table.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
bool HasPrimaryKey { get; }
ReadOnly Property HasPrimaryKey As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

ITableSchema Interface
SchemaExplorer Namespace


ITableSchema.Indexes Property

ITableSchemaIndexes Property

Provides information about the indexes contained in the table.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
IReadOnlyNamedObjectCollection<IIndexSchema> Indexes { get; }
ReadOnly Property Indexes As IReadOnlyNamedObjectCollection(Of IIndexSchema)
    Get

Property Value

Type: IReadOnlyNamedObjectCollectionIIndexSchema
See Also

Reference

ITableSchema Interface
SchemaExplorer Namespace


ITableSchema.Keys Property

ITableSchemaKeys Property

Provides information about the keys contained in the table.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
IReadOnlyNamedObjectCollection<ITableKeySchema> Keys { get; }
ReadOnly Property Keys As IReadOnlyNamedObjectCollection(Of ITableKeySchema)
    Get

Property Value

Type: IReadOnlyNamedObjectCollectionITableKeySchema
See Also

Reference

ITableSchema Interface
SchemaExplorer Namespace


ITableSchema.NonForeignKeyColumns Property

ITableSchemaNonForeignKeyColumns Property

Provides information about all columns who are not members of a foreign key.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
IReadOnlyNamedObjectCollection<IColumnSchema> NonForeignKeyColumns { get; }
ReadOnly Property NonForeignKeyColumns As IReadOnlyNamedObjectCollection(Of IColumnSchema)
    Get

Property Value

Type: IReadOnlyNamedObjectCollectionIColumnSchema
See Also

Reference

ITableSchema Interface
SchemaExplorer Namespace


ITableSchema.NonKeyColumns Property

ITableSchemaNonKeyColumns Property

Provides information about all non-key columns.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
IReadOnlyNamedObjectCollection<IColumnSchema> NonKeyColumns { get; }
ReadOnly Property NonKeyColumns As IReadOnlyNamedObjectCollection(Of IColumnSchema)
    Get

Property Value

Type: IReadOnlyNamedObjectCollectionIColumnSchema
See Also

Reference

ITableSchema Interface
SchemaExplorer Namespace


ITableSchema.NonPrimaryKeyColumns Property

ITableSchemaNonPrimaryKeyColumns Property

Provides information about all non-primary key table columns.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
IReadOnlyNamedObjectCollection<IColumnSchema> NonPrimaryKeyColumns { get; }
ReadOnly Property NonPrimaryKeyColumns As IReadOnlyNamedObjectCollection(Of IColumnSchema)
    Get

Property Value

Type: IReadOnlyNamedObjectCollectionIColumnSchema
See Also

Reference

ITableSchema Interface
SchemaExplorer Namespace


ITableSchema.PrimaryKey Property

ITableSchemaPrimaryKey Property

Provides information about the primary key of the table.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
IPrimaryKeySchema PrimaryKey { get; }
ReadOnly Property PrimaryKey As IPrimaryKeySchema
    Get

Property Value

Type: IPrimaryKeySchema
See Also

Reference

ITableSchema Interface
SchemaExplorer Namespace


ITableSchema.PrimaryKeys Property

ITableSchemaPrimaryKeys Property

Provides information about the primary keys (keys where the current table is the primary table) contained in the table.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
IReadOnlyNamedObjectCollection<ITableKeySchema> PrimaryKeys { get; }
ReadOnly Property PrimaryKeys As IReadOnlyNamedObjectCollection(Of ITableKeySchema)
    Get

Property Value

Type: IReadOnlyNamedObjectCollectionITableKeySchema
See Also

Reference

ITableSchema Interface
SchemaExplorer Namespace


ITableSchema Methods

The ITableSchema type exposes the following members.

Methods
 | Name | Description
Public method | GetData | Gets the data contained within the schema object. (Inherited from ITabularObject.)
Public method | GetTableData | Gets the data contained within the table.
Public method | Refresh | Allows the object to be refreshed. (Inherited from ISchemaObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Selected | Determines if the specified item is selected using the rules defined in SchemaSelector. (Defined by SchemaSelectorExtensions.)
Top
See Also

Reference

ITableSchema Interface
SchemaExplorer Namespace


ITableSchema.GetTableData Method

ITableSchemaGetTableData Method

Gets the data contained within the table.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
DataTable GetTableData()
Function GetTableData As DataTable

Return Value

Type: DataTable
See Also

Reference

ITableSchema Interface
SchemaExplorer Namespace


ITabularObject Interface

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public interface ITabularObject : ISchemaObjectWithOwner,
    ISchemaObject
Public Interface ITabularObject
    Inherits ISchemaObjectWithOwner, ISchemaObject

The ITabularObject type exposes the following members.

Properties
 | Name | Description
Public property | Database | Allows access to the DatabaseSchema object that contains this schema object. (Inherited from ISchemaObject.)
Public property | DataObjects | Provides information about the schema objects columns.
Public property | DateCreated | Returns the date this table was created. (Inherited from ISchemaObject.)
Public property | DeepLoad | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from ISchemaObject.)
Public property | DefaultExtendedProperties | (Inherited from ISchemaObject.)
Public property | Description | The description of the object. (Inherited from ISchemaObject.)
Public property | ExtendedProperties | Used to store any additional information about the schema object. (Inherited from ISchemaObject.)
Public property | FullName | Returns the owner and name of the table. (Inherited from ISchemaObject.)
Public property | IncludeFunctions | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from ISchemaObject.)
Public property | Item | Index to allow easy access to the columns in this schema object.
Public property | Owner | Returns the owner of the table. (Inherited from ISchemaObjectWithOwner.)
Public property | SortName | Gets the name used to sort in 'Table (Owner)' format. (Inherited from ISchemaObject.)
Top
Methods
 | Name | Description
Public method | GetData | Gets the data contained within the schema object.
Public method | Refresh | Allows the object to be refreshed. (Inherited from ISchemaObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Selected | Determines if the specified item is selected using the rules defined in SchemaSelector. (Defined by SchemaSelectorExtensions.)
Top
See Also

Reference

SchemaExplorer Namespace


ITabularObject Properties

The ITabularObject type exposes the following members.

Properties
 | Name | Description
Public property | Database | Allows access to the DatabaseSchema object that contains this schema object. (Inherited from ISchemaObject.)
Public property | DataObjects | Provides information about the schema objects columns.
Public property | DateCreated | Returns the date this table was created. (Inherited from ISchemaObject.)
Public property | DeepLoad | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from ISchemaObject.)
Public property | DefaultExtendedProperties | (Inherited from ISchemaObject.)
Public property | Description | The description of the object. (Inherited from ISchemaObject.)
Public property | ExtendedProperties | Used to store any additional information about the schema object. (Inherited from ISchemaObject.)
Public property | FullName | Returns the owner and name of the table. (Inherited from ISchemaObject.)
Public property | IncludeFunctions | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from ISchemaObject.)
Public property | Item | Index to allow easy access to the columns in this schema object.
Public property | Owner | Returns the owner of the table. (Inherited from ISchemaObjectWithOwner.)
Public property | SortName | Gets the name used to sort in 'Table (Owner)' format. (Inherited from ISchemaObject.)
Top
See Also

Reference

ITabularObject Interface
SchemaExplorer Namespace


ITabularObject.DataObjects Property

ITabularObjectDataObjects Property

Provides information about the schema objects columns.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
IReadOnlyNamedObjectCollection<IDataObject> DataObjects { get; }
ReadOnly Property DataObjects As IReadOnlyNamedObjectCollection(Of IDataObject)
    Get

Property Value

Type: IReadOnlyNamedObjectCollectionIDataObject
See Also

Reference

ITabularObject Interface
SchemaExplorer Namespace


ITabularObject.Item Property

ITabularObjectItem Property

Index to allow easy access to the columns in this schema object.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
IDataObject this[
    int index
] { get; }
ReadOnly Default Property Item (
    index As Integer
) As IDataObject
    Get

Parameters

index
Type: SystemInt32

Property Value

Type: IDataObject
See Also

Reference

ITabularObject Interface
SchemaExplorer Namespace


ITabularObject Methods

The ITabularObject type exposes the following members.

Methods
 | Name | Description
Public method | GetData | Gets the data contained within the schema object.
Public method | Refresh | Allows the object to be refreshed. (Inherited from ISchemaObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Selected | Determines if the specified item is selected using the rules defined in SchemaSelector. (Defined by SchemaSelectorExtensions.)
Top
See Also

Reference

ITabularObject Interface
SchemaExplorer Namespace


ITabularObject.GetData Method

ITabularObjectGetData Method

Gets the data contained within the schema object.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
DataTable GetData()
Function GetData As DataTable

Return Value

Type: DataTable
See Also

Reference

ITabularObject Interface
SchemaExplorer Namespace


IViewColumnSchema Interface

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public interface IViewColumnSchema : IDataObject,
    ISchemaObject
Public Interface IViewColumnSchema
    Inherits IDataObject, ISchemaObject

The IViewColumnSchema type exposes the following members.

Properties
 | Name | Description
Public property | AllowDBNull | Whether or not the data object allows null values. (Inherited from IDataObject.)
Public property | Database | Allows access to the DatabaseSchema object that contains this schema object. (Inherited from ISchemaObject.)
Public property | DataType | The data type of a (column) parameter is specific to the .NET Framework data provider. Specifying the type converts the value of the Parameter to the data provider Type before passing the value to the data source. seealso: http://msdn.microsoft.com/en-us/library/system.data.dbtype.aspx example: DbType.AnsiString (Inherited from IDataObject.)
Public property | DateCreated | Returns the date this table was created. (Inherited from ISchemaObject.)
Public property | DeepLoad | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from ISchemaObject.)
Public property | DefaultExtendedProperties | (Inherited from ISchemaObject.)
Public property | Description | The description of the object. (Inherited from ISchemaObject.)
Public property | ExtendedProperties | Used to store any additional information about the schema object. (Inherited from ISchemaObject.)
Public property | FullName | Returns the owner and name of the table. (Inherited from ISchemaObject.)
Public property | IncludeFunctions | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from ISchemaObject.)
Public property | NativeType | This is the native data type from the database. example: nvarchar (Inherited from IDataObject.)
Public property | Parent | The Parent Schema Object. (Inherited from IDataObject.)
Public property | Precision | The precision of the data object. (Inherited from IDataObject.)
Public property | Scale | The scale of the data object. (Inherited from IDataObject.)
Public property | Size | The size of the data object. (Inherited from IDataObject.)
Public property | SortName | Gets the name used to sort in 'Table (Owner)' format. (Inherited from ISchemaObject.)
Public property | SystemType | The System Type that is resolved from DataType. example: typeof(System.String) (Inherited from IDataObject.)
Public property | View | The view that contains this column.
Top
Methods
 | Name | Description
Public method | Refresh | Allows the object to be refreshed. (Inherited from ISchemaObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Selected | Determines if the specified item is selected using the rules defined in SchemaSelector. (Defined by SchemaSelectorExtensions.)
Top
See Also

Reference

SchemaExplorer Namespace


IViewColumnSchema Properties

The IViewColumnSchema type exposes the following members.

Properties
 | Name | Description
Public property | AllowDBNull | Whether or not the data object allows null values. (Inherited from IDataObject.)
Public property | Database | Allows access to the DatabaseSchema object that contains this schema object. (Inherited from ISchemaObject.)
Public property | DataType | The data type of a (column) parameter is specific to the .NET Framework data provider. Specifying the type converts the value of the Parameter to the data provider Type before passing the value to the data source. seealso: http://msdn.microsoft.com/en-us/library/system.data.dbtype.aspx example: DbType.AnsiString (Inherited from IDataObject.)
Public property | DateCreated | Returns the date this table was created. (Inherited from ISchemaObject.)
Public property | DeepLoad | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from ISchemaObject.)
Public property | DefaultExtendedProperties | (Inherited from ISchemaObject.)
Public property | Description | The description of the object. (Inherited from ISchemaObject.)
Public property | ExtendedProperties | Used to store any additional information about the schema object. (Inherited from ISchemaObject.)
Public property | FullName | Returns the owner and name of the table. (Inherited from ISchemaObject.)
Public property | IncludeFunctions | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from ISchemaObject.)
Public property | NativeType | This is the native data type from the database. example: nvarchar (Inherited from IDataObject.)
Public property | Parent | The Parent Schema Object. (Inherited from IDataObject.)
Public property | Precision | The precision of the data object. (Inherited from IDataObject.)
Public property | Scale | The scale of the data object. (Inherited from IDataObject.)
Public property | Size | The size of the data object. (Inherited from IDataObject.)
Public property | SortName | Gets the name used to sort in 'Table (Owner)' format. (Inherited from ISchemaObject.)
Public property | SystemType | The System Type that is resolved from DataType. example: typeof(System.String) (Inherited from IDataObject.)
Public property | View | The view that contains this column.
Top
See Also

Reference

IViewColumnSchema Interface
SchemaExplorer Namespace


IViewColumnSchema.View Property

IViewColumnSchemaView Property

The view that contains this column.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
IViewSchema View { get; }
ReadOnly Property View As IViewSchema
    Get

Property Value

Type: IViewSchema
See Also

Reference

IViewColumnSchema Interface
SchemaExplorer Namespace


IViewColumnSchema Methods

The IViewColumnSchema type exposes the following members.

Methods
 | Name | Description
Public method | Refresh | Allows the object to be refreshed. (Inherited from ISchemaObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Selected | Determines if the specified item is selected using the rules defined in SchemaSelector. (Defined by SchemaSelectorExtensions.)
Top
See Also

Reference

IViewColumnSchema Interface
SchemaExplorer Namespace


IViewSchema Interface

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public interface IViewSchema : ITabularObject,
    ISchemaObjectWithOwner, ISchemaObject
Public Interface IViewSchema
    Inherits ITabularObject, ISchemaObjectWithOwner, ISchemaObject

The IViewSchema type exposes the following members.

Properties
 | Name | Description
Public property | Columns | Provides information about the view columns.
Public property | Database | Allows access to the DatabaseSchema object that contains this schema object. (Inherited from ISchemaObject.)
Public property | DataObjects | Provides information about the schema objects columns. (Inherited from ITabularObject.)
Public property | DateCreated | Returns the date this table was created. (Inherited from ISchemaObject.)
Public property | DeepLoad | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from ISchemaObject.)
Public property | DefaultExtendedProperties | (Inherited from ISchemaObject.)
Public property | Description | The description of the object. (Inherited from ISchemaObject.)
Public property | ExtendedProperties | Used to store any additional information about the schema object. (Inherited from ISchemaObject.)
Public property | FullName | Returns the owner and name of the table. (Inherited from ISchemaObject.)
Public property | IncludeFunctions | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from ISchemaObject.)
Public property | Item | Index to allow easy access to the columns in this schema object. (Inherited from ITabularObject.)
Public property | Owner | Returns the owner of the table. (Inherited from ISchemaObjectWithOwner.)
Public property | SortName | Gets the name used to sort in 'Table (Owner)' format. (Inherited from ISchemaObject.)
Public property | ViewText | Gets the view text for this view.
Top
Methods
 | Name | Description
Public method | GetData | Gets the data contained within the schema object. (Inherited from ITabularObject.)
Public method | GetViewData | Gets the data contained within the table.
Public method | Refresh | Allows the object to be refreshed. (Inherited from ISchemaObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Selected | Determines if the specified item is selected using the rules defined in SchemaSelector. (Defined by SchemaSelectorExtensions.)
Top
See Also

Reference

SchemaExplorer Namespace


IViewSchema Properties

The IViewSchema type exposes the following members.

Properties
 | Name | Description
Public property | Columns | Provides information about the view columns.
Public property | Database | Allows access to the DatabaseSchema object that contains this schema object. (Inherited from ISchemaObject.)
Public property | DataObjects | Provides information about the schema objects columns. (Inherited from ITabularObject.)
Public property | DateCreated | Returns the date this table was created. (Inherited from ISchemaObject.)
Public property | DeepLoad | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from ISchemaObject.)
Public property | DefaultExtendedProperties | (Inherited from ISchemaObject.)
Public property | Description | The description of the object. (Inherited from ISchemaObject.)
Public property | ExtendedProperties | Used to store any additional information about the schema object. (Inherited from ISchemaObject.)
Public property | FullName | Returns the owner and name of the table. (Inherited from ISchemaObject.)
Public property | IncludeFunctions | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from ISchemaObject.)
Public property | Item | Index to allow easy access to the columns in this schema object. (Inherited from ITabularObject.)
Public property | Owner | Returns the owner of the table. (Inherited from ISchemaObjectWithOwner.)
Public property | SortName | Gets the name used to sort in 'Table (Owner)' format. (Inherited from ISchemaObject.)
Public property | ViewText | Gets the view text for this view.
Top
See Also

Reference

IViewSchema Interface
SchemaExplorer Namespace


IViewSchema.Columns Property

IViewSchemaColumns Property

Provides information about the view columns.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
IReadOnlyNamedObjectCollection<IViewColumnSchema> Columns { get; }
ReadOnly Property Columns As IReadOnlyNamedObjectCollection(Of IViewColumnSchema)
    Get

Property Value

Type: IReadOnlyNamedObjectCollectionIViewColumnSchema
See Also

Reference

IViewSchema Interface
SchemaExplorer Namespace


IViewSchema.ViewText Property

IViewSchemaViewText Property

Gets the view text for this view.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
string ViewText { get; }
ReadOnly Property ViewText As String
    Get

Property Value

Type: String
See Also

Reference

IViewSchema Interface
SchemaExplorer Namespace


IViewSchema Methods

The IViewSchema type exposes the following members.

Methods
 | Name | Description
Public method | GetData | Gets the data contained within the schema object. (Inherited from ITabularObject.)
Public method | GetViewData | Gets the data contained within the table.
Public method | Refresh | Allows the object to be refreshed. (Inherited from ISchemaObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Selected | Determines if the specified item is selected using the rules defined in SchemaSelector. (Defined by SchemaSelectorExtensions.)
Top
See Also

Reference

IViewSchema Interface
SchemaExplorer Namespace


IViewSchema.GetViewData Method

IViewSchemaGetViewData Method

Gets the data contained within the table.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
DataTable GetViewData()
Function GetViewData As DataTable

Return Value

Type: DataTable
See Also

Reference

IViewSchema Interface
SchemaExplorer Namespace


MemberColumnSchema Class

Wraps a ColumnSchema object and allows for storing extended properties specific to this instance of the member column.
Inheritance Hierarchy
SystemObject
NamedObjectBase
SchemaExplorerSchemaObjectBase
SchemaExplorerDataObjectBase
SchemaExplorerColumnSchema
SchemaExplorerMemberColumnSchema

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
public class MemberColumnSchema : ColumnSchema,
    IMemberColumnSchema, IColumnSchema, IDataObject, ISchemaObject
<SerializableAttribute>
Public Class MemberColumnSchema
    Inherits ColumnSchema
    Implements IMemberColumnSchema, IColumnSchema, IDataObject, ISchemaObject

The MemberColumnSchema type exposes the following members.

Constructors
 | Name | Description
Public method | MemberColumnSchema(ColumnSchema) | Creates a new instance of the MemberColumnSchema object.
Public method | MemberColumnSchema(ColumnSchema, ExtendedProperty) | Creates a new instance of the MemberColumnSchema object.
Top
Properties
 | Name | Description
Public property | AllowDBNull | Whether or not the data object allows null values. (Overrides DataObjectBaseAllowDBNull.)
Public property | Column | The column that this member column object wraps.
Public property | ColumnExtendedProperties | The underlying column's extended properties.
Public property | Database | Allows access to the DatabaseSchema object that contains this schema object. (Overrides SchemaObjectBaseDatabase.)
Public property | DataType | The data type for this data object. (Overrides DataObjectBaseDataType.)
Public property | DateCreated | Returns the date this table was created. (Inherited from SchemaObjectBase.)
Public property | DeepLoad | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from SchemaObjectBase.)
Public property | Description | The description of the object. (Overrides SchemaObjectBaseDescription.)
Public property | ExtendedProperties | Used to store any additional information about the schema object. (Overrides SchemaObjectBaseExtendedProperties.)
Public property | FullName | Returns the owner and name. (Inherited from DataObjectBase.)
Public property | IncludeFunctions | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from SchemaObjectBase.)
Public property | IsForeignKeyMember | Whether or not the column is a foreign key member. (Overrides ColumnSchemaIsForeignKeyMember.)
Public property | IsPrimaryKeyMember | Whether or not the column is a primary key member. (Overrides ColumnSchemaIsPrimaryKeyMember.)
Public property | IsUnique | Whether or not this column is unique. (Overrides ColumnSchemaIsUnique.)
Public property | Name | The name of the object. (Overrides NamedObjectBase.Name.)
Public property | NativeType | The native data type for this data object. (Overrides DataObjectBaseNativeType.)
Public property | Parent | The Parent Schema Object. (Overrides DataObjectBaseParent.)
Public property | Precision | The precision of the data object. (Overrides DataObjectBasePrecision.)
Public property | Scale | The scale of the data object. (Overrides DataObjectBaseScale.)
Public property | Size | The size of the data object. (Overrides DataObjectBaseSize.)
Public property | SortName | Gets the name used to sort in 'Name (Parent)' format. (Inherited from DataObjectBase.)
Public property | SystemType | The system type that for this data object. (Overrides DataObjectBaseSystemType.)
Public property | Table | The table that contains this column. (Overrides ColumnSchemaTable.)
Top
Methods
 | Name | Description
Public method | Equals | Determines if another column is the same as this column. (Overrides DataObjectBaseEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns a HashCode based on the database, table and name of the column. (Overrides DataObjectBaseGetHashCode.)
Public method | GetLoadedExtendedProperties | Gets the existing ExtendedProperties without causing a lazy load. (Inherited from SchemaObjectBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MarkLoaded | (Inherited from SchemaObjectBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh | Used to refresh this instance. (Overrides DataObjectBaseRefresh.)
Public method | ToString | Returns the name of the column. (Inherited from DataObjectBase.)
Top
Fields
 | Name | Description
Protected field | _allowDBNull | (Inherited from DataObjectBase.)
Protected field | _database | (Inherited from SchemaObjectBase.)
Protected field | _dataType | (Inherited from DataObjectBase.)
Protected field | _dateCreated | (Inherited from SchemaObjectBase.)
Protected field | _defaultExtendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _extendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _gotExtendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _nativeType | (Inherited from DataObjectBase.)
Protected field | _parent | (Inherited from DataObjectBase.)
Protected field | _precision | (Inherited from DataObjectBase.)
Protected field | _scale | (Inherited from DataObjectBase.)
Protected field | _size | (Inherited from DataObjectBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Selected | Determines if the specified item is selected using the rules defined in SchemaSelector. (Defined by SchemaSelectorExtensions.)
Top
See Also

Reference

SchemaExplorer Namespace


MemberColumnSchema Constructor

Overload List
 | Name | Description
Public method | MemberColumnSchema(ColumnSchema) | Creates a new instance of the MemberColumnSchema object.
Public method | MemberColumnSchema(ColumnSchema, ExtendedProperty) | Creates a new instance of the MemberColumnSchema object.
Top
See Also

Reference

MemberColumnSchema Class
SchemaExplorer Namespace


MemberColumnSchema Constructor (ColumnSchema)

Creates a new instance of the MemberColumnSchema object.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public MemberColumnSchema(
    ColumnSchema memberColumn
)
Public Sub New (
    memberColumn As ColumnSchema
)

Parameters

memberColumn
Type: SchemaExplorerColumnSchema
The column that is member column refers to.
See Also

Reference

MemberColumnSchema Class
MemberColumnSchema Overload
SchemaExplorer Namespace


MemberColumnSchema Constructor (ColumnSchema, ExtendedProperty[])

MemberColumnSchema Constructor (ColumnSchema, ExtendedProperty)

Creates a new instance of the MemberColumnSchema object.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public MemberColumnSchema(
    ColumnSchema memberColumn,
    ExtendedProperty[] extendedProperties
)
Public Sub New (
    memberColumn As ColumnSchema,
    extendedProperties As ExtendedProperty()
)

Parameters

memberColumn
Type: SchemaExplorerColumnSchema
The column that is member column refers to.
extendedProperties
Type: SchemaExplorerExtendedProperty
The array of extended properties for the member column.
See Also

Reference

MemberColumnSchema Class
MemberColumnSchema Overload
SchemaExplorer Namespace


MemberColumnSchema Properties

The MemberColumnSchema type exposes the following members.

Properties
 | Name | Description
Public property | AllowDBNull | Whether or not the data object allows null values. (Overrides DataObjectBaseAllowDBNull.)
Public property | Column | The column that this member column object wraps.
Public property | ColumnExtendedProperties | The underlying column's extended properties.
Public property | Database | Allows access to the DatabaseSchema object that contains this schema object. (Overrides SchemaObjectBaseDatabase.)
Public property | DataType | The data type for this data object. (Overrides DataObjectBaseDataType.)
Public property | DateCreated | Returns the date this table was created. (Inherited from SchemaObjectBase.)
Public property | DeepLoad | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from SchemaObjectBase.)
Public property | Description | The description of the object. (Overrides SchemaObjectBaseDescription.)
Public property | ExtendedProperties | Used to store any additional information about the schema object. (Overrides SchemaObjectBaseExtendedProperties.)
Public property | FullName | Returns the owner and name. (Inherited from DataObjectBase.)
Public property | IncludeFunctions | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from SchemaObjectBase.)
Public property | IsForeignKeyMember | Whether or not the column is a foreign key member. (Overrides ColumnSchemaIsForeignKeyMember.)
Public property | IsPrimaryKeyMember | Whether or not the column is a primary key member. (Overrides ColumnSchemaIsPrimaryKeyMember.)
Public property | IsUnique | Whether or not this column is unique. (Overrides ColumnSchemaIsUnique.)
Public property | Name | The name of the object. (Overrides NamedObjectBase.Name.)
Public property | NativeType | The native data type for this data object. (Overrides DataObjectBaseNativeType.)
Public property | Parent | The Parent Schema Object. (Overrides DataObjectBaseParent.)
Public property | Precision | The precision of the data object. (Overrides DataObjectBasePrecision.)
Public property | Scale | The scale of the data object. (Overrides DataObjectBaseScale.)
Public property | Size | The size of the data object. (Overrides DataObjectBaseSize.)
Public property | SortName | Gets the name used to sort in 'Name (Parent)' format. (Inherited from DataObjectBase.)
Public property | SystemType | The system type that for this data object. (Overrides DataObjectBaseSystemType.)
Public property | Table | The table that contains this column. (Overrides ColumnSchemaTable.)
Top
See Also

Reference

MemberColumnSchema Class
SchemaExplorer Namespace


MemberColumnSchema.AllowDBNull Property

MemberColumnSchemaAllowDBNull Property

Whether or not the data object allows null values.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override bool AllowDBNull { get; }
Public Overrides ReadOnly Property AllowDBNull As Boolean
    Get

Property Value

Type: Boolean

Implements

IDataObjectAllowDBNull
IDataObjectAllowDBNull
See Also

Reference

MemberColumnSchema Class
SchemaExplorer Namespace


MemberColumnSchema.Column Property

MemberColumnSchemaColumn Property

The column that this member column object wraps.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ColumnSchema Column { get; }
Public ReadOnly Property Column As ColumnSchema
    Get

Property Value

Type: ColumnSchema
See Also

Reference

MemberColumnSchema Class
SchemaExplorer Namespace


MemberColumnSchema.ColumnExtendedProperties Property

MemberColumnSchemaColumnExtendedProperties Property

The underlying column's extended properties.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ExtendedPropertyCollection ColumnExtendedProperties { get; }
Public ReadOnly Property ColumnExtendedProperties As ExtendedPropertyCollection
    Get

Property Value

Type: ExtendedPropertyCollection
See Also

Reference

MemberColumnSchema Class
SchemaExplorer Namespace


MemberColumnSchema.Database Property

MemberColumnSchemaDatabase Property

Allows access to the DatabaseSchema object that contains this schema object.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override DatabaseSchema Database { get; }
Public Overrides ReadOnly Property Database As DatabaseSchema
    Get

Property Value

Type: DatabaseSchema
See Also

Reference

MemberColumnSchema Class
SchemaExplorer Namespace


MemberColumnSchema.DataType Property

MemberColumnSchemaDataType Property

The data type for this data object.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override DbType DataType { get; }
Public Overrides ReadOnly Property DataType As DbType
    Get

Property Value

Type: DbType

Implements

IDataObjectDataType
IDataObjectDataType
See Also

Reference

MemberColumnSchema Class
SchemaExplorer Namespace


MemberColumnSchema.Description Property

MemberColumnSchemaDescription Property

The description of the object.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
    Get

Property Value

Type: String

Implements

ISchemaObjectDescription
ISchemaObjectDescription
See Also

Reference

MemberColumnSchema Class
SchemaExplorer Namespace


MemberColumnSchema.ExtendedProperties Property

MemberColumnSchemaExtendedProperties Property

Used to store any additional information about the schema object.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override ExtendedPropertyCollection ExtendedProperties { get; protected set; }
Public Overrides Property ExtendedProperties As ExtendedPropertyCollection
    Get
    Protected Set

Property Value

Type: ExtendedPropertyCollection
See Also

Reference

MemberColumnSchema Class
SchemaExplorer Namespace


MemberColumnSchema.IsForeignKeyMember Property

MemberColumnSchemaIsForeignKeyMember Property

Whether or not the column is a foreign key member.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override bool IsForeignKeyMember { get; }
Public Overrides ReadOnly Property IsForeignKeyMember As Boolean
    Get

Property Value

Type: Boolean

Implements

IColumnSchemaIsForeignKeyMember
IColumnSchemaIsForeignKeyMember
See Also

Reference

MemberColumnSchema Class
SchemaExplorer Namespace


MemberColumnSchema.IsPrimaryKeyMember Property

MemberColumnSchemaIsPrimaryKeyMember Property

Whether or not the column is a primary key member.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override bool IsPrimaryKeyMember { get; }
Public Overrides ReadOnly Property IsPrimaryKeyMember As Boolean
    Get

Property Value

Type: Boolean

Implements

IColumnSchemaIsPrimaryKeyMember
IColumnSchemaIsPrimaryKeyMember
See Also

Reference

MemberColumnSchema Class
SchemaExplorer Namespace


MemberColumnSchema.IsUnique Property

MemberColumnSchemaIsUnique Property

Whether or not this column is unique.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override bool IsUnique { get; }
Public Overrides ReadOnly Property IsUnique As Boolean
    Get

Property Value

Type: Boolean

Implements

IColumnSchemaIsUnique
IColumnSchemaIsUnique
See Also

Reference

MemberColumnSchema Class
SchemaExplorer Namespace


MemberColumnSchema.Name Property

MemberColumnSchemaName Property

The name of the object.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override string Name { get; }
Public Overrides ReadOnly Property Name As String
    Get

Property Value

Type: String
See Also

Reference

MemberColumnSchema Class
SchemaExplorer Namespace


MemberColumnSchema.NativeType Property

MemberColumnSchemaNativeType Property

The native data type for this data object.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override string NativeType { get; }
Public Overrides ReadOnly Property NativeType As String
    Get

Property Value

Type: String

Implements

IDataObjectNativeType
IDataObjectNativeType
See Also

Reference

MemberColumnSchema Class
SchemaExplorer Namespace


MemberColumnSchema.Parent Property

MemberColumnSchemaParent Property

The Parent Schema Object.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override ISchemaObject Parent { get; }
Public Overrides ReadOnly Property Parent As ISchemaObject
    Get

Property Value

Type: ISchemaObject

Implements

IDataObjectParent
IDataObjectParent
See Also

Reference

MemberColumnSchema Class
SchemaExplorer Namespace


MemberColumnSchema.Precision Property

MemberColumnSchemaPrecision Property

The precision of the data object.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override byte Precision { get; }
Public Overrides ReadOnly Property Precision As Byte
    Get

Property Value

Type: Byte

Implements

IDataObjectPrecision
IDataObjectPrecision
See Also

Reference

MemberColumnSchema Class
SchemaExplorer Namespace


MemberColumnSchema.Scale Property

MemberColumnSchemaScale Property

The scale of the data object.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override int Scale { get; }
Public Overrides ReadOnly Property Scale As Integer
    Get

Property Value

Type: Int32

Implements

IDataObjectScale
IDataObjectScale
See Also

Reference

MemberColumnSchema Class
SchemaExplorer Namespace


MemberColumnSchema.Size Property

MemberColumnSchemaSize Property

The size of the data object.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override int Size { get; }
Public Overrides ReadOnly Property Size As Integer
    Get

Property Value

Type: Int32

Implements

IDataObjectSize
IDataObjectSize
See Also

Reference

MemberColumnSchema Class
SchemaExplorer Namespace


MemberColumnSchema.SystemType Property

MemberColumnSchemaSystemType Property

The system type that for this data object.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override Type SystemType { get; }
Public Overrides ReadOnly Property SystemType As Type
    Get

Property Value

Type: Type

Implements

IDataObjectSystemType
IDataObjectSystemType
See Also

Reference

MemberColumnSchema Class
SchemaExplorer Namespace


MemberColumnSchema.Table Property

MemberColumnSchemaTable Property

The table that contains this column.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override TableSchema Table { get; }
Public Overrides ReadOnly Property Table As TableSchema
    Get

Property Value

Type: TableSchema
See Also

Reference

MemberColumnSchema Class
SchemaExplorer Namespace


MemberColumnSchema Methods

The MemberColumnSchema type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines if another column is the same as this column. (Overrides DataObjectBaseEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns a HashCode based on the database, table and name of the column. (Overrides DataObjectBaseGetHashCode.)
Public method | GetLoadedExtendedProperties | Gets the existing ExtendedProperties without causing a lazy load. (Inherited from SchemaObjectBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MarkLoaded | (Inherited from SchemaObjectBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh | Used to refresh this instance. (Overrides DataObjectBaseRefresh.)
Public method | ToString | Returns the name of the column. (Inherited from DataObjectBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Selected | Determines if the specified item is selected using the rules defined in SchemaSelector. (Defined by SchemaSelectorExtensions.)
Top
See Also

Reference

MemberColumnSchema Class
SchemaExplorer Namespace


MemberColumnSchema.Equals Method

MemberColumnSchemaEquals Method

Determines if another column is the same as this column.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
The column to check against.

Return Value

Type: Boolean
true/false
See Also

Reference

MemberColumnSchema Class
SchemaExplorer Namespace


MemberColumnSchema.GetHashCode Method

MemberColumnSchemaGetHashCode Method

Returns a HashCode based on the database, table and name of the column.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
See Also

Reference

MemberColumnSchema Class
SchemaExplorer Namespace


MemberColumnSchema.Refresh Method

MemberColumnSchemaRefresh Method

Used to refresh this instance.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override void Refresh()
Public Overrides Sub Refresh

Implements

ISchemaObjectRefresh
ISchemaObjectRefresh
ISchemaObjectRefresh
See Also

Reference

MemberColumnSchema Class
SchemaExplorer Namespace


MemberColumnSchema Fields

The MemberColumnSchema type exposes the following members.

Fields
 | Name | Description
Protected field | _allowDBNull | (Inherited from DataObjectBase.)
Protected field | _database | (Inherited from SchemaObjectBase.)
Protected field | _dataType | (Inherited from DataObjectBase.)
Protected field | _dateCreated | (Inherited from SchemaObjectBase.)
Protected field | _defaultExtendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _extendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _gotExtendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _nativeType | (Inherited from DataObjectBase.)
Protected field | _parent | (Inherited from DataObjectBase.)
Protected field | _precision | (Inherited from DataObjectBase.)
Protected field | _scale | (Inherited from DataObjectBase.)
Protected field | _size | (Inherited from DataObjectBase.)
Top
See Also

Reference

MemberColumnSchema Class
SchemaExplorer Namespace


MemberColumnSchemaCollection Class

Implements a strongly typed collection of MemberColumnSchema elements.
Inheritance Hierarchy
SystemObject
ObservableListMemberColumnSchema
NamedObjectCollectionMemberColumnSchema
SchemaExplorerSchemaObjectCollection MemberColumnSchema
SchemaExplorerMemberColumnSchemaCollection

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
public class MemberColumnSchemaCollection : SchemaObjectCollection<MemberColumnSchema>
<SerializableAttribute>
Public Class MemberColumnSchemaCollection
    Inherits SchemaObjectCollection(Of MemberColumnSchema)

The MemberColumnSchemaCollection type exposes the following members.

Constructors
 | Name | Description
Public method | MemberColumnSchemaCollection | Initializes a new instance of the MemberColumnSchemaCollection class.
Public method | MemberColumnSchemaCollection(IEnumerableMemberColumnSchema) | Initializes a new instance of the MemberColumnSchemaCollection class.
Public method | MemberColumnSchemaCollection(Int32) | Initializes a new instance of the MemberColumnSchemaCollection class.
Top
Methods
 | Name | Description
Public method | Clone | (Inherited from SchemaObjectCollectionT.)
Public method | Contains | Determines whether the MemberColumnSchemaCollection contains a MemberColumnSchema element that points to the specified ColumnSchema .
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the zero-based index of the first occurrence of the specified MemberColumnSchema in the MemberColumnSchemaCollection that points to the specified ColumnSchema ..
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh | (Inherited from SchemaObjectCollectionT.)
Public method | ToString | (Inherited from SchemaObjectCollectionT.)
Top
Operators
Name | Description
(MemberColumnSchemaCollection to ColumnSchemaCollection) |
Top
Remarks
MemberColumnSchemaCollection provides an SchemaObjectCollectionT that is strongly typed for MemberColumnSchema elements.
See Also

Reference

SchemaExplorer Namespace


MemberColumnSchemaCollection Constructor

Overload List
 | Name | Description
Public method | MemberColumnSchemaCollection | Initializes a new instance of the MemberColumnSchemaCollection class.
Public method | MemberColumnSchemaCollection(IEnumerableMemberColumnSchema) | Initializes a new instance of the MemberColumnSchemaCollection class.
Public method | MemberColumnSchemaCollection(Int32) | Initializes a new instance of the MemberColumnSchemaCollection class.
Top
See Also

Reference

MemberColumnSchemaCollection Class
SchemaExplorer Namespace


MemberColumnSchemaCollection Constructor

Initializes a new instance of the MemberColumnSchemaCollection class.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public MemberColumnSchemaCollection()
Public Sub New
See Also

Reference

MemberColumnSchemaCollection Class
MemberColumnSchemaCollection Overload
SchemaExplorer Namespace


MemberColumnSchemaCollection Constructor (IEnumerable(MemberColumnSchema))

MemberColumnSchemaCollection Constructor (IEnumerableMemberColumnSchema)

Initializes a new instance of the MemberColumnSchemaCollection class.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public MemberColumnSchemaCollection(
    IEnumerable<MemberColumnSchema> collection
)
Public Sub New (
    collection As IEnumerable(Of MemberColumnSchema)
)

Parameters

collection
Type: System.Collections.GenericIEnumerable MemberColumnSchema
The collection from which the elements are copied.
See Also

Reference

MemberColumnSchemaCollection Class
MemberColumnSchemaCollection Overload
SchemaExplorer Namespace


MemberColumnSchemaCollection Constructor (Int32)

Initializes a new instance of the MemberColumnSchemaCollection class.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public MemberColumnSchemaCollection(
    int capacity
)
Public Sub New (
    capacity As Integer
)

Parameters

capacity
Type: SystemInt32
The number of elements that the new list can initially store.
See Also

Reference

MemberColumnSchemaCollection Class
MemberColumnSchemaCollection Overload
SchemaExplorer Namespace


MemberColumnSchemaCollection Methods

The MemberColumnSchemaCollection type exposes the following members.

Methods
 | Name | Description
Public method | Clone | (Inherited from SchemaObjectCollectionT.)
Public method | Contains | Determines whether the MemberColumnSchemaCollection contains a MemberColumnSchema element that points to the specified ColumnSchema .
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the zero-based index of the first occurrence of the specified MemberColumnSchema in the MemberColumnSchemaCollection that points to the specified ColumnSchema ..
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh | (Inherited from SchemaObjectCollectionT.)
Public method | ToString | (Inherited from SchemaObjectCollectionT.)
Top
See Also

Reference

MemberColumnSchemaCollection Class
SchemaExplorer Namespace


MemberColumnSchemaCollection.Contains Method

MemberColumnSchemaCollectionContains Method

Determines whether the MemberColumnSchemaCollection contains a MemberColumnSchema element that points to the specified ColumnSchema .

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual bool Contains(
    ColumnSchema value
)
Public Overridable Function Contains (
    value As ColumnSchema
) As Boolean

Parameters

value
Type: SchemaExplorerColumnSchema
The ColumnSchema object to locate in the MemberColumnSchemaCollection. This argument can be a null reference.

Return Value

Type: Boolean
true if value is found in the MemberColumnSchemaCollection; otherwise, false.
Remarks
Please refer to Contains(Object) for details.
See Also

Reference

MemberColumnSchemaCollection Class
SchemaExplorer Namespace


MemberColumnSchemaCollection.IndexOf Method

MemberColumnSchemaCollectionIndexOf Method

Returns the zero-based index of the first occurrence of the specified MemberColumnSchema in the MemberColumnSchemaCollection that points to the specified ColumnSchema ..

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual int IndexOf(
    ColumnSchema value
)
Public Overridable Function IndexOf (
    value As ColumnSchema
) As Integer

Parameters

value
Type: SchemaExplorerColumnSchema
The ColumnSchema object to locate in the MemberColumnSchemaCollection. This argument can be a null reference.

Return Value

Type: Int32
The zero-based index of the first occurrence of value in the MemberColumnSchemaCollection, if found; otherwise, -1.
Remarks
Please refer to IndexOf(Object) for details.
See Also

Reference

MemberColumnSchemaCollection Class
SchemaExplorer Namespace


MemberColumnSchemaCollection Type Conversions

The MemberColumnSchemaCollection type exposes the following members.

Operators
Name | Description
(MemberColumnSchemaCollection to ColumnSchemaCollection) |
Top
See Also

Reference

MemberColumnSchemaCollection Class
SchemaExplorer Namespace


MemberColumnSchemaCollection Implicit Conversion (MemberColumnSchemaCollection to ColumnSchemaCollection)

MemberColumnSchemaCollection Conversion (MemberColumnSchemaCollection to ColumnSchemaCollection)

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static implicit operator ColumnSchemaCollection (
    MemberColumnSchemaCollection memberColumns
)
Public Shared Widening Operator CType (
    memberColumns As MemberColumnSchemaCollection
) As ColumnSchemaCollection

Parameters

memberColumns
Type: SchemaExplorerMemberColumnSchemaCollection

Return Value

Type: ColumnSchemaCollection
See Also

Reference

MemberColumnSchemaCollection Class
SchemaExplorer Namespace


ParameterSchema Class

Provides information about a parameter.
Inheritance Hierarchy
SystemObject
NamedObjectBase
SchemaExplorerSchemaObjectBase
SchemaExplorerDataObjectBase
SchemaExplorerParameterSchema

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
public class ParameterSchema : DataObjectBase,
    IParameterSchema, IDataObject, ISchemaObject
<SerializableAttribute>
Public Class ParameterSchema
    Inherits DataObjectBase
    Implements IParameterSchema, IDataObject, ISchemaObject

The ParameterSchema type exposes the following members.

Constructors
 | Name | Description
Public method | ParameterSchema(CommandSchema, String, ParameterDirection, DbType, String, Int32, Byte, Int32, Boolean) | Initializes a new instance of the ParameterSchema class
Public method | ParameterSchema(CommandSchema, String, ParameterDirection, DbType, String, Int32, Byte, Int32, Boolean, ExtendedProperty) | Initializes a new instance of the ParameterSchema class
Top
Properties
 | Name | Description
Public property | AllowDBNull | Whether or not the data object allows null values. (Inherited from DataObjectBase.)
Public property | Command | The command that contains this parameter.
Public property | Database | Allows access to the DatabaseSchema object that contains this schema object. (Inherited from SchemaObjectBase.)
Public property | DataType | The data type of a (column) parameter is specific to the .NET Framework data provider. Specifying the type converts the value of the Parameter to the data provider Type before passing the value to the data source. see also: http://msdn.microsoft.com/en-us/library/system.data.dbtype.aspx example: DbType.AnsiString (Inherited from DataObjectBase.)
Public property | DateCreated | Returns the date this table was created. (Inherited from SchemaObjectBase.)
Public property | DeepLoad | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from SchemaObjectBase.)
Public property | Description | The description of the object. (Inherited from SchemaObjectBase.)
Public property | Direction | The parameter direction.
Public property | ExtendedProperties | Used to store any additional information about the schema object. (Inherited from SchemaObjectBase.)
Public property | FullName | Returns the owner and name. (Inherited from DataObjectBase.)
Public property | IncludeFunctions | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from SchemaObjectBase.)
Public property | NativeType | This is the native data type from the database. example: nvarchar (Inherited from DataObjectBase.)
Public property | Parent | The Parent Schema Object. (Inherited from DataObjectBase.)
Public property | Precision | The precision of the data object. (Inherited from DataObjectBase.)
Public property | Scale | The scale of the data object. (Inherited from DataObjectBase.)
Public property | Size | The size of the data object. (Inherited from DataObjectBase.)
Public property | SortName | Gets the name used to sort in 'Name (Parent)' format. (Inherited from DataObjectBase.)
Public property | SystemType | The System Type that is resolved from DataType. example: typeof(System.String) (Inherited from DataObjectBase.)
Top
Methods
 | Name | Description
Public method | Equals | Determines if another view column is the same as this view column. (Inherited from DataObjectBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns a hashcode based on the database, view and name of the view column. (Inherited from DataObjectBase.)
Public method | GetLoadedExtendedProperties | Gets the existing ExtendedProperties without causing a lazy load. (Inherited from SchemaObjectBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MarkLoaded | (Inherited from SchemaObjectBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh | Used to refresh this instance. (Inherited from DataObjectBase.)
Public method | ToString | Returns the name of the column. (Inherited from DataObjectBase.)
Top
Fields
 | Name | Description
Protected field | _allowDBNull | (Inherited from DataObjectBase.)
Protected field | _database | (Inherited from SchemaObjectBase.)
Protected field | _dataType | (Inherited from DataObjectBase.)
Protected field | _dateCreated | (Inherited from SchemaObjectBase.)
Protected field | _defaultExtendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _extendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _gotExtendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _nativeType | (Inherited from DataObjectBase.)
Protected field | _parent | (Inherited from DataObjectBase.)
Protected field | _precision | (Inherited from DataObjectBase.)
Protected field | _scale | (Inherited from DataObjectBase.)
Protected field | _size | (Inherited from DataObjectBase.)
Top
See Also

Reference

SchemaExplorer Namespace


ParameterSchema Constructor

Overload List
 | Name | Description
Public method | ParameterSchema(CommandSchema, String, ParameterDirection, DbType, String, Int32, Byte, Int32, Boolean) | Initializes a new instance of the ParameterSchema class
Public method | ParameterSchema(CommandSchema, String, ParameterDirection, DbType, String, Int32, Byte, Int32, Boolean, ExtendedProperty) | Initializes a new instance of the ParameterSchema class
Top
See Also

Reference

ParameterSchema Class
SchemaExplorer Namespace


ParameterSchema Constructor (CommandSchema, String, ParameterDirection, DbType, String, Int32, Byte, Int32, Boolean)

Initializes a new instance of the ParameterSchema class

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ParameterSchema(
    CommandSchema command,
    string name,
    ParameterDirection direction,
    DbType dataType,
    string nativeType,
    int size,
    byte precision,
    int scale,
    bool allowDbNull
)
Public Sub New (
    command As CommandSchema,
    name As String,
    direction As ParameterDirection,
    dataType As DbType,
    nativeType As String,
    size As Integer,
    precision As Byte,
    scale As Integer,
    allowDbNull As Boolean
)

Parameters

command
Type: SchemaExplorerCommandSchema
name
Type: SystemString
direction
Type: System.DataParameterDirection
dataType
Type: System.DataDbType
nativeType
Type: SystemString
size
Type: SystemInt32
precision
Type: SystemByte
scale
Type: SystemInt32
allowDbNull
Type: SystemBoolean
See Also

Reference

ParameterSchema Class
ParameterSchema Overload
SchemaExplorer Namespace


ParameterSchema Constructor (CommandSchema, String, ParameterDirection, DbType, String, Int32, Byte, Int32, Boolean, ExtendedProperty[])

ParameterSchema Constructor (CommandSchema, String, ParameterDirection, DbType, String, Int32, Byte, Int32, Boolean, ExtendedProperty)

Initializes a new instance of the ParameterSchema class

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ParameterSchema(
    CommandSchema command,
    string name,
    ParameterDirection direction,
    DbType dataType,
    string nativeType,
    int size,
    byte precision,
    int scale,
    bool allowDbNull,
    ExtendedProperty[] extendedProperties
)
Public Sub New (
    command As CommandSchema,
    name As String,
    direction As ParameterDirection,
    dataType As DbType,
    nativeType As String,
    size As Integer,
    precision As Byte,
    scale As Integer,
    allowDbNull As Boolean,
    extendedProperties As ExtendedProperty()
)

Parameters

command
Type: SchemaExplorerCommandSchema
name
Type: SystemString
direction
Type: System.DataParameterDirection
dataType
Type: System.DataDbType
nativeType
Type: SystemString
size
Type: SystemInt32
precision
Type: SystemByte
scale
Type: SystemInt32
allowDbNull
Type: SystemBoolean
extendedProperties
Type: SchemaExplorerExtendedProperty
See Also

Reference

ParameterSchema Class
ParameterSchema Overload
SchemaExplorer Namespace


ParameterSchema Properties

The ParameterSchema type exposes the following members.

Properties
 | Name | Description
Public property | AllowDBNull | Whether or not the data object allows null values. (Inherited from DataObjectBase.)
Public property | Command | The command that contains this parameter.
Public property | Database | Allows access to the DatabaseSchema object that contains this schema object. (Inherited from SchemaObjectBase.)
Public property | DataType | The data type of a (column) parameter is specific to the .NET Framework data provider. Specifying the type converts the value of the Parameter to the data provider Type before passing the value to the data source. see also: http://msdn.microsoft.com/en-us/library/system.data.dbtype.aspx example: DbType.AnsiString (Inherited from DataObjectBase.)
Public property | DateCreated | Returns the date this table was created. (Inherited from SchemaObjectBase.)
Public property | DeepLoad | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from SchemaObjectBase.)
Public property | Description | The description of the object. (Inherited from SchemaObjectBase.)
Public property | Direction | The parameter direction.
Public property | ExtendedProperties | Used to store any additional information about the schema object. (Inherited from SchemaObjectBase.)
Public property | FullName | Returns the owner and name. (Inherited from DataObjectBase.)
Public property | IncludeFunctions | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from SchemaObjectBase.)
Public property | NativeType | This is the native data type from the database. example: nvarchar (Inherited from DataObjectBase.)
Public property | Parent | The Parent Schema Object. (Inherited from DataObjectBase.)
Public property | Precision | The precision of the data object. (Inherited from DataObjectBase.)
Public property | Scale | The scale of the data object. (Inherited from DataObjectBase.)
Public property | Size | The size of the data object. (Inherited from DataObjectBase.)
Public property | SortName | Gets the name used to sort in 'Name (Parent)' format. (Inherited from DataObjectBase.)
Public property | SystemType | The System Type that is resolved from DataType. example: typeof(System.String) (Inherited from DataObjectBase.)
Top
See Also

Reference

ParameterSchema Class
SchemaExplorer Namespace


ParameterSchema.Command Property

ParameterSchemaCommand Property

The command that contains this parameter.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CommandSchema Command { get; }
Public ReadOnly Property Command As CommandSchema
    Get

Property Value

Type: CommandSchema
See Also

Reference

ParameterSchema Class
SchemaExplorer Namespace


ParameterSchema.Direction Property

ParameterSchemaDirection Property

The parameter direction.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ParameterDirection Direction { get; }
Public ReadOnly Property Direction As ParameterDirection
    Get

Property Value

Type: ParameterDirection

Implements

IParameterSchemaDirection
See Also

Reference

ParameterSchema Class
SchemaExplorer Namespace


ParameterSchema Methods

The ParameterSchema type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines if another view column is the same as this view column. (Inherited from DataObjectBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns a hashcode based on the database, view and name of the view column. (Inherited from DataObjectBase.)
Public method | GetLoadedExtendedProperties | Gets the existing ExtendedProperties without causing a lazy load. (Inherited from SchemaObjectBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MarkLoaded | (Inherited from SchemaObjectBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh | Used to refresh this instance. (Inherited from DataObjectBase.)
Public method | ToString | Returns the name of the column. (Inherited from DataObjectBase.)
Top
See Also

Reference

ParameterSchema Class
SchemaExplorer Namespace


ParameterSchema Fields

The ParameterSchema type exposes the following members.

Fields
 | Name | Description
Protected field | _allowDBNull | (Inherited from DataObjectBase.)
Protected field | _database | (Inherited from SchemaObjectBase.)
Protected field | _dataType | (Inherited from DataObjectBase.)
Protected field | _dateCreated | (Inherited from SchemaObjectBase.)
Protected field | _defaultExtendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _extendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _gotExtendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _nativeType | (Inherited from DataObjectBase.)
Protected field | _parent | (Inherited from DataObjectBase.)
Protected field | _precision | (Inherited from DataObjectBase.)
Protected field | _scale | (Inherited from DataObjectBase.)
Protected field | _size | (Inherited from DataObjectBase.)
Top
See Also

Reference

ParameterSchema Class
SchemaExplorer Namespace


ParameterSchemaCollection Class

Implements a strongly typed collection of ParameterSchema elements.
Inheritance Hierarchy
SystemObject
ObservableListParameterSchema
NamedObjectCollectionParameterSchema
SchemaExplorerSchemaObjectCollection ParameterSchema
SchemaExplorerParameterSchemaCollection

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
public class ParameterSchemaCollection : SchemaObjectCollection<ParameterSchema>
<SerializableAttribute>
Public Class ParameterSchemaCollection
    Inherits SchemaObjectCollection(Of ParameterSchema)

The ParameterSchemaCollection type exposes the following members.

Constructors
 | Name | Description
Public method | ParameterSchemaCollection | Initializes a new instance of the ParameterSchemaCollection class.
Public method | ParameterSchemaCollection(IEnumerableParameterSchema) | Initializes a new instance of the ParameterSchemaCollection class.
Public method | ParameterSchemaCollection(Int32) | Initializes a new instance of the ParameterSchemaCollection class.
Top
Methods
 | Name | Description
Public method | Clone | (Inherited from SchemaObjectCollectionT.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh | (Inherited from SchemaObjectCollectionT.)
Public method | ToString | (Inherited from SchemaObjectCollectionT.)
Top
Remarks
ParameterSchemaCollection provides an SchemaObjectCollectionT that is strongly typed for ParameterSchema elements.
See Also

Reference

SchemaExplorer Namespace


ParameterSchemaCollection Constructor

Overload List
 | Name | Description
Public method | ParameterSchemaCollection | Initializes a new instance of the ParameterSchemaCollection class.
Public method | ParameterSchemaCollection(IEnumerableParameterSchema) | Initializes a new instance of the ParameterSchemaCollection class.
Public method | ParameterSchemaCollection(Int32) | Initializes a new instance of the ParameterSchemaCollection class.
Top
See Also

Reference

ParameterSchemaCollection Class
SchemaExplorer Namespace


ParameterSchemaCollection Constructor

Initializes a new instance of the ParameterSchemaCollection class.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ParameterSchemaCollection()
Public Sub New
See Also

Reference

ParameterSchemaCollection Class
ParameterSchemaCollection Overload
SchemaExplorer Namespace


ParameterSchemaCollection Constructor (IEnumerable(ParameterSchema))

ParameterSchemaCollection Constructor (IEnumerableParameterSchema)

Initializes a new instance of the ParameterSchemaCollection class.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ParameterSchemaCollection(
    IEnumerable<ParameterSchema> collection
)
Public Sub New (
    collection As IEnumerable(Of ParameterSchema)
)

Parameters

collection
Type: System.Collections.GenericIEnumerable ParameterSchema
The collection from which the elements are copied.
See Also

Reference

ParameterSchemaCollection Class
ParameterSchemaCollection Overload
SchemaExplorer Namespace


ParameterSchemaCollection Constructor (Int32)

Initializes a new instance of the ParameterSchemaCollection class.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ParameterSchemaCollection(
    int capacity
)
Public Sub New (
    capacity As Integer
)

Parameters

capacity
Type: SystemInt32
The number of elements that the new list can initially store.
See Also

Reference

ParameterSchemaCollection Class
ParameterSchemaCollection Overload
SchemaExplorer Namespace


ParameterSchemaCollection Methods

The ParameterSchemaCollection type exposes the following members.

Methods
 | Name | Description
Public method | Clone | (Inherited from SchemaObjectCollectionT.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh | (Inherited from SchemaObjectCollectionT.)
Public method | ToString | (Inherited from SchemaObjectCollectionT.)
Top
See Also

Reference

ParameterSchemaCollection Class
SchemaExplorer Namespace


PrimaryKeySchema Class

Provides information about a table primary key.
Inheritance Hierarchy
SystemObject
NamedObjectBase
SchemaExplorerSchemaObjectBase
SchemaExplorerPrimaryKeySchema

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
public class PrimaryKeySchema : SchemaObjectBase,
    IPrimaryKeySchema, ISchemaObject
<SerializableAttribute>
Public Class PrimaryKeySchema
    Inherits SchemaObjectBase
    Implements IPrimaryKeySchema, ISchemaObject

The PrimaryKeySchema type exposes the following members.

Constructors
 | Name | Description
Public method | PrimaryKeySchema(TableSchema, String) | Initializes a new instance of the PrimaryKeySchema class
Public method | PrimaryKeySchema(TableSchema, String, ExtendedProperty) | Initializes a new instance of the PrimaryKeySchema class
Public method | PrimaryKeySchema(TableSchema, String, IEnumerableString) | Initializes a new instance of the PrimaryKeySchema class
Public method | PrimaryKeySchema(TableSchema, String, IEnumerableString, ExtendedProperty) | Initializes a new instance of the PrimaryKeySchema class
Top
Properties
 | Name | Description
Public property | Database | Allows access to the DatabaseSchema object that contains this schema object. (Inherited from SchemaObjectBase.)
Public property | DateCreated | Returns the date this table was created. (Inherited from SchemaObjectBase.)
Public property | DeepLoad | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from SchemaObjectBase.)
Public property | Description | The description of the object. (Inherited from SchemaObjectBase.)
Public property | ExtendedProperties | Used to store any additional information about the schema object. (Inherited from SchemaObjectBase.)
Public property | FullName | Returns the owner and name of the table. (Inherited from SchemaObjectBase.)
Public property | IncludeFunctions | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from SchemaObjectBase.)
Public property | MemberColumns | The primary key's member columns.
Public property | SortName | Gets the name used to sort in 'Table (Owner)' format. (Inherited from SchemaObjectBase.)
Public property | Table | The table that contains this primary key.
Top
Methods
 | Name | Description
Public method | Equals | Determines if another primary key is the same as this primary key. (Overrides SchemaObjectBaseEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns a hashcode based on the database, table and name of the primary key. (Overrides SchemaObjectBaseGetHashCode.)
Public method | GetLoadedExtendedProperties | Gets the existing ExtendedProperties without causing a lazy load. (Inherited from SchemaObjectBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MarkLoaded | (Inherited from SchemaObjectBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh | (Overrides SchemaObjectBaseRefresh.)
Top
Fields
 | Name | Description
Protected field | _database | (Inherited from SchemaObjectBase.)
Protected field | _dateCreated | (Inherited from SchemaObjectBase.)
Protected field | _defaultExtendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _extendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _gotExtendedProperties | (Inherited from SchemaObjectBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Selected | Determines if the specified item is selected using the rules defined in SchemaSelector. All tables and columns that are part of the key need to be selected for the key to be considered selected. (Defined by SchemaSelectorExtensions.)
Top
See Also

Reference

SchemaExplorer Namespace


PrimaryKeySchema Constructor

Overload List
 | Name | Description
Public method | PrimaryKeySchema(TableSchema, String) | Initializes a new instance of the PrimaryKeySchema class
Public method | PrimaryKeySchema(TableSchema, String, ExtendedProperty) | Initializes a new instance of the PrimaryKeySchema class
Public method | PrimaryKeySchema(TableSchema, String, IEnumerableString) | Initializes a new instance of the PrimaryKeySchema class
Public method | PrimaryKeySchema(TableSchema, String, IEnumerableString, ExtendedProperty) | Initializes a new instance of the PrimaryKeySchema class
Top
See Also

Reference

PrimaryKeySchema Class
SchemaExplorer Namespace


PrimaryKeySchema Constructor (TableSchema, String)

Initializes a new instance of the PrimaryKeySchema class

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public PrimaryKeySchema(
    TableSchema table,
    string name
)
Public Sub New (
    table As TableSchema,
    name As String
)

Parameters

table
Type: SchemaExplorerTableSchema
name
Type: SystemString
See Also

Reference

PrimaryKeySchema Class
PrimaryKeySchema Overload
SchemaExplorer Namespace


PrimaryKeySchema Constructor (TableSchema, String, ExtendedProperty[])

PrimaryKeySchema Constructor (TableSchema, String, ExtendedProperty)

Initializes a new instance of the PrimaryKeySchema class

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public PrimaryKeySchema(
    TableSchema table,
    string name,
    ExtendedProperty[] extendedProperties
)
Public Sub New (
    table As TableSchema,
    name As String,
    extendedProperties As ExtendedProperty()
)

Parameters

table
Type: SchemaExplorerTableSchema
name
Type: SystemString
extendedProperties
Type: SchemaExplorerExtendedProperty
See Also

Reference

PrimaryKeySchema Class
PrimaryKeySchema Overload
SchemaExplorer Namespace


PrimaryKeySchema Constructor (TableSchema, String, IEnumerable(String))

PrimaryKeySchema Constructor (TableSchema, String, IEnumerableString)

Initializes a new instance of the PrimaryKeySchema class

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public PrimaryKeySchema(
    TableSchema table,
    string name,
    IEnumerable<string> memberColumns
)
Public Sub New (
    table As TableSchema,
    name As String,
    memberColumns As IEnumerable(Of String)
)

Parameters

table
Type: SchemaExplorerTableSchema
name
Type: SystemString
memberColumns
Type: System.Collections.GenericIEnumerable String
See Also

Reference

PrimaryKeySchema Class
PrimaryKeySchema Overload
SchemaExplorer Namespace


PrimaryKeySchema Constructor (TableSchema, String, IEnumerable(String), ExtendedProperty[])

PrimaryKeySchema Constructor (TableSchema, String, IEnumerableString, ExtendedProperty)

Initializes a new instance of the PrimaryKeySchema class

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public PrimaryKeySchema(
    TableSchema table,
    string name,
    IEnumerable<string> memberColumns,
    ExtendedProperty[] extendedProperties
)
Public Sub New (
    table As TableSchema,
    name As String,
    memberColumns As IEnumerable(Of String),
    extendedProperties As ExtendedProperty()
)

Parameters

table
Type: SchemaExplorerTableSchema
name
Type: SystemString
memberColumns
Type: System.Collections.GenericIEnumerable String
extendedProperties
Type: SchemaExplorerExtendedProperty
See Also

Reference

PrimaryKeySchema Class
PrimaryKeySchema Overload
SchemaExplorer Namespace


PrimaryKeySchema Properties

The PrimaryKeySchema type exposes the following members.

Properties
 | Name | Description
Public property | Database | Allows access to the DatabaseSchema object that contains this schema object. (Inherited from SchemaObjectBase.)
Public property | DateCreated | Returns the date this table was created. (Inherited from SchemaObjectBase.)
Public property | DeepLoad | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from SchemaObjectBase.)
Public property | Description | The description of the object. (Inherited from SchemaObjectBase.)
Public property | ExtendedProperties | Used to store any additional information about the schema object. (Inherited from SchemaObjectBase.)
Public property | FullName | Returns the owner and name of the table. (Inherited from SchemaObjectBase.)
Public property | IncludeFunctions | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from SchemaObjectBase.)
Public property | MemberColumns | The primary key's member columns.
Public property | SortName | Gets the name used to sort in 'Table (Owner)' format. (Inherited from SchemaObjectBase.)
Public property | Table | The table that contains this primary key.
Top
See Also

Reference

PrimaryKeySchema Class
SchemaExplorer Namespace


PrimaryKeySchema.MemberColumns Property

PrimaryKeySchemaMemberColumns Property

The primary key's member columns.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public MemberColumnSchemaCollection MemberColumns { get; }
Public ReadOnly Property MemberColumns As MemberColumnSchemaCollection
    Get

Property Value

Type: MemberColumnSchemaCollection
See Also

Reference

PrimaryKeySchema Class
SchemaExplorer Namespace


PrimaryKeySchema.Table Property

PrimaryKeySchemaTable Property

The table that contains this primary key.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public TableSchema Table { get; }
Public ReadOnly Property Table As TableSchema
    Get

Property Value

Type: TableSchema
See Also

Reference

PrimaryKeySchema Class
SchemaExplorer Namespace


PrimaryKeySchema Methods

The PrimaryKeySchema type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines if another primary key is the same as this primary key. (Overrides SchemaObjectBaseEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns a hashcode based on the database, table and name of the primary key. (Overrides SchemaObjectBaseGetHashCode.)
Public method | GetLoadedExtendedProperties | Gets the existing ExtendedProperties without causing a lazy load. (Inherited from SchemaObjectBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MarkLoaded | (Inherited from SchemaObjectBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh | (Overrides SchemaObjectBaseRefresh.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Selected | Determines if the specified item is selected using the rules defined in SchemaSelector. All tables and columns that are part of the key need to be selected for the key to be considered selected. (Defined by SchemaSelectorExtensions.)
Top
See Also

Reference

PrimaryKeySchema Class
SchemaExplorer Namespace


PrimaryKeySchema.Equals Method

PrimaryKeySchemaEquals Method

Determines if another primary key is the same as this primary key.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
The primary key to check against.

Return Value

Type: Boolean
true/false
See Also

Reference

PrimaryKeySchema Class
SchemaExplorer Namespace


PrimaryKeySchema.GetHashCode Method

PrimaryKeySchemaGetHashCode Method

Returns a hashcode based on the database, table and name of the primary key.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
See Also

Reference

PrimaryKeySchema Class
SchemaExplorer Namespace


PrimaryKeySchema.Refresh Method

PrimaryKeySchemaRefresh Method

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override void Refresh()
Public Overrides Sub Refresh

Implements

ISchemaObjectRefresh
ISchemaObjectRefresh
See Also

Reference

PrimaryKeySchema Class
SchemaExplorer Namespace


PrimaryKeySchema Fields

The PrimaryKeySchema type exposes the following members.

Fields
 | Name | Description
Protected field | _database | (Inherited from SchemaObjectBase.)
Protected field | _dateCreated | (Inherited from SchemaObjectBase.)
Protected field | _defaultExtendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _extendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _gotExtendedProperties | (Inherited from SchemaObjectBase.)
Top
See Also

Reference

PrimaryKeySchema Class
SchemaExplorer Namespace


PropertyComparer Class

Inheritance Hierarchy
SystemObject
SchemaExplorerPropertyComparer
SchemaExplorerPropertyComparerT

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class PropertyComparer : IComparer,
    IEqualityComparer
Public Class PropertyComparer
    Implements IComparer, IEqualityComparer

The PropertyComparer type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyComparer(SortExpression) | Initializes a new instance of the PropertyComparer class
Public method | PropertyComparer(String) | Initializes a new instance of the PropertyComparer class
Public method | PropertyComparer(String, ListSortDirection) | Initializes a new instance of the PropertyComparer class
Top
Properties
 | Name | Description
Public property | SortExpressions |
Top
Methods
 | Name | Description
Public method | Compare |
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Equals(Object, Object) |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetHashCode(Object) |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SchemaExplorer Namespace


PropertyComparer Constructor

Overload List
 | Name | Description
Public method | PropertyComparer(SortExpression) | Initializes a new instance of the PropertyComparer class
Public method | PropertyComparer(String) | Initializes a new instance of the PropertyComparer class
Public method | PropertyComparer(String, ListSortDirection) | Initializes a new instance of the PropertyComparer class
Top
See Also

Reference

PropertyComparer Class
SchemaExplorer Namespace


PropertyComparer Constructor (SortExpression[])

PropertyComparer Constructor (SortExpression)

Initializes a new instance of the PropertyComparer class

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public PropertyComparer(
    SortExpression[] sortExpressions
)
Public Sub New (
    sortExpressions As SortExpression()
)

Parameters

sortExpressions
Type: SchemaExplorerSortExpression
See Also

Reference

PropertyComparer Class
PropertyComparer Overload
SchemaExplorer Namespace


PropertyComparer Constructor (String)

Initializes a new instance of the PropertyComparer class

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public PropertyComparer(
    string orderByClause
)
Public Sub New (
    orderByClause As String
)

Parameters

orderByClause
Type: SystemString
See Also

Reference

PropertyComparer Class
PropertyComparer Overload
SchemaExplorer Namespace


PropertyComparer Constructor (String, ListSortDirection)

Initializes a new instance of the PropertyComparer class

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public PropertyComparer(
    string propertyName,
    ListSortDirection sortDirection
)
Public Sub New (
    propertyName As String,
    sortDirection As ListSortDirection
)

Parameters

propertyName
Type: SystemString
sortDirection
Type: System.ComponentModelListSortDirection
See Also

Reference

PropertyComparer Class
PropertyComparer Overload
SchemaExplorer Namespace


PropertyComparer Properties

The PropertyComparer type exposes the following members.

Properties
 | Name | Description
Public property | SortExpressions |
Top
See Also

Reference

PropertyComparer Class
SchemaExplorer Namespace


PropertyComparer.SortExpressions Property

PropertyComparerSortExpressions Property

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public SortExpression[] SortExpressions { get; set; }
Public Property SortExpressions As SortExpression()
    Get
    Set

Property Value

Type: SortExpression
See Also

Reference

PropertyComparer Class
SchemaExplorer Namespace


PropertyComparer Methods

The PropertyComparer type exposes the following members.

Methods
 | Name | Description
Public method | Compare |
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Equals(Object, Object) |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetHashCode(Object) |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PropertyComparer Class
SchemaExplorer Namespace


PropertyComparer.Compare Method

PropertyComparerCompare Method

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public int Compare(
    Object a,
    Object b
)
Public Function Compare (
    a As Object,
    b As Object
) As Integer

Parameters

a
Type: SystemObject
b
Type: SystemObject

Return Value

Type: Int32

Implements

IComparerCompare(Object, Object)
See Also

Reference

PropertyComparer Class
SchemaExplorer Namespace


PropertyComparer.Equals Method

PropertyComparerEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Equals(Object, Object) |
Top
See Also

Reference

PropertyComparer Class
SchemaExplorer Namespace


PropertyComparer.Equals Method (Object, Object)

PropertyComparerEquals Method (Object, Object)

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool Equals(
    Object x,
    Object y
)
Public Function Equals (
    x As Object,
    y As Object
) As Boolean

Parameters

x
Type: SystemObject
y
Type: SystemObject

Return Value

Type: Boolean

Implements

IEqualityComparerEquals(Object, Object)
See Also

Reference

PropertyComparer Class
Equals Overload
SchemaExplorer Namespace


PropertyComparer.GetHashCode Method

PropertyComparerGetHashCode Method

Overload List
 | Name | Description
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetHashCode(Object) |
Top
See Also

Reference

PropertyComparer Class
SchemaExplorer Namespace


PropertyComparer.GetHashCode Method (Object)

PropertyComparerGetHashCode Method (Object)

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public int GetHashCode(
    Object obj
)
Public Function GetHashCode (
    obj As Object
) As Integer

Parameters

obj
Type: SystemObject

Return Value

Type: Int32

Implements

IEqualityComparerGetHashCode(Object)
See Also

Reference

PropertyComparer Class
GetHashCode Overload
SchemaExplorer Namespace


PropertyComparer(T) Class

PropertyComparerT Class

Inheritance Hierarchy
SystemObject
SchemaExplorerPropertyComparer
SchemaExplorerPropertyComparerT

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class PropertyComparer<T> : PropertyComparer,
    IComparer<T>, IEqualityComparer<T>

Public Class PropertyComparer(Of T)
    Inherits PropertyComparer
    Implements IComparer(Of T), IEqualityComparer(Of T)

Type Parameters

T

The PropertyComparerT type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyComparerT(SortExpression) | Initializes a new instance of the PropertyComparerT class
Public method | PropertyComparerT(String) | Initializes a new instance of the PropertyComparerT class
Public method | PropertyComparerT(String, ListSortDirection) | Initializes a new instance of the PropertyComparerT class
Top
Properties
 | Name | Description
Public property | SortExpressions | (Inherited from PropertyComparer.)
Top
Methods
 | Name | Description
Public method | Compare(Object, Object) | (Inherited from PropertyComparer.)
Public method | Compare(T, T) |
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Equals(Object, Object) | (Inherited from PropertyComparer.)
Public method | Equals(T, T) |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetHashCode(Object) | (Inherited from PropertyComparer.)
Public method | GetHashCode(T) |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SchemaExplorer Namespace


PropertyComparer(T) Constructor

PropertyComparerT Constructor

Overload List
 | Name | Description
Public method | PropertyComparerT(SortExpression) | Initializes a new instance of the PropertyComparerT class
Public method | PropertyComparerT(String) | Initializes a new instance of the PropertyComparerT class
Public method | PropertyComparerT(String, ListSortDirection) | Initializes a new instance of the PropertyComparerT class
Top
See Also

Reference

PropertyComparerT Class
SchemaExplorer Namespace


PropertyComparer(T) Constructor (SortExpression[])

PropertyComparerT Constructor (SortExpression)

Initializes a new instance of the PropertyComparerT class

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public PropertyComparer(
    SortExpression[] sortExpressions
)
Public Sub New (
    sortExpressions As SortExpression()
)

Parameters

sortExpressions
Type: SchemaExplorerSortExpression
See Also

Reference

PropertyComparerT Class
PropertyComparerT Overload
SchemaExplorer Namespace


PropertyComparer(T) Constructor (String)

PropertyComparerT Constructor (String)

Initializes a new instance of the PropertyComparerT class

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public PropertyComparer(
    string orderByClause
)
Public Sub New (
    orderByClause As String
)

Parameters

orderByClause
Type: SystemString
See Also

Reference

PropertyComparerT Class
PropertyComparerT Overload
SchemaExplorer Namespace


PropertyComparer(T) Constructor (String, ListSortDirection)

PropertyComparerT Constructor (String, ListSortDirection)

Initializes a new instance of the PropertyComparerT class

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public PropertyComparer(
    string propertyName,
    ListSortDirection sortDirection
)
Public Sub New (
    propertyName As String,
    sortDirection As ListSortDirection
)

Parameters

propertyName
Type: SystemString
sortDirection
Type: System.ComponentModelListSortDirection
See Also

Reference

PropertyComparerT Class
PropertyComparerT Overload
SchemaExplorer Namespace


PropertyComparer(T) Properties

PropertyComparerT Properties

The PropertyComparerT generic type exposes the following members.

Properties
 | Name | Description
Public property | SortExpressions | (Inherited from PropertyComparer.)
Top
See Also

Reference

PropertyComparerT Class
SchemaExplorer Namespace


PropertyComparer(T) Methods

PropertyComparerT Methods

The PropertyComparerT generic type exposes the following members.

Methods
 | Name | Description
Public method | Compare(Object, Object) | (Inherited from PropertyComparer.)
Public method | Compare(T, T) |
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Equals(Object, Object) | (Inherited from PropertyComparer.)
Public method | Equals(T, T) |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetHashCode(Object) | (Inherited from PropertyComparer.)
Public method | GetHashCode(T) |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PropertyComparerT Class
SchemaExplorer Namespace


PropertyComparer(T).Compare Method

PropertyComparerTCompare Method

Overload List
 | Name | Description
Public method | Compare(Object, Object) | (Inherited from PropertyComparer.)
Public method | Compare(T, T) |
Top
See Also

Reference

PropertyComparerT Class
SchemaExplorer Namespace


PropertyComparer(T).Compare Method (T, T)

PropertyComparerTCompare Method (T, T)

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public int Compare(
    T x,
    T y
)
Public Function Compare (
    x As T,
    y As T
) As Integer

Parameters

x
Type: T
y
Type: T

Return Value

Type: Int32

Implements

IComparerTCompare(T, T)
See Also

Reference

PropertyComparerT Class
Compare Overload
SchemaExplorer Namespace


PropertyComparer(T).Equals Method

PropertyComparerTEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Equals(Object, Object) | (Inherited from PropertyComparer.)
Public method | Equals(T, T) |
Top
See Also

Reference

PropertyComparerT Class
SchemaExplorer Namespace


PropertyComparer(T).Equals Method (T, T)

PropertyComparerTEquals Method (T, T)

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool Equals(
    T x,
    T y
)
Public Function Equals (
    x As T,
    y As T
) As Boolean

Parameters

x
Type: T
y
Type: T

Return Value

Type: Boolean

Implements

IEqualityComparerTEquals(T, T)
See Also

Reference

PropertyComparerT Class
Equals Overload
SchemaExplorer Namespace


PropertyComparer(T).GetHashCode Method

PropertyComparerTGetHashCode Method

Overload List
 | Name | Description
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetHashCode(Object) | (Inherited from PropertyComparer.)
Public method | GetHashCode(T) |
Top
See Also

Reference

PropertyComparerT Class
SchemaExplorer Namespace


PropertyComparer(T).GetHashCode Method (T)

PropertyComparerTGetHashCode Method (T)

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public int GetHashCode(
    T obj
)
Public Function GetHashCode (
    obj As T
) As Integer

Parameters

obj
Type: T

Return Value

Type: Int32

Implements

IEqualityComparerTGetHashCode(T)
See Also

Reference

PropertyComparerT Class
GetHashCode Overload
SchemaExplorer Namespace


PropertyStateEnum Enumeration

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public enum PropertyStateEnum
Public Enumeration PropertyStateEnum
Members
Member name | Value | Description
Unmodified | 0 |
Dirty | 1 |
New | 2 |
Deleted | 3 |
ReadOnly | 4 |
See Also

Reference

SchemaExplorer Namespace


SchemaObjectBase Class

Provides a base for all schema objects to derive from.
Inheritance Hierarchy
SystemObject
NamedObjectBase
SchemaExplorerSchemaObjectBase
More...

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
[TypeConverterAttribute(typeof(SchemaObjectFactoryTypeConverter))]
public abstract class SchemaObjectBase : NamedObjectBase,
    ISchemaObject
<SerializableAttribute>
<TypeConverterAttribute(GetType(SchemaObjectFactoryTypeConverter))>
Public MustInherit Class SchemaObjectBase
    Inherits NamedObjectBase
    Implements ISchemaObject

The SchemaObjectBase type exposes the following members.

Constructors
 | Name | Description
Public method | SchemaObjectBase(DatabaseSchema, String) | Initializes a new instance of the SchemaObjectBase class
Public method | SchemaObjectBase(DatabaseSchema, String, ExtendedProperty) | Initializes a new instance of the SchemaObjectBase class
Public method | SchemaObjectBase(DatabaseSchema, String, DateTime) | Initializes a new instance of the SchemaObjectBase class
Public method | SchemaObjectBase(DatabaseSchema, String, DateTime, ExtendedProperty) | Initializes a new instance of the SchemaObjectBase class
Top
Properties
 | Name | Description
Public property | Database | Allows access to the DatabaseSchema object that contains this schema object.
Public property | DateCreated | Returns the date this table was created.
Public property | DeepLoad | Gets or sets a value indicating this schema object and all its children will be loaded.
Public property | Description | The description of the object.
Public property | ExtendedProperties | Used to store any additional information about the schema object.
Public property | FullName | Returns the owner and name of the table.
Public property | IncludeFunctions | Gets or sets a value indicating this schema object and all its children will be loaded.
Public property | SortName | Gets the name used to sort in 'Table (Owner)' format.
Top
Methods
 | Name | Description
Public method | Equals | Determines if another table is the same as this table. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FormatFullName | Formats the full name.
Public method | GetHashCode | Returns a HashCode based on the database and name of the table. (Overrides ObjectGetHashCode.)
Public method | GetLoadedExtendedProperties | Gets the existing ExtendedProperties without causing a lazy load.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MarkLoaded |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh | Allows the object to be refreshed.
Top
Fields
 | Name | Description
Protected field | _database |
Protected field | _dateCreated |
Protected field | _defaultExtendedProperties |
Protected field | _extendedProperties |
Protected field | _gotExtendedProperties |
Top
See Also

Reference

SchemaExplorer Namespace
Inheritance Hierarchy
SystemObject
NamedObjectBase
SchemaExplorerSchemaObjectBase
SchemaExplorerDatabaseSchema
SchemaExplorerDataObjectBase
SchemaExplorerIndexSchema
SchemaExplorerPrimaryKeySchema
SchemaExplorerSchemaObjectWithOwnerBase
SchemaExplorerTableKeySchema


SchemaObjectBase Constructor

Overload List
 | Name | Description
Public method | SchemaObjectBase(DatabaseSchema, String) | Initializes a new instance of the SchemaObjectBase class
Public method | SchemaObjectBase(DatabaseSchema, String, ExtendedProperty) | Initializes a new instance of the SchemaObjectBase class
Public method | SchemaObjectBase(DatabaseSchema, String, DateTime) | Initializes a new instance of the SchemaObjectBase class
Public method | SchemaObjectBase(DatabaseSchema, String, DateTime, ExtendedProperty) | Initializes a new instance of the SchemaObjectBase class
Top
See Also

Reference

SchemaObjectBase Class
SchemaExplorer Namespace


SchemaObjectBase Constructor (DatabaseSchema, String)

Initializes a new instance of the SchemaObjectBase class

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public SchemaObjectBase(
    DatabaseSchema database,
    string name
)
Public Sub New (
    database As DatabaseSchema,
    name As String
)

Parameters

database
Type: SchemaExplorerDatabaseSchema
name
Type: SystemString
See Also

Reference

SchemaObjectBase Class
SchemaObjectBase Overload
SchemaExplorer Namespace


SchemaObjectBase Constructor (DatabaseSchema, String, ExtendedProperty[])

SchemaObjectBase Constructor (DatabaseSchema, String, ExtendedProperty)

Initializes a new instance of the SchemaObjectBase class

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public SchemaObjectBase(
    DatabaseSchema database,
    string name,
    ExtendedProperty[] extendedProperties
)
Public Sub New (
    database As DatabaseSchema,
    name As String,
    extendedProperties As ExtendedProperty()
)

Parameters

database
Type: SchemaExplorerDatabaseSchema
name
Type: SystemString
extendedProperties
Type: SchemaExplorerExtendedProperty
See Also

Reference

SchemaObjectBase Class
SchemaObjectBase Overload
SchemaExplorer Namespace


SchemaObjectBase Constructor (DatabaseSchema, String, DateTime)

Initializes a new instance of the SchemaObjectBase class

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public SchemaObjectBase(
    DatabaseSchema database,
    string name,
    DateTime dateCreated
)
Public Sub New (
    database As DatabaseSchema,
    name As String,
    dateCreated As DateTime
)

Parameters

database
Type: SchemaExplorerDatabaseSchema
name
Type: SystemString
dateCreated
Type: SystemDateTime
See Also

Reference

SchemaObjectBase Class
SchemaObjectBase Overload
SchemaExplorer Namespace


SchemaObjectBase Constructor (DatabaseSchema, String, DateTime, ExtendedProperty[])

SchemaObjectBase Constructor (DatabaseSchema, String, DateTime, ExtendedProperty)

Initializes a new instance of the SchemaObjectBase class

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public SchemaObjectBase(
    DatabaseSchema database,
    string name,
    DateTime dateCreated,
    ExtendedProperty[] extendedProperties
)
Public Sub New (
    database As DatabaseSchema,
    name As String,
    dateCreated As DateTime,
    extendedProperties As ExtendedProperty()
)

Parameters

database
Type: SchemaExplorerDatabaseSchema
name
Type: SystemString
dateCreated
Type: SystemDateTime
extendedProperties
Type: SchemaExplorerExtendedProperty
See Also

Reference

SchemaObjectBase Class
SchemaObjectBase Overload
SchemaExplorer Namespace


SchemaObjectBase Properties

The SchemaObjectBase type exposes the following members.

Properties
 | Name | Description
Public property | Database | Allows access to the DatabaseSchema object that contains this schema object.
Public property | DateCreated | Returns the date this table was created.
Public property | DeepLoad | Gets or sets a value indicating this schema object and all its children will be loaded.
Public property | Description | The description of the object.
Public property | ExtendedProperties | Used to store any additional information about the schema object.
Public property | FullName | Returns the owner and name of the table.
Public property | IncludeFunctions | Gets or sets a value indicating this schema object and all its children will be loaded.
Public property | SortName | Gets the name used to sort in 'Table (Owner)' format.
Top
See Also

Reference

SchemaObjectBase Class
SchemaExplorer Namespace


SchemaObjectBase.Database Property

SchemaObjectBaseDatabase Property

Allows access to the DatabaseSchema object that contains this schema object.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual DatabaseSchema Database { get; }
Public Overridable ReadOnly Property Database As DatabaseSchema
    Get

Property Value

Type: DatabaseSchema
See Also

Reference

SchemaObjectBase Class
SchemaExplorer Namespace


SchemaObjectBase.DateCreated Property

SchemaObjectBaseDateCreated Property

Returns the date this table was created.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public DateTime DateCreated { get; }
Public ReadOnly Property DateCreated As DateTime
    Get

Property Value

Type: DateTime

Implements

ISchemaObjectDateCreated
See Also

Reference

SchemaObjectBase Class
SchemaExplorer Namespace


SchemaObjectBase.DeepLoad Property

SchemaObjectBaseDeepLoad Property

Gets or sets a value indicating this schema object and all its children will be loaded.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool DeepLoad { get; set; }
Public Property DeepLoad As Boolean
    Get
    Set

Property Value

Type: Boolean
true if deep load; otherwise, false.

Implements

ISchemaObjectDeepLoad
See Also

Reference

SchemaObjectBase Class
SchemaExplorer Namespace


SchemaObjectBase.Description Property

SchemaObjectBaseDescription Property

The description of the object.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual string Description { get; set; }
Public Overridable Property Description As String
    Get
    Set

Property Value

Type: String

Implements

ISchemaObjectDescription
See Also

Reference

SchemaObjectBase Class
SchemaExplorer Namespace


SchemaObjectBase.ExtendedProperties Property

SchemaObjectBaseExtendedProperties Property

Used to store any additional information about the schema object.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual ExtendedPropertyCollection ExtendedProperties { get; protected set; }
Public Overridable Property ExtendedProperties As ExtendedPropertyCollection
    Get
    Protected Set

Property Value

Type: ExtendedPropertyCollection
See Also

Reference

SchemaObjectBase Class
SchemaExplorer Namespace


SchemaObjectBase.FullName Property

SchemaObjectBaseFullName Property

Returns the owner and name of the table.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual string FullName { get; }
Public Overridable ReadOnly Property FullName As String
    Get

Return Value

Type: String

Implements

ISchemaObjectFullName
See Also

Reference

SchemaObjectBase Class
SchemaExplorer Namespace


SchemaObjectBase.IncludeFunctions Property

SchemaObjectBaseIncludeFunctions Property

Gets or sets a value indicating this schema object and all its children will be loaded.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool IncludeFunctions { get; set; }
Public Property IncludeFunctions As Boolean
    Get
    Set

Property Value

Type: Boolean
true if functions should be included; otherwise, false.

Implements

ISchemaObjectIncludeFunctions
See Also

Reference

SchemaObjectBase Class
SchemaExplorer Namespace


SchemaObjectBase.SortName Property

SchemaObjectBaseSortName Property

Gets the name used to sort in 'Table (Owner)' format.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual string SortName { get; }
Public Overridable ReadOnly Property SortName As String
    Get

Property Value

Type: String
The name used to sort.

Implements

ISchemaObjectSortName
See Also

Reference

SchemaObjectBase Class
SchemaExplorer Namespace


SchemaObjectBase Methods

The SchemaObjectBase type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines if another table is the same as this table. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FormatFullName | Formats the full name.
Public method | GetHashCode | Returns a HashCode based on the database and name of the table. (Overrides ObjectGetHashCode.)
Public method | GetLoadedExtendedProperties | Gets the existing ExtendedProperties without causing a lazy load.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MarkLoaded |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh | Allows the object to be refreshed.
Top
See Also

Reference

SchemaObjectBase Class
SchemaExplorer Namespace


SchemaObjectBase.Equals Method

SchemaObjectBaseEquals Method

Determines if another table is the same as this table.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
The table to check against.

Return Value

Type: Boolean
true/false
See Also

Reference

SchemaObjectBase Class
SchemaExplorer Namespace


SchemaObjectBase.FormatFullName Method

SchemaObjectBaseFormatFullName Method

Formats the full name.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static string FormatFullName(
    string owner,
    string name
)
Public Shared Function FormatFullName (
    owner As String,
    name As String
) As String

Parameters

owner
Type: SystemString
The owner.
name
Type: SystemString
The name.

Return Value

Type: String
See Also

Reference

SchemaObjectBase Class
SchemaExplorer Namespace


SchemaObjectBase.GetHashCode Method

SchemaObjectBaseGetHashCode Method

Returns a HashCode based on the database and name of the table.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
See Also

Reference

SchemaObjectBase Class
SchemaExplorer Namespace


SchemaObjectBase.GetLoadedExtendedProperties Method

SchemaObjectBaseGetLoadedExtendedProperties Method

Gets the existing ExtendedProperties without causing a lazy load.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ExtendedPropertyCollection GetLoadedExtendedProperties()
Public Function GetLoadedExtendedProperties As ExtendedPropertyCollection

Return Value

Type: ExtendedPropertyCollection
See Also

Reference

SchemaObjectBase Class
SchemaExplorer Namespace


SchemaObjectBase.MarkLoaded Method

SchemaObjectBaseMarkLoaded Method

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual void MarkLoaded()
Public Overridable Sub MarkLoaded
See Also

Reference

SchemaObjectBase Class
SchemaExplorer Namespace


SchemaObjectBase.Refresh Method

SchemaObjectBaseRefresh Method

Allows the object to be refreshed.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual void Refresh()
Public Overridable Sub Refresh

Implements

ISchemaObjectRefresh
See Also

Reference

SchemaObjectBase Class
SchemaExplorer Namespace


SchemaObjectBase Fields

The SchemaObjectBase type exposes the following members.

Fields
 | Name | Description
Protected field | _database |
Protected field | _dateCreated |
Protected field | _defaultExtendedProperties |
Protected field | _extendedProperties |
Protected field | _gotExtendedProperties |
Top
See Also

Reference

SchemaObjectBase Class
SchemaExplorer Namespace


SchemaObjectBase._database Field

SchemaObjectBase_database Field

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected DatabaseSchema _database
Protected _database As DatabaseSchema

Field Value

Type: DatabaseSchema
See Also

Reference

SchemaObjectBase Class
SchemaExplorer Namespace


SchemaObjectBase._dateCreated Field

SchemaObjectBase_dateCreated Field

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected readonly DateTime _dateCreated
Protected ReadOnly _dateCreated As DateTime

Field Value

Type: DateTime
See Also

Reference

SchemaObjectBase Class
SchemaExplorer Namespace


SchemaObjectBase._defaultExtendedProperties Field

SchemaObjectBase_defaultExtendedProperties Field

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected ExtendedProperty[] _defaultExtendedProperties
Protected _defaultExtendedProperties As ExtendedProperty()

Field Value

Type: ExtendedProperty
See Also

Reference

SchemaObjectBase Class
SchemaExplorer Namespace


SchemaObjectBase._extendedProperties Field

SchemaObjectBase_extendedProperties Field

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected ExtendedPropertyCollection _extendedProperties
Protected _extendedProperties As ExtendedPropertyCollection

Field Value

Type: ExtendedPropertyCollection
See Also

Reference

SchemaObjectBase Class
SchemaExplorer Namespace


SchemaObjectBase._gotExtendedProperties Field

SchemaObjectBase_gotExtendedProperties Field

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected bool _gotExtendedProperties
Protected _gotExtendedProperties As Boolean

Field Value

Type: Boolean
See Also

Reference

SchemaObjectBase Class
SchemaExplorer Namespace


SchemaObjectBaseCollection Class

Inheritance Hierarchy
SystemObject
ObservableListISchemaObject
NamedObjectCollectionISchemaObject
SchemaExplorerSchemaObjectCollection ISchemaObject
SchemaExplorerSchemaObjectBaseCollection

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
public class SchemaObjectBaseCollection : SchemaObjectCollection<ISchemaObject>
<SerializableAttribute>
Public Class SchemaObjectBaseCollection
    Inherits SchemaObjectCollection(Of ISchemaObject)

The SchemaObjectBaseCollection type exposes the following members.

Constructors
 | Name | Description
Public method | SchemaObjectBaseCollection | Initializes a new instance of the SchemaObjectBaseCollection class.
Public method | SchemaObjectBaseCollection(IEnumerableISchemaObject) | Initializes a new instance of the SchemaObjectBaseCollection class.
Public method | SchemaObjectBaseCollection(Int32) | Initializes a new instance of the SchemaObjectBaseCollection class.
Top
Methods
 | Name | Description
Public method | Clone | (Inherited from SchemaObjectCollectionT.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh | (Inherited from SchemaObjectCollectionT.)
Public method | ToString | (Inherited from SchemaObjectCollectionT.)
Top
See Also

Reference

SchemaExplorer Namespace


SchemaObjectBaseCollection Constructor

Overload List
 | Name | Description
Public method | SchemaObjectBaseCollection | Initializes a new instance of the SchemaObjectBaseCollection class.
Public method | SchemaObjectBaseCollection(IEnumerableISchemaObject) | Initializes a new instance of the SchemaObjectBaseCollection class.
Public method | SchemaObjectBaseCollection(Int32) | Initializes a new instance of the SchemaObjectBaseCollection class.
Top
See Also

Reference

SchemaObjectBaseCollection Class
SchemaExplorer Namespace


SchemaObjectBaseCollection Constructor

Initializes a new instance of the SchemaObjectBaseCollection class.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public SchemaObjectBaseCollection()
Public Sub New
See Also

Reference

SchemaObjectBaseCollection Class
SchemaObjectBaseCollection Overload
SchemaExplorer Namespace


SchemaObjectBaseCollection Constructor (IEnumerable(ISchemaObject))

SchemaObjectBaseCollection Constructor (IEnumerableISchemaObject)

Initializes a new instance of the SchemaObjectBaseCollection class.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public SchemaObjectBaseCollection(
    IEnumerable<ISchemaObject> collection
)
Public Sub New (
    collection As IEnumerable(Of ISchemaObject)
)

Parameters

collection
Type: System.Collections.GenericIEnumerable ISchemaObject
The collection from which the elements are copied.
See Also

Reference

SchemaObjectBaseCollection Class
SchemaObjectBaseCollection Overload
SchemaExplorer Namespace


SchemaObjectBaseCollection Constructor (Int32)

Initializes a new instance of the SchemaObjectBaseCollection class.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public SchemaObjectBaseCollection(
    int capacity
)
Public Sub New (
    capacity As Integer
)

Parameters

capacity
Type: SystemInt32
The number of elements that the new list can initially store.
See Also

Reference

SchemaObjectBaseCollection Class
SchemaObjectBaseCollection Overload
SchemaExplorer Namespace


SchemaObjectBaseCollection Methods

The SchemaObjectBaseCollection type exposes the following members.

Methods
 | Name | Description
Public method | Clone | (Inherited from SchemaObjectCollectionT.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh | (Inherited from SchemaObjectCollectionT.)
Public method | ToString | (Inherited from SchemaObjectCollectionT.)
Top
See Also

Reference

SchemaObjectBaseCollection Class
SchemaExplorer Namespace


SchemaObjectCollection(T) Class

SchemaObjectCollectionT Class

Implements a strongly typed collection of ISchemaObject elements.
Inheritance Hierarchy
SystemObject
ObservableListT
NamedObjectCollectionT
SchemaExplorerSchemaObjectCollectionT
More...

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
[TypeConverterAttribute(typeof(SchemaObjectFactoryTypeConverter))]
public class SchemaObjectCollection<T> : NamedObjectCollection<T>,
    ISchemaObjectCollection<T>, IList<T>, ICollection<T>, IEnumerable<T>,
    IEnumerable, INotifyCollectionChanged, INotifyPropertyChanged, IReadOnlySchemaObjectCollection<T>
where T : ISchemaObject

<SerializableAttribute>
<TypeConverterAttribute(GetType(SchemaObjectFactoryTypeConverter))>
Public Class SchemaObjectCollection(Of T As ISchemaObject)
    Inherits NamedObjectCollection(Of T)
    Implements ISchemaObjectCollection(Of T), IList(Of T),
    ICollection(Of T), IEnumerable(Of T), IEnumerable, INotifyCollectionChanged,
    INotifyPropertyChanged, IReadOnlySchemaObjectCollection(Of T)

Type Parameters

T

The SchemaObjectCollectionT type exposes the following members.

Constructors
 | Name | Description
Public method | SchemaObjectCollectionT | Initializes a new instance of the SchemaObjectCollectionT class.
Public method | SchemaObjectCollectionT(IEnumerableT) | Initializes a new instance of the SchemaObjectCollectionT class.
Public method | SchemaObjectCollectionT(Int32) | Initializes a new instance of the SchemaObjectCollectionT class.
Top
Methods
 | Name | Description
Public method | Clone |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh |
Public method | ToString | (Overrides NamedObjectCollection.ToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AsIndexedEnumerableT | Returns an IndexedEnumerable from any collection implementing IEnumerable<T> (Defined by IndexedEnumerable.)
Top
Remarks
SchemaObjectBaseCollection provides an ObservableList that is strongly typed for ISchemaObject elements.
See Also

Reference

SchemaExplorer Namespace
Inheritance Hierarchy
SystemObject
ObservableListT
NamedObjectCollectionT
SchemaExplorerSchemaObjectCollectionT
SchemaExplorerDataObjectBaseCollection
SchemaExplorerDataObjectBaseCollectionT
SchemaExplorerIndexSchemaCollection
SchemaExplorerMemberColumnSchemaCollection
SchemaExplorerParameterSchemaCollection
SchemaExplorerSchemaObjectBaseCollection
SchemaExplorerSchemaObjectWithOwnerCollectionT
SchemaExplorerTableKeySchemaCollection


SchemaObjectCollection(T) Constructor

SchemaObjectCollectionT Constructor

Overload List
 | Name | Description
Public method | SchemaObjectCollectionT | Initializes a new instance of the SchemaObjectCollectionT class.
Public method | SchemaObjectCollectionT(IEnumerableT) | Initializes a new instance of the SchemaObjectCollectionT class.
Public method | SchemaObjectCollectionT(Int32) | Initializes a new instance of the SchemaObjectCollectionT class.
Top
See Also

Reference

SchemaObjectCollectionT Class
SchemaExplorer Namespace


SchemaObjectCollection(T) Constructor

SchemaObjectCollectionT Constructor

Initializes a new instance of the SchemaObjectCollectionT class.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public SchemaObjectCollection()
Public Sub New
See Also

Reference

SchemaObjectCollectionT Class
SchemaObjectCollectionT Overload
SchemaExplorer Namespace


SchemaObjectCollection(T) Constructor (IEnumerable(T))

SchemaObjectCollectionT Constructor (IEnumerableT)

Initializes a new instance of the SchemaObjectCollectionT class.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public SchemaObjectCollection(
    IEnumerable<T> collection
)
Public Sub New (
    collection As IEnumerable(Of T)
)

Parameters

collection
Type: System.Collections.GenericIEnumerable T
The collection from which the elements are copied.
See Also

Reference

SchemaObjectCollectionT Class
SchemaObjectCollectionT Overload
SchemaExplorer Namespace


SchemaObjectCollection(T) Constructor (Int32)

SchemaObjectCollectionT Constructor (Int32)

Initializes a new instance of the SchemaObjectCollectionT class.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public SchemaObjectCollection(
    int capacity
)
Public Sub New (
    capacity As Integer
)

Parameters

capacity
Type: SystemInt32
The number of elements that the new list can initially store.
See Also

Reference

SchemaObjectCollectionT Class
SchemaObjectCollectionT Overload
SchemaExplorer Namespace


SchemaObjectCollection(T) Methods

SchemaObjectCollectionT Methods

The SchemaObjectCollectionT generic type exposes the following members.

Methods
 | Name | Description
Public method | Clone |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh |
Public method | ToString | (Overrides NamedObjectCollection.ToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AsIndexedEnumerableT | Returns an IndexedEnumerable from any collection implementing IEnumerable<T> (Defined by IndexedEnumerable.)
Top
See Also

Reference

SchemaObjectCollectionT Class
SchemaExplorer Namespace


SchemaObjectCollection(T).Clone Method

SchemaObjectCollectionTClone Method

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public Object Clone()
Public Function Clone As Object

Return Value

Type: Object
See Also

Reference

SchemaObjectCollectionT Class
SchemaExplorer Namespace


SchemaObjectCollection(T).Refresh Method

SchemaObjectCollectionTRefresh Method

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void Refresh()
Public Sub Refresh

Implements

ISchemaObjectCollectionTRefresh
IReadOnlySchemaObjectCollectionTRefresh
See Also

Reference

SchemaObjectCollectionT Class
SchemaExplorer Namespace


SchemaObjectCollection(T).ToString Method

SchemaObjectCollectionTToString Method

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
See Also

Reference

SchemaObjectCollectionT Class
SchemaExplorer Namespace


SchemaObjectWithOwnerBase Class

Provides a base for all schema objects to derive from.
Inheritance Hierarchy
SystemObject
NamedObjectBase
SchemaExplorerSchemaObjectBase
SchemaExplorerSchemaObjectWithOwnerBase
SchemaExplorerCommandSchema
SchemaExplorerTabularObjectBase

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
public abstract class SchemaObjectWithOwnerBase : SchemaObjectBase,
    ISchemaObjectWithOwner, ISchemaObject
<SerializableAttribute>
Public MustInherit Class SchemaObjectWithOwnerBase
    Inherits SchemaObjectBase
    Implements ISchemaObjectWithOwner, ISchemaObject

The SchemaObjectWithOwnerBase type exposes the following members.

Constructors
 | Name | Description
Public method | SchemaObjectWithOwnerBase(DatabaseSchema, String, String) | Initializes a new instance of the SchemaObjectWithOwnerBase class
Public method | SchemaObjectWithOwnerBase(DatabaseSchema, String, String, ExtendedProperty) | Initializes a new instance of the SchemaObjectWithOwnerBase class
Public method | SchemaObjectWithOwnerBase(DatabaseSchema, String, String, DateTime) | Initializes a new instance of the SchemaObjectWithOwnerBase class
Public method | SchemaObjectWithOwnerBase(DatabaseSchema, String, String, DateTime, ExtendedProperty) | Initializes a new instance of the SchemaObjectWithOwnerBase class
Top
Properties
 | Name | Description
Public property | Database | Allows access to the DatabaseSchema object that contains this schema object. (Inherited from SchemaObjectBase.)
Public property | DateCreated | Returns the date this table was created. (Inherited from SchemaObjectBase.)
Public property | DeepLoad | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from SchemaObjectBase.)
Public property | Description | The description of the object. (Inherited from SchemaObjectBase.)
Public property | ExtendedProperties | Used to store any additional information about the schema object. (Inherited from SchemaObjectBase.)
Public property | FullName | Returns the owner and name of the table. (Overrides SchemaObjectBaseFullName.)
Public property | IncludeFunctions | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from SchemaObjectBase.)
Public property | Owner | Returns the owner of the table.
Public property | SortName | Gets the name used to sort in 'Table (Owner)' format. (Overrides SchemaObjectBaseSortName.)
Top
Methods
 | Name | Description
Public method | Equals | Determines if another table is the same as this table. (Overrides SchemaObjectBaseEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns a HashCode based on the database and name of the table. (Overrides SchemaObjectBaseGetHashCode.)
Public method | GetLoadedExtendedProperties | Gets the existing ExtendedProperties without causing a lazy load. (Inherited from SchemaObjectBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MarkLoaded | (Inherited from SchemaObjectBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh | Allows the object to be refreshed. (Inherited from SchemaObjectBase.)
Public method | ToString | Returns the name of the table. (Overrides NamedObjectBase.ToString.)
Top
Fields
 | Name | Description
Protected field | _database | (Inherited from SchemaObjectBase.)
Protected field | _dateCreated | (Inherited from SchemaObjectBase.)
Protected field | _defaultExtendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _extendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _gotExtendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _owner |
Top
See Also

Reference

SchemaExplorer Namespace


SchemaObjectWithOwnerBase Constructor

Overload List
 | Name | Description
Public method | SchemaObjectWithOwnerBase(DatabaseSchema, String, String) | Initializes a new instance of the SchemaObjectWithOwnerBase class
Public method | SchemaObjectWithOwnerBase(DatabaseSchema, String, String, ExtendedProperty) | Initializes a new instance of the SchemaObjectWithOwnerBase class
Public method | SchemaObjectWithOwnerBase(DatabaseSchema, String, String, DateTime) | Initializes a new instance of the SchemaObjectWithOwnerBase class
Public method | SchemaObjectWithOwnerBase(DatabaseSchema, String, String, DateTime, ExtendedProperty) | Initializes a new instance of the SchemaObjectWithOwnerBase class
Top
See Also

Reference

SchemaObjectWithOwnerBase Class
SchemaExplorer Namespace


SchemaObjectWithOwnerBase Constructor (DatabaseSchema, String, String)

Initializes a new instance of the SchemaObjectWithOwnerBase class

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public SchemaObjectWithOwnerBase(
    DatabaseSchema database,
    string name,
    string owner
)
Public Sub New (
    database As DatabaseSchema,
    name As String,
    owner As String
)

Parameters

database
Type: SchemaExplorerDatabaseSchema
name
Type: SystemString
owner
Type: SystemString
See Also

Reference

SchemaObjectWithOwnerBase Class
SchemaObjectWithOwnerBase Overload
SchemaExplorer Namespace


SchemaObjectWithOwnerBase Constructor (DatabaseSchema, String, String, ExtendedProperty[])

SchemaObjectWithOwnerBase Constructor (DatabaseSchema, String, String, ExtendedProperty)

Initializes a new instance of the SchemaObjectWithOwnerBase class

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public SchemaObjectWithOwnerBase(
    DatabaseSchema database,
    string name,
    string owner,
    ExtendedProperty[] extendedProperties
)
Public Sub New (
    database As DatabaseSchema,
    name As String,
    owner As String,
    extendedProperties As ExtendedProperty()
)

Parameters

database
Type: SchemaExplorerDatabaseSchema
name
Type: SystemString
owner
Type: SystemString
extendedProperties
Type: SchemaExplorerExtendedProperty
See Also

Reference

SchemaObjectWithOwnerBase Class
SchemaObjectWithOwnerBase Overload
SchemaExplorer Namespace


SchemaObjectWithOwnerBase Constructor (DatabaseSchema, String, String, DateTime)

Initializes a new instance of the SchemaObjectWithOwnerBase class

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public SchemaObjectWithOwnerBase(
    DatabaseSchema database,
    string name,
    string owner,
    DateTime dateCreated
)
Public Sub New (
    database As DatabaseSchema,
    name As String,
    owner As String,
    dateCreated As DateTime
)

Parameters

database
Type: SchemaExplorerDatabaseSchema
name
Type: SystemString
owner
Type: SystemString
dateCreated
Type: SystemDateTime
See Also

Reference

SchemaObjectWithOwnerBase Class
SchemaObjectWithOwnerBase Overload
SchemaExplorer Namespace


SchemaObjectWithOwnerBase Constructor (DatabaseSchema, String, String, DateTime, ExtendedProperty[])

SchemaObjectWithOwnerBase Constructor (DatabaseSchema, String, String, DateTime, ExtendedProperty)

Initializes a new instance of the SchemaObjectWithOwnerBase class

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public SchemaObjectWithOwnerBase(
    DatabaseSchema database,
    string name,
    string owner,
    DateTime dateCreated,
    ExtendedProperty[] extendedProperties
)
Public Sub New (
    database As DatabaseSchema,
    name As String,
    owner As String,
    dateCreated As DateTime,
    extendedProperties As ExtendedProperty()
)

Parameters

database
Type: SchemaExplorerDatabaseSchema
name
Type: SystemString
owner
Type: SystemString
dateCreated
Type: SystemDateTime
extendedProperties
Type: SchemaExplorerExtendedProperty
See Also

Reference

SchemaObjectWithOwnerBase Class
SchemaObjectWithOwnerBase Overload
SchemaExplorer Namespace


SchemaObjectWithOwnerBase Properties

The SchemaObjectWithOwnerBase type exposes the following members.

Properties
 | Name | Description
Public property | Database | Allows access to the DatabaseSchema object that contains this schema object. (Inherited from SchemaObjectBase.)
Public property | DateCreated | Returns the date this table was created. (Inherited from SchemaObjectBase.)
Public property | DeepLoad | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from SchemaObjectBase.)
Public property | Description | The description of the object. (Inherited from SchemaObjectBase.)
Public property | ExtendedProperties | Used to store any additional information about the schema object. (Inherited from SchemaObjectBase.)
Public property | FullName | Returns the owner and name of the table. (Overrides SchemaObjectBaseFullName.)
Public property | IncludeFunctions | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from SchemaObjectBase.)
Public property | Owner | Returns the owner of the table.
Public property | SortName | Gets the name used to sort in 'Table (Owner)' format. (Overrides SchemaObjectBaseSortName.)
Top
See Also

Reference

SchemaObjectWithOwnerBase Class
SchemaExplorer Namespace


SchemaObjectWithOwnerBase.FullName Property

SchemaObjectWithOwnerBaseFullName Property

Returns the owner and name of the table.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override string FullName { get; }
Public Overrides ReadOnly Property FullName As String
    Get

Return Value

Type: String

Implements

ISchemaObjectFullName
ISchemaObjectFullName
See Also

Reference

SchemaObjectWithOwnerBase Class
SchemaExplorer Namespace


SchemaObjectWithOwnerBase.Owner Property

SchemaObjectWithOwnerBaseOwner Property

Returns the owner of the table.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string Owner { get; }
Public ReadOnly Property Owner As String
    Get

Return Value

Type: String

Implements

ISchemaObjectWithOwnerOwner
See Also

Reference

SchemaObjectWithOwnerBase Class
SchemaExplorer Namespace


SchemaObjectWithOwnerBase.SortName Property

SchemaObjectWithOwnerBaseSortName Property

Gets the name used to sort in 'Table (Owner)' format.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override string SortName { get; }
Public Overrides ReadOnly Property SortName As String
    Get

Property Value

Type: String
The name used to sort.

Implements

ISchemaObjectSortName
ISchemaObjectSortName
See Also

Reference

SchemaObjectWithOwnerBase Class
SchemaExplorer Namespace


SchemaObjectWithOwnerBase Methods

The SchemaObjectWithOwnerBase type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines if another table is the same as this table. (Overrides SchemaObjectBaseEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns a HashCode based on the database and name of the table. (Overrides SchemaObjectBaseGetHashCode.)
Public method | GetLoadedExtendedProperties | Gets the existing ExtendedProperties without causing a lazy load. (Inherited from SchemaObjectBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MarkLoaded | (Inherited from SchemaObjectBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh | Allows the object to be refreshed. (Inherited from SchemaObjectBase.)
Public method | ToString | Returns the name of the table. (Overrides NamedObjectBase.ToString.)
Top
See Also

Reference

SchemaObjectWithOwnerBase Class
SchemaExplorer Namespace


SchemaObjectWithOwnerBase.Equals Method

SchemaObjectWithOwnerBaseEquals Method

Determines if another table is the same as this table.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
The table to check against.

Return Value

Type: Boolean
true/false
See Also

Reference

SchemaObjectWithOwnerBase Class
SchemaExplorer Namespace


SchemaObjectWithOwnerBase.GetHashCode Method

SchemaObjectWithOwnerBaseGetHashCode Method

Returns a HashCode based on the database and name of the table.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
See Also

Reference

SchemaObjectWithOwnerBase Class
SchemaExplorer Namespace


SchemaObjectWithOwnerBase.ToString Method

SchemaObjectWithOwnerBaseToString Method

Returns the name of the table.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
See Also

Reference

SchemaObjectWithOwnerBase Class
SchemaExplorer Namespace


SchemaObjectWithOwnerBase Fields

The SchemaObjectWithOwnerBase type exposes the following members.

Fields
 | Name | Description
Protected field | _database | (Inherited from SchemaObjectBase.)
Protected field | _dateCreated | (Inherited from SchemaObjectBase.)
Protected field | _defaultExtendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _extendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _gotExtendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _owner |
Top
See Also

Reference

SchemaObjectWithOwnerBase Class
SchemaExplorer Namespace


SchemaObjectWithOwnerBase._owner Field

SchemaObjectWithOwnerBase_owner Field

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected readonly string _owner
Protected ReadOnly _owner As String

Field Value

Type: String
See Also

Reference

SchemaObjectWithOwnerBase Class
SchemaExplorer Namespace


SchemaObjectWithOwnerCollection(T) Class

SchemaObjectWithOwnerCollectionT Class

Inheritance Hierarchy
SystemObject
ObservableListT
NamedObjectCollectionT
SchemaExplorerSchemaObjectCollection T
SchemaExplorerSchemaObjectWithOwnerCollectionT
SchemaExplorerCommandResultSchemaCollection
SchemaExplorerCommandSchemaCollection
SchemaExplorerTableSchemaCollection
SchemaExplorerTabularObjectBaseCollection
SchemaExplorerViewSchemaCollection

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
public class SchemaObjectWithOwnerCollection<T> : SchemaObjectCollection<T>,
    ISchemaObjectWithOwnerCollection<T>, ISchemaObjectCollection<T>, IList<T>, ICollection<T>,
    IEnumerable<T>, IEnumerable, INotifyCollectionChanged, INotifyPropertyChanged, IReadOnlySchemaObjectWithOwnerCollection<T>,
    IReadOnlySchemaObjectCollection<T>
where T : ISchemaObjectWithOwner

<SerializableAttribute>
Public Class SchemaObjectWithOwnerCollection(Of T As ISchemaObjectWithOwner)
    Inherits SchemaObjectCollection(Of T)
    Implements ISchemaObjectWithOwnerCollection(Of T), ISchemaObjectCollection(Of T),
    IList(Of T), ICollection(Of T), IEnumerable(Of T),
    IEnumerable, INotifyCollectionChanged, INotifyPropertyChanged, IReadOnlySchemaObjectWithOwnerCollection(Of T), IReadOnlySchemaObjectCollection(Of T)

Type Parameters

T

The SchemaObjectWithOwnerCollectionT type exposes the following members.

Constructors
 | Name | Description
Public method | SchemaObjectWithOwnerCollectionT | Initializes a new instance of the TableSchemaCollection class.
Public method | SchemaObjectWithOwnerCollectionT(IEnumerableT) | Initializes a new instance of the TableSchemaCollection class.
Public method | SchemaObjectWithOwnerCollectionT(Int32) | Initializes a new instance of the TableSchemaCollection class.
Top
Properties
 | Name | Description
Public property | Item | Gets the TableSchema with the specified owner and name.
Top
Methods
 | Name | Description
Public method | Clone | (Inherited from SchemaObjectCollectionT.)
Public method | Contains | Determines whether an element is in the collection with the specified owner and name.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of an item with the specified owner and name.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh | (Inherited from SchemaObjectCollectionT.)
Public method | ToString | (Inherited from SchemaObjectCollectionT.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AsIndexedEnumerableT | Returns an IndexedEnumerable from any collection implementing IEnumerable<T> (Defined by IndexedEnumerable.)
Top
See Also

Reference

SchemaExplorer Namespace


SchemaObjectWithOwnerCollection(T) Constructor

SchemaObjectWithOwnerCollectionT Constructor

Overload List
 | Name | Description
Public method | SchemaObjectWithOwnerCollectionT | Initializes a new instance of the TableSchemaCollection class.
Public method | SchemaObjectWithOwnerCollectionT(IEnumerableT) | Initializes a new instance of the TableSchemaCollection class.
Public method | SchemaObjectWithOwnerCollectionT(Int32) | Initializes a new instance of the TableSchemaCollection class.
Top
See Also

Reference

SchemaObjectWithOwnerCollectionT Class
SchemaExplorer Namespace


SchemaObjectWithOwnerCollection(T) Constructor

SchemaObjectWithOwnerCollectionT Constructor

Initializes a new instance of the TableSchemaCollection class.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public SchemaObjectWithOwnerCollection()
Public Sub New
See Also

Reference

SchemaObjectWithOwnerCollectionT Class
SchemaObjectWithOwnerCollectionT Overload
SchemaExplorer Namespace


SchemaObjectWithOwnerCollection(T) Constructor (IEnumerable(T))

SchemaObjectWithOwnerCollectionT Constructor (IEnumerableT)

Initializes a new instance of the TableSchemaCollection class.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public SchemaObjectWithOwnerCollection(
    IEnumerable<T> collection
)
Public Sub New (
    collection As IEnumerable(Of T)
)

Parameters

collection
Type: System.Collections.GenericIEnumerable T
The collection from which the elements are copied.
See Also

Reference

SchemaObjectWithOwnerCollectionT Class
SchemaObjectWithOwnerCollectionT Overload
SchemaExplorer Namespace


SchemaObjectWithOwnerCollection(T) Constructor (Int32)

SchemaObjectWithOwnerCollectionT Constructor (Int32)

Initializes a new instance of the TableSchemaCollection class.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public SchemaObjectWithOwnerCollection(
    int capacity
)
Public Sub New (
    capacity As Integer
)

Parameters

capacity
Type: SystemInt32
The number of elements that the new list can initially store.
See Also

Reference

SchemaObjectWithOwnerCollectionT Class
SchemaObjectWithOwnerCollectionT Overload
SchemaExplorer Namespace


SchemaObjectWithOwnerCollection(T) Properties

SchemaObjectWithOwnerCollectionT Properties

The SchemaObjectWithOwnerCollectionT generic type exposes the following members.

Properties
 | Name | Description
Public property | Item | Gets the TableSchema with the specified owner and name.
Top
See Also

Reference

SchemaObjectWithOwnerCollectionT Class
SchemaExplorer Namespace


SchemaObjectWithOwnerCollection(T).Item Property

SchemaObjectWithOwnerCollectionTItem Property

Gets the TableSchema with the specified owner and name.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public T this[
    string owner,
    string name
] { get; }
Public ReadOnly Default Property Item (
    owner As String,
    name As String
) As T
    Get

Parameters

owner
Type: SystemString
name
Type: SystemString

Return Value

Type: T
The TableSchema with the specified owner and name.

Implements

ISchemaObjectWithOwnerCollectionTItemString, String
IReadOnlySchemaObjectWithOwnerCollectionTItemString, String
See Also

Reference

SchemaObjectWithOwnerCollectionT Class
SchemaExplorer Namespace


SchemaObjectWithOwnerCollection(T) Methods

SchemaObjectWithOwnerCollectionT Methods

The SchemaObjectWithOwnerCollectionT generic type exposes the following members.

Methods
 | Name | Description
Public method | Clone | (Inherited from SchemaObjectCollectionT.)
Public method | Contains | Determines whether an element is in the collection with the specified owner and name.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of an item with the specified owner and name.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh | (Inherited from SchemaObjectCollectionT.)
Public method | ToString | (Inherited from SchemaObjectCollectionT.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AsIndexedEnumerableT | Returns an IndexedEnumerable from any collection implementing IEnumerable<T> (Defined by IndexedEnumerable.)
Top
See Also

Reference

SchemaObjectWithOwnerCollectionT Class
SchemaExplorer Namespace


SchemaObjectWithOwnerCollection(T).Contains Method

SchemaObjectWithOwnerCollectionTContains Method

Determines whether an element is in the collection with the specified owner and name.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool Contains(
    string owner,
    string name
)
Public Function Contains (
    owner As String,
    name As String
) As Boolean

Parameters

owner
Type: SystemString
The owner of the item to locate in the collection.
name
Type: SystemString
The name of the item to locate in the collection.

Return Value

Type: Boolean
true if item is found in the collection; otherwise, false.

Implements

ISchemaObjectWithOwnerCollectionTContains(String, String)
IReadOnlySchemaObjectWithOwnerCollectionTContains(String, String)
See Also

Reference

SchemaObjectWithOwnerCollectionT Class
SchemaExplorer Namespace


SchemaObjectWithOwnerCollection(T).IndexOf Method

SchemaObjectWithOwnerCollectionTIndexOf Method

Determines the index of an item with the specified owner and name.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public int IndexOf(
    string owner,
    string name
)
Public Function IndexOf (
    owner As String,
    name As String
) As Integer

Parameters

owner
Type: SystemString
The owner of the item to locate in the collection.
name
Type: SystemString
The name of the item to locate in the collection.

Return Value

Type: Int32
The index of item if found in the list; otherwise, -1.

Implements

ISchemaObjectWithOwnerCollectionTIndexOf(String, String)
IReadOnlySchemaObjectWithOwnerCollectionTIndexOf(String, String)
See Also

Reference

SchemaObjectWithOwnerCollectionT Class
SchemaExplorer Namespace


SchemaProvider Class

Inheritance Hierarchy
SystemObject
SchemaExplorerSchemaProvider

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class SchemaProvider : IComparable,
    IComparable<string>, IComparable<SchemaProvider>, IEquatable<string>,
    IEquatable<SchemaProvider>
Public Class SchemaProvider
    Implements IComparable, IComparable(Of String),
    IComparable(Of SchemaProvider), IEquatable(Of String), IEquatable(Of SchemaProvider)

The SchemaProvider type exposes the following members.

Constructors
 | Name | Description
Public method | SchemaProvider(String) | Initializes a new instance of the SchemaProvider class.
Public method | SchemaProvider(String, String) | Initializes a new instance of the SchemaProvider class.
Top
Properties
 | Name | Description
Public property | AssemblyQualifiedName | Gets the assembly-qualified name of the Type, which includes the name of the assembly from which the Type was loaded.
Public property | DisplayName | Gets the display name.
Top
Methods
 | Name | Description
Public method | CompareTo(SchemaProvider) | Compares the current object with another object of the same type.
Public method | CompareTo(String) | Compares the current object with another object of the same type.
Public method | CreateEditor | Creates an instance of IDbConnectionStringEditor for the type specified in AssemblyQualifiedName.
Public method | CreateEditor(Boolean) | Creates an instance of IDbConnectionStringEditor for the type specified in AssemblyQualifiedName.
Public method | CreateProvider | Creates an instance of IDbSchemaProvider for the type specified in AssemblyQualifiedName.
Public method | CreateProvider(Boolean) | Creates an instance of IDbSchemaProvider for the type specified in AssemblyQualifiedName.
Public method | Equals(Object) | Determines whether the specified Object is equal to this instance. (Overrides ObjectEquals(Object).)
Public method | Equals(SchemaProvider) | Indicates whether the current object is equal to another object of the same type.
Public method | Equals(String) | Indicates whether the current object is equal to another object of the same type.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns a hash code for this instance. (Overrides ObjectGetHashCode.)
Public method | GetProviderType | Gets the Type for the provider specified in AssemblyQualifiedName.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance. (Overrides ObjectToString.)
Top
Operators
Name | Description
(SchemaProvider to String) | Performs an implicit conversion from SchemaProvider to String.
(String to SchemaProvider) | Performs an implicit conversion from String to SchemaProvider.
Top
See Also

Reference

SchemaExplorer Namespace


SchemaProvider Constructor

Overload List
 | Name | Description
Public method | SchemaProvider(String) | Initializes a new instance of the SchemaProvider class.
Public method | SchemaProvider(String, String) | Initializes a new instance of the SchemaProvider class.
Top
See Also

Reference

SchemaProvider Class
SchemaExplorer Namespace


SchemaProvider Constructor (String)

Initializes a new instance of the SchemaProvider class.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public SchemaProvider(
    string assemblyQualifiedName
)
Public Sub New (
    assemblyQualifiedName As String
)

Parameters

assemblyQualifiedName
Type: SystemString
The assembly-qualified name of the Type, which includes the name of the assembly from which the Type was loaded.
See Also

Reference

SchemaProvider Class
SchemaProvider Overload
SchemaExplorer Namespace


SchemaProvider Constructor (String, String)

Initializes a new instance of the SchemaProvider class.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public SchemaProvider(
    string assemblyQualifiedName,
    string displayName
)
Public Sub New (
    assemblyQualifiedName As String,
    displayName As String
)

Parameters

assemblyQualifiedName
Type: SystemString
The assembly-qualified name of the Type, which includes the name of the assembly from which the Type was loaded.
displayName
Type: SystemString
The name used in displaying this DataSourceProvider.
See Also

Reference

SchemaProvider Class
SchemaProvider Overload
SchemaExplorer Namespace


SchemaProvider Properties

The SchemaProvider type exposes the following members.

Properties
 | Name | Description
Public property | AssemblyQualifiedName | Gets the assembly-qualified name of the Type, which includes the name of the assembly from which the Type was loaded.
Public property | DisplayName | Gets the display name.
Top
See Also

Reference

SchemaProvider Class
SchemaExplorer Namespace


SchemaProvider.AssemblyQualifiedName Property

SchemaProviderAssemblyQualifiedName Property

Gets the assembly-qualified name of the Type, which includes the name of the assembly from which the Type was loaded.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string AssemblyQualifiedName { get; }
Public ReadOnly Property AssemblyQualifiedName As String
    Get

Property Value

Type: String
See Also

Reference

SchemaProvider Class
SchemaExplorer Namespace


SchemaProvider.DisplayName Property

SchemaProviderDisplayName Property

Gets the display name.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string DisplayName { get; }
Public ReadOnly Property DisplayName As String
    Get

Property Value

Type: String
See Also

Reference

SchemaProvider Class
SchemaExplorer Namespace


SchemaProvider Methods

The SchemaProvider type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(SchemaProvider) | Compares the current object with another object of the same type.
Public method | CompareTo(String) | Compares the current object with another object of the same type.
Public method | CreateEditor | Creates an instance of IDbConnectionStringEditor for the type specified in AssemblyQualifiedName.
Public method | CreateEditor(Boolean) | Creates an instance of IDbConnectionStringEditor for the type specified in AssemblyQualifiedName.
Public method | CreateProvider | Creates an instance of IDbSchemaProvider for the type specified in AssemblyQualifiedName.
Public method | CreateProvider(Boolean) | Creates an instance of IDbSchemaProvider for the type specified in AssemblyQualifiedName.
Public method | Equals(Object) | Determines whether the specified Object is equal to this instance. (Overrides ObjectEquals(Object).)
Public method | Equals(SchemaProvider) | Indicates whether the current object is equal to another object of the same type.
Public method | Equals(String) | Indicates whether the current object is equal to another object of the same type.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns a hash code for this instance. (Overrides ObjectGetHashCode.)
Public method | GetProviderType | Gets the Type for the provider specified in AssemblyQualifiedName.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance. (Overrides ObjectToString.)
Top
See Also

Reference

SchemaProvider Class
SchemaExplorer Namespace


SchemaProvider.CompareTo Method

SchemaProviderCompareTo Method

Overload List
 | Name | Description
Public method | CompareTo(SchemaProvider) | Compares the current object with another object of the same type.
Public method | CompareTo(String) | Compares the current object with another object of the same type.
Top
See Also

Reference

SchemaProvider Class
SchemaExplorer Namespace


SchemaProvider.CompareTo Method (SchemaProvider)

SchemaProviderCompareTo Method (SchemaProvider)

Compares the current object with another object of the same type.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public int CompareTo(
    SchemaProvider other
)
Public Function CompareTo (
    other As SchemaProvider
) As Integer

Parameters

other
Type: SchemaExplorerSchemaProvider
An object to compare with this object.

Return Value

Type: Int32
A 32-bit signed integer that indicates the relative order of the objects being compared.

Implements

IComparableTCompareTo(T)
See Also

Reference

SchemaProvider Class
CompareTo Overload
SchemaExplorer Namespace


SchemaProvider.CompareTo Method (String)

SchemaProviderCompareTo Method (String)

Compares the current object with another object of the same type.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public int CompareTo(
    string other
)
Public Function CompareTo (
    other As String
) As Integer

Parameters

other
Type: SystemString
An object to compare with this object.

Return Value

Type: Int32
A 32-bit signed integer that indicates the relative order of the objects being compared.

Implements

IComparableTCompareTo(T)
See Also

Reference

SchemaProvider Class
CompareTo Overload
SchemaExplorer Namespace


SchemaProvider.CreateEditor Method

SchemaProviderCreateEditor Method

Overload List
 | Name | Description
Public method | CreateEditor | Creates an instance of IDbConnectionStringEditor for the type specified in AssemblyQualifiedName.
Public method | CreateEditor(Boolean) | Creates an instance of IDbConnectionStringEditor for the type specified in AssemblyQualifiedName.
Top
See Also

Reference

SchemaProvider Class
SchemaExplorer Namespace


SchemaProvider.CreateEditor Method

SchemaProviderCreateEditor Method

Creates an instance of IDbConnectionStringEditor for the type specified in AssemblyQualifiedName.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public IDbConnectionStringEditor CreateEditor()
Public Function CreateEditor As IDbConnectionStringEditor

Return Value

Type: IDbConnectionStringEditor
An instance of IDbConnectionStringEditor, null if the type can not be resolved.
See Also

Reference

SchemaProvider Class
CreateEditor Overload
SchemaExplorer Namespace


SchemaProvider.CreateEditor Method (Boolean)

SchemaProviderCreateEditor Method (Boolean)

Creates an instance of IDbConnectionStringEditor for the type specified in AssemblyQualifiedName.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public IDbConnectionStringEditor CreateEditor(
    bool cache
)
Public Function CreateEditor (
    cache As Boolean
) As IDbConnectionStringEditor

Parameters

cache
Type: SystemBoolean
if set to true, the an instance will be cached and return on future calls.

Return Value

Type: IDbConnectionStringEditor
An instance of IDbConnectionStringEditor, null if the type can not be resolved.
See Also

Reference

SchemaProvider Class
CreateEditor Overload
SchemaExplorer Namespace


SchemaProvider.CreateProvider Method

SchemaProviderCreateProvider Method

Overload List
 | Name | Description
Public method | CreateProvider | Creates an instance of IDbSchemaProvider for the type specified in AssemblyQualifiedName.
Public method | CreateProvider(Boolean) | Creates an instance of IDbSchemaProvider for the type specified in AssemblyQualifiedName.
Top
See Also

Reference

SchemaProvider Class
SchemaExplorer Namespace


SchemaProvider.CreateProvider Method

SchemaProviderCreateProvider Method

Creates an instance of IDbSchemaProvider for the type specified in AssemblyQualifiedName.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public IDbSchemaProvider CreateProvider()
Public Function CreateProvider As IDbSchemaProvider

Return Value

Type: IDbSchemaProvider
An instance of IDbSchemaProvider, null if the type can not be resolved.
See Also

Reference

SchemaProvider Class
CreateProvider Overload
SchemaExplorer Namespace


SchemaProvider.CreateProvider Method (Boolean)

SchemaProviderCreateProvider Method (Boolean)

Creates an instance of IDbSchemaProvider for the type specified in AssemblyQualifiedName.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public IDbSchemaProvider CreateProvider(
    bool cache
)
Public Function CreateProvider (
    cache As Boolean
) As IDbSchemaProvider

Parameters

cache
Type: SystemBoolean
if set to true, the an instance will be cached and return on future calls.

Return Value

Type: IDbSchemaProvider
An instance of IDbSchemaProvider, null if the type can not be resolved.
See Also

Reference

SchemaProvider Class
CreateProvider Overload
SchemaExplorer Namespace


SchemaProvider.Equals Method

SchemaProviderEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to this instance. (Overrides ObjectEquals(Object).)
Public method | Equals(SchemaProvider) | Indicates whether the current object is equal to another object of the same type.
Public method | Equals(String) | Indicates whether the current object is equal to another object of the same type.
Top
See Also

Reference

SchemaProvider Class
SchemaExplorer Namespace


SchemaProvider.Equals Method (Object)

SchemaProviderEquals Method (Object)

Determines whether the specified Object is equal to this instance.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
The Object to compare with this instance.

Return Value

Type: Boolean
true if the specified Object is equal to this instance; otherwise, false.
See Also

Reference

SchemaProvider Class
Equals Overload
SchemaExplorer Namespace


SchemaProvider.Equals Method (SchemaProvider)

SchemaProviderEquals Method (SchemaProvider)

Indicates whether the current object is equal to another object of the same type.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool Equals(
    SchemaProvider other
)
Public Function Equals (
    other As SchemaProvider
) As Boolean

Parameters

other
Type: SchemaExplorerSchemaProvider
An object to compare with this object.

Return Value

Type: Boolean
true if the current object is equal to the other parameter; otherwise, false.

Implements

IEquatableTEquals(T)
See Also

Reference

SchemaProvider Class
Equals Overload
SchemaExplorer Namespace


SchemaProvider.Equals Method (String)

SchemaProviderEquals Method (String)

Indicates whether the current object is equal to another object of the same type.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool Equals(
    string other
)
Public Function Equals (
    other As String
) As Boolean

Parameters

other
Type: SystemString
An object to compare with this object.

Return Value

Type: Boolean
true if the current object is equal to the other parameter; otherwise, false.

Implements

IEquatableTEquals(T)
See Also

Reference

SchemaProvider Class
Equals Overload
SchemaExplorer Namespace


SchemaProvider.GetHashCode Method

SchemaProviderGetHashCode Method

Returns a hash code for this instance.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.
See Also

Reference

SchemaProvider Class
SchemaExplorer Namespace


SchemaProvider.GetProviderType Method

SchemaProviderGetProviderType Method

Gets the Type for the provider specified in AssemblyQualifiedName.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public Type GetProviderType()
Public Function GetProviderType As Type

Return Value

Type: Type
The Type for the provider specified in AssemblyQualifiedName. If the Type can not be resolved, null is returned.
See Also

Reference

SchemaProvider Class
SchemaExplorer Namespace


SchemaProvider.ToString Method

SchemaProviderToString Method

Returns a String that represents this instance.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A String that represents this instance.
See Also

Reference

SchemaProvider Class
SchemaExplorer Namespace


SchemaProvider Type Conversions

Operators
Name | Description
(SchemaProvider to String) | Performs an implicit conversion from SchemaProvider to String.
(String to SchemaProvider) | Performs an implicit conversion from String to SchemaProvider.
Top
See Also

Reference

SchemaProvider Class
SchemaExplorer Namespace


SchemaProvider Implicit Conversion Operators

SchemaProvider Conversion Operators

Overload List
Name | Description
(SchemaProvider to String) | Performs an implicit conversion from SchemaProvider to String.
(String to SchemaProvider) | Performs an implicit conversion from String to SchemaProvider.
Top
See Also

Reference

SchemaProvider Class
SchemaExplorer Namespace


SchemaProvider Implicit Conversion (SchemaProvider to String)

SchemaProvider Conversion (SchemaProvider to String)

Performs an implicit conversion from SchemaProvider to String.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static implicit operator string (
    SchemaProvider schemaProvider
)
Public Shared Widening Operator CType (
    schemaProvider As SchemaProvider
) As String

Parameters

schemaProvider
Type: SchemaExplorerSchemaProvider
The data source provider.

Return Value

Type: String
The result of the conversion.
See Also

Reference

SchemaProvider Class
Overload
SchemaExplorer Namespace


SchemaProvider Implicit Conversion (String to SchemaProvider)

SchemaProvider Conversion (String to SchemaProvider)

Performs an implicit conversion from String to SchemaProvider.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static implicit operator SchemaProvider (
    string assemblyQualifiedName
)
Public Shared Widening Operator CType (
    assemblyQualifiedName As String
) As SchemaProvider

Parameters

assemblyQualifiedName
Type: SystemString
Name of the assembly qualified.

Return Value

Type: SchemaProvider
The result of the conversion.
See Also

Reference

SchemaProvider Class
Overload
SchemaExplorer Namespace


SchemaSelector Class

A DatabaseSchema extension allowing for flexible schema object selection.
Inheritance Hierarchy
SystemObject
NamedObjectBase
SchemaExplorerSchemaObjectBase
SchemaExplorerDatabaseSchema
SchemaExplorerSchemaSelector

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
[TypeConverterAttribute(typeof(SchemaSelectorTypeConverter))]
public class SchemaSelector : DatabaseSchema
<SerializableAttribute>
<TypeConverterAttribute(GetType(SchemaSelectorTypeConverter))>
Public Class SchemaSelector
    Inherits DatabaseSchema

The SchemaSelector type exposes the following members.

Constructors
 | Name | Description
Public method | SchemaSelector | Initializes a new instance of the SchemaSelector class.
Public method | SchemaSelector(IDbSchemaProvider, String) | Initializes a new instance of the SchemaSelector class.
Top
Properties
 | Name | Description
Public property | ColumnExpressions | Gets or sets the regular expressions for selecting column objects. The expressions are used to match table and view columns. The expression is compared against FullName.
Public property | Commands | Provides access to the commands contained in the database. (Inherited from DatabaseSchema.)
Public property | ConnectionString | Gets or sets the current connection string for this instance. (Inherited from DatabaseSchema.)
Public property | Database | Allows access to the DatabaseSchema object that contains this schema object. (Inherited from SchemaObjectBase.)
Public property | DateCreated | Returns the date this table was created. (Inherited from SchemaObjectBase.)
Public property | DeepLoad | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from SchemaObjectBase.)
Public property | Description | The description of the object. (Inherited from SchemaObjectBase.)
Public property | ExtendedProperties | Used to store any additional information about the schema object. (Inherited from SchemaObjectBase.)
Public property | FullName | Returns the owner and name of the table. (Inherited from SchemaObjectBase.)
Public property | IncludeFunctions | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from SchemaObjectBase.)
Public property | Name | The name of the database. (Inherited from DatabaseSchema.)
Public property | Provider | Gets or sets the current provider for this instance. (Inherited from DatabaseSchema.)
Public property | SchemaExpressions | Gets or sets the regular expressions for selecting schema objects. The expressions are used to match tables, views and commands. The expression is compared against FullName.
Public property | SelectedColumns | Gets or sets the selected columns. Values should be FullName of the column selected.
Public property | SelectedCommands | Gets or sets the selected commands. Values should be FullName of the command selected.
Public property | SelectedTables | Gets or sets the selected tables and views. Values should be FullName of the table selected.
Public property | SelectMode | Gets or sets the select mode. When SelectMode.Exclude, selected items will be treated as items to be excluded. When SelectMode.Include, the selected items will be treated as items to include.
Public property | SortName | Gets the name used to sort in 'Table (Owner)' format. (Inherited from SchemaObjectBase.)
Public property | Tables | Provides access to the tables contained in the database. (Inherited from DatabaseSchema.)
Public property | Views | Provides access to the views contained in the database. (Inherited from DatabaseSchema.)
Top
Methods
 | Name | Description
Public method | Clear | Clears all selected items.
Public method | Equals | Determines if another database is the same as this database. (Inherited from DatabaseSchema.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns a hashcode based on the database. (Inherited from DatabaseSchema.)
Public method | GetLoadedExtendedProperties | Gets the existing ExtendedProperties without causing a lazy load. (Inherited from SchemaObjectBase.)
Public method | GetProvider | Obsolete. Gets a provider by name. (Inherited from DatabaseSchema.)
Public method | GetProviders | Obsolete. Returns a collection of available providers. (Inherited from DatabaseSchema.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MarkLoaded | (Inherited from SchemaObjectBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh | Allows for programmatic refreshing of the database schema. (Inherited from DatabaseSchema.)
Public method | ToString | Returns the name of the database. (Inherited from DatabaseSchema.)
Top
Fields
 | Name | Description
Protected field | _database | (Inherited from SchemaObjectBase.)
Protected field | _dateCreated | (Inherited from SchemaObjectBase.)
Protected field | _defaultExtendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _extendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _gotExtendedProperties | (Inherited from SchemaObjectBase.)
Top
See Also

Reference

SchemaExplorer Namespace


SchemaSelector Constructor

Overload List
 | Name | Description
Public method | SchemaSelector | Initializes a new instance of the SchemaSelector class.
Public method | SchemaSelector(IDbSchemaProvider, String) | Initializes a new instance of the SchemaSelector class.
Top
See Also

Reference

SchemaSelector Class
SchemaExplorer Namespace


SchemaSelector Constructor

Initializes a new instance of the SchemaSelector class.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public SchemaSelector()
Public Sub New
See Also

Reference

SchemaSelector Class
SchemaSelector Overload
SchemaExplorer Namespace


SchemaSelector Constructor (IDbSchemaProvider, String)

Initializes a new instance of the SchemaSelector class.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public SchemaSelector(
    IDbSchemaProvider provider,
    string connectionString
)
Public Sub New (
    provider As IDbSchemaProvider,
    connectionString As String
)

Parameters

provider
Type: SchemaExplorerIDbSchemaProvider
The provider to use for this instance.
connectionString
Type: SystemString
The connection string to use for this instance.
See Also

Reference

SchemaSelector Class
SchemaSelector Overload
SchemaExplorer Namespace


SchemaSelector Properties

The SchemaSelector type exposes the following members.

Properties
 | Name | Description
Public property | ColumnExpressions | Gets or sets the regular expressions for selecting column objects. The expressions are used to match table and view columns. The expression is compared against FullName.
Public property | Commands | Provides access to the commands contained in the database. (Inherited from DatabaseSchema.)
Public property | ConnectionString | Gets or sets the current connection string for this instance. (Inherited from DatabaseSchema.)
Public property | Database | Allows access to the DatabaseSchema object that contains this schema object. (Inherited from SchemaObjectBase.)
Public property | DateCreated | Returns the date this table was created. (Inherited from SchemaObjectBase.)
Public property | DeepLoad | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from SchemaObjectBase.)
Public property | Description | The description of the object. (Inherited from SchemaObjectBase.)
Public property | ExtendedProperties | Used to store any additional information about the schema object. (Inherited from SchemaObjectBase.)
Public property | FullName | Returns the owner and name of the table. (Inherited from SchemaObjectBase.)
Public property | IncludeFunctions | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from SchemaObjectBase.)
Public property | Name | The name of the database. (Inherited from DatabaseSchema.)
Public property | Provider | Gets or sets the current provider for this instance. (Inherited from DatabaseSchema.)
Public property | SchemaExpressions | Gets or sets the regular expressions for selecting schema objects. The expressions are used to match tables, views and commands. The expression is compared against FullName.
Public property | SelectedColumns | Gets or sets the selected columns. Values should be FullName of the column selected.
Public property | SelectedCommands | Gets or sets the selected commands. Values should be FullName of the command selected.
Public property | SelectedTables | Gets or sets the selected tables and views. Values should be FullName of the table selected.
Public property | SelectMode | Gets or sets the select mode. When SelectMode.Exclude, selected items will be treated as items to be excluded. When SelectMode.Include, the selected items will be treated as items to include.
Public property | SortName | Gets the name used to sort in 'Table (Owner)' format. (Inherited from SchemaObjectBase.)
Public property | Tables | Provides access to the tables contained in the database. (Inherited from DatabaseSchema.)
Public property | Views | Provides access to the views contained in the database. (Inherited from DatabaseSchema.)
Top
See Also

Reference

SchemaSelector Class
SchemaExplorer Namespace


SchemaSelector.ColumnExpressions Property

SchemaSelectorColumnExpressions Property

Gets or sets the regular expressions for selecting column objects. The expressions are used to match table and view columns. The expression is compared against FullName.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public HashSet<string> ColumnExpressions { get; set; }
Public Property ColumnExpressions As HashSet(Of String)
    Get
    Set

Property Value

Type: HashSet String
See Also

Reference

SchemaSelector Class
SchemaExplorer Namespace


SchemaSelector.SchemaExpressions Property

SchemaSelectorSchemaExpressions Property

Gets or sets the regular expressions for selecting schema objects. The expressions are used to match tables, views and commands. The expression is compared against FullName.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public HashSet<string> SchemaExpressions { get; set; }
Public Property SchemaExpressions As HashSet(Of String)
    Get
    Set

Property Value

Type: HashSet String
See Also

Reference

SchemaSelector Class
SchemaExplorer Namespace


SchemaSelector.SelectedColumns Property

SchemaSelectorSelectedColumns Property

Gets or sets the selected columns. Values should be FullName of the column selected.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public HashSet<string> SelectedColumns { get; set; }
Public Property SelectedColumns As HashSet(Of String)
    Get
    Set

Property Value

Type: HashSet String
See Also

Reference

SchemaSelector Class
SchemaExplorer Namespace


SchemaSelector.SelectedCommands Property

SchemaSelectorSelectedCommands Property

Gets or sets the selected commands. Values should be FullName of the command selected.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public HashSet<string> SelectedCommands { get; set; }
Public Property SelectedCommands As HashSet(Of String)
    Get
    Set

Property Value

Type: HashSet String
See Also

Reference

SchemaSelector Class
SchemaExplorer Namespace


SchemaSelector.SelectedTables Property

SchemaSelectorSelectedTables Property

Gets or sets the selected tables and views. Values should be FullName of the table selected.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public HashSet<string> SelectedTables { get; set; }
Public Property SelectedTables As HashSet(Of String)
    Get
    Set

Property Value

Type: HashSet String
See Also

Reference

SchemaSelector Class
SchemaExplorer Namespace


SchemaSelector.SelectMode Property

SchemaSelectorSelectMode Property

Gets or sets the select mode. When SelectMode.Exclude, selected items will be treated as items to be excluded. When SelectMode.Include, the selected items will be treated as items to include.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public SelectMode SelectMode { get; set; }
Public Property SelectMode As SelectMode
    Get
    Set

Property Value

Type: SelectMode
See Also

Reference

SchemaSelector Class
SchemaExplorer Namespace


SchemaSelector Methods

The SchemaSelector type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Clears all selected items.
Public method | Equals | Determines if another database is the same as this database. (Inherited from DatabaseSchema.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns a hashcode based on the database. (Inherited from DatabaseSchema.)
Public method | GetLoadedExtendedProperties | Gets the existing ExtendedProperties without causing a lazy load. (Inherited from SchemaObjectBase.)
Public method | GetProvider | Obsolete. Gets a provider by name. (Inherited from DatabaseSchema.)
Public method | GetProviders | Obsolete. Returns a collection of available providers. (Inherited from DatabaseSchema.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MarkLoaded | (Inherited from SchemaObjectBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh | Allows for programmatic refreshing of the database schema. (Inherited from DatabaseSchema.)
Public method | ToString | Returns the name of the database. (Inherited from DatabaseSchema.)
Top
See Also

Reference

SchemaSelector Class
SchemaExplorer Namespace


SchemaSelector.Clear Method

SchemaSelectorClear Method

Clears all selected items.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void Clear()
Public Sub Clear
See Also

Reference

SchemaSelector Class
SchemaExplorer Namespace


SchemaSelector Fields

The SchemaSelector type exposes the following members.

Fields
 | Name | Description
Protected field | _database | (Inherited from SchemaObjectBase.)
Protected field | _dateCreated | (Inherited from SchemaObjectBase.)
Protected field | _defaultExtendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _extendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _gotExtendedProperties | (Inherited from SchemaObjectBase.)
Top
See Also

Reference

SchemaSelector Class
SchemaExplorer Namespace


SchemaSelectorExtensions Class

Extension methods to filter schema to selected items.
Inheritance Hierarchy
SystemObject
SchemaExplorerSchemaSelectorExtensions

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static class SchemaSelectorExtensions
<ExtensionAttribute>
Public NotInheritable Class SchemaSelectorExtensions

The SchemaSelectorExtensions type exposes the following members.

Methods
Name | Description
Selected(IColumnSchema) | Determines if the specified item is selected using the rules defined in SchemaSelector.
Selected(ICommandSchema) | Determines if the specified item is selected using the rules defined in SchemaSelector.
Selected(IEnumerableColumnSchema) | Filters the specified columns to those that are selected using the rules defined in SchemaSelector.
Selected(IEnumerableCommandSchema) | Filters the specified commands to those that are selected using the rules defined in SchemaSelector.
Selected(IEnumerableTableKeySchema) | Filters the specified table keys to those that are selected using the rules defined in SchemaSelector. All tables and columns that are part of the key need to be selected for the key to be considered selected.
Selected(IEnumerableViewColumnSchema) | Filters the specified columns to those that are selected using the rules defined in SchemaSelector.
Selected(IPrimaryKeySchema) | Determines if the specified item is selected using the rules defined in SchemaSelector. All tables and columns that are part of the key need to be selected for the key to be considered selected.
Selected(ITableKeySchema) | Determines if the specified item is selected using the rules defined in SchemaSelector. All tables and columns that are part of the key need to be selected for the key to be considered selected.
Selected(ITabularObject) | Determines if the specified item is selected using the rules defined in SchemaSelector.
Selected(IViewColumnSchema) | Determines if the specified item is selected using the rules defined in SchemaSelector.
SelectedTTabular(IEnumerableTTabular) | Filters the specified tables to those that are selected using the rules defined in SchemaSelector.
ToColumns(IEnumerableColumnSchema) | Converts the IEnumerable of type ColumnSchema to a ColumnSchemaCollection.
ToColumns(IEnumerableViewColumnSchema) | Converts the IEnumerable of type ViewColumnSchema to a ViewColumnSchemaCollection.
ToCommands | Converts the IEnumerable of type CommandSchema to a CommandSchemaCollection.
ToKeys | Converts the IEnumerable of type TableKeySchema to a TableKeySchemaCollection.
ToTables | Converts the IEnumerable of type TableSchema to a TableSchemaCollection.
ToViews | Converts the IEnumerable of type ViewSchema to a ViewSchemaCollection.
Top
See Also

Reference

SchemaExplorer Namespace
SchemaSelector


SchemaSelectorExtensions Methods

The SchemaSelectorExtensions type exposes the following members.

Methods
Name | Description
Selected(IColumnSchema) | Determines if the specified item is selected using the rules defined in SchemaSelector.
Selected(ICommandSchema) | Determines if the specified item is selected using the rules defined in SchemaSelector.
Selected(IEnumerableColumnSchema) | Filters the specified columns to those that are selected using the rules defined in SchemaSelector.
Selected(IEnumerableCommandSchema) | Filters the specified commands to those that are selected using the rules defined in SchemaSelector.
Selected(IEnumerableTableKeySchema) | Filters the specified table keys to those that are selected using the rules defined in SchemaSelector. All tables and columns that are part of the key need to be selected for the key to be considered selected.
Selected(IEnumerableViewColumnSchema) | Filters the specified columns to those that are selected using the rules defined in SchemaSelector.
Selected(IPrimaryKeySchema) | Determines if the specified item is selected using the rules defined in SchemaSelector. All tables and columns that are part of the key need to be selected for the key to be considered selected.
Selected(ITableKeySchema) | Determines if the specified item is selected using the rules defined in SchemaSelector. All tables and columns that are part of the key need to be selected for the key to be considered selected.
Selected(ITabularObject) | Determines if the specified item is selected using the rules defined in SchemaSelector.
Selected(IViewColumnSchema) | Determines if the specified item is selected using the rules defined in SchemaSelector.
SelectedTTabular(IEnumerableTTabular) | Filters the specified tables to those that are selected using the rules defined in SchemaSelector.
ToColumns(IEnumerableColumnSchema) | Converts the IEnumerable of type ColumnSchema to a ColumnSchemaCollection.
ToColumns(IEnumerableViewColumnSchema) | Converts the IEnumerable of type ViewColumnSchema to a ViewColumnSchemaCollection.
ToCommands | Converts the IEnumerable of type CommandSchema to a CommandSchemaCollection.
ToKeys | Converts the IEnumerable of type TableKeySchema to a TableKeySchemaCollection.
ToTables | Converts the IEnumerable of type TableSchema to a TableSchemaCollection.
ToViews | Converts the IEnumerable of type ViewSchema to a ViewSchemaCollection.
Top
See Also

Reference

SchemaSelectorExtensions Class
SchemaExplorer Namespace


SchemaSelectorExtensions.Selected Method

SchemaSelectorExtensionsSelected Method

Overload List
Name | Description
Selected(IColumnSchema) | Determines if the specified item is selected using the rules defined in SchemaSelector.
Selected(ICommandSchema) | Determines if the specified item is selected using the rules defined in SchemaSelector.
Selected(IEnumerableColumnSchema) | Filters the specified columns to those that are selected using the rules defined in SchemaSelector.
Selected(IEnumerableCommandSchema) | Filters the specified commands to those that are selected using the rules defined in SchemaSelector.
Selected(IEnumerableTableKeySchema) | Filters the specified table keys to those that are selected using the rules defined in SchemaSelector. All tables and columns that are part of the key need to be selected for the key to be considered selected.
Selected(IEnumerableViewColumnSchema) | Filters the specified columns to those that are selected using the rules defined in SchemaSelector.
SelectedTTabular(IEnumerableTTabular) | Filters the specified tables to those that are selected using the rules defined in SchemaSelector.
Selected(IPrimaryKeySchema) | Determines if the specified item is selected using the rules defined in SchemaSelector. All tables and columns that are part of the key need to be selected for the key to be considered selected.
Selected(ITableKeySchema) | Determines if the specified item is selected using the rules defined in SchemaSelector. All tables and columns that are part of the key need to be selected for the key to be considered selected.
Selected(ITabularObject) | Determines if the specified item is selected using the rules defined in SchemaSelector.
Selected(IViewColumnSchema) | Determines if the specified item is selected using the rules defined in SchemaSelector.
Top
See Also

Reference

SchemaSelectorExtensions Class
SchemaExplorer Namespace


SchemaSelectorExtensions.Selected Method (IColumnSchema)

SchemaSelectorExtensionsSelected Method (IColumnSchema)

Determines if the specified item is selected using the rules defined in SchemaSelector.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static bool Selected(
    this IColumnSchema item
)
<ExtensionAttribute>
Public Shared Function Selected (
    item As IColumnSchema
) As Boolean

Parameters

item
Type: SchemaExplorerIColumnSchema
The item to determine selection.

Return Value

Type: Boolean
true if the speciefied item is selected; otherwise false.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IColumnSchema. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SchemaSelectorExtensions Class
Selected Overload
SchemaExplorer Namespace
SchemaSelector
SchemaSelector.SelectedColumns
SchemaSelector.ColumnExpressions


SchemaSelectorExtensions.Selected Method (ICommandSchema)

SchemaSelectorExtensionsSelected Method (ICommandSchema)

Determines if the specified item is selected using the rules defined in SchemaSelector.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static bool Selected(
    this ICommandSchema item
)
<ExtensionAttribute>
Public Shared Function Selected (
    item As ICommandSchema
) As Boolean

Parameters

item
Type: SchemaExplorerICommandSchema
The item to determine selection.

Return Value

Type: Boolean
true if the speciefied item is selected; otherwise false.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ICommandSchema. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SchemaSelectorExtensions Class
Selected Overload
SchemaExplorer Namespace
SchemaSelector
SchemaSelector.SelectedCommands
SchemaSelector.SchemaExpressions


SchemaSelectorExtensions.Selected Method (IEnumerable(ColumnSchema))

SchemaSelectorExtensionsSelected Method (IEnumerableColumnSchema)

Filters the specified columns to those that are selected using the rules defined in SchemaSelector.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static IEnumerable<ColumnSchema> Selected(
    this IEnumerable<ColumnSchema> items
)
<ExtensionAttribute>
Public Shared Function Selected (
    items As IEnumerable(Of ColumnSchema)
) As IEnumerable(Of ColumnSchema)

Parameters

items
Type: System.Collections.GenericIEnumerable ColumnSchema
The items to be filtered.

Return Value

Type: IEnumerable ColumnSchema
An IEnumerable of the selected items.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IEnumerable ColumnSchema . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SchemaSelectorExtensions Class
Selected Overload
SchemaExplorer Namespace


SchemaSelectorExtensions.Selected Method (IEnumerable(CommandSchema))

SchemaSelectorExtensionsSelected Method (IEnumerableCommandSchema)

Filters the specified commands to those that are selected using the rules defined in SchemaSelector.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static IEnumerable<CommandSchema> Selected(
    this IEnumerable<CommandSchema> items
)
<ExtensionAttribute>
Public Shared Function Selected (
    items As IEnumerable(Of CommandSchema)
) As IEnumerable(Of CommandSchema)

Parameters

items
Type: System.Collections.GenericIEnumerable CommandSchema
The items to be filtered.

Return Value

Type: IEnumerable CommandSchema
An IEnumerable of the selected items.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IEnumerable CommandSchema . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SchemaSelectorExtensions Class
Selected Overload
SchemaExplorer Namespace


SchemaSelectorExtensions.Selected Method (IEnumerable(TableKeySchema))

SchemaSelectorExtensionsSelected Method (IEnumerableTableKeySchema)

Filters the specified table keys to those that are selected using the rules defined in SchemaSelector. All tables and columns that are part of the key need to be selected for the key to be considered selected.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static IEnumerable<TableKeySchema> Selected(
    this IEnumerable<TableKeySchema> items
)
<ExtensionAttribute>
Public Shared Function Selected (
    items As IEnumerable(Of TableKeySchema)
) As IEnumerable(Of TableKeySchema)

Parameters

items
Type: System.Collections.GenericIEnumerable TableKeySchema
The items to be filtered.

Return Value

Type: IEnumerable TableKeySchema
An IEnumerable of the selected items.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IEnumerable TableKeySchema . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SchemaSelectorExtensions Class
Selected Overload
SchemaExplorer Namespace


SchemaSelectorExtensions.Selected Method (IEnumerable(ViewColumnSchema))

SchemaSelectorExtensionsSelected Method (IEnumerableViewColumnSchema)

Filters the specified columns to those that are selected using the rules defined in SchemaSelector.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static IEnumerable<ViewColumnSchema> Selected(
    this IEnumerable<ViewColumnSchema> items
)
<ExtensionAttribute>
Public Shared Function Selected (
    items As IEnumerable(Of ViewColumnSchema)
) As IEnumerable(Of ViewColumnSchema)

Parameters

items
Type: System.Collections.GenericIEnumerable ViewColumnSchema
The items to be filtered.

Return Value

Type: IEnumerable ViewColumnSchema
An IEnumerable of the selected items.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IEnumerable ViewColumnSchema . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SchemaSelectorExtensions Class
Selected Overload
SchemaExplorer Namespace


SchemaSelectorExtensions.Selected(TTabular) Method (IEnumerable(TTabular))

SchemaSelectorExtensionsSelectedTTabular Method (IEnumerableTTabular)

Filters the specified tables to those that are selected using the rules defined in SchemaSelector.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static IEnumerable<TTabular> Selected<TTabular>(
    this IEnumerable<TTabular> items
)
where TTabular : ITabularObject

<ExtensionAttribute>
Public Shared Function Selected(Of TTabular As ITabularObject) (
    items As IEnumerable(Of TTabular)
) As IEnumerable(Of TTabular)

Parameters

items
Type: System.Collections.GenericIEnumerable TTabular
The items to be filtered.

Type Parameters

TTabular
The type of the tabular item.

Return Value

Type: IEnumerable TTabular
An IEnumerable of the selected items.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IEnumerable TTabular. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SchemaSelectorExtensions Class
Selected Overload
SchemaExplorer Namespace


SchemaSelectorExtensions.Selected Method (IPrimaryKeySchema)

SchemaSelectorExtensionsSelected Method (IPrimaryKeySchema)

Determines if the specified item is selected using the rules defined in SchemaSelector. All tables and columns that are part of the key need to be selected for the key to be considered selected.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static bool Selected(
    this IPrimaryKeySchema item
)
<ExtensionAttribute>
Public Shared Function Selected (
    item As IPrimaryKeySchema
) As Boolean

Parameters

item
Type: SchemaExplorerIPrimaryKeySchema
The item to determine selection.

Return Value

Type: Boolean
true if the speciefied item is selected; otherwise false.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IPrimaryKeySchema. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SchemaSelectorExtensions Class
Selected Overload
SchemaExplorer Namespace
SchemaSelector


SchemaSelectorExtensions.Selected Method (ITableKeySchema)

SchemaSelectorExtensionsSelected Method (ITableKeySchema)

Determines if the specified item is selected using the rules defined in SchemaSelector. All tables and columns that are part of the key need to be selected for the key to be considered selected.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static bool Selected(
    this ITableKeySchema item
)
<ExtensionAttribute>
Public Shared Function Selected (
    item As ITableKeySchema
) As Boolean

Parameters

item
Type: SchemaExplorerITableKeySchema
The item to determine selection.

Return Value

Type: Boolean
true if the speciefied item is selected; otherwise false.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ITableKeySchema. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SchemaSelectorExtensions Class
Selected Overload
SchemaExplorer Namespace
SchemaSelector


SchemaSelectorExtensions.Selected Method (ITabularObject)

SchemaSelectorExtensionsSelected Method (ITabularObject)

Determines if the specified item is selected using the rules defined in SchemaSelector.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static bool Selected(
    this ITabularObject item
)
<ExtensionAttribute>
Public Shared Function Selected (
    item As ITabularObject
) As Boolean

Parameters

item
Type: SchemaExplorerITabularObject
The item to determine selection.

Return Value

Type: Boolean
true if the speciefied item is selected; otherwise false.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ITabularObject. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SchemaSelectorExtensions Class
Selected Overload
SchemaExplorer Namespace
SchemaSelector
SchemaSelector.SelectedTables
SchemaSelector.SchemaExpressions


SchemaSelectorExtensions.Selected Method (IViewColumnSchema)

SchemaSelectorExtensionsSelected Method (IViewColumnSchema)

Determines if the specified item is selected using the rules defined in SchemaSelector.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static bool Selected(
    this IViewColumnSchema item
)
<ExtensionAttribute>
Public Shared Function Selected (
    item As IViewColumnSchema
) As Boolean

Parameters

item
Type: SchemaExplorerIViewColumnSchema
The item to determine selection.

Return Value

Type: Boolean
true if the speciefied item is selected; otherwise false.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IViewColumnSchema. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SchemaSelectorExtensions Class
Selected Overload
SchemaExplorer Namespace
SchemaSelector
SchemaSelector.SelectedColumns
SchemaSelector.ColumnExpressions


SchemaSelectorExtensions.ToColumns Method

SchemaSelectorExtensionsToColumns Method

Overload List
Name | Description
ToColumns(IEnumerableColumnSchema) | Converts the IEnumerable of type ColumnSchema to a ColumnSchemaCollection.
ToColumns(IEnumerableViewColumnSchema) | Converts the IEnumerable of type ViewColumnSchema to a ViewColumnSchemaCollection.
Top
See Also

Reference

SchemaSelectorExtensions Class
SchemaExplorer Namespace


SchemaSelectorExtensions.ToColumns Method (IEnumerable(ColumnSchema))

SchemaSelectorExtensionsToColumns Method (IEnumerableColumnSchema)

Converts the IEnumerable of type ColumnSchema to a ColumnSchemaCollection.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static ColumnSchemaCollection ToColumns(
    this IEnumerable<ColumnSchema> items
)
<ExtensionAttribute>
Public Shared Function ToColumns (
    items As IEnumerable(Of ColumnSchema)
) As ColumnSchemaCollection

Parameters

items
Type: System.Collections.GenericIEnumerable ColumnSchema
The items to be converted.

Return Value

Type: ColumnSchemaCollection
An instance of ColumnSchemaCollection containing the specified items.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IEnumerable ColumnSchema . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SchemaSelectorExtensions Class
ToColumns Overload
SchemaExplorer Namespace


SchemaSelectorExtensions.ToColumns Method (IEnumerable(ViewColumnSchema))

SchemaSelectorExtensionsToColumns Method (IEnumerableViewColumnSchema)

Converts the IEnumerable of type ViewColumnSchema to a ViewColumnSchemaCollection.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static ViewColumnSchemaCollection ToColumns(
    this IEnumerable<ViewColumnSchema> items
)
<ExtensionAttribute>
Public Shared Function ToColumns (
    items As IEnumerable(Of ViewColumnSchema)
) As ViewColumnSchemaCollection

Parameters

items
Type: System.Collections.GenericIEnumerable ViewColumnSchema
The items to be converted.

Return Value

Type: ViewColumnSchemaCollection
An instance of ViewColumnSchemaCollection containing the specified items.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IEnumerable ViewColumnSchema . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SchemaSelectorExtensions Class
ToColumns Overload
SchemaExplorer Namespace


SchemaSelectorExtensions.ToCommands Method

SchemaSelectorExtensionsToCommands Method

Converts the IEnumerable of type CommandSchema to a CommandSchemaCollection.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static CommandSchemaCollection ToCommands(
    this IEnumerable<CommandSchema> items
)
<ExtensionAttribute>
Public Shared Function ToCommands (
    items As IEnumerable(Of CommandSchema)
) As CommandSchemaCollection

Parameters

items
Type: System.Collections.GenericIEnumerable CommandSchema
The items to be converted.

Return Value

Type: CommandSchemaCollection
An instance of CommandSchemaCollection containing the specified items.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IEnumerable CommandSchema . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SchemaSelectorExtensions Class
SchemaExplorer Namespace


SchemaSelectorExtensions.ToKeys Method

SchemaSelectorExtensionsToKeys Method

Converts the IEnumerable of type TableKeySchema to a TableKeySchemaCollection.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static TableKeySchemaCollection ToKeys(
    this IEnumerable<TableKeySchema> items
)
<ExtensionAttribute>
Public Shared Function ToKeys (
    items As IEnumerable(Of TableKeySchema)
) As TableKeySchemaCollection

Parameters

items
Type: System.Collections.GenericIEnumerable TableKeySchema
The items to be converted.

Return Value

Type: TableKeySchemaCollection
An instance of TableKeySchemaCollection containing the specified items.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IEnumerable TableKeySchema . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SchemaSelectorExtensions Class
SchemaExplorer Namespace


SchemaSelectorExtensions.ToTables Method

SchemaSelectorExtensionsToTables Method

Converts the IEnumerable of type TableSchema to a TableSchemaCollection.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static TableSchemaCollection ToTables(
    this IEnumerable<TableSchema> items
)
<ExtensionAttribute>
Public Shared Function ToTables (
    items As IEnumerable(Of TableSchema)
) As TableSchemaCollection

Parameters

items
Type: System.Collections.GenericIEnumerable TableSchema
The items to be converted.

Return Value

Type: TableSchemaCollection
An instance of TableSchemaCollection containing the specified items.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IEnumerable TableSchema . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SchemaSelectorExtensions Class
SchemaExplorer Namespace


SchemaSelectorExtensions.ToViews Method

SchemaSelectorExtensionsToViews Method

Converts the IEnumerable of type ViewSchema to a ViewSchemaCollection.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static ViewSchemaCollection ToViews(
    this IEnumerable<ViewSchema> items
)
<ExtensionAttribute>
Public Shared Function ToViews (
    items As IEnumerable(Of ViewSchema)
) As ViewSchemaCollection

Parameters

items
Type: System.Collections.GenericIEnumerable ViewSchema
The items to be converted.

Return Value

Type: ViewSchemaCollection
An instance of ViewSchemaCollection containing the specified items.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IEnumerable ViewSchema . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SchemaSelectorExtensions Class
SchemaExplorer Namespace


SchemaUtility Class

Summary description for SchemaUtility.
Inheritance Hierarchy
SystemObject
SchemaExplorerSchemaUtility

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class SchemaUtility
Public Class SchemaUtility

The SchemaUtility type exposes the following members.

Constructors
 | Name | Description
Public method | SchemaUtility | Initializes a new instance of the SchemaUtility class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetSystemType(DbType) |
 | GetSystemType(SqlDbType) |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeExtendedProperties |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SchemaExplorer Namespace


SchemaUtility Constructor

Initializes a new instance of the SchemaUtility class

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public SchemaUtility()
Public Sub New
See Also

Reference

SchemaUtility Class
SchemaExplorer Namespace


SchemaUtility Methods

The SchemaUtility type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetSystemType(DbType) |
 | GetSystemType(SqlDbType) |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeExtendedProperties |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SchemaUtility Class
SchemaExplorer Namespace


SchemaUtility.GetSystemType Method

SchemaUtilityGetSystemType Method

Overload List
Name | Description
GetSystemType(DbType) |
GetSystemType(SqlDbType) |
Top
See Also

Reference

SchemaUtility Class
SchemaExplorer Namespace


SchemaUtility.GetSystemType Method (DbType)

SchemaUtilityGetSystemType Method (DbType)

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static Type GetSystemType(
    DbType type
)
Public Shared Function GetSystemType (
    type As DbType
) As Type

Parameters

type
Type: System.DataDbType

Return Value

Type: Type
See Also

Reference

SchemaUtility Class
GetSystemType Overload
SchemaExplorer Namespace


SchemaUtility.GetSystemType Method (SqlDbType)

SchemaUtilityGetSystemType Method (SqlDbType)

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static Type GetSystemType(
    SqlDbType type
)
Public Shared Function GetSystemType (
    type As SqlDbType
) As Type

Parameters

type
Type: System.DataSqlDbType

Return Value

Type: Type
See Also

Reference

SchemaUtility Class
GetSystemType Overload
SchemaExplorer Namespace


SchemaUtility.MergeExtendedProperties Method

SchemaUtilityMergeExtendedProperties Method

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static ExtendedPropertyCollection MergeExtendedProperties(
    ExtendedPropertyCollection target,
    ExtendedPropertyCollection source
)
Public Shared Function MergeExtendedProperties (
    target As ExtendedPropertyCollection,
    source As ExtendedPropertyCollection
) As ExtendedPropertyCollection

Parameters

target
Type: SchemaExplorerExtendedPropertyCollection
source
Type: SchemaExplorerExtendedPropertyCollection

Return Value

Type: ExtendedPropertyCollection
See Also

Reference

SchemaUtility Class
SchemaExplorer Namespace


SelectMode Enumeration

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public enum SelectMode
Public Enumeration SelectMode
Members
Member name | Value | Description
Include | 0 |
Exclude | 1 |
See Also

Reference

SchemaExplorer Namespace


SortExpression Structure

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public struct SortExpression
Public Structure SortExpression

The SortExpression type exposes the following members.

Constructors
 | Name | Description
Public method | SortExpression(String) | Initializes a new instance of the SortExpression class
Public method | SortExpression(String, ListSortDirection) | Initializes a new instance of the SortExpression class
Top
Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetPropertyValue |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Fields
 | Name | Description
Public field | PropertyDescriptor |
Public field | PropertyName |
Public field | SortDirection |
Top
See Also

Reference

SchemaExplorer Namespace


SortExpression Constructor

Overload List
 | Name | Description
Public method | SortExpression(String) | Initializes a new instance of the SortExpression class
Public method | SortExpression(String, ListSortDirection) | Initializes a new instance of the SortExpression class
Top
See Also

Reference

SortExpression Structure
SchemaExplorer Namespace


SortExpression Constructor (String)

Initializes a new instance of the SortExpression class

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public SortExpression(
    string propertyName
)
Public Sub New (
    propertyName As String
)

Parameters

propertyName
Type: SystemString
See Also

Reference

SortExpression Structure
SortExpression Overload
SchemaExplorer Namespace


SortExpression Constructor (String, ListSortDirection)

Initializes a new instance of the SortExpression class

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public SortExpression(
    string propertyName,
    ListSortDirection sortDirection
)
Public Sub New (
    propertyName As String,
    sortDirection As ListSortDirection
)

Parameters

propertyName
Type: SystemString
sortDirection
Type: System.ComponentModelListSortDirection
See Also

Reference

SortExpression Structure
SortExpression Overload
SchemaExplorer Namespace


SortExpression Methods

The SortExpression type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetPropertyValue |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

SortExpression Structure
SchemaExplorer Namespace


SortExpression.GetPropertyValue Method

SortExpressionGetPropertyValue Method

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public Object GetPropertyValue(
    Object obj
)
Public Function GetPropertyValue (
    obj As Object
) As Object

Parameters

obj
Type: SystemObject

Return Value

Type: Object
See Also

Reference

SortExpression Structure
SchemaExplorer Namespace


SortExpression Fields

The SortExpression type exposes the following members.

Fields
 | Name | Description
Public field | PropertyDescriptor |
Public field | PropertyName |
Public field | SortDirection |
Top
See Also

Reference

SortExpression Structure
SchemaExplorer Namespace


SortExpression.PropertyDescriptor Field

SortExpressionPropertyDescriptor Field

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public PropertyDescriptor PropertyDescriptor
Public PropertyDescriptor As PropertyDescriptor

Field Value

Type: PropertyDescriptor
See Also

Reference

SortExpression Structure
SchemaExplorer Namespace


SortExpression.PropertyName Field

SortExpressionPropertyName Field

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string PropertyName
Public PropertyName As String

Field Value

Type: String
See Also

Reference

SortExpression Structure
SchemaExplorer Namespace


SortExpression.SortDirection Field

SortExpressionSortDirection Field

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ListSortDirection SortDirection
Public SortDirection As ListSortDirection

Field Value

Type: ListSortDirection
See Also

Reference

SortExpression Structure
SchemaExplorer Namespace


TableDependancyComparer Class

Sorts TableSchema objects based on their dependencies.
Inheritance Hierarchy
SystemObject
SchemaExplorerTableDependancyComparer

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class TableDependancyComparer : IComparer
Public Class TableDependancyComparer
    Implements IComparer

The TableDependancyComparer type exposes the following members.

Constructors
 | Name | Description
Public method | TableDependancyComparer | Initializes a new instance of the TableDependancyComparer class
Public method | TableDependancyComparer(TableSortOrder) | Initializes a new instance of the TableDependancyComparer class
Top
Properties
 | Name | Description
Public property | TableSortOrder |
Top
Methods
 | Name | Description
Public method | Compare |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SchemaExplorer Namespace


TableDependancyComparer Constructor

Overload List
 | Name | Description
Public method | TableDependancyComparer | Initializes a new instance of the TableDependancyComparer class
Public method | TableDependancyComparer(TableSortOrder) | Initializes a new instance of the TableDependancyComparer class
Top
See Also

Reference

TableDependancyComparer Class
SchemaExplorer Namespace


TableDependancyComparer Constructor

Initializes a new instance of the TableDependancyComparer class

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public TableDependancyComparer()
Public Sub New
See Also

Reference

TableDependancyComparer Class
TableDependancyComparer Overload
SchemaExplorer Namespace


TableDependancyComparer Constructor (TableSortOrder)

Initializes a new instance of the TableDependancyComparer class

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public TableDependancyComparer(
    TableSortOrder tableSortOrder
)
Public Sub New (
    tableSortOrder As TableSortOrder
)

Parameters

tableSortOrder
Type: SchemaExplorerTableSortOrder
See Also

Reference

TableDependancyComparer Class
TableDependancyComparer Overload
SchemaExplorer Namespace


TableDependancyComparer Properties

The TableDependancyComparer type exposes the following members.

Properties
 | Name | Description
Public property | TableSortOrder |
Top
See Also

Reference

TableDependancyComparer Class
SchemaExplorer Namespace


TableDependancyComparer.TableSortOrder Property

TableDependancyComparerTableSortOrder Property

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public TableSortOrder TableSortOrder { get; }
Public ReadOnly Property TableSortOrder As TableSortOrder
    Get

Property Value

Type: TableSortOrder
See Also

Reference

TableDependancyComparer Class
SchemaExplorer Namespace


TableDependancyComparer Methods

The TableDependancyComparer type exposes the following members.

Methods
 | Name | Description
Public method | Compare |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TableDependancyComparer Class
SchemaExplorer Namespace


TableDependancyComparer.Compare Method

TableDependancyComparerCompare Method

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public int Compare(
    Object x,
    Object y
)
Public Function Compare (
    x As Object,
    y As Object
) As Integer

Parameters

x
Type: SystemObject
y
Type: SystemObject

Return Value

Type: Int32

Implements

IComparerCompare(Object, Object)
See Also

Reference

TableDependancyComparer Class
SchemaExplorer Namespace


TableKeySchema Class

Provides information about a table key.
Inheritance Hierarchy
SystemObject
NamedObjectBase
SchemaExplorerSchemaObjectBase
SchemaExplorerTableKeySchema

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
public class TableKeySchema : SchemaObjectBase,
    ITableKeySchema, ISchemaObject
<SerializableAttribute>
Public Class TableKeySchema
    Inherits SchemaObjectBase
    Implements ITableKeySchema, ISchemaObject

The TableKeySchema type exposes the following members.

Constructors
 | Name | Description
Public method | TableKeySchema(String, TableSchema, TableSchema, ExtendedProperty) | Initializes a new instance of the TableKeySchema class
Public method | TableKeySchema(DatabaseSchema, String, String, String, String, String) | Initializes a new instance of the TableKeySchema class
Public method | TableKeySchema(DatabaseSchema, String, String, String, String, String, ExtendedProperty) | Initializes a new instance of the TableKeySchema class
Public method | TableKeySchema(DatabaseSchema, String, String, String, String, String, String, String) | Initializes a new instance of the TableKeySchema class
Public method | TableKeySchema(DatabaseSchema, String, String, String, String, String, String, String, ExtendedProperty) | Initializes a new instance of the TableKeySchema class
Top
Properties
 | Name | Description
Public property | Database | Allows access to the DatabaseSchema object that contains this schema object. (Inherited from SchemaObjectBase.)
Public property | DateCreated | Returns the date this table was created. (Inherited from SchemaObjectBase.)
Public property | DeepLoad | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from SchemaObjectBase.)
Public property | Description | The description of the object. (Inherited from SchemaObjectBase.)
Public property | ExtendedProperties | Used to store any additional information about the schema object. (Inherited from SchemaObjectBase.)
Public property | ForeignKeyMemberColumns | The foreign key table columns that make up this key.
Public property | ForeignKeyTable | The foreign key table.
Public property | FullName | Returns the owner and name of the table. (Inherited from SchemaObjectBase.)
Public property | IncludeFunctions | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from SchemaObjectBase.)
Public property | PrimaryKey | The primary key for the table that this key refers to.
Public property | PrimaryKeyMemberColumns | The primary key table columns that make up this key.
Public property | PrimaryKeyTable | The primary key table.
Public property | SortName | Gets the name used to sort in 'Table (Owner)' format. (Inherited from SchemaObjectBase.)
Top
Methods
 | Name | Description
Public method | Equals | Determines if another table key is the same as this table key. (Overrides SchemaObjectBaseEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FormatFullName | Formats the full name.
Public method | GetHashCode | Returns a hashcode based on the database, table and name of the table key. (Overrides SchemaObjectBaseGetHashCode.)
Public method | GetLoadedExtendedProperties | Gets the existing ExtendedProperties without causing a lazy load. (Inherited from SchemaObjectBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MarkLoaded | (Inherited from SchemaObjectBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh | Refresh this object. (Overrides SchemaObjectBaseRefresh.)
Top
Fields
 | Name | Description
Protected field | _database | (Inherited from SchemaObjectBase.)
Protected field | _dateCreated | (Inherited from SchemaObjectBase.)
Protected field | _defaultExtendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _extendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _gotExtendedProperties | (Inherited from SchemaObjectBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Selected | Determines if the specified item is selected using the rules defined in SchemaSelector. All tables and columns that are part of the key need to be selected for the key to be considered selected. (Defined by SchemaSelectorExtensions.)
Top
See Also

Reference

SchemaExplorer Namespace


TableKeySchema Constructor

Overload List
 | Name | Description
Public method | TableKeySchema(String, TableSchema, TableSchema, ExtendedProperty) | Initializes a new instance of the TableKeySchema class
Public method | TableKeySchema(DatabaseSchema, String, String, String, String, String) | Initializes a new instance of the TableKeySchema class
Public method | TableKeySchema(DatabaseSchema, String, String, String, String, String, ExtendedProperty) | Initializes a new instance of the TableKeySchema class
Public method | TableKeySchema(DatabaseSchema, String, String, String, String, String, String, String) | Initializes a new instance of the TableKeySchema class
Public method | TableKeySchema(DatabaseSchema, String, String, String, String, String, String, String, ExtendedProperty) | Initializes a new instance of the TableKeySchema class
Top
See Also

Reference

TableKeySchema Class
SchemaExplorer Namespace


TableKeySchema Constructor (String, TableSchema, TableSchema, ExtendedProperty[])

TableKeySchema Constructor (String, TableSchema, TableSchema, ExtendedProperty)

Initializes a new instance of the TableKeySchema class

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public TableKeySchema(
    string name,
    TableSchema foreignKeyTable,
    TableSchema primaryKeyTable,
    ExtendedProperty[] extendedProperties
)
Public Sub New (
    name As String,
    foreignKeyTable As TableSchema,
    primaryKeyTable As TableSchema,
    extendedProperties As ExtendedProperty()
)

Parameters

name
Type: SystemString
foreignKeyTable
Type: SchemaExplorerTableSchema
primaryKeyTable
Type: SchemaExplorerTableSchema
extendedProperties
Type: SchemaExplorerExtendedProperty
See Also

Reference

TableKeySchema Class
TableKeySchema Overload
SchemaExplorer Namespace


TableKeySchema Constructor (DatabaseSchema, String, String[], String, String[], String)

TableKeySchema Constructor (DatabaseSchema, String, String, String, String, String)

Initializes a new instance of the TableKeySchema class

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public TableKeySchema(
    DatabaseSchema database,
    string name,
    string[] foreignKeyMemberColumns,
    string foreignKeyTable,
    string[] primaryKeyMemberColumns,
    string primaryKeyTable
)
Public Sub New (
    database As DatabaseSchema,
    name As String,
    foreignKeyMemberColumns As String(),
    foreignKeyTable As String,
    primaryKeyMemberColumns As String(),
    primaryKeyTable As String
)

Parameters

database
Type: SchemaExplorerDatabaseSchema
name
Type: SystemString
foreignKeyMemberColumns
Type: SystemString
foreignKeyTable
Type: SystemString
primaryKeyMemberColumns
Type: SystemString
primaryKeyTable
Type: SystemString
See Also

Reference

TableKeySchema Class
TableKeySchema Overload
SchemaExplorer Namespace


TableKeySchema Constructor (DatabaseSchema, String, String[], String, String[], String, ExtendedProperty[])

TableKeySchema Constructor (DatabaseSchema, String, String, String, String, String, ExtendedProperty)

Initializes a new instance of the TableKeySchema class

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public TableKeySchema(
    DatabaseSchema database,
    string name,
    string[] foreignKeyMemberColumns,
    string foreignKeyTable,
    string[] primaryKeyMemberColumns,
    string primaryKeyTable,
    ExtendedProperty[] extendedProperties
)
Public Sub New (
    database As DatabaseSchema,
    name As String,
    foreignKeyMemberColumns As String(),
    foreignKeyTable As String,
    primaryKeyMemberColumns As String(),
    primaryKeyTable As String,
    extendedProperties As ExtendedProperty()
)

Parameters

database
Type: SchemaExplorerDatabaseSchema
name
Type: SystemString
foreignKeyMemberColumns
Type: SystemString
foreignKeyTable
Type: SystemString
primaryKeyMemberColumns
Type: SystemString
primaryKeyTable
Type: SystemString
extendedProperties
Type: SchemaExplorerExtendedProperty
See Also

Reference

TableKeySchema Class
TableKeySchema Overload
SchemaExplorer Namespace


TableKeySchema Constructor (DatabaseSchema, String, String[], String, String, String[], String, String)

TableKeySchema Constructor (DatabaseSchema, String, String, String, String, String, String, String)

Initializes a new instance of the TableKeySchema class

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public TableKeySchema(
    DatabaseSchema database,
    string name,
    string[] foreignKeyMemberColumns,
    string foreignKeyTableOwner,
    string foreignKeyTable,
    string[] primaryKeyMemberColumns,
    string primaryKeyTableOwner,
    string primaryKeyTable
)
Public Sub New (
    database As DatabaseSchema,
    name As String,
    foreignKeyMemberColumns As String(),
    foreignKeyTableOwner As String,
    foreignKeyTable As String,
    primaryKeyMemberColumns As String(),
    primaryKeyTableOwner As String,
    primaryKeyTable As String
)

Parameters

database
Type: SchemaExplorerDatabaseSchema
name
Type: SystemString
foreignKeyMemberColumns
Type: SystemString
foreignKeyTableOwner
Type: SystemString
foreignKeyTable
Type: SystemString
primaryKeyMemberColumns
Type: SystemString
primaryKeyTableOwner
Type: SystemString
primaryKeyTable
Type: SystemString
See Also

Reference

TableKeySchema Class
TableKeySchema Overload
SchemaExplorer Namespace


TableKeySchema Constructor (DatabaseSchema, String, String[], String, String, String[], String, String, ExtendedProperty[])

TableKeySchema Constructor (DatabaseSchema, String, String, String, String, String, String, String, ExtendedProperty)

Initializes a new instance of the TableKeySchema class

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public TableKeySchema(
    DatabaseSchema database,
    string name,
    string[] foreignKeyMemberColumns,
    string foreignKeyTableOwner,
    string foreignKeyTable,
    string[] primaryKeyMemberColumns,
    string primaryKeyTableOwner,
    string primaryKeyTable,
    ExtendedProperty[] extendedProperties
)
Public Sub New (
    database As DatabaseSchema,
    name As String,
    foreignKeyMemberColumns As String(),
    foreignKeyTableOwner As String,
    foreignKeyTable As String,
    primaryKeyMemberColumns As String(),
    primaryKeyTableOwner As String,
    primaryKeyTable As String,
    extendedProperties As ExtendedProperty()
)

Parameters

database
Type: SchemaExplorerDatabaseSchema
name
Type: SystemString
foreignKeyMemberColumns
Type: SystemString
foreignKeyTableOwner
Type: SystemString
foreignKeyTable
Type: SystemString
primaryKeyMemberColumns
Type: SystemString
primaryKeyTableOwner
Type: SystemString
primaryKeyTable
Type: SystemString
extendedProperties
Type: SchemaExplorerExtendedProperty
See Also

Reference

TableKeySchema Class
TableKeySchema Overload
SchemaExplorer Namespace


TableKeySchema Properties

The TableKeySchema type exposes the following members.

Properties
 | Name | Description
Public property | Database | Allows access to the DatabaseSchema object that contains this schema object. (Inherited from SchemaObjectBase.)
Public property | DateCreated | Returns the date this table was created. (Inherited from SchemaObjectBase.)
Public property | DeepLoad | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from SchemaObjectBase.)
Public property | Description | The description of the object. (Inherited from SchemaObjectBase.)
Public property | ExtendedProperties | Used to store any additional information about the schema object. (Inherited from SchemaObjectBase.)
Public property | ForeignKeyMemberColumns | The foreign key table columns that make up this key.
Public property | ForeignKeyTable | The foreign key table.
Public property | FullName | Returns the owner and name of the table. (Inherited from SchemaObjectBase.)
Public property | IncludeFunctions | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from SchemaObjectBase.)
Public property | PrimaryKey | The primary key for the table that this key refers to.
Public property | PrimaryKeyMemberColumns | The primary key table columns that make up this key.
Public property | PrimaryKeyTable | The primary key table.
Public property | SortName | Gets the name used to sort in 'Table (Owner)' format. (Inherited from SchemaObjectBase.)
Top
See Also

Reference

TableKeySchema Class
SchemaExplorer Namespace


TableKeySchema.ForeignKeyMemberColumns Property

TableKeySchemaForeignKeyMemberColumns Property

The foreign key table columns that make up this key.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public MemberColumnSchemaCollection ForeignKeyMemberColumns { get; }
Public ReadOnly Property ForeignKeyMemberColumns As MemberColumnSchemaCollection
    Get

Property Value

Type: MemberColumnSchemaCollection
See Also

Reference

TableKeySchema Class
SchemaExplorer Namespace


TableKeySchema.ForeignKeyTable Property

TableKeySchemaForeignKeyTable Property

The foreign key table.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public TableSchema ForeignKeyTable { get; }
Public ReadOnly Property ForeignKeyTable As TableSchema
    Get

Property Value

Type: TableSchema
See Also

Reference

TableKeySchema Class
SchemaExplorer Namespace


TableKeySchema.PrimaryKey Property

TableKeySchemaPrimaryKey Property

The primary key for the table that this key refers to.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public PrimaryKeySchema PrimaryKey { get; }
Public ReadOnly Property PrimaryKey As PrimaryKeySchema
    Get

Property Value

Type: PrimaryKeySchema
See Also

Reference

TableKeySchema Class
SchemaExplorer Namespace


TableKeySchema.PrimaryKeyMemberColumns Property

TableKeySchemaPrimaryKeyMemberColumns Property

The primary key table columns that make up this key.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public MemberColumnSchemaCollection PrimaryKeyMemberColumns { get; }
Public ReadOnly Property PrimaryKeyMemberColumns As MemberColumnSchemaCollection
    Get

Property Value

Type: MemberColumnSchemaCollection
See Also

Reference

TableKeySchema Class
SchemaExplorer Namespace


TableKeySchema.PrimaryKeyTable Property

TableKeySchemaPrimaryKeyTable Property

The primary key table.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public TableSchema PrimaryKeyTable { get; }
Public ReadOnly Property PrimaryKeyTable As TableSchema
    Get

Property Value

Type: TableSchema
See Also

Reference

TableKeySchema Class
SchemaExplorer Namespace


TableKeySchema Methods

The TableKeySchema type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines if another table key is the same as this table key. (Overrides SchemaObjectBaseEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FormatFullName | Formats the full name.
Public method | GetHashCode | Returns a hashcode based on the database, table and name of the table key. (Overrides SchemaObjectBaseGetHashCode.)
Public method | GetLoadedExtendedProperties | Gets the existing ExtendedProperties without causing a lazy load. (Inherited from SchemaObjectBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MarkLoaded | (Inherited from SchemaObjectBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh | Refresh this object. (Overrides SchemaObjectBaseRefresh.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Selected | Determines if the specified item is selected using the rules defined in SchemaSelector. All tables and columns that are part of the key need to be selected for the key to be considered selected. (Defined by SchemaSelectorExtensions.)
Top
See Also

Reference

TableKeySchema Class
SchemaExplorer Namespace


TableKeySchema.Equals Method

TableKeySchemaEquals Method

Determines if another table key is the same as this table key.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
The table key to check against.

Return Value

Type: Boolean
true/false
See Also

Reference

TableKeySchema Class
SchemaExplorer Namespace


TableKeySchema.FormatFullName Method

TableKeySchemaFormatFullName Method

Formats the full name.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static string FormatFullName(
    string owner,
    string tableName,
    string keyName
)
Public Shared Function FormatFullName (
    owner As String,
    tableName As String,
    keyName As String
) As String

Parameters

owner
Type: SystemString
The owner.
tableName
Type: SystemString
Name of the table.
keyName
Type: SystemString
Name of the key.

Return Value

Type: String
See Also

Reference

TableKeySchema Class
SchemaExplorer Namespace


TableKeySchema.GetHashCode Method

TableKeySchemaGetHashCode Method

Returns a hashcode based on the database, table and name of the table key.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
See Also

Reference

TableKeySchema Class
SchemaExplorer Namespace


TableKeySchema.Refresh Method

TableKeySchemaRefresh Method

Refresh this object.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override void Refresh()
Public Overrides Sub Refresh

Implements

ISchemaObjectRefresh
ISchemaObjectRefresh
See Also

Reference

TableKeySchema Class
SchemaExplorer Namespace


TableKeySchema Fields

The TableKeySchema type exposes the following members.

Fields
 | Name | Description
Protected field | _database | (Inherited from SchemaObjectBase.)
Protected field | _dateCreated | (Inherited from SchemaObjectBase.)
Protected field | _defaultExtendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _extendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _gotExtendedProperties | (Inherited from SchemaObjectBase.)
Top
See Also

Reference

TableKeySchema Class
SchemaExplorer Namespace


TableKeySchemaCollection Class

Implements a strongly typed collection of TableKeySchema elements.
Inheritance Hierarchy
SystemObject
ObservableListTableKeySchema
NamedObjectCollectionTableKeySchema
SchemaExplorerSchemaObjectCollection TableKeySchema
SchemaExplorerTableKeySchemaCollection

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
public class TableKeySchemaCollection : SchemaObjectCollection<TableKeySchema>
<SerializableAttribute>
Public Class TableKeySchemaCollection
    Inherits SchemaObjectCollection(Of TableKeySchema)

The TableKeySchemaCollection type exposes the following members.

Constructors
 | Name | Description
Public method | TableKeySchemaCollection | Initializes a new instance of the TableKeySchemaCollection class.
Public method | TableKeySchemaCollection(IEnumerableTableKeySchema) | Initializes a new instance of the TableKeySchemaCollection class.
Public method | TableKeySchemaCollection(Int32) | Initializes a new instance of the TableKeySchemaCollection class.
Top
Methods
 | Name | Description
Public method | Clone | (Inherited from SchemaObjectCollectionT.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh | (Inherited from SchemaObjectCollectionT.)
Public method | ToString | (Inherited from SchemaObjectCollectionT.)
Top
Remarks
TableKeySchemaCollection provides an SchemaObjectCollectionT that is strongly typed for TableKeySchema elements.
See Also

Reference

SchemaExplorer Namespace


TableKeySchemaCollection Constructor

Overload List
 | Name | Description
Public method | TableKeySchemaCollection | Initializes a new instance of the TableKeySchemaCollection class.
Public method | TableKeySchemaCollection(IEnumerableTableKeySchema) | Initializes a new instance of the TableKeySchemaCollection class.
Public method | TableKeySchemaCollection(Int32) | Initializes a new instance of the TableKeySchemaCollection class.
Top
See Also

Reference

TableKeySchemaCollection Class
SchemaExplorer Namespace


TableKeySchemaCollection Constructor

Initializes a new instance of the TableKeySchemaCollection class.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public TableKeySchemaCollection()
Public Sub New
See Also

Reference

TableKeySchemaCollection Class
TableKeySchemaCollection Overload
SchemaExplorer Namespace


TableKeySchemaCollection Constructor (IEnumerable(TableKeySchema))

TableKeySchemaCollection Constructor (IEnumerableTableKeySchema)

Initializes a new instance of the TableKeySchemaCollection class.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public TableKeySchemaCollection(
    IEnumerable<TableKeySchema> collection
)
Public Sub New (
    collection As IEnumerable(Of TableKeySchema)
)

Parameters

collection
Type: System.Collections.GenericIEnumerable TableKeySchema
The collection from which the elements are copied.
See Also

Reference

TableKeySchemaCollection Class
TableKeySchemaCollection Overload
SchemaExplorer Namespace


TableKeySchemaCollection Constructor (Int32)

Initializes a new instance of the TableKeySchemaCollection class.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public TableKeySchemaCollection(
    int capacity
)
Public Sub New (
    capacity As Integer
)

Parameters

capacity
Type: SystemInt32
The number of elements that the new list can initially store.
See Also

Reference

TableKeySchemaCollection Class
TableKeySchemaCollection Overload
SchemaExplorer Namespace


TableKeySchemaCollection Methods

The TableKeySchemaCollection type exposes the following members.

Methods
 | Name | Description
Public method | Clone | (Inherited from SchemaObjectCollectionT.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh | (Inherited from SchemaObjectCollectionT.)
Public method | ToString | (Inherited from SchemaObjectCollectionT.)
Top
See Also

Reference

TableKeySchemaCollection Class
SchemaExplorer Namespace


TableSchema Class

Provides information about a database table.
Inheritance Hierarchy
SystemObject
NamedObjectBase
SchemaExplorerSchemaObjectBase
SchemaExplorerSchemaObjectWithOwnerBase
SchemaExplorerTabularObjectBase
SchemaExplorerTableSchema

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
public class TableSchema : TabularObjectBase,
    ITableSchema, ITabularObject, ISchemaObjectWithOwner, ISchemaObject
<SerializableAttribute>
Public Class TableSchema
    Inherits TabularObjectBase
    Implements ITableSchema, ITabularObject, ISchemaObjectWithOwner, ISchemaObject

The TableSchema type exposes the following members.

Constructors
 | Name | Description
Public method | TableSchema(DatabaseSchema, String, String, DateTime) | Initializes a new instance of the TableSchema class
Public method | TableSchema(DatabaseSchema, String, String, DateTime, ExtendedProperty) | Initializes a new instance of the TableSchema class
Top
Properties
 | Name | Description
Public property | Columns | Provides information about the table columns.
Public property | Database | Allows access to the DatabaseSchema object that contains this schema object. (Inherited from SchemaObjectBase.)
Public property | DataObjects | (Overrides TabularObjectBaseDataObjects.)
Public property | DateCreated | Returns the date this table was created. (Inherited from SchemaObjectBase.)
Public property | DeepLoad | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from SchemaObjectBase.)
Public property | Description | The description of the object. (Inherited from SchemaObjectBase.)
Public property | ExtendedProperties | Used to store any additional information about the schema object. (Inherited from SchemaObjectBase.)
Public property | ForeignKeyColumns | Provides information about all columns who are members of a foreign key.
Public property | ForeignKeys | Provides information about the foreign keys (keys where the current table is the foreign table) contained in the table.
Public property | FullName | Returns the owner and name of the table. (Inherited from SchemaObjectWithOwnerBase.)
Public property | HasPrimaryKey | Provides information about the primary key of the table.
Public property | IncludeFunctions | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from SchemaObjectBase.)
Public property | Indexes | Provides information about the indexes contained in the table.
Public property | Item | Index to allow easy access to the columns in this schema object. (Inherited from TabularObjectBase.)
Public property | Keys | Provides information about the keys contained in the table.
Public property | NonForeignKeyColumns | Provides information about all columns who are not members of a foreign key.
Public property | NonKeyColumns | Provides information about all non-key columns.
Public property | NonPrimaryKeyColumns | Provides information about all non-primary key table columns.
Public property | Owner | Returns the owner of the table. (Inherited from SchemaObjectWithOwnerBase.)
Public property | PrimaryKey | Provides information about the primary key of the table.
Public property | PrimaryKeys | Provides information about the primary keys (keys where the current table is the primary table) contained in the table.
Public property | SortName | Gets the name used to sort in 'Table (Owner)' format. (Inherited from SchemaObjectWithOwnerBase.)
Top
Methods
 | Name | Description
Public method | Equals | Determines if another table is the same as this table. (Inherited from SchemaObjectWithOwnerBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetData | Gets the data contained within the table. (Inherited from TabularObjectBase.)
Public method | GetHashCode | Returns a HashCode based on the database and name of the table. (Inherited from SchemaObjectWithOwnerBase.)
Public method | GetLoadedExtendedProperties | Gets the existing ExtendedProperties without causing a lazy load. (Inherited from SchemaObjectBase.)
Public method | GetTableData | Gets the data contained within the table.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDependantOf | Determines whether the current table is a dependant of the supplied table.
Public method | MarkLoaded | (Inherited from SchemaObjectBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh | Allows you to refresh the information for this table. (Overrides TabularObjectBaseRefresh.)
Public method | ToString | Returns the name of the table. (Inherited from SchemaObjectWithOwnerBase.)
Top
Fields
 | Name | Description
Protected field | _database | (Inherited from SchemaObjectBase.)
Protected field | _dataObjects | (Inherited from TabularObjectBase.)
Protected field | _dateCreated | (Inherited from SchemaObjectBase.)
Protected field | _defaultExtendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _extendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _gotExtendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _owner | (Inherited from SchemaObjectWithOwnerBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Selected | Determines if the specified item is selected using the rules defined in SchemaSelector. (Defined by SchemaSelectorExtensions.)
Top
See Also

Reference

SchemaExplorer Namespace


TableSchema Constructor

Overload List
 | Name | Description
Public method | TableSchema(DatabaseSchema, String, String, DateTime) | Initializes a new instance of the TableSchema class
Public method | TableSchema(DatabaseSchema, String, String, DateTime, ExtendedProperty) | Initializes a new instance of the TableSchema class
Top
See Also

Reference

TableSchema Class
SchemaExplorer Namespace


TableSchema Constructor (DatabaseSchema, String, String, DateTime)

Initializes a new instance of the TableSchema class

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public TableSchema(
    DatabaseSchema database,
    string name,
    string owner,
    DateTime dateCreated
)
Public Sub New (
    database As DatabaseSchema,
    name As String,
    owner As String,
    dateCreated As DateTime
)

Parameters

database
Type: SchemaExplorerDatabaseSchema
name
Type: SystemString
owner
Type: SystemString
dateCreated
Type: SystemDateTime
See Also

Reference

TableSchema Class
TableSchema Overload
SchemaExplorer Namespace


TableSchema Constructor (DatabaseSchema, String, String, DateTime, ExtendedProperty[])

TableSchema Constructor (DatabaseSchema, String, String, DateTime, ExtendedProperty)

Initializes a new instance of the TableSchema class

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public TableSchema(
    DatabaseSchema database,
    string name,
    string owner,
    DateTime dateCreated,
    ExtendedProperty[] extendedProperties
)
Public Sub New (
    database As DatabaseSchema,
    name As String,
    owner As String,
    dateCreated As DateTime,
    extendedProperties As ExtendedProperty()
)

Parameters

database
Type: SchemaExplorerDatabaseSchema
name
Type: SystemString
owner
Type: SystemString
dateCreated
Type: SystemDateTime
extendedProperties
Type: SchemaExplorerExtendedProperty
See Also

Reference

TableSchema Class
TableSchema Overload
SchemaExplorer Namespace


TableSchema Properties

The TableSchema type exposes the following members.

Properties
 | Name | Description
Public property | Columns | Provides information about the table columns.
Public property | Database | Allows access to the DatabaseSchema object that contains this schema object. (Inherited from SchemaObjectBase.)
Public property | DataObjects | (Overrides TabularObjectBaseDataObjects.)
Public property | DateCreated | Returns the date this table was created. (Inherited from SchemaObjectBase.)
Public property | DeepLoad | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from SchemaObjectBase.)
Public property | Description | The description of the object. (Inherited from SchemaObjectBase.)
Public property | ExtendedProperties | Used to store any additional information about the schema object. (Inherited from SchemaObjectBase.)
Public property | ForeignKeyColumns | Provides information about all columns who are members of a foreign key.
Public property | ForeignKeys | Provides information about the foreign keys (keys where the current table is the foreign table) contained in the table.
Public property | FullName | Returns the owner and name of the table. (Inherited from SchemaObjectWithOwnerBase.)
Public property | HasPrimaryKey | Provides information about the primary key of the table.
Public property | IncludeFunctions | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from SchemaObjectBase.)
Public property | Indexes | Provides information about the indexes contained in the table.
Public property | Item | Index to allow easy access to the columns in this schema object. (Inherited from TabularObjectBase.)
Public property | Keys | Provides information about the keys contained in the table.
Public property | NonForeignKeyColumns | Provides information about all columns who are not members of a foreign key.
Public property | NonKeyColumns | Provides information about all non-key columns.
Public property | NonPrimaryKeyColumns | Provides information about all non-primary key table columns.
Public property | Owner | Returns the owner of the table. (Inherited from SchemaObjectWithOwnerBase.)
Public property | PrimaryKey | Provides information about the primary key of the table.
Public property | PrimaryKeys | Provides information about the primary keys (keys where the current table is the primary table) contained in the table.
Public property | SortName | Gets the name used to sort in 'Table (Owner)' format. (Inherited from SchemaObjectWithOwnerBase.)
Top
See Also

Reference

TableSchema Class
SchemaExplorer Namespace


TableSchema.Columns Property

TableSchemaColumns Property

Provides information about the table columns.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ColumnSchemaCollection Columns { get; set; }
Public Property Columns As ColumnSchemaCollection
    Get
    Set

Property Value

Type: ColumnSchemaCollection
See Also

Reference

TableSchema Class
SchemaExplorer Namespace


TableSchema.DataObjects Property

TableSchemaDataObjects Property

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override IReadOnlyNamedObjectCollection<IDataObject> DataObjects { get; }
Public Overrides ReadOnly Property DataObjects As IReadOnlyNamedObjectCollection(Of IDataObject)
    Get

Property Value

Type: IReadOnlyNamedObjectCollectionIDataObject

Implements

ITabularObjectDataObjects
ITabularObjectDataObjects
See Also

Reference

TableSchema Class
SchemaExplorer Namespace


TableSchema.ForeignKeyColumns Property

TableSchemaForeignKeyColumns Property

Provides information about all columns who are members of a foreign key.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ColumnSchemaCollection ForeignKeyColumns { get; }
Public ReadOnly Property ForeignKeyColumns As ColumnSchemaCollection
    Get

Property Value

Type: ColumnSchemaCollection
See Also

Reference

TableSchema Class
SchemaExplorer Namespace


TableSchema.ForeignKeys Property

TableSchemaForeignKeys Property

Provides information about the foreign keys (keys where the current table is the foreign table) contained in the table.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public TableKeySchemaCollection ForeignKeys { get; }
Public ReadOnly Property ForeignKeys As TableKeySchemaCollection
    Get

Property Value

Type: TableKeySchemaCollection
See Also

Reference

TableSchema Class
SchemaExplorer Namespace


TableSchema.HasPrimaryKey Property

TableSchemaHasPrimaryKey Property

Provides information about the primary key of the table.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool HasPrimaryKey { get; }
Public ReadOnly Property HasPrimaryKey As Boolean
    Get

Property Value

Type: Boolean

Implements

ITableSchemaHasPrimaryKey
See Also

Reference

TableSchema Class
SchemaExplorer Namespace


TableSchema.Indexes Property

TableSchemaIndexes Property

Provides information about the indexes contained in the table.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public IndexSchemaCollection Indexes { get; set; }
Public Property Indexes As IndexSchemaCollection
    Get
    Set

Property Value

Type: IndexSchemaCollection
See Also

Reference

TableSchema Class
SchemaExplorer Namespace


TableSchema.Keys Property

TableSchemaKeys Property

Provides information about the keys contained in the table.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public TableKeySchemaCollection Keys { get; set; }
Public Property Keys As TableKeySchemaCollection
    Get
    Set

Property Value

Type: TableKeySchemaCollection
See Also

Reference

TableSchema Class
SchemaExplorer Namespace


TableSchema.NonForeignKeyColumns Property

TableSchemaNonForeignKeyColumns Property

Provides information about all columns who are not members of a foreign key.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ColumnSchemaCollection NonForeignKeyColumns { get; }
Public ReadOnly Property NonForeignKeyColumns As ColumnSchemaCollection
    Get

Property Value

Type: ColumnSchemaCollection
See Also

Reference

TableSchema Class
SchemaExplorer Namespace


TableSchema.NonKeyColumns Property

TableSchemaNonKeyColumns Property

Provides information about all non-key columns.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ColumnSchemaCollection NonKeyColumns { get; }
Public ReadOnly Property NonKeyColumns As ColumnSchemaCollection
    Get

Property Value

Type: ColumnSchemaCollection
See Also

Reference

TableSchema Class
SchemaExplorer Namespace


TableSchema.NonPrimaryKeyColumns Property

TableSchemaNonPrimaryKeyColumns Property

Provides information about all non-primary key table columns.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ColumnSchemaCollection NonPrimaryKeyColumns { get; }
Public ReadOnly Property NonPrimaryKeyColumns As ColumnSchemaCollection
    Get

Property Value

Type: ColumnSchemaCollection
See Also

Reference

TableSchema Class
SchemaExplorer Namespace


TableSchema.PrimaryKey Property

TableSchemaPrimaryKey Property

Provides information about the primary key of the table.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public PrimaryKeySchema PrimaryKey { get; set; }
Public Property PrimaryKey As PrimaryKeySchema
    Get
    Set

Property Value

Type: PrimaryKeySchema
See Also

Reference

TableSchema Class
SchemaExplorer Namespace


TableSchema.PrimaryKeys Property

TableSchemaPrimaryKeys Property

Provides information about the primary keys (keys where the current table is the primary table) contained in the table.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public TableKeySchemaCollection PrimaryKeys { get; }
Public ReadOnly Property PrimaryKeys As TableKeySchemaCollection
    Get

Property Value

Type: TableKeySchemaCollection
See Also

Reference

TableSchema Class
SchemaExplorer Namespace


TableSchema Methods

The TableSchema type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines if another table is the same as this table. (Inherited from SchemaObjectWithOwnerBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetData | Gets the data contained within the table. (Inherited from TabularObjectBase.)
Public method | GetHashCode | Returns a HashCode based on the database and name of the table. (Inherited from SchemaObjectWithOwnerBase.)
Public method | GetLoadedExtendedProperties | Gets the existing ExtendedProperties without causing a lazy load. (Inherited from SchemaObjectBase.)
Public method | GetTableData | Gets the data contained within the table.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDependantOf | Determines whether the current table is a dependant of the supplied table.
Public method | MarkLoaded | (Inherited from SchemaObjectBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh | Allows you to refresh the information for this table. (Overrides TabularObjectBaseRefresh.)
Public method | ToString | Returns the name of the table. (Inherited from SchemaObjectWithOwnerBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Selected | Determines if the specified item is selected using the rules defined in SchemaSelector. (Defined by SchemaSelectorExtensions.)
Top
See Also

Reference

TableSchema Class
SchemaExplorer Namespace


TableSchema.GetTableData Method

TableSchemaGetTableData Method

Gets the data contained within the table.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public DataTable GetTableData()
Public Function GetTableData As DataTable

Return Value

Type: DataTable

Implements

ITableSchemaGetTableData
See Also

Reference

TableSchema Class
SchemaExplorer Namespace


TableSchema.IsDependantOf Method

TableSchemaIsDependantOf Method

Determines whether the current table is a dependant of the supplied table.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool IsDependantOf(
    ITableSchema table
)
Public Function IsDependantOf (
    table As ITableSchema
) As Boolean

Parameters

table
Type: SchemaExplorerITableSchema
The table to check against.

Return Value

Type: Boolean
true/false
See Also

Reference

TableSchema Class
SchemaExplorer Namespace


TableSchema.Refresh Method

TableSchemaRefresh Method

Allows you to refresh the information for this table.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override void Refresh()
Public Overrides Sub Refresh

Implements

ISchemaObjectRefresh
ISchemaObjectRefresh
ISchemaObjectRefresh
See Also

Reference

TableSchema Class
SchemaExplorer Namespace


TableSchema Fields

The TableSchema type exposes the following members.

Fields
 | Name | Description
Protected field | _database | (Inherited from SchemaObjectBase.)
Protected field | _dataObjects | (Inherited from TabularObjectBase.)
Protected field | _dateCreated | (Inherited from SchemaObjectBase.)
Protected field | _defaultExtendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _extendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _gotExtendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _owner | (Inherited from SchemaObjectWithOwnerBase.)
Top
See Also

Reference

TableSchema Class
SchemaExplorer Namespace


TableSchemaCollection Class

Implements a strongly typed collection of TableSchema elements.
Inheritance Hierarchy
SystemObject
ObservableListTableSchema
NamedObjectCollectionTableSchema
SchemaExplorerSchemaObjectCollection TableSchema
SchemaExplorerSchemaObjectWithOwnerCollection TableSchema
SchemaExplorerTableSchemaCollection

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
public class TableSchemaCollection : SchemaObjectWithOwnerCollection<TableSchema>
<SerializableAttribute>
Public Class TableSchemaCollection
    Inherits SchemaObjectWithOwnerCollection(Of TableSchema)

The TableSchemaCollection type exposes the following members.

Constructors
 | Name | Description
Public method | TableSchemaCollection | Initializes a new instance of the TableSchemaCollection class.
Public method | TableSchemaCollection(IEnumerableTableSchema) | Initializes a new instance of the TableSchemaCollection class.
Public method | TableSchemaCollection(Int32) | Initializes a new instance of the TableSchemaCollection class.
Top
Properties
 | Name | Description
Public property | Item | Gets the TableSchema with the specified owner and name. (Inherited from SchemaObjectWithOwnerCollectionT.)
Top
Methods
 | Name | Description
Public method | Clone | (Inherited from SchemaObjectCollectionT.)
Public method | Contains | Determines whether an element is in the collection with the specified owner and name. (Inherited from SchemaObjectWithOwnerCollectionT.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of an item with the specified owner and name. (Inherited from SchemaObjectWithOwnerCollectionT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh | (Inherited from SchemaObjectCollectionT.)
Public method | ToString | (Inherited from SchemaObjectCollectionT.)
Top
Remarks
TableSchemaCollection provides an SchemaObjectWithOwnerCollectionT that is strongly typed for TableSchema elements.
See Also

Reference

SchemaExplorer Namespace


TableSchemaCollection Constructor

Overload List
 | Name | Description
Public method | TableSchemaCollection | Initializes a new instance of the TableSchemaCollection class.
Public method | TableSchemaCollection(IEnumerableTableSchema) | Initializes a new instance of the TableSchemaCollection class.
Public method | TableSchemaCollection(Int32) | Initializes a new instance of the TableSchemaCollection class.
Top
See Also

Reference

TableSchemaCollection Class
SchemaExplorer Namespace


TableSchemaCollection Constructor

Initializes a new instance of the TableSchemaCollection class.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public TableSchemaCollection()
Public Sub New
See Also

Reference

TableSchemaCollection Class
TableSchemaCollection Overload
SchemaExplorer Namespace


TableSchemaCollection Constructor (IEnumerable(TableSchema))

TableSchemaCollection Constructor (IEnumerableTableSchema)

Initializes a new instance of the TableSchemaCollection class.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public TableSchemaCollection(
    IEnumerable<TableSchema> collection
)
Public Sub New (
    collection As IEnumerable(Of TableSchema)
)

Parameters

collection
Type: System.Collections.GenericIEnumerable TableSchema
The collection from which the elements are copied.
See Also

Reference

TableSchemaCollection Class
TableSchemaCollection Overload
SchemaExplorer Namespace


TableSchemaCollection Constructor (Int32)

Initializes a new instance of the TableSchemaCollection class.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public TableSchemaCollection(
    int capacity
)
Public Sub New (
    capacity As Integer
)

Parameters

capacity
Type: SystemInt32
The number of elements that the new list can initially store.
See Also

Reference

TableSchemaCollection Class
TableSchemaCollection Overload
SchemaExplorer Namespace


TableSchemaCollection Properties

The TableSchemaCollection type exposes the following members.

Properties
 | Name | Description
Public property | Item | Gets the TableSchema with the specified owner and name. (Inherited from SchemaObjectWithOwnerCollectionT.)
Top
See Also

Reference

TableSchemaCollection Class
SchemaExplorer Namespace


TableSchemaCollection Methods

The TableSchemaCollection type exposes the following members.

Methods
 | Name | Description
Public method | Clone | (Inherited from SchemaObjectCollectionT.)
Public method | Contains | Determines whether an element is in the collection with the specified owner and name. (Inherited from SchemaObjectWithOwnerCollectionT.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of an item with the specified owner and name. (Inherited from SchemaObjectWithOwnerCollectionT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh | (Inherited from SchemaObjectCollectionT.)
Public method | ToString | (Inherited from SchemaObjectCollectionT.)
Top
See Also

Reference

TableSchemaCollection Class
SchemaExplorer Namespace


TableSortOrder Enumeration

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public enum TableSortOrder
Public Enumeration TableSortOrder
Members
Member name | Value | Description
DependantsFirst | 0 |
DependantsLast | 1 |
See Also

Reference

SchemaExplorer Namespace


TabularObject Class

Inheritance Hierarchy
SystemObject
NamedObjectBase
SchemaExplorerSchemaObjectBase
SchemaExplorerSchemaObjectWithOwnerBase
SchemaExplorerTabularObjectBase
SchemaExplorerTabularObject

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class TabularObject : TabularObjectBase
Public Class TabularObject
    Inherits TabularObjectBase

The TabularObject type exposes the following members.

Constructors
 | Name | Description
Public method | TabularObject | Initializes a new instance of the TabularObject class
Top
Properties
 | Name | Description
Public property | Database | Allows access to the DatabaseSchema object that contains this schema object. (Inherited from SchemaObjectBase.)
Public property | DataObjects | Provides information about the schema objects columns. (Inherited from TabularObjectBase.)
Public property | DateCreated | Returns the date this table was created. (Inherited from SchemaObjectBase.)
Public property | DeepLoad | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from SchemaObjectBase.)
Public property | Description | The description of the object. (Inherited from SchemaObjectBase.)
Public property | ExtendedProperties | Used to store any additional information about the schema object. (Inherited from SchemaObjectBase.)
Public property | FullName | Returns the owner and name of the table. (Inherited from SchemaObjectWithOwnerBase.)
Public property | IncludeFunctions | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from SchemaObjectBase.)
Public property | Item | Index to allow easy access to the columns in this schema object. (Inherited from TabularObjectBase.)
Public property | Owner | Returns the owner of the table. (Inherited from SchemaObjectWithOwnerBase.)
Public property | SortName | Gets the name used to sort in 'Table (Owner)' format. (Inherited from SchemaObjectWithOwnerBase.)
Top
Methods
 | Name | Description
Public method | Equals | Determines if another table is the same as this table. (Inherited from SchemaObjectWithOwnerBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetData | Gets the data contained within the table. (Inherited from TabularObjectBase.)
Public method | GetHashCode | Returns a HashCode based on the database and name of the table. (Inherited from SchemaObjectWithOwnerBase.)
Public method | GetLoadedExtendedProperties | Gets the existing ExtendedProperties without causing a lazy load. (Inherited from SchemaObjectBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MarkLoaded | (Inherited from SchemaObjectBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh | (Inherited from TabularObjectBase.)
Public method | ToString | Returns the name of the table. (Inherited from SchemaObjectWithOwnerBase.)
Top
Fields
 | Name | Description
Protected field | _database | (Inherited from SchemaObjectBase.)
Protected field | _dataObjects | (Inherited from TabularObjectBase.)
Protected field | _dateCreated | (Inherited from SchemaObjectBase.)
Protected field | _defaultExtendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _extendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _gotExtendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _owner | (Inherited from SchemaObjectWithOwnerBase.)
Top
See Also

Reference

SchemaExplorer Namespace


TabularObject Constructor

Initializes a new instance of the TabularObject class

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public TabularObject(
    ITabularObject tabularObject
)
Public Sub New (
    tabularObject As ITabularObject
)

Parameters

tabularObject
Type: SchemaExplorerITabularObject
See Also

Reference

TabularObject Class
SchemaExplorer Namespace


TabularObject Properties

The TabularObject type exposes the following members.

Properties
 | Name | Description
Public property | Database | Allows access to the DatabaseSchema object that contains this schema object. (Inherited from SchemaObjectBase.)
Public property | DataObjects | Provides information about the schema objects columns. (Inherited from TabularObjectBase.)
Public property | DateCreated | Returns the date this table was created. (Inherited from SchemaObjectBase.)
Public property | DeepLoad | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from SchemaObjectBase.)
Public property | Description | The description of the object. (Inherited from SchemaObjectBase.)
Public property | ExtendedProperties | Used to store any additional information about the schema object. (Inherited from SchemaObjectBase.)
Public property | FullName | Returns the owner and name of the table. (Inherited from SchemaObjectWithOwnerBase.)
Public property | IncludeFunctions | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from SchemaObjectBase.)
Public property | Item | Index to allow easy access to the columns in this schema object. (Inherited from TabularObjectBase.)
Public property | Owner | Returns the owner of the table. (Inherited from SchemaObjectWithOwnerBase.)
Public property | SortName | Gets the name used to sort in 'Table (Owner)' format. (Inherited from SchemaObjectWithOwnerBase.)
Top
See Also

Reference

TabularObject Class
SchemaExplorer Namespace


TabularObject Methods

The TabularObject type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines if another table is the same as this table. (Inherited from SchemaObjectWithOwnerBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetData | Gets the data contained within the table. (Inherited from TabularObjectBase.)
Public method | GetHashCode | Returns a HashCode based on the database and name of the table. (Inherited from SchemaObjectWithOwnerBase.)
Public method | GetLoadedExtendedProperties | Gets the existing ExtendedProperties without causing a lazy load. (Inherited from SchemaObjectBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MarkLoaded | (Inherited from SchemaObjectBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh | (Inherited from TabularObjectBase.)
Public method | ToString | Returns the name of the table. (Inherited from SchemaObjectWithOwnerBase.)
Top
See Also

Reference

TabularObject Class
SchemaExplorer Namespace


TabularObject Fields

The TabularObject type exposes the following members.

Fields
 | Name | Description
Protected field | _database | (Inherited from SchemaObjectBase.)
Protected field | _dataObjects | (Inherited from TabularObjectBase.)
Protected field | _dateCreated | (Inherited from SchemaObjectBase.)
Protected field | _defaultExtendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _extendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _gotExtendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _owner | (Inherited from SchemaObjectWithOwnerBase.)
Top
See Also

Reference

TabularObject Class
SchemaExplorer Namespace


TabularObjectBase Class

Provides a common base for all tabular schema objects.
Inheritance Hierarchy
SystemObject
NamedObjectBase
SchemaExplorerSchemaObjectBase
SchemaExplorerSchemaObjectWithOwnerBase
SchemaExplorerTabularObjectBase
SchemaExplorerCommandResultSchema
SchemaExplorerTableSchema
SchemaExplorerTabularObject
SchemaExplorerViewSchema

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
public abstract class TabularObjectBase : SchemaObjectWithOwnerBase,
    ITabularObject, ISchemaObjectWithOwner, ISchemaObject
<SerializableAttribute>
Public MustInherit Class TabularObjectBase
    Inherits SchemaObjectWithOwnerBase
    Implements ITabularObject, ISchemaObjectWithOwner, ISchemaObject

The TabularObjectBase type exposes the following members.

Constructors
 | Name | Description
Public method | TabularObjectBase(DatabaseSchema, String, String) | Initializes a new instance of the TabularObjectBase class
Public method | TabularObjectBase(DatabaseSchema, String, String, ExtendedProperty) | Initializes a new instance of the TabularObjectBase class
Public method | TabularObjectBase(DatabaseSchema, String, String, DateTime) | Initializes a new instance of the TabularObjectBase class
Public method | TabularObjectBase(DatabaseSchema, String, String, DateTime, ExtendedProperty) | Initializes a new instance of the TabularObjectBase class
Top
Properties
 | Name | Description
Public property | Database | Allows access to the DatabaseSchema object that contains this schema object. (Inherited from SchemaObjectBase.)
Public property | DataObjects | Provides information about the schema objects columns.
Public property | DateCreated | Returns the date this table was created. (Inherited from SchemaObjectBase.)
Public property | DeepLoad | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from SchemaObjectBase.)
Public property | Description | The description of the object. (Inherited from SchemaObjectBase.)
Public property | ExtendedProperties | Used to store any additional information about the schema object. (Inherited from SchemaObjectBase.)
Public property | FullName | Returns the owner and name of the table. (Inherited from SchemaObjectWithOwnerBase.)
Public property | IncludeFunctions | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from SchemaObjectBase.)
Public property | Item | Index to allow easy access to the columns in this schema object.
Public property | Owner | Returns the owner of the table. (Inherited from SchemaObjectWithOwnerBase.)
Public property | SortName | Gets the name used to sort in 'Table (Owner)' format. (Inherited from SchemaObjectWithOwnerBase.)
Top
Methods
 | Name | Description
Public method | Equals | Determines if another table is the same as this table. (Inherited from SchemaObjectWithOwnerBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetData | Gets the data contained within the table.
Public method | GetHashCode | Returns a HashCode based on the database and name of the table. (Inherited from SchemaObjectWithOwnerBase.)
Public method | GetLoadedExtendedProperties | Gets the existing ExtendedProperties without causing a lazy load. (Inherited from SchemaObjectBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MarkLoaded | (Inherited from SchemaObjectBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh | (Overrides SchemaObjectBaseRefresh.)
Public method | ToString | Returns the name of the table. (Inherited from SchemaObjectWithOwnerBase.)
Top
Fields
 | Name | Description
Protected field | _database | (Inherited from SchemaObjectBase.)
Protected field | _dataObjects |
Protected field | _dateCreated | (Inherited from SchemaObjectBase.)
Protected field | _defaultExtendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _extendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _gotExtendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _owner | (Inherited from SchemaObjectWithOwnerBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Selected | Determines if the specified item is selected using the rules defined in SchemaSelector. (Defined by SchemaSelectorExtensions.)
Top
See Also

Reference

SchemaExplorer Namespace


TabularObjectBase Constructor

Overload List
 | Name | Description
Public method | TabularObjectBase(DatabaseSchema, String, String) | Initializes a new instance of the TabularObjectBase class
Public method | TabularObjectBase(DatabaseSchema, String, String, ExtendedProperty) | Initializes a new instance of the TabularObjectBase class
Public method | TabularObjectBase(DatabaseSchema, String, String, DateTime) | Initializes a new instance of the TabularObjectBase class
Public method | TabularObjectBase(DatabaseSchema, String, String, DateTime, ExtendedProperty) | Initializes a new instance of the TabularObjectBase class
Top
See Also

Reference

TabularObjectBase Class
SchemaExplorer Namespace


TabularObjectBase Constructor (DatabaseSchema, String, String)

Initializes a new instance of the TabularObjectBase class

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public TabularObjectBase(
    DatabaseSchema database,
    string name,
    string owner
)
Public Sub New (
    database As DatabaseSchema,
    name As String,
    owner As String
)

Parameters

database
Type: SchemaExplorerDatabaseSchema
name
Type: SystemString
owner
Type: SystemString
See Also

Reference

TabularObjectBase Class
TabularObjectBase Overload
SchemaExplorer Namespace


TabularObjectBase Constructor (DatabaseSchema, String, String, ExtendedProperty[])

TabularObjectBase Constructor (DatabaseSchema, String, String, ExtendedProperty)

Initializes a new instance of the TabularObjectBase class

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public TabularObjectBase(
    DatabaseSchema database,
    string name,
    string owner,
    ExtendedProperty[] extendedProperties
)
Public Sub New (
    database As DatabaseSchema,
    name As String,
    owner As String,
    extendedProperties As ExtendedProperty()
)

Parameters

database
Type: SchemaExplorerDatabaseSchema
name
Type: SystemString
owner
Type: SystemString
extendedProperties
Type: SchemaExplorerExtendedProperty
See Also

Reference

TabularObjectBase Class
TabularObjectBase Overload
SchemaExplorer Namespace


TabularObjectBase Constructor (DatabaseSchema, String, String, DateTime)

Initializes a new instance of the TabularObjectBase class

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public TabularObjectBase(
    DatabaseSchema database,
    string name,
    string owner,
    DateTime dateCreated
)
Public Sub New (
    database As DatabaseSchema,
    name As String,
    owner As String,
    dateCreated As DateTime
)

Parameters

database
Type: SchemaExplorerDatabaseSchema
name
Type: SystemString
owner
Type: SystemString
dateCreated
Type: SystemDateTime
See Also

Reference

TabularObjectBase Class
TabularObjectBase Overload
SchemaExplorer Namespace


TabularObjectBase Constructor (DatabaseSchema, String, String, DateTime, ExtendedProperty[])

TabularObjectBase Constructor (DatabaseSchema, String, String, DateTime, ExtendedProperty)

Initializes a new instance of the TabularObjectBase class

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public TabularObjectBase(
    DatabaseSchema database,
    string name,
    string owner,
    DateTime dateCreated,
    ExtendedProperty[] extendedProperties
)
Public Sub New (
    database As DatabaseSchema,
    name As String,
    owner As String,
    dateCreated As DateTime,
    extendedProperties As ExtendedProperty()
)

Parameters

database
Type: SchemaExplorerDatabaseSchema
name
Type: SystemString
owner
Type: SystemString
dateCreated
Type: SystemDateTime
extendedProperties
Type: SchemaExplorerExtendedProperty
See Also

Reference

TabularObjectBase Class
TabularObjectBase Overload
SchemaExplorer Namespace


TabularObjectBase Properties

The TabularObjectBase type exposes the following members.

Properties
 | Name | Description
Public property | Database | Allows access to the DatabaseSchema object that contains this schema object. (Inherited from SchemaObjectBase.)
Public property | DataObjects | Provides information about the schema objects columns.
Public property | DateCreated | Returns the date this table was created. (Inherited from SchemaObjectBase.)
Public property | DeepLoad | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from SchemaObjectBase.)
Public property | Description | The description of the object. (Inherited from SchemaObjectBase.)
Public property | ExtendedProperties | Used to store any additional information about the schema object. (Inherited from SchemaObjectBase.)
Public property | FullName | Returns the owner and name of the table. (Inherited from SchemaObjectWithOwnerBase.)
Public property | IncludeFunctions | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from SchemaObjectBase.)
Public property | Item | Index to allow easy access to the columns in this schema object.
Public property | Owner | Returns the owner of the table. (Inherited from SchemaObjectWithOwnerBase.)
Public property | SortName | Gets the name used to sort in 'Table (Owner)' format. (Inherited from SchemaObjectWithOwnerBase.)
Top
See Also

Reference

TabularObjectBase Class
SchemaExplorer Namespace


TabularObjectBase.DataObjects Property

TabularObjectBaseDataObjects Property

Provides information about the schema objects columns.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual IReadOnlyNamedObjectCollection<IDataObject> DataObjects { get; }
Public Overridable ReadOnly Property DataObjects As IReadOnlyNamedObjectCollection(Of IDataObject)
    Get

Property Value

Type: IReadOnlyNamedObjectCollectionIDataObject

Implements

ITabularObjectDataObjects
See Also

Reference

TabularObjectBase Class
SchemaExplorer Namespace


TabularObjectBase.Item Property

TabularObjectBaseItem Property

Index to allow easy access to the columns in this schema object.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public IDataObject this[
    int index
] { get; }
Public ReadOnly Default Property Item (
    index As Integer
) As IDataObject
    Get

Parameters

index
Type: SystemInt32

Property Value

Type: IDataObject

Implements

ITabularObjectItemInt32
See Also

Reference

TabularObjectBase Class
SchemaExplorer Namespace


TabularObjectBase Methods

The TabularObjectBase type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines if another table is the same as this table. (Inherited from SchemaObjectWithOwnerBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetData | Gets the data contained within the table.
Public method | GetHashCode | Returns a HashCode based on the database and name of the table. (Inherited from SchemaObjectWithOwnerBase.)
Public method | GetLoadedExtendedProperties | Gets the existing ExtendedProperties without causing a lazy load. (Inherited from SchemaObjectBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MarkLoaded | (Inherited from SchemaObjectBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh | (Overrides SchemaObjectBaseRefresh.)
Public method | ToString | Returns the name of the table. (Inherited from SchemaObjectWithOwnerBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Selected | Determines if the specified item is selected using the rules defined in SchemaSelector. (Defined by SchemaSelectorExtensions.)
Top
See Also

Reference

TabularObjectBase Class
SchemaExplorer Namespace


TabularObjectBase.GetData Method

TabularObjectBaseGetData Method

Gets the data contained within the table.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual DataTable GetData()
Public Overridable Function GetData As DataTable

Return Value

Type: DataTable

Implements

ITabularObjectGetData
See Also

Reference

TabularObjectBase Class
SchemaExplorer Namespace


TabularObjectBase.Refresh Method

TabularObjectBaseRefresh Method

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override void Refresh()
Public Overrides Sub Refresh

Implements

ISchemaObjectRefresh
ISchemaObjectRefresh
See Also

Reference

TabularObjectBase Class
SchemaExplorer Namespace


TabularObjectBase Fields

The TabularObjectBase type exposes the following members.

Fields
 | Name | Description
Protected field | _database | (Inherited from SchemaObjectBase.)
Protected field | _dataObjects |
Protected field | _dateCreated | (Inherited from SchemaObjectBase.)
Protected field | _defaultExtendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _extendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _gotExtendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _owner | (Inherited from SchemaObjectWithOwnerBase.)
Top
See Also

Reference

TabularObjectBase Class
SchemaExplorer Namespace


TabularObjectBase._dataObjects Field

TabularObjectBase_dataObjects Field

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected IReadOnlyNamedObjectCollection<IDataObject> _dataObjects
Protected _dataObjects As IReadOnlyNamedObjectCollection(Of IDataObject)

Field Value

Type: IReadOnlyNamedObjectCollectionIDataObject
See Also

Reference

TabularObjectBase Class
SchemaExplorer Namespace


TabularObjectBaseCollection Class

Implements a strongly typed collection of SchemaObjectWithOwnerCollectionT elements.
Inheritance Hierarchy
SystemObject
ObservableListITabularObject
NamedObjectCollectionITabularObject
SchemaExplorerSchemaObjectCollection ITabularObject
SchemaExplorerSchemaObjectWithOwnerCollection ITabularObject
SchemaExplorerTabularObjectBaseCollection

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
public class TabularObjectBaseCollection : SchemaObjectWithOwnerCollection<ITabularObject>
<SerializableAttribute>
Public Class TabularObjectBaseCollection
    Inherits SchemaObjectWithOwnerCollection(Of ITabularObject)

The TabularObjectBaseCollection type exposes the following members.

Constructors
 | Name | Description
Public method | TabularObjectBaseCollection | Initializes a new instance of the TabularObjectBaseCollection class.
Public method | TabularObjectBaseCollection(IEnumerableITabularObject) | Initializes a new instance of the TabularObjectBaseCollection class.
Public method | TabularObjectBaseCollection(Int32) | Initializes a new instance of the TabularObjectBaseCollection class.
Top
Properties
 | Name | Description
Public property | Item | Gets the TableSchema with the specified owner and name. (Inherited from SchemaObjectWithOwnerCollectionT.)
Top
Methods
 | Name | Description
Public method | Clone | (Inherited from SchemaObjectCollectionT.)
Public method | Contains | Determines whether an element is in the collection with the specified owner and name. (Inherited from SchemaObjectWithOwnerCollectionT.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of an item with the specified owner and name. (Inherited from SchemaObjectWithOwnerCollectionT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh | (Inherited from SchemaObjectCollectionT.)
Public method | ToString | (Inherited from SchemaObjectCollectionT.)
Top
Remarks
TabularObjectBaseCollection provides an SchemaObjectWithOwnerCollectionT that is strongly typed for ITabularObject elements.
See Also

Reference

SchemaExplorer Namespace


TabularObjectBaseCollection Constructor

Overload List
 | Name | Description
Public method | TabularObjectBaseCollection | Initializes a new instance of the TabularObjectBaseCollection class.
Public method | TabularObjectBaseCollection(IEnumerableITabularObject) | Initializes a new instance of the TabularObjectBaseCollection class.
Public method | TabularObjectBaseCollection(Int32) | Initializes a new instance of the TabularObjectBaseCollection class.
Top
See Also

Reference

TabularObjectBaseCollection Class
SchemaExplorer Namespace


TabularObjectBaseCollection Constructor

Initializes a new instance of the TabularObjectBaseCollection class.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public TabularObjectBaseCollection()
Public Sub New
See Also

Reference

TabularObjectBaseCollection Class
TabularObjectBaseCollection Overload
SchemaExplorer Namespace


TabularObjectBaseCollection Constructor (IEnumerable(ITabularObject))

TabularObjectBaseCollection Constructor (IEnumerableITabularObject)

Initializes a new instance of the TabularObjectBaseCollection class.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public TabularObjectBaseCollection(
    IEnumerable<ITabularObject> collection
)
Public Sub New (
    collection As IEnumerable(Of ITabularObject)
)

Parameters

collection
Type: System.Collections.GenericIEnumerable ITabularObject
The collection from which the elements are copied.
See Also

Reference

TabularObjectBaseCollection Class
TabularObjectBaseCollection Overload
SchemaExplorer Namespace


TabularObjectBaseCollection Constructor (Int32)

Initializes a new instance of the TabularObjectBaseCollection class.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public TabularObjectBaseCollection(
    int capacity
)
Public Sub New (
    capacity As Integer
)

Parameters

capacity
Type: SystemInt32
The number of elements that the new list can initially store.
See Also

Reference

TabularObjectBaseCollection Class
TabularObjectBaseCollection Overload
SchemaExplorer Namespace


TabularObjectBaseCollection Properties

The TabularObjectBaseCollection type exposes the following members.

Properties
 | Name | Description
Public property | Item | Gets the TableSchema with the specified owner and name. (Inherited from SchemaObjectWithOwnerCollectionT.)
Top
See Also

Reference

TabularObjectBaseCollection Class
SchemaExplorer Namespace


TabularObjectBaseCollection Methods

The TabularObjectBaseCollection type exposes the following members.

Methods
 | Name | Description
Public method | Clone | (Inherited from SchemaObjectCollectionT.)
Public method | Contains | Determines whether an element is in the collection with the specified owner and name. (Inherited from SchemaObjectWithOwnerCollectionT.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of an item with the specified owner and name. (Inherited from SchemaObjectWithOwnerCollectionT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh | (Inherited from SchemaObjectCollectionT.)
Public method | ToString | (Inherited from SchemaObjectCollectionT.)
Top
See Also

Reference

TabularObjectBaseCollection Class
SchemaExplorer Namespace


ViewColumnSchema Class

Provides information about a view column.
Inheritance Hierarchy
SystemObject
NamedObjectBase
SchemaExplorerSchemaObjectBase
SchemaExplorerDataObjectBase
SchemaExplorerViewColumnSchema

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
public class ViewColumnSchema : DataObjectBase,
    IViewColumnSchema, IDataObject, ISchemaObject
<SerializableAttribute>
Public Class ViewColumnSchema
    Inherits DataObjectBase
    Implements IViewColumnSchema, IDataObject, ISchemaObject

The ViewColumnSchema type exposes the following members.

Constructors
 | Name | Description
Public method | ViewColumnSchema(ViewSchema, String, DbType, String, Int32, Byte, Int32) | Obsolete. Creates a new instance of the ViewColumnSchema object.
Public method | ViewColumnSchema(ViewSchema, String, DbType, String, Int32, Byte, Int32, ExtendedProperty) | Obsolete. Creates a new instance of the ViewColumnSchema object.
Public method | ViewColumnSchema(ViewSchema, String, DbType, String, Int32, Byte, Int32, Boolean) | Creates a new instance of the ViewColumnSchema object.
Public method | ViewColumnSchema(ViewSchema, String, DbType, String, Int32, Byte, Int32, Boolean, ExtendedProperty) | Creates a new instance of the ViewColumnSchema object.
Top
Properties
 | Name | Description
Public property | AllowDBNull | Whether or not the data object allows null values. (Inherited from DataObjectBase.)
Public property | Database | Allows access to the DatabaseSchema object that contains this schema object. (Inherited from SchemaObjectBase.)
Public property | DataType | The data type of a (column) parameter is specific to the .NET Framework data provider. Specifying the type converts the value of the Parameter to the data provider Type before passing the value to the data source. see also: http://msdn.microsoft.com/en-us/library/system.data.dbtype.aspx example: DbType.AnsiString (Inherited from DataObjectBase.)
Public property | DateCreated | Returns the date this table was created. (Inherited from SchemaObjectBase.)
Public property | DeepLoad | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from SchemaObjectBase.)
Public property | Description | The description of the object. (Inherited from SchemaObjectBase.)
Public property | ExtendedProperties | Used to store any additional information about the schema object. (Inherited from SchemaObjectBase.)
Public property | FullName | Returns the owner and name. (Inherited from DataObjectBase.)
Public property | IncludeFunctions | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from SchemaObjectBase.)
Public property | NativeType | This is the native data type from the database. example: nvarchar (Inherited from DataObjectBase.)
Public property | Parent | The Parent Schema Object. (Inherited from DataObjectBase.)
Public property | Precision | The precision of the data object. (Inherited from DataObjectBase.)
Public property | Scale | The scale of the data object. (Inherited from DataObjectBase.)
Public property | Size | The size of the data object. (Inherited from DataObjectBase.)
Public property | SortName | Gets the name used to sort in 'Name (Parent)' format. (Inherited from DataObjectBase.)
Public property | SystemType | The System Type that is resolved from DataType. example: typeof(System.String) (Inherited from DataObjectBase.)
Public property | View | The view that contains this column.
Top
Methods
 | Name | Description
Public method | Equals | Determines if another view column is the same as this view column. (Inherited from DataObjectBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns a hashcode based on the database, view and name of the view column. (Inherited from DataObjectBase.)
Public method | GetLoadedExtendedProperties | Gets the existing ExtendedProperties without causing a lazy load. (Inherited from SchemaObjectBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MarkLoaded | (Inherited from SchemaObjectBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh | Used to refresh this instance. (Inherited from DataObjectBase.)
Public method | ToString | Returns the name of the column. (Inherited from DataObjectBase.)
Top
Fields
 | Name | Description
Protected field | _allowDBNull | (Inherited from DataObjectBase.)
Protected field | _database | (Inherited from SchemaObjectBase.)
Protected field | _dataType | (Inherited from DataObjectBase.)
Protected field | _dateCreated | (Inherited from SchemaObjectBase.)
Protected field | _defaultExtendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _extendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _gotExtendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _nativeType | (Inherited from DataObjectBase.)
Protected field | _parent | (Inherited from DataObjectBase.)
Protected field | _precision | (Inherited from DataObjectBase.)
Protected field | _scale | (Inherited from DataObjectBase.)
Protected field | _size | (Inherited from DataObjectBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Selected | Determines if the specified item is selected using the rules defined in SchemaSelector. (Defined by SchemaSelectorExtensions.)
Top
See Also

Reference

SchemaExplorer Namespace


ViewColumnSchema Constructor

Overload List
 | Name | Description
Public method | ViewColumnSchema(ViewSchema, String, DbType, String, Int32, Byte, Int32) | Obsolete. Creates a new instance of the ViewColumnSchema object.
Public method | ViewColumnSchema(ViewSchema, String, DbType, String, Int32, Byte, Int32, ExtendedProperty) | Obsolete. Creates a new instance of the ViewColumnSchema object.
Public method | ViewColumnSchema(ViewSchema, String, DbType, String, Int32, Byte, Int32, Boolean) | Creates a new instance of the ViewColumnSchema object.
Public method | ViewColumnSchema(ViewSchema, String, DbType, String, Int32, Byte, Int32, Boolean, ExtendedProperty) | Creates a new instance of the ViewColumnSchema object.
Top
See Also

Reference

ViewColumnSchema Class
SchemaExplorer Namespace


ViewColumnSchema Constructor (ViewSchema, String, DbType, String, Int32, Byte, Int32)

Note: This API is now obsolete.

Creates a new instance of the ViewColumnSchema object.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[ObsoleteAttribute("Please use the constructors that contain the allowDBNull parameter.",
    false)]
public ViewColumnSchema(
    ViewSchema view,
    string name,
    DbType dataType,
    string nativeType,
    int size,
    byte precision,
    int scale
)
<ObsoleteAttribute("Please use the constructors that contain the allowDBNull parameter.",
    false)>
Public Sub New (
    view As ViewSchema,
    name As String,
    dataType As DbType,
    nativeType As String,
    size As Integer,
    precision As Byte,
    scale As Integer
)

Parameters

view
Type: SchemaExplorerViewSchema
The view that the column belongs to.
name
Type: SystemString
The name of the column.
dataType
Type: System.DataDbType
The columns data type.
nativeType
Type: SystemString
The columns native type.
size
Type: SystemInt32
The size of the column.
precision
Type: SystemByte
The precision of the column.
scale
Type: SystemInt32
The scale of the column.
See Also

Reference

ViewColumnSchema Class
ViewColumnSchema Overload
SchemaExplorer Namespace


ViewColumnSchema Constructor (ViewSchema, String, DbType, String, Int32, Byte, Int32, ExtendedProperty[])

ViewColumnSchema Constructor (ViewSchema, String, DbType, String, Int32, Byte, Int32, ExtendedProperty)

Note: This API is now obsolete.

Creates a new instance of the ViewColumnSchema object.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[ObsoleteAttribute("Please use the constructors that contain the allowDBNull parameter.",
    false)]
public ViewColumnSchema(
    ViewSchema view,
    string name,
    DbType dataType,
    string nativeType,
    int size,
    byte precision,
    int scale,
    ExtendedProperty[] extendedProperties
)
<ObsoleteAttribute("Please use the constructors that contain the allowDBNull parameter.",
    false)>
Public Sub New (
    view As ViewSchema,
    name As String,
    dataType As DbType,
    nativeType As String,
    size As Integer,
    precision As Byte,
    scale As Integer,
    extendedProperties As ExtendedProperty()
)

Parameters

view
Type: SchemaExplorerViewSchema
The view that the column belongs to.
name
Type: SystemString
The name of the column.
dataType
Type: System.DataDbType
The columns data type.
nativeType
Type: SystemString
The columns native type.
size
Type: SystemInt32
The size of the column.
precision
Type: SystemByte
The precision of the column.
scale
Type: SystemInt32
The scale of the column.
extendedProperties
Type: SchemaExplorerExtendedProperty
The array of extended properties for this column.
See Also

Reference

ViewColumnSchema Class
ViewColumnSchema Overload
SchemaExplorer Namespace


ViewColumnSchema Constructor (ViewSchema, String, DbType, String, Int32, Byte, Int32, Boolean)

Creates a new instance of the ViewColumnSchema object.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ViewColumnSchema(
    ViewSchema view,
    string name,
    DbType dataType,
    string nativeType,
    int size,
    byte precision,
    int scale,
    bool allowDBNull
)
Public Sub New (
    view As ViewSchema,
    name As String,
    dataType As DbType,
    nativeType As String,
    size As Integer,
    precision As Byte,
    scale As Integer,
    allowDBNull As Boolean
)

Parameters

view
Type: SchemaExplorerViewSchema
The view that the column belongs to.
name
Type: SystemString
The name of the column.
dataType
Type: System.DataDbType
The columns data type.
nativeType
Type: SystemString
The columns native type.
size
Type: SystemInt32
The size of the column.
precision
Type: SystemByte
The precision of the column.
scale
Type: SystemInt32
The scale of the column.
allowDBNull
Type: SystemBoolean
Whether the column allows null values.
See Also

Reference

ViewColumnSchema Class
ViewColumnSchema Overload
SchemaExplorer Namespace


ViewColumnSchema Constructor (ViewSchema, String, DbType, String, Int32, Byte, Int32, Boolean, ExtendedProperty[])

ViewColumnSchema Constructor (ViewSchema, String, DbType, String, Int32, Byte, Int32, Boolean, ExtendedProperty)

Creates a new instance of the ViewColumnSchema object.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ViewColumnSchema(
    ViewSchema view,
    string name,
    DbType dataType,
    string nativeType,
    int size,
    byte precision,
    int scale,
    bool allowDBNull,
    ExtendedProperty[] extendedProperties
)
Public Sub New (
    view As ViewSchema,
    name As String,
    dataType As DbType,
    nativeType As String,
    size As Integer,
    precision As Byte,
    scale As Integer,
    allowDBNull As Boolean,
    extendedProperties As ExtendedProperty()
)

Parameters

view
Type: SchemaExplorerViewSchema
The view that the column belongs to.
name
Type: SystemString
The name of the column.
dataType
Type: System.DataDbType
The columns data type.
nativeType
Type: SystemString
The columns native type.
size
Type: SystemInt32
The size of the column.
precision
Type: SystemByte
The precision of the column.
scale
Type: SystemInt32
The scale of the column.
allowDBNull
Type: SystemBoolean
Whether the column allows null values.
extendedProperties
Type: SchemaExplorerExtendedProperty
The array of extended properties for this column.
See Also

Reference

ViewColumnSchema Class
ViewColumnSchema Overload
SchemaExplorer Namespace


ViewColumnSchema Properties

The ViewColumnSchema type exposes the following members.

Properties
 | Name | Description
Public property | AllowDBNull | Whether or not the data object allows null values. (Inherited from DataObjectBase.)
Public property | Database | Allows access to the DatabaseSchema object that contains this schema object. (Inherited from SchemaObjectBase.)
Public property | DataType | The data type of a (column) parameter is specific to the .NET Framework data provider. Specifying the type converts the value of the Parameter to the data provider Type before passing the value to the data source. see also: http://msdn.microsoft.com/en-us/library/system.data.dbtype.aspx example: DbType.AnsiString (Inherited from DataObjectBase.)
Public property | DateCreated | Returns the date this table was created. (Inherited from SchemaObjectBase.)
Public property | DeepLoad | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from SchemaObjectBase.)
Public property | Description | The description of the object. (Inherited from SchemaObjectBase.)
Public property | ExtendedProperties | Used to store any additional information about the schema object. (Inherited from SchemaObjectBase.)
Public property | FullName | Returns the owner and name. (Inherited from DataObjectBase.)
Public property | IncludeFunctions | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from SchemaObjectBase.)
Public property | NativeType | This is the native data type from the database. example: nvarchar (Inherited from DataObjectBase.)
Public property | Parent | The Parent Schema Object. (Inherited from DataObjectBase.)
Public property | Precision | The precision of the data object. (Inherited from DataObjectBase.)
Public property | Scale | The scale of the data object. (Inherited from DataObjectBase.)
Public property | Size | The size of the data object. (Inherited from DataObjectBase.)
Public property | SortName | Gets the name used to sort in 'Name (Parent)' format. (Inherited from DataObjectBase.)
Public property | SystemType | The System Type that is resolved from DataType. example: typeof(System.String) (Inherited from DataObjectBase.)
Public property | View | The view that contains this column.
Top
See Also

Reference

ViewColumnSchema Class
SchemaExplorer Namespace


ViewColumnSchema.View Property

ViewColumnSchemaView Property

The view that contains this column.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual ViewSchema View { get; }
Public Overridable ReadOnly Property View As ViewSchema
    Get

Property Value

Type: ViewSchema
See Also

Reference

ViewColumnSchema Class
SchemaExplorer Namespace


ViewColumnSchema Methods

The ViewColumnSchema type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines if another view column is the same as this view column. (Inherited from DataObjectBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns a hashcode based on the database, view and name of the view column. (Inherited from DataObjectBase.)
Public method | GetLoadedExtendedProperties | Gets the existing ExtendedProperties without causing a lazy load. (Inherited from SchemaObjectBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MarkLoaded | (Inherited from SchemaObjectBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh | Used to refresh this instance. (Inherited from DataObjectBase.)
Public method | ToString | Returns the name of the column. (Inherited from DataObjectBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Selected | Determines if the specified item is selected using the rules defined in SchemaSelector. (Defined by SchemaSelectorExtensions.)
Top
See Also

Reference

ViewColumnSchema Class
SchemaExplorer Namespace


ViewColumnSchema Fields

The ViewColumnSchema type exposes the following members.

Fields
 | Name | Description
Protected field | _allowDBNull | (Inherited from DataObjectBase.)
Protected field | _database | (Inherited from SchemaObjectBase.)
Protected field | _dataType | (Inherited from DataObjectBase.)
Protected field | _dateCreated | (Inherited from SchemaObjectBase.)
Protected field | _defaultExtendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _extendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _gotExtendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _nativeType | (Inherited from DataObjectBase.)
Protected field | _parent | (Inherited from DataObjectBase.)
Protected field | _precision | (Inherited from DataObjectBase.)
Protected field | _scale | (Inherited from DataObjectBase.)
Protected field | _size | (Inherited from DataObjectBase.)
Top
See Also

Reference

ViewColumnSchema Class
SchemaExplorer Namespace


ViewColumnSchemaCollection Class

Implements a strongly typed collection of ViewColumnSchema elements.
Inheritance Hierarchy
SystemObject
ObservableListViewColumnSchema
NamedObjectCollectionViewColumnSchema
SchemaExplorerSchemaObjectCollection ViewColumnSchema
SchemaExplorerDataObjectBaseCollection ViewColumnSchema
SchemaExplorerViewColumnSchemaCollection

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
public class ViewColumnSchemaCollection : DataObjectBaseCollection<ViewColumnSchema>
<SerializableAttribute>
Public Class ViewColumnSchemaCollection
    Inherits DataObjectBaseCollection(Of ViewColumnSchema)

The ViewColumnSchemaCollection type exposes the following members.

Constructors
 | Name | Description
Public method | ViewColumnSchemaCollection | Initializes a new instance of the ViewColumnSchemaCollection class.
Public method | ViewColumnSchemaCollection(IEnumerableViewColumnSchema) | Initializes a new instance of the ViewColumnSchemaCollection class.
Public method | ViewColumnSchemaCollection(Int32) | Initializes a new instance of the ViewColumnSchemaCollection class.
Top
Methods
 | Name | Description
Public method | Clone | (Inherited from SchemaObjectCollectionT.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh | (Inherited from SchemaObjectCollectionT.)
Public method | ToString | (Inherited from SchemaObjectCollectionT.)
Top
Remarks
ViewColumnSchemaCollection provides an DataObjectBaseCollectionT that is strongly typed for ViewColumnSchema elements.
See Also

Reference

SchemaExplorer Namespace


ViewColumnSchemaCollection Constructor

Overload List
 | Name | Description
Public method | ViewColumnSchemaCollection | Initializes a new instance of the ViewColumnSchemaCollection class.
Public method | ViewColumnSchemaCollection(IEnumerableViewColumnSchema) | Initializes a new instance of the ViewColumnSchemaCollection class.
Public method | ViewColumnSchemaCollection(Int32) | Initializes a new instance of the ViewColumnSchemaCollection class.
Top
See Also

Reference

ViewColumnSchemaCollection Class
SchemaExplorer Namespace


ViewColumnSchemaCollection Constructor

Initializes a new instance of the ViewColumnSchemaCollection class.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ViewColumnSchemaCollection()
Public Sub New
See Also

Reference

ViewColumnSchemaCollection Class
ViewColumnSchemaCollection Overload
SchemaExplorer Namespace


ViewColumnSchemaCollection Constructor (IEnumerable(ViewColumnSchema))

ViewColumnSchemaCollection Constructor (IEnumerableViewColumnSchema)

Initializes a new instance of the ViewColumnSchemaCollection class.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ViewColumnSchemaCollection(
    IEnumerable<ViewColumnSchema> collection
)
Public Sub New (
    collection As IEnumerable(Of ViewColumnSchema)
)

Parameters

collection
Type: System.Collections.GenericIEnumerable ViewColumnSchema
The collection from which the elements are copied.
See Also

Reference

ViewColumnSchemaCollection Class
ViewColumnSchemaCollection Overload
SchemaExplorer Namespace


ViewColumnSchemaCollection Constructor (Int32)

Initializes a new instance of the ViewColumnSchemaCollection class.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ViewColumnSchemaCollection(
    int capacity
)
Public Sub New (
    capacity As Integer
)

Parameters

capacity
Type: SystemInt32
The number of elements that the new list can initially store.
See Also

Reference

ViewColumnSchemaCollection Class
ViewColumnSchemaCollection Overload
SchemaExplorer Namespace


ViewColumnSchemaCollection Methods

The ViewColumnSchemaCollection type exposes the following members.

Methods
 | Name | Description
Public method | Clone | (Inherited from SchemaObjectCollectionT.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh | (Inherited from SchemaObjectCollectionT.)
Public method | ToString | (Inherited from SchemaObjectCollectionT.)
Top
See Also

Reference

ViewColumnSchemaCollection Class
SchemaExplorer Namespace


ViewSchema Class

Provides information about a database table.
Inheritance Hierarchy
SystemObject
NamedObjectBase
SchemaExplorerSchemaObjectBase
SchemaExplorerSchemaObjectWithOwnerBase
SchemaExplorerTabularObjectBase
SchemaExplorerViewSchema

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
public class ViewSchema : TabularObjectBase, IViewSchema,
    ITabularObject, ISchemaObjectWithOwner, ISchemaObject
<SerializableAttribute>
Public Class ViewSchema
    Inherits TabularObjectBase
    Implements IViewSchema, ITabularObject, ISchemaObjectWithOwner, ISchemaObject

The ViewSchema type exposes the following members.

Constructors
 | Name | Description
Public method | ViewSchema(DatabaseSchema, String, String, DateTime) | Initializes a new instance of the ViewSchema class
Public method | ViewSchema(DatabaseSchema, String, String, DateTime, ExtendedProperty) | Initializes a new instance of the ViewSchema class
Top
Properties
 | Name | Description
Public property | Columns | Provides information about the view columns.
Public property | Database | Allows access to the DatabaseSchema object that contains this schema object. (Inherited from SchemaObjectBase.)
Public property | DataObjects | (Overrides TabularObjectBaseDataObjects.)
Public property | DateCreated | Returns the date this table was created. (Inherited from SchemaObjectBase.)
Public property | DeepLoad | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from SchemaObjectBase.)
Public property | Description | The description of the object. (Inherited from SchemaObjectBase.)
Public property | ExtendedProperties | Used to store any additional information about the schema object. (Inherited from SchemaObjectBase.)
Public property | FullName | Returns the owner and name of the table. (Inherited from SchemaObjectWithOwnerBase.)
Public property | IncludeFunctions | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from SchemaObjectBase.)
Public property | Item | Index to allow easy access to the columns in this schema object. (Inherited from TabularObjectBase.)
Public property | Owner | Returns the owner of the table. (Inherited from SchemaObjectWithOwnerBase.)
Public property | SortName | Gets the name used to sort in 'Table (Owner)' format. (Inherited from SchemaObjectWithOwnerBase.)
Public property | ViewText | Gets the view text for this view.
Top
Methods
 | Name | Description
Public method | Equals | Determines if another table is the same as this table. (Inherited from SchemaObjectWithOwnerBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetData | Gets the data contained within the table. (Inherited from TabularObjectBase.)
Public method | GetHashCode | Returns a HashCode based on the database and name of the table. (Inherited from SchemaObjectWithOwnerBase.)
Public method | GetLoadedExtendedProperties | Gets the existing ExtendedProperties without causing a lazy load. (Inherited from SchemaObjectBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetViewData | Gets the data contained within the table.
Public method | MarkLoaded | (Inherited from SchemaObjectBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh | Allows you to refresh the information for this table. (Overrides TabularObjectBaseRefresh.)
Public method | ToString | Returns the name of the table. (Inherited from SchemaObjectWithOwnerBase.)
Top
Fields
 | Name | Description
Protected field | _database | (Inherited from SchemaObjectBase.)
Protected field | _dataObjects | (Inherited from TabularObjectBase.)
Protected field | _dateCreated | (Inherited from SchemaObjectBase.)
Protected field | _defaultExtendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _extendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _gotExtendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _owner | (Inherited from SchemaObjectWithOwnerBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Selected | Determines if the specified item is selected using the rules defined in SchemaSelector. (Defined by SchemaSelectorExtensions.)
Top
See Also

Reference

SchemaExplorer Namespace


ViewSchema Constructor

Overload List
 | Name | Description
Public method | ViewSchema(DatabaseSchema, String, String, DateTime) | Initializes a new instance of the ViewSchema class
Public method | ViewSchema(DatabaseSchema, String, String, DateTime, ExtendedProperty) | Initializes a new instance of the ViewSchema class
Top
See Also

Reference

ViewSchema Class
SchemaExplorer Namespace


ViewSchema Constructor (DatabaseSchema, String, String, DateTime)

Initializes a new instance of the ViewSchema class

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ViewSchema(
    DatabaseSchema database,
    string name,
    string owner,
    DateTime dateCreated
)
Public Sub New (
    database As DatabaseSchema,
    name As String,
    owner As String,
    dateCreated As DateTime
)

Parameters

database
Type: SchemaExplorerDatabaseSchema
name
Type: SystemString
owner
Type: SystemString
dateCreated
Type: SystemDateTime
See Also

Reference

ViewSchema Class
ViewSchema Overload
SchemaExplorer Namespace


ViewSchema Constructor (DatabaseSchema, String, String, DateTime, ExtendedProperty[])

ViewSchema Constructor (DatabaseSchema, String, String, DateTime, ExtendedProperty)

Initializes a new instance of the ViewSchema class

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ViewSchema(
    DatabaseSchema database,
    string name,
    string owner,
    DateTime dateCreated,
    ExtendedProperty[] extendedProperties
)
Public Sub New (
    database As DatabaseSchema,
    name As String,
    owner As String,
    dateCreated As DateTime,
    extendedProperties As ExtendedProperty()
)

Parameters

database
Type: SchemaExplorerDatabaseSchema
name
Type: SystemString
owner
Type: SystemString
dateCreated
Type: SystemDateTime
extendedProperties
Type: SchemaExplorerExtendedProperty
See Also

Reference

ViewSchema Class
ViewSchema Overload
SchemaExplorer Namespace


ViewSchema Properties

The ViewSchema type exposes the following members.

Properties
 | Name | Description
Public property | Columns | Provides information about the view columns.
Public property | Database | Allows access to the DatabaseSchema object that contains this schema object. (Inherited from SchemaObjectBase.)
Public property | DataObjects | (Overrides TabularObjectBaseDataObjects.)
Public property | DateCreated | Returns the date this table was created. (Inherited from SchemaObjectBase.)
Public property | DeepLoad | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from SchemaObjectBase.)
Public property | Description | The description of the object. (Inherited from SchemaObjectBase.)
Public property | ExtendedProperties | Used to store any additional information about the schema object. (Inherited from SchemaObjectBase.)
Public property | FullName | Returns the owner and name of the table. (Inherited from SchemaObjectWithOwnerBase.)
Public property | IncludeFunctions | Gets or sets a value indicating this schema object and all its children will be loaded. (Inherited from SchemaObjectBase.)
Public property | Item | Index to allow easy access to the columns in this schema object. (Inherited from TabularObjectBase.)
Public property | Owner | Returns the owner of the table. (Inherited from SchemaObjectWithOwnerBase.)
Public property | SortName | Gets the name used to sort in 'Table (Owner)' format. (Inherited from SchemaObjectWithOwnerBase.)
Public property | ViewText | Gets the view text for this view.
Top
See Also

Reference

ViewSchema Class
SchemaExplorer Namespace


ViewSchema.Columns Property

ViewSchemaColumns Property

Provides information about the view columns.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ViewColumnSchemaCollection Columns { get; set; }
Public Property Columns As ViewColumnSchemaCollection
    Get
    Set

Property Value

Type: ViewColumnSchemaCollection
See Also

Reference

ViewSchema Class
SchemaExplorer Namespace


ViewSchema.DataObjects Property

ViewSchemaDataObjects Property

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override IReadOnlyNamedObjectCollection<IDataObject> DataObjects { get; }
Public Overrides ReadOnly Property DataObjects As IReadOnlyNamedObjectCollection(Of IDataObject)
    Get

Property Value

Type: IReadOnlyNamedObjectCollectionIDataObject

Implements

ITabularObjectDataObjects
ITabularObjectDataObjects
See Also

Reference

ViewSchema Class
SchemaExplorer Namespace


ViewSchema.ViewText Property

ViewSchemaViewText Property

Gets the view text for this view.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string ViewText { get; }
Public ReadOnly Property ViewText As String
    Get

Property Value

Type: String

Implements

IViewSchemaViewText
See Also

Reference

ViewSchema Class
SchemaExplorer Namespace


ViewSchema Methods

The ViewSchema type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines if another table is the same as this table. (Inherited from SchemaObjectWithOwnerBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetData | Gets the data contained within the table. (Inherited from TabularObjectBase.)
Public method | GetHashCode | Returns a HashCode based on the database and name of the table. (Inherited from SchemaObjectWithOwnerBase.)
Public method | GetLoadedExtendedProperties | Gets the existing ExtendedProperties without causing a lazy load. (Inherited from SchemaObjectBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetViewData | Gets the data contained within the table.
Public method | MarkLoaded | (Inherited from SchemaObjectBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh | Allows you to refresh the information for this table. (Overrides TabularObjectBaseRefresh.)
Public method | ToString | Returns the name of the table. (Inherited from SchemaObjectWithOwnerBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Selected | Determines if the specified item is selected using the rules defined in SchemaSelector. (Defined by SchemaSelectorExtensions.)
Top
See Also

Reference

ViewSchema Class
SchemaExplorer Namespace


ViewSchema.GetViewData Method

ViewSchemaGetViewData Method

Gets the data contained within the table.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public DataTable GetViewData()
Public Function GetViewData As DataTable

Return Value

Type: DataTable

Implements

IViewSchemaGetViewData
See Also

Reference

ViewSchema Class
SchemaExplorer Namespace


ViewSchema.Refresh Method

ViewSchemaRefresh Method

Allows you to refresh the information for this table.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override void Refresh()
Public Overrides Sub Refresh

Implements

ISchemaObjectRefresh
ISchemaObjectRefresh
ISchemaObjectRefresh
See Also

Reference

ViewSchema Class
SchemaExplorer Namespace


ViewSchema Fields

The ViewSchema type exposes the following members.

Fields
 | Name | Description
Protected field | _database | (Inherited from SchemaObjectBase.)
Protected field | _dataObjects | (Inherited from TabularObjectBase.)
Protected field | _dateCreated | (Inherited from SchemaObjectBase.)
Protected field | _defaultExtendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _extendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _gotExtendedProperties | (Inherited from SchemaObjectBase.)
Protected field | _owner | (Inherited from SchemaObjectWithOwnerBase.)
Top
See Also

Reference

ViewSchema Class
SchemaExplorer Namespace


ViewSchemaCollection Class

Implements a strongly typed collection of ViewSchema elements.
Inheritance Hierarchy
SystemObject
ObservableListViewSchema
NamedObjectCollectionViewSchema
SchemaExplorerSchemaObjectCollection ViewSchema
SchemaExplorerSchemaObjectWithOwnerCollection ViewSchema
SchemaExplorerViewSchemaCollection

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
public class ViewSchemaCollection : SchemaObjectWithOwnerCollection<ViewSchema>
<SerializableAttribute>
Public Class ViewSchemaCollection
    Inherits SchemaObjectWithOwnerCollection(Of ViewSchema)

The ViewSchemaCollection type exposes the following members.

Constructors
 | Name | Description
Public method | ViewSchemaCollection | Initializes a new instance of the ViewSchemaCollection class.
Public method | ViewSchemaCollection(IEnumerableViewSchema) | Initializes a new instance of the ViewSchemaCollection class.
Public method | ViewSchemaCollection(Int32) | Initializes a new instance of the ViewSchemaCollection class.
Top
Properties
 | Name | Description
Public property | Item | Gets the TableSchema with the specified owner and name. (Inherited from SchemaObjectWithOwnerCollectionT.)
Top
Methods
 | Name | Description
Public method | Clone | (Inherited from SchemaObjectCollectionT.)
Public method | Contains | Determines whether an element is in the collection with the specified owner and name. (Inherited from SchemaObjectWithOwnerCollectionT.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of an item with the specified owner and name. (Inherited from SchemaObjectWithOwnerCollectionT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh | (Inherited from SchemaObjectCollectionT.)
Public method | ToString | (Inherited from SchemaObjectCollectionT.)
Top
Remarks
ViewSchemaCollection provides an SchemaObjectWithOwnerCollectionT that is strongly typed for ViewSchema elements.
See Also

Reference

SchemaExplorer Namespace


ViewSchemaCollection Constructor

Overload List
 | Name | Description
Public method | ViewSchemaCollection | Initializes a new instance of the ViewSchemaCollection class.
Public method | ViewSchemaCollection(IEnumerableViewSchema) | Initializes a new instance of the ViewSchemaCollection class.
Public method | ViewSchemaCollection(Int32) | Initializes a new instance of the ViewSchemaCollection class.
Top
See Also

Reference

ViewSchemaCollection Class
SchemaExplorer Namespace


ViewSchemaCollection Constructor

Initializes a new instance of the ViewSchemaCollection class.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ViewSchemaCollection()
Public Sub New
See Also

Reference

ViewSchemaCollection Class
ViewSchemaCollection Overload
SchemaExplorer Namespace


ViewSchemaCollection Constructor (IEnumerable(ViewSchema))

ViewSchemaCollection Constructor (IEnumerableViewSchema)

Initializes a new instance of the ViewSchemaCollection class.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ViewSchemaCollection(
    IEnumerable<ViewSchema> collection
)
Public Sub New (
    collection As IEnumerable(Of ViewSchema)
)

Parameters

collection
Type: System.Collections.GenericIEnumerable ViewSchema
The collection from which the elements are copied.
See Also

Reference

ViewSchemaCollection Class
ViewSchemaCollection Overload
SchemaExplorer Namespace


ViewSchemaCollection Constructor (Int32)

Initializes a new instance of the ViewSchemaCollection class.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ViewSchemaCollection(
    int capacity
)
Public Sub New (
    capacity As Integer
)

Parameters

capacity
Type: SystemInt32
The number of elements that the new list can initially store.
See Also

Reference

ViewSchemaCollection Class
ViewSchemaCollection Overload
SchemaExplorer Namespace


ViewSchemaCollection Properties

The ViewSchemaCollection type exposes the following members.

Properties
 | Name | Description
Public property | Item | Gets the TableSchema with the specified owner and name. (Inherited from SchemaObjectWithOwnerCollectionT.)
Top
See Also

Reference

ViewSchemaCollection Class
SchemaExplorer Namespace


ViewSchemaCollection Methods

The ViewSchemaCollection type exposes the following members.

Methods
 | Name | Description
Public method | Clone | (Inherited from SchemaObjectCollectionT.)
Public method | Contains | Determines whether an element is in the collection with the specified owner and name. (Inherited from SchemaObjectWithOwnerCollectionT.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of an item with the specified owner and name. (Inherited from SchemaObjectWithOwnerCollectionT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh | (Inherited from SchemaObjectCollectionT.)
Public method | ToString | (Inherited from SchemaObjectCollectionT.)
Top
See Also

Reference

ViewSchemaCollection Class
SchemaExplorer Namespace


WrappedNamedObjectCollection(TBase, TActual) Class

WrappedNamedObjectCollectionTBase, TActual Class

Inheritance Hierarchy
SystemObject
WrappedObservableListTBase, TActual
SchemaExplorerWrappedNamedObjectCollectionTBase, TActual

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
public class WrappedNamedObjectCollection<TBase, TActual> : WrappedObservableList<TBase, TActual>,
    IList<TBase>, ICollection<TBase>, IEnumerable<TBase>, IEnumerable,
    INotifyCollectionChanged, INotifyPropertyChanged
where TBase : class
where TActual : class, TBase

<SerializableAttribute>
Public Class WrappedNamedObjectCollection(Of TBase As Class, TActual As {Class, TBase})
    Inherits WrappedObservableList(Of TBase, TActual)
    Implements IList(Of TBase), ICollection(Of TBase),
    IEnumerable(Of TBase), IEnumerable, INotifyCollectionChanged, INotifyPropertyChanged

Type Parameters

TBase
TActual

The WrappedNamedObjectCollectionTBase, TActual type exposes the following members.

Constructors
 | Name | Description
Public method | WrappedNamedObjectCollectionTBase, TActual | Initializes a new instance of the WrappedNamedObjectCollectionTBase, TActual class
Public method | WrappedNamedObjectCollectionTBase, TActual(IEnumerableTBase) | Initializes a new instance of the WrappedNamedObjectCollectionTBase, TActual class
Public method | WrappedNamedObjectCollectionTBase, TActual(IEnumerableTActual) | Initializes a new instance of the WrappedNamedObjectCollectionTBase, TActual class
Top
Properties
 | Name | Description
Public property | Item | Gets the [!:TBase] with the specified owner and name.
Top
Methods
 | Name | Description
Public method | Contains | Determines whether an element is in the collection with the specified owner and name.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of an item with the specified owner and name.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AsIndexedEnumerableTBase | Returns an IndexedEnumerable from any collection implementing IEnumerable<T> (Defined by IndexedEnumerable.)
Top
See Also

Reference

SchemaExplorer Namespace


WrappedNamedObjectCollection(TBase, TActual) Constructor

WrappedNamedObjectCollectionTBase, TActual Constructor

Overload List
 | Name | Description
Public method | WrappedNamedObjectCollectionTBase, TActual | Initializes a new instance of the WrappedNamedObjectCollectionTBase, TActual class
Public method | WrappedNamedObjectCollectionTBase, TActual(IEnumerableTBase) | Initializes a new instance of the WrappedNamedObjectCollectionTBase, TActual class
Public method | WrappedNamedObjectCollectionTBase, TActual(IEnumerableTActual) | Initializes a new instance of the WrappedNamedObjectCollectionTBase, TActual class
Top
See Also

Reference

WrappedNamedObjectCollectionTBase, TActual Class
SchemaExplorer Namespace


WrappedNamedObjectCollection(TBase, TActual) Constructor

WrappedNamedObjectCollectionTBase, TActual Constructor

Initializes a new instance of the WrappedNamedObjectCollectionTBase, TActual class

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public WrappedNamedObjectCollection()
Public Sub New
See Also

Reference

WrappedNamedObjectCollectionTBase, TActual Class
WrappedNamedObjectCollectionTBase, TActual Overload
SchemaExplorer Namespace


WrappedNamedObjectCollection(TBase, TActual) Constructor (IEnumerable(TBase))

WrappedNamedObjectCollectionTBase, TActual Constructor (IEnumerableTBase)

Initializes a new instance of the WrappedNamedObjectCollectionTBase, TActual class

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public WrappedNamedObjectCollection(
    IEnumerable<TBase> data
)
Public Sub New (
    data As IEnumerable(Of TBase)
)

Parameters

data
Type: System.Collections.GenericIEnumerable TBase
See Also

Reference

WrappedNamedObjectCollectionTBase, TActual Class
WrappedNamedObjectCollectionTBase, TActual Overload
SchemaExplorer Namespace


WrappedNamedObjectCollection(TBase, TActual) Constructor (IEnumerable(TActual))

WrappedNamedObjectCollectionTBase, TActual Constructor (IEnumerableTActual)

Initializes a new instance of the WrappedNamedObjectCollectionTBase, TActual class

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public WrappedNamedObjectCollection(
    IEnumerable<TActual> data
)
Public Sub New (
    data As IEnumerable(Of TActual)
)

Parameters

data
Type: System.Collections.GenericIEnumerable TActual
See Also

Reference

WrappedNamedObjectCollectionTBase, TActual Class
WrappedNamedObjectCollectionTBase, TActual Overload
SchemaExplorer Namespace


WrappedNamedObjectCollection(TBase, TActual) Properties

WrappedNamedObjectCollectionTBase, TActual Properties

The WrappedNamedObjectCollectionTBase, TActual generic type exposes the following members.

Properties
 | Name | Description
Public property | Item | Gets the [!:TBase] with the specified owner and name.
Top
See Also

Reference

WrappedNamedObjectCollectionTBase, TActual Class
SchemaExplorer Namespace


WrappedNamedObjectCollection(TBase, TActual).Item Property

WrappedNamedObjectCollectionTBase, TActualItem Property

Gets the [!:TBase] with the specified owner and name.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public TBase this[
    string name
] { get; }
Public ReadOnly Default Property Item (
    name As String
) As TBase
    Get

Parameters

name
Type: SystemString

Return Value

Type: TBase
The [!:TBase] with the specified owner and name.
See Also

Reference

WrappedNamedObjectCollectionTBase, TActual Class
SchemaExplorer Namespace


WrappedNamedObjectCollection(TBase, TActual) Methods

WrappedNamedObjectCollectionTBase, TActual Methods

The WrappedNamedObjectCollectionTBase, TActual generic type exposes the following members.

Methods
 | Name | Description
Public method | Contains | Determines whether an element is in the collection with the specified owner and name.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of an item with the specified owner and name.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AsIndexedEnumerableTBase | Returns an IndexedEnumerable from any collection implementing IEnumerable<T> (Defined by IndexedEnumerable.)
Top
See Also

Reference

WrappedNamedObjectCollectionTBase, TActual Class
SchemaExplorer Namespace


WrappedNamedObjectCollection(TBase, TActual).Contains Method

WrappedNamedObjectCollectionTBase, TActualContains Method

Determines whether an element is in the collection with the specified owner and name.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool Contains(
    string name
)
Public Function Contains (
    name As String
) As Boolean

Parameters

name
Type: SystemString
The name of the item to locate in the collection.

Return Value

Type: Boolean
true if item is found in the collection; otherwise, false.
See Also

Reference

WrappedNamedObjectCollectionTBase, TActual Class
SchemaExplorer Namespace


WrappedNamedObjectCollection(TBase, TActual).IndexOf Method

WrappedNamedObjectCollectionTBase, TActualIndexOf Method

Determines the index of an item with the specified owner and name.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public int IndexOf(
    string name
)
Public Function IndexOf (
    name As String
) As Integer

Parameters

name
Type: SystemString
The name of the item to locate in the collection.

Return Value

Type: Int32
The index of item if found in the list; otherwise, -1.
See Also

Reference

WrappedNamedObjectCollectionTBase, TActual Class
SchemaExplorer Namespace


WrappedSchemaObjectCollection(TBase, TActual) Class

WrappedSchemaObjectCollectionTBase, TActual Class

Inheritance Hierarchy
SystemObject
WrappedObservableListTBase, TActual
SchemaExplorerWrappedSchemaObjectCollectionTBase, TActual
SchemaExplorerWrappedSchemaObjectWithOwnerCollectionTBase, TActual

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class WrappedSchemaObjectCollection<TBase, TActual> : WrappedObservableList<TBase, TActual>,
    ISchemaObjectCollection<TBase>, IList<TBase>, ICollection<TBase>, IEnumerable<TBase>,
    IEnumerable, INotifyCollectionChanged, INotifyPropertyChanged
where TBase : class, ISchemaObject
where TActual : class, ISchemaObject, TBase

Public Class WrappedSchemaObjectCollection(Of TBase As {Class, ISchemaObject}, TActual As {Class, ISchemaObject, TBase})
    Inherits WrappedObservableList(Of TBase, TActual)
    Implements ISchemaObjectCollection(Of TBase), IList(Of TBase),
    ICollection(Of TBase), IEnumerable(Of TBase), IEnumerable,
    INotifyCollectionChanged, INotifyPropertyChanged

Type Parameters

TBase
TActual

The WrappedSchemaObjectCollectionTBase, TActual type exposes the following members.

Constructors
 | Name | Description
Public method | WrappedSchemaObjectCollectionTBase, TActual | Initializes a new instance of the WrappedSchemaObjectCollectionTBase, TActual class
Public method | WrappedSchemaObjectCollectionTBase, TActual(IEnumerableTBase) | Initializes a new instance of the WrappedSchemaObjectCollectionTBase, TActual class
Public method | WrappedSchemaObjectCollectionTBase, TActual(IEnumerableTActual) | Initializes a new instance of the WrappedSchemaObjectCollectionTBase, TActual class
Top
Properties
 | Name | Description
Public property | Item | Gets the item with the specified name.
Top
Methods
 | Name | Description
Public method | Clone |
Public method | Contains | Determines whether an element is in the collection with the specified name.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the list.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh |
Public method | ToString | (Overrides ObjectToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AsIndexedEnumerableTBase | Returns an IndexedEnumerable from any collection implementing IEnumerable<T> (Defined by IndexedEnumerable.)
Top
See Also

Reference

SchemaExplorer Namespace


WrappedSchemaObjectCollection(TBase, TActual) Constructor

WrappedSchemaObjectCollectionTBase, TActual Constructor

Overload List
 | Name | Description
Public method | WrappedSchemaObjectCollectionTBase, TActual | Initializes a new instance of the WrappedSchemaObjectCollectionTBase, TActual class
Public method | WrappedSchemaObjectCollectionTBase, TActual(IEnumerableTBase) | Initializes a new instance of the WrappedSchemaObjectCollectionTBase, TActual class
Public method | WrappedSchemaObjectCollectionTBase, TActual(IEnumerableTActual) | Initializes a new instance of the WrappedSchemaObjectCollectionTBase, TActual class
Top
See Also

Reference

WrappedSchemaObjectCollectionTBase, TActual Class
SchemaExplorer Namespace


WrappedSchemaObjectCollection(TBase, TActual) Constructor

WrappedSchemaObjectCollectionTBase, TActual Constructor

Initializes a new instance of the WrappedSchemaObjectCollectionTBase, TActual class

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public WrappedSchemaObjectCollection()
Public Sub New
See Also

Reference

WrappedSchemaObjectCollectionTBase, TActual Class
WrappedSchemaObjectCollectionTBase, TActual Overload
SchemaExplorer Namespace


WrappedSchemaObjectCollection(TBase, TActual) Constructor (IEnumerable(TBase))

WrappedSchemaObjectCollectionTBase, TActual Constructor (IEnumerableTBase)

Initializes a new instance of the WrappedSchemaObjectCollectionTBase, TActual class

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public WrappedSchemaObjectCollection(
    IEnumerable<TBase> data
)
Public Sub New (
    data As IEnumerable(Of TBase)
)

Parameters

data
Type: System.Collections.GenericIEnumerable TBase
See Also

Reference

WrappedSchemaObjectCollectionTBase, TActual Class
WrappedSchemaObjectCollectionTBase, TActual Overload
SchemaExplorer Namespace


WrappedSchemaObjectCollection(TBase, TActual) Constructor (IEnumerable(TActual))

WrappedSchemaObjectCollectionTBase, TActual Constructor (IEnumerableTActual)

Initializes a new instance of the WrappedSchemaObjectCollectionTBase, TActual class

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public WrappedSchemaObjectCollection(
    IEnumerable<TActual> data
)
Public Sub New (
    data As IEnumerable(Of TActual)
)

Parameters

data
Type: System.Collections.GenericIEnumerable TActual
See Also

Reference

WrappedSchemaObjectCollectionTBase, TActual Class
WrappedSchemaObjectCollectionTBase, TActual Overload
SchemaExplorer Namespace


WrappedSchemaObjectCollection(TBase, TActual) Properties

WrappedSchemaObjectCollectionTBase, TActual Properties

The WrappedSchemaObjectCollectionTBase, TActual generic type exposes the following members.

Properties
 | Name | Description
Public property | Item | Gets the item with the specified name.
Top
See Also

Reference

WrappedSchemaObjectCollectionTBase, TActual Class
SchemaExplorer Namespace


WrappedSchemaObjectCollection(TBase, TActual).Item Property

WrappedSchemaObjectCollectionTBase, TActualItem Property

Gets the item with the specified name.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual TBase this[
    string name
] { get; }
Public Overridable ReadOnly Default Property Item (
    name As String
) As TBase
    Get

Parameters

name
Type: SystemString

Return Value

Type: TBase
The item with the specified name.
See Also

Reference

WrappedSchemaObjectCollectionTBase, TActual Class
SchemaExplorer Namespace


WrappedSchemaObjectCollection(TBase, TActual) Methods

WrappedSchemaObjectCollectionTBase, TActual Methods

The WrappedSchemaObjectCollectionTBase, TActual generic type exposes the following members.

Methods
 | Name | Description
Public method | Clone |
Public method | Contains | Determines whether an element is in the collection with the specified name.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the list.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh |
Public method | ToString | (Overrides ObjectToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AsIndexedEnumerableTBase | Returns an IndexedEnumerable from any collection implementing IEnumerable<T> (Defined by IndexedEnumerable.)
Top
See Also

Reference

WrappedSchemaObjectCollectionTBase, TActual Class
SchemaExplorer Namespace


WrappedSchemaObjectCollection(TBase, TActual).Clone Method

WrappedSchemaObjectCollectionTBase, TActualClone Method

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public SchemaObjectCollection<TBase> Clone()
Public Function Clone As SchemaObjectCollection(Of TBase)

Return Value

Type: SchemaObjectCollection TBase
See Also

Reference

WrappedSchemaObjectCollectionTBase, TActual Class
SchemaExplorer Namespace


WrappedSchemaObjectCollection(TBase, TActual).Contains Method

WrappedSchemaObjectCollectionTBase, TActualContains Method

Determines whether an element is in the collection with the specified name.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool Contains(
    string name
)
Public Function Contains (
    name As String
) As Boolean

Parameters

name
Type: SystemString
The name of the item to locate in the collection.

Return Value

Type: Boolean
true if item is found in the collection; otherwise, false.
See Also

Reference

WrappedSchemaObjectCollectionTBase, TActual Class
SchemaExplorer Namespace


WrappedSchemaObjectCollection(TBase, TActual).IndexOf Method

WrappedSchemaObjectCollectionTBase, TActualIndexOf Method

Determines the index of a specific item in the list.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public int IndexOf(
    string name
)
Public Function IndexOf (
    name As String
) As Integer

Parameters

name
Type: SystemString
The name of the item to locate in the list.

Return Value

Type: Int32
The index of item if found in the list; otherwise, -1.
See Also

Reference

WrappedSchemaObjectCollectionTBase, TActual Class
SchemaExplorer Namespace


WrappedSchemaObjectCollection(TBase, TActual).Refresh Method

WrappedSchemaObjectCollectionTBase, TActualRefresh Method

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void Refresh()
Public Sub Refresh

Implements

ISchemaObjectCollectionTRefresh
See Also

Reference

WrappedSchemaObjectCollectionTBase, TActual Class
SchemaExplorer Namespace


WrappedSchemaObjectCollection(TBase, TActual).ToString Method

WrappedSchemaObjectCollectionTBase, TActualToString Method

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
See Also

Reference

WrappedSchemaObjectCollectionTBase, TActual Class
SchemaExplorer Namespace


WrappedSchemaObjectWithOwnerCollection(TBase, TActual) Class

WrappedSchemaObjectWithOwnerCollectionTBase, TActual Class

Inheritance Hierarchy
SystemObject
WrappedObservableListTBase, TActual
SchemaExplorerWrappedSchemaObjectCollection TBase, TActual
SchemaExplorerWrappedSchemaObjectWithOwnerCollectionTBase, TActual

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
[SerializableAttribute]
public class WrappedSchemaObjectWithOwnerCollection<TBase, TActual> : WrappedSchemaObjectCollection<TBase, TActual>,
    ISchemaObjectWithOwnerCollection<TBase>, ISchemaObjectCollection<TBase>, IList<TBase>, ICollection<TBase>,
    IEnumerable<TBase>, IEnumerable, INotifyCollectionChanged, INotifyPropertyChanged
where TBase : class, ISchemaObjectWithOwner
where TActual : class, ISchemaObjectWithOwner, TBase

<SerializableAttribute>
Public Class WrappedSchemaObjectWithOwnerCollection(Of TBase As {Class, ISchemaObjectWithOwner}, TActual As {Class, ISchemaObjectWithOwner, TBase})
    Inherits WrappedSchemaObjectCollection(Of TBase, TActual)
    Implements ISchemaObjectWithOwnerCollection(Of TBase), ISchemaObjectCollection(Of TBase),
    IList(Of TBase), ICollection(Of TBase), IEnumerable(Of TBase),
    IEnumerable, INotifyCollectionChanged, INotifyPropertyChanged

Type Parameters

TBase
TActual

The WrappedSchemaObjectWithOwnerCollectionTBase, TActual type exposes the following members.

Constructors
 | Name | Description
Public method | WrappedSchemaObjectWithOwnerCollectionTBase, TActual | Initializes a new instance of the WrappedSchemaObjectWithOwnerCollectionTBase, TActual class
Public method | WrappedSchemaObjectWithOwnerCollectionTBase, TActual(IEnumerableTBase) | Initializes a new instance of the WrappedSchemaObjectWithOwnerCollectionTBase, TActual class
Public method | WrappedSchemaObjectWithOwnerCollectionTBase, TActual(IEnumerableTActual) | Initializes a new instance of the WrappedSchemaObjectWithOwnerCollectionTBase, TActual class
Top
Properties
 | Name | Description
Public property | ItemString | Gets the item with the specified name. (Inherited from WrappedSchemaObjectCollectionTBase, TActual.)
Public property | ItemString, String | Gets the TableSchema with the specified owner and name.
Top
Methods
 | Name | Description
Public method | Clone | (Inherited from WrappedSchemaObjectCollectionTBase, TActual.)
Public method | Contains(String) | Determines whether an element is in the collection with the specified name. (Inherited from WrappedSchemaObjectCollectionTBase, TActual.)
Public method | Contains(String, String) | Determines whether an element is in the collection with the specified owner and name.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(String) | Determines the index of a specific item in the list. (Inherited from WrappedSchemaObjectCollectionTBase, TActual.)
Public method | IndexOf(String, String) | Determines the index of an item with the specified owner and name.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh | (Inherited from WrappedSchemaObjectCollectionTBase, TActual.)
Public method | ToString | (Inherited from WrappedSchemaObjectCollectionTBase, TActual.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AsIndexedEnumerableTBase | Returns an IndexedEnumerable from any collection implementing IEnumerable<T> (Defined by IndexedEnumerable.)
Top
See Also

Reference

SchemaExplorer Namespace


WrappedSchemaObjectWithOwnerCollection(TBase, TActual) Constructor

WrappedSchemaObjectWithOwnerCollectionTBase, TActual Constructor

Overload List
 | Name | Description
Public method | WrappedSchemaObjectWithOwnerCollectionTBase, TActual | Initializes a new instance of the WrappedSchemaObjectWithOwnerCollectionTBase, TActual class
Public method | WrappedSchemaObjectWithOwnerCollectionTBase, TActual(IEnumerableTBase) | Initializes a new instance of the WrappedSchemaObjectWithOwnerCollectionTBase, TActual class
Public method | WrappedSchemaObjectWithOwnerCollectionTBase, TActual(IEnumerableTActual) | Initializes a new instance of the WrappedSchemaObjectWithOwnerCollectionTBase, TActual class
Top
See Also

Reference

WrappedSchemaObjectWithOwnerCollectionTBase, TActual Class
SchemaExplorer Namespace


WrappedSchemaObjectWithOwnerCollection(TBase, TActual) Constructor

WrappedSchemaObjectWithOwnerCollectionTBase, TActual Constructor

Initializes a new instance of the WrappedSchemaObjectWithOwnerCollectionTBase, TActual class

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public WrappedSchemaObjectWithOwnerCollection()
Public Sub New
See Also

Reference

WrappedSchemaObjectWithOwnerCollectionTBase, TActual Class
WrappedSchemaObjectWithOwnerCollectionTBase, TActual Overload
SchemaExplorer Namespace


WrappedSchemaObjectWithOwnerCollection(TBase, TActual) Constructor (IEnumerable(TBase))

WrappedSchemaObjectWithOwnerCollectionTBase, TActual Constructor (IEnumerableTBase)

Initializes a new instance of the WrappedSchemaObjectWithOwnerCollectionTBase, TActual class

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public WrappedSchemaObjectWithOwnerCollection(
    IEnumerable<TBase> data
)
Public Sub New (
    data As IEnumerable(Of TBase)
)

Parameters

data
Type: System.Collections.GenericIEnumerable TBase
See Also

Reference

WrappedSchemaObjectWithOwnerCollectionTBase, TActual Class
WrappedSchemaObjectWithOwnerCollectionTBase, TActual Overload
SchemaExplorer Namespace


WrappedSchemaObjectWithOwnerCollection(TBase, TActual) Constructor (IEnumerable(TActual))

WrappedSchemaObjectWithOwnerCollectionTBase, TActual Constructor (IEnumerableTActual)

Initializes a new instance of the WrappedSchemaObjectWithOwnerCollectionTBase, TActual class

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public WrappedSchemaObjectWithOwnerCollection(
    IEnumerable<TActual> data
)
Public Sub New (
    data As IEnumerable(Of TActual)
)

Parameters

data
Type: System.Collections.GenericIEnumerable TActual
See Also

Reference

WrappedSchemaObjectWithOwnerCollectionTBase, TActual Class
WrappedSchemaObjectWithOwnerCollectionTBase, TActual Overload
SchemaExplorer Namespace


WrappedSchemaObjectWithOwnerCollection(TBase, TActual) Properties

WrappedSchemaObjectWithOwnerCollectionTBase, TActual Properties

Properties
 | Name | Description
Public property | ItemString | Gets the item with the specified name. (Inherited from WrappedSchemaObjectCollectionTBase, TActual.)
Public property | ItemString, String | Gets the TableSchema with the specified owner and name.
Top
See Also

Reference

WrappedSchemaObjectWithOwnerCollectionTBase, TActual Class
SchemaExplorer Namespace


WrappedSchemaObjectWithOwnerCollection(TBase, TActual).Item Property

WrappedSchemaObjectWithOwnerCollectionTBase, TActualItem Property

Overload List
 | Name | Description
Public property | ItemString | Gets the item with the specified name. (Inherited from WrappedSchemaObjectCollectionTBase, TActual.)
Public property | ItemString, String | Gets the TableSchema with the specified owner and name.
Top
See Also

Reference

WrappedSchemaObjectWithOwnerCollectionTBase, TActual Class
SchemaExplorer Namespace


WrappedSchemaObjectWithOwnerCollection(TBase, TActual).Item Property (String, String)

WrappedSchemaObjectWithOwnerCollectionTBase, TActualItem Property (String, String)

Gets the TableSchema with the specified owner and name.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public TBase this[
    string owner,
    string name
] { get; }
Public ReadOnly Default Property Item (
    owner As String,
    name As String
) As TBase
    Get

Parameters

owner
Type: SystemString
name
Type: SystemString

Return Value

Type: TBase
The TableSchema with the specified owner and name.

Implements

ISchemaObjectWithOwnerCollectionTItemString, String
See Also

Reference

WrappedSchemaObjectWithOwnerCollectionTBase, TActual Class
Item Overload
SchemaExplorer Namespace


WrappedSchemaObjectWithOwnerCollection(TBase, TActual) Methods

WrappedSchemaObjectWithOwnerCollectionTBase, TActual Methods

The WrappedSchemaObjectWithOwnerCollectionTBase, TActual generic type exposes the following members.

Methods
 | Name | Description
Public method | Clone | (Inherited from WrappedSchemaObjectCollectionTBase, TActual.)
Public method | Contains(String) | Determines whether an element is in the collection with the specified name. (Inherited from WrappedSchemaObjectCollectionTBase, TActual.)
Public method | Contains(String, String) | Determines whether an element is in the collection with the specified owner and name.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(String) | Determines the index of a specific item in the list. (Inherited from WrappedSchemaObjectCollectionTBase, TActual.)
Public method | IndexOf(String, String) | Determines the index of an item with the specified owner and name.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh | (Inherited from WrappedSchemaObjectCollectionTBase, TActual.)
Public method | ToString | (Inherited from WrappedSchemaObjectCollectionTBase, TActual.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AsIndexedEnumerableTBase | Returns an IndexedEnumerable from any collection implementing IEnumerable<T> (Defined by IndexedEnumerable.)
Top
See Also

Reference

WrappedSchemaObjectWithOwnerCollectionTBase, TActual Class
SchemaExplorer Namespace


WrappedSchemaObjectWithOwnerCollection(TBase, TActual).Contains Method

WrappedSchemaObjectWithOwnerCollectionTBase, TActualContains Method

Overload List
 | Name | Description
Public method | Contains(String) | Determines whether an element is in the collection with the specified name. (Inherited from WrappedSchemaObjectCollectionTBase, TActual.)
Public method | Contains(String, String) | Determines whether an element is in the collection with the specified owner and name.
Top
See Also

Reference

WrappedSchemaObjectWithOwnerCollectionTBase, TActual Class
SchemaExplorer Namespace


WrappedSchemaObjectWithOwnerCollection(TBase, TActual).Contains Method (String, String)

WrappedSchemaObjectWithOwnerCollectionTBase, TActualContains Method (String, String)

Determines whether an element is in the collection with the specified owner and name.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool Contains(
    string owner,
    string name
)
Public Function Contains (
    owner As String,
    name As String
) As Boolean

Parameters

owner
Type: SystemString
The owner of the item to locate in the collection.
name
Type: SystemString
The name of the item to locate in the collection.

Return Value

Type: Boolean
true if item is found in the collection; otherwise, false.

Implements

ISchemaObjectWithOwnerCollectionTContains(String, String)
See Also

Reference

WrappedSchemaObjectWithOwnerCollectionTBase, TActual Class
Contains Overload
SchemaExplorer Namespace


WrappedSchemaObjectWithOwnerCollection(TBase, TActual).IndexOf Method

WrappedSchemaObjectWithOwnerCollectionTBase, TActualIndexOf Method

Overload List
 | Name | Description
Public method | IndexOf(String) | Determines the index of a specific item in the list. (Inherited from WrappedSchemaObjectCollectionTBase, TActual.)
Public method | IndexOf(String, String) | Determines the index of an item with the specified owner and name.
Top
See Also

Reference

WrappedSchemaObjectWithOwnerCollectionTBase, TActual Class
SchemaExplorer Namespace


WrappedSchemaObjectWithOwnerCollection(TBase, TActual).IndexOf Method (String, String)

WrappedSchemaObjectWithOwnerCollectionTBase, TActualIndexOf Method (String, String)

Determines the index of an item with the specified owner and name.

Namespace: SchemaExplorer
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public int IndexOf(
    string owner,
    string name
)
Public Function IndexOf (
    owner As String,
    name As String
) As Integer

Parameters

owner
Type: SystemString
The owner of the item to locate in the collection.
name
Type: SystemString
The name of the item to locate in the collection.

Return Value

Type: Int32
The index of item if found in the list; otherwise, -1.

Implements

ISchemaObjectWithOwnerCollectionTIndexOf(String, String)
See Also

Reference

WrappedSchemaObjectWithOwnerCollectionTBase, TActual Class
IndexOf Overload
SchemaExplorer Namespace


SchemaExplorer.Design Namespace

Classes
 | Class | Description
Public class | ColumnSchemaPickerUI |
Public class | CommandSchemaPickerUI |
Public class | DatabaseSchemaPickerUI |
Public class | DataSourceManagerUI |
Public class | DataSourceUI |
Public class | ErrorDialog |
Public class | ExtendedBindableProperty |
Public class | ExtendedPropertyEditorUI |
Public class | SchemaObjectEditor |
Public class | SchemaSelectorEditor |
Public class | SchemaSelectorEditorUI |
Public class | TableSchemaPickerUI |
Public class | TabularObjectBasePickerUI |
Public class | ThreeStateTreeView |
Public class | ViewColumnSchemaPickerUI |
Public class | ViewSchemaPickerUI |


ColumnSchemaPickerUI Class

Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
SchemaExplorer.DesignColumnSchemaPickerUI

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class ColumnSchemaPickerUI : Form
Public Class ColumnSchemaPickerUI
    Inherits Form

The ColumnSchemaPickerUI type exposes the following members.

Constructors
 | Name | Description
Public method | ColumnSchemaPickerUI | Initializes a new instance of the ColumnSchemaPickerUI class
Public method | ColumnSchemaPickerUI(Boolean) | Initializes a new instance of the ColumnSchemaPickerUI class
Top
Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | Gets or sets a value that indicates whether controls in this container will be automatically validated when the focus changes. (Inherited from Form.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Form.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DeviceDpi | Gets the DPI value for the display device where the control is currently being displayed. (Inherited from Control.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
Protected property | MaximizedBounds | Gets or sets the size of the form when it is maximized. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SelectedColumnSchema |
Public property | SelectedColumnSchemaCollection |
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Protected property | ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Form.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Protected method | ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Protected method | AdjustFormScrollbars | Adjusts the scroll bars on the container based on the current control positions and the control currently selected. (Inherited from Form.)
Protected method | ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
Protected method | CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Form.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Form.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides FormDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | End |
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Filter |
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Form.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Public method | LogicalToDeviceUnits(Int32) | Converts a Logical DPI value to its equivalent DeviceUnit DPI value. (Inherited from Control.)
Public method | LogicalToDeviceUnits(Size) | Transforms a size from logical to device units by scaling it for the current DPI and rounding down to the nearest integer value for width and height. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnActivated | Raises the Activated event. (Inherited from Form.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnClosed | Raises the Closed event. (Inherited from Form.)
Protected method | OnClosing | Raises the Closing event. (Inherited from Form.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDpiChanged | Raises the DpiChanged event. (Inherited from Form.)
Protected method | OnDpiChangedAfterParent | Raises the DpiChangedAfterParent event. (Inherited from Control.)
Protected method | OnDpiChangedBeforeParent | Raises the DpiChangedBeforeParent event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Form.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Form.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Form.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
Protected method | OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
Protected method | OnGetDpiScaledSize | Raises the GetDpiScaledSize event. (Inherited from Form.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Form.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Form.)
Protected method | OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
Protected method | OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Form.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from Form.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
Protected method | OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
Protected method | OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
Protected method | OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
Protected method | OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
Protected method | OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Form.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Form.)
Protected method | OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
Protected method | OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnShown | Raises the Shown event. (Inherited from Form.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Form.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Form.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Form.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Form.)
Protected method | ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Form.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Form.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from Form.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Protected method | RescaleConstantsForDpi | Provides constants for rescaling the control when a DPI change occurs. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value (Empty). (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScaleBitmapLogicalToDevice | Scales a logical bitmap value to it's equivalent device unit value when a DPI change occurs. (Inherited from Control.)
Protected method | ScaleControl | Scales the location, size, padding, and margin of a control. (Inherited from Form.)
Protected method | ScaleCore | Performs scaling of the form. (Inherited from Form.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Form.)
Protected method | SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either or . (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Form.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog | Shows the form as a modal dialog box. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | Start |
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | Causes all of the child controls within a control that support validation to validate their data. (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | Causes all of the child controls within a control that support validation to validate their data. (Inherited from Form.)
Protected method | WndProc | Processes Windows messages. (Inherited from Form.)
Top
Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from Form.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DpiChanged | Occurs when the DPI setting changes on the display device where the form is currently displayed. (Inherited from Form.)
Public event | DpiChangedAfterParent | Occurs when the DPI setting for a control is changed programmatically after the DPI of its parent control or form has changed. (Inherited from Control.)
Public event | DpiChangedBeforeParent | Occurs when the DPI setting for a control is changed programmatically before a DPI change event for its parent control or form has occurred. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the Margin property changes. (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | Occurs when the TabStop property changes. (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

SchemaExplorer.Design Namespace


ColumnSchemaPickerUI Constructor

Overload List
 | Name | Description
Public method | ColumnSchemaPickerUI | Initializes a new instance of the ColumnSchemaPickerUI class
Public method | ColumnSchemaPickerUI(Boolean) | Initializes a new instance of the ColumnSchemaPickerUI class
Top
See Also

Reference

ColumnSchemaPickerUI Class
SchemaExplorer.Design Namespace


ColumnSchemaPickerUI Constructor

Initializes a new instance of the ColumnSchemaPickerUI class

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ColumnSchemaPickerUI()
Public Sub New
See Also

Reference

ColumnSchemaPickerUI Class
ColumnSchemaPickerUI Overload
SchemaExplorer.Design Namespace


ColumnSchemaPickerUI Constructor (Boolean)

Initializes a new instance of the ColumnSchemaPickerUI class

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ColumnSchemaPickerUI(
    bool allowMultiple
)
Public Sub New (
    allowMultiple As Boolean
)

Parameters

allowMultiple
Type: SystemBoolean
See Also

Reference

ColumnSchemaPickerUI Class
ColumnSchemaPickerUI Overload
SchemaExplorer.Design Namespace


ColumnSchemaPickerUI Properties

The ColumnSchemaPickerUI type exposes the following members.

Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | Gets or sets a value that indicates whether controls in this container will be automatically validated when the focus changes. (Inherited from Form.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Form.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DeviceDpi | Gets the DPI value for the display device where the control is currently being displayed. (Inherited from Control.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
Protected property | MaximizedBounds | Gets or sets the size of the form when it is maximized. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SelectedColumnSchema |
Public property | SelectedColumnSchemaCollection |
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Protected property | ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Form.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

ColumnSchemaPickerUI Class
SchemaExplorer.Design Namespace


ColumnSchemaPickerUI.SelectedColumnSchema Property

ColumnSchemaPickerUISelectedColumnSchema Property

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ColumnSchema SelectedColumnSchema { get; }
Public ReadOnly Property SelectedColumnSchema As ColumnSchema
    Get

Property Value

Type: ColumnSchema
See Also

Reference

ColumnSchemaPickerUI Class
SchemaExplorer.Design Namespace


ColumnSchemaPickerUI.SelectedColumnSchemaCollection Property

ColumnSchemaPickerUISelectedColumnSchemaCollection Property

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ColumnSchemaCollection SelectedColumnSchemaCollection { get; }
Public ReadOnly Property SelectedColumnSchemaCollection As ColumnSchemaCollection
    Get

Property Value

Type: ColumnSchemaCollection
See Also

Reference

ColumnSchemaPickerUI Class
SchemaExplorer.Design Namespace


ColumnSchemaPickerUI Methods

The ColumnSchemaPickerUI type exposes the following members.

Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Protected method | ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Protected method | AdjustFormScrollbars | Adjusts the scroll bars on the container based on the current control positions and the control currently selected. (Inherited from Form.)
Protected method | ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
Protected method | CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Form.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Form.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides FormDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | End |
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Filter |
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Form.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Public method | LogicalToDeviceUnits(Int32) | Converts a Logical DPI value to its equivalent DeviceUnit DPI value. (Inherited from Control.)
Public method | LogicalToDeviceUnits(Size) | Transforms a size from logical to device units by scaling it for the current DPI and rounding down to the nearest integer value for width and height. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnActivated | Raises the Activated event. (Inherited from Form.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnClosed | Raises the Closed event. (Inherited from Form.)
Protected method | OnClosing | Raises the Closing event. (Inherited from Form.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDpiChanged | Raises the DpiChanged event. (Inherited from Form.)
Protected method | OnDpiChangedAfterParent | Raises the DpiChangedAfterParent event. (Inherited from Control.)
Protected method | OnDpiChangedBeforeParent | Raises the DpiChangedBeforeParent event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Form.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Form.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Form.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
Protected method | OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
Protected method | OnGetDpiScaledSize | Raises the GetDpiScaledSize event. (Inherited from Form.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Form.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Form.)
Protected method | OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
Protected method | OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Form.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from Form.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
Protected method | OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
Protected method | OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
Protected method | OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
Protected method | OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
Protected method | OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Form.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Form.)
Protected method | OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
Protected method | OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnShown | Raises the Shown event. (Inherited from Form.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Form.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Form.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Form.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Form.)
Protected method | ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Form.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Form.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from Form.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Protected method | RescaleConstantsForDpi | Provides constants for rescaling the control when a DPI change occurs. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value (Empty). (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScaleBitmapLogicalToDevice | Scales a logical bitmap value to it's equivalent device unit value when a DPI change occurs. (Inherited from Control.)
Protected method | ScaleControl | Scales the location, size, padding, and margin of a control. (Inherited from Form.)
Protected method | ScaleCore | Performs scaling of the form. (Inherited from Form.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Form.)
Protected method | SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either or . (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Form.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog | Shows the form as a modal dialog box. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | Start |
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | Causes all of the child controls within a control that support validation to validate their data. (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | Causes all of the child controls within a control that support validation to validate their data. (Inherited from Form.)
Protected method | WndProc | Processes Windows messages. (Inherited from Form.)
Top
See Also

Reference

ColumnSchemaPickerUI Class
SchemaExplorer.Design Namespace


ColumnSchemaPickerUI.Dispose Method

ColumnSchemaPickerUIDispose Method

Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides FormDispose(Boolean).)
Top
See Also

Reference

ColumnSchemaPickerUI Class
SchemaExplorer.Design Namespace


ColumnSchemaPickerUI.Dispose Method (Boolean)

ColumnSchemaPickerUIDispose Method (Boolean)

Clean up any resources being used.

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
true if managed resources should be disposed; otherwise, false.
See Also

Reference

ColumnSchemaPickerUI Class
Dispose Overload
SchemaExplorer.Design Namespace


ColumnSchemaPickerUI.End Method

ColumnSchemaPickerUIEnd Method

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void End()
Public Sub End
See Also

Reference

ColumnSchemaPickerUI Class
SchemaExplorer.Design Namespace


ColumnSchemaPickerUI.Filter Method

ColumnSchemaPickerUIFilter Method

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void Filter(
    Object filter
)
Public Sub Filter (
    filter As Object
)

Parameters

filter
Type: SystemObject
See Also

Reference

ColumnSchemaPickerUI Class
SchemaExplorer.Design Namespace


ColumnSchemaPickerUI.Start Method

ColumnSchemaPickerUIStart Method

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void Start(
    Object value
)
Public Sub Start (
    value As Object
)

Parameters

value
Type: SystemObject
See Also

Reference

ColumnSchemaPickerUI Class
SchemaExplorer.Design Namespace


ColumnSchemaPickerUI Events

The ColumnSchemaPickerUI type exposes the following members.

Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from Form.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DpiChanged | Occurs when the DPI setting changes on the display device where the form is currently displayed. (Inherited from Form.)
Public event | DpiChangedAfterParent | Occurs when the DPI setting for a control is changed programmatically after the DPI of its parent control or form has changed. (Inherited from Control.)
Public event | DpiChangedBeforeParent | Occurs when the DPI setting for a control is changed programmatically before a DPI change event for its parent control or form has occurred. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the Margin property changes. (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | Occurs when the TabStop property changes. (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

ColumnSchemaPickerUI Class
SchemaExplorer.Design Namespace


CommandSchemaPickerUI Class

Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
SchemaExplorer.DesignCommandSchemaPickerUI

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class CommandSchemaPickerUI : Form
Public Class CommandSchemaPickerUI
    Inherits Form

The CommandSchemaPickerUI type exposes the following members.

Constructors
 | Name | Description
Public method | CommandSchemaPickerUI | Initializes a new instance of the CommandSchemaPickerUI class
Public method | CommandSchemaPickerUI(Boolean) | Initializes a new instance of the CommandSchemaPickerUI class
Top
Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | Gets or sets a value that indicates whether controls in this container will be automatically validated when the focus changes. (Inherited from Form.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Form.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DeviceDpi | Gets the DPI value for the display device where the control is currently being displayed. (Inherited from Control.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | IncludeFunctions | Gets or sets a value indicating this schema object and all its children will be loaded.
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
Protected property | MaximizedBounds | Gets or sets the size of the form when it is maximized. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SelectedCommandSchema |
Public property | SelectedCommandSchemaCollection |
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Protected property | ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Form.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Protected method | ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Protected method | AdjustFormScrollbars | Adjusts the scroll bars on the container based on the current control positions and the control currently selected. (Inherited from Form.)
Protected method | ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
Protected method | CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Form.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Form.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides FormDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | End |
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Filter |
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Form.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Public method | LogicalToDeviceUnits(Int32) | Converts a Logical DPI value to its equivalent DeviceUnit DPI value. (Inherited from Control.)
Public method | LogicalToDeviceUnits(Size) | Transforms a size from logical to device units by scaling it for the current DPI and rounding down to the nearest integer value for width and height. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnActivated | Raises the Activated event. (Inherited from Form.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnClosed | Raises the Closed event. (Inherited from Form.)
Protected method | OnClosing | Raises the Closing event. (Inherited from Form.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDpiChanged | Raises the DpiChanged event. (Inherited from Form.)
Protected method | OnDpiChangedAfterParent | Raises the DpiChangedAfterParent event. (Inherited from Control.)
Protected method | OnDpiChangedBeforeParent | Raises the DpiChangedBeforeParent event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Form.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Form.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Form.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
Protected method | OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
Protected method | OnGetDpiScaledSize | Raises the GetDpiScaledSize event. (Inherited from Form.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Form.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Form.)
Protected method | OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
Protected method | OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Form.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from Form.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
Protected method | OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
Protected method | OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
Protected method | OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
Protected method | OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
Protected method | OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Form.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Form.)
Protected method | OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
Protected method | OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnShown | Raises the Shown event. (Inherited from Form.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Form.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Form.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Form.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Form.)
Protected method | ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Form.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Form.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from Form.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Protected method | RescaleConstantsForDpi | Provides constants for rescaling the control when a DPI change occurs. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value (Empty). (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScaleBitmapLogicalToDevice | Scales a logical bitmap value to it's equivalent device unit value when a DPI change occurs. (Inherited from Control.)
Protected method | ScaleControl | Scales the location, size, padding, and margin of a control. (Inherited from Form.)
Protected method | ScaleCore | Performs scaling of the form. (Inherited from Form.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Form.)
Protected method | SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either or . (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Form.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog | Shows the form as a modal dialog box. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | Start |
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | Causes all of the child controls within a control that support validation to validate their data. (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | Causes all of the child controls within a control that support validation to validate their data. (Inherited from Form.)
Protected method | WndProc | Processes Windows messages. (Inherited from Form.)
Top
Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from Form.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DpiChanged | Occurs when the DPI setting changes on the display device where the form is currently displayed. (Inherited from Form.)
Public event | DpiChangedAfterParent | Occurs when the DPI setting for a control is changed programmatically after the DPI of its parent control or form has changed. (Inherited from Control.)
Public event | DpiChangedBeforeParent | Occurs when the DPI setting for a control is changed programmatically before a DPI change event for its parent control or form has occurred. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the Margin property changes. (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | Occurs when the TabStop property changes. (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

SchemaExplorer.Design Namespace


CommandSchemaPickerUI Constructor

Overload List
 | Name | Description
Public method | CommandSchemaPickerUI | Initializes a new instance of the CommandSchemaPickerUI class
Public method | CommandSchemaPickerUI(Boolean) | Initializes a new instance of the CommandSchemaPickerUI class
Top
See Also

Reference

CommandSchemaPickerUI Class
SchemaExplorer.Design Namespace


CommandSchemaPickerUI Constructor

Initializes a new instance of the CommandSchemaPickerUI class

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CommandSchemaPickerUI()
Public Sub New
See Also

Reference

CommandSchemaPickerUI Class
CommandSchemaPickerUI Overload
SchemaExplorer.Design Namespace


CommandSchemaPickerUI Constructor (Boolean)

Initializes a new instance of the CommandSchemaPickerUI class

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CommandSchemaPickerUI(
    bool allowMultiple
)
Public Sub New (
    allowMultiple As Boolean
)

Parameters

allowMultiple
Type: SystemBoolean
See Also

Reference

CommandSchemaPickerUI Class
CommandSchemaPickerUI Overload
SchemaExplorer.Design Namespace


CommandSchemaPickerUI Properties

The CommandSchemaPickerUI type exposes the following members.

Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | Gets or sets a value that indicates whether controls in this container will be automatically validated when the focus changes. (Inherited from Form.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Form.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DeviceDpi | Gets the DPI value for the display device where the control is currently being displayed. (Inherited from Control.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | IncludeFunctions | Gets or sets a value indicating this schema object and all its children will be loaded.
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
Protected property | MaximizedBounds | Gets or sets the size of the form when it is maximized. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SelectedCommandSchema |
Public property | SelectedCommandSchemaCollection |
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Protected property | ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Form.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

CommandSchemaPickerUI Class
SchemaExplorer.Design Namespace


CommandSchemaPickerUI.IncludeFunctions Property

CommandSchemaPickerUIIncludeFunctions Property

Gets or sets a value indicating this schema object and all its children will be loaded.

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool IncludeFunctions { get; set; }
Public Property IncludeFunctions As Boolean
    Get
    Set

Property Value

Type: Boolean
true if functions should be included; otherwise, false.
See Also

Reference

CommandSchemaPickerUI Class
SchemaExplorer.Design Namespace


CommandSchemaPickerUI.SelectedCommandSchema Property

CommandSchemaPickerUISelectedCommandSchema Property

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CommandSchema SelectedCommandSchema { get; }
Public ReadOnly Property SelectedCommandSchema As CommandSchema
    Get

Property Value

Type: CommandSchema
See Also

Reference

CommandSchemaPickerUI Class
SchemaExplorer.Design Namespace


CommandSchemaPickerUI.SelectedCommandSchemaCollection Property

CommandSchemaPickerUISelectedCommandSchemaCollection Property

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public CommandSchemaCollection SelectedCommandSchemaCollection { get; }
Public ReadOnly Property SelectedCommandSchemaCollection As CommandSchemaCollection
    Get

Property Value

Type: CommandSchemaCollection
See Also

Reference

CommandSchemaPickerUI Class
SchemaExplorer.Design Namespace


CommandSchemaPickerUI Methods

The CommandSchemaPickerUI type exposes the following members.

Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Protected method | ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Protected method | AdjustFormScrollbars | Adjusts the scroll bars on the container based on the current control positions and the control currently selected. (Inherited from Form.)
Protected method | ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
Protected method | CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Form.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Form.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides FormDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | End |
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Filter |
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Form.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Public method | LogicalToDeviceUnits(Int32) | Converts a Logical DPI value to its equivalent DeviceUnit DPI value. (Inherited from Control.)
Public method | LogicalToDeviceUnits(Size) | Transforms a size from logical to device units by scaling it for the current DPI and rounding down to the nearest integer value for width and height. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnActivated | Raises the Activated event. (Inherited from Form.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnClosed | Raises the Closed event. (Inherited from Form.)
Protected method | OnClosing | Raises the Closing event. (Inherited from Form.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDpiChanged | Raises the DpiChanged event. (Inherited from Form.)
Protected method | OnDpiChangedAfterParent | Raises the DpiChangedAfterParent event. (Inherited from Control.)
Protected method | OnDpiChangedBeforeParent | Raises the DpiChangedBeforeParent event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Form.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Form.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Form.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
Protected method | OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
Protected method | OnGetDpiScaledSize | Raises the GetDpiScaledSize event. (Inherited from Form.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Form.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Form.)
Protected method | OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
Protected method | OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Form.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from Form.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
Protected method | OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
Protected method | OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
Protected method | OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
Protected method | OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
Protected method | OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Form.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Form.)
Protected method | OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
Protected method | OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnShown | Raises the Shown event. (Inherited from Form.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Form.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Form.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Form.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Form.)
Protected method | ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Form.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Form.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from Form.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Protected method | RescaleConstantsForDpi | Provides constants for rescaling the control when a DPI change occurs. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value (Empty). (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScaleBitmapLogicalToDevice | Scales a logical bitmap value to it's equivalent device unit value when a DPI change occurs. (Inherited from Control.)
Protected method | ScaleControl | Scales the location, size, padding, and margin of a control. (Inherited from Form.)
Protected method | ScaleCore | Performs scaling of the form. (Inherited from Form.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Form.)
Protected method | SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either or . (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Form.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog | Shows the form as a modal dialog box. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | Start |
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | Causes all of the child controls within a control that support validation to validate their data. (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | Causes all of the child controls within a control that support validation to validate their data. (Inherited from Form.)
Protected method | WndProc | Processes Windows messages. (Inherited from Form.)
Top
See Also

Reference

CommandSchemaPickerUI Class
SchemaExplorer.Design Namespace


CommandSchemaPickerUI.Dispose Method

CommandSchemaPickerUIDispose Method

Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides FormDispose(Boolean).)
Top
See Also

Reference

CommandSchemaPickerUI Class
SchemaExplorer.Design Namespace


CommandSchemaPickerUI.Dispose Method (Boolean)

CommandSchemaPickerUIDispose Method (Boolean)

Clean up any resources being used.

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
true if managed resources should be disposed; otherwise, false.
See Also

Reference

CommandSchemaPickerUI Class
Dispose Overload
SchemaExplorer.Design Namespace


CommandSchemaPickerUI.End Method

CommandSchemaPickerUIEnd Method

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void End()
Public Sub End
See Also

Reference

CommandSchemaPickerUI Class
SchemaExplorer.Design Namespace


CommandSchemaPickerUI.Filter Method

CommandSchemaPickerUIFilter Method

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void Filter(
    Object filter
)
Public Sub Filter (
    filter As Object
)

Parameters

filter
Type: SystemObject
See Also

Reference

CommandSchemaPickerUI Class
SchemaExplorer.Design Namespace


CommandSchemaPickerUI.Start Method

CommandSchemaPickerUIStart Method

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void Start(
    Object value
)
Public Sub Start (
    value As Object
)

Parameters

value
Type: SystemObject
See Also

Reference

CommandSchemaPickerUI Class
SchemaExplorer.Design Namespace


CommandSchemaPickerUI Events

The CommandSchemaPickerUI type exposes the following members.

Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from Form.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DpiChanged | Occurs when the DPI setting changes on the display device where the form is currently displayed. (Inherited from Form.)
Public event | DpiChangedAfterParent | Occurs when the DPI setting for a control is changed programmatically after the DPI of its parent control or form has changed. (Inherited from Control.)
Public event | DpiChangedBeforeParent | Occurs when the DPI setting for a control is changed programmatically before a DPI change event for its parent control or form has occurred. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the Margin property changes. (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | Occurs when the TabStop property changes. (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

CommandSchemaPickerUI Class
SchemaExplorer.Design Namespace


DatabaseSchemaPickerUI Class

Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
SchemaExplorer.DesignDatabaseSchemaPickerUI

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class DatabaseSchemaPickerUI : Form
Public Class DatabaseSchemaPickerUI
    Inherits Form

The DatabaseSchemaPickerUI type exposes the following members.

Constructors
 | Name | Description
Public method | DatabaseSchemaPickerUI | Initializes a new instance of the DatabaseSchemaPickerUI class
Top
Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | Gets or sets a value that indicates whether controls in this container will be automatically validated when the focus changes. (Inherited from Form.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DatabaseSchema |
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Form.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DeviceDpi | Gets the DPI value for the display device where the control is currently being displayed. (Inherited from Control.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
Protected property | MaximizedBounds | Gets or sets the size of the form when it is maximized. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Protected property | ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Form.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Protected method | ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Protected method | AdjustFormScrollbars | Adjusts the scroll bars on the container based on the current control positions and the control currently selected. (Inherited from Form.)
Protected method | ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
Protected method | CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Form.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Form.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides FormDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | End |
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Form.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Public method | LogicalToDeviceUnits(Int32) | Converts a Logical DPI value to its equivalent DeviceUnit DPI value. (Inherited from Control.)
Public method | LogicalToDeviceUnits(Size) | Transforms a size from logical to device units by scaling it for the current DPI and rounding down to the nearest integer value for width and height. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnActivated | Raises the Activated event. (Inherited from Form.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnClosed | Raises the Closed event. (Inherited from Form.)
Protected method | OnClosing | Raises the Closing event. (Inherited from Form.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDpiChanged | Raises the DpiChanged event. (Inherited from Form.)
Protected method | OnDpiChangedAfterParent | Raises the DpiChangedAfterParent event. (Inherited from Control.)
Protected method | OnDpiChangedBeforeParent | Raises the DpiChangedBeforeParent event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Form.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Form.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Form.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
Protected method | OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
Protected method | OnGetDpiScaledSize | Raises the GetDpiScaledSize event. (Inherited from Form.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Form.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Form.)
Protected method | OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
Protected method | OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Form.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from Form.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
Protected method | OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
Protected method | OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
Protected method | OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
Protected method | OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
Protected method | OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Form.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Form.)
Protected method | OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
Protected method | OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnShown | Raises the Shown event. (Inherited from Form.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Form.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Form.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Form.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Form.)
Protected method | ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Form.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Form.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from Form.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Protected method | RescaleConstantsForDpi | Provides constants for rescaling the control when a DPI change occurs. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value (Empty). (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScaleBitmapLogicalToDevice | Scales a logical bitmap value to it's equivalent device unit value when a DPI change occurs. (Inherited from Control.)
Protected method | ScaleControl | Scales the location, size, padding, and margin of a control. (Inherited from Form.)
Protected method | ScaleCore | Performs scaling of the form. (Inherited from Form.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Form.)
Protected method | SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either or . (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Form.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog | Shows the form as a modal dialog box. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | Start |
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | Causes all of the child controls within a control that support validation to validate their data. (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | Causes all of the child controls within a control that support validation to validate their data. (Inherited from Form.)
Protected method | WndProc | Processes Windows messages. (Inherited from Form.)
Top
Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from Form.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DpiChanged | Occurs when the DPI setting changes on the display device where the form is currently displayed. (Inherited from Form.)
Public event | DpiChangedAfterParent | Occurs when the DPI setting for a control is changed programmatically after the DPI of its parent control or form has changed. (Inherited from Control.)
Public event | DpiChangedBeforeParent | Occurs when the DPI setting for a control is changed programmatically before a DPI change event for its parent control or form has occurred. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the Margin property changes. (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | Occurs when the TabStop property changes. (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

SchemaExplorer.Design Namespace


DatabaseSchemaPickerUI Constructor

Initializes a new instance of the DatabaseSchemaPickerUI class

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public DatabaseSchemaPickerUI()
Public Sub New
See Also

Reference

DatabaseSchemaPickerUI Class
SchemaExplorer.Design Namespace


DatabaseSchemaPickerUI Properties

The DatabaseSchemaPickerUI type exposes the following members.

Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | Gets or sets a value that indicates whether controls in this container will be automatically validated when the focus changes. (Inherited from Form.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DatabaseSchema |
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Form.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DeviceDpi | Gets the DPI value for the display device where the control is currently being displayed. (Inherited from Control.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
Protected property | MaximizedBounds | Gets or sets the size of the form when it is maximized. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Protected property | ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Form.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

DatabaseSchemaPickerUI Class
SchemaExplorer.Design Namespace


DatabaseSchemaPickerUI.DatabaseSchema Property

DatabaseSchemaPickerUIDatabaseSchema Property

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public DatabaseSchema DatabaseSchema { get; set; }
Public Property DatabaseSchema As DatabaseSchema
    Get
    Set

Property Value

Type: DatabaseSchema
See Also

Reference

DatabaseSchemaPickerUI Class
SchemaExplorer.Design Namespace


DatabaseSchemaPickerUI Methods

The DatabaseSchemaPickerUI type exposes the following members.

Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Protected method | ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Protected method | AdjustFormScrollbars | Adjusts the scroll bars on the container based on the current control positions and the control currently selected. (Inherited from Form.)
Protected method | ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
Protected method | CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Form.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Form.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides FormDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | End |
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Form.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Public method | LogicalToDeviceUnits(Int32) | Converts a Logical DPI value to its equivalent DeviceUnit DPI value. (Inherited from Control.)
Public method | LogicalToDeviceUnits(Size) | Transforms a size from logical to device units by scaling it for the current DPI and rounding down to the nearest integer value for width and height. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnActivated | Raises the Activated event. (Inherited from Form.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnClosed | Raises the Closed event. (Inherited from Form.)
Protected method | OnClosing | Raises the Closing event. (Inherited from Form.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDpiChanged | Raises the DpiChanged event. (Inherited from Form.)
Protected method | OnDpiChangedAfterParent | Raises the DpiChangedAfterParent event. (Inherited from Control.)
Protected method | OnDpiChangedBeforeParent | Raises the DpiChangedBeforeParent event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Form.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Form.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Form.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
Protected method | OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
Protected method | OnGetDpiScaledSize | Raises the GetDpiScaledSize event. (Inherited from Form.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Form.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Form.)
Protected method | OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
Protected method | OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Form.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from Form.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
Protected method | OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
Protected method | OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
Protected method | OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
Protected method | OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
Protected method | OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Form.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Form.)
Protected method | OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
Protected method | OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnShown | Raises the Shown event. (Inherited from Form.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Form.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Form.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Form.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Form.)
Protected method | ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Form.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Form.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from Form.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Protected method | RescaleConstantsForDpi | Provides constants for rescaling the control when a DPI change occurs. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value (Empty). (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScaleBitmapLogicalToDevice | Scales a logical bitmap value to it's equivalent device unit value when a DPI change occurs. (Inherited from Control.)
Protected method | ScaleControl | Scales the location, size, padding, and margin of a control. (Inherited from Form.)
Protected method | ScaleCore | Performs scaling of the form. (Inherited from Form.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Form.)
Protected method | SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either or . (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Form.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog | Shows the form as a modal dialog box. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | Start |
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | Causes all of the child controls within a control that support validation to validate their data. (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | Causes all of the child controls within a control that support validation to validate their data. (Inherited from Form.)
Protected method | WndProc | Processes Windows messages. (Inherited from Form.)
Top
See Also

Reference

DatabaseSchemaPickerUI Class
SchemaExplorer.Design Namespace


DatabaseSchemaPickerUI.Dispose Method

DatabaseSchemaPickerUIDispose Method

Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides FormDispose(Boolean).)
Top
See Also

Reference

DatabaseSchemaPickerUI Class
SchemaExplorer.Design Namespace


DatabaseSchemaPickerUI.Dispose Method (Boolean)

DatabaseSchemaPickerUIDispose Method (Boolean)

Clean up any resources being used.

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
true if managed resources should be disposed; otherwise, false.
See Also

Reference

DatabaseSchemaPickerUI Class
Dispose Overload
SchemaExplorer.Design Namespace


DatabaseSchemaPickerUI.End Method

DatabaseSchemaPickerUIEnd Method

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void End()
Public Sub End
See Also

Reference

DatabaseSchemaPickerUI Class
SchemaExplorer.Design Namespace


DatabaseSchemaPickerUI.Start Method

DatabaseSchemaPickerUIStart Method

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void Start(
    IWindowsFormsEditorService editorService,
    Object value
)
Public Sub Start (
    editorService As IWindowsFormsEditorService,
    value As Object
)

Parameters

editorService
Type: System.Windows.Forms.DesignIWindowsFormsEditorService
value
Type: SystemObject
See Also

Reference

DatabaseSchemaPickerUI Class
SchemaExplorer.Design Namespace


DatabaseSchemaPickerUI Events

The DatabaseSchemaPickerUI type exposes the following members.

Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from Form.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DpiChanged | Occurs when the DPI setting changes on the display device where the form is currently displayed. (Inherited from Form.)
Public event | DpiChangedAfterParent | Occurs when the DPI setting for a control is changed programmatically after the DPI of its parent control or form has changed. (Inherited from Control.)
Public event | DpiChangedBeforeParent | Occurs when the DPI setting for a control is changed programmatically before a DPI change event for its parent control or form has occurred. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the Margin property changes. (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | Occurs when the TabStop property changes. (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

DatabaseSchemaPickerUI Class
SchemaExplorer.Design Namespace


DataSourceManagerUI Class

Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
SchemaExplorer.DesignDataSourceManagerUI

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class DataSourceManagerUI : Form
Public Class DataSourceManagerUI
    Inherits Form

The DataSourceManagerUI type exposes the following members.

Constructors
 | Name | Description
Public method | DataSourceManagerUI | Initializes a new instance of the DataSourceManagerUI class
Top
Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | Gets or sets a value that indicates whether controls in this container will be automatically validated when the focus changes. (Inherited from Form.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Form.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DeviceDpi | Gets the DPI value for the display device where the control is currently being displayed. (Inherited from Control.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
Protected property | MaximizedBounds | Gets or sets the size of the form when it is maximized. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Protected property | ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Form.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Protected method | ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Protected method | AdjustFormScrollbars | Adjusts the scroll bars on the container based on the current control positions and the control currently selected. (Inherited from Form.)
Protected method | ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
Protected method | CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Form.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Form.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides FormDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Form.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Public method | LogicalToDeviceUnits(Int32) | Converts a Logical DPI value to its equivalent DeviceUnit DPI value. (Inherited from Control.)
Public method | LogicalToDeviceUnits(Size) | Transforms a size from logical to device units by scaling it for the current DPI and rounding down to the nearest integer value for width and height. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnActivated | Raises the Activated event. (Inherited from Form.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnClosed | Raises the Closed event. (Inherited from Form.)
Protected method | OnClosing | Raises the Closing event. (Inherited from Form.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDpiChanged | Raises the DpiChanged event. (Inherited from Form.)
Protected method | OnDpiChangedAfterParent | Raises the DpiChangedAfterParent event. (Inherited from Control.)
Protected method | OnDpiChangedBeforeParent | Raises the DpiChangedBeforeParent event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Form.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Form.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Form.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
Protected method | OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
Protected method | OnGetDpiScaledSize | Raises the GetDpiScaledSize event. (Inherited from Form.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Form.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Form.)
Protected method | OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
Protected method | OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Form.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from Form.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
Protected method | OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
Protected method | OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
Protected method | OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
Protected method | OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
Protected method | OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Form.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Form.)
Protected method | OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
Protected method | OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnShown | Raises the Shown event. (Inherited from Form.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Form.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Form.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Form.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Form.)
Protected method | ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Form.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Form.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from Form.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Protected method | RescaleConstantsForDpi | Provides constants for rescaling the control when a DPI change occurs. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value (Empty). (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScaleBitmapLogicalToDevice | Scales a logical bitmap value to it's equivalent device unit value when a DPI change occurs. (Inherited from Control.)
Protected method | ScaleControl | Scales the location, size, padding, and margin of a control. (Inherited from Form.)
Protected method | ScaleCore | Performs scaling of the form. (Inherited from Form.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Form.)
Protected method | SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either or . (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Form.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog | Shows the form as a modal dialog box. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | Causes all of the child controls within a control that support validation to validate their data. (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | Causes all of the child controls within a control that support validation to validate their data. (Inherited from Form.)
Protected method | WndProc | Processes Windows messages. (Inherited from Form.)
Top
Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from Form.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DpiChanged | Occurs when the DPI setting changes on the display device where the form is currently displayed. (Inherited from Form.)
Public event | DpiChangedAfterParent | Occurs when the DPI setting for a control is changed programmatically after the DPI of its parent control or form has changed. (Inherited from Control.)
Public event | DpiChangedBeforeParent | Occurs when the DPI setting for a control is changed programmatically before a DPI change event for its parent control or form has occurred. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the Margin property changes. (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | Occurs when the TabStop property changes. (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

SchemaExplorer.Design Namespace


DataSourceManagerUI Constructor

Initializes a new instance of the DataSourceManagerUI class

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public DataSourceManagerUI()
Public Sub New
See Also

Reference

DataSourceManagerUI Class
SchemaExplorer.Design Namespace


DataSourceManagerUI Properties

The DataSourceManagerUI type exposes the following members.

Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | Gets or sets a value that indicates whether controls in this container will be automatically validated when the focus changes. (Inherited from Form.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Form.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DeviceDpi | Gets the DPI value for the display device where the control is currently being displayed. (Inherited from Control.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
Protected property | MaximizedBounds | Gets or sets the size of the form when it is maximized. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Protected property | ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Form.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

DataSourceManagerUI Class
SchemaExplorer.Design Namespace


DataSourceManagerUI Methods

The DataSourceManagerUI type exposes the following members.

Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Protected method | ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Protected method | AdjustFormScrollbars | Adjusts the scroll bars on the container based on the current control positions and the control currently selected. (Inherited from Form.)
Protected method | ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
Protected method | CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Form.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Form.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides FormDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Form.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Public method | LogicalToDeviceUnits(Int32) | Converts a Logical DPI value to its equivalent DeviceUnit DPI value. (Inherited from Control.)
Public method | LogicalToDeviceUnits(Size) | Transforms a size from logical to device units by scaling it for the current DPI and rounding down to the nearest integer value for width and height. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnActivated | Raises the Activated event. (Inherited from Form.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnClosed | Raises the Closed event. (Inherited from Form.)
Protected method | OnClosing | Raises the Closing event. (Inherited from Form.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDpiChanged | Raises the DpiChanged event. (Inherited from Form.)
Protected method | OnDpiChangedAfterParent | Raises the DpiChangedAfterParent event. (Inherited from Control.)
Protected method | OnDpiChangedBeforeParent | Raises the DpiChangedBeforeParent event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Form.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Form.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Form.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
Protected method | OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
Protected method | OnGetDpiScaledSize | Raises the GetDpiScaledSize event. (Inherited from Form.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Form.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Form.)
Protected method | OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
Protected method | OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Form.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from Form.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
Protected method | OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
Protected method | OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
Protected method | OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
Protected method | OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
Protected method | OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Form.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Form.)
Protected method | OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
Protected method | OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnShown | Raises the Shown event. (Inherited from Form.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Form.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Form.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Form.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Form.)
Protected method | ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Form.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Form.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from Form.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Protected method | RescaleConstantsForDpi | Provides constants for rescaling the control when a DPI change occurs. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value (Empty). (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScaleBitmapLogicalToDevice | Scales a logical bitmap value to it's equivalent device unit value when a DPI change occurs. (Inherited from Control.)
Protected method | ScaleControl | Scales the location, size, padding, and margin of a control. (Inherited from Form.)
Protected method | ScaleCore | Performs scaling of the form. (Inherited from Form.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Form.)
Protected method | SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either or . (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Form.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog | Shows the form as a modal dialog box. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | Causes all of the child controls within a control that support validation to validate their data. (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | Causes all of the child controls within a control that support validation to validate their data. (Inherited from Form.)
Protected method | WndProc | Processes Windows messages. (Inherited from Form.)
Top
See Also

Reference

DataSourceManagerUI Class
SchemaExplorer.Design Namespace


DataSourceManagerUI.Dispose Method

DataSourceManagerUIDispose Method

Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides FormDispose(Boolean).)
Top
See Also

Reference

DataSourceManagerUI Class
SchemaExplorer.Design Namespace


DataSourceManagerUI.Dispose Method (Boolean)

DataSourceManagerUIDispose Method (Boolean)

Clean up any resources being used.

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
true if managed resources should be disposed; otherwise, false.
See Also

Reference

DataSourceManagerUI Class
Dispose Overload
SchemaExplorer.Design Namespace


DataSourceManagerUI Events

The DataSourceManagerUI type exposes the following members.

Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from Form.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DpiChanged | Occurs when the DPI setting changes on the display device where the form is currently displayed. (Inherited from Form.)
Public event | DpiChangedAfterParent | Occurs when the DPI setting for a control is changed programmatically after the DPI of its parent control or form has changed. (Inherited from Control.)
Public event | DpiChangedBeforeParent | Occurs when the DPI setting for a control is changed programmatically before a DPI change event for its parent control or form has occurred. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the Margin property changes. (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | Occurs when the TabStop property changes. (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

DataSourceManagerUI Class
SchemaExplorer.Design Namespace


DataSourceUI Class

Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
SchemaExplorer.DesignDataSourceUI

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class DataSourceUI : Form
Public Class DataSourceUI
    Inherits Form

The DataSourceUI type exposes the following members.

Constructors
 | Name | Description
Public method | DataSourceUI | Initializes a new instance of the DataSourceUI class
Public method | DataSourceUI(DataSource) | Initializes a new instance of the DataSourceUI class
Top
Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | Gets or sets a value that indicates whether controls in this container will be automatically validated when the focus changes. (Inherited from Form.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Form.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DeviceDpi | Gets the DPI value for the display device where the control is currently being displayed. (Inherited from Control.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
Protected property | MaximizedBounds | Gets or sets the size of the form when it is maximized. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Protected property | ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Form.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Protected method | ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Protected method | AdjustFormScrollbars | Adjusts the scroll bars on the container based on the current control positions and the control currently selected. (Inherited from Form.)
Protected method | ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
Protected method | CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Form.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Form.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides FormDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetConnectionStringEditor |
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Form.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Public method | LogicalToDeviceUnits(Int32) | Converts a Logical DPI value to its equivalent DeviceUnit DPI value. (Inherited from Control.)
Public method | LogicalToDeviceUnits(Size) | Transforms a size from logical to device units by scaling it for the current DPI and rounding down to the nearest integer value for width and height. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnActivated | Raises the Activated event. (Inherited from Form.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnClosed | Raises the Closed event. (Inherited from Form.)
Protected method | OnClosing | Raises the Closing event. (Inherited from Form.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDpiChanged | Raises the DpiChanged event. (Inherited from Form.)
Protected method | OnDpiChangedAfterParent | Raises the DpiChangedAfterParent event. (Inherited from Control.)
Protected method | OnDpiChangedBeforeParent | Raises the DpiChangedBeforeParent event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Form.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Form.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Form.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
Protected method | OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
Protected method | OnGetDpiScaledSize | Raises the GetDpiScaledSize event. (Inherited from Form.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Form.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Form.)
Protected method | OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
Protected method | OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Form.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from Form.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
Protected method | OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
Protected method | OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
Protected method | OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
Protected method | OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
Protected method | OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Form.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Form.)
Protected method | OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
Protected method | OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnShown | Raises the Shown event. (Inherited from Form.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Form.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Form.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Form.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Form.)
Protected method | ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Form.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Form.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from Form.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Protected method | RescaleConstantsForDpi | Provides constants for rescaling the control when a DPI change occurs. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value (Empty). (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScaleBitmapLogicalToDevice | Scales a logical bitmap value to it's equivalent device unit value when a DPI change occurs. (Inherited from Control.)
Protected method | ScaleControl | Scales the location, size, padding, and margin of a control. (Inherited from Form.)
Protected method | ScaleCore | Performs scaling of the form. (Inherited from Form.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Form.)
Protected method | SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either or . (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Form.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog | Shows the form as a modal dialog box. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | Causes all of the child controls within a control that support validation to validate their data. (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | Causes all of the child controls within a control that support validation to validate their data. (Inherited from Form.)
Protected method | WndProc | Processes Windows messages. (Inherited from Form.)
Top
Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from Form.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DpiChanged | Occurs when the DPI setting changes on the display device where the form is currently displayed. (Inherited from Form.)
Public event | DpiChangedAfterParent | Occurs when the DPI setting for a control is changed programmatically after the DPI of its parent control or form has changed. (Inherited from Control.)
Public event | DpiChangedBeforeParent | Occurs when the DPI setting for a control is changed programmatically before a DPI change event for its parent control or form has occurred. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the Margin property changes. (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | Occurs when the TabStop property changes. (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

SchemaExplorer.Design Namespace


DataSourceUI Constructor

Overload List
 | Name | Description
Public method | DataSourceUI | Initializes a new instance of the DataSourceUI class
Public method | DataSourceUI(DataSource) | Initializes a new instance of the DataSourceUI class
Top
See Also

Reference

DataSourceUI Class
SchemaExplorer.Design Namespace


DataSourceUI Constructor

Initializes a new instance of the DataSourceUI class

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public DataSourceUI()
Public Sub New
See Also

Reference

DataSourceUI Class
DataSourceUI Overload
SchemaExplorer.Design Namespace


DataSourceUI Constructor (DataSource)

Initializes a new instance of the DataSourceUI class

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public DataSourceUI(
    DataSource dataSource
)
Public Sub New (
    dataSource As DataSource
)

Parameters

dataSource
Type: SchemaExplorerDataSource
See Also

Reference

DataSourceUI Class
DataSourceUI Overload
SchemaExplorer.Design Namespace


DataSourceUI Properties

The DataSourceUI type exposes the following members.

Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | Gets or sets a value that indicates whether controls in this container will be automatically validated when the focus changes. (Inherited from Form.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Form.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DeviceDpi | Gets the DPI value for the display device where the control is currently being displayed. (Inherited from Control.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
Protected property | MaximizedBounds | Gets or sets the size of the form when it is maximized. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Protected property | ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Form.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

DataSourceUI Class
SchemaExplorer.Design Namespace


DataSourceUI Methods

The DataSourceUI type exposes the following members.

Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Protected method | ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Protected method | AdjustFormScrollbars | Adjusts the scroll bars on the container based on the current control positions and the control currently selected. (Inherited from Form.)
Protected method | ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
Protected method | CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Form.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Form.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides FormDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetConnectionStringEditor |
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Form.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Public method | LogicalToDeviceUnits(Int32) | Converts a Logical DPI value to its equivalent DeviceUnit DPI value. (Inherited from Control.)
Public method | LogicalToDeviceUnits(Size) | Transforms a size from logical to device units by scaling it for the current DPI and rounding down to the nearest integer value for width and height. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnActivated | Raises the Activated event. (Inherited from Form.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnClosed | Raises the Closed event. (Inherited from Form.)
Protected method | OnClosing | Raises the Closing event. (Inherited from Form.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDpiChanged | Raises the DpiChanged event. (Inherited from Form.)
Protected method | OnDpiChangedAfterParent | Raises the DpiChangedAfterParent event. (Inherited from Control.)
Protected method | OnDpiChangedBeforeParent | Raises the DpiChangedBeforeParent event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Form.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Form.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Form.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
Protected method | OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
Protected method | OnGetDpiScaledSize | Raises the GetDpiScaledSize event. (Inherited from Form.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Form.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Form.)
Protected method | OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
Protected method | OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Form.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from Form.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
Protected method | OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
Protected method | OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
Protected method | OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
Protected method | OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
Protected method | OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Form.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Form.)
Protected method | OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
Protected method | OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnShown | Raises the Shown event. (Inherited from Form.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Form.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Form.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Form.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Form.)
Protected method | ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Form.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Form.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from Form.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Protected method | RescaleConstantsForDpi | Provides constants for rescaling the control when a DPI change occurs. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value (Empty). (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScaleBitmapLogicalToDevice | Scales a logical bitmap value to it's equivalent device unit value when a DPI change occurs. (Inherited from Control.)
Protected method | ScaleControl | Scales the location, size, padding, and margin of a control. (Inherited from Form.)
Protected method | ScaleCore | Performs scaling of the form. (Inherited from Form.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Form.)
Protected method | SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either or . (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Form.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog | Shows the form as a modal dialog box. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | Causes all of the child controls within a control that support validation to validate their data. (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | Causes all of the child controls within a control that support validation to validate their data. (Inherited from Form.)
Protected method | WndProc | Processes Windows messages. (Inherited from Form.)
Top
See Also

Reference

DataSourceUI Class
SchemaExplorer.Design Namespace


DataSourceUI.Dispose Method

DataSourceUIDispose Method

Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides FormDispose(Boolean).)
Top
See Also

Reference

DataSourceUI Class
SchemaExplorer.Design Namespace


DataSourceUI.Dispose Method (Boolean)

DataSourceUIDispose Method (Boolean)

Clean up any resources being used.

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
true if managed resources should be disposed; otherwise, false.
See Also

Reference

DataSourceUI Class
Dispose Overload
SchemaExplorer.Design Namespace


DataSourceUI.GetConnectionStringEditor Method

DataSourceUIGetConnectionStringEditor Method

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public IDbConnectionStringEditor GetConnectionStringEditor()
Public Function GetConnectionStringEditor As IDbConnectionStringEditor

Return Value

Type: IDbConnectionStringEditor
See Also

Reference

DataSourceUI Class
SchemaExplorer.Design Namespace


DataSourceUI Events

The DataSourceUI type exposes the following members.

Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from Form.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DpiChanged | Occurs when the DPI setting changes on the display device where the form is currently displayed. (Inherited from Form.)
Public event | DpiChangedAfterParent | Occurs when the DPI setting for a control is changed programmatically after the DPI of its parent control or form has changed. (Inherited from Control.)
Public event | DpiChangedBeforeParent | Occurs when the DPI setting for a control is changed programmatically before a DPI change event for its parent control or form has occurred. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the Margin property changes. (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | Occurs when the TabStop property changes. (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

DataSourceUI Class
SchemaExplorer.Design Namespace


ErrorDialog Class

Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
SchemaExplorer.DesignErrorDialog

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class ErrorDialog : Form
Public Class ErrorDialog
    Inherits Form

The ErrorDialog type exposes the following members.

Constructors
 | Name | Description
Public method | ErrorDialog | Initializes a new instance of the ErrorDialog class
Top
Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | Gets or sets a value that indicates whether controls in this container will be automatically validated when the focus changes. (Inherited from Form.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Form.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DeviceDpi | Gets the DPI value for the display device where the control is currently being displayed. (Inherited from Control.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
Protected property | MaximizedBounds | Gets or sets the size of the form when it is maximized. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Protected property | ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Form.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Protected method | ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Protected method | AdjustFormScrollbars | Adjusts the scroll bars on the container based on the current control positions and the control currently selected. (Inherited from Form.)
Protected method | ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
Protected method | CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Form.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Form.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Disposes of the resources (other than memory) used by the Form. (Inherited from Form.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Form.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Public method | LogicalToDeviceUnits(Int32) | Converts a Logical DPI value to its equivalent DeviceUnit DPI value. (Inherited from Control.)
Public method | LogicalToDeviceUnits(Size) | Transforms a size from logical to device units by scaling it for the current DPI and rounding down to the nearest integer value for width and height. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnActivated | Raises the Activated event. (Inherited from Form.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnClosed | Raises the Closed event. (Inherited from Form.)
Protected method | OnClosing | Raises the Closing event. (Inherited from Form.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDpiChanged | Raises the DpiChanged event. (Inherited from Form.)
Protected method | OnDpiChangedAfterParent | Raises the DpiChangedAfterParent event. (Inherited from Control.)
Protected method | OnDpiChangedBeforeParent | Raises the DpiChangedBeforeParent event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Form.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Form.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Form.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
Protected method | OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
Protected method | OnGetDpiScaledSize | Raises the GetDpiScaledSize event. (Inherited from Form.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Form.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Form.)
Protected method | OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
Protected method | OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Form.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from Form.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
Protected method | OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
Protected method | OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
Protected method | OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
Protected method | OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
Protected method | OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Form.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Form.)
Protected method | OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
Protected method | OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnShown | Raises the Shown event. (Inherited from Form.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Form.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Form.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Form.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Form.)
Protected method | ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Form.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Form.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from Form.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Protected method | RescaleConstantsForDpi | Provides constants for rescaling the control when a DPI change occurs. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value (Empty). (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScaleBitmapLogicalToDevice | Scales a logical bitmap value to it's equivalent device unit value when a DPI change occurs. (Inherited from Control.)
Protected method | ScaleControl | Scales the location, size, padding, and margin of a control. (Inherited from Form.)
Protected method | ScaleCore | Performs scaling of the form. (Inherited from Form.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Form.)
Protected method | SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either or . (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Form.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
 | Show(IWin32Window, Exception) |
 | Show(IWin32Window, String, String) |
 | Show(IWin32Window, String, String, String) |
Public method | ShowDialog | Shows the form as a modal dialog box. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | Causes all of the child controls within a control that support validation to validate their data. (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | Causes all of the child controls within a control that support validation to validate their data. (Inherited from Form.)
Protected method | WndProc | Processes Windows messages. (Inherited from Form.)
Top
Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from Form.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DpiChanged | Occurs when the DPI setting changes on the display device where the form is currently displayed. (Inherited from Form.)
Public event | DpiChangedAfterParent | Occurs when the DPI setting for a control is changed programmatically after the DPI of its parent control or form has changed. (Inherited from Control.)
Public event | DpiChangedBeforeParent | Occurs when the DPI setting for a control is changed programmatically before a DPI change event for its parent control or form has occurred. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the Margin property changes. (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | Occurs when the TabStop property changes. (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

SchemaExplorer.Design Namespace


ErrorDialog Constructor

Initializes a new instance of the ErrorDialog class

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ErrorDialog(
    string title,
    string errorMessage,
    string details
)
Public Sub New (
    title As String,
    errorMessage As String,
    details As String
)

Parameters

title
Type: SystemString
errorMessage
Type: SystemString
details
Type: SystemString
See Also

Reference

ErrorDialog Class
SchemaExplorer.Design Namespace


ErrorDialog Properties

The ErrorDialog type exposes the following members.

Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | Gets or sets a value that indicates whether controls in this container will be automatically validated when the focus changes. (Inherited from Form.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Form.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DeviceDpi | Gets the DPI value for the display device where the control is currently being displayed. (Inherited from Control.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
Protected property | MaximizedBounds | Gets or sets the size of the form when it is maximized. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Protected property | ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Form.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

ErrorDialog Class
SchemaExplorer.Design Namespace


ErrorDialog Methods

The ErrorDialog type exposes the following members.

Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Protected method | ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Protected method | AdjustFormScrollbars | Adjusts the scroll bars on the container based on the current control positions and the control currently selected. (Inherited from Form.)
Protected method | ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
Protected method | CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Form.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Form.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Disposes of the resources (other than memory) used by the Form. (Inherited from Form.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Form.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Public method | LogicalToDeviceUnits(Int32) | Converts a Logical DPI value to its equivalent DeviceUnit DPI value. (Inherited from Control.)
Public method | LogicalToDeviceUnits(Size) | Transforms a size from logical to device units by scaling it for the current DPI and rounding down to the nearest integer value for width and height. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnActivated | Raises the Activated event. (Inherited from Form.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnClosed | Raises the Closed event. (Inherited from Form.)
Protected method | OnClosing | Raises the Closing event. (Inherited from Form.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDpiChanged | Raises the DpiChanged event. (Inherited from Form.)
Protected method | OnDpiChangedAfterParent | Raises the DpiChangedAfterParent event. (Inherited from Control.)
Protected method | OnDpiChangedBeforeParent | Raises the DpiChangedBeforeParent event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Form.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Form.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Form.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
Protected method | OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
Protected method | OnGetDpiScaledSize | Raises the GetDpiScaledSize event. (Inherited from Form.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Form.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Form.)
Protected method | OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
Protected method | OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Form.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from Form.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
Protected method | OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
Protected method | OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
Protected method | OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
Protected method | OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
Protected method | OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Form.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Form.)
Protected method | OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
Protected method | OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnShown | Raises the Shown event. (Inherited from Form.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Form.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Form.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Form.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Form.)
Protected method | ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Form.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Form.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from Form.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Protected method | RescaleConstantsForDpi | Provides constants for rescaling the control when a DPI change occurs. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value (Empty). (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScaleBitmapLogicalToDevice | Scales a logical bitmap value to it's equivalent device unit value when a DPI change occurs. (Inherited from Control.)
Protected method | ScaleControl | Scales the location, size, padding, and margin of a control. (Inherited from Form.)
Protected method | ScaleCore | Performs scaling of the form. (Inherited from Form.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Form.)
Protected method | SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either or . (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Form.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
 | Show(IWin32Window, Exception) |
 | Show(IWin32Window, String, String) |
 | Show(IWin32Window, String, String, String) |
Public method | ShowDialog | Shows the form as a modal dialog box. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | Causes all of the child controls within a control that support validation to validate their data. (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | Causes all of the child controls within a control that support validation to validate their data. (Inherited from Form.)
Protected method | WndProc | Processes Windows messages. (Inherited from Form.)
Top
See Also

Reference

ErrorDialog Class
SchemaExplorer.Design Namespace


ErrorDialog.Show Method

ErrorDialogShow Method

Overload List
 | Name | Description
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
 | Show(IWin32Window, Exception) |
 | Show(IWin32Window, String, String) |
 | Show(IWin32Window, String, String, String) |
Top
See Also

Reference

ErrorDialog Class
SchemaExplorer.Design Namespace


ErrorDialog.Show Method (IWin32Window, Exception)

ErrorDialogShow Method (IWin32Window, Exception)

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static DialogResult Show(
    IWin32Window owner,
    Exception e
)
Public Shared Function Show (
    owner As IWin32Window,
    e As Exception
) As DialogResult

Parameters

owner
Type: System.Windows.FormsIWin32Window
e
Type: SystemException

Return Value

Type: DialogResult
See Also

Reference

ErrorDialog Class
Show Overload
SchemaExplorer.Design Namespace


ErrorDialog.Show Method (IWin32Window, String, String)

ErrorDialogShow Method (IWin32Window, String, String)

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static DialogResult Show(
    IWin32Window owner,
    string errorMessage,
    string details
)
Public Shared Function Show (
    owner As IWin32Window,
    errorMessage As String,
    details As String
) As DialogResult

Parameters

owner
Type: System.Windows.FormsIWin32Window
errorMessage
Type: SystemString
details
Type: SystemString

Return Value

Type: DialogResult
See Also

Reference

ErrorDialog Class
Show Overload
SchemaExplorer.Design Namespace


ErrorDialog.Show Method (IWin32Window, String, String, String)

ErrorDialogShow Method (IWin32Window, String, String, String)

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static DialogResult Show(
    IWin32Window owner,
    string title,
    string errorMessage,
    string details
)
Public Shared Function Show (
    owner As IWin32Window,
    title As String,
    errorMessage As String,
    details As String
) As DialogResult

Parameters

owner
Type: System.Windows.FormsIWin32Window
title
Type: SystemString
errorMessage
Type: SystemString
details
Type: SystemString

Return Value

Type: DialogResult
See Also

Reference

ErrorDialog Class
Show Overload
SchemaExplorer.Design Namespace


ErrorDialog Events

The ErrorDialog type exposes the following members.

Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from Form.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DpiChanged | Occurs when the DPI setting changes on the display device where the form is currently displayed. (Inherited from Form.)
Public event | DpiChangedAfterParent | Occurs when the DPI setting for a control is changed programmatically after the DPI of its parent control or form has changed. (Inherited from Control.)
Public event | DpiChangedBeforeParent | Occurs when the DPI setting for a control is changed programmatically before a DPI change event for its parent control or form has occurred. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the Margin property changes. (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | Occurs when the TabStop property changes. (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

ErrorDialog Class
SchemaExplorer.Design Namespace


ExtendedBindableProperty Class

Inheritance Hierarchy
SystemObject
SchemaExplorer.DesignExtendedBindableProperty

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class ExtendedBindableProperty : IDataErrorInfo
Public Class ExtendedBindableProperty
    Implements IDataErrorInfo

The ExtendedBindableProperty type exposes the following members.

Constructors
 | Name | Description
Public method | ExtendedBindableProperty | Initializes a new instance of the ExtendedBindableProperty class
Public method | ExtendedBindableProperty(ExtendedProperty) | Initializes a new instance of the ExtendedBindableProperty class
Top
Properties
 | Name | Description
Public property | DataType |
Public property | IsDirty |
Public property | IsNew |
Public property | IsReadonly |
Public property | Name |
Public property | Value |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate |
Top
See Also

Reference

SchemaExplorer.Design Namespace


ExtendedBindableProperty Constructor

Overload List
 | Name | Description
Public method | ExtendedBindableProperty | Initializes a new instance of the ExtendedBindableProperty class
Public method | ExtendedBindableProperty(ExtendedProperty) | Initializes a new instance of the ExtendedBindableProperty class
Top
See Also

Reference

ExtendedBindableProperty Class
SchemaExplorer.Design Namespace


ExtendedBindableProperty Constructor

Initializes a new instance of the ExtendedBindableProperty class

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ExtendedBindableProperty()
Public Sub New
See Also

Reference

ExtendedBindableProperty Class
ExtendedBindableProperty Overload
SchemaExplorer.Design Namespace


ExtendedBindableProperty Constructor (ExtendedProperty)

Initializes a new instance of the ExtendedBindableProperty class

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ExtendedBindableProperty(
    ExtendedProperty property
)
Public Sub New (
    property As ExtendedProperty
)

Parameters

property
Type: SchemaExplorerExtendedProperty
See Also

Reference

ExtendedBindableProperty Class
ExtendedBindableProperty Overload
SchemaExplorer.Design Namespace


ExtendedBindableProperty Properties

The ExtendedBindableProperty type exposes the following members.

Properties
 | Name | Description
Public property | DataType |
Public property | IsDirty |
Public property | IsNew |
Public property | IsReadonly |
Public property | Name |
Public property | Value |
Top
See Also

Reference

ExtendedBindableProperty Class
SchemaExplorer.Design Namespace


ExtendedBindableProperty.DataType Property

ExtendedBindablePropertyDataType Property

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public DbType DataType { get; set; }
Public Property DataType As DbType
    Get
    Set

Property Value

Type: DbType
See Also

Reference

ExtendedBindableProperty Class
SchemaExplorer.Design Namespace


ExtendedBindableProperty.IsDirty Property

ExtendedBindablePropertyIsDirty Property

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool IsDirty { get; set; }
Public Property IsDirty As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

ExtendedBindableProperty Class
SchemaExplorer.Design Namespace


ExtendedBindableProperty.IsNew Property

ExtendedBindablePropertyIsNew Property

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool IsNew { get; set; }
Public Property IsNew As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

ExtendedBindableProperty Class
SchemaExplorer.Design Namespace


ExtendedBindableProperty.IsReadonly Property

ExtendedBindablePropertyIsReadonly Property

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool IsReadonly { get; set; }
Public Property IsReadonly As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

ExtendedBindableProperty Class
SchemaExplorer.Design Namespace


ExtendedBindableProperty.Name Property

ExtendedBindablePropertyName Property

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set

Property Value

Type: String
See Also

Reference

ExtendedBindableProperty Class
SchemaExplorer.Design Namespace


ExtendedBindableProperty.Value Property

ExtendedBindablePropertyValue Property

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public Object Value { get; set; }
Public Property Value As Object
    Get
    Set

Property Value

Type: Object
See Also

Reference

ExtendedBindableProperty Class
SchemaExplorer.Design Namespace


ExtendedBindableProperty Methods

The ExtendedBindableProperty type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate |
Top
See Also

Reference

ExtendedBindableProperty Class
SchemaExplorer.Design Namespace


ExtendedBindableProperty.Validate Method

ExtendedBindablePropertyValidate Method

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool Validate()
Public Function Validate As Boolean

Return Value

Type: Boolean
See Also

Reference

ExtendedBindableProperty Class
SchemaExplorer.Design Namespace


ExtendedPropertyEditorUI Class

Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
SchemaExplorer.DesignExtendedPropertyEditorUI

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class ExtendedPropertyEditorUI : Form
Public Class ExtendedPropertyEditorUI
    Inherits Form

The ExtendedPropertyEditorUI type exposes the following members.

Constructors
 | Name | Description
Public method | ExtendedPropertyEditorUI | Initializes a new instance of the ExtendedPropertyEditorUI class
Public method | ExtendedPropertyEditorUI(SchemaObjectBase) | Initializes a new instance of the ExtendedPropertyEditorUI class
Top
Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | Gets or sets a value that indicates whether controls in this container will be automatically validated when the focus changes. (Inherited from Form.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Form.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DeviceDpi | Gets the DPI value for the display device where the control is currently being displayed. (Inherited from Control.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | ExtendedPropertyCollection |
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDirty |
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
Protected property | MaximizedBounds | Gets or sets the size of the form when it is maximized. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Protected property | ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Form.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Protected method | ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Protected method | AdjustFormScrollbars | Adjusts the scroll bars on the container based on the current control positions and the control currently selected. (Inherited from Form.)
Protected method | ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
Protected method | CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Form.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Form.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides FormDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | End |
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Form.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Public method | LogicalToDeviceUnits(Int32) | Converts a Logical DPI value to its equivalent DeviceUnit DPI value. (Inherited from Control.)
Public method | LogicalToDeviceUnits(Size) | Transforms a size from logical to device units by scaling it for the current DPI and rounding down to the nearest integer value for width and height. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnActivated | Raises the Activated event. (Inherited from Form.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnClosed | Raises the Closed event. (Inherited from Form.)
Protected method | OnClosing | Raises the Closing event. (Inherited from Form.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDpiChanged | Raises the DpiChanged event. (Inherited from Form.)
Protected method | OnDpiChangedAfterParent | Raises the DpiChangedAfterParent event. (Inherited from Control.)
Protected method | OnDpiChangedBeforeParent | Raises the DpiChangedBeforeParent event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Form.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Form.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Form.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
Protected method | OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
Protected method | OnGetDpiScaledSize | Raises the GetDpiScaledSize event. (Inherited from Form.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Form.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Form.)
Protected method | OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
Protected method | OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Form.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from Form.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
Protected method | OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
Protected method | OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
Protected method | OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
Protected method | OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
Protected method | OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Form.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Form.)
Protected method | OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
Protected method | OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnShown | Raises the Shown event. (Inherited from Form.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Form.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Form.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Form.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Form.)
Protected method | ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Form.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Form.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from Form.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Protected method | RescaleConstantsForDpi | Provides constants for rescaling the control when a DPI change occurs. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value (Empty). (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScaleBitmapLogicalToDevice | Scales a logical bitmap value to it's equivalent device unit value when a DPI change occurs. (Inherited from Control.)
Protected method | ScaleControl | Scales the location, size, padding, and margin of a control. (Inherited from Form.)
Protected method | ScaleCore | Performs scaling of the form. (Inherited from Form.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Form.)
Protected method | SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either or . (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Form.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog | Shows the form as a modal dialog box. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | Start |
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | Causes all of the child controls within a control that support validation to validate their data. (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | Causes all of the child controls within a control that support validation to validate their data. (Inherited from Form.)
Protected method | WndProc | Processes Windows messages. (Inherited from Form.)
Top
Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from Form.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DpiChanged | Occurs when the DPI setting changes on the display device where the form is currently displayed. (Inherited from Form.)
Public event | DpiChangedAfterParent | Occurs when the DPI setting for a control is changed programmatically after the DPI of its parent control or form has changed. (Inherited from Control.)
Public event | DpiChangedBeforeParent | Occurs when the DPI setting for a control is changed programmatically before a DPI change event for its parent control or form has occurred. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the Margin property changes. (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | Occurs when the TabStop property changes. (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

SchemaExplorer.Design Namespace


ExtendedPropertyEditorUI Constructor

Overload List
 | Name | Description
Public method | ExtendedPropertyEditorUI | Initializes a new instance of the ExtendedPropertyEditorUI class
Public method | ExtendedPropertyEditorUI(SchemaObjectBase) | Initializes a new instance of the ExtendedPropertyEditorUI class
Top
See Also

Reference

ExtendedPropertyEditorUI Class
SchemaExplorer.Design Namespace


ExtendedPropertyEditorUI Constructor

Initializes a new instance of the ExtendedPropertyEditorUI class

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ExtendedPropertyEditorUI()
Public Sub New
See Also

Reference

ExtendedPropertyEditorUI Class
ExtendedPropertyEditorUI Overload
SchemaExplorer.Design Namespace


ExtendedPropertyEditorUI Constructor (SchemaObjectBase)

Initializes a new instance of the ExtendedPropertyEditorUI class

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ExtendedPropertyEditorUI(
    SchemaObjectBase schemaObject
)
Public Sub New (
    schemaObject As SchemaObjectBase
)

Parameters

schemaObject
Type: SchemaExplorerSchemaObjectBase
See Also

Reference

ExtendedPropertyEditorUI Class
ExtendedPropertyEditorUI Overload
SchemaExplorer.Design Namespace


ExtendedPropertyEditorUI Properties

The ExtendedPropertyEditorUI type exposes the following members.

Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | Gets or sets a value that indicates whether controls in this container will be automatically validated when the focus changes. (Inherited from Form.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Form.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DeviceDpi | Gets the DPI value for the display device where the control is currently being displayed. (Inherited from Control.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | ExtendedPropertyCollection |
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDirty |
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
Protected property | MaximizedBounds | Gets or sets the size of the form when it is maximized. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Protected property | ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Form.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

ExtendedPropertyEditorUI Class
SchemaExplorer.Design Namespace


ExtendedPropertyEditorUI.ExtendedPropertyCollection Property

ExtendedPropertyEditorUIExtendedPropertyCollection Property

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ExtendedPropertyCollection ExtendedPropertyCollection { get; set; }
Public Property ExtendedPropertyCollection As ExtendedPropertyCollection
    Get
    Set

Property Value

Type: ExtendedPropertyCollection
See Also

Reference

ExtendedPropertyEditorUI Class
SchemaExplorer.Design Namespace


ExtendedPropertyEditorUI.IsDirty Property

ExtendedPropertyEditorUIIsDirty Property

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool IsDirty { get; set; }
Public Property IsDirty As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

ExtendedPropertyEditorUI Class
SchemaExplorer.Design Namespace


ExtendedPropertyEditorUI Methods

The ExtendedPropertyEditorUI type exposes the following members.

Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Protected method | ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Protected method | AdjustFormScrollbars | Adjusts the scroll bars on the container based on the current control positions and the control currently selected. (Inherited from Form.)
Protected method | ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
Protected method | CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Form.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Form.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides FormDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | End |
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Form.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Public method | LogicalToDeviceUnits(Int32) | Converts a Logical DPI value to its equivalent DeviceUnit DPI value. (Inherited from Control.)
Public method | LogicalToDeviceUnits(Size) | Transforms a size from logical to device units by scaling it for the current DPI and rounding down to the nearest integer value for width and height. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnActivated | Raises the Activated event. (Inherited from Form.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnClosed | Raises the Closed event. (Inherited from Form.)
Protected method | OnClosing | Raises the Closing event. (Inherited from Form.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDpiChanged | Raises the DpiChanged event. (Inherited from Form.)
Protected method | OnDpiChangedAfterParent | Raises the DpiChangedAfterParent event. (Inherited from Control.)
Protected method | OnDpiChangedBeforeParent | Raises the DpiChangedBeforeParent event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Form.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Form.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Form.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
Protected method | OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
Protected method | OnGetDpiScaledSize | Raises the GetDpiScaledSize event. (Inherited from Form.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Form.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Form.)
Protected method | OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
Protected method | OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Form.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from Form.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
Protected method | OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
Protected method | OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
Protected method | OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
Protected method | OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
Protected method | OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Form.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Form.)
Protected method | OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
Protected method | OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnShown | Raises the Shown event. (Inherited from Form.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Form.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Form.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Form.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Form.)
Protected method | ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Form.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Form.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from Form.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Protected method | RescaleConstantsForDpi | Provides constants for rescaling the control when a DPI change occurs. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value (Empty). (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScaleBitmapLogicalToDevice | Scales a logical bitmap value to it's equivalent device unit value when a DPI change occurs. (Inherited from Control.)
Protected method | ScaleControl | Scales the location, size, padding, and margin of a control. (Inherited from Form.)
Protected method | ScaleCore | Performs scaling of the form. (Inherited from Form.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Form.)
Protected method | SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either or . (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Form.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog | Shows the form as a modal dialog box. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | Start |
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | Causes all of the child controls within a control that support validation to validate their data. (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | Causes all of the child controls within a control that support validation to validate their data. (Inherited from Form.)
Protected method | WndProc | Processes Windows messages. (Inherited from Form.)
Top
See Also

Reference

ExtendedPropertyEditorUI Class
SchemaExplorer.Design Namespace


ExtendedPropertyEditorUI.Dispose Method

ExtendedPropertyEditorUIDispose Method

Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides FormDispose(Boolean).)
Top
See Also

Reference

ExtendedPropertyEditorUI Class
SchemaExplorer.Design Namespace


ExtendedPropertyEditorUI.Dispose Method (Boolean)

ExtendedPropertyEditorUIDispose Method (Boolean)

Clean up any resources being used.

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
true if managed resources should be disposed; otherwise, false.
See Also

Reference

ExtendedPropertyEditorUI Class
Dispose Overload
SchemaExplorer.Design Namespace


ExtendedPropertyEditorUI.End Method

ExtendedPropertyEditorUIEnd Method

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void End()
Public Sub End
See Also

Reference

ExtendedPropertyEditorUI Class
SchemaExplorer.Design Namespace


ExtendedPropertyEditorUI.Start Method

ExtendedPropertyEditorUIStart Method

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void Start(
    Object value,
    string name
)
Public Sub Start (
    value As Object,
    name As String
)

Parameters

value
Type: SystemObject
name
Type: SystemString
See Also

Reference

ExtendedPropertyEditorUI Class
SchemaExplorer.Design Namespace


ExtendedPropertyEditorUI Events

The ExtendedPropertyEditorUI type exposes the following members.

Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from Form.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DpiChanged | Occurs when the DPI setting changes on the display device where the form is currently displayed. (Inherited from Form.)
Public event | DpiChangedAfterParent | Occurs when the DPI setting for a control is changed programmatically after the DPI of its parent control or form has changed. (Inherited from Control.)
Public event | DpiChangedBeforeParent | Occurs when the DPI setting for a control is changed programmatically before a DPI change event for its parent control or form has occurred. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the Margin property changes. (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | Occurs when the TabStop property changes. (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

ExtendedPropertyEditorUI Class
SchemaExplorer.Design Namespace


SchemaObjectEditor Class

Inheritance Hierarchy
SystemObject
PropertyEditor
DialogTextBoxPropertyEditor
DialogPropertyEditor
SchemaExplorer.DesignSchemaObjectEditor

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class SchemaObjectEditor : DialogPropertyEditor
Public Class SchemaObjectEditor
    Inherits DialogPropertyEditor

The SchemaObjectEditor type exposes the following members.

Constructors
 | Name | Description
Public method | SchemaObjectEditor | Initializes a new instance of the SchemaObjectEditor class
Top
Properties
 | Name | Description
Public property | IsValid | (Inherited from PropertyEditor.)
Public property | NameStyles | (Inherited from PropertyEditor.)
Public property | NameTemplate | (Inherited from PropertyEditor.)
Public property | NameTemplateKey | (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | (Inherited from PropertyEditor.)
Public property | ObjectType | (Inherited from PropertyEditor.)
Public property | PropertyName | (Inherited from PropertyEditor.)
Public property | PropertyType | (Inherited from PropertyEditor.)
Public property | ValueStyles | (Inherited from PropertyEditor.)
Public property | ValueTemplate | (Inherited from DialogTextBoxPropertyEditor.)
Public property | ValueTemplateKey | (Inherited from DialogTextBoxPropertyEditor.)
Public property | ValueTemplateSelector | (Inherited from DialogTextBoxPropertyEditor.)
Top
Methods
 | Name | Description
Public method | CanShowDialog | (Inherited from DialogPropertyEditor.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetMatchOrder(PropertyEditor) | (Inherited from PropertyEditor.)
Public method | GetMatchOrder(Type, String, Type) | (Inherited from PropertyEditor.)
Public method | GetMatchOrder(Type, String, Type, Int32) | (Inherited from PropertyEditor.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SetDeepLoad |
 | SetIncludeFunctions |
Public method | ShowDialog | (Overrides DialogPropertyEditor.ShowDialog(Object, ExecutedRoutedEventArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SchemaExplorer.Design Namespace


SchemaObjectEditor Constructor

Initializes a new instance of the SchemaObjectEditor class

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public SchemaObjectEditor()
Public Sub New
See Also

Reference

SchemaObjectEditor Class
SchemaExplorer.Design Namespace


SchemaObjectEditor Properties

The SchemaObjectEditor type exposes the following members.

Properties
 | Name | Description
Public property | IsValid | (Inherited from PropertyEditor.)
Public property | NameStyles | (Inherited from PropertyEditor.)
Public property | NameTemplate | (Inherited from PropertyEditor.)
Public property | NameTemplateKey | (Inherited from PropertyEditor.)
Public property | NameTemplateSelector | (Inherited from PropertyEditor.)
Public property | ObjectType | (Inherited from PropertyEditor.)
Public property | PropertyName | (Inherited from PropertyEditor.)
Public property | PropertyType | (Inherited from PropertyEditor.)
Public property | ValueStyles | (Inherited from PropertyEditor.)
Public property | ValueTemplate | (Inherited from DialogTextBoxPropertyEditor.)
Public property | ValueTemplateKey | (Inherited from DialogTextBoxPropertyEditor.)
Public property | ValueTemplateSelector | (Inherited from DialogTextBoxPropertyEditor.)
Top
See Also

Reference

SchemaObjectEditor Class
SchemaExplorer.Design Namespace


SchemaObjectEditor Methods

The SchemaObjectEditor type exposes the following members.

Methods
 | Name | Description
Public method | CanShowDialog | (Inherited from DialogPropertyEditor.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetMatchOrder(PropertyEditor) | (Inherited from PropertyEditor.)
Public method | GetMatchOrder(Type, String, Type) | (Inherited from PropertyEditor.)
Public method | GetMatchOrder(Type, String, Type, Int32) | (Inherited from PropertyEditor.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SetDeepLoad |
 | SetIncludeFunctions |
Public method | ShowDialog | (Overrides DialogPropertyEditor.ShowDialog(Object, ExecutedRoutedEventArgs).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SchemaObjectEditor Class
SchemaExplorer.Design Namespace


SchemaObjectEditor.SetDeepLoad Method

SchemaObjectEditorSetDeepLoad Method

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static void SetDeepLoad(
    IPropertyDataAccessor context,
    SchemaObjectBase schemaObject
)
Public Shared Sub SetDeepLoad (
    context As IPropertyDataAccessor,
    schemaObject As SchemaObjectBase
)

Parameters

context
Type: IPropertyDataAccessor
schemaObject
Type: SchemaExplorerSchemaObjectBase
See Also

Reference

SchemaObjectEditor Class
SchemaExplorer.Design Namespace


SchemaObjectEditor.SetIncludeFunctions Method

SchemaObjectEditorSetIncludeFunctions Method

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static void SetIncludeFunctions(
    IPropertyDataAccessor context,
    SchemaObjectBase schemaObject
)
Public Shared Sub SetIncludeFunctions (
    context As IPropertyDataAccessor,
    schemaObject As SchemaObjectBase
)

Parameters

context
Type: IPropertyDataAccessor
schemaObject
Type: SchemaExplorerSchemaObjectBase
See Also

Reference

SchemaObjectEditor Class
SchemaExplorer.Design Namespace


SchemaObjectEditor.ShowDialog Method

SchemaObjectEditorShowDialog Method

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override void ShowDialog(
    Object sender,
    ExecutedRoutedEventArgs e
)
Public Overrides Sub ShowDialog (
    sender As Object,
    e As ExecutedRoutedEventArgs
)

Parameters

sender
Type: SystemObject
e
Type: System.Windows.InputExecutedRoutedEventArgs
See Also

Reference

SchemaObjectEditor Class
SchemaExplorer.Design Namespace


SchemaSelectorEditor Class

Inheritance Hierarchy
SystemObject
System.Drawing.DesignUITypeEditor
SchemaExplorer.DesignSchemaSelectorEditor

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class SchemaSelectorEditor : UITypeEditor
Public Class SchemaSelectorEditor
    Inherits UITypeEditor

The SchemaSelectorEditor type exposes the following members.

Constructors
 | Name | Description
Public method | SchemaSelectorEditor | Initializes a new instance of the SchemaSelectorEditor class
Top
Properties
 | Name | Description
Public property | IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Inherited from UITypeEditor.)
Top
Methods
 | Name | Description
Public method | EditValue(IServiceProvider, Object) | Edits the value of the specified object using the editor style indicated by the GetEditStyle method. (Inherited from UITypeEditor.)
Public method | EditValue(ITypeDescriptorContext, IServiceProvider, Object) | (Overrides UITypeEditorEditValue(ITypeDescriptorContext, IServiceProvider, Object).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEditStyle | Gets the editor style used by the EditValue(IServiceProvider, Object) method. (Inherited from UITypeEditor.)
Public method | GetEditStyle(ITypeDescriptorContext) | (Overrides UITypeEditorGetEditStyle(ITypeDescriptorContext).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetPaintValueSupported | Indicates whether this editor supports painting a representation of an object's value. (Inherited from UITypeEditor.)
Public method | GetPaintValueSupported(ITypeDescriptorContext) | Indicates whether the specified context supports painting a representation of an object's value within the specified context. (Inherited from UITypeEditor.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PaintValue(PaintValueEventArgs) | Paints a representation of the value of an object using the specified PaintValueEventArgs. (Inherited from UITypeEditor.)
Public method | PaintValue(Object, Graphics, Rectangle) | Paints a representation of the value of the specified object to the specified canvas. (Inherited from UITypeEditor.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SchemaExplorer.Design Namespace


SchemaSelectorEditor Constructor

Initializes a new instance of the SchemaSelectorEditor class

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public SchemaSelectorEditor()
Public Sub New
See Also

Reference

SchemaSelectorEditor Class
SchemaExplorer.Design Namespace


SchemaSelectorEditor Properties

The SchemaSelectorEditor type exposes the following members.

Properties
 | Name | Description
Public property | IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Inherited from UITypeEditor.)
Top
See Also

Reference

SchemaSelectorEditor Class
SchemaExplorer.Design Namespace


SchemaSelectorEditor Methods

The SchemaSelectorEditor type exposes the following members.

Methods
 | Name | Description
Public method | EditValue(IServiceProvider, Object) | Edits the value of the specified object using the editor style indicated by the GetEditStyle method. (Inherited from UITypeEditor.)
Public method | EditValue(ITypeDescriptorContext, IServiceProvider, Object) | (Overrides UITypeEditorEditValue(ITypeDescriptorContext, IServiceProvider, Object).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEditStyle | Gets the editor style used by the EditValue(IServiceProvider, Object) method. (Inherited from UITypeEditor.)
Public method | GetEditStyle(ITypeDescriptorContext) | (Overrides UITypeEditorGetEditStyle(ITypeDescriptorContext).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetPaintValueSupported | Indicates whether this editor supports painting a representation of an object's value. (Inherited from UITypeEditor.)
Public method | GetPaintValueSupported(ITypeDescriptorContext) | Indicates whether the specified context supports painting a representation of an object's value within the specified context. (Inherited from UITypeEditor.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PaintValue(PaintValueEventArgs) | Paints a representation of the value of an object using the specified PaintValueEventArgs. (Inherited from UITypeEditor.)
Public method | PaintValue(Object, Graphics, Rectangle) | Paints a representation of the value of the specified object to the specified canvas. (Inherited from UITypeEditor.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SchemaSelectorEditor Class
SchemaExplorer.Design Namespace


SchemaSelectorEditor.EditValue Method

SchemaSelectorEditorEditValue Method

Overload List
 | Name | Description
Public method | EditValue(IServiceProvider, Object) | Edits the value of the specified object using the editor style indicated by the GetEditStyle method. (Inherited from UITypeEditor.)
Public method | EditValue(ITypeDescriptorContext, IServiceProvider, Object) | (Overrides UITypeEditorEditValue(ITypeDescriptorContext, IServiceProvider, Object).)
Top
See Also

Reference

SchemaSelectorEditor Class
SchemaExplorer.Design Namespace


SchemaSelectorEditor.EditValue Method (ITypeDescriptorContext, IServiceProvider, Object)

SchemaSelectorEditorEditValue Method (ITypeDescriptorContext, IServiceProvider, Object)

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override Object EditValue(
    ITypeDescriptorContext context,
    IServiceProvider provider,
    Object value
)
Public Overrides Function EditValue (
    context As ITypeDescriptorContext,
    provider As IServiceProvider,
    value As Object
) As Object

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
provider
Type: SystemIServiceProvider
value
Type: SystemObject

Return Value

Type: Object
See Also

Reference

SchemaSelectorEditor Class
EditValue Overload
SchemaExplorer.Design Namespace


SchemaSelectorEditor.GetEditStyle Method

SchemaSelectorEditorGetEditStyle Method

Overload List
 | Name | Description
Public method | GetEditStyle | Gets the editor style used by the EditValue(IServiceProvider, Object) method. (Inherited from UITypeEditor.)
Public method | GetEditStyle(ITypeDescriptorContext) | (Overrides UITypeEditorGetEditStyle(ITypeDescriptorContext).)
Top
See Also

Reference

SchemaSelectorEditor Class
SchemaExplorer.Design Namespace


SchemaSelectorEditor.GetEditStyle Method (ITypeDescriptorContext)

SchemaSelectorEditorGetEditStyle Method (ITypeDescriptorContext)

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override UITypeEditorEditStyle GetEditStyle(
    ITypeDescriptorContext context
)
Public Overrides Function GetEditStyle (
    context As ITypeDescriptorContext
) As UITypeEditorEditStyle

Parameters

context
Type: System.ComponentModelITypeDescriptorContext

Return Value

Type: UITypeEditorEditStyle
See Also

Reference

SchemaSelectorEditor Class
GetEditStyle Overload
SchemaExplorer.Design Namespace


SchemaSelectorEditorUI Class

Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
SchemaExplorer.DesignSchemaSelectorEditorUI

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class SchemaSelectorEditorUI : Form
Public Class SchemaSelectorEditorUI
    Inherits Form

The SchemaSelectorEditorUI type exposes the following members.

Constructors
 | Name | Description
Public method | SchemaSelectorEditorUI | Initializes a new instance of the SchemaSelectorEditorUI class
Top
Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | Gets or sets a value that indicates whether controls in this container will be automatically validated when the focus changes. (Inherited from Form.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Form.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DeviceDpi | Gets the DPI value for the display device where the control is currently being displayed. (Inherited from Control.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
Protected property | MaximizedBounds | Gets or sets the size of the form when it is maximized. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SchemaSelector |
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Protected property | ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Form.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Protected method | ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Protected method | AdjustFormScrollbars | Adjusts the scroll bars on the container based on the current control positions and the control currently selected. (Inherited from Form.)
Protected method | ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
Protected method | CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Form.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Form.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides FormDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | End |
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Form.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Public method | LogicalToDeviceUnits(Int32) | Converts a Logical DPI value to its equivalent DeviceUnit DPI value. (Inherited from Control.)
Public method | LogicalToDeviceUnits(Size) | Transforms a size from logical to device units by scaling it for the current DPI and rounding down to the nearest integer value for width and height. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnActivated | Raises the Activated event. (Inherited from Form.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnClosed | Raises the Closed event. (Inherited from Form.)
Protected method | OnClosing | Raises the Closing event. (Inherited from Form.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDpiChanged | Raises the DpiChanged event. (Inherited from Form.)
Protected method | OnDpiChangedAfterParent | Raises the DpiChangedAfterParent event. (Inherited from Control.)
Protected method | OnDpiChangedBeforeParent | Raises the DpiChangedBeforeParent event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Form.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Form.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Form.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
Protected method | OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
Protected method | OnGetDpiScaledSize | Raises the GetDpiScaledSize event. (Inherited from Form.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Form.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Form.)
Protected method | OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
Protected method | OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Form.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from Form.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
Protected method | OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
Protected method | OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
Protected method | OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
Protected method | OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
Protected method | OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Form.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Form.)
Protected method | OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
Protected method | OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnShown | Raises the Shown event. (Inherited from Form.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Form.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Form.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Form.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Form.)
Protected method | ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Form.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Form.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from Form.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Protected method | RescaleConstantsForDpi | Provides constants for rescaling the control when a DPI change occurs. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value (Empty). (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScaleBitmapLogicalToDevice | Scales a logical bitmap value to it's equivalent device unit value when a DPI change occurs. (Inherited from Control.)
Protected method | ScaleControl | Scales the location, size, padding, and margin of a control. (Inherited from Form.)
Protected method | ScaleCore | Performs scaling of the form. (Inherited from Form.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Form.)
Protected method | SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either or . (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Form.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog | Shows the form as a modal dialog box. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | Start |
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | Causes all of the child controls within a control that support validation to validate their data. (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | Causes all of the child controls within a control that support validation to validate their data. (Inherited from Form.)
Protected method | WndProc | Processes Windows messages. (Inherited from Form.)
Top
Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from Form.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DpiChanged | Occurs when the DPI setting changes on the display device where the form is currently displayed. (Inherited from Form.)
Public event | DpiChangedAfterParent | Occurs when the DPI setting for a control is changed programmatically after the DPI of its parent control or form has changed. (Inherited from Control.)
Public event | DpiChangedBeforeParent | Occurs when the DPI setting for a control is changed programmatically before a DPI change event for its parent control or form has occurred. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the Margin property changes. (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | Occurs when the TabStop property changes. (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

SchemaExplorer.Design Namespace


SchemaSelectorEditorUI Constructor

Initializes a new instance of the SchemaSelectorEditorUI class

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public SchemaSelectorEditorUI()
Public Sub New
See Also

Reference

SchemaSelectorEditorUI Class
SchemaExplorer.Design Namespace


SchemaSelectorEditorUI Properties

The SchemaSelectorEditorUI type exposes the following members.

Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | Gets or sets a value that indicates whether controls in this container will be automatically validated when the focus changes. (Inherited from Form.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Form.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DeviceDpi | Gets the DPI value for the display device where the control is currently being displayed. (Inherited from Control.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
Protected property | MaximizedBounds | Gets or sets the size of the form when it is maximized. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SchemaSelector |
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Protected property | ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Form.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

SchemaSelectorEditorUI Class
SchemaExplorer.Design Namespace


SchemaSelectorEditorUI.SchemaSelector Property

SchemaSelectorEditorUISchemaSelector Property

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public SchemaSelector SchemaSelector { get; set; }
Public Property SchemaSelector As SchemaSelector
    Get
    Set

Property Value

Type: SchemaSelector
See Also

Reference

SchemaSelectorEditorUI Class
SchemaExplorer.Design Namespace


SchemaSelectorEditorUI Methods

The SchemaSelectorEditorUI type exposes the following members.

Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Protected method | ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Protected method | AdjustFormScrollbars | Adjusts the scroll bars on the container based on the current control positions and the control currently selected. (Inherited from Form.)
Protected method | ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
Protected method | CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Form.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Form.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides FormDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | End |
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Form.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Public method | LogicalToDeviceUnits(Int32) | Converts a Logical DPI value to its equivalent DeviceUnit DPI value. (Inherited from Control.)
Public method | LogicalToDeviceUnits(Size) | Transforms a size from logical to device units by scaling it for the current DPI and rounding down to the nearest integer value for width and height. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnActivated | Raises the Activated event. (Inherited from Form.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnClosed | Raises the Closed event. (Inherited from Form.)
Protected method | OnClosing | Raises the Closing event. (Inherited from Form.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDpiChanged | Raises the DpiChanged event. (Inherited from Form.)
Protected method | OnDpiChangedAfterParent | Raises the DpiChangedAfterParent event. (Inherited from Control.)
Protected method | OnDpiChangedBeforeParent | Raises the DpiChangedBeforeParent event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Form.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Form.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Form.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
Protected method | OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
Protected method | OnGetDpiScaledSize | Raises the GetDpiScaledSize event. (Inherited from Form.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Form.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Form.)
Protected method | OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
Protected method | OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Form.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from Form.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
Protected method | OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
Protected method | OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
Protected method | OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
Protected method | OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
Protected method | OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Form.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Form.)
Protected method | OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
Protected method | OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnShown | Raises the Shown event. (Inherited from Form.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Form.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Form.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Form.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Form.)
Protected method | ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Form.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Form.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from Form.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Protected method | RescaleConstantsForDpi | Provides constants for rescaling the control when a DPI change occurs. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value (Empty). (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScaleBitmapLogicalToDevice | Scales a logical bitmap value to it's equivalent device unit value when a DPI change occurs. (Inherited from Control.)
Protected method | ScaleControl | Scales the location, size, padding, and margin of a control. (Inherited from Form.)
Protected method | ScaleCore | Performs scaling of the form. (Inherited from Form.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Form.)
Protected method | SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either or . (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Form.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog | Shows the form as a modal dialog box. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | Start |
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | Causes all of the child controls within a control that support validation to validate their data. (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | Causes all of the child controls within a control that support validation to validate their data. (Inherited from Form.)
Protected method | WndProc | Processes Windows messages. (Inherited from Form.)
Top
See Also

Reference

SchemaSelectorEditorUI Class
SchemaExplorer.Design Namespace


SchemaSelectorEditorUI.Dispose Method

SchemaSelectorEditorUIDispose Method

Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides FormDispose(Boolean).)
Top
See Also

Reference

SchemaSelectorEditorUI Class
SchemaExplorer.Design Namespace


SchemaSelectorEditorUI.Dispose Method (Boolean)

SchemaSelectorEditorUIDispose Method (Boolean)

Clean up any resources being used.

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
true if managed resources should be disposed; otherwise, false.
See Also

Reference

SchemaSelectorEditorUI Class
Dispose Overload
SchemaExplorer.Design Namespace


SchemaSelectorEditorUI.End Method

SchemaSelectorEditorUIEnd Method

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void End()
Public Sub End
See Also

Reference

SchemaSelectorEditorUI Class
SchemaExplorer.Design Namespace


SchemaSelectorEditorUI.Start Method

SchemaSelectorEditorUIStart Method

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void Start(
    IWindowsFormsEditorService editorService,
    Object value
)
Public Sub Start (
    editorService As IWindowsFormsEditorService,
    value As Object
)

Parameters

editorService
Type: System.Windows.Forms.DesignIWindowsFormsEditorService
value
Type: SystemObject
See Also

Reference

SchemaSelectorEditorUI Class
SchemaExplorer.Design Namespace


SchemaSelectorEditorUI Events

The SchemaSelectorEditorUI type exposes the following members.

Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from Form.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DpiChanged | Occurs when the DPI setting changes on the display device where the form is currently displayed. (Inherited from Form.)
Public event | DpiChangedAfterParent | Occurs when the DPI setting for a control is changed programmatically after the DPI of its parent control or form has changed. (Inherited from Control.)
Public event | DpiChangedBeforeParent | Occurs when the DPI setting for a control is changed programmatically before a DPI change event for its parent control or form has occurred. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the Margin property changes. (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | Occurs when the TabStop property changes. (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

SchemaSelectorEditorUI Class
SchemaExplorer.Design Namespace


TableSchemaPickerUI Class

Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
SchemaExplorer.DesignTableSchemaPickerUI

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class TableSchemaPickerUI : Form
Public Class TableSchemaPickerUI
    Inherits Form

The TableSchemaPickerUI type exposes the following members.

Constructors
 | Name | Description
Public method | TableSchemaPickerUI | Initializes a new instance of the TableSchemaPickerUI class
Public method | TableSchemaPickerUI(Boolean) | Initializes a new instance of the TableSchemaPickerUI class
Top
Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | Gets or sets a value that indicates whether controls in this container will be automatically validated when the focus changes. (Inherited from Form.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Form.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DeviceDpi | Gets the DPI value for the display device where the control is currently being displayed. (Inherited from Control.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
Protected property | MaximizedBounds | Gets or sets the size of the form when it is maximized. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SelectedTableSchema |
Public property | SelectedTableSchemaCollection |
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Protected property | ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Form.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Protected method | ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Protected method | AdjustFormScrollbars | Adjusts the scroll bars on the container based on the current control positions and the control currently selected. (Inherited from Form.)
Protected method | ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
Protected method | CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Form.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Form.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides FormDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | End |
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Form.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Public method | LogicalToDeviceUnits(Int32) | Converts a Logical DPI value to its equivalent DeviceUnit DPI value. (Inherited from Control.)
Public method | LogicalToDeviceUnits(Size) | Transforms a size from logical to device units by scaling it for the current DPI and rounding down to the nearest integer value for width and height. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnActivated | Raises the Activated event. (Inherited from Form.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnClosed | Raises the Closed event. (Inherited from Form.)
Protected method | OnClosing | Raises the Closing event. (Inherited from Form.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDpiChanged | Raises the DpiChanged event. (Inherited from Form.)
Protected method | OnDpiChangedAfterParent | Raises the DpiChangedAfterParent event. (Inherited from Control.)
Protected method | OnDpiChangedBeforeParent | Raises the DpiChangedBeforeParent event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Form.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Form.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Form.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
Protected method | OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
Protected method | OnGetDpiScaledSize | Raises the GetDpiScaledSize event. (Inherited from Form.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Form.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Form.)
Protected method | OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
Protected method | OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Form.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from Form.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
Protected method | OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
Protected method | OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
Protected method | OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
Protected method | OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
Protected method | OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Form.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Form.)
Protected method | OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
Protected method | OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnShown | Raises the Shown event. (Inherited from Form.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Form.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Form.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Form.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Form.)
Protected method | ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Form.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Form.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from Form.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Protected method | RescaleConstantsForDpi | Provides constants for rescaling the control when a DPI change occurs. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value (Empty). (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScaleBitmapLogicalToDevice | Scales a logical bitmap value to it's equivalent device unit value when a DPI change occurs. (Inherited from Control.)
Protected method | ScaleControl | Scales the location, size, padding, and margin of a control. (Inherited from Form.)
Protected method | ScaleCore | Performs scaling of the form. (Inherited from Form.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Form.)
Protected method | SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either or . (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Form.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog | Shows the form as a modal dialog box. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | Start |
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | Causes all of the child controls within a control that support validation to validate their data. (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | Causes all of the child controls within a control that support validation to validate their data. (Inherited from Form.)
Protected method | WndProc | Processes Windows messages. (Inherited from Form.)
Top
Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from Form.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DpiChanged | Occurs when the DPI setting changes on the display device where the form is currently displayed. (Inherited from Form.)
Public event | DpiChangedAfterParent | Occurs when the DPI setting for a control is changed programmatically after the DPI of its parent control or form has changed. (Inherited from Control.)
Public event | DpiChangedBeforeParent | Occurs when the DPI setting for a control is changed programmatically before a DPI change event for its parent control or form has occurred. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the Margin property changes. (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | Occurs when the TabStop property changes. (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

SchemaExplorer.Design Namespace


TableSchemaPickerUI Constructor

Overload List
 | Name | Description
Public method | TableSchemaPickerUI | Initializes a new instance of the TableSchemaPickerUI class
Public method | TableSchemaPickerUI(Boolean) | Initializes a new instance of the TableSchemaPickerUI class
Top
See Also

Reference

TableSchemaPickerUI Class
SchemaExplorer.Design Namespace


TableSchemaPickerUI Constructor

Initializes a new instance of the TableSchemaPickerUI class

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public TableSchemaPickerUI()
Public Sub New
See Also

Reference

TableSchemaPickerUI Class
TableSchemaPickerUI Overload
SchemaExplorer.Design Namespace


TableSchemaPickerUI Constructor (Boolean)

Initializes a new instance of the TableSchemaPickerUI class

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public TableSchemaPickerUI(
    bool allowMultiple
)
Public Sub New (
    allowMultiple As Boolean
)

Parameters

allowMultiple
Type: SystemBoolean
See Also

Reference

TableSchemaPickerUI Class
TableSchemaPickerUI Overload
SchemaExplorer.Design Namespace


TableSchemaPickerUI Properties

The TableSchemaPickerUI type exposes the following members.

Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | Gets or sets a value that indicates whether controls in this container will be automatically validated when the focus changes. (Inherited from Form.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Form.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DeviceDpi | Gets the DPI value for the display device where the control is currently being displayed. (Inherited from Control.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
Protected property | MaximizedBounds | Gets or sets the size of the form when it is maximized. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SelectedTableSchema |
Public property | SelectedTableSchemaCollection |
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Protected property | ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Form.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

TableSchemaPickerUI Class
SchemaExplorer.Design Namespace


TableSchemaPickerUI.SelectedTableSchema Property

TableSchemaPickerUISelectedTableSchema Property

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public TableSchema SelectedTableSchema { get; }
Public ReadOnly Property SelectedTableSchema As TableSchema
    Get

Property Value

Type: TableSchema
See Also

Reference

TableSchemaPickerUI Class
SchemaExplorer.Design Namespace


TableSchemaPickerUI.SelectedTableSchemaCollection Property

TableSchemaPickerUISelectedTableSchemaCollection Property

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public TableSchemaCollection SelectedTableSchemaCollection { get; }
Public ReadOnly Property SelectedTableSchemaCollection As TableSchemaCollection
    Get

Property Value

Type: TableSchemaCollection
See Also

Reference

TableSchemaPickerUI Class
SchemaExplorer.Design Namespace


TableSchemaPickerUI Methods

The TableSchemaPickerUI type exposes the following members.

Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Protected method | ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Protected method | AdjustFormScrollbars | Adjusts the scroll bars on the container based on the current control positions and the control currently selected. (Inherited from Form.)
Protected method | ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
Protected method | CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Form.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Form.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides FormDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | End |
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Form.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Public method | LogicalToDeviceUnits(Int32) | Converts a Logical DPI value to its equivalent DeviceUnit DPI value. (Inherited from Control.)
Public method | LogicalToDeviceUnits(Size) | Transforms a size from logical to device units by scaling it for the current DPI and rounding down to the nearest integer value for width and height. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnActivated | Raises the Activated event. (Inherited from Form.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnClosed | Raises the Closed event. (Inherited from Form.)
Protected method | OnClosing | Raises the Closing event. (Inherited from Form.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDpiChanged | Raises the DpiChanged event. (Inherited from Form.)
Protected method | OnDpiChangedAfterParent | Raises the DpiChangedAfterParent event. (Inherited from Control.)
Protected method | OnDpiChangedBeforeParent | Raises the DpiChangedBeforeParent event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Form.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Form.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Form.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
Protected method | OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
Protected method | OnGetDpiScaledSize | Raises the GetDpiScaledSize event. (Inherited from Form.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Form.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Form.)
Protected method | OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
Protected method | OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Form.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from Form.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
Protected method | OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
Protected method | OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
Protected method | OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
Protected method | OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
Protected method | OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Form.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Form.)
Protected method | OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
Protected method | OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnShown | Raises the Shown event. (Inherited from Form.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Form.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Form.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Form.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Form.)
Protected method | ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Form.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Form.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from Form.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Protected method | RescaleConstantsForDpi | Provides constants for rescaling the control when a DPI change occurs. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value (Empty). (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScaleBitmapLogicalToDevice | Scales a logical bitmap value to it's equivalent device unit value when a DPI change occurs. (Inherited from Control.)
Protected method | ScaleControl | Scales the location, size, padding, and margin of a control. (Inherited from Form.)
Protected method | ScaleCore | Performs scaling of the form. (Inherited from Form.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Form.)
Protected method | SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either or . (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Form.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog | Shows the form as a modal dialog box. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | Start |
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | Causes all of the child controls within a control that support validation to validate their data. (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | Causes all of the child controls within a control that support validation to validate their data. (Inherited from Form.)
Protected method | WndProc | Processes Windows messages. (Inherited from Form.)
Top
See Also

Reference

TableSchemaPickerUI Class
SchemaExplorer.Design Namespace


TableSchemaPickerUI.Dispose Method

TableSchemaPickerUIDispose Method

Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides FormDispose(Boolean).)
Top
See Also

Reference

TableSchemaPickerUI Class
SchemaExplorer.Design Namespace


TableSchemaPickerUI.Dispose Method (Boolean)

TableSchemaPickerUIDispose Method (Boolean)

Clean up any resources being used.

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
true if managed resources should be disposed; otherwise, false.
See Also

Reference

TableSchemaPickerUI Class
Dispose Overload
SchemaExplorer.Design Namespace


TableSchemaPickerUI.End Method

TableSchemaPickerUIEnd Method

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void End()
Public Sub End
See Also

Reference

TableSchemaPickerUI Class
SchemaExplorer.Design Namespace


TableSchemaPickerUI.Start Method

TableSchemaPickerUIStart Method

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void Start(
    Object value
)
Public Sub Start (
    value As Object
)

Parameters

value
Type: SystemObject
See Also

Reference

TableSchemaPickerUI Class
SchemaExplorer.Design Namespace


TableSchemaPickerUI Events

The TableSchemaPickerUI type exposes the following members.

Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from Form.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DpiChanged | Occurs when the DPI setting changes on the display device where the form is currently displayed. (Inherited from Form.)
Public event | DpiChangedAfterParent | Occurs when the DPI setting for a control is changed programmatically after the DPI of its parent control or form has changed. (Inherited from Control.)
Public event | DpiChangedBeforeParent | Occurs when the DPI setting for a control is changed programmatically before a DPI change event for its parent control or form has occurred. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the Margin property changes. (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | Occurs when the TabStop property changes. (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

TableSchemaPickerUI Class
SchemaExplorer.Design Namespace


TabularObjectBasePickerUI Class

Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
SchemaExplorer.DesignTabularObjectBasePickerUI

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class TabularObjectBasePickerUI : Form
Public Class TabularObjectBasePickerUI
    Inherits Form

The TabularObjectBasePickerUI type exposes the following members.

Constructors
 | Name | Description
Public method | TabularObjectBasePickerUI | Initializes a new instance of the TabularObjectBasePickerUI class
Public method | TabularObjectBasePickerUI(Boolean) | Initializes a new instance of the TabularObjectBasePickerUI class
Top
Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | Gets or sets a value that indicates whether controls in this container will be automatically validated when the focus changes. (Inherited from Form.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Form.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DeviceDpi | Gets the DPI value for the display device where the control is currently being displayed. (Inherited from Control.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
Protected property | MaximizedBounds | Gets or sets the size of the form when it is maximized. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SelectedTabularObjectBase |
Public property | SelectedTabularObjectBaseCollection |
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Protected property | ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Form.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Protected method | ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Protected method | AdjustFormScrollbars | Adjusts the scroll bars on the container based on the current control positions and the control currently selected. (Inherited from Form.)
Protected method | ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
Protected method | CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Form.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Form.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides FormDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | End |
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Form.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Public method | LogicalToDeviceUnits(Int32) | Converts a Logical DPI value to its equivalent DeviceUnit DPI value. (Inherited from Control.)
Public method | LogicalToDeviceUnits(Size) | Transforms a size from logical to device units by scaling it for the current DPI and rounding down to the nearest integer value for width and height. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnActivated | Raises the Activated event. (Inherited from Form.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnClosed | Raises the Closed event. (Inherited from Form.)
Protected method | OnClosing | Raises the Closing event. (Inherited from Form.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDpiChanged | Raises the DpiChanged event. (Inherited from Form.)
Protected method | OnDpiChangedAfterParent | Raises the DpiChangedAfterParent event. (Inherited from Control.)
Protected method | OnDpiChangedBeforeParent | Raises the DpiChangedBeforeParent event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Form.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Form.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Form.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
Protected method | OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
Protected method | OnGetDpiScaledSize | Raises the GetDpiScaledSize event. (Inherited from Form.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Form.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Form.)
Protected method | OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
Protected method | OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Form.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from Form.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
Protected method | OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
Protected method | OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
Protected method | OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
Protected method | OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
Protected method | OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Form.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Form.)
Protected method | OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
Protected method | OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnShown | Raises the Shown event. (Inherited from Form.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Form.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Form.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Form.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Form.)
Protected method | ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Form.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Form.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from Form.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Protected method | RescaleConstantsForDpi | Provides constants for rescaling the control when a DPI change occurs. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value (Empty). (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScaleBitmapLogicalToDevice | Scales a logical bitmap value to it's equivalent device unit value when a DPI change occurs. (Inherited from Control.)
Protected method | ScaleControl | Scales the location, size, padding, and margin of a control. (Inherited from Form.)
Protected method | ScaleCore | Performs scaling of the form. (Inherited from Form.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Form.)
Protected method | SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either or . (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Form.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog | Shows the form as a modal dialog box. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | Start |
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | Causes all of the child controls within a control that support validation to validate their data. (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | Causes all of the child controls within a control that support validation to validate their data. (Inherited from Form.)
Protected method | WndProc | Processes Windows messages. (Inherited from Form.)
Top
Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from Form.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DpiChanged | Occurs when the DPI setting changes on the display device where the form is currently displayed. (Inherited from Form.)
Public event | DpiChangedAfterParent | Occurs when the DPI setting for a control is changed programmatically after the DPI of its parent control or form has changed. (Inherited from Control.)
Public event | DpiChangedBeforeParent | Occurs when the DPI setting for a control is changed programmatically before a DPI change event for its parent control or form has occurred. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the Margin property changes. (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | Occurs when the TabStop property changes. (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

SchemaExplorer.Design Namespace


TabularObjectBasePickerUI Constructor

Overload List
 | Name | Description
Public method | TabularObjectBasePickerUI | Initializes a new instance of the TabularObjectBasePickerUI class
Public method | TabularObjectBasePickerUI(Boolean) | Initializes a new instance of the TabularObjectBasePickerUI class
Top
See Also

Reference

TabularObjectBasePickerUI Class
SchemaExplorer.Design Namespace


TabularObjectBasePickerUI Constructor

Initializes a new instance of the TabularObjectBasePickerUI class

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public TabularObjectBasePickerUI()
Public Sub New
See Also

Reference

TabularObjectBasePickerUI Class
TabularObjectBasePickerUI Overload
SchemaExplorer.Design Namespace


TabularObjectBasePickerUI Constructor (Boolean)

Initializes a new instance of the TabularObjectBasePickerUI class

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public TabularObjectBasePickerUI(
    bool allowMultiple
)
Public Sub New (
    allowMultiple As Boolean
)

Parameters

allowMultiple
Type: SystemBoolean
See Also

Reference

TabularObjectBasePickerUI Class
TabularObjectBasePickerUI Overload
SchemaExplorer.Design Namespace


TabularObjectBasePickerUI Properties

The TabularObjectBasePickerUI type exposes the following members.

Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | Gets or sets a value that indicates whether controls in this container will be automatically validated when the focus changes. (Inherited from Form.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Form.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DeviceDpi | Gets the DPI value for the display device where the control is currently being displayed. (Inherited from Control.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
Protected property | MaximizedBounds | Gets or sets the size of the form when it is maximized. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SelectedTabularObjectBase |
Public property | SelectedTabularObjectBaseCollection |
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Protected property | ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Form.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

TabularObjectBasePickerUI Class
SchemaExplorer.Design Namespace


TabularObjectBasePickerUI.SelectedTabularObjectBase Property

TabularObjectBasePickerUISelectedTabularObjectBase Property

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ITabularObject SelectedTabularObjectBase { get; }
Public ReadOnly Property SelectedTabularObjectBase As ITabularObject
    Get

Property Value

Type: ITabularObject
See Also

Reference

TabularObjectBasePickerUI Class
SchemaExplorer.Design Namespace


TabularObjectBasePickerUI.SelectedTabularObjectBaseCollection Property

TabularObjectBasePickerUISelectedTabularObjectBaseCollection Property

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public TabularObjectBaseCollection SelectedTabularObjectBaseCollection { get; }
Public ReadOnly Property SelectedTabularObjectBaseCollection As TabularObjectBaseCollection
    Get

Property Value

Type: TabularObjectBaseCollection
See Also

Reference

TabularObjectBasePickerUI Class
SchemaExplorer.Design Namespace


TabularObjectBasePickerUI Methods

The TabularObjectBasePickerUI type exposes the following members.

Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Protected method | ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Protected method | AdjustFormScrollbars | Adjusts the scroll bars on the container based on the current control positions and the control currently selected. (Inherited from Form.)
Protected method | ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
Protected method | CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Form.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Form.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides FormDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | End |
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Form.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Public method | LogicalToDeviceUnits(Int32) | Converts a Logical DPI value to its equivalent DeviceUnit DPI value. (Inherited from Control.)
Public method | LogicalToDeviceUnits(Size) | Transforms a size from logical to device units by scaling it for the current DPI and rounding down to the nearest integer value for width and height. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnActivated | Raises the Activated event. (Inherited from Form.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnClosed | Raises the Closed event. (Inherited from Form.)
Protected method | OnClosing | Raises the Closing event. (Inherited from Form.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDpiChanged | Raises the DpiChanged event. (Inherited from Form.)
Protected method | OnDpiChangedAfterParent | Raises the DpiChangedAfterParent event. (Inherited from Control.)
Protected method | OnDpiChangedBeforeParent | Raises the DpiChangedBeforeParent event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Form.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Form.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Form.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
Protected method | OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
Protected method | OnGetDpiScaledSize | Raises the GetDpiScaledSize event. (Inherited from Form.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Form.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Form.)
Protected method | OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
Protected method | OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Form.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from Form.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
Protected method | OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
Protected method | OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
Protected method | OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
Protected method | OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
Protected method | OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Form.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Form.)
Protected method | OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
Protected method | OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnShown | Raises the Shown event. (Inherited from Form.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Form.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Form.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Form.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Form.)
Protected method | ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Form.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Form.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from Form.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Protected method | RescaleConstantsForDpi | Provides constants for rescaling the control when a DPI change occurs. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value (Empty). (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScaleBitmapLogicalToDevice | Scales a logical bitmap value to it's equivalent device unit value when a DPI change occurs. (Inherited from Control.)
Protected method | ScaleControl | Scales the location, size, padding, and margin of a control. (Inherited from Form.)
Protected method | ScaleCore | Performs scaling of the form. (Inherited from Form.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Form.)
Protected method | SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either or . (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Form.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog | Shows the form as a modal dialog box. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | Start |
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | Causes all of the child controls within a control that support validation to validate their data. (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | Causes all of the child controls within a control that support validation to validate their data. (Inherited from Form.)
Protected method | WndProc | Processes Windows messages. (Inherited from Form.)
Top
See Also

Reference

TabularObjectBasePickerUI Class
SchemaExplorer.Design Namespace


TabularObjectBasePickerUI.Dispose Method

TabularObjectBasePickerUIDispose Method

Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides FormDispose(Boolean).)
Top
See Also

Reference

TabularObjectBasePickerUI Class
SchemaExplorer.Design Namespace


TabularObjectBasePickerUI.Dispose Method (Boolean)

TabularObjectBasePickerUIDispose Method (Boolean)

Clean up any resources being used.

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
true if managed resources should be disposed; otherwise, false.
See Also

Reference

TabularObjectBasePickerUI Class
Dispose Overload
SchemaExplorer.Design Namespace


TabularObjectBasePickerUI.End Method

TabularObjectBasePickerUIEnd Method

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void End()
Public Sub End
See Also

Reference

TabularObjectBasePickerUI Class
SchemaExplorer.Design Namespace


TabularObjectBasePickerUI.Start Method

TabularObjectBasePickerUIStart Method

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void Start(
    Object value
)
Public Sub Start (
    value As Object
)

Parameters

value
Type: SystemObject
See Also

Reference

TabularObjectBasePickerUI Class
SchemaExplorer.Design Namespace


TabularObjectBasePickerUI Events

The TabularObjectBasePickerUI type exposes the following members.

Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from Form.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DpiChanged | Occurs when the DPI setting changes on the display device where the form is currently displayed. (Inherited from Form.)
Public event | DpiChangedAfterParent | Occurs when the DPI setting for a control is changed programmatically after the DPI of its parent control or form has changed. (Inherited from Control.)
Public event | DpiChangedBeforeParent | Occurs when the DPI setting for a control is changed programmatically before a DPI change event for its parent control or form has occurred. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the Margin property changes. (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | Occurs when the TabStop property changes. (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

TabularObjectBasePickerUI Class
SchemaExplorer.Design Namespace


ThreeStateTreeView Class

Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsTreeView
SchemaExplorer.DesignThreeStateTreeView

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class ThreeStateTreeView : TreeView
Public Class ThreeStateTreeView
    Inherits TreeView

The ThreeStateTreeView type exposes the following members.

Constructors
 | Name | Description
Public method | ThreeStateTreeView | Initializes a new instance of the ThreeStateTreeView class
Top
Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from TreeView.)
Public property | BackgroundImage | Gets or set the background image for the TreeView control. (Inherited from TreeView.)
Public property | BackgroundImageLayout | Gets or sets the layout of the background image for the TreeView control. (Inherited from TreeView.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderStyle | Gets or sets the border style of the tree view control. (Inherited from TreeView.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | CheckBoxes |
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from TreeView.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from TreeView.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DeviceDpi | Gets the DPI value for the display device where the control is currently being displayed. (Inherited from Control.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether the control should redraw its surface using a secondary buffer. The DoubleBuffered property does not affect the TreeView control. (Inherited from TreeView.)
Public property | DrawMode | Gets or sets the mode in which the control is drawn. (Inherited from TreeView.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from TreeView.)
Public property | FullRowSelect | Gets or sets a value indicating whether the selection highlight spans the width of the tree view control. (Inherited from TreeView.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HideSelection | Gets or sets a value indicating whether the selected tree node remains highlighted even when the tree view has lost the focus. (Inherited from TreeView.)
Public property | HotTracking | Gets or sets a value indicating whether a tree node label takes on the appearance of a hyperlink as the mouse pointer passes over it. (Inherited from TreeView.)
Public property | ImageIndex | Gets or sets the image-list index value of the default image that is displayed by the tree nodes. (Inherited from TreeView.)
Public property | ImageKey | Gets or sets the key of the default image for each node in the TreeView control when it is in an unselected state. (Inherited from TreeView.)
Public property | ImageList | Gets or sets the ImageList that contains the Image objects that are used by the tree nodes. (Inherited from TreeView.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | Indent | Gets or sets the distance to indent each child tree node level. (Inherited from TreeView.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | ItemHeight | Gets or sets the height of each tree node in the tree view control. (Inherited from TreeView.)
Public property | LabelEdit | Gets or sets a value indicating whether the label text of the tree nodes can be edited. (Inherited from TreeView.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | LineColor | Gets or sets the color of the lines connecting the nodes of the TreeView control. (Inherited from TreeView.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Nodes | Gets the collection of tree nodes that are assigned to the tree view control. (Inherited from TreeView.)
Public property | Padding | Gets or sets the spacing between the TreeView control's contents and its edges. (Inherited from TreeView.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PathSeparator | Gets or sets the delimiter string that the tree node path uses. (Inherited from TreeView.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value that indicates whether the TreeView should be laid out from right-to-left. (Inherited from TreeView.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | Scrollable | Gets or sets a value indicating whether the tree view control displays scroll bars when they are needed. (Inherited from TreeView.)
Public property | SelectedImageIndex | Gets or sets the image list index value of the image that is displayed when a tree node is selected. (Inherited from TreeView.)
Public property | SelectedImageKey | Gets or sets the key of the default image shown when a TreeNode is in a selected state. (Inherited from TreeView.)
Public property | SelectedNode | Gets or sets the tree node that is currently selected in the tree view control. (Inherited from TreeView.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | ShowLines | Gets or sets a value indicating whether lines are drawn between tree nodes in the tree view control. (Inherited from TreeView.)
Public property | ShowNodeToolTips | Gets or sets a value indicating ToolTips are shown when the mouse pointer hovers over a TreeNode. (Inherited from TreeView.)
Public property | ShowPlusMinus | Gets or sets a value indicating whether plus-sign (+) and minus-sign (-) buttons are displayed next to tree nodes that contain child tree nodes. (Inherited from TreeView.)
Public property | ShowRootLines | Gets or sets a value indicating whether lines are drawn between the tree nodes that are at the root of the tree view. (Inherited from TreeView.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | Sorted | Gets or sets a value indicating whether the tree nodes in the tree view are sorted. (Inherited from TreeView.)
Public property | StateImageList | Gets or sets the image list that is used to indicate the state of the TreeView and its nodes. (Inherited from TreeView.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text of the TreeView. (Inherited from TreeView.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopNode | Gets or sets the first fully-visible tree node in the tree view control. (Inherited from TreeView.)
Public property | TreeViewNodeSorter | Gets or sets the implementation of IComparer to perform a custom sort of the TreeView nodes. (Inherited from TreeView.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | VisibleCount | Gets the number of tree nodes that can be fully visible in the tree view control. (Inherited from TreeView.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginUpdate | Disables any redrawing of the tree view. (Inherited from TreeView.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | CheckedNodes |
Public method | CollapseAll | Collapses all the tree nodes. (Inherited from TreeView.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from TreeView.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the TreeView and optionally releases the managed resources. (Inherited from TreeView.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EndUpdate | Enables the redrawing of the tree view. (Inherited from TreeView.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | ExpandAll | Expands all the tree nodes. (Inherited from TreeView.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChecked |
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetItemRenderStyles | Returns an OwnerDrawPropertyBag for the specified TreeNode. (Inherited from TreeView.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetNodeAt(Point) | Retrieves the tree node that is at the specified point. (Inherited from TreeView.)
Public method | GetNodeAt(Int32, Int32) | Retrieves the tree node at the point with the specified coordinates. (Inherited from TreeView.)
Public method | GetNodeCount | Retrieves the number of tree nodes, optionally including those in all subtrees, assigned to the tree view control. (Inherited from TreeView.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | HitTest(Point) | Provides node information, given a point. (Inherited from TreeView.)
Public method | HitTest(Int32, Int32) | Provides node information, given x- and y-coordinates. (Inherited from TreeView.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | InitializeNodesState |
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
 | IsAllChildrenSame |
 | IsChildrenChecked |
 | IsChildrenUnchecked |
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from TreeView.)
Public method | LogicalToDeviceUnits(Int32) | Converts a Logical DPI value to its equivalent DeviceUnit DPI value. (Inherited from Control.)
Public method | LogicalToDeviceUnits(Size) | Transforms a size from logical to device units by scaling it for the current DPI and rounding down to the nearest integer value for width and height. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAfterCheck | Raises the AfterCheck event. (Inherited from TreeView.)
Protected method | OnAfterCollapse | Raises the AfterCollapse event. (Inherited from TreeView.)
Protected method | OnAfterExpand | Raises the AfterExpand event. (Inherited from TreeView.)
Protected method | OnAfterLabelEdit | Raises the AfterLabelEdit event. (Inherited from TreeView.)
Protected method | OnAfterSelect | Raises the AfterSelect event. (Inherited from TreeView.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBeforeCheck | Raises the BeforeCheck event. (Inherited from TreeView.)
Protected method | OnBeforeCollapse | Raises the BeforeCollapse event. (Inherited from TreeView.)
Protected method | OnBeforeExpand | Raises the BeforeExpand event. (Inherited from TreeView.)
Protected method | OnBeforeLabelEdit | Raises the BeforeLabelEdit event. (Inherited from TreeView.)
Protected method | OnBeforeSelect | Raises the BeforeSelect event. (Inherited from TreeView.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDpiChangedAfterParent | Raises the DpiChangedAfterParent event. (Inherited from Control.)
Protected method | OnDpiChangedBeforeParent | Raises the DpiChangedBeforeParent event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnDrawNode | Raises the DrawNode event. (Inherited from TreeView.)
Protected method | OnEnabledChanged | (Overrides ControlOnEnabledChanged(EventArgs).)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | (Overrides TreeViewOnHandleCreated(EventArgs).)
Protected method | OnHandleDestroyed | Overrides OnHandleDestroyed(EventArgs). (Inherited from TreeView.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnItemDrag | Raises the ItemDrag event. (Inherited from TreeView.)
Protected method | OnKeyDown | (Overrides TreeViewOnKeyDown(KeyEventArgs).)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from TreeView.)
Protected method | OnKeyUp | Overrides OnKeyUp(KeyEventArgs). (Inherited from TreeView.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from TreeView.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from TreeView.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNodeMouseClick | (Overrides TreeViewOnNodeMouseClick(TreeNodeMouseClickEventArgs).)
Protected method | OnNodeMouseDoubleClick | Raises the NodeMouseDoubleClick event. (Inherited from TreeView.)
Protected method | OnNodeMouseHover | Raises the NodeMouseHover event. (Inherited from TreeView.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from TreeView.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Protected method | RescaleConstantsForDpi | Provides constants for rescaling the control when a DPI change occurs. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value (Empty). (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScaleBitmapLogicalToDevice | Scales a logical bitmap value to it's equivalent device unit value when a DPI change occurs. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Public method | SetChecked |
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either or . (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | Sort | Sorts the items in TreeView control. (Inherited from TreeView.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from TreeView.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Public method | UpdateChildren |
Public method | UpdateParent |
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Overrides WndProc(Message). (Inherited from TreeView.)
Top
Events
 | Name | Description
Public event | AfterCheck | Occurs after the tree node check box is checked. (Inherited from TreeView.)
Public event | AfterCollapse | Occurs after the tree node is collapsed. (Inherited from TreeView.)
Public event | AfterExpand | Occurs after the tree node is expanded. (Inherited from TreeView.)
Public event | AfterLabelEdit | Occurs after the tree node label text is edited. (Inherited from TreeView.)
Public event | AfterSelect | Occurs after the tree node is selected. (Inherited from TreeView.)
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the BackgroundImage property changes. (Inherited from TreeView.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from TreeView.)
Public event | BeforeCheck | Occurs before the tree node check box is checked. (Inherited from TreeView.)
Public event | BeforeCollapse | Occurs before the tree node is collapsed. (Inherited from TreeView.)
Public event | BeforeExpand | Occurs before the tree node is expanded. (Inherited from TreeView.)
Public event | BeforeLabelEdit | Occurs before the tree node label text is edited. (Inherited from TreeView.)
Public event | BeforeSelect | Occurs before the tree node is selected. (Inherited from TreeView.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DpiChangedAfterParent | Occurs when the DPI setting for a control is changed programmatically after the DPI of its parent control or form has changed. (Inherited from Control.)
Public event | DpiChangedBeforeParent | Occurs when the DPI setting for a control is changed programmatically before a DPI change event for its parent control or form has occurred. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | DrawNode | Occurs when a TreeView is drawn and the DrawMode property is set to a TreeViewDrawMode value other than Normal. (Inherited from TreeView.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | ItemDrag | Occurs when the user begins dragging a node. (Inherited from TreeView.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | NodeMouseClick | Occurs when the user clicks a TreeNode with the mouse. (Inherited from TreeView.)
Public event | NodeMouseDoubleClick | Occurs when the user double-clicks a TreeNode with the mouse. (Inherited from TreeView.)
Public event | NodeMouseHover | Occurs when the mouse hovers over a TreeNode. (Inherited from TreeView.)
Public event | PaddingChanged | Occurs when the value of the Padding property changes. (Inherited from TreeView.)
Public event | Paint | Occurs when the TreeView is drawn. (Inherited from TreeView.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs when the value of the RightToLeftLayout property changes. (Inherited from TreeView.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property changes. (Inherited from TreeView.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

SchemaExplorer.Design Namespace


ThreeStateTreeView Constructor

Initializes a new instance of the ThreeStateTreeView class

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ThreeStateTreeView()
Public Sub New
See Also

Reference

ThreeStateTreeView Class
SchemaExplorer.Design Namespace


ThreeStateTreeView Properties

The ThreeStateTreeView type exposes the following members.

Properties
 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoSize | This property is not relevant for this class. (Inherited from Control.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from TreeView.)
Public property | BackgroundImage | Gets or set the background image for the TreeView control. (Inherited from TreeView.)
Public property | BackgroundImageLayout | Gets or sets the layout of the background image for the TreeView control. (Inherited from TreeView.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from Control.)
Public property | BorderStyle | Gets or sets the border style of the tree view control. (Inherited from TreeView.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | CheckBoxes |
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from TreeView.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from TreeView.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DeviceDpi | Gets the DPI value for the display device where the control is currently being displayed. (Inherited from Control.)
Public property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from Control.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether the control should redraw its surface using a secondary buffer. The DoubleBuffered property does not affect the TreeView control. (Inherited from TreeView.)
Public property | DrawMode | Gets or sets the mode in which the control is drawn. (Inherited from TreeView.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from TreeView.)
Public property | FullRowSelect | Gets or sets a value indicating whether the selection highlight spans the width of the tree view control. (Inherited from TreeView.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HideSelection | Gets or sets a value indicating whether the selected tree node remains highlighted even when the tree view has lost the focus. (Inherited from TreeView.)
Public property | HotTracking | Gets or sets a value indicating whether a tree node label takes on the appearance of a hyperlink as the mouse pointer passes over it. (Inherited from TreeView.)
Public property | ImageIndex | Gets or sets the image-list index value of the default image that is displayed by the tree nodes. (Inherited from TreeView.)
Public property | ImageKey | Gets or sets the key of the default image for each node in the TreeView control when it is in an unselected state. (Inherited from TreeView.)
Public property | ImageList | Gets or sets the ImageList that contains the Image objects that are used by the tree nodes. (Inherited from TreeView.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | Indent | Gets or sets the distance to indent each child tree node level. (Inherited from TreeView.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | ItemHeight | Gets or sets the height of each tree node in the tree view control. (Inherited from TreeView.)
Public property | LabelEdit | Gets or sets a value indicating whether the label text of the tree nodes can be edited. (Inherited from TreeView.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | LineColor | Gets or sets the color of the lines connecting the nodes of the TreeView control. (Inherited from TreeView.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Nodes | Gets the collection of tree nodes that are assigned to the tree view control. (Inherited from TreeView.)
Public property | Padding | Gets or sets the spacing between the TreeView control's contents and its edges. (Inherited from TreeView.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | PathSeparator | Gets or sets the delimiter string that the tree node path uses. (Inherited from TreeView.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value that indicates whether the TreeView should be laid out from right-to-left. (Inherited from TreeView.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | Scrollable | Gets or sets a value indicating whether the tree view control displays scroll bars when they are needed. (Inherited from TreeView.)
Public property | SelectedImageIndex | Gets or sets the image list index value of the image that is displayed when a tree node is selected. (Inherited from TreeView.)
Public property | SelectedImageKey | Gets or sets the key of the default image shown when a TreeNode is in a selected state. (Inherited from TreeView.)
Public property | SelectedNode | Gets or sets the tree node that is currently selected in the tree view control. (Inherited from TreeView.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Public property | ShowLines | Gets or sets a value indicating whether lines are drawn between tree nodes in the tree view control. (Inherited from TreeView.)
Public property | ShowNodeToolTips | Gets or sets a value indicating ToolTips are shown when the mouse pointer hovers over a TreeNode. (Inherited from TreeView.)
Public property | ShowPlusMinus | Gets or sets a value indicating whether plus-sign (+) and minus-sign (-) buttons are displayed next to tree nodes that contain child tree nodes. (Inherited from TreeView.)
Public property | ShowRootLines | Gets or sets a value indicating whether lines are drawn between the tree nodes that are at the root of the tree view. (Inherited from TreeView.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | Sorted | Gets or sets a value indicating whether the tree nodes in the tree view are sorted. (Inherited from TreeView.)
Public property | StateImageList | Gets or sets the image list that is used to indicate the state of the TreeView and its nodes. (Inherited from TreeView.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text of the TreeView. (Inherited from TreeView.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopNode | Gets or sets the first fully-visible tree node in the tree view control. (Inherited from TreeView.)
Public property | TreeViewNodeSorter | Gets or sets the implementation of IComparer to perform a custom sort of the TreeView nodes. (Inherited from TreeView.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Public property | VisibleCount | Gets the number of tree nodes that can be fully visible in the tree view control. (Inherited from TreeView.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

ThreeStateTreeView Class
SchemaExplorer.Design Namespace


ThreeStateTreeView.CheckBoxes Property

ThreeStateTreeViewCheckBoxes Property

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool CheckBoxes { get; set; }
Public Property CheckBoxes As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

ThreeStateTreeView Class
SchemaExplorer.Design Namespace


ThreeStateTreeView Methods

The ThreeStateTreeView type exposes the following members.

Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginUpdate | Disables any redrawing of the tree view. (Inherited from TreeView.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | CheckedNodes |
Public method | CollapseAll | Collapses all the tree nodes. (Inherited from TreeView.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates a handle for the control. (Inherited from TreeView.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Control.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the TreeView and optionally releases the managed resources. (Inherited from TreeView.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | EndUpdate | Enables the redrawing of the tree view. (Inherited from TreeView.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | ExpandAll | Expands all the tree nodes. (Inherited from TreeView.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChecked |
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetItemRenderStyles | Returns an OwnerDrawPropertyBag for the specified TreeNode. (Inherited from TreeView.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetNodeAt(Point) | Retrieves the tree node that is at the specified point. (Inherited from TreeView.)
Public method | GetNodeAt(Int32, Int32) | Retrieves the tree node at the point with the specified coordinates. (Inherited from TreeView.)
Public method | GetNodeCount | Retrieves the number of tree nodes, optionally including those in all subtrees, assigned to the tree view control. (Inherited from TreeView.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | HitTest(Point) | Provides node information, given a point. (Inherited from TreeView.)
Public method | HitTest(Int32, Int32) | Provides node information, given x- and y-coordinates. (Inherited from TreeView.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | InitializeNodesState |
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
 | IsAllChildrenSame |
 | IsChildrenChecked |
 | IsChildrenUnchecked |
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from TreeView.)
Public method | LogicalToDeviceUnits(Int32) | Converts a Logical DPI value to its equivalent DeviceUnit DPI value. (Inherited from Control.)
Public method | LogicalToDeviceUnits(Size) | Transforms a size from logical to device units by scaling it for the current DPI and rounding down to the nearest integer value for width and height. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnAfterCheck | Raises the AfterCheck event. (Inherited from TreeView.)
Protected method | OnAfterCollapse | Raises the AfterCollapse event. (Inherited from TreeView.)
Protected method | OnAfterExpand | Raises the AfterExpand event. (Inherited from TreeView.)
Protected method | OnAfterLabelEdit | Raises the AfterLabelEdit event. (Inherited from TreeView.)
Protected method | OnAfterSelect | Raises the AfterSelect event. (Inherited from TreeView.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
Protected method | OnBeforeCheck | Raises the BeforeCheck event. (Inherited from TreeView.)
Protected method | OnBeforeCollapse | Raises the BeforeCollapse event. (Inherited from TreeView.)
Protected method | OnBeforeExpand | Raises the BeforeExpand event. (Inherited from TreeView.)
Protected method | OnBeforeLabelEdit | Raises the BeforeLabelEdit event. (Inherited from TreeView.)
Protected method | OnBeforeSelect | Raises the BeforeSelect event. (Inherited from TreeView.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl method. (Inherited from Control.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDpiChangedAfterParent | Raises the DpiChangedAfterParent event. (Inherited from Control.)
Protected method | OnDpiChangedBeforeParent | Raises the DpiChangedBeforeParent event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnDrawNode | Raises the DrawNode event. (Inherited from TreeView.)
Protected method | OnEnabledChanged | (Overrides ControlOnEnabledChanged(EventArgs).)
Protected method | OnEnter | Raises the Enter event. (Inherited from Control.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Control.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | (Overrides TreeViewOnHandleCreated(EventArgs).)
Protected method | OnHandleDestroyed | Overrides OnHandleDestroyed(EventArgs). (Inherited from TreeView.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnItemDrag | Raises the ItemDrag event. (Inherited from TreeView.)
Protected method | OnKeyDown | (Overrides TreeViewOnKeyDown(KeyEventArgs).)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from TreeView.)
Protected method | OnKeyUp | Overrides OnKeyUp(KeyEventArgs). (Inherited from TreeView.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Control.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from TreeView.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from TreeView.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from Control.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNodeMouseClick | (Overrides TreeViewOnNodeMouseClick(TreeNodeMouseClickEventArgs).)
Protected method | OnNodeMouseDoubleClick | Raises the NodeMouseDoubleClick event. (Inherited from TreeView.)
Protected method | OnNodeMouseHover | Raises the NodeMouseHover event. (Inherited from TreeView.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from Control.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Control.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from Control.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from Control.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Control.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from Control.)
Protected method | OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from TreeView.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Control.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Control.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Control.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Control.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Control.)
Protected method | ProcessDialogKey | Processes a dialog key. (Inherited from Control.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Control.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Control.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Protected method | RescaleConstantsForDpi | Provides constants for rescaling the control when a DPI change occurs. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value (Empty). (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScaleBitmapLogicalToDevice | Scales a logical bitmap value to it's equivalent device unit value when a DPI change occurs. (Inherited from Control.)
Protected method | ScaleControl | Scales a control's location, size, padding and margin. (Inherited from Control.)
Protected method | ScaleCore | This method is not relevant for this class. (Inherited from Control.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Activates a child control. Optionally specifies the direction in the tab order to select the control from. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
Public method | SetChecked |
Protected method | SetClientSizeCore | Sets the size of the client area of the control. (Inherited from Control.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either or . (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Control.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | Sort | Sorts the items in TreeView control. (Inherited from TreeView.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from TreeView.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Public method | UpdateChildren |
Public method | UpdateParent |
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Protected method | WndProc | Overrides WndProc(Message). (Inherited from TreeView.)
Top
See Also

Reference

ThreeStateTreeView Class
SchemaExplorer.Design Namespace


ThreeStateTreeView.CheckedNodes Method

ThreeStateTreeViewCheckedNodes Method

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public IList<TreeNode> CheckedNodes()
Public Function CheckedNodes As IList(Of TreeNode)

Return Value

Type: IList TreeNode
See Also

Reference

ThreeStateTreeView Class
SchemaExplorer.Design Namespace


ThreeStateTreeView.GetChecked Method

ThreeStateTreeViewGetChecked Method

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public bool GetChecked(
    TreeNode node
)
Public Function GetChecked (
    node As TreeNode
) As Boolean

Parameters

node
Type: System.Windows.FormsTreeNode

Return Value

Type: Boolean
See Also

Reference

ThreeStateTreeView Class
SchemaExplorer.Design Namespace


ThreeStateTreeView.InitializeNodesState Method

ThreeStateTreeViewInitializeNodesState Method

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void InitializeNodesState(
    TreeNodeCollection nodes
)
Public Sub InitializeNodesState (
    nodes As TreeNodeCollection
)

Parameters

nodes
Type: System.Windows.FormsTreeNodeCollection
See Also

Reference

ThreeStateTreeView Class
SchemaExplorer.Design Namespace


ThreeStateTreeView.IsAllChildrenSame Method

ThreeStateTreeViewIsAllChildrenSame Method

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static bool IsAllChildrenSame(
    TreeNode parent,
    int state
)
Public Shared Function IsAllChildrenSame (
    parent As TreeNode,
    state As Integer
) As Boolean

Parameters

parent
Type: System.Windows.FormsTreeNode
state
Type: SystemInt32

Return Value

Type: Boolean
See Also

Reference

ThreeStateTreeView Class
SchemaExplorer.Design Namespace


ThreeStateTreeView.IsChildrenChecked Method

ThreeStateTreeViewIsChildrenChecked Method

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static bool IsChildrenChecked(
    TreeNode parent
)
Public Shared Function IsChildrenChecked (
    parent As TreeNode
) As Boolean

Parameters

parent
Type: System.Windows.FormsTreeNode

Return Value

Type: Boolean
See Also

Reference

ThreeStateTreeView Class
SchemaExplorer.Design Namespace


ThreeStateTreeView.IsChildrenUnchecked Method

ThreeStateTreeViewIsChildrenUnchecked Method

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static bool IsChildrenUnchecked(
    TreeNode parent
)
Public Shared Function IsChildrenUnchecked (
    parent As TreeNode
) As Boolean

Parameters

parent
Type: System.Windows.FormsTreeNode

Return Value

Type: Boolean
See Also

Reference

ThreeStateTreeView Class
SchemaExplorer.Design Namespace


ThreeStateTreeView.OnEnabledChanged Method

ThreeStateTreeViewOnEnabledChanged Method

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected override void OnEnabledChanged(
    EventArgs e
)
Protected Overrides Sub OnEnabledChanged (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
See Also

Reference

ThreeStateTreeView Class
SchemaExplorer.Design Namespace


ThreeStateTreeView.OnHandleCreated Method

ThreeStateTreeViewOnHandleCreated Method

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected override void OnHandleCreated(
    EventArgs e
)
Protected Overrides Sub OnHandleCreated (
    e As EventArgs
)

Parameters

e
Type: SystemEventArgs
See Also

Reference

ThreeStateTreeView Class
SchemaExplorer.Design Namespace


ThreeStateTreeView.OnKeyDown Method

ThreeStateTreeViewOnKeyDown Method

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected override void OnKeyDown(
    KeyEventArgs e
)
Protected Overrides Sub OnKeyDown (
    e As KeyEventArgs
)

Parameters

e
Type: System.Windows.FormsKeyEventArgs
See Also

Reference

ThreeStateTreeView Class
SchemaExplorer.Design Namespace


ThreeStateTreeView.OnNodeMouseClick Method

ThreeStateTreeViewOnNodeMouseClick Method

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected override void OnNodeMouseClick(
    TreeNodeMouseClickEventArgs e
)
Protected Overrides Sub OnNodeMouseClick (
    e As TreeNodeMouseClickEventArgs
)

Parameters

e
Type: System.Windows.FormsTreeNodeMouseClickEventArgs
See Also

Reference

ThreeStateTreeView Class
SchemaExplorer.Design Namespace


ThreeStateTreeView.SetChecked Method

ThreeStateTreeViewSetChecked Method

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void SetChecked(
    TreeNode node
)
Public Sub SetChecked (
    node As TreeNode
)

Parameters

node
Type: System.Windows.FormsTreeNode
See Also

Reference

ThreeStateTreeView Class
SchemaExplorer.Design Namespace


ThreeStateTreeView.UpdateChildren Method

ThreeStateTreeViewUpdateChildren Method

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void UpdateChildren(
    TreeNode parent
)
Public Sub UpdateChildren (
    parent As TreeNode
)

Parameters

parent
Type: System.Windows.FormsTreeNode
See Also

Reference

ThreeStateTreeView Class
SchemaExplorer.Design Namespace


ThreeStateTreeView.UpdateParent Method

ThreeStateTreeViewUpdateParent Method

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void UpdateParent(
    TreeNode child
)
Public Sub UpdateParent (
    child As TreeNode
)

Parameters

child
Type: System.Windows.FormsTreeNode
See Also

Reference

ThreeStateTreeView Class
SchemaExplorer.Design Namespace


ThreeStateTreeView Events

The ThreeStateTreeView type exposes the following members.

Events
 | Name | Description
Public event | AfterCheck | Occurs after the tree node check box is checked. (Inherited from TreeView.)
Public event | AfterCollapse | Occurs after the tree node is collapsed. (Inherited from TreeView.)
Public event | AfterExpand | Occurs after the tree node is expanded. (Inherited from TreeView.)
Public event | AfterLabelEdit | Occurs after the tree node label text is edited. (Inherited from TreeView.)
Public event | AfterSelect | Occurs after the tree node is selected. (Inherited from TreeView.)
Public event | AutoSizeChanged | This event is not relevant for this class. (Inherited from Control.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the BackgroundImage property changes. (Inherited from TreeView.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from TreeView.)
Public event | BeforeCheck | Occurs before the tree node check box is checked. (Inherited from TreeView.)
Public event | BeforeCollapse | Occurs before the tree node is collapsed. (Inherited from TreeView.)
Public event | BeforeExpand | Occurs before the tree node is expanded. (Inherited from TreeView.)
Public event | BeforeLabelEdit | Occurs before the tree node label text is edited. (Inherited from TreeView.)
Public event | BeforeSelect | Occurs before the tree node is selected. (Inherited from TreeView.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DpiChangedAfterParent | Occurs when the DPI setting for a control is changed programmatically after the DPI of its parent control or form has changed. (Inherited from Control.)
Public event | DpiChangedBeforeParent | Occurs when the DPI setting for a control is changed programmatically before a DPI change event for its parent control or form has occurred. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | DrawNode | Occurs when a TreeView is drawn and the DrawMode property is set to a TreeViewDrawMode value other than Normal. (Inherited from TreeView.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | ItemDrag | Occurs when the user begins dragging a node. (Inherited from TreeView.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | NodeMouseClick | Occurs when the user clicks a TreeNode with the mouse. (Inherited from TreeView.)
Public event | NodeMouseDoubleClick | Occurs when the user double-clicks a TreeNode with the mouse. (Inherited from TreeView.)
Public event | NodeMouseHover | Occurs when the mouse hovers over a TreeNode. (Inherited from TreeView.)
Public event | PaddingChanged | Occurs when the value of the Padding property changes. (Inherited from TreeView.)
Public event | Paint | Occurs when the TreeView is drawn. (Inherited from TreeView.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs when the value of the RightToLeftLayout property changes. (Inherited from TreeView.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | Occurs when the Text property changes. (Inherited from TreeView.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

ThreeStateTreeView Class
SchemaExplorer.Design Namespace


ViewColumnSchemaPickerUI Class

Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
SchemaExplorer.DesignViewColumnSchemaPickerUI

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class ViewColumnSchemaPickerUI : Form
Public Class ViewColumnSchemaPickerUI
    Inherits Form

The ViewColumnSchemaPickerUI type exposes the following members.

Constructors
 | Name | Description
Public method | ViewColumnSchemaPickerUI | Initializes a new instance of the ViewColumnSchemaPickerUI class
Public method | ViewColumnSchemaPickerUI(Boolean) | Initializes a new instance of the ViewColumnSchemaPickerUI class
Top
Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | Gets or sets a value that indicates whether controls in this container will be automatically validated when the focus changes. (Inherited from Form.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Form.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DeviceDpi | Gets the DPI value for the display device where the control is currently being displayed. (Inherited from Control.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
Protected property | MaximizedBounds | Gets or sets the size of the form when it is maximized. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SelectedViewColumnSchema |
Public property | SelectedViewColumnSchemaCollection |
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Protected property | ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Form.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Protected method | ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Protected method | AdjustFormScrollbars | Adjusts the scroll bars on the container based on the current control positions and the control currently selected. (Inherited from Form.)
Protected method | ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
Protected method | CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Form.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Form.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides FormDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | End |
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Filter |
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Form.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Public method | LogicalToDeviceUnits(Int32) | Converts a Logical DPI value to its equivalent DeviceUnit DPI value. (Inherited from Control.)
Public method | LogicalToDeviceUnits(Size) | Transforms a size from logical to device units by scaling it for the current DPI and rounding down to the nearest integer value for width and height. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnActivated | Raises the Activated event. (Inherited from Form.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnClosed | Raises the Closed event. (Inherited from Form.)
Protected method | OnClosing | Raises the Closing event. (Inherited from Form.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDpiChanged | Raises the DpiChanged event. (Inherited from Form.)
Protected method | OnDpiChangedAfterParent | Raises the DpiChangedAfterParent event. (Inherited from Control.)
Protected method | OnDpiChangedBeforeParent | Raises the DpiChangedBeforeParent event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Form.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Form.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Form.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
Protected method | OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
Protected method | OnGetDpiScaledSize | Raises the GetDpiScaledSize event. (Inherited from Form.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Form.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Form.)
Protected method | OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
Protected method | OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Form.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from Form.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
Protected method | OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
Protected method | OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
Protected method | OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
Protected method | OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
Protected method | OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Form.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Form.)
Protected method | OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
Protected method | OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnShown | Raises the Shown event. (Inherited from Form.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Form.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Form.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Form.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Form.)
Protected method | ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Form.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Form.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from Form.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Protected method | RescaleConstantsForDpi | Provides constants for rescaling the control when a DPI change occurs. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value (Empty). (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScaleBitmapLogicalToDevice | Scales a logical bitmap value to it's equivalent device unit value when a DPI change occurs. (Inherited from Control.)
Protected method | ScaleControl | Scales the location, size, padding, and margin of a control. (Inherited from Form.)
Protected method | ScaleCore | Performs scaling of the form. (Inherited from Form.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Form.)
Protected method | SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either or . (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Form.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog | Shows the form as a modal dialog box. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | Start |
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | Causes all of the child controls within a control that support validation to validate their data. (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | Causes all of the child controls within a control that support validation to validate their data. (Inherited from Form.)
Protected method | WndProc | Processes Windows messages. (Inherited from Form.)
Top
Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from Form.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DpiChanged | Occurs when the DPI setting changes on the display device where the form is currently displayed. (Inherited from Form.)
Public event | DpiChangedAfterParent | Occurs when the DPI setting for a control is changed programmatically after the DPI of its parent control or form has changed. (Inherited from Control.)
Public event | DpiChangedBeforeParent | Occurs when the DPI setting for a control is changed programmatically before a DPI change event for its parent control or form has occurred. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the Margin property changes. (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | Occurs when the TabStop property changes. (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

SchemaExplorer.Design Namespace


ViewColumnSchemaPickerUI Constructor

Overload List
 | Name | Description
Public method | ViewColumnSchemaPickerUI | Initializes a new instance of the ViewColumnSchemaPickerUI class
Public method | ViewColumnSchemaPickerUI(Boolean) | Initializes a new instance of the ViewColumnSchemaPickerUI class
Top
See Also

Reference

ViewColumnSchemaPickerUI Class
SchemaExplorer.Design Namespace


ViewColumnSchemaPickerUI Constructor

Initializes a new instance of the ViewColumnSchemaPickerUI class

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ViewColumnSchemaPickerUI()
Public Sub New
See Also

Reference

ViewColumnSchemaPickerUI Class
ViewColumnSchemaPickerUI Overload
SchemaExplorer.Design Namespace


ViewColumnSchemaPickerUI Constructor (Boolean)

Initializes a new instance of the ViewColumnSchemaPickerUI class

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ViewColumnSchemaPickerUI(
    bool allowMultiple
)
Public Sub New (
    allowMultiple As Boolean
)

Parameters

allowMultiple
Type: SystemBoolean
See Also

Reference

ViewColumnSchemaPickerUI Class
ViewColumnSchemaPickerUI Overload
SchemaExplorer.Design Namespace


ViewColumnSchemaPickerUI Properties

The ViewColumnSchemaPickerUI type exposes the following members.

Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | Gets or sets a value that indicates whether controls in this container will be automatically validated when the focus changes. (Inherited from Form.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Form.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DeviceDpi | Gets the DPI value for the display device where the control is currently being displayed. (Inherited from Control.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
Protected property | MaximizedBounds | Gets or sets the size of the form when it is maximized. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SelectedViewColumnSchema |
Public property | SelectedViewColumnSchemaCollection |
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Protected property | ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Form.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

ViewColumnSchemaPickerUI Class
SchemaExplorer.Design Namespace


ViewColumnSchemaPickerUI.SelectedViewColumnSchema Property

ViewColumnSchemaPickerUISelectedViewColumnSchema Property

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ViewColumnSchema SelectedViewColumnSchema { get; }
Public ReadOnly Property SelectedViewColumnSchema As ViewColumnSchema
    Get

Property Value

Type: ViewColumnSchema
See Also

Reference

ViewColumnSchemaPickerUI Class
SchemaExplorer.Design Namespace


ViewColumnSchemaPickerUI.SelectedViewColumnSchemaCollection Property

ViewColumnSchemaPickerUISelectedViewColumnSchemaCollection Property

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ViewColumnSchemaCollection SelectedViewColumnSchemaCollection { get; }
Public ReadOnly Property SelectedViewColumnSchemaCollection As ViewColumnSchemaCollection
    Get

Property Value

Type: ViewColumnSchemaCollection
See Also

Reference

ViewColumnSchemaPickerUI Class
SchemaExplorer.Design Namespace


ViewColumnSchemaPickerUI Methods

The ViewColumnSchemaPickerUI type exposes the following members.

Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Protected method | ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Protected method | AdjustFormScrollbars | Adjusts the scroll bars on the container based on the current control positions and the control currently selected. (Inherited from Form.)
Protected method | ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
Protected method | CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Form.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Form.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides FormDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | End |
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Filter |
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Form.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Public method | LogicalToDeviceUnits(Int32) | Converts a Logical DPI value to its equivalent DeviceUnit DPI value. (Inherited from Control.)
Public method | LogicalToDeviceUnits(Size) | Transforms a size from logical to device units by scaling it for the current DPI and rounding down to the nearest integer value for width and height. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnActivated | Raises the Activated event. (Inherited from Form.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnClosed | Raises the Closed event. (Inherited from Form.)
Protected method | OnClosing | Raises the Closing event. (Inherited from Form.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDpiChanged | Raises the DpiChanged event. (Inherited from Form.)
Protected method | OnDpiChangedAfterParent | Raises the DpiChangedAfterParent event. (Inherited from Control.)
Protected method | OnDpiChangedBeforeParent | Raises the DpiChangedBeforeParent event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Form.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Form.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Form.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
Protected method | OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
Protected method | OnGetDpiScaledSize | Raises the GetDpiScaledSize event. (Inherited from Form.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Form.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Form.)
Protected method | OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
Protected method | OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Form.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from Form.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
Protected method | OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
Protected method | OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
Protected method | OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
Protected method | OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
Protected method | OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Form.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Form.)
Protected method | OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
Protected method | OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnShown | Raises the Shown event. (Inherited from Form.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Form.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Form.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Form.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Form.)
Protected method | ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Form.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Form.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from Form.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Protected method | RescaleConstantsForDpi | Provides constants for rescaling the control when a DPI change occurs. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value (Empty). (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScaleBitmapLogicalToDevice | Scales a logical bitmap value to it's equivalent device unit value when a DPI change occurs. (Inherited from Control.)
Protected method | ScaleControl | Scales the location, size, padding, and margin of a control. (Inherited from Form.)
Protected method | ScaleCore | Performs scaling of the form. (Inherited from Form.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Form.)
Protected method | SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either or . (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Form.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog | Shows the form as a modal dialog box. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | Start |
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | Causes all of the child controls within a control that support validation to validate their data. (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | Causes all of the child controls within a control that support validation to validate their data. (Inherited from Form.)
Protected method | WndProc | Processes Windows messages. (Inherited from Form.)
Top
See Also

Reference

ViewColumnSchemaPickerUI Class
SchemaExplorer.Design Namespace


ViewColumnSchemaPickerUI.Dispose Method

ViewColumnSchemaPickerUIDispose Method

Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides FormDispose(Boolean).)
Top
See Also

Reference

ViewColumnSchemaPickerUI Class
SchemaExplorer.Design Namespace


ViewColumnSchemaPickerUI.Dispose Method (Boolean)

ViewColumnSchemaPickerUIDispose Method (Boolean)

Clean up any resources being used.

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
true if managed resources should be disposed; otherwise, false.
See Also

Reference

ViewColumnSchemaPickerUI Class
Dispose Overload
SchemaExplorer.Design Namespace


ViewColumnSchemaPickerUI.End Method

ViewColumnSchemaPickerUIEnd Method

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void End()
Public Sub End
See Also

Reference

ViewColumnSchemaPickerUI Class
SchemaExplorer.Design Namespace


ViewColumnSchemaPickerUI.Filter Method

ViewColumnSchemaPickerUIFilter Method

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void Filter(
    Object filter
)
Public Sub Filter (
    filter As Object
)

Parameters

filter
Type: SystemObject
See Also

Reference

ViewColumnSchemaPickerUI Class
SchemaExplorer.Design Namespace


ViewColumnSchemaPickerUI.Start Method

ViewColumnSchemaPickerUIStart Method

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void Start(
    Object value
)
Public Sub Start (
    value As Object
)

Parameters

value
Type: SystemObject
See Also

Reference

ViewColumnSchemaPickerUI Class
SchemaExplorer.Design Namespace


ViewColumnSchemaPickerUI Events

The ViewColumnSchemaPickerUI type exposes the following members.

Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from Form.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DpiChanged | Occurs when the DPI setting changes on the display device where the form is currently displayed. (Inherited from Form.)
Public event | DpiChangedAfterParent | Occurs when the DPI setting for a control is changed programmatically after the DPI of its parent control or form has changed. (Inherited from Control.)
Public event | DpiChangedBeforeParent | Occurs when the DPI setting for a control is changed programmatically before a DPI change event for its parent control or form has occurred. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the Margin property changes. (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | Occurs when the TabStop property changes. (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

ViewColumnSchemaPickerUI Class
SchemaExplorer.Design Namespace


ViewSchemaPickerUI Class

Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
SchemaExplorer.DesignViewSchemaPickerUI

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class ViewSchemaPickerUI : Form
Public Class ViewSchemaPickerUI
    Inherits Form

The ViewSchemaPickerUI type exposes the following members.

Constructors
 | Name | Description
Public method | ViewSchemaPickerUI | Initializes a new instance of the ViewSchemaPickerUI class
Public method | ViewSchemaPickerUI(Boolean) | Initializes a new instance of the ViewSchemaPickerUI class
Top
Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | Gets or sets a value that indicates whether controls in this container will be automatically validated when the focus changes. (Inherited from Form.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Form.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DeviceDpi | Gets the DPI value for the display device where the control is currently being displayed. (Inherited from Control.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
Protected property | MaximizedBounds | Gets or sets the size of the form when it is maximized. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SelectedViewSchema |
Public property | SelectedViewSchemaCollection |
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Protected property | ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Form.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Protected method | ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Protected method | AdjustFormScrollbars | Adjusts the scroll bars on the container based on the current control positions and the control currently selected. (Inherited from Form.)
Protected method | ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
Protected method | CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Form.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Form.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides FormDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | End |
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Form.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Public method | LogicalToDeviceUnits(Int32) | Converts a Logical DPI value to its equivalent DeviceUnit DPI value. (Inherited from Control.)
Public method | LogicalToDeviceUnits(Size) | Transforms a size from logical to device units by scaling it for the current DPI and rounding down to the nearest integer value for width and height. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnActivated | Raises the Activated event. (Inherited from Form.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnClosed | Raises the Closed event. (Inherited from Form.)
Protected method | OnClosing | Raises the Closing event. (Inherited from Form.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDpiChanged | Raises the DpiChanged event. (Inherited from Form.)
Protected method | OnDpiChangedAfterParent | Raises the DpiChangedAfterParent event. (Inherited from Control.)
Protected method | OnDpiChangedBeforeParent | Raises the DpiChangedBeforeParent event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Form.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Form.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Form.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
Protected method | OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
Protected method | OnGetDpiScaledSize | Raises the GetDpiScaledSize event. (Inherited from Form.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Form.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Form.)
Protected method | OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
Protected method | OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Form.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from Form.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
Protected method | OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
Protected method | OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
Protected method | OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
Protected method | OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
Protected method | OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Form.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Form.)
Protected method | OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
Protected method | OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnShown | Raises the Shown event. (Inherited from Form.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Form.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Form.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Form.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Form.)
Protected method | ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Form.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Form.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from Form.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Protected method | RescaleConstantsForDpi | Provides constants for rescaling the control when a DPI change occurs. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value (Empty). (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScaleBitmapLogicalToDevice | Scales a logical bitmap value to it's equivalent device unit value when a DPI change occurs. (Inherited from Control.)
Protected method | ScaleControl | Scales the location, size, padding, and margin of a control. (Inherited from Form.)
Protected method | ScaleCore | Performs scaling of the form. (Inherited from Form.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Form.)
Protected method | SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either or . (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Form.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog | Shows the form as a modal dialog box. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | Start |
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | Causes all of the child controls within a control that support validation to validate their data. (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | Causes all of the child controls within a control that support validation to validate their data. (Inherited from Form.)
Protected method | WndProc | Processes Windows messages. (Inherited from Form.)
Top
Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from Form.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DpiChanged | Occurs when the DPI setting changes on the display device where the form is currently displayed. (Inherited from Form.)
Public event | DpiChangedAfterParent | Occurs when the DPI setting for a control is changed programmatically after the DPI of its parent control or form has changed. (Inherited from Control.)
Public event | DpiChangedBeforeParent | Occurs when the DPI setting for a control is changed programmatically before a DPI change event for its parent control or form has occurred. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the Margin property changes. (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | Occurs when the TabStop property changes. (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

SchemaExplorer.Design Namespace


ViewSchemaPickerUI Constructor

Overload List
 | Name | Description
Public method | ViewSchemaPickerUI | Initializes a new instance of the ViewSchemaPickerUI class
Public method | ViewSchemaPickerUI(Boolean) | Initializes a new instance of the ViewSchemaPickerUI class
Top
See Also

Reference

ViewSchemaPickerUI Class
SchemaExplorer.Design Namespace


ViewSchemaPickerUI Constructor

Initializes a new instance of the ViewSchemaPickerUI class

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ViewSchemaPickerUI()
Public Sub New
See Also

Reference

ViewSchemaPickerUI Class
ViewSchemaPickerUI Overload
SchemaExplorer.Design Namespace


ViewSchemaPickerUI Constructor (Boolean)

Initializes a new instance of the ViewSchemaPickerUI class

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ViewSchemaPickerUI(
    bool allowMultiple
)
Public Sub New (
    allowMultiple As Boolean
)

Parameters

allowMultiple
Type: SystemBoolean
See Also

Reference

ViewSchemaPickerUI Class
ViewSchemaPickerUI Overload
SchemaExplorer.Design Namespace


ViewSchemaPickerUI Properties

The ViewSchemaPickerUI type exposes the following members.

Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | Gets or sets a value that indicates whether controls in this container will be automatically validated when the focus changes. (Inherited from Form.)
Public property | BackColor | Gets or sets the background color for the control. (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | Gets or sets the BindingContext for the control. (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | Gets the required creation parameters when the control handle is created. (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | Gets the default size of the control. (Inherited from Form.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DeviceDpi | Gets the DPI value for the display device where the control is currently being displayed. (Inherited from Control.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
Protected property | MaximizedBounds | Gets or sets the size of the form when it is maximized. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Public property | SelectedViewSchema |
Public property | SelectedViewSchemaCollection |
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Protected property | ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | Gets or sets the text associated with this control. (Inherited from Form.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

ViewSchemaPickerUI Class
SchemaExplorer.Design Namespace


ViewSchemaPickerUI.SelectedViewSchema Property

ViewSchemaPickerUISelectedViewSchema Property

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ViewSchema SelectedViewSchema { get; }
Public ReadOnly Property SelectedViewSchema As ViewSchema
    Get

Property Value

Type: ViewSchema
See Also

Reference

ViewSchemaPickerUI Class
SchemaExplorer.Design Namespace


ViewSchemaPickerUI.SelectedViewSchemaCollection Property

ViewSchemaPickerUISelectedViewSchemaCollection Property

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ViewSchemaCollection SelectedViewSchemaCollection { get; }
Public ReadOnly Property SelectedViewSchemaCollection As ViewSchemaCollection
    Get

Property Value

Type: ViewSchemaCollection
See Also

Reference

ViewSchemaPickerUI Class
SchemaExplorer.Design Namespace


ViewSchemaPickerUI Methods

The ViewSchemaPickerUI type exposes the following members.

Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Protected method | ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Protected method | AdjustFormScrollbars | Adjusts the scroll bars on the container based on the current control positions and the control currently selected. (Inherited from Form.)
Protected method | ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
Protected method | CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | Creates a new instance of the control collection for the control. (Inherited from Form.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | Sends the specified message to the default window procedure. (Inherited from Form.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides FormDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | End |
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | Retrieves the bounds within which the control is scaled. (Inherited from Form.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Public method | LogicalToDeviceUnits(Int32) | Converts a Logical DPI value to its equivalent DeviceUnit DPI value. (Inherited from Control.)
Public method | LogicalToDeviceUnits(Size) | Transforms a size from logical to device units by scaling it for the current DPI and rounding down to the nearest integer value for width and height. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnActivated | Raises the Activated event. (Inherited from Form.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnClosed | Raises the Closed event. (Inherited from Form.)
Protected method | OnClosing | Raises the Closing event. (Inherited from Form.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDpiChanged | Raises the DpiChanged event. (Inherited from Form.)
Protected method | OnDpiChangedAfterParent | Raises the DpiChangedAfterParent event. (Inherited from Control.)
Protected method | OnDpiChangedBeforeParent | Raises the DpiChangedBeforeParent event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | Raises the EnabledChanged event. (Inherited from Form.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Form.)
Protected method | OnFontChanged | Raises the FontChanged event. (Inherited from Form.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
Protected method | OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
Protected method | OnGetDpiScaledSize | Raises the GetDpiScaledSize event. (Inherited from Form.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | Raises the HandleCreated event. (Inherited from Form.)
Protected method | OnHandleDestroyed | Raises the HandleDestroyed event. (Inherited from Form.)
Protected method | OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
Protected method | OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Form.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from Form.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
Protected method | OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
Protected method | OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
Protected method | OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
Protected method | OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
Protected method | OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | Raises the Paint event. (Inherited from Form.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | Raises the ParentChanged event. (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | Raises the Resize event. (Inherited from Form.)
Protected method | OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
Protected method | OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
Protected method | OnRightToLeftChanged | Raises the RightToLeftChanged event. (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnShown | Raises the Shown event. (Inherited from Form.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | Raises the StyleChanged event. (Inherited from Form.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | Raises the TextChanged event. (Inherited from Form.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Form.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Form.)
Protected method | ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | Previews a keyboard message. (Inherited from Form.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Form.)
Protected method | ProcessTabKey | Selects the next available control and makes it the active control. (Inherited from Form.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Protected method | RescaleConstantsForDpi | Provides constants for rescaling the control when a DPI change occurs. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value (Empty). (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScaleBitmapLogicalToDevice | Scales a logical bitmap value to it's equivalent device unit value when a DPI change occurs. (Inherited from Control.)
Protected method | ScaleControl | Scales the location, size, padding, and margin of a control. (Inherited from Form.)
Protected method | ScaleCore | Performs scaling of the form. (Inherited from Form.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | Performs the work of setting the specified bounds of this control. (Inherited from Form.)
Protected method | SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either or . (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | Sets the control to the specified visible state. (Inherited from Form.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog | Shows the form as a modal dialog box. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | Start |
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | Causes all of the child controls within a control that support validation to validate their data. (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | Causes all of the child controls within a control that support validation to validate their data. (Inherited from Form.)
Protected method | WndProc | Processes Windows messages. (Inherited from Form.)
Top
See Also

Reference

ViewSchemaPickerUI Class
SchemaExplorer.Design Namespace


ViewSchemaPickerUI.Dispose Method

ViewSchemaPickerUIDispose Method

Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides FormDispose(Boolean).)
Top
See Also

Reference

ViewSchemaPickerUI Class
SchemaExplorer.Design Namespace


ViewSchemaPickerUI.Dispose Method (Boolean)

ViewSchemaPickerUIDispose Method (Boolean)

Clean up any resources being used.

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)

Parameters

disposing
Type: SystemBoolean
true if managed resources should be disposed; otherwise, false.
See Also

Reference

ViewSchemaPickerUI Class
Dispose Overload
SchemaExplorer.Design Namespace


ViewSchemaPickerUI.End Method

ViewSchemaPickerUIEnd Method

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void End()
Public Sub End
See Also

Reference

ViewSchemaPickerUI Class
SchemaExplorer.Design Namespace


ViewSchemaPickerUI.Start Method

ViewSchemaPickerUIStart Method

Namespace: SchemaExplorer.Design
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void Start(
    Object value
)
Public Sub Start (
    value As Object
)

Parameters

value
Type: SystemObject
See Also

Reference

ViewSchemaPickerUI Class
SchemaExplorer.Design Namespace


ViewSchemaPickerUI Events

The ViewSchemaPickerUI type exposes the following members.

Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from Form.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DpiChanged | Occurs when the DPI setting changes on the display device where the form is currently displayed. (Inherited from Form.)
Public event | DpiChangedAfterParent | Occurs when the DPI setting for a control is changed programmatically after the DPI of its parent control or form has changed. (Inherited from Control.)
Public event | DpiChangedBeforeParent | Occurs when the DPI setting for a control is changed programmatically before a DPI change event for its parent control or form has occurred. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a character. space or backspace key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the Margin property changes. (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | Occurs when the TabStop property changes. (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

ViewSchemaPickerUI Class
SchemaExplorer.Design Namespace


SchemaExplorer.Extensions Namespace

Classes
 | Class | Description
Public class | ExtendedPropertyCollectionExtensions |


ExtendedPropertyCollectionExtensions Class

Inheritance Hierarchy
SystemObject
SchemaExplorer.ExtensionsExtendedPropertyCollectionExtensions

Namespace: SchemaExplorer.Extensions
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static class ExtendedPropertyCollectionExtensions
<ExtensionAttribute>
Public NotInheritable Class ExtendedPropertyCollectionExtensions
Methods
Name | Description
GetByKey(IReadOnlyNamedObjectCollectionIExtendedProperty, String) |
GetByKeyT(IReadOnlyNamedObjectCollectionIExtendedProperty, String) |
Top
See Also

Reference

SchemaExplorer.Extensions Namespace


ExtendedPropertyCollectionExtensions Methods

Methods
Name | Description
GetByKey(IReadOnlyNamedObjectCollectionIExtendedProperty, String) |
GetByKeyT(IReadOnlyNamedObjectCollectionIExtendedProperty, String) |
Top
See Also

Reference

ExtendedPropertyCollectionExtensions Class
SchemaExplorer.Extensions Namespace


ExtendedPropertyCollectionExtensions.GetByKey Method

ExtendedPropertyCollectionExtensionsGetByKey Method

Overload List
Name | Description
GetByKey(IReadOnlyNamedObjectCollectionIExtendedProperty, String) |
GetByKeyT(IReadOnlyNamedObjectCollectionIExtendedProperty, String) |
Top
See Also

Reference

ExtendedPropertyCollectionExtensions Class
SchemaExplorer.Extensions Namespace


ExtendedPropertyCollectionExtensions.GetByKey Method (IReadOnlyNamedObjectCollection`1(IExtendedProperty), String)

ExtendedPropertyCollectionExtensionsGetByKey Method (IReadOnlyNamedObjectCollection`1IExtendedProperty, String)

Namespace: SchemaExplorer.Extensions
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static Object GetByKey(
    this IReadOnlyNamedObjectCollection<IExtendedProperty> collection,
    string key
)
<ExtensionAttribute>
Public Shared Function GetByKey (
    collection As IReadOnlyNamedObjectCollection(Of IExtendedProperty),
    key As String
) As Object

Parameters

collection
Type: IReadOnlyNamedObjectCollectionIExtendedProperty
key
Type: SystemString

Return Value

Type: Object

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IReadOnlyNamedObjectCollectionIExtendedProperty . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ExtendedPropertyCollectionExtensions Class
GetByKey Overload
SchemaExplorer.Extensions Namespace


ExtendedPropertyCollectionExtensions.GetByKey(T) Method (IReadOnlyNamedObjectCollection`1(IExtendedProperty), String)

ExtendedPropertyCollectionExtensionsGetByKeyT Method (IReadOnlyNamedObjectCollection`1IExtendedProperty, String)

Namespace: SchemaExplorer.Extensions
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static T GetByKey<T>(
    this IReadOnlyNamedObjectCollection<IExtendedProperty> collection,
    string key
)

<ExtensionAttribute>
Public Shared Function GetByKey(Of T) (
    collection As IReadOnlyNamedObjectCollection(Of IExtendedProperty),
    key As String
) As T

Parameters

collection
Type: IReadOnlyNamedObjectCollectionIExtendedProperty
key
Type: SystemString

Type Parameters

T

Return Value

Type: T

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IReadOnlyNamedObjectCollectionIExtendedProperty . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ExtendedPropertyCollectionExtensions Class
GetByKey Overload
SchemaExplorer.Extensions Namespace


SchemaExplorer.Serialization Namespace

Classes
 | Class | Description
Public class | DatabaseSchemaSerializer |
Public class | DataObjectSerializer |
Public class | SchemaObjectFactorySerializer |
Public class | SchemaObjectSerializer |
Public class | SchemaSelectorSerializer |


DatabaseSchemaSerializer Class

Inheritance Hierarchy
SystemObject
JsonConverter
SchemaExplorer.SerializationDatabaseSchemaSerializer
SchemaExplorer.SerializationSchemaObjectSerializer

Namespace: SchemaExplorer.Serialization
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class DatabaseSchemaSerializer : JsonConverter,
    IPropertySerializer
Public Class DatabaseSchemaSerializer
    Inherits JsonConverter
    Implements IPropertySerializer

The DatabaseSchemaSerializer type exposes the following members.

Constructors
 | Name | Description
Public method | DatabaseSchemaSerializer | Initializes a new instance of the DatabaseSchemaSerializer class
Top
Methods
 | Name | Description
Public method | CanConvert | (Overrides JsonConverter.CanConvert(Type).)
Protected method | CreateDatabaseSchemaFromNavigator |
Protected method | CreateDatabaseSchemaInstance |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetDatabaseSchemaFromName |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | IsCollection |
Public method | LoadProperty |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseDefaultValue |
Public method | ReadJson | (Overrides JsonConverter.ReadJson(JsonReader, Type, Object, JsonSerializer).)
Public method | ReadPropertyXml |
Public method | SaveProperty |
 | SetDeepLoad |
 | SetIncludeFunctions |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WriteJson | (Overrides JsonConverter.WriteJson(JsonWriter, Object, JsonSerializer).)
Public method | WritePropertyXml |
Top
See Also

Reference

SchemaExplorer.Serialization Namespace


DatabaseSchemaSerializer Constructor

Initializes a new instance of the DatabaseSchemaSerializer class

Namespace: SchemaExplorer.Serialization
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public DatabaseSchemaSerializer()
Public Sub New
See Also

Reference

DatabaseSchemaSerializer Class
SchemaExplorer.Serialization Namespace


DatabaseSchemaSerializer Methods

The DatabaseSchemaSerializer type exposes the following members.

Methods
 | Name | Description
Public method | CanConvert | (Overrides JsonConverter.CanConvert(Type).)
Protected method | CreateDatabaseSchemaFromNavigator |
Protected method | CreateDatabaseSchemaInstance |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetDatabaseSchemaFromName |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | IsCollection |
Public method | LoadProperty |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseDefaultValue |
Public method | ReadJson | (Overrides JsonConverter.ReadJson(JsonReader, Type, Object, JsonSerializer).)
Public method | ReadPropertyXml |
Public method | SaveProperty |
 | SetDeepLoad |
 | SetIncludeFunctions |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WriteJson | (Overrides JsonConverter.WriteJson(JsonWriter, Object, JsonSerializer).)
Public method | WritePropertyXml |
Top
See Also

Reference

DatabaseSchemaSerializer Class
SchemaExplorer.Serialization Namespace


DatabaseSchemaSerializer.CanConvert Method

DatabaseSchemaSerializerCanConvert Method

Namespace: SchemaExplorer.Serialization
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override bool CanConvert(
    Type objectType
)
Public Overrides Function CanConvert (
    objectType As Type
) As Boolean

Parameters

objectType
Type: SystemType

Return Value

Type: Boolean
See Also

Reference

DatabaseSchemaSerializer Class
SchemaExplorer.Serialization Namespace


DatabaseSchemaSerializer.CreateDatabaseSchemaFromNavigator Method

DatabaseSchemaSerializerCreateDatabaseSchemaFromNavigator Method

Namespace: SchemaExplorer.Serialization
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected IDatabaseSchema CreateDatabaseSchemaFromNavigator(
    XPathNavigator navigator
)
Protected Function CreateDatabaseSchemaFromNavigator (
    navigator As XPathNavigator
) As IDatabaseSchema

Parameters

navigator
Type: System.Xml.XPathXPathNavigator

Return Value

Type: IDatabaseSchema
See Also

Reference

DatabaseSchemaSerializer Class
SchemaExplorer.Serialization Namespace


DatabaseSchemaSerializer.CreateDatabaseSchemaInstance Method

DatabaseSchemaSerializerCreateDatabaseSchemaInstance Method

Namespace: SchemaExplorer.Serialization
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected IDatabaseSchema CreateDatabaseSchemaInstance(
    string connectionString,
    string providerType
)
Protected Function CreateDatabaseSchemaInstance (
    connectionString As String,
    providerType As String
) As IDatabaseSchema

Parameters

connectionString
Type: SystemString
providerType
Type: SystemString

Return Value

Type: IDatabaseSchema
See Also

Reference

DatabaseSchemaSerializer Class
SchemaExplorer.Serialization Namespace


DatabaseSchemaSerializer.GetDatabaseSchemaFromName Method

DatabaseSchemaSerializerGetDatabaseSchemaFromName Method

Namespace: SchemaExplorer.Serialization
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static IDatabaseSchema GetDatabaseSchemaFromName(
    string dataSourceName
)
Public Shared Function GetDatabaseSchemaFromName (
    dataSourceName As String
) As IDatabaseSchema

Parameters

dataSourceName
Type: SystemString

Return Value

Type: IDatabaseSchema
See Also

Reference

DatabaseSchemaSerializer Class
SchemaExplorer.Serialization Namespace


DatabaseSchemaSerializer.IsCollection Method

DatabaseSchemaSerializerIsCollection Method

Namespace: SchemaExplorer.Serialization
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected bool IsCollection(
    Type propertyType
)
Protected Function IsCollection (
    propertyType As Type
) As Boolean

Parameters

propertyType
Type: SystemType

Return Value

Type: Boolean
See Also

Reference

DatabaseSchemaSerializer Class
SchemaExplorer.Serialization Namespace


DatabaseSchemaSerializer.LoadProperty Method

DatabaseSchemaSerializerLoadProperty Method

Namespace: SchemaExplorer.Serialization
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual Object LoadProperty(
    PropertySerializerContext context,
    Object propertyValue
)
Public Overridable Function LoadProperty (
    context As PropertySerializerContext,
    propertyValue As Object
) As Object

Parameters

context
Type: CodeSmith.EnginePropertySerializerContext
propertyValue
Type: SystemObject

Return Value

Type: Object

Implements

IPropertySerializerLoadProperty(PropertySerializerContext, Object)
See Also

Reference

DatabaseSchemaSerializer Class
SchemaExplorer.Serialization Namespace


DatabaseSchemaSerializer.ParseDefaultValue Method

DatabaseSchemaSerializerParseDefaultValue Method

Namespace: SchemaExplorer.Serialization
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual Object ParseDefaultValue(
    PropertySerializerContext context,
    string defaultValue
)
Public Overridable Function ParseDefaultValue (
    context As PropertySerializerContext,
    defaultValue As String
) As Object

Parameters

context
Type: CodeSmith.EnginePropertySerializerContext
defaultValue
Type: SystemString

Return Value

Type: Object

Implements

IPropertySerializerParseDefaultValue(PropertySerializerContext, String)
See Also

Reference

DatabaseSchemaSerializer Class
SchemaExplorer.Serialization Namespace


DatabaseSchemaSerializer.ReadJson Method

DatabaseSchemaSerializerReadJson Method

Namespace: SchemaExplorer.Serialization
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override Object ReadJson(
    JsonReader reader,
    Type schemaType,
    Object existingValue,
    JsonSerializer serializer
)
Public Overrides Function ReadJson (
    reader As JsonReader,
    schemaType As Type,
    existingValue As Object,
    serializer As JsonSerializer
) As Object

Parameters

reader
Type: JsonReader
schemaType
Type: SystemType
existingValue
Type: SystemObject
serializer
Type: JsonSerializer

Return Value

Type: Object
See Also

Reference

DatabaseSchemaSerializer Class
SchemaExplorer.Serialization Namespace


DatabaseSchemaSerializer.ReadPropertyXml Method

DatabaseSchemaSerializerReadPropertyXml Method

Namespace: SchemaExplorer.Serialization
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual Object ReadPropertyXml(
    PropertySerializerContext context,
    XmlNode propertyValue
)
Public Overridable Function ReadPropertyXml (
    context As PropertySerializerContext,
    propertyValue As XmlNode
) As Object

Parameters

context
Type: CodeSmith.EnginePropertySerializerContext
propertyValue
Type: System.XmlXmlNode

Return Value

Type: Object

Implements

IPropertySerializerReadPropertyXml(PropertySerializerContext, XmlNode)
See Also

Reference

DatabaseSchemaSerializer Class
SchemaExplorer.Serialization Namespace


DatabaseSchemaSerializer.SaveProperty Method

DatabaseSchemaSerializerSaveProperty Method

Namespace: SchemaExplorer.Serialization
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual Object SaveProperty(
    PropertySerializerContext context,
    Object propertyValue
)
Public Overridable Function SaveProperty (
    context As PropertySerializerContext,
    propertyValue As Object
) As Object

Parameters

context
Type: CodeSmith.EnginePropertySerializerContext
propertyValue
Type: SystemObject

Return Value

Type: Object

Implements

IPropertySerializerSaveProperty(PropertySerializerContext, Object)
See Also

Reference

DatabaseSchemaSerializer Class
SchemaExplorer.Serialization Namespace


DatabaseSchemaSerializer.SetDeepLoad Method

DatabaseSchemaSerializerSetDeepLoad Method

Namespace: SchemaExplorer.Serialization
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static void SetDeepLoad(
    PropertySerializerContext context,
    ISchemaObject schemaObject
)
Public Shared Sub SetDeepLoad (
    context As PropertySerializerContext,
    schemaObject As ISchemaObject
)

Parameters

context
Type: CodeSmith.EnginePropertySerializerContext
schemaObject
Type: SchemaExplorerISchemaObject
See Also

Reference

DatabaseSchemaSerializer Class
SchemaExplorer.Serialization Namespace


DatabaseSchemaSerializer.SetIncludeFunctions Method

DatabaseSchemaSerializerSetIncludeFunctions Method

Namespace: SchemaExplorer.Serialization
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static void SetIncludeFunctions(
    PropertySerializerContext context,
    ISchemaObject schemaObject
)
Public Shared Sub SetIncludeFunctions (
    context As PropertySerializerContext,
    schemaObject As ISchemaObject
)

Parameters

context
Type: CodeSmith.EnginePropertySerializerContext
schemaObject
Type: SchemaExplorerISchemaObject
See Also

Reference

DatabaseSchemaSerializer Class
SchemaExplorer.Serialization Namespace


DatabaseSchemaSerializer.WriteJson Method

DatabaseSchemaSerializerWriteJson Method

Namespace: SchemaExplorer.Serialization
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override void WriteJson(
    JsonWriter writer,
    Object value,
    JsonSerializer serializer
)
Public Overrides Sub WriteJson (
    writer As JsonWriter,
    value As Object,
    serializer As JsonSerializer
)

Parameters

writer
Type: JsonWriter
value
Type: SystemObject
serializer
Type: JsonSerializer
See Also

Reference

DatabaseSchemaSerializer Class
SchemaExplorer.Serialization Namespace


DatabaseSchemaSerializer.WritePropertyXml Method

DatabaseSchemaSerializerWritePropertyXml Method

Namespace: SchemaExplorer.Serialization
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public virtual void WritePropertyXml(
    PropertySerializerContext context,
    XmlWriter writer,
    Object propertyValue
)
Public Overridable Sub WritePropertyXml (
    context As PropertySerializerContext,
    writer As XmlWriter,
    propertyValue As Object
)

Parameters

context
Type: CodeSmith.EnginePropertySerializerContext
writer
Type: System.XmlXmlWriter
propertyValue
Type: SystemObject

Implements

IPropertySerializerWritePropertyXml(PropertySerializerContext, XmlWriter, Object)
See Also

Reference

DatabaseSchemaSerializer Class
SchemaExplorer.Serialization Namespace


DataObjectSerializer Class

Inheritance Hierarchy
SystemObject
JsonConverter
SchemaExplorer.SerializationDatabaseSchemaSerializer
SchemaExplorer.SerializationSchemaObjectSerializer
SchemaExplorer.SerializationDataObjectSerializer

Namespace: SchemaExplorer.Serialization
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class DataObjectSerializer : SchemaObjectSerializer
Public Class DataObjectSerializer
    Inherits SchemaObjectSerializer

The DataObjectSerializer type exposes the following members.

Constructors
 | Name | Description
Public method | DataObjectSerializer | Initializes a new instance of the DataObjectSerializer class
Top
Properties
 | Name | Description
Protected property | Find | (Inherited from SchemaObjectSerializer.)
Protected property | ObjectName | (Inherited from SchemaObjectSerializer.)
Top
Methods
 | Name | Description
Public method | CanConvert | (Inherited from DatabaseSchemaSerializer.)
Protected method | CreateDatabaseSchemaFromNavigator | (Inherited from DatabaseSchemaSerializer.)
Protected method | CreateDatabaseSchemaInstance | (Inherited from DatabaseSchemaSerializer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDataObjectFromName |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetNameExpressions | (Overrides SchemaObjectSerializerGetNameExpressions(PropertySerializerContext).)
Protected method | GetObjectNameExpressions |
Protected method | GetOwnerExpressions | (Overrides SchemaObjectSerializerGetOwnerExpressions(PropertySerializerContext).)
Protected method | GetSchemaObjectExpressions | (Overrides SchemaObjectSerializerGetSchemaObjectExpressions(PropertySerializerContext).)
Public method | GetSchemaObjectFromName | (Inherited from SchemaObjectSerializer.)
Protected method | GetSchemaObjectFromNavigator | (Overrides SchemaObjectSerializerGetSchemaObjectFromNavigator(PropertySerializerContext, IDatabaseSchema, XPathNavigator, XmlNamespaceManager).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | IsCollection | (Inherited from DatabaseSchemaSerializer.)
Public method | LoadProperty | (Inherited from DatabaseSchemaSerializer.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseDefaultValue | (Overrides SchemaObjectSerializerParseDefaultValue(PropertySerializerContext, String).)
Public method | ReadJson | (Inherited from DatabaseSchemaSerializer.)
Public method | ReadPropertyXml | (Inherited from SchemaObjectSerializer.)
Public method | SaveProperty | (Inherited from DatabaseSchemaSerializer.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WriteJson | (Inherited from DatabaseSchemaSerializer.)
Public method | WritePropertyXml | (Inherited from SchemaObjectSerializer.)
Protected method | WriteSchemaObjectXml | (Overrides SchemaObjectSerializerWriteSchemaObjectXml(XmlWriter, ISchemaObject).)
Top
See Also

Reference

SchemaExplorer.Serialization Namespace


DataObjectSerializer Constructor

Initializes a new instance of the DataObjectSerializer class

Namespace: SchemaExplorer.Serialization
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public DataObjectSerializer(
    string objectName,
    Func<IDatabaseSchema, string, string, ISchemaObject> findFunction
)
Public Sub New (
    objectName As String,
    findFunction As Func(Of IDatabaseSchema, String, String, ISchemaObject)
)

Parameters

objectName
Type: SystemString
findFunction
Type: SystemFunc IDatabaseSchema, String, String, ISchemaObject
See Also

Reference

DataObjectSerializer Class
SchemaExplorer.Serialization Namespace


DataObjectSerializer Properties

The DataObjectSerializer type exposes the following members.

Properties
 | Name | Description
Protected property | Find | (Inherited from SchemaObjectSerializer.)
Protected property | ObjectName | (Inherited from SchemaObjectSerializer.)
Top
See Also

Reference

DataObjectSerializer Class
SchemaExplorer.Serialization Namespace


DataObjectSerializer Methods

The DataObjectSerializer type exposes the following members.

Methods
 | Name | Description
Public method | CanConvert | (Inherited from DatabaseSchemaSerializer.)
Protected method | CreateDatabaseSchemaFromNavigator | (Inherited from DatabaseSchemaSerializer.)
Protected method | CreateDatabaseSchemaInstance | (Inherited from DatabaseSchemaSerializer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDataObjectFromName |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetNameExpressions | (Overrides SchemaObjectSerializerGetNameExpressions(PropertySerializerContext).)
Protected method | GetObjectNameExpressions |
Protected method | GetOwnerExpressions | (Overrides SchemaObjectSerializerGetOwnerExpressions(PropertySerializerContext).)
Protected method | GetSchemaObjectExpressions | (Overrides SchemaObjectSerializerGetSchemaObjectExpressions(PropertySerializerContext).)
Public method | GetSchemaObjectFromName | (Inherited from SchemaObjectSerializer.)
Protected method | GetSchemaObjectFromNavigator | (Overrides SchemaObjectSerializerGetSchemaObjectFromNavigator(PropertySerializerContext, IDatabaseSchema, XPathNavigator, XmlNamespaceManager).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | IsCollection | (Inherited from DatabaseSchemaSerializer.)
Public method | LoadProperty | (Inherited from DatabaseSchemaSerializer.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseDefaultValue | (Overrides SchemaObjectSerializerParseDefaultValue(PropertySerializerContext, String).)
Public method | ReadJson | (Inherited from DatabaseSchemaSerializer.)
Public method | ReadPropertyXml | (Inherited from SchemaObjectSerializer.)
Public method | SaveProperty | (Inherited from DatabaseSchemaSerializer.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WriteJson | (Inherited from DatabaseSchemaSerializer.)
Public method | WritePropertyXml | (Inherited from SchemaObjectSerializer.)
Protected method | WriteSchemaObjectXml | (Overrides SchemaObjectSerializerWriteSchemaObjectXml(XmlWriter, ISchemaObject).)
Top
See Also

Reference

DataObjectSerializer Class
SchemaExplorer.Serialization Namespace


DataObjectSerializer.GetDataObjectFromName Method

DataObjectSerializerGetDataObjectFromName Method

Namespace: SchemaExplorer.Serialization
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public IDataObject GetDataObjectFromName(
    string objectName,
    Object currentValue
)
Public Function GetDataObjectFromName (
    objectName As String,
    currentValue As Object
) As IDataObject

Parameters

objectName
Type: SystemString
currentValue
Type: SystemObject

Return Value

Type: IDataObject
See Also

Reference

DataObjectSerializer Class
SchemaExplorer.Serialization Namespace


DataObjectSerializer.GetNameExpressions Method

DataObjectSerializerGetNameExpressions Method

Namespace: SchemaExplorer.Serialization
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected override string[] GetNameExpressions(
    PropertySerializerContext context
)
Protected Overrides Function GetNameExpressions (
    context As PropertySerializerContext
) As String()

Parameters

context
Type: CodeSmith.EnginePropertySerializerContext

Return Value

Type: String
See Also

Reference

DataObjectSerializer Class
SchemaExplorer.Serialization Namespace


DataObjectSerializer.GetObjectNameExpressions Method

DataObjectSerializerGetObjectNameExpressions Method

Namespace: SchemaExplorer.Serialization
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual string[] GetObjectNameExpressions(
    PropertySerializerContext context
)
Protected Overridable Function GetObjectNameExpressions (
    context As PropertySerializerContext
) As String()

Parameters

context
Type: CodeSmith.EnginePropertySerializerContext

Return Value

Type: String
See Also

Reference

DataObjectSerializer Class
SchemaExplorer.Serialization Namespace


DataObjectSerializer.GetOwnerExpressions Method

DataObjectSerializerGetOwnerExpressions Method

Namespace: SchemaExplorer.Serialization
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected override string[] GetOwnerExpressions(
    PropertySerializerContext context
)
Protected Overrides Function GetOwnerExpressions (
    context As PropertySerializerContext
) As String()

Parameters

context
Type: CodeSmith.EnginePropertySerializerContext

Return Value

Type: String
See Also

Reference

DataObjectSerializer Class
SchemaExplorer.Serialization Namespace


DataObjectSerializer.GetSchemaObjectExpressions Method

DataObjectSerializerGetSchemaObjectExpressions Method

Namespace: SchemaExplorer.Serialization
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected override string[] GetSchemaObjectExpressions(
    PropertySerializerContext context
)
Protected Overrides Function GetSchemaObjectExpressions (
    context As PropertySerializerContext
) As String()

Parameters

context
Type: CodeSmith.EnginePropertySerializerContext

Return Value

Type: String
See Also

Reference

DataObjectSerializer Class
SchemaExplorer.Serialization Namespace


DataObjectSerializer.GetSchemaObjectFromNavigator Method

DataObjectSerializerGetSchemaObjectFromNavigator Method

Namespace: SchemaExplorer.Serialization
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected override ISchemaObject GetSchemaObjectFromNavigator(
    PropertySerializerContext context,
    IDatabaseSchema databaseSchema,
    XPathNavigator node,
    XmlNamespaceManager manager
)
Protected Overrides Function GetSchemaObjectFromNavigator (
    context As PropertySerializerContext,
    databaseSchema As IDatabaseSchema,
    node As XPathNavigator,
    manager As XmlNamespaceManager
) As ISchemaObject

Parameters

context
Type: CodeSmith.EnginePropertySerializerContext
databaseSchema
Type: SchemaExplorerIDatabaseSchema
node
Type: System.Xml.XPathXPathNavigator
manager
Type: System.XmlXmlNamespaceManager

Return Value

Type: ISchemaObject
See Also

Reference

DataObjectSerializer Class
SchemaExplorer.Serialization Namespace


DataObjectSerializer.ParseDefaultValue Method

DataObjectSerializerParseDefaultValue Method

Namespace: SchemaExplorer.Serialization
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override Object ParseDefaultValue(
    PropertySerializerContext context,
    string defaultValue
)
Public Overrides Function ParseDefaultValue (
    context As PropertySerializerContext,
    defaultValue As String
) As Object

Parameters

context
Type: CodeSmith.EnginePropertySerializerContext
defaultValue
Type: SystemString

Return Value

Type: Object

Implements

IPropertySerializerParseDefaultValue(PropertySerializerContext, String)
See Also

Reference

DataObjectSerializer Class
SchemaExplorer.Serialization Namespace


DataObjectSerializer.WriteSchemaObjectXml Method

DataObjectSerializerWriteSchemaObjectXml Method

Namespace: SchemaExplorer.Serialization
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected override void WriteSchemaObjectXml(
    XmlWriter writer,
    ISchemaObject schemaObject
)
Protected Overrides Sub WriteSchemaObjectXml (
    writer As XmlWriter,
    schemaObject As ISchemaObject
)

Parameters

writer
Type: System.XmlXmlWriter
schemaObject
Type: SchemaExplorerISchemaObject
See Also

Reference

DataObjectSerializer Class
SchemaExplorer.Serialization Namespace


SchemaObjectFactorySerializer Class

Inheritance Hierarchy
SystemObject
SchemaExplorer.SerializationSchemaObjectFactorySerializer

Namespace: SchemaExplorer.Serialization
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class SchemaObjectFactorySerializer : IPropertySerializer
Public Class SchemaObjectFactorySerializer
    Implements IPropertySerializer

The SchemaObjectFactorySerializer type exposes the following members.

Constructors
 | Name | Description
Public method | SchemaObjectFactorySerializer | Initializes a new instance of the SchemaObjectFactorySerializer class
Top
Methods
 | Name | Description
 | Create |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadProperty |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseDefaultValue |
Public method | ReadPropertyXml |
Public method | SaveProperty |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WritePropertyXml |
Top
See Also

Reference

SchemaExplorer.Serialization Namespace


SchemaObjectFactorySerializer Constructor

Initializes a new instance of the SchemaObjectFactorySerializer class

Namespace: SchemaExplorer.Serialization
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public SchemaObjectFactorySerializer()
Public Sub New
See Also

Reference

SchemaObjectFactorySerializer Class
SchemaExplorer.Serialization Namespace


SchemaObjectFactorySerializer Methods

The SchemaObjectFactorySerializer type exposes the following members.

Methods
 | Name | Description
 | Create |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadProperty |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseDefaultValue |
Public method | ReadPropertyXml |
Public method | SaveProperty |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WritePropertyXml |
Top
See Also

Reference

SchemaObjectFactorySerializer Class
SchemaExplorer.Serialization Namespace


SchemaObjectFactorySerializer.Create Method

SchemaObjectFactorySerializerCreate Method

Namespace: SchemaExplorer.Serialization
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public static IPropertySerializer Create(
    Type schemaType
)
Public Shared Function Create (
    schemaType As Type
) As IPropertySerializer

Parameters

schemaType
Type: SystemType

Return Value

Type: IPropertySerializer
See Also

Reference

SchemaObjectFactorySerializer Class
SchemaExplorer.Serialization Namespace


SchemaObjectFactorySerializer.LoadProperty Method

SchemaObjectFactorySerializerLoadProperty Method

Namespace: SchemaExplorer.Serialization
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public Object LoadProperty(
    PropertySerializerContext context,
    Object propertyValue
)
Public Function LoadProperty (
    context As PropertySerializerContext,
    propertyValue As Object
) As Object

Parameters

context
Type: CodeSmith.EnginePropertySerializerContext
propertyValue
Type: SystemObject

Return Value

Type: Object

Implements

IPropertySerializerLoadProperty(PropertySerializerContext, Object)
See Also

Reference

SchemaObjectFactorySerializer Class
SchemaExplorer.Serialization Namespace


SchemaObjectFactorySerializer.ParseDefaultValue Method

SchemaObjectFactorySerializerParseDefaultValue Method

Namespace: SchemaExplorer.Serialization
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public Object ParseDefaultValue(
    PropertySerializerContext context,
    string defaultValue
)
Public Function ParseDefaultValue (
    context As PropertySerializerContext,
    defaultValue As String
) As Object

Parameters

context
Type: CodeSmith.EnginePropertySerializerContext
defaultValue
Type: SystemString

Return Value

Type: Object

Implements

IPropertySerializerParseDefaultValue(PropertySerializerContext, String)
See Also

Reference

SchemaObjectFactorySerializer Class
SchemaExplorer.Serialization Namespace


SchemaObjectFactorySerializer.ReadPropertyXml Method

SchemaObjectFactorySerializerReadPropertyXml Method

Namespace: SchemaExplorer.Serialization
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public Object ReadPropertyXml(
    PropertySerializerContext context,
    XmlNode propertyValue
)
Public Function ReadPropertyXml (
    context As PropertySerializerContext,
    propertyValue As XmlNode
) As Object

Parameters

context
Type: CodeSmith.EnginePropertySerializerContext
propertyValue
Type: System.XmlXmlNode

Return Value

Type: Object

Implements

IPropertySerializerReadPropertyXml(PropertySerializerContext, XmlNode)
See Also

Reference

SchemaObjectFactorySerializer Class
SchemaExplorer.Serialization Namespace


SchemaObjectFactorySerializer.SaveProperty Method

SchemaObjectFactorySerializerSaveProperty Method

Namespace: SchemaExplorer.Serialization
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public Object SaveProperty(
    PropertySerializerContext context,
    Object propertyValue
)
Public Function SaveProperty (
    context As PropertySerializerContext,
    propertyValue As Object
) As Object

Parameters

context
Type: CodeSmith.EnginePropertySerializerContext
propertyValue
Type: SystemObject

Return Value

Type: Object

Implements

IPropertySerializerSaveProperty(PropertySerializerContext, Object)
See Also

Reference

SchemaObjectFactorySerializer Class
SchemaExplorer.Serialization Namespace


SchemaObjectFactorySerializer.WritePropertyXml Method

SchemaObjectFactorySerializerWritePropertyXml Method

Namespace: SchemaExplorer.Serialization
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void WritePropertyXml(
    PropertySerializerContext context,
    XmlWriter writer,
    Object propertyValue
)
Public Sub WritePropertyXml (
    context As PropertySerializerContext,
    writer As XmlWriter,
    propertyValue As Object
)

Parameters

context
Type: CodeSmith.EnginePropertySerializerContext
writer
Type: System.XmlXmlWriter
propertyValue
Type: SystemObject

Implements

IPropertySerializerWritePropertyXml(PropertySerializerContext, XmlWriter, Object)
See Also

Reference

SchemaObjectFactorySerializer Class
SchemaExplorer.Serialization Namespace


SchemaObjectSerializer Class

Inheritance Hierarchy
SystemObject
JsonConverter
SchemaExplorer.SerializationDatabaseSchemaSerializer
SchemaExplorer.SerializationSchemaObjectSerializer
SchemaExplorer.SerializationDataObjectSerializer

Namespace: SchemaExplorer.Serialization
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class SchemaObjectSerializer : DatabaseSchemaSerializer
Public Class SchemaObjectSerializer
    Inherits DatabaseSchemaSerializer

The SchemaObjectSerializer type exposes the following members.

Constructors
 | Name | Description
Public method | SchemaObjectSerializer | Initializes a new instance of the SchemaObjectSerializer class
Top
Properties
 | Name | Description
Protected property | Find |
Protected property | ObjectName |
Top
Methods
 | Name | Description
Public method | CanConvert | (Inherited from DatabaseSchemaSerializer.)
Protected method | CreateDatabaseSchemaFromNavigator | (Inherited from DatabaseSchemaSerializer.)
Protected method | CreateDatabaseSchemaInstance | (Inherited from DatabaseSchemaSerializer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetNameExpressions |
Protected method | GetOwnerExpressions |
Protected method | GetSchemaObjectExpressions |
Public method | GetSchemaObjectFromName |
Protected method | GetSchemaObjectFromNavigator |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | IsCollection | (Inherited from DatabaseSchemaSerializer.)
Public method | LoadProperty | (Inherited from DatabaseSchemaSerializer.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseDefaultValue | (Overrides DatabaseSchemaSerializerParseDefaultValue(PropertySerializerContext, String).)
Public method | ReadJson | (Inherited from DatabaseSchemaSerializer.)
Public method | ReadPropertyXml | (Overrides DatabaseSchemaSerializerReadPropertyXml(PropertySerializerContext, XmlNode).)
Public method | SaveProperty | (Inherited from DatabaseSchemaSerializer.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WriteJson | (Inherited from DatabaseSchemaSerializer.)
Public method | WritePropertyXml | (Overrides DatabaseSchemaSerializerWritePropertyXml(PropertySerializerContext, XmlWriter, Object).)
Protected method | WriteSchemaObjectXml |
Top
See Also

Reference

SchemaExplorer.Serialization Namespace


SchemaObjectSerializer Constructor

Initializes a new instance of the SchemaObjectSerializer class

Namespace: SchemaExplorer.Serialization
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public SchemaObjectSerializer(
    string objectName,
    Func<IDatabaseSchema, string, string, ISchemaObject> findFunction
)
Public Sub New (
    objectName As String,
    findFunction As Func(Of IDatabaseSchema, String, String, ISchemaObject)
)

Parameters

objectName
Type: SystemString
findFunction
Type: SystemFunc IDatabaseSchema, String, String, ISchemaObject
See Also

Reference

SchemaObjectSerializer Class
SchemaExplorer.Serialization Namespace


SchemaObjectSerializer Properties

The SchemaObjectSerializer type exposes the following members.

Properties
 | Name | Description
Protected property | Find |
Protected property | ObjectName |
Top
See Also

Reference

SchemaObjectSerializer Class
SchemaExplorer.Serialization Namespace


SchemaObjectSerializer.Find Property

SchemaObjectSerializerFind Property

Namespace: SchemaExplorer.Serialization
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected Func<IDatabaseSchema, string, string, ISchemaObject> Find { get; set; }
Protected Property Find As Func(Of IDatabaseSchema, String, String, ISchemaObject)
    Get
    Set

Property Value

Type: Func IDatabaseSchema, String, String, ISchemaObject
See Also

Reference

SchemaObjectSerializer Class
SchemaExplorer.Serialization Namespace


SchemaObjectSerializer.ObjectName Property

SchemaObjectSerializerObjectName Property

Namespace: SchemaExplorer.Serialization
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected string ObjectName { get; set; }
Protected Property ObjectName As String
    Get
    Set

Property Value

Type: String
See Also

Reference

SchemaObjectSerializer Class
SchemaExplorer.Serialization Namespace


SchemaObjectSerializer Methods

The SchemaObjectSerializer type exposes the following members.

Methods
 | Name | Description
Public method | CanConvert | (Inherited from DatabaseSchemaSerializer.)
Protected method | CreateDatabaseSchemaFromNavigator | (Inherited from DatabaseSchemaSerializer.)
Protected method | CreateDatabaseSchemaInstance | (Inherited from DatabaseSchemaSerializer.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Protected method | GetNameExpressions |
Protected method | GetOwnerExpressions |
Protected method | GetSchemaObjectExpressions |
Public method | GetSchemaObjectFromName |
Protected method | GetSchemaObjectFromNavigator |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | IsCollection | (Inherited from DatabaseSchemaSerializer.)
Public method | LoadProperty | (Inherited from DatabaseSchemaSerializer.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseDefaultValue | (Overrides DatabaseSchemaSerializerParseDefaultValue(PropertySerializerContext, String).)
Public method | ReadJson | (Inherited from DatabaseSchemaSerializer.)
Public method | ReadPropertyXml | (Overrides DatabaseSchemaSerializerReadPropertyXml(PropertySerializerContext, XmlNode).)
Public method | SaveProperty | (Inherited from DatabaseSchemaSerializer.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WriteJson | (Inherited from DatabaseSchemaSerializer.)
Public method | WritePropertyXml | (Overrides DatabaseSchemaSerializerWritePropertyXml(PropertySerializerContext, XmlWriter, Object).)
Protected method | WriteSchemaObjectXml |
Top
See Also

Reference

SchemaObjectSerializer Class
SchemaExplorer.Serialization Namespace


SchemaObjectSerializer.GetNameExpressions Method

SchemaObjectSerializerGetNameExpressions Method

Namespace: SchemaExplorer.Serialization
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual string[] GetNameExpressions(
    PropertySerializerContext context
)
Protected Overridable Function GetNameExpressions (
    context As PropertySerializerContext
) As String()

Parameters

context
Type: CodeSmith.EnginePropertySerializerContext

Return Value

Type: String
See Also

Reference

SchemaObjectSerializer Class
SchemaExplorer.Serialization Namespace


SchemaObjectSerializer.GetOwnerExpressions Method

SchemaObjectSerializerGetOwnerExpressions Method

Namespace: SchemaExplorer.Serialization
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual string[] GetOwnerExpressions(
    PropertySerializerContext context
)
Protected Overridable Function GetOwnerExpressions (
    context As PropertySerializerContext
) As String()

Parameters

context
Type: CodeSmith.EnginePropertySerializerContext

Return Value

Type: String
See Also

Reference

SchemaObjectSerializer Class
SchemaExplorer.Serialization Namespace


SchemaObjectSerializer.GetSchemaObjectExpressions Method

SchemaObjectSerializerGetSchemaObjectExpressions Method

Namespace: SchemaExplorer.Serialization
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual string[] GetSchemaObjectExpressions(
    PropertySerializerContext context
)
Protected Overridable Function GetSchemaObjectExpressions (
    context As PropertySerializerContext
) As String()

Parameters

context
Type: CodeSmith.EnginePropertySerializerContext

Return Value

Type: String
See Also

Reference

SchemaObjectSerializer Class
SchemaExplorer.Serialization Namespace


SchemaObjectSerializer.GetSchemaObjectFromName Method

SchemaObjectSerializerGetSchemaObjectFromName Method

Namespace: SchemaExplorer.Serialization
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public ISchemaObject GetSchemaObjectFromName(
    string objectName,
    Object currentValue
)
Public Function GetSchemaObjectFromName (
    objectName As String,
    currentValue As Object
) As ISchemaObject

Parameters

objectName
Type: SystemString
currentValue
Type: SystemObject

Return Value

Type: ISchemaObject
See Also

Reference

SchemaObjectSerializer Class
SchemaExplorer.Serialization Namespace


SchemaObjectSerializer.GetSchemaObjectFromNavigator Method

SchemaObjectSerializerGetSchemaObjectFromNavigator Method

Namespace: SchemaExplorer.Serialization
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual ISchemaObject GetSchemaObjectFromNavigator(
    PropertySerializerContext context,
    IDatabaseSchema databaseSchema,
    XPathNavigator node,
    XmlNamespaceManager manager
)
Protected Overridable Function GetSchemaObjectFromNavigator (
    context As PropertySerializerContext,
    databaseSchema As IDatabaseSchema,
    node As XPathNavigator,
    manager As XmlNamespaceManager
) As ISchemaObject

Parameters

context
Type: CodeSmith.EnginePropertySerializerContext
databaseSchema
Type: SchemaExplorerIDatabaseSchema
node
Type: System.Xml.XPathXPathNavigator
manager
Type: System.XmlXmlNamespaceManager

Return Value

Type: ISchemaObject
See Also

Reference

SchemaObjectSerializer Class
SchemaExplorer.Serialization Namespace


SchemaObjectSerializer.ParseDefaultValue Method

SchemaObjectSerializerParseDefaultValue Method

Namespace: SchemaExplorer.Serialization
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override Object ParseDefaultValue(
    PropertySerializerContext context,
    string defaultValue
)
Public Overrides Function ParseDefaultValue (
    context As PropertySerializerContext,
    defaultValue As String
) As Object

Parameters

context
Type: CodeSmith.EnginePropertySerializerContext
defaultValue
Type: SystemString

Return Value

Type: Object

Implements

IPropertySerializerParseDefaultValue(PropertySerializerContext, String)
See Also

Reference

SchemaObjectSerializer Class
SchemaExplorer.Serialization Namespace


SchemaObjectSerializer.ReadPropertyXml Method

SchemaObjectSerializerReadPropertyXml Method

Namespace: SchemaExplorer.Serialization
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override Object ReadPropertyXml(
    PropertySerializerContext context,
    XmlNode propertyValue
)
Public Overrides Function ReadPropertyXml (
    context As PropertySerializerContext,
    propertyValue As XmlNode
) As Object

Parameters

context
Type: CodeSmith.EnginePropertySerializerContext
propertyValue
Type: System.XmlXmlNode

Return Value

Type: Object

Implements

IPropertySerializerReadPropertyXml(PropertySerializerContext, XmlNode)
See Also

Reference

SchemaObjectSerializer Class
SchemaExplorer.Serialization Namespace


SchemaObjectSerializer.WritePropertyXml Method

SchemaObjectSerializerWritePropertyXml Method

Namespace: SchemaExplorer.Serialization
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override void WritePropertyXml(
    PropertySerializerContext context,
    XmlWriter writer,
    Object propertyValue
)
Public Overrides Sub WritePropertyXml (
    context As PropertySerializerContext,
    writer As XmlWriter,
    propertyValue As Object
)

Parameters

context
Type: CodeSmith.EnginePropertySerializerContext
writer
Type: System.XmlXmlWriter
propertyValue
Type: SystemObject

Implements

IPropertySerializerWritePropertyXml(PropertySerializerContext, XmlWriter, Object)
See Also

Reference

SchemaObjectSerializer Class
SchemaExplorer.Serialization Namespace


SchemaObjectSerializer.WriteSchemaObjectXml Method

SchemaObjectSerializerWriteSchemaObjectXml Method

Namespace: SchemaExplorer.Serialization
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
protected virtual void WriteSchemaObjectXml(
    XmlWriter writer,
    ISchemaObject schemaObject
)
Protected Overridable Sub WriteSchemaObjectXml (
    writer As XmlWriter,
    schemaObject As ISchemaObject
)

Parameters

writer
Type: System.XmlXmlWriter
schemaObject
Type: SchemaExplorerISchemaObject
See Also

Reference

SchemaObjectSerializer Class
SchemaExplorer.Serialization Namespace


SchemaSelectorSerializer Class

Inheritance Hierarchy
SystemObject
SchemaExplorer.SerializationSchemaSelectorSerializer

Namespace: SchemaExplorer.Serialization
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class SchemaSelectorSerializer : IPropertySerializer
Public Class SchemaSelectorSerializer
    Implements IPropertySerializer

The SchemaSelectorSerializer type exposes the following members.

Constructors
 | Name | Description
Public method | SchemaSelectorSerializer | Initializes a new instance of the SchemaSelectorSerializer class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadProperty |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseDefaultValue |
Public method | ReadPropertyXml |
Public method | SaveProperty |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WritePropertyXml |
Top
See Also

Reference

SchemaExplorer.Serialization Namespace


SchemaSelectorSerializer Constructor

Initializes a new instance of the SchemaSelectorSerializer class

Namespace: SchemaExplorer.Serialization
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public SchemaSelectorSerializer()
Public Sub New
See Also

Reference

SchemaSelectorSerializer Class
SchemaExplorer.Serialization Namespace


SchemaSelectorSerializer Methods

The SchemaSelectorSerializer type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadProperty |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseDefaultValue |
Public method | ReadPropertyXml |
Public method | SaveProperty |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WritePropertyXml |
Top
See Also

Reference

SchemaSelectorSerializer Class
SchemaExplorer.Serialization Namespace


SchemaSelectorSerializer.LoadProperty Method

SchemaSelectorSerializerLoadProperty Method

Namespace: SchemaExplorer.Serialization
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public Object LoadProperty(
    PropertySerializerContext context,
    Object propertyValue
)
Public Function LoadProperty (
    context As PropertySerializerContext,
    propertyValue As Object
) As Object

Parameters

context
Type: CodeSmith.EnginePropertySerializerContext
propertyValue
Type: SystemObject

Return Value

Type: Object

Implements

IPropertySerializerLoadProperty(PropertySerializerContext, Object)
See Also

Reference

SchemaSelectorSerializer Class
SchemaExplorer.Serialization Namespace


SchemaSelectorSerializer.ParseDefaultValue Method

SchemaSelectorSerializerParseDefaultValue Method

Namespace: SchemaExplorer.Serialization
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public Object ParseDefaultValue(
    PropertySerializerContext context,
    string defaultValue
)
Public Function ParseDefaultValue (
    context As PropertySerializerContext,
    defaultValue As String
) As Object

Parameters

context
Type: CodeSmith.EnginePropertySerializerContext
defaultValue
Type: SystemString

Return Value

Type: Object

Implements

IPropertySerializerParseDefaultValue(PropertySerializerContext, String)
See Also

Reference

SchemaSelectorSerializer Class
SchemaExplorer.Serialization Namespace


SchemaSelectorSerializer.ReadPropertyXml Method

SchemaSelectorSerializerReadPropertyXml Method

Namespace: SchemaExplorer.Serialization
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public Object ReadPropertyXml(
    PropertySerializerContext context,
    XmlNode propertyValue
)
Public Function ReadPropertyXml (
    context As PropertySerializerContext,
    propertyValue As XmlNode
) As Object

Parameters

context
Type: CodeSmith.EnginePropertySerializerContext
propertyValue
Type: System.XmlXmlNode

Return Value

Type: Object

Implements

IPropertySerializerReadPropertyXml(PropertySerializerContext, XmlNode)
See Also

Reference

SchemaSelectorSerializer Class
SchemaExplorer.Serialization Namespace


SchemaSelectorSerializer.SaveProperty Method

SchemaSelectorSerializerSaveProperty Method

Namespace: SchemaExplorer.Serialization
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public Object SaveProperty(
    PropertySerializerContext context,
    Object propertyValue
)
Public Function SaveProperty (
    context As PropertySerializerContext,
    propertyValue As Object
) As Object

Parameters

context
Type: CodeSmith.EnginePropertySerializerContext
propertyValue
Type: SystemObject

Return Value

Type: Object

Implements

IPropertySerializerSaveProperty(PropertySerializerContext, Object)
See Also

Reference

SchemaSelectorSerializer Class
SchemaExplorer.Serialization Namespace


SchemaSelectorSerializer.WritePropertyXml Method

SchemaSelectorSerializerWritePropertyXml Method

Namespace: SchemaExplorer.Serialization
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public void WritePropertyXml(
    PropertySerializerContext context,
    XmlWriter writer,
    Object propertyValue
)
Public Sub WritePropertyXml (
    context As PropertySerializerContext,
    writer As XmlWriter,
    propertyValue As Object
)

Parameters

context
Type: CodeSmith.EnginePropertySerializerContext
writer
Type: System.XmlXmlWriter
propertyValue
Type: SystemObject

Implements

IPropertySerializerWritePropertyXml(PropertySerializerContext, XmlWriter, Object)
See Also

Reference

SchemaSelectorSerializer Class
SchemaExplorer.Serialization Namespace


SchemaExplorer.TypeConverters Namespace

Classes
 | Class | Description
Public class | SchemaObjectFactoryTypeConverter |
Public class | SchemaSelectorTypeConverter |


SchemaObjectFactoryTypeConverter Class

Inheritance Hierarchy
SystemObject
System.ComponentModelTypeConverter
SchemaExplorer.TypeConvertersSchemaObjectFactoryTypeConverter

Namespace: SchemaExplorer.TypeConverters
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class SchemaObjectFactoryTypeConverter : TypeConverter
Public Class SchemaObjectFactoryTypeConverter
    Inherits TypeConverter

The SchemaObjectFactoryTypeConverter type exposes the following members.

Constructors
 | Name | Description
Public method | SchemaObjectFactoryTypeConverter | Initializes a new instance of the SchemaObjectFactoryTypeConverter class
Top
Methods
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | (Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Returns whether this converter can convert the object to the specified type, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
Public method | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified type, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
Public method | CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Protected method | GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object, Attribute) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported | Returns whether this object supports properties. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | Returns whether this object supports properties, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValues | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
Public method | GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
Public method | IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SchemaExplorer.TypeConverters Namespace


SchemaObjectFactoryTypeConverter Constructor

Initializes a new instance of the SchemaObjectFactoryTypeConverter class

Namespace: SchemaExplorer.TypeConverters
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public SchemaObjectFactoryTypeConverter()
Public Sub New
See Also

Reference

SchemaObjectFactoryTypeConverter Class
SchemaExplorer.TypeConverters Namespace


SchemaObjectFactoryTypeConverter Methods

The SchemaObjectFactoryTypeConverter type exposes the following members.

Methods
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | (Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | Returns whether this converter can convert the object to the specified type, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
Public method | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified type, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
Public method | CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Protected method | GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object, Attribute) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported | Returns whether this object supports properties. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | Returns whether this object supports properties, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValues | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
Public method | GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
Public method | IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SchemaObjectFactoryTypeConverter Class
SchemaExplorer.TypeConverters Namespace


SchemaObjectFactoryTypeConverter.CanConvertFrom Method

SchemaObjectFactoryTypeConverterCanConvertFrom Method

Overload List
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | (Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Top
See Also

Reference

SchemaObjectFactoryTypeConverter Class
SchemaExplorer.TypeConverters Namespace


SchemaObjectFactoryTypeConverter.CanConvertFrom Method (ITypeDescriptorContext, Type)

SchemaObjectFactoryTypeConverterCanConvertFrom Method (ITypeDescriptorContext, Type)

Namespace: SchemaExplorer.TypeConverters
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override bool CanConvertFrom(
    ITypeDescriptorContext context,
    Type sourceType
)
Public Overrides Function CanConvertFrom (
    context As ITypeDescriptorContext,
    sourceType As Type
) As Boolean

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
sourceType
Type: SystemType

Return Value

Type: Boolean
See Also

Reference

SchemaObjectFactoryTypeConverter Class
CanConvertFrom Overload
SchemaExplorer.TypeConverters Namespace


SchemaObjectFactoryTypeConverter.ConvertFrom Method

SchemaObjectFactoryTypeConverterConvertFrom Method

Overload List
 | Name | Description
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Top
See Also

Reference

SchemaObjectFactoryTypeConverter Class
SchemaExplorer.TypeConverters Namespace


SchemaObjectFactoryTypeConverter.ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

SchemaObjectFactoryTypeConverterConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

Namespace: SchemaExplorer.TypeConverters
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override Object ConvertFrom(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value
)
Public Overrides Function ConvertFrom (
    context As ITypeDescriptorContext,
    culture As CultureInfo,
    value As Object
) As Object

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
culture
Type: System.GlobalizationCultureInfo
value
Type: SystemObject

Return Value

Type: Object
See Also

Reference

SchemaObjectFactoryTypeConverter Class
ConvertFrom Overload
SchemaExplorer.TypeConverters Namespace


SchemaSelectorTypeConverter Class

Inheritance Hierarchy
SystemObject
System.ComponentModelTypeConverter
SchemaExplorer.TypeConvertersSchemaSelectorTypeConverter

Namespace: SchemaExplorer.TypeConverters
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public class SchemaSelectorTypeConverter : TypeConverter
Public Class SchemaSelectorTypeConverter
    Inherits TypeConverter

The SchemaSelectorTypeConverter type exposes the following members.

Constructors
 | Name | Description
Public method | SchemaSelectorTypeConverter | Initializes a new instance of the SchemaSelectorTypeConverter class
Top
Methods
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | (Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | (Overrides TypeConverterCanConvertTo(ITypeDescriptorContext, Type).)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
Public method | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | (Overrides TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Public method | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
Public method | CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Protected method | GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object, Attribute) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported | Returns whether this object supports properties. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | Returns whether this object supports properties, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValues | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
Public method | GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
Public method | IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SchemaExplorer.TypeConverters Namespace


SchemaSelectorTypeConverter Constructor

Initializes a new instance of the SchemaSelectorTypeConverter class

Namespace: SchemaExplorer.TypeConverters
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public SchemaSelectorTypeConverter()
Public Sub New
See Also

Reference

SchemaSelectorTypeConverter Class
SchemaExplorer.TypeConverters Namespace


SchemaSelectorTypeConverter Methods

The SchemaSelectorTypeConverter type exposes the following members.

Methods
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | (Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | (Overrides TypeConverterCanConvertTo(ITypeDescriptorContext, Type).)
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
Public method | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | (Overrides TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Public method | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
Public method | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)
Public method | ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
Public method | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)
Public method | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
Public method | CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Protected method | GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
Public method | GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
Public method | GetProperties(ITypeDescriptorContext, Object, Attribute) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported | Returns whether this object supports properties. (Inherited from TypeConverter.)
Public method | GetPropertiesSupported(ITypeDescriptorContext) | Returns whether this object supports properties, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValues | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
Public method | GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list. (Inherited from TypeConverter.)
Public method | GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
Public method | GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
Public method | IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SchemaSelectorTypeConverter Class
SchemaExplorer.TypeConverters Namespace


SchemaSelectorTypeConverter.CanConvertFrom Method

SchemaSelectorTypeConverterCanConvertFrom Method

Overload List
 | Name | Description
Public method | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
Public method | CanConvertFrom(ITypeDescriptorContext, Type) | (Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Top
See Also

Reference

SchemaSelectorTypeConverter Class
SchemaExplorer.TypeConverters Namespace


SchemaSelectorTypeConverter.CanConvertFrom Method (ITypeDescriptorContext, Type)

SchemaSelectorTypeConverterCanConvertFrom Method (ITypeDescriptorContext, Type)

Namespace: SchemaExplorer.TypeConverters
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override bool CanConvertFrom(
    ITypeDescriptorContext context,
    Type sourceType
)
Public Overrides Function CanConvertFrom (
    context As ITypeDescriptorContext,
    sourceType As Type
) As Boolean

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
sourceType
Type: SystemType

Return Value

Type: Boolean
See Also

Reference

SchemaSelectorTypeConverter Class
CanConvertFrom Overload
SchemaExplorer.TypeConverters Namespace


SchemaSelectorTypeConverter.CanConvertTo Method

SchemaSelectorTypeConverterCanConvertTo Method

Overload List
 | Name | Description
Public method | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
Public method | CanConvertTo(ITypeDescriptorContext, Type) | (Overrides TypeConverterCanConvertTo(ITypeDescriptorContext, Type).)
Top
See Also

Reference

SchemaSelectorTypeConverter Class
SchemaExplorer.TypeConverters Namespace


SchemaSelectorTypeConverter.CanConvertTo Method (ITypeDescriptorContext, Type)

SchemaSelectorTypeConverterCanConvertTo Method (ITypeDescriptorContext, Type)

Namespace: SchemaExplorer.TypeConverters
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override bool CanConvertTo(
    ITypeDescriptorContext context,
    Type destinationType
)
Public Overrides Function CanConvertTo (
    context As ITypeDescriptorContext,
    destinationType As Type
) As Boolean

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
destinationType
Type: SystemType

Return Value

Type: Boolean
See Also

Reference

SchemaSelectorTypeConverter Class
CanConvertTo Overload
SchemaExplorer.TypeConverters Namespace


SchemaSelectorTypeConverter.ConvertFrom Method

SchemaSelectorTypeConverterConvertFrom Method

Overload List
 | Name | Description
Public method | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
Public method | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | (Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Top
See Also

Reference

SchemaSelectorTypeConverter Class
SchemaExplorer.TypeConverters Namespace


SchemaSelectorTypeConverter.ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

SchemaSelectorTypeConverterConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

Namespace: SchemaExplorer.TypeConverters
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override Object ConvertFrom(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value
)
Public Overrides Function ConvertFrom (
    context As ITypeDescriptorContext,
    culture As CultureInfo,
    value As Object
) As Object

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
culture
Type: System.GlobalizationCultureInfo
value
Type: SystemObject

Return Value

Type: Object
See Also

Reference

SchemaSelectorTypeConverter Class
ConvertFrom Overload
SchemaExplorer.TypeConverters Namespace


SchemaSelectorTypeConverter.ConvertTo Method

SchemaSelectorTypeConverterConvertTo Method

Overload List
 | Name | Description
Public method | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
Public method | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | (Overrides TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Top
See Also

Reference

SchemaSelectorTypeConverter Class
SchemaExplorer.TypeConverters Namespace


SchemaSelectorTypeConverter.ConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)

SchemaSelectorTypeConverterConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)

Namespace: SchemaExplorer.TypeConverters
Assembly: SchemaExplorer (in SchemaExplorer.dll) Version: 8.5.0.154
Syntax
C#
VB
Copy
public override Object ConvertTo(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value,
    Type destinationType
)
Public Overrides Function ConvertTo (
    context As ITypeDescriptorContext,
    culture As CultureInfo,
    value As Object,
    destinationType As Type
) As Object

Parameters

context
Type: System.ComponentModelITypeDescriptorContext
culture
Type: System.GlobalizationCultureInfo
value
Type: SystemObject
destinationType
Type: SystemType

Return Value

Type: Object
See Also

Reference

SchemaSelectorTypeConverter Class
ConvertTo Overload
SchemaExplorer.TypeConverters Namespace